ComponentSpace.SAML2 Namespace

The ComponentSpace.SAML2 namespace contains classes that enable ASP.NET applications to participate in SAML v2.0 federated single sign-on (SSO) either as an Identity Provider (IdP) or Service Provider (SP).
Classes
 | Class | Description
Public class | SAMLController | The SAML controller maintains the SAML configuration and other properties.
Public class | SAMLIdentifiers | Defines SAML identifiers.
Public class | SAMLIdentifiersActionNamespaces | Action namespace identifiers.
Public class | SAMLIdentifiersActions | Actions.
Public class | SAMLIdentifiersAttributeNameFormats | Attribute name format identifiers.
Public class | SAMLIdentifiersAuthnContextClasses | Authentication context classes.
Public class | SAMLIdentifiersAuthnContextComparison | Authentication context comparisons.
Public class | SAMLIdentifiersAuthzDecision | Authorization decisions.
Public class | SAMLIdentifiersBindingURIs | The SAML binding URIs.
Public class | SAMLIdentifiersConsentIdentifiers | Consent identifiers.
Public class | SAMLIdentifiersCryptographicServiceProviderNames | Windows Cryptographic Service Provider (CSP) names.
Public class | SAMLIdentifiersCryptographicServiceProviderTypes | Windows Cryptographic Service Provider (CSP) types.
Public class | SAMLIdentifiersDataEncryptionMethods | Data encryption methods.
Public class | SAMLIdentifiersDigestMethods | Digest methods.
Public class | SAMLIdentifiersKeyEncryptionMethods | Key encryption methods.
Public class | SAMLIdentifiersNameIdentifierFormats | Name identifier format identifiers.
Public class | SAMLIdentifiersPrimaryStatusCodes | Top level status codes.
Public class | SAMLIdentifiersProfileURIs | The SAML profile URIs.
Public class | SAMLIdentifiersSecondaryStatusCodes | Second level status codes.
Public class | SAMLIdentifiersSignatureMethods | Signature methods.
Public class | SAMLIdentifiersSubjectConfirmationMethods | Consent identifiers.
Public class | SAMLIdentityProvider | Provides Identity Provider (IdP) support for web browser single sign-on.
Public class | SAMLServiceProvider | Provides Service Provider (SP) support for web browser single sign-on.
Public class | SSOOptions | Specifies single sign-on options.
Enumerations
 | Enumeration | Description
Public enumeration | SAMLIdentifiersBinding | The SAML bindings.
Public enumeration | SAMLIdentifiersMessageType | The SAML message types.
Public enumeration | SAMLIdentifiersProfile | The SAML profiles.

Copyright (c) ComponentSpace Pty Ltd 2004-2016. All rights reserved.

Send comments on this topic to support@componentspace.com


SAMLController Class

The SAML controller maintains the SAML configuration and other properties.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLController

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAMLController
Public NotInheritable Class SAMLController
public ref class SAMLController abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAMLController =  class end

The SAMLController type exposes the following members.

Properties
Name | Description
CertificateManager | Gets or sets the certificate manager. By default the configuration certificate manager is used. The configuration certificate manager is suitable for certificates stored on the file system or Windows certificate store.
Configuration | Gets or sets the SAML configuration. For most applications, a single SAML configuration is used and the SAML configuration identifier is not required.
ConfigurationID | Gets or sets the SAML configuration identifier for the current SAML SSO session. For most applications, a single SAML configuration is used and the SAML configuration identifier is not required. For multi-tenanted applications and other special use cases with multiple SAML configurations, the SAML identifier specifies the configuration to use.
Configurations | Gets or sets the SAML configurations. For most applications, a single SAML configuration is required. For multi-tenanted applications and other special use cases, multiple SAML configurations may be specified. The dictionary key is the configuration ID.
IDCache | Gets or sets the ID cache. By default the in-memory cache is used. The in-memory cache is suitable for applications deployed to a single server.
SSOSessionStore | Gets or sets the single sign-on session store. By default the HTTP session is used to store the single sign-on session.
TraceLevel | Gets or sets the trace level. The diagnostics section in web.config specifies the trace configuration. This includes the trace switch value which effectively turns verbose trace on or off. The trace level property may be used to override the trace switch. If the trace level is not set then the trace switch is in effect. If the trace level is set then this overrides the trace switch.
ValidateMessagesAgainstSchema | Gets or sets the flag indicating whether SAML messages should be validated against the XML schema. Validating SAML messages against the XML schema is good practice but does result in a small performace hit.
Top
Methods
Name | Description
Initialize | Initializes the SAML environment. This occurs automatically just-in-time but initialization can be forced if required. If the configuration has been set programmatically then this will be used. Otherwise, a SAML configuration file is assumed.
Uninitialize | Uninitializes the SAML environment. Any SAML configuration is unloaded.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace


SAMLController Properties

The SAMLController type exposes the following members.

Properties
Name | Description
CertificateManager | Gets or sets the certificate manager. By default the configuration certificate manager is used. The configuration certificate manager is suitable for certificates stored on the file system or Windows certificate store.
Configuration | Gets or sets the SAML configuration. For most applications, a single SAML configuration is used and the SAML configuration identifier is not required.
ConfigurationID | Gets or sets the SAML configuration identifier for the current SAML SSO session. For most applications, a single SAML configuration is used and the SAML configuration identifier is not required. For multi-tenanted applications and other special use cases with multiple SAML configurations, the SAML identifier specifies the configuration to use.
Configurations | Gets or sets the SAML configurations. For most applications, a single SAML configuration is required. For multi-tenanted applications and other special use cases, multiple SAML configurations may be specified. The dictionary key is the configuration ID.
IDCache | Gets or sets the ID cache. By default the in-memory cache is used. The in-memory cache is suitable for applications deployed to a single server.
SSOSessionStore | Gets or sets the single sign-on session store. By default the HTTP session is used to store the single sign-on session.
TraceLevel | Gets or sets the trace level. The diagnostics section in web.config specifies the trace configuration. This includes the trace switch value which effectively turns verbose trace on or off. The trace level property may be used to override the trace switch. If the trace level is not set then the trace switch is in effect. If the trace level is set then this overrides the trace switch.
ValidateMessagesAgainstSchema | Gets or sets the flag indicating whether SAML messages should be validated against the XML schema. Validating SAML messages against the XML schema is good practice but does result in a small performace hit.
Top
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace


SAMLController.CertificateManager Property

ComponentSpace SAML v2.0 Class Library

SAMLControllerCertificateManager Property

Gets or sets the certificate manager.

By default the configuration certificate manager is used. The configuration certificate manager is suitable for certificates stored on the file system or Windows certificate store.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static ICertificateManager CertificateManager { get; set; }
Public Shared Property CertificateManager As ICertificateManager
    Get
    Set
public:
static property ICertificateManager^ CertificateManager {
    ICertificateManager^ get ();
    void set (ICertificateManager^ value);
}
static member CertificateManager : ICertificateManager with get, set

Property Value

Type: ICertificateManager
The certificate manager.
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace


SAMLController.Configuration Property

SAMLControllerConfiguration Property

Gets or sets the SAML configuration.

For most applications, a single SAML configuration is used and the SAML configuration identifier is not required.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static SAMLConfiguration Configuration { get; set; }
Public Shared Property Configuration As SAMLConfiguration
    Get
    Set
public:
static property SAMLConfiguration^ Configuration {
    SAMLConfiguration^ get ();
    void set (SAMLConfiguration^ value);
}
static member Configuration : SAMLConfiguration with get, set

Property Value

Type: SAMLConfiguration
The SAML configuration or null if none or more than one.
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace
SAMLControllerConfigurations


SAMLController.ConfigurationID Property

SAMLControllerConfigurationID Property

Gets or sets the SAML configuration identifier for the current SAML SSO session.

For most applications, a single SAML configuration is used and the SAML configuration identifier is not required. For multi-tenanted applications and other special use cases with multiple SAML configurations, the SAML identifier specifies the configuration to use.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string ConfigurationID { get; set; }
Public Shared Property ConfigurationID As String
    Get
    Set
public:
static property String^ ConfigurationID {
    String^ get ();
    void set (String^ value);
}
static member ConfigurationID : string with get, set

Property Value

Type: String
The SAML configuration identifier or null if none.
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace
SAMLControllerConfigurations


SAMLController.Configurations Property

SAMLControllerConfigurations Property

Gets or sets the SAML configurations.

For most applications, a single SAML configuration is required. For multi-tenanted applications and other special use cases, multiple SAML configurations may be specified.

The dictionary key is the configuration ID.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IDictionary<string, SAMLConfiguration> Configurations { get; set; }
Public Shared Property Configurations As IDictionary(Of String, SAMLConfiguration)
    Get
    Set
public:
static property IDictionary<String^, SAMLConfiguration^>^ Configurations {
    IDictionary<String^, SAMLConfiguration^>^ get ();
    void set (IDictionary<String^, SAMLConfiguration^>^ value);
}
static member Configurations : IDictionary<string, SAMLConfiguration> with get, set

Property Value

Type: IDictionary String, SAMLConfiguration
The SAML configurations.
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace
SAMLControllerConfigurationID
SAMLControllerConfiguration


SAMLController.IDCache Property

SAMLControllerIDCache Property

Gets or sets the ID cache.

By default the in-memory cache is used. The in-memory cache is suitable for applications deployed to a single server.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IIDCache IDCache { get; set; }
Public Shared Property IDCache As IIDCache
    Get
    Set
public:
static property IIDCache^ IDCache {
    IIDCache^ get ();
    void set (IIDCache^ value);
}
static member IDCache : IIDCache with get, set

Property Value

Type: IIDCache
The ID cache.
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace


SAMLController.SSOSessionStore Property

SAMLControllerSSOSessionStore Property

Gets or sets the single sign-on session store.

By default the HTTP session is used to store the single sign-on session.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static ISSOSessionStore SSOSessionStore { get; set; }
Public Shared Property SSOSessionStore As ISSOSessionStore
    Get
    Set
public:
static property ISSOSessionStore^ SSOSessionStore {
    ISSOSessionStore^ get ();
    void set (ISSOSessionStore^ value);
}
static member SSOSessionStore : ISSOSessionStore with get, set

Property Value

Type: ISSOSessionStore
The single sign-on session store.
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace


SAMLController.TraceLevel Property

SAMLControllerTraceLevel Property

Gets or sets the trace level.

The diagnostics section in web.config specifies the trace configuration. This includes the trace switch value which effectively turns verbose trace on or off. The trace level property may be used to override the trace switch. If the trace level is not set then the trace switch is in effect. If the trace level is set then this overrides the trace switch.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static Nullable<TraceLevel> TraceLevel { get; set; }
Public Shared Property TraceLevel As Nullable(Of TraceLevel)
    Get
    Set
public:
static property Nullable<TraceLevel> TraceLevel {
    Nullable<TraceLevel> get ();
    void set (Nullable<TraceLevel> value);
}
static member TraceLevel : Nullable<TraceLevel> with get, set

Property Value

Type: Nullable TraceLevel
The trace level.
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace


SAMLController.ValidateMessagesAgainstSchema Property

SAMLControllerValidateMessagesAgainstSchema Property

Gets or sets the flag indicating whether SAML messages should be validated against the XML schema.

Validating SAML messages against the XML schema is good practice but does result in a small performace hit.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool ValidateMessagesAgainstSchema { get; set; }
Public Shared Property ValidateMessagesAgainstSchema As Boolean
    Get
    Set
public:
static property bool ValidateMessagesAgainstSchema {
    bool get ();
    void set (bool value);
}
static member ValidateMessagesAgainstSchema : bool with get, set

Property Value

Type: Boolean
The flag indicating whether SAML messages should be validated against the XML schema.
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace


SAMLController Methods

The SAMLController type exposes the following members.

Methods
Name | Description
Initialize | Initializes the SAML environment. This occurs automatically just-in-time but initialization can be forced if required. If the configuration has been set programmatically then this will be used. Otherwise, a SAML configuration file is assumed.
Uninitialize | Uninitializes the SAML environment. Any SAML configuration is unloaded.
Top
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace


SAMLController.Initialize Method

SAMLControllerInitialize Method

Initializes the SAML environment.

This occurs automatically just-in-time but initialization can be forced if required.

If the configuration has been set programmatically then this will be used. Otherwise, a SAML configuration file is assumed.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Initialize()
Public Shared Sub Initialize
public:
static void Initialize()
static member Initialize : unit -> unit
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace


SAMLController.Uninitialize Method

SAMLControllerUninitialize Method

Uninitializes the SAML environment.

Any SAML configuration is unloaded.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Uninitialize()
Public Shared Sub Uninitialize
public:
static void Uninitialize()
static member Uninitialize : unit -> unit
See Also

Reference

SAMLController Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers Class

Defines SAML identifiers.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiers

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAMLIdentifiers
Public NotInheritable Class SAMLIdentifiers
public ref class SAMLIdentifiers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAMLIdentifiers =  class end
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ActionNamespaces Class

SAMLIdentifiersActionNamespaces Class

Action namespace identifiers.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersActionNamespaces

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class ActionNamespaces
Public NotInheritable Class ActionNamespaces
public ref class ActionNamespaces abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ActionNamespaces =  class end

The SAMLIdentifiersActionNamespaces type exposes the following members.

Fields
Name | Description
GHPP | Get/Head/Put/Post.
RWEDC | Read/Write/Execute/Delete/Control.
RWEDCWithNegation | Read/Write/Execute/Delete/Control with Negation.
Unix | UNIX File Permissions.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.AssertionsAction


ActionNamespaces Fields

The SAMLIdentifiersActionNamespaces type exposes the following members.

Fields
Name | Description
GHPP | Get/Head/Put/Post.
RWEDC | Read/Write/Execute/Delete/Control.
RWEDCWithNegation | Read/Write/Execute/Delete/Control with Negation.
Unix | UNIX File Permissions.
Top
See Also

Reference

SAMLIdentifiersActionNamespaces Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ActionNamespaces.GHPP Field

SAMLIdentifiersActionNamespacesGHPP Field

Get/Head/Put/Post.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string GHPP = "urn:oasis:names:tc:SAML:1.0:action:ghpp"
Public Const GHPP As String = "urn:oasis:names:tc:SAML:1.0:action:ghpp"
public:
literal String^ GHPP = "urn:oasis:names:tc:SAML:1.0:action:ghpp"
static val mutable GHPP: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActionNamespaces Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ActionNamespaces.RWEDC Field

SAMLIdentifiersActionNamespacesRWEDC Field

Read/Write/Execute/Delete/Control.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RWEDC = "urn:oasis:names:tc:SAML:1.0:action:rwedc"
Public Const RWEDC As String = "urn:oasis:names:tc:SAML:1.0:action:rwedc"
public:
literal String^ RWEDC = "urn:oasis:names:tc:SAML:1.0:action:rwedc"
static val mutable RWEDC: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActionNamespaces Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ActionNamespaces.RWEDCWithNegation Field

SAMLIdentifiersActionNamespacesRWEDCWithNegation Field

Read/Write/Execute/Delete/Control with Negation.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RWEDCWithNegation = "urn:oasis:names:tc:SAML:1.0:action:rwedc-negation"
Public Const RWEDCWithNegation As String = "urn:oasis:names:tc:SAML:1.0:action:rwedc-negation"
public:
literal String^ RWEDCWithNegation = "urn:oasis:names:tc:SAML:1.0:action:rwedc-negation"
static val mutable RWEDCWithNegation: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActionNamespaces Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ActionNamespaces.Unix Field

SAMLIdentifiersActionNamespacesUnix Field

UNIX File Permissions.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Unix = "urn:oasis:names:tc:SAML:1.0:action:unix"
Public Const Unix As String = "urn:oasis:names:tc:SAML:1.0:action:unix"
public:
literal String^ Unix = "urn:oasis:names:tc:SAML:1.0:action:unix"
static val mutable Unix: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActionNamespaces Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions Class

SAMLIdentifiersActions Class

Actions.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersActions

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class Actions
Public NotInheritable Class Actions
public ref class Actions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Actions =  class end

The SAMLIdentifiersActions type exposes the following members.

Fields
Name | Description
Control | Control.
Delete | Delete.
Execute | Execute.
GET | GET.
HEAD | HEAD.
NotControl | Negated Control.
NotDelete | Negated Delete.
NotExecute | Negated Execute.
NotRead | Negated Read.
NotWrite | Negated Write.
POST | POST.
PUT | PUT.
Read | Read.
Write | Write.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.AssertionsAction


Actions Fields

The SAMLIdentifiersActions type exposes the following members.

Fields
Name | Description
Control | Control.
Delete | Delete.
Execute | Execute.
GET | GET.
HEAD | HEAD.
NotControl | Negated Control.
NotDelete | Negated Delete.
NotExecute | Negated Execute.
NotRead | Negated Read.
NotWrite | Negated Write.
POST | POST.
PUT | PUT.
Read | Read.
Write | Write.
Top
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.Control Field

SAMLIdentifiersActionsControl Field

Control.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Control = "Control"
Public Const Control As String = "Control"
public:
literal String^ Control = "Control"
static val mutable Control: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.Delete Field

SAMLIdentifiersActionsDelete Field

Delete.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Delete = "Delete"
Public Const Delete As String = "Delete"
public:
literal String^ Delete = "Delete"
static val mutable Delete: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.Execute Field

SAMLIdentifiersActionsExecute Field

Execute.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Execute = "Execute"
Public Const Execute As String = "Execute"
public:
literal String^ Execute = "Execute"
static val mutable Execute: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.GET Field

SAMLIdentifiersActionsGET Field

GET.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string GET = "GET"
Public Const GET As String = "GET"
public:
literal String^ GET = "GET"
static val mutable GET: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.HEAD Field

SAMLIdentifiersActionsHEAD Field

HEAD.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string HEAD = "HEAD"
Public Const HEAD As String = "HEAD"
public:
literal String^ HEAD = "HEAD"
static val mutable HEAD: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.NotControl Field

SAMLIdentifiersActionsNotControl Field

Negated Control.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NotControl = "~Control"
Public Const NotControl As String = "~Control"
public:
literal String^ NotControl = "~Control"
static val mutable NotControl: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.NotDelete Field

SAMLIdentifiersActionsNotDelete Field

Negated Delete.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NotDelete = "~Delete"
Public Const NotDelete As String = "~Delete"
public:
literal String^ NotDelete = "~Delete"
static val mutable NotDelete: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.NotExecute Field

SAMLIdentifiersActionsNotExecute Field

Negated Execute.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NotExecute = "~Execute"
Public Const NotExecute As String = "~Execute"
public:
literal String^ NotExecute = "~Execute"
static val mutable NotExecute: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.NotRead Field

SAMLIdentifiersActionsNotRead Field

Negated Read.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NotRead = "~Read"
Public Const NotRead As String = "~Read"
public:
literal String^ NotRead = "~Read"
static val mutable NotRead: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.NotWrite Field

SAMLIdentifiersActionsNotWrite Field

Negated Write.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NotWrite = "~Write"
Public Const NotWrite As String = "~Write"
public:
literal String^ NotWrite = "~Write"
static val mutable NotWrite: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.POST Field

SAMLIdentifiersActionsPOST Field

POST.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string POST = "POST"
Public Const POST As String = "POST"
public:
literal String^ POST = "POST"
static val mutable POST: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.PUT Field

SAMLIdentifiersActionsPUT Field

PUT.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string PUT = "PUT"
Public Const PUT As String = "PUT"
public:
literal String^ PUT = "PUT"
static val mutable PUT: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.Read Field

SAMLIdentifiersActionsRead Field

Read.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Read = "Read"
Public Const Read As String = "Read"
public:
literal String^ Read = "Read"
static val mutable Read: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Actions.Write Field

SAMLIdentifiersActionsWrite Field

Write.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Write = "Write"
Public Const Write As String = "Write"
public:
literal String^ Write = "Write"
static val mutable Write: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersActions Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AttributeNameFormats Class

SAMLIdentifiersAttributeNameFormats Class

Attribute name format identifiers.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersAttributeNameFormats

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AttributeNameFormats
Public NotInheritable Class AttributeNameFormats
public ref class AttributeNameFormats abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AttributeNameFormats =  class end

The SAMLIdentifiersAttributeNameFormats type exposes the following members.

Fields
Name | Description
Basic | Basic.
Unspecified | Unspecified.
URI | URI.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.AssertionsSAMLAttribute


AttributeNameFormats Fields

The SAMLIdentifiersAttributeNameFormats type exposes the following members.

Fields
Name | Description
Basic | Basic.
Unspecified | Unspecified.
URI | URI.
Top
See Also

Reference

SAMLIdentifiersAttributeNameFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AttributeNameFormats.Basic Field

SAMLIdentifiersAttributeNameFormatsBasic Field

Basic.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Basic = "urn:oasis:names:tc:SAML:2.0:attrname-format:basic"
Public Const Basic As String = "urn:oasis:names:tc:SAML:2.0:attrname-format:basic"
public:
literal String^ Basic = "urn:oasis:names:tc:SAML:2.0:attrname-format:basic"
static val mutable Basic: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAttributeNameFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AttributeNameFormats.Unspecified Field

SAMLIdentifiersAttributeNameFormatsUnspecified Field

Unspecified.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Unspecified = "urn:oasis:names:tc:SAML:2.0:attrname-format:unspecified"
Public Const Unspecified As String = "urn:oasis:names:tc:SAML:2.0:attrname-format:unspecified"
public:
literal String^ Unspecified = "urn:oasis:names:tc:SAML:2.0:attrname-format:unspecified"
static val mutable Unspecified: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAttributeNameFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AttributeNameFormats.URI Field

SAMLIdentifiersAttributeNameFormatsURI Field

URI.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string URI = "urn:oasis:names:tc:SAML:2.0:attrname-format:uri"
Public Const URI As String = "urn:oasis:names:tc:SAML:2.0:attrname-format:uri"
public:
literal String^ URI = "urn:oasis:names:tc:SAML:2.0:attrname-format:uri"
static val mutable URI: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAttributeNameFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses Class

SAMLIdentifiersAuthnContextClasses Class

Authentication context classes.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersAuthnContextClasses

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AuthnContextClasses
Public NotInheritable Class AuthnContextClasses
public ref class AuthnContextClasses abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AuthnContextClasses =  class end

The SAMLIdentifiersAuthnContextClasses type exposes the following members.

Fields
Name | Description
AuthenticatedTelephony | AuthenticatedTelephony.
InternetProtocol | InternetProtocol.
InternetProtocolPassword | InternetProtocolPassword.
Kerberos | Kerberos.
MobileOneFactorContract | MobileOneFactorContract.
MobileOneFactorUnregistered | MobileOneFactorUnregistered.
MobileTwoFactorContract | MobileTwoFactorContract.
MobileTwoFactorUnregistered | MobileTwoFactorUnregistered.
NomadTelephony | NomadTelephony.
Password | Password.
PasswordProtectedTransport | PasswordProtectedTransport.
PersonalTelephony | PersonalTelephony.
PGP | PGP.
PreviousSession | PreviousSession.
SecureRemotePassword | SecureRemotePassword.
Smartcard | Smartcard.
SmartcardPKI | SmartcardPKI.
SoftwarePKI | SoftwarePKI.
SPKI | SPKI.
Telephony | Telephony.
TimeSyncToken | TimeSyncToken.
TLSClient | TLSClient.
Unspecified | Unspecified.
X509 | X509.
XMLDSig | XMLDSig.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.AssertionsAuthnContextClassRef


AuthnContextClasses Fields

The SAMLIdentifiersAuthnContextClasses type exposes the following members.

Fields
Name | Description
AuthenticatedTelephony | AuthenticatedTelephony.
InternetProtocol | InternetProtocol.
InternetProtocolPassword | InternetProtocolPassword.
Kerberos | Kerberos.
MobileOneFactorContract | MobileOneFactorContract.
MobileOneFactorUnregistered | MobileOneFactorUnregistered.
MobileTwoFactorContract | MobileTwoFactorContract.
MobileTwoFactorUnregistered | MobileTwoFactorUnregistered.
NomadTelephony | NomadTelephony.
Password | Password.
PasswordProtectedTransport | PasswordProtectedTransport.
PersonalTelephony | PersonalTelephony.
PGP | PGP.
PreviousSession | PreviousSession.
SecureRemotePassword | SecureRemotePassword.
Smartcard | Smartcard.
SmartcardPKI | SmartcardPKI.
SoftwarePKI | SoftwarePKI.
SPKI | SPKI.
Telephony | Telephony.
TimeSyncToken | TimeSyncToken.
TLSClient | TLSClient.
Unspecified | Unspecified.
X509 | X509.
XMLDSig | XMLDSig.
Top
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.AuthenticatedTelephony Field

SAMLIdentifiersAuthnContextClassesAuthenticatedTelephony Field

AuthenticatedTelephony.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string AuthenticatedTelephony = "urn:oasis:names:tc:SAML:2.0:ac:classes:AuthenticatedTelephony"
Public Const AuthenticatedTelephony As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:AuthenticatedTelephony"
public:
literal String^ AuthenticatedTelephony = "urn:oasis:names:tc:SAML:2.0:ac:classes:AuthenticatedTelephony"
static val mutable AuthenticatedTelephony: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.InternetProtocol Field

SAMLIdentifiersAuthnContextClassesInternetProtocol Field

InternetProtocol.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string InternetProtocol = "urn:oasis:names:tc:SAML:2.0:ac:classes:InternetProtocol"
Public Const InternetProtocol As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:InternetProtocol"
public:
literal String^ InternetProtocol = "urn:oasis:names:tc:SAML:2.0:ac:classes:InternetProtocol"
static val mutable InternetProtocol: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.InternetProtocolPassword Field

SAMLIdentifiersAuthnContextClassesInternetProtocolPassword Field

InternetProtocolPassword.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string InternetProtocolPassword = "urn:oasis:names:tc:SAML:2.0:ac:classes:InternetProtocolPassword"
Public Const InternetProtocolPassword As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:InternetProtocolPassword"
public:
literal String^ InternetProtocolPassword = "urn:oasis:names:tc:SAML:2.0:ac:classes:InternetProtocolPassword"
static val mutable InternetProtocolPassword: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.Kerberos Field

SAMLIdentifiersAuthnContextClassesKerberos Field

Kerberos.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Kerberos = "urn:oasis:names:tc:SAML:2.0:ac:classes:Kerberos"
Public Const Kerberos As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:Kerberos"
public:
literal String^ Kerberos = "urn:oasis:names:tc:SAML:2.0:ac:classes:Kerberos"
static val mutable Kerberos: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.MobileOneFactorContract Field

SAMLIdentifiersAuthnContextClassesMobileOneFactorContract Field

MobileOneFactorContract.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string MobileOneFactorContract = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileOneFactorContract"
Public Const MobileOneFactorContract As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileOneFactorContract"
public:
literal String^ MobileOneFactorContract = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileOneFactorContract"
static val mutable MobileOneFactorContract: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.MobileOneFactorUnregistered Field

SAMLIdentifiersAuthnContextClassesMobileOneFactorUnregistered Field

MobileOneFactorUnregistered.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string MobileOneFactorUnregistered = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileOneFactorUnregistered"
Public Const MobileOneFactorUnregistered As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileOneFactorUnregistered"
public:
literal String^ MobileOneFactorUnregistered = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileOneFactorUnregistered"
static val mutable MobileOneFactorUnregistered: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.MobileTwoFactorContract Field

SAMLIdentifiersAuthnContextClassesMobileTwoFactorContract Field

MobileTwoFactorContract.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string MobileTwoFactorContract = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileTwoFactorContract"
Public Const MobileTwoFactorContract As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileTwoFactorContract"
public:
literal String^ MobileTwoFactorContract = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileTwoFactorContract"
static val mutable MobileTwoFactorContract: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.MobileTwoFactorUnregistered Field

SAMLIdentifiersAuthnContextClassesMobileTwoFactorUnregistered Field

MobileTwoFactorUnregistered.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string MobileTwoFactorUnregistered = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileTwoFactorUnregistered"
Public Const MobileTwoFactorUnregistered As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileTwoFactorUnregistered"
public:
literal String^ MobileTwoFactorUnregistered = "urn:oasis:names:tc:SAML:2.0:ac:classes:MobileTwoFactorUnregistered"
static val mutable MobileTwoFactorUnregistered: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.NomadTelephony Field

SAMLIdentifiersAuthnContextClassesNomadTelephony Field

NomadTelephony.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NomadTelephony = "urn:oasis:names:tc:SAML:2.0:ac:classes:NomadTelephony"
Public Const NomadTelephony As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:NomadTelephony"
public:
literal String^ NomadTelephony = "urn:oasis:names:tc:SAML:2.0:ac:classes:NomadTelephony"
static val mutable NomadTelephony: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.Password Field

SAMLIdentifiersAuthnContextClassesPassword Field

Password.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Password = "urn:oasis:names:tc:SAML:2.0:ac:classes:Password"
Public Const Password As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:Password"
public:
literal String^ Password = "urn:oasis:names:tc:SAML:2.0:ac:classes:Password"
static val mutable Password: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.PasswordProtectedTransport Field

SAMLIdentifiersAuthnContextClassesPasswordProtectedTransport Field

PasswordProtectedTransport.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string PasswordProtectedTransport = "urn:oasis:names:tc:SAML:2.0:ac:classes:PasswordProtectedTransport"
Public Const PasswordProtectedTransport As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:PasswordProtectedTransport"
public:
literal String^ PasswordProtectedTransport = "urn:oasis:names:tc:SAML:2.0:ac:classes:PasswordProtectedTransport"
static val mutable PasswordProtectedTransport: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.PersonalTelephony Field

SAMLIdentifiersAuthnContextClassesPersonalTelephony Field

PersonalTelephony.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string PersonalTelephony = "urn:oasis:names:tc:SAML:2.0:ac:classes:PersonalTelephony"
Public Const PersonalTelephony As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:PersonalTelephony"
public:
literal String^ PersonalTelephony = "urn:oasis:names:tc:SAML:2.0:ac:classes:PersonalTelephony"
static val mutable PersonalTelephony: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.PGP Field

SAMLIdentifiersAuthnContextClassesPGP Field

PGP.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string PGP = "urn:oasis:names:tc:SAML:2.0:ac:classes:PGP"
Public Const PGP As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:PGP"
public:
literal String^ PGP = "urn:oasis:names:tc:SAML:2.0:ac:classes:PGP"
static val mutable PGP: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.PreviousSession Field

SAMLIdentifiersAuthnContextClassesPreviousSession Field

PreviousSession.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string PreviousSession = "urn:oasis:names:tc:SAML:2.0:ac:classes:PreviousSession"
Public Const PreviousSession As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:PreviousSession"
public:
literal String^ PreviousSession = "urn:oasis:names:tc:SAML:2.0:ac:classes:PreviousSession"
static val mutable PreviousSession: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.SecureRemotePassword Field

SAMLIdentifiersAuthnContextClassesSecureRemotePassword Field

SecureRemotePassword.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SecureRemotePassword = "urn:oasis:names:tc:SAML:2.0:ac:classes:SecureRemotePassword"
Public Const SecureRemotePassword As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:SecureRemotePassword"
public:
literal String^ SecureRemotePassword = "urn:oasis:names:tc:SAML:2.0:ac:classes:SecureRemotePassword"
static val mutable SecureRemotePassword: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.Smartcard Field

SAMLIdentifiersAuthnContextClassesSmartcard Field

Smartcard.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Smartcard = "urn:oasis:names:tc:SAML:2.0:ac:classes:Smartcard"
Public Const Smartcard As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:Smartcard"
public:
literal String^ Smartcard = "urn:oasis:names:tc:SAML:2.0:ac:classes:Smartcard"
static val mutable Smartcard: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.SmartcardPKI Field

SAMLIdentifiersAuthnContextClassesSmartcardPKI Field

SmartcardPKI.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SmartcardPKI = "urn:oasis:names:tc:SAML:2.0:ac:classes:SmartcardPKI"
Public Const SmartcardPKI As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:SmartcardPKI"
public:
literal String^ SmartcardPKI = "urn:oasis:names:tc:SAML:2.0:ac:classes:SmartcardPKI"
static val mutable SmartcardPKI: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.SoftwarePKI Field

SAMLIdentifiersAuthnContextClassesSoftwarePKI Field

SoftwarePKI.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SoftwarePKI = "urn:oasis:names:tc:SAML:2.0:ac:classes:SoftwarePKI"
Public Const SoftwarePKI As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:SoftwarePKI"
public:
literal String^ SoftwarePKI = "urn:oasis:names:tc:SAML:2.0:ac:classes:SoftwarePKI"
static val mutable SoftwarePKI: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.SPKI Field

SAMLIdentifiersAuthnContextClassesSPKI Field

SPKI.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SPKI = "urn:oasis:names:tc:SAML:2.0:ac:classes:SPKI"
Public Const SPKI As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:SPKI"
public:
literal String^ SPKI = "urn:oasis:names:tc:SAML:2.0:ac:classes:SPKI"
static val mutable SPKI: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.Telephony Field

SAMLIdentifiersAuthnContextClassesTelephony Field

Telephony.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Telephony = "urn:oasis:names:tc:SAML:2.0:ac:classes:Telephony"
Public Const Telephony As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:Telephony"
public:
literal String^ Telephony = "urn:oasis:names:tc:SAML:2.0:ac:classes:Telephony"
static val mutable Telephony: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.TimeSyncToken Field

SAMLIdentifiersAuthnContextClassesTimeSyncToken Field

TimeSyncToken.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string TimeSyncToken = "urn:oasis:names:tc:SAML:2.0:ac:classes:TimeSyncToken"
Public Const TimeSyncToken As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:TimeSyncToken"
public:
literal String^ TimeSyncToken = "urn:oasis:names:tc:SAML:2.0:ac:classes:TimeSyncToken"
static val mutable TimeSyncToken: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.TLSClient Field

SAMLIdentifiersAuthnContextClassesTLSClient Field

TLSClient.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string TLSClient = "urn:oasis:names:tc:SAML:2.0:ac:classes:TLSClient"
Public Const TLSClient As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:TLSClient"
public:
literal String^ TLSClient = "urn:oasis:names:tc:SAML:2.0:ac:classes:TLSClient"
static val mutable TLSClient: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.Unspecified Field

SAMLIdentifiersAuthnContextClassesUnspecified Field

Unspecified.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Unspecified = "urn:oasis:names:tc:SAML:2.0:ac:classes:unspecified"
Public Const Unspecified As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:unspecified"
public:
literal String^ Unspecified = "urn:oasis:names:tc:SAML:2.0:ac:classes:unspecified"
static val mutable Unspecified: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.X509 Field

SAMLIdentifiersAuthnContextClassesX509 Field

X509.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string X509 = "urn:oasis:names:tc:SAML:2.0:ac:classes:X509"
Public Const X509 As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:X509"
public:
literal String^ X509 = "urn:oasis:names:tc:SAML:2.0:ac:classes:X509"
static val mutable X509: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextClasses.XMLDSig Field

SAMLIdentifiersAuthnContextClassesXMLDSig Field

XMLDSig.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string XMLDSig = "urn:oasis:names:tc:SAML:2.0:ac:classes:XMLDSig"
Public Const XMLDSig As String = "urn:oasis:names:tc:SAML:2.0:ac:classes:XMLDSig"
public:
literal String^ XMLDSig = "urn:oasis:names:tc:SAML:2.0:ac:classes:XMLDSig"
static val mutable XMLDSig: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextClasses Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextComparison Class

SAMLIdentifiersAuthnContextComparison Class

Authentication context comparisons.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersAuthnContextComparison

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AuthnContextComparison
Public NotInheritable Class AuthnContextComparison
public ref class AuthnContextComparison abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AuthnContextComparison =  class end

The SAMLIdentifiersAuthnContextComparison type exposes the following members.

Fields
Name | Description
Better | Better.
Exact | Exact.
Maximum | Maximum.
Minimum | Minimum.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.ProtocolsRequestedAuthnContext


AuthnContextComparison Fields

The SAMLIdentifiersAuthnContextComparison type exposes the following members.

Fields
Name | Description
Better | Better.
Exact | Exact.
Maximum | Maximum.
Minimum | Minimum.
Top
See Also

Reference

SAMLIdentifiersAuthnContextComparison Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextComparison.Better Field

SAMLIdentifiersAuthnContextComparisonBetter Field

Better.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Better = "better"
Public Const Better As String = "better"
public:
literal String^ Better = "better"
static val mutable Better: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextComparison Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextComparison.Exact Field

SAMLIdentifiersAuthnContextComparisonExact Field

Exact.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Exact = "exact"
Public Const Exact As String = "exact"
public:
literal String^ Exact = "exact"
static val mutable Exact: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextComparison Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextComparison.Maximum Field

SAMLIdentifiersAuthnContextComparisonMaximum Field

Maximum.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Maximum = "maximum"
Public Const Maximum As String = "maximum"
public:
literal String^ Maximum = "maximum"
static val mutable Maximum: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextComparison Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthnContextComparison.Minimum Field

SAMLIdentifiersAuthnContextComparisonMinimum Field

Minimum.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Minimum = "minimum"
Public Const Minimum As String = "minimum"
public:
literal String^ Minimum = "minimum"
static val mutable Minimum: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthnContextComparison Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthzDecision Class

SAMLIdentifiersAuthzDecision Class

Authorization decisions.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersAuthzDecision

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AuthzDecision
Public NotInheritable Class AuthzDecision
public ref class AuthzDecision abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AuthzDecision =  class end

The SAMLIdentifiersAuthzDecision type exposes the following members.

Fields
Name | Description
Deny | Deny.
Indeterminate | Indeterminate.
Permit | Permit.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.AssertionsAuthzDecisionStatement


AuthzDecision Fields

The SAMLIdentifiersAuthzDecision type exposes the following members.

Fields
Name | Description
Deny | Deny.
Indeterminate | Indeterminate.
Permit | Permit.
Top
See Also

Reference

SAMLIdentifiersAuthzDecision Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthzDecision.Deny Field

SAMLIdentifiersAuthzDecisionDeny Field

Deny.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Deny = "Deny"
Public Const Deny As String = "Deny"
public:
literal String^ Deny = "Deny"
static val mutable Deny: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthzDecision Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthzDecision.Indeterminate Field

SAMLIdentifiersAuthzDecisionIndeterminate Field

Indeterminate.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Indeterminate = "Indeterminate"
Public Const Indeterminate As String = "Indeterminate"
public:
literal String^ Indeterminate = "Indeterminate"
static val mutable Indeterminate: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthzDecision Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.AuthzDecision.Permit Field

SAMLIdentifiersAuthzDecisionPermit Field

Permit.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Permit = "Permit"
Public Const Permit As String = "Permit"
public:
literal String^ Permit = "Permit"
static val mutable Permit: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersAuthzDecision Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Binding Enumeration

SAMLIdentifiersBinding Enumeration

The SAML bindings.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public enum Binding
Public Enumeration Binding
public enum class Binding
type Binding
Members
Member name | Value | Description
Unspecified | 0 | A special value indicating the binding has not been specified
SOAP | 1 | SOAP
PAOS | 2 | PAOS
HTTPRedirect | 3 | HTTP redirect
HTTPPost | 4 | HTTP POST
HTTPArtifact | 5 | HTTP artifact
URI | 6 | URI
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2SAMLIdentifiersBindingURIs


SAMLIdentifiers.BindingURIs Class

SAMLIdentifiersBindingURIs Class

The SAML binding URIs.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersBindingURIs

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class BindingURIs
Public NotInheritable Class BindingURIs
public ref class BindingURIs abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BindingURIs =  class end

The SAMLIdentifiersBindingURIs type exposes the following members.

Methods
Name | Description
BindingToURI | Converts the binding to the corresponding binding URI.
URIToBinding | Converts the binding URI to the corresponding binding.
Top
Fields
Name | Description
HTTPArtifact | HTTP artifact
HTTPPost | HTTP POST
HTTPRedirect | HTTP redirect
PAOS | PAOS
SOAP | SOAP
URI | URI
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.Bindings


BindingURIs Methods

The SAMLIdentifiersBindingURIs type exposes the following members.

Methods
Name | Description
BindingToURI | Converts the binding to the corresponding binding URI.
URIToBinding | Converts the binding URI to the corresponding binding.
Top
See Also

Reference

SAMLIdentifiersBindingURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.BindingURIs.BindingToURI Method

SAMLIdentifiersBindingURIsBindingToURI Method

Converts the binding to the corresponding binding URI.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string BindingToURI(
    SAMLIdentifiersBinding binding
)
Public Shared Function BindingToURI (
    binding As SAMLIdentifiersBinding
) As String
public:
static String^ BindingToURI(
    SAMLIdentifiersBinding binding
)
static member BindingToURI :
        binding : SAMLIdentifiersBinding -> string

Parameters

binding
Type: ComponentSpace.SAML2SAMLIdentifiersBinding
The binding.

Return Value

Type: String
The binding URI.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the binding is invalid.
See Also

Reference

SAMLIdentifiersBindingURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.BindingURIs.URIToBinding Method

SAMLIdentifiersBindingURIsURIToBinding Method

Converts the binding URI to the corresponding binding.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static SAMLIdentifiersBinding URIToBinding(
    string bindingURI
)
Public Shared Function URIToBinding (
    bindingURI As String
) As SAMLIdentifiersBinding
public:
static SAMLIdentifiersBinding URIToBinding(
    String^ bindingURI
)
static member URIToBinding :
        bindingURI : string -> SAMLIdentifiersBinding

Parameters

bindingURI
Type: SystemString
The binding URI.

Return Value

Type: SAMLIdentifiersBinding
The binding.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the binding URI is invalid.
See Also

Reference

SAMLIdentifiersBindingURIs Class
ComponentSpace.SAML2 Namespace


BindingURIs Fields

The SAMLIdentifiersBindingURIs type exposes the following members.

Fields
Name | Description
HTTPArtifact | HTTP artifact
HTTPPost | HTTP POST
HTTPRedirect | HTTP redirect
PAOS | PAOS
SOAP | SOAP
URI | URI
Top
See Also

Reference

SAMLIdentifiersBindingURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.BindingURIs.HTTPArtifact Field

SAMLIdentifiersBindingURIsHTTPArtifact Field

HTTP artifact

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string HTTPArtifact = "urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Artifact"
Public Const HTTPArtifact As String = "urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Artifact"
public:
literal String^ HTTPArtifact = "urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Artifact"
static val mutable HTTPArtifact: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersBindingURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.BindingURIs.HTTPPost Field

SAMLIdentifiersBindingURIsHTTPPost Field

HTTP POST

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string HTTPPost = "urn:oasis:names:tc:SAML:2.0:bindings:HTTP-POST"
Public Const HTTPPost As String = "urn:oasis:names:tc:SAML:2.0:bindings:HTTP-POST"
public:
literal String^ HTTPPost = "urn:oasis:names:tc:SAML:2.0:bindings:HTTP-POST"
static val mutable HTTPPost: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersBindingURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.BindingURIs.HTTPRedirect Field

SAMLIdentifiersBindingURIsHTTPRedirect Field

HTTP redirect

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string HTTPRedirect = "urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect"
Public Const HTTPRedirect As String = "urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect"
public:
literal String^ HTTPRedirect = "urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect"
static val mutable HTTPRedirect: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersBindingURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.BindingURIs.PAOS Field

SAMLIdentifiersBindingURIsPAOS Field

PAOS

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string PAOS = "urn:oasis:names:tc:SAML:2.0:bindings:PAOS"
Public Const PAOS As String = "urn:oasis:names:tc:SAML:2.0:bindings:PAOS"
public:
literal String^ PAOS = "urn:oasis:names:tc:SAML:2.0:bindings:PAOS"
static val mutable PAOS: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersBindingURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.BindingURIs.SOAP Field

SAMLIdentifiersBindingURIsSOAP Field

SOAP

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SOAP = "urn:oasis:names:tc:SAML:2.0:bindings:SOAP"
Public Const SOAP As String = "urn:oasis:names:tc:SAML:2.0:bindings:SOAP"
public:
literal String^ SOAP = "urn:oasis:names:tc:SAML:2.0:bindings:SOAP"
static val mutable SOAP: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersBindingURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.BindingURIs.URI Field

SAMLIdentifiersBindingURIsURI Field

URI

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string URI = "urn:oasis:names:tc:SAML:2.0:bindings:URI"
Public Const URI As String = "urn:oasis:names:tc:SAML:2.0:bindings:URI"
public:
literal String^ URI = "urn:oasis:names:tc:SAML:2.0:bindings:URI"
static val mutable URI: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersBindingURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ConsentIdentifiers Class

SAMLIdentifiersConsentIdentifiers Class

Consent identifiers.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersConsentIdentifiers

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class ConsentIdentifiers
Public NotInheritable Class ConsentIdentifiers
public ref class ConsentIdentifiers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConsentIdentifiers =  class end

The SAMLIdentifiersConsentIdentifiers type exposes the following members.

Fields
Name | Description
Explicit | Explicit.
Implicit | Implicit.
Inapplicable | Inapplicable.
Obtained | Obtained.
Prior | Prior.
Unavailable | Unavailable.
Unspecified | Unspecified.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsStatusResponseType


ConsentIdentifiers Fields

The SAMLIdentifiersConsentIdentifiers type exposes the following members.

Fields
Name | Description
Explicit | Explicit.
Implicit | Implicit.
Inapplicable | Inapplicable.
Obtained | Obtained.
Prior | Prior.
Unavailable | Unavailable.
Unspecified | Unspecified.
Top
See Also

Reference

SAMLIdentifiersConsentIdentifiers Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ConsentIdentifiers.Explicit Field

SAMLIdentifiersConsentIdentifiersExplicit Field

Explicit.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Explicit = "urn:oasis:names:tc:SAML:2.0:consent:current-explicit"
Public Const Explicit As String = "urn:oasis:names:tc:SAML:2.0:consent:current-explicit"
public:
literal String^ Explicit = "urn:oasis:names:tc:SAML:2.0:consent:current-explicit"
static val mutable Explicit: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersConsentIdentifiers Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ConsentIdentifiers.Implicit Field

SAMLIdentifiersConsentIdentifiersImplicit Field

Implicit.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Implicit = "urn:oasis:names:tc:SAML:2.0:consent:current-implicit"
Public Const Implicit As String = "urn:oasis:names:tc:SAML:2.0:consent:current-implicit"
public:
literal String^ Implicit = "urn:oasis:names:tc:SAML:2.0:consent:current-implicit"
static val mutable Implicit: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersConsentIdentifiers Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ConsentIdentifiers.Inapplicable Field

SAMLIdentifiersConsentIdentifiersInapplicable Field

Inapplicable.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Inapplicable = "urn:oasis:names:tc:SAML:2.0:consent:inapplicable"
Public Const Inapplicable As String = "urn:oasis:names:tc:SAML:2.0:consent:inapplicable"
public:
literal String^ Inapplicable = "urn:oasis:names:tc:SAML:2.0:consent:inapplicable"
static val mutable Inapplicable: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersConsentIdentifiers Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ConsentIdentifiers.Obtained Field

SAMLIdentifiersConsentIdentifiersObtained Field

Obtained.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Obtained = "urn:oasis:names:tc:SAML:2.0:consent:obtained"
Public Const Obtained As String = "urn:oasis:names:tc:SAML:2.0:consent:obtained"
public:
literal String^ Obtained = "urn:oasis:names:tc:SAML:2.0:consent:obtained"
static val mutable Obtained: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersConsentIdentifiers Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ConsentIdentifiers.Prior Field

SAMLIdentifiersConsentIdentifiersPrior Field

Prior.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Prior = "urn:oasis:names:tc:SAML:2.0:consent:prior"
Public Const Prior As String = "urn:oasis:names:tc:SAML:2.0:consent:prior"
public:
literal String^ Prior = "urn:oasis:names:tc:SAML:2.0:consent:prior"
static val mutable Prior: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersConsentIdentifiers Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ConsentIdentifiers.Unavailable Field

SAMLIdentifiersConsentIdentifiersUnavailable Field

Unavailable.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Unavailable = "urn:oasis:names:tc:SAML:2.0:consent:unavailable"
Public Const Unavailable As String = "urn:oasis:names:tc:SAML:2.0:consent:unavailable"
public:
literal String^ Unavailable = "urn:oasis:names:tc:SAML:2.0:consent:unavailable"
static val mutable Unavailable: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersConsentIdentifiers Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ConsentIdentifiers.Unspecified Field

SAMLIdentifiersConsentIdentifiersUnspecified Field

Unspecified.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Unspecified = "urn:oasis:names:tc:SAML:2.0:consent:unspecified"
Public Const Unspecified As String = "urn:oasis:names:tc:SAML:2.0:consent:unspecified"
public:
literal String^ Unspecified = "urn:oasis:names:tc:SAML:2.0:consent:unspecified"
static val mutable Unspecified: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersConsentIdentifiers Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.CryptographicServiceProviderNames Class

SAMLIdentifiersCryptographicServiceProviderNames Class

Windows Cryptographic Service Provider (CSP) names.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersCryptographicServiceProviderNames

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class CryptographicServiceProviderNames
Public NotInheritable Class CryptographicServiceProviderNames
public ref class CryptographicServiceProviderNames abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CryptographicServiceProviderNames =  class end

The SAMLIdentifiersCryptographicServiceProviderNames type exposes the following members.

Fields
Name | Description
MicrosoftEnhancedRSAandAESCryptographicProvider | Microsoft Enhanced RSA and AES Cryptographic Provider.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace


CryptographicServiceProviderNames Fields

The SAMLIdentifiersCryptographicServiceProviderNames type exposes the following members.

Fields
Name | Description
MicrosoftEnhancedRSAandAESCryptographicProvider | Microsoft Enhanced RSA and AES Cryptographic Provider.
Top
See Also

Reference

SAMLIdentifiersCryptographicServiceProviderNames Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.CryptographicServiceProviderNames.MicrosoftEnhancedRSAandAESCryptographicProvider Field

SAMLIdentifiersCryptographicServiceProviderNamesMicrosoftEnhancedRSAandAESCryptographicProvider Field

Microsoft Enhanced RSA and AES Cryptographic Provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string MicrosoftEnhancedRSAandAESCryptographicProvider = "Microsoft Enhanced RSA and AES Cryptographic Provider"
Public Const MicrosoftEnhancedRSAandAESCryptographicProvider As String = "Microsoft Enhanced RSA and AES Cryptographic Provider"
public:
literal String^ MicrosoftEnhancedRSAandAESCryptographicProvider = "Microsoft Enhanced RSA and AES Cryptographic Provider"
static val mutable MicrosoftEnhancedRSAandAESCryptographicProvider: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersCryptographicServiceProviderNames Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.CryptographicServiceProviderTypes Class

SAMLIdentifiersCryptographicServiceProviderTypes Class

Windows Cryptographic Service Provider (CSP) types.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersCryptographicServiceProviderTypes

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class CryptographicServiceProviderTypes
Public NotInheritable Class CryptographicServiceProviderTypes
public ref class CryptographicServiceProviderTypes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CryptographicServiceProviderTypes =  class end

The SAMLIdentifiersCryptographicServiceProviderTypes type exposes the following members.

Fields
Name | Description
MicrosoftEnhancedRSAandAESCryptographicProvider | Microsoft Enhanced RSA and AES Cryptographic Provider.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace


CryptographicServiceProviderTypes Fields

The SAMLIdentifiersCryptographicServiceProviderTypes type exposes the following members.

Fields
Name | Description
MicrosoftEnhancedRSAandAESCryptographicProvider | Microsoft Enhanced RSA and AES Cryptographic Provider.
Top
See Also

Reference

SAMLIdentifiersCryptographicServiceProviderTypes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.CryptographicServiceProviderTypes.MicrosoftEnhancedRSAandAESCryptographicProvider Field

SAMLIdentifiersCryptographicServiceProviderTypesMicrosoftEnhancedRSAandAESCryptographicProvider Field

Microsoft Enhanced RSA and AES Cryptographic Provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const int MicrosoftEnhancedRSAandAESCryptographicProvider = 24
Public Const MicrosoftEnhancedRSAandAESCryptographicProvider As Integer = 24
public:
literal int MicrosoftEnhancedRSAandAESCryptographicProvider = 24
static val mutable MicrosoftEnhancedRSAandAESCryptographicProvider: int

Field Value

Type: Int32
See Also

Reference

SAMLIdentifiersCryptographicServiceProviderTypes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.DataEncryptionMethods Class

SAMLIdentifiersDataEncryptionMethods Class

Data encryption methods.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersDataEncryptionMethods

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class DataEncryptionMethods
Public NotInheritable Class DataEncryptionMethods
public ref class DataEncryptionMethods abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataEncryptionMethods =  class end

The SAMLIdentifiersDataEncryptionMethods type exposes the following members.

Fields
Name | Description
AES_128 | AES 128
AES_192 | AES 128
AES_256 | AES 128
TRIPLE_DES | Triple DES.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace


DataEncryptionMethods Fields

The SAMLIdentifiersDataEncryptionMethods type exposes the following members.

Fields
Name | Description
AES_128 | AES 128
AES_192 | AES 128
AES_256 | AES 128
TRIPLE_DES | Triple DES.
Top
See Also

Reference

SAMLIdentifiersDataEncryptionMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.DataEncryptionMethods.AES_128 Field

SAMLIdentifiersDataEncryptionMethodsAES_128 Field

AES 128

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string AES_128 = "http://www.w3.org/2001/04/xmlenc#aes128-cbc"
Public Const AES_128 As String = "http://www.w3.org/2001/04/xmlenc#aes128-cbc"
public:
literal String^ AES_128 = "http://www.w3.org/2001/04/xmlenc#aes128-cbc"
static val mutable AES_128: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersDataEncryptionMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.DataEncryptionMethods.AES_192 Field

SAMLIdentifiersDataEncryptionMethodsAES_192 Field

AES 128

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string AES_192 = "http://www.w3.org/2001/04/xmlenc#aes192-cbc"
Public Const AES_192 As String = "http://www.w3.org/2001/04/xmlenc#aes192-cbc"
public:
literal String^ AES_192 = "http://www.w3.org/2001/04/xmlenc#aes192-cbc"
static val mutable AES_192: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersDataEncryptionMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.DataEncryptionMethods.AES_256 Field

SAMLIdentifiersDataEncryptionMethodsAES_256 Field

AES 128

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string AES_256 = "http://www.w3.org/2001/04/xmlenc#aes256-cbc"
Public Const AES_256 As String = "http://www.w3.org/2001/04/xmlenc#aes256-cbc"
public:
literal String^ AES_256 = "http://www.w3.org/2001/04/xmlenc#aes256-cbc"
static val mutable AES_256: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersDataEncryptionMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.DataEncryptionMethods.TRIPLE_DES Field

SAMLIdentifiersDataEncryptionMethodsTRIPLE_DES Field

Triple DES.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string TRIPLE_DES = "http://www.w3.org/2001/04/xmlenc#tripledes-cbc"
Public Const TRIPLE_DES As String = "http://www.w3.org/2001/04/xmlenc#tripledes-cbc"
public:
literal String^ TRIPLE_DES = "http://www.w3.org/2001/04/xmlenc#tripledes-cbc"
static val mutable TRIPLE_DES: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersDataEncryptionMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.DigestMethods Class

SAMLIdentifiersDigestMethods Class

Digest methods.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersDigestMethods

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class DigestMethods
Public NotInheritable Class DigestMethods
public ref class DigestMethods abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DigestMethods =  class end

The SAMLIdentifiersDigestMethods type exposes the following members.

Fields
Name | Description
SHA1 | SHA1.
SHA256 | SHA256.
SHA384 | RSA-SHA384.
SHA512 | RSA-SHA512.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace


DigestMethods Fields

The SAMLIdentifiersDigestMethods type exposes the following members.

Fields
Name | Description
SHA1 | SHA1.
SHA256 | SHA256.
SHA384 | RSA-SHA384.
SHA512 | RSA-SHA512.
Top
See Also

Reference

SAMLIdentifiersDigestMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.DigestMethods.SHA1 Field

SAMLIdentifiersDigestMethodsSHA1 Field

SHA1.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SHA1 = "http://www.w3.org/2000/09/xmldsig#sha1"
Public Const SHA1 As String = "http://www.w3.org/2000/09/xmldsig#sha1"
public:
literal String^ SHA1 = "http://www.w3.org/2000/09/xmldsig#sha1"
static val mutable SHA1: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersDigestMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.DigestMethods.SHA256 Field

SAMLIdentifiersDigestMethodsSHA256 Field

SHA256.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SHA256 = "http://www.w3.org/2001/04/xmlenc#sha256"
Public Const SHA256 As String = "http://www.w3.org/2001/04/xmlenc#sha256"
public:
literal String^ SHA256 = "http://www.w3.org/2001/04/xmlenc#sha256"
static val mutable SHA256: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersDigestMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.DigestMethods.SHA384 Field

SAMLIdentifiersDigestMethodsSHA384 Field

RSA-SHA384.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SHA384 = "http://www.w3.org/2001/04/xmldsig-more#sha384"
Public Const SHA384 As String = "http://www.w3.org/2001/04/xmldsig-more#sha384"
public:
literal String^ SHA384 = "http://www.w3.org/2001/04/xmldsig-more#sha384"
static val mutable SHA384: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersDigestMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.DigestMethods.SHA512 Field

SAMLIdentifiersDigestMethodsSHA512 Field

RSA-SHA512.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SHA512 = "http://www.w3.org/2001/04/xmlenc#sha512"
Public Const SHA512 As String = "http://www.w3.org/2001/04/xmlenc#sha512"
public:
literal String^ SHA512 = "http://www.w3.org/2001/04/xmlenc#sha512"
static val mutable SHA512: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersDigestMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.KeyEncryptionMethods Class

SAMLIdentifiersKeyEncryptionMethods Class

Key encryption methods.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersKeyEncryptionMethods

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class KeyEncryptionMethods
Public NotInheritable Class KeyEncryptionMethods
public ref class KeyEncryptionMethods abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KeyEncryptionMethods =  class end

The SAMLIdentifiersKeyEncryptionMethods type exposes the following members.

Fields
Name | Description
RSA_OAEP | RSA OAEP.
RSA_V1_5 | RSA v1.5.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace


KeyEncryptionMethods Fields

The SAMLIdentifiersKeyEncryptionMethods type exposes the following members.

Fields
Name | Description
RSA_OAEP | RSA OAEP.
RSA_V1_5 | RSA v1.5.
Top
See Also

Reference

SAMLIdentifiersKeyEncryptionMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.KeyEncryptionMethods.RSA_OAEP Field

SAMLIdentifiersKeyEncryptionMethodsRSA_OAEP Field

RSA OAEP.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RSA_OAEP = "http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p"
Public Const RSA_OAEP As String = "http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p"
public:
literal String^ RSA_OAEP = "http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p"
static val mutable RSA_OAEP: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersKeyEncryptionMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.KeyEncryptionMethods.RSA_V1_5 Field

SAMLIdentifiersKeyEncryptionMethodsRSA_V1_5 Field

RSA v1.5.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RSA_V1_5 = "http://www.w3.org/2001/04/xmlenc#rsa-1_5"
Public Const RSA_V1_5 As String = "http://www.w3.org/2001/04/xmlenc#rsa-1_5"
public:
literal String^ RSA_V1_5 = "http://www.w3.org/2001/04/xmlenc#rsa-1_5"
static val mutable RSA_V1_5: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersKeyEncryptionMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.MessageType Enumeration

SAMLIdentifiersMessageType Enumeration

The SAML message types.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public enum MessageType
Public Enumeration MessageType
public enum class MessageType
type MessageType
Members
Member name | Value | Description
ArtifactResolve | 0 | Artifact Resolve
ArtifactResponse | 1 | Artifact Response
AssertionIDRequest | 2 | Assertion ID Request
AttributeQuery | 3 | Attribute Query
AuthnQuery | 4 | Authn Query
AuthnRequest | 5 | Authn Request
AuthzDecisionQuery | 6 | Authz Decision Query
LogoutRequest | 7 | Logout Request
LogoutResponse | 8 | Logout Response
ManageNameIDRequest | 9 | Manage Name ID Request
ManageNameIDResponse | 10 | Name ID Mapping Response
NameIDMappingRequest | 11 | Name ID Mapping Request
NameIDMappingResponse | 12 | Name ID Mapping Response
SAMLResponse | 13 | SAML Response
SubjectQuery | 14 | Subject Query
See Also

Reference

ComponentSpace.SAML2 Namespace


SAMLIdentifiers.NameIdentifierFormats Class

SAMLIdentifiersNameIdentifierFormats Class

Name identifier format identifiers.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersNameIdentifierFormats

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class NameIdentifierFormats
Public NotInheritable Class NameIdentifierFormats
public ref class NameIdentifierFormats abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NameIdentifierFormats =  class end

The SAMLIdentifiersNameIdentifierFormats type exposes the following members.

Fields
Name | Description
EmailAddress | Email Address.
Entity | Entity Identifier.
Kerberos | Kerberos Principal Name.
Persistent | Persistent Identifier.
Transient | Transient Identifier.
Unspecified | Unspecified.
WindowsDomainQualifiedName | Windows Domain Qualified Name.
X509SubjectName | X.509 Subject Name.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.AssertionsNameIDType
ComponentSpace.SAML2.AssertionsNameID
ComponentSpace.SAML2.AssertionsIssuer
ComponentSpace.SAML2.ProtocolsNameIDPolicy


NameIdentifierFormats Fields

The SAMLIdentifiersNameIdentifierFormats type exposes the following members.

Fields
Name | Description
EmailAddress | Email Address.
Entity | Entity Identifier.
Kerberos | Kerberos Principal Name.
Persistent | Persistent Identifier.
Transient | Transient Identifier.
Unspecified | Unspecified.
WindowsDomainQualifiedName | Windows Domain Qualified Name.
X509SubjectName | X.509 Subject Name.
Top
See Also

Reference

SAMLIdentifiersNameIdentifierFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.NameIdentifierFormats.EmailAddress Field

SAMLIdentifiersNameIdentifierFormatsEmailAddress Field

Email Address.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string EmailAddress = "urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress"
Public Const EmailAddress As String = "urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress"
public:
literal String^ EmailAddress = "urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress"
static val mutable EmailAddress: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersNameIdentifierFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.NameIdentifierFormats.Entity Field

SAMLIdentifiersNameIdentifierFormatsEntity Field

Entity Identifier.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Entity = "urn:oasis:names:tc:SAML:2.0:nameid-format:entity"
Public Const Entity As String = "urn:oasis:names:tc:SAML:2.0:nameid-format:entity"
public:
literal String^ Entity = "urn:oasis:names:tc:SAML:2.0:nameid-format:entity"
static val mutable Entity: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersNameIdentifierFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.NameIdentifierFormats.Kerberos Field

SAMLIdentifiersNameIdentifierFormatsKerberos Field

Kerberos Principal Name.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Kerberos = "urn:oasis:names:tc:SAML:2.0:nameid-format:kerberos"
Public Const Kerberos As String = "urn:oasis:names:tc:SAML:2.0:nameid-format:kerberos"
public:
literal String^ Kerberos = "urn:oasis:names:tc:SAML:2.0:nameid-format:kerberos"
static val mutable Kerberos: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersNameIdentifierFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.NameIdentifierFormats.Persistent Field

SAMLIdentifiersNameIdentifierFormatsPersistent Field

Persistent Identifier.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Persistent = "urn:oasis:names:tc:SAML:2.0:nameid-format:persistent"
Public Const Persistent As String = "urn:oasis:names:tc:SAML:2.0:nameid-format:persistent"
public:
literal String^ Persistent = "urn:oasis:names:tc:SAML:2.0:nameid-format:persistent"
static val mutable Persistent: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersNameIdentifierFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.NameIdentifierFormats.Transient Field

SAMLIdentifiersNameIdentifierFormatsTransient Field

Transient Identifier.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Transient = "urn:oasis:names:tc:SAML:2.0:nameid-format:transient"
Public Const Transient As String = "urn:oasis:names:tc:SAML:2.0:nameid-format:transient"
public:
literal String^ Transient = "urn:oasis:names:tc:SAML:2.0:nameid-format:transient"
static val mutable Transient: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersNameIdentifierFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.NameIdentifierFormats.Unspecified Field

SAMLIdentifiersNameIdentifierFormatsUnspecified Field

Unspecified.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Unspecified = "urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified"
Public Const Unspecified As String = "urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified"
public:
literal String^ Unspecified = "urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified"
static val mutable Unspecified: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersNameIdentifierFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.NameIdentifierFormats.WindowsDomainQualifiedName Field

SAMLIdentifiersNameIdentifierFormatsWindowsDomainQualifiedName Field

Windows Domain Qualified Name.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string WindowsDomainQualifiedName = "urn:oasis:names:tc:SAML:1.1:nameid-format:WindowsDomainQualifiedName"
Public Const WindowsDomainQualifiedName As String = "urn:oasis:names:tc:SAML:1.1:nameid-format:WindowsDomainQualifiedName"
public:
literal String^ WindowsDomainQualifiedName = "urn:oasis:names:tc:SAML:1.1:nameid-format:WindowsDomainQualifiedName"
static val mutable WindowsDomainQualifiedName: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersNameIdentifierFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.NameIdentifierFormats.X509SubjectName Field

SAMLIdentifiersNameIdentifierFormatsX509SubjectName Field

X.509 Subject Name.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string X509SubjectName = "urn:oasis:names:tc:SAML:1.1:nameid-format:X509SubjectName"
Public Const X509SubjectName As String = "urn:oasis:names:tc:SAML:1.1:nameid-format:X509SubjectName"
public:
literal String^ X509SubjectName = "urn:oasis:names:tc:SAML:1.1:nameid-format:X509SubjectName"
static val mutable X509SubjectName: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersNameIdentifierFormats Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.PrimaryStatusCodes Class

SAMLIdentifiersPrimaryStatusCodes Class

Top level status codes.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersPrimaryStatusCodes

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class PrimaryStatusCodes
Public NotInheritable Class PrimaryStatusCodes
public ref class PrimaryStatusCodes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PrimaryStatusCodes =  class end

The SAMLIdentifiersPrimaryStatusCodes type exposes the following members.

Fields
Name | Description
Requester | Requester.
Responder | Responder.
Success | Success.
VersionMismatch | VersionMismatch.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.ProtocolsStatusCode


PrimaryStatusCodes Fields

The SAMLIdentifiersPrimaryStatusCodes type exposes the following members.

Fields
Name | Description
Requester | Requester.
Responder | Responder.
Success | Success.
VersionMismatch | VersionMismatch.
Top
See Also

Reference

SAMLIdentifiersPrimaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.PrimaryStatusCodes.Requester Field

SAMLIdentifiersPrimaryStatusCodesRequester Field

Requester.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Requester = "urn:oasis:names:tc:SAML:2.0:status:Requester"
Public Const Requester As String = "urn:oasis:names:tc:SAML:2.0:status:Requester"
public:
literal String^ Requester = "urn:oasis:names:tc:SAML:2.0:status:Requester"
static val mutable Requester: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersPrimaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.PrimaryStatusCodes.Responder Field

SAMLIdentifiersPrimaryStatusCodesResponder Field

Responder.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Responder = "urn:oasis:names:tc:SAML:2.0:status:Responder"
Public Const Responder As String = "urn:oasis:names:tc:SAML:2.0:status:Responder"
public:
literal String^ Responder = "urn:oasis:names:tc:SAML:2.0:status:Responder"
static val mutable Responder: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersPrimaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.PrimaryStatusCodes.Success Field

SAMLIdentifiersPrimaryStatusCodesSuccess Field

Success.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Success = "urn:oasis:names:tc:SAML:2.0:status:Success"
Public Const Success As String = "urn:oasis:names:tc:SAML:2.0:status:Success"
public:
literal String^ Success = "urn:oasis:names:tc:SAML:2.0:status:Success"
static val mutable Success: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersPrimaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.PrimaryStatusCodes.VersionMismatch Field

SAMLIdentifiersPrimaryStatusCodesVersionMismatch Field

VersionMismatch.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string VersionMismatch = "urn:oasis:names:tc:SAML:2.0:status:VersionMismatch"
Public Const VersionMismatch As String = "urn:oasis:names:tc:SAML:2.0:status:VersionMismatch"
public:
literal String^ VersionMismatch = "urn:oasis:names:tc:SAML:2.0:status:VersionMismatch"
static val mutable VersionMismatch: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersPrimaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.Profile Enumeration

SAMLIdentifiersProfile Enumeration

The SAML profiles.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public enum Profile
Public Enumeration Profile
public enum class Profile
type Profile
Members
Member name | Value | Description
Unspecified | 0 | A special value indicating the profile has not been specified
SSOBrowser | 1 | SSO browser
SSOECP | 2 | Enhanced client or proxy
SSOLogout | 3 | SSO logout
NameIDManagement | 4 | Name identifier management
Artifact | 5 | Artifact resolution
Query | 6 | Assertion query/request
NameIDMapping | 7 | Name identifier mapping
BasicAttribute | 8 | Basic attribute
X500 | 9 | X.500/LDAP attribute
UUID | 10 | UUID attribute
DCE | 11 | DCE PAC attribute
XACML | 12 | XACML attribute
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2SAMLIdentifiersProfileURIs


SAMLIdentifiers.ProfileURIs Class

SAMLIdentifiersProfileURIs Class

The SAML profile URIs.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersProfileURIs

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class ProfileURIs
Public NotInheritable Class ProfileURIs
public ref class ProfileURIs abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ProfileURIs =  class end

The SAMLIdentifiersProfileURIs type exposes the following members.

Methods
Name | Description
ProfileToURI | Converts the profile to the corresponding profile URI.
URIToProfile | Converts the profile URI to the corresponding profile.
Top
Fields
Name | Description
Artifact | Artifact resolution
BasicAttribute | Basic attribute
DCE | DCE PAC attribute
NameIDManagement | Name identifier management
NameIDMapping | Name identifier mapping
Query | Assertion query/request
SSOBrowser | SSO browser
SSOECP | Enhanced client or proxy
SSOLogout | SSO logout
UUID | UUID attribute
X500 | X.500/LDAP attribute
XACML | XACML attribute
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2SAMLIdentifiersProfileURIs


ProfileURIs Methods

The SAMLIdentifiersProfileURIs type exposes the following members.

Methods
Name | Description
ProfileToURI | Converts the profile to the corresponding profile URI.
URIToProfile | Converts the profile URI to the corresponding profile.
Top
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.ProfileToURI Method

SAMLIdentifiersProfileURIsProfileToURI Method

Converts the profile to the corresponding profile URI.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string ProfileToURI(
    SAMLIdentifiersProfile profile
)
Public Shared Function ProfileToURI (
    profile As SAMLIdentifiersProfile
) As String
public:
static String^ ProfileToURI(
    SAMLIdentifiersProfile profile
)
static member ProfileToURI :
        profile : SAMLIdentifiersProfile -> string

Parameters

profile
Type: ComponentSpace.SAML2SAMLIdentifiersProfile
The profile.

Return Value

Type: String
The profile URI.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the profile is invalid.
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.URIToProfile Method

SAMLIdentifiersProfileURIsURIToProfile Method

Converts the profile URI to the corresponding profile.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static SAMLIdentifiersProfile URIToProfile(
    string profileURI
)
Public Shared Function URIToProfile (
    profileURI As String
) As SAMLIdentifiersProfile
public:
static SAMLIdentifiersProfile URIToProfile(
    String^ profileURI
)
static member URIToProfile :
        profileURI : string -> SAMLIdentifiersProfile

Parameters

profileURI
Type: SystemString
The profile URI.

Return Value

Type: SAMLIdentifiersProfile
The profile.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the profile URI is invalid.
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


ProfileURIs Fields

The SAMLIdentifiersProfileURIs type exposes the following members.

Fields
Name | Description
Artifact | Artifact resolution
BasicAttribute | Basic attribute
DCE | DCE PAC attribute
NameIDManagement | Name identifier management
NameIDMapping | Name identifier mapping
Query | Assertion query/request
SSOBrowser | SSO browser
SSOECP | Enhanced client or proxy
SSOLogout | SSO logout
UUID | UUID attribute
X500 | X.500/LDAP attribute
XACML | XACML attribute
Top
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.Artifact Field

SAMLIdentifiersProfileURIsArtifact Field

Artifact resolution

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Artifact = "urn:oasis:names:tc:SAML:2.0:profiles:artifact"
Public Const Artifact As String = "urn:oasis:names:tc:SAML:2.0:profiles:artifact"
public:
literal String^ Artifact = "urn:oasis:names:tc:SAML:2.0:profiles:artifact"
static val mutable Artifact: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.BasicAttribute Field

SAMLIdentifiersProfileURIsBasicAttribute Field

Basic attribute

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string BasicAttribute = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:basic"
Public Const BasicAttribute As String = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:basic"
public:
literal String^ BasicAttribute = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:basic"
static val mutable BasicAttribute: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.DCE Field

SAMLIdentifiersProfileURIsDCE Field

DCE PAC attribute

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string DCE = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:DCE"
Public Const DCE As String = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:DCE"
public:
literal String^ DCE = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:DCE"
static val mutable DCE: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.NameIDManagement Field

SAMLIdentifiersProfileURIsNameIDManagement Field

Name identifier management

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NameIDManagement = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:nameid-mgmt"
Public Const NameIDManagement As String = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:nameid-mgmt"
public:
literal String^ NameIDManagement = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:nameid-mgmt"
static val mutable NameIDManagement: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.NameIDMapping Field

SAMLIdentifiersProfileURIsNameIDMapping Field

Name identifier mapping

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NameIDMapping = "urn:oasis:names:tc:SAML:2.0:profiles:nameidmapping"
Public Const NameIDMapping As String = "urn:oasis:names:tc:SAML:2.0:profiles:nameidmapping"
public:
literal String^ NameIDMapping = "urn:oasis:names:tc:SAML:2.0:profiles:nameidmapping"
static val mutable NameIDMapping: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.Query Field

SAMLIdentifiersProfileURIsQuery Field

Assertion query/request

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Query = "urn:oasis:names:tc:SAML:2.0:profiles:query"
Public Const Query As String = "urn:oasis:names:tc:SAML:2.0:profiles:query"
public:
literal String^ Query = "urn:oasis:names:tc:SAML:2.0:profiles:query"
static val mutable Query: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.SSOBrowser Field

SAMLIdentifiersProfileURIsSSOBrowser Field

SSO browser

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SSOBrowser = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:browser"
Public Const SSOBrowser As String = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:browser"
public:
literal String^ SSOBrowser = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:browser"
static val mutable SSOBrowser: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.SSOECP Field

SAMLIdentifiersProfileURIsSSOECP Field

Enhanced client or proxy

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SSOECP = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:ecp"
Public Const SSOECP As String = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:ecp"
public:
literal String^ SSOECP = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:ecp"
static val mutable SSOECP: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.SSOLogout Field

SAMLIdentifiersProfileURIsSSOLogout Field

SSO logout

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SSOLogout = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:logout"
Public Const SSOLogout As String = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:logout"
public:
literal String^ SSOLogout = "urn:oasis:names:tc:SAML:2.0:profiles:SSO:logout"
static val mutable SSOLogout: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.UUID Field

SAMLIdentifiersProfileURIsUUID Field

UUID attribute

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string UUID = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:UUID"
Public Const UUID As String = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:UUID"
public:
literal String^ UUID = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:UUID"
static val mutable UUID: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.X500 Field

SAMLIdentifiersProfileURIsX500 Field

X.500/LDAP attribute

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string X500 = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:X500"
Public Const X500 As String = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:X500"
public:
literal String^ X500 = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:X500"
static val mutable X500: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.ProfileURIs.XACML Field

SAMLIdentifiersProfileURIsXACML Field

XACML attribute

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string XACML = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:XACML"
Public Const XACML As String = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:XACML"
public:
literal String^ XACML = "urn:oasis:names:tc:SAML:2.0:profiles:attribute:XACML"
static val mutable XACML: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersProfileURIs Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes Class

SAMLIdentifiersSecondaryStatusCodes Class

Second level status codes.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersSecondaryStatusCodes

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SecondaryStatusCodes
Public NotInheritable Class SecondaryStatusCodes
public ref class SecondaryStatusCodes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SecondaryStatusCodes =  class end

The SAMLIdentifiersSecondaryStatusCodes type exposes the following members.

Fields
Name | Description
AuthnFailed | AuthnFailed.
InvalidAttrNameOrValue | InvalidAttrNameOrValue.
InvalidNameIDPolicy | InvalidNameIDPolicy.
NoAuthnContext | NoAuthnContext.
NoAvailableIDP | NoAvailableIDP.
NoPassive | NoPassive.
NoSupportedIDP | NoSupportedIDP.
PartialLogout | PartialLogout.
ProxyCountExceeded | ProxyCountExceeded.
RequestDenied | RequestDenied.
RequestUnsupported | RequestUnsupported.
RequestVersionDeprecated | RequestVersionDeprecated.
RequestVersionTooHigh | RequestVersionTooHigh.
RequestVersionTooLow | RequestVersionTooLow.
ResourceNotRecognized | ResourceNotRecognized.
TooManyResponses | TooManyResponses.
UnknownAttrProfile | UnknownAttrProfile.
UnknownPrincipal | UnknownPrincipal.
UnsupportedBinding | UnsupportedBinding.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.ProtocolsStatusCode


SecondaryStatusCodes Fields

The SAMLIdentifiersSecondaryStatusCodes type exposes the following members.

Fields
Name | Description
AuthnFailed | AuthnFailed.
InvalidAttrNameOrValue | InvalidAttrNameOrValue.
InvalidNameIDPolicy | InvalidNameIDPolicy.
NoAuthnContext | NoAuthnContext.
NoAvailableIDP | NoAvailableIDP.
NoPassive | NoPassive.
NoSupportedIDP | NoSupportedIDP.
PartialLogout | PartialLogout.
ProxyCountExceeded | ProxyCountExceeded.
RequestDenied | RequestDenied.
RequestUnsupported | RequestUnsupported.
RequestVersionDeprecated | RequestVersionDeprecated.
RequestVersionTooHigh | RequestVersionTooHigh.
RequestVersionTooLow | RequestVersionTooLow.
ResourceNotRecognized | ResourceNotRecognized.
TooManyResponses | TooManyResponses.
UnknownAttrProfile | UnknownAttrProfile.
UnknownPrincipal | UnknownPrincipal.
UnsupportedBinding | UnsupportedBinding.
Top
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.AuthnFailed Field

SAMLIdentifiersSecondaryStatusCodesAuthnFailed Field

AuthnFailed.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string AuthnFailed = "urn:oasis:names:tc:SAML:2.0:status:AuthnFailed"
Public Const AuthnFailed As String = "urn:oasis:names:tc:SAML:2.0:status:AuthnFailed"
public:
literal String^ AuthnFailed = "urn:oasis:names:tc:SAML:2.0:status:AuthnFailed"
static val mutable AuthnFailed: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.InvalidAttrNameOrValue Field

SAMLIdentifiersSecondaryStatusCodesInvalidAttrNameOrValue Field

InvalidAttrNameOrValue.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string InvalidAttrNameOrValue = "urn:oasis:names:tc:SAML:2.0:status:InvalidAttrNameOrValue"
Public Const InvalidAttrNameOrValue As String = "urn:oasis:names:tc:SAML:2.0:status:InvalidAttrNameOrValue"
public:
literal String^ InvalidAttrNameOrValue = "urn:oasis:names:tc:SAML:2.0:status:InvalidAttrNameOrValue"
static val mutable InvalidAttrNameOrValue: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.InvalidNameIDPolicy Field

SAMLIdentifiersSecondaryStatusCodesInvalidNameIDPolicy Field

InvalidNameIDPolicy.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string InvalidNameIDPolicy = "urn:oasis:names:tc:SAML:2.0:status:urn:oasis:names:tc:SAML:2.0:status:InvalidNameIDPolicy"
Public Const InvalidNameIDPolicy As String = "urn:oasis:names:tc:SAML:2.0:status:urn:oasis:names:tc:SAML:2.0:status:InvalidNameIDPolicy"
public:
literal String^ InvalidNameIDPolicy = "urn:oasis:names:tc:SAML:2.0:status:urn:oasis:names:tc:SAML:2.0:status:InvalidNameIDPolicy"
static val mutable InvalidNameIDPolicy: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.NoAuthnContext Field

SAMLIdentifiersSecondaryStatusCodesNoAuthnContext Field

NoAuthnContext.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NoAuthnContext = "urn:oasis:names:tc:SAML:2.0:status:NoAuthnContext"
Public Const NoAuthnContext As String = "urn:oasis:names:tc:SAML:2.0:status:NoAuthnContext"
public:
literal String^ NoAuthnContext = "urn:oasis:names:tc:SAML:2.0:status:NoAuthnContext"
static val mutable NoAuthnContext: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.NoAvailableIDP Field

SAMLIdentifiersSecondaryStatusCodesNoAvailableIDP Field

NoAvailableIDP.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NoAvailableIDP = "urn:oasis:names:tc:SAML:2.0:status:NoAvailableIDP"
Public Const NoAvailableIDP As String = "urn:oasis:names:tc:SAML:2.0:status:NoAvailableIDP"
public:
literal String^ NoAvailableIDP = "urn:oasis:names:tc:SAML:2.0:status:NoAvailableIDP"
static val mutable NoAvailableIDP: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.NoPassive Field

SAMLIdentifiersSecondaryStatusCodesNoPassive Field

NoPassive.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NoPassive = "urn:oasis:names:tc:SAML:2.0:status:NoPassive"
Public Const NoPassive As String = "urn:oasis:names:tc:SAML:2.0:status:NoPassive"
public:
literal String^ NoPassive = "urn:oasis:names:tc:SAML:2.0:status:NoPassive"
static val mutable NoPassive: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.NoSupportedIDP Field

SAMLIdentifiersSecondaryStatusCodesNoSupportedIDP Field

NoSupportedIDP.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NoSupportedIDP = "urn:oasis:names:tc:SAML:2.0:status:NoSupportedIDP"
Public Const NoSupportedIDP As String = "urn:oasis:names:tc:SAML:2.0:status:NoSupportedIDP"
public:
literal String^ NoSupportedIDP = "urn:oasis:names:tc:SAML:2.0:status:NoSupportedIDP"
static val mutable NoSupportedIDP: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.PartialLogout Field

SAMLIdentifiersSecondaryStatusCodesPartialLogout Field

PartialLogout.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string PartialLogout = "urn:oasis:names:tc:SAML:2.0:status:PartialLogout"
Public Const PartialLogout As String = "urn:oasis:names:tc:SAML:2.0:status:PartialLogout"
public:
literal String^ PartialLogout = "urn:oasis:names:tc:SAML:2.0:status:PartialLogout"
static val mutable PartialLogout: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.ProxyCountExceeded Field

SAMLIdentifiersSecondaryStatusCodesProxyCountExceeded Field

ProxyCountExceeded.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string ProxyCountExceeded = "urn:oasis:names:tc:SAML:2.0:status:ProxyCountExceeded"
Public Const ProxyCountExceeded As String = "urn:oasis:names:tc:SAML:2.0:status:ProxyCountExceeded"
public:
literal String^ ProxyCountExceeded = "urn:oasis:names:tc:SAML:2.0:status:ProxyCountExceeded"
static val mutable ProxyCountExceeded: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.RequestDenied Field

SAMLIdentifiersSecondaryStatusCodesRequestDenied Field

RequestDenied.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RequestDenied = "urn:oasis:names:tc:SAML:2.0:status:RequestDenied"
Public Const RequestDenied As String = "urn:oasis:names:tc:SAML:2.0:status:RequestDenied"
public:
literal String^ RequestDenied = "urn:oasis:names:tc:SAML:2.0:status:RequestDenied"
static val mutable RequestDenied: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.RequestUnsupported Field

SAMLIdentifiersSecondaryStatusCodesRequestUnsupported Field

RequestUnsupported.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RequestUnsupported = "urn:oasis:names:tc:SAML:2.0:status:RequestUnsupported"
Public Const RequestUnsupported As String = "urn:oasis:names:tc:SAML:2.0:status:RequestUnsupported"
public:
literal String^ RequestUnsupported = "urn:oasis:names:tc:SAML:2.0:status:RequestUnsupported"
static val mutable RequestUnsupported: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.RequestVersionDeprecated Field

SAMLIdentifiersSecondaryStatusCodesRequestVersionDeprecated Field

RequestVersionDeprecated.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RequestVersionDeprecated = "urn:oasis:names:tc:SAML:2.0:status:RequestVersionDeprecated"
Public Const RequestVersionDeprecated As String = "urn:oasis:names:tc:SAML:2.0:status:RequestVersionDeprecated"
public:
literal String^ RequestVersionDeprecated = "urn:oasis:names:tc:SAML:2.0:status:RequestVersionDeprecated"
static val mutable RequestVersionDeprecated: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.RequestVersionTooHigh Field

SAMLIdentifiersSecondaryStatusCodesRequestVersionTooHigh Field

RequestVersionTooHigh.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RequestVersionTooHigh = "urn:oasis:names:tc:SAML:2.0:status:RequestVersionTooHigh"
Public Const RequestVersionTooHigh As String = "urn:oasis:names:tc:SAML:2.0:status:RequestVersionTooHigh"
public:
literal String^ RequestVersionTooHigh = "urn:oasis:names:tc:SAML:2.0:status:RequestVersionTooHigh"
static val mutable RequestVersionTooHigh: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.RequestVersionTooLow Field

SAMLIdentifiersSecondaryStatusCodesRequestVersionTooLow Field

RequestVersionTooLow.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RequestVersionTooLow = "urn:oasis:names:tc:SAML:2.0:status:RequestVersionTooLow"
Public Const RequestVersionTooLow As String = "urn:oasis:names:tc:SAML:2.0:status:RequestVersionTooLow"
public:
literal String^ RequestVersionTooLow = "urn:oasis:names:tc:SAML:2.0:status:RequestVersionTooLow"
static val mutable RequestVersionTooLow: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.ResourceNotRecognized Field

SAMLIdentifiersSecondaryStatusCodesResourceNotRecognized Field

ResourceNotRecognized.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string ResourceNotRecognized = "urn:oasis:names:tc:SAML:2.0:status:ResourceNotRecognized"
Public Const ResourceNotRecognized As String = "urn:oasis:names:tc:SAML:2.0:status:ResourceNotRecognized"
public:
literal String^ ResourceNotRecognized = "urn:oasis:names:tc:SAML:2.0:status:ResourceNotRecognized"
static val mutable ResourceNotRecognized: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.TooManyResponses Field

SAMLIdentifiersSecondaryStatusCodesTooManyResponses Field

TooManyResponses.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string TooManyResponses = "urn:oasis:names:tc:SAML:2.0:status:TooManyResponses"
Public Const TooManyResponses As String = "urn:oasis:names:tc:SAML:2.0:status:TooManyResponses"
public:
literal String^ TooManyResponses = "urn:oasis:names:tc:SAML:2.0:status:TooManyResponses"
static val mutable TooManyResponses: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.UnknownAttrProfile Field

SAMLIdentifiersSecondaryStatusCodesUnknownAttrProfile Field

UnknownAttrProfile.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string UnknownAttrProfile = "urn:oasis:names:tc:SAML:2.0:status:UnknownAttrProfile"
Public Const UnknownAttrProfile As String = "urn:oasis:names:tc:SAML:2.0:status:UnknownAttrProfile"
public:
literal String^ UnknownAttrProfile = "urn:oasis:names:tc:SAML:2.0:status:UnknownAttrProfile"
static val mutable UnknownAttrProfile: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.UnknownPrincipal Field

SAMLIdentifiersSecondaryStatusCodesUnknownPrincipal Field

UnknownPrincipal.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string UnknownPrincipal = "urn:oasis:names:tc:SAML:2.0:status:UnknownPrincipal"
Public Const UnknownPrincipal As String = "urn:oasis:names:tc:SAML:2.0:status:UnknownPrincipal"
public:
literal String^ UnknownPrincipal = "urn:oasis:names:tc:SAML:2.0:status:UnknownPrincipal"
static val mutable UnknownPrincipal: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SecondaryStatusCodes.UnsupportedBinding Field

SAMLIdentifiersSecondaryStatusCodesUnsupportedBinding Field

UnsupportedBinding.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string UnsupportedBinding = "urn:oasis:names:tc:SAML:2.0:status:UnsupportedBinding"
Public Const UnsupportedBinding As String = "urn:oasis:names:tc:SAML:2.0:status:UnsupportedBinding"
public:
literal String^ UnsupportedBinding = "urn:oasis:names:tc:SAML:2.0:status:UnsupportedBinding"
static val mutable UnsupportedBinding: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSecondaryStatusCodes Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SignatureMethods Class

SAMLIdentifiersSignatureMethods Class

Signature methods.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersSignatureMethods

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SignatureMethods
Public NotInheritable Class SignatureMethods
public ref class SignatureMethods abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SignatureMethods =  class end

The SAMLIdentifiersSignatureMethods type exposes the following members.

Fields
Name | Description
DSA_SHA1 | DSA-SHA1.
RSA_SHA1 | RSA-SHA1.
RSA_SHA256 | RSA-SHA256.
RSA_SHA384 | RSA-SHA384.
RSA_SHA512 | RSA-SHA512.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace


SignatureMethods Fields

The SAMLIdentifiersSignatureMethods type exposes the following members.

Fields
Name | Description
DSA_SHA1 | DSA-SHA1.
RSA_SHA1 | RSA-SHA1.
RSA_SHA256 | RSA-SHA256.
RSA_SHA384 | RSA-SHA384.
RSA_SHA512 | RSA-SHA512.
Top
See Also

Reference

SAMLIdentifiersSignatureMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SignatureMethods.DSA_SHA1 Field

SAMLIdentifiersSignatureMethodsDSA_SHA1 Field

DSA-SHA1.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string DSA_SHA1 = "http://www.w3.org/2000/09/xmldsig#dsa-sha1"
Public Const DSA_SHA1 As String = "http://www.w3.org/2000/09/xmldsig#dsa-sha1"
public:
literal String^ DSA_SHA1 = "http://www.w3.org/2000/09/xmldsig#dsa-sha1"
static val mutable DSA_SHA1: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSignatureMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SignatureMethods.RSA_SHA1 Field

SAMLIdentifiersSignatureMethodsRSA_SHA1 Field

RSA-SHA1.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RSA_SHA1 = "http://www.w3.org/2000/09/xmldsig#rsa-sha1"
Public Const RSA_SHA1 As String = "http://www.w3.org/2000/09/xmldsig#rsa-sha1"
public:
literal String^ RSA_SHA1 = "http://www.w3.org/2000/09/xmldsig#rsa-sha1"
static val mutable RSA_SHA1: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSignatureMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SignatureMethods.RSA_SHA256 Field

SAMLIdentifiersSignatureMethodsRSA_SHA256 Field

RSA-SHA256.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RSA_SHA256 = "http://www.w3.org/2001/04/xmldsig-more#rsa-sha256"
Public Const RSA_SHA256 As String = "http://www.w3.org/2001/04/xmldsig-more#rsa-sha256"
public:
literal String^ RSA_SHA256 = "http://www.w3.org/2001/04/xmldsig-more#rsa-sha256"
static val mutable RSA_SHA256: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSignatureMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SignatureMethods.RSA_SHA384 Field

SAMLIdentifiersSignatureMethodsRSA_SHA384 Field

RSA-SHA384.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RSA_SHA384 = "http://www.w3.org/2001/04/xmldsig-more#rsa-sha384"
Public Const RSA_SHA384 As String = "http://www.w3.org/2001/04/xmldsig-more#rsa-sha384"
public:
literal String^ RSA_SHA384 = "http://www.w3.org/2001/04/xmldsig-more#rsa-sha384"
static val mutable RSA_SHA384: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSignatureMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SignatureMethods.RSA_SHA512 Field

SAMLIdentifiersSignatureMethodsRSA_SHA512 Field

RSA-SHA512.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string RSA_SHA512 = "http://www.w3.org/2001/04/xmldsig-more#rsa-sha512"
Public Const RSA_SHA512 As String = "http://www.w3.org/2001/04/xmldsig-more#rsa-sha512"
public:
literal String^ RSA_SHA512 = "http://www.w3.org/2001/04/xmldsig-more#rsa-sha512"
static val mutable RSA_SHA512: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSignatureMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SubjectConfirmationMethods Class

SAMLIdentifiersSubjectConfirmationMethods Class

Consent identifiers.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentifiersSubjectConfirmationMethods

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SubjectConfirmationMethods
Public NotInheritable Class SubjectConfirmationMethods
public ref class SubjectConfirmationMethods abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SubjectConfirmationMethods =  class end

The SAMLIdentifiersSubjectConfirmationMethods type exposes the following members.

Fields
Name | Description
Bearer | Bearer.
HolderOfKey | Holder of key.
SenderVouches | Sender vouches.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace
ComponentSpace.SAML2.AssertionsSubjectConfirmation


SubjectConfirmationMethods Fields

The SAMLIdentifiersSubjectConfirmationMethods type exposes the following members.

Fields
Name | Description
Bearer | Bearer.
HolderOfKey | Holder of key.
SenderVouches | Sender vouches.
Top
See Also

Reference

SAMLIdentifiersSubjectConfirmationMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SubjectConfirmationMethods.Bearer Field

SAMLIdentifiersSubjectConfirmationMethodsBearer Field

Bearer.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Bearer = "urn:oasis:names:tc:SAML:2.0:cm:bearer"
Public Const Bearer As String = "urn:oasis:names:tc:SAML:2.0:cm:bearer"
public:
literal String^ Bearer = "urn:oasis:names:tc:SAML:2.0:cm:bearer"
static val mutable Bearer: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSubjectConfirmationMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SubjectConfirmationMethods.HolderOfKey Field

SAMLIdentifiersSubjectConfirmationMethodsHolderOfKey Field

Holder of key.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string HolderOfKey = "urn:oasis:names:tc:SAML:2.0:cm:holder-of-key"
Public Const HolderOfKey As String = "urn:oasis:names:tc:SAML:2.0:cm:holder-of-key"
public:
literal String^ HolderOfKey = "urn:oasis:names:tc:SAML:2.0:cm:holder-of-key"
static val mutable HolderOfKey: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSubjectConfirmationMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentifiers.SubjectConfirmationMethods.SenderVouches Field

SAMLIdentifiersSubjectConfirmationMethodsSenderVouches Field

Sender vouches.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SenderVouches = "urn:oasis:names:tc:SAML:2.0:cm:sender-vouches"
Public Const SenderVouches As String = "urn:oasis:names:tc:SAML:2.0:cm:sender-vouches"
public:
literal String^ SenderVouches = "urn:oasis:names:tc:SAML:2.0:cm:sender-vouches"
static val mutable SenderVouches: string

Field Value

Type: String
See Also

Reference

SAMLIdentifiersSubjectConfirmationMethods Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider Class

Provides Identity Provider (IdP) support for web browser single sign-on.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLIdentityProvider

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAMLIdentityProvider
Public NotInheritable Class SAMLIdentityProvider
public ref class SAMLIdentityProvider abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAMLIdentityProvider =  class end

The SAMLIdentityProvider type exposes the following members.

Methods
Name | Description
GetPartnerPendingResponse | Gets the name of the partner service provider to which a single sign-on or logout response is pending.
InitiateSLO(HttpResponse, String, String) | Initiates single logout from the identity provider to the service providers (ie. IdP-initiated SLO). A logout request is sent to the service providers that are signed in.
InitiateSLO(HttpResponseBase, String, String) | Initiates single logout from the identity provider to the service providers (ie. IdP-initiated SLO). A logout request is sent to the service providers that are signed in.
InitiateSSO(HttpResponse, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, SAMLAttribute, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, IDictionaryString, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, SAMLAttribute, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, IDictionaryString, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, SAMLAttribute, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, IDictionaryString, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, SAMLAttribute, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, IDictionaryString, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, SAMLAttribute, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, IDictionaryString, String, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, SAMLAttribute, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, IDictionaryString, String, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
IsReceiveSLOPending | Indicates whether a single logout response from a service provider is pending. Single logout is pending if a logout request has been sent to a service provider and a logout response is pending.
IsReceiveSLOPending(String) | Indicates whether a single logout response from a service provider is pending. Single logout is pending if a logout request has been sent to a service provider and a logout response is pending.
IsSendSLOPending | Indicates whether a single logout response to a service provider is pending. Single logout is pending if a logout request has been received from a service provider and a logout response is pending.
IsSendSLOPending(String) | Indicates whether a single logout response to a service provider is pending. Single logout is pending if a logout request has been received from a service provider and a logout response is pending.
IsSendSSOPending | Indicates whether single sign-on to a service provider is pending. Single sign-on is pending if an authn request has been received from a service provider and a SAML response is pending.
IsSendSSOPending(String) | Indicates whether single sign-on to a service provider is pending. Single sign-on is pending if an authn request has been received from the service provider and a SAML response is pending.
IsSSO | Indicates whether the identity provider is currently single signed-on to a service provider.
IsSSO(String) | Indicates whether the identity provider is currently single signed-on to a service provider.
ReceiveSLO(HttpRequest, HttpResponse, Boolean, Boolean, String, String, String) | Receives a single logout request (ie. SP-initiated SLO) or single logout response (ie. IdP-initiated SLO) from a service provider.
ReceiveSLO(HttpRequestBase, HttpResponseBase, Boolean, Boolean, String, String, String) | Receives a single logout request (ie. SP-initiated SLO) or single logout response (ie. IdP-initiated SLO) from a service provider.
ReceiveSSO(HttpRequest, String) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
ReceiveSSO(HttpRequestBase, String) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
ReceiveSSO(HttpRequest, String, SSOOptions) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
ReceiveSSO(HttpRequestBase, String, SSOOptions) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
SendSLO(HttpResponse, String) | Sends a single logout message to a service provider (ie. SP-initiated SLO).
SendSLO(HttpResponseBase, String) | Sends a single logout message to a service provider (ie. SP-initiated SLO).
SendSSO(HttpResponse, Status) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponse, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, Status) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, Status, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponse, String, SAMLAttribute) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, IDictionaryString, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, Status, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, String, SAMLAttribute) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, IDictionaryString, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponse, String, SAMLAttribute, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, IDictionaryString, String, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, String, SAMLAttribute, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, IDictionaryString, String, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
Top
See Also

Reference

ComponentSpace.SAML2 Namespace


SAMLIdentityProvider Methods

The SAMLIdentityProvider type exposes the following members.

Methods
Name | Description
GetPartnerPendingResponse | Gets the name of the partner service provider to which a single sign-on or logout response is pending.
InitiateSLO(HttpResponse, String, String) | Initiates single logout from the identity provider to the service providers (ie. IdP-initiated SLO). A logout request is sent to the service providers that are signed in.
InitiateSLO(HttpResponseBase, String, String) | Initiates single logout from the identity provider to the service providers (ie. IdP-initiated SLO). A logout request is sent to the service providers that are signed in.
InitiateSSO(HttpResponse, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, SAMLAttribute, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, IDictionaryString, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, SAMLAttribute, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, IDictionaryString, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, SAMLAttribute, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, IDictionaryString, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, SAMLAttribute, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, IDictionaryString, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, SAMLAttribute, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, IDictionaryString, String, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, SAMLAttribute, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, IDictionaryString, String, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
IsReceiveSLOPending | Indicates whether a single logout response from a service provider is pending. Single logout is pending if a logout request has been sent to a service provider and a logout response is pending.
IsReceiveSLOPending(String) | Indicates whether a single logout response from a service provider is pending. Single logout is pending if a logout request has been sent to a service provider and a logout response is pending.
IsSendSLOPending | Indicates whether a single logout response to a service provider is pending. Single logout is pending if a logout request has been received from a service provider and a logout response is pending.
IsSendSLOPending(String) | Indicates whether a single logout response to a service provider is pending. Single logout is pending if a logout request has been received from a service provider and a logout response is pending.
IsSendSSOPending | Indicates whether single sign-on to a service provider is pending. Single sign-on is pending if an authn request has been received from a service provider and a SAML response is pending.
IsSendSSOPending(String) | Indicates whether single sign-on to a service provider is pending. Single sign-on is pending if an authn request has been received from the service provider and a SAML response is pending.
IsSSO | Indicates whether the identity provider is currently single signed-on to a service provider.
IsSSO(String) | Indicates whether the identity provider is currently single signed-on to a service provider.
ReceiveSLO(HttpRequest, HttpResponse, Boolean, Boolean, String, String, String) | Receives a single logout request (ie. SP-initiated SLO) or single logout response (ie. IdP-initiated SLO) from a service provider.
ReceiveSLO(HttpRequestBase, HttpResponseBase, Boolean, Boolean, String, String, String) | Receives a single logout request (ie. SP-initiated SLO) or single logout response (ie. IdP-initiated SLO) from a service provider.
ReceiveSSO(HttpRequest, String) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
ReceiveSSO(HttpRequestBase, String) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
ReceiveSSO(HttpRequest, String, SSOOptions) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
ReceiveSSO(HttpRequestBase, String, SSOOptions) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
SendSLO(HttpResponse, String) | Sends a single logout message to a service provider (ie. SP-initiated SLO).
SendSLO(HttpResponseBase, String) | Sends a single logout message to a service provider (ie. SP-initiated SLO).
SendSSO(HttpResponse, Status) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponse, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, Status) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, Status, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponse, String, SAMLAttribute) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, IDictionaryString, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, Status, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, String, SAMLAttribute) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, IDictionaryString, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponse, String, SAMLAttribute, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, IDictionaryString, String, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, String, SAMLAttribute, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, IDictionaryString, String, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.GetPartnerPendingResponse Method

SAMLIdentityProviderGetPartnerPendingResponse Method

Gets the name of the partner service provider to which a single sign-on or logout response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetPartnerPendingResponse()
Public Shared Function GetPartnerPendingResponse As String
public:
static String^ GetPartnerPendingResponse()
static member GetPartnerPendingResponse : unit -> string

Return Value

Type: String
The name of the partner service provider or null if none.
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSLO Method

SAMLIdentityProviderInitiateSLO Method

Overload List
Name | Description
InitiateSLO(HttpResponse, String, String) | Initiates single logout from the identity provider to the service providers (ie. IdP-initiated SLO). A logout request is sent to the service providers that are signed in.
InitiateSLO(HttpResponseBase, String, String) | Initiates single logout from the identity provider to the service providers (ie. IdP-initiated SLO). A logout request is sent to the service providers that are signed in.
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSLO Method (HttpResponse, String, String)

SAMLIdentityProviderInitiateSLO Method (HttpResponse, String, String)

Initiates single logout from the identity provider to the service providers (ie. IdP-initiated SLO).

A logout request is sent to the service providers that are signed in.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSLO(
    HttpResponse httpResponse,
    string logoutReason,
    string relayState
)
Public Shared Sub InitiateSLO (
    httpResponse As HttpResponse,
    logoutReason As String,
    relayState As String
)
public:
static void InitiateSLO(
    HttpResponse^ httpResponse,
    String^ logoutReason,
    String^ relayState
)
static member InitiateSLO :
        httpResponse : HttpResponse *
        logoutReason : string *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
logoutReason
Type: SystemString
The logout reason or null if none.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single logout fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSLO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSLO Method (HttpResponseBase, String, String)

SAMLIdentityProviderInitiateSLO Method (HttpResponseBase, String, String)

Initiates single logout from the identity provider to the service providers (ie. IdP-initiated SLO).

A logout request is sent to the service providers that are signed in.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSLO(
    HttpResponseBase httpResponse,
    string logoutReason,
    string relayState
)
Public Shared Sub InitiateSLO (
    httpResponse As HttpResponseBase,
    logoutReason As String,
    relayState As String
)
public:
static void InitiateSLO(
    HttpResponseBase^ httpResponse,
    String^ logoutReason,
    String^ relayState
)
static member InitiateSLO :
        httpResponse : HttpResponseBase *
        logoutReason : string *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
logoutReason
Type: SystemString
The logout reason or null if none.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single logout fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSLO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method

SAMLIdentityProviderInitiateSSO Method

Overload List
Name | Description
InitiateSSO(HttpResponse, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, SAMLAttribute, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, IDictionaryString, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, SAMLAttribute, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, IDictionaryString, String, String) | Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, SAMLAttribute, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, IDictionaryString, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, SAMLAttribute, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, IDictionaryString, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, SAMLAttribute, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponse, String, IDictionaryString, String, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, SAMLAttribute, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
InitiateSSO(HttpResponseBase, String, IDictionaryString, String, String, String, String) | Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO). A SAML response containing a SAML assertion is sent to the service provider.
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponse, String, String)

SAMLIdentityProviderInitiateSSO Method (HttpResponse, String, String)

Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse,
    string userName,
    string relayState
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse,
    userName As String,
    relayState As String
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    String^ relayState
)
static member InitiateSSO :
        httpResponse : HttpResponse *
        userName : string *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponseBase, String, String)

SAMLIdentityProviderInitiateSSO Method (HttpResponseBase, String, String)

Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse,
    string userName,
    string relayState
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    relayState As String
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    String^ relayState
)
static member InitiateSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponse, String, SAMLAttribute[], String)

SAMLIdentityProviderInitiateSSO Method (HttpResponse, String, SAMLAttribute, String)

Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse,
    string userName,
    SAMLAttribute[] attributes,
    string relayState
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse,
    userName As String,
    attributes As SAMLAttribute(),
    relayState As String
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    array<SAMLAttribute^>^ attributes,
    String^ relayState
)
static member InitiateSSO :
        httpResponse : HttpResponse *
        userName : string *
        attributes : SAMLAttribute[] *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponse, String, IDictionary(String, String), String)

SAMLIdentityProviderInitiateSSO Method (HttpResponse, String, IDictionaryString, String, String)

Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse,
    string userName,
    IDictionary<string, string> attributes,
    string relayState
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse,
    userName As String,
    attributes As IDictionary(Of String, String),
    relayState As String
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    IDictionary<String^, String^>^ attributes,
    String^ relayState
)
static member InitiateSSO :
        httpResponse : HttpResponse *
        userName : string *
        attributes : IDictionary<string, string> *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponseBase, String, SAMLAttribute[], String)

SAMLIdentityProviderInitiateSSO Method (HttpResponseBase, String, SAMLAttribute, String)

Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse,
    string userName,
    SAMLAttribute[] attributes,
    string relayState
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    attributes As SAMLAttribute(),
    relayState As String
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    array<SAMLAttribute^>^ attributes,
    String^ relayState
)
static member InitiateSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        attributes : SAMLAttribute[] *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponseBase, String, IDictionary(String, String), String)

SAMLIdentityProviderInitiateSSO Method (HttpResponseBase, String, IDictionaryString, String, String)

Initiates single sign-on from the identity provider to the service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse,
    string userName,
    IDictionary<string, string> attributes,
    string relayState
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    attributes As IDictionary(Of String, String),
    relayState As String
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    IDictionary<String^, String^>^ attributes,
    String^ relayState
)
static member InitiateSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        attributes : IDictionary<string, string> *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponse, String, SAMLAttribute[], String, String)

SAMLIdentityProviderInitiateSSO Method (HttpResponse, String, SAMLAttribute, String, String)

Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse,
    string userName,
    SAMLAttribute[] attributes,
    string relayState,
    string partnerSP
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse,
    userName As String,
    attributes As SAMLAttribute(),
    relayState As String,
    partnerSP As String
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    array<SAMLAttribute^>^ attributes,
    String^ relayState,
    String^ partnerSP
)
static member InitiateSSO :
        httpResponse : HttpResponse *
        userName : string *
        attributes : SAMLAttribute[] *
        relayState : string *
        partnerSP : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
partnerSP
Type: SystemString
The partner service provider name or null.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponse, String, IDictionary(String, String), String, String)

SAMLIdentityProviderInitiateSSO Method (HttpResponse, String, IDictionaryString, String, String, String)

Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse,
    string userName,
    IDictionary<string, string> attributes,
    string relayState,
    string partnerSP
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse,
    userName As String,
    attributes As IDictionary(Of String, String),
    relayState As String,
    partnerSP As String
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    IDictionary<String^, String^>^ attributes,
    String^ relayState,
    String^ partnerSP
)
static member InitiateSSO :
        httpResponse : HttpResponse *
        userName : string *
        attributes : IDictionary<string, string> *
        relayState : string *
        partnerSP : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
partnerSP
Type: SystemString
The partner service provider name or null.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponseBase, String, SAMLAttribute[], String, String)

SAMLIdentityProviderInitiateSSO Method (HttpResponseBase, String, SAMLAttribute, String, String)

Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse,
    string userName,
    SAMLAttribute[] attributes,
    string relayState,
    string partnerSP
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    attributes As SAMLAttribute(),
    relayState As String,
    partnerSP As String
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    array<SAMLAttribute^>^ attributes,
    String^ relayState,
    String^ partnerSP
)
static member InitiateSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        attributes : SAMLAttribute[] *
        relayState : string *
        partnerSP : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
partnerSP
Type: SystemString
The partner service provider name or null.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponseBase, String, IDictionary(String, String), String, String)

SAMLIdentityProviderInitiateSSO Method (HttpResponseBase, String, IDictionaryString, String, String, String)

Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse,
    string userName,
    IDictionary<string, string> attributes,
    string relayState,
    string partnerSP
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    attributes As IDictionary(Of String, String),
    relayState As String,
    partnerSP As String
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    IDictionary<String^, String^>^ attributes,
    String^ relayState,
    String^ partnerSP
)
static member InitiateSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        attributes : IDictionary<string, string> *
        relayState : string *
        partnerSP : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
partnerSP
Type: SystemString
The partner service provider name or null.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponse, String, SAMLAttribute[], String, String, String)

SAMLIdentityProviderInitiateSSO Method (HttpResponse, String, SAMLAttribute, String, String, String)

Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse,
    string userName,
    SAMLAttribute[] attributes,
    string relayState,
    string partnerSP,
    string assertionConsumerServiceUrl
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse,
    userName As String,
    attributes As SAMLAttribute(),
    relayState As String,
    partnerSP As String,
    assertionConsumerServiceUrl As String
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    array<SAMLAttribute^>^ attributes,
    String^ relayState,
    String^ partnerSP,
    String^ assertionConsumerServiceUrl
)
static member InitiateSSO :
        httpResponse : HttpResponse *
        userName : string *
        attributes : SAMLAttribute[] *
        relayState : string *
        partnerSP : string *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
partnerSP
Type: SystemString
The partner service provider name or null.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponse, String, IDictionary(String, String), String, String, String)

SAMLIdentityProviderInitiateSSO Method (HttpResponse, String, IDictionaryString, String, String, String, String)

Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse,
    string userName,
    IDictionary<string, string> attributes,
    string relayState,
    string partnerSP,
    string assertionConsumerServiceUrl
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse,
    userName As String,
    attributes As IDictionary(Of String, String),
    relayState As String,
    partnerSP As String,
    assertionConsumerServiceUrl As String
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    IDictionary<String^, String^>^ attributes,
    String^ relayState,
    String^ partnerSP,
    String^ assertionConsumerServiceUrl
)
static member InitiateSSO :
        httpResponse : HttpResponse *
        userName : string *
        attributes : IDictionary<string, string> *
        relayState : string *
        partnerSP : string *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
partnerSP
Type: SystemString
The partner service provider name or null.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponseBase, String, SAMLAttribute[], String, String, String)

SAMLIdentityProviderInitiateSSO Method (HttpResponseBase, String, SAMLAttribute, String, String, String)

Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse,
    string userName,
    SAMLAttribute[] attributes,
    string relayState,
    string partnerSP,
    string assertionConsumerServiceUrl
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    attributes As SAMLAttribute(),
    relayState As String,
    partnerSP As String,
    assertionConsumerServiceUrl As String
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    array<SAMLAttribute^>^ attributes,
    String^ relayState,
    String^ partnerSP,
    String^ assertionConsumerServiceUrl
)
static member InitiateSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        attributes : SAMLAttribute[] *
        relayState : string *
        partnerSP : string *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
partnerSP
Type: SystemString
The partner service provider name or null.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.InitiateSSO Method (HttpResponseBase, String, IDictionary(String, String), String, String, String)

SAMLIdentityProviderInitiateSSO Method (HttpResponseBase, String, IDictionaryString, String, String, String, String)

Initiates single sign-on from the identity provider to the specified service provider (ie. IdP-initiated SSO).

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse,
    string userName,
    IDictionary<string, string> attributes,
    string relayState,
    string partnerSP,
    string assertionConsumerServiceUrl
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    attributes As IDictionary(Of String, String),
    relayState As String,
    partnerSP As String,
    assertionConsumerServiceUrl As String
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    IDictionary<String^, String^>^ attributes,
    String^ relayState,
    String^ partnerSP,
    String^ assertionConsumerServiceUrl
)
static member InitiateSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        attributes : IDictionary<string, string> *
        relayState : string *
        partnerSP : string *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes to include in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state (eg target URL) or null if none.
partnerSP
Type: SystemString
The partner service provider name or null.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsReceiveSLOPending Method

SAMLIdentityProviderIsReceiveSLOPending Method

Overload List
Name | Description
IsReceiveSLOPending | Indicates whether a single logout response from a service provider is pending. Single logout is pending if a logout request has been sent to a service provider and a logout response is pending.
IsReceiveSLOPending(String) | Indicates whether a single logout response from a service provider is pending. Single logout is pending if a logout request has been sent to a service provider and a logout response is pending.
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsReceiveSLOPending Method

SAMLIdentityProviderIsReceiveSLOPending Method

Indicates whether a single logout response from a service provider is pending.

Single logout is pending if a logout request has been sent to a service provider and a logout response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsReceiveSLOPending()
Public Shared Function IsReceiveSLOPending As Boolean
public:
static bool IsReceiveSLOPending()
static member IsReceiveSLOPending : unit -> bool

Return Value

Type: Boolean
true if single logout is pending; otherwise false.
See Also

Reference

SAMLIdentityProvider Class
IsReceiveSLOPending Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsReceiveSLOPending Method (String)

SAMLIdentityProviderIsReceiveSLOPending Method (String)

Indicates whether a single logout response from a service provider is pending.

Single logout is pending if a logout request has been sent to a service provider and a logout response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsReceiveSLOPending(
    string partnerSP
)
Public Shared Function IsReceiveSLOPending (
    partnerSP As String
) As Boolean
public:
static bool IsReceiveSLOPending(
    String^ partnerSP
)
static member IsReceiveSLOPending :
        partnerSP : string -> bool

Parameters

partnerSP
Type: SystemString
The partner service provider name.

Return Value

Type: Boolean
true if single logout is pending; otherwise false.
See Also

Reference

SAMLIdentityProvider Class
IsReceiveSLOPending Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsSendSLOPending Method

SAMLIdentityProviderIsSendSLOPending Method

Overload List
Name | Description
IsSendSLOPending | Indicates whether a single logout response to a service provider is pending. Single logout is pending if a logout request has been received from a service provider and a logout response is pending.
IsSendSLOPending(String) | Indicates whether a single logout response to a service provider is pending. Single logout is pending if a logout request has been received from a service provider and a logout response is pending.
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsSendSLOPending Method

SAMLIdentityProviderIsSendSLOPending Method

Indicates whether a single logout response to a service provider is pending.

Single logout is pending if a logout request has been received from a service provider and a logout response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSendSLOPending()
Public Shared Function IsSendSLOPending As Boolean
public:
static bool IsSendSLOPending()
static member IsSendSLOPending : unit -> bool

Return Value

Type: Boolean
true if single logout is pending; otherwise false.
See Also

Reference

SAMLIdentityProvider Class
IsSendSLOPending Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsSendSLOPending Method (String)

SAMLIdentityProviderIsSendSLOPending Method (String)

Indicates whether a single logout response to a service provider is pending.

Single logout is pending if a logout request has been received from a service provider and a logout response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSendSLOPending(
    string partnerSP
)
Public Shared Function IsSendSLOPending (
    partnerSP As String
) As Boolean
public:
static bool IsSendSLOPending(
    String^ partnerSP
)
static member IsSendSLOPending :
        partnerSP : string -> bool

Parameters

partnerSP
Type: SystemString
The partner service provider name.

Return Value

Type: Boolean
true if single logout is pending; otherwise false.
See Also

Reference

SAMLIdentityProvider Class
IsSendSLOPending Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsSendSSOPending Method

SAMLIdentityProviderIsSendSSOPending Method

Overload List
Name | Description
IsSendSSOPending | Indicates whether single sign-on to a service provider is pending. Single sign-on is pending if an authn request has been received from a service provider and a SAML response is pending.
IsSendSSOPending(String) | Indicates whether single sign-on to a service provider is pending. Single sign-on is pending if an authn request has been received from the service provider and a SAML response is pending.
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsSendSSOPending Method

SAMLIdentityProviderIsSendSSOPending Method

Indicates whether single sign-on to a service provider is pending.

Single sign-on is pending if an authn request has been received from a service provider and a SAML response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSendSSOPending()
Public Shared Function IsSendSSOPending As Boolean
public:
static bool IsSendSSOPending()
static member IsSendSSOPending : unit -> bool

Return Value

Type: Boolean
true if single sign-on is pending; otherwise false.
See Also

Reference

SAMLIdentityProvider Class
IsSendSSOPending Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsSendSSOPending Method (String)

SAMLIdentityProviderIsSendSSOPending Method (String)

Indicates whether single sign-on to a service provider is pending.

Single sign-on is pending if an authn request has been received from the service provider and a SAML response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSendSSOPending(
    string partnerSP
)
Public Shared Function IsSendSSOPending (
    partnerSP As String
) As Boolean
public:
static bool IsSendSSOPending(
    String^ partnerSP
)
static member IsSendSSOPending :
        partnerSP : string -> bool

Parameters

partnerSP
Type: SystemString
The partner service provider name.

Return Value

Type: Boolean
true if single sign-on is pending; otherwise false.
See Also

Reference

SAMLIdentityProvider Class
IsSendSSOPending Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsSSO Method

SAMLIdentityProviderIsSSO Method

Overload List
Name | Description
IsSSO | Indicates whether the identity provider is currently single signed-on to a service provider.
IsSSO(String) | Indicates whether the identity provider is currently single signed-on to a service provider.
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsSSO Method

SAMLIdentityProviderIsSSO Method

Indicates whether the identity provider is currently single signed-on to a service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSSO()
Public Shared Function IsSSO As Boolean
public:
static bool IsSSO()
static member IsSSO : unit -> bool

Return Value

Type: Boolean
true if currently single signed-on; otherwise false.
See Also

Reference

SAMLIdentityProvider Class
IsSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.IsSSO Method (String)

SAMLIdentityProviderIsSSO Method (String)

Indicates whether the identity provider is currently single signed-on to a service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSSO(
    string partnerSP
)
Public Shared Function IsSSO (
    partnerSP As String
) As Boolean
public:
static bool IsSSO(
    String^ partnerSP
)
static member IsSSO :
        partnerSP : string -> bool

Parameters

partnerSP
Type: SystemString
The partner service provider name.

Return Value

Type: Boolean
true if currently single signed-on; otherwise false.
See Also

Reference

SAMLIdentityProvider Class
IsSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.ReceiveSLO Method

SAMLIdentityProviderReceiveSLO Method

Overload List
Name | Description
ReceiveSLO(HttpRequest, HttpResponse, Boolean, Boolean, String, String, String) | Receives a single logout request (ie. SP-initiated SLO) or single logout response (ie. IdP-initiated SLO) from a service provider.
ReceiveSLO(HttpRequestBase, HttpResponseBase, Boolean, Boolean, String, String, String) | Receives a single logout request (ie. SP-initiated SLO) or single logout response (ie. IdP-initiated SLO) from a service provider.
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.ReceiveSLO Method (HttpRequest, HttpResponse, Boolean, Boolean, String, String, String)

SAMLIdentityProviderReceiveSLO Method (HttpRequest, HttpResponse, Boolean, Boolean, String, String, String)

Receives a single logout request (ie. SP-initiated SLO) or single logout response (ie. IdP-initiated SLO) from a service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSLO(
    HttpRequest httpRequest,
    HttpResponse httpResponse,
    out bool isRequest,
    out bool hasCompleted,
    out string logoutReason,
    out string partnerSP,
    out string relayState
)
Public Shared Sub ReceiveSLO (
    httpRequest As HttpRequest,
    httpResponse As HttpResponse,
    <OutAttribute> ByRef isRequest As Boolean,
    <OutAttribute> ByRef hasCompleted As Boolean,
    <OutAttribute> ByRef logoutReason As String,
    <OutAttribute> ByRef partnerSP As String,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveSLO(
    HttpRequest^ httpRequest,
    HttpResponse^ httpResponse,
    [OutAttribute] bool% isRequest,
    [OutAttribute] bool% hasCompleted,
    [OutAttribute] String^% logoutReason,
    [OutAttribute] String^% partnerSP,
    [OutAttribute] String^% relayState
)
static member ReceiveSLO :
        httpRequest : HttpRequest *
        httpResponse : HttpResponse *
        isRequest : bool byref *
        hasCompleted : bool byref *
        logoutReason : string byref *
        partnerSP : string byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request.
httpResponse
Type: System.WebHttpResponse
The HTTP response.
isRequest
Type: SystemBoolean
true if a logout request has been received; otherwise false if a logout response has been received.
hasCompleted
Type: SystemBoolean
true if IdP-initiated SLO has completed; otherwise false.
logoutReason
Type: SystemString
The reason associated with the logout request or null if none.
partnerSP
Type: SystemString
The partner service provider name.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single logout fails.
See Also

Reference

SAMLIdentityProvider Class
ReceiveSLO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.ReceiveSLO Method (HttpRequestBase, HttpResponseBase, Boolean, Boolean, String, String, String)

SAMLIdentityProviderReceiveSLO Method (HttpRequestBase, HttpResponseBase, Boolean, Boolean, String, String, String)

Receives a single logout request (ie. SP-initiated SLO) or single logout response (ie. IdP-initiated SLO) from a service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSLO(
    HttpRequestBase httpRequest,
    HttpResponseBase httpResponse,
    out bool isRequest,
    out bool hasCompleted,
    out string logoutReason,
    out string partnerSP,
    out string relayState
)
Public Shared Sub ReceiveSLO (
    httpRequest As HttpRequestBase,
    httpResponse As HttpResponseBase,
    <OutAttribute> ByRef isRequest As Boolean,
    <OutAttribute> ByRef hasCompleted As Boolean,
    <OutAttribute> ByRef logoutReason As String,
    <OutAttribute> ByRef partnerSP As String,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveSLO(
    HttpRequestBase^ httpRequest,
    HttpResponseBase^ httpResponse,
    [OutAttribute] bool% isRequest,
    [OutAttribute] bool% hasCompleted,
    [OutAttribute] String^% logoutReason,
    [OutAttribute] String^% partnerSP,
    [OutAttribute] String^% relayState
)
static member ReceiveSLO :
        httpRequest : HttpRequestBase *
        httpResponse : HttpResponseBase *
        isRequest : bool byref *
        hasCompleted : bool byref *
        logoutReason : string byref *
        partnerSP : string byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request.
httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
isRequest
Type: SystemBoolean
true if a logout request has been received; otherwise false if a logout response has been received.
hasCompleted
Type: SystemBoolean
true if IdP-initiated SLO has completed; otherwise false.
logoutReason
Type: SystemString
The reason associated with the logout request or null if none.
partnerSP
Type: SystemString
The partner service provider name.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single logout fails.
See Also

Reference

SAMLIdentityProvider Class
ReceiveSLO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.ReceiveSSO Method

SAMLIdentityProviderReceiveSSO Method

Overload List
Name | Description
ReceiveSSO(HttpRequest, String) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
ReceiveSSO(HttpRequestBase, String) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
ReceiveSSO(HttpRequest, String, SSOOptions) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
ReceiveSSO(HttpRequestBase, String, SSOOptions) | Receives a single sign-on request from a service provider (ie. SP-initiated SSO). An authn request is received from the service provider.
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.ReceiveSSO Method (HttpRequest, String)

SAMLIdentityProviderReceiveSSO Method (HttpRequest, String)

Receives a single sign-on request from a service provider (ie. SP-initiated SSO).

An authn request is received from the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSSO(
    HttpRequest httpRequest,
    out string partnerSP
)
Public Shared Sub ReceiveSSO (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef partnerSP As String
)
public:
static void ReceiveSSO(
    HttpRequest^ httpRequest,
    [OutAttribute] String^% partnerSP
)
static member ReceiveSSO :
        httpRequest : HttpRequest *
        partnerSP : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request.
partnerSP
Type: SystemString
The partner service provider name.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
ReceiveSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.ReceiveSSO Method (HttpRequestBase, String)

SAMLIdentityProviderReceiveSSO Method (HttpRequestBase, String)

Receives a single sign-on request from a service provider (ie. SP-initiated SSO).

An authn request is received from the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSSO(
    HttpRequestBase httpRequest,
    out string partnerSP
)
Public Shared Sub ReceiveSSO (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef partnerSP As String
)
public:
static void ReceiveSSO(
    HttpRequestBase^ httpRequest,
    [OutAttribute] String^% partnerSP
)
static member ReceiveSSO :
        httpRequest : HttpRequestBase *
        partnerSP : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request.
partnerSP
Type: SystemString
The partner service provider name.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
ReceiveSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.ReceiveSSO Method (HttpRequest, String, SSOOptions)

SAMLIdentityProviderReceiveSSO Method (HttpRequest, String, SSOOptions)

Receives a single sign-on request from a service provider (ie. SP-initiated SSO).

An authn request is received from the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSSO(
    HttpRequest httpRequest,
    out string partnerSP,
    out SSOOptions ssoOptions
)
Public Shared Sub ReceiveSSO (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef partnerSP As String,
    <OutAttribute> ByRef ssoOptions As SSOOptions
)
public:
static void ReceiveSSO(
    HttpRequest^ httpRequest,
    [OutAttribute] String^% partnerSP,
    [OutAttribute] SSOOptions^% ssoOptions
)
static member ReceiveSSO :
        httpRequest : HttpRequest *
        partnerSP : string byref *
        ssoOptions : SSOOptions byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request.
partnerSP
Type: SystemString
The partner service provider name.
ssoOptions
Type: ComponentSpace.SAML2SSOOptions
The SSO options.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
ReceiveSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.ReceiveSSO Method (HttpRequestBase, String, SSOOptions)

SAMLIdentityProviderReceiveSSO Method (HttpRequestBase, String, SSOOptions)

Receives a single sign-on request from a service provider (ie. SP-initiated SSO).

An authn request is received from the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSSO(
    HttpRequestBase httpRequest,
    out string partnerSP,
    out SSOOptions ssoOptions
)
Public Shared Sub ReceiveSSO (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef partnerSP As String,
    <OutAttribute> ByRef ssoOptions As SSOOptions
)
public:
static void ReceiveSSO(
    HttpRequestBase^ httpRequest,
    [OutAttribute] String^% partnerSP,
    [OutAttribute] SSOOptions^% ssoOptions
)
static member ReceiveSSO :
        httpRequest : HttpRequestBase *
        partnerSP : string byref *
        ssoOptions : SSOOptions byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request.
partnerSP
Type: SystemString
The partner service provider name.
ssoOptions
Type: ComponentSpace.SAML2SSOOptions
The SSO options.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
ReceiveSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSLO Method

SAMLIdentityProviderSendSLO Method

Overload List
Name | Description
SendSLO(HttpResponse, String) | Sends a single logout message to a service provider (ie. SP-initiated SLO).
SendSLO(HttpResponseBase, String) | Sends a single logout message to a service provider (ie. SP-initiated SLO).
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSLO Method (HttpResponse, String)

SAMLIdentityProviderSendSLO Method (HttpResponse, String)

Sends a single logout message to a service provider (ie. SP-initiated SLO).

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSLO(
    HttpResponse httpResponse,
    string errorMessage
)
Public Shared Sub SendSLO (
    httpResponse As HttpResponse,
    errorMessage As String
)
public:
static void SendSLO(
    HttpResponse^ httpResponse,
    String^ errorMessage
)
static member SendSLO :
        httpResponse : HttpResponse *
        errorMessage : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
errorMessage
Type: SystemString
The error message or null if logout was successful.
See Also

Reference

SAMLIdentityProvider Class
SendSLO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSLO Method (HttpResponseBase, String)

SAMLIdentityProviderSendSLO Method (HttpResponseBase, String)

Sends a single logout message to a service provider (ie. SP-initiated SLO).

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSLO(
    HttpResponseBase httpResponse,
    string errorMessage
)
Public Shared Sub SendSLO (
    httpResponse As HttpResponseBase,
    errorMessage As String
)
public:
static void SendSLO(
    HttpResponseBase^ httpResponse,
    String^ errorMessage
)
static member SendSLO :
        httpResponse : HttpResponseBase *
        errorMessage : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
errorMessage
Type: SystemString
The error message or null if logout was successful.
See Also

Reference

SAMLIdentityProvider Class
SendSLO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method

SAMLIdentityProviderSendSSO Method

Overload List
Name | Description
SendSSO(HttpResponse, Status) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponse, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, Status) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, Status, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponse, String, SAMLAttribute) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, IDictionaryString, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, Status, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, String, SAMLAttribute) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, IDictionaryString, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponse, String, SAMLAttribute, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, IDictionaryString, String, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponse, String, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
SendSSO(HttpResponseBase, String, SAMLAttribute, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, IDictionaryString, String, String) | Sends a single sign-on response as part of SP-initiated SSO. A SAML response containing a SAML assertion is sent to the service provider.
SendSSO(HttpResponseBase, String, String, String) | Sends a single sign-on error response as part of SP-initiated SSO. A SAML error response is sent to the service provider.
Top
See Also

Reference

SAMLIdentityProvider Class
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponse, Status)

SAMLIdentityProviderSendSSO Method (HttpResponse, Status)

Sends a single sign-on error response as part of SP-initiated SSO.

A SAML error response is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponse httpResponse,
    Status status
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponse,
    status As Status
)
public:
static void SendSSO(
    HttpResponse^ httpResponse,
    Status^ status
)
static member SendSSO :
        httpResponse : HttpResponse *
        status : Status -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response
status
Type: ComponentSpace.SAML2.ProtocolsStatus
The error status.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponse, String)

SAMLIdentityProviderSendSSO Method (HttpResponse, String)

Sends a single sign-on response as part of SP-initiated SSO.

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponse httpResponse,
    string userName
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponse,
    userName As String
)
public:
static void SendSSO(
    HttpResponse^ httpResponse,
    String^ userName
)
static member SendSSO :
        httpResponse : HttpResponse *
        userName : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response
userName
Type: SystemString
The user name to include in the SAML assertion.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponseBase, Status)

SAMLIdentityProviderSendSSO Method (HttpResponseBase, Status)

Sends a single sign-on error response as part of SP-initiated SSO.

A SAML error response is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponseBase httpResponse,
    Status status
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponseBase,
    status As Status
)
public:
static void SendSSO(
    HttpResponseBase^ httpResponse,
    Status^ status
)
static member SendSSO :
        httpResponse : HttpResponseBase *
        status : Status -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response
status
Type: ComponentSpace.SAML2.ProtocolsStatus
The error status.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponseBase, String)

SAMLIdentityProviderSendSSO Method (HttpResponseBase, String)

Sends a single sign-on response as part of SP-initiated SSO.

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponseBase httpResponse,
    string userName
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponseBase,
    userName As String
)
public:
static void SendSSO(
    HttpResponseBase^ httpResponse,
    String^ userName
)
static member SendSSO :
        httpResponse : HttpResponseBase *
        userName : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response
userName
Type: SystemString
The user name to include in the SAML assertion.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponse, Status, String)

SAMLIdentityProviderSendSSO Method (HttpResponse, Status, String)

Sends a single sign-on error response as part of SP-initiated SSO.

A SAML error response is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponse httpResponse,
    Status status,
    string assertionConsumerServiceUrl
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponse,
    status As Status,
    assertionConsumerServiceUrl As String
)
public:
static void SendSSO(
    HttpResponse^ httpResponse,
    Status^ status,
    String^ assertionConsumerServiceUrl
)
static member SendSSO :
        httpResponse : HttpResponse *
        status : Status *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response
status
Type: ComponentSpace.SAML2.ProtocolsStatus
The error status.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponse, String, SAMLAttribute[])

SAMLIdentityProviderSendSSO Method (HttpResponse, String, SAMLAttribute)

Sends a single sign-on response as part of SP-initiated SSO.

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponse httpResponse,
    string userName,
    SAMLAttribute[] attributes
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponse,
    userName As String,
    attributes As SAMLAttribute()
)
public:
static void SendSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    array<SAMLAttribute^>^ attributes
)
static member SendSSO :
        httpResponse : HttpResponse *
        userName : string *
        attributes : SAMLAttribute[] -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes to include in the SAML assertion or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponse, String, IDictionary(String, String))

SAMLIdentityProviderSendSSO Method (HttpResponse, String, IDictionaryString, String)

Sends a single sign-on response as part of SP-initiated SSO.

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponse httpResponse,
    string userName,
    IDictionary<string, string> attributes
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponse,
    userName As String,
    attributes As IDictionary(Of String, String)
)
public:
static void SendSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    IDictionary<String^, String^>^ attributes
)
static member SendSSO :
        httpResponse : HttpResponse *
        userName : string *
        attributes : IDictionary<string, string> -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes to include in the SAML assertion or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponse, String, String)

SAMLIdentityProviderSendSSO Method (HttpResponse, String, String)

Sends a single sign-on error response as part of SP-initiated SSO.

A SAML error response is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponse httpResponse,
    string statusCode,
    string statusMessage
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponse,
    statusCode As String,
    statusMessage As String
)
public:
static void SendSSO(
    HttpResponse^ httpResponse,
    String^ statusCode,
    String^ statusMessage
)
static member SendSSO :
        httpResponse : HttpResponse *
        statusCode : string *
        statusMessage : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response
statusCode
Type: SystemString
The error status code.
statusMessage
Type: SystemString
The status message or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponseBase, Status, String)

SAMLIdentityProviderSendSSO Method (HttpResponseBase, Status, String)

Sends a single sign-on error response as part of SP-initiated SSO.

A SAML error response is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponseBase httpResponse,
    Status status,
    string assertionConsumerServiceUrl
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponseBase,
    status As Status,
    assertionConsumerServiceUrl As String
)
public:
static void SendSSO(
    HttpResponseBase^ httpResponse,
    Status^ status,
    String^ assertionConsumerServiceUrl
)
static member SendSSO :
        httpResponse : HttpResponseBase *
        status : Status *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response
status
Type: ComponentSpace.SAML2.ProtocolsStatus
The error status.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponseBase, String, SAMLAttribute[])

SAMLIdentityProviderSendSSO Method (HttpResponseBase, String, SAMLAttribute)

Sends a single sign-on response as part of SP-initiated SSO.

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponseBase httpResponse,
    string userName,
    SAMLAttribute[] attributes
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    attributes As SAMLAttribute()
)
public:
static void SendSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    array<SAMLAttribute^>^ attributes
)
static member SendSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        attributes : SAMLAttribute[] -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes to include in the SAML assertion or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponseBase, String, IDictionary(String, String))

SAMLIdentityProviderSendSSO Method (HttpResponseBase, String, IDictionaryString, String)

Sends a single sign-on response as part of SP-initiated SSO.

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponseBase httpResponse,
    string userName,
    IDictionary<string, string> attributes
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    attributes As IDictionary(Of String, String)
)
public:
static void SendSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    IDictionary<String^, String^>^ attributes
)
static member SendSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        attributes : IDictionary<string, string> -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes to include in the SAML assertion or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponseBase, String, String)

SAMLIdentityProviderSendSSO Method (HttpResponseBase, String, String)

Sends a single sign-on error response as part of SP-initiated SSO.

A SAML error response is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponseBase httpResponse,
    string statusCode,
    string statusMessage
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponseBase,
    statusCode As String,
    statusMessage As String
)
public:
static void SendSSO(
    HttpResponseBase^ httpResponse,
    String^ statusCode,
    String^ statusMessage
)
static member SendSSO :
        httpResponse : HttpResponseBase *
        statusCode : string *
        statusMessage : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response
statusCode
Type: SystemString
The error status code.
statusMessage
Type: SystemString
The status message or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponse, String, SAMLAttribute[], String)

SAMLIdentityProviderSendSSO Method (HttpResponse, String, SAMLAttribute, String)

Sends a single sign-on response as part of SP-initiated SSO.

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponse httpResponse,
    string userName,
    SAMLAttribute[] attributes,
    string assertionConsumerServiceUrl
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponse,
    userName As String,
    attributes As SAMLAttribute(),
    assertionConsumerServiceUrl As String
)
public:
static void SendSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    array<SAMLAttribute^>^ attributes,
    String^ assertionConsumerServiceUrl
)
static member SendSSO :
        httpResponse : HttpResponse *
        userName : string *
        attributes : SAMLAttribute[] *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes to include in the SAML assertion or null if none.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponse, String, IDictionary(String, String), String)

SAMLIdentityProviderSendSSO Method (HttpResponse, String, IDictionaryString, String, String)

Sends a single sign-on response as part of SP-initiated SSO.

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponse httpResponse,
    string userName,
    IDictionary<string, string> attributes,
    string assertionConsumerServiceUrl
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponse,
    userName As String,
    attributes As IDictionary(Of String, String),
    assertionConsumerServiceUrl As String
)
public:
static void SendSSO(
    HttpResponse^ httpResponse,
    String^ userName,
    IDictionary<String^, String^>^ attributes,
    String^ assertionConsumerServiceUrl
)
static member SendSSO :
        httpResponse : HttpResponse *
        userName : string *
        attributes : IDictionary<string, string> *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes to include in the SAML assertion or null if none.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponse, String, String, String)

SAMLIdentityProviderSendSSO Method (HttpResponse, String, String, String)

Sends a single sign-on error response as part of SP-initiated SSO.

A SAML error response is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponse httpResponse,
    string statusCode,
    string statusMessage,
    string assertionConsumerServiceUrl
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponse,
    statusCode As String,
    statusMessage As String,
    assertionConsumerServiceUrl As String
)
public:
static void SendSSO(
    HttpResponse^ httpResponse,
    String^ statusCode,
    String^ statusMessage,
    String^ assertionConsumerServiceUrl
)
static member SendSSO :
        httpResponse : HttpResponse *
        statusCode : string *
        statusMessage : string *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response
statusCode
Type: SystemString
The error status code.
statusMessage
Type: SystemString
The status message or null if none.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponseBase, String, SAMLAttribute[], String)

SAMLIdentityProviderSendSSO Method (HttpResponseBase, String, SAMLAttribute, String)

Sends a single sign-on response as part of SP-initiated SSO.

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponseBase httpResponse,
    string userName,
    SAMLAttribute[] attributes,
    string assertionConsumerServiceUrl
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    attributes As SAMLAttribute(),
    assertionConsumerServiceUrl As String
)
public:
static void SendSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    array<SAMLAttribute^>^ attributes,
    String^ assertionConsumerServiceUrl
)
static member SendSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        attributes : SAMLAttribute[] *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes to include in the SAML assertion or null if none.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponseBase, String, IDictionary(String, String), String)

SAMLIdentityProviderSendSSO Method (HttpResponseBase, String, IDictionaryString, String, String)

Sends a single sign-on response as part of SP-initiated SSO.

A SAML response containing a SAML assertion is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponseBase httpResponse,
    string userName,
    IDictionary<string, string> attributes,
    string assertionConsumerServiceUrl
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponseBase,
    userName As String,
    attributes As IDictionary(Of String, String),
    assertionConsumerServiceUrl As String
)
public:
static void SendSSO(
    HttpResponseBase^ httpResponse,
    String^ userName,
    IDictionary<String^, String^>^ attributes,
    String^ assertionConsumerServiceUrl
)
static member SendSSO :
        httpResponse : HttpResponseBase *
        userName : string *
        attributes : IDictionary<string, string> *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response
userName
Type: SystemString
The user name to include in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes to include in the SAML assertion or null if none.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLIdentityProvider.SendSSO Method (HttpResponseBase, String, String, String)

SAMLIdentityProviderSendSSO Method (HttpResponseBase, String, String, String)

Sends a single sign-on error response as part of SP-initiated SSO.

A SAML error response is sent to the service provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSSO(
    HttpResponseBase httpResponse,
    string statusCode,
    string statusMessage,
    string assertionConsumerServiceUrl
)
Public Shared Sub SendSSO (
    httpResponse As HttpResponseBase,
    statusCode As String,
    statusMessage As String,
    assertionConsumerServiceUrl As String
)
public:
static void SendSSO(
    HttpResponseBase^ httpResponse,
    String^ statusCode,
    String^ statusMessage,
    String^ assertionConsumerServiceUrl
)
static member SendSSO :
        httpResponse : HttpResponseBase *
        statusCode : string *
        statusMessage : string *
        assertionConsumerServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response
statusCode
Type: SystemString
The error status code.
statusMessage
Type: SystemString
The status message or null if none.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLIdentityProvider Class
SendSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider Class

Provides Service Provider (SP) support for web browser single sign-on.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SAMLServiceProvider

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAMLServiceProvider
Public NotInheritable Class SAMLServiceProvider
public ref class SAMLServiceProvider abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAMLServiceProvider =  class end

The SAMLServiceProvider type exposes the following members.

Methods
Name | Description
GetPartnerPendingResponse | Gets the name of the partner identity provider to which a logout response is pending.
InitiateSLO(HttpResponse, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). A logout request is sent to the identity provider.
InitiateSLO(HttpResponseBase, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). A logout request is sent to the identity provider.
InitiateSLO(HttpResponse, String, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). An logout request is sent to the identity provider.
InitiateSLO(HttpResponseBase, String, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). An logout request is sent to the identity provider.
InitiateSSO(HttpResponse) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponse, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponse, String, String, SSOOptions) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase, String, String, SSOOptions) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponse, String, String, SSOOptions, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase, String, String, SSOOptions, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
IsReceiveSLOPending | Indicates whether a single logout response from an identity provider is pending. Single logout is pending if a logout request has been sent to an identity provider and a logout response is pending.
IsReceiveSLOPending(String) | Indicates whether a single logout response from an identity provider is pending. Single logout is pending if a logout request has been sent to an identity provider and a logout response is pending.
IsReceiveSSOPending | Indicates whether single sign-on to an identity provider is pending. Single sign-on is pending if an authn request has been sent to an identity provider and a SAML response is pending.
IsReceiveSSOPending(String) | Indicates whether single sign-on to an identity provider is pending. Single sign-on is pending if an authn request has been sent to an identity provider and a SAML response is pending.
IsSendSLOPending | Indicates whether a single logout response to an identity provider is pending. Single logout is pending if a logout request has been received from an identity provider and a logout response is pending.
IsSendSLOPending(String) | Indicates whether a single logout response to an identity provider is pending. Single logout is pending if a logout request has been received from an identity provider and a logout response is pending.
IsSSO | Indicates whether the service provider is currently single signed-on to an identity provider.
IsSSO(String) | Indicates whether the service provider is currently single signed-on to an identity provider.
ReceiveSLO(HttpRequest, Boolean, String, String, String) | Receives a single logout request (ie. IdP-initiated SLO) or single logout response (ie. SP-initiated SLO) from an identity provider.
ReceiveSLO(HttpRequestBase, Boolean, String, String, String) | Receives a single logout request (ie. IdP-initiated SLO) or single logout response (ie. SP-initiated SLO) from an identity provider.
ReceiveSSO(HttpRequest, Boolean, String, String, SAMLAttribute, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
ReceiveSSO(HttpRequest, Boolean, String, String, IDictionaryString, String, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
ReceiveSSO(HttpRequestBase, Boolean, String, String, SAMLAttribute, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
ReceiveSSO(HttpRequestBase, Boolean, String, String, IDictionaryString, String, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
SendSLO(HttpResponse, String) | Sends a single logout response to the identity provider (ie IdP-initiated SLO).
SendSLO(HttpResponseBase, String) | Sends a single logout response to the identity provider (ie IdP-initiated SLO).
Top
See Also

Reference

ComponentSpace.SAML2 Namespace


SAMLServiceProvider Methods

The SAMLServiceProvider type exposes the following members.

Methods
Name | Description
GetPartnerPendingResponse | Gets the name of the partner identity provider to which a logout response is pending.
InitiateSLO(HttpResponse, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). A logout request is sent to the identity provider.
InitiateSLO(HttpResponseBase, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). A logout request is sent to the identity provider.
InitiateSLO(HttpResponse, String, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). An logout request is sent to the identity provider.
InitiateSLO(HttpResponseBase, String, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). An logout request is sent to the identity provider.
InitiateSSO(HttpResponse) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponse, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponse, String, String, SSOOptions) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase, String, String, SSOOptions) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponse, String, String, SSOOptions, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase, String, String, SSOOptions, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
IsReceiveSLOPending | Indicates whether a single logout response from an identity provider is pending. Single logout is pending if a logout request has been sent to an identity provider and a logout response is pending.
IsReceiveSLOPending(String) | Indicates whether a single logout response from an identity provider is pending. Single logout is pending if a logout request has been sent to an identity provider and a logout response is pending.
IsReceiveSSOPending | Indicates whether single sign-on to an identity provider is pending. Single sign-on is pending if an authn request has been sent to an identity provider and a SAML response is pending.
IsReceiveSSOPending(String) | Indicates whether single sign-on to an identity provider is pending. Single sign-on is pending if an authn request has been sent to an identity provider and a SAML response is pending.
IsSendSLOPending | Indicates whether a single logout response to an identity provider is pending. Single logout is pending if a logout request has been received from an identity provider and a logout response is pending.
IsSendSLOPending(String) | Indicates whether a single logout response to an identity provider is pending. Single logout is pending if a logout request has been received from an identity provider and a logout response is pending.
IsSSO | Indicates whether the service provider is currently single signed-on to an identity provider.
IsSSO(String) | Indicates whether the service provider is currently single signed-on to an identity provider.
ReceiveSLO(HttpRequest, Boolean, String, String, String) | Receives a single logout request (ie. IdP-initiated SLO) or single logout response (ie. SP-initiated SLO) from an identity provider.
ReceiveSLO(HttpRequestBase, Boolean, String, String, String) | Receives a single logout request (ie. IdP-initiated SLO) or single logout response (ie. SP-initiated SLO) from an identity provider.
ReceiveSSO(HttpRequest, Boolean, String, String, SAMLAttribute, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
ReceiveSSO(HttpRequest, Boolean, String, String, IDictionaryString, String, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
ReceiveSSO(HttpRequestBase, Boolean, String, String, SAMLAttribute, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
ReceiveSSO(HttpRequestBase, Boolean, String, String, IDictionaryString, String, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
SendSLO(HttpResponse, String) | Sends a single logout response to the identity provider (ie IdP-initiated SLO).
SendSLO(HttpResponseBase, String) | Sends a single logout response to the identity provider (ie IdP-initiated SLO).
Top
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.GetPartnerPendingResponse Method

SAMLServiceProviderGetPartnerPendingResponse Method

Gets the name of the partner identity provider to which a logout response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetPartnerPendingResponse()
Public Shared Function GetPartnerPendingResponse As String
public:
static String^ GetPartnerPendingResponse()
static member GetPartnerPendingResponse : unit -> string

Return Value

Type: String
The name of the partner identity provider or null if none.
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSLO Method

SAMLServiceProviderInitiateSLO Method

Overload List
Name | Description
InitiateSLO(HttpResponse, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). A logout request is sent to the identity provider.
InitiateSLO(HttpResponseBase, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). A logout request is sent to the identity provider.
InitiateSLO(HttpResponse, String, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). An logout request is sent to the identity provider.
InitiateSLO(HttpResponseBase, String, String, String) | Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO). An logout request is sent to the identity provider.
Top
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSLO Method (HttpResponse, String, String)

SAMLServiceProviderInitiateSLO Method (HttpResponse, String, String)

Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO).

A logout request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSLO(
    HttpResponse httpResponse,
    string logoutReason,
    string relayState
)
Public Shared Sub InitiateSLO (
    httpResponse As HttpResponse,
    logoutReason As String,
    relayState As String
)
public:
static void InitiateSLO(
    HttpResponse^ httpResponse,
    String^ logoutReason,
    String^ relayState
)
static member InitiateSLO :
        httpResponse : HttpResponse *
        logoutReason : string *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
logoutReason
Type: SystemString
The logout reason or null if none.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single logout fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSLO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSLO Method (HttpResponseBase, String, String)

SAMLServiceProviderInitiateSLO Method (HttpResponseBase, String, String)

Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO).

A logout request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSLO(
    HttpResponseBase httpResponse,
    string logoutReason,
    string relayState
)
Public Shared Sub InitiateSLO (
    httpResponse As HttpResponseBase,
    logoutReason As String,
    relayState As String
)
public:
static void InitiateSLO(
    HttpResponseBase^ httpResponse,
    String^ logoutReason,
    String^ relayState
)
static member InitiateSLO :
        httpResponse : HttpResponseBase *
        logoutReason : string *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
logoutReason
Type: SystemString
The logout reason or null if none.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single logout fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSLO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSLO Method (HttpResponse, String, String, String)

SAMLServiceProviderInitiateSLO Method (HttpResponse, String, String, String)

Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO).

An logout request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSLO(
    HttpResponse httpResponse,
    string logoutReason,
    string relayState,
    string partnerIdP
)
Public Shared Sub InitiateSLO (
    httpResponse As HttpResponse,
    logoutReason As String,
    relayState As String,
    partnerIdP As String
)
public:
static void InitiateSLO(
    HttpResponse^ httpResponse,
    String^ logoutReason,
    String^ relayState,
    String^ partnerIdP
)
static member InitiateSLO :
        httpResponse : HttpResponse *
        logoutReason : string *
        relayState : string *
        partnerIdP : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
logoutReason
Type: SystemString
The logout reason or null if none.
relayState
Type: SystemString
The relay state or null if none.
partnerIdP
Type: SystemString
The partner identity provider name or null.
Exceptions
Exception | Condition
SAMLException | Thrown when the single logout fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSLO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSLO Method (HttpResponseBase, String, String, String)

SAMLServiceProviderInitiateSLO Method (HttpResponseBase, String, String, String)

Initiates single logout from the service provider to the identity provider (ie. SP-initiated SLO).

An logout request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSLO(
    HttpResponseBase httpResponse,
    string logoutReason,
    string relayState,
    string partnerIdP
)
Public Shared Sub InitiateSLO (
    httpResponse As HttpResponseBase,
    logoutReason As String,
    relayState As String,
    partnerIdP As String
)
public:
static void InitiateSLO(
    HttpResponseBase^ httpResponse,
    String^ logoutReason,
    String^ relayState,
    String^ partnerIdP
)
static member InitiateSLO :
        httpResponse : HttpResponseBase *
        logoutReason : string *
        relayState : string *
        partnerIdP : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
logoutReason
Type: SystemString
The logout reason or null if none.
relayState
Type: SystemString
The relay state or null if none.
partnerIdP
Type: SystemString
The partner identity provider name or null.
Exceptions
Exception | Condition
SAMLException | Thrown when the single logout fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSLO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSSO Method

SAMLServiceProviderInitiateSSO Method

Overload List
Name | Description
InitiateSSO(HttpResponse) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponse, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponse, String, String, SSOOptions) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase, String, String, SSOOptions) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponse, String, String, SSOOptions, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
InitiateSSO(HttpResponseBase, String, String, SSOOptions, String, String) | Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO). An authn request is sent to the identity provider.
Top
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSSO Method (HttpResponse)

SAMLServiceProviderInitiateSSO Method (HttpResponse)

Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO).

An authn request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse
)
static member InitiateSSO :
        httpResponse : HttpResponse -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSSO Method (HttpResponseBase)

SAMLServiceProviderInitiateSSO Method (HttpResponseBase)

Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO).

An authn request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse
)
static member InitiateSSO :
        httpResponse : HttpResponseBase -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSSO Method (HttpResponse, String, String)

SAMLServiceProviderInitiateSSO Method (HttpResponse, String, String)

Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO).

An authn request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse,
    string relayState,
    string partnerIdP
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse,
    relayState As String,
    partnerIdP As String
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse,
    String^ relayState,
    String^ partnerIdP
)
static member InitiateSSO :
        httpResponse : HttpResponse *
        relayState : string *
        partnerIdP : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
relayState
Type: SystemString
The relay state or null if none.
partnerIdP
Type: SystemString
The partner identity provider name or null.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSSO Method (HttpResponseBase, String, String)

SAMLServiceProviderInitiateSSO Method (HttpResponseBase, String, String)

Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO).

An authn request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse,
    string relayState,
    string partnerIdP
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase,
    relayState As String,
    partnerIdP As String
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse,
    String^ relayState,
    String^ partnerIdP
)
static member InitiateSSO :
        httpResponse : HttpResponseBase *
        relayState : string *
        partnerIdP : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
relayState
Type: SystemString
The relay state or null if none.
partnerIdP
Type: SystemString
The partner identity provider name or null.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSSO Method (HttpResponse, String, String, SSOOptions)

SAMLServiceProviderInitiateSSO Method (HttpResponse, String, String, SSOOptions)

Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO).

An authn request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse,
    string relayState,
    string partnerIdP,
    SSOOptions ssoOptions
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse,
    relayState As String,
    partnerIdP As String,
    ssoOptions As SSOOptions
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse,
    String^ relayState,
    String^ partnerIdP,
    SSOOptions^ ssoOptions
)
static member InitiateSSO :
        httpResponse : HttpResponse *
        relayState : string *
        partnerIdP : string *
        ssoOptions : SSOOptions -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
relayState
Type: SystemString
The relay state or null if none.
partnerIdP
Type: SystemString
The partner identity provider name or null.
ssoOptions
Type: ComponentSpace.SAML2SSOOptions
The SSO options or null.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSSO Method (HttpResponseBase, String, String, SSOOptions)

SAMLServiceProviderInitiateSSO Method (HttpResponseBase, String, String, SSOOptions)

Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO).

An authn request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse,
    string relayState,
    string partnerIdP,
    SSOOptions ssoOptions
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase,
    relayState As String,
    partnerIdP As String,
    ssoOptions As SSOOptions
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse,
    String^ relayState,
    String^ partnerIdP,
    SSOOptions^ ssoOptions
)
static member InitiateSSO :
        httpResponse : HttpResponseBase *
        relayState : string *
        partnerIdP : string *
        ssoOptions : SSOOptions -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
relayState
Type: SystemString
The relay state or null if none.
partnerIdP
Type: SystemString
The partner identity provider name or null.
ssoOptions
Type: ComponentSpace.SAML2SSOOptions
The SSO options or null.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSSO Method (HttpResponse, String, String, SSOOptions, String, String)

SAMLServiceProviderInitiateSSO Method (HttpResponse, String, String, SSOOptions, String, String)

Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO).

An authn request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponse httpResponse,
    string relayState,
    string partnerIdP,
    SSOOptions ssoOptions,
    string assertionConsumerServiceUrl,
    string singleSignOnServiceUrl
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponse,
    relayState As String,
    partnerIdP As String,
    ssoOptions As SSOOptions,
    assertionConsumerServiceUrl As String,
    singleSignOnServiceUrl As String
)
public:
static void InitiateSSO(
    HttpResponse^ httpResponse,
    String^ relayState,
    String^ partnerIdP,
    SSOOptions^ ssoOptions,
    String^ assertionConsumerServiceUrl,
    String^ singleSignOnServiceUrl
)
static member InitiateSSO :
        httpResponse : HttpResponse *
        relayState : string *
        partnerIdP : string *
        ssoOptions : SSOOptions *
        assertionConsumerServiceUrl : string *
        singleSignOnServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
relayState
Type: SystemString
The relay state or null if none.
partnerIdP
Type: SystemString
The partner identity provider name or null.
ssoOptions
Type: ComponentSpace.SAML2SSOOptions
The SSO options or null.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
singleSignOnServiceUrl
Type: SystemString
The single sign-on service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.InitiateSSO Method (HttpResponseBase, String, String, SSOOptions, String, String)

SAMLServiceProviderInitiateSSO Method (HttpResponseBase, String, String, SSOOptions, String, String)

Initiates single sign-on from the service provider to the identity provider (ie. SP-initiated SSO).

An authn request is sent to the identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void InitiateSSO(
    HttpResponseBase httpResponse,
    string relayState,
    string partnerIdP,
    SSOOptions ssoOptions,
    string assertionConsumerServiceUrl,
    string singleSignOnServiceUrl
)
Public Shared Sub InitiateSSO (
    httpResponse As HttpResponseBase,
    relayState As String,
    partnerIdP As String,
    ssoOptions As SSOOptions,
    assertionConsumerServiceUrl As String,
    singleSignOnServiceUrl As String
)
public:
static void InitiateSSO(
    HttpResponseBase^ httpResponse,
    String^ relayState,
    String^ partnerIdP,
    SSOOptions^ ssoOptions,
    String^ assertionConsumerServiceUrl,
    String^ singleSignOnServiceUrl
)
static member InitiateSSO :
        httpResponse : HttpResponseBase *
        relayState : string *
        partnerIdP : string *
        ssoOptions : SSOOptions *
        assertionConsumerServiceUrl : string *
        singleSignOnServiceUrl : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
relayState
Type: SystemString
The relay state or null if none.
partnerIdP
Type: SystemString
The partner identity provider name or null.
ssoOptions
Type: ComponentSpace.SAML2SSOOptions
The SSO options or null.
assertionConsumerServiceUrl
Type: SystemString
The assertion consumer service URL or null if the configured URL is to be used.
singleSignOnServiceUrl
Type: SystemString
The single sign-on service URL or null if the configured URL is to be used.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
InitiateSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsReceiveSLOPending Method

SAMLServiceProviderIsReceiveSLOPending Method

Overload List
Name | Description
IsReceiveSLOPending | Indicates whether a single logout response from an identity provider is pending. Single logout is pending if a logout request has been sent to an identity provider and a logout response is pending.
IsReceiveSLOPending(String) | Indicates whether a single logout response from an identity provider is pending. Single logout is pending if a logout request has been sent to an identity provider and a logout response is pending.
Top
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsReceiveSLOPending Method

SAMLServiceProviderIsReceiveSLOPending Method

Indicates whether a single logout response from an identity provider is pending.

Single logout is pending if a logout request has been sent to an identity provider and a logout response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsReceiveSLOPending()
Public Shared Function IsReceiveSLOPending As Boolean
public:
static bool IsReceiveSLOPending()
static member IsReceiveSLOPending : unit -> bool

Return Value

Type: Boolean
true if single logout is pending; otherwise false.
See Also

Reference

SAMLServiceProvider Class
IsReceiveSLOPending Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsReceiveSLOPending Method (String)

SAMLServiceProviderIsReceiveSLOPending Method (String)

Indicates whether a single logout response from an identity provider is pending.

Single logout is pending if a logout request has been sent to an identity provider and a logout response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsReceiveSLOPending(
    string partnerIdP
)
Public Shared Function IsReceiveSLOPending (
    partnerIdP As String
) As Boolean
public:
static bool IsReceiveSLOPending(
    String^ partnerIdP
)
static member IsReceiveSLOPending :
        partnerIdP : string -> bool

Parameters

partnerIdP
Type: SystemString
The partner identity provider name.

Return Value

Type: Boolean
true if single logout is pending; otherwise false.
See Also

Reference

SAMLServiceProvider Class
IsReceiveSLOPending Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsReceiveSSOPending Method

SAMLServiceProviderIsReceiveSSOPending Method

Overload List
Name | Description
IsReceiveSSOPending | Indicates whether single sign-on to an identity provider is pending. Single sign-on is pending if an authn request has been sent to an identity provider and a SAML response is pending.
IsReceiveSSOPending(String) | Indicates whether single sign-on to an identity provider is pending. Single sign-on is pending if an authn request has been sent to an identity provider and a SAML response is pending.
Top
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsReceiveSSOPending Method

SAMLServiceProviderIsReceiveSSOPending Method

Indicates whether single sign-on to an identity provider is pending.

Single sign-on is pending if an authn request has been sent to an identity provider and a SAML response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsReceiveSSOPending()
Public Shared Function IsReceiveSSOPending As Boolean
public:
static bool IsReceiveSSOPending()
static member IsReceiveSSOPending : unit -> bool

Return Value

Type: Boolean
true if single sign-on is pending; otherwise false.
See Also

Reference

SAMLServiceProvider Class
IsReceiveSSOPending Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsReceiveSSOPending Method (String)

SAMLServiceProviderIsReceiveSSOPending Method (String)

Indicates whether single sign-on to an identity provider is pending.

Single sign-on is pending if an authn request has been sent to an identity provider and a SAML response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsReceiveSSOPending(
    string partnerIdP
)
Public Shared Function IsReceiveSSOPending (
    partnerIdP As String
) As Boolean
public:
static bool IsReceiveSSOPending(
    String^ partnerIdP
)
static member IsReceiveSSOPending :
        partnerIdP : string -> bool

Parameters

partnerIdP
Type: SystemString
The partner identity provider name.

Return Value

Type: Boolean
true if single sign-on is pending; otherwise false.
See Also

Reference

SAMLServiceProvider Class
IsReceiveSSOPending Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsSendSLOPending Method

SAMLServiceProviderIsSendSLOPending Method

Overload List
Name | Description
IsSendSLOPending | Indicates whether a single logout response to an identity provider is pending. Single logout is pending if a logout request has been received from an identity provider and a logout response is pending.
IsSendSLOPending(String) | Indicates whether a single logout response to an identity provider is pending. Single logout is pending if a logout request has been received from an identity provider and a logout response is pending.
Top
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsSendSLOPending Method

SAMLServiceProviderIsSendSLOPending Method

Indicates whether a single logout response to an identity provider is pending.

Single logout is pending if a logout request has been received from an identity provider and a logout response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSendSLOPending()
Public Shared Function IsSendSLOPending As Boolean
public:
static bool IsSendSLOPending()
static member IsSendSLOPending : unit -> bool

Return Value

Type: Boolean
true if single logout is pending; otherwise false.
See Also

Reference

SAMLServiceProvider Class
IsSendSLOPending Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsSendSLOPending Method (String)

SAMLServiceProviderIsSendSLOPending Method (String)

Indicates whether a single logout response to an identity provider is pending.

Single logout is pending if a logout request has been received from an identity provider and a logout response is pending.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSendSLOPending(
    string partnerIdP
)
Public Shared Function IsSendSLOPending (
    partnerIdP As String
) As Boolean
public:
static bool IsSendSLOPending(
    String^ partnerIdP
)
static member IsSendSLOPending :
        partnerIdP : string -> bool

Parameters

partnerIdP
Type: SystemString
The partner identity provider name.

Return Value

Type: Boolean
true if single logout is pending; otherwise false.
See Also

Reference

SAMLServiceProvider Class
IsSendSLOPending Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsSSO Method

SAMLServiceProviderIsSSO Method

Overload List
Name | Description
IsSSO | Indicates whether the service provider is currently single signed-on to an identity provider.
IsSSO(String) | Indicates whether the service provider is currently single signed-on to an identity provider.
Top
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsSSO Method

SAMLServiceProviderIsSSO Method

Indicates whether the service provider is currently single signed-on to an identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSSO()
Public Shared Function IsSSO As Boolean
public:
static bool IsSSO()
static member IsSSO : unit -> bool

Return Value

Type: Boolean
true if currently single signed-on; otherwise false.
See Also

Reference

SAMLServiceProvider Class
IsSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.IsSSO Method (String)

SAMLServiceProviderIsSSO Method (String)

Indicates whether the service provider is currently single signed-on to an identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSSO(
    string partnerIdP
)
Public Shared Function IsSSO (
    partnerIdP As String
) As Boolean
public:
static bool IsSSO(
    String^ partnerIdP
)
static member IsSSO :
        partnerIdP : string -> bool

Parameters

partnerIdP
Type: SystemString
The partner identity provider name.

Return Value

Type: Boolean
true if currently single signed-on; otherwise false.
See Also

Reference

SAMLServiceProvider Class
IsSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.ReceiveSLO Method

SAMLServiceProviderReceiveSLO Method

Overload List
Name | Description
ReceiveSLO(HttpRequest, Boolean, String, String, String) | Receives a single logout request (ie. IdP-initiated SLO) or single logout response (ie. SP-initiated SLO) from an identity provider.
ReceiveSLO(HttpRequestBase, Boolean, String, String, String) | Receives a single logout request (ie. IdP-initiated SLO) or single logout response (ie. SP-initiated SLO) from an identity provider.
Top
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.ReceiveSLO Method (HttpRequest, Boolean, String, String, String)

SAMLServiceProviderReceiveSLO Method (HttpRequest, Boolean, String, String, String)

Receives a single logout request (ie. IdP-initiated SLO) or single logout response (ie. SP-initiated SLO) from an identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSLO(
    HttpRequest httpRequest,
    out bool isRequest,
    out string logoutReason,
    out string partnerIdP,
    out string relayState
)
Public Shared Sub ReceiveSLO (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef isRequest As Boolean,
    <OutAttribute> ByRef logoutReason As String,
    <OutAttribute> ByRef partnerIdP As String,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveSLO(
    HttpRequest^ httpRequest,
    [OutAttribute] bool% isRequest,
    [OutAttribute] String^% logoutReason,
    [OutAttribute] String^% partnerIdP,
    [OutAttribute] String^% relayState
)
static member ReceiveSLO :
        httpRequest : HttpRequest *
        isRequest : bool byref *
        logoutReason : string byref *
        partnerIdP : string byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request.
isRequest
Type: SystemBoolean
true if a logout request has been received; otherwise false if a logout response has been received.
logoutReason
Type: SystemString
The reason associated with the logout request or null if none.
partnerIdP
Type: SystemString
The partner identity provider name.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single logout fails.
See Also

Reference

SAMLServiceProvider Class
ReceiveSLO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.ReceiveSLO Method (HttpRequestBase, Boolean, String, String, String)

SAMLServiceProviderReceiveSLO Method (HttpRequestBase, Boolean, String, String, String)

Receives a single logout request (ie. IdP-initiated SLO) or single logout response (ie. SP-initiated SLO) from an identity provider.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSLO(
    HttpRequestBase httpRequest,
    out bool isRequest,
    out string logoutReason,
    out string partnerIdP,
    out string relayState
)
Public Shared Sub ReceiveSLO (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef isRequest As Boolean,
    <OutAttribute> ByRef logoutReason As String,
    <OutAttribute> ByRef partnerIdP As String,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveSLO(
    HttpRequestBase^ httpRequest,
    [OutAttribute] bool% isRequest,
    [OutAttribute] String^% logoutReason,
    [OutAttribute] String^% partnerIdP,
    [OutAttribute] String^% relayState
)
static member ReceiveSLO :
        httpRequest : HttpRequestBase *
        isRequest : bool byref *
        logoutReason : string byref *
        partnerIdP : string byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request.
isRequest
Type: SystemBoolean
true if a logout request has been received; otherwise false if a logout response has been received.
logoutReason
Type: SystemString
The reason associated with the logout request or null if none.
partnerIdP
Type: SystemString
The partner identity provider name.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single logout fails.
See Also

Reference

SAMLServiceProvider Class
ReceiveSLO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.ReceiveSSO Method

SAMLServiceProviderReceiveSSO Method

Overload List
Name | Description
ReceiveSSO(HttpRequest, Boolean, String, String, SAMLAttribute, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
ReceiveSSO(HttpRequest, Boolean, String, String, IDictionaryString, String, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
ReceiveSSO(HttpRequestBase, Boolean, String, String, SAMLAttribute, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
ReceiveSSO(HttpRequestBase, Boolean, String, String, IDictionaryString, String, String) | Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).
Top
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.ReceiveSSO Method (HttpRequest, Boolean, String, String, SAMLAttribute[], String)

SAMLServiceProviderReceiveSSO Method (HttpRequest, Boolean, String, String, SAMLAttribute, String)

Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSSO(
    HttpRequest httpRequest,
    out bool isInResponseTo,
    out string partnerIdP,
    out string userName,
    out SAMLAttribute[] attributes,
    out string relayState
)
Public Shared Sub ReceiveSSO (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef isInResponseTo As Boolean,
    <OutAttribute> ByRef partnerIdP As String,
    <OutAttribute> ByRef userName As String,
    <OutAttribute> ByRef attributes As SAMLAttribute(),
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveSSO(
    HttpRequest^ httpRequest,
    [OutAttribute] bool% isInResponseTo,
    [OutAttribute] String^% partnerIdP,
    [OutAttribute] String^% userName,
    [OutAttribute] array<SAMLAttribute^>^% attributes,
    [OutAttribute] String^% relayState
)
static member ReceiveSSO :
        httpRequest : HttpRequest *
        isInResponseTo : bool byref *
        partnerIdP : string byref *
        userName : string byref *
        attributes : SAMLAttribute[] byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request.
isInResponseTo
Type: SystemBoolean
true if the SAML response is in response to an authn request; otherwise false.
partnerIdP
Type: SystemString
The partner identity provider name.
userName
Type: SystemString
The user name in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
ReceiveSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.ReceiveSSO Method (HttpRequest, Boolean, String, String, IDictionary(String, String), String)

SAMLServiceProviderReceiveSSO Method (HttpRequest, Boolean, String, String, IDictionaryString, String, String)

Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSSO(
    HttpRequest httpRequest,
    out bool isInResponseTo,
    out string partnerIdP,
    out string userName,
    out IDictionary<string, string> attributes,
    out string relayState
)
Public Shared Sub ReceiveSSO (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef isInResponseTo As Boolean,
    <OutAttribute> ByRef partnerIdP As String,
    <OutAttribute> ByRef userName As String,
    <OutAttribute> ByRef attributes As IDictionary(Of String, String),
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveSSO(
    HttpRequest^ httpRequest,
    [OutAttribute] bool% isInResponseTo,
    [OutAttribute] String^% partnerIdP,
    [OutAttribute] String^% userName,
    [OutAttribute] IDictionary<String^, String^>^% attributes,
    [OutAttribute] String^% relayState
)
static member ReceiveSSO :
        httpRequest : HttpRequest *
        isInResponseTo : bool byref *
        partnerIdP : string byref *
        userName : string byref *
        attributes : IDictionary<string, string> byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request.
isInResponseTo
Type: SystemBoolean
true if the SAML response is in response to an authn request; otherwise false.
partnerIdP
Type: SystemString
The partner identity provider name.
userName
Type: SystemString
The user name in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
ReceiveSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.ReceiveSSO Method (HttpRequestBase, Boolean, String, String, SAMLAttribute[], String)

SAMLServiceProviderReceiveSSO Method (HttpRequestBase, Boolean, String, String, SAMLAttribute, String)

Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSSO(
    HttpRequestBase httpRequest,
    out bool isInResponseTo,
    out string partnerIdP,
    out string userName,
    out SAMLAttribute[] attributes,
    out string relayState
)
Public Shared Sub ReceiveSSO (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef isInResponseTo As Boolean,
    <OutAttribute> ByRef partnerIdP As String,
    <OutAttribute> ByRef userName As String,
    <OutAttribute> ByRef attributes As SAMLAttribute(),
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveSSO(
    HttpRequestBase^ httpRequest,
    [OutAttribute] bool% isInResponseTo,
    [OutAttribute] String^% partnerIdP,
    [OutAttribute] String^% userName,
    [OutAttribute] array<SAMLAttribute^>^% attributes,
    [OutAttribute] String^% relayState
)
static member ReceiveSSO :
        httpRequest : HttpRequestBase *
        isInResponseTo : bool byref *
        partnerIdP : string byref *
        userName : string byref *
        attributes : SAMLAttribute[] byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request.
isInResponseTo
Type: SystemBoolean
true if the SAML response is in response to an authn request; otherwise false.
partnerIdP
Type: SystemString
The partner identity provider name.
userName
Type: SystemString
The user name in the SAML assertion.
attributes
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The attributes in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
ReceiveSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.ReceiveSSO Method (HttpRequestBase, Boolean, String, String, IDictionary(String, String), String)

SAMLServiceProviderReceiveSSO Method (HttpRequestBase, Boolean, String, String, IDictionaryString, String, String)

Receives a single sign-on response from the identity provider (ie. IdP-initiated or SP-initiated SSO).

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSSO(
    HttpRequestBase httpRequest,
    out bool isInResponseTo,
    out string partnerIdP,
    out string userName,
    out IDictionary<string, string> attributes,
    out string relayState
)
Public Shared Sub ReceiveSSO (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef isInResponseTo As Boolean,
    <OutAttribute> ByRef partnerIdP As String,
    <OutAttribute> ByRef userName As String,
    <OutAttribute> ByRef attributes As IDictionary(Of String, String),
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveSSO(
    HttpRequestBase^ httpRequest,
    [OutAttribute] bool% isInResponseTo,
    [OutAttribute] String^% partnerIdP,
    [OutAttribute] String^% userName,
    [OutAttribute] IDictionary<String^, String^>^% attributes,
    [OutAttribute] String^% relayState
)
static member ReceiveSSO :
        httpRequest : HttpRequestBase *
        isInResponseTo : bool byref *
        partnerIdP : string byref *
        userName : string byref *
        attributes : IDictionary<string, string> byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request.
isInResponseTo
Type: SystemBoolean
true if the SAML response is in response to an authn request; otherwise false.
partnerIdP
Type: SystemString
The partner identity provider name.
userName
Type: SystemString
The user name in the SAML assertion.
attributes
Type: System.Collections.GenericIDictionary String, String
The attributes in the SAML assertion or null if none.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the single sign-on fails.
See Also

Reference

SAMLServiceProvider Class
ReceiveSSO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.SendSLO Method

SAMLServiceProviderSendSLO Method

Overload List
Name | Description
SendSLO(HttpResponse, String) | Sends a single logout response to the identity provider (ie IdP-initiated SLO).
SendSLO(HttpResponseBase, String) | Sends a single logout response to the identity provider (ie IdP-initiated SLO).
Top
See Also

Reference

SAMLServiceProvider Class
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.SendSLO Method (HttpResponse, String)

SAMLServiceProviderSendSLO Method (HttpResponse, String)

Sends a single logout response to the identity provider (ie IdP-initiated SLO).

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSLO(
    HttpResponse httpResponse,
    string errorMessage
)
Public Shared Sub SendSLO (
    httpResponse As HttpResponse,
    errorMessage As String
)
public:
static void SendSLO(
    HttpResponse^ httpResponse,
    String^ errorMessage
)
static member SendSLO :
        httpResponse : HttpResponse *
        errorMessage : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
errorMessage
Type: SystemString
The error message or null if logout was successful.
See Also

Reference

SAMLServiceProvider Class
SendSLO Overload
ComponentSpace.SAML2 Namespace


SAMLServiceProvider.SendSLO Method (HttpResponseBase, String)

SAMLServiceProviderSendSLO Method (HttpResponseBase, String)

Sends a single logout response to the identity provider (ie IdP-initiated SLO).

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSLO(
    HttpResponseBase httpResponse,
    string errorMessage
)
Public Shared Sub SendSLO (
    httpResponse As HttpResponseBase,
    errorMessage As String
)
public:
static void SendSLO(
    HttpResponseBase^ httpResponse,
    String^ errorMessage
)
static member SendSLO :
        httpResponse : HttpResponseBase *
        errorMessage : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
errorMessage
Type: SystemString
The error message or null if logout was successful.
See Also

Reference

SAMLServiceProvider Class
SendSLO Overload
ComponentSpace.SAML2 Namespace


SSOOptions Class

Specifies single sign-on options.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2SSOOptions

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SSOOptions
Public Class SSOOptions
public ref class SSOOptions
type SSOOptions =  class end

The SSOOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SSOOptions | Initializes a new instance of the SSOOptions class.
Public method | SSOOptions(Boolean, Boolean, Boolean, String, String, IListString) | Initializes a new instance of the SSOOptions class.
Public method | SSOOptions(Boolean, Boolean, Boolean, String, String, String) | Initializes a new instance of the SSOOptions class.
Top
Properties
 | Name | Description
Public property | AllowCreate | Gets or sets the optional allow create flag. If true the identity provider is allowed to create a new identifier for the user.
Public property | ForceAuthn | Gets or sets the optional force authentication flag. If true the identity provider should discard any existing user authentication session and establish a new user authentication session.
Public property | IsPassive | Gets or sets the optional is passive flag. If true the identity provider must not visibly take control of the user interface.
Public property | ProviderName | Gets or sets the optional provider name.
Public property | RequestedAuthnContexts | Gets or sets the optional requested authentication contexts.
Public property | SPNameQualifier | Gets or sets the optional service provider name qualifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2 Namespace


SSOOptions Constructor

Overload List
 | Name | Description
Public method | SSOOptions | Initializes a new instance of the SSOOptions class.
Public method | SSOOptions(Boolean, Boolean, Boolean, String, String, IListString) | Initializes a new instance of the SSOOptions class.
Public method | SSOOptions(Boolean, Boolean, Boolean, String, String, String) | Initializes a new instance of the SSOOptions class.
Top
See Also

Reference

SSOOptions Class
ComponentSpace.SAML2 Namespace


SSOOptions Constructor

Initializes a new instance of the SSOOptions class.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SSOOptions()
Public Sub New
public:
SSOOptions()
new : unit -> SSOOptions
See Also

Reference

SSOOptions Class
SSOOptions Overload
ComponentSpace.SAML2 Namespace


SSOOptions Constructor (Boolean, Boolean, Boolean, String, String, IList(String))

SSOOptions Constructor (Boolean, Boolean, Boolean, String, String, IListString)

Initializes a new instance of the SSOOptions class.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SSOOptions(
    bool forceAuthn,
    bool isPassive,
    bool allowCreate,
    string providerName,
    string spNameQualifier,
    IList<string> requestedAuthnContexts
)
Public Sub New (
    forceAuthn As Boolean,
    isPassive As Boolean,
    allowCreate As Boolean,
    providerName As String,
    spNameQualifier As String,
    requestedAuthnContexts As IList(Of String)
)
public:
SSOOptions(
    bool forceAuthn,
    bool isPassive,
    bool allowCreate,
    String^ providerName,
    String^ spNameQualifier,
    IList<String^>^ requestedAuthnContexts
)
new :
        forceAuthn : bool *
        isPassive : bool *
        allowCreate : bool *
        providerName : string *
        spNameQualifier : string *
        requestedAuthnContexts : IList<string> -> SSOOptions

Parameters

forceAuthn
Type: SystemBoolean
The force authentication flag.
isPassive
Type: SystemBoolean
The is passive flag.
allowCreate
Type: SystemBoolean
The allow create flag.
providerName
Type: SystemString
The provider name.
spNameQualifier
Type: SystemString
The service provider name qualifier.
requestedAuthnContexts
Type: System.Collections.GenericIList String
The requested authentication contexts.
See Also

Reference

SSOOptions Class
SSOOptions Overload
ComponentSpace.SAML2 Namespace


SSOOptions Constructor (Boolean, Boolean, Boolean, String, String, String)

Initializes a new instance of the SSOOptions class.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SSOOptions(
    bool forceAuthn,
    bool isPassive,
    bool allowCreate,
    string providerName,
    string spNameQualifier,
    string requestedAuthnContext
)
Public Sub New (
    forceAuthn As Boolean,
    isPassive As Boolean,
    allowCreate As Boolean,
    providerName As String,
    spNameQualifier As String,
    requestedAuthnContext As String
)
public:
SSOOptions(
    bool forceAuthn,
    bool isPassive,
    bool allowCreate,
    String^ providerName,
    String^ spNameQualifier,
    String^ requestedAuthnContext
)
new :
        forceAuthn : bool *
        isPassive : bool *
        allowCreate : bool *
        providerName : string *
        spNameQualifier : string *
        requestedAuthnContext : string -> SSOOptions

Parameters

forceAuthn
Type: SystemBoolean
The force authentication flag.
isPassive
Type: SystemBoolean
The is passive flag.
allowCreate
Type: SystemBoolean
The allow create flag.
providerName
Type: SystemString
The provider name.
spNameQualifier
Type: SystemString
The service provider name qualifier.
requestedAuthnContext
Type: SystemString
The requested authentication context.
See Also

Reference

SSOOptions Class
SSOOptions Overload
ComponentSpace.SAML2 Namespace


SSOOptions Properties

The SSOOptions type exposes the following members.

Properties
 | Name | Description
Public property | AllowCreate | Gets or sets the optional allow create flag. If true the identity provider is allowed to create a new identifier for the user.
Public property | ForceAuthn | Gets or sets the optional force authentication flag. If true the identity provider should discard any existing user authentication session and establish a new user authentication session.
Public property | IsPassive | Gets or sets the optional is passive flag. If true the identity provider must not visibly take control of the user interface.
Public property | ProviderName | Gets or sets the optional provider name.
Public property | RequestedAuthnContexts | Gets or sets the optional requested authentication contexts.
Public property | SPNameQualifier | Gets or sets the optional service provider name qualifier.
Top
See Also

Reference

SSOOptions Class
ComponentSpace.SAML2 Namespace


SSOOptions.AllowCreate Property

SSOOptionsAllowCreate Property

Gets or sets the optional allow create flag. If true the identity provider is allowed to create a new identifier for the user.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool AllowCreate { get; set; }
Public Property AllowCreate As Boolean
    Get
    Set
public:
property bool AllowCreate {
    bool get ();
    void set (bool value);
}
member AllowCreate : bool with get, set

Property Value

Type: Boolean
The allow create flag.
See Also

Reference

SSOOptions Class
ComponentSpace.SAML2 Namespace


SSOOptions.ForceAuthn Property

SSOOptionsForceAuthn Property

Gets or sets the optional force authentication flag. If true the identity provider should discard any existing user authentication session and establish a new user authentication session.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool ForceAuthn { get; set; }
Public Property ForceAuthn As Boolean
    Get
    Set
public:
property bool ForceAuthn {
    bool get ();
    void set (bool value);
}
member ForceAuthn : bool with get, set

Property Value

Type: Boolean
The force authentication flag.
See Also

Reference

SSOOptions Class
ComponentSpace.SAML2 Namespace


SSOOptions.IsPassive Property

SSOOptionsIsPassive Property

Gets or sets the optional is passive flag. If true the identity provider must not visibly take control of the user interface.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool IsPassive { get; set; }
Public Property IsPassive As Boolean
    Get
    Set
public:
property bool IsPassive {
    bool get ();
    void set (bool value);
}
member IsPassive : bool with get, set

Property Value

Type: Boolean
The is passive flag.
See Also

Reference

SSOOptions Class
ComponentSpace.SAML2 Namespace


SSOOptions.ProviderName Property

SSOOptionsProviderName Property

Gets or sets the optional provider name.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ProviderName { get; set; }
Public Property ProviderName As String
    Get
    Set
public:
property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
member ProviderName : string with get, set

Property Value

Type: String
The provider name.
See Also

Reference

SSOOptions Class
ComponentSpace.SAML2 Namespace


SSOOptions.RequestedAuthnContexts Property

SSOOptionsRequestedAuthnContexts Property

Gets or sets the optional requested authentication contexts.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<string> RequestedAuthnContexts { get; set; }
Public Property RequestedAuthnContexts As IList(Of String)
    Get
    Set
public:
property IList<String^>^ RequestedAuthnContexts {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member RequestedAuthnContexts : IList<string> with get, set

Property Value

Type: IList String
The requested authentication contexts.
See Also

Reference

SSOOptions Class
ComponentSpace.SAML2 Namespace


SSOOptions.SPNameQualifier Property

SSOOptionsSPNameQualifier Property

Gets or sets the optional service provider name qualifier.

Namespace: ComponentSpace.SAML2
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SPNameQualifier { get; set; }
Public Property SPNameQualifier As String
    Get
    Set
public:
property String^ SPNameQualifier {
    String^ get ();
    void set (String^ value);
}
member SPNameQualifier : string with get, set

Property Value

Type: String
The service provider name qualifier.
See Also

Reference

SSOOptions Class
ComponentSpace.SAML2 Namespace


SSOOptions Methods

The SSOOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SSOOptions Class
ComponentSpace.SAML2 Namespace


ComponentSpace.SAML2.Assertions Namespace

The ComponentSpace.SAML2.Assertions namespace contains classes for manipulating SAML v2.0 assertions.

Use the SAMLAssertion class to create, manipulate and access SAML assertions.

Generate and verify XML digital signatures within SAML assertions using the SAMLAssertionSignature class.

Classes
 | Class | Description
Public class | Action | Represents an action.
Public class | Advice | Represents advice.
Public class | AssertionIDCache | Provides a cache for recording previously used SAMLAssertion identifiers. The cache may be used when enforcing single use of SAML assertions.
Public class | AssertionIDRef | Represents an assertion ID reference.
Public class | AssertionURIRef | Represents an assertion URI reference.
Public class | AttributeStatement | Represents an attribute statement.
Public class | AttributeType | Represents the attribute type.
Public class | AttributeValue | Represents a SAML attribute value.
Public class | Audience | Represents an audience.
Public class | AudienceRestriction | Represents an audience restriction.
Public class | AuthenticatingAuthority | Represents an authenticating authority.
Public class | AuthnContext | Represents an authentication context.
Public class | AuthnContextClassRef | Represents an authentication context class reference.
Public class | AuthnContextDecl | Represents an authentication context declaration.
Public class | AuthnContextDeclRef | Represents an authentication context declaration reference.
Public class | AuthnStatement | Represents an authentication statement.
Public class | AuthzDecisionStatement | Represents an authorization decision statement.
Public class | BaseID | Represents a base identifier.
Public class | BaseIDAbstractType | Represents the base identifier abstract type.
Public class | Conditions | Represents conditions.
Public class | EncryptedAssertion | Represents an encrypted assertion.
Public class | EncryptedAttribute | Represents an encrypted attribute.
Public class | EncryptedElementType | Represents the encrypted element type.
Public class | EncryptedID | Represents an encrypted identifier.
Public class | Evidence | Represents evidence.
Public class | Issuer | Represents an issuer.
Public class | NameID | Represents a name identifier.
Public class | NameIDType | Represents the name identifier type.
Public class | NewEncryptedID | Represents a new encrypted identifier.
Public class | OneTimeUse | Represents a one time use condition.
Public class | ProxyRestriction | Represents a proxy restriction.
Public class | SAMLAssertion | Represents the Assertion element.
Public class | SAMLAssertionSerializer | Permits the serialization and deserialization of SAML assertions.
Public class | SAMLAssertionSignature | Permits XML signature generation and verification for SAML assertions.
Public class | SAMLAttribute | Represents an attribute.
Public class | StringAttributeValueSerializer | Serializes string attribute values to XML. The attribute value is a string.
Public class | Subject | Represents a subject.
Public class | SubjectConfirmation | Represents a subject confirmation.
Public class | SubjectConfirmationData | Represents subject confirmation data.
Public class | SubjectLocality | Represents a subject locality.
Public class | XmlAttributeValueSerializer | Serializes XML element attribute values to XML. The attribute value is an XmlElement.
Interfaces
 | Interface | Description
Public interface | IAttributeValueSerializer | The interface for serializing attribute values to XML. Implement this interface to support custom attribute values.
Public interface | ICondition | Represents a condition.
Public interface | IStatement | Represents a statement.


Action Class

Represents an action.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAction

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Action
Public Class Action
public ref class Action
type Action =  class end

The Action type exposes the following members.

Constructors
 | Name | Description
Public method | Action | Initializes a new instance of the Action class.
Public method | Action(XmlElement) | Initializes a new instance of the Action class from XML.
Public method | Action(String, String) | Initializes a new instance of the Action class.
Top
Properties
 | Name | Description
Public property | ActionNamespace | Gets or sets the action namespace.
Public property | ActionValue | Gets or sets the action value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an action.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the action to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


Action Constructor

Overload List
 | Name | Description
Public method | Action | Initializes a new instance of the Action class.
Public method | Action(XmlElement) | Initializes a new instance of the Action class from XML.
Public method | Action(String, String) | Initializes a new instance of the Action class.
Top
See Also

Reference

Action Class
ComponentSpace.SAML2.Assertions Namespace


Action Constructor

Initializes a new instance of the Action class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Action()
Public Sub New
public:
Action()
new : unit -> Action
See Also

Reference

Action Class
Action Overload
ComponentSpace.SAML2.Assertions Namespace


Action Constructor (XmlElement)

Initializes a new instance of the Action class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Action(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Action(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Action

Parameters

xmlElement
Type: System.XmlXmlElement
The action XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Action Class
Action Overload
ComponentSpace.SAML2.Assertions Namespace


Action Constructor (String, String)

Initializes a new instance of the Action class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Action(
    string actionNamespace,
    string actionValue
)
Public Sub New (
    actionNamespace As String,
    actionValue As String
)
public:
Action(
    String^ actionNamespace,
    String^ actionValue
)
new :
        actionNamespace : string *
        actionValue : string -> Action

Parameters

actionNamespace
Type: SystemString
The action namespace.
actionValue
Type: SystemString
The action value.
See Also

Reference

Action Class
Action Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersActionNamespaces
ComponentSpace.SAML2SAMLIdentifiersActions


Action Properties

The Action type exposes the following members.

Properties
 | Name | Description
Public property | ActionNamespace | Gets or sets the action namespace.
Public property | ActionValue | Gets or sets the action value.
Top
See Also

Reference

Action Class
ComponentSpace.SAML2.Assertions Namespace


Action.ActionNamespace Property

ActionActionNamespace Property

Gets or sets the action namespace.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ActionNamespace { get; set; }
Public Property ActionNamespace As String
    Get
    Set
public:
property String^ ActionNamespace {
    String^ get ();
    void set (String^ value);
}
member ActionNamespace : string with get, set

Property Value

Type: String
The action namespace.
See Also

Reference

Action Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersActionNamespaces


Action.ActionValue Property

ActionActionValue Property

Gets or sets the action value.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ActionValue { get; set; }
Public Property ActionValue As String
    Get
    Set
public:
property String^ ActionValue {
    String^ get ();
    void set (String^ value);
}
member ActionValue : string with get, set

Property Value

Type: String
The action value.
See Also

Reference

Action Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersActions


Action Methods

The Action type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an action.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the action to XML.
Top
See Also

Reference

Action Class
ComponentSpace.SAML2.Assertions Namespace


Action.IsValid Method

ActionIsValid Method

Indicates whether the XML is an action.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an action; otherwise false.
See Also

Reference

Action Class
ComponentSpace.SAML2.Assertions Namespace


Action.ToXml Method

ActionToXml Method

Serializes the action to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The action as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Action Class
ComponentSpace.SAML2.Assertions Namespace


Advice Class

Represents advice.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAdvice

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Advice
Public Class Advice
public ref class Advice
type Advice =  class end

The Advice type exposes the following members.

Constructors
 | Name | Description
Public method | Advice | Initializes a new instance of the Advice class.
Public method | Advice(XmlElement) | Initializes a new instance of the Advice class from XML.
Top
Properties
 | Name | Description
Public property | AdviceList | Gets or sets the list of advice.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is advice.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the advice to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


Advice Constructor

Overload List
 | Name | Description
Public method | Advice | Initializes a new instance of the Advice class.
Public method | Advice(XmlElement) | Initializes a new instance of the Advice class from XML.
Top
See Also

Reference

Advice Class
ComponentSpace.SAML2.Assertions Namespace


Advice Constructor

Initializes a new instance of the Advice class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Advice()
Public Sub New
public:
Advice()
new : unit -> Advice
See Also

Reference

Advice Class
Advice Overload
ComponentSpace.SAML2.Assertions Namespace


Advice Constructor (XmlElement)

Initializes a new instance of the Advice class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Advice(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Advice(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Advice

Parameters

xmlElement
Type: System.XmlXmlElement
The advice XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Advice Class
Advice Overload
ComponentSpace.SAML2.Assertions Namespace


Advice Properties

The Advice type exposes the following members.

Properties
 | Name | Description
Public property | AdviceList | Gets or sets the list of advice.
Top
See Also

Reference

Advice Class
ComponentSpace.SAML2.Assertions Namespace


Advice.AdviceList Property

AdviceAdviceList Property

Gets or sets the list of advice.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList AdviceList { get; set; }
Public Property AdviceList As IList
    Get
    Set
public:
property IList^ AdviceList {
    IList^ get ();
    void set (IList^ value);
}
member AdviceList : IList with get, set

Property Value

Type: IList
The list of advice.
See Also

Reference

Advice Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAssertionIDRef
ComponentSpace.SAML2.AssertionsAssertionURIRef
ComponentSpace.SAML2.AssertionsSAMLAssertion
ComponentSpace.SAML2.AssertionsEncryptedAssertion


Advice Methods

The Advice type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is advice.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the advice to XML.
Top
See Also

Reference

Advice Class
ComponentSpace.SAML2.Assertions Namespace


Advice.IsValid Method

AdviceIsValid Method

Indicates whether the XML is advice.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is advice; otherwise false.
See Also

Reference

Advice Class
ComponentSpace.SAML2.Assertions Namespace


Advice.ToXml Method

AdviceToXml Method

Serializes the advice to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The advice as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Advice Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDCache Class

Provides a cache for recording previously used SAMLAssertion identifiers. The cache may be used when enforcing single use of SAML assertions.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAssertionIDCache

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AssertionIDCache
Public NotInheritable Class AssertionIDCache
public ref class AssertionIDCache abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AssertionIDCache =  class end

The AssertionIDCache type exposes the following members.

Properties
Name | Description
Expiration | Gets or sets the expiration time span for cached assertion identifier entries.
Top
Methods
Name | Description
Add(String) | Adds an assertion identifier to the cache. The assertion identifier cannot already exist in the cache.
Add(SAMLAssertion) | Adds an assertion identifier to the cache. The assertion identifier cannot already exist in the cache.
Contains | Indicates whether the assertion identifier is contained in the cache.
Remove | Removes an assertion identifier from the cache.
Top
Remarks
The cache is implemented using the System.Web.Caching.Cache. Use of this cache is entirely optional. Refer to the System.Web.Caching.Cache documentation for usage restrictions.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AssertionIDCache Properties

The AssertionIDCache type exposes the following members.

Properties
Name | Description
Expiration | Gets or sets the expiration time span for cached assertion identifier entries.
Top
See Also

Reference

AssertionIDCache Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDCache.Expiration Property

AssertionIDCacheExpiration Property

Gets or sets the expiration time span for cached assertion identifier entries.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static TimeSpan Expiration { get; set; }
Public Shared Property Expiration As TimeSpan
    Get
    Set
public:
static property TimeSpan Expiration {
    TimeSpan get ();
    void set (TimeSpan value);
}
static member Expiration : TimeSpan with get, set

Property Value

Type: TimeSpan
The expiration time span for cached assertion identifier entries.
See Also

Reference

AssertionIDCache Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDCache Methods

The AssertionIDCache type exposes the following members.

Methods
Name | Description
Add(String) | Adds an assertion identifier to the cache. The assertion identifier cannot already exist in the cache.
Add(SAMLAssertion) | Adds an assertion identifier to the cache. The assertion identifier cannot already exist in the cache.
Contains | Indicates whether the assertion identifier is contained in the cache.
Remove | Removes an assertion identifier from the cache.
Top
See Also

Reference

AssertionIDCache Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDCache.Add Method

AssertionIDCacheAdd Method

Overload List
Name | Description
Add(String) | Adds an assertion identifier to the cache. The assertion identifier cannot already exist in the cache.
Add(SAMLAssertion) | Adds an assertion identifier to the cache. The assertion identifier cannot already exist in the cache.
Top
See Also

Reference

AssertionIDCache Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDCache.Add Method (String)

AssertionIDCacheAdd Method (String)

Adds an assertion identifier to the cache. The assertion identifier cannot already exist in the cache.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Add(
    string id
)
Public Shared Function Add (
    id As String
) As Boolean
public:
static bool Add(
    String^ id
)
static member Add :
        id : string -> bool

Parameters

id
Type: SystemString
The SAML assertion identifier.

Return Value

Type: Boolean
true if the assertion identifier was added to the cache; otherwise false.
See Also

Reference

AssertionIDCache Class
Add Overload
ComponentSpace.SAML2.Assertions Namespace


AssertionIDCache.Add Method (SAMLAssertion)

AssertionIDCacheAdd Method (SAMLAssertion)

Adds an assertion identifier to the cache. The assertion identifier cannot already exist in the cache.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Add(
    SAMLAssertion samlAssertion
)
Public Shared Function Add (
    samlAssertion As SAMLAssertion
) As Boolean
public:
static bool Add(
    SAMLAssertion^ samlAssertion
)
static member Add :
        samlAssertion : SAMLAssertion -> bool

Parameters

samlAssertion
Type: ComponentSpace.SAML2.AssertionsSAMLAssertion
The SAML assertion whose identifier is to be cached.

Return Value

Type: Boolean
true if the entry was added in the cache; otherwise false.
Remarks
If the SAML assertion includes a Conditions element with a NotOnOrAfter time then that value is used as the expiration time for the cache entry. Otherwise the default expiration time is used.
See Also

Reference

AssertionIDCache Class
Add Overload
ComponentSpace.SAML2.Assertions Namespace


AssertionIDCache.Contains Method

AssertionIDCacheContains Method

Indicates whether the assertion identifier is contained in the cache.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Contains(
    string id
)
Public Shared Function Contains (
    id As String
) As Boolean
public:
static bool Contains(
    String^ id
)
static member Contains :
        id : string -> bool

Parameters

id
Type: SystemString
The SAML assertion identifier.

Return Value

Type: Boolean
true if the assertion identifier is contained in the cache; otherwise false.
See Also

Reference

AssertionIDCache Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDCache.Remove Method

AssertionIDCacheRemove Method

Removes an assertion identifier from the cache.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Remove(
    string id
)
Public Shared Sub Remove (
    id As String
)
public:
static void Remove(
    String^ id
)
static member Remove :
        id : string -> unit

Parameters

id
Type: SystemString
The SAML assertion identifier.
See Also

Reference

AssertionIDCache Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDRef Class

Represents an assertion ID reference.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAssertionIDRef

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AssertionIDRef
Public Class AssertionIDRef
public ref class AssertionIDRef
type AssertionIDRef =  class end

The AssertionIDRef type exposes the following members.

Constructors
 | Name | Description
Public method | AssertionIDRef | Initializes a new instance of the AssertionIDRef class.
Public method | AssertionIDRef(String) | Initializes a new instance of the AssertionIDRef class.
Public method | AssertionIDRef(XmlElement) | Initializes a new instance of the AssertionIDRef class from XML.
Top
Properties
 | Name | Description
Public property | Reference | Gets or sets the reference.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an assertion ID reference.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the assertion ID reference to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AssertionIDRef Constructor

Overload List
 | Name | Description
Public method | AssertionIDRef | Initializes a new instance of the AssertionIDRef class.
Public method | AssertionIDRef(String) | Initializes a new instance of the AssertionIDRef class.
Public method | AssertionIDRef(XmlElement) | Initializes a new instance of the AssertionIDRef class from XML.
Top
See Also

Reference

AssertionIDRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDRef Constructor

Initializes a new instance of the AssertionIDRef class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AssertionIDRef()
Public Sub New
public:
AssertionIDRef()
new : unit -> AssertionIDRef
See Also

Reference

AssertionIDRef Class
AssertionIDRef Overload
ComponentSpace.SAML2.Assertions Namespace


AssertionIDRef Constructor (String)

Initializes a new instance of the AssertionIDRef class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AssertionIDRef(
    string reference
)
Public Sub New (
    reference As String
)
public:
AssertionIDRef(
    String^ reference
)
new :
        reference : string -> AssertionIDRef

Parameters

reference
Type: SystemString
The reference.
See Also

Reference

AssertionIDRef Class
AssertionIDRef Overload
ComponentSpace.SAML2.Assertions Namespace


AssertionIDRef Constructor (XmlElement)

Initializes a new instance of the AssertionIDRef class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AssertionIDRef(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AssertionIDRef(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AssertionIDRef

Parameters

xmlElement
Type: System.XmlXmlElement
The AssertionIDRef XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AssertionIDRef Class
AssertionIDRef Overload
ComponentSpace.SAML2.Assertions Namespace


AssertionIDRef Properties

The AssertionIDRef type exposes the following members.

Properties
 | Name | Description
Public property | Reference | Gets or sets the reference.
Top
See Also

Reference

AssertionIDRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDRef.Reference Property

AssertionIDRefReference Property

Gets or sets the reference.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Reference { get; set; }
Public Property Reference As String
    Get
    Set
public:
property String^ Reference {
    String^ get ();
    void set (String^ value);
}
member Reference : string with get, set

Property Value

Type: String
The reference.
See Also

Reference

AssertionIDRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDRef Methods

The AssertionIDRef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an assertion ID reference.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the assertion ID reference to XML.
Top
See Also

Reference

AssertionIDRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDRef.IsValid Method

AssertionIDRefIsValid Method

Indicates whether the XML is an assertion ID reference.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an assertion ID reference; otherwise false.
See Also

Reference

AssertionIDRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionIDRef.ToXml Method

AssertionIDRefToXml Method

Serializes the assertion ID reference to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The assertion ID reference as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AssertionIDRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionURIRef Class

Represents an assertion URI reference.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAssertionURIRef

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AssertionURIRef
Public Class AssertionURIRef
public ref class AssertionURIRef
type AssertionURIRef =  class end

The AssertionURIRef type exposes the following members.

Constructors
 | Name | Description
Public method | AssertionURIRef | Initializes a new instance of the AssertionURIRef class.
Public method | AssertionURIRef(String) | Initializes a new instance of the AssertionURIRef class.
Public method | AssertionURIRef(XmlElement) | Initializes a new instance of the AssertionURIRef class from XML.
Top
Properties
 | Name | Description
Public property | Reference | Gets or sets the reference.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an assertion URI reference.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the assertion URI reference to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AssertionURIRef Constructor

Overload List
 | Name | Description
Public method | AssertionURIRef | Initializes a new instance of the AssertionURIRef class.
Public method | AssertionURIRef(String) | Initializes a new instance of the AssertionURIRef class.
Public method | AssertionURIRef(XmlElement) | Initializes a new instance of the AssertionURIRef class from XML.
Top
See Also

Reference

AssertionURIRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionURIRef Constructor

Initializes a new instance of the AssertionURIRef class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AssertionURIRef()
Public Sub New
public:
AssertionURIRef()
new : unit -> AssertionURIRef
See Also

Reference

AssertionURIRef Class
AssertionURIRef Overload
ComponentSpace.SAML2.Assertions Namespace


AssertionURIRef Constructor (String)

Initializes a new instance of the AssertionURIRef class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AssertionURIRef(
    string reference
)
Public Sub New (
    reference As String
)
public:
AssertionURIRef(
    String^ reference
)
new :
        reference : string -> AssertionURIRef

Parameters

reference
Type: SystemString
The reference.
See Also

Reference

AssertionURIRef Class
AssertionURIRef Overload
ComponentSpace.SAML2.Assertions Namespace


AssertionURIRef Constructor (XmlElement)

Initializes a new instance of the AssertionURIRef class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AssertionURIRef(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AssertionURIRef(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AssertionURIRef

Parameters

xmlElement
Type: System.XmlXmlElement
The AssertionURIRef XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AssertionURIRef Class
AssertionURIRef Overload
ComponentSpace.SAML2.Assertions Namespace


AssertionURIRef Properties

The AssertionURIRef type exposes the following members.

Properties
 | Name | Description
Public property | Reference | Gets or sets the reference.
Top
See Also

Reference

AssertionURIRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionURIRef.Reference Property

AssertionURIRefReference Property

Gets or sets the reference.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Reference { get; set; }
Public Property Reference As String
    Get
    Set
public:
property String^ Reference {
    String^ get ();
    void set (String^ value);
}
member Reference : string with get, set

Property Value

Type: String
The reference.
See Also

Reference

AssertionURIRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionURIRef Methods

The AssertionURIRef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an assertion URI reference.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the assertion URI reference to XML.
Top
See Also

Reference

AssertionURIRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionURIRef.IsValid Method

AssertionURIRefIsValid Method

Indicates whether the XML is an assertion URI reference.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an assertion URI reference; otherwise false.
See Also

Reference

AssertionURIRef Class
ComponentSpace.SAML2.Assertions Namespace


AssertionURIRef.ToXml Method

AssertionURIRefToXml Method

Serializes the assertion URI reference to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The assertion URI reference as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AssertionURIRef Class
ComponentSpace.SAML2.Assertions Namespace


AttributeStatement Class

Represents an attribute statement.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAttributeStatement

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AttributeStatement : IStatement
Public Class AttributeStatement
    Implements IStatement
public ref class AttributeStatement : IStatement
type AttributeStatement =
    class
        interface IStatement
    end

The AttributeStatement type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeStatement | Initializes a new instance of the AttributeStatement class.
Public method | AttributeStatement(XmlElement) | Initializes a new instance of the AttributeStatement class from XML.
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets the attributes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEncryptedAttributes | Returns all encrypted attributes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnencryptedAttributes | Returns all unencrypted attributes.
 | IsValid | Indicates whether the XML is an attribute statement.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the attribute statement to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AttributeStatement Constructor

Overload List
 | Name | Description
Public method | AttributeStatement | Initializes a new instance of the AttributeStatement class.
Public method | AttributeStatement(XmlElement) | Initializes a new instance of the AttributeStatement class from XML.
Top
See Also

Reference

AttributeStatement Class
ComponentSpace.SAML2.Assertions Namespace


AttributeStatement Constructor

Initializes a new instance of the AttributeStatement class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeStatement()
Public Sub New
public:
AttributeStatement()
new : unit -> AttributeStatement
See Also

Reference

AttributeStatement Class
AttributeStatement Overload
ComponentSpace.SAML2.Assertions Namespace


AttributeStatement Constructor (XmlElement)

Initializes a new instance of the AttributeStatement class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeStatement(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AttributeStatement(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AttributeStatement

Parameters

xmlElement
Type: System.XmlXmlElement
The attribute statement XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AttributeStatement Class
AttributeStatement Overload
ComponentSpace.SAML2.Assertions Namespace


AttributeStatement Properties

The AttributeStatement type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets the attributes.
Top
See Also

Reference

AttributeStatement Class
ComponentSpace.SAML2.Assertions Namespace


AttributeStatement.Attributes Property

AttributeStatementAttributes Property

Gets or sets the attributes.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList Attributes { get; set; }
Public Property Attributes As IList
    Get
    Set
public:
property IList^ Attributes {
    IList^ get ();
    void set (IList^ value);
}
member Attributes : IList with get, set

Property Value

Type: IList
The attributes.
See Also

Reference

AttributeStatement Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsSAMLAttribute
ComponentSpace.SAML2.AssertionsEncryptedAttribute


AttributeStatement Methods

The AttributeStatement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEncryptedAttributes | Returns all encrypted attributes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnencryptedAttributes | Returns all unencrypted attributes.
 | IsValid | Indicates whether the XML is an attribute statement.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the attribute statement to XML.
Top
See Also

Reference

AttributeStatement Class
ComponentSpace.SAML2.Assertions Namespace


AttributeStatement.GetEncryptedAttributes Method

AttributeStatementGetEncryptedAttributes Method

Returns all encrypted attributes.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EncryptedAttribute> GetEncryptedAttributes()
Public Function GetEncryptedAttributes As IList(Of EncryptedAttribute)
public:
IList<EncryptedAttribute^>^ GetEncryptedAttributes()
member GetEncryptedAttributes : unit -> IList<EncryptedAttribute>

Return Value

Type: IList EncryptedAttribute
The encrypted attributes.
See Also

Reference

AttributeStatement Class
ComponentSpace.SAML2.Assertions Namespace
AttributeStatementAttributes
ComponentSpace.SAML2.AssertionsEncryptedAttribute


AttributeStatement.GetUnencryptedAttributes Method

AttributeStatementGetUnencryptedAttributes Method

Returns all unencrypted attributes.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<SAMLAttribute> GetUnencryptedAttributes()
Public Function GetUnencryptedAttributes As IList(Of SAMLAttribute)
public:
IList<SAMLAttribute^>^ GetUnencryptedAttributes()
member GetUnencryptedAttributes : unit -> IList<SAMLAttribute>

Return Value

Type: IList SAMLAttribute
The unencrypted attributes.
See Also

Reference

AttributeStatement Class
ComponentSpace.SAML2.Assertions Namespace
AttributeStatementAttributes
SystemAttribute


AttributeStatement.IsValid Method

AttributeStatementIsValid Method

Indicates whether the XML is an attribute statement.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an attribute statement; otherwise false.
See Also

Reference

AttributeStatement Class
ComponentSpace.SAML2.Assertions Namespace


AttributeStatement.ToXml Method

AttributeStatementToXml Method

Serializes the attribute statement to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The attribute statement as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AttributeStatement Class
ComponentSpace.SAML2.Assertions Namespace


AttributeType Class

Represents the attribute type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAttributeType
ComponentSpace.SAML2.AssertionsSAMLAttribute
ComponentSpace.SAML2.MetadataRequestedAttribute

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AttributeType
Public Class AttributeType
public ref class AttributeType
type AttributeType =  class end

The AttributeType type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeType | Initializes a new instance of the AttributeType class.
Public method | AttributeType(XmlElement) | Initializes a new instance of the AttributeType class from XML.
Public method | AttributeType(String, String, String) | Initializes a new instance of the AttributeType class.
Public method | AttributeType(String, String, String, String) | Initializes a new instance of the AttributeType class.
Public method | AttributeType(String, String, String, String, Object) | Initializes a new instance of the AttributeType class.
Public method | AttributeType(String, String, String, String, String) | Initializes a new instance of the AttributeType class.
Top
Properties
 | Name | Description
Public property | FriendlyName | Gets or sets the attribute's friendly name.
Public property | Name | Gets or sets the attribute's name.
Public property | NameFormat | Gets or sets the attribute's name format.
Public property | Values | Gets or sets the attribute values.
Top
Methods
 | Name | Description
 | DeregisterAttributeValueSerializer | Deregisters an attribute value serializer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttributeValueSerializer | Gets the attribute value serializer for the specified attribute name and name format.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAttributeValueSerializerRegistered | Indicates whether the attribute value serializer is registered.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterAttributeValueSerializer | Registers an attribute value serializer for serializing attribute values to XML. Attribute value serializers are identified by attribute name and name format, both of which are optional. If an attribute name and name format are specified then the serializer matches on both. If an attribute name is not specified then the serializer matches on attribute name format. If an attribute name format is not specified then the serializer matches on attribute name. If neither an attribute name nor name format are specified then the serializer matches all. If there's no registered attribute value serializer then the default serializer is used and the attribute value is assumed to be a string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the attribute type to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AttributeType Constructor

Overload List
 | Name | Description
Public method | AttributeType | Initializes a new instance of the AttributeType class.
Public method | AttributeType(XmlElement) | Initializes a new instance of the AttributeType class from XML.
Public method | AttributeType(String, String, String) | Initializes a new instance of the AttributeType class.
Public method | AttributeType(String, String, String, String) | Initializes a new instance of the AttributeType class.
Public method | AttributeType(String, String, String, String, Object) | Initializes a new instance of the AttributeType class.
Public method | AttributeType(String, String, String, String, String) | Initializes a new instance of the AttributeType class.
Top
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace


AttributeType Constructor

Initializes a new instance of the AttributeType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeType()
Public Sub New
public:
AttributeType()
new : unit -> AttributeType
See Also

Reference

AttributeType Class
AttributeType Overload
ComponentSpace.SAML2.Assertions Namespace


AttributeType Constructor (XmlElement)

Initializes a new instance of the AttributeType class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AttributeType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AttributeType

Parameters

xmlElement
Type: System.XmlXmlElement
The attribute type XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AttributeType Class
AttributeType Overload
ComponentSpace.SAML2.Assertions Namespace


AttributeType Constructor (String, String, String)

Initializes a new instance of the AttributeType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeType(
    string name,
    string nameFormat,
    string friendlyName
)
Public Sub New (
    name As String,
    nameFormat As String,
    friendlyName As String
)
public:
AttributeType(
    String^ name,
    String^ nameFormat,
    String^ friendlyName
)
new :
        name : string *
        nameFormat : string *
        friendlyName : string -> AttributeType

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The name format.
friendlyName
Type: SystemString
The friendly name.
See Also

Reference

AttributeType Class
AttributeType Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAttributeNameFormats


AttributeType Constructor (String, String, String, String)

Initializes a new instance of the AttributeType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeType(
    string name,
    string nameFormat,
    string friendlyName,
    string attributeValue
)
Public Sub New (
    name As String,
    nameFormat As String,
    friendlyName As String,
    attributeValue As String
)
public:
AttributeType(
    String^ name,
    String^ nameFormat,
    String^ friendlyName,
    String^ attributeValue
)
new :
        name : string *
        nameFormat : string *
        friendlyName : string *
        attributeValue : string -> AttributeType

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The name format.
friendlyName
Type: SystemString
The friendly name.
attributeValue
Type: SystemString
The attribute value.
See Also

Reference

AttributeType Class
AttributeType Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAttributeNameFormats


AttributeType Constructor (String, String, String, String, Object)

Initializes a new instance of the AttributeType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeType(
    string name,
    string nameFormat,
    string friendlyName,
    string attributeType,
    Object attributeValue
)
Public Sub New (
    name As String,
    nameFormat As String,
    friendlyName As String,
    attributeType As String,
    attributeValue As Object
)
public:
AttributeType(
    String^ name,
    String^ nameFormat,
    String^ friendlyName,
    String^ attributeType,
    Object^ attributeValue
)
new :
        name : string *
        nameFormat : string *
        friendlyName : string *
        attributeType : string *
        attributeValue : Object -> AttributeType

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The name format.
friendlyName
Type: SystemString
The friendly name.
attributeType
Type: SystemString
The attribute type.
attributeValue
Type: SystemObject
The attribute value.
See Also

Reference

AttributeType Class
AttributeType Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAttributeNameFormats
ComponentSpace.SAML2.UtilityXmlSchemaSimpleTypes


AttributeType Constructor (String, String, String, String, String)

Initializes a new instance of the AttributeType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeType(
    string name,
    string nameFormat,
    string friendlyName,
    string attributeType,
    string attributeValue
)
Public Sub New (
    name As String,
    nameFormat As String,
    friendlyName As String,
    attributeType As String,
    attributeValue As String
)
public:
AttributeType(
    String^ name,
    String^ nameFormat,
    String^ friendlyName,
    String^ attributeType,
    String^ attributeValue
)
new :
        name : string *
        nameFormat : string *
        friendlyName : string *
        attributeType : string *
        attributeValue : string -> AttributeType

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The name format.
friendlyName
Type: SystemString
The friendly name.
attributeType
Type: SystemString
The attribute type.
attributeValue
Type: SystemString
The attribute value.
See Also

Reference

AttributeType Class
AttributeType Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAttributeNameFormats
ComponentSpace.SAML2.UtilityXmlSchemaSimpleTypes


AttributeType Properties

The AttributeType type exposes the following members.

Properties
 | Name | Description
Public property | FriendlyName | Gets or sets the attribute's friendly name.
Public property | Name | Gets or sets the attribute's name.
Public property | NameFormat | Gets or sets the attribute's name format.
Public property | Values | Gets or sets the attribute values.
Top
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace


AttributeType.FriendlyName Property

AttributeTypeFriendlyName Property

Gets or sets the attribute's friendly name.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string FriendlyName { get; set; }
Public Property FriendlyName As String
    Get
    Set
public:
property String^ FriendlyName {
    String^ get ();
    void set (String^ value);
}
member FriendlyName : string with get, set

Property Value

Type: String
The attribute's friendly name.
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace


AttributeType.Name Property

AttributeTypeName Property

Gets or sets the attribute's name.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The attribute's name.
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace


AttributeType.NameFormat Property

AttributeTypeNameFormat Property

Gets or sets the attribute's name format.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string NameFormat { get; set; }
Public Property NameFormat As String
    Get
    Set
public:
property String^ NameFormat {
    String^ get ();
    void set (String^ value);
}
member NameFormat : string with get, set

Property Value

Type: String
The attribute's name format.
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAttributeNameFormats


AttributeType.Values Property

AttributeTypeValues Property

Gets or sets the attribute values.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<AttributeValue> Values { get; set; }
Public Property Values As IList(Of AttributeValue)
    Get
    Set
public:
property IList<AttributeValue^>^ Values {
    IList<AttributeValue^>^ get ();
    void set (IList<AttributeValue^>^ value);
}
member Values : IList<AttributeValue> with get, set

Property Value

Type: IList AttributeValue
The attribute values.
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAttributeValue


AttributeType Methods

The AttributeType type exposes the following members.

Methods
 | Name | Description
 | DeregisterAttributeValueSerializer | Deregisters an attribute value serializer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttributeValueSerializer | Gets the attribute value serializer for the specified attribute name and name format.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAttributeValueSerializerRegistered | Indicates whether the attribute value serializer is registered.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterAttributeValueSerializer | Registers an attribute value serializer for serializing attribute values to XML. Attribute value serializers are identified by attribute name and name format, both of which are optional. If an attribute name and name format are specified then the serializer matches on both. If an attribute name is not specified then the serializer matches on attribute name format. If an attribute name format is not specified then the serializer matches on attribute name. If neither an attribute name nor name format are specified then the serializer matches all. If there's no registered attribute value serializer then the default serializer is used and the attribute value is assumed to be a string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the attribute type to XML.
Top
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace


AttributeType.DeregisterAttributeValueSerializer Method

AttributeTypeDeregisterAttributeValueSerializer Method

Deregisters an attribute value serializer.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void DeregisterAttributeValueSerializer(
    string name,
    string nameFormat
)
Public Shared Sub DeregisterAttributeValueSerializer (
    name As String,
    nameFormat As String
)
public:
static void DeregisterAttributeValueSerializer(
    String^ name,
    String^ nameFormat
)
static member DeregisterAttributeValueSerializer :
        name : string *
        nameFormat : string -> unit

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The attribute name format.
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace
AttributeTypeRegisterAttributeValueSerializer(String, String, IAttributeValueSerializer)


AttributeType.GetAttributeValueSerializer Method

AttributeTypeGetAttributeValueSerializer Method

Gets the attribute value serializer for the specified attribute name and name format.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IAttributeValueSerializer GetAttributeValueSerializer(
    string name,
    string nameFormat
)
Public Shared Function GetAttributeValueSerializer (
    name As String,
    nameFormat As String
) As IAttributeValueSerializer
public:
static IAttributeValueSerializer^ GetAttributeValueSerializer(
    String^ name,
    String^ nameFormat
)
static member GetAttributeValueSerializer :
        name : string *
        nameFormat : string -> IAttributeValueSerializer

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The attribute name format.

Return Value

Type: IAttributeValueSerializer
The attribute value serializer.
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace
AttributeTypeRegisterAttributeValueSerializer(String, String, IAttributeValueSerializer)


AttributeType.IsAttributeValueSerializerRegistered Method

AttributeTypeIsAttributeValueSerializerRegistered Method

Indicates whether the attribute value serializer is registered.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsAttributeValueSerializerRegistered(
    string name,
    string nameFormat
)
Public Shared Function IsAttributeValueSerializerRegistered (
    name As String,
    nameFormat As String
) As Boolean
public:
static bool IsAttributeValueSerializerRegistered(
    String^ name,
    String^ nameFormat
)
static member IsAttributeValueSerializerRegistered :
        name : string *
        nameFormat : string -> bool

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The attribute name format.

Return Value

Type: Boolean
true if the attribute value serializer is registered; otherwise false.
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace
AttributeTypeRegisterAttributeValueSerializer(String, String, IAttributeValueSerializer)
AttributeTypeDeregisterAttributeValueSerializer(String, String)


AttributeType.RegisterAttributeValueSerializer Method

AttributeTypeRegisterAttributeValueSerializer Method

Registers an attribute value serializer for serializing attribute values to XML. Attribute value serializers are identified by attribute name and name format, both of which are optional.

If an attribute name and name format are specified then the serializer matches on both. If an attribute name is not specified then the serializer matches on attribute name format. If an attribute name format is not specified then the serializer matches on attribute name. If neither an attribute name nor name format are specified then the serializer matches all.

If there's no registered attribute value serializer then the default serializer is used and the attribute value is assumed to be a string.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void RegisterAttributeValueSerializer(
    string name,
    string nameFormat,
    IAttributeValueSerializer attributeValueSerializer
)
Public Shared Sub RegisterAttributeValueSerializer (
    name As String,
    nameFormat As String,
    attributeValueSerializer As IAttributeValueSerializer
)
public:
static void RegisterAttributeValueSerializer(
    String^ name,
    String^ nameFormat,
    IAttributeValueSerializer^ attributeValueSerializer
)
static member RegisterAttributeValueSerializer :
        name : string *
        nameFormat : string *
        attributeValueSerializer : IAttributeValueSerializer -> unit

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The attribute name format.
attributeValueSerializer
Type: ComponentSpace.SAML2.AssertionsIAttributeValueSerializer
The attribute value serializer.
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace
AttributeTypeDeregisterAttributeValueSerializer(String, String)
ComponentSpace.SAML2.AssertionsStringAttributeValueSerializer
ComponentSpace.SAML2.AssertionsXmlAttributeValueSerializer


AttributeType.ToXml Method

AttributeTypeToXml Method

Serializes the attribute type to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void ToXml(
    XmlElement xmlElement
)
Public Sub ToXml (
    xmlElement As XmlElement
)
public:
void ToXml(
    XmlElement^ xmlElement
)
member ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AttributeType Class
ComponentSpace.SAML2.Assertions Namespace


AttributeValue Class

Represents a SAML attribute value.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAttributeValue

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AttributeValue
Public Class AttributeValue
public ref class AttributeValue
type AttributeValue =  class end

The AttributeValue type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeValue | Initializes a new instance of the AttributeValue class.
Public method | AttributeValue(Object) | Initializes a new instance of the AttributeValue class.
Public method | AttributeValue(String, Object) | Initializes a new instance of the AttributeValue class.
Public method | AttributeValue(XmlElement, IAttributeValueSerializer) | Initializes a new instance of the AttributeValue class from XML.
Public method | AttributeValue(IDictionaryString, String, String, Object) | Initializes a new instance of the AttributeValue class.
Top
Properties
 | Name | Description
Public property | Data | Gets or sets the attribute value data.
Public property | Type | Gets or sets the attribute value type.
Public property | XmlAttributes | Gets or sets the XML attributes keyed by named and containing the XML attribute values.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an attribute value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the attribute value. (Overrides ObjectToString.)
Public method | ToXml | Serializes the attribute value to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AttributeValue Constructor

Overload List
 | Name | Description
Public method | AttributeValue | Initializes a new instance of the AttributeValue class.
Public method | AttributeValue(Object) | Initializes a new instance of the AttributeValue class.
Public method | AttributeValue(String, Object) | Initializes a new instance of the AttributeValue class.
Public method | AttributeValue(XmlElement, IAttributeValueSerializer) | Initializes a new instance of the AttributeValue class from XML.
Public method | AttributeValue(IDictionaryString, String, String, Object) | Initializes a new instance of the AttributeValue class.
Top
See Also

Reference

AttributeValue Class
ComponentSpace.SAML2.Assertions Namespace


AttributeValue Constructor

Initializes a new instance of the AttributeValue class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeValue()
Public Sub New
public:
AttributeValue()
new : unit -> AttributeValue
See Also

Reference

AttributeValue Class
AttributeValue Overload
ComponentSpace.SAML2.Assertions Namespace


AttributeValue Constructor (Object)

Initializes a new instance of the AttributeValue class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeValue(
    Object data
)
Public Sub New (
    data As Object
)
public:
AttributeValue(
    Object^ data
)
new :
        data : Object -> AttributeValue

Parameters

data
Type: SystemObject
The attribute value data.
See Also

Reference

AttributeValue Class
AttributeValue Overload
ComponentSpace.SAML2.Assertions Namespace


AttributeValue Constructor (String, Object)

Initializes a new instance of the AttributeValue class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeValue(
    string type,
    Object data
)
Public Sub New (
    type As String,
    data As Object
)
public:
AttributeValue(
    String^ type,
    Object^ data
)
new :
        type : string *
        data : Object -> AttributeValue

Parameters

type
Type: SystemString
The attribute value type.
data
Type: SystemObject
The attribute value data.
See Also

Reference

AttributeValue Class
AttributeValue Overload
ComponentSpace.SAML2.Assertions Namespace


AttributeValue Constructor (XmlElement, IAttributeValueSerializer)

Initializes a new instance of the AttributeValue class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeValue(
    XmlElement xmlElement,
    IAttributeValueSerializer attributeValueSerializer
)
Public Sub New (
    xmlElement As XmlElement,
    attributeValueSerializer As IAttributeValueSerializer
)
public:
AttributeValue(
    XmlElement^ xmlElement,
    IAttributeValueSerializer^ attributeValueSerializer
)
new :
        xmlElement : XmlElement *
        attributeValueSerializer : IAttributeValueSerializer -> AttributeValue

Parameters

xmlElement
Type: System.XmlXmlElement
The attribute value XML.
attributeValueSerializer
Type: ComponentSpace.SAML2.AssertionsIAttributeValueSerializer
The attribute value serializer.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AttributeValue Class
AttributeValue Overload
ComponentSpace.SAML2.Assertions Namespace
AttributeTypeRegisterAttributeValueSerializer(String, String, IAttributeValueSerializer)
ComponentSpace.SAML2.AssertionsStringAttributeValueSerializer
ComponentSpace.SAML2.AssertionsXmlAttributeValueSerializer


AttributeValue Constructor (IDictionary(String, String), String, Object)

AttributeValue Constructor (IDictionaryString, String, String, Object)

Initializes a new instance of the AttributeValue class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeValue(
    IDictionary<string, string> xmlAttributes,
    string type,
    Object data
)
Public Sub New (
    xmlAttributes As IDictionary(Of String, String),
    type As String,
    data As Object
)
public:
AttributeValue(
    IDictionary<String^, String^>^ xmlAttributes,
    String^ type,
    Object^ data
)
new :
        xmlAttributes : IDictionary<string, string> *
        type : string *
        data : Object -> AttributeValue

Parameters

xmlAttributes
Type: System.Collections.GenericIDictionary String, String
The XML attributes keyed by named and containing the XML attribute values.
type
Type: SystemString
The attribute value type.
data
Type: SystemObject
The attribute value data.
See Also

Reference

AttributeValue Class
AttributeValue Overload
ComponentSpace.SAML2.Assertions Namespace


AttributeValue Properties

The AttributeValue type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets or sets the attribute value data.
Public property | Type | Gets or sets the attribute value type.
Public property | XmlAttributes | Gets or sets the XML attributes keyed by named and containing the XML attribute values.
Top
See Also

Reference

AttributeValue Class
ComponentSpace.SAML2.Assertions Namespace


AttributeValue.Data Property

AttributeValueData Property

Gets or sets the attribute value data.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Object Data { get; set; }
Public Property Data As Object
    Get
    Set
public:
property Object^ Data {
    Object^ get ();
    void set (Object^ value);
}
member Data : Object with get, set

Property Value

Type: Object
The attribute value data.
See Also

Reference

AttributeValue Class
ComponentSpace.SAML2.Assertions Namespace


AttributeValue.Type Property

AttributeValueType Property

Gets or sets the attribute value type.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
The attribute value type.
See Also

Reference

AttributeValue Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.UtilityXmlSchemaSimpleTypes


AttributeValue.XmlAttributes Property

AttributeValueXmlAttributes Property

Gets or sets the XML attributes keyed by named and containing the XML attribute values.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> XmlAttributes { get; set; }
Public Property XmlAttributes As IDictionary(Of String, String)
    Get
    Set
public:
property IDictionary<String^, String^>^ XmlAttributes {
    IDictionary<String^, String^>^ get ();
    void set (IDictionary<String^, String^>^ value);
}
member XmlAttributes : IDictionary<string, string> with get, set

Property Value

Type: IDictionary String, String
The XML attributes keyed by named and containing the XML attribute values.
See Also

Reference

AttributeValue Class
ComponentSpace.SAML2.Assertions Namespace


AttributeValue Methods

The AttributeValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an attribute value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the attribute value. (Overrides ObjectToString.)
Public method | ToXml | Serializes the attribute value to XML.
Top
See Also

Reference

AttributeValue Class
ComponentSpace.SAML2.Assertions Namespace


AttributeValue.IsValid Method

AttributeValueIsValid Method

Indicates whether the XML is an attribute value.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an attribute value; otherwise false.
See Also

Reference

AttributeValue Class
ComponentSpace.SAML2.Assertions Namespace


AttributeValue.ToString Method

AttributeValueToString Method

Returns the attribute value.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The attribute value
See Also

Reference

AttributeValue Class
ComponentSpace.SAML2.Assertions Namespace


AttributeValue.ToXml Method

AttributeValueToXml Method

Serializes the attribute value to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument,
    IAttributeValueSerializer attributeValueSerializer
)
Public Function ToXml (
    xmlDocument As XmlDocument,
    attributeValueSerializer As IAttributeValueSerializer
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument,
    IAttributeValueSerializer^ attributeValueSerializer
)
member ToXml :
        xmlDocument : XmlDocument *
        attributeValueSerializer : IAttributeValueSerializer -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.
attributeValueSerializer
Type: ComponentSpace.SAML2.AssertionsIAttributeValueSerializer
The attribute value serializer.

Return Value

Type: XmlElement
The attribute value as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AttributeValue Class
ComponentSpace.SAML2.Assertions Namespace
AttributeTypeRegisterAttributeValueSerializer(String, String, IAttributeValueSerializer)
ComponentSpace.SAML2.AssertionsStringAttributeValueSerializer
ComponentSpace.SAML2.AssertionsXmlAttributeValueSerializer


Audience Class

Represents an audience.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAudience

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Audience
Public Class Audience
public ref class Audience
type Audience =  class end

The Audience type exposes the following members.

Constructors
 | Name | Description
Public method | Audience | Initializes a new instance of the Audience class.
Public method | Audience(String) | Initializes a new instance of the Audience class.
Public method | Audience(XmlElement) | Initializes a new instance of the Audience class from XML.
Top
Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an audience.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the audience to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


Audience Constructor

Overload List
 | Name | Description
Public method | Audience | Initializes a new instance of the Audience class.
Public method | Audience(String) | Initializes a new instance of the Audience class.
Public method | Audience(XmlElement) | Initializes a new instance of the Audience class from XML.
Top
See Also

Reference

Audience Class
ComponentSpace.SAML2.Assertions Namespace


Audience Constructor

Initializes a new instance of the Audience class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Audience()
Public Sub New
public:
Audience()
new : unit -> Audience
See Also

Reference

Audience Class
Audience Overload
ComponentSpace.SAML2.Assertions Namespace


Audience Constructor (String)

Initializes a new instance of the Audience class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Audience(
    string uri
)
Public Sub New (
    uri As String
)
public:
Audience(
    String^ uri
)
new :
        uri : string -> Audience

Parameters

uri
Type: SystemString
The URI.
See Also

Reference

Audience Class
Audience Overload
ComponentSpace.SAML2.Assertions Namespace


Audience Constructor (XmlElement)

Initializes a new instance of the Audience class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Audience(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Audience(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Audience

Parameters

xmlElement
Type: System.XmlXmlElement
The audience XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Audience Class
Audience Overload
ComponentSpace.SAML2.Assertions Namespace


Audience Properties

The Audience type exposes the following members.

Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
See Also

Reference

Audience Class
ComponentSpace.SAML2.Assertions Namespace


Audience.URI Property

AudienceURI Property

Gets or sets the URI.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string URI { get; set; }
Public Property URI As String
    Get
    Set
public:
property String^ URI {
    String^ get ();
    void set (String^ value);
}
member URI : string with get, set

Property Value

Type: String
The URI.
See Also

Reference

Audience Class
ComponentSpace.SAML2.Assertions Namespace


Audience Methods

The Audience type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an audience.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the audience to XML.
Top
See Also

Reference

Audience Class
ComponentSpace.SAML2.Assertions Namespace


Audience.IsValid Method

AudienceIsValid Method

Indicates whether the XML is an audience.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an Audience; otherwise false.
See Also

Reference

Audience Class
ComponentSpace.SAML2.Assertions Namespace


Audience.ToXml Method

AudienceToXml Method

Serializes the audience to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The audience as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Audience Class
ComponentSpace.SAML2.Assertions Namespace


AudienceRestriction Class

Represents an audience restriction.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAudienceRestriction

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AudienceRestriction : ICondition
Public Class AudienceRestriction
    Implements ICondition
public ref class AudienceRestriction : ICondition
type AudienceRestriction =
    class
        interface ICondition
    end

The AudienceRestriction type exposes the following members.

Constructors
 | Name | Description
Public method | AudienceRestriction | Initializes a new instance of the AudienceRestriction class.
Public method | AudienceRestriction(XmlElement) | Initializes a new instance of the AudienceRestriction class from XML.
Top
Properties
 | Name | Description
Public property | Audiences | Gets or sets the audiences.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an audience restriction.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the audience restriction to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AudienceRestriction Constructor

Overload List
 | Name | Description
Public method | AudienceRestriction | Initializes a new instance of the AudienceRestriction class.
Public method | AudienceRestriction(XmlElement) | Initializes a new instance of the AudienceRestriction class from XML.
Top
See Also

Reference

AudienceRestriction Class
ComponentSpace.SAML2.Assertions Namespace


AudienceRestriction Constructor

Initializes a new instance of the AudienceRestriction class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AudienceRestriction()
Public Sub New
public:
AudienceRestriction()
new : unit -> AudienceRestriction
See Also

Reference

AudienceRestriction Class
AudienceRestriction Overload
ComponentSpace.SAML2.Assertions Namespace


AudienceRestriction Constructor (XmlElement)

Initializes a new instance of the AudienceRestriction class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AudienceRestriction(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AudienceRestriction(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AudienceRestriction

Parameters

xmlElement
Type: System.XmlXmlElement
The audience restriction XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AudienceRestriction Class
AudienceRestriction Overload
ComponentSpace.SAML2.Assertions Namespace


AudienceRestriction Properties

The AudienceRestriction type exposes the following members.

Properties
 | Name | Description
Public property | Audiences | Gets or sets the audiences.
Top
See Also

Reference

AudienceRestriction Class
ComponentSpace.SAML2.Assertions Namespace


AudienceRestriction.Audiences Property

AudienceRestrictionAudiences Property

Gets or sets the audiences.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<Audience> Audiences { get; set; }
Public Property Audiences As IList(Of Audience)
    Get
    Set
public:
property IList<Audience^>^ Audiences {
    IList<Audience^>^ get ();
    void set (IList<Audience^>^ value);
}
member Audiences : IList<Audience> with get, set

Property Value

Type: IList Audience
The audiences.
See Also

Reference

AudienceRestriction Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAudience


AudienceRestriction Methods

The AudienceRestriction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an audience restriction.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the audience restriction to XML.
Top
See Also

Reference

AudienceRestriction Class
ComponentSpace.SAML2.Assertions Namespace


AudienceRestriction.IsValid Method

AudienceRestrictionIsValid Method

Indicates whether the XML is an audience restriction.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an audience restriction; otherwise false.
See Also

Reference

AudienceRestriction Class
ComponentSpace.SAML2.Assertions Namespace


AudienceRestriction.ToXml Method

AudienceRestrictionToXml Method

Serializes the audience restriction to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The audience restriction as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AudienceRestriction Class
ComponentSpace.SAML2.Assertions Namespace


AuthenticatingAuthority Class

Represents an authenticating authority.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAuthenticatingAuthority

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthenticatingAuthority
Public Class AuthenticatingAuthority
public ref class AuthenticatingAuthority
type AuthenticatingAuthority =  class end

The AuthenticatingAuthority type exposes the following members.

Constructors
 | Name | Description
Public method | AuthenticatingAuthority | Initializes a new instance of the AuthenticatingAuthority class.
Public method | AuthenticatingAuthority(String) | Initializes a new instance of the AuthenticatingAuthority class.
Public method | AuthenticatingAuthority(XmlElement) | Initializes a new instance of the AuthenticatingAuthority class from XML.
Top
Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authenticating authority.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authenticating authority to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AuthenticatingAuthority Constructor

Overload List
 | Name | Description
Public method | AuthenticatingAuthority | Initializes a new instance of the AuthenticatingAuthority class.
Public method | AuthenticatingAuthority(String) | Initializes a new instance of the AuthenticatingAuthority class.
Public method | AuthenticatingAuthority(XmlElement) | Initializes a new instance of the AuthenticatingAuthority class from XML.
Top
See Also

Reference

AuthenticatingAuthority Class
ComponentSpace.SAML2.Assertions Namespace


AuthenticatingAuthority Constructor

Initializes a new instance of the AuthenticatingAuthority class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthenticatingAuthority()
Public Sub New
public:
AuthenticatingAuthority()
new : unit -> AuthenticatingAuthority
See Also

Reference

AuthenticatingAuthority Class
AuthenticatingAuthority Overload
ComponentSpace.SAML2.Assertions Namespace


AuthenticatingAuthority Constructor (String)

Initializes a new instance of the AuthenticatingAuthority class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthenticatingAuthority(
    string uri
)
Public Sub New (
    uri As String
)
public:
AuthenticatingAuthority(
    String^ uri
)
new :
        uri : string -> AuthenticatingAuthority

Parameters

uri
Type: SystemString
The URI.
See Also

Reference

AuthenticatingAuthority Class
AuthenticatingAuthority Overload
ComponentSpace.SAML2.Assertions Namespace


AuthenticatingAuthority Constructor (XmlElement)

Initializes a new instance of the AuthenticatingAuthority class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthenticatingAuthority(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthenticatingAuthority(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthenticatingAuthority

Parameters

xmlElement
Type: System.XmlXmlElement
The authenticating authority XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthenticatingAuthority Class
AuthenticatingAuthority Overload
ComponentSpace.SAML2.Assertions Namespace


AuthenticatingAuthority Properties

The AuthenticatingAuthority type exposes the following members.

Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
See Also

Reference

AuthenticatingAuthority Class
ComponentSpace.SAML2.Assertions Namespace


AuthenticatingAuthority.URI Property

AuthenticatingAuthorityURI Property

Gets or sets the URI.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string URI { get; set; }
Public Property URI As String
    Get
    Set
public:
property String^ URI {
    String^ get ();
    void set (String^ value);
}
member URI : string with get, set

Property Value

Type: String
The URI.
See Also

Reference

AuthenticatingAuthority Class
ComponentSpace.SAML2.Assertions Namespace


AuthenticatingAuthority Methods

The AuthenticatingAuthority type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authenticating authority.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authenticating authority to XML.
Top
See Also

Reference

AuthenticatingAuthority Class
ComponentSpace.SAML2.Assertions Namespace


AuthenticatingAuthority.IsValid Method

AuthenticatingAuthorityIsValid Method

Indicates whether the XML is an authenticating authority.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an AuthenticatingAuthority; otherwise false.
See Also

Reference

AuthenticatingAuthority Class
ComponentSpace.SAML2.Assertions Namespace


AuthenticatingAuthority.ToXml Method

AuthenticatingAuthorityToXml Method

Serializes the authenticating authority to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authenticating authority as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthenticatingAuthority Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContext Class

Represents an authentication context.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAuthnContext

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthnContext
Public Class AuthnContext
public ref class AuthnContext
type AuthnContext =  class end

The AuthnContext type exposes the following members.

Constructors
 | Name | Description
Public method | AuthnContext | Initializes a new instance of the AuthnContext class.
Public method | AuthnContext(XmlElement) | Initializes a new instance of the AuthnContext class from XML.
Top
Properties
 | Name | Description
Public property | AuthenticatingAuthorities | Gets or sets the authenticating authorities.
Public property | AuthnContextClassRef | Gets or sets the authentication context class reference.
Public property | AuthnContextDecl | Gets or sets the authentication context declaration.
Public property | AuthnContextDeclRef | Gets or sets the authentication context declaration reference.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication context.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authentication context to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AuthnContext Constructor

Overload List
 | Name | Description
Public method | AuthnContext | Initializes a new instance of the AuthnContext class.
Public method | AuthnContext(XmlElement) | Initializes a new instance of the AuthnContext class from XML.
Top
See Also

Reference

AuthnContext Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContext Constructor

Initializes a new instance of the AuthnContext class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContext()
Public Sub New
public:
AuthnContext()
new : unit -> AuthnContext
See Also

Reference

AuthnContext Class
AuthnContext Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnContext Constructor (XmlElement)

Initializes a new instance of the AuthnContext class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContext(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthnContext(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthnContext

Parameters

xmlElement
Type: System.XmlXmlElement
The authentication context XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthnContext Class
AuthnContext Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnContext Properties

The AuthnContext type exposes the following members.

Properties
 | Name | Description
Public property | AuthenticatingAuthorities | Gets or sets the authenticating authorities.
Public property | AuthnContextClassRef | Gets or sets the authentication context class reference.
Public property | AuthnContextDecl | Gets or sets the authentication context declaration.
Public property | AuthnContextDeclRef | Gets or sets the authentication context declaration reference.
Top
See Also

Reference

AuthnContext Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContext.AuthenticatingAuthorities Property

AuthnContextAuthenticatingAuthorities Property

Gets or sets the authenticating authorities.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<AuthenticatingAuthority> AuthenticatingAuthorities { get; set; }
Public Property AuthenticatingAuthorities As IList(Of AuthenticatingAuthority)
    Get
    Set
public:
property IList<AuthenticatingAuthority^>^ AuthenticatingAuthorities {
    IList<AuthenticatingAuthority^>^ get ();
    void set (IList<AuthenticatingAuthority^>^ value);
}
member AuthenticatingAuthorities : IList<AuthenticatingAuthority> with get, set

Property Value

Type: IList AuthenticatingAuthority
The authenticating authorities.
See Also

Reference

AuthnContext Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContext.AuthnContextClassRef Property

AuthnContextAuthnContextClassRef Property

Gets or sets the authentication context class reference.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextClassRef AuthnContextClassRef { get; set; }
Public Property AuthnContextClassRef As AuthnContextClassRef
    Get
    Set
public:
property AuthnContextClassRef^ AuthnContextClassRef {
    AuthnContextClassRef^ get ();
    void set (AuthnContextClassRef^ value);
}
member AuthnContextClassRef : AuthnContextClassRef with get, set

Property Value

Type: AuthnContextClassRef
The authentication context class reference.
See Also

Reference

AuthnContext Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContext.AuthnContextDecl Property

AuthnContextAuthnContextDecl Property

Gets or sets the authentication context declaration.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextDecl AuthnContextDecl { get; set; }
Public Property AuthnContextDecl As AuthnContextDecl
    Get
    Set
public:
property AuthnContextDecl^ AuthnContextDecl {
    AuthnContextDecl^ get ();
    void set (AuthnContextDecl^ value);
}
member AuthnContextDecl : AuthnContextDecl with get, set

Property Value

Type: AuthnContextDecl
The authentication context class declaration.
See Also

Reference

AuthnContext Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContext.AuthnContextDeclRef Property

AuthnContextAuthnContextDeclRef Property

Gets or sets the authentication context declaration reference.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextDeclRef AuthnContextDeclRef { get; set; }
Public Property AuthnContextDeclRef As AuthnContextDeclRef
    Get
    Set
public:
property AuthnContextDeclRef^ AuthnContextDeclRef {
    AuthnContextDeclRef^ get ();
    void set (AuthnContextDeclRef^ value);
}
member AuthnContextDeclRef : AuthnContextDeclRef with get, set

Property Value

Type: AuthnContextDeclRef
The authentication context declaration reference.
See Also

Reference

AuthnContext Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContext Methods

The AuthnContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication context.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authentication context to XML.
Top
See Also

Reference

AuthnContext Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContext.IsValid Method

AuthnContextIsValid Method

Indicates whether the XML is an authentication context.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an authentication context; otherwise false.
See Also

Reference

AuthnContext Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContext.ToXml Method

AuthnContextToXml Method

Serializes the authentication context to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authentication context as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthnContext Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextClassRef Class

Represents an authentication context class reference.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAuthnContextClassRef

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthnContextClassRef
Public Class AuthnContextClassRef
public ref class AuthnContextClassRef
type AuthnContextClassRef =  class end

The AuthnContextClassRef type exposes the following members.

Constructors
 | Name | Description
Public method | AuthnContextClassRef | Initializes a new instance of the AuthnContextClassRef class.
Public method | AuthnContextClassRef(String) | Initializes a new instance of the AuthnContextClassRef class.
Public method | AuthnContextClassRef(XmlElement) | Initializes a new instance of the AuthnContextClassRef class from XML.
Top
Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication context class reference.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authentication context class reference to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AuthnContextClassRef Constructor

Overload List
 | Name | Description
Public method | AuthnContextClassRef | Initializes a new instance of the AuthnContextClassRef class.
Public method | AuthnContextClassRef(String) | Initializes a new instance of the AuthnContextClassRef class.
Public method | AuthnContextClassRef(XmlElement) | Initializes a new instance of the AuthnContextClassRef class from XML.
Top
See Also

Reference

AuthnContextClassRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextClassRef Constructor

Initializes a new instance of the AuthnContextClassRef class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextClassRef()
Public Sub New
public:
AuthnContextClassRef()
new : unit -> AuthnContextClassRef
See Also

Reference

AuthnContextClassRef Class
AuthnContextClassRef Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnContextClassRef Constructor (String)

Initializes a new instance of the AuthnContextClassRef class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextClassRef(
    string uri
)
Public Sub New (
    uri As String
)
public:
AuthnContextClassRef(
    String^ uri
)
new :
        uri : string -> AuthnContextClassRef

Parameters

uri
Type: SystemString
The URI.
See Also

Reference

AuthnContextClassRef Class
AuthnContextClassRef Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAuthnContextClasses


AuthnContextClassRef Constructor (XmlElement)

Initializes a new instance of the AuthnContextClassRef class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextClassRef(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthnContextClassRef(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthnContextClassRef

Parameters

xmlElement
Type: System.XmlXmlElement
The authentication context class reference XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthnContextClassRef Class
AuthnContextClassRef Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnContextClassRef Properties

The AuthnContextClassRef type exposes the following members.

Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
See Also

Reference

AuthnContextClassRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextClassRef.URI Property

AuthnContextClassRefURI Property

Gets or sets the URI.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string URI { get; set; }
Public Property URI As String
    Get
    Set
public:
property String^ URI {
    String^ get ();
    void set (String^ value);
}
member URI : string with get, set

Property Value

Type: String
The URI.
See Also

Reference

AuthnContextClassRef Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAuthnContextClasses


AuthnContextClassRef Methods

The AuthnContextClassRef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication context class reference.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authentication context class reference to XML.
Top
See Also

Reference

AuthnContextClassRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextClassRef.IsValid Method

AuthnContextClassRefIsValid Method

Indicates whether the XML is an authentication context class reference.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an AuthnContextClassRef; otherwise false.
See Also

Reference

AuthnContextClassRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextClassRef.ToXml Method

AuthnContextClassRefToXml Method

Serializes the authentication context class reference to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authentication context class reference as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthnContextClassRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDecl Class

Represents an authentication context declaration.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAuthnContextDecl

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthnContextDecl
Public Class AuthnContextDecl
public ref class AuthnContextDecl
type AuthnContextDecl =  class end

The AuthnContextDecl type exposes the following members.

Constructors
 | Name | Description
Public method | AuthnContextDecl | Initializes a new instance of the AuthnContextDecl class.
Public method | AuthnContextDecl(XmlElement) | Initializes a new instance of the AuthnContextDecl class from XML.
Public method | AuthnContextDecl(XmlNodeList) | Initializes a new instance of the AuthnContextDecl class.
Top
Properties
 | Name | Description
Public property | Declaration | Gets or sets the declaration.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication context declaration.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authentication context declaration to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AuthnContextDecl Constructor

Overload List
 | Name | Description
Public method | AuthnContextDecl | Initializes a new instance of the AuthnContextDecl class.
Public method | AuthnContextDecl(XmlElement) | Initializes a new instance of the AuthnContextDecl class from XML.
Public method | AuthnContextDecl(XmlNodeList) | Initializes a new instance of the AuthnContextDecl class.
Top
See Also

Reference

AuthnContextDecl Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDecl Constructor

Initializes a new instance of the AuthnContextDecl class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextDecl()
Public Sub New
public:
AuthnContextDecl()
new : unit -> AuthnContextDecl
See Also

Reference

AuthnContextDecl Class
AuthnContextDecl Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDecl Constructor (XmlElement)

Initializes a new instance of the AuthnContextDecl class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextDecl(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthnContextDecl(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthnContextDecl

Parameters

xmlElement
Type: System.XmlXmlElement
The authentication context declaration XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthnContextDecl Class
AuthnContextDecl Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDecl Constructor (XmlNodeList)

Initializes a new instance of the AuthnContextDecl class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextDecl(
    XmlNodeList declaration
)
Public Sub New (
    declaration As XmlNodeList
)
public:
AuthnContextDecl(
    XmlNodeList^ declaration
)
new :
        declaration : XmlNodeList -> AuthnContextDecl

Parameters

declaration
Type: System.XmlXmlNodeList
The authentication context declaration.
See Also

Reference

AuthnContextDecl Class
AuthnContextDecl Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDecl Properties

The AuthnContextDecl type exposes the following members.

Properties
 | Name | Description
Public property | Declaration | Gets or sets the declaration.
Top
See Also

Reference

AuthnContextDecl Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDecl.Declaration Property

AuthnContextDeclDeclaration Property

Gets or sets the declaration.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlNodeList Declaration { get; set; }
Public Property Declaration As XmlNodeList
    Get
    Set
public:
property XmlNodeList^ Declaration {
    XmlNodeList^ get ();
    void set (XmlNodeList^ value);
}
member Declaration : XmlNodeList with get, set

Property Value

Type: XmlNodeList
The declaration.
See Also

Reference

AuthnContextDecl Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDecl Methods

The AuthnContextDecl type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication context declaration.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authentication context declaration to XML.
Top
See Also

Reference

AuthnContextDecl Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDecl.IsValid Method

AuthnContextDeclIsValid Method

Indicates whether the XML is an authentication context declaration.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an authentication context declaration; otherwise false.
See Also

Reference

AuthnContextDecl Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDecl.ToXml Method

AuthnContextDeclToXml Method

Serializes the authentication context declaration to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authentication context declaration as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthnContextDecl Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDeclRef Class

Represents an authentication context declaration reference.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAuthnContextDeclRef

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthnContextDeclRef
Public Class AuthnContextDeclRef
public ref class AuthnContextDeclRef
type AuthnContextDeclRef =  class end

The AuthnContextDeclRef type exposes the following members.

Constructors
 | Name | Description
Public method | AuthnContextDeclRef | Initializes a new instance of the AuthnContextDeclRef class.
Public method | AuthnContextDeclRef(String) | Initializes a new instance of the AuthnContextDeclRef class.
Public method | AuthnContextDeclRef(XmlElement) | Initializes a new instance of the AuthnContextDeclRef class from XML.
Top
Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication context declaration reference.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authentication context declaration reference to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AuthnContextDeclRef Constructor

Overload List
 | Name | Description
Public method | AuthnContextDeclRef | Initializes a new instance of the AuthnContextDeclRef class.
Public method | AuthnContextDeclRef(String) | Initializes a new instance of the AuthnContextDeclRef class.
Public method | AuthnContextDeclRef(XmlElement) | Initializes a new instance of the AuthnContextDeclRef class from XML.
Top
See Also

Reference

AuthnContextDeclRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDeclRef Constructor

Initializes a new instance of the AuthnContextDeclRef class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextDeclRef()
Public Sub New
public:
AuthnContextDeclRef()
new : unit -> AuthnContextDeclRef
See Also

Reference

AuthnContextDeclRef Class
AuthnContextDeclRef Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDeclRef Constructor (String)

Initializes a new instance of the AuthnContextDeclRef class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextDeclRef(
    string uri
)
Public Sub New (
    uri As String
)
public:
AuthnContextDeclRef(
    String^ uri
)
new :
        uri : string -> AuthnContextDeclRef

Parameters

uri
Type: SystemString
The URI.
See Also

Reference

AuthnContextDeclRef Class
AuthnContextDeclRef Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDeclRef Constructor (XmlElement)

Initializes a new instance of the AuthnContextDeclRef class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContextDeclRef(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthnContextDeclRef(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthnContextDeclRef

Parameters

xmlElement
Type: System.XmlXmlElement
The authentication context declaration reference XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthnContextDeclRef Class
AuthnContextDeclRef Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDeclRef Properties

The AuthnContextDeclRef type exposes the following members.

Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
See Also

Reference

AuthnContextDeclRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDeclRef.URI Property

AuthnContextDeclRefURI Property

Gets or sets the URI.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string URI { get; set; }
Public Property URI As String
    Get
    Set
public:
property String^ URI {
    String^ get ();
    void set (String^ value);
}
member URI : string with get, set

Property Value

Type: String
The URI.
See Also

Reference

AuthnContextDeclRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDeclRef Methods

The AuthnContextDeclRef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication context declaration reference.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authentication context declaration reference to XML.
Top
See Also

Reference

AuthnContextDeclRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDeclRef.IsValid Method

AuthnContextDeclRefIsValid Method

Indicates whether the XML is an authentication context declaration reference.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an AuthnContextDeclRef; otherwise false.
See Also

Reference

AuthnContextDeclRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnContextDeclRef.ToXml Method

AuthnContextDeclRefToXml Method

Serializes the authentication context declaration reference to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authentication context declaration reference as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthnContextDeclRef Class
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement Class

Represents an authentication statement.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAuthnStatement

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthnStatement : IStatement
Public Class AuthnStatement
    Implements IStatement
public ref class AuthnStatement : IStatement
type AuthnStatement =
    class
        interface IStatement
    end

The AuthnStatement type exposes the following members.

Constructors
 | Name | Description
Public method | AuthnStatement | Initializes a new instance of the AuthnStatement class.
Public method | AuthnStatement(XmlElement) | Initializes a new instance of the AuthnStatement class from XML.
Top
Properties
 | Name | Description
Public property | AuthnContext | Gets or sets the authentication context.
Public property | AuthnInstant | Gets or sets the authentication instant.
Public property | SessionIndex | Gets or sets the session index.
Public property | SessionNotOnOrAfter | Gets or sets the session not on or after time.
Public property | SubjectLocality | Gets or sets the subject locality.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication statement.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authentication statement to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AuthnStatement Constructor

Overload List
 | Name | Description
Public method | AuthnStatement | Initializes a new instance of the AuthnStatement class.
Public method | AuthnStatement(XmlElement) | Initializes a new instance of the AuthnStatement class from XML.
Top
See Also

Reference

AuthnStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement Constructor

Initializes a new instance of the AuthnStatement class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnStatement()
Public Sub New
public:
AuthnStatement()
new : unit -> AuthnStatement
Remarks
The authentication statement is initialized with an authentication instant of now.
See Also

Reference

AuthnStatement Class
AuthnStatement Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement Constructor (XmlElement)

Initializes a new instance of the AuthnStatement class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnStatement(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthnStatement(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthnStatement

Parameters

xmlElement
Type: System.XmlXmlElement
The authentication statement XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthnStatement Class
AuthnStatement Overload
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement Properties

The AuthnStatement type exposes the following members.

Properties
 | Name | Description
Public property | AuthnContext | Gets or sets the authentication context.
Public property | AuthnInstant | Gets or sets the authentication instant.
Public property | SessionIndex | Gets or sets the session index.
Public property | SessionNotOnOrAfter | Gets or sets the session not on or after time.
Public property | SubjectLocality | Gets or sets the subject locality.
Top
See Also

Reference

AuthnStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement.AuthnContext Property

AuthnStatementAuthnContext Property

Gets or sets the authentication context.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnContext AuthnContext { get; set; }
Public Property AuthnContext As AuthnContext
    Get
    Set
public:
property AuthnContext^ AuthnContext {
    AuthnContext^ get ();
    void set (AuthnContext^ value);
}
member AuthnContext : AuthnContext with get, set

Property Value

Type: AuthnContext
The authentication context.
See Also

Reference

AuthnStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement.AuthnInstant Property

AuthnStatementAuthnInstant Property

Gets or sets the authentication instant.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime AuthnInstant { get; set; }
Public Property AuthnInstant As DateTime
    Get
    Set
public:
property DateTime AuthnInstant {
    DateTime get ();
    void set (DateTime value);
}
member AuthnInstant : DateTime with get, set

Property Value

Type: DateTime
The authentication instant as coordinated universal time (UTC). A value of DateTime.MinValue indicates the value has not been set.
See Also

Reference

AuthnStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement.SessionIndex Property

AuthnStatementSessionIndex Property

Gets or sets the session index.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SessionIndex { get; set; }
Public Property SessionIndex As String
    Get
    Set
public:
property String^ SessionIndex {
    String^ get ();
    void set (String^ value);
}
member SessionIndex : string with get, set

Property Value

Type: String
The session index.
See Also

Reference

AuthnStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement.SessionNotOnOrAfter Property

AuthnStatementSessionNotOnOrAfter Property

Gets or sets the session not on or after time.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime SessionNotOnOrAfter { get; set; }
Public Property SessionNotOnOrAfter As DateTime
    Get
    Set
public:
property DateTime SessionNotOnOrAfter {
    DateTime get ();
    void set (DateTime value);
}
member SessionNotOnOrAfter : DateTime with get, set

Property Value

Type: DateTime
The session not on or after time as coordinated universal time (UTC). A value of DateTime.MaxValue indicates the value has not been set.
See Also

Reference

AuthnStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement.SubjectLocality Property

AuthnStatementSubjectLocality Property

Gets or sets the subject locality.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectLocality SubjectLocality { get; set; }
Public Property SubjectLocality As SubjectLocality
    Get
    Set
public:
property SubjectLocality^ SubjectLocality {
    SubjectLocality^ get ();
    void set (SubjectLocality^ value);
}
member SubjectLocality : SubjectLocality with get, set

Property Value

Type: SubjectLocality
The subject locality.
See Also

Reference

AuthnStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement Methods

The AuthnStatement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication statement.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authentication statement to XML.
Top
See Also

Reference

AuthnStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement.IsValid Method

AuthnStatementIsValid Method

Indicates whether the XML is an authentication statement.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an authentication statement; otherwise false.
See Also

Reference

AuthnStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthnStatement.ToXml Method

AuthnStatementToXml Method

Serializes the authentication statement to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authentication statement as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthnStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthzDecisionStatement Class

Represents an authorization decision statement.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAuthzDecisionStatement

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthzDecisionStatement : IStatement
Public Class AuthzDecisionStatement
    Implements IStatement
public ref class AuthzDecisionStatement : IStatement
type AuthzDecisionStatement =
    class
        interface IStatement
    end

The AuthzDecisionStatement type exposes the following members.

Constructors
 | Name | Description
Public method | AuthzDecisionStatement | Initializes a new instance of the AuthzDecisionStatement class.
Public method | AuthzDecisionStatement(XmlElement) | Initializes a new instance of the AuthzDecisionStatement class from XML.
Top
Properties
 | Name | Description
Public property | Actions | Gets or sets the actions.
Public property | Decision | Gets or sets the decision.
Public property | Evidence | Gets or sets the evidence.
Public property | Resource | Gets or sets the resource.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authorization decision statement.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authorization decision statement to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


AuthzDecisionStatement Constructor

Overload List
 | Name | Description
Public method | AuthzDecisionStatement | Initializes a new instance of the AuthzDecisionStatement class.
Public method | AuthzDecisionStatement(XmlElement) | Initializes a new instance of the AuthzDecisionStatement class from XML.
Top
See Also

Reference

AuthzDecisionStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthzDecisionStatement Constructor

Initializes a new instance of the AuthzDecisionStatement class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthzDecisionStatement()
Public Sub New
public:
AuthzDecisionStatement()
new : unit -> AuthzDecisionStatement
See Also

Reference

AuthzDecisionStatement Class
AuthzDecisionStatement Overload
ComponentSpace.SAML2.Assertions Namespace


AuthzDecisionStatement Constructor (XmlElement)

Initializes a new instance of the AuthzDecisionStatement class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthzDecisionStatement(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthzDecisionStatement(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthzDecisionStatement

Parameters

xmlElement
Type: System.XmlXmlElement
The authorization decision statement XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthzDecisionStatement Class
AuthzDecisionStatement Overload
ComponentSpace.SAML2.Assertions Namespace


AuthzDecisionStatement Properties

The AuthzDecisionStatement type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Gets or sets the actions.
Public property | Decision | Gets or sets the decision.
Public property | Evidence | Gets or sets the evidence.
Public property | Resource | Gets or sets the resource.
Top
See Also

Reference

AuthzDecisionStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthzDecisionStatement.Actions Property

AuthzDecisionStatementActions Property

Gets or sets the actions.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<Action> Actions { get; set; }
Public Property Actions As IList(Of Action)
    Get
    Set
public:
property IList<Action^>^ Actions {
    IList<Action^>^ get ();
    void set (IList<Action^>^ value);
}
member Actions : IList<Action> with get, set

Property Value

Type: IList Action
The actions.
See Also

Reference

AuthzDecisionStatement Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAction


AuthzDecisionStatement.Decision Property

AuthzDecisionStatementDecision Property

Gets or sets the decision.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Decision { get; set; }
Public Property Decision As String
    Get
    Set
public:
property String^ Decision {
    String^ get ();
    void set (String^ value);
}
member Decision : string with get, set

Property Value

Type: String
The decision.
See Also

Reference

AuthzDecisionStatement Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAuthzDecision


AuthzDecisionStatement.Evidence Property

AuthzDecisionStatementEvidence Property

Gets or sets the evidence.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Evidence Evidence { get; set; }
Public Property Evidence As Evidence
    Get
    Set
public:
property Evidence^ Evidence {
    Evidence^ get ();
    void set (Evidence^ value);
}
member Evidence : Evidence with get, set

Property Value

Type: Evidence
The evidence.
See Also

Reference

AuthzDecisionStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthzDecisionStatement.Resource Property

AuthzDecisionStatementResource Property

Gets or sets the resource.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Resource { get; set; }
Public Property Resource As String
    Get
    Set
public:
property String^ Resource {
    String^ get ();
    void set (String^ value);
}
member Resource : string with get, set

Property Value

Type: String
The resource.
See Also

Reference

AuthzDecisionStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthzDecisionStatement Methods

The AuthzDecisionStatement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authorization decision statement.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the authorization decision statement to XML.
Top
See Also

Reference

AuthzDecisionStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthzDecisionStatement.IsValid Method

AuthzDecisionStatementIsValid Method

Indicates whether the XML is an authorization decision statement.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an authorization decision statement; otherwise false.
See Also

Reference

AuthzDecisionStatement Class
ComponentSpace.SAML2.Assertions Namespace


AuthzDecisionStatement.ToXml Method

AuthzDecisionStatementToXml Method

Serializes the authorization decision statement to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authorization decision statement as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthzDecisionStatement Class
ComponentSpace.SAML2.Assertions Namespace


BaseID Class

Represents a base identifier.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsBaseIDAbstractType
ComponentSpace.SAML2.AssertionsBaseID

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class BaseID : BaseIDAbstractType
Public Class BaseID
    Inherits BaseIDAbstractType
public ref class BaseID : public BaseIDAbstractType
type BaseID =
    class
        inherit BaseIDAbstractType
    end

The BaseID type exposes the following members.

Constructors
 | Name | Description
Public method | BaseID | Initializes a new instance of the BaseID class.
Public method | BaseID(XmlElement) | Initializes a new instance of the BaseID class from XML.
Public method | BaseID(String, String) | Initializes a new instance of the BaseID class.
Top
Properties
 | Name | Description
Public property | NameQualifier | Gets or sets the name qualifier. (Inherited from BaseIDAbstractType.)
Public property | SPNameQualifier | Gets or sets the SP name qualifier. (Inherited from BaseIDAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a base identifier.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the base identifier to XML.
Public method | ToXml(XmlElement) | Serializes the base identifier to XML. (Inherited from BaseIDAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


BaseID Constructor

Overload List
 | Name | Description
Public method | BaseID | Initializes a new instance of the BaseID class.
Public method | BaseID(XmlElement) | Initializes a new instance of the BaseID class from XML.
Public method | BaseID(String, String) | Initializes a new instance of the BaseID class.
Top
See Also

Reference

BaseID Class
ComponentSpace.SAML2.Assertions Namespace


BaseID Constructor

Initializes a new instance of the BaseID class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public BaseID()
Public Sub New
public:
BaseID()
new : unit -> BaseID
See Also

Reference

BaseID Class
BaseID Overload
ComponentSpace.SAML2.Assertions Namespace


BaseID Constructor (XmlElement)

Initializes a new instance of the BaseID class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public BaseID(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
BaseID(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> BaseID

Parameters

xmlElement
Type: System.XmlXmlElement
The base identifier XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

BaseID Class
BaseID Overload
ComponentSpace.SAML2.Assertions Namespace


BaseID Constructor (String, String)

Initializes a new instance of the BaseID class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public BaseID(
    string nameQualifier,
    string spNameQualifier
)
Public Sub New (
    nameQualifier As String,
    spNameQualifier As String
)
public:
BaseID(
    String^ nameQualifier,
    String^ spNameQualifier
)
new :
        nameQualifier : string *
        spNameQualifier : string -> BaseID

Parameters

nameQualifier
Type: SystemString
The name qualifier.
spNameQualifier
Type: SystemString
The SP name qualifier.
See Also

Reference

BaseID Class
BaseID Overload
ComponentSpace.SAML2.Assertions Namespace


BaseID Properties

The BaseID type exposes the following members.

Properties
 | Name | Description
Public property | NameQualifier | Gets or sets the name qualifier. (Inherited from BaseIDAbstractType.)
Public property | SPNameQualifier | Gets or sets the SP name qualifier. (Inherited from BaseIDAbstractType.)
Top
See Also

Reference

BaseID Class
ComponentSpace.SAML2.Assertions Namespace


BaseID Methods

The BaseID type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a base identifier.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the base identifier to XML.
Public method | ToXml(XmlElement) | Serializes the base identifier to XML. (Inherited from BaseIDAbstractType.)
Top
See Also

Reference

BaseID Class
ComponentSpace.SAML2.Assertions Namespace


BaseID.IsValid Method

BaseIDIsValid Method

Indicates whether the XML is a base identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a base identifier; otherwise false.
See Also

Reference

BaseID Class
ComponentSpace.SAML2.Assertions Namespace


BaseID.ToXml Method

BaseIDToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlDocument) | Serializes the base identifier to XML.
Public method | ToXml(XmlElement) | Serializes the base identifier to XML. (Inherited from BaseIDAbstractType.)
Top
See Also

Reference

BaseID Class
ComponentSpace.SAML2.Assertions Namespace


BaseID.ToXml Method (XmlDocument)

BaseIDToXml Method (XmlDocument)

Serializes the base identifier to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The base identifier as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

BaseID Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


BaseIDAbstractType Class

Represents the base identifier abstract type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsBaseIDAbstractType
ComponentSpace.SAML2.AssertionsBaseID

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class BaseIDAbstractType
Public MustInherit Class BaseIDAbstractType
public ref class BaseIDAbstractType abstract
[<AbstractClassAttribute>]
type BaseIDAbstractType =  class end

The BaseIDAbstractType type exposes the following members.

Constructors
 | Name | Description
Public method | BaseIDAbstractType | Initializes a new instance of the BaseIDAbstractType class.
Public method | BaseIDAbstractType(XmlElement) | Initializes a new instance of the BaseIDAbstractType class from XML.
Public method | BaseIDAbstractType(String, String) | Initializes a new instance of the BaseIDAbstractType class.
Top
Properties
 | Name | Description
Public property | NameQualifier | Gets or sets the name qualifier.
Public property | SPNameQualifier | Gets or sets the SP name qualifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the base identifier to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


BaseIDAbstractType Constructor

Overload List
 | Name | Description
Public method | BaseIDAbstractType | Initializes a new instance of the BaseIDAbstractType class.
Public method | BaseIDAbstractType(XmlElement) | Initializes a new instance of the BaseIDAbstractType class from XML.
Public method | BaseIDAbstractType(String, String) | Initializes a new instance of the BaseIDAbstractType class.
Top
See Also

Reference

BaseIDAbstractType Class
ComponentSpace.SAML2.Assertions Namespace


BaseIDAbstractType Constructor

Initializes a new instance of the BaseIDAbstractType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public BaseIDAbstractType()
Public Sub New
public:
BaseIDAbstractType()
new : unit -> BaseIDAbstractType
See Also

Reference

BaseIDAbstractType Class
BaseIDAbstractType Overload
ComponentSpace.SAML2.Assertions Namespace


BaseIDAbstractType Constructor (XmlElement)

Initializes a new instance of the BaseIDAbstractType class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public BaseIDAbstractType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
BaseIDAbstractType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> BaseIDAbstractType

Parameters

xmlElement
Type: System.XmlXmlElement
The base identifier XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

BaseIDAbstractType Class
BaseIDAbstractType Overload
ComponentSpace.SAML2.Assertions Namespace


BaseIDAbstractType Constructor (String, String)

Initializes a new instance of the BaseIDAbstractType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public BaseIDAbstractType(
    string nameQualifier,
    string spNameQualifier
)
Public Sub New (
    nameQualifier As String,
    spNameQualifier As String
)
public:
BaseIDAbstractType(
    String^ nameQualifier,
    String^ spNameQualifier
)
new :
        nameQualifier : string *
        spNameQualifier : string -> BaseIDAbstractType

Parameters

nameQualifier
Type: SystemString
The name qualifier.
spNameQualifier
Type: SystemString
The SP name qualifier.
See Also

Reference

BaseIDAbstractType Class
BaseIDAbstractType Overload
ComponentSpace.SAML2.Assertions Namespace


BaseIDAbstractType Properties

The BaseIDAbstractType type exposes the following members.

Properties
 | Name | Description
Public property | NameQualifier | Gets or sets the name qualifier.
Public property | SPNameQualifier | Gets or sets the SP name qualifier.
Top
See Also

Reference

BaseIDAbstractType Class
ComponentSpace.SAML2.Assertions Namespace


BaseIDAbstractType.NameQualifier Property

BaseIDAbstractTypeNameQualifier Property

Gets or sets the name qualifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string NameQualifier { get; set; }
Public Property NameQualifier As String
    Get
    Set
public:
property String^ NameQualifier {
    String^ get ();
    void set (String^ value);
}
member NameQualifier : string with get, set

Property Value

Type: String
The name qualifier.
See Also

Reference

BaseIDAbstractType Class
ComponentSpace.SAML2.Assertions Namespace


BaseIDAbstractType.SPNameQualifier Property

BaseIDAbstractTypeSPNameQualifier Property

Gets or sets the SP name qualifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SPNameQualifier { get; set; }
Public Property SPNameQualifier As String
    Get
    Set
public:
property String^ SPNameQualifier {
    String^ get ();
    void set (String^ value);
}
member SPNameQualifier : string with get, set

Property Value

Type: String
The SP name qualifier.
See Also

Reference

BaseIDAbstractType Class
ComponentSpace.SAML2.Assertions Namespace


BaseIDAbstractType Methods

The BaseIDAbstractType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the base identifier to XML.
Top
See Also

Reference

BaseIDAbstractType Class
ComponentSpace.SAML2.Assertions Namespace


BaseIDAbstractType.ToXml Method

BaseIDAbstractTypeToXml Method

Serializes the base identifier to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void ToXml(
    XmlElement xmlElement
)
Public Sub ToXml (
    xmlElement As XmlElement
)
public:
void ToXml(
    XmlElement^ xmlElement
)
member ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

BaseIDAbstractType Class
ComponentSpace.SAML2.Assertions Namespace


Conditions Class

Represents conditions.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsConditions

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Conditions
Public Class Conditions
public ref class Conditions
type Conditions =  class end

The Conditions type exposes the following members.

Constructors
 | Name | Description
Public method | Conditions | Initializes a new instance of the Conditions class.
Public method | Conditions(TimeSpan) | Initializes a new instance of the Conditions class.
Public method | Conditions(XmlElement) | Initializes a new instance of the Conditions class from XML.
Public method | Conditions(DateTime, DateTime) | Initializes a new instance of the Conditions class.
Top
Properties
 | Name | Description
Public property | ConditionsList | Gets or sets the list of conditions.
Public property | NotBefore | Gets or sets the not before time.
Public property | NotOnOrAfter | Gets or sets the not on or after time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is conditions.
Public method | IsWithinTimePeriod | Indicates whether the current UTC time is within the not before and not on or after period, if specified.
Public method | IsWithinTimePeriod(TimeSpan) | Indicates whether the current UTC time is within the not before and not on or after period, if specified. The supplied time span is to allow for clock skew.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the conditions to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


Conditions Constructor

Overload List
 | Name | Description
Public method | Conditions | Initializes a new instance of the Conditions class.
Public method | Conditions(TimeSpan) | Initializes a new instance of the Conditions class.
Public method | Conditions(XmlElement) | Initializes a new instance of the Conditions class from XML.
Public method | Conditions(DateTime, DateTime) | Initializes a new instance of the Conditions class.
Top
See Also

Reference

Conditions Class
ComponentSpace.SAML2.Assertions Namespace


Conditions Constructor

Initializes a new instance of the Conditions class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Conditions()
Public Sub New
public:
Conditions()
new : unit -> Conditions
See Also

Reference

Conditions Class
Conditions Overload
ComponentSpace.SAML2.Assertions Namespace


Conditions Constructor (TimeSpan)

Initializes a new instance of the Conditions class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Conditions(
    TimeSpan timeSpan
)
Public Sub New (
    timeSpan As TimeSpan
)
public:
Conditions(
    TimeSpan timeSpan
)
new :
        timeSpan : TimeSpan -> Conditions

Parameters

timeSpan
Type: SystemTimeSpan
The timespan before and after now.
Remarks
The not before time is calculated as the current UTC time less the time span. The not on or after time is calculated as the current UTC time plus the time span.
See Also

Reference

Conditions Class
Conditions Overload
ComponentSpace.SAML2.Assertions Namespace


Conditions Constructor (XmlElement)

Initializes a new instance of the Conditions class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Conditions(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Conditions(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Conditions

Parameters

xmlElement
Type: System.XmlXmlElement
The conditions XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Conditions Class
Conditions Overload
ComponentSpace.SAML2.Assertions Namespace


Conditions Constructor (DateTime, DateTime)

Initializes a new instance of the Conditions class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Conditions(
    DateTime notBefore,
    DateTime notOnOrAfter
)
Public Sub New (
    notBefore As DateTime,
    notOnOrAfter As DateTime
)
public:
Conditions(
    DateTime notBefore,
    DateTime notOnOrAfter
)
new :
        notBefore : DateTime *
        notOnOrAfter : DateTime -> Conditions

Parameters

notBefore
Type: SystemDateTime
The not before time as coordinated universal time (UTC).
notOnOrAfter
Type: SystemDateTime
The not on or after time as coordinated universal time (UTC).
See Also

Reference

Conditions Class
Conditions Overload
ComponentSpace.SAML2.Assertions Namespace


Conditions Properties

The Conditions type exposes the following members.

Properties
 | Name | Description
Public property | ConditionsList | Gets or sets the list of conditions.
Public property | NotBefore | Gets or sets the not before time.
Public property | NotOnOrAfter | Gets or sets the not on or after time.
Top
See Also

Reference

Conditions Class
ComponentSpace.SAML2.Assertions Namespace


Conditions.ConditionsList Property

ConditionsConditionsList Property

Gets or sets the list of conditions.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<ICondition> ConditionsList { get; set; }
Public Property ConditionsList As IList(Of ICondition)
    Get
    Set
public:
property IList<ICondition^>^ ConditionsList {
    IList<ICondition^>^ get ();
    void set (IList<ICondition^>^ value);
}
member ConditionsList : IList<ICondition> with get, set

Property Value

Type: IList ICondition
The list of conditions.
See Also

Reference

Conditions Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAudienceRestriction
ComponentSpace.SAML2.AssertionsOneTimeUse
ComponentSpace.SAML2.AssertionsProxyRestriction


Conditions.NotBefore Property

ConditionsNotBefore Property

Gets or sets the not before time.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime NotBefore { get; set; }
Public Property NotBefore As DateTime
    Get
    Set
public:
property DateTime NotBefore {
    DateTime get ();
    void set (DateTime value);
}
member NotBefore : DateTime with get, set

Property Value

Type: DateTime
The not before time as coordinated universal time (UTC). A value of DateTime.MinValue indicates the value has not been set.
See Also

Reference

Conditions Class
ComponentSpace.SAML2.Assertions Namespace


Conditions.NotOnOrAfter Property

ConditionsNotOnOrAfter Property

Gets or sets the not on or after time.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime NotOnOrAfter { get; set; }
Public Property NotOnOrAfter As DateTime
    Get
    Set
public:
property DateTime NotOnOrAfter {
    DateTime get ();
    void set (DateTime value);
}
member NotOnOrAfter : DateTime with get, set

Property Value

Type: DateTime
The not on or after time as coordinated universal time (UTC). A value of DateTime.MaxValue indicates the value has not been set.
See Also

Reference

Conditions Class
ComponentSpace.SAML2.Assertions Namespace


Conditions Methods

The Conditions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is conditions.
Public method | IsWithinTimePeriod | Indicates whether the current UTC time is within the not before and not on or after period, if specified.
Public method | IsWithinTimePeriod(TimeSpan) | Indicates whether the current UTC time is within the not before and not on or after period, if specified. The supplied time span is to allow for clock skew.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the conditions to XML.
Top
See Also

Reference

Conditions Class
ComponentSpace.SAML2.Assertions Namespace


Conditions.IsValid Method

ConditionsIsValid Method

Indicates whether the XML is conditions.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is conditions; otherwise false.
See Also

Reference

Conditions Class
ComponentSpace.SAML2.Assertions Namespace


Conditions.IsWithinTimePeriod Method

ConditionsIsWithinTimePeriod Method

Overload List
 | Name | Description
Public method | IsWithinTimePeriod | Indicates whether the current UTC time is within the not before and not on or after period, if specified.
Public method | IsWithinTimePeriod(TimeSpan) | Indicates whether the current UTC time is within the not before and not on or after period, if specified. The supplied time span is to allow for clock skew.
Top
See Also

Reference

Conditions Class
ComponentSpace.SAML2.Assertions Namespace


Conditions.IsWithinTimePeriod Method

ConditionsIsWithinTimePeriod Method

Indicates whether the current UTC time is within the not before and not on or after period, if specified.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool IsWithinTimePeriod()
Public Function IsWithinTimePeriod As Boolean
public:
bool IsWithinTimePeriod()
member IsWithinTimePeriod : unit -> bool

Return Value

Type: Boolean
true if within the time period; otherwise false.
Remarks
To be within the time period, not before > UTC now >= not on or after
See Also

Reference

Conditions Class
IsWithinTimePeriod Overload
ComponentSpace.SAML2.Assertions Namespace


Conditions.IsWithinTimePeriod Method (TimeSpan)

ConditionsIsWithinTimePeriod Method (TimeSpan)

Indicates whether the current UTC time is within the not before and not on or after period, if specified. The supplied time span is to allow for clock skew.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool IsWithinTimePeriod(
    TimeSpan clockSkew
)
Public Function IsWithinTimePeriod (
    clockSkew As TimeSpan
) As Boolean
public:
bool IsWithinTimePeriod(
    TimeSpan clockSkew
)
member IsWithinTimePeriod :
        clockSkew : TimeSpan -> bool

Parameters

clockSkew
Type: SystemTimeSpan
The time span to allow for clock skew.

Return Value

Type: Boolean
true if within the time period; otherwise false.
Remarks
To be within the time period, not before - clock skew > UTC now >= not on or after + clock skew
See Also

Reference

Conditions Class
IsWithinTimePeriod Overload
ComponentSpace.SAML2.Assertions Namespace


Conditions.ToXml Method

ConditionsToXml Method

Serializes the conditions to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The conditions as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Conditions Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Class

Represents an encrypted assertion.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsEncryptedElementType
ComponentSpace.SAML2.AssertionsEncryptedAssertion

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class EncryptedAssertion : EncryptedElementType
Public Class EncryptedAssertion
    Inherits EncryptedElementType
public ref class EncryptedAssertion : public EncryptedElementType
type EncryptedAssertion =
    class
        inherit EncryptedElementType
    end

The EncryptedAssertion type exposes the following members.

Constructors
 | Name | Description
Public method | EncryptedAssertion | Initializes a new instance of the EncryptedAssertion class.
Public method | EncryptedAssertion(XmlElement) | Initializes a new instance of the EncryptedAssertion class from XML.
Public method | EncryptedAssertion(XmlElement, X509Certificate2) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(XmlElement, XmlNodeList) | Initializes a new instance of the EncryptedAssertion class.
Public method | EncryptedAssertion(SAMLAssertion, X509Certificate2) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Public method | EncryptedAssertion(XmlElement, AsymmetricAlgorithm, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(XmlElement, X509Certificate2, EncryptionMethod) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(SAMLAssertion, AsymmetricAlgorithm, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Public method | EncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Public method | EncryptedAssertion(XmlElement, AsymmetricAlgorithm, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(XmlElement, X509Certificate2, EncryptionMethod, EncryptionMethod) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(SAMLAssertion, AsymmetricAlgorithm, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Public method | EncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Public method | EncryptedAssertion(XmlElement, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(SAMLAssertion, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Top
Properties
 | Name | Description
Public property | EncryptedData | Gets or sets the encrypted data. (Inherited from EncryptedElementType.)
Public property | EncryptedKeys | Gets or sets the encrypted keys. (Inherited from EncryptedElementType.)
Top
Methods
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm) | Decrypts an encrypted assertion.
Public method | Decrypt(X509Certificate2) | Decrypts an encrypted assertion.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | DecryptToXml(AsymmetricAlgorithm) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(X509Certificate2) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(X509Certificate2, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an encrypted assertion.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the encrypted assertion to XML.
Public method | ToXml(XmlDocument) | Serializes the encrypted assertion to XML.
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Constructor

Overload List
 | Name | Description
Public method | EncryptedAssertion | Initializes a new instance of the EncryptedAssertion class.
Public method | EncryptedAssertion(XmlElement) | Initializes a new instance of the EncryptedAssertion class from XML.
Public method | EncryptedAssertion(XmlElement, X509Certificate2) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(XmlElement, XmlNodeList) | Initializes a new instance of the EncryptedAssertion class.
Public method | EncryptedAssertion(SAMLAssertion, X509Certificate2) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Public method | EncryptedAssertion(XmlElement, AsymmetricAlgorithm, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(XmlElement, X509Certificate2, EncryptionMethod) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(SAMLAssertion, AsymmetricAlgorithm, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Public method | EncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Public method | EncryptedAssertion(XmlElement, AsymmetricAlgorithm, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(XmlElement, X509Certificate2, EncryptionMethod, EncryptionMethod) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(SAMLAssertion, AsymmetricAlgorithm, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Public method | EncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Public method | EncryptedAssertion(XmlElement, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.
Public method | EncryptedAssertion(SAMLAssertion, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAssertion class from a SAML assertion.
Top
See Also

Reference

EncryptedAssertion Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Constructor

Initializes a new instance of the EncryptedAssertion class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion()
Public Sub New
public:
EncryptedAssertion()
new : unit -> EncryptedAssertion
See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Constructor (XmlElement)

Initializes a new instance of the EncryptedAssertion class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
EncryptedAssertion(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> EncryptedAssertion

Parameters

xmlElement
Type: System.XmlXmlElement
The encrypted assertion XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Constructor (XmlElement, X509Certificate2)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    XmlElement samlAssertion,
    X509Certificate2 x509Certificate
)
Public Sub New (
    samlAssertion As XmlElement,
    x509Certificate As X509Certificate2
)
public:
EncryptedAssertion(
    XmlElement^ samlAssertion,
    X509Certificate2^ x509Certificate
)
new :
        samlAssertion : XmlElement *
        x509Certificate : X509Certificate2 -> EncryptedAssertion

Parameters

samlAssertion
Type: System.XmlXmlElement
The SAML assertion XML.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The encryption method for the data is http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedAssertionDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion Constructor (XmlElement, XmlNodeList)

Initializes a new instance of the EncryptedAssertion class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    XmlElement encryptedData,
    XmlNodeList encryptedKeys
)
Public Sub New (
    encryptedData As XmlElement,
    encryptedKeys As XmlNodeList
)
public:
EncryptedAssertion(
    XmlElement^ encryptedData,
    XmlNodeList^ encryptedKeys
)
new :
        encryptedData : XmlElement *
        encryptedKeys : XmlNodeList -> EncryptedAssertion

Parameters

encryptedData
Type: System.XmlXmlElement
The encrypted data.
encryptedKeys
Type: System.XmlXmlNodeList
The encrypted keys.
See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Constructor (SAMLAssertion, X509Certificate2)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    SAMLAssertion samlAssertion,
    X509Certificate2 x509Certificate
)
Public Sub New (
    samlAssertion As SAMLAssertion,
    x509Certificate As X509Certificate2
)
public:
EncryptedAssertion(
    SAMLAssertion^ samlAssertion,
    X509Certificate2^ x509Certificate
)
new :
        samlAssertion : SAMLAssertion *
        x509Certificate : X509Certificate2 -> EncryptedAssertion

Parameters

samlAssertion
Type: ComponentSpace.SAML2.AssertionsSAMLAssertion
The SAML assertion.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The encryption method for the data is http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedAssertionDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion Constructor (XmlElement, AsymmetricAlgorithm, KeyInfo)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    XmlElement samlAssertion,
    AsymmetricAlgorithm keyEncryptingKey,
    KeyInfo keyInfo
)
Public Sub New (
    samlAssertion As XmlElement,
    keyEncryptingKey As AsymmetricAlgorithm,
    keyInfo As KeyInfo
)
public:
EncryptedAssertion(
    XmlElement^ samlAssertion,
    AsymmetricAlgorithm^ keyEncryptingKey,
    KeyInfo^ keyInfo
)
new :
        samlAssertion : XmlElement *
        keyEncryptingKey : AsymmetricAlgorithm *
        keyInfo : KeyInfo -> EncryptedAssertion

Parameters

samlAssertion
Type: System.XmlXmlElement
The SAML assertion XML.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The encryption method for the data is http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Constructor (XmlElement, X509Certificate2, EncryptionMethod)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    XmlElement samlAssertion,
    X509Certificate2 x509Certificate,
    EncryptionMethod dataEncryptionMethod
)
Public Sub New (
    samlAssertion As XmlElement,
    x509Certificate As X509Certificate2,
    dataEncryptionMethod As EncryptionMethod
)
public:
EncryptedAssertion(
    XmlElement^ samlAssertion,
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ dataEncryptionMethod
)
new :
        samlAssertion : XmlElement *
        x509Certificate : X509Certificate2 *
        dataEncryptionMethod : EncryptionMethod -> EncryptedAssertion

Parameters

samlAssertion
Type: System.XmlXmlElement
The SAML assertion XML.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedAssertionDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion Constructor (SAMLAssertion, AsymmetricAlgorithm, KeyInfo)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    SAMLAssertion samlAssertion,
    AsymmetricAlgorithm keyEncryptingKey,
    KeyInfo keyInfo
)
Public Sub New (
    samlAssertion As SAMLAssertion,
    keyEncryptingKey As AsymmetricAlgorithm,
    keyInfo As KeyInfo
)
public:
EncryptedAssertion(
    SAMLAssertion^ samlAssertion,
    AsymmetricAlgorithm^ keyEncryptingKey,
    KeyInfo^ keyInfo
)
new :
        samlAssertion : SAMLAssertion *
        keyEncryptingKey : AsymmetricAlgorithm *
        keyInfo : KeyInfo -> EncryptedAssertion

Parameters

samlAssertion
Type: ComponentSpace.SAML2.AssertionsSAMLAssertion
The SAML assertion.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The encryption method for the data is http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Constructor (SAMLAssertion, X509Certificate2, EncryptionMethod)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    SAMLAssertion samlAssertion,
    X509Certificate2 x509Certificate,
    EncryptionMethod dataEncryptionMethod
)
Public Sub New (
    samlAssertion As SAMLAssertion,
    x509Certificate As X509Certificate2,
    dataEncryptionMethod As EncryptionMethod
)
public:
EncryptedAssertion(
    SAMLAssertion^ samlAssertion,
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ dataEncryptionMethod
)
new :
        samlAssertion : SAMLAssertion *
        x509Certificate : X509Certificate2 *
        dataEncryptionMethod : EncryptionMethod -> EncryptedAssertion

Parameters

samlAssertion
Type: ComponentSpace.SAML2.AssertionsSAMLAssertion
The SAML assertion.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedAssertionDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion Constructor (XmlElement, AsymmetricAlgorithm, EncryptionMethod, KeyInfo)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    XmlElement samlAssertion,
    AsymmetricAlgorithm keyEncryptingKey,
    EncryptionMethod dataEncryptionMethod,
    KeyInfo keyInfo
)
Public Sub New (
    samlAssertion As XmlElement,
    keyEncryptingKey As AsymmetricAlgorithm,
    dataEncryptionMethod As EncryptionMethod,
    keyInfo As KeyInfo
)
public:
EncryptedAssertion(
    XmlElement^ samlAssertion,
    AsymmetricAlgorithm^ keyEncryptingKey,
    EncryptionMethod^ dataEncryptionMethod,
    KeyInfo^ keyInfo
)
new :
        samlAssertion : XmlElement *
        keyEncryptingKey : AsymmetricAlgorithm *
        dataEncryptionMethod : EncryptionMethod *
        keyInfo : KeyInfo -> EncryptedAssertion

Parameters

samlAssertion
Type: System.XmlXmlElement
The SAML assertion XML.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Constructor (XmlElement, X509Certificate2, EncryptionMethod, EncryptionMethod)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    XmlElement samlAssertion,
    X509Certificate2 x509Certificate,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Sub New (
    samlAssertion As XmlElement,
    x509Certificate As X509Certificate2,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
)
public:
EncryptedAssertion(
    XmlElement^ samlAssertion,
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
new :
        samlAssertion : XmlElement *
        x509Certificate : X509Certificate2 *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> EncryptedAssertion

Parameters

samlAssertion
Type: System.XmlXmlElement
The SAML assertion XML.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the symmetric key (http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p).
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The specified key encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedAssertionDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion Constructor (SAMLAssertion, AsymmetricAlgorithm, EncryptionMethod, KeyInfo)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    SAMLAssertion samlAssertion,
    AsymmetricAlgorithm keyEncryptingKey,
    EncryptionMethod dataEncryptionMethod,
    KeyInfo keyInfo
)
Public Sub New (
    samlAssertion As SAMLAssertion,
    keyEncryptingKey As AsymmetricAlgorithm,
    dataEncryptionMethod As EncryptionMethod,
    keyInfo As KeyInfo
)
public:
EncryptedAssertion(
    SAMLAssertion^ samlAssertion,
    AsymmetricAlgorithm^ keyEncryptingKey,
    EncryptionMethod^ dataEncryptionMethod,
    KeyInfo^ keyInfo
)
new :
        samlAssertion : SAMLAssertion *
        keyEncryptingKey : AsymmetricAlgorithm *
        dataEncryptionMethod : EncryptionMethod *
        keyInfo : KeyInfo -> EncryptedAssertion

Parameters

samlAssertion
Type: ComponentSpace.SAML2.AssertionsSAMLAssertion
The SAML assertion.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Constructor (SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    SAMLAssertion samlAssertion,
    X509Certificate2 x509Certificate,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Sub New (
    samlAssertion As SAMLAssertion,
    x509Certificate As X509Certificate2,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
)
public:
EncryptedAssertion(
    SAMLAssertion^ samlAssertion,
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
new :
        samlAssertion : SAMLAssertion *
        x509Certificate : X509Certificate2 *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> EncryptedAssertion

Parameters

samlAssertion
Type: ComponentSpace.SAML2.AssertionsSAMLAssertion
The SAML assertion.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the symmetric key (http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p).
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The specified key encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedAssertionDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion Constructor (XmlElement, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    XmlElement samlAssertion,
    AsymmetricAlgorithm keyEncryptingKey,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod,
    KeyInfo keyInfo
)
Public Sub New (
    samlAssertion As XmlElement,
    keyEncryptingKey As AsymmetricAlgorithm,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod,
    keyInfo As KeyInfo
)
public:
EncryptedAssertion(
    XmlElement^ samlAssertion,
    AsymmetricAlgorithm^ keyEncryptingKey,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod,
    KeyInfo^ keyInfo
)
new :
        samlAssertion : XmlElement *
        keyEncryptingKey : AsymmetricAlgorithm *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod *
        keyInfo : KeyInfo -> EncryptedAssertion

Parameters

samlAssertion
Type: System.XmlXmlElement
The SAML assertion XML.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the symmetric key (http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p).
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The specified key encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Constructor (SAMLAssertion, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)

Initializes a new instance of the EncryptedAssertion class from a SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion(
    SAMLAssertion samlAssertion,
    AsymmetricAlgorithm keyEncryptingKey,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod,
    KeyInfo keyInfo
)
Public Sub New (
    samlAssertion As SAMLAssertion,
    keyEncryptingKey As AsymmetricAlgorithm,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod,
    keyInfo As KeyInfo
)
public:
EncryptedAssertion(
    SAMLAssertion^ samlAssertion,
    AsymmetricAlgorithm^ keyEncryptingKey,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod,
    KeyInfo^ keyInfo
)
new :
        samlAssertion : SAMLAssertion *
        keyEncryptingKey : AsymmetricAlgorithm *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod *
        keyInfo : KeyInfo -> EncryptedAssertion

Parameters

samlAssertion
Type: ComponentSpace.SAML2.AssertionsSAMLAssertion
The SAML assertion.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the symmetric key (http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p).
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The specified key encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
EncryptedAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Properties

The EncryptedAssertion type exposes the following members.

Properties
 | Name | Description
Public property | EncryptedData | Gets or sets the encrypted data. (Inherited from EncryptedElementType.)
Public property | EncryptedKeys | Gets or sets the encrypted keys. (Inherited from EncryptedElementType.)
Top
See Also

Reference

EncryptedAssertion Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion Methods

The EncryptedAssertion type exposes the following members.

Methods
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm) | Decrypts an encrypted assertion.
Public method | Decrypt(X509Certificate2) | Decrypts an encrypted assertion.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | DecryptToXml(AsymmetricAlgorithm) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(X509Certificate2) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(X509Certificate2, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an encrypted assertion.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the encrypted assertion to XML.
Public method | ToXml(XmlDocument) | Serializes the encrypted assertion to XML.
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Top
See Also

Reference

EncryptedAssertion Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion.Decrypt Method

EncryptedAssertionDecrypt Method

Overload List
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm) | Decrypts an encrypted assertion.
Public method | Decrypt(X509Certificate2) | Decrypts an encrypted assertion.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion.
Top
See Also

Reference

EncryptedAssertion Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion.Decrypt Method (AsymmetricAlgorithm)

EncryptedAssertionDecrypt Method (AsymmetricAlgorithm)

Decrypts an encrypted assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion Decrypt(
    AsymmetricAlgorithm keyDecryptingKey
)
Public Function Decrypt (
    keyDecryptingKey As AsymmetricAlgorithm
) As SAMLAssertion
public:
SAMLAssertion^ Decrypt(
    AsymmetricAlgorithm^ keyDecryptingKey
)
member Decrypt :
        keyDecryptingKey : AsymmetricAlgorithm -> SAMLAssertion

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.

Return Value

Type: SAMLAssertion
The SAML assertion.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data.

DecryptToXml should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion.Decrypt Method (X509Certificate2)

EncryptedAssertionDecrypt Method (X509Certificate2)

Decrypts an encrypted assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion Decrypt(
    X509Certificate2 x509Certificate
)
Public Function Decrypt (
    x509Certificate As X509Certificate2
) As SAMLAssertion
public:
SAMLAssertion^ Decrypt(
    X509Certificate2^ x509Certificate
)
member Decrypt :
        x509Certificate : X509Certificate2 -> SAMLAssertion

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.

Return Value

Type: SAMLAssertion
The SAML assertion.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data.

DecryptToXml should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod)


EncryptedAssertion.Decrypt Method (AsymmetricAlgorithm, EncryptionMethod)

EncryptedAssertionDecrypt Method (AsymmetricAlgorithm, EncryptionMethod)

Decrypts an encrypted assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion Decrypt(
    AsymmetricAlgorithm keyDecryptingKey,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    keyDecryptingKey As AsymmetricAlgorithm,
    dataEncryptionMethod As EncryptionMethod
) As SAMLAssertion
public:
SAMLAssertion^ Decrypt(
    AsymmetricAlgorithm^ keyDecryptingKey,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        keyDecryptingKey : AsymmetricAlgorithm *
        dataEncryptionMethod : EncryptionMethod -> SAMLAssertion

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: SAMLAssertion
The SAML assertion.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

DecryptToXml should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion.Decrypt Method (X509Certificate2, EncryptionMethod)

EncryptedAssertionDecrypt Method (X509Certificate2, EncryptionMethod)

Decrypts an encrypted assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion Decrypt(
    X509Certificate2 x509Certificate,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    x509Certificate As X509Certificate2,
    dataEncryptionMethod As EncryptionMethod
) As SAMLAssertion
public:
SAMLAssertion^ Decrypt(
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        x509Certificate : X509Certificate2 *
        dataEncryptionMethod : EncryptionMethod -> SAMLAssertion

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: SAMLAssertion
The SAML assertion.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

DecryptToXml should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod)


EncryptedAssertion.Decrypt Method (AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)

EncryptedAssertionDecrypt Method (AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)

Decrypts an encrypted assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion Decrypt(
    AsymmetricAlgorithm keyDecryptingKey,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    keyDecryptingKey As AsymmetricAlgorithm,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
) As SAMLAssertion
public:
SAMLAssertion^ Decrypt(
    AsymmetricAlgorithm^ keyDecryptingKey,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        keyDecryptingKey : AsymmetricAlgorithm *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> SAMLAssertion

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the symmetric key or null if specified in the encrypted key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: SAMLAssertion
The SAML assertion.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the key is specified in the encrypted data or may be explicitly specified.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

DecryptToXml should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion.Decrypt Method (X509Certificate2, EncryptionMethod, EncryptionMethod)

EncryptedAssertionDecrypt Method (X509Certificate2, EncryptionMethod, EncryptionMethod)

Decrypts an encrypted assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion Decrypt(
    X509Certificate2 x509Certificate,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    x509Certificate As X509Certificate2,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
) As SAMLAssertion
public:
SAMLAssertion^ Decrypt(
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        x509Certificate : X509Certificate2 *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> SAMLAssertion

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the symmetric key or null if specified in the encrypted key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: SAMLAssertion
The SAML assertion.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the key is specified in the encrypted data or may be explicitly specified.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

DecryptToXml should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod)


EncryptedAssertion.DecryptToXml Method

EncryptedAssertionDecryptToXml Method

Overload List
 | Name | Description
Public method | DecryptToXml(AsymmetricAlgorithm) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(X509Certificate2) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(X509Certificate2, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Public method | DecryptToXml(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted assertion to XML.
Top
See Also

Reference

EncryptedAssertion Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion.DecryptToXml Method (AsymmetricAlgorithm)

EncryptedAssertionDecryptToXml Method (AsymmetricAlgorithm)

Decrypts an encrypted assertion to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement DecryptToXml(
    AsymmetricAlgorithm keyDecryptingKey
)
Public Function DecryptToXml (
    keyDecryptingKey As AsymmetricAlgorithm
) As XmlElement
public:
XmlElement^ DecryptToXml(
    AsymmetricAlgorithm^ keyDecryptingKey
)
member DecryptToXml :
        keyDecryptingKey : AsymmetricAlgorithm -> XmlElement

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.

Return Value

Type: XmlElement
The SAML assertion XML.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data.

This method should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
DecryptToXml Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion.DecryptToXml Method (X509Certificate2)

EncryptedAssertionDecryptToXml Method (X509Certificate2)

Decrypts an encrypted assertion to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement DecryptToXml(
    X509Certificate2 x509Certificate
)
Public Function DecryptToXml (
    x509Certificate As X509Certificate2
) As XmlElement
public:
XmlElement^ DecryptToXml(
    X509Certificate2^ x509Certificate
)
member DecryptToXml :
        x509Certificate : X509Certificate2 -> XmlElement

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.

Return Value

Type: XmlElement
The SAML assertion XML.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data.

This method should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
DecryptToXml Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion.DecryptToXml Method (AsymmetricAlgorithm, EncryptionMethod)

EncryptedAssertionDecryptToXml Method (AsymmetricAlgorithm, EncryptionMethod)

Decrypts an encrypted assertion to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement DecryptToXml(
    AsymmetricAlgorithm keyDecryptingKey,
    EncryptionMethod dataEncryptionMethod
)
Public Function DecryptToXml (
    keyDecryptingKey As AsymmetricAlgorithm,
    dataEncryptionMethod As EncryptionMethod
) As XmlElement
public:
XmlElement^ DecryptToXml(
    AsymmetricAlgorithm^ keyDecryptingKey,
    EncryptionMethod^ dataEncryptionMethod
)
member DecryptToXml :
        keyDecryptingKey : AsymmetricAlgorithm *
        dataEncryptionMethod : EncryptionMethod -> XmlElement

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: XmlElement
The SAML assertion XML.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

This method should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
DecryptToXml Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion.DecryptToXml Method (X509Certificate2, EncryptionMethod)

EncryptedAssertionDecryptToXml Method (X509Certificate2, EncryptionMethod)

Decrypts an encrypted assertion to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement DecryptToXml(
    X509Certificate2 x509Certificate,
    EncryptionMethod dataEncryptionMethod
)
Public Function DecryptToXml (
    x509Certificate As X509Certificate2,
    dataEncryptionMethod As EncryptionMethod
) As XmlElement
public:
XmlElement^ DecryptToXml(
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ dataEncryptionMethod
)
member DecryptToXml :
        x509Certificate : X509Certificate2 *
        dataEncryptionMethod : EncryptionMethod -> XmlElement

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: XmlElement
The SAML assertion XML.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

This method should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
DecryptToXml Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion.DecryptToXml Method (AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)

EncryptedAssertionDecryptToXml Method (AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)

Decrypts an encrypted assertion to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement DecryptToXml(
    AsymmetricAlgorithm keyDecryptingKey,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Function DecryptToXml (
    keyDecryptingKey As AsymmetricAlgorithm,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
) As XmlElement
public:
XmlElement^ DecryptToXml(
    AsymmetricAlgorithm^ keyDecryptingKey,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
member DecryptToXml :
        keyDecryptingKey : AsymmetricAlgorithm *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> XmlElement

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the symmetric key or null if specified in the encrypted key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: XmlElement
The SAML assertion XML.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the key is specified in the encrypted data or may be explicitly specified.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

This method should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
DecryptToXml Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion.DecryptToXml Method (X509Certificate2, EncryptionMethod, EncryptionMethod)

EncryptedAssertionDecryptToXml Method (X509Certificate2, EncryptionMethod, EncryptionMethod)

Decrypts an encrypted assertion to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement DecryptToXml(
    X509Certificate2 x509Certificate,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Function DecryptToXml (
    x509Certificate As X509Certificate2,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
) As XmlElement
public:
XmlElement^ DecryptToXml(
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
member DecryptToXml :
        x509Certificate : X509Certificate2 *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> XmlElement

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the symmetric key or null if specified in the encrypted key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: XmlElement
The SAML assertion XML.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the key is specified in the encrypted data or may be explicitly specified.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

This method should be used if the assertion includes a signature to be verified.

The supported key encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#rsa-1_5
  • http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p

The supported data encryption methods are:

  • http://www.w3.org/2001/04/xmlenc#tripledes-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-tripledes
  • http://www.w3.org/2001/04/xmlenc#aes128-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes128
  • http://www.w3.org/2001/04/xmlenc#aes192-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes192
  • http://www.w3.org/2001/04/xmlenc#aes256-cbc
  • http://www.w3.org/2001/04/xmlenc#kw-aes256

See Also

Reference

EncryptedAssertion Class
DecryptToXml Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAssertionEncryptedAssertion(SAMLAssertion, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAssertion.IsValid Method

EncryptedAssertionIsValid Method

Indicates whether the XML is an encrypted assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an encrypted assertion; otherwise false.
See Also

Reference

EncryptedAssertion Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion.ToXml Method

EncryptedAssertionToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the encrypted assertion to XML.
Public method | ToXml(XmlDocument) | Serializes the encrypted assertion to XML.
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Top
See Also

Reference

EncryptedAssertion Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion.ToXml Method

EncryptedAssertionToXml Method

Serializes the encrypted assertion to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The encrypted assertion as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

EncryptedAssertion Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAssertion.ToXml Method (XmlDocument)

EncryptedAssertionToXml Method (XmlDocument)

Serializes the encrypted assertion to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The encrypted assertion as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

EncryptedAssertion Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute Class

Represents an encrypted attribute.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsEncryptedElementType
ComponentSpace.SAML2.AssertionsEncryptedAttribute

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class EncryptedAttribute : EncryptedElementType
Public Class EncryptedAttribute
    Inherits EncryptedElementType
public ref class EncryptedAttribute : public EncryptedElementType
type EncryptedAttribute =
    class
        inherit EncryptedElementType
    end

The EncryptedAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | EncryptedAttribute | Initializes a new instance of the EncryptedAttribute class.
Public method | EncryptedAttribute(XmlElement) | Initializes a new instance of the EncryptedAttribute class from XML.
Public method | EncryptedAttribute(XmlElement, XmlNodeList) | Initializes a new instance of the EncryptedAttribute class.
Public method | EncryptedAttribute(SAMLAttribute, X509Certificate2, EncryptionMethod) | Initializes a new instance of the EncryptedAttribute class from a SAML attribute.
Public method | EncryptedAttribute(SAMLAttribute, AsymmetricAlgorithm, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAttribute class from a SAML attribute.
Public method | EncryptedAttribute(SAMLAttribute, X509Certificate2, EncryptionMethod, EncryptionMethod) | Initializes a new instance of the EncryptedAttribute class from a SAML attribute.
Public method | EncryptedAttribute(SAMLAttribute, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAttribute class from a SAML attribute.
Top
Properties
 | Name | Description
Public property | EncryptedData | Gets or sets the encrypted data. (Inherited from EncryptedElementType.)
Public property | EncryptedKeys | Gets or sets the encrypted keys. (Inherited from EncryptedElementType.)
Top
Methods
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an encrypted attribute.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the encrypted attribute to XML.
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute Constructor

Overload List
 | Name | Description
Public method | EncryptedAttribute | Initializes a new instance of the EncryptedAttribute class.
Public method | EncryptedAttribute(XmlElement) | Initializes a new instance of the EncryptedAttribute class from XML.
Public method | EncryptedAttribute(XmlElement, XmlNodeList) | Initializes a new instance of the EncryptedAttribute class.
Public method | EncryptedAttribute(SAMLAttribute, X509Certificate2, EncryptionMethod) | Initializes a new instance of the EncryptedAttribute class from a SAML attribute.
Public method | EncryptedAttribute(SAMLAttribute, AsymmetricAlgorithm, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAttribute class from a SAML attribute.
Public method | EncryptedAttribute(SAMLAttribute, X509Certificate2, EncryptionMethod, EncryptionMethod) | Initializes a new instance of the EncryptedAttribute class from a SAML attribute.
Public method | EncryptedAttribute(SAMLAttribute, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedAttribute class from a SAML attribute.
Top
See Also

Reference

EncryptedAttribute Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute Constructor

Initializes a new instance of the EncryptedAttribute class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAttribute()
Public Sub New
public:
EncryptedAttribute()
new : unit -> EncryptedAttribute
See Also

Reference

EncryptedAttribute Class
EncryptedAttribute Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute Constructor (XmlElement)

Initializes a new instance of the EncryptedAttribute class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAttribute(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
EncryptedAttribute(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> EncryptedAttribute

Parameters

xmlElement
Type: System.XmlXmlElement
The encrypted attribute XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

EncryptedAttribute Class
EncryptedAttribute Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute Constructor (XmlElement, XmlNodeList)

Initializes a new instance of the EncryptedAttribute class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAttribute(
    XmlElement encryptedData,
    XmlNodeList encryptedKeys
)
Public Sub New (
    encryptedData As XmlElement,
    encryptedKeys As XmlNodeList
)
public:
EncryptedAttribute(
    XmlElement^ encryptedData,
    XmlNodeList^ encryptedKeys
)
new :
        encryptedData : XmlElement *
        encryptedKeys : XmlNodeList -> EncryptedAttribute

Parameters

encryptedData
Type: System.XmlXmlElement
The encrypted data.
encryptedKeys
Type: System.XmlXmlNodeList
The encrypted keys.
See Also

Reference

EncryptedAttribute Class
EncryptedAttribute Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute Constructor (SAMLAttribute, X509Certificate2, EncryptionMethod)

Initializes a new instance of the EncryptedAttribute class from a SAML attribute.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAttribute(
    SAMLAttribute samlAttribute,
    X509Certificate2 x509Certificate,
    EncryptionMethod dataEncryptionMethod
)
Public Sub New (
    samlAttribute As SAMLAttribute,
    x509Certificate As X509Certificate2,
    dataEncryptionMethod As EncryptionMethod
)
public:
EncryptedAttribute(
    SAMLAttribute^ samlAttribute,
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ dataEncryptionMethod
)
new :
        samlAttribute : SAMLAttribute *
        x509Certificate : X509Certificate2 *
        dataEncryptionMethod : EncryptionMethod -> EncryptedAttribute

Parameters

samlAttribute
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The SAML attribute.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedAttribute Class
EncryptedAttribute Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAttributeDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedAttributeDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAttribute Constructor (SAMLAttribute, AsymmetricAlgorithm, EncryptionMethod, KeyInfo)

Initializes a new instance of the EncryptedAttribute class from a SAML attribute.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAttribute(
    SAMLAttribute samlAttribute,
    AsymmetricAlgorithm keyEncryptingKey,
    EncryptionMethod dataEncryptionMethod,
    KeyInfo keyInfo
)
Public Sub New (
    samlAttribute As SAMLAttribute,
    keyEncryptingKey As AsymmetricAlgorithm,
    dataEncryptionMethod As EncryptionMethod,
    keyInfo As KeyInfo
)
public:
EncryptedAttribute(
    SAMLAttribute^ samlAttribute,
    AsymmetricAlgorithm^ keyEncryptingKey,
    EncryptionMethod^ dataEncryptionMethod,
    KeyInfo^ keyInfo
)
new :
        samlAttribute : SAMLAttribute *
        keyEncryptingKey : AsymmetricAlgorithm *
        dataEncryptionMethod : EncryptionMethod *
        keyInfo : KeyInfo -> EncryptedAttribute

Parameters

samlAttribute
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The SAML attribute.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedAttribute Class
EncryptedAttribute Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAttributeDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedAttributeDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAttribute Constructor (SAMLAttribute, X509Certificate2, EncryptionMethod, EncryptionMethod)

Initializes a new instance of the EncryptedAttribute class from a SAML attribute.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAttribute(
    SAMLAttribute samlAttribute,
    X509Certificate2 x509Certificate,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Sub New (
    samlAttribute As SAMLAttribute,
    x509Certificate As X509Certificate2,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
)
public:
EncryptedAttribute(
    SAMLAttribute^ samlAttribute,
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
new :
        samlAttribute : SAMLAttribute *
        x509Certificate : X509Certificate2 *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> EncryptedAttribute

Parameters

samlAttribute
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The SAML attribute.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the symmetric key (http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p).
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The specified key encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedAttribute Class
EncryptedAttribute Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAttributeDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedAttributeDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAttribute Constructor (SAMLAttribute, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)

Initializes a new instance of the EncryptedAttribute class from a SAML attribute.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAttribute(
    SAMLAttribute samlAttribute,
    AsymmetricAlgorithm keyEncryptingKey,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod,
    KeyInfo keyInfo
)
Public Sub New (
    samlAttribute As SAMLAttribute,
    keyEncryptingKey As AsymmetricAlgorithm,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod,
    keyInfo As KeyInfo
)
public:
EncryptedAttribute(
    SAMLAttribute^ samlAttribute,
    AsymmetricAlgorithm^ keyEncryptingKey,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod,
    KeyInfo^ keyInfo
)
new :
        samlAttribute : SAMLAttribute *
        keyEncryptingKey : AsymmetricAlgorithm *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod *
        keyInfo : KeyInfo -> EncryptedAttribute

Parameters

samlAttribute
Type: ComponentSpace.SAML2.AssertionsSAMLAttribute
The SAML attribute.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the symmetric key (http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p).
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The specified key encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedAttribute Class
EncryptedAttribute Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAttributeDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedAttributeDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAttribute Properties

The EncryptedAttribute type exposes the following members.

Properties
 | Name | Description
Public property | EncryptedData | Gets or sets the encrypted data. (Inherited from EncryptedElementType.)
Public property | EncryptedKeys | Gets or sets the encrypted keys. (Inherited from EncryptedElementType.)
Top
See Also

Reference

EncryptedAttribute Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute Methods

The EncryptedAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an encrypted attribute.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the encrypted attribute to XML.
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Top
See Also

Reference

EncryptedAttribute Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute.Decrypt Method

EncryptedAttributeDecrypt Method

Overload List
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted attribute.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted attribute.
Top
See Also

Reference

EncryptedAttribute Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute.Decrypt Method (AsymmetricAlgorithm, EncryptionMethod)

EncryptedAttributeDecrypt Method (AsymmetricAlgorithm, EncryptionMethod)

Decrypts an encrypted attribute.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAttribute Decrypt(
    AsymmetricAlgorithm keyDecryptingKey,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    keyDecryptingKey As AsymmetricAlgorithm,
    dataEncryptionMethod As EncryptionMethod
) As SAMLAttribute
public:
SAMLAttribute^ Decrypt(
    AsymmetricAlgorithm^ keyDecryptingKey,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        keyDecryptingKey : AsymmetricAlgorithm *
        dataEncryptionMethod : EncryptionMethod -> SAMLAttribute

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: SAMLAttribute
The SAML attribute.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

EncryptedAttribute Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAttributeEncryptedAttribute(SAMLAttribute, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)
EncryptedAttributeEncryptedAttribute(SAMLAttribute, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAttribute.Decrypt Method (X509Certificate2, EncryptionMethod)

EncryptedAttributeDecrypt Method (X509Certificate2, EncryptionMethod)

Decrypts an encrypted attribute.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAttribute Decrypt(
    X509Certificate2 x509Certificate,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    x509Certificate As X509Certificate2,
    dataEncryptionMethod As EncryptionMethod
) As SAMLAttribute
public:
SAMLAttribute^ Decrypt(
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        x509Certificate : X509Certificate2 *
        dataEncryptionMethod : EncryptionMethod -> SAMLAttribute

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: SAMLAttribute
The SAML attribute.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

EncryptedAttribute Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAttributeEncryptedAttribute(SAMLAttribute, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)
EncryptedAttributeEncryptedAttribute(SAMLAttribute, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAttribute.Decrypt Method (AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)

EncryptedAttributeDecrypt Method (AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)

Decrypts an encrypted attribute.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAttribute Decrypt(
    AsymmetricAlgorithm keyDecryptingKey,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    keyDecryptingKey As AsymmetricAlgorithm,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
) As SAMLAttribute
public:
SAMLAttribute^ Decrypt(
    AsymmetricAlgorithm^ keyDecryptingKey,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        keyDecryptingKey : AsymmetricAlgorithm *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> SAMLAttribute

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the symmetric key or null if specified in the encrypted key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: SAMLAttribute
The SAML attribute.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the key is specified in the encrypted data or may be explicitly specified.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

EncryptedAttribute Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAttributeEncryptedAttribute(SAMLAttribute, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)
EncryptedAttributeEncryptedAttribute(SAMLAttribute, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAttribute.Decrypt Method (X509Certificate2, EncryptionMethod, EncryptionMethod)

EncryptedAttributeDecrypt Method (X509Certificate2, EncryptionMethod, EncryptionMethod)

Decrypts an encrypted attribute.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAttribute Decrypt(
    X509Certificate2 x509Certificate,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    x509Certificate As X509Certificate2,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
) As SAMLAttribute
public:
SAMLAttribute^ Decrypt(
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        x509Certificate : X509Certificate2 *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> SAMLAttribute

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the symmetric key or null if specified in the encrypted key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: SAMLAttribute
The SAML attribute.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the key is specified in the encrypted data or may be explicitly specified.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

EncryptedAttribute Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedAttributeEncryptedAttribute(SAMLAttribute, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)
EncryptedAttributeEncryptedAttribute(SAMLAttribute, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedAttribute.IsValid Method

EncryptedAttributeIsValid Method

Indicates whether the XML is an encrypted attribute.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an encrypted attribute; otherwise false.
See Also

Reference

EncryptedAttribute Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute.ToXml Method

EncryptedAttributeToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlDocument) | Serializes the encrypted attribute to XML.
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Top
See Also

Reference

EncryptedAttribute Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedAttribute.ToXml Method (XmlDocument)

EncryptedAttributeToXml Method (XmlDocument)

Serializes the encrypted attribute to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The encrypted attribute as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

EncryptedAttribute Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedElementType Class

Represents the encrypted element type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsEncryptedElementType
ComponentSpace.SAML2.AssertionsEncryptedAssertion
ComponentSpace.SAML2.AssertionsEncryptedAttribute
ComponentSpace.SAML2.AssertionsEncryptedID
ComponentSpace.SAML2.AssertionsNewEncryptedID

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class EncryptedElementType
Public Class EncryptedElementType
public ref class EncryptedElementType
type EncryptedElementType =  class end

The EncryptedElementType type exposes the following members.

Constructors
 | Name | Description
Public method | EncryptedElementType | Initializes a new instance of the EncryptedElementType class.
Public method | EncryptedElementType(XmlElement) | Initializes a new instance of the EncryptedElementType class from XML.
Public method | EncryptedElementType(XmlElement, XmlNodeList) | Initializes a new instance of the EncryptedElementType class.
Top
Properties
 | Name | Description
Public property | EncryptedData | Gets or sets the encrypted data.
Public property | EncryptedKeys | Gets or sets the encrypted keys.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCertificate | Gets the X.509 certificate embedded in the encrypted XML or null if none.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKeyInfo | Gets the key info embedded in the encrypted XML or null if none.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the encrypted element to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


EncryptedElementType Constructor

Overload List
 | Name | Description
Public method | EncryptedElementType | Initializes a new instance of the EncryptedElementType class.
Public method | EncryptedElementType(XmlElement) | Initializes a new instance of the EncryptedElementType class from XML.
Public method | EncryptedElementType(XmlElement, XmlNodeList) | Initializes a new instance of the EncryptedElementType class.
Top
See Also

Reference

EncryptedElementType Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedElementType Constructor

Initializes a new instance of the EncryptedElementType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedElementType()
Public Sub New
public:
EncryptedElementType()
new : unit -> EncryptedElementType
See Also

Reference

EncryptedElementType Class
EncryptedElementType Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedElementType Constructor (XmlElement)

Initializes a new instance of the EncryptedElementType class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedElementType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
EncryptedElementType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> EncryptedElementType

Parameters

xmlElement
Type: System.XmlXmlElement
The encrypted element XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

EncryptedElementType Class
EncryptedElementType Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedElementType Constructor (XmlElement, XmlNodeList)

Initializes a new instance of the EncryptedElementType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedElementType(
    XmlElement encryptedData,
    XmlNodeList encryptedKeys
)
Public Sub New (
    encryptedData As XmlElement,
    encryptedKeys As XmlNodeList
)
public:
EncryptedElementType(
    XmlElement^ encryptedData,
    XmlNodeList^ encryptedKeys
)
new :
        encryptedData : XmlElement *
        encryptedKeys : XmlNodeList -> EncryptedElementType

Parameters

encryptedData
Type: System.XmlXmlElement
The encrypted data.
encryptedKeys
Type: System.XmlXmlNodeList
The encrypted keys.
See Also

Reference

EncryptedElementType Class
EncryptedElementType Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedElementType Properties

The EncryptedElementType type exposes the following members.

Properties
 | Name | Description
Public property | EncryptedData | Gets or sets the encrypted data.
Public property | EncryptedKeys | Gets or sets the encrypted keys.
Top
See Also

Reference

EncryptedElementType Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedElementType.EncryptedData Property

EncryptedElementTypeEncryptedData Property

Gets or sets the encrypted data.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement EncryptedData { get; set; }
Public Property EncryptedData As XmlElement
    Get
    Set
public:
property XmlElement^ EncryptedData {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member EncryptedData : XmlElement with get, set

Property Value

Type: XmlElement
The encrypted data.
See Also

Reference

EncryptedElementType Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedElementType.EncryptedKeys Property

EncryptedElementTypeEncryptedKeys Property

Gets or sets the encrypted keys.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlNodeList EncryptedKeys { get; set; }
Public Property EncryptedKeys As XmlNodeList
    Get
    Set
public:
property XmlNodeList^ EncryptedKeys {
    XmlNodeList^ get ();
    void set (XmlNodeList^ value);
}
member EncryptedKeys : XmlNodeList with get, set

Property Value

Type: XmlNodeList
The encrypted keys.
See Also

Reference

EncryptedElementType Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedElementType Methods

The EncryptedElementType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCertificate | Gets the X.509 certificate embedded in the encrypted XML or null if none.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKeyInfo | Gets the key info embedded in the encrypted XML or null if none.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the encrypted element to XML.
Top
See Also

Reference

EncryptedElementType Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedElementType.GetCertificate Method

EncryptedElementTypeGetCertificate Method

Gets the X.509 certificate embedded in the encrypted XML or null if none.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static X509Certificate2 GetCertificate(
    XmlElement xmlElement
)
Public Shared Function GetCertificate (
    xmlElement As XmlElement
) As X509Certificate2
public:
static X509Certificate2^ GetCertificate(
    XmlElement^ xmlElement
)
static member GetCertificate :
        xmlElement : XmlElement -> X509Certificate2

Parameters

xmlElement
Type: System.XmlXmlElement
The encrypted XML.

Return Value

Type: X509Certificate2
The X.509 certificate embedded in the encrypted XML or null if none.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the X.509 certificate retrieval fails.
See Also

Reference

EncryptedElementType Class
ComponentSpace.SAML2.Assertions Namespace
EncryptedElementTypeGetKeyInfo(XmlElement)


EncryptedElementType.GetKeyInfo Method

EncryptedElementTypeGetKeyInfo Method

Gets the key info embedded in the encrypted XML or null if none.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static KeyInfo GetKeyInfo(
    XmlElement xmlElement
)
Public Shared Function GetKeyInfo (
    xmlElement As XmlElement
) As KeyInfo
public:
static KeyInfo^ GetKeyInfo(
    XmlElement^ xmlElement
)
static member GetKeyInfo :
        xmlElement : XmlElement -> KeyInfo

Parameters

xmlElement
Type: System.XmlXmlElement
The encrypted XML.

Return Value

Type: KeyInfo
The key info embedded in the encrypted XML or null if none.
Exceptions
Exception | Condition
SAMLEncryptionException | Thrown when the key info retrieval fails.
See Also

Reference

EncryptedElementType Class
ComponentSpace.SAML2.Assertions Namespace
EncryptedElementTypeGetCertificate(XmlElement)


EncryptedElementType.ToXml Method

EncryptedElementTypeToXml Method

Serializes the encrypted element to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void ToXml(
    XmlElement xmlElement
)
Public Sub ToXml (
    xmlElement As XmlElement
)
public:
void ToXml(
    XmlElement^ xmlElement
)
member ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.

Return Value

Type:
The encrypted element as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

EncryptedElementType Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedID Class

Represents an encrypted identifier.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsEncryptedElementType
ComponentSpace.SAML2.AssertionsEncryptedID

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class EncryptedID : EncryptedElementType
Public Class EncryptedID
    Inherits EncryptedElementType
public ref class EncryptedID : public EncryptedElementType
type EncryptedID =
    class
        inherit EncryptedElementType
    end

The EncryptedID type exposes the following members.

Constructors
 | Name | Description
Public method | EncryptedID | Initializes a new instance of the EncryptedID class.
Public method | EncryptedID(XmlElement) | Initializes a new instance of the EncryptedID class from XML.
Public method | EncryptedID(XmlElement, XmlNodeList) | Initializes a new instance of the EncryptedID class.
Public method | EncryptedID(NameID, X509Certificate2, EncryptionMethod) | Initializes a new instance of the EncryptedID class from a name identifier.
Public method | EncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedID class from a name identifier.
Public method | EncryptedID(NameID, X509Certificate2, EncryptionMethod, EncryptionMethod) | Initializes a new instance of the EncryptedID class from a name identifier.
Public method | EncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedID class from a name identifier.
Top
Properties
 | Name | Description
Public property | EncryptedData | Gets or sets the encrypted data. (Inherited from EncryptedElementType.)
Public property | EncryptedKeys | Gets or sets the encrypted keys. (Inherited from EncryptedElementType.)
Top
Methods
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an encrypted identifier.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Public method | ToXml(XmlDocument) | Serializes the encrypted identifier to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


EncryptedID Constructor

Overload List
 | Name | Description
Public method | EncryptedID | Initializes a new instance of the EncryptedID class.
Public method | EncryptedID(XmlElement) | Initializes a new instance of the EncryptedID class from XML.
Public method | EncryptedID(XmlElement, XmlNodeList) | Initializes a new instance of the EncryptedID class.
Public method | EncryptedID(NameID, X509Certificate2, EncryptionMethod) | Initializes a new instance of the EncryptedID class from a name identifier.
Public method | EncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedID class from a name identifier.
Public method | EncryptedID(NameID, X509Certificate2, EncryptionMethod, EncryptionMethod) | Initializes a new instance of the EncryptedID class from a name identifier.
Public method | EncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo) | Initializes a new instance of the EncryptedID class from a name identifier.
Top
See Also

Reference

EncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedID Constructor

Initializes a new instance of the EncryptedID class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID()
Public Sub New
public:
EncryptedID()
new : unit -> EncryptedID
See Also

Reference

EncryptedID Class
EncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedID Constructor (XmlElement)

Initializes a new instance of the EncryptedID class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
EncryptedID(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> EncryptedID

Parameters

xmlElement
Type: System.XmlXmlElement
The encrypted identifier XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

EncryptedID Class
EncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedID Constructor (XmlElement, XmlNodeList)

Initializes a new instance of the EncryptedID class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID(
    XmlElement encryptedData,
    XmlNodeList encryptedKeys
)
Public Sub New (
    encryptedData As XmlElement,
    encryptedKeys As XmlNodeList
)
public:
EncryptedID(
    XmlElement^ encryptedData,
    XmlNodeList^ encryptedKeys
)
new :
        encryptedData : XmlElement *
        encryptedKeys : XmlNodeList -> EncryptedID

Parameters

encryptedData
Type: System.XmlXmlElement
The encrypted data.
encryptedKeys
Type: System.XmlXmlNodeList
The encrypted keys.
See Also

Reference

EncryptedID Class
EncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace


EncryptedID Constructor (NameID, X509Certificate2, EncryptionMethod)

Initializes a new instance of the EncryptedID class from a name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID(
    NameID nameID,
    X509Certificate2 x509Certificate,
    EncryptionMethod dataEncryptionMethod
)
Public Sub New (
    nameID As NameID,
    x509Certificate As X509Certificate2,
    dataEncryptionMethod As EncryptionMethod
)
public:
EncryptedID(
    NameID^ nameID,
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ dataEncryptionMethod
)
new :
        nameID : NameID *
        x509Certificate : X509Certificate2 *
        dataEncryptionMethod : EncryptionMethod -> EncryptedID

Parameters

nameID
Type: ComponentSpace.SAML2.AssertionsNameID
The name identifier.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedID Class
EncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedIDDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedIDDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedID Constructor (NameID, AsymmetricAlgorithm, EncryptionMethod, KeyInfo)

Initializes a new instance of the EncryptedID class from a name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID(
    NameID nameID,
    AsymmetricAlgorithm keyEncryptingKey,
    EncryptionMethod dataEncryptionMethod,
    KeyInfo keyInfo
)
Public Sub New (
    nameID As NameID,
    keyEncryptingKey As AsymmetricAlgorithm,
    dataEncryptionMethod As EncryptionMethod,
    keyInfo As KeyInfo
)
public:
EncryptedID(
    NameID^ nameID,
    AsymmetricAlgorithm^ keyEncryptingKey,
    EncryptionMethod^ dataEncryptionMethod,
    KeyInfo^ keyInfo
)
new :
        nameID : NameID *
        keyEncryptingKey : AsymmetricAlgorithm *
        dataEncryptionMethod : EncryptionMethod *
        keyInfo : KeyInfo -> EncryptedID

Parameters

nameID
Type: ComponentSpace.SAML2.AssertionsNameID
The name identifier.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedID Class
EncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedIDDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedIDDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedID Constructor (NameID, X509Certificate2, EncryptionMethod, EncryptionMethod)

Initializes a new instance of the EncryptedID class from a name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID(
    NameID nameID,
    X509Certificate2 x509Certificate,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Sub New (
    nameID As NameID,
    x509Certificate As X509Certificate2,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
)
public:
EncryptedID(
    NameID^ nameID,
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
new :
        nameID : NameID *
        x509Certificate : X509Certificate2 *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> EncryptedID

Parameters

nameID
Type: ComponentSpace.SAML2.AssertionsNameID
The name identifier.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the symmetric key (http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p).
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The specified key encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedID Class
EncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedIDDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedIDDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedID Constructor (NameID, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)

Initializes a new instance of the EncryptedID class from a name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID(
    NameID nameID,
    AsymmetricAlgorithm keyEncryptingKey,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod,
    KeyInfo keyInfo
)
Public Sub New (
    nameID As NameID,
    keyEncryptingKey As AsymmetricAlgorithm,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod,
    keyInfo As KeyInfo
)
public:
EncryptedID(
    NameID^ nameID,
    AsymmetricAlgorithm^ keyEncryptingKey,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod,
    KeyInfo^ keyInfo
)
new :
        nameID : NameID *
        keyEncryptingKey : AsymmetricAlgorithm *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod *
        keyInfo : KeyInfo -> EncryptedID

Parameters

nameID
Type: ComponentSpace.SAML2.AssertionsNameID
The name identifier.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the symmetric key (http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p).
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The specified key encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

EncryptedID Class
EncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedIDDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
EncryptedIDDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedID Properties

The EncryptedID type exposes the following members.

Properties
 | Name | Description
Public property | EncryptedData | Gets or sets the encrypted data. (Inherited from EncryptedElementType.)
Public property | EncryptedKeys | Gets or sets the encrypted keys. (Inherited from EncryptedElementType.)
Top
See Also

Reference

EncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedID Methods

The EncryptedID type exposes the following members.

Methods
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an encrypted identifier.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Public method | ToXml(XmlDocument) | Serializes the encrypted identifier to XML.
Top
See Also

Reference

EncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedID.Decrypt Method

EncryptedIDDecrypt Method

Overload List
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Top
See Also

Reference

EncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedID.Decrypt Method (AsymmetricAlgorithm, EncryptionMethod)

EncryptedIDDecrypt Method (AsymmetricAlgorithm, EncryptionMethod)

Decrypts an encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID Decrypt(
    AsymmetricAlgorithm keyDecryptingKey,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    keyDecryptingKey As AsymmetricAlgorithm,
    dataEncryptionMethod As EncryptionMethod
) As NameID
public:
NameID^ Decrypt(
    AsymmetricAlgorithm^ keyDecryptingKey,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        keyDecryptingKey : AsymmetricAlgorithm *
        dataEncryptionMethod : EncryptionMethod -> NameID

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: NameID
The identifier.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

EncryptedID Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedIDEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, KeyInfo)
EncryptedIDEncryptedID(NameID, X509Certificate2, EncryptionMethod)


EncryptedID.Decrypt Method (X509Certificate2, EncryptionMethod)

EncryptedIDDecrypt Method (X509Certificate2, EncryptionMethod)

Decrypts an encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID Decrypt(
    X509Certificate2 x509Certificate,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    x509Certificate As X509Certificate2,
    dataEncryptionMethod As EncryptionMethod
) As NameID
public:
NameID^ Decrypt(
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        x509Certificate : X509Certificate2 *
        dataEncryptionMethod : EncryptionMethod -> NameID

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: NameID
The identifier.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

EncryptedID Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedIDEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)
EncryptedIDEncryptedID(NameID, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedID.Decrypt Method (AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)

EncryptedIDDecrypt Method (AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)

Decrypts an encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID Decrypt(
    AsymmetricAlgorithm keyDecryptingKey,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    keyDecryptingKey As AsymmetricAlgorithm,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
) As NameID
public:
NameID^ Decrypt(
    AsymmetricAlgorithm^ keyDecryptingKey,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        keyDecryptingKey : AsymmetricAlgorithm *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> NameID

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the symmetric key or null if specified in the encrypted key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: NameID
The identifier.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the key is specified in the encrypted data or may be explicitly specified.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

EncryptedID Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedIDEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, KeyInfo)
EncryptedIDEncryptedID(NameID, X509Certificate2, EncryptionMethod)


EncryptedID.Decrypt Method (X509Certificate2, EncryptionMethod, EncryptionMethod)

EncryptedIDDecrypt Method (X509Certificate2, EncryptionMethod, EncryptionMethod)

Decrypts an encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID Decrypt(
    X509Certificate2 x509Certificate,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    x509Certificate As X509Certificate2,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
) As NameID
public:
NameID^ Decrypt(
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        x509Certificate : X509Certificate2 *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> NameID

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the symmetric key or null if specified in the encrypted key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: NameID
The identifier.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the key is specified in the encrypted data or may be explicitly specified.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

EncryptedID Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
EncryptedIDEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)
EncryptedIDEncryptedID(NameID, X509Certificate2, EncryptionMethod, EncryptionMethod)


EncryptedID.IsValid Method

EncryptedIDIsValid Method

Indicates whether the XML is an encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an encrypted identifier; otherwise false.
See Also

Reference

EncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedID.ToXml Method

EncryptedIDToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Public method | ToXml(XmlDocument) | Serializes the encrypted identifier to XML.
Top
See Also

Reference

EncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


EncryptedID.ToXml Method (XmlDocument)

EncryptedIDToXml Method (XmlDocument)

Serializes the encrypted identifier to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The encrypted identifier as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

EncryptedID Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


Evidence Class

Represents evidence.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsEvidence

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Evidence
Public Class Evidence
public ref class Evidence
type Evidence =  class end

The Evidence type exposes the following members.

Constructors
 | Name | Description
Public method | Evidence | Initializes a new instance of the Evidence class.
Public method | Evidence(XmlElement) | Initializes a new instance of the Evidence class from XML.
Top
Properties
 | Name | Description
Public property | EvidenceList | Gets or sets the list of evidence.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is evidence.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the evidence to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


Evidence Constructor

Overload List
 | Name | Description
Public method | Evidence | Initializes a new instance of the Evidence class.
Public method | Evidence(XmlElement) | Initializes a new instance of the Evidence class from XML.
Top
See Also

Reference

Evidence Class
ComponentSpace.SAML2.Assertions Namespace


Evidence Constructor

Initializes a new instance of the Evidence class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Evidence()
Public Sub New
public:
Evidence()
new : unit -> Evidence
See Also

Reference

Evidence Class
Evidence Overload
ComponentSpace.SAML2.Assertions Namespace


Evidence Constructor (XmlElement)

Initializes a new instance of the Evidence class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Evidence(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Evidence(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Evidence

Parameters

xmlElement
Type: System.XmlXmlElement
The evidence XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Evidence Class
Evidence Overload
ComponentSpace.SAML2.Assertions Namespace


Evidence Properties

The Evidence type exposes the following members.

Properties
 | Name | Description
Public property | EvidenceList | Gets or sets the list of evidence.
Top
See Also

Reference

Evidence Class
ComponentSpace.SAML2.Assertions Namespace


Evidence.EvidenceList Property

EvidenceEvidenceList Property

Gets or sets the list of evidence.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList EvidenceList { get; set; }
Public Property EvidenceList As IList
    Get
    Set
public:
property IList^ EvidenceList {
    IList^ get ();
    void set (IList^ value);
}
member EvidenceList : IList with get, set

Property Value

Type: IList
The list of evidence.
See Also

Reference

Evidence Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAssertionIDRef
ComponentSpace.SAML2.AssertionsAssertionURIRef
ComponentSpace.SAML2.AssertionsSAMLAssertion
ComponentSpace.SAML2.AssertionsEncryptedAssertion


Evidence Methods

The Evidence type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is evidence.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the evidence to XML.
Top
See Also

Reference

Evidence Class
ComponentSpace.SAML2.Assertions Namespace


Evidence.IsValid Method

EvidenceIsValid Method

Indicates whether the XML is evidence.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is evidence; otherwise false.
See Also

Reference

Evidence Class
ComponentSpace.SAML2.Assertions Namespace


Evidence.ToXml Method

EvidenceToXml Method

Serializes the evidence to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The evidence as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Evidence Class
ComponentSpace.SAML2.Assertions Namespace


IAttributeValueSerializer Interface

The interface for serializing attribute values to XML. Implement this interface to support custom attribute values.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public interface IAttributeValueSerializer
Public Interface IAttributeValueSerializer
public interface class IAttributeValueSerializer
type IAttributeValueSerializer =  interface end

The IAttributeValueSerializer type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | Deserializes the attribute value from XML.
Public method | Serialize | Serialize the attribute value to XML.
Top
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAttributeValue
AttributeTypeRegisterAttributeValueSerializer(String, String, IAttributeValueSerializer)
ComponentSpace.SAML2.AssertionsStringAttributeValueSerializer
ComponentSpace.SAML2.AssertionsXmlAttributeValueSerializer


IAttributeValueSerializer Methods

The IAttributeValueSerializer type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | Deserializes the attribute value from XML.
Public method | Serialize | Serialize the attribute value to XML.
Top
See Also

Reference

IAttributeValueSerializer Interface
ComponentSpace.SAML2.Assertions Namespace


IAttributeValueSerializer.Deserialize Method

IAttributeValueSerializerDeserialize Method

Deserializes the attribute value from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
Object Deserialize(
    XmlElement parentElement
)
Function Deserialize (
    parentElement As XmlElement
) As Object
Object^ Deserialize(
    XmlElement^ parentElement
)
abstract Deserialize :
        parentElement : XmlElement -> Object

Parameters

parentElement
Type: System.XmlXmlElement
The parent element of the attribute value.

Return Value

Type: Object
The attribute value.
See Also

Reference

IAttributeValueSerializer Interface
ComponentSpace.SAML2.Assertions Namespace


IAttributeValueSerializer.Serialize Method

IAttributeValueSerializerSerialize Method

Serialize the attribute value to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void Serialize(
    XmlElement parentElement,
    Object attributeValue
)
Sub Serialize (
    parentElement As XmlElement,
    attributeValue As Object
)
void Serialize(
    XmlElement^ parentElement,
    Object^ attributeValue
)
abstract Serialize :
        parentElement : XmlElement *
        attributeValue : Object -> unit

Parameters

parentElement
Type: System.XmlXmlElement
The parent element of the attribute value.
attributeValue
Type: SystemObject
The attribute value.
See Also

Reference

IAttributeValueSerializer Interface
ComponentSpace.SAML2.Assertions Namespace


ICondition Interface

Represents a condition.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public interface ICondition
Public Interface ICondition
public interface class ICondition
type ICondition =  interface end
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


Issuer Class

Represents an issuer.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsNameIDType
ComponentSpace.SAML2.AssertionsIssuer

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Issuer : NameIDType
Public Class Issuer
    Inherits NameIDType
public ref class Issuer : public NameIDType
type Issuer =
    class
        inherit NameIDType
    end

The Issuer type exposes the following members.

Constructors
 | Name | Description
Public method | Issuer | Initializes a new instance of the Issuer class.
Public method | Issuer(String) | Initializes a new instance of the Issuer class.
Public method | Issuer(XmlElement) | Initializes a new instance of the Issuer class from XML.
Public method | Issuer(String, String, String, String, String) | Initializes a new instance of the Issuer class.
Top
Properties
 | Name | Description
Public property | Format | Gets or sets the format. (Inherited from NameIDType.)
Public property | NameIdentifier | Gets or sets the name ID. (Inherited from NameIDType.)
Public property | NameQualifier | Gets or sets the name qualifier. (Inherited from NameIDType.)
Public property | SPNameQualifier | Gets or sets the SP name qualifier. (Inherited from NameIDType.)
Public property | SPProvidedID | Gets or sets the SP provided ID. (Inherited from NameIDType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAnyIssuer | Gets the issuer. The issuer is a descendant element.
 | GetAnyIssuerName | Gets the issuer name. The issuer is a descendant element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIssuer | Gets the issuer. The issuer is a child element.
 | GetIssuerName | Gets the issuer name. The issuer is a child element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an issuer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the issuer to XML.
Public method | ToXml(XmlElement) | Serializes the name identifier to XML. (Inherited from NameIDType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


Issuer Constructor

Overload List
 | Name | Description
Public method | Issuer | Initializes a new instance of the Issuer class.
Public method | Issuer(String) | Initializes a new instance of the Issuer class.
Public method | Issuer(XmlElement) | Initializes a new instance of the Issuer class from XML.
Public method | Issuer(String, String, String, String, String) | Initializes a new instance of the Issuer class.
Top
See Also

Reference

Issuer Class
ComponentSpace.SAML2.Assertions Namespace


Issuer Constructor

Initializes a new instance of the Issuer class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Issuer()
Public Sub New
public:
Issuer()
new : unit -> Issuer
See Also

Reference

Issuer Class
Issuer Overload
ComponentSpace.SAML2.Assertions Namespace


Issuer Constructor (String)

Initializes a new instance of the Issuer class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Issuer(
    string nameID
)
Public Sub New (
    nameID As String
)
public:
Issuer(
    String^ nameID
)
new :
        nameID : string -> Issuer

Parameters

nameID
Type: SystemString
The name ID.
See Also

Reference

Issuer Class
Issuer Overload
ComponentSpace.SAML2.Assertions Namespace


Issuer Constructor (XmlElement)

Initializes a new instance of the Issuer class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Issuer(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Issuer(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Issuer

Parameters

xmlElement
Type: System.XmlXmlElement
The issuer XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Issuer Class
Issuer Overload
ComponentSpace.SAML2.Assertions Namespace


Issuer Constructor (String, String, String, String, String)

Initializes a new instance of the Issuer class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Issuer(
    string nameID,
    string nameQualifier,
    string spNameQualifier,
    string format,
    string spProvidedID
)
Public Sub New (
    nameID As String,
    nameQualifier As String,
    spNameQualifier As String,
    format As String,
    spProvidedID As String
)
public:
Issuer(
    String^ nameID,
    String^ nameQualifier,
    String^ spNameQualifier,
    String^ format,
    String^ spProvidedID
)
new :
        nameID : string *
        nameQualifier : string *
        spNameQualifier : string *
        format : string *
        spProvidedID : string -> Issuer

Parameters

nameID
Type: SystemString
The name ID.
nameQualifier
Type: SystemString
The name qualifier.
spNameQualifier
Type: SystemString
The SP name qualifier.
format
Type: SystemString
The format.
spProvidedID
Type: SystemString
The SP provided ID.
See Also

Reference

Issuer Class
Issuer Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersNameIdentifierFormats


Issuer Properties

The Issuer type exposes the following members.

Properties
 | Name | Description
Public property | Format | Gets or sets the format. (Inherited from NameIDType.)
Public property | NameIdentifier | Gets or sets the name ID. (Inherited from NameIDType.)
Public property | NameQualifier | Gets or sets the name qualifier. (Inherited from NameIDType.)
Public property | SPNameQualifier | Gets or sets the SP name qualifier. (Inherited from NameIDType.)
Public property | SPProvidedID | Gets or sets the SP provided ID. (Inherited from NameIDType.)
Top
See Also

Reference

Issuer Class
ComponentSpace.SAML2.Assertions Namespace


Issuer Methods

The Issuer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAnyIssuer | Gets the issuer. The issuer is a descendant element.
 | GetAnyIssuerName | Gets the issuer name. The issuer is a descendant element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIssuer | Gets the issuer. The issuer is a child element.
 | GetIssuerName | Gets the issuer name. The issuer is a child element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an issuer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the issuer to XML.
Public method | ToXml(XmlElement) | Serializes the name identifier to XML. (Inherited from NameIDType.)
Top
See Also

Reference

Issuer Class
ComponentSpace.SAML2.Assertions Namespace


Issuer.GetAnyIssuer Method

IssuerGetAnyIssuer Method

Gets the issuer.

The issuer is a descendant element.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static Issuer GetAnyIssuer(
    XmlElement xmlElement
)
Public Shared Function GetAnyIssuer (
    xmlElement As XmlElement
) As Issuer
public:
static Issuer^ GetAnyIssuer(
    XmlElement^ xmlElement
)
static member GetAnyIssuer :
        xmlElement : XmlElement -> Issuer

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element containing the issuer as a descendant element.

Return Value

Type: Issuer
The issuer or null if none.
See Also

Reference

Issuer Class
ComponentSpace.SAML2.Assertions Namespace


Issuer.GetAnyIssuerName Method

IssuerGetAnyIssuerName Method

Gets the issuer name.

The issuer is a descendant element.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetAnyIssuerName(
    XmlElement xmlElement
)
Public Shared Function GetAnyIssuerName (
    xmlElement As XmlElement
) As String
public:
static String^ GetAnyIssuerName(
    XmlElement^ xmlElement
)
static member GetAnyIssuerName :
        xmlElement : XmlElement -> string

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element containing the issuer as a descendant element.

Return Value

Type: String
The issuer name or null if none.
See Also

Reference

Issuer Class
ComponentSpace.SAML2.Assertions Namespace


Issuer.GetIssuer Method

IssuerGetIssuer Method

Gets the issuer.

The issuer is a child element.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static Issuer GetIssuer(
    XmlElement xmlElement
)
Public Shared Function GetIssuer (
    xmlElement As XmlElement
) As Issuer
public:
static Issuer^ GetIssuer(
    XmlElement^ xmlElement
)
static member GetIssuer :
        xmlElement : XmlElement -> Issuer

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element containing the issuer as a child element.

Return Value

Type: Issuer
The issuer or null if none.
See Also

Reference

Issuer Class
ComponentSpace.SAML2.Assertions Namespace


Issuer.GetIssuerName Method

IssuerGetIssuerName Method

Gets the issuer name.

The issuer is a child element.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetIssuerName(
    XmlElement xmlElement
)
Public Shared Function GetIssuerName (
    xmlElement As XmlElement
) As String
public:
static String^ GetIssuerName(
    XmlElement^ xmlElement
)
static member GetIssuerName :
        xmlElement : XmlElement -> string

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element containing the issuer as a child element.

Return Value

Type: String
The issuer name or null if none.
See Also

Reference

Issuer Class
ComponentSpace.SAML2.Assertions Namespace


Issuer.IsValid Method

IssuerIsValid Method

Indicates whether the XML is an issuer.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an issuer; otherwise false.
See Also

Reference

Issuer Class
ComponentSpace.SAML2.Assertions Namespace


Issuer.ToXml Method

IssuerToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlDocument) | Serializes the issuer to XML.
Public method | ToXml(XmlElement) | Serializes the name identifier to XML. (Inherited from NameIDType.)
Top
See Also

Reference

Issuer Class
ComponentSpace.SAML2.Assertions Namespace


Issuer.ToXml Method (XmlDocument)

IssuerToXml Method (XmlDocument)

Serializes the issuer to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The issuer as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Issuer Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


IStatement Interface

Represents a statement.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public interface IStatement
Public Interface IStatement
public interface class IStatement
type IStatement =  interface end
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


NameID Class

Represents a name identifier.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsNameIDType
ComponentSpace.SAML2.AssertionsNameID

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class NameID : NameIDType
Public Class NameID
    Inherits NameIDType
public ref class NameID : public NameIDType
type NameID =
    class
        inherit NameIDType
    end

The NameID type exposes the following members.

Constructors
 | Name | Description
Public method | NameID | Initializes a new instance of the NameID class.
Public method | NameID(String) | Initializes a new instance of the NameID class.
Public method | NameID(XmlElement) | Initializes a new instance of the NameID class from XML.
Public method | NameID(String, String, String, String, String) | Initializes a new instance of the NameID class.
Top
Properties
 | Name | Description
Public property | Format | Gets or sets the format. (Inherited from NameIDType.)
Public property | NameIdentifier | Gets or sets the name ID. (Inherited from NameIDType.)
Public property | NameQualifier | Gets or sets the name qualifier. (Inherited from NameIDType.)
Public property | SPNameQualifier | Gets or sets the SP name qualifier. (Inherited from NameIDType.)
Public property | SPProvidedID | Gets or sets the SP provided ID. (Inherited from NameIDType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a name identifier.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the name identifier to XML.
Public method | ToXml(XmlElement) | Serializes the name identifier to XML. (Inherited from NameIDType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


NameID Constructor

Overload List
 | Name | Description
Public method | NameID | Initializes a new instance of the NameID class.
Public method | NameID(String) | Initializes a new instance of the NameID class.
Public method | NameID(XmlElement) | Initializes a new instance of the NameID class from XML.
Public method | NameID(String, String, String, String, String) | Initializes a new instance of the NameID class.
Top
See Also

Reference

NameID Class
ComponentSpace.SAML2.Assertions Namespace


NameID Constructor

Initializes a new instance of the NameID class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID()
Public Sub New
public:
NameID()
new : unit -> NameID
See Also

Reference

NameID Class
NameID Overload
ComponentSpace.SAML2.Assertions Namespace


NameID Constructor (String)

Initializes a new instance of the NameID class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID(
    string nameID
)
Public Sub New (
    nameID As String
)
public:
NameID(
    String^ nameID
)
new :
        nameID : string -> NameID

Parameters

nameID
Type: SystemString
The name ID.
See Also

Reference

NameID Class
NameID Overload
ComponentSpace.SAML2.Assertions Namespace


NameID Constructor (XmlElement)

Initializes a new instance of the NameID class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
NameID(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> NameID

Parameters

xmlElement
Type: System.XmlXmlElement
The name identifier XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

NameID Class
NameID Overload
ComponentSpace.SAML2.Assertions Namespace


NameID Constructor (String, String, String, String, String)

Initializes a new instance of the NameID class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID(
    string nameID,
    string nameQualifier,
    string spNameQualifier,
    string format,
    string spProvidedID
)
Public Sub New (
    nameID As String,
    nameQualifier As String,
    spNameQualifier As String,
    format As String,
    spProvidedID As String
)
public:
NameID(
    String^ nameID,
    String^ nameQualifier,
    String^ spNameQualifier,
    String^ format,
    String^ spProvidedID
)
new :
        nameID : string *
        nameQualifier : string *
        spNameQualifier : string *
        format : string *
        spProvidedID : string -> NameID

Parameters

nameID
Type: SystemString
The name ID.
nameQualifier
Type: SystemString
The name qualifier.
spNameQualifier
Type: SystemString
The SP name qualifier.
format
Type: SystemString
The format.
spProvidedID
Type: SystemString
The SP provided ID.
See Also

Reference

NameID Class
NameID Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersNameIdentifierFormats


NameID Properties

The NameID type exposes the following members.

Properties
 | Name | Description
Public property | Format | Gets or sets the format. (Inherited from NameIDType.)
Public property | NameIdentifier | Gets or sets the name ID. (Inherited from NameIDType.)
Public property | NameQualifier | Gets or sets the name qualifier. (Inherited from NameIDType.)
Public property | SPNameQualifier | Gets or sets the SP name qualifier. (Inherited from NameIDType.)
Public property | SPProvidedID | Gets or sets the SP provided ID. (Inherited from NameIDType.)
Top
See Also

Reference

NameID Class
ComponentSpace.SAML2.Assertions Namespace


NameID Methods

The NameID type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a name identifier.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the name identifier to XML.
Public method | ToXml(XmlElement) | Serializes the name identifier to XML. (Inherited from NameIDType.)
Top
See Also

Reference

NameID Class
ComponentSpace.SAML2.Assertions Namespace


NameID.IsValid Method

NameIDIsValid Method

Indicates whether the XML is a name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a name identifier; otherwise false.
See Also

Reference

NameID Class
ComponentSpace.SAML2.Assertions Namespace


NameID.ToXml Method

NameIDToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlDocument) | Serializes the name identifier to XML.
Public method | ToXml(XmlElement) | Serializes the name identifier to XML. (Inherited from NameIDType.)
Top
See Also

Reference

NameID Class
ComponentSpace.SAML2.Assertions Namespace


NameID.ToXml Method (XmlDocument)

NameIDToXml Method (XmlDocument)

Serializes the name identifier to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The name identifier as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

NameID Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


NameIDType Class

Represents the name identifier type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsNameIDType
ComponentSpace.SAML2.AssertionsIssuer
ComponentSpace.SAML2.AssertionsNameID

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class NameIDType
Public Class NameIDType
public ref class NameIDType
type NameIDType =  class end

The NameIDType type exposes the following members.

Constructors
 | Name | Description
Public method | NameIDType | Initializes a new instance of the NameIDType class.
Public method | NameIDType(String) | Initializes a new instance of the NameIDType class.
Public method | NameIDType(XmlElement) | Initializes a new instance of the NameIDType class from XML.
Public method | NameIDType(String, String, String, String, String) | Initializes a new instance of the NameIDType class.
Top
Properties
 | Name | Description
Public property | Format | Gets or sets the format.
Public property | NameIdentifier | Gets or sets the name ID.
Public property | NameQualifier | Gets or sets the name qualifier.
Public property | SPNameQualifier | Gets or sets the SP name qualifier.
Public property | SPProvidedID | Gets or sets the SP provided ID.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the name identifier to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


NameIDType Constructor

Overload List
 | Name | Description
Public method | NameIDType | Initializes a new instance of the NameIDType class.
Public method | NameIDType(String) | Initializes a new instance of the NameIDType class.
Public method | NameIDType(XmlElement) | Initializes a new instance of the NameIDType class from XML.
Public method | NameIDType(String, String, String, String, String) | Initializes a new instance of the NameIDType class.
Top
See Also

Reference

NameIDType Class
ComponentSpace.SAML2.Assertions Namespace


NameIDType Constructor

Initializes a new instance of the NameIDType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDType()
Public Sub New
public:
NameIDType()
new : unit -> NameIDType
See Also

Reference

NameIDType Class
NameIDType Overload
ComponentSpace.SAML2.Assertions Namespace


NameIDType Constructor (String)

Initializes a new instance of the NameIDType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDType(
    string nameID
)
Public Sub New (
    nameID As String
)
public:
NameIDType(
    String^ nameID
)
new :
        nameID : string -> NameIDType

Parameters

nameID
Type: SystemString
The name ID.
See Also

Reference

NameIDType Class
NameIDType Overload
ComponentSpace.SAML2.Assertions Namespace


NameIDType Constructor (XmlElement)

Initializes a new instance of the NameIDType class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
NameIDType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> NameIDType

Parameters

xmlElement
Type: System.XmlXmlElement
The name identifier XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

NameIDType Class
NameIDType Overload
ComponentSpace.SAML2.Assertions Namespace


NameIDType Constructor (String, String, String, String, String)

Initializes a new instance of the NameIDType class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDType(
    string nameID,
    string nameQualifier,
    string spNameQualifier,
    string format,
    string spProvidedID
)
Public Sub New (
    nameID As String,
    nameQualifier As String,
    spNameQualifier As String,
    format As String,
    spProvidedID As String
)
public:
NameIDType(
    String^ nameID,
    String^ nameQualifier,
    String^ spNameQualifier,
    String^ format,
    String^ spProvidedID
)
new :
        nameID : string *
        nameQualifier : string *
        spNameQualifier : string *
        format : string *
        spProvidedID : string -> NameIDType

Parameters

nameID
Type: SystemString
The name ID.
nameQualifier
Type: SystemString
The name qualifier.
spNameQualifier
Type: SystemString
The SP name qualifier.
format
Type: SystemString
The format.
spProvidedID
Type: SystemString
The SP provided ID.
See Also

Reference

NameIDType Class
NameIDType Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersNameIdentifierFormats


NameIDType Properties

The NameIDType type exposes the following members.

Properties
 | Name | Description
Public property | Format | Gets or sets the format.
Public property | NameIdentifier | Gets or sets the name ID.
Public property | NameQualifier | Gets or sets the name qualifier.
Public property | SPNameQualifier | Gets or sets the SP name qualifier.
Public property | SPProvidedID | Gets or sets the SP provided ID.
Top
See Also

Reference

NameIDType Class
ComponentSpace.SAML2.Assertions Namespace


NameIDType.Format Property

NameIDTypeFormat Property

Gets or sets the format.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
member Format : string with get, set

Property Value

Type: String
The format.
See Also

Reference

NameIDType Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersNameIdentifierFormats


NameIDType.NameIdentifier Property

NameIDTypeNameIdentifier Property

Gets or sets the name ID.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string NameIdentifier { get; set; }
Public Property NameIdentifier As String
    Get
    Set
public:
property String^ NameIdentifier {
    String^ get ();
    void set (String^ value);
}
member NameIdentifier : string with get, set

Property Value

Type: String
The name ID.
See Also

Reference

NameIDType Class
ComponentSpace.SAML2.Assertions Namespace


NameIDType.NameQualifier Property

NameIDTypeNameQualifier Property

Gets or sets the name qualifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string NameQualifier { get; set; }
Public Property NameQualifier As String
    Get
    Set
public:
property String^ NameQualifier {
    String^ get ();
    void set (String^ value);
}
member NameQualifier : string with get, set

Property Value

Type: String
The name qualifier.
See Also

Reference

NameIDType Class
ComponentSpace.SAML2.Assertions Namespace


NameIDType.SPNameQualifier Property

NameIDTypeSPNameQualifier Property

Gets or sets the SP name qualifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SPNameQualifier { get; set; }
Public Property SPNameQualifier As String
    Get
    Set
public:
property String^ SPNameQualifier {
    String^ get ();
    void set (String^ value);
}
member SPNameQualifier : string with get, set

Property Value

Type: String
The SP name qualifier.
See Also

Reference

NameIDType Class
ComponentSpace.SAML2.Assertions Namespace


NameIDType.SPProvidedID Property

NameIDTypeSPProvidedID Property

Gets or sets the SP provided ID.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SPProvidedID { get; set; }
Public Property SPProvidedID As String
    Get
    Set
public:
property String^ SPProvidedID {
    String^ get ();
    void set (String^ value);
}
member SPProvidedID : string with get, set

Property Value

Type: String
The SP provided ID.
See Also

Reference

NameIDType Class
ComponentSpace.SAML2.Assertions Namespace


NameIDType Methods

The NameIDType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the name identifier to XML.
Top
See Also

Reference

NameIDType Class
ComponentSpace.SAML2.Assertions Namespace


NameIDType.ToXml Method

NameIDTypeToXml Method

Serializes the name identifier to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void ToXml(
    XmlElement xmlElement
)
Public Sub ToXml (
    xmlElement As XmlElement
)
public:
void ToXml(
    XmlElement^ xmlElement
)
member ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

NameIDType Class
ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID Class

Represents a new encrypted identifier.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsEncryptedElementType
ComponentSpace.SAML2.AssertionsNewEncryptedID

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class NewEncryptedID : EncryptedElementType
Public Class NewEncryptedID
    Inherits EncryptedElementType
public ref class NewEncryptedID : public EncryptedElementType
type NewEncryptedID =
    class
        inherit EncryptedElementType
    end

The NewEncryptedID type exposes the following members.

Constructors
 | Name | Description
Public method | NewEncryptedID | Initializes a new instance of the NewEncryptedID class.
Public method | NewEncryptedID(XmlElement) | Initializes a new instance of the NewEncryptedID class from XML.
Public method | NewEncryptedID(XmlElement, XmlNodeList) | Initializes a new instance of the NewEncryptedID class.
Public method | NewEncryptedID(NameID, X509Certificate2, EncryptionMethod) | Initializes a new instance of the NewEncryptedID class from a name identifier.
Public method | NewEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, KeyInfo) | Initializes a new instance of the NewEncryptedID class from a name identifier.
Public method | NewEncryptedID(NameID, X509Certificate2, EncryptionMethod, EncryptionMethod) | Initializes a new instance of the NewEncryptedID class from a name identifier.
Public method | NewEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo) | Initializes a new instance of the NewEncryptedID class from a name identifier.
Top
Properties
 | Name | Description
Public property | EncryptedData | Gets or sets the encrypted data. (Inherited from EncryptedElementType.)
Public property | EncryptedKeys | Gets or sets the encrypted keys. (Inherited from EncryptedElementType.)
Top
Methods
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a new encrypted identifier.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Public method | ToXml(XmlDocument) | Serializes the new encrypted identifier to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID Constructor

Overload List
 | Name | Description
Public method | NewEncryptedID | Initializes a new instance of the NewEncryptedID class.
Public method | NewEncryptedID(XmlElement) | Initializes a new instance of the NewEncryptedID class from XML.
Public method | NewEncryptedID(XmlElement, XmlNodeList) | Initializes a new instance of the NewEncryptedID class.
Public method | NewEncryptedID(NameID, X509Certificate2, EncryptionMethod) | Initializes a new instance of the NewEncryptedID class from a name identifier.
Public method | NewEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, KeyInfo) | Initializes a new instance of the NewEncryptedID class from a name identifier.
Public method | NewEncryptedID(NameID, X509Certificate2, EncryptionMethod, EncryptionMethod) | Initializes a new instance of the NewEncryptedID class from a name identifier.
Public method | NewEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo) | Initializes a new instance of the NewEncryptedID class from a name identifier.
Top
See Also

Reference

NewEncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID Constructor

Initializes a new instance of the NewEncryptedID class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewEncryptedID()
Public Sub New
public:
NewEncryptedID()
new : unit -> NewEncryptedID
See Also

Reference

NewEncryptedID Class
NewEncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID Constructor (XmlElement)

Initializes a new instance of the NewEncryptedID class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewEncryptedID(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
NewEncryptedID(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> NewEncryptedID

Parameters

xmlElement
Type: System.XmlXmlElement
The new encrypted identifier XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

NewEncryptedID Class
NewEncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID Constructor (XmlElement, XmlNodeList)

Initializes a new instance of the NewEncryptedID class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewEncryptedID(
    XmlElement encryptedData,
    XmlNodeList encryptedKeys
)
Public Sub New (
    encryptedData As XmlElement,
    encryptedKeys As XmlNodeList
)
public:
NewEncryptedID(
    XmlElement^ encryptedData,
    XmlNodeList^ encryptedKeys
)
new :
        encryptedData : XmlElement *
        encryptedKeys : XmlNodeList -> NewEncryptedID

Parameters

encryptedData
Type: System.XmlXmlElement
The encrypted data.
encryptedKeys
Type: System.XmlXmlNodeList
The encrypted keys.
See Also

Reference

NewEncryptedID Class
NewEncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID Constructor (NameID, X509Certificate2, EncryptionMethod)

Initializes a new instance of the NewEncryptedID class from a name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewEncryptedID(
    NameID nameID,
    X509Certificate2 x509Certificate,
    EncryptionMethod dataEncryptionMethod
)
Public Sub New (
    nameID As NameID,
    x509Certificate As X509Certificate2,
    dataEncryptionMethod As EncryptionMethod
)
public:
NewEncryptedID(
    NameID^ nameID,
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ dataEncryptionMethod
)
new :
        nameID : NameID *
        x509Certificate : X509Certificate2 *
        dataEncryptionMethod : EncryptionMethod -> NewEncryptedID

Parameters

nameID
Type: ComponentSpace.SAML2.AssertionsNameID
The name identifier.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

NewEncryptedID Class
NewEncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace
NewEncryptedIDDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
NewEncryptedIDDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


NewEncryptedID Constructor (NameID, AsymmetricAlgorithm, EncryptionMethod, KeyInfo)

Initializes a new instance of the NewEncryptedID class from a name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewEncryptedID(
    NameID nameID,
    AsymmetricAlgorithm keyEncryptingKey,
    EncryptionMethod dataEncryptionMethod,
    KeyInfo keyInfo
)
Public Sub New (
    nameID As NameID,
    keyEncryptingKey As AsymmetricAlgorithm,
    dataEncryptionMethod As EncryptionMethod,
    keyInfo As KeyInfo
)
public:
NewEncryptedID(
    NameID^ nameID,
    AsymmetricAlgorithm^ keyEncryptingKey,
    EncryptionMethod^ dataEncryptionMethod,
    KeyInfo^ keyInfo
)
new :
        nameID : NameID *
        keyEncryptingKey : AsymmetricAlgorithm *
        dataEncryptionMethod : EncryptionMethod *
        keyInfo : KeyInfo -> NewEncryptedID

Parameters

nameID
Type: ComponentSpace.SAML2.AssertionsNameID
The name identifier.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The encryption method for the encrypted symmetric key is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

NewEncryptedID Class
NewEncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace
NewEncryptedIDDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
NewEncryptedIDDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


NewEncryptedID Constructor (NameID, X509Certificate2, EncryptionMethod, EncryptionMethod)

Initializes a new instance of the NewEncryptedID class from a name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewEncryptedID(
    NameID nameID,
    X509Certificate2 x509Certificate,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Sub New (
    nameID As NameID,
    x509Certificate As X509Certificate2,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
)
public:
NewEncryptedID(
    NameID^ nameID,
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
new :
        nameID : NameID *
        x509Certificate : X509Certificate2 *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> NewEncryptedID

Parameters

nameID
Type: ComponentSpace.SAML2.AssertionsNameID
The name identifier.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used when encrypting the data.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the symmetric key (http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p).
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public key contained within the X.509 certificate. The symmetric key is used to encrypt the data.

The specified key encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

NewEncryptedID Class
NewEncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace
NewEncryptedIDDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
NewEncryptedIDDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


NewEncryptedID Constructor (NameID, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)

Initializes a new instance of the NewEncryptedID class from a name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewEncryptedID(
    NameID nameID,
    AsymmetricAlgorithm keyEncryptingKey,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod,
    KeyInfo keyInfo
)
Public Sub New (
    nameID As NameID,
    keyEncryptingKey As AsymmetricAlgorithm,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod,
    keyInfo As KeyInfo
)
public:
NewEncryptedID(
    NameID^ nameID,
    AsymmetricAlgorithm^ keyEncryptingKey,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod,
    KeyInfo^ keyInfo
)
new :
        nameID : NameID *
        keyEncryptingKey : AsymmetricAlgorithm *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod *
        keyInfo : KeyInfo -> NewEncryptedID

Parameters

nameID
Type: ComponentSpace.SAML2.AssertionsNameID
The name identifier.
keyEncryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key encrypting key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the symmetric key (http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p).
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for encrypting the data.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include with the encrypted data.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the encryption fails.
Remarks
A random symmetric session key is generated from the public asymmetric key. The symmetric key is used to encrypt the data.

The specified key encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#rsa-1_5.

The specified data encryption method is used. For example, http://www.w3.org/2001/04/xmlenc#aes256-cbc.

See Also

Reference

NewEncryptedID Class
NewEncryptedID Overload
ComponentSpace.SAML2.Assertions Namespace
NewEncryptedIDDecrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)
NewEncryptedIDDecrypt(X509Certificate2, EncryptionMethod, EncryptionMethod)


NewEncryptedID Properties

The NewEncryptedID type exposes the following members.

Properties
 | Name | Description
Public property | EncryptedData | Gets or sets the encrypted data. (Inherited from EncryptedElementType.)
Public property | EncryptedKeys | Gets or sets the encrypted keys. (Inherited from EncryptedElementType.)
Top
See Also

Reference

NewEncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID Methods

The NewEncryptedID type exposes the following members.

Methods
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a new encrypted identifier.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Public method | ToXml(XmlDocument) | Serializes the new encrypted identifier to XML.
Top
See Also

Reference

NewEncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID.Decrypt Method

NewEncryptedIDDecrypt Method

Overload List
 | Name | Description
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Public method | Decrypt(X509Certificate2, EncryptionMethod, EncryptionMethod) | Decrypts an encrypted identifier.
Top
See Also

Reference

NewEncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID.Decrypt Method (AsymmetricAlgorithm, EncryptionMethod)

NewEncryptedIDDecrypt Method (AsymmetricAlgorithm, EncryptionMethod)

Decrypts an encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID Decrypt(
    AsymmetricAlgorithm keyDecryptingKey,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    keyDecryptingKey As AsymmetricAlgorithm,
    dataEncryptionMethod As EncryptionMethod
) As NameID
public:
NameID^ Decrypt(
    AsymmetricAlgorithm^ keyDecryptingKey,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        keyDecryptingKey : AsymmetricAlgorithm *
        dataEncryptionMethod : EncryptionMethod -> NameID

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: NameID
The identifier.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

NewEncryptedID Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
NewEncryptedIDNewEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)
NewEncryptedIDNewEncryptedID(NameID, X509Certificate2, EncryptionMethod, EncryptionMethod)


NewEncryptedID.Decrypt Method (X509Certificate2, EncryptionMethod)

NewEncryptedIDDecrypt Method (X509Certificate2, EncryptionMethod)

Decrypts an encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID Decrypt(
    X509Certificate2 x509Certificate,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    x509Certificate As X509Certificate2,
    dataEncryptionMethod As EncryptionMethod
) As NameID
public:
NameID^ Decrypt(
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        x509Certificate : X509Certificate2 *
        dataEncryptionMethod : EncryptionMethod -> NameID

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: NameID
The identifier.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

NewEncryptedID Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
NewEncryptedIDNewEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, KeyInfo)
NewEncryptedIDNewEncryptedID(NameID, X509Certificate2, EncryptionMethod)


NewEncryptedID.Decrypt Method (AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)

NewEncryptedIDDecrypt Method (AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod)

Decrypts an encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID Decrypt(
    AsymmetricAlgorithm keyDecryptingKey,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    keyDecryptingKey As AsymmetricAlgorithm,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
) As NameID
public:
NameID^ Decrypt(
    AsymmetricAlgorithm^ keyDecryptingKey,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        keyDecryptingKey : AsymmetricAlgorithm *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> NameID

Parameters

keyDecryptingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The asymmetric key decrypting key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the symmetric key or null if specified in the encrypted key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: NameID
The identifier.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The asymmetric key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the key is specified in the encrypted data or may be explicitly specified.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

NewEncryptedID Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
NewEncryptedIDNewEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, EncryptionMethod, KeyInfo)
NewEncryptedIDNewEncryptedID(NameID, X509Certificate2, EncryptionMethod, EncryptionMethod)


NewEncryptedID.Decrypt Method (X509Certificate2, EncryptionMethod, EncryptionMethod)

NewEncryptedIDDecrypt Method (X509Certificate2, EncryptionMethod, EncryptionMethod)

Decrypts an encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID Decrypt(
    X509Certificate2 x509Certificate,
    EncryptionMethod keyEncryptionMethod,
    EncryptionMethod dataEncryptionMethod
)
Public Function Decrypt (
    x509Certificate As X509Certificate2,
    keyEncryptionMethod As EncryptionMethod,
    dataEncryptionMethod As EncryptionMethod
) As NameID
public:
NameID^ Decrypt(
    X509Certificate2^ x509Certificate,
    EncryptionMethod^ keyEncryptionMethod,
    EncryptionMethod^ dataEncryptionMethod
)
member Decrypt :
        x509Certificate : X509Certificate2 *
        keyEncryptionMethod : EncryptionMethod *
        dataEncryptionMethod : EncryptionMethod -> NameID

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate containing a private key.
keyEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the symmetric key or null if specified in the encrypted key.
dataEncryptionMethod
Type: System.Security.Cryptography.XmlEncryptionMethod
The method for decrypting the data or null if specified in the encrypted data.

Return Value

Type: NameID
The identifier.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
SAMLEncryptionException | Thrown when the decryption fails.
Remarks
The X.509 certificate's private key is used to decrypt the symmetric key contained within the encrypted data. The symmetric key is used to decrypt the data.

The encryption method for the encrypted symmetric key is expected to be http://www.w3.org/2001/04/xmlenc#rsa-1_5 or http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p.

The encryption method for the key is specified in the encrypted data or may be explicitly specified.

The encryption method for the data is specified in the encrypted data or may be explicitly specified.

See Also

Reference

NewEncryptedID Class
Decrypt Overload
ComponentSpace.SAML2.Assertions Namespace
NewEncryptedIDNewEncryptedID(NameID, AsymmetricAlgorithm, EncryptionMethod, KeyInfo)
NewEncryptedIDNewEncryptedID(NameID, X509Certificate2, EncryptionMethod)


NewEncryptedID.IsValid Method

NewEncryptedIDIsValid Method

Indicates whether the XML is a new encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a new encrypted identifier; otherwise false.
See Also

Reference

NewEncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID.ToXml Method

NewEncryptedIDToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlElement) | Serializes the encrypted element to XML. (Inherited from EncryptedElementType.)
Public method | ToXml(XmlDocument) | Serializes the new encrypted identifier to XML.
Top
See Also

Reference

NewEncryptedID Class
ComponentSpace.SAML2.Assertions Namespace


NewEncryptedID.ToXml Method (XmlDocument)

NewEncryptedIDToXml Method (XmlDocument)

Serializes the new encrypted identifier to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The new encrypted identifier as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

NewEncryptedID Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


OneTimeUse Class

Represents a one time use condition.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsOneTimeUse

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class OneTimeUse : ICondition
Public Class OneTimeUse
    Implements ICondition
public ref class OneTimeUse : ICondition
type OneTimeUse =
    class
        interface ICondition
    end

The OneTimeUse type exposes the following members.

Constructors
 | Name | Description
Public method | OneTimeUse | Initializes a new instance of the OneTimeUse class.
Public method | OneTimeUse(XmlElement) | Initializes a new instance of the OneTimeUse class from XML.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a one time use condition.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the one time use condition to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


OneTimeUse Constructor

Overload List
 | Name | Description
Public method | OneTimeUse | Initializes a new instance of the OneTimeUse class.
Public method | OneTimeUse(XmlElement) | Initializes a new instance of the OneTimeUse class from XML.
Top
See Also

Reference

OneTimeUse Class
ComponentSpace.SAML2.Assertions Namespace


OneTimeUse Constructor

Initializes a new instance of the OneTimeUse class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OneTimeUse()
Public Sub New
public:
OneTimeUse()
new : unit -> OneTimeUse
See Also

Reference

OneTimeUse Class
OneTimeUse Overload
ComponentSpace.SAML2.Assertions Namespace


OneTimeUse Constructor (XmlElement)

Initializes a new instance of the OneTimeUse class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OneTimeUse(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
OneTimeUse(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> OneTimeUse

Parameters

xmlElement
Type: System.XmlXmlElement
The one time use condition XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

OneTimeUse Class
OneTimeUse Overload
ComponentSpace.SAML2.Assertions Namespace


OneTimeUse Methods

The OneTimeUse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a one time use condition.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the one time use condition to XML.
Top
See Also

Reference

OneTimeUse Class
ComponentSpace.SAML2.Assertions Namespace


OneTimeUse.IsValid Method

OneTimeUseIsValid Method

Indicates whether the XML is a one time use condition.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a one time use condition; otherwise false.
See Also

Reference

OneTimeUse Class
ComponentSpace.SAML2.Assertions Namespace


OneTimeUse.ToXml Method

OneTimeUseToXml Method

Serializes the one time use condition to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The one time use condition as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

OneTimeUse Class
ComponentSpace.SAML2.Assertions Namespace


ProxyRestriction Class

Represents a proxy restriction.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsProxyRestriction

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class ProxyRestriction : ICondition
Public Class ProxyRestriction
    Implements ICondition
public ref class ProxyRestriction : ICondition
type ProxyRestriction =
    class
        interface ICondition
    end

The ProxyRestriction type exposes the following members.

Constructors
 | Name | Description
Public method | ProxyRestriction | Initializes a new instance of the ProxyRestriction class.
Public method | ProxyRestriction(XmlElement) | Initializes a new instance of the ProxyRestriction class from XML.
Top
Properties
 | Name | Description
Public property | Audiences | Gets or sets the audiences.
Public property | Count | Gets or sets the count.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a proxy restriction.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the audience restriction to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


ProxyRestriction Constructor

Overload List
 | Name | Description
Public method | ProxyRestriction | Initializes a new instance of the ProxyRestriction class.
Public method | ProxyRestriction(XmlElement) | Initializes a new instance of the ProxyRestriction class from XML.
Top
See Also

Reference

ProxyRestriction Class
ComponentSpace.SAML2.Assertions Namespace


ProxyRestriction Constructor

Initializes a new instance of the ProxyRestriction class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ProxyRestriction()
Public Sub New
public:
ProxyRestriction()
new : unit -> ProxyRestriction
See Also

Reference

ProxyRestriction Class
ProxyRestriction Overload
ComponentSpace.SAML2.Assertions Namespace


ProxyRestriction Constructor (XmlElement)

Initializes a new instance of the ProxyRestriction class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ProxyRestriction(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
ProxyRestriction(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> ProxyRestriction

Parameters

xmlElement
Type: System.XmlXmlElement
The proxy restriction XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

ProxyRestriction Class
ProxyRestriction Overload
ComponentSpace.SAML2.Assertions Namespace


ProxyRestriction Properties

The ProxyRestriction type exposes the following members.

Properties
 | Name | Description
Public property | Audiences | Gets or sets the audiences.
Public property | Count | Gets or sets the count.
Top
See Also

Reference

ProxyRestriction Class
ComponentSpace.SAML2.Assertions Namespace


ProxyRestriction.Audiences Property

ProxyRestrictionAudiences Property

Gets or sets the audiences.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<Audience> Audiences { get; set; }
Public Property Audiences As IList(Of Audience)
    Get
    Set
public:
property IList<Audience^>^ Audiences {
    IList<Audience^>^ get ();
    void set (IList<Audience^>^ value);
}
member Audiences : IList<Audience> with get, set

Property Value

Type: IList Audience
The audiences.
See Also

Reference

ProxyRestriction Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAudience


ProxyRestriction.Count Property

ProxyRestrictionCount Property

Gets or sets the count.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int Count { get; set; }
Public Property Count As Integer
    Get
    Set
public:
property int Count {
    int get ();
    void set (int value);
}
member Count : int with get, set

Property Value

Type: Int32
The count. A value of Int32.MinValue indicates the value has not been set.
See Also

Reference

ProxyRestriction Class
ComponentSpace.SAML2.Assertions Namespace


ProxyRestriction Methods

The ProxyRestriction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a proxy restriction.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the audience restriction to XML.
Top
See Also

Reference

ProxyRestriction Class
ComponentSpace.SAML2.Assertions Namespace


ProxyRestriction.IsValid Method

ProxyRestrictionIsValid Method

Indicates whether the XML is a proxy restriction.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a proxy restriction; otherwise false.
See Also

Reference

ProxyRestriction Class
ComponentSpace.SAML2.Assertions Namespace


ProxyRestriction.ToXml Method

ProxyRestrictionToXml Method

Serializes the audience restriction to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The audience restriction as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

ProxyRestriction Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion Class

Represents the Assertion element.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsSAMLAssertion

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLAssertion : ISerializable
<SerializableAttribute>
Public Class SAMLAssertion
    Implements ISerializable
[SerializableAttribute]
public ref class SAMLAssertion : ISerializable
[<SerializableAttribute>]
type SAMLAssertion =
    class
        interface ISerializable
    end

The SAMLAssertion type exposes the following members.

Constructors
 | Name | Description
Public method | SAMLAssertion | Initializes a new instance of the SAMLAssertion class.
Public method | SAMLAssertion(String) | Initializes a new instance of the SAMLAssertion class from an XML string.
Public method | SAMLAssertion(XmlElement) | Initializes a new instance of the SAMLAssertion class from XML.
Protected method | SAMLAssertion(SerializationInfo, StreamingContext) | Initializes a new instance of the SAMLAssertion class.
Top
Properties
 | Name | Description
Public property | Advice | Gets or sets the advice.
Public property | Conditions | Gets or sets the conditions.
Public property | ID | Gets or sets the ID.
Public property | IssueInstant | Gets or sets the issue instant.
Public property | Issuer | Gets or sets the issuer.
Public property | Signature | Gets or sets the digital signature.
Public property | Statements | Gets or sets the statements.
Public property | Subject | Gets or sets the subject.
Public property | Version | Gets or sets the version.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Returns the list of SAML assertion XML elements contained within the supplied XML.
Public method | GetAttributes | Returns all unencrypted attributes with the specified name.
Public method | GetAttributesByFriendlyName | Returns all unencrypted attributes with the specified friendly name.
Public method | GetAttributeStatements | Returns all attribute statements.
Public method | GetAttributeValue | Returns the value of the unencrypted attribute with the specified name.
Public method | GetAttributeValueByFriendlyName | Returns the value of the unencrypted attribute with the specified friendly name.
Public method | GetAuthenticationStatements | Returns all authentication statements.
Public method | GetAuthorizationDecisionStatements | Returns all authorization decision statements.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNameID | Gets the name identifier from the subject.
Public method | GetObjectData | Serialize the SAML assertion.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an assertion.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeValue(String, String) | Sets the attribute value by adding an attribute statement containing an attribute with the specified name and value.
Public method | SetAttributeValue(String, String, String) | Sets the attribute value by adding an attribute statement containing an attribute with the specified name and value.
Public method | SetAttributeValues(String, String) | Sets the attribute values by adding an attribute statement containing attributes with the specified names and values.
Public method | SetAttributeValues(String, String, String) | Sets the attribute values by adding an attribute statement containing attributes with the specified names and values.
Public method | ToString | Converts the SAML assertion to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the SAML assertion to XML.
Public method | ToXml(XmlDocument) | Serializes the SAML assertion to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion Constructor

Overload List
 | Name | Description
Public method | SAMLAssertion | Initializes a new instance of the SAMLAssertion class.
Public method | SAMLAssertion(String) | Initializes a new instance of the SAMLAssertion class from an XML string.
Public method | SAMLAssertion(XmlElement) | Initializes a new instance of the SAMLAssertion class from XML.
Protected method | SAMLAssertion(SerializationInfo, StreamingContext) | Initializes a new instance of the SAMLAssertion class.
Top
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion Constructor

Initializes a new instance of the SAMLAssertion class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion()
Public Sub New
public:
SAMLAssertion()
new : unit -> SAMLAssertion
Remarks
The SAML assertion is initialized with a version number of 2.0, a random identifier, and the issue instant of now.
See Also

Reference

SAMLAssertion Class
SAMLAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion Constructor (String)

Initializes a new instance of the SAMLAssertion class from an XML string.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion(
    string xmlString
)
Public Sub New (
    xmlString As String
)
public:
SAMLAssertion(
    String^ xmlString
)
new :
        xmlString : string -> SAMLAssertion

Parameters

xmlString
Type: SystemString
The assertion XML string.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SAMLAssertion Class
SAMLAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion Constructor (XmlElement)

Initializes a new instance of the SAMLAssertion class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SAMLAssertion(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SAMLAssertion

Parameters

xmlElement
Type: System.XmlXmlElement
The assertion XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SAMLAssertion Class
SAMLAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the SAMLAssertion class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
protected SAMLAssertion(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
SAMLAssertion(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SAMLAssertion

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information.
context
Type: System.Runtime.SerializationStreamingContext
The streaming context.
Remarks
This constructor supports serialization.
See Also

Reference

SAMLAssertion Class
SAMLAssertion Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion Properties

The SAMLAssertion type exposes the following members.

Properties
 | Name | Description
Public property | Advice | Gets or sets the advice.
Public property | Conditions | Gets or sets the conditions.
Public property | ID | Gets or sets the ID.
Public property | IssueInstant | Gets or sets the issue instant.
Public property | Issuer | Gets or sets the issuer.
Public property | Signature | Gets or sets the digital signature.
Public property | Statements | Gets or sets the statements.
Public property | Subject | Gets or sets the subject.
Public property | Version | Gets or sets the version.
Top
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.Advice Property

SAMLAssertionAdvice Property

Gets or sets the advice.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Advice Advice { get; set; }
Public Property Advice As Advice
    Get
    Set
public:
property Advice^ Advice {
    Advice^ get ();
    void set (Advice^ value);
}
member Advice : Advice with get, set

Property Value

Type: Advice
The advice.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.Conditions Property

SAMLAssertionConditions Property

Gets or sets the conditions.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Conditions Conditions { get; set; }
Public Property Conditions As Conditions
    Get
    Set
public:
property Conditions^ Conditions {
    Conditions^ get ();
    void set (Conditions^ value);
}
member Conditions : Conditions with get, set

Property Value

Type: Conditions
The conditions.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.ID Property

SAMLAssertionID Property

Gets or sets the ID.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
The ID.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.IssueInstant Property

SAMLAssertionIssueInstant Property

Gets or sets the issue instant.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime IssueInstant { get; set; }
Public Property IssueInstant As DateTime
    Get
    Set
public:
property DateTime IssueInstant {
    DateTime get ();
    void set (DateTime value);
}
member IssueInstant : DateTime with get, set

Property Value

Type: DateTime
The issue instant as coordinated universal time (UTC).
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.Issuer Property

SAMLAssertionIssuer Property

Gets or sets the issuer.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Issuer Issuer { get; set; }
Public Property Issuer As Issuer
    Get
    Set
public:
property Issuer^ Issuer {
    Issuer^ get ();
    void set (Issuer^ value);
}
member Issuer : Issuer with get, set

Property Value

Type: Issuer
The issuer.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.Signature Property

SAMLAssertionSignature Property

Gets or sets the digital signature.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement Signature { get; set; }
Public Property Signature As XmlElement
    Get
    Set
public:
property XmlElement^ Signature {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member Signature : XmlElement with get, set

Property Value

Type: XmlElement
The digital signature.
Remarks
To generate or verify signatures, use SAMLAssertionSignature.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsSAMLAssertionSignature


SAMLAssertion.Statements Property

SAMLAssertionStatements Property

Gets or sets the statements.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<IStatement> Statements { get; set; }
Public Property Statements As IList(Of IStatement)
    Get
    Set
public:
property IList<IStatement^>^ Statements {
    IList<IStatement^>^ get ();
    void set (IList<IStatement^>^ value);
}
member Statements : IList<IStatement> with get, set

Property Value

Type: IList IStatement
The statements.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAuthnStatement
ComponentSpace.SAML2.AssertionsAuthzDecisionStatement
ComponentSpace.SAML2.AssertionsAttributeStatement
SAMLAssertionGetAuthenticationStatements
SAMLAssertionGetAuthorizationDecisionStatements
SAMLAssertionGetAttributeStatements


SAMLAssertion.Subject Property

SAMLAssertionSubject Property

Gets or sets the subject.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Subject Subject { get; set; }
Public Property Subject As Subject
    Get
    Set
public:
property Subject^ Subject {
    Subject^ get ();
    void set (Subject^ value);
}
member Subject : Subject with get, set

Property Value

Type: Subject
The subject.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.Version Property

SAMLAssertionVersion Property

Gets or sets the version.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
The version. The default is 2.0.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion Methods

The SAMLAssertion type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Find | Returns the list of SAML assertion XML elements contained within the supplied XML.
Public method | GetAttributes | Returns all unencrypted attributes with the specified name.
Public method | GetAttributesByFriendlyName | Returns all unencrypted attributes with the specified friendly name.
Public method | GetAttributeStatements | Returns all attribute statements.
Public method | GetAttributeValue | Returns the value of the unencrypted attribute with the specified name.
Public method | GetAttributeValueByFriendlyName | Returns the value of the unencrypted attribute with the specified friendly name.
Public method | GetAuthenticationStatements | Returns all authentication statements.
Public method | GetAuthorizationDecisionStatements | Returns all authorization decision statements.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNameID | Gets the name identifier from the subject.
Public method | GetObjectData | Serialize the SAML assertion.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an assertion.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeValue(String, String) | Sets the attribute value by adding an attribute statement containing an attribute with the specified name and value.
Public method | SetAttributeValue(String, String, String) | Sets the attribute value by adding an attribute statement containing an attribute with the specified name and value.
Public method | SetAttributeValues(String, String) | Sets the attribute values by adding an attribute statement containing attributes with the specified names and values.
Public method | SetAttributeValues(String, String, String) | Sets the attribute values by adding an attribute statement containing attributes with the specified names and values.
Public method | ToString | Converts the SAML assertion to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the SAML assertion to XML.
Public method | ToXml(XmlDocument) | Serializes the SAML assertion to XML.
Top
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.Find Method

SAMLAssertionFind Method

Returns the list of SAML assertion XML elements contained within the supplied XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<XmlElement> Find(
    XmlElement xmlElement
)
Public Shared Function Find (
    xmlElement As XmlElement
) As IList(Of XmlElement)
public:
static IList<XmlElement^>^ Find(
    XmlElement^ xmlElement
)
static member Find :
        xmlElement : XmlElement -> IList<XmlElement>

Parameters

xmlElement
Type: System.XmlXmlElement
The XML in which to search for SAML assertions XML elements.

Return Value

Type: IList XmlElement
The list of SAML assertion XmlElement objects.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.GetAttributes Method

SAMLAssertionGetAttributes Method

Returns all unencrypted attributes with the specified name.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<SAMLAttribute> GetAttributes(
    string attributeName
)
Public Function GetAttributes (
    attributeName As String
) As IList(Of SAMLAttribute)
public:
IList<SAMLAttribute^>^ GetAttributes(
    String^ attributeName
)
member GetAttributes :
        attributeName : string -> IList<SAMLAttribute>

Parameters

attributeName
Type: SystemString
The attribute name.

Return Value

Type: IList SAMLAttribute
The matching unencrypted attributes.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionGetAttributeStatements
SAMLAssertionGetAttributeValue(String)


SAMLAssertion.GetAttributesByFriendlyName Method

SAMLAssertionGetAttributesByFriendlyName Method

Returns all unencrypted attributes with the specified friendly name.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<SAMLAttribute> GetAttributesByFriendlyName(
    string friendlyName
)
Public Function GetAttributesByFriendlyName (
    friendlyName As String
) As IList(Of SAMLAttribute)
public:
IList<SAMLAttribute^>^ GetAttributesByFriendlyName(
    String^ friendlyName
)
member GetAttributesByFriendlyName :
        friendlyName : string -> IList<SAMLAttribute>

Parameters

friendlyName
Type: SystemString
The attribute friendly name.

Return Value

Type: IList SAMLAttribute
The matching unencrypted attributes.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionGetAttributeStatements
SAMLAssertionGetAttributeValueByFriendlyName(String)


SAMLAssertion.GetAttributeStatements Method

SAMLAssertionGetAttributeStatements Method

Returns all attribute statements.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<AttributeStatement> GetAttributeStatements()
Public Function GetAttributeStatements As IList(Of AttributeStatement)
public:
IList<AttributeStatement^>^ GetAttributeStatements()
member GetAttributeStatements : unit -> IList<AttributeStatement>

Return Value

Type: IList AttributeStatement
The attribute statements.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionStatements
ComponentSpace.SAML2.AssertionsAttributeStatement
SAMLAssertionGetAttributes(String)
SAMLAssertionGetAttributeValue(String)


SAMLAssertion.GetAttributeValue Method

SAMLAssertionGetAttributeValue Method

Returns the value of the unencrypted attribute with the specified name.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string GetAttributeValue(
    string attributeName
)
Public Function GetAttributeValue (
    attributeName As String
) As String
public:
String^ GetAttributeValue(
    String^ attributeName
)
member GetAttributeValue :
        attributeName : string -> string

Parameters

attributeName
Type: SystemString
The attribute name.

Return Value

Type: String
The attribute value or null if none.
Remarks
It's assumed that only one attribute exists with the specified name, that the attribute only has one value, and the value is a string. If this isn't the case then use one of the other attribute related methods.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionGetAttributeStatements
SAMLAssertionGetAttributes(String)


SAMLAssertion.GetAttributeValueByFriendlyName Method

SAMLAssertionGetAttributeValueByFriendlyName Method

Returns the value of the unencrypted attribute with the specified friendly name.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string GetAttributeValueByFriendlyName(
    string friendlyName
)
Public Function GetAttributeValueByFriendlyName (
    friendlyName As String
) As String
public:
String^ GetAttributeValueByFriendlyName(
    String^ friendlyName
)
member GetAttributeValueByFriendlyName :
        friendlyName : string -> string

Parameters

friendlyName
Type: SystemString
The attribute friendly name.

Return Value

Type: String
The attribute value or null if none.
Remarks
It's assumed that only one attribute exists with the specified friendly name, that the attribute only has one value, and the value is a string. If this isn't the case then use one of the other attribute related methods.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionGetAttributeStatements
SAMLAssertionGetAttributesByFriendlyName(String)


SAMLAssertion.GetAuthenticationStatements Method

SAMLAssertionGetAuthenticationStatements Method

Returns all authentication statements.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<AuthnStatement> GetAuthenticationStatements()
Public Function GetAuthenticationStatements As IList(Of AuthnStatement)
public:
IList<AuthnStatement^>^ GetAuthenticationStatements()
member GetAuthenticationStatements : unit -> IList<AuthnStatement>

Return Value

Type: IList AuthnStatement
The authentication statements.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionStatements
ComponentSpace.SAML2.AssertionsAuthnStatement


SAMLAssertion.GetAuthorizationDecisionStatements Method

SAMLAssertionGetAuthorizationDecisionStatements Method

Returns all authorization decision statements.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<AuthzDecisionStatement> GetAuthorizationDecisionStatements()
Public Function GetAuthorizationDecisionStatements As IList(Of AuthzDecisionStatement)
public:
IList<AuthzDecisionStatement^>^ GetAuthorizationDecisionStatements()
member GetAuthorizationDecisionStatements : unit -> IList<AuthzDecisionStatement>

Return Value

Type: IList AuthzDecisionStatement
The authorization decision statements.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionStatements
ComponentSpace.SAML2.AssertionsAuthzDecisionStatement


SAMLAssertion.GetNameID Method

SAMLAssertionGetNameID Method

Gets the name identifier from the subject.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string GetNameID()
Public Function GetNameID As String
public:
String^ GetNameID()
member GetNameID : unit -> string

Return Value

Type: String
The name identifier from the subject or null if none.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionSubject


SAMLAssertion.GetObjectData Method

SAMLAssertionGetObjectData Method

Serialize the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information.
context
Type: System.Runtime.SerializationStreamingContext
The streaming context.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.IsValid Method

SAMLAssertionIsValid Method

Indicates whether the XML is an assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an assertion; otherwise false.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.SetAttributeValue Method

SAMLAssertionSetAttributeValue Method

Overload List
 | Name | Description
Public method | SetAttributeValue(String, String) | Sets the attribute value by adding an attribute statement containing an attribute with the specified name and value.
Public method | SetAttributeValue(String, String, String) | Sets the attribute value by adding an attribute statement containing an attribute with the specified name and value.
Top
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.SetAttributeValue Method (String, String)

SAMLAssertionSetAttributeValue Method (String, String)

Sets the attribute value by adding an attribute statement containing an attribute with the specified name and value.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void SetAttributeValue(
    string name,
    string attributeValue
)
Public Sub SetAttributeValue (
    name As String,
    attributeValue As String
)
public:
void SetAttributeValue(
    String^ name,
    String^ attributeValue
)
member SetAttributeValue :
        name : string *
        attributeValue : string -> unit

Parameters

name
Type: SystemString
The attribute name.
attributeValue
Type: SystemString
The attribute value.
See Also

Reference

SAMLAssertion Class
SetAttributeValue Overload
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionSetAttributeValues(String, String)
ComponentSpace.SAML2.AssertionsAttributeStatement
ComponentSpace.SAML2.AssertionsSAMLAttribute
ComponentSpace.SAML2.AssertionsAttributeValue


SAMLAssertion.SetAttributeValue Method (String, String, String)

SAMLAssertionSetAttributeValue Method (String, String, String)

Sets the attribute value by adding an attribute statement containing an attribute with the specified name and value.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void SetAttributeValue(
    string name,
    string attributeType,
    string attributeValue
)
Public Sub SetAttributeValue (
    name As String,
    attributeType As String,
    attributeValue As String
)
public:
void SetAttributeValue(
    String^ name,
    String^ attributeType,
    String^ attributeValue
)
member SetAttributeValue :
        name : string *
        attributeType : string *
        attributeValue : string -> unit

Parameters

name
Type: SystemString
The attribute name.
attributeType
Type: SystemString
The attribute type.
attributeValue
Type: SystemString
The attribute value.
See Also

Reference

SAMLAssertion Class
SetAttributeValue Overload
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionSetAttributeValues(String, String, String)
ComponentSpace.SAML2.AssertionsAttributeStatement
ComponentSpace.SAML2.AssertionsSAMLAttribute
ComponentSpace.SAML2.AssertionsAttributeValue
ComponentSpace.SAML2.UtilityXmlSchemaSimpleTypes


SAMLAssertion.SetAttributeValues Method

SAMLAssertionSetAttributeValues Method

Overload List
 | Name | Description
Public method | SetAttributeValues(String, String) | Sets the attribute values by adding an attribute statement containing attributes with the specified names and values.
Public method | SetAttributeValues(String, String, String) | Sets the attribute values by adding an attribute statement containing attributes with the specified names and values.
Top
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.SetAttributeValues Method (String[], String[])

SAMLAssertionSetAttributeValues Method (String, String)

Sets the attribute values by adding an attribute statement containing attributes with the specified names and values.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void SetAttributeValues(
    string[] names,
    string[] attributeValues
)
Public Sub SetAttributeValues (
    names As String(),
    attributeValues As String()
)
public:
void SetAttributeValues(
    array<String^>^ names,
    array<String^>^ attributeValues
)
member SetAttributeValues :
        names : string[] *
        attributeValues : string[] -> unit

Parameters

names
Type: SystemString
The attribute names.
attributeValues
Type: SystemString
The attribute values.
See Also

Reference

SAMLAssertion Class
SetAttributeValues Overload
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionSetAttributeValue(String, String)
ComponentSpace.SAML2.AssertionsAttributeStatement
ComponentSpace.SAML2.AssertionsSAMLAttribute
ComponentSpace.SAML2.AssertionsAttributeValue


SAMLAssertion.SetAttributeValues Method (String[], String[], String[])

SAMLAssertionSetAttributeValues Method (String, String, String)

Sets the attribute values by adding an attribute statement containing attributes with the specified names and values.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void SetAttributeValues(
    string[] names,
    string[] attributeTypes,
    string[] attributeValues
)
Public Sub SetAttributeValues (
    names As String(),
    attributeTypes As String(),
    attributeValues As String()
)
public:
void SetAttributeValues(
    array<String^>^ names,
    array<String^>^ attributeTypes,
    array<String^>^ attributeValues
)
member SetAttributeValues :
        names : string[] *
        attributeTypes : string[] *
        attributeValues : string[] -> unit

Parameters

names
Type: SystemString
The attribute names.
attributeTypes
Type: SystemString
The attribute types.
attributeValues
Type: SystemString
The attribute values.
See Also

Reference

SAMLAssertion Class
SetAttributeValues Overload
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionSetAttributeValue(String, String, String)
ComponentSpace.SAML2.AssertionsAttributeStatement
ComponentSpace.SAML2.AssertionsSAMLAttribute
ComponentSpace.SAML2.AssertionsAttributeValue


SAMLAssertion.ToString Method

SAMLAssertionToString Method

Converts the SAML assertion to a string.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The SAML assertion as a string.
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.ToXml Method

SAMLAssertionToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the SAML assertion to XML.
Public method | ToXml(XmlDocument) | Serializes the SAML assertion to XML.
Top
See Also

Reference

SAMLAssertion Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.ToXml Method

SAMLAssertionToXml Method

Serializes the SAML assertion to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The SAML assertion as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

SAMLAssertion Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertion.ToXml Method (XmlDocument)

SAMLAssertionToXml Method (XmlDocument)

Serializes the SAML assertion to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The SAML assertion as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SAMLAssertion Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSerializer Class

Permits the serialization and deserialization of SAML assertions.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsSAMLAssertionSerializer

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAMLAssertionSerializer
Public NotInheritable Class SAMLAssertionSerializer
public ref class SAMLAssertionSerializer abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAMLAssertionSerializer =  class end

The SAMLAssertionSerializer type exposes the following members.

Methods
Name | Description
Deserialize | Deserialize the SAML assertion from the stream.
Serialize | Serialize the SAML assertion to the stream.
Top
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSerializer Methods

The SAMLAssertionSerializer type exposes the following members.

Methods
Name | Description
Deserialize | Deserialize the SAML assertion from the stream.
Serialize | Serialize the SAML assertion to the stream.
Top
See Also

Reference

SAMLAssertionSerializer Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSerializer.Deserialize Method

SAMLAssertionSerializerDeserialize Method

Deserialize the SAML assertion from the stream.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static SAMLAssertion Deserialize(
    Stream stream
)
Public Shared Function Deserialize (
    stream As Stream
) As SAMLAssertion
public:
static SAMLAssertion^ Deserialize(
    Stream^ stream
)
static member Deserialize :
        stream : Stream -> SAMLAssertion

Parameters

stream
Type: System.IOStream
The stream.

Return Value

Type: SAMLAssertion
The SAML assertion.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SAMLAssertionSerializer Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSerializer.Serialize Method

SAMLAssertionSerializerSerialize Method

Serialize the SAML assertion to the stream.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Serialize(
    SAMLAssertion samlAssertion,
    Stream stream
)
Public Shared Sub Serialize (
    samlAssertion As SAMLAssertion,
    stream As Stream
)
public:
static void Serialize(
    SAMLAssertion^ samlAssertion,
    Stream^ stream
)
static member Serialize :
        samlAssertion : SAMLAssertion *
        stream : Stream -> unit

Parameters

samlAssertion
Type: ComponentSpace.SAML2.AssertionsSAMLAssertion
The SAML assertion.
stream
Type: System.IOStream
The stream.
See Also

Reference

SAMLAssertionSerializer Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature Class

Permits XML signature generation and verification for SAML assertions.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsSAMLAssertionSignature

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAMLAssertionSignature
Public NotInheritable Class SAMLAssertionSignature
public ref class SAMLAssertionSignature abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAMLAssertionSignature =  class end

The SAMLAssertionSignature type exposes the following members.

Methods
Name | Description
Generate(XmlElement, AsymmetricAlgorithm) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
GetCertificate | Gets the X.509 certificate embedded in the XML signature or null if none.
GetKeyInfo | Gets the key info embedded in the XML signature or null if none.
IsSigned | Indicates whether the SAML assertion contains an XML signature.
RemoveSignature | Removes the XML signature, if any, from the SAML assertion.
Verify(XmlElement) | Verifies the XML signature.
Verify(XmlElement, AsymmetricAlgorithm) | Verifies the XML signature.
Verify(XmlElement, X509Certificate2) | Verifies the XML signature.
Verify(XmlElement, KeyInfo) | Verifies the XML signature.
Verify(XmlElement, KeyInfoX509Data) | Verifies the XML signature.
Top
Fields
Name | Description
DefaultInclusiveNamespacesPrefixList | The default inclusive namespace prefix list.
Top
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature Methods

The SAMLAssertionSignature type exposes the following members.

Methods
Name | Description
Generate(XmlElement, AsymmetricAlgorithm) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
GetCertificate | Gets the X.509 certificate embedded in the XML signature or null if none.
GetKeyInfo | Gets the key info embedded in the XML signature or null if none.
IsSigned | Indicates whether the SAML assertion contains an XML signature.
RemoveSignature | Removes the XML signature, if any, from the SAML assertion.
Verify(XmlElement) | Verifies the XML signature.
Verify(XmlElement, AsymmetricAlgorithm) | Verifies the XML signature.
Verify(XmlElement, X509Certificate2) | Verifies the XML signature.
Verify(XmlElement, KeyInfo) | Verifies the XML signature.
Verify(XmlElement, KeyInfoX509Data) | Verifies the XML signature.
Top
See Also

Reference

SAMLAssertionSignature Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method

SAMLAssertionSignatureGenerate Method

Overload List
Name | Description
Generate(XmlElement, AsymmetricAlgorithm) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String) | Generates an XML signature and adds it to the SAML assertion.
Top
See Also

Reference

SAMLAssertionSignature Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method (XmlElement, AsymmetricAlgorithm)

SAMLAssertionSignatureGenerate Method (XmlElement, AsymmetricAlgorithm)

Generates an XML signature and adds it to the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML assertion. The signature is created using the supplied signing key.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLAssertionSignature Class
Generate Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2)

SAMLAssertionSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2)

Generates an XML signature and adds it to the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2 x509Certificate
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificate As X509Certificate2
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2^ x509Certificate
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificate : X509Certificate2 -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate to include in the key info.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML assertion. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificate, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLAssertionSignature Class
Generate Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection)

SAMLAssertionSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection)

Generates an XML signature and adds it to the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2Collection x509Certificates
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificates As X509Certificate2Collection
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2Collection^ x509Certificates
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificates : X509Certificate2Collection -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificates
Type: System.Security.Cryptography.X509CertificatesX509Certificate2Collection
The list of X.509 certificate to include in the key info.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML assertion. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificates, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLAssertionSignature Class
Generate Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfo)

SAMLAssertionSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfo)

Generates an XML signature and adds it to the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfo keyInfo
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfo As KeyInfo
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfo^ keyInfo
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfo : KeyInfo -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include in the signature.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML assertion. The signature is created using the supplied signing key. The key info will be included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLAssertionSignature Class
Generate Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data)

SAMLAssertionSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data)

Generates an XML signature and adds it to the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfoX509Data keyInfoX509Data
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfoX509Data As KeyInfoX509Data
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfoX509Data^ keyInfoX509Data
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfoX509Data : KeyInfoX509Data -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfoX509Data
Type: System.Security.Cryptography.XmlKeyInfoX509Data
The X.509 data to include in the signature.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML assertion. The signature is created using the supplied signing key. Key info, using the supplied X.509 data, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLAssertionSignature Class
Generate Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method (XmlElement, AsymmetricAlgorithm, String, String, String)

SAMLAssertionSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, String, String, String)

Generates an XML signature and adds it to the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML assertion. The signature is created using the supplied signing key.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLAssertionSignature Class
Generate Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String)

SAMLAssertionSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String)

Generates an XML signature and adds it to the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2 x509Certificate,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificate As X509Certificate2,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2^ x509Certificate,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificate : X509Certificate2 *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate to include in the key info.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML assertion. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificate, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLAssertionSignature Class
Generate Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String)

SAMLAssertionSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String)

Generates an XML signature and adds it to the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2Collection x509Certificates,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificates As X509Certificate2Collection,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2Collection^ x509Certificates,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificates : X509Certificate2Collection *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificates
Type: System.Security.Cryptography.X509CertificatesX509Certificate2Collection
The list of X.509 certificate to include in the key info.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML assertion. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificates, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLAssertionSignature Class
Generate Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String)

SAMLAssertionSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String)

Generates an XML signature and adds it to the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfo keyInfo,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfo As KeyInfo,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfo^ keyInfo,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfo : KeyInfo *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include in the signature.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML assertion. The signature is created using the supplied signing key. The key info will be included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLAssertionSignature Class
Generate Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String)

SAMLAssertionSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String)

Generates an XML signature and adds it to the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfoX509Data keyInfoX509Data,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfoX509Data As KeyInfoX509Data,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfoX509Data^ keyInfoX509Data,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfoX509Data : KeyInfoX509Data *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfoX509Data
Type: System.Security.Cryptography.XmlKeyInfoX509Data
The X.509 data to include in the signature.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML assertion. The signature is created using the supplied signing key. Key info, using the supplied X.509 data, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLAssertionSignature Class
Generate Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.GetCertificate Method

SAMLAssertionSignatureGetCertificate Method

Gets the X.509 certificate embedded in the XML signature or null if none.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static X509Certificate2 GetCertificate(
    XmlElement xmlElement
)
Public Shared Function GetCertificate (
    xmlElement As XmlElement
) As X509Certificate2
public:
static X509Certificate2^ GetCertificate(
    XmlElement^ xmlElement
)
static member GetCertificate :
        xmlElement : XmlElement -> X509Certificate2

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion containing the signature with X.509 certificate.

Return Value

Type: X509Certificate2
The X.509 certificate embedded in the XML signature or null if none.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the X.509 certificate retrieval fails.
See Also

Reference

SAMLAssertionSignature Class
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionSignatureGetKeyInfo(XmlElement)


SAMLAssertionSignature.GetKeyInfo Method

SAMLAssertionSignatureGetKeyInfo Method

Gets the key info embedded in the XML signature or null if none.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static KeyInfo GetKeyInfo(
    XmlElement xmlElement
)
Public Shared Function GetKeyInfo (
    xmlElement As XmlElement
) As KeyInfo
public:
static KeyInfo^ GetKeyInfo(
    XmlElement^ xmlElement
)
static member GetKeyInfo :
        xmlElement : XmlElement -> KeyInfo

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion containing the signature with key info.

Return Value

Type: KeyInfo
The key info embedded in the XML signature or null if none.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the key info retrieval fails.
See Also

Reference

SAMLAssertionSignature Class
ComponentSpace.SAML2.Assertions Namespace
SAMLAssertionSignatureGetCertificate(XmlElement)


SAMLAssertionSignature.IsSigned Method

SAMLAssertionSignatureIsSigned Method

Indicates whether the SAML assertion contains an XML signature.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSigned(
    XmlElement xmlElement
)
Public Shared Function IsSigned (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsSigned(
    XmlElement^ xmlElement
)
static member IsSigned :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion.

Return Value

Type: Boolean
true if the XML contains an XML signature; otherwise false.
See Also

Reference

SAMLAssertionSignature Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.RemoveSignature Method

SAMLAssertionSignatureRemoveSignature Method

Removes the XML signature, if any, from the SAML assertion.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void RemoveSignature(
    XmlElement xmlElement
)
Public Shared Sub RemoveSignature (
    xmlElement As XmlElement
)
public:
static void RemoveSignature(
    XmlElement^ xmlElement
)
static member RemoveSignature :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion.
See Also

Reference

SAMLAssertionSignature Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Verify Method

SAMLAssertionSignatureVerify Method

Overload List
Name | Description
Verify(XmlElement) | Verifies the XML signature.
Verify(XmlElement, AsymmetricAlgorithm) | Verifies the XML signature.
Verify(XmlElement, X509Certificate2) | Verifies the XML signature.
Verify(XmlElement, KeyInfo) | Verifies the XML signature.
Verify(XmlElement, KeyInfoX509Data) | Verifies the XML signature.
Top
See Also

Reference

SAMLAssertionSignature Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Verify Method (XmlElement)

SAMLAssertionSignatureVerify Method (XmlElement)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement
)
Public Shared Function Verify (
    xmlElement As XmlElement
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement
)
static member Verify :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion containing the signature to verify.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The key info included with the signature is used to perform the verification.
See Also

Reference

SAMLAssertionSignature Class
Verify Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Verify Method (XmlElement, AsymmetricAlgorithm)

SAMLAssertionSignatureVerify Method (XmlElement, AsymmetricAlgorithm)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey
)
static member Verify :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion containing the signature to verify.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The public key used to perform the verification or null if none.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied public key is used to perform the verification.
See Also

Reference

SAMLAssertionSignature Class
Verify Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Verify Method (XmlElement, X509Certificate2)

SAMLAssertionSignatureVerify Method (XmlElement, X509Certificate2)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    X509Certificate2 x509Certificate
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    x509Certificate As X509Certificate2
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    X509Certificate2^ x509Certificate
)
static member Verify :
        xmlElement : XmlElement *
        x509Certificate : X509Certificate2 -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion containing the signature to verify.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used to perform the verification.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied X.509 certificate is used to perform the verification.
See Also

Reference

SAMLAssertionSignature Class
Verify Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Verify Method (XmlElement, KeyInfo)

SAMLAssertionSignatureVerify Method (XmlElement, KeyInfo)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    KeyInfo keyInfo
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    keyInfo As KeyInfo
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    KeyInfo^ keyInfo
)
static member Verify :
        xmlElement : XmlElement *
        keyInfo : KeyInfo -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion containing the signature to verify.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info used to perform the verification or null if none.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied key info is used to perform the verification.
See Also

Reference

SAMLAssertionSignature Class
Verify Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.Verify Method (XmlElement, KeyInfoX509Data)

SAMLAssertionSignatureVerify Method (XmlElement, KeyInfoX509Data)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    KeyInfoX509Data keyInfoX509Data
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    keyInfoX509Data As KeyInfoX509Data
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    KeyInfoX509Data^ keyInfoX509Data
)
static member Verify :
        xmlElement : XmlElement *
        keyInfoX509Data : KeyInfoX509Data -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML assertion containing the signature to verify.
keyInfoX509Data
Type: System.Security.Cryptography.XmlKeyInfoX509Data
The X.509 data used to perform the verification or null if none.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied X.509 data is used to perform the verification.
See Also

Reference

SAMLAssertionSignature Class
Verify Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature Fields

The SAMLAssertionSignature type exposes the following members.

Fields
Name | Description
DefaultInclusiveNamespacesPrefixList | The default inclusive namespace prefix list.
Top
See Also

Reference

SAMLAssertionSignature Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAssertionSignature.DefaultInclusiveNamespacesPrefixList Field

SAMLAssertionSignatureDefaultInclusiveNamespacesPrefixList Field

The default inclusive namespace prefix list.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string DefaultInclusiveNamespacesPrefixList = "#default saml ds xs xsi"
Public Const DefaultInclusiveNamespacesPrefixList As String = "#default saml ds xs xsi"
public:
literal String^ DefaultInclusiveNamespacesPrefixList = "#default saml ds xs xsi"
static val mutable DefaultInclusiveNamespacesPrefixList: string

Field Value

Type: String
See Also

Reference

SAMLAssertionSignature Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAttribute Class

Represents an attribute.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAttributeType
ComponentSpace.SAML2.AssertionsSAMLAttribute

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SAMLAttribute : AttributeType
Public Class SAMLAttribute
    Inherits AttributeType
public ref class SAMLAttribute : public AttributeType
type SAMLAttribute =
    class
        inherit AttributeType
    end

The SAMLAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SAMLAttribute | Initializes a new instance of the SAMLAttribute class.
Public method | SAMLAttribute(XmlElement) | Initializes a new instance of the SAMLAttribute class from XML.
Public method | SAMLAttribute(String, String, String) | Initializes a new instance of the SAMLAttribute class.
Public method | SAMLAttribute(String, String, String, String) | Initializes a new instance of the SAMLAttribute class.
Public method | SAMLAttribute(String, String, String, String, Object) | Initializes a new instance of the SAMLAttribute class.
Public method | SAMLAttribute(String, String, String, String, String) | Initializes a new instance of the SAMLAttribute class.
Top
Properties
 | Name | Description
Public property | FriendlyName | Gets or sets the attribute's friendly name. (Inherited from AttributeType.)
Public property | Name | Gets or sets the attribute's name. (Inherited from AttributeType.)
Public property | NameFormat | Gets or sets the attribute's name format. (Inherited from AttributeType.)
Public property | Values | Gets or sets the attribute values. (Inherited from AttributeType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an attribute.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the attribute type to XML. (Inherited from AttributeType.)
Public method | ToXml(XmlDocument) | Serializes the attribute to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


SAMLAttribute Constructor

Overload List
 | Name | Description
Public method | SAMLAttribute | Initializes a new instance of the SAMLAttribute class.
Public method | SAMLAttribute(XmlElement) | Initializes a new instance of the SAMLAttribute class from XML.
Public method | SAMLAttribute(String, String, String) | Initializes a new instance of the SAMLAttribute class.
Public method | SAMLAttribute(String, String, String, String) | Initializes a new instance of the SAMLAttribute class.
Public method | SAMLAttribute(String, String, String, String, Object) | Initializes a new instance of the SAMLAttribute class.
Public method | SAMLAttribute(String, String, String, String, String) | Initializes a new instance of the SAMLAttribute class.
Top
See Also

Reference

SAMLAttribute Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAttribute Constructor

Initializes a new instance of the SAMLAttribute class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAttribute()
Public Sub New
public:
SAMLAttribute()
new : unit -> SAMLAttribute
See Also

Reference

SAMLAttribute Class
SAMLAttribute Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAttribute Constructor (XmlElement)

Initializes a new instance of the SAMLAttribute class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAttribute(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SAMLAttribute(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SAMLAttribute

Parameters

xmlElement
Type: System.XmlXmlElement
The attribute XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SAMLAttribute Class
SAMLAttribute Overload
ComponentSpace.SAML2.Assertions Namespace


SAMLAttribute Constructor (String, String, String)

Initializes a new instance of the SAMLAttribute class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAttribute(
    string name,
    string nameFormat,
    string friendlyName
)
Public Sub New (
    name As String,
    nameFormat As String,
    friendlyName As String
)
public:
SAMLAttribute(
    String^ name,
    String^ nameFormat,
    String^ friendlyName
)
new :
        name : string *
        nameFormat : string *
        friendlyName : string -> SAMLAttribute

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The name format.
friendlyName
Type: SystemString
The friendly name.
See Also

Reference

SAMLAttribute Class
SAMLAttribute Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAttributeNameFormats


SAMLAttribute Constructor (String, String, String, String)

Initializes a new instance of the SAMLAttribute class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAttribute(
    string name,
    string nameFormat,
    string friendlyName,
    string attributeValue
)
Public Sub New (
    name As String,
    nameFormat As String,
    friendlyName As String,
    attributeValue As String
)
public:
SAMLAttribute(
    String^ name,
    String^ nameFormat,
    String^ friendlyName,
    String^ attributeValue
)
new :
        name : string *
        nameFormat : string *
        friendlyName : string *
        attributeValue : string -> SAMLAttribute

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The name format.
friendlyName
Type: SystemString
The friendly name.
attributeValue
Type: SystemString
The attribute value.
See Also

Reference

SAMLAttribute Class
SAMLAttribute Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAttributeNameFormats


SAMLAttribute Constructor (String, String, String, String, Object)

Initializes a new instance of the SAMLAttribute class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAttribute(
    string name,
    string nameFormat,
    string friendlyName,
    string attributeType,
    Object attributeValue
)
Public Sub New (
    name As String,
    nameFormat As String,
    friendlyName As String,
    attributeType As String,
    attributeValue As Object
)
public:
SAMLAttribute(
    String^ name,
    String^ nameFormat,
    String^ friendlyName,
    String^ attributeType,
    Object^ attributeValue
)
new :
        name : string *
        nameFormat : string *
        friendlyName : string *
        attributeType : string *
        attributeValue : Object -> SAMLAttribute

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The name format.
friendlyName
Type: SystemString
The friendly name.
attributeType
Type: SystemString
The attribute type.
attributeValue
Type: SystemObject
The attribute value.
See Also

Reference

SAMLAttribute Class
SAMLAttribute Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAttributeNameFormats
ComponentSpace.SAML2.UtilityXmlSchemaSimpleTypes


SAMLAttribute Constructor (String, String, String, String, String)

Initializes a new instance of the SAMLAttribute class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAttribute(
    string name,
    string nameFormat,
    string friendlyName,
    string attributeType,
    string attributeValue
)
Public Sub New (
    name As String,
    nameFormat As String,
    friendlyName As String,
    attributeType As String,
    attributeValue As String
)
public:
SAMLAttribute(
    String^ name,
    String^ nameFormat,
    String^ friendlyName,
    String^ attributeType,
    String^ attributeValue
)
new :
        name : string *
        nameFormat : string *
        friendlyName : string *
        attributeType : string *
        attributeValue : string -> SAMLAttribute

Parameters

name
Type: SystemString
The attribute name.
nameFormat
Type: SystemString
The name format.
friendlyName
Type: SystemString
The friendly name.
attributeType
Type: SystemString
The attribute type.
attributeValue
Type: SystemString
The attribute value.
See Also

Reference

SAMLAttribute Class
SAMLAttribute Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersAttributeNameFormats
ComponentSpace.SAML2.UtilityXmlSchemaSimpleTypes


SAMLAttribute Properties

The SAMLAttribute type exposes the following members.

Properties
 | Name | Description
Public property | FriendlyName | Gets or sets the attribute's friendly name. (Inherited from AttributeType.)
Public property | Name | Gets or sets the attribute's name. (Inherited from AttributeType.)
Public property | NameFormat | Gets or sets the attribute's name format. (Inherited from AttributeType.)
Public property | Values | Gets or sets the attribute values. (Inherited from AttributeType.)
Top
See Also

Reference

SAMLAttribute Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAttribute Methods

The SAMLAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an attribute.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the attribute type to XML. (Inherited from AttributeType.)
Public method | ToXml(XmlDocument) | Serializes the attribute to XML.
Top
See Also

Reference

SAMLAttribute Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAttribute.IsValid Method

SAMLAttributeIsValid Method

Indicates whether the XML is an attribute.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an attribute; otherwise false.
See Also

Reference

SAMLAttribute Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAttribute.ToXml Method

SAMLAttributeToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlElement) | Serializes the attribute type to XML. (Inherited from AttributeType.)
Public method | ToXml(XmlDocument) | Serializes the attribute to XML.
Top
See Also

Reference

SAMLAttribute Class
ComponentSpace.SAML2.Assertions Namespace


SAMLAttribute.ToXml Method (XmlDocument)

SAMLAttributeToXml Method (XmlDocument)

Serializes the attribute to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The attribute as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SAMLAttribute Class
ToXml Overload
ComponentSpace.SAML2.Assertions Namespace


StringAttributeValueSerializer Class

Serializes string attribute values to XML. The attribute value is a string.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsStringAttributeValueSerializer

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class StringAttributeValueSerializer : IAttributeValueSerializer
Public Class StringAttributeValueSerializer
    Implements IAttributeValueSerializer
public ref class StringAttributeValueSerializer : IAttributeValueSerializer
type StringAttributeValueSerializer =
    class
        interface IAttributeValueSerializer
    end

The StringAttributeValueSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | StringAttributeValueSerializer | Initializes a new instance of the StringAttributeValueSerializer class.
Top
Methods
 | Name | Description
Public method | Deserialize | Deserializes the string attribute value from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize the string attribute value to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAttributeValue
AttributeTypeRegisterAttributeValueSerializer(String, String, IAttributeValueSerializer)
ComponentSpace.SAML2.AssertionsXmlAttributeValueSerializer


StringAttributeValueSerializer Constructor

Initializes a new instance of the StringAttributeValueSerializer class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StringAttributeValueSerializer()
Public Sub New
public:
StringAttributeValueSerializer()
new : unit -> StringAttributeValueSerializer
See Also

Reference

StringAttributeValueSerializer Class
ComponentSpace.SAML2.Assertions Namespace


StringAttributeValueSerializer Methods

The StringAttributeValueSerializer type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | Deserializes the string attribute value from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize the string attribute value to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringAttributeValueSerializer Class
ComponentSpace.SAML2.Assertions Namespace


StringAttributeValueSerializer.Deserialize Method

StringAttributeValueSerializerDeserialize Method

Deserializes the string attribute value from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Object Deserialize(
    XmlElement parentElement
)
Public Function Deserialize (
    parentElement As XmlElement
) As Object
public:
virtual Object^ Deserialize(
    XmlElement^ parentElement
) sealed
abstract Deserialize :
        parentElement : XmlElement -> Object
override Deserialize :
        parentElement : XmlElement -> Object

Parameters

parentElement
Type: System.XmlXmlElement
The parent element of the attribute value.

Return Value

Type: Object
The attribute value.

Implements

IAttributeValueSerializerDeserialize(XmlElement)
See Also

Reference

StringAttributeValueSerializer Class
ComponentSpace.SAML2.Assertions Namespace


StringAttributeValueSerializer.Serialize Method

StringAttributeValueSerializerSerialize Method

Serialize the string attribute value to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void Serialize(
    XmlElement parentElement,
    Object attributeValue
)
Public Sub Serialize (
    parentElement As XmlElement,
    attributeValue As Object
)
public:
virtual void Serialize(
    XmlElement^ parentElement,
    Object^ attributeValue
) sealed
abstract Serialize :
        parentElement : XmlElement *
        attributeValue : Object -> unit
override Serialize :
        parentElement : XmlElement *
        attributeValue : Object -> unit

Parameters

parentElement
Type: System.XmlXmlElement
The parent element of the attribute value.
attributeValue
Type: SystemObject
The attribute value.

Implements

IAttributeValueSerializerSerialize(XmlElement, Object)
See Also

Reference

StringAttributeValueSerializer Class
ComponentSpace.SAML2.Assertions Namespace


Subject Class

Represents a subject.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsSubject

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Subject
Public Class Subject
public ref class Subject
type Subject =  class end

The Subject type exposes the following members.

Constructors
 | Name | Description
Public method | Subject | Initializes a new instance of the Subject class.
Public method | Subject(XmlElement) | Initializes a new instance of the Subject class from XML.
Public method | Subject(BaseID) | Initializes a new instance of the Subject class.
Public method | Subject(EncryptedID) | Initializes a new instance of the Subject class.
Public method | Subject(NameID) | Initializes a new instance of the Subject class.
Top
Properties
 | Name | Description
Public property | BaseID | Gets or sets the base identifier.
Public property | EncryptedID | Gets or sets the encrypted identifier.
Public property | NameID | Gets or sets the name identifier.
Public property | SubjectConfirmations | Gets the subject confirmations.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a subject.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the subject to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


Subject Constructor

Overload List
 | Name | Description
Public method | Subject | Initializes a new instance of the Subject class.
Public method | Subject(XmlElement) | Initializes a new instance of the Subject class from XML.
Public method | Subject(BaseID) | Initializes a new instance of the Subject class.
Public method | Subject(EncryptedID) | Initializes a new instance of the Subject class.
Public method | Subject(NameID) | Initializes a new instance of the Subject class.
Top
See Also

Reference

Subject Class
ComponentSpace.SAML2.Assertions Namespace


Subject Constructor

Initializes a new instance of the Subject class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Subject()
Public Sub New
public:
Subject()
new : unit -> Subject
See Also

Reference

Subject Class
Subject Overload
ComponentSpace.SAML2.Assertions Namespace


Subject Constructor (XmlElement)

Initializes a new instance of the Subject class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Subject(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Subject(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Subject

Parameters

xmlElement
Type: System.XmlXmlElement
The subject XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Subject Class
Subject Overload
ComponentSpace.SAML2.Assertions Namespace


Subject Constructor (BaseID)

Initializes a new instance of the Subject class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Subject(
    BaseID baseID
)
Public Sub New (
    baseID As BaseID
)
public:
Subject(
    BaseID^ baseID
)
new :
        baseID : BaseID -> Subject

Parameters

baseID
Type: ComponentSpace.SAML2.AssertionsBaseID
The base identifier.
See Also

Reference

Subject Class
Subject Overload
ComponentSpace.SAML2.Assertions Namespace


Subject Constructor (EncryptedID)

Initializes a new instance of the Subject class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Subject(
    EncryptedID encryptedID
)
Public Sub New (
    encryptedID As EncryptedID
)
public:
Subject(
    EncryptedID^ encryptedID
)
new :
        encryptedID : EncryptedID -> Subject

Parameters

encryptedID
Type: ComponentSpace.SAML2.AssertionsEncryptedID
The encrypted identifier.
See Also

Reference

Subject Class
Subject Overload
ComponentSpace.SAML2.Assertions Namespace


Subject Constructor (NameID)

Initializes a new instance of the Subject class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Subject(
    NameID nameID
)
Public Sub New (
    nameID As NameID
)
public:
Subject(
    NameID^ nameID
)
new :
        nameID : NameID -> Subject

Parameters

nameID
Type: ComponentSpace.SAML2.AssertionsNameID
The name identifier.
See Also

Reference

Subject Class
Subject Overload
ComponentSpace.SAML2.Assertions Namespace


Subject Properties

The Subject type exposes the following members.

Properties
 | Name | Description
Public property | BaseID | Gets or sets the base identifier.
Public property | EncryptedID | Gets or sets the encrypted identifier.
Public property | NameID | Gets or sets the name identifier.
Public property | SubjectConfirmations | Gets the subject confirmations.
Top
See Also

Reference

Subject Class
ComponentSpace.SAML2.Assertions Namespace


Subject.BaseID Property

SubjectBaseID Property

Gets or sets the base identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public BaseID BaseID { get; set; }
Public Property BaseID As BaseID
    Get
    Set
public:
property BaseID^ BaseID {
    BaseID^ get ();
    void set (BaseID^ value);
}
member BaseID : BaseID with get, set

Property Value

Type: BaseID
The base identifier.
See Also

Reference

Subject Class
ComponentSpace.SAML2.Assertions Namespace


Subject.EncryptedID Property

SubjectEncryptedID Property

Gets or sets the encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID EncryptedID { get; set; }
Public Property EncryptedID As EncryptedID
    Get
    Set
public:
property EncryptedID^ EncryptedID {
    EncryptedID^ get ();
    void set (EncryptedID^ value);
}
member EncryptedID : EncryptedID with get, set

Property Value

Type: EncryptedID
The encrypted identifier.
See Also

Reference

Subject Class
ComponentSpace.SAML2.Assertions Namespace


Subject.NameID Property

SubjectNameID Property

Gets or sets the name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID NameID { get; set; }
Public Property NameID As NameID
    Get
    Set
public:
property NameID^ NameID {
    NameID^ get ();
    void set (NameID^ value);
}
member NameID : NameID with get, set

Property Value

Type: NameID
The name identifier.
See Also

Reference

Subject Class
ComponentSpace.SAML2.Assertions Namespace


Subject.SubjectConfirmations Property

SubjectSubjectConfirmations Property

Gets the subject confirmations.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<SubjectConfirmation> SubjectConfirmations { get; }
Public ReadOnly Property SubjectConfirmations As IList(Of SubjectConfirmation)
    Get
public:
property IList<SubjectConfirmation^>^ SubjectConfirmations {
    IList<SubjectConfirmation^>^ get ();
}
member SubjectConfirmations : IList<SubjectConfirmation> with get

Property Value

Type: IList SubjectConfirmation
The subject confirmations.
See Also

Reference

Subject Class
ComponentSpace.SAML2.Assertions Namespace


Subject Methods

The Subject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a subject.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the subject to XML.
Top
See Also

Reference

Subject Class
ComponentSpace.SAML2.Assertions Namespace


Subject.IsValid Method

SubjectIsValid Method

Indicates whether the XML is a subject.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a subject; otherwise false.
See Also

Reference

Subject Class
ComponentSpace.SAML2.Assertions Namespace


Subject.ToXml Method

SubjectToXml Method

Serializes the subject to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The subject as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Subject Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation Class

Represents a subject confirmation.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsSubjectConfirmation

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SubjectConfirmation
Public Class SubjectConfirmation
public ref class SubjectConfirmation
type SubjectConfirmation =  class end

The SubjectConfirmation type exposes the following members.

Constructors
 | Name | Description
Public method | SubjectConfirmation | Initializes a new instance of the SubjectConfirmation class.
Public method | SubjectConfirmation(String) | Initializes a new instance of the SubjectConfirmation class.
Public method | SubjectConfirmation(XmlElement) | Initializes a new instance of the SubjectConfirmation class from XML.
Public method | SubjectConfirmation(String, BaseID) | Initializes a new instance of the SubjectConfirmation class.
Public method | SubjectConfirmation(String, EncryptedID) | Initializes a new instance of the SubjectConfirmation class.
Public method | SubjectConfirmation(String, NameID) | Initializes a new instance of the SubjectConfirmation class.
Top
Properties
 | Name | Description
Public property | BaseID | Gets or sets the base identifier.
Public property | EncryptedID | Gets or sets the encrypted identifier.
Public property | Method | Gets or sets the method.
Public property | NameID | Gets or sets the name identifier.
Public property | SubjectConfirmationData | Gets or sets the subject confirmation data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a subject confirmation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the subject confirmation to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation Constructor

Overload List
 | Name | Description
Public method | SubjectConfirmation | Initializes a new instance of the SubjectConfirmation class.
Public method | SubjectConfirmation(String) | Initializes a new instance of the SubjectConfirmation class.
Public method | SubjectConfirmation(XmlElement) | Initializes a new instance of the SubjectConfirmation class from XML.
Public method | SubjectConfirmation(String, BaseID) | Initializes a new instance of the SubjectConfirmation class.
Public method | SubjectConfirmation(String, EncryptedID) | Initializes a new instance of the SubjectConfirmation class.
Public method | SubjectConfirmation(String, NameID) | Initializes a new instance of the SubjectConfirmation class.
Top
See Also

Reference

SubjectConfirmation Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation Constructor

Initializes a new instance of the SubjectConfirmation class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmation()
Public Sub New
public:
SubjectConfirmation()
new : unit -> SubjectConfirmation
See Also

Reference

SubjectConfirmation Class
SubjectConfirmation Overload
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation Constructor (String)

Initializes a new instance of the SubjectConfirmation class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmation(
    string method
)
Public Sub New (
    method As String
)
public:
SubjectConfirmation(
    String^ method
)
new :
        method : string -> SubjectConfirmation

Parameters

method
Type: SystemString
The method.
See Also

Reference

SubjectConfirmation Class
SubjectConfirmation Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersSubjectConfirmationMethods


SubjectConfirmation Constructor (XmlElement)

Initializes a new instance of the SubjectConfirmation class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmation(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SubjectConfirmation(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SubjectConfirmation

Parameters

xmlElement
Type: System.XmlXmlElement
The subject confirmation XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SubjectConfirmation Class
SubjectConfirmation Overload
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation Constructor (String, BaseID)

Initializes a new instance of the SubjectConfirmation class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmation(
    string method,
    BaseID baseID
)
Public Sub New (
    method As String,
    baseID As BaseID
)
public:
SubjectConfirmation(
    String^ method,
    BaseID^ baseID
)
new :
        method : string *
        baseID : BaseID -> SubjectConfirmation

Parameters

method
Type: SystemString
The method.
baseID
Type: ComponentSpace.SAML2.AssertionsBaseID
The base identifier.
See Also

Reference

SubjectConfirmation Class
SubjectConfirmation Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersSubjectConfirmationMethods


SubjectConfirmation Constructor (String, EncryptedID)

Initializes a new instance of the SubjectConfirmation class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmation(
    string method,
    EncryptedID encryptedID
)
Public Sub New (
    method As String,
    encryptedID As EncryptedID
)
public:
SubjectConfirmation(
    String^ method,
    EncryptedID^ encryptedID
)
new :
        method : string *
        encryptedID : EncryptedID -> SubjectConfirmation

Parameters

method
Type: SystemString
The method.
encryptedID
Type: ComponentSpace.SAML2.AssertionsEncryptedID
The encrypted identifier.
See Also

Reference

SubjectConfirmation Class
SubjectConfirmation Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersSubjectConfirmationMethods


SubjectConfirmation Constructor (String, NameID)

Initializes a new instance of the SubjectConfirmation class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmation(
    string method,
    NameID nameID
)
Public Sub New (
    method As String,
    nameID As NameID
)
public:
SubjectConfirmation(
    String^ method,
    NameID^ nameID
)
new :
        method : string *
        nameID : NameID -> SubjectConfirmation

Parameters

method
Type: SystemString
The method.
nameID
Type: ComponentSpace.SAML2.AssertionsNameID
The name identifier.
See Also

Reference

SubjectConfirmation Class
SubjectConfirmation Overload
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersSubjectConfirmationMethods


SubjectConfirmation Properties

The SubjectConfirmation type exposes the following members.

Properties
 | Name | Description
Public property | BaseID | Gets or sets the base identifier.
Public property | EncryptedID | Gets or sets the encrypted identifier.
Public property | Method | Gets or sets the method.
Public property | NameID | Gets or sets the name identifier.
Public property | SubjectConfirmationData | Gets or sets the subject confirmation data.
Top
See Also

Reference

SubjectConfirmation Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation.BaseID Property

SubjectConfirmationBaseID Property

Gets or sets the base identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public BaseID BaseID { get; set; }
Public Property BaseID As BaseID
    Get
    Set
public:
property BaseID^ BaseID {
    BaseID^ get ();
    void set (BaseID^ value);
}
member BaseID : BaseID with get, set

Property Value

Type: BaseID
The base identifier.
See Also

Reference

SubjectConfirmation Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation.EncryptedID Property

SubjectConfirmationEncryptedID Property

Gets or sets the encrypted identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID EncryptedID { get; set; }
Public Property EncryptedID As EncryptedID
    Get
    Set
public:
property EncryptedID^ EncryptedID {
    EncryptedID^ get ();
    void set (EncryptedID^ value);
}
member EncryptedID : EncryptedID with get, set

Property Value

Type: EncryptedID
The encrypted identifier.
See Also

Reference

SubjectConfirmation Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation.Method Property

SubjectConfirmationMethod Property

Gets or sets the method.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Method { get; set; }
Public Property Method As String
    Get
    Set
public:
property String^ Method {
    String^ get ();
    void set (String^ value);
}
member Method : string with get, set

Property Value

Type: String
The method.
See Also

Reference

SubjectConfirmation Class
ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2SAMLIdentifiersSubjectConfirmationMethods


SubjectConfirmation.NameID Property

SubjectConfirmationNameID Property

Gets or sets the name identifier.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID NameID { get; set; }
Public Property NameID As NameID
    Get
    Set
public:
property NameID^ NameID {
    NameID^ get ();
    void set (NameID^ value);
}
member NameID : NameID with get, set

Property Value

Type: NameID
The name identifier.
See Also

Reference

SubjectConfirmation Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation.SubjectConfirmationData Property

SubjectConfirmationSubjectConfirmationData Property

Gets or sets the subject confirmation data.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmationData SubjectConfirmationData { get; set; }
Public Property SubjectConfirmationData As SubjectConfirmationData
    Get
    Set
public:
property SubjectConfirmationData^ SubjectConfirmationData {
    SubjectConfirmationData^ get ();
    void set (SubjectConfirmationData^ value);
}
member SubjectConfirmationData : SubjectConfirmationData with get, set

Property Value

Type: SubjectConfirmationData
The subject confirmation data.
See Also

Reference

SubjectConfirmation Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation Methods

The SubjectConfirmation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a subject confirmation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the subject confirmation to XML.
Top
See Also

Reference

SubjectConfirmation Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation.IsValid Method

SubjectConfirmationIsValid Method

Indicates whether the XML is a subject confirmation.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a subject confirmation; otherwise false.
See Also

Reference

SubjectConfirmation Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmation.ToXml Method

SubjectConfirmationToXml Method

Serializes the subject confirmation to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The subject confirmation as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SubjectConfirmation Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData Class

Represents subject confirmation data.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsSubjectConfirmationData

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SubjectConfirmationData
Public Class SubjectConfirmationData
public ref class SubjectConfirmationData
type SubjectConfirmationData =  class end

The SubjectConfirmationData type exposes the following members.

Constructors
 | Name | Description
Public method | SubjectConfirmationData | Initializes a new instance of the SubjectConfirmationData class.
Public method | SubjectConfirmationData(TimeSpan) | Initializes a new instance of the SubjectConfirmationData class.
Public method | SubjectConfirmationData(XmlElement) | Initializes a new instance of the SubjectConfirmationData class from XML.
Public method | SubjectConfirmationData(DateTime, DateTime) | Initializes a new instance of the SubjectConfirmationData class.
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the address.
Public property | InResponseTo | Gets or sets the in response to value.
Public property | KeyInfo | Gets or sets the key info.
Public property | NotBefore | Gets or sets the not before time.
Public property | NotOnOrAfter | Gets or sets the not on or after time.
Public property | Recipient | Gets or sets the recipient.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is subject confirmation data.
Public method | IsWithinTimePeriod | Indicates whether the current UTC time is within the not before and not on or after period, if specified.
Public method | IsWithinTimePeriod(TimeSpan) | Indicates whether the current UTC time is within the not before and not on or after period, if specified. The supplied time span is to allow for clock skew.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the subject confirmation data to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData Constructor

Overload List
 | Name | Description
Public method | SubjectConfirmationData | Initializes a new instance of the SubjectConfirmationData class.
Public method | SubjectConfirmationData(TimeSpan) | Initializes a new instance of the SubjectConfirmationData class.
Public method | SubjectConfirmationData(XmlElement) | Initializes a new instance of the SubjectConfirmationData class from XML.
Public method | SubjectConfirmationData(DateTime, DateTime) | Initializes a new instance of the SubjectConfirmationData class.
Top
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData Constructor

Initializes a new instance of the SubjectConfirmationData class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmationData()
Public Sub New
public:
SubjectConfirmationData()
new : unit -> SubjectConfirmationData
See Also

Reference

SubjectConfirmationData Class
SubjectConfirmationData Overload
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData Constructor (TimeSpan)

Initializes a new instance of the SubjectConfirmationData class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmationData(
    TimeSpan timeSpan
)
Public Sub New (
    timeSpan As TimeSpan
)
public:
SubjectConfirmationData(
    TimeSpan timeSpan
)
new :
        timeSpan : TimeSpan -> SubjectConfirmationData

Parameters

timeSpan
Type: SystemTimeSpan
The timespan before and after now.
Remarks
The not before time is calculated as the current UTC time less the time span. The not on or after time is calculated as the current UTC time plus the time span.
See Also

Reference

SubjectConfirmationData Class
SubjectConfirmationData Overload
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData Constructor (XmlElement)

Initializes a new instance of the SubjectConfirmationData class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmationData(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SubjectConfirmationData(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SubjectConfirmationData

Parameters

xmlElement
Type: System.XmlXmlElement
The subject confirmation data XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SubjectConfirmationData Class
SubjectConfirmationData Overload
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData Constructor (DateTime, DateTime)

Initializes a new instance of the SubjectConfirmationData class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectConfirmationData(
    DateTime notBefore,
    DateTime notOnOrAfter
)
Public Sub New (
    notBefore As DateTime,
    notOnOrAfter As DateTime
)
public:
SubjectConfirmationData(
    DateTime notBefore,
    DateTime notOnOrAfter
)
new :
        notBefore : DateTime *
        notOnOrAfter : DateTime -> SubjectConfirmationData

Parameters

notBefore
Type: SystemDateTime
The not before time as coordinated universal time (UTC).
notOnOrAfter
Type: SystemDateTime
The not on or after time as coordinated universal time (UTC).
See Also

Reference

SubjectConfirmationData Class
SubjectConfirmationData Overload
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData Properties

The SubjectConfirmationData type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the address.
Public property | InResponseTo | Gets or sets the in response to value.
Public property | KeyInfo | Gets or sets the key info.
Public property | NotBefore | Gets or sets the not before time.
Public property | NotOnOrAfter | Gets or sets the not on or after time.
Public property | Recipient | Gets or sets the recipient.
Top
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.Address Property

SubjectConfirmationDataAddress Property

Gets or sets the address.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
The address.
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.InResponseTo Property

SubjectConfirmationDataInResponseTo Property

Gets or sets the in response to value.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string InResponseTo { get; set; }
Public Property InResponseTo As String
    Get
    Set
public:
property String^ InResponseTo {
    String^ get ();
    void set (String^ value);
}
member InResponseTo : string with get, set

Property Value

Type: String
The in response to value.
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.KeyInfo Property

SubjectConfirmationDataKeyInfo Property

Gets or sets the key info.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement KeyInfo { get; set; }
Public Property KeyInfo As XmlElement
    Get
    Set
public:
property XmlElement^ KeyInfo {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member KeyInfo : XmlElement with get, set

Property Value

Type: XmlElement
The key info.
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.NotBefore Property

SubjectConfirmationDataNotBefore Property

Gets or sets the not before time.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime NotBefore { get; set; }
Public Property NotBefore As DateTime
    Get
    Set
public:
property DateTime NotBefore {
    DateTime get ();
    void set (DateTime value);
}
member NotBefore : DateTime with get, set

Property Value

Type: DateTime
The not before time as coordinated universal time (UTC). A value of DateTime.MinValue indicates the value has not been set.
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.NotOnOrAfter Property

SubjectConfirmationDataNotOnOrAfter Property

Gets or sets the not on or after time.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime NotOnOrAfter { get; set; }
Public Property NotOnOrAfter As DateTime
    Get
    Set
public:
property DateTime NotOnOrAfter {
    DateTime get ();
    void set (DateTime value);
}
member NotOnOrAfter : DateTime with get, set

Property Value

Type: DateTime
The not on or after time as coordinated universal time (UTC). A value of DateTime.MaxValue indicates the value has not been set.
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.Recipient Property

SubjectConfirmationDataRecipient Property

Gets or sets the recipient.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Recipient { get; set; }
Public Property Recipient As String
    Get
    Set
public:
property String^ Recipient {
    String^ get ();
    void set (String^ value);
}
member Recipient : string with get, set

Property Value

Type: String
The recipient.
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData Methods

The SubjectConfirmationData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is subject confirmation data.
Public method | IsWithinTimePeriod | Indicates whether the current UTC time is within the not before and not on or after period, if specified.
Public method | IsWithinTimePeriod(TimeSpan) | Indicates whether the current UTC time is within the not before and not on or after period, if specified. The supplied time span is to allow for clock skew.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the subject confirmation data to XML.
Top
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.IsValid Method

SubjectConfirmationDataIsValid Method

Indicates whether the XML is subject confirmation data.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is subject confirmation data; otherwise false.
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.IsWithinTimePeriod Method

SubjectConfirmationDataIsWithinTimePeriod Method

Overload List
 | Name | Description
Public method | IsWithinTimePeriod | Indicates whether the current UTC time is within the not before and not on or after period, if specified.
Public method | IsWithinTimePeriod(TimeSpan) | Indicates whether the current UTC time is within the not before and not on or after period, if specified. The supplied time span is to allow for clock skew.
Top
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.IsWithinTimePeriod Method

SubjectConfirmationDataIsWithinTimePeriod Method

Indicates whether the current UTC time is within the not before and not on or after period, if specified.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool IsWithinTimePeriod()
Public Function IsWithinTimePeriod As Boolean
public:
bool IsWithinTimePeriod()
member IsWithinTimePeriod : unit -> bool

Return Value

Type: Boolean
true if within the time period; otherwise false.
Remarks
To be within the time period, not before > UTC now >= not on or after
See Also

Reference

SubjectConfirmationData Class
IsWithinTimePeriod Overload
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.IsWithinTimePeriod Method (TimeSpan)

SubjectConfirmationDataIsWithinTimePeriod Method (TimeSpan)

Indicates whether the current UTC time is within the not before and not on or after period, if specified. The supplied time span is to allow for clock skew.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool IsWithinTimePeriod(
    TimeSpan clockSkew
)
Public Function IsWithinTimePeriod (
    clockSkew As TimeSpan
) As Boolean
public:
bool IsWithinTimePeriod(
    TimeSpan clockSkew
)
member IsWithinTimePeriod :
        clockSkew : TimeSpan -> bool

Parameters

clockSkew
Type: SystemTimeSpan
The time span to allow for clock skew.

Return Value

Type: Boolean
true if within the time period; otherwise false.
Remarks
To be within the time period, not before - clock skew > UTC now >= not on or after + clock skew
See Also

Reference

SubjectConfirmationData Class
IsWithinTimePeriod Overload
ComponentSpace.SAML2.Assertions Namespace


SubjectConfirmationData.ToXml Method

SubjectConfirmationDataToXml Method

Serializes the subject confirmation data to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The subject confirmation data as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SubjectConfirmationData Class
ComponentSpace.SAML2.Assertions Namespace


SubjectLocality Class

Represents a subject locality.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsSubjectLocality

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SubjectLocality
Public Class SubjectLocality
public ref class SubjectLocality
type SubjectLocality =  class end

The SubjectLocality type exposes the following members.

Constructors
 | Name | Description
Public method | SubjectLocality | Initializes a new instance of the SubjectLocality class.
Public method | SubjectLocality(XmlElement) | Initializes a new instance of the SubjectLocality class from XML.
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the address.
Public property | DNSName | Gets or sets the DNS name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a subject locality.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the subject locality to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace


SubjectLocality Constructor

Overload List
 | Name | Description
Public method | SubjectLocality | Initializes a new instance of the SubjectLocality class.
Public method | SubjectLocality(XmlElement) | Initializes a new instance of the SubjectLocality class from XML.
Top
See Also

Reference

SubjectLocality Class
ComponentSpace.SAML2.Assertions Namespace


SubjectLocality Constructor

Initializes a new instance of the SubjectLocality class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectLocality()
Public Sub New
public:
SubjectLocality()
new : unit -> SubjectLocality
See Also

Reference

SubjectLocality Class
SubjectLocality Overload
ComponentSpace.SAML2.Assertions Namespace


SubjectLocality Constructor (XmlElement)

Initializes a new instance of the SubjectLocality class from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectLocality(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SubjectLocality(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SubjectLocality

Parameters

xmlElement
Type: System.XmlXmlElement
The subject locality XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SubjectLocality Class
SubjectLocality Overload
ComponentSpace.SAML2.Assertions Namespace


SubjectLocality Properties

The SubjectLocality type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the address.
Public property | DNSName | Gets or sets the DNS name.
Top
See Also

Reference

SubjectLocality Class
ComponentSpace.SAML2.Assertions Namespace


SubjectLocality.Address Property

SubjectLocalityAddress Property

Gets or sets the address.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
The address.
See Also

Reference

SubjectLocality Class
ComponentSpace.SAML2.Assertions Namespace


SubjectLocality.DNSName Property

SubjectLocalityDNSName Property

Gets or sets the DNS name.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string DNSName { get; set; }
Public Property DNSName As String
    Get
    Set
public:
property String^ DNSName {
    String^ get ();
    void set (String^ value);
}
member DNSName : string with get, set

Property Value

Type: String
The DNS name.
See Also

Reference

SubjectLocality Class
ComponentSpace.SAML2.Assertions Namespace


SubjectLocality Methods

The SubjectLocality type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a subject locality.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the subject locality to XML.
Top
See Also

Reference

SubjectLocality Class
ComponentSpace.SAML2.Assertions Namespace


SubjectLocality.IsValid Method

SubjectLocalityIsValid Method

Indicates whether the XML is a subject locality.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a subject locality; otherwise false.
See Also

Reference

SubjectLocality Class
ComponentSpace.SAML2.Assertions Namespace


SubjectLocality.ToXml Method

SubjectLocalityToXml Method

Serializes the subject locality to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The subject locality as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SubjectLocality Class
ComponentSpace.SAML2.Assertions Namespace


XmlAttributeValueSerializer Class

Serializes XML element attribute values to XML. The attribute value is an XmlElement.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsXmlAttributeValueSerializer

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class XmlAttributeValueSerializer : IAttributeValueSerializer
Public Class XmlAttributeValueSerializer
    Implements IAttributeValueSerializer
public ref class XmlAttributeValueSerializer : IAttributeValueSerializer
type XmlAttributeValueSerializer =
    class
        interface IAttributeValueSerializer
    end

The XmlAttributeValueSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlAttributeValueSerializer | Initializes a new instance of the XmlAttributeValueSerializer class.
Top
Methods
 | Name | Description
Public method | Deserialize | Deserializes the XML element attribute value from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize the XML element attribute value to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Assertions Namespace
ComponentSpace.SAML2.AssertionsAttributeValue
AttributeTypeRegisterAttributeValueSerializer(String, String, IAttributeValueSerializer)
ComponentSpace.SAML2.AssertionsStringAttributeValueSerializer


XmlAttributeValueSerializer Constructor

Initializes a new instance of the XmlAttributeValueSerializer class.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlAttributeValueSerializer()
Public Sub New
public:
XmlAttributeValueSerializer()
new : unit -> XmlAttributeValueSerializer
See Also

Reference

XmlAttributeValueSerializer Class
ComponentSpace.SAML2.Assertions Namespace


XmlAttributeValueSerializer Methods

The XmlAttributeValueSerializer type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | Deserializes the XML element attribute value from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize the XML element attribute value to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlAttributeValueSerializer Class
ComponentSpace.SAML2.Assertions Namespace


XmlAttributeValueSerializer.Deserialize Method

XmlAttributeValueSerializerDeserialize Method

Deserializes the XML element attribute value from XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Object Deserialize(
    XmlElement parentElement
)
Public Function Deserialize (
    parentElement As XmlElement
) As Object
public:
virtual Object^ Deserialize(
    XmlElement^ parentElement
) sealed
abstract Deserialize :
        parentElement : XmlElement -> Object
override Deserialize :
        parentElement : XmlElement -> Object

Parameters

parentElement
Type: System.XmlXmlElement
The parent element of the attribute value.

Return Value

Type: Object
The attribute value.

Implements

IAttributeValueSerializerDeserialize(XmlElement)
See Also

Reference

XmlAttributeValueSerializer Class
ComponentSpace.SAML2.Assertions Namespace


XmlAttributeValueSerializer.Serialize Method

XmlAttributeValueSerializerSerialize Method

Serialize the XML element attribute value to XML.

Namespace: ComponentSpace.SAML2.Assertions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void Serialize(
    XmlElement parentElement,
    Object attributeValue
)
Public Sub Serialize (
    parentElement As XmlElement,
    attributeValue As Object
)
public:
virtual void Serialize(
    XmlElement^ parentElement,
    Object^ attributeValue
) sealed
abstract Serialize :
        parentElement : XmlElement *
        attributeValue : Object -> unit
override Serialize :
        parentElement : XmlElement *
        attributeValue : Object -> unit

Parameters

parentElement
Type: System.XmlXmlElement
The parent element of the attribute value.
attributeValue
Type: SystemObject
The attribute value.

Implements

IAttributeValueSerializerSerialize(XmlElement, Object)
See Also

Reference

XmlAttributeValueSerializer Class
ComponentSpace.SAML2.Assertions Namespace


ComponentSpace.SAML2.Bindings Namespace

The ComponentSpace.SAML2.Bindings namespace contains classes associated with the SAML v2.0 bindings.
Classes
 | Class | Description
Public class | HTTPArtifact | Represents an artifact used in the HTTP artifact binding.
Public class | HTTPArtifactBinding | Supports the HTTP artifact binding.
Public class | HTTPArtifactState | Provides storage for state information when using the HTTP artifact binding.
Public class | HTTPArtifactStateCache | Provides a cache for storing HTTPArtifactState.
Public class | HTTPArtifactType4 | Represents a type 4 artifact used in the HTTP artifact binding.
Public class | HTTPPostBinding | Supports the HTTP POST binding.
Public class | HTTPRedirectBinding | Supports the HTTP redirect binding.
Public class | PAOSBinding | Supports the reverse SOAP (PAOS) binding.
Public class | RelayState | Provides storage for state information used during SSO.
Public class | RelayStateCache | Provides a cache for storing RelayState.
Public class | SOAPBinding | Supports the SOAP binding.
Public class | URIBinding | Supports the URI binding.


HTTPArtifact Class

Represents an artifact used in the HTTP artifact binding.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsHTTPArtifact
ComponentSpace.SAML2.BindingsHTTPArtifactType4

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class HTTPArtifact
Public MustInherit Class HTTPArtifact
public ref class HTTPArtifact abstract
[<AbstractClassAttribute>]
type HTTPArtifact =  class end

The HTTPArtifact type exposes the following members.

Constructors
 | Name | Description
Public method | HTTPArtifact | Initializes a new instance of the HTTPArtifact class.
Public method | HTTPArtifact(Byte) | Initializes a new instance of the HTTPArtifact class.
Public method | HTTPArtifact(Byte, Byte) | Initializes a new instance of the HTTPArtifact class.
Top
Properties
 | Name | Description
Public property | EndpointIndex | Gets or sets the 2 byte endpoint index.
Public property | TypeCode | Gets or sets the 2 byte type code.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromArray | Initializes the Artifact class from a byte array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Returns the artifact as a byte array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
ArtifactMinimumLength | The minimum length in bytes
EndpointIndexLength | The endpoint index length in bytes
TypeCodeLength | The type code length in bytes
Top
Remarks
Refer to the Bindings for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact Constructor

Overload List
 | Name | Description
Public method | HTTPArtifact | Initializes a new instance of the HTTPArtifact class.
Public method | HTTPArtifact(Byte) | Initializes a new instance of the HTTPArtifact class.
Public method | HTTPArtifact(Byte, Byte) | Initializes a new instance of the HTTPArtifact class.
Top
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact Constructor

Initializes a new instance of the HTTPArtifact class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HTTPArtifact()
Public Sub New
public:
HTTPArtifact()
new : unit -> HTTPArtifact
See Also

Reference

HTTPArtifact Class
HTTPArtifact Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact Constructor (Byte[])

HTTPArtifact Constructor (Byte)

Initializes a new instance of the HTTPArtifact class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HTTPArtifact(
    byte[] typeCode
)
Public Sub New (
    typeCode As Byte()
)
public:
HTTPArtifact(
    array<unsigned char>^ typeCode
)
new :
        typeCode : byte[] -> HTTPArtifact

Parameters

typeCode
Type: SystemByte
The 2 byte type code.
See Also

Reference

HTTPArtifact Class
HTTPArtifact Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact Constructor (Byte[], Byte[])

HTTPArtifact Constructor (Byte, Byte)

Initializes a new instance of the HTTPArtifact class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HTTPArtifact(
    byte[] typeCode,
    byte[] endpointIndex
)
Public Sub New (
    typeCode As Byte(),
    endpointIndex As Byte()
)
public:
HTTPArtifact(
    array<unsigned char>^ typeCode,
    array<unsigned char>^ endpointIndex
)
new :
        typeCode : byte[] *
        endpointIndex : byte[] -> HTTPArtifact

Parameters

typeCode
Type: SystemByte
The 2 byte type code.
endpointIndex
Type: SystemByte
The 2 byte endpoint index.
See Also

Reference

HTTPArtifact Class
HTTPArtifact Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact Properties

The HTTPArtifact type exposes the following members.

Properties
 | Name | Description
Public property | EndpointIndex | Gets or sets the 2 byte endpoint index.
Public property | TypeCode | Gets or sets the 2 byte type code.
Top
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact.EndpointIndex Property

HTTPArtifactEndpointIndex Property

Gets or sets the 2 byte endpoint index.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public byte[] EndpointIndex { get; set; }
Public Property EndpointIndex As Byte()
    Get
    Set
public:
property array<unsigned char>^ EndpointIndex {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member EndpointIndex : byte[] with get, set

Property Value

Type: Byte
The 2 byte endpoint index.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the endpoint index is invalid.
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact.TypeCode Property

HTTPArtifactTypeCode Property

Gets or sets the 2 byte type code.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public byte[] TypeCode { get; set; }
Public Property TypeCode As Byte()
    Get
    Set
public:
property array<unsigned char>^ TypeCode {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member TypeCode : byte[] with get, set

Property Value

Type: Byte
The 2 byte type code.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the type code is invalid.
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact Methods

The HTTPArtifact type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromArray | Initializes the Artifact class from a byte array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Returns the artifact as a byte array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact.FromArray Method

HTTPArtifactFromArray Method

Initializes the Artifact class from a byte array.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void FromArray(
    byte[] artifact
)
Public Sub FromArray (
    artifact As Byte()
)
public:
void FromArray(
    array<unsigned char>^ artifact
)
member FromArray :
        artifact : byte[] -> unit

Parameters

artifact
Type: SystemByte
The artifact as a byte array
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the artifact is invalid.
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact.ToArray Method

HTTPArtifactToArray Method

Returns the artifact as a byte array.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public byte[] ToArray()
Public Function ToArray As Byte()
public:
array<unsigned char>^ ToArray()
member ToArray : unit -> byte[]

Return Value

Type: Byte
The artifact as a byte array.
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact Fields

The HTTPArtifact type exposes the following members.

Fields
Name | Description
ArtifactMinimumLength | The minimum length in bytes
EndpointIndexLength | The endpoint index length in bytes
TypeCodeLength | The type code length in bytes
Top
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact.ArtifactMinimumLength Field

HTTPArtifactArtifactMinimumLength Field

The minimum length in bytes

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const int ArtifactMinimumLength = 4
Public Const ArtifactMinimumLength As Integer = 4
public:
literal int ArtifactMinimumLength = 4
static val mutable ArtifactMinimumLength: int

Field Value

Type: Int32
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact.EndpointIndexLength Field

HTTPArtifactEndpointIndexLength Field

The endpoint index length in bytes

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const int EndpointIndexLength = 2
Public Const EndpointIndexLength As Integer = 2
public:
literal int EndpointIndexLength = 2
static val mutable EndpointIndexLength: int

Field Value

Type: Int32
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifact.TypeCodeLength Field

HTTPArtifactTypeCodeLength Field

The type code length in bytes

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const int TypeCodeLength = 2
Public Const TypeCodeLength As Integer = 2
public:
literal int TypeCodeLength = 2
static val mutable TypeCodeLength: int

Field Value

Type: Int32
See Also

Reference

HTTPArtifact Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding Class

Supports the HTTP artifact binding.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsHTTPArtifactBinding

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class HTTPArtifactBinding
Public NotInheritable Class HTTPArtifactBinding
public ref class HTTPArtifactBinding abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HTTPArtifactBinding =  class end
Methods
Name | Description
ReceiveArtifactInForm(HttpRequest, HTTPArtifact, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInForm(HttpRequest, String, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInForm(HttpRequestBase, HTTPArtifact, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInForm(HttpRequestBase, String, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInQueryString(HttpRequest, HTTPArtifact, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
ReceiveArtifactInQueryString(HttpRequest, String, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
ReceiveArtifactInQueryString(HttpRequestBase, HTTPArtifact, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
ReceiveArtifactInQueryString(HttpRequestBase, String, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
SendArtifactInForm(HttpResponse, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as hidden controls in a posted form.
SendArtifactInForm(HttpResponseBase, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as hidden controls in a posted form.
SendArtifactInQueryString(HttpResponse, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as query string parameters in an HTTP redirect.
SendArtifactInQueryString(HttpResponseBase, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as query string parameters in an HTTP redirect.
Top
Remarks
Refer to the Bindings for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace
ComponentSpace.SAML2SAMLIdentifiersBindingURIs


HTTPArtifactBinding Methods

Methods
Name | Description
ReceiveArtifactInForm(HttpRequest, HTTPArtifact, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInForm(HttpRequest, String, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInForm(HttpRequestBase, HTTPArtifact, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInForm(HttpRequestBase, String, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInQueryString(HttpRequest, HTTPArtifact, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
ReceiveArtifactInQueryString(HttpRequest, String, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
ReceiveArtifactInQueryString(HttpRequestBase, HTTPArtifact, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
ReceiveArtifactInQueryString(HttpRequestBase, String, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
SendArtifactInForm(HttpResponse, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as hidden controls in a posted form.
SendArtifactInForm(HttpResponseBase, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as hidden controls in a posted form.
SendArtifactInQueryString(HttpResponse, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as query string parameters in an HTTP redirect.
SendArtifactInQueryString(HttpResponseBase, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as query string parameters in an HTTP redirect.
Top
See Also

Reference

HTTPArtifactBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.ReceiveArtifactInForm Method

HTTPArtifactBindingReceiveArtifactInForm Method

Overload List
Name | Description
ReceiveArtifactInForm(HttpRequest, HTTPArtifact, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInForm(HttpRequest, String, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInForm(HttpRequestBase, HTTPArtifact, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
ReceiveArtifactInForm(HttpRequestBase, String, String) | Receives the SAML artifact and optional relay state data from the form's hidden controls.
Top
See Also

Reference

HTTPArtifactBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.ReceiveArtifactInForm Method (HttpRequest, HTTPArtifact, String)

HTTPArtifactBindingReceiveArtifactInForm Method (HttpRequest, HTTPArtifact, String)

Receives the SAML artifact and optional relay state data from the form's hidden controls.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactInForm(
    HttpRequest httpRequest,
    out HTTPArtifact artifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactInForm (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef artifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactInForm(
    HttpRequest^ httpRequest,
    [OutAttribute] HTTPArtifact^% artifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactInForm :
        httpRequest : HttpRequest *
        artifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
artifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned SAML artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPArtifactBinding Class
ReceiveArtifactInForm Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.ReceiveArtifactInForm Method (HttpRequest, String, String)

HTTPArtifactBindingReceiveArtifactInForm Method (HttpRequest, String, String)

Receives the SAML artifact and optional relay state data from the form's hidden controls.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactInForm(
    HttpRequest httpRequest,
    out string artifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactInForm (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef artifact As String,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactInForm(
    HttpRequest^ httpRequest,
    [OutAttribute] String^% artifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactInForm :
        httpRequest : HttpRequest *
        artifact : string byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
artifact
Type: SystemString
The returned SAML artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPArtifactBinding Class
ReceiveArtifactInForm Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.ReceiveArtifactInForm Method (HttpRequestBase, HTTPArtifact, String)

HTTPArtifactBindingReceiveArtifactInForm Method (HttpRequestBase, HTTPArtifact, String)

Receives the SAML artifact and optional relay state data from the form's hidden controls.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactInForm(
    HttpRequestBase httpRequest,
    out HTTPArtifact artifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactInForm (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef artifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactInForm(
    HttpRequestBase^ httpRequest,
    [OutAttribute] HTTPArtifact^% artifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactInForm :
        httpRequest : HttpRequestBase *
        artifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
artifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned SAML artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPArtifactBinding Class
ReceiveArtifactInForm Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.ReceiveArtifactInForm Method (HttpRequestBase, String, String)

HTTPArtifactBindingReceiveArtifactInForm Method (HttpRequestBase, String, String)

Receives the SAML artifact and optional relay state data from the form's hidden controls.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactInForm(
    HttpRequestBase httpRequest,
    out string artifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactInForm (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef artifact As String,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactInForm(
    HttpRequestBase^ httpRequest,
    [OutAttribute] String^% artifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactInForm :
        httpRequest : HttpRequestBase *
        artifact : string byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
artifact
Type: SystemString
The returned SAML artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPArtifactBinding Class
ReceiveArtifactInForm Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.ReceiveArtifactInQueryString Method

HTTPArtifactBindingReceiveArtifactInQueryString Method

Overload List
Name | Description
ReceiveArtifactInQueryString(HttpRequest, HTTPArtifact, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
ReceiveArtifactInQueryString(HttpRequest, String, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
ReceiveArtifactInQueryString(HttpRequestBase, HTTPArtifact, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
ReceiveArtifactInQueryString(HttpRequestBase, String, String) | Receives the SAML artifact and optional relay state by extracting them from the query string.
Top
See Also

Reference

HTTPArtifactBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.ReceiveArtifactInQueryString Method (HttpRequest, HTTPArtifact, String)

HTTPArtifactBindingReceiveArtifactInQueryString Method (HttpRequest, HTTPArtifact, String)

Receives the SAML artifact and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactInQueryString(
    HttpRequest httpRequest,
    out HTTPArtifact artifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactInQueryString (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef artifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactInQueryString(
    HttpRequest^ httpRequest,
    [OutAttribute] HTTPArtifact^% artifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactInQueryString :
        httpRequest : HttpRequest *
        artifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
artifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned SAML artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPArtifactBinding Class
ReceiveArtifactInQueryString Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.ReceiveArtifactInQueryString Method (HttpRequest, String, String)

HTTPArtifactBindingReceiveArtifactInQueryString Method (HttpRequest, String, String)

Receives the SAML artifact and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactInQueryString(
    HttpRequest httpRequest,
    out string artifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactInQueryString (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef artifact As String,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactInQueryString(
    HttpRequest^ httpRequest,
    [OutAttribute] String^% artifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactInQueryString :
        httpRequest : HttpRequest *
        artifact : string byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
artifact
Type: SystemString
The returned SAML artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPArtifactBinding Class
ReceiveArtifactInQueryString Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.ReceiveArtifactInQueryString Method (HttpRequestBase, HTTPArtifact, String)

HTTPArtifactBindingReceiveArtifactInQueryString Method (HttpRequestBase, HTTPArtifact, String)

Receives the SAML artifact and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactInQueryString(
    HttpRequestBase httpRequest,
    out HTTPArtifact artifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactInQueryString (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef artifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactInQueryString(
    HttpRequestBase^ httpRequest,
    [OutAttribute] HTTPArtifact^% artifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactInQueryString :
        httpRequest : HttpRequestBase *
        artifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
artifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned SAML artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPArtifactBinding Class
ReceiveArtifactInQueryString Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.ReceiveArtifactInQueryString Method (HttpRequestBase, String, String)

HTTPArtifactBindingReceiveArtifactInQueryString Method (HttpRequestBase, String, String)

Receives the SAML artifact and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactInQueryString(
    HttpRequestBase httpRequest,
    out string artifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactInQueryString (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef artifact As String,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactInQueryString(
    HttpRequestBase^ httpRequest,
    [OutAttribute] String^% artifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactInQueryString :
        httpRequest : HttpRequestBase *
        artifact : string byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
artifact
Type: SystemString
The returned SAML artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPArtifactBinding Class
ReceiveArtifactInQueryString Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.SendArtifactInForm Method

HTTPArtifactBindingSendArtifactInForm Method

Overload List
Name | Description
SendArtifactInForm(HttpResponse, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as hidden controls in a posted form.
SendArtifactInForm(HttpResponseBase, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as hidden controls in a posted form.
Top
See Also

Reference

HTTPArtifactBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.SendArtifactInForm Method (HttpResponse, String, HTTPArtifact, String)

HTTPArtifactBindingSendArtifactInForm Method (HttpResponse, String, HTTPArtifact, String)

Sends the SAML artifact and optional relay state data as hidden controls in a posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactInForm(
    HttpResponse httpResponse,
    string targetURL,
    HTTPArtifact artifact,
    string relayState
)
Public Shared Sub SendArtifactInForm (
    httpResponse As HttpResponse,
    targetURL As String,
    artifact As HTTPArtifact,
    relayState As String
)
public:
static void SendArtifactInForm(
    HttpResponse^ httpResponse,
    String^ targetURL,
    HTTPArtifact^ artifact,
    String^ relayState
)
static member SendArtifactInForm :
        httpResponse : HttpResponse *
        targetURL : string *
        artifact : HTTPArtifact *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will return the form to post.
targetURL
Type: SystemString
The target URL for the posted form.
artifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The SAML artifact.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPArtifactBinding Class
SendArtifactInForm Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.SendArtifactInForm Method (HttpResponseBase, String, HTTPArtifact, String)

HTTPArtifactBindingSendArtifactInForm Method (HttpResponseBase, String, HTTPArtifact, String)

Sends the SAML artifact and optional relay state data as hidden controls in a posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactInForm(
    HttpResponseBase httpResponse,
    string targetURL,
    HTTPArtifact artifact,
    string relayState
)
Public Shared Sub SendArtifactInForm (
    httpResponse As HttpResponseBase,
    targetURL As String,
    artifact As HTTPArtifact,
    relayState As String
)
public:
static void SendArtifactInForm(
    HttpResponseBase^ httpResponse,
    String^ targetURL,
    HTTPArtifact^ artifact,
    String^ relayState
)
static member SendArtifactInForm :
        httpResponse : HttpResponseBase *
        targetURL : string *
        artifact : HTTPArtifact *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will return the form to post.
targetURL
Type: SystemString
The target URL for the posted form.
artifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The SAML artifact.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPArtifactBinding Class
SendArtifactInForm Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.SendArtifactInQueryString Method

HTTPArtifactBindingSendArtifactInQueryString Method

Overload List
Name | Description
SendArtifactInQueryString(HttpResponse, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as query string parameters in an HTTP redirect.
SendArtifactInQueryString(HttpResponseBase, String, HTTPArtifact, String) | Sends the SAML artifact and optional relay state data as query string parameters in an HTTP redirect.
Top
See Also

Reference

HTTPArtifactBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.SendArtifactInQueryString Method (HttpResponse, String, HTTPArtifact, String)

HTTPArtifactBindingSendArtifactInQueryString Method (HttpResponse, String, HTTPArtifact, String)

Sends the SAML artifact and optional relay state data as query string parameters in an HTTP redirect.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactInQueryString(
    HttpResponse httpResponse,
    string redirectURL,
    HTTPArtifact artifact,
    string relayState
)
Public Shared Sub SendArtifactInQueryString (
    httpResponse As HttpResponse,
    redirectURL As String,
    artifact As HTTPArtifact,
    relayState As String
)
public:
static void SendArtifactInQueryString(
    HttpResponse^ httpResponse,
    String^ redirectURL,
    HTTPArtifact^ artifact,
    String^ relayState
)
static member SendArtifactInQueryString :
        httpResponse : HttpResponse *
        redirectURL : string *
        artifact : HTTPArtifact *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
redirectURL
Type: SystemString
The redirect URL.
artifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The SAML artifact.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPArtifactBinding Class
SendArtifactInQueryString Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactBinding.SendArtifactInQueryString Method (HttpResponseBase, String, HTTPArtifact, String)

HTTPArtifactBindingSendArtifactInQueryString Method (HttpResponseBase, String, HTTPArtifact, String)

Sends the SAML artifact and optional relay state data as query string parameters in an HTTP redirect.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactInQueryString(
    HttpResponseBase httpResponse,
    string redirectURL,
    HTTPArtifact artifact,
    string relayState
)
Public Shared Sub SendArtifactInQueryString (
    httpResponse As HttpResponseBase,
    redirectURL As String,
    artifact As HTTPArtifact,
    relayState As String
)
public:
static void SendArtifactInQueryString(
    HttpResponseBase^ httpResponse,
    String^ redirectURL,
    HTTPArtifact^ artifact,
    String^ relayState
)
static member SendArtifactInQueryString :
        httpResponse : HttpResponseBase *
        redirectURL : string *
        artifact : HTTPArtifact *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
redirectURL
Type: SystemString
The redirect URL.
artifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The SAML artifact.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPArtifactBinding Class
SendArtifactInQueryString Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactState Class

Provides storage for state information when using the HTTP artifact binding.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsHTTPArtifactState

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class HTTPArtifactState
Public Class HTTPArtifactState
public ref class HTTPArtifactState
type HTTPArtifactState =  class end

The HTTPArtifactState type exposes the following members.

Constructors
 | Name | Description
Public method | HTTPArtifactState | Initializes a new instance of the HTTPArtifactState class.
Public method | HTTPArtifactState(XmlElement, Object) | Initializes a new instance of the HTTPArtifactState class.
Top
Properties
 | Name | Description
Public property | AdditionalState | Gets or sets the additional state information.
Public property | SAMLMessage | Gets or sets the SAML message associated with the artifact.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactState Constructor

Overload List
 | Name | Description
Public method | HTTPArtifactState | Initializes a new instance of the HTTPArtifactState class.
Public method | HTTPArtifactState(XmlElement, Object) | Initializes a new instance of the HTTPArtifactState class.
Top
See Also

Reference

HTTPArtifactState Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactState Constructor

Initializes a new instance of the HTTPArtifactState class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HTTPArtifactState()
Public Sub New
public:
HTTPArtifactState()
new : unit -> HTTPArtifactState
See Also

Reference

HTTPArtifactState Class
HTTPArtifactState Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactState Constructor (XmlElement, Object)

Initializes a new instance of the HTTPArtifactState class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HTTPArtifactState(
    XmlElement samlMessage,
    Object additionalState
)
Public Sub New (
    samlMessage As XmlElement,
    additionalState As Object
)
public:
HTTPArtifactState(
    XmlElement^ samlMessage,
    Object^ additionalState
)
new :
        samlMessage : XmlElement *
        additionalState : Object -> HTTPArtifactState

Parameters

samlMessage
Type: System.XmlXmlElement
The SAML message associated with the artifact.
additionalState
Type: SystemObject
Additional state information or null if none.
See Also

Reference

HTTPArtifactState Class
HTTPArtifactState Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactState Properties

The HTTPArtifactState type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalState | Gets or sets the additional state information.
Public property | SAMLMessage | Gets or sets the SAML message associated with the artifact.
Top
See Also

Reference

HTTPArtifactState Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactState.AdditionalState Property

HTTPArtifactStateAdditionalState Property

Gets or sets the additional state information.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Object AdditionalState { get; set; }
Public Property AdditionalState As Object
    Get
    Set
public:
property Object^ AdditionalState {
    Object^ get ();
    void set (Object^ value);
}
member AdditionalState : Object with get, set

Property Value

Type: Object
The additional state information or null if none.
See Also

Reference

HTTPArtifactState Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactState.SAMLMessage Property

HTTPArtifactStateSAMLMessage Property

Gets or sets the SAML message associated with the artifact.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement SAMLMessage { get; set; }
Public Property SAMLMessage As XmlElement
    Get
    Set
public:
property XmlElement^ SAMLMessage {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member SAMLMessage : XmlElement with get, set

Property Value

Type: XmlElement
The SAML message.
See Also

Reference

HTTPArtifactState Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactState Methods

The HTTPArtifactState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HTTPArtifactState Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactStateCache Class

Provides a cache for storing HTTPArtifactState.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsHTTPArtifactStateCache

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class HTTPArtifactStateCache
Public NotInheritable Class HTTPArtifactStateCache
public ref class HTTPArtifactStateCache abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HTTPArtifactStateCache =  class end

The HTTPArtifactStateCache type exposes the following members.

Properties
Name | Description
Expiration | Gets or sets the expiration time span for cached artifact state entries.
Top
Methods
Name | Description
Add | Adds an entry to the cache.
Get | Gets an entry from the cache.
Remove | Removes an entry from the cache.
Top
Remarks
The cache is implemented using the System.Web.Caching.Cache. Use of this cache is entirely optional. Refer to the System.Web.Caching.Cache documentation for usage restrictions.
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactStateCache Properties

The HTTPArtifactStateCache type exposes the following members.

Properties
Name | Description
Expiration | Gets or sets the expiration time span for cached artifact state entries.
Top
See Also

Reference

HTTPArtifactStateCache Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactStateCache.Expiration Property

HTTPArtifactStateCacheExpiration Property

Gets or sets the expiration time span for cached artifact state entries.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static TimeSpan Expiration { get; set; }
Public Shared Property Expiration As TimeSpan
    Get
    Set
public:
static property TimeSpan Expiration {
    TimeSpan get ();
    void set (TimeSpan value);
}
static member Expiration : TimeSpan with get, set

Property Value

Type: TimeSpan
The expiration time span for cached artifact state entries.
See Also

Reference

HTTPArtifactStateCache Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactStateCache Methods

The HTTPArtifactStateCache type exposes the following members.

Methods
Name | Description
Add | Adds an entry to the cache.
Get | Gets an entry from the cache.
Remove | Removes an entry from the cache.
Top
See Also

Reference

HTTPArtifactStateCache Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactStateCache.Add Method

HTTPArtifactStateCacheAdd Method

Adds an entry to the cache.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Add(
    HTTPArtifact httpArtifact,
    HTTPArtifactState httpArtifactState
)
Public Shared Sub Add (
    httpArtifact As HTTPArtifact,
    httpArtifactState As HTTPArtifactState
)
public:
static void Add(
    HTTPArtifact^ httpArtifact,
    HTTPArtifactState^ httpArtifactState
)
static member Add :
        httpArtifact : HTTPArtifact *
        httpArtifactState : HTTPArtifactState -> unit

Parameters

httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact whose string value is used as a cache key.
httpArtifactState
Type: ComponentSpace.SAML2.BindingsHTTPArtifactState
The item to cache.
See Also

Reference

HTTPArtifactStateCache Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactStateCache.Get Method

HTTPArtifactStateCacheGet Method

Gets an entry from the cache.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static HTTPArtifactState Get(
    HTTPArtifact httpArtifact
)
Public Shared Function Get (
    httpArtifact As HTTPArtifact
) As HTTPArtifactState
public:
static HTTPArtifactState^ Get(
    HTTPArtifact^ httpArtifact
)
static member Get :
        httpArtifact : HTTPArtifact -> HTTPArtifactState

Parameters

httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact whose string value is used as a cache key.

Return Value

Type: HTTPArtifactState
The cached item or null if none.
See Also

Reference

HTTPArtifactStateCache Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactStateCache.Remove Method

HTTPArtifactStateCacheRemove Method

Removes an entry from the cache.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static HTTPArtifactState Remove(
    HTTPArtifact httpArtifact
)
Public Shared Function Remove (
    httpArtifact As HTTPArtifact
) As HTTPArtifactState
public:
static HTTPArtifactState^ Remove(
    HTTPArtifact^ httpArtifact
)
static member Remove :
        httpArtifact : HTTPArtifact -> HTTPArtifactState

Parameters

httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact whose string value is used as a cache key.

Return Value

Type: HTTPArtifactState
The item removed from the cache or null if none.
See Also

Reference

HTTPArtifactStateCache Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4 Class

Represents a type 4 artifact used in the HTTP artifact binding.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsHTTPArtifact
ComponentSpace.SAML2.BindingsHTTPArtifactType4

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class HTTPArtifactType4 : HTTPArtifact
Public Class HTTPArtifactType4
    Inherits HTTPArtifact
public ref class HTTPArtifactType4 : public HTTPArtifact
type HTTPArtifactType4 =
    class
        inherit HTTPArtifact
    end

The HTTPArtifactType4 type exposes the following members.

Constructors
 | Name | Description
Public method | HTTPArtifactType4 | Initializes a new instance of the HTTPArtifactType4 class.
Public method | HTTPArtifactType4(String) | Initializes a new instance of the HTTPArtifactType4 class.
Public method | HTTPArtifactType4(Byte, Byte) | Initializes a new instance of the HTTPArtifactType4 class.
Public method | HTTPArtifactType4(Byte, Byte, Byte) | Initializes a new instance of the HTTPArtifactType4 class.
Top
Properties
 | Name | Description
Public property | EndpointIndex | Gets or sets the 2 byte endpoint index. (Inherited from HTTPArtifact.)
Public property | MessageHandle | Gets or sets the 20 byte message handle.
Public property | SourceID | Gets or sets the 20 byte source ID.
Public property | TypeCode | Gets or sets the 2 byte type code. (Inherited from HTTPArtifact.)
Top
Methods
 | Name | Description
 | CreateMessageHandle | Creates a message handle from a random GUID.
 | CreateSourceId | Creates a source identifier by computing the SHA-1 hash of the identification URL.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromArray | Initializes the Artifact class from a byte array. (Inherited from HTTPArtifact.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the artifact is valid or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Returns the artifact as a byte array. (Inherited from HTTPArtifact.)
Public method | ToString | Returns the base 64 encoded artifact. (Overrides ObjectToString.)
Top
Fields
Name | Description
ArtifactType4Length | The type 4 artifact length.
MessageHandleLength | The message handle length.
SourceIDLength | The source identifier length.
Top
Remarks
Refer to the Bindings for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4 Constructor

Overload List
 | Name | Description
Public method | HTTPArtifactType4 | Initializes a new instance of the HTTPArtifactType4 class.
Public method | HTTPArtifactType4(String) | Initializes a new instance of the HTTPArtifactType4 class.
Public method | HTTPArtifactType4(Byte, Byte) | Initializes a new instance of the HTTPArtifactType4 class.
Public method | HTTPArtifactType4(Byte, Byte, Byte) | Initializes a new instance of the HTTPArtifactType4 class.
Top
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4 Constructor

Initializes a new instance of the HTTPArtifactType4 class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HTTPArtifactType4()
Public Sub New
public:
HTTPArtifactType4()
new : unit -> HTTPArtifactType4
See Also

Reference

HTTPArtifactType4 Class
HTTPArtifactType4 Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4 Constructor (String)

Initializes a new instance of the HTTPArtifactType4 class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HTTPArtifactType4(
    string artifact
)
Public Sub New (
    artifact As String
)
public:
HTTPArtifactType4(
    String^ artifact
)
new :
        artifact : string -> HTTPArtifactType4

Parameters

artifact
Type: SystemString
The base 64 encoded artifact.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the artifact is invalid.
See Also

Reference

HTTPArtifactType4 Class
HTTPArtifactType4 Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4 Constructor (Byte[], Byte[])

HTTPArtifactType4 Constructor (Byte, Byte)

Initializes a new instance of the HTTPArtifactType4 class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HTTPArtifactType4(
    byte[] sourceID,
    byte[] messageHandle
)
Public Sub New (
    sourceID As Byte(),
    messageHandle As Byte()
)
public:
HTTPArtifactType4(
    array<unsigned char>^ sourceID,
    array<unsigned char>^ messageHandle
)
new :
        sourceID : byte[] *
        messageHandle : byte[] -> HTTPArtifactType4

Parameters

sourceID
Type: SystemByte
The 20 byte source ID.
messageHandle
Type: SystemByte
The 20 byte message handle.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the artifact is invalid.
See Also

Reference

HTTPArtifactType4 Class
HTTPArtifactType4 Overload
ComponentSpace.SAML2.Bindings Namespace
HTTPArtifactType4CreateSourceId(String)
HTTPArtifactType4CreateMessageHandle


HTTPArtifactType4 Constructor (Byte[], Byte[], Byte[])

HTTPArtifactType4 Constructor (Byte, Byte, Byte)

Initializes a new instance of the HTTPArtifactType4 class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HTTPArtifactType4(
    byte[] endpointIndex,
    byte[] sourceID,
    byte[] messageHandle
)
Public Sub New (
    endpointIndex As Byte(),
    sourceID As Byte(),
    messageHandle As Byte()
)
public:
HTTPArtifactType4(
    array<unsigned char>^ endpointIndex,
    array<unsigned char>^ sourceID,
    array<unsigned char>^ messageHandle
)
new :
        endpointIndex : byte[] *
        sourceID : byte[] *
        messageHandle : byte[] -> HTTPArtifactType4

Parameters

endpointIndex
Type: SystemByte
The 2 byte endpoint index.
sourceID
Type: SystemByte
The 20 byte source ID.
messageHandle
Type: SystemByte
The 20 byte message handle.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the artifact is invalid.
See Also

Reference

HTTPArtifactType4 Class
HTTPArtifactType4 Overload
ComponentSpace.SAML2.Bindings Namespace
HTTPArtifactType4CreateSourceId(String)
HTTPArtifactType4CreateMessageHandle


HTTPArtifactType4 Properties

The HTTPArtifactType4 type exposes the following members.

Properties
 | Name | Description
Public property | EndpointIndex | Gets or sets the 2 byte endpoint index. (Inherited from HTTPArtifact.)
Public property | MessageHandle | Gets or sets the 20 byte message handle.
Public property | SourceID | Gets or sets the 20 byte source ID.
Public property | TypeCode | Gets or sets the 2 byte type code. (Inherited from HTTPArtifact.)
Top
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4.MessageHandle Property

HTTPArtifactType4MessageHandle Property

Gets or sets the 20 byte message handle.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public byte[] MessageHandle { get; set; }
Public Property MessageHandle As Byte()
    Get
    Set
public:
property array<unsigned char>^ MessageHandle {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member MessageHandle : byte[] with get, set

Property Value

Type: Byte
The 20 byte message handle.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the message handle is invalid.
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace
HTTPArtifactType4CreateMessageHandle


HTTPArtifactType4.SourceID Property

HTTPArtifactType4SourceID Property

Gets or sets the 20 byte source ID.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public byte[] SourceID { get; set; }
Public Property SourceID As Byte()
    Get
    Set
public:
property array<unsigned char>^ SourceID {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member SourceID : byte[] with get, set

Property Value

Type: Byte
The 20 byte source ID.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the source ID is invalid.
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace
HTTPArtifactType4CreateSourceId(String)


HTTPArtifactType4 Methods

The HTTPArtifactType4 type exposes the following members.

Methods
 | Name | Description
 | CreateMessageHandle | Creates a message handle from a random GUID.
 | CreateSourceId | Creates a source identifier by computing the SHA-1 hash of the identification URL.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromArray | Initializes the Artifact class from a byte array. (Inherited from HTTPArtifact.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the artifact is valid or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Returns the artifact as a byte array. (Inherited from HTTPArtifact.)
Public method | ToString | Returns the base 64 encoded artifact. (Overrides ObjectToString.)
Top
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4.CreateMessageHandle Method

HTTPArtifactType4CreateMessageHandle Method

Creates a message handle from a random GUID.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static byte[] CreateMessageHandle()
Public Shared Function CreateMessageHandle As Byte()
public:
static array<unsigned char>^ CreateMessageHandle()
static member CreateMessageHandle : unit -> byte[]

Return Value

Type: Byte
The 20 byte message handle.
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4.CreateSourceId Method

HTTPArtifactType4CreateSourceId Method

Creates a source identifier by computing the SHA-1 hash of the identification URL.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static byte[] CreateSourceId(
    string identificationURL
)
Public Shared Function CreateSourceId (
    identificationURL As String
) As Byte()
public:
static array<unsigned char>^ CreateSourceId(
    String^ identificationURL
)
static member CreateSourceId :
        identificationURL : string -> byte[]

Parameters

identificationURL
Type: SystemString
The identification URL.

Return Value

Type: Byte
The source identifier.
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4.IsValid Method

HTTPArtifactType4IsValid Method

Indicates whether the artifact is valid or not.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    string artifact
)
Public Shared Function IsValid (
    artifact As String
) As Boolean
public:
static bool IsValid(
    String^ artifact
)
static member IsValid :
        artifact : string -> bool

Parameters

artifact
Type: SystemString
The base 64 encoded artifact.

Return Value

Type: Boolean
true if the artifact is valid; otherwise false.
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4.ToString Method

HTTPArtifactType4ToString Method

Returns the base 64 encoded artifact.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The base 64 encoded artifact
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4 Fields

The HTTPArtifactType4 type exposes the following members.

Fields
Name | Description
ArtifactType4Length | The type 4 artifact length.
MessageHandleLength | The message handle length.
SourceIDLength | The source identifier length.
Top
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4.ArtifactType4Length Field

HTTPArtifactType4ArtifactType4Length Field

The type 4 artifact length.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const int ArtifactType4Length = 44
Public Const ArtifactType4Length As Integer = 44
public:
literal int ArtifactType4Length = 44
static val mutable ArtifactType4Length: int

Field Value

Type: Int32
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4.MessageHandleLength Field

HTTPArtifactType4MessageHandleLength Field

The message handle length.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const int MessageHandleLength = 20
Public Const MessageHandleLength As Integer = 20
public:
literal int MessageHandleLength = 20
static val mutable MessageHandleLength: int

Field Value

Type: Int32
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPArtifactType4.SourceIDLength Field

HTTPArtifactType4SourceIDLength Field

The source identifier length.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const int SourceIDLength = 20
Public Const SourceIDLength As Integer = 20
public:
literal int SourceIDLength = 20
static val mutable SourceIDLength: int

Field Value

Type: Int32
See Also

Reference

HTTPArtifactType4 Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding Class

Supports the HTTP POST binding.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsHTTPPostBinding

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class HTTPPostBinding
Public NotInheritable Class HTTPPostBinding
public ref class HTTPPostBinding abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HTTPPostBinding =  class end

The HTTPPostBinding type exposes the following members.

Properties
Name | Description
HTMLFormTemplate | Gets or sets the HTML form template that's used when posting.
Top
Methods
Name | Description
CreateRequestPostData | Creates HTTP POST data from the SAML request and optional relay state.
CreateResponsePostData | Creates HTTP POST data from the SAML response and optional relay state.
ReceiveMessage(HttpRequest, XmlElement, String, Boolean) | Receives the SAML request or response and optional relay state data by extracting them from the posted form.
ReceiveMessage(HttpRequestBase, XmlElement, String, Boolean) | Receives the SAML request or response and optional relay state data by extracting them from the posted form.
ReceiveRequest(HttpRequest, XmlElement, String) | Receives the SAML request and optional relay state data by extracting them from the posted form.
ReceiveRequest(HttpRequestBase, XmlElement, String) | Receives the SAML request and optional relay state data by extracting them from the posted form.
ReceiveResponse(HttpRequest, XmlElement, String) | Receives the SAML response and optional relay state data by extracting them from the posted form.
ReceiveResponse(HttpRequestBase, XmlElement, String) | Receives the SAML response and optional relay state data by extracting them from the posted form.
SendRequest(Stream, String, XmlElement, String) | Sends the SAML request and optional relay state data as hidden controls in a posted form.
SendRequest(HttpResponse, String, XmlElement, String) | Sends the SAML request and optional relay state data as hidden controls in a posted form.
SendRequest(HttpResponseBase, String, XmlElement, String) | Sends the SAML request and optional relay state data as hidden controls in a posted form.
SendResponse(Stream, String, XmlElement, String) | Sends the SAML response and optional relay state data as hidden controls in a posted form.
SendResponse(HttpResponse, String, XmlElement, String) | Sends the SAML response and optional relay state data as hidden controls in a posted form.
SendResponse(HttpResponseBase, String, XmlElement, String) | Sends the SAML response and optional relay state data as hidden controls in a posted form.
Top
Remarks
Refer to the Bindings for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace
ComponentSpace.SAML2SAMLIdentifiersBindingURIs


HTTPPostBinding Properties

The HTTPPostBinding type exposes the following members.

Properties
Name | Description
HTMLFormTemplate | Gets or sets the HTML form template that's used when posting.
Top
See Also

Reference

HTTPPostBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.HTMLFormTemplate Property

HTTPPostBindingHTMLFormTemplate Property

Gets or sets the HTML form template that's used when posting.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string HTMLFormTemplate { get; set; }
Public Shared Property HTMLFormTemplate As String
    Get
    Set
public:
static property String^ HTMLFormTemplate {
    String^ get ();
    void set (String^ value);
}
static member HTMLFormTemplate : string with get, set

Property Value

Type: String
The HTML form template that's used when posting.
See Also

Reference

HTTPPostBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding Methods

The HTTPPostBinding type exposes the following members.

Methods
Name | Description
CreateRequestPostData | Creates HTTP POST data from the SAML request and optional relay state.
CreateResponsePostData | Creates HTTP POST data from the SAML response and optional relay state.
ReceiveMessage(HttpRequest, XmlElement, String, Boolean) | Receives the SAML request or response and optional relay state data by extracting them from the posted form.
ReceiveMessage(HttpRequestBase, XmlElement, String, Boolean) | Receives the SAML request or response and optional relay state data by extracting them from the posted form.
ReceiveRequest(HttpRequest, XmlElement, String) | Receives the SAML request and optional relay state data by extracting them from the posted form.
ReceiveRequest(HttpRequestBase, XmlElement, String) | Receives the SAML request and optional relay state data by extracting them from the posted form.
ReceiveResponse(HttpRequest, XmlElement, String) | Receives the SAML response and optional relay state data by extracting them from the posted form.
ReceiveResponse(HttpRequestBase, XmlElement, String) | Receives the SAML response and optional relay state data by extracting them from the posted form.
SendRequest(Stream, String, XmlElement, String) | Sends the SAML request and optional relay state data as hidden controls in a posted form.
SendRequest(HttpResponse, String, XmlElement, String) | Sends the SAML request and optional relay state data as hidden controls in a posted form.
SendRequest(HttpResponseBase, String, XmlElement, String) | Sends the SAML request and optional relay state data as hidden controls in a posted form.
SendResponse(Stream, String, XmlElement, String) | Sends the SAML response and optional relay state data as hidden controls in a posted form.
SendResponse(HttpResponse, String, XmlElement, String) | Sends the SAML response and optional relay state data as hidden controls in a posted form.
SendResponse(HttpResponseBase, String, XmlElement, String) | Sends the SAML response and optional relay state data as hidden controls in a posted form.
Top
See Also

Reference

HTTPPostBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.CreateRequestPostData Method

HTTPPostBindingCreateRequestPostData Method

Creates HTTP POST data from the SAML request and optional relay state.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string CreateRequestPostData(
    XmlElement samlMessage,
    string relayState
)
Public Shared Function CreateRequestPostData (
    samlMessage As XmlElement,
    relayState As String
) As String
public:
static String^ CreateRequestPostData(
    XmlElement^ samlMessage,
    String^ relayState
)
static member CreateRequestPostData :
        samlMessage : XmlElement *
        relayState : string -> string

Parameters

samlMessage
Type: System.XmlXmlElement
The SAML request.
relayState
Type: SystemString
The relay state or null if none.

Return Value

Type: String
The HTTP POST data.
See Also

Reference

HTTPPostBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.CreateResponsePostData Method

HTTPPostBindingCreateResponsePostData Method

Creates HTTP POST data from the SAML response and optional relay state.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string CreateResponsePostData(
    XmlElement samlMessage,
    string relayState
)
Public Shared Function CreateResponsePostData (
    samlMessage As XmlElement,
    relayState As String
) As String
public:
static String^ CreateResponsePostData(
    XmlElement^ samlMessage,
    String^ relayState
)
static member CreateResponsePostData :
        samlMessage : XmlElement *
        relayState : string -> string

Parameters

samlMessage
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.

Return Value

Type: String
The HTTP POST data.
See Also

Reference

HTTPPostBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.ReceiveMessage Method

HTTPPostBindingReceiveMessage Method

Overload List
Name | Description
ReceiveMessage(HttpRequest, XmlElement, String, Boolean) | Receives the SAML request or response and optional relay state data by extracting them from the posted form.
ReceiveMessage(HttpRequestBase, XmlElement, String, Boolean) | Receives the SAML request or response and optional relay state data by extracting them from the posted form.
Top
See Also

Reference

HTTPPostBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.ReceiveMessage Method (HttpRequest, XmlElement, String, Boolean)

HTTPPostBindingReceiveMessage Method (HttpRequest, XmlElement, String, Boolean)

Receives the SAML request or response and optional relay state data by extracting them from the posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveMessage(
    HttpRequest httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out bool isRequest
)
Public Shared Sub ReceiveMessage (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef isRequest As Boolean
)
public:
static void ReceiveMessage(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% isRequest
)
static member ReceiveMessage :
        httpRequest : HttpRequest *
        samlMessage : XmlElement byref *
        relayState : string byref *
        isRequest : bool byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
samlMessage
Type: System.XmlXmlElement
The returned SAML request or response.
relayState
Type: SystemString
The returned relay state or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPPostBinding Class
ReceiveMessage Overload
ComponentSpace.SAML2.Bindings Namespace
HTTPPostBindingReceiveRequest(HttpRequest, XmlElement, String)
HTTPPostBindingReceiveResponse(HttpRequest, XmlElement, String)


HTTPPostBinding.ReceiveMessage Method (HttpRequestBase, XmlElement, String, Boolean)

HTTPPostBindingReceiveMessage Method (HttpRequestBase, XmlElement, String, Boolean)

Receives the SAML request or response and optional relay state data by extracting them from the posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveMessage(
    HttpRequestBase httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out bool isRequest
)
Public Shared Sub ReceiveMessage (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef isRequest As Boolean
)
public:
static void ReceiveMessage(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% isRequest
)
static member ReceiveMessage :
        httpRequest : HttpRequestBase *
        samlMessage : XmlElement byref *
        relayState : string byref *
        isRequest : bool byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
samlMessage
Type: System.XmlXmlElement
The returned SAML request or response.
relayState
Type: SystemString
The returned relay state or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPPostBinding Class
ReceiveMessage Overload
ComponentSpace.SAML2.Bindings Namespace
HTTPPostBindingReceiveRequest(HttpRequestBase, XmlElement, String)
HTTPPostBindingReceiveResponse(HttpRequestBase, XmlElement, String)


HTTPPostBinding.ReceiveRequest Method

HTTPPostBindingReceiveRequest Method

Overload List
Name | Description
ReceiveRequest(HttpRequest, XmlElement, String) | Receives the SAML request and optional relay state data by extracting them from the posted form.
ReceiveRequest(HttpRequestBase, XmlElement, String) | Receives the SAML request and optional relay state data by extracting them from the posted form.
Top
See Also

Reference

HTTPPostBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.ReceiveRequest Method (HttpRequest, XmlElement, String)

HTTPPostBindingReceiveRequest Method (HttpRequest, XmlElement, String)

Receives the SAML request and optional relay state data by extracting them from the posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveRequest(
    HttpRequest httpRequest,
    out XmlElement samlMessage,
    out string relayState
)
Public Shared Sub ReceiveRequest (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveRequest(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState
)
static member ReceiveRequest :
        httpRequest : HttpRequest *
        samlMessage : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
samlMessage
Type: System.XmlXmlElement
The returned SAML request.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPPostBinding Class
ReceiveRequest Overload
ComponentSpace.SAML2.Bindings Namespace
HTTPPostBindingReceiveMessage(HttpRequest, XmlElement, String, Boolean)


HTTPPostBinding.ReceiveRequest Method (HttpRequestBase, XmlElement, String)

HTTPPostBindingReceiveRequest Method (HttpRequestBase, XmlElement, String)

Receives the SAML request and optional relay state data by extracting them from the posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveRequest(
    HttpRequestBase httpRequest,
    out XmlElement samlMessage,
    out string relayState
)
Public Shared Sub ReceiveRequest (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveRequest(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState
)
static member ReceiveRequest :
        httpRequest : HttpRequestBase *
        samlMessage : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
samlMessage
Type: System.XmlXmlElement
The returned SAML request.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPPostBinding Class
ReceiveRequest Overload
ComponentSpace.SAML2.Bindings Namespace
HTTPPostBindingReceiveMessage(HttpRequestBase, XmlElement, String, Boolean)


HTTPPostBinding.ReceiveResponse Method

HTTPPostBindingReceiveResponse Method

Overload List
Name | Description
ReceiveResponse(HttpRequest, XmlElement, String) | Receives the SAML response and optional relay state data by extracting them from the posted form.
ReceiveResponse(HttpRequestBase, XmlElement, String) | Receives the SAML response and optional relay state data by extracting them from the posted form.
Top
See Also

Reference

HTTPPostBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.ReceiveResponse Method (HttpRequest, XmlElement, String)

HTTPPostBindingReceiveResponse Method (HttpRequest, XmlElement, String)

Receives the SAML response and optional relay state data by extracting them from the posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveResponse(
    HttpRequest httpRequest,
    out XmlElement samlMessage,
    out string relayState
)
Public Shared Sub ReceiveResponse (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveResponse(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState
)
static member ReceiveResponse :
        httpRequest : HttpRequest *
        samlMessage : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
samlMessage
Type: System.XmlXmlElement
The returned SAML response.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPPostBinding Class
ReceiveResponse Overload
ComponentSpace.SAML2.Bindings Namespace
HTTPPostBindingReceiveMessage(HttpRequest, XmlElement, String, Boolean)


HTTPPostBinding.ReceiveResponse Method (HttpRequestBase, XmlElement, String)

HTTPPostBindingReceiveResponse Method (HttpRequestBase, XmlElement, String)

Receives the SAML response and optional relay state data by extracting them from the posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveResponse(
    HttpRequestBase httpRequest,
    out XmlElement samlMessage,
    out string relayState
)
Public Shared Sub ReceiveResponse (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveResponse(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState
)
static member ReceiveResponse :
        httpRequest : HttpRequestBase *
        samlMessage : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
samlMessage
Type: System.XmlXmlElement
The returned SAML response.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPPostBinding Class
ReceiveResponse Overload
ComponentSpace.SAML2.Bindings Namespace
HTTPPostBindingReceiveMessage(HttpRequestBase, XmlElement, String, Boolean)


HTTPPostBinding.SendRequest Method

HTTPPostBindingSendRequest Method

Overload List
Name | Description
SendRequest(Stream, String, XmlElement, String) | Sends the SAML request and optional relay state data as hidden controls in a posted form.
SendRequest(HttpResponse, String, XmlElement, String) | Sends the SAML request and optional relay state data as hidden controls in a posted form.
SendRequest(HttpResponseBase, String, XmlElement, String) | Sends the SAML request and optional relay state data as hidden controls in a posted form.
Top
See Also

Reference

HTTPPostBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.SendRequest Method (Stream, String, XmlElement, String)

HTTPPostBindingSendRequest Method (Stream, String, XmlElement, String)

Sends the SAML request and optional relay state data as hidden controls in a posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendRequest(
    Stream stream,
    string targetURL,
    XmlElement samlMessage,
    string relayState
)
Public Shared Sub SendRequest (
    stream As Stream,
    targetURL As String,
    samlMessage As XmlElement,
    relayState As String
)
public:
static void SendRequest(
    Stream^ stream,
    String^ targetURL,
    XmlElement^ samlMessage,
    String^ relayState
)
static member SendRequest :
        stream : Stream *
        targetURL : string *
        samlMessage : XmlElement *
        relayState : string -> unit

Parameters

stream
Type: System.IOStream
The stream to which the form is written.
targetURL
Type: SystemString
The target URL for the posted form.
samlMessage
Type: System.XmlXmlElement
The SAML request.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPPostBinding Class
SendRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.SendRequest Method (HttpResponse, String, XmlElement, String)

HTTPPostBindingSendRequest Method (HttpResponse, String, XmlElement, String)

Sends the SAML request and optional relay state data as hidden controls in a posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendRequest(
    HttpResponse httpResponse,
    string targetURL,
    XmlElement samlMessage,
    string relayState
)
Public Shared Sub SendRequest (
    httpResponse As HttpResponse,
    targetURL As String,
    samlMessage As XmlElement,
    relayState As String
)
public:
static void SendRequest(
    HttpResponse^ httpResponse,
    String^ targetURL,
    XmlElement^ samlMessage,
    String^ relayState
)
static member SendRequest :
        httpResponse : HttpResponse *
        targetURL : string *
        samlMessage : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will return the form to post.
targetURL
Type: SystemString
The target URL for the posted form.
samlMessage
Type: System.XmlXmlElement
The SAML request.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPPostBinding Class
SendRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.SendRequest Method (HttpResponseBase, String, XmlElement, String)

HTTPPostBindingSendRequest Method (HttpResponseBase, String, XmlElement, String)

Sends the SAML request and optional relay state data as hidden controls in a posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendRequest(
    HttpResponseBase httpResponse,
    string targetURL,
    XmlElement samlMessage,
    string relayState
)
Public Shared Sub SendRequest (
    httpResponse As HttpResponseBase,
    targetURL As String,
    samlMessage As XmlElement,
    relayState As String
)
public:
static void SendRequest(
    HttpResponseBase^ httpResponse,
    String^ targetURL,
    XmlElement^ samlMessage,
    String^ relayState
)
static member SendRequest :
        httpResponse : HttpResponseBase *
        targetURL : string *
        samlMessage : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will return the form to post.
targetURL
Type: SystemString
The target URL for the posted form.
samlMessage
Type: System.XmlXmlElement
The SAML request.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPPostBinding Class
SendRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.SendResponse Method

HTTPPostBindingSendResponse Method

Overload List
Name | Description
SendResponse(Stream, String, XmlElement, String) | Sends the SAML response and optional relay state data as hidden controls in a posted form.
SendResponse(HttpResponse, String, XmlElement, String) | Sends the SAML response and optional relay state data as hidden controls in a posted form.
SendResponse(HttpResponseBase, String, XmlElement, String) | Sends the SAML response and optional relay state data as hidden controls in a posted form.
Top
See Also

Reference

HTTPPostBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.SendResponse Method (Stream, String, XmlElement, String)

HTTPPostBindingSendResponse Method (Stream, String, XmlElement, String)

Sends the SAML response and optional relay state data as hidden controls in a posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    Stream stream,
    string targetURL,
    XmlElement samlMessage,
    string relayState
)
Public Shared Sub SendResponse (
    stream As Stream,
    targetURL As String,
    samlMessage As XmlElement,
    relayState As String
)
public:
static void SendResponse(
    Stream^ stream,
    String^ targetURL,
    XmlElement^ samlMessage,
    String^ relayState
)
static member SendResponse :
        stream : Stream *
        targetURL : string *
        samlMessage : XmlElement *
        relayState : string -> unit

Parameters

stream
Type: System.IOStream
The stream to which the form is written.
targetURL
Type: SystemString
The target URL for the posted form.
samlMessage
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPPostBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.SendResponse Method (HttpResponse, String, XmlElement, String)

HTTPPostBindingSendResponse Method (HttpResponse, String, XmlElement, String)

Sends the SAML response and optional relay state data as hidden controls in a posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    HttpResponse httpResponse,
    string targetURL,
    XmlElement samlMessage,
    string relayState
)
Public Shared Sub SendResponse (
    httpResponse As HttpResponse,
    targetURL As String,
    samlMessage As XmlElement,
    relayState As String
)
public:
static void SendResponse(
    HttpResponse^ httpResponse,
    String^ targetURL,
    XmlElement^ samlMessage,
    String^ relayState
)
static member SendResponse :
        httpResponse : HttpResponse *
        targetURL : string *
        samlMessage : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will return the form to post.
targetURL
Type: SystemString
The target URL for the posted form.
samlMessage
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPPostBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPPostBinding.SendResponse Method (HttpResponseBase, String, XmlElement, String)

HTTPPostBindingSendResponse Method (HttpResponseBase, String, XmlElement, String)

Sends the SAML response and optional relay state data as hidden controls in a posted form.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    HttpResponseBase httpResponse,
    string targetURL,
    XmlElement samlMessage,
    string relayState
)
Public Shared Sub SendResponse (
    httpResponse As HttpResponseBase,
    targetURL As String,
    samlMessage As XmlElement,
    relayState As String
)
public:
static void SendResponse(
    HttpResponseBase^ httpResponse,
    String^ targetURL,
    XmlElement^ samlMessage,
    String^ relayState
)
static member SendResponse :
        httpResponse : HttpResponseBase *
        targetURL : string *
        samlMessage : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will return the form to post.
targetURL
Type: SystemString
The target URL for the posted form.
samlMessage
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPPostBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding Class

Supports the HTTP redirect binding.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsHTTPRedirectBinding

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class HTTPRedirectBinding
Public NotInheritable Class HTTPRedirectBinding
public ref class HTTPRedirectBinding abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HTTPRedirectBinding =  class end

The HTTPRedirectBinding type exposes the following members.

Methods
Name | Description
CreateRequestRedirectURL(String, XmlElement, String, AsymmetricAlgorithm) | Creates the redirect URL containing the SAML request and optional relay state and generated signature query string parameters.
CreateRequestRedirectURL(String, XmlElement, String, AsymmetricAlgorithm, String) | Creates the redirect URL containing the SAML request and optional relay state and generated signature query string parameters.
CreateResponseRedirectURL(String, XmlElement, String, AsymmetricAlgorithm) | Creates the redirect URL containing the SAML response and optional relay state and generated signature query string parameters.
CreateResponseRedirectURL(String, XmlElement, String, AsymmetricAlgorithm, String) | Creates the redirect URL containing the SAML response and optional relay state and generated signature query string parameters.
GetMessageFromRedirectURL | Extracts the SAML request or response and optional relay state from the redirect URL's query string.
GetRequestFromRedirectURL | Extracts the SAML request and optional relay state from the redirect URL's query string.
GetResponseFromRedirectURL | Extracts the SAML response and optional relay state from the redirect URL's query string.
ReceiveMessage(HttpRequest, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveMessage(HttpRequest, XmlElement, String, String, String, Boolean) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveMessage(HttpRequestBase, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveMessage(HttpRequestBase, XmlElement, String, String, String, Boolean) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequest, XmlElement, String, String, String) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequestBase, XmlElement, String, String, String) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML response and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequest, XmlElement, String, String, String) | Receives the SAML response and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML response and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequestBase, XmlElement, String, String, String) | Receives the SAML response and optional relay state by extracting them from the query string.
SendRequest(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendRequest(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendRequest(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendRequest(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
VerifyRequestSignature(String, String, String, AsymmetricAlgorithm) | Verifies the request signature.
VerifyRequestSignature(HttpRequest, String, String, AsymmetricAlgorithm) | Verifies the request signature.
VerifyRequestSignature(HttpRequestBase, String, String, AsymmetricAlgorithm) | Verifies the request signature.
VerifyResponseSignature(String, String, String, AsymmetricAlgorithm) | Verifies the response signature.
VerifyResponseSignature(HttpRequest, String, String, AsymmetricAlgorithm) | Verifies the response signature.
VerifyResponseSignature(HttpRequestBase, String, String, AsymmetricAlgorithm) | Verifies the response signature.
Top
Remarks
Refer to the Bindings for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace
ComponentSpace.SAML2SAMLIdentifiersBindingURIs


HTTPRedirectBinding Methods

The HTTPRedirectBinding type exposes the following members.

Methods
Name | Description
CreateRequestRedirectURL(String, XmlElement, String, AsymmetricAlgorithm) | Creates the redirect URL containing the SAML request and optional relay state and generated signature query string parameters.
CreateRequestRedirectURL(String, XmlElement, String, AsymmetricAlgorithm, String) | Creates the redirect URL containing the SAML request and optional relay state and generated signature query string parameters.
CreateResponseRedirectURL(String, XmlElement, String, AsymmetricAlgorithm) | Creates the redirect URL containing the SAML response and optional relay state and generated signature query string parameters.
CreateResponseRedirectURL(String, XmlElement, String, AsymmetricAlgorithm, String) | Creates the redirect URL containing the SAML response and optional relay state and generated signature query string parameters.
GetMessageFromRedirectURL | Extracts the SAML request or response and optional relay state from the redirect URL's query string.
GetRequestFromRedirectURL | Extracts the SAML request and optional relay state from the redirect URL's query string.
GetResponseFromRedirectURL | Extracts the SAML response and optional relay state from the redirect URL's query string.
ReceiveMessage(HttpRequest, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveMessage(HttpRequest, XmlElement, String, String, String, Boolean) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveMessage(HttpRequestBase, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveMessage(HttpRequestBase, XmlElement, String, String, String, Boolean) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequest, XmlElement, String, String, String) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequestBase, XmlElement, String, String, String) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML response and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequest, XmlElement, String, String, String) | Receives the SAML response and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML response and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequestBase, XmlElement, String, String, String) | Receives the SAML response and optional relay state by extracting them from the query string.
SendRequest(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendRequest(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendRequest(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendRequest(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
VerifyRequestSignature(String, String, String, AsymmetricAlgorithm) | Verifies the request signature.
VerifyRequestSignature(HttpRequest, String, String, AsymmetricAlgorithm) | Verifies the request signature.
VerifyRequestSignature(HttpRequestBase, String, String, AsymmetricAlgorithm) | Verifies the request signature.
VerifyResponseSignature(String, String, String, AsymmetricAlgorithm) | Verifies the response signature.
VerifyResponseSignature(HttpRequest, String, String, AsymmetricAlgorithm) | Verifies the response signature.
VerifyResponseSignature(HttpRequestBase, String, String, AsymmetricAlgorithm) | Verifies the response signature.
Top
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.CreateRequestRedirectURL Method

HTTPRedirectBindingCreateRequestRedirectURL Method

Overload List
Name | Description
CreateRequestRedirectURL(String, XmlElement, String, AsymmetricAlgorithm) | Creates the redirect URL containing the SAML request and optional relay state and generated signature query string parameters.
CreateRequestRedirectURL(String, XmlElement, String, AsymmetricAlgorithm, String) | Creates the redirect URL containing the SAML request and optional relay state and generated signature query string parameters.
Top
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.CreateRequestRedirectURL Method (String, XmlElement, String, AsymmetricAlgorithm)

HTTPRedirectBindingCreateRequestRedirectURL Method (String, XmlElement, String, AsymmetricAlgorithm)

Creates the redirect URL containing the SAML request and optional relay state and generated signature query string parameters.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string CreateRequestRedirectURL(
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Function CreateRequestRedirectURL (
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
) As String
public:
static String^ CreateRequestRedirectURL(
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member CreateRequestRedirectURL :
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> string

Parameters

baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.

Return Value

Type: String
The redirect URL.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the URL cannot be created.
See Also

Reference

HTTPRedirectBinding Class
CreateRequestRedirectURL Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.CreateRequestRedirectURL Method (String, XmlElement, String, AsymmetricAlgorithm, String)

HTTPRedirectBindingCreateRequestRedirectURL Method (String, XmlElement, String, AsymmetricAlgorithm, String)

Creates the redirect URL containing the SAML request and optional relay state and generated signature query string parameters.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string CreateRequestRedirectURL(
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Function CreateRequestRedirectURL (
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
) As String
public:
static String^ CreateRequestRedirectURL(
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member CreateRequestRedirectURL :
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> string

Parameters

baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.

Return Value

Type: String
The redirect URL.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the URL cannot be created.
See Also

Reference

HTTPRedirectBinding Class
CreateRequestRedirectURL Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.CreateResponseRedirectURL Method

HTTPRedirectBindingCreateResponseRedirectURL Method

Overload List
Name | Description
CreateResponseRedirectURL(String, XmlElement, String, AsymmetricAlgorithm) | Creates the redirect URL containing the SAML response and optional relay state and generated signature query string parameters.
CreateResponseRedirectURL(String, XmlElement, String, AsymmetricAlgorithm, String) | Creates the redirect URL containing the SAML response and optional relay state and generated signature query string parameters.
Top
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.CreateResponseRedirectURL Method (String, XmlElement, String, AsymmetricAlgorithm)

HTTPRedirectBindingCreateResponseRedirectURL Method (String, XmlElement, String, AsymmetricAlgorithm)

Creates the redirect URL containing the SAML response and optional relay state and generated signature query string parameters.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string CreateResponseRedirectURL(
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Function CreateResponseRedirectURL (
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
) As String
public:
static String^ CreateResponseRedirectURL(
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member CreateResponseRedirectURL :
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> string

Parameters

baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.

Return Value

Type: String
The redirect URL.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the URL cannot be created.
See Also

Reference

HTTPRedirectBinding Class
CreateResponseRedirectURL Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.CreateResponseRedirectURL Method (String, XmlElement, String, AsymmetricAlgorithm, String)

HTTPRedirectBindingCreateResponseRedirectURL Method (String, XmlElement, String, AsymmetricAlgorithm, String)

Creates the redirect URL containing the SAML response and optional relay state and generated signature query string parameters.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string CreateResponseRedirectURL(
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Function CreateResponseRedirectURL (
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
) As String
public:
static String^ CreateResponseRedirectURL(
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member CreateResponseRedirectURL :
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> string

Parameters

baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.

Return Value

Type: String
The redirect URL.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the URL cannot be created.
See Also

Reference

HTTPRedirectBinding Class
CreateResponseRedirectURL Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.GetMessageFromRedirectURL Method

HTTPRedirectBindingGetMessageFromRedirectURL Method

Extracts the SAML request or response and optional relay state from the redirect URL's query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void GetMessageFromRedirectURL(
    string redirectURL,
    out XmlElement samlMessage,
    out string relayState,
    out bool isRequest,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub GetMessageFromRedirectURL (
    redirectURL As String,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef isRequest As Boolean,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void GetMessageFromRedirectURL(
    String^ redirectURL,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% isRequest,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member GetMessageFromRedirectURL :
        redirectURL : string *
        samlMessage : XmlElement byref *
        relayState : string byref *
        isRequest : bool byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

redirectURL
Type: SystemString
The HTTP redirect URL including the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML request or response.
relayState
Type: SystemString
The returned relay state or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the message and relay state cannot be extracted from the redirect URL.
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
If a key is supplied and the message is signed then the signature is verified.
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.GetRequestFromRedirectURL Method

HTTPRedirectBindingGetRequestFromRedirectURL Method

Extracts the SAML request and optional relay state from the redirect URL's query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void GetRequestFromRedirectURL(
    string redirectURL,
    out XmlElement samlMessage,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub GetRequestFromRedirectURL (
    redirectURL As String,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void GetRequestFromRedirectURL(
    String^ redirectURL,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member GetRequestFromRedirectURL :
        redirectURL : string *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

redirectURL
Type: SystemString
The HTTP redirect URL including the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML request.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML request is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the message and relay state cannot be extracted from the redirect URL.
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
If a key is supplied and the message is signed then the signature is verified.
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.GetResponseFromRedirectURL Method

HTTPRedirectBindingGetResponseFromRedirectURL Method

Extracts the SAML response and optional relay state from the redirect URL's query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void GetResponseFromRedirectURL(
    string redirectURL,
    out XmlElement samlMessage,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub GetResponseFromRedirectURL (
    redirectURL As String,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void GetResponseFromRedirectURL(
    String^ redirectURL,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member GetResponseFromRedirectURL :
        redirectURL : string *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

redirectURL
Type: SystemString
The HTTP redirect URL including the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML response.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML response is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the message and relay state cannot be extracted from the redirect URL.
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
If a key is supplied and the message is signed then the signature is verified.
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveMessage Method

HTTPRedirectBindingReceiveMessage Method

Overload List
Name | Description
ReceiveMessage(HttpRequest, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveMessage(HttpRequest, XmlElement, String, String, String, Boolean) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveMessage(HttpRequestBase, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the SAML request or response and optional relay state by extracting them from the query string.
ReceiveMessage(HttpRequestBase, XmlElement, String, String, String, Boolean) | Receives the SAML request or response and optional relay state by extracting them from the query string.
Top
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveMessage Method (HttpRequest, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm)

HTTPRedirectBindingReceiveMessage Method (HttpRequest, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm)

Receives the SAML request or response and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveMessage(
    HttpRequest httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out bool isRequest,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveMessage (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef isRequest As Boolean,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveMessage(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% isRequest,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveMessage :
        httpRequest : HttpRequest *
        samlMessage : XmlElement byref *
        relayState : string byref *
        isRequest : bool byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML request or response.
relayState
Type: SystemString
The returned relay state or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
If a key is supplied and the message is signed then the signature is verified.
See Also

Reference

HTTPRedirectBinding Class
ReceiveMessage Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveMessage Method (HttpRequest, XmlElement, String, String, String, Boolean)

HTTPRedirectBindingReceiveMessage Method (HttpRequest, XmlElement, String, String, String, Boolean)

Receives the SAML request or response and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveMessage(
    HttpRequest httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out string signatureAlgorithm,
    out string signature,
    out bool isRequest
)
Public Shared Sub ReceiveMessage (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signatureAlgorithm As String,
    <OutAttribute> ByRef signature As String,
    <OutAttribute> ByRef isRequest As Boolean
)
public:
static void ReceiveMessage(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] String^% signatureAlgorithm,
    [OutAttribute] String^% signature,
    [OutAttribute] bool% isRequest
)
static member ReceiveMessage :
        httpRequest : HttpRequest *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signatureAlgorithm : string byref *
        signature : string byref *
        isRequest : bool byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML request or response.
relayState
Type: SystemString
The returned relay state or null if none.
signatureAlgorithm
Type: SystemString
The returned signature algorithm or null if none.
signature
Type: SystemString
The returned signature or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPRedirectBinding Class
ReceiveMessage Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveMessage Method (HttpRequestBase, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm)

HTTPRedirectBindingReceiveMessage Method (HttpRequestBase, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm)

Receives the SAML request or response and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveMessage(
    HttpRequestBase httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out bool isRequest,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveMessage (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef isRequest As Boolean,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveMessage(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% isRequest,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveMessage :
        httpRequest : HttpRequestBase *
        samlMessage : XmlElement byref *
        relayState : string byref *
        isRequest : bool byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML request or response.
relayState
Type: SystemString
The returned relay state or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
If a key is supplied and the message is signed then the signature is verified.
See Also

Reference

HTTPRedirectBinding Class
ReceiveMessage Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveMessage Method (HttpRequestBase, XmlElement, String, String, String, Boolean)

HTTPRedirectBindingReceiveMessage Method (HttpRequestBase, XmlElement, String, String, String, Boolean)

Receives the SAML request or response and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveMessage(
    HttpRequestBase httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out string signatureAlgorithm,
    out string signature,
    out bool isRequest
)
Public Shared Sub ReceiveMessage (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signatureAlgorithm As String,
    <OutAttribute> ByRef signature As String,
    <OutAttribute> ByRef isRequest As Boolean
)
public:
static void ReceiveMessage(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] String^% signatureAlgorithm,
    [OutAttribute] String^% signature,
    [OutAttribute] bool% isRequest
)
static member ReceiveMessage :
        httpRequest : HttpRequestBase *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signatureAlgorithm : string byref *
        signature : string byref *
        isRequest : bool byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML request or response.
relayState
Type: SystemString
The returned relay state or null if none.
signatureAlgorithm
Type: SystemString
The returned signature algorithm or null if none.
signature
Type: SystemString
The returned signature or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPRedirectBinding Class
ReceiveMessage Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveRequest Method

HTTPRedirectBindingReceiveRequest Method

Overload List
Name | Description
ReceiveRequest(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequest, XmlElement, String, String, String) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML request and optional relay state by extracting them from the query string.
ReceiveRequest(HttpRequestBase, XmlElement, String, String, String) | Receives the SAML request and optional relay state by extracting them from the query string.
Top
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveRequest Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

HTTPRedirectBindingReceiveRequest Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the SAML request and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveRequest(
    HttpRequest httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveRequest (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveRequest(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveRequest :
        httpRequest : HttpRequest *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML request.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML request is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
If a key is supplied and the message is signed then the signature is verified.
See Also

Reference

HTTPRedirectBinding Class
ReceiveRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveRequest Method (HttpRequest, XmlElement, String, String, String)

HTTPRedirectBindingReceiveRequest Method (HttpRequest, XmlElement, String, String, String)

Receives the SAML request and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveRequest(
    HttpRequest httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out string signatureAlgorithm,
    out string signature
)
Public Shared Sub ReceiveRequest (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signatureAlgorithm As String,
    <OutAttribute> ByRef signature As String
)
public:
static void ReceiveRequest(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] String^% signatureAlgorithm,
    [OutAttribute] String^% signature
)
static member ReceiveRequest :
        httpRequest : HttpRequest *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signatureAlgorithm : string byref *
        signature : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML request.
relayState
Type: SystemString
The returned relay state or null if none.
signatureAlgorithm
Type: SystemString
The returned signature algorithm or null if none.
signature
Type: SystemString
The returned signature or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPRedirectBinding Class
ReceiveRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveRequest Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

HTTPRedirectBindingReceiveRequest Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the SAML request and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveRequest(
    HttpRequestBase httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveRequest (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveRequest(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveRequest :
        httpRequest : HttpRequestBase *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML request.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML request is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
If a key is supplied and the message is signed then the signature is verified.
See Also

Reference

HTTPRedirectBinding Class
ReceiveRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveRequest Method (HttpRequestBase, XmlElement, String, String, String)

HTTPRedirectBindingReceiveRequest Method (HttpRequestBase, XmlElement, String, String, String)

Receives the SAML request and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveRequest(
    HttpRequestBase httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out string signatureAlgorithm,
    out string signature
)
Public Shared Sub ReceiveRequest (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signatureAlgorithm As String,
    <OutAttribute> ByRef signature As String
)
public:
static void ReceiveRequest(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] String^% signatureAlgorithm,
    [OutAttribute] String^% signature
)
static member ReceiveRequest :
        httpRequest : HttpRequestBase *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signatureAlgorithm : string byref *
        signature : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML request.
relayState
Type: SystemString
The returned relay state or null if none.
signatureAlgorithm
Type: SystemString
The returned signature algorithm or null if none.
signature
Type: SystemString
The returned signature or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPRedirectBinding Class
ReceiveRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveResponse Method

HTTPRedirectBindingReceiveResponse Method

Overload List
Name | Description
ReceiveResponse(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML response and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequest, XmlElement, String, String, String) | Receives the SAML response and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the SAML response and optional relay state by extracting them from the query string.
ReceiveResponse(HttpRequestBase, XmlElement, String, String, String) | Receives the SAML response and optional relay state by extracting them from the query string.
Top
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveResponse Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

HTTPRedirectBindingReceiveResponse Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the SAML response and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveResponse(
    HttpRequest httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveResponse (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveResponse(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveResponse :
        httpRequest : HttpRequest *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML response.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML response is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
If a key is supplied and the message is signed then the signature is verified.
See Also

Reference

HTTPRedirectBinding Class
ReceiveResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveResponse Method (HttpRequest, XmlElement, String, String, String)

HTTPRedirectBindingReceiveResponse Method (HttpRequest, XmlElement, String, String, String)

Receives the SAML response and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveResponse(
    HttpRequest httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out string signatureAlgorithm,
    out string signature
)
Public Shared Sub ReceiveResponse (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signatureAlgorithm As String,
    <OutAttribute> ByRef signature As String
)
public:
static void ReceiveResponse(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] String^% signatureAlgorithm,
    [OutAttribute] String^% signature
)
static member ReceiveResponse :
        httpRequest : HttpRequest *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signatureAlgorithm : string byref *
        signature : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML response.
relayState
Type: SystemString
The returned relay state or null if none.
signatureAlgorithm
Type: SystemString
The returned signature algorithm or null if none.
signature
Type: SystemString
The returned signature or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPRedirectBinding Class
ReceiveResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveResponse Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

HTTPRedirectBindingReceiveResponse Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the SAML response and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveResponse(
    HttpRequestBase httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveResponse (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveResponse(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveResponse :
        httpRequest : HttpRequestBase *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML response.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML response is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
If a key is supplied and the message is signed then the signature is verified.
See Also

Reference

HTTPRedirectBinding Class
ReceiveResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.ReceiveResponse Method (HttpRequestBase, XmlElement, String, String, String)

HTTPRedirectBindingReceiveResponse Method (HttpRequestBase, XmlElement, String, String, String)

Receives the SAML response and optional relay state by extracting them from the query string.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveResponse(
    HttpRequestBase httpRequest,
    out XmlElement samlMessage,
    out string relayState,
    out string signatureAlgorithm,
    out string signature
)
Public Shared Sub ReceiveResponse (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef samlMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signatureAlgorithm As String,
    <OutAttribute> ByRef signature As String
)
public:
static void ReceiveResponse(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% samlMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] String^% signatureAlgorithm,
    [OutAttribute] String^% signature
)
static member ReceiveResponse :
        httpRequest : HttpRequestBase *
        samlMessage : XmlElement byref *
        relayState : string byref *
        signatureAlgorithm : string byref *
        signature : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
samlMessage
Type: System.XmlXmlElement
The returned SAML response.
relayState
Type: SystemString
The returned relay state or null if none.
signatureAlgorithm
Type: SystemString
The returned signature algorithm or null if none.
signature
Type: SystemString
The returned signature or null if none.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

HTTPRedirectBinding Class
ReceiveResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.SendRequest Method

HTTPRedirectBindingSendRequest Method

Overload List
Name | Description
SendRequest(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendRequest(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendRequest(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendRequest(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.
Top
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.SendRequest Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm)

HTTPRedirectBindingSendRequest Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm)

Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendRequest(
    HttpResponse httpResponse,
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Sub SendRequest (
    httpResponse As HttpResponse,
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
)
public:
static void SendRequest(
    HttpResponse^ httpResponse,
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member SendRequest :
        httpResponse : HttpResponse *
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPRedirectBinding Class
SendRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.SendRequest Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm)

HTTPRedirectBindingSendRequest Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm)

Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendRequest(
    HttpResponseBase httpResponse,
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Sub SendRequest (
    httpResponse As HttpResponseBase,
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
)
public:
static void SendRequest(
    HttpResponseBase^ httpResponse,
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member SendRequest :
        httpResponse : HttpResponseBase *
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPRedirectBinding Class
SendRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.SendRequest Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String)

HTTPRedirectBindingSendRequest Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String)

Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendRequest(
    HttpResponse httpResponse,
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Sub SendRequest (
    httpResponse As HttpResponse,
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
static void SendRequest(
    HttpResponse^ httpResponse,
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member SendRequest :
        httpResponse : HttpResponse *
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPRedirectBinding Class
SendRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.SendRequest Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String)

HTTPRedirectBindingSendRequest Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String)

Sends the SAML request and optional relay state and generated signature as query string parameters in an HTTP redirect.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendRequest(
    HttpResponseBase httpResponse,
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Sub SendRequest (
    httpResponse As HttpResponseBase,
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
static void SendRequest(
    HttpResponseBase^ httpResponse,
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member SendRequest :
        httpResponse : HttpResponseBase *
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPRedirectBinding Class
SendRequest Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.SendResponse Method

HTTPRedirectBindingSendResponse Method

Overload List
Name | Description
SendResponse(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
SendResponse(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.
Top
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.SendResponse Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm)

HTTPRedirectBindingSendResponse Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm)

Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    HttpResponse httpResponse,
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Sub SendResponse (
    httpResponse As HttpResponse,
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
)
public:
static void SendResponse(
    HttpResponse^ httpResponse,
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member SendResponse :
        httpResponse : HttpResponse *
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPRedirectBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.SendResponse Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm)

HTTPRedirectBindingSendResponse Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm)

Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    HttpResponseBase httpResponse,
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Sub SendResponse (
    httpResponse As HttpResponseBase,
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
)
public:
static void SendResponse(
    HttpResponseBase^ httpResponse,
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member SendResponse :
        httpResponse : HttpResponseBase *
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPRedirectBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.SendResponse Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String)

HTTPRedirectBindingSendResponse Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String)

Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    HttpResponse httpResponse,
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Sub SendResponse (
    httpResponse As HttpResponse,
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
static void SendResponse(
    HttpResponse^ httpResponse,
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member SendResponse :
        httpResponse : HttpResponse *
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPRedirectBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.SendResponse Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String)

HTTPRedirectBindingSendResponse Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String)

Sends the SAML response and optional relay state and generated signature as query string parameters in an HTTP redirect.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    HttpResponseBase httpResponse,
    string baseURL,
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Sub SendResponse (
    httpResponse As HttpResponseBase,
    baseURL As String,
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
static void SendResponse(
    HttpResponseBase^ httpResponse,
    String^ baseURL,
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member SendResponse :
        httpResponse : HttpResponseBase *
        baseURL : string *
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
baseURL
Type: SystemString
The base URL to which the query string parameters are appended.
samlMessage
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

HTTPRedirectBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.VerifyRequestSignature Method

HTTPRedirectBindingVerifyRequestSignature Method

Overload List
Name | Description
VerifyRequestSignature(String, String, String, AsymmetricAlgorithm) | Verifies the request signature.
VerifyRequestSignature(HttpRequest, String, String, AsymmetricAlgorithm) | Verifies the request signature.
VerifyRequestSignature(HttpRequestBase, String, String, AsymmetricAlgorithm) | Verifies the request signature.
Top
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.VerifyRequestSignature Method (String, String, String, AsymmetricAlgorithm)

HTTPRedirectBindingVerifyRequestSignature Method (String, String, String, AsymmetricAlgorithm)

Verifies the request signature.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void VerifyRequestSignature(
    string redirectURL,
    string signatureAlgorithm,
    string signature,
    AsymmetricAlgorithm key
)
Public Shared Sub VerifyRequestSignature (
    redirectURL As String,
    signatureAlgorithm As String,
    signature As String,
    key As AsymmetricAlgorithm
)
public:
static void VerifyRequestSignature(
    String^ redirectURL,
    String^ signatureAlgorithm,
    String^ signature,
    AsymmetricAlgorithm^ key
)
static member VerifyRequestSignature :
        redirectURL : string *
        signatureAlgorithm : string *
        signature : string *
        key : AsymmetricAlgorithm -> unit

Parameters

redirectURL
Type: SystemString
The HTTP redirect URL including the query string.
signatureAlgorithm
Type: SystemString
The signature algorithm.
signature
Type: SystemString
The encoded signature.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The signature key.
Exceptions
Exception | Condition
SAMLBindingException | Thrown if the signature is invalid.
See Also

Reference

HTTPRedirectBinding Class
VerifyRequestSignature Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.VerifyRequestSignature Method (HttpRequest, String, String, AsymmetricAlgorithm)

HTTPRedirectBindingVerifyRequestSignature Method (HttpRequest, String, String, AsymmetricAlgorithm)

Verifies the request signature.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void VerifyRequestSignature(
    HttpRequest httpRequest,
    string signatureAlgorithm,
    string signature,
    AsymmetricAlgorithm key
)
Public Shared Sub VerifyRequestSignature (
    httpRequest As HttpRequest,
    signatureAlgorithm As String,
    signature As String,
    key As AsymmetricAlgorithm
)
public:
static void VerifyRequestSignature(
    HttpRequest^ httpRequest,
    String^ signatureAlgorithm,
    String^ signature,
    AsymmetricAlgorithm^ key
)
static member VerifyRequestSignature :
        httpRequest : HttpRequest *
        signatureAlgorithm : string *
        signature : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
signatureAlgorithm
Type: SystemString
The signature algorithm.
signature
Type: SystemString
The encoded signature.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The signature key.
Exceptions
Exception | Condition
SAMLBindingException | Thrown if the signature is invalid.
See Also

Reference

HTTPRedirectBinding Class
VerifyRequestSignature Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.VerifyRequestSignature Method (HttpRequestBase, String, String, AsymmetricAlgorithm)

HTTPRedirectBindingVerifyRequestSignature Method (HttpRequestBase, String, String, AsymmetricAlgorithm)

Verifies the request signature.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void VerifyRequestSignature(
    HttpRequestBase httpRequest,
    string signatureAlgorithm,
    string signature,
    AsymmetricAlgorithm key
)
Public Shared Sub VerifyRequestSignature (
    httpRequest As HttpRequestBase,
    signatureAlgorithm As String,
    signature As String,
    key As AsymmetricAlgorithm
)
public:
static void VerifyRequestSignature(
    HttpRequestBase^ httpRequest,
    String^ signatureAlgorithm,
    String^ signature,
    AsymmetricAlgorithm^ key
)
static member VerifyRequestSignature :
        httpRequest : HttpRequestBase *
        signatureAlgorithm : string *
        signature : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
signatureAlgorithm
Type: SystemString
The signature algorithm.
signature
Type: SystemString
The encoded signature.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The signature key.
Exceptions
Exception | Condition
SAMLBindingException | Thrown if the signature is invalid.
See Also

Reference

HTTPRedirectBinding Class
VerifyRequestSignature Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.VerifyResponseSignature Method

HTTPRedirectBindingVerifyResponseSignature Method

Overload List
Name | Description
VerifyResponseSignature(String, String, String, AsymmetricAlgorithm) | Verifies the response signature.
VerifyResponseSignature(HttpRequest, String, String, AsymmetricAlgorithm) | Verifies the response signature.
VerifyResponseSignature(HttpRequestBase, String, String, AsymmetricAlgorithm) | Verifies the response signature.
Top
See Also

Reference

HTTPRedirectBinding Class
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.VerifyResponseSignature Method (String, String, String, AsymmetricAlgorithm)

HTTPRedirectBindingVerifyResponseSignature Method (String, String, String, AsymmetricAlgorithm)

Verifies the response signature.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void VerifyResponseSignature(
    string redirectURL,
    string signatureAlgorithm,
    string signature,
    AsymmetricAlgorithm key
)
Public Shared Sub VerifyResponseSignature (
    redirectURL As String,
    signatureAlgorithm As String,
    signature As String,
    key As AsymmetricAlgorithm
)
public:
static void VerifyResponseSignature(
    String^ redirectURL,
    String^ signatureAlgorithm,
    String^ signature,
    AsymmetricAlgorithm^ key
)
static member VerifyResponseSignature :
        redirectURL : string *
        signatureAlgorithm : string *
        signature : string *
        key : AsymmetricAlgorithm -> unit

Parameters

redirectURL
Type: SystemString
The HTTP redirect URL including the query string.
signatureAlgorithm
Type: SystemString
The signature algorithm.
signature
Type: SystemString
The encoded signature.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The signature key.
Exceptions
Exception | Condition
SAMLBindingException | Thrown if the signature is invalid.
See Also

Reference

HTTPRedirectBinding Class
VerifyResponseSignature Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.VerifyResponseSignature Method (HttpRequest, String, String, AsymmetricAlgorithm)

HTTPRedirectBindingVerifyResponseSignature Method (HttpRequest, String, String, AsymmetricAlgorithm)

Verifies the response signature.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void VerifyResponseSignature(
    HttpRequest httpRequest,
    string signatureAlgorithm,
    string signature,
    AsymmetricAlgorithm key
)
Public Shared Sub VerifyResponseSignature (
    httpRequest As HttpRequest,
    signatureAlgorithm As String,
    signature As String,
    key As AsymmetricAlgorithm
)
public:
static void VerifyResponseSignature(
    HttpRequest^ httpRequest,
    String^ signatureAlgorithm,
    String^ signature,
    AsymmetricAlgorithm^ key
)
static member VerifyResponseSignature :
        httpRequest : HttpRequest *
        signatureAlgorithm : string *
        signature : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
signatureAlgorithm
Type: SystemString
The signature algorithm.
signature
Type: SystemString
The encoded signature.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The signature key.
Exceptions
Exception | Condition
SAMLBindingException | Thrown if the signature is invalid.
See Also

Reference

HTTPRedirectBinding Class
VerifyResponseSignature Overload
ComponentSpace.SAML2.Bindings Namespace


HTTPRedirectBinding.VerifyResponseSignature Method (HttpRequestBase, String, String, AsymmetricAlgorithm)

HTTPRedirectBindingVerifyResponseSignature Method (HttpRequestBase, String, String, AsymmetricAlgorithm)

Verifies the response signature.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void VerifyResponseSignature(
    HttpRequestBase httpRequest,
    string signatureAlgorithm,
    string signature,
    AsymmetricAlgorithm key
)
Public Shared Sub VerifyResponseSignature (
    httpRequest As HttpRequestBase,
    signatureAlgorithm As String,
    signature As String,
    key As AsymmetricAlgorithm
)
public:
static void VerifyResponseSignature(
    HttpRequestBase^ httpRequest,
    String^ signatureAlgorithm,
    String^ signature,
    AsymmetricAlgorithm^ key
)
static member VerifyResponseSignature :
        httpRequest : HttpRequestBase *
        signatureAlgorithm : string *
        signature : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
signatureAlgorithm
Type: SystemString
The signature algorithm.
signature
Type: SystemString
The encoded signature.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The signature key.
Exceptions
Exception | Condition
SAMLBindingException | Thrown if the signature is invalid.
See Also

Reference

HTTPRedirectBinding Class
VerifyResponseSignature Overload
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding Class

Supports the reverse SOAP (PAOS) binding.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsPAOSBinding

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class PAOSBinding
Public NotInheritable Class PAOSBinding
public ref class PAOSBinding abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PAOSBinding =  class end
Methods
Name | Description
ReceiveRequest(WebRequest) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
ReceiveRequest(String) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
ReceiveResponse(HttpRequest) | Receives a SAML response. The SAML response is extracted from the received SOAP message.
ReceiveResponse(HttpRequestBase) | Receives a SAML response. The SAML response is extracted from the received SOAP message.
SendRequest(HttpResponse, XmlElement) | Sends a SAML request. The SAML request is wrapped in a SOAP message prior to sending.
SendRequest(HttpResponseBase, XmlElement) | Sends a SAML request. The SAML request is wrapped in a SOAP message prior to sending.
SendResponse(WebRequest, XmlElement) | Sends the SAML response. The SAML response is wrapped in a SOAP message prior to sending.
SendResponse(String, XmlElement) | Sends the SAML response. The SAML response is wrapped in a SOAP message prior to sending.
Top
Remarks
Refer to the Bindings for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace
ComponentSpace.SAML2SAMLIdentifiersBindingURIs


PAOSBinding Methods

Methods
Name | Description
ReceiveRequest(WebRequest) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
ReceiveRequest(String) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
ReceiveResponse(HttpRequest) | Receives a SAML response. The SAML response is extracted from the received SOAP message.
ReceiveResponse(HttpRequestBase) | Receives a SAML response. The SAML response is extracted from the received SOAP message.
SendRequest(HttpResponse, XmlElement) | Sends a SAML request. The SAML request is wrapped in a SOAP message prior to sending.
SendRequest(HttpResponseBase, XmlElement) | Sends a SAML request. The SAML request is wrapped in a SOAP message prior to sending.
SendResponse(WebRequest, XmlElement) | Sends the SAML response. The SAML response is wrapped in a SOAP message prior to sending.
SendResponse(String, XmlElement) | Sends the SAML response. The SAML response is wrapped in a SOAP message prior to sending.
Top
See Also

Reference

PAOSBinding Class
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.ReceiveRequest Method

PAOSBindingReceiveRequest Method

Overload List
Name | Description
ReceiveRequest(WebRequest) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
ReceiveRequest(String) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
Top
See Also

Reference

PAOSBinding Class
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.ReceiveRequest Method (WebRequest)

PAOSBindingReceiveRequest Method (WebRequest)

Receives a SAML request. The SAML request is extracted from the received SOAP message.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveRequest(
    WebRequest webRequest
)
Public Shared Function ReceiveRequest (
    webRequest As WebRequest
) As XmlElement
public:
static XmlElement^ ReceiveRequest(
    WebRequest^ webRequest
)
static member ReceiveRequest :
        webRequest : WebRequest -> XmlElement

Parameters

webRequest
Type: System.NetWebRequest
The WebRequest object used to receive the request.

Return Value

Type: XmlElement
The SAML request.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
Remarks
The client can use this method to send an HTTP request and receive a SAML request from the service provider.
See Also

Reference

PAOSBinding Class
ReceiveRequest Overload
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.ReceiveRequest Method (String)

PAOSBindingReceiveRequest Method (String)

Receives a SAML request. The SAML request is extracted from the received SOAP message.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveRequest(
    string destinationURL
)
Public Shared Function ReceiveRequest (
    destinationURL As String
) As XmlElement
public:
static XmlElement^ ReceiveRequest(
    String^ destinationURL
)
static member ReceiveRequest :
        destinationURL : string -> XmlElement

Parameters

destinationURL
Type: SystemString
The destination URL.

Return Value

Type: XmlElement
The SAML request.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
Remarks
The client can use this method to send an HTTP request and receive a SAML request from the service provider.
See Also

Reference

PAOSBinding Class
ReceiveRequest Overload
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.ReceiveResponse Method

PAOSBindingReceiveResponse Method

Overload List
Name | Description
ReceiveResponse(HttpRequest) | Receives a SAML response. The SAML response is extracted from the received SOAP message.
ReceiveResponse(HttpRequestBase) | Receives a SAML response. The SAML response is extracted from the received SOAP message.
Top
See Also

Reference

PAOSBinding Class
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.ReceiveResponse Method (HttpRequest)

PAOSBindingReceiveResponse Method (HttpRequest)

Receives a SAML response. The SAML response is extracted from the received SOAP message.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveResponse(
    HttpRequest httpRequest
)
Public Shared Function ReceiveResponse (
    httpRequest As HttpRequest
) As XmlElement
public:
static XmlElement^ ReceiveResponse(
    HttpRequest^ httpRequest
)
static member ReceiveResponse :
        httpRequest : HttpRequest -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the SAML response.

Return Value

Type: XmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
Remarks
The service provider can use this method to receive a SAML response and send an HTTP response to the client.
See Also

Reference

PAOSBinding Class
ReceiveResponse Overload
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.ReceiveResponse Method (HttpRequestBase)

PAOSBindingReceiveResponse Method (HttpRequestBase)

Receives a SAML response. The SAML response is extracted from the received SOAP message.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveResponse(
    HttpRequestBase httpRequest
)
Public Shared Function ReceiveResponse (
    httpRequest As HttpRequestBase
) As XmlElement
public:
static XmlElement^ ReceiveResponse(
    HttpRequestBase^ httpRequest
)
static member ReceiveResponse :
        httpRequest : HttpRequestBase -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the SAML response.

Return Value

Type: XmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
Remarks
The service provider can use this method to receive a SAML response and send an HTTP response to the client.
See Also

Reference

PAOSBinding Class
ReceiveResponse Overload
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.SendRequest Method

PAOSBindingSendRequest Method

Overload List
Name | Description
SendRequest(HttpResponse, XmlElement) | Sends a SAML request. The SAML request is wrapped in a SOAP message prior to sending.
SendRequest(HttpResponseBase, XmlElement) | Sends a SAML request. The SAML request is wrapped in a SOAP message prior to sending.
Top
See Also

Reference

PAOSBinding Class
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.SendRequest Method (HttpResponse, XmlElement)

PAOSBindingSendRequest Method (HttpResponse, XmlElement)

Sends a SAML request. The SAML request is wrapped in a SOAP message prior to sending.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendRequest(
    HttpResponse httpResponse,
    XmlElement samlMessage
)
Public Shared Sub SendRequest (
    httpResponse As HttpResponse,
    samlMessage As XmlElement
)
public:
static void SendRequest(
    HttpResponse^ httpResponse,
    XmlElement^ samlMessage
)
static member SendRequest :
        httpResponse : HttpResponse *
        samlMessage : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will return the SAML request.
samlMessage
Type: System.XmlXmlElement
The SAML request.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
Remarks
The service provider can use this method to return a SAML request in response to the client's HTTP request.
See Also

Reference

PAOSBinding Class
SendRequest Overload
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.SendRequest Method (HttpResponseBase, XmlElement)

PAOSBindingSendRequest Method (HttpResponseBase, XmlElement)

Sends a SAML request. The SAML request is wrapped in a SOAP message prior to sending.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendRequest(
    HttpResponseBase httpResponse,
    XmlElement samlMessage
)
Public Shared Sub SendRequest (
    httpResponse As HttpResponseBase,
    samlMessage As XmlElement
)
public:
static void SendRequest(
    HttpResponseBase^ httpResponse,
    XmlElement^ samlMessage
)
static member SendRequest :
        httpResponse : HttpResponseBase *
        samlMessage : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will return the SAML request.
samlMessage
Type: System.XmlXmlElement
The SAML request.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
Remarks
The service provider can use this method to return a SAML request in response to the client's HTTP request.
See Also

Reference

PAOSBinding Class
SendRequest Overload
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.SendResponse Method

PAOSBindingSendResponse Method

Overload List
Name | Description
SendResponse(WebRequest, XmlElement) | Sends the SAML response. The SAML response is wrapped in a SOAP message prior to sending.
SendResponse(String, XmlElement) | Sends the SAML response. The SAML response is wrapped in a SOAP message prior to sending.
Top
See Also

Reference

PAOSBinding Class
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.SendResponse Method (WebRequest, XmlElement)

PAOSBindingSendResponse Method (WebRequest, XmlElement)

Sends the SAML response. The SAML response is wrapped in a SOAP message prior to sending.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    WebRequest webRequest,
    XmlElement samlMessage
)
Public Shared Sub SendResponse (
    webRequest As WebRequest,
    samlMessage As XmlElement
)
public:
static void SendResponse(
    WebRequest^ webRequest,
    XmlElement^ samlMessage
)
static member SendResponse :
        webRequest : WebRequest *
        samlMessage : XmlElement -> unit

Parameters

webRequest
Type: System.NetWebRequest
The WebRequest object used to send the response.
samlMessage
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
Remarks
The client can use this method to send a SAML response and receive an HTTP response from the service provider.
See Also

Reference

PAOSBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


PAOSBinding.SendResponse Method (String, XmlElement)

PAOSBindingSendResponse Method (String, XmlElement)

Sends the SAML response. The SAML response is wrapped in a SOAP message prior to sending.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    string destinationURL,
    XmlElement samlMessage
)
Public Shared Sub SendResponse (
    destinationURL As String,
    samlMessage As XmlElement
)
public:
static void SendResponse(
    String^ destinationURL,
    XmlElement^ samlMessage
)
static member SendResponse :
        destinationURL : string *
        samlMessage : XmlElement -> unit

Parameters

destinationURL
Type: SystemString
The destination URL.
samlMessage
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
Remarks
The client can use this method to send a SAML response and receive an HTTP response from the service provider.
See Also

Reference

PAOSBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


RelayState Class

Provides storage for state information used during SSO.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsRelayState

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class RelayState
Public Class RelayState
public ref class RelayState
type RelayState =  class end

The RelayState type exposes the following members.

Constructors
 | Name | Description
Public method | RelayState | Initializes a new instance of the RelayState class.
Public method | RelayState(String, Object) | Initializes a new instance of the RelayState class.
Top
Properties
 | Name | Description
Public property | AdditionalState | Gets or sets the additional state information.
Public property | ResourceURL | Gets or sets the resource URL.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace


RelayState Constructor

Overload List
 | Name | Description
Public method | RelayState | Initializes a new instance of the RelayState class.
Public method | RelayState(String, Object) | Initializes a new instance of the RelayState class.
Top
See Also

Reference

RelayState Class
ComponentSpace.SAML2.Bindings Namespace


RelayState Constructor

Initializes a new instance of the RelayState class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RelayState()
Public Sub New
public:
RelayState()
new : unit -> RelayState
See Also

Reference

RelayState Class
RelayState Overload
ComponentSpace.SAML2.Bindings Namespace


RelayState Constructor (String, Object)

Initializes a new instance of the RelayState class.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RelayState(
    string resourceURL,
    Object additionalState
)
Public Sub New (
    resourceURL As String,
    additionalState As Object
)
public:
RelayState(
    String^ resourceURL,
    Object^ additionalState
)
new :
        resourceURL : string *
        additionalState : Object -> RelayState

Parameters

resourceURL
Type: SystemString
The resource URL.
additionalState
Type: SystemObject
Additional state information or null if none.
See Also

Reference

RelayState Class
RelayState Overload
ComponentSpace.SAML2.Bindings Namespace


RelayState Properties

The RelayState type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalState | Gets or sets the additional state information.
Public property | ResourceURL | Gets or sets the resource URL.
Top
See Also

Reference

RelayState Class
ComponentSpace.SAML2.Bindings Namespace


RelayState.AdditionalState Property

RelayStateAdditionalState Property

Gets or sets the additional state information.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Object AdditionalState { get; set; }
Public Property AdditionalState As Object
    Get
    Set
public:
property Object^ AdditionalState {
    Object^ get ();
    void set (Object^ value);
}
member AdditionalState : Object with get, set

Property Value

Type: Object
The additional state information or null if none.
See Also

Reference

RelayState Class
ComponentSpace.SAML2.Bindings Namespace


RelayState.ResourceURL Property

RelayStateResourceURL Property

Gets or sets the resource URL.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ResourceURL { get; set; }
Public Property ResourceURL As String
    Get
    Set
public:
property String^ ResourceURL {
    String^ get ();
    void set (String^ value);
}
member ResourceURL : string with get, set

Property Value

Type: String
The resource URL.
See Also

Reference

RelayState Class
ComponentSpace.SAML2.Bindings Namespace


RelayState Methods

The RelayState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RelayState Class
ComponentSpace.SAML2.Bindings Namespace


RelayStateCache Class

Provides a cache for storing RelayState.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsRelayStateCache

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class RelayStateCache
Public NotInheritable Class RelayStateCache
public ref class RelayStateCache abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RelayStateCache =  class end

The RelayStateCache type exposes the following members.

Properties
Name | Description
Expiration | Gets or sets the expiration time span for cached relay state entries.
Top
Methods
Name | Description
Add | Adds an entry to the cache and returns the key to this entry.
Get | Gets an entry from the cache.
Remove | Removes an entry from the cache.
Top
Remarks
The cache is implemented using the System.Web.Caching.Cache. Use of this cache is entirely optional. Refer to the System.Web.Caching.Cache documentation for usage restrictions.
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace


RelayStateCache Properties

The RelayStateCache type exposes the following members.

Properties
Name | Description
Expiration | Gets or sets the expiration time span for cached relay state entries.
Top
See Also

Reference

RelayStateCache Class
ComponentSpace.SAML2.Bindings Namespace


RelayStateCache.Expiration Property

RelayStateCacheExpiration Property

Gets or sets the expiration time span for cached relay state entries.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static TimeSpan Expiration { get; set; }
Public Shared Property Expiration As TimeSpan
    Get
    Set
public:
static property TimeSpan Expiration {
    TimeSpan get ();
    void set (TimeSpan value);
}
static member Expiration : TimeSpan with get, set

Property Value

Type: TimeSpan
The expiration time span for cached relay state entries.
See Also

Reference

RelayStateCache Class
ComponentSpace.SAML2.Bindings Namespace


RelayStateCache Methods

The RelayStateCache type exposes the following members.

Methods
Name | Description
Add | Adds an entry to the cache and returns the key to this entry.
Get | Gets an entry from the cache.
Remove | Removes an entry from the cache.
Top
See Also

Reference

RelayStateCache Class
ComponentSpace.SAML2.Bindings Namespace


RelayStateCache.Add Method

RelayStateCacheAdd Method

Adds an entry to the cache and returns the key to this entry.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string Add(
    RelayState relayState
)
Public Shared Function Add (
    relayState As RelayState
) As String
public:
static String^ Add(
    RelayState^ relayState
)
static member Add :
        relayState : RelayState -> string

Parameters

relayState
Type: ComponentSpace.SAML2.BindingsRelayState
The item to cache.

Return Value

Type: String
The key to this entry in the cache.
See Also

Reference

RelayStateCache Class
ComponentSpace.SAML2.Bindings Namespace


RelayStateCache.Get Method

RelayStateCacheGet Method

Gets an entry from the cache.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static RelayState Get(
    string key
)
Public Shared Function Get (
    key As String
) As RelayState
public:
static RelayState^ Get(
    String^ key
)
static member Get :
        key : string -> RelayState

Parameters

key
Type: SystemString
The key to the cache item to remove.

Return Value

Type: RelayState
The cached item or null if none.
See Also

Reference

RelayStateCache Class
ComponentSpace.SAML2.Bindings Namespace


RelayStateCache.Remove Method

RelayStateCacheRemove Method

Removes an entry from the cache.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static RelayState Remove(
    string key
)
Public Shared Function Remove (
    key As String
) As RelayState
public:
static RelayState^ Remove(
    String^ key
)
static member Remove :
        key : string -> RelayState

Parameters

key
Type: SystemString
The key to the cache item to remove.

Return Value

Type: RelayState
The item removed from the cache or null if none.
See Also

Reference

RelayStateCache Class
ComponentSpace.SAML2.Bindings Namespace


SOAPBinding Class

Supports the SOAP binding.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsSOAPBinding

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SOAPBinding
Public NotInheritable Class SOAPBinding
public ref class SOAPBinding abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SOAPBinding =  class end
Methods
Name | Description
ReceiveRequest(HttpRequest) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
ReceiveRequest(HttpRequestBase) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
SendRequestReceiveResponse(WebRequest, XmlElement) | Sends a SAML request and receives a SAML response. The SAML request is wrapped in a SOAP message prior to sending. The SAML response is extracted from the received SOAP message.
SendRequestReceiveResponse(String, XmlElement) | Sends a SAML request and receives a SAML response. The SAML request is wrapped in a SOAP message prior to sending. The SAML response is extracted from the received SOAP message.
SendResponse(HttpResponse, XmlElement) | Sends a SAML response. The SAML response is wrapped in a SOAP message prior to sending.
SendResponse(HttpResponseBase, XmlElement) | Sends a SAML response. The SAML response is wrapped in a SOAP message prior to sending.
Top
Remarks
Refer to the Bindings for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace
ComponentSpace.SAML2SAMLIdentifiersBindingURIs


SOAPBinding Methods

Methods
Name | Description
ReceiveRequest(HttpRequest) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
ReceiveRequest(HttpRequestBase) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
SendRequestReceiveResponse(WebRequest, XmlElement) | Sends a SAML request and receives a SAML response. The SAML request is wrapped in a SOAP message prior to sending. The SAML response is extracted from the received SOAP message.
SendRequestReceiveResponse(String, XmlElement) | Sends a SAML request and receives a SAML response. The SAML request is wrapped in a SOAP message prior to sending. The SAML response is extracted from the received SOAP message.
SendResponse(HttpResponse, XmlElement) | Sends a SAML response. The SAML response is wrapped in a SOAP message prior to sending.
SendResponse(HttpResponseBase, XmlElement) | Sends a SAML response. The SAML response is wrapped in a SOAP message prior to sending.
Top
See Also

Reference

SOAPBinding Class
ComponentSpace.SAML2.Bindings Namespace


SOAPBinding.ReceiveRequest Method

SOAPBindingReceiveRequest Method

Overload List
Name | Description
ReceiveRequest(HttpRequest) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
ReceiveRequest(HttpRequestBase) | Receives a SAML request. The SAML request is extracted from the received SOAP message.
Top
See Also

Reference

SOAPBinding Class
ComponentSpace.SAML2.Bindings Namespace


SOAPBinding.ReceiveRequest Method (HttpRequest)

SOAPBindingReceiveRequest Method (HttpRequest)

Receives a SAML request. The SAML request is extracted from the received SOAP message.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveRequest(
    HttpRequest httpRequest
)
Public Shared Function ReceiveRequest (
    httpRequest As HttpRequest
) As XmlElement
public:
static XmlElement^ ReceiveRequest(
    HttpRequest^ httpRequest
)
static member ReceiveRequest :
        httpRequest : HttpRequest -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the SAML request.

Return Value

Type: XmlElement
The SAML request.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

SOAPBinding Class
ReceiveRequest Overload
ComponentSpace.SAML2.Bindings Namespace


SOAPBinding.ReceiveRequest Method (HttpRequestBase)

SOAPBindingReceiveRequest Method (HttpRequestBase)

Receives a SAML request. The SAML request is extracted from the received SOAP message.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveRequest(
    HttpRequestBase httpRequest
)
Public Shared Function ReceiveRequest (
    httpRequest As HttpRequestBase
) As XmlElement
public:
static XmlElement^ ReceiveRequest(
    HttpRequestBase^ httpRequest
)
static member ReceiveRequest :
        httpRequest : HttpRequestBase -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the SAML request.

Return Value

Type: XmlElement
The SAML request.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

SOAPBinding Class
ReceiveRequest Overload
ComponentSpace.SAML2.Bindings Namespace


SOAPBinding.SendRequestReceiveResponse Method

SOAPBindingSendRequestReceiveResponse Method

Overload List
Name | Description
SendRequestReceiveResponse(WebRequest, XmlElement) | Sends a SAML request and receives a SAML response. The SAML request is wrapped in a SOAP message prior to sending. The SAML response is extracted from the received SOAP message.
SendRequestReceiveResponse(String, XmlElement) | Sends a SAML request and receives a SAML response. The SAML request is wrapped in a SOAP message prior to sending. The SAML response is extracted from the received SOAP message.
Top
See Also

Reference

SOAPBinding Class
ComponentSpace.SAML2.Bindings Namespace


SOAPBinding.SendRequestReceiveResponse Method (WebRequest, XmlElement)

SOAPBindingSendRequestReceiveResponse Method (WebRequest, XmlElement)

Sends a SAML request and receives a SAML response. The SAML request is wrapped in a SOAP message prior to sending. The SAML response is extracted from the received SOAP message.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendRequestReceiveResponse(
    WebRequest webRequest,
    XmlElement samlMessage
)
Public Shared Function SendRequestReceiveResponse (
    webRequest As WebRequest,
    samlMessage As XmlElement
) As XmlElement
public:
static XmlElement^ SendRequestReceiveResponse(
    WebRequest^ webRequest,
    XmlElement^ samlMessage
)
static member SendRequestReceiveResponse :
        webRequest : WebRequest *
        samlMessage : XmlElement -> XmlElement

Parameters

webRequest
Type: System.NetWebRequest
The WebRequest object used to send the request.
samlMessage
Type: System.XmlXmlElement
The SAML request.

Return Value

Type: XmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

SOAPBinding Class
SendRequestReceiveResponse Overload
ComponentSpace.SAML2.Bindings Namespace


SOAPBinding.SendRequestReceiveResponse Method (String, XmlElement)

SOAPBindingSendRequestReceiveResponse Method (String, XmlElement)

Sends a SAML request and receives a SAML response. The SAML request is wrapped in a SOAP message prior to sending. The SAML response is extracted from the received SOAP message.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendRequestReceiveResponse(
    string destinationURL,
    XmlElement samlMessage
)
Public Shared Function SendRequestReceiveResponse (
    destinationURL As String,
    samlMessage As XmlElement
) As XmlElement
public:
static XmlElement^ SendRequestReceiveResponse(
    String^ destinationURL,
    XmlElement^ samlMessage
)
static member SendRequestReceiveResponse :
        destinationURL : string *
        samlMessage : XmlElement -> XmlElement

Parameters

destinationURL
Type: SystemString
The destination URL.
samlMessage
Type: System.XmlXmlElement
The SAML request.

Return Value

Type: XmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

SOAPBinding Class
SendRequestReceiveResponse Overload
ComponentSpace.SAML2.Bindings Namespace


SOAPBinding.SendResponse Method

SOAPBindingSendResponse Method

Overload List
Name | Description
SendResponse(HttpResponse, XmlElement) | Sends a SAML response. The SAML response is wrapped in a SOAP message prior to sending.
SendResponse(HttpResponseBase, XmlElement) | Sends a SAML response. The SAML response is wrapped in a SOAP message prior to sending.
Top
See Also

Reference

SOAPBinding Class
ComponentSpace.SAML2.Bindings Namespace


SOAPBinding.SendResponse Method (HttpResponse, XmlElement)

SOAPBindingSendResponse Method (HttpResponse, XmlElement)

Sends a SAML response. The SAML response is wrapped in a SOAP message prior to sending.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    HttpResponse httpResponse,
    XmlElement samlMessage
)
Public Shared Sub SendResponse (
    httpResponse As HttpResponse,
    samlMessage As XmlElement
)
public:
static void SendResponse(
    HttpResponse^ httpResponse,
    XmlElement^ samlMessage
)
static member SendResponse :
        httpResponse : HttpResponse *
        samlMessage : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to send the SAML response.
samlMessage
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

SOAPBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


SOAPBinding.SendResponse Method (HttpResponseBase, XmlElement)

SOAPBindingSendResponse Method (HttpResponseBase, XmlElement)

Sends a SAML response. The SAML response is wrapped in a SOAP message prior to sending.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    HttpResponseBase httpResponse,
    XmlElement samlMessage
)
Public Shared Sub SendResponse (
    httpResponse As HttpResponseBase,
    samlMessage As XmlElement
)
public:
static void SendResponse(
    HttpResponseBase^ httpResponse,
    XmlElement^ samlMessage
)
static member SendResponse :
        httpResponse : HttpResponseBase *
        samlMessage : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to send the SAML response.
samlMessage
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

SOAPBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


URIBinding Class

Supports the URI binding.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.BindingsURIBinding

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class URIBinding
Public NotInheritable Class URIBinding
public ref class URIBinding abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type URIBinding =  class end

The URIBinding type exposes the following members.

Methods
Name | Description
ReceiveID(HttpRequest) | Receives the identifier.
ReceiveID(HttpRequestBase) | Receives the identifier.
SendIDReceiveResponse | Sends the identifier and receives the SAML response.
SendResponse(HttpResponse, XmlElement) | Sends the SAML response.
SendResponse(HttpResponseBase, XmlElement) | Sends the SAML response.
Top
Remarks
Refer to the Bindings for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Bindings Namespace
ComponentSpace.SAML2SAMLIdentifiersBindingURIs


URIBinding Methods

The URIBinding type exposes the following members.

Methods
Name | Description
ReceiveID(HttpRequest) | Receives the identifier.
ReceiveID(HttpRequestBase) | Receives the identifier.
SendIDReceiveResponse | Sends the identifier and receives the SAML response.
SendResponse(HttpResponse, XmlElement) | Sends the SAML response.
SendResponse(HttpResponseBase, XmlElement) | Sends the SAML response.
Top
See Also

Reference

URIBinding Class
ComponentSpace.SAML2.Bindings Namespace


URIBinding.ReceiveID Method

URIBindingReceiveID Method

Overload List
Name | Description
ReceiveID(HttpRequest) | Receives the identifier.
ReceiveID(HttpRequestBase) | Receives the identifier.
Top
See Also

Reference

URIBinding Class
ComponentSpace.SAML2.Bindings Namespace


URIBinding.ReceiveID Method (HttpRequest)

URIBindingReceiveID Method (HttpRequest)

Receives the identifier.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string ReceiveID(
    HttpRequest httpRequest
)
Public Shared Function ReceiveID (
    httpRequest As HttpRequest
) As String
public:
static String^ ReceiveID(
    HttpRequest^ httpRequest
)
static member ReceiveID :
        httpRequest : HttpRequest -> string

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the identifier.

Return Value

Type: String
The identifier.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

URIBinding Class
ReceiveID Overload
ComponentSpace.SAML2.Bindings Namespace


URIBinding.ReceiveID Method (HttpRequestBase)

URIBindingReceiveID Method (HttpRequestBase)

Receives the identifier.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string ReceiveID(
    HttpRequestBase httpRequest
)
Public Shared Function ReceiveID (
    httpRequest As HttpRequestBase
) As String
public:
static String^ ReceiveID(
    HttpRequestBase^ httpRequest
)
static member ReceiveID :
        httpRequest : HttpRequestBase -> string

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the identifier.

Return Value

Type: String
The identifier.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the receive fails.
See Also

Reference

URIBinding Class
ReceiveID Overload
ComponentSpace.SAML2.Bindings Namespace


URIBinding.SendIDReceiveResponse Method

URIBindingSendIDReceiveResponse Method

Sends the identifier and receives the SAML response.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendIDReceiveResponse(
    string destinationURL,
    string id
)
Public Shared Function SendIDReceiveResponse (
    destinationURL As String,
    id As String
) As XmlElement
public:
static XmlElement^ SendIDReceiveResponse(
    String^ destinationURL,
    String^ id
)
static member SendIDReceiveResponse :
        destinationURL : string *
        id : string -> XmlElement

Parameters

destinationURL
Type: SystemString
The destination URL.
id
Type: SystemString
The identifier.

Return Value

Type: XmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

URIBinding Class
ComponentSpace.SAML2.Bindings Namespace


URIBinding.SendResponse Method

URIBindingSendResponse Method

Overload List
Name | Description
SendResponse(HttpResponse, XmlElement) | Sends the SAML response.
SendResponse(HttpResponseBase, XmlElement) | Sends the SAML response.
Top
See Also

Reference

URIBinding Class
ComponentSpace.SAML2.Bindings Namespace


URIBinding.SendResponse Method (HttpResponse, XmlElement)

URIBindingSendResponse Method (HttpResponse, XmlElement)

Sends the SAML response.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    HttpResponse httpResponse,
    XmlElement samlMessage
)
Public Shared Sub SendResponse (
    httpResponse As HttpResponse,
    samlMessage As XmlElement
)
public:
static void SendResponse(
    HttpResponse^ httpResponse,
    XmlElement^ samlMessage
)
static member SendResponse :
        httpResponse : HttpResponse *
        samlMessage : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will return the SAML response.
samlMessage
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

URIBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


URIBinding.SendResponse Method (HttpResponseBase, XmlElement)

URIBindingSendResponse Method (HttpResponseBase, XmlElement)

Sends the SAML response.

Namespace: ComponentSpace.SAML2.Bindings
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendResponse(
    HttpResponseBase httpResponse,
    XmlElement samlMessage
)
Public Shared Sub SendResponse (
    httpResponse As HttpResponseBase,
    samlMessage As XmlElement
)
public:
static void SendResponse(
    HttpResponseBase^ httpResponse,
    XmlElement^ samlMessage
)
static member SendResponse :
        httpResponse : HttpResponseBase *
        samlMessage : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will return the SAML response.
samlMessage
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLBindingException | Thrown when the send fails.
See Also

Reference

URIBinding Class
SendResponse Overload
ComponentSpace.SAML2.Bindings Namespace


ComponentSpace.SAML2.Certificates Namespace

The ComponentSpace.SAML2.Certificates namespace contains classes associated with X.509 certificate management.
Classes
 | Class | Description
Public class | CachedCertificateLoader | The cached certificate loader loads X.509 certificates. Certificates are cached in memory for performance.
Public class | CertificateLoader | The certificate loader loads X.509 certificates.
Public class | CertificateManager | The certificate manager manages X.509 certificates.
Interfaces
 | Interface | Description
Public interface | ICertificateLoader | The certificate loader loads X.509 certificates.
Public interface | ICertificateManager | The certificate manager manages X.509 certificates.


CachedCertificateLoader Class

The cached certificate loader loads X.509 certificates.

Certificates are cached in memory for performance.

Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.CertificatesCertificateLoader
ComponentSpace.SAML2.CertificatesCachedCertificateLoader

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class CachedCertificateLoader : CertificateLoader
Public Class CachedCertificateLoader
    Inherits CertificateLoader
public ref class CachedCertificateLoader : public CertificateLoader
type CachedCertificateLoader =
    class
        inherit CertificateLoader
    end

The CachedCertificateLoader type exposes the following members.

Constructors
 | Name | Description
Public method | CachedCertificateLoader | Initializes a new instance of the CachedCertificateLoader class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadCertificateFromFile | Loads an X.509 certificate from the file system. Certificates are cached in memory for performance. (Overrides CertificateLoaderLoadCertificateFromFile(String, String).)
Public method | LoadCertificateFromStore | Loads an X.509 certificate from the Windows Certificate Store. Certificates are cached in memory for performance. (Overrides CertificateLoaderLoadCertificateFromStore(StoreLocation, X509FindType, Object).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Certificates Namespace


CachedCertificateLoader Constructor

Initializes a new instance of the CachedCertificateLoader class

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public CachedCertificateLoader()
Public Sub New
public:
CachedCertificateLoader()
new : unit -> CachedCertificateLoader
See Also

Reference

CachedCertificateLoader Class
ComponentSpace.SAML2.Certificates Namespace


CachedCertificateLoader Methods

The CachedCertificateLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadCertificateFromFile | Loads an X.509 certificate from the file system. Certificates are cached in memory for performance. (Overrides CertificateLoaderLoadCertificateFromFile(String, String).)
Public method | LoadCertificateFromStore | Loads an X.509 certificate from the Windows Certificate Store. Certificates are cached in memory for performance. (Overrides CertificateLoaderLoadCertificateFromStore(StoreLocation, X509FindType, Object).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CachedCertificateLoader Class
ComponentSpace.SAML2.Certificates Namespace


CachedCertificateLoader.LoadCertificateFromFile Method

CachedCertificateLoaderLoadCertificateFromFile Method

Loads an X.509 certificate from the file system.

Certificates are cached in memory for performance.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override X509Certificate2 LoadCertificateFromFile(
    string certificateFile,
    string certificatePassword
)
Public Overrides Function LoadCertificateFromFile (
    certificateFile As String,
    certificatePassword As String
) As X509Certificate2
public:
virtual X509Certificate2^ LoadCertificateFromFile(
    String^ certificateFile,
    String^ certificatePassword
) override
abstract LoadCertificateFromFile :
        certificateFile : string *
        certificatePassword : string -> X509Certificate2
override LoadCertificateFromFile :
        certificateFile : string *
        certificatePassword : string -> X509Certificate2

Parameters

certificateFile
Type: SystemString
The certificate file name.
certificatePassword
Type: SystemString
The certificate file password or null if none.

Return Value

Type: X509Certificate2
The X.509 certificate.

Implements

ICertificateLoaderLoadCertificateFromFile(String, String)
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be loaded.
See Also

Reference

CachedCertificateLoader Class
ComponentSpace.SAML2.Certificates Namespace


CachedCertificateLoader.LoadCertificateFromStore Method

CachedCertificateLoaderLoadCertificateFromStore Method

Loads an X.509 certificate from the Windows Certificate Store.

Certificates are cached in memory for performance.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override X509Certificate2 LoadCertificateFromStore(
    StoreLocation storeLocation,
    X509FindType findType,
    Object findValue
)
Public Overrides Function LoadCertificateFromStore (
    storeLocation As StoreLocation,
    findType As X509FindType,
    findValue As Object
) As X509Certificate2
public:
virtual X509Certificate2^ LoadCertificateFromStore(
    StoreLocation storeLocation,
    X509FindType findType,
    Object^ findValue
) override
abstract LoadCertificateFromStore :
        storeLocation : StoreLocation *
        findType : X509FindType *
        findValue : Object -> X509Certificate2
override LoadCertificateFromStore :
        storeLocation : StoreLocation *
        findType : X509FindType *
        findValue : Object -> X509Certificate2

Parameters

storeLocation
Type: System.Security.Cryptography.X509CertificatesStoreLocation
The store location.
findType
Type: System.Security.Cryptography.X509CertificatesX509FindType
The find type for searching the certificate store.
findValue
Type: SystemObject
The find value for searching the certificate store.

Return Value

Type: X509Certificate2
The X.509 certificate.

Implements

ICertificateLoaderLoadCertificateFromStore(StoreLocation, X509FindType, Object)
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be loaded.
See Also

Reference

CachedCertificateLoader Class
ComponentSpace.SAML2.Certificates Namespace


CertificateLoader Class

The certificate loader loads X.509 certificates.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.CertificatesCertificateLoader
ComponentSpace.SAML2.CertificatesCachedCertificateLoader

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class CertificateLoader : ICertificateLoader
Public Class CertificateLoader
    Implements ICertificateLoader
public ref class CertificateLoader : ICertificateLoader
type CertificateLoader =
    class
        interface ICertificateLoader
    end

The CertificateLoader type exposes the following members.

Constructors
 | Name | Description
Public method | CertificateLoader | Initializes a new instance of the CertificateLoader class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadCertificateFromFile | Loads an X.509 certificate from the file system.
Public method | LoadCertificateFromStore | Loads an X.509 certificate from the Windows Certificate Store.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Certificates Namespace


CertificateLoader Constructor

Initializes a new instance of the CertificateLoader class

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public CertificateLoader()
Public Sub New
public:
CertificateLoader()
new : unit -> CertificateLoader
See Also

Reference

CertificateLoader Class
ComponentSpace.SAML2.Certificates Namespace


CertificateLoader Methods

The CertificateLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadCertificateFromFile | Loads an X.509 certificate from the file system.
Public method | LoadCertificateFromStore | Loads an X.509 certificate from the Windows Certificate Store.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CertificateLoader Class
ComponentSpace.SAML2.Certificates Namespace


CertificateLoader.LoadCertificateFromFile Method

CertificateLoaderLoadCertificateFromFile Method

Loads an X.509 certificate from the file system.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual X509Certificate2 LoadCertificateFromFile(
    string certificateFile,
    string certificatePassword
)
Public Overridable Function LoadCertificateFromFile (
    certificateFile As String,
    certificatePassword As String
) As X509Certificate2
public:
virtual X509Certificate2^ LoadCertificateFromFile(
    String^ certificateFile,
    String^ certificatePassword
)
abstract LoadCertificateFromFile :
        certificateFile : string *
        certificatePassword : string -> X509Certificate2
override LoadCertificateFromFile :
        certificateFile : string *
        certificatePassword : string -> X509Certificate2

Parameters

certificateFile
Type: SystemString
The certificate file name.
certificatePassword
Type: SystemString
The certificate file password or null if none.

Return Value

Type: X509Certificate2
The X.509 certificate.

Implements

ICertificateLoaderLoadCertificateFromFile(String, String)
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be loaded.
See Also

Reference

CertificateLoader Class
ComponentSpace.SAML2.Certificates Namespace


CertificateLoader.LoadCertificateFromStore Method

CertificateLoaderLoadCertificateFromStore Method

Loads an X.509 certificate from the Windows Certificate Store.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual X509Certificate2 LoadCertificateFromStore(
    StoreLocation storeLocation,
    X509FindType findType,
    Object findValue
)
Public Overridable Function LoadCertificateFromStore (
    storeLocation As StoreLocation,
    findType As X509FindType,
    findValue As Object
) As X509Certificate2
public:
virtual X509Certificate2^ LoadCertificateFromStore(
    StoreLocation storeLocation,
    X509FindType findType,
    Object^ findValue
)
abstract LoadCertificateFromStore :
        storeLocation : StoreLocation *
        findType : X509FindType *
        findValue : Object -> X509Certificate2
override LoadCertificateFromStore :
        storeLocation : StoreLocation *
        findType : X509FindType *
        findValue : Object -> X509Certificate2

Parameters

storeLocation
Type: System.Security.Cryptography.X509CertificatesStoreLocation
The store location.
findType
Type: System.Security.Cryptography.X509CertificatesX509FindType
The find type for searching the certificate store.
findValue
Type: SystemObject
The find value for searching the certificate store.

Return Value

Type: X509Certificate2
The X.509 certificate.

Implements

ICertificateLoaderLoadCertificateFromStore(StoreLocation, X509FindType, Object)
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be loaded.
See Also

Reference

CertificateLoader Class
ComponentSpace.SAML2.Certificates Namespace


CertificateManager Class

The certificate manager manages X.509 certificates.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.CertificatesCertificateManager

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class CertificateManager : ICertificateManager
Public Class CertificateManager
    Implements ICertificateManager
public ref class CertificateManager : ICertificateManager
type CertificateManager =
    class
        interface ICertificateManager
    end

The CertificateManager type exposes the following members.

Constructors
 | Name | Description
Public method | CertificateManager | Constructs a CertificateManager. By default the cached certificate loader is used for improved performance. To turn off caching, use the non-caching certificate loader. Caching is recommended if certificates are stored on the file system. If certificates are stored in the Windows certificate store, caching may be turned off. The advantage of no caching is that any certificate changes are picked up immediately.
Public method | CertificateManager(ICertificateLoader) | Constructs a CertificateManager.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalIdentityProviderSignatureCertificates | Gets the local identity provider X.509 signature certificates.
Public method | GetLocalServiceProviderEncryptionCertificates | Gets the local service provider X.509 encryption certificates.
Public method | GetLocalServiceProviderSignatureCertificates | Gets the local service provider X.509 signature certificates.
Public method | GetPartnerIdentityProviderSignatureCertificates | Gets the partner identity provider X.509 signature certificates.
Public method | GetPartnerServiceProviderEncryptionCertificates | Gets the partner service provider X.509 encryption certificates.
Public method | GetPartnerServiceProviderSignatureCertificates | Gets the partner service provider X.509 signature certificates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Certificates Namespace


CertificateManager Constructor

Overload List
 | Name | Description
Public method | CertificateManager | Constructs a CertificateManager. By default the cached certificate loader is used for improved performance. To turn off caching, use the non-caching certificate loader. Caching is recommended if certificates are stored on the file system. If certificates are stored in the Windows certificate store, caching may be turned off. The advantage of no caching is that any certificate changes are picked up immediately.
Public method | CertificateManager(ICertificateLoader) | Constructs a CertificateManager.
Top
See Also

Reference

CertificateManager Class
ComponentSpace.SAML2.Certificates Namespace


CertificateManager Constructor

Constructs a CertificateManager.

By default the cached certificate loader is used for improved performance. To turn off caching, use the non-caching certificate loader. Caching is recommended if certificates are stored on the file system. If certificates are stored in the Windows certificate store, caching may be turned off. The advantage of no caching is that any certificate changes are picked up immediately.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public CertificateManager()
Public Sub New
public:
CertificateManager()
new : unit -> CertificateManager
See Also

Reference

CertificateManager Class
CertificateManager Overload
ComponentSpace.SAML2.Certificates Namespace


CertificateManager Constructor (ICertificateLoader)

Constructs a CertificateManager.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public CertificateManager(
    ICertificateLoader certificateLoader
)
Public Sub New (
    certificateLoader As ICertificateLoader
)
public:
CertificateManager(
    ICertificateLoader^ certificateLoader
)
new :
        certificateLoader : ICertificateLoader -> CertificateManager

Parameters

certificateLoader
Type: ComponentSpace.SAML2.CertificatesICertificateLoader
The certificate loader.
See Also

Reference

CertificateManager Class
CertificateManager Overload
ComponentSpace.SAML2.Certificates Namespace


CertificateManager Methods

The CertificateManager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalIdentityProviderSignatureCertificates | Gets the local identity provider X.509 signature certificates.
Public method | GetLocalServiceProviderEncryptionCertificates | Gets the local service provider X.509 encryption certificates.
Public method | GetLocalServiceProviderSignatureCertificates | Gets the local service provider X.509 signature certificates.
Public method | GetPartnerIdentityProviderSignatureCertificates | Gets the partner identity provider X.509 signature certificates.
Public method | GetPartnerServiceProviderEncryptionCertificates | Gets the partner service provider X.509 encryption certificates.
Public method | GetPartnerServiceProviderSignatureCertificates | Gets the partner service provider X.509 signature certificates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CertificateManager Class
ComponentSpace.SAML2.Certificates Namespace


CertificateManager.GetLocalIdentityProviderSignatureCertificates Method

CertificateManagerGetLocalIdentityProviderSignatureCertificates Method

Gets the local identity provider X.509 signature certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<X509Certificate2> GetLocalIdentityProviderSignatureCertificates(
    string configurationID,
    string partnerServiceProviderName
)
Public Function GetLocalIdentityProviderSignatureCertificates (
    configurationID As String,
    partnerServiceProviderName As String
) As IList(Of X509Certificate2)
public:
virtual IList<X509Certificate2^>^ GetLocalIdentityProviderSignatureCertificates(
    String^ configurationID,
    String^ partnerServiceProviderName
) sealed
abstract GetLocalIdentityProviderSignatureCertificates :
        configurationID : string *
        partnerServiceProviderName : string -> IList<X509Certificate2>
override GetLocalIdentityProviderSignatureCertificates :
        configurationID : string *
        partnerServiceProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerServiceProviderName
Type: SystemString
The partner service provider name or null if none.

Return Value

Type: IList X509Certificate2
The local identity provider X.509 signature certificates or null if none.

Implements

ICertificateManagerGetLocalIdentityProviderSignatureCertificates(String, String)
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

CertificateManager Class
ComponentSpace.SAML2.Certificates Namespace


CertificateManager.GetLocalServiceProviderEncryptionCertificates Method

CertificateManagerGetLocalServiceProviderEncryptionCertificates Method

Gets the local service provider X.509 encryption certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<X509Certificate2> GetLocalServiceProviderEncryptionCertificates(
    string configurationID,
    string partnerIdentityProviderName
)
Public Function GetLocalServiceProviderEncryptionCertificates (
    configurationID As String,
    partnerIdentityProviderName As String
) As IList(Of X509Certificate2)
public:
virtual IList<X509Certificate2^>^ GetLocalServiceProviderEncryptionCertificates(
    String^ configurationID,
    String^ partnerIdentityProviderName
) sealed
abstract GetLocalServiceProviderEncryptionCertificates :
        configurationID : string *
        partnerIdentityProviderName : string -> IList<X509Certificate2>
override GetLocalServiceProviderEncryptionCertificates :
        configurationID : string *
        partnerIdentityProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerIdentityProviderName
Type: SystemString
The partner identity provider name or null if none.

Return Value

Type: IList X509Certificate2
The local service provider X.509 encryption certificates or null if none.

Implements

ICertificateManagerGetLocalServiceProviderEncryptionCertificates(String, String)
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

CertificateManager Class
ComponentSpace.SAML2.Certificates Namespace


CertificateManager.GetLocalServiceProviderSignatureCertificates Method

CertificateManagerGetLocalServiceProviderSignatureCertificates Method

Gets the local service provider X.509 signature certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<X509Certificate2> GetLocalServiceProviderSignatureCertificates(
    string configurationID,
    string partnerIdentityProviderName
)
Public Function GetLocalServiceProviderSignatureCertificates (
    configurationID As String,
    partnerIdentityProviderName As String
) As IList(Of X509Certificate2)
public:
virtual IList<X509Certificate2^>^ GetLocalServiceProviderSignatureCertificates(
    String^ configurationID,
    String^ partnerIdentityProviderName
) sealed
abstract GetLocalServiceProviderSignatureCertificates :
        configurationID : string *
        partnerIdentityProviderName : string -> IList<X509Certificate2>
override GetLocalServiceProviderSignatureCertificates :
        configurationID : string *
        partnerIdentityProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerIdentityProviderName
Type: SystemString
The partner identity provider name or null if none.

Return Value

Type: IList X509Certificate2
The local service provider X.509 signature certificates or null if none.

Implements

ICertificateManagerGetLocalServiceProviderSignatureCertificates(String, String)
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

CertificateManager Class
ComponentSpace.SAML2.Certificates Namespace


CertificateManager.GetPartnerIdentityProviderSignatureCertificates Method

CertificateManagerGetPartnerIdentityProviderSignatureCertificates Method

Gets the partner identity provider X.509 signature certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<X509Certificate2> GetPartnerIdentityProviderSignatureCertificates(
    string configurationID,
    string partnerIdentityProviderName
)
Public Function GetPartnerIdentityProviderSignatureCertificates (
    configurationID As String,
    partnerIdentityProviderName As String
) As IList(Of X509Certificate2)
public:
virtual IList<X509Certificate2^>^ GetPartnerIdentityProviderSignatureCertificates(
    String^ configurationID,
    String^ partnerIdentityProviderName
) sealed
abstract GetPartnerIdentityProviderSignatureCertificates :
        configurationID : string *
        partnerIdentityProviderName : string -> IList<X509Certificate2>
override GetPartnerIdentityProviderSignatureCertificates :
        configurationID : string *
        partnerIdentityProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerIdentityProviderName
Type: SystemString
The partner identity provider name.

Return Value

Type: IList X509Certificate2
The partner identity provider X.509 signature certificates or null if none.

Implements

ICertificateManagerGetPartnerIdentityProviderSignatureCertificates(String, String)
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

CertificateManager Class
ComponentSpace.SAML2.Certificates Namespace


CertificateManager.GetPartnerServiceProviderEncryptionCertificates Method

CertificateManagerGetPartnerServiceProviderEncryptionCertificates Method

Gets the partner service provider X.509 encryption certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<X509Certificate2> GetPartnerServiceProviderEncryptionCertificates(
    string configurationID,
    string partnerServiceProviderName
)
Public Function GetPartnerServiceProviderEncryptionCertificates (
    configurationID As String,
    partnerServiceProviderName As String
) As IList(Of X509Certificate2)
public:
virtual IList<X509Certificate2^>^ GetPartnerServiceProviderEncryptionCertificates(
    String^ configurationID,
    String^ partnerServiceProviderName
) sealed
abstract GetPartnerServiceProviderEncryptionCertificates :
        configurationID : string *
        partnerServiceProviderName : string -> IList<X509Certificate2>
override GetPartnerServiceProviderEncryptionCertificates :
        configurationID : string *
        partnerServiceProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerServiceProviderName
Type: SystemString
The partner service provider name.

Return Value

Type: IList X509Certificate2
The partner service provider X.509 encryption certificates or null if none.

Implements

ICertificateManagerGetPartnerServiceProviderEncryptionCertificates(String, String)
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

CertificateManager Class
ComponentSpace.SAML2.Certificates Namespace


CertificateManager.GetPartnerServiceProviderSignatureCertificates Method

CertificateManagerGetPartnerServiceProviderSignatureCertificates Method

Gets the partner service provider X.509 signature certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<X509Certificate2> GetPartnerServiceProviderSignatureCertificates(
    string configurationID,
    string partnerServiceProviderName
)
Public Function GetPartnerServiceProviderSignatureCertificates (
    configurationID As String,
    partnerServiceProviderName As String
) As IList(Of X509Certificate2)
public:
virtual IList<X509Certificate2^>^ GetPartnerServiceProviderSignatureCertificates(
    String^ configurationID,
    String^ partnerServiceProviderName
) sealed
abstract GetPartnerServiceProviderSignatureCertificates :
        configurationID : string *
        partnerServiceProviderName : string -> IList<X509Certificate2>
override GetPartnerServiceProviderSignatureCertificates :
        configurationID : string *
        partnerServiceProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerServiceProviderName
Type: SystemString
The partner service provider name.

Return Value

Type: IList X509Certificate2
The partner service provider X.509 signature certificates or null if none.

Implements

ICertificateManagerGetPartnerServiceProviderSignatureCertificates(String, String)
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

CertificateManager Class
ComponentSpace.SAML2.Certificates Namespace


ICertificateLoader Interface

The certificate loader loads X.509 certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public interface ICertificateLoader
Public Interface ICertificateLoader
public interface class ICertificateLoader
type ICertificateLoader =  interface end

The ICertificateLoader type exposes the following members.

Methods
 | Name | Description
Public method | LoadCertificateFromFile | Loads an X.509 certificate from the file system.
Public method | LoadCertificateFromStore | Loads an X.509 certificate from the Windows Certificate Store.
Top
See Also

Reference

ComponentSpace.SAML2.Certificates Namespace


ICertificateLoader Methods

The ICertificateLoader type exposes the following members.

Methods
 | Name | Description
Public method | LoadCertificateFromFile | Loads an X.509 certificate from the file system.
Public method | LoadCertificateFromStore | Loads an X.509 certificate from the Windows Certificate Store.
Top
See Also

Reference

ICertificateLoader Interface
ComponentSpace.SAML2.Certificates Namespace


ICertificateLoader.LoadCertificateFromFile Method

ICertificateLoaderLoadCertificateFromFile Method

Loads an X.509 certificate from the file system.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
X509Certificate2 LoadCertificateFromFile(
    string certificateFile,
    string certificatePassword
)
Function LoadCertificateFromFile (
    certificateFile As String,
    certificatePassword As String
) As X509Certificate2
X509Certificate2^ LoadCertificateFromFile(
    String^ certificateFile,
    String^ certificatePassword
)
abstract LoadCertificateFromFile :
        certificateFile : string *
        certificatePassword : string -> X509Certificate2

Parameters

certificateFile
Type: SystemString
The certificate file name.
certificatePassword
Type: SystemString
The certificate file password or null if none.

Return Value

Type: X509Certificate2
The X.509 certificate.
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be loaded.
See Also

Reference

ICertificateLoader Interface
ComponentSpace.SAML2.Certificates Namespace


ICertificateLoader.LoadCertificateFromStore Method

ICertificateLoaderLoadCertificateFromStore Method

Loads an X.509 certificate from the Windows Certificate Store.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
X509Certificate2 LoadCertificateFromStore(
    StoreLocation storeLocation,
    X509FindType findType,
    Object findValue
)
Function LoadCertificateFromStore (
    storeLocation As StoreLocation,
    findType As X509FindType,
    findValue As Object
) As X509Certificate2
X509Certificate2^ LoadCertificateFromStore(
    StoreLocation storeLocation,
    X509FindType findType,
    Object^ findValue
)
abstract LoadCertificateFromStore :
        storeLocation : StoreLocation *
        findType : X509FindType *
        findValue : Object -> X509Certificate2

Parameters

storeLocation
Type: System.Security.Cryptography.X509CertificatesStoreLocation
The store location.
findType
Type: System.Security.Cryptography.X509CertificatesX509FindType
The find type for searching the certificate store.
findValue
Type: SystemObject
The find value for searching the certificate store.

Return Value

Type: X509Certificate2
The X.509 certificate.
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be loaded.
See Also

Reference

ICertificateLoader Interface
ComponentSpace.SAML2.Certificates Namespace


ICertificateManager Interface

The certificate manager manages X.509 certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public interface ICertificateManager
Public Interface ICertificateManager
public interface class ICertificateManager
type ICertificateManager =  interface end

The ICertificateManager type exposes the following members.

Methods
 | Name | Description
Public method | GetLocalIdentityProviderSignatureCertificates | Gets the local identity provider X.509 signature certificates.
Public method | GetLocalServiceProviderEncryptionCertificates | Gets the local service provider X.509 encryption certificates.
Public method | GetLocalServiceProviderSignatureCertificates | Gets the local service provider X.509 signature certificates.
Public method | GetPartnerIdentityProviderSignatureCertificates | Gets the partner identity provider X.509 signature certificates.
Public method | GetPartnerServiceProviderEncryptionCertificates | Gets the partner service provider X.509 encryption certificates.
Public method | GetPartnerServiceProviderSignatureCertificates | Gets the partner service provider X.509 signature certificates.
Top
See Also

Reference

ComponentSpace.SAML2.Certificates Namespace


ICertificateManager Methods

The ICertificateManager type exposes the following members.

Methods
 | Name | Description
Public method | GetLocalIdentityProviderSignatureCertificates | Gets the local identity provider X.509 signature certificates.
Public method | GetLocalServiceProviderEncryptionCertificates | Gets the local service provider X.509 encryption certificates.
Public method | GetLocalServiceProviderSignatureCertificates | Gets the local service provider X.509 signature certificates.
Public method | GetPartnerIdentityProviderSignatureCertificates | Gets the partner identity provider X.509 signature certificates.
Public method | GetPartnerServiceProviderEncryptionCertificates | Gets the partner service provider X.509 encryption certificates.
Public method | GetPartnerServiceProviderSignatureCertificates | Gets the partner service provider X.509 signature certificates.
Top
See Also

Reference

ICertificateManager Interface
ComponentSpace.SAML2.Certificates Namespace


ICertificateManager.GetLocalIdentityProviderSignatureCertificates Method

ICertificateManagerGetLocalIdentityProviderSignatureCertificates Method

Gets the local identity provider X.509 signature certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
IList<X509Certificate2> GetLocalIdentityProviderSignatureCertificates(
    string configurationID,
    string partnerServiceProviderName
)
Function GetLocalIdentityProviderSignatureCertificates (
    configurationID As String,
    partnerServiceProviderName As String
) As IList(Of X509Certificate2)
IList<X509Certificate2^>^ GetLocalIdentityProviderSignatureCertificates(
    String^ configurationID,
    String^ partnerServiceProviderName
)
abstract GetLocalIdentityProviderSignatureCertificates :
        configurationID : string *
        partnerServiceProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerServiceProviderName
Type: SystemString
The partner service provider name or null if none.

Return Value

Type: IList X509Certificate2
The local identity provider X.509 signature certificates or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

ICertificateManager Interface
ComponentSpace.SAML2.Certificates Namespace


ICertificateManager.GetLocalServiceProviderEncryptionCertificates Method

ICertificateManagerGetLocalServiceProviderEncryptionCertificates Method

Gets the local service provider X.509 encryption certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
IList<X509Certificate2> GetLocalServiceProviderEncryptionCertificates(
    string configurationID,
    string partnerIdentityProviderName
)
Function GetLocalServiceProviderEncryptionCertificates (
    configurationID As String,
    partnerIdentityProviderName As String
) As IList(Of X509Certificate2)
IList<X509Certificate2^>^ GetLocalServiceProviderEncryptionCertificates(
    String^ configurationID,
    String^ partnerIdentityProviderName
)
abstract GetLocalServiceProviderEncryptionCertificates :
        configurationID : string *
        partnerIdentityProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerIdentityProviderName
Type: SystemString
The partner identity provider name or null if none.

Return Value

Type: IList X509Certificate2
The local service provider X.509 encryption certificates or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

ICertificateManager Interface
ComponentSpace.SAML2.Certificates Namespace


ICertificateManager.GetLocalServiceProviderSignatureCertificates Method

ICertificateManagerGetLocalServiceProviderSignatureCertificates Method

Gets the local service provider X.509 signature certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
IList<X509Certificate2> GetLocalServiceProviderSignatureCertificates(
    string configurationID,
    string partnerIdentityProviderName
)
Function GetLocalServiceProviderSignatureCertificates (
    configurationID As String,
    partnerIdentityProviderName As String
) As IList(Of X509Certificate2)
IList<X509Certificate2^>^ GetLocalServiceProviderSignatureCertificates(
    String^ configurationID,
    String^ partnerIdentityProviderName
)
abstract GetLocalServiceProviderSignatureCertificates :
        configurationID : string *
        partnerIdentityProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerIdentityProviderName
Type: SystemString
The partner identity provider name or null if none.

Return Value

Type: IList X509Certificate2
The local service provider X.509 signature certificates or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

ICertificateManager Interface
ComponentSpace.SAML2.Certificates Namespace


ICertificateManager.GetPartnerIdentityProviderSignatureCertificates Method

ICertificateManagerGetPartnerIdentityProviderSignatureCertificates Method

Gets the partner identity provider X.509 signature certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
IList<X509Certificate2> GetPartnerIdentityProviderSignatureCertificates(
    string configurationID,
    string partnerIdentityProviderName
)
Function GetPartnerIdentityProviderSignatureCertificates (
    configurationID As String,
    partnerIdentityProviderName As String
) As IList(Of X509Certificate2)
IList<X509Certificate2^>^ GetPartnerIdentityProviderSignatureCertificates(
    String^ configurationID,
    String^ partnerIdentityProviderName
)
abstract GetPartnerIdentityProviderSignatureCertificates :
        configurationID : string *
        partnerIdentityProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerIdentityProviderName
Type: SystemString
The partner identity provider name.

Return Value

Type: IList X509Certificate2
The partner identity provider X.509 signature certificates or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

ICertificateManager Interface
ComponentSpace.SAML2.Certificates Namespace


ICertificateManager.GetPartnerServiceProviderEncryptionCertificates Method

ICertificateManagerGetPartnerServiceProviderEncryptionCertificates Method

Gets the partner service provider X.509 encryption certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
IList<X509Certificate2> GetPartnerServiceProviderEncryptionCertificates(
    string configurationID,
    string partnerServiceProviderName
)
Function GetPartnerServiceProviderEncryptionCertificates (
    configurationID As String,
    partnerServiceProviderName As String
) As IList(Of X509Certificate2)
IList<X509Certificate2^>^ GetPartnerServiceProviderEncryptionCertificates(
    String^ configurationID,
    String^ partnerServiceProviderName
)
abstract GetPartnerServiceProviderEncryptionCertificates :
        configurationID : string *
        partnerServiceProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerServiceProviderName
Type: SystemString
The partner service provider name.

Return Value

Type: IList X509Certificate2
The partner service provider X.509 encryption certificates or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

ICertificateManager Interface
ComponentSpace.SAML2.Certificates Namespace


ICertificateManager.GetPartnerServiceProviderSignatureCertificates Method

ICertificateManagerGetPartnerServiceProviderSignatureCertificates Method

Gets the partner service provider X.509 signature certificates.

Namespace: ComponentSpace.SAML2.Certificates
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
IList<X509Certificate2> GetPartnerServiceProviderSignatureCertificates(
    string configurationID,
    string partnerServiceProviderName
)
Function GetPartnerServiceProviderSignatureCertificates (
    configurationID As String,
    partnerServiceProviderName As String
) As IList(Of X509Certificate2)
IList<X509Certificate2^>^ GetPartnerServiceProviderSignatureCertificates(
    String^ configurationID,
    String^ partnerServiceProviderName
)
abstract GetPartnerServiceProviderSignatureCertificates :
        configurationID : string *
        partnerServiceProviderName : string -> IList<X509Certificate2>

Parameters

configurationID
Type: SystemString
The SAML configuration identifier or null if none.
partnerServiceProviderName
Type: SystemString
The partner service provider name.

Return Value

Type: IList X509Certificate2
The partner service provider X.509 signature certificates or null if none.
Exceptions
Exception | Condition
SAMLException | Thrown when the X.509 certificates cannot be retrieved.
See Also

Reference

ICertificateManager Interface
ComponentSpace.SAML2.Certificates Namespace


ComponentSpace.SAML2.Configuration Namespace

The ComponentSpace.SAML2.Configuration namespace contains classes that support configuration for the high-level SAML APIs.
Classes
 | Class | Description
Public class | LocalIdentityProviderConfiguration | The local identity provider configuration specifies the configuration for the local identity provider.
Public class | LocalProviderConfiguration | The local provider configuration is configuration common to local identity providers and service providers.
Public class | LocalServiceProviderConfiguration | The local service provider configuration specifies the configuration for the local service provider.
Public class | MetadataExporter | Exports the SAML configuration as SAML metadata.
Public class | MetadataImporter | Imports SAML metadata into the SAML configuration.
Public class | PartnerIdentityProviderConfiguration | The partner identity provider configuration specifies the configuration for the partner identity provider.
Public class | PartnerProviderConfiguration | The partner provider configuration is configuration common to partner identity providers and service providers.
Public class | PartnerServiceProviderConfiguration | The partner service provider configuration specifies the configuration for the partner service provider.
Public class | ProviderConfiguration | The provider configuration is configuration common to local and partner identity providers and service providers.
Public class | SAMLConfiguration | The SAML configuration specifies the configuration for SAML single sign-on.
Public class | SAMLConfigurationFile | Loads and saves SAML configuration files.
Public class | SAMLConfigurations | The SAML configurations specifies the configurations for SAML single sign-on.


LocalIdentityProviderConfiguration Class

The local identity provider configuration specifies the configuration for the local identity provider.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationProviderConfiguration
ComponentSpace.SAML2.ConfigurationLocalProviderConfiguration
ComponentSpace.SAML2.ConfigurationLocalIdentityProviderConfiguration

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class LocalIdentityProviderConfiguration : LocalProviderConfiguration
Public Class LocalIdentityProviderConfiguration
    Inherits LocalProviderConfiguration
public ref class LocalIdentityProviderConfiguration : public LocalProviderConfiguration
type LocalIdentityProviderConfiguration =
    class
        inherit LocalProviderConfiguration
    end

The LocalIdentityProviderConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | LocalIdentityProviderConfiguration | Constructs an identity provider configuration.
Public method | LocalIdentityProviderConfiguration(XmlElement) | Constructs an identity provider configuration from XML.
Top
Properties
 | Name | Description
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | SingleSignOnServiceUrl | Gets or sets the identity provider's single sign-on service URL. The single sign-on service URL is the endpoint at which the SAML authn request is received.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the identity provider configuration to XML. (Overrides LocalProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


LocalIdentityProviderConfiguration Constructor

Overload List
 | Name | Description
Public method | LocalIdentityProviderConfiguration | Constructs an identity provider configuration.
Public method | LocalIdentityProviderConfiguration(XmlElement) | Constructs an identity provider configuration from XML.
Top
See Also

Reference

LocalIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalIdentityProviderConfiguration Constructor

Constructs an identity provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalIdentityProviderConfiguration()
Public Sub New
public:
LocalIdentityProviderConfiguration()
new : unit -> LocalIdentityProviderConfiguration
See Also

Reference

LocalIdentityProviderConfiguration Class
LocalIdentityProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


LocalIdentityProviderConfiguration Constructor (XmlElement)

Constructs an identity provider configuration from XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalIdentityProviderConfiguration(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
LocalIdentityProviderConfiguration(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> LocalIdentityProviderConfiguration

Parameters

xmlElement
Type: System.XmlXmlElement
The identity provider configuration XML.
See Also

Reference

LocalIdentityProviderConfiguration Class
LocalIdentityProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


LocalIdentityProviderConfiguration Properties

The LocalIdentityProviderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | SingleSignOnServiceUrl | Gets or sets the identity provider's single sign-on service URL. The single sign-on service URL is the endpoint at which the SAML authn request is received.
Top
See Also

Reference

LocalIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalIdentityProviderConfiguration.SingleSignOnServiceUrl Property

LocalIdentityProviderConfigurationSingleSignOnServiceUrl Property

Gets or sets the identity provider's single sign-on service URL.

The single sign-on service URL is the endpoint at which the SAML authn request is received.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SingleSignOnServiceUrl { get; set; }
Public Property SingleSignOnServiceUrl As String
    Get
    Set
public:
property String^ SingleSignOnServiceUrl {
    String^ get ();
    void set (String^ value);
}
member SingleSignOnServiceUrl : string with get, set

Property Value

Type: String
The identity provider's single sign-on service URL.
See Also

Reference

LocalIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalIdentityProviderConfiguration Methods

The LocalIdentityProviderConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the identity provider configuration to XML. (Overrides LocalProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

LocalIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalIdentityProviderConfiguration.ToXml Method

LocalIdentityProviderConfigurationToXml Method

Serializes the identity provider configuration to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    XmlElement xmlElement
)
Public Overrides Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
) override
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element.
See Also

Reference

LocalIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalProviderConfiguration Class

The local provider configuration is configuration common to local identity providers and service providers.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationProviderConfiguration
ComponentSpace.SAML2.ConfigurationLocalProviderConfiguration
ComponentSpace.SAML2.ConfigurationLocalIdentityProviderConfiguration
ComponentSpace.SAML2.ConfigurationLocalServiceProviderConfiguration

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class LocalProviderConfiguration : ProviderConfiguration
Public MustInherit Class LocalProviderConfiguration
    Inherits ProviderConfiguration
public ref class LocalProviderConfiguration abstract : public ProviderConfiguration
[<AbstractClassAttribute>]
type LocalProviderConfiguration =
    class
        inherit ProviderConfiguration
    end

The LocalProviderConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | LocalProviderConfiguration | Constructs a local provider configuration.
Public method | LocalProviderConfiguration(XmlElement) | Constructs a local provider configuration from XML.
Top
Properties
 | Name | Description
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the local provider configuration to XML. (Overrides ProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


LocalProviderConfiguration Constructor

Overload List
 | Name | Description
Public method | LocalProviderConfiguration | Constructs a local provider configuration.
Public method | LocalProviderConfiguration(XmlElement) | Constructs a local provider configuration from XML.
Top
See Also

Reference

LocalProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalProviderConfiguration Constructor

Constructs a local provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalProviderConfiguration()
Public Sub New
public:
LocalProviderConfiguration()
new : unit -> LocalProviderConfiguration
See Also

Reference

LocalProviderConfiguration Class
LocalProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


LocalProviderConfiguration Constructor (XmlElement)

Constructs a local provider configuration from XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalProviderConfiguration(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
LocalProviderConfiguration(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> LocalProviderConfiguration

Parameters

xmlElement
Type: System.XmlXmlElement
The local provider configuration XML.
See Also

Reference

LocalProviderConfiguration Class
LocalProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


LocalProviderConfiguration Properties

The LocalProviderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Top
See Also

Reference

LocalProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalProviderConfiguration Methods

The LocalProviderConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the local provider configuration to XML. (Overrides ProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

LocalProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalProviderConfiguration.ToXml Method

LocalProviderConfigurationToXml Method

Serializes the local provider configuration to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    XmlElement xmlElement
)
Public Overrides Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
) override
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element.
See Also

Reference

LocalProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalServiceProviderConfiguration Class

The local service provider configuration specifies the configuration for the local service provider.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationProviderConfiguration
ComponentSpace.SAML2.ConfigurationLocalProviderConfiguration
ComponentSpace.SAML2.ConfigurationLocalServiceProviderConfiguration

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class LocalServiceProviderConfiguration : LocalProviderConfiguration
Public Class LocalServiceProviderConfiguration
    Inherits LocalProviderConfiguration
public ref class LocalServiceProviderConfiguration : public LocalProviderConfiguration
type LocalServiceProviderConfiguration =
    class
        inherit LocalProviderConfiguration
    end

The LocalServiceProviderConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | LocalServiceProviderConfiguration | Constructs a service provider configuration.
Public method | LocalServiceProviderConfiguration(XmlElement) | Constructs a service provider configuration from XML.
Top
Properties
 | Name | Description
Public property | AssertionConsumerServiceUrl | Gets or sets the service provider's assertion consumer service (ACS) URL. The assertion consumer service URL is the endpoint at which the SAML response is received.
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the service provider configuration to XML. (Overrides LocalProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


LocalServiceProviderConfiguration Constructor

Overload List
 | Name | Description
Public method | LocalServiceProviderConfiguration | Constructs a service provider configuration.
Public method | LocalServiceProviderConfiguration(XmlElement) | Constructs a service provider configuration from XML.
Top
See Also

Reference

LocalServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalServiceProviderConfiguration Constructor

Constructs a service provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalServiceProviderConfiguration()
Public Sub New
public:
LocalServiceProviderConfiguration()
new : unit -> LocalServiceProviderConfiguration
See Also

Reference

LocalServiceProviderConfiguration Class
LocalServiceProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


LocalServiceProviderConfiguration Constructor (XmlElement)

Constructs a service provider configuration from XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalServiceProviderConfiguration(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
LocalServiceProviderConfiguration(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> LocalServiceProviderConfiguration

Parameters

xmlElement
Type: System.XmlXmlElement
The service provider configuration XML.
See Also

Reference

LocalServiceProviderConfiguration Class
LocalServiceProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


LocalServiceProviderConfiguration Properties

The LocalServiceProviderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AssertionConsumerServiceUrl | Gets or sets the service provider's assertion consumer service (ACS) URL. The assertion consumer service URL is the endpoint at which the SAML response is received.
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Top
See Also

Reference

LocalServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalServiceProviderConfiguration.AssertionConsumerServiceUrl Property

LocalServiceProviderConfigurationAssertionConsumerServiceUrl Property

Gets or sets the service provider's assertion consumer service (ACS) URL.

The assertion consumer service URL is the endpoint at which the SAML response is received.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string AssertionConsumerServiceUrl { get; set; }
Public Property AssertionConsumerServiceUrl As String
    Get
    Set
public:
property String^ AssertionConsumerServiceUrl {
    String^ get ();
    void set (String^ value);
}
member AssertionConsumerServiceUrl : string with get, set

Property Value

Type: String
The service provider's assertion consumer service (ACS) URL.
See Also

Reference

LocalServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalServiceProviderConfiguration Methods

The LocalServiceProviderConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the service provider configuration to XML. (Overrides LocalProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

LocalServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


LocalServiceProviderConfiguration.ToXml Method

LocalServiceProviderConfigurationToXml Method

Serializes the service provider configuration to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    XmlElement xmlElement
)
Public Overrides Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
) override
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element.
See Also

Reference

LocalServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


MetadataExporter Class

Exports the SAML configuration as SAML metadata.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationMetadataExporter

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class MetadataExporter
Public NotInheritable Class MetadataExporter
public ref class MetadataExporter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MetadataExporter =  class end

The MetadataExporter type exposes the following members.

Methods
Name | Description
Export | Exports the SAML configuration and X.509 certificate as SAML metadata.
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


MetadataExporter Methods

The MetadataExporter type exposes the following members.

Methods
Name | Description
Export | Exports the SAML configuration and X.509 certificate as SAML metadata.
Top
See Also

Reference

MetadataExporter Class
ComponentSpace.SAML2.Configuration Namespace


MetadataExporter.Export Method

MetadataExporterExport Method

Exports the SAML configuration and X.509 certificate as SAML metadata.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static EntityDescriptor Export(
    SAMLConfiguration samlConfiguration,
    string partnerName
)
Public Shared Function Export (
    samlConfiguration As SAMLConfiguration,
    partnerName As String
) As EntityDescriptor
public:
static EntityDescriptor^ Export(
    SAMLConfiguration^ samlConfiguration,
    String^ partnerName
)
static member Export :
        samlConfiguration : SAMLConfiguration *
        partnerName : string -> EntityDescriptor

Parameters

samlConfiguration
Type: ComponentSpace.SAML2.ConfigurationSAMLConfiguration
The SAML configuration.
partnerName
Type: SystemString
The SAML configuration partner name.

Return Value

Type: EntityDescriptor
The SAML metadata entity descriptor.
See Also

Reference

MetadataExporter Class
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter Class

Imports SAML metadata into the SAML configuration.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationMetadataImporter

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class MetadataImporter
Public NotInheritable Class MetadataImporter
public ref class MetadataImporter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MetadataImporter =  class end

The MetadataImporter type exposes the following members.

Methods
Name | Description
Import(EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity and service provider metadata entities descriptor by updating the SAML configuration and retrieving the X.509 certificates.
Import(EntityDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity and service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
ImportCertificates(EntitiesDescriptor) | Imports the identity and service provider X.509 certificates.
ImportCertificates(EntityDescriptor) | Imports the identity and service provider X.509 certificates.
ImportIdentityProviderCertificates(EntitiesDescriptor) | Imports the identity provider X.509 certificates.
ImportIdentityProviderCertificates(EntityDescriptor) | Imports the identity provider X.509 certificates.
ImportIdentityProviders(EntitiesDescriptor) | Imports the SAML identity provider metadata entity descriptor.
ImportIdentityProviders(EntityDescriptor) | Imports the SAML identity provider metadata entity descriptor.
ImportIdentityProviders(EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
ImportIdentityProviders(EntityDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
ImportServiceProviderCertificates(EntitiesDescriptor) | Imports the service provider X.509 certificates.
ImportServiceProviderCertificates(EntityDescriptor) | Imports the service provider X.509 certificates.
ImportServiceProviders(EntitiesDescriptor) | Imports the SAML service provider metadata entity descriptor.
ImportServiceProviders(EntityDescriptor) | Imports the SAML service provider metadata entity descriptor.
ImportServiceProviders(EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
ImportServiceProviders(EntityDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
SaveCertificate | Saves the X.509 certificate to the specified file.
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


MetadataImporter Methods

The MetadataImporter type exposes the following members.

Methods
Name | Description
Import(EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity and service provider metadata entities descriptor by updating the SAML configuration and retrieving the X.509 certificates.
Import(EntityDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity and service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
ImportCertificates(EntitiesDescriptor) | Imports the identity and service provider X.509 certificates.
ImportCertificates(EntityDescriptor) | Imports the identity and service provider X.509 certificates.
ImportIdentityProviderCertificates(EntitiesDescriptor) | Imports the identity provider X.509 certificates.
ImportIdentityProviderCertificates(EntityDescriptor) | Imports the identity provider X.509 certificates.
ImportIdentityProviders(EntitiesDescriptor) | Imports the SAML identity provider metadata entity descriptor.
ImportIdentityProviders(EntityDescriptor) | Imports the SAML identity provider metadata entity descriptor.
ImportIdentityProviders(EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
ImportIdentityProviders(EntityDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
ImportServiceProviderCertificates(EntitiesDescriptor) | Imports the service provider X.509 certificates.
ImportServiceProviderCertificates(EntityDescriptor) | Imports the service provider X.509 certificates.
ImportServiceProviders(EntitiesDescriptor) | Imports the SAML service provider metadata entity descriptor.
ImportServiceProviders(EntityDescriptor) | Imports the SAML service provider metadata entity descriptor.
ImportServiceProviders(EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
ImportServiceProviders(EntityDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
SaveCertificate | Saves the X.509 certificate to the specified file.
Top
See Also

Reference

MetadataImporter Class
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.Import Method

MetadataImporterImport Method

Overload List
Name | Description
Import(EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity and service provider metadata entities descriptor by updating the SAML configuration and retrieving the X.509 certificates.
Import(EntityDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity and service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
Top
See Also

Reference

MetadataImporter Class
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.Import Method (EntitiesDescriptor, SAMLConfiguration, IList(X509Certificate2))

MetadataImporterImport Method (EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2)

Imports the SAML identity and service provider metadata entities descriptor by updating the SAML configuration and retrieving the X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Import(
    EntitiesDescriptor entitiesDescriptor,
    SAMLConfiguration samlConfiguration,
    IList<X509Certificate2> x509Certificates
)
Public Shared Sub Import (
    entitiesDescriptor As EntitiesDescriptor,
    samlConfiguration As SAMLConfiguration,
    x509Certificates As IList(Of X509Certificate2)
)
public:
static void Import(
    EntitiesDescriptor^ entitiesDescriptor,
    SAMLConfiguration^ samlConfiguration,
    IList<X509Certificate2^>^ x509Certificates
)
static member Import :
        entitiesDescriptor : EntitiesDescriptor *
        samlConfiguration : SAMLConfiguration *
        x509Certificates : IList<X509Certificate2> -> unit

Parameters

entitiesDescriptor
Type: ComponentSpace.SAML2.MetadataEntitiesDescriptor
The SAML metadata entities descriptor.
samlConfiguration
Type: ComponentSpace.SAML2.ConfigurationSAMLConfiguration
The SAML configuration to be updated.
x509Certificates
Type: System.Collections.GenericIList X509Certificate2
The list of X.509 certificates to be updated.
See Also

Reference

MetadataImporter Class
Import Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.Import Method (EntityDescriptor, SAMLConfiguration, IList(X509Certificate2))

MetadataImporterImport Method (EntityDescriptor, SAMLConfiguration, IListX509Certificate2)

Imports the SAML identity and service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Import(
    EntityDescriptor entityDescriptor,
    SAMLConfiguration samlConfiguration,
    IList<X509Certificate2> x509Certificates
)
Public Shared Sub Import (
    entityDescriptor As EntityDescriptor,
    samlConfiguration As SAMLConfiguration,
    x509Certificates As IList(Of X509Certificate2)
)
public:
static void Import(
    EntityDescriptor^ entityDescriptor,
    SAMLConfiguration^ samlConfiguration,
    IList<X509Certificate2^>^ x509Certificates
)
static member Import :
        entityDescriptor : EntityDescriptor *
        samlConfiguration : SAMLConfiguration *
        x509Certificates : IList<X509Certificate2> -> unit

Parameters

entityDescriptor
Type: ComponentSpace.SAML2.MetadataEntityDescriptor
The SAML metadata entity descriptor.
samlConfiguration
Type: ComponentSpace.SAML2.ConfigurationSAMLConfiguration
The SAML configuration to be updated.
x509Certificates
Type: System.Collections.GenericIList X509Certificate2
The list of X.509 certificates to be updated.
See Also

Reference

MetadataImporter Class
Import Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportCertificates Method

MetadataImporterImportCertificates Method

Overload List
Name | Description
ImportCertificates(EntitiesDescriptor) | Imports the identity and service provider X.509 certificates.
ImportCertificates(EntityDescriptor) | Imports the identity and service provider X.509 certificates.
Top
See Also

Reference

MetadataImporter Class
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportCertificates Method (EntitiesDescriptor)

MetadataImporterImportCertificates Method (EntitiesDescriptor)

Imports the identity and service provider X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<X509Certificate2> ImportCertificates(
    EntitiesDescriptor entitiesDescriptor
)
Public Shared Function ImportCertificates (
    entitiesDescriptor As EntitiesDescriptor
) As IList(Of X509Certificate2)
public:
static IList<X509Certificate2^>^ ImportCertificates(
    EntitiesDescriptor^ entitiesDescriptor
)
static member ImportCertificates :
        entitiesDescriptor : EntitiesDescriptor -> IList<X509Certificate2>

Parameters

entitiesDescriptor
Type: ComponentSpace.SAML2.MetadataEntitiesDescriptor
The SAML metadata entities descriptor.

Return Value

Type: IList X509Certificate2
The list of partner service provider X.509 certificates.
See Also

Reference

MetadataImporter Class
ImportCertificates Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportCertificates Method (EntityDescriptor)

MetadataImporterImportCertificates Method (EntityDescriptor)

Imports the identity and service provider X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<X509Certificate2> ImportCertificates(
    EntityDescriptor entityDescriptor
)
Public Shared Function ImportCertificates (
    entityDescriptor As EntityDescriptor
) As IList(Of X509Certificate2)
public:
static IList<X509Certificate2^>^ ImportCertificates(
    EntityDescriptor^ entityDescriptor
)
static member ImportCertificates :
        entityDescriptor : EntityDescriptor -> IList<X509Certificate2>

Parameters

entityDescriptor
Type: ComponentSpace.SAML2.MetadataEntityDescriptor
The SAML metadata entity descriptor.

Return Value

Type: IList X509Certificate2
The list of partner service provider X.509 certificates.
See Also

Reference

MetadataImporter Class
ImportCertificates Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportIdentityProviderCertificates Method

MetadataImporterImportIdentityProviderCertificates Method

Overload List
Name | Description
ImportIdentityProviderCertificates(EntitiesDescriptor) | Imports the identity provider X.509 certificates.
ImportIdentityProviderCertificates(EntityDescriptor) | Imports the identity provider X.509 certificates.
Top
See Also

Reference

MetadataImporter Class
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportIdentityProviderCertificates Method (EntitiesDescriptor)

MetadataImporterImportIdentityProviderCertificates Method (EntitiesDescriptor)

Imports the identity provider X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<X509Certificate2> ImportIdentityProviderCertificates(
    EntitiesDescriptor entitiesDescriptor
)
Public Shared Function ImportIdentityProviderCertificates (
    entitiesDescriptor As EntitiesDescriptor
) As IList(Of X509Certificate2)
public:
static IList<X509Certificate2^>^ ImportIdentityProviderCertificates(
    EntitiesDescriptor^ entitiesDescriptor
)
static member ImportIdentityProviderCertificates :
        entitiesDescriptor : EntitiesDescriptor -> IList<X509Certificate2>

Parameters

entitiesDescriptor
Type: ComponentSpace.SAML2.MetadataEntitiesDescriptor
The SAML metadata entities descriptor.

Return Value

Type: IList X509Certificate2
The list of partner identity provider X.509 certificates.
See Also

Reference

MetadataImporter Class
ImportIdentityProviderCertificates Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportIdentityProviderCertificates Method (EntityDescriptor)

MetadataImporterImportIdentityProviderCertificates Method (EntityDescriptor)

Imports the identity provider X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<X509Certificate2> ImportIdentityProviderCertificates(
    EntityDescriptor entityDescriptor
)
Public Shared Function ImportIdentityProviderCertificates (
    entityDescriptor As EntityDescriptor
) As IList(Of X509Certificate2)
public:
static IList<X509Certificate2^>^ ImportIdentityProviderCertificates(
    EntityDescriptor^ entityDescriptor
)
static member ImportIdentityProviderCertificates :
        entityDescriptor : EntityDescriptor -> IList<X509Certificate2>

Parameters

entityDescriptor
Type: ComponentSpace.SAML2.MetadataEntityDescriptor
The SAML metadata entity descriptor.

Return Value

Type: IList X509Certificate2
The list of partner identity provider X.509 certificates.
See Also

Reference

MetadataImporter Class
ImportIdentityProviderCertificates Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportIdentityProviders Method

MetadataImporterImportIdentityProviders Method

Overload List
Name | Description
ImportIdentityProviders(EntitiesDescriptor) | Imports the SAML identity provider metadata entity descriptor.
ImportIdentityProviders(EntityDescriptor) | Imports the SAML identity provider metadata entity descriptor.
ImportIdentityProviders(EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
ImportIdentityProviders(EntityDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML identity provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
Top
See Also

Reference

MetadataImporter Class
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportIdentityProviders Method (EntitiesDescriptor)

MetadataImporterImportIdentityProviders Method (EntitiesDescriptor)

Imports the SAML identity provider metadata entity descriptor.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<PartnerIdentityProviderConfiguration> ImportIdentityProviders(
    EntitiesDescriptor entitiesDescriptor
)
Public Shared Function ImportIdentityProviders (
    entitiesDescriptor As EntitiesDescriptor
) As IList(Of PartnerIdentityProviderConfiguration)
public:
static IList<PartnerIdentityProviderConfiguration^>^ ImportIdentityProviders(
    EntitiesDescriptor^ entitiesDescriptor
)
static member ImportIdentityProviders :
        entitiesDescriptor : EntitiesDescriptor -> IList<PartnerIdentityProviderConfiguration>

Parameters

entitiesDescriptor
Type: ComponentSpace.SAML2.MetadataEntitiesDescriptor
The SAML metadata entities descriptor.

Return Value

Type: IList PartnerIdentityProviderConfiguration
The list of partner identity provider configurations.
See Also

Reference

MetadataImporter Class
ImportIdentityProviders Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportIdentityProviders Method (EntityDescriptor)

MetadataImporterImportIdentityProviders Method (EntityDescriptor)

Imports the SAML identity provider metadata entity descriptor.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<PartnerIdentityProviderConfiguration> ImportIdentityProviders(
    EntityDescriptor entityDescriptor
)
Public Shared Function ImportIdentityProviders (
    entityDescriptor As EntityDescriptor
) As IList(Of PartnerIdentityProviderConfiguration)
public:
static IList<PartnerIdentityProviderConfiguration^>^ ImportIdentityProviders(
    EntityDescriptor^ entityDescriptor
)
static member ImportIdentityProviders :
        entityDescriptor : EntityDescriptor -> IList<PartnerIdentityProviderConfiguration>

Parameters

entityDescriptor
Type: ComponentSpace.SAML2.MetadataEntityDescriptor
The SAML metadata entity descriptor.

Return Value

Type: IList PartnerIdentityProviderConfiguration
The list of partner identity provider configurations.
See Also

Reference

MetadataImporter Class
ImportIdentityProviders Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportIdentityProviders Method (EntitiesDescriptor, SAMLConfiguration, IList(X509Certificate2))

MetadataImporterImportIdentityProviders Method (EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2)

Imports the SAML identity provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ImportIdentityProviders(
    EntitiesDescriptor entitiesDescriptor,
    SAMLConfiguration samlConfiguration,
    IList<X509Certificate2> x509Certificates
)
Public Shared Sub ImportIdentityProviders (
    entitiesDescriptor As EntitiesDescriptor,
    samlConfiguration As SAMLConfiguration,
    x509Certificates As IList(Of X509Certificate2)
)
public:
static void ImportIdentityProviders(
    EntitiesDescriptor^ entitiesDescriptor,
    SAMLConfiguration^ samlConfiguration,
    IList<X509Certificate2^>^ x509Certificates
)
static member ImportIdentityProviders :
        entitiesDescriptor : EntitiesDescriptor *
        samlConfiguration : SAMLConfiguration *
        x509Certificates : IList<X509Certificate2> -> unit

Parameters

entitiesDescriptor
Type: ComponentSpace.SAML2.MetadataEntitiesDescriptor
The SAML metadata entities descriptor.
samlConfiguration
Type: ComponentSpace.SAML2.ConfigurationSAMLConfiguration
The SAML configuration to be updated.
x509Certificates
Type: System.Collections.GenericIList X509Certificate2
The list of X.509 certificates to be updated.
See Also

Reference

MetadataImporter Class
ImportIdentityProviders Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportIdentityProviders Method (EntityDescriptor, SAMLConfiguration, IList(X509Certificate2))

MetadataImporterImportIdentityProviders Method (EntityDescriptor, SAMLConfiguration, IListX509Certificate2)

Imports the SAML identity provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ImportIdentityProviders(
    EntityDescriptor entityDescriptor,
    SAMLConfiguration samlConfiguration,
    IList<X509Certificate2> x509Certificates
)
Public Shared Sub ImportIdentityProviders (
    entityDescriptor As EntityDescriptor,
    samlConfiguration As SAMLConfiguration,
    x509Certificates As IList(Of X509Certificate2)
)
public:
static void ImportIdentityProviders(
    EntityDescriptor^ entityDescriptor,
    SAMLConfiguration^ samlConfiguration,
    IList<X509Certificate2^>^ x509Certificates
)
static member ImportIdentityProviders :
        entityDescriptor : EntityDescriptor *
        samlConfiguration : SAMLConfiguration *
        x509Certificates : IList<X509Certificate2> -> unit

Parameters

entityDescriptor
Type: ComponentSpace.SAML2.MetadataEntityDescriptor
The SAML metadata entity descriptor.
samlConfiguration
Type: ComponentSpace.SAML2.ConfigurationSAMLConfiguration
The SAML configuration to be updated.
x509Certificates
Type: System.Collections.GenericIList X509Certificate2
The list of X.509 certificates to be updated.
See Also

Reference

MetadataImporter Class
ImportIdentityProviders Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportServiceProviderCertificates Method

MetadataImporterImportServiceProviderCertificates Method

Overload List
Name | Description
ImportServiceProviderCertificates(EntitiesDescriptor) | Imports the service provider X.509 certificates.
ImportServiceProviderCertificates(EntityDescriptor) | Imports the service provider X.509 certificates.
Top
See Also

Reference

MetadataImporter Class
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportServiceProviderCertificates Method (EntitiesDescriptor)

MetadataImporterImportServiceProviderCertificates Method (EntitiesDescriptor)

Imports the service provider X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<X509Certificate2> ImportServiceProviderCertificates(
    EntitiesDescriptor entitiesDescriptor
)
Public Shared Function ImportServiceProviderCertificates (
    entitiesDescriptor As EntitiesDescriptor
) As IList(Of X509Certificate2)
public:
static IList<X509Certificate2^>^ ImportServiceProviderCertificates(
    EntitiesDescriptor^ entitiesDescriptor
)
static member ImportServiceProviderCertificates :
        entitiesDescriptor : EntitiesDescriptor -> IList<X509Certificate2>

Parameters

entitiesDescriptor
Type: ComponentSpace.SAML2.MetadataEntitiesDescriptor
The SAML metadata entities descriptor.

Return Value

Type: IList X509Certificate2
The list of partner service provider X.509 certificates.
See Also

Reference

MetadataImporter Class
ImportServiceProviderCertificates Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportServiceProviderCertificates Method (EntityDescriptor)

MetadataImporterImportServiceProviderCertificates Method (EntityDescriptor)

Imports the service provider X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<X509Certificate2> ImportServiceProviderCertificates(
    EntityDescriptor entityDescriptor
)
Public Shared Function ImportServiceProviderCertificates (
    entityDescriptor As EntityDescriptor
) As IList(Of X509Certificate2)
public:
static IList<X509Certificate2^>^ ImportServiceProviderCertificates(
    EntityDescriptor^ entityDescriptor
)
static member ImportServiceProviderCertificates :
        entityDescriptor : EntityDescriptor -> IList<X509Certificate2>

Parameters

entityDescriptor
Type: ComponentSpace.SAML2.MetadataEntityDescriptor
The SAML metadata entity descriptor.

Return Value

Type: IList X509Certificate2
The list of partner service provider X.509 certificates.
See Also

Reference

MetadataImporter Class
ImportServiceProviderCertificates Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportServiceProviders Method

MetadataImporterImportServiceProviders Method

Overload List
Name | Description
ImportServiceProviders(EntitiesDescriptor) | Imports the SAML service provider metadata entity descriptor.
ImportServiceProviders(EntityDescriptor) | Imports the SAML service provider metadata entity descriptor.
ImportServiceProviders(EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
ImportServiceProviders(EntityDescriptor, SAMLConfiguration, IListX509Certificate2) | Imports the SAML service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.
Top
See Also

Reference

MetadataImporter Class
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportServiceProviders Method (EntitiesDescriptor)

MetadataImporterImportServiceProviders Method (EntitiesDescriptor)

Imports the SAML service provider metadata entity descriptor.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<PartnerServiceProviderConfiguration> ImportServiceProviders(
    EntitiesDescriptor entitiesDescriptor
)
Public Shared Function ImportServiceProviders (
    entitiesDescriptor As EntitiesDescriptor
) As IList(Of PartnerServiceProviderConfiguration)
public:
static IList<PartnerServiceProviderConfiguration^>^ ImportServiceProviders(
    EntitiesDescriptor^ entitiesDescriptor
)
static member ImportServiceProviders :
        entitiesDescriptor : EntitiesDescriptor -> IList<PartnerServiceProviderConfiguration>

Parameters

entitiesDescriptor
Type: ComponentSpace.SAML2.MetadataEntitiesDescriptor
The SAML metadata entities descriptor.

Return Value

Type: IList PartnerServiceProviderConfiguration
The list of partner service provider configurations.
See Also

Reference

MetadataImporter Class
ImportServiceProviders Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportServiceProviders Method (EntityDescriptor)

MetadataImporterImportServiceProviders Method (EntityDescriptor)

Imports the SAML service provider metadata entity descriptor.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static IList<PartnerServiceProviderConfiguration> ImportServiceProviders(
    EntityDescriptor entityDescriptor
)
Public Shared Function ImportServiceProviders (
    entityDescriptor As EntityDescriptor
) As IList(Of PartnerServiceProviderConfiguration)
public:
static IList<PartnerServiceProviderConfiguration^>^ ImportServiceProviders(
    EntityDescriptor^ entityDescriptor
)
static member ImportServiceProviders :
        entityDescriptor : EntityDescriptor -> IList<PartnerServiceProviderConfiguration>

Parameters

entityDescriptor
Type: ComponentSpace.SAML2.MetadataEntityDescriptor
The SAML metadata entity descriptor.

Return Value

Type: IList PartnerServiceProviderConfiguration
The list of partner service provider configurations.
See Also

Reference

MetadataImporter Class
ImportServiceProviders Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportServiceProviders Method (EntitiesDescriptor, SAMLConfiguration, IList(X509Certificate2))

MetadataImporterImportServiceProviders Method (EntitiesDescriptor, SAMLConfiguration, IListX509Certificate2)

Imports the SAML service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ImportServiceProviders(
    EntitiesDescriptor entitiesDescriptor,
    SAMLConfiguration samlConfiguration,
    IList<X509Certificate2> x509Certificates
)
Public Shared Sub ImportServiceProviders (
    entitiesDescriptor As EntitiesDescriptor,
    samlConfiguration As SAMLConfiguration,
    x509Certificates As IList(Of X509Certificate2)
)
public:
static void ImportServiceProviders(
    EntitiesDescriptor^ entitiesDescriptor,
    SAMLConfiguration^ samlConfiguration,
    IList<X509Certificate2^>^ x509Certificates
)
static member ImportServiceProviders :
        entitiesDescriptor : EntitiesDescriptor *
        samlConfiguration : SAMLConfiguration *
        x509Certificates : IList<X509Certificate2> -> unit

Parameters

entitiesDescriptor
Type: ComponentSpace.SAML2.MetadataEntitiesDescriptor
The SAML metadata entities descriptor.
samlConfiguration
Type: ComponentSpace.SAML2.ConfigurationSAMLConfiguration
The SAML configuration to be updated.
x509Certificates
Type: System.Collections.GenericIList X509Certificate2
The list of X.509 certificates to be updated.
See Also

Reference

MetadataImporter Class
ImportServiceProviders Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.ImportServiceProviders Method (EntityDescriptor, SAMLConfiguration, IList(X509Certificate2))

MetadataImporterImportServiceProviders Method (EntityDescriptor, SAMLConfiguration, IListX509Certificate2)

Imports the SAML service provider metadata entity descriptor by updating the SAML configuration and retrieving the X.509 certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ImportServiceProviders(
    EntityDescriptor entityDescriptor,
    SAMLConfiguration samlConfiguration,
    IList<X509Certificate2> x509Certificates
)
Public Shared Sub ImportServiceProviders (
    entityDescriptor As EntityDescriptor,
    samlConfiguration As SAMLConfiguration,
    x509Certificates As IList(Of X509Certificate2)
)
public:
static void ImportServiceProviders(
    EntityDescriptor^ entityDescriptor,
    SAMLConfiguration^ samlConfiguration,
    IList<X509Certificate2^>^ x509Certificates
)
static member ImportServiceProviders :
        entityDescriptor : EntityDescriptor *
        samlConfiguration : SAMLConfiguration *
        x509Certificates : IList<X509Certificate2> -> unit

Parameters

entityDescriptor
Type: ComponentSpace.SAML2.MetadataEntityDescriptor
The SAML metadata entity descriptor.
samlConfiguration
Type: ComponentSpace.SAML2.ConfigurationSAMLConfiguration
The SAML configuration to be updated.
x509Certificates
Type: System.Collections.GenericIList X509Certificate2
The list of X.509 certificates to be updated.
See Also

Reference

MetadataImporter Class
ImportServiceProviders Overload
ComponentSpace.SAML2.Configuration Namespace


MetadataImporter.SaveCertificate Method

MetadataImporterSaveCertificate Method

Saves the X.509 certificate to the specified file.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SaveCertificate(
    X509Certificate2 x509Certificate,
    string fileName
)
Public Shared Sub SaveCertificate (
    x509Certificate As X509Certificate2,
    fileName As String
)
public:
static void SaveCertificate(
    X509Certificate2^ x509Certificate,
    String^ fileName
)
static member SaveCertificate :
        x509Certificate : X509Certificate2 *
        fileName : string -> unit

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate.
fileName
Type: SystemString
The file name.
See Also

Reference

MetadataImporter Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration Class

The partner identity provider configuration specifies the configuration for the partner identity provider.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationProviderConfiguration
ComponentSpace.SAML2.ConfigurationPartnerProviderConfiguration
ComponentSpace.SAML2.ConfigurationPartnerIdentityProviderConfiguration

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class PartnerIdentityProviderConfiguration : PartnerProviderConfiguration
Public Class PartnerIdentityProviderConfiguration
    Inherits PartnerProviderConfiguration
public ref class PartnerIdentityProviderConfiguration : public PartnerProviderConfiguration
type PartnerIdentityProviderConfiguration =
    class
        inherit PartnerProviderConfiguration
    end

The PartnerIdentityProviderConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | PartnerIdentityProviderConfiguration | Constructs a partner identity provider configuration.
Public method | PartnerIdentityProviderConfiguration(XmlElement) | Constructs a partner identity provider configuration from XML.
Top
Properties
 | Name | Description
Public property | AuthnContext | Gets or sets the authentication context. (Inherited from PartnerProviderConfiguration.)
Public property | ClockSkew | Gets or sets the clock skew. The clock skew allows for differences between local and partner computer clocks when checking time intervals. The default time span is 3 minutes. (Inherited from PartnerProviderConfiguration.)
Public property | DataEncryptionMethod | Gets or sets the XML encryption data encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#aes128-cbc. (Inherited from PartnerProviderConfiguration.)
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | DigestMethod | Gets or sets the XML signature digest algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#sha256. (Inherited from PartnerProviderConfiguration.)
Public property | DisableAssertionReplayCheck | Gets or sets the flag indicating whether to check for assertion replay.
Public property | DisableAudienceRestrictionCheck | Gets or sets the flag indicating whether the audience restriction condition is checked.
Public property | DisableAuthnContextCheck | Gets or sets the flag indicating whether the authn context is checked.
Public property | DisableDestinationCheck | Gets or sets the flag indicating whether the destination is checked. (Inherited from PartnerProviderConfiguration.)
Public property | DisableInboundLogout | Gets or sets the flag indicating whether to disable inbound logout. (Inherited from PartnerProviderConfiguration.)
Public property | DisableInResponseToCheck | Gets or sets the flag indicating whether the InResponseTo is checked. (Inherited from PartnerProviderConfiguration.)
Public property | DisableOutboundLogout | Gets or sets the flag indicating whether to disable outbound logout. (Inherited from PartnerProviderConfiguration.)
Public property | DisablePendingLogoutCheck | Gets or sets the flag indicating whether a logout is pending is checked. (Inherited from PartnerProviderConfiguration.)
Public property | DisableRecipientCheck | Gets or sets the flag indicating whether the SAML recipient is checked.
Public property | DisableTimePeriodCheck | Gets or sets the flag indicating whether the not-before/not-on-or-after time period is checked.
Public property | ForceAuthn | Gets or sets the flag indicating whether to set the force authentication attribute in authn requests.
Public property | IssuerFormat | Gets or sets the issuer format. The default issuer format is not explicitly specified. (Inherited from PartnerProviderConfiguration.)
Public property | KeyEncryptionMethod | Gets or sets the XML encryption key encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#rsa-1_5. (Inherited from PartnerProviderConfiguration.)
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | LogoutRequestLifeTime | Gets or sets the logout request lifetime. The default time span is 3 minutes. (Inherited from PartnerProviderConfiguration.)
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | NameIDFormat | Gets or sets the name identifier format. The default name identifier format is urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified. (Inherited from PartnerProviderConfiguration.)
Public property | OverridePendingAuthnRequest | Gets or sets the flag indicating whether a pending authentication request may be overridden and an IdP-initiated SAML response received. If a service provider sends an authentication request then it expects the SAML response it receives to come from the identity provider it sent the authentication request to and that the SAML response is in response to this authentication request. If a different identity provider sends a SAML response or the expected identity provider sends a SAML response but it is not in response to this authentication request, this is treated as an error if this flag is false. If this flag is true then these restrictions do not apply. Setting this flag to true supports an SP-initiated SSO flow being supplanted by an IdP-initiated SSO.
Public property | PartnerCertificateFile | Gets or sets the partner certificate file path. The file path is either absolute or relative to the application folder. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateSerialNumber | Gets or sets the partner certificate serial number. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateStoreLocation | Gets or sets the partner certificate store location. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateSubject | Gets or sets the partner certificate subject. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateThumbprint | Gets or sets the partner certificate thumbprint. (Inherited from PartnerProviderConfiguration.)
Public property | ProviderName | Gets or sets the optional provider name to include in the authn request.
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | SecondaryPartnerCertificateFile | Gets or sets the secondary partner certificate file path. The file path is either absolute or relative to the application folder. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateSerialNumber | Gets or sets the secondary partner certificate serial number. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateStoreLocation | Gets or sets the secondary partner certificate store location. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateSubject | Gets or sets the secondary partner certificate subject. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateThumbprint | Gets or sets the secondary partner certificate thumbprint. (Inherited from PartnerProviderConfiguration.)
Public property | SignatureMethod | Gets or sets the XML signature algorithm. The default algorithm is http://www.w3.org/2001/04/xmldsig-more#rsa-sha256. (Inherited from PartnerProviderConfiguration.)
Public property | SignAuthnRequest | Gets or sets the flag indicating whether to sign authn requests.
Public property | SignLogoutRequest | Gets or sets the flag indicating whether to sign sent logout responses. (Inherited from PartnerProviderConfiguration.)
Public property | SignLogoutResponse | Gets or sets the flag indicating whether to sign sent logout responses. (Inherited from PartnerProviderConfiguration.)
Public property | SingleLogoutServiceBinding | Gets or sets the partner provider's single sign-on service binding. The default binding is urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect. (Inherited from PartnerProviderConfiguration.)
Public property | SingleLogoutServiceResponseUrl | Gets or sets the partner provider's single sign-on service response URL. (Inherited from PartnerProviderConfiguration.)
Public property | SingleLogoutServiceUrl | Gets or sets the partner provider's single sign-on service URL. (Inherited from PartnerProviderConfiguration.)
Public property | SingleSignOnServiceBinding | Gets or sets the partner identity provider's single sign-on service binding. The default binding is urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect.
Public property | SingleSignOnServiceUrl | Gets or sets the partner identity provider's single sign-on service URL.
Public property | UseEmbeddedCertificate | Gets or sets the flag to indicate whether to use embedded certificates. (Inherited from PartnerProviderConfiguration.)
Public property | WantAssertionEncrypted | Gets or sets the flag indicating whether SAML assertions should be encrypted.
Public property | WantAssertionSigned | Gets or sets the flag indicating whether SAML assertions should be signed.
Public property | WantDigestMethod | Gets or sets the XML signature digest algorithm expected from the partner provider. If not specified then any algorithm is accepted. (Inherited from PartnerProviderConfiguration.)
Public property | WantLogoutRequestSigned | Gets or sets the flag indicating whether received logout requests should be signed. (Inherited from PartnerProviderConfiguration.)
Public property | WantLogoutResponseSigned | Gets or sets the flag indicating whether received logout responses should be signed. (Inherited from PartnerProviderConfiguration.)
Public property | WantSAMLResponseSigned | Gets or sets the flag indicating whether SAML responses should be signed.
Public property | WantSignatureMethod | Gets or sets the XML signature algorithm expected from the partner provider. If not specified then any algorithm is accepted. (Inherited from PartnerProviderConfiguration.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the partner identity provider configuration to XML. (Overrides PartnerProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration Constructor

Overload List
 | Name | Description
Public method | PartnerIdentityProviderConfiguration | Constructs a partner identity provider configuration.
Public method | PartnerIdentityProviderConfiguration(XmlElement) | Constructs a partner identity provider configuration from XML.
Top
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration Constructor

Constructs a partner identity provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public PartnerIdentityProviderConfiguration()
Public Sub New
public:
PartnerIdentityProviderConfiguration()
new : unit -> PartnerIdentityProviderConfiguration
See Also

Reference

PartnerIdentityProviderConfiguration Class
PartnerIdentityProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration Constructor (XmlElement)

Constructs a partner identity provider configuration from XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public PartnerIdentityProviderConfiguration(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
PartnerIdentityProviderConfiguration(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> PartnerIdentityProviderConfiguration

Parameters

xmlElement
Type: System.XmlXmlElement
The partner identity provider configuration XML.
See Also

Reference

PartnerIdentityProviderConfiguration Class
PartnerIdentityProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration Properties

The PartnerIdentityProviderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AuthnContext | Gets or sets the authentication context. (Inherited from PartnerProviderConfiguration.)
Public property | ClockSkew | Gets or sets the clock skew. The clock skew allows for differences between local and partner computer clocks when checking time intervals. The default time span is 3 minutes. (Inherited from PartnerProviderConfiguration.)
Public property | DataEncryptionMethod | Gets or sets the XML encryption data encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#aes128-cbc. (Inherited from PartnerProviderConfiguration.)
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | DigestMethod | Gets or sets the XML signature digest algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#sha256. (Inherited from PartnerProviderConfiguration.)
Public property | DisableAssertionReplayCheck | Gets or sets the flag indicating whether to check for assertion replay.
Public property | DisableAudienceRestrictionCheck | Gets or sets the flag indicating whether the audience restriction condition is checked.
Public property | DisableAuthnContextCheck | Gets or sets the flag indicating whether the authn context is checked.
Public property | DisableDestinationCheck | Gets or sets the flag indicating whether the destination is checked. (Inherited from PartnerProviderConfiguration.)
Public property | DisableInboundLogout | Gets or sets the flag indicating whether to disable inbound logout. (Inherited from PartnerProviderConfiguration.)
Public property | DisableInResponseToCheck | Gets or sets the flag indicating whether the InResponseTo is checked. (Inherited from PartnerProviderConfiguration.)
Public property | DisableOutboundLogout | Gets or sets the flag indicating whether to disable outbound logout. (Inherited from PartnerProviderConfiguration.)
Public property | DisablePendingLogoutCheck | Gets or sets the flag indicating whether a logout is pending is checked. (Inherited from PartnerProviderConfiguration.)
Public property | DisableRecipientCheck | Gets or sets the flag indicating whether the SAML recipient is checked.
Public property | DisableTimePeriodCheck | Gets or sets the flag indicating whether the not-before/not-on-or-after time period is checked.
Public property | ForceAuthn | Gets or sets the flag indicating whether to set the force authentication attribute in authn requests.
Public property | IssuerFormat | Gets or sets the issuer format. The default issuer format is not explicitly specified. (Inherited from PartnerProviderConfiguration.)
Public property | KeyEncryptionMethod | Gets or sets the XML encryption key encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#rsa-1_5. (Inherited from PartnerProviderConfiguration.)
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | LogoutRequestLifeTime | Gets or sets the logout request lifetime. The default time span is 3 minutes. (Inherited from PartnerProviderConfiguration.)
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | NameIDFormat | Gets or sets the name identifier format. The default name identifier format is urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified. (Inherited from PartnerProviderConfiguration.)
Public property | OverridePendingAuthnRequest | Gets or sets the flag indicating whether a pending authentication request may be overridden and an IdP-initiated SAML response received. If a service provider sends an authentication request then it expects the SAML response it receives to come from the identity provider it sent the authentication request to and that the SAML response is in response to this authentication request. If a different identity provider sends a SAML response or the expected identity provider sends a SAML response but it is not in response to this authentication request, this is treated as an error if this flag is false. If this flag is true then these restrictions do not apply. Setting this flag to true supports an SP-initiated SSO flow being supplanted by an IdP-initiated SSO.
Public property | PartnerCertificateFile | Gets or sets the partner certificate file path. The file path is either absolute or relative to the application folder. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateSerialNumber | Gets or sets the partner certificate serial number. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateStoreLocation | Gets or sets the partner certificate store location. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateSubject | Gets or sets the partner certificate subject. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateThumbprint | Gets or sets the partner certificate thumbprint. (Inherited from PartnerProviderConfiguration.)
Public property | ProviderName | Gets or sets the optional provider name to include in the authn request.
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | SecondaryPartnerCertificateFile | Gets or sets the secondary partner certificate file path. The file path is either absolute or relative to the application folder. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateSerialNumber | Gets or sets the secondary partner certificate serial number. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateStoreLocation | Gets or sets the secondary partner certificate store location. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateSubject | Gets or sets the secondary partner certificate subject. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateThumbprint | Gets or sets the secondary partner certificate thumbprint. (Inherited from PartnerProviderConfiguration.)
Public property | SignatureMethod | Gets or sets the XML signature algorithm. The default algorithm is http://www.w3.org/2001/04/xmldsig-more#rsa-sha256. (Inherited from PartnerProviderConfiguration.)
Public property | SignAuthnRequest | Gets or sets the flag indicating whether to sign authn requests.
Public property | SignLogoutRequest | Gets or sets the flag indicating whether to sign sent logout responses. (Inherited from PartnerProviderConfiguration.)
Public property | SignLogoutResponse | Gets or sets the flag indicating whether to sign sent logout responses. (Inherited from PartnerProviderConfiguration.)
Public property | SingleLogoutServiceBinding | Gets or sets the partner provider's single sign-on service binding. The default binding is urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect. (Inherited from PartnerProviderConfiguration.)
Public property | SingleLogoutServiceResponseUrl | Gets or sets the partner provider's single sign-on service response URL. (Inherited from PartnerProviderConfiguration.)
Public property | SingleLogoutServiceUrl | Gets or sets the partner provider's single sign-on service URL. (Inherited from PartnerProviderConfiguration.)
Public property | SingleSignOnServiceBinding | Gets or sets the partner identity provider's single sign-on service binding. The default binding is urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect.
Public property | SingleSignOnServiceUrl | Gets or sets the partner identity provider's single sign-on service URL.
Public property | UseEmbeddedCertificate | Gets or sets the flag to indicate whether to use embedded certificates. (Inherited from PartnerProviderConfiguration.)
Public property | WantAssertionEncrypted | Gets or sets the flag indicating whether SAML assertions should be encrypted.
Public property | WantAssertionSigned | Gets or sets the flag indicating whether SAML assertions should be signed.
Public property | WantDigestMethod | Gets or sets the XML signature digest algorithm expected from the partner provider. If not specified then any algorithm is accepted. (Inherited from PartnerProviderConfiguration.)
Public property | WantLogoutRequestSigned | Gets or sets the flag indicating whether received logout requests should be signed. (Inherited from PartnerProviderConfiguration.)
Public property | WantLogoutResponseSigned | Gets or sets the flag indicating whether received logout responses should be signed. (Inherited from PartnerProviderConfiguration.)
Public property | WantSAMLResponseSigned | Gets or sets the flag indicating whether SAML responses should be signed.
Public property | WantSignatureMethod | Gets or sets the XML signature algorithm expected from the partner provider. If not specified then any algorithm is accepted. (Inherited from PartnerProviderConfiguration.)
Top
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.DisableAssertionReplayCheck Property

PartnerIdentityProviderConfigurationDisableAssertionReplayCheck Property

Gets or sets the flag indicating whether to check for assertion replay.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DisableAssertionReplayCheck { get; set; }
Public Property DisableAssertionReplayCheck As Boolean
    Get
    Set
public:
property bool DisableAssertionReplayCheck {
    bool get ();
    void set (bool value);
}
member DisableAssertionReplayCheck : bool with get, set

Property Value

Type: Boolean
The flag indicating whether to check for assertion replay.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.DisableAudienceRestrictionCheck Property

PartnerIdentityProviderConfigurationDisableAudienceRestrictionCheck Property

Gets or sets the flag indicating whether the audience restriction condition is checked.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DisableAudienceRestrictionCheck { get; set; }
Public Property DisableAudienceRestrictionCheck As Boolean
    Get
    Set
public:
property bool DisableAudienceRestrictionCheck {
    bool get ();
    void set (bool value);
}
member DisableAudienceRestrictionCheck : bool with get, set

Property Value

Type: Boolean
The flag indicating whether the audience restriction condition is checked.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.DisableAuthnContextCheck Property

PartnerIdentityProviderConfigurationDisableAuthnContextCheck Property

Gets or sets the flag indicating whether the authn context is checked.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DisableAuthnContextCheck { get; set; }
Public Property DisableAuthnContextCheck As Boolean
    Get
    Set
public:
property bool DisableAuthnContextCheck {
    bool get ();
    void set (bool value);
}
member DisableAuthnContextCheck : bool with get, set

Property Value

Type: Boolean
The flag indicating whether the authn context is checked.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.DisableRecipientCheck Property

PartnerIdentityProviderConfigurationDisableRecipientCheck Property

Gets or sets the flag indicating whether the SAML recipient is checked.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DisableRecipientCheck { get; set; }
Public Property DisableRecipientCheck As Boolean
    Get
    Set
public:
property bool DisableRecipientCheck {
    bool get ();
    void set (bool value);
}
member DisableRecipientCheck : bool with get, set

Property Value

Type: Boolean
The flag indicating whether the SAML recipient is checked.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.DisableTimePeriodCheck Property

PartnerIdentityProviderConfigurationDisableTimePeriodCheck Property

Gets or sets the flag indicating whether the not-before/not-on-or-after time period is checked.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DisableTimePeriodCheck { get; set; }
Public Property DisableTimePeriodCheck As Boolean
    Get
    Set
public:
property bool DisableTimePeriodCheck {
    bool get ();
    void set (bool value);
}
member DisableTimePeriodCheck : bool with get, set

Property Value

Type: Boolean
The flag indicating whether the not-before/not-on-or-after time period is checked.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.ForceAuthn Property

PartnerIdentityProviderConfigurationForceAuthn Property

Gets or sets the flag indicating whether to set the force authentication attribute in authn requests.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool ForceAuthn { get; set; }
Public Property ForceAuthn As Boolean
    Get
    Set
public:
property bool ForceAuthn {
    bool get ();
    void set (bool value);
}
member ForceAuthn : bool with get, set

Property Value

Type: Boolean
The flag indicating whether to set the force authentication attribute in authn requests.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.OverridePendingAuthnRequest Property

PartnerIdentityProviderConfigurationOverridePendingAuthnRequest Property

Gets or sets the flag indicating whether a pending authentication request may be overridden and an IdP-initiated SAML response received.

If a service provider sends an authentication request then it expects the SAML response it receives to come from the identity provider it sent the authentication request to and that the SAML response is in response to this authentication request. If a different identity provider sends a SAML response or the expected identity provider sends a SAML response but it is not in response to this authentication request, this is treated as an error if this flag is false. If this flag is true then these restrictions do not apply.

Setting this flag to true supports an SP-initiated SSO flow being supplanted by an IdP-initiated SSO.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool OverridePendingAuthnRequest { get; set; }
Public Property OverridePendingAuthnRequest As Boolean
    Get
    Set
public:
property bool OverridePendingAuthnRequest {
    bool get ();
    void set (bool value);
}
member OverridePendingAuthnRequest : bool with get, set

Property Value

Type: Boolean
The flag indicating whether a pending authentication request may be overridden.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.ProviderName Property

PartnerIdentityProviderConfigurationProviderName Property

Gets or sets the optional provider name to include in the authn request.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ProviderName { get; set; }
Public Property ProviderName As String
    Get
    Set
public:
property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
member ProviderName : string with get, set

Property Value

Type: String
The optional provider name to include in the authn request.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.SignAuthnRequest Property

PartnerIdentityProviderConfigurationSignAuthnRequest Property

Gets or sets the flag indicating whether to sign authn requests.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool SignAuthnRequest { get; set; }
Public Property SignAuthnRequest As Boolean
    Get
    Set
public:
property bool SignAuthnRequest {
    bool get ();
    void set (bool value);
}
member SignAuthnRequest : bool with get, set

Property Value

Type: Boolean
The flag indicating whether to sign authn requests.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.SingleSignOnServiceBinding Property

PartnerIdentityProviderConfigurationSingleSignOnServiceBinding Property

Gets or sets the partner identity provider's single sign-on service binding.

The default binding is urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SingleSignOnServiceBinding { get; set; }
Public Property SingleSignOnServiceBinding As String
    Get
    Set
public:
property String^ SingleSignOnServiceBinding {
    String^ get ();
    void set (String^ value);
}
member SingleSignOnServiceBinding : string with get, set

Property Value

Type: String
The partner identity provider's single sign-on service binding.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.SingleSignOnServiceUrl Property

PartnerIdentityProviderConfigurationSingleSignOnServiceUrl Property

Gets or sets the partner identity provider's single sign-on service URL.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SingleSignOnServiceUrl { get; set; }
Public Property SingleSignOnServiceUrl As String
    Get
    Set
public:
property String^ SingleSignOnServiceUrl {
    String^ get ();
    void set (String^ value);
}
member SingleSignOnServiceUrl : string with get, set

Property Value

Type: String
The partner identity provider's single sign-on service URL.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.WantAssertionEncrypted Property

PartnerIdentityProviderConfigurationWantAssertionEncrypted Property

Gets or sets the flag indicating whether SAML assertions should be encrypted.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool WantAssertionEncrypted { get; set; }
Public Property WantAssertionEncrypted As Boolean
    Get
    Set
public:
property bool WantAssertionEncrypted {
    bool get ();
    void set (bool value);
}
member WantAssertionEncrypted : bool with get, set

Property Value

Type: Boolean
The flag indicating whether SAML assertions should be encrypted.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.WantAssertionSigned Property

PartnerIdentityProviderConfigurationWantAssertionSigned Property

Gets or sets the flag indicating whether SAML assertions should be signed.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool WantAssertionSigned { get; set; }
Public Property WantAssertionSigned As Boolean
    Get
    Set
public:
property bool WantAssertionSigned {
    bool get ();
    void set (bool value);
}
member WantAssertionSigned : bool with get, set

Property Value

Type: Boolean
The flag indicating whether SAML assertions should be signed.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.WantSAMLResponseSigned Property

PartnerIdentityProviderConfigurationWantSAMLResponseSigned Property

Gets or sets the flag indicating whether SAML responses should be signed.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool WantSAMLResponseSigned { get; set; }
Public Property WantSAMLResponseSigned As Boolean
    Get
    Set
public:
property bool WantSAMLResponseSigned {
    bool get ();
    void set (bool value);
}
member WantSAMLResponseSigned : bool with get, set

Property Value

Type: Boolean
The flag indicating whether SAML responses should be signed.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration Methods

The PartnerIdentityProviderConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the partner identity provider configuration to XML. (Overrides PartnerProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerIdentityProviderConfiguration.ToXml Method

PartnerIdentityProviderConfigurationToXml Method

Serializes the partner identity provider configuration to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    XmlElement xmlElement
)
Public Overrides Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
) override
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element.
See Also

Reference

PartnerIdentityProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration Class

The partner provider configuration is configuration common to partner identity providers and service providers.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationProviderConfiguration
ComponentSpace.SAML2.ConfigurationPartnerProviderConfiguration
ComponentSpace.SAML2.ConfigurationPartnerIdentityProviderConfiguration
ComponentSpace.SAML2.ConfigurationPartnerServiceProviderConfiguration

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class PartnerProviderConfiguration : ProviderConfiguration
Public MustInherit Class PartnerProviderConfiguration
    Inherits ProviderConfiguration
public ref class PartnerProviderConfiguration abstract : public ProviderConfiguration
[<AbstractClassAttribute>]
type PartnerProviderConfiguration =
    class
        inherit ProviderConfiguration
    end

The PartnerProviderConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | PartnerProviderConfiguration | Constructs a partner provider configuration.
Public method | PartnerProviderConfiguration(XmlElement) | Constructs a partner provider configuration from XML.
Top
Properties
 | Name | Description
Public property | AuthnContext | Gets or sets the authentication context.
Public property | ClockSkew | Gets or sets the clock skew. The clock skew allows for differences between local and partner computer clocks when checking time intervals. The default time span is 3 minutes.
Public property | DataEncryptionMethod | Gets or sets the XML encryption data encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#aes128-cbc.
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | DigestMethod | Gets or sets the XML signature digest algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#sha256.
Public property | DisableDestinationCheck | Gets or sets the flag indicating whether the destination is checked.
Public property | DisableInboundLogout | Gets or sets the flag indicating whether to disable inbound logout.
Public property | DisableInResponseToCheck | Gets or sets the flag indicating whether the InResponseTo is checked.
Public property | DisableOutboundLogout | Gets or sets the flag indicating whether to disable outbound logout.
Public property | DisablePendingLogoutCheck | Gets or sets the flag indicating whether a logout is pending is checked.
Public property | IssuerFormat | Gets or sets the issuer format. The default issuer format is not explicitly specified.
Public property | KeyEncryptionMethod | Gets or sets the XML encryption key encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#rsa-1_5.
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | LogoutRequestLifeTime | Gets or sets the logout request lifetime. The default time span is 3 minutes.
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | NameIDFormat | Gets or sets the name identifier format. The default name identifier format is urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified.
Public property | PartnerCertificateFile | Gets or sets the partner certificate file path. The file path is either absolute or relative to the application folder.
Public property | PartnerCertificateSerialNumber | Gets or sets the partner certificate serial number.
Public property | PartnerCertificateStoreLocation | Gets or sets the partner certificate store location.
Public property | PartnerCertificateSubject | Gets or sets the partner certificate subject.
Public property | PartnerCertificateThumbprint | Gets or sets the partner certificate thumbprint.
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | SecondaryPartnerCertificateFile | Gets or sets the secondary partner certificate file path. The file path is either absolute or relative to the application folder.
Public property | SecondaryPartnerCertificateSerialNumber | Gets or sets the secondary partner certificate serial number.
Public property | SecondaryPartnerCertificateStoreLocation | Gets or sets the secondary partner certificate store location.
Public property | SecondaryPartnerCertificateSubject | Gets or sets the secondary partner certificate subject.
Public property | SecondaryPartnerCertificateThumbprint | Gets or sets the secondary partner certificate thumbprint.
Public property | SignatureMethod | Gets or sets the XML signature algorithm. The default algorithm is http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Public property | SignLogoutRequest | Gets or sets the flag indicating whether to sign sent logout responses.
Public property | SignLogoutResponse | Gets or sets the flag indicating whether to sign sent logout responses.
Public property | SingleLogoutServiceBinding | Gets or sets the partner provider's single sign-on service binding. The default binding is urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect.
Public property | SingleLogoutServiceResponseUrl | Gets or sets the partner provider's single sign-on service response URL.
Public property | SingleLogoutServiceUrl | Gets or sets the partner provider's single sign-on service URL.
Public property | UseEmbeddedCertificate | Gets or sets the flag to indicate whether to use embedded certificates.
Public property | WantDigestMethod | Gets or sets the XML signature digest algorithm expected from the partner provider. If not specified then any algorithm is accepted.
Public property | WantLogoutRequestSigned | Gets or sets the flag indicating whether received logout requests should be signed.
Public property | WantLogoutResponseSigned | Gets or sets the flag indicating whether received logout responses should be signed.
Public property | WantSignatureMethod | Gets or sets the XML signature algorithm expected from the partner provider. If not specified then any algorithm is accepted.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the partner provider configuration to XML. (Overrides ProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration Constructor

Overload List
 | Name | Description
Public method | PartnerProviderConfiguration | Constructs a partner provider configuration.
Public method | PartnerProviderConfiguration(XmlElement) | Constructs a partner provider configuration from XML.
Top
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration Constructor

Constructs a partner provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public PartnerProviderConfiguration()
Public Sub New
public:
PartnerProviderConfiguration()
new : unit -> PartnerProviderConfiguration
See Also

Reference

PartnerProviderConfiguration Class
PartnerProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration Constructor (XmlElement)

Constructs a partner provider configuration from XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public PartnerProviderConfiguration(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
PartnerProviderConfiguration(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> PartnerProviderConfiguration

Parameters

xmlElement
Type: System.XmlXmlElement
The partner provider configuration XML.
See Also

Reference

PartnerProviderConfiguration Class
PartnerProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration Properties

The PartnerProviderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AuthnContext | Gets or sets the authentication context.
Public property | ClockSkew | Gets or sets the clock skew. The clock skew allows for differences between local and partner computer clocks when checking time intervals. The default time span is 3 minutes.
Public property | DataEncryptionMethod | Gets or sets the XML encryption data encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#aes128-cbc.
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | DigestMethod | Gets or sets the XML signature digest algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#sha256.
Public property | DisableDestinationCheck | Gets or sets the flag indicating whether the destination is checked.
Public property | DisableInboundLogout | Gets or sets the flag indicating whether to disable inbound logout.
Public property | DisableInResponseToCheck | Gets or sets the flag indicating whether the InResponseTo is checked.
Public property | DisableOutboundLogout | Gets or sets the flag indicating whether to disable outbound logout.
Public property | DisablePendingLogoutCheck | Gets or sets the flag indicating whether a logout is pending is checked.
Public property | IssuerFormat | Gets or sets the issuer format. The default issuer format is not explicitly specified.
Public property | KeyEncryptionMethod | Gets or sets the XML encryption key encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#rsa-1_5.
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | LogoutRequestLifeTime | Gets or sets the logout request lifetime. The default time span is 3 minutes.
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | NameIDFormat | Gets or sets the name identifier format. The default name identifier format is urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified.
Public property | PartnerCertificateFile | Gets or sets the partner certificate file path. The file path is either absolute or relative to the application folder.
Public property | PartnerCertificateSerialNumber | Gets or sets the partner certificate serial number.
Public property | PartnerCertificateStoreLocation | Gets or sets the partner certificate store location.
Public property | PartnerCertificateSubject | Gets or sets the partner certificate subject.
Public property | PartnerCertificateThumbprint | Gets or sets the partner certificate thumbprint.
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | SecondaryPartnerCertificateFile | Gets or sets the secondary partner certificate file path. The file path is either absolute or relative to the application folder.
Public property | SecondaryPartnerCertificateSerialNumber | Gets or sets the secondary partner certificate serial number.
Public property | SecondaryPartnerCertificateStoreLocation | Gets or sets the secondary partner certificate store location.
Public property | SecondaryPartnerCertificateSubject | Gets or sets the secondary partner certificate subject.
Public property | SecondaryPartnerCertificateThumbprint | Gets or sets the secondary partner certificate thumbprint.
Public property | SignatureMethod | Gets or sets the XML signature algorithm. The default algorithm is http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Public property | SignLogoutRequest | Gets or sets the flag indicating whether to sign sent logout responses.
Public property | SignLogoutResponse | Gets or sets the flag indicating whether to sign sent logout responses.
Public property | SingleLogoutServiceBinding | Gets or sets the partner provider's single sign-on service binding. The default binding is urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect.
Public property | SingleLogoutServiceResponseUrl | Gets or sets the partner provider's single sign-on service response URL.
Public property | SingleLogoutServiceUrl | Gets or sets the partner provider's single sign-on service URL.
Public property | UseEmbeddedCertificate | Gets or sets the flag to indicate whether to use embedded certificates.
Public property | WantDigestMethod | Gets or sets the XML signature digest algorithm expected from the partner provider. If not specified then any algorithm is accepted.
Public property | WantLogoutRequestSigned | Gets or sets the flag indicating whether received logout requests should be signed.
Public property | WantLogoutResponseSigned | Gets or sets the flag indicating whether received logout responses should be signed.
Public property | WantSignatureMethod | Gets or sets the XML signature algorithm expected from the partner provider. If not specified then any algorithm is accepted.
Top
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.AuthnContext Property

PartnerProviderConfigurationAuthnContext Property

Gets or sets the authentication context.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string AuthnContext { get; set; }
Public Property AuthnContext As String
    Get
    Set
public:
property String^ AuthnContext {
    String^ get ();
    void set (String^ value);
}
member AuthnContext : string with get, set

Property Value

Type: String
The authentication context.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.ClockSkew Property

PartnerProviderConfigurationClockSkew Property

Gets or sets the clock skew. The clock skew allows for differences between local and partner computer clocks when checking time intervals.

The default time span is 3 minutes.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public TimeSpan ClockSkew { get; set; }
Public Property ClockSkew As TimeSpan
    Get
    Set
public:
property TimeSpan ClockSkew {
    TimeSpan get ();
    void set (TimeSpan value);
}
member ClockSkew : TimeSpan with get, set

Property Value

Type: TimeSpan
The clock skew.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.DataEncryptionMethod Property

PartnerProviderConfigurationDataEncryptionMethod Property

Gets or sets the XML encryption data encryption algorithm.

The default algorithm is http://www.w3.org/2001/04/xmlenc#aes128-cbc.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string DataEncryptionMethod { get; set; }
Public Property DataEncryptionMethod As String
    Get
    Set
public:
property String^ DataEncryptionMethod {
    String^ get ();
    void set (String^ value);
}
member DataEncryptionMethod : string with get, set

Property Value

Type: String
The XML encryption data encryption algorithm.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.DigestMethod Property

PartnerProviderConfigurationDigestMethod Property

Gets or sets the XML signature digest algorithm.

The default algorithm is http://www.w3.org/2001/04/xmlenc#sha256.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string DigestMethod { get; set; }
Public Property DigestMethod As String
    Get
    Set
public:
property String^ DigestMethod {
    String^ get ();
    void set (String^ value);
}
member DigestMethod : string with get, set

Property Value

Type: String
The XML signature digest algorithm.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.DisableDestinationCheck Property

PartnerProviderConfigurationDisableDestinationCheck Property

Gets or sets the flag indicating whether the destination is checked.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DisableDestinationCheck { get; set; }
Public Property DisableDestinationCheck As Boolean
    Get
    Set
public:
property bool DisableDestinationCheck {
    bool get ();
    void set (bool value);
}
member DisableDestinationCheck : bool with get, set

Property Value

Type: Boolean
The flag indicating whether the destination is checked.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.DisableInboundLogout Property

PartnerProviderConfigurationDisableInboundLogout Property

Gets or sets the flag indicating whether to disable inbound logout.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DisableInboundLogout { get; set; }
Public Property DisableInboundLogout As Boolean
    Get
    Set
public:
property bool DisableInboundLogout {
    bool get ();
    void set (bool value);
}
member DisableInboundLogout : bool with get, set

Property Value

Type: Boolean
The flag indicating whether to disable inbound logout.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.DisableInResponseToCheck Property

PartnerProviderConfigurationDisableInResponseToCheck Property

Gets or sets the flag indicating whether the InResponseTo is checked.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DisableInResponseToCheck { get; set; }
Public Property DisableInResponseToCheck As Boolean
    Get
    Set
public:
property bool DisableInResponseToCheck {
    bool get ();
    void set (bool value);
}
member DisableInResponseToCheck : bool with get, set

Property Value

Type: Boolean
The flag indicating whether the InResponseTo is checked.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.DisableOutboundLogout Property

PartnerProviderConfigurationDisableOutboundLogout Property

Gets or sets the flag indicating whether to disable outbound logout.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DisableOutboundLogout { get; set; }
Public Property DisableOutboundLogout As Boolean
    Get
    Set
public:
property bool DisableOutboundLogout {
    bool get ();
    void set (bool value);
}
member DisableOutboundLogout : bool with get, set

Property Value

Type: Boolean
The flag indicating whether to disable outbound logout.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.DisablePendingLogoutCheck Property

PartnerProviderConfigurationDisablePendingLogoutCheck Property

Gets or sets the flag indicating whether a logout is pending is checked.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DisablePendingLogoutCheck { get; set; }
Public Property DisablePendingLogoutCheck As Boolean
    Get
    Set
public:
property bool DisablePendingLogoutCheck {
    bool get ();
    void set (bool value);
}
member DisablePendingLogoutCheck : bool with get, set

Property Value

Type: Boolean
The flag indicating whether a logout is pending is checked.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.IssuerFormat Property

PartnerProviderConfigurationIssuerFormat Property

Gets or sets the issuer format.

The default issuer format is not explicitly specified.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string IssuerFormat { get; set; }
Public Property IssuerFormat As String
    Get
    Set
public:
property String^ IssuerFormat {
    String^ get ();
    void set (String^ value);
}
member IssuerFormat : string with get, set

Property Value

Type: String
The issuer format.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.KeyEncryptionMethod Property

PartnerProviderConfigurationKeyEncryptionMethod Property

Gets or sets the XML encryption key encryption algorithm.

The default algorithm is http://www.w3.org/2001/04/xmlenc#rsa-1_5.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string KeyEncryptionMethod { get; set; }
Public Property KeyEncryptionMethod As String
    Get
    Set
public:
property String^ KeyEncryptionMethod {
    String^ get ();
    void set (String^ value);
}
member KeyEncryptionMethod : string with get, set

Property Value

Type: String
The XML encryption key encryption algorithm.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.LogoutRequestLifeTime Property

PartnerProviderConfigurationLogoutRequestLifeTime Property

Gets or sets the logout request lifetime.

The default time span is 3 minutes.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public TimeSpan LogoutRequestLifeTime { get; set; }
Public Property LogoutRequestLifeTime As TimeSpan
    Get
    Set
public:
property TimeSpan LogoutRequestLifeTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
member LogoutRequestLifeTime : TimeSpan with get, set

Property Value

Type: TimeSpan
The logout request lifetime.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.NameIDFormat Property

PartnerProviderConfigurationNameIDFormat Property

Gets or sets the name identifier format.

The default name identifier format is urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string NameIDFormat { get; set; }
Public Property NameIDFormat As String
    Get
    Set
public:
property String^ NameIDFormat {
    String^ get ();
    void set (String^ value);
}
member NameIDFormat : string with get, set

Property Value

Type: String
The name identifier format.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.PartnerCertificateFile Property

PartnerProviderConfigurationPartnerCertificateFile Property

Gets or sets the partner certificate file path.

The file path is either absolute or relative to the application folder.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string PartnerCertificateFile { get; set; }
Public Property PartnerCertificateFile As String
    Get
    Set
public:
property String^ PartnerCertificateFile {
    String^ get ();
    void set (String^ value);
}
member PartnerCertificateFile : string with get, set

Property Value

Type: String
The partner certificate file path.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.PartnerCertificateSerialNumber Property

PartnerProviderConfigurationPartnerCertificateSerialNumber Property

Gets or sets the partner certificate serial number.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string PartnerCertificateSerialNumber { get; set; }
Public Property PartnerCertificateSerialNumber As String
    Get
    Set
public:
property String^ PartnerCertificateSerialNumber {
    String^ get ();
    void set (String^ value);
}
member PartnerCertificateSerialNumber : string with get, set

Property Value

Type: String
The partner certificate serial number.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.PartnerCertificateStoreLocation Property

PartnerProviderConfigurationPartnerCertificateStoreLocation Property

Gets or sets the partner certificate store location.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StoreLocation PartnerCertificateStoreLocation { get; set; }
Public Property PartnerCertificateStoreLocation As StoreLocation
    Get
    Set
public:
property StoreLocation PartnerCertificateStoreLocation {
    StoreLocation get ();
    void set (StoreLocation value);
}
member PartnerCertificateStoreLocation : StoreLocation with get, set

Property Value

Type: StoreLocation
The partner certificate store location.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.PartnerCertificateSubject Property

PartnerProviderConfigurationPartnerCertificateSubject Property

Gets or sets the partner certificate subject.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string PartnerCertificateSubject { get; set; }
Public Property PartnerCertificateSubject As String
    Get
    Set
public:
property String^ PartnerCertificateSubject {
    String^ get ();
    void set (String^ value);
}
member PartnerCertificateSubject : string with get, set

Property Value

Type: String
The partner certificate subject.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.PartnerCertificateThumbprint Property

PartnerProviderConfigurationPartnerCertificateThumbprint Property

Gets or sets the partner certificate thumbprint.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string PartnerCertificateThumbprint { get; set; }
Public Property PartnerCertificateThumbprint As String
    Get
    Set
public:
property String^ PartnerCertificateThumbprint {
    String^ get ();
    void set (String^ value);
}
member PartnerCertificateThumbprint : string with get, set

Property Value

Type: String
The partner certificate thumbprint.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SecondaryPartnerCertificateFile Property

PartnerProviderConfigurationSecondaryPartnerCertificateFile Property

Gets or sets the secondary partner certificate file path.

The file path is either absolute or relative to the application folder.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SecondaryPartnerCertificateFile { get; set; }
Public Property SecondaryPartnerCertificateFile As String
    Get
    Set
public:
property String^ SecondaryPartnerCertificateFile {
    String^ get ();
    void set (String^ value);
}
member SecondaryPartnerCertificateFile : string with get, set

Property Value

Type: String
The secondary partner certificate file path.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SecondaryPartnerCertificateSerialNumber Property

PartnerProviderConfigurationSecondaryPartnerCertificateSerialNumber Property

Gets or sets the secondary partner certificate serial number.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SecondaryPartnerCertificateSerialNumber { get; set; }
Public Property SecondaryPartnerCertificateSerialNumber As String
    Get
    Set
public:
property String^ SecondaryPartnerCertificateSerialNumber {
    String^ get ();
    void set (String^ value);
}
member SecondaryPartnerCertificateSerialNumber : string with get, set

Property Value

Type: String
The secondary partner certificate serial number.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SecondaryPartnerCertificateStoreLocation Property

PartnerProviderConfigurationSecondaryPartnerCertificateStoreLocation Property

Gets or sets the secondary partner certificate store location.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StoreLocation SecondaryPartnerCertificateStoreLocation { get; set; }
Public Property SecondaryPartnerCertificateStoreLocation As StoreLocation
    Get
    Set
public:
property StoreLocation SecondaryPartnerCertificateStoreLocation {
    StoreLocation get ();
    void set (StoreLocation value);
}
member SecondaryPartnerCertificateStoreLocation : StoreLocation with get, set

Property Value

Type: StoreLocation
The secondary partner certificate store location.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SecondaryPartnerCertificateSubject Property

PartnerProviderConfigurationSecondaryPartnerCertificateSubject Property

Gets or sets the secondary partner certificate subject.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SecondaryPartnerCertificateSubject { get; set; }
Public Property SecondaryPartnerCertificateSubject As String
    Get
    Set
public:
property String^ SecondaryPartnerCertificateSubject {
    String^ get ();
    void set (String^ value);
}
member SecondaryPartnerCertificateSubject : string with get, set

Property Value

Type: String
The secondary partner certificate subject.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SecondaryPartnerCertificateThumbprint Property

PartnerProviderConfigurationSecondaryPartnerCertificateThumbprint Property

Gets or sets the secondary partner certificate thumbprint.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SecondaryPartnerCertificateThumbprint { get; set; }
Public Property SecondaryPartnerCertificateThumbprint As String
    Get
    Set
public:
property String^ SecondaryPartnerCertificateThumbprint {
    String^ get ();
    void set (String^ value);
}
member SecondaryPartnerCertificateThumbprint : string with get, set

Property Value

Type: String
The secondary partner certificate thumbprint.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SignatureMethod Property

PartnerProviderConfigurationSignatureMethod Property

Gets or sets the XML signature algorithm.

The default algorithm is http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SignatureMethod { get; set; }
Public Property SignatureMethod As String
    Get
    Set
public:
property String^ SignatureMethod {
    String^ get ();
    void set (String^ value);
}
member SignatureMethod : string with get, set

Property Value

Type: String
The XML signature algorithm.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SignLogoutRequest Property

PartnerProviderConfigurationSignLogoutRequest Property

Gets or sets the flag indicating whether to sign sent logout responses.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool SignLogoutRequest { get; set; }
Public Property SignLogoutRequest As Boolean
    Get
    Set
public:
property bool SignLogoutRequest {
    bool get ();
    void set (bool value);
}
member SignLogoutRequest : bool with get, set

Property Value

Type: Boolean
The flag indicating whether to sign sent logout responses.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SignLogoutResponse Property

PartnerProviderConfigurationSignLogoutResponse Property

Gets or sets the flag indicating whether to sign sent logout responses.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool SignLogoutResponse { get; set; }
Public Property SignLogoutResponse As Boolean
    Get
    Set
public:
property bool SignLogoutResponse {
    bool get ();
    void set (bool value);
}
member SignLogoutResponse : bool with get, set

Property Value

Type: Boolean
The flag indicating whether to sign sent logout responses.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SingleLogoutServiceBinding Property

PartnerProviderConfigurationSingleLogoutServiceBinding Property

Gets or sets the partner provider's single sign-on service binding.

The default binding is urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SingleLogoutServiceBinding { get; set; }
Public Property SingleLogoutServiceBinding As String
    Get
    Set
public:
property String^ SingleLogoutServiceBinding {
    String^ get ();
    void set (String^ value);
}
member SingleLogoutServiceBinding : string with get, set

Property Value

Type: String
The partner provider's single sign-on service binding.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SingleLogoutServiceResponseUrl Property

PartnerProviderConfigurationSingleLogoutServiceResponseUrl Property

Gets or sets the partner provider's single sign-on service response URL.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SingleLogoutServiceResponseUrl { get; set; }
Public Property SingleLogoutServiceResponseUrl As String
    Get
    Set
public:
property String^ SingleLogoutServiceResponseUrl {
    String^ get ();
    void set (String^ value);
}
member SingleLogoutServiceResponseUrl : string with get, set

Property Value

Type: String
The partner provider's single sign-on service response URL.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.SingleLogoutServiceUrl Property

PartnerProviderConfigurationSingleLogoutServiceUrl Property

Gets or sets the partner provider's single sign-on service URL.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SingleLogoutServiceUrl { get; set; }
Public Property SingleLogoutServiceUrl As String
    Get
    Set
public:
property String^ SingleLogoutServiceUrl {
    String^ get ();
    void set (String^ value);
}
member SingleLogoutServiceUrl : string with get, set

Property Value

Type: String
The partner provider's single sign-on service URL.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.UseEmbeddedCertificate Property

PartnerProviderConfigurationUseEmbeddedCertificate Property

Gets or sets the flag to indicate whether to use embedded certificates.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool UseEmbeddedCertificate { get; set; }
Public Property UseEmbeddedCertificate As Boolean
    Get
    Set
public:
property bool UseEmbeddedCertificate {
    bool get ();
    void set (bool value);
}
member UseEmbeddedCertificate : bool with get, set

Property Value

Type: Boolean
The flag to indicate whether to use embedded certificates.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.WantDigestMethod Property

PartnerProviderConfigurationWantDigestMethod Property

Gets or sets the XML signature digest algorithm expected from the partner provider.

If not specified then any algorithm is accepted.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string WantDigestMethod { get; set; }
Public Property WantDigestMethod As String
    Get
    Set
public:
property String^ WantDigestMethod {
    String^ get ();
    void set (String^ value);
}
member WantDigestMethod : string with get, set

Property Value

Type: String
The expected XML signature digest algorithm or null if none..
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.WantLogoutRequestSigned Property

PartnerProviderConfigurationWantLogoutRequestSigned Property

Gets or sets the flag indicating whether received logout requests should be signed.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool WantLogoutRequestSigned { get; set; }
Public Property WantLogoutRequestSigned As Boolean
    Get
    Set
public:
property bool WantLogoutRequestSigned {
    bool get ();
    void set (bool value);
}
member WantLogoutRequestSigned : bool with get, set

Property Value

Type: Boolean
The flag indicating whether received logout requests should be signed.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.WantLogoutResponseSigned Property

PartnerProviderConfigurationWantLogoutResponseSigned Property

Gets or sets the flag indicating whether received logout responses should be signed.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool WantLogoutResponseSigned { get; set; }
Public Property WantLogoutResponseSigned As Boolean
    Get
    Set
public:
property bool WantLogoutResponseSigned {
    bool get ();
    void set (bool value);
}
member WantLogoutResponseSigned : bool with get, set

Property Value

Type: Boolean
The flag indicating whether received logout responses should be signed.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.WantSignatureMethod Property

PartnerProviderConfigurationWantSignatureMethod Property

Gets or sets the XML signature algorithm expected from the partner provider.

If not specified then any algorithm is accepted.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string WantSignatureMethod { get; set; }
Public Property WantSignatureMethod As String
    Get
    Set
public:
property String^ WantSignatureMethod {
    String^ get ();
    void set (String^ value);
}
member WantSignatureMethod : string with get, set

Property Value

Type: String
The expected XML signature algorithm or null if none..
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration Methods

The PartnerProviderConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the partner provider configuration to XML. (Overrides ProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerProviderConfiguration.ToXml Method

PartnerProviderConfigurationToXml Method

Serializes the partner provider configuration to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    XmlElement xmlElement
)
Public Overrides Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
) override
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element.
See Also

Reference

PartnerProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration Class

The partner service provider configuration specifies the configuration for the partner service provider.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationProviderConfiguration
ComponentSpace.SAML2.ConfigurationPartnerProviderConfiguration
ComponentSpace.SAML2.ConfigurationPartnerServiceProviderConfiguration

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class PartnerServiceProviderConfiguration : PartnerProviderConfiguration
Public Class PartnerServiceProviderConfiguration
    Inherits PartnerProviderConfiguration
public ref class PartnerServiceProviderConfiguration : public PartnerProviderConfiguration
type PartnerServiceProviderConfiguration =
    class
        inherit PartnerProviderConfiguration
    end

The PartnerServiceProviderConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | PartnerServiceProviderConfiguration | Constructs a partner service provider configuration.
Public method | PartnerServiceProviderConfiguration(XmlElement) | Constructs a partner service provider configuration from XML.
Top
Properties
 | Name | Description
Public property | AssertionConsumerServiceUrl | Gets or sets the partner service provider's assertion consumer service URL.
Public property | AssertionLifeTime | Gets or sets the time span for which SAML assertions will be valid. The default time span is 3 minutes.
Public property | AuthnContext | Gets or sets the authentication context. (Inherited from PartnerProviderConfiguration.)
Public property | ClockSkew | Gets or sets the clock skew. The clock skew allows for differences between local and partner computer clocks when checking time intervals. The default time span is 3 minutes. (Inherited from PartnerProviderConfiguration.)
Public property | DataEncryptionMethod | Gets or sets the XML encryption data encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#aes128-cbc. (Inherited from PartnerProviderConfiguration.)
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | DigestMethod | Gets or sets the XML signature digest algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#sha256. (Inherited from PartnerProviderConfiguration.)
Public property | DisableDestinationCheck | Gets or sets the flag indicating whether the destination is checked. (Inherited from PartnerProviderConfiguration.)
Public property | DisableInboundLogout | Gets or sets the flag indicating whether to disable inbound logout. (Inherited from PartnerProviderConfiguration.)
Public property | DisableInResponseToCheck | Gets or sets the flag indicating whether the InResponseTo is checked. (Inherited from PartnerProviderConfiguration.)
Public property | DisableOutboundLogout | Gets or sets the flag indicating whether to disable outbound logout. (Inherited from PartnerProviderConfiguration.)
Public property | DisablePendingLogoutCheck | Gets or sets the flag indicating whether a logout is pending is checked. (Inherited from PartnerProviderConfiguration.)
Public property | EncryptAssertion | Gets or sets the flag indicating whether to encrypt SAML assertions.
Public property | IssuerFormat | Gets or sets the issuer format. The default issuer format is not explicitly specified. (Inherited from PartnerProviderConfiguration.)
Public property | KeyEncryptionMethod | Gets or sets the XML encryption key encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#rsa-1_5. (Inherited from PartnerProviderConfiguration.)
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | LogoutRequestLifeTime | Gets or sets the logout request lifetime. The default time span is 3 minutes. (Inherited from PartnerProviderConfiguration.)
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | NameIDFormat | Gets or sets the name identifier format. The default name identifier format is urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateFile | Gets or sets the partner certificate file path. The file path is either absolute or relative to the application folder. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateSerialNumber | Gets or sets the partner certificate serial number. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateStoreLocation | Gets or sets the partner certificate store location. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateSubject | Gets or sets the partner certificate subject. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateThumbprint | Gets or sets the partner certificate thumbprint. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | SecondaryPartnerCertificateFile | Gets or sets the secondary partner certificate file path. The file path is either absolute or relative to the application folder. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateSerialNumber | Gets or sets the secondary partner certificate serial number. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateStoreLocation | Gets or sets the secondary partner certificate store location. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateSubject | Gets or sets the secondary partner certificate subject. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateThumbprint | Gets or sets the secondary partner certificate thumbprint. (Inherited from PartnerProviderConfiguration.)
Public property | SignAssertion | Gets or sets the flag indicating whether to sign SAML assertions.
Public property | SignatureMethod | Gets or sets the XML signature algorithm. The default algorithm is http://www.w3.org/2001/04/xmldsig-more#rsa-sha256. (Inherited from PartnerProviderConfiguration.)
Public property | SignLogoutRequest | Gets or sets the flag indicating whether to sign sent logout responses. (Inherited from PartnerProviderConfiguration.)
Public property | SignLogoutResponse | Gets or sets the flag indicating whether to sign sent logout responses. (Inherited from PartnerProviderConfiguration.)
Public property | SignSAMLResponse | Gets or sets the flag indicating whether to sign SAML responses.
Public property | SingleLogoutServiceBinding | Gets or sets the partner provider's single sign-on service binding. The default binding is urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect. (Inherited from PartnerProviderConfiguration.)
Public property | SingleLogoutServiceResponseUrl | Gets or sets the partner provider's single sign-on service response URL. (Inherited from PartnerProviderConfiguration.)
Public property | SingleLogoutServiceUrl | Gets or sets the partner provider's single sign-on service URL. (Inherited from PartnerProviderConfiguration.)
Public property | UseEmbeddedCertificate | Gets or sets the flag to indicate whether to use embedded certificates. (Inherited from PartnerProviderConfiguration.)
Public property | WantAuthnRequestSigned | Gets or sets the flag indicating whether authn requests should be signed.
Public property | WantDigestMethod | Gets or sets the XML signature digest algorithm expected from the partner provider. If not specified then any algorithm is accepted. (Inherited from PartnerProviderConfiguration.)
Public property | WantLogoutRequestSigned | Gets or sets the flag indicating whether received logout requests should be signed. (Inherited from PartnerProviderConfiguration.)
Public property | WantLogoutResponseSigned | Gets or sets the flag indicating whether received logout responses should be signed. (Inherited from PartnerProviderConfiguration.)
Public property | WantSignatureMethod | Gets or sets the XML signature algorithm expected from the partner provider. If not specified then any algorithm is accepted. (Inherited from PartnerProviderConfiguration.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the partner service provider configuration to XML. (Overrides PartnerProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration Constructor

Overload List
 | Name | Description
Public method | PartnerServiceProviderConfiguration | Constructs a partner service provider configuration.
Public method | PartnerServiceProviderConfiguration(XmlElement) | Constructs a partner service provider configuration from XML.
Top
See Also

Reference

PartnerServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration Constructor

Constructs a partner service provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public PartnerServiceProviderConfiguration()
Public Sub New
public:
PartnerServiceProviderConfiguration()
new : unit -> PartnerServiceProviderConfiguration
See Also

Reference

PartnerServiceProviderConfiguration Class
PartnerServiceProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration Constructor (XmlElement)

Constructs a partner service provider configuration from XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public PartnerServiceProviderConfiguration(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
PartnerServiceProviderConfiguration(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> PartnerServiceProviderConfiguration

Parameters

xmlElement
Type: System.XmlXmlElement
The partner service provider configuration XML.
See Also

Reference

PartnerServiceProviderConfiguration Class
PartnerServiceProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration Properties

The PartnerServiceProviderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AssertionConsumerServiceUrl | Gets or sets the partner service provider's assertion consumer service URL.
Public property | AssertionLifeTime | Gets or sets the time span for which SAML assertions will be valid. The default time span is 3 minutes.
Public property | AuthnContext | Gets or sets the authentication context. (Inherited from PartnerProviderConfiguration.)
Public property | ClockSkew | Gets or sets the clock skew. The clock skew allows for differences between local and partner computer clocks when checking time intervals. The default time span is 3 minutes. (Inherited from PartnerProviderConfiguration.)
Public property | DataEncryptionMethod | Gets or sets the XML encryption data encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#aes128-cbc. (Inherited from PartnerProviderConfiguration.)
Public property | Description | Gets or sets the provider description. (Inherited from ProviderConfiguration.)
Public property | DigestMethod | Gets or sets the XML signature digest algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#sha256. (Inherited from PartnerProviderConfiguration.)
Public property | DisableDestinationCheck | Gets or sets the flag indicating whether the destination is checked. (Inherited from PartnerProviderConfiguration.)
Public property | DisableInboundLogout | Gets or sets the flag indicating whether to disable inbound logout. (Inherited from PartnerProviderConfiguration.)
Public property | DisableInResponseToCheck | Gets or sets the flag indicating whether the InResponseTo is checked. (Inherited from PartnerProviderConfiguration.)
Public property | DisableOutboundLogout | Gets or sets the flag indicating whether to disable outbound logout. (Inherited from PartnerProviderConfiguration.)
Public property | DisablePendingLogoutCheck | Gets or sets the flag indicating whether a logout is pending is checked. (Inherited from PartnerProviderConfiguration.)
Public property | EncryptAssertion | Gets or sets the flag indicating whether to encrypt SAML assertions.
Public property | IssuerFormat | Gets or sets the issuer format. The default issuer format is not explicitly specified. (Inherited from PartnerProviderConfiguration.)
Public property | KeyEncryptionMethod | Gets or sets the XML encryption key encryption algorithm. The default algorithm is http://www.w3.org/2001/04/xmlenc#rsa-1_5. (Inherited from PartnerProviderConfiguration.)
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePassword | Gets or sets the local certificate file password. (Inherited from ProviderConfiguration.)
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateSubject | Gets or sets the local certificate subject. (Inherited from ProviderConfiguration.)
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | LogoutRequestLifeTime | Gets or sets the logout request lifetime. The default time span is 3 minutes. (Inherited from PartnerProviderConfiguration.)
Public property | Name | Gets or sets the provider name. (Inherited from ProviderConfiguration.)
Public property | NameIDFormat | Gets or sets the name identifier format. The default name identifier format is urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateFile | Gets or sets the partner certificate file path. The file path is either absolute or relative to the application folder. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateSerialNumber | Gets or sets the partner certificate serial number. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateStoreLocation | Gets or sets the partner certificate store location. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateSubject | Gets or sets the partner certificate subject. (Inherited from PartnerProviderConfiguration.)
Public property | PartnerCertificateThumbprint | Gets or sets the partner certificate thumbprint. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject. (Inherited from ProviderConfiguration.)
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint. (Inherited from ProviderConfiguration.)
Public property | SecondaryPartnerCertificateFile | Gets or sets the secondary partner certificate file path. The file path is either absolute or relative to the application folder. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateSerialNumber | Gets or sets the secondary partner certificate serial number. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateStoreLocation | Gets or sets the secondary partner certificate store location. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateSubject | Gets or sets the secondary partner certificate subject. (Inherited from PartnerProviderConfiguration.)
Public property | SecondaryPartnerCertificateThumbprint | Gets or sets the secondary partner certificate thumbprint. (Inherited from PartnerProviderConfiguration.)
Public property | SignAssertion | Gets or sets the flag indicating whether to sign SAML assertions.
Public property | SignatureMethod | Gets or sets the XML signature algorithm. The default algorithm is http://www.w3.org/2001/04/xmldsig-more#rsa-sha256. (Inherited from PartnerProviderConfiguration.)
Public property | SignLogoutRequest | Gets or sets the flag indicating whether to sign sent logout responses. (Inherited from PartnerProviderConfiguration.)
Public property | SignLogoutResponse | Gets or sets the flag indicating whether to sign sent logout responses. (Inherited from PartnerProviderConfiguration.)
Public property | SignSAMLResponse | Gets or sets the flag indicating whether to sign SAML responses.
Public property | SingleLogoutServiceBinding | Gets or sets the partner provider's single sign-on service binding. The default binding is urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect. (Inherited from PartnerProviderConfiguration.)
Public property | SingleLogoutServiceResponseUrl | Gets or sets the partner provider's single sign-on service response URL. (Inherited from PartnerProviderConfiguration.)
Public property | SingleLogoutServiceUrl | Gets or sets the partner provider's single sign-on service URL. (Inherited from PartnerProviderConfiguration.)
Public property | UseEmbeddedCertificate | Gets or sets the flag to indicate whether to use embedded certificates. (Inherited from PartnerProviderConfiguration.)
Public property | WantAuthnRequestSigned | Gets or sets the flag indicating whether authn requests should be signed.
Public property | WantDigestMethod | Gets or sets the XML signature digest algorithm expected from the partner provider. If not specified then any algorithm is accepted. (Inherited from PartnerProviderConfiguration.)
Public property | WantLogoutRequestSigned | Gets or sets the flag indicating whether received logout requests should be signed. (Inherited from PartnerProviderConfiguration.)
Public property | WantLogoutResponseSigned | Gets or sets the flag indicating whether received logout responses should be signed. (Inherited from PartnerProviderConfiguration.)
Public property | WantSignatureMethod | Gets or sets the XML signature algorithm expected from the partner provider. If not specified then any algorithm is accepted. (Inherited from PartnerProviderConfiguration.)
Top
See Also

Reference

PartnerServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration.AssertionConsumerServiceUrl Property

PartnerServiceProviderConfigurationAssertionConsumerServiceUrl Property

Gets or sets the partner service provider's assertion consumer service URL.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string AssertionConsumerServiceUrl { get; set; }
Public Property AssertionConsumerServiceUrl As String
    Get
    Set
public:
property String^ AssertionConsumerServiceUrl {
    String^ get ();
    void set (String^ value);
}
member AssertionConsumerServiceUrl : string with get, set

Property Value

Type: String
The partner service provider's assertion consumer service URL.
See Also

Reference

PartnerServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration.AssertionLifeTime Property

PartnerServiceProviderConfigurationAssertionLifeTime Property

Gets or sets the time span for which SAML assertions will be valid.

The default time span is 3 minutes.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public TimeSpan AssertionLifeTime { get; set; }
Public Property AssertionLifeTime As TimeSpan
    Get
    Set
public:
property TimeSpan AssertionLifeTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
member AssertionLifeTime : TimeSpan with get, set

Property Value

Type: TimeSpan
The time span for which SAML assertions will be valid.
See Also

Reference

PartnerServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration.EncryptAssertion Property

PartnerServiceProviderConfigurationEncryptAssertion Property

Gets or sets the flag indicating whether to encrypt SAML assertions.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool EncryptAssertion { get; set; }
Public Property EncryptAssertion As Boolean
    Get
    Set
public:
property bool EncryptAssertion {
    bool get ();
    void set (bool value);
}
member EncryptAssertion : bool with get, set

Property Value

Type: Boolean
The flag indicating whether to encrypt SAML assertions.
See Also

Reference

PartnerServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration.SignAssertion Property

PartnerServiceProviderConfigurationSignAssertion Property

Gets or sets the flag indicating whether to sign SAML assertions.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool SignAssertion { get; set; }
Public Property SignAssertion As Boolean
    Get
    Set
public:
property bool SignAssertion {
    bool get ();
    void set (bool value);
}
member SignAssertion : bool with get, set

Property Value

Type: Boolean
The flag indicating whether to sign SAML assertions.
See Also

Reference

PartnerServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration.SignSAMLResponse Property

PartnerServiceProviderConfigurationSignSAMLResponse Property

Gets or sets the flag indicating whether to sign SAML responses.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool SignSAMLResponse { get; set; }
Public Property SignSAMLResponse As Boolean
    Get
    Set
public:
property bool SignSAMLResponse {
    bool get ();
    void set (bool value);
}
member SignSAMLResponse : bool with get, set

Property Value

Type: Boolean
The flag indicating whether to sign SAML responses.
See Also

Reference

PartnerServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration.WantAuthnRequestSigned Property

PartnerServiceProviderConfigurationWantAuthnRequestSigned Property

Gets or sets the flag indicating whether authn requests should be signed.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool WantAuthnRequestSigned { get; set; }
Public Property WantAuthnRequestSigned As Boolean
    Get
    Set
public:
property bool WantAuthnRequestSigned {
    bool get ();
    void set (bool value);
}
member WantAuthnRequestSigned : bool with get, set

Property Value

Type: Boolean
The flag indicating whether authn requests should be signed.
See Also

Reference

PartnerServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration Methods

The PartnerServiceProviderConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the partner service provider configuration to XML. (Overrides PartnerProviderConfigurationToXml(XmlElement).)
Top
See Also

Reference

PartnerServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


PartnerServiceProviderConfiguration.ToXml Method

PartnerServiceProviderConfigurationToXml Method

Serializes the partner service provider configuration to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    XmlElement xmlElement
)
Public Overrides Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
) override
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element.
See Also

Reference

PartnerServiceProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration Class

The provider configuration is configuration common to local and partner identity providers and service providers.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationProviderConfiguration
ComponentSpace.SAML2.ConfigurationLocalProviderConfiguration
ComponentSpace.SAML2.ConfigurationPartnerProviderConfiguration

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class ProviderConfiguration
Public MustInherit Class ProviderConfiguration
public ref class ProviderConfiguration abstract
[<AbstractClassAttribute>]
type ProviderConfiguration =  class end

The ProviderConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | ProviderConfiguration | Constructs a provider configuration.
Public method | ProviderConfiguration(XmlElement) | Constructs a provider configuration from XML.
Top
Properties
 | Name | Description
Public property | Description | Gets or sets the provider description.
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder.
Public property | LocalCertificatePassword | Gets or sets the local certificate file password.
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key.
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number.
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location.
Public property | LocalCertificateSubject | Gets or sets the local certificate subject.
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint.
Public property | Name | Gets or sets the provider name.
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder.
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password.
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key.
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number.
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location.
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject.
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the provider configuration to XML.
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration Constructor

Overload List
 | Name | Description
Public method | ProviderConfiguration | Constructs a provider configuration.
Public method | ProviderConfiguration(XmlElement) | Constructs a provider configuration from XML.
Top
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration Constructor

Constructs a provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ProviderConfiguration()
Public Sub New
public:
ProviderConfiguration()
new : unit -> ProviderConfiguration
See Also

Reference

ProviderConfiguration Class
ProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration Constructor (XmlElement)

Constructs a provider configuration from XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ProviderConfiguration(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
ProviderConfiguration(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> ProviderConfiguration

Parameters

xmlElement
Type: System.XmlXmlElement
The provider configuration XML.
See Also

Reference

ProviderConfiguration Class
ProviderConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration Properties

The ProviderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the provider description.
Public property | LocalCertificateFile | Gets or sets the local certificate file path. The file path is either absolute or relative to the application folder.
Public property | LocalCertificatePassword | Gets or sets the local certificate file password.
Public property | LocalCertificatePasswordKey | Gets or sets the local certificate file password key.
Public property | LocalCertificateSerialNumber | Gets or sets the local certificate serial number.
Public property | LocalCertificateStoreLocation | Gets or sets the local certificate store location.
Public property | LocalCertificateSubject | Gets or sets the local certificate subject.
Public property | LocalCertificateThumbprint | Gets or sets the local certificate thumbprint.
Public property | Name | Gets or sets the provider name.
Public property | SecondaryLocalCertificateFile | Gets or sets the secondary local certificate file path. The file path is either absolute or relative to the application folder.
Public property | SecondaryLocalCertificatePassword | Gets or sets the secondary local certificate file password.
Public property | SecondaryLocalCertificatePasswordKey | Gets or sets the secondary local certificate file password key.
Public property | SecondaryLocalCertificateSerialNumber | Gets or sets the secondary local certificate serial number.
Public property | SecondaryLocalCertificateStoreLocation | Gets or sets the secondary local certificate store location.
Public property | SecondaryLocalCertificateSubject | Gets or sets the secondary local certificate subject.
Public property | SecondaryLocalCertificateThumbprint | Gets or sets the secondary local certificate thumbprint.
Top
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.Description Property

ProviderConfigurationDescription Property

Gets or sets the provider description.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
The provider description.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.LocalCertificateFile Property

ProviderConfigurationLocalCertificateFile Property

Gets or sets the local certificate file path.

The file path is either absolute or relative to the application folder.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string LocalCertificateFile { get; set; }
Public Property LocalCertificateFile As String
    Get
    Set
public:
property String^ LocalCertificateFile {
    String^ get ();
    void set (String^ value);
}
member LocalCertificateFile : string with get, set

Property Value

Type: String
The local certificate file path.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.LocalCertificatePassword Property

ProviderConfigurationLocalCertificatePassword Property

Gets or sets the local certificate file password.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string LocalCertificatePassword { get; set; }
Public Property LocalCertificatePassword As String
    Get
    Set
public:
property String^ LocalCertificatePassword {
    String^ get ();
    void set (String^ value);
}
member LocalCertificatePassword : string with get, set

Property Value

Type: String
The local certificate file password.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.LocalCertificatePasswordKey Property

ProviderConfigurationLocalCertificatePasswordKey Property

Gets or sets the local certificate file password key.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string LocalCertificatePasswordKey { get; set; }
Public Property LocalCertificatePasswordKey As String
    Get
    Set
public:
property String^ LocalCertificatePasswordKey {
    String^ get ();
    void set (String^ value);
}
member LocalCertificatePasswordKey : string with get, set

Property Value

Type: String
The local certificate file password key.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.LocalCertificateSerialNumber Property

ProviderConfigurationLocalCertificateSerialNumber Property

Gets or sets the local certificate serial number.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string LocalCertificateSerialNumber { get; set; }
Public Property LocalCertificateSerialNumber As String
    Get
    Set
public:
property String^ LocalCertificateSerialNumber {
    String^ get ();
    void set (String^ value);
}
member LocalCertificateSerialNumber : string with get, set

Property Value

Type: String
The local certificate serial number.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.LocalCertificateStoreLocation Property

ProviderConfigurationLocalCertificateStoreLocation Property

Gets or sets the local certificate store location.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StoreLocation LocalCertificateStoreLocation { get; set; }
Public Property LocalCertificateStoreLocation As StoreLocation
    Get
    Set
public:
property StoreLocation LocalCertificateStoreLocation {
    StoreLocation get ();
    void set (StoreLocation value);
}
member LocalCertificateStoreLocation : StoreLocation with get, set

Property Value

Type: StoreLocation
The local certificate store location.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.LocalCertificateSubject Property

ProviderConfigurationLocalCertificateSubject Property

Gets or sets the local certificate subject.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string LocalCertificateSubject { get; set; }
Public Property LocalCertificateSubject As String
    Get
    Set
public:
property String^ LocalCertificateSubject {
    String^ get ();
    void set (String^ value);
}
member LocalCertificateSubject : string with get, set

Property Value

Type: String
The local certificate subject.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.LocalCertificateThumbprint Property

ProviderConfigurationLocalCertificateThumbprint Property

Gets or sets the local certificate thumbprint.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string LocalCertificateThumbprint { get; set; }
Public Property LocalCertificateThumbprint As String
    Get
    Set
public:
property String^ LocalCertificateThumbprint {
    String^ get ();
    void set (String^ value);
}
member LocalCertificateThumbprint : string with get, set

Property Value

Type: String
The local certificate thumbprint.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.Name Property

ProviderConfigurationName Property

Gets or sets the provider name.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The provider name.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.SecondaryLocalCertificateFile Property

ProviderConfigurationSecondaryLocalCertificateFile Property

Gets or sets the secondary local certificate file path.

The file path is either absolute or relative to the application folder.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SecondaryLocalCertificateFile { get; set; }
Public Property SecondaryLocalCertificateFile As String
    Get
    Set
public:
property String^ SecondaryLocalCertificateFile {
    String^ get ();
    void set (String^ value);
}
member SecondaryLocalCertificateFile : string with get, set

Property Value

Type: String
The secondary local certificate file path.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.SecondaryLocalCertificatePassword Property

ProviderConfigurationSecondaryLocalCertificatePassword Property

Gets or sets the secondary local certificate file password.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SecondaryLocalCertificatePassword { get; set; }
Public Property SecondaryLocalCertificatePassword As String
    Get
    Set
public:
property String^ SecondaryLocalCertificatePassword {
    String^ get ();
    void set (String^ value);
}
member SecondaryLocalCertificatePassword : string with get, set

Property Value

Type: String
The secondary local certificate file password.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.SecondaryLocalCertificatePasswordKey Property

ProviderConfigurationSecondaryLocalCertificatePasswordKey Property

Gets or sets the secondary local certificate file password key.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SecondaryLocalCertificatePasswordKey { get; set; }
Public Property SecondaryLocalCertificatePasswordKey As String
    Get
    Set
public:
property String^ SecondaryLocalCertificatePasswordKey {
    String^ get ();
    void set (String^ value);
}
member SecondaryLocalCertificatePasswordKey : string with get, set

Property Value

Type: String
The secondary local certificate file password key.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.SecondaryLocalCertificateSerialNumber Property

ProviderConfigurationSecondaryLocalCertificateSerialNumber Property

Gets or sets the secondary local certificate serial number.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SecondaryLocalCertificateSerialNumber { get; set; }
Public Property SecondaryLocalCertificateSerialNumber As String
    Get
    Set
public:
property String^ SecondaryLocalCertificateSerialNumber {
    String^ get ();
    void set (String^ value);
}
member SecondaryLocalCertificateSerialNumber : string with get, set

Property Value

Type: String
The secondary local certificate serial number.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.SecondaryLocalCertificateStoreLocation Property

ProviderConfigurationSecondaryLocalCertificateStoreLocation Property

Gets or sets the secondary local certificate store location.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StoreLocation SecondaryLocalCertificateStoreLocation { get; set; }
Public Property SecondaryLocalCertificateStoreLocation As StoreLocation
    Get
    Set
public:
property StoreLocation SecondaryLocalCertificateStoreLocation {
    StoreLocation get ();
    void set (StoreLocation value);
}
member SecondaryLocalCertificateStoreLocation : StoreLocation with get, set

Property Value

Type: StoreLocation
The secondary local certificate store location.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.SecondaryLocalCertificateSubject Property

ProviderConfigurationSecondaryLocalCertificateSubject Property

Gets or sets the secondary local certificate subject.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SecondaryLocalCertificateSubject { get; set; }
Public Property SecondaryLocalCertificateSubject As String
    Get
    Set
public:
property String^ SecondaryLocalCertificateSubject {
    String^ get ();
    void set (String^ value);
}
member SecondaryLocalCertificateSubject : string with get, set

Property Value

Type: String
The secondary local certificate subject.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.SecondaryLocalCertificateThumbprint Property

ProviderConfigurationSecondaryLocalCertificateThumbprint Property

Gets or sets the secondary local certificate thumbprint.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SecondaryLocalCertificateThumbprint { get; set; }
Public Property SecondaryLocalCertificateThumbprint As String
    Get
    Set
public:
property String^ SecondaryLocalCertificateThumbprint {
    String^ get ();
    void set (String^ value);
}
member SecondaryLocalCertificateThumbprint : string with get, set

Property Value

Type: String
The secondary local certificate thumbprint.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration Methods

The ProviderConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the provider configuration to XML.
Top
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


ProviderConfiguration.ToXml Method

ProviderConfigurationToXml Method

Serializes the provider configuration to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void ToXml(
    XmlElement xmlElement
)
Public Overridable Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
)
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element.
See Also

Reference

ProviderConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration Class

The SAML configuration specifies the configuration for SAML single sign-on.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationSAMLConfiguration

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SAMLConfiguration
Public Class SAMLConfiguration
public ref class SAMLConfiguration
type SAMLConfiguration =  class end

The SAMLConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | SAMLConfiguration | Initializes a new instance of the SAMLConfiguration class.
Public method | SAMLConfiguration(XmlElement) | Initializes a new instance of the SAMLConfiguration class.
Top
Properties
 | Name | Description
Public property | ID | Gets or sets the configuration ID. The configuration ID is used in multi-tenanted applications.
Public property | LocalIdentityProviderConfiguration | Gets or sets the local identity provider configuration.
Public property | LocalServiceProviderConfiguration | Gets or sets the local service provider configuration.
Public property | PartnerIdentityProviderConfigurations | Gets or sets the partner identity provider configurations.
Public property | PartnerServiceProviderConfigurations | Gets or sets the partner service provider configurations.
Top
Methods
 | Name | Description
Public method | AddPartnerIdentityProvider | Adds the partner identity provider configuration.
Public method | AddPartnerServiceProvider | Adds the partner service provider configuration.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartnerIdentityProvider | Gets the specified partner identity provider configuration. If a single partner identity provider is configured then a name doesn't have to be specified.
Public method | GetPartnerServiceProvider | Gets the specified partner service provider configuration. If a single partner service provider is configured then a name doesn't have to be specified.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the configuration to XML.
Public method | ToXml(XmlDocument) | Serializes the configuration to XML.
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration Constructor

Overload List
 | Name | Description
Public method | SAMLConfiguration | Initializes a new instance of the SAMLConfiguration class.
Public method | SAMLConfiguration(XmlElement) | Initializes a new instance of the SAMLConfiguration class.
Top
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration Constructor

Initializes a new instance of the SAMLConfiguration class.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLConfiguration()
Public Sub New
public:
SAMLConfiguration()
new : unit -> SAMLConfiguration
See Also

Reference

SAMLConfiguration Class
SAMLConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration Constructor (XmlElement)

Initializes a new instance of the SAMLConfiguration class.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLConfiguration(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SAMLConfiguration(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SAMLConfiguration

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML configuration XML.
See Also

Reference

SAMLConfiguration Class
SAMLConfiguration Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration Properties

The SAMLConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ID | Gets or sets the configuration ID. The configuration ID is used in multi-tenanted applications.
Public property | LocalIdentityProviderConfiguration | Gets or sets the local identity provider configuration.
Public property | LocalServiceProviderConfiguration | Gets or sets the local service provider configuration.
Public property | PartnerIdentityProviderConfigurations | Gets or sets the partner identity provider configurations.
Public property | PartnerServiceProviderConfigurations | Gets or sets the partner service provider configurations.
Top
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.ID Property

SAMLConfigurationID Property

Gets or sets the configuration ID.

The configuration ID is used in multi-tenanted applications.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
The configuration ID or null if none.
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.LocalIdentityProviderConfiguration Property

SAMLConfigurationLocalIdentityProviderConfiguration Property

Gets or sets the local identity provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalIdentityProviderConfiguration LocalIdentityProviderConfiguration { get; set; }
Public Property LocalIdentityProviderConfiguration As LocalIdentityProviderConfiguration
    Get
    Set
public:
property LocalIdentityProviderConfiguration^ LocalIdentityProviderConfiguration {
    LocalIdentityProviderConfiguration^ get ();
    void set (LocalIdentityProviderConfiguration^ value);
}
member LocalIdentityProviderConfiguration : LocalIdentityProviderConfiguration with get, set

Property Value

Type: LocalIdentityProviderConfiguration
The local identity provider configuration.
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.LocalServiceProviderConfiguration Property

SAMLConfigurationLocalServiceProviderConfiguration Property

Gets or sets the local service provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalServiceProviderConfiguration LocalServiceProviderConfiguration { get; set; }
Public Property LocalServiceProviderConfiguration As LocalServiceProviderConfiguration
    Get
    Set
public:
property LocalServiceProviderConfiguration^ LocalServiceProviderConfiguration {
    LocalServiceProviderConfiguration^ get ();
    void set (LocalServiceProviderConfiguration^ value);
}
member LocalServiceProviderConfiguration : LocalServiceProviderConfiguration with get, set

Property Value

Type: LocalServiceProviderConfiguration
The local service provider configuration.
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.PartnerIdentityProviderConfigurations Property

SAMLConfigurationPartnerIdentityProviderConfigurations Property

Gets or sets the partner identity provider configurations.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, PartnerIdentityProviderConfiguration> PartnerIdentityProviderConfigurations { get; set; }
Public Property PartnerIdentityProviderConfigurations As IDictionary(Of String, PartnerIdentityProviderConfiguration)
    Get
    Set
public:
property IDictionary<String^, PartnerIdentityProviderConfiguration^>^ PartnerIdentityProviderConfigurations {
    IDictionary<String^, PartnerIdentityProviderConfiguration^>^ get ();
    void set (IDictionary<String^, PartnerIdentityProviderConfiguration^>^ value);
}
member PartnerIdentityProviderConfigurations : IDictionary<string, PartnerIdentityProviderConfiguration> with get, set

Property Value

Type: IDictionary String, PartnerIdentityProviderConfiguration
The partner identity provider configurations.
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.PartnerServiceProviderConfigurations Property

SAMLConfigurationPartnerServiceProviderConfigurations Property

Gets or sets the partner service provider configurations.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, PartnerServiceProviderConfiguration> PartnerServiceProviderConfigurations { get; set; }
Public Property PartnerServiceProviderConfigurations As IDictionary(Of String, PartnerServiceProviderConfiguration)
    Get
    Set
public:
property IDictionary<String^, PartnerServiceProviderConfiguration^>^ PartnerServiceProviderConfigurations {
    IDictionary<String^, PartnerServiceProviderConfiguration^>^ get ();
    void set (IDictionary<String^, PartnerServiceProviderConfiguration^>^ value);
}
member PartnerServiceProviderConfigurations : IDictionary<string, PartnerServiceProviderConfiguration> with get, set

Property Value

Type: IDictionary String, PartnerServiceProviderConfiguration
The partner service provider configurations.
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration Methods

The SAMLConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | AddPartnerIdentityProvider | Adds the partner identity provider configuration.
Public method | AddPartnerServiceProvider | Adds the partner service provider configuration.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartnerIdentityProvider | Gets the specified partner identity provider configuration. If a single partner identity provider is configured then a name doesn't have to be specified.
Public method | GetPartnerServiceProvider | Gets the specified partner service provider configuration. If a single partner service provider is configured then a name doesn't have to be specified.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the configuration to XML.
Public method | ToXml(XmlDocument) | Serializes the configuration to XML.
Top
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.AddPartnerIdentityProvider Method

SAMLConfigurationAddPartnerIdentityProvider Method

Adds the partner identity provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void AddPartnerIdentityProvider(
    PartnerIdentityProviderConfiguration partnerIdentityProviderConfiguration
)
Public Sub AddPartnerIdentityProvider (
    partnerIdentityProviderConfiguration As PartnerIdentityProviderConfiguration
)
public:
void AddPartnerIdentityProvider(
    PartnerIdentityProviderConfiguration^ partnerIdentityProviderConfiguration
)
member AddPartnerIdentityProvider :
        partnerIdentityProviderConfiguration : PartnerIdentityProviderConfiguration -> unit

Parameters

partnerIdentityProviderConfiguration
Type: ComponentSpace.SAML2.ConfigurationPartnerIdentityProviderConfiguration
The partner identity provider configuration.
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.AddPartnerServiceProvider Method

SAMLConfigurationAddPartnerServiceProvider Method

Adds the partner service provider configuration.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void AddPartnerServiceProvider(
    PartnerServiceProviderConfiguration partnerServiceProviderConfiguration
)
Public Sub AddPartnerServiceProvider (
    partnerServiceProviderConfiguration As PartnerServiceProviderConfiguration
)
public:
void AddPartnerServiceProvider(
    PartnerServiceProviderConfiguration^ partnerServiceProviderConfiguration
)
member AddPartnerServiceProvider :
        partnerServiceProviderConfiguration : PartnerServiceProviderConfiguration -> unit

Parameters

partnerServiceProviderConfiguration
Type: ComponentSpace.SAML2.ConfigurationPartnerServiceProviderConfiguration
The partner service provider configuration.
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.GetPartnerIdentityProvider Method

SAMLConfigurationGetPartnerIdentityProvider Method

Gets the specified partner identity provider configuration.

If a single partner identity provider is configured then a name doesn't have to be specified.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public PartnerIdentityProviderConfiguration GetPartnerIdentityProvider(
    string name
)
Public Function GetPartnerIdentityProvider (
    name As String
) As PartnerIdentityProviderConfiguration
public:
PartnerIdentityProviderConfiguration^ GetPartnerIdentityProvider(
    String^ name
)
member GetPartnerIdentityProvider :
        name : string -> PartnerIdentityProviderConfiguration

Parameters

name
Type: SystemString
The partner identity provider name or null if none.

Return Value

Type: PartnerIdentityProviderConfiguration
The partner identity provider configuration.
Exceptions
Exception | Condition
SAMLException | Thrown when the partner identity provider configuration cannot be found.
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.GetPartnerServiceProvider Method

SAMLConfigurationGetPartnerServiceProvider Method

Gets the specified partner service provider configuration.

If a single partner service provider is configured then a name doesn't have to be specified.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public PartnerServiceProviderConfiguration GetPartnerServiceProvider(
    string name
)
Public Function GetPartnerServiceProvider (
    name As String
) As PartnerServiceProviderConfiguration
public:
PartnerServiceProviderConfiguration^ GetPartnerServiceProvider(
    String^ name
)
member GetPartnerServiceProvider :
        name : string -> PartnerServiceProviderConfiguration

Parameters

name
Type: SystemString
The partner service provider name or null if none.

Return Value

Type: PartnerServiceProviderConfiguration
The partner service provider configuration.
Exceptions
Exception | Condition
SAMLException | Thrown when the partner service provider configuration cannot be found.
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.ToXml Method

SAMLConfigurationToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the configuration to XML.
Public method | ToXml(XmlDocument) | Serializes the configuration to XML.
Top
See Also

Reference

SAMLConfiguration Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.ToXml Method

SAMLConfigurationToXml Method

Serializes the configuration to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The configuration as XML.
See Also

Reference

SAMLConfiguration Class
ToXml Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfiguration.ToXml Method (XmlDocument)

SAMLConfigurationToXml Method (XmlDocument)

Serializes the configuration to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The configuration as XML.
See Also

Reference

SAMLConfiguration Class
ToXml Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile Class

Loads and saves SAML configuration files.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationSAMLConfigurationFile

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAMLConfigurationFile
Public NotInheritable Class SAMLConfigurationFile
public ref class SAMLConfigurationFile abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAMLConfigurationFile =  class end

The SAMLConfigurationFile type exposes the following members.

Properties
Name | Description
ReloadOnConfigurationChange | Gets or sets the flag indicating whether the application should be reloaded if the configuration file changes.
Top
Methods
Name | Description
Load | Loads the configuration from the saml.config file. The configuration file path may be specified by the SAMLConfigFile application setting in web.config. Otherwise, the saml.config is assumed to be in the application folder.
Load(String) | Loads the configuration from the specified file.
Save(SAMLConfiguration) | Saves the configuration to the saml.config file. The configuration file path may be specified by the SAMLConfigFile application setting in web.config. Otherwise, the saml.config is assumed to be in the application folder.
Save(SAMLConfigurations) | Saves the configurations to the saml.config file. The configuration file path may be specified by the SAMLConfigFile application setting in web.config. Otherwise, the saml.config is assumed to be in the application folder.
Save(SAMLConfiguration, String) | Saves the configuration to the file.
Save(SAMLConfigurations, String) | Saves the configurations to the file.
Validate | Validates the configuration file against the XML schema.
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile Properties

The SAMLConfigurationFile type exposes the following members.

Properties
Name | Description
ReloadOnConfigurationChange | Gets or sets the flag indicating whether the application should be reloaded if the configuration file changes.
Top
See Also

Reference

SAMLConfigurationFile Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile.ReloadOnConfigurationChange Property

SAMLConfigurationFileReloadOnConfigurationChange Property

Gets or sets the flag indicating whether the application should be reloaded if the configuration file changes.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool ReloadOnConfigurationChange { get; set; }
Public Shared Property ReloadOnConfigurationChange As Boolean
    Get
    Set
public:
static property bool ReloadOnConfigurationChange {
    bool get ();
    void set (bool value);
}
static member ReloadOnConfigurationChange : bool with get, set

Property Value

Type: Boolean
The flag indicating whether the application should be reloaded if the configuration file changes.
See Also

Reference

SAMLConfigurationFile Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile Methods

The SAMLConfigurationFile type exposes the following members.

Methods
Name | Description
Load | Loads the configuration from the saml.config file. The configuration file path may be specified by the SAMLConfigFile application setting in web.config. Otherwise, the saml.config is assumed to be in the application folder.
Load(String) | Loads the configuration from the specified file.
Save(SAMLConfiguration) | Saves the configuration to the saml.config file. The configuration file path may be specified by the SAMLConfigFile application setting in web.config. Otherwise, the saml.config is assumed to be in the application folder.
Save(SAMLConfigurations) | Saves the configurations to the saml.config file. The configuration file path may be specified by the SAMLConfigFile application setting in web.config. Otherwise, the saml.config is assumed to be in the application folder.
Save(SAMLConfiguration, String) | Saves the configuration to the file.
Save(SAMLConfigurations, String) | Saves the configurations to the file.
Validate | Validates the configuration file against the XML schema.
Top
See Also

Reference

SAMLConfigurationFile Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile.Load Method

SAMLConfigurationFileLoad Method

Overload List
Name | Description
Load | Loads the configuration from the saml.config file. The configuration file path may be specified by the SAMLConfigFile application setting in web.config. Otherwise, the saml.config is assumed to be in the application folder.
Load(String) | Loads the configuration from the specified file.
Top
See Also

Reference

SAMLConfigurationFile Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile.Load Method

SAMLConfigurationFileLoad Method

Loads the configuration from the saml.config file.

The configuration file path may be specified by the SAMLConfigFile application setting in web.config.

Otherwise, the saml.config is assumed to be in the application folder.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static SAMLConfigurations Load()
Public Shared Function Load As SAMLConfigurations
public:
static SAMLConfigurations^ Load()
static member Load : unit -> SAMLConfigurations

Return Value

Type: SAMLConfigurations
The SAML configurations.
Exceptions
Exception | Condition
SAMLException | Thrown when the SAML configuration cannot be loaded.
See Also

Reference

SAMLConfigurationFile Class
Load Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile.Load Method (String)

SAMLConfigurationFileLoad Method (String)

Loads the configuration from the specified file.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static SAMLConfigurations Load(
    string fileName
)
Public Shared Function Load (
    fileName As String
) As SAMLConfigurations
public:
static SAMLConfigurations^ Load(
    String^ fileName
)
static member Load :
        fileName : string -> SAMLConfigurations

Parameters

fileName
Type: SystemString
The configuration file.

Return Value

Type: SAMLConfigurations
The SAML configurations.
Exceptions
Exception | Condition
SAMLException | Thrown when the SAML configuration cannot be loaded.
See Also

Reference

SAMLConfigurationFile Class
Load Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile.Save Method

SAMLConfigurationFileSave Method

Overload List
Name | Description
Save(SAMLConfiguration) | Saves the configuration to the saml.config file. The configuration file path may be specified by the SAMLConfigFile application setting in web.config. Otherwise, the saml.config is assumed to be in the application folder.
Save(SAMLConfigurations) | Saves the configurations to the saml.config file. The configuration file path may be specified by the SAMLConfigFile application setting in web.config. Otherwise, the saml.config is assumed to be in the application folder.
Save(SAMLConfiguration, String) | Saves the configuration to the file.
Save(SAMLConfigurations, String) | Saves the configurations to the file.
Top
See Also

Reference

SAMLConfigurationFile Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile.Save Method (SAMLConfiguration)

SAMLConfigurationFileSave Method (SAMLConfiguration)

Saves the configuration to the saml.config file.

The configuration file path may be specified by the SAMLConfigFile application setting in web.config.

Otherwise, the saml.config is assumed to be in the application folder.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Save(
    SAMLConfiguration samlConfiguration
)
Public Shared Sub Save (
    samlConfiguration As SAMLConfiguration
)
public:
static void Save(
    SAMLConfiguration^ samlConfiguration
)
static member Save :
        samlConfiguration : SAMLConfiguration -> unit

Parameters

samlConfiguration
Type: ComponentSpace.SAML2.ConfigurationSAMLConfiguration
The SAML configuration.
Exceptions
Exception | Condition
SAMLException | Thrown when the SAML configuration cannot be saved.
See Also

Reference

SAMLConfigurationFile Class
Save Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile.Save Method (SAMLConfigurations)

SAMLConfigurationFileSave Method (SAMLConfigurations)

Saves the configurations to the saml.config file.

The configuration file path may be specified by the SAMLConfigFile application setting in web.config.

Otherwise, the saml.config is assumed to be in the application folder.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Save(
    SAMLConfigurations samlConfigurations
)
Public Shared Sub Save (
    samlConfigurations As SAMLConfigurations
)
public:
static void Save(
    SAMLConfigurations^ samlConfigurations
)
static member Save :
        samlConfigurations : SAMLConfigurations -> unit

Parameters

samlConfigurations
Type: ComponentSpace.SAML2.ConfigurationSAMLConfigurations
The SAML configurations.
Exceptions
Exception | Condition
SAMLException | Thrown when the SAML configurations cannot be saved.
See Also

Reference

SAMLConfigurationFile Class
Save Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile.Save Method (SAMLConfiguration, String)

SAMLConfigurationFileSave Method (SAMLConfiguration, String)

Saves the configuration to the file.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Save(
    SAMLConfiguration samlConfiguration,
    string fileName
)
Public Shared Sub Save (
    samlConfiguration As SAMLConfiguration,
    fileName As String
)
public:
static void Save(
    SAMLConfiguration^ samlConfiguration,
    String^ fileName
)
static member Save :
        samlConfiguration : SAMLConfiguration *
        fileName : string -> unit

Parameters

samlConfiguration
Type: ComponentSpace.SAML2.ConfigurationSAMLConfiguration
The SAML configuration.
fileName
Type: SystemString
The configuration file.
Exceptions
Exception | Condition
SAMLException | Thrown when the SAML configuration cannot be saved.
See Also

Reference

SAMLConfigurationFile Class
Save Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile.Save Method (SAMLConfigurations, String)

SAMLConfigurationFileSave Method (SAMLConfigurations, String)

Saves the configurations to the file.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Save(
    SAMLConfigurations samlConfigurations,
    string fileName
)
Public Shared Sub Save (
    samlConfigurations As SAMLConfigurations,
    fileName As String
)
public:
static void Save(
    SAMLConfigurations^ samlConfigurations,
    String^ fileName
)
static member Save :
        samlConfigurations : SAMLConfigurations *
        fileName : string -> unit

Parameters

samlConfigurations
Type: ComponentSpace.SAML2.ConfigurationSAMLConfigurations
The SAML configurations.
fileName
Type: SystemString
The configuration file.
Exceptions
Exception | Condition
SAMLException | Thrown when the SAML configurations cannot be saved.
See Also

Reference

SAMLConfigurationFile Class
Save Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurationFile.Validate Method

SAMLConfigurationFileValidate Method

Validates the configuration file against the XML schema.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Validate(
    string fileName
)
Public Shared Sub Validate (
    fileName As String
)
public:
static void Validate(
    String^ fileName
)
static member Validate :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
The configuration file.
Exceptions
Exception | Condition
SAMLException | Thrown when the validation fails.
See Also

Reference

SAMLConfigurationFile Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations Class

The SAML configurations specifies the configurations for SAML single sign-on.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ConfigurationSAMLConfigurations

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SAMLConfigurations
Public Class SAMLConfigurations
public ref class SAMLConfigurations
type SAMLConfigurations =  class end

The SAMLConfigurations type exposes the following members.

Constructors
 | Name | Description
Public method | SAMLConfigurations | Initializes a new instance of the SAMLConfigurations class.
Public method | SAMLConfigurations(XmlElement) | Initializes a new instance of the SAMLConfigurations class.
Top
Properties
 | Name | Description
Public property | Configurations | Gets or sets the dictionary of SAML configurations keyed by configuration ID.
Public property | ReloadOnConfigurationChange | Gets or sets the flag indicating whether the application should be reloaded if the configuration changes.
Public property | TraceLevel | Gets or sets the trace level. The diagnostics section in web.config specifies the trace configuration. This includes the trace switch value which effectively turns verbose trace on or off. The trace level property may be used to override the trace switch. If the trace level is not set then the trace switch is in effect. If the trace level is set then this overrides the trace switch.
Public property | ValidateMessagesAgainstSchema | Gets or sets the flag indicating whether SAML messages should be validated against the XML schema.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the configurations to XML.
Public method | ToXml(XmlDocument) | Serializes the configurations to XML.
Top
See Also

Reference

ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations Constructor

Overload List
 | Name | Description
Public method | SAMLConfigurations | Initializes a new instance of the SAMLConfigurations class.
Public method | SAMLConfigurations(XmlElement) | Initializes a new instance of the SAMLConfigurations class.
Top
See Also

Reference

SAMLConfigurations Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations Constructor

Initializes a new instance of the SAMLConfigurations class.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLConfigurations()
Public Sub New
public:
SAMLConfigurations()
new : unit -> SAMLConfigurations
See Also

Reference

SAMLConfigurations Class
SAMLConfigurations Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations Constructor (XmlElement)

Initializes a new instance of the SAMLConfigurations class.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLConfigurations(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SAMLConfigurations(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SAMLConfigurations

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML configuration XML.
See Also

Reference

SAMLConfigurations Class
SAMLConfigurations Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations Properties

The SAMLConfigurations type exposes the following members.

Properties
 | Name | Description
Public property | Configurations | Gets or sets the dictionary of SAML configurations keyed by configuration ID.
Public property | ReloadOnConfigurationChange | Gets or sets the flag indicating whether the application should be reloaded if the configuration changes.
Public property | TraceLevel | Gets or sets the trace level. The diagnostics section in web.config specifies the trace configuration. This includes the trace switch value which effectively turns verbose trace on or off. The trace level property may be used to override the trace switch. If the trace level is not set then the trace switch is in effect. If the trace level is set then this overrides the trace switch.
Public property | ValidateMessagesAgainstSchema | Gets or sets the flag indicating whether SAML messages should be validated against the XML schema.
Top
See Also

Reference

SAMLConfigurations Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations.Configurations Property

SAMLConfigurationsConfigurations Property

Gets or sets the dictionary of SAML configurations keyed by configuration ID.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, SAMLConfiguration> Configurations { get; set; }
Public Property Configurations As IDictionary(Of String, SAMLConfiguration)
    Get
    Set
public:
property IDictionary<String^, SAMLConfiguration^>^ Configurations {
    IDictionary<String^, SAMLConfiguration^>^ get ();
    void set (IDictionary<String^, SAMLConfiguration^>^ value);
}
member Configurations : IDictionary<string, SAMLConfiguration> with get, set

Property Value

Type: IDictionary String, SAMLConfiguration
The dictionary of SAML configurations.
See Also

Reference

SAMLConfigurations Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations.ReloadOnConfigurationChange Property

SAMLConfigurationsReloadOnConfigurationChange Property

Gets or sets the flag indicating whether the application should be reloaded if the configuration changes.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool ReloadOnConfigurationChange { get; set; }
Public Property ReloadOnConfigurationChange As Boolean
    Get
    Set
public:
property bool ReloadOnConfigurationChange {
    bool get ();
    void set (bool value);
}
member ReloadOnConfigurationChange : bool with get, set

Property Value

Type: Boolean
The flag indicating whether the application should be reloaded if the configuration changes.
See Also

Reference

SAMLConfigurations Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations.TraceLevel Property

SAMLConfigurationsTraceLevel Property

Gets or sets the trace level.

The diagnostics section in web.config specifies the trace configuration. This includes the trace switch value which effectively turns verbose trace on or off. The trace level property may be used to override the trace switch. If the trace level is not set then the trace switch is in effect. If the trace level is set then this overrides the trace switch.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Nullable<TraceLevel> TraceLevel { get; set; }
Public Property TraceLevel As Nullable(Of TraceLevel)
    Get
    Set
public:
property Nullable<TraceLevel> TraceLevel {
    Nullable<TraceLevel> get ();
    void set (Nullable<TraceLevel> value);
}
member TraceLevel : Nullable<TraceLevel> with get, set

Property Value

Type: Nullable TraceLevel
The trace level.
See Also

Reference

SAMLConfigurations Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations.ValidateMessagesAgainstSchema Property

SAMLConfigurationsValidateMessagesAgainstSchema Property

Gets or sets the flag indicating whether SAML messages should be validated against the XML schema.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool ValidateMessagesAgainstSchema { get; set; }
Public Property ValidateMessagesAgainstSchema As Boolean
    Get
    Set
public:
property bool ValidateMessagesAgainstSchema {
    bool get ();
    void set (bool value);
}
member ValidateMessagesAgainstSchema : bool with get, set

Property Value

Type: Boolean
The flag indicating whether SAML messages should be validated against the XML schema.
See Also

Reference

SAMLConfigurations Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations Methods

The SAMLConfigurations type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the configurations to XML.
Public method | ToXml(XmlDocument) | Serializes the configurations to XML.
Top
See Also

Reference

SAMLConfigurations Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations.ToXml Method

SAMLConfigurationsToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the configurations to XML.
Public method | ToXml(XmlDocument) | Serializes the configurations to XML.
Top
See Also

Reference

SAMLConfigurations Class
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations.ToXml Method

SAMLConfigurationsToXml Method

Serializes the configurations to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The configurations as XML.
See Also

Reference

SAMLConfigurations Class
ToXml Overload
ComponentSpace.SAML2.Configuration Namespace


SAMLConfigurations.ToXml Method (XmlDocument)

SAMLConfigurationsToXml Method (XmlDocument)

Serializes the configurations to XML.

Namespace: ComponentSpace.SAML2.Configuration
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The configurations as XML.
See Also

Reference

SAMLConfigurations Class
ToXml Overload
ComponentSpace.SAML2.Configuration Namespace


ComponentSpace.SAML2.Data Namespace

The ComponentSpace.SAML2.Data namespace contains classes that support data for the high-level SAML APIs.
Classes
 | Class | Description
Public class | AbstractDatabaseSSOSessionStore | The abstract database single sign-on session store provides common functionality for storing single sign-on session state in a database.
Public class | AbstractSSOSessionStore | The single sign-on session store provides common functionality for storing single sign-on session state.
Public class | DatabaseIDCache | The database ID cache stores IDs in a database. The database ID cache is suitable for applications deployed to a web farm.
Public class | DatabaseSSOSessionStore | The single sign-on session store stores single sign-on session state in a database. The HTTP session ID is used to uniquely identify SSO sessions.
Public class | HttpSSOSessionStore | The single sign-on session store stores single sign-on session state in the HTTP session.
Public class | InMemoryIDCache | The in-memory ID cache stores IDs in-memory. The in-memory ID cache is suitable for applications deployed to a single server. For applications deployed to a web farm, an ID cache implemented using a database or shared state server is required.
Public class | InMemorySSOSessionStore | The single sign-on session store stores single sign-on session state in memory.
Public class | SessionIDDelegates | The standard session ID delegates.
Interfaces
 | Interface | Description
Public interface | IIDCache | The ID cache manages IDs.
Public interface | ISSOSessionStore | The single sign-on session store.
Delegates
 | Delegate | Description
Public delegate | SessionIDDelegate | The session ID delegate returns a unique SSO session identifier. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session.


AbstractDatabaseSSOSessionStore Class

The abstract database single sign-on session store provides common functionality for storing single sign-on session state in a database.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.DataAbstractSSOSessionStore
ComponentSpace.SAML2.DataAbstractDatabaseSSOSessionStore
ComponentSpace.SAML2.DataDatabaseSSOSessionStore

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class AbstractDatabaseSSOSessionStore : AbstractSSOSessionStore
Public MustInherit Class AbstractDatabaseSSOSessionStore
    Inherits AbstractSSOSessionStore
public ref class AbstractDatabaseSSOSessionStore abstract : public AbstractSSOSessionStore
[<AbstractClassAttribute>]
type AbstractDatabaseSSOSessionStore =
    class
        inherit AbstractSSOSessionStore
    end

The AbstractDatabaseSSOSessionStore type exposes the following members.

Constructors
 | Name | Description
Public method | AbstractDatabaseSSOSessionStore | Constructs a AbstractDatabaseSSOSessionStore. The default database connection string name is assumed to be configured in web.config.
Public method | AbstractDatabaseSSOSessionStore(String) | Constructs a AbstractDatabaseSSOSessionStore.
Public method | AbstractDatabaseSSOSessionStore(String, String) | Constructs a AbstractDatabaseSSOSessionStore.
Public method | AbstractDatabaseSSOSessionStore(String, String, String) | Constructs a AbstractDatabaseSSOSessionStore.
Top
Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier. (Inherited from AbstractSSOSessionStore.)
Public property | SessionIDColumnName | Gets or sets the name of the session ID column. The default name is SessionID.
Public property | SessionIDDelegate | Gets or sets the session ID delegate. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session. If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled. (Inherited from AbstractSSOSessionStore.)
Public property | SessionObjectColumnName | Gets or sets the name of the session object column. The default name is SessionObject.
Public property | UpdateDateTimeColumnName | Gets or sets the name of the update date/time column. The default name is UpdateDateTime.
Top
Methods
 | Name | Description
Public method | CreateSessionIDForType | Creates a unique session ID for the specified type from the session ID and session object type. (Inherited from AbstractSSOSessionStore.)
Public method | Delete | Deletes any SSO session objects for the specified session from the database.
Public method | DeleteExpired | Deletes any expired SSO session objects from the database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the SSO session object. (Overrides AbstractSSOSessionStoreLoad(Type).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the SSO session object. (Overrides AbstractSSOSessionStoreSave(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore Constructor

Overload List
 | Name | Description
Public method | AbstractDatabaseSSOSessionStore | Constructs a AbstractDatabaseSSOSessionStore. The default database connection string name is assumed to be configured in web.config.
Public method | AbstractDatabaseSSOSessionStore(String) | Constructs a AbstractDatabaseSSOSessionStore.
Public method | AbstractDatabaseSSOSessionStore(String, String) | Constructs a AbstractDatabaseSSOSessionStore.
Public method | AbstractDatabaseSSOSessionStore(String, String, String) | Constructs a AbstractDatabaseSSOSessionStore.
Top
See Also

Reference

AbstractDatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore Constructor

Constructs a AbstractDatabaseSSOSessionStore.

The default database connection string name is assumed to be configured in web.config.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AbstractDatabaseSSOSessionStore()
Public Sub New
public:
AbstractDatabaseSSOSessionStore()
new : unit -> AbstractDatabaseSSOSessionStore
See Also

Reference

AbstractDatabaseSSOSessionStore Class
AbstractDatabaseSSOSessionStore Overload
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore Constructor (String)

Constructs a AbstractDatabaseSSOSessionStore.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AbstractDatabaseSSOSessionStore(
    string connectionStringName
)
Public Sub New (
    connectionStringName As String
)
public:
AbstractDatabaseSSOSessionStore(
    String^ connectionStringName
)
new :
        connectionStringName : string -> AbstractDatabaseSSOSessionStore

Parameters

connectionStringName
Type: SystemString
The database connection string name configured in web.config.
See Also

Reference

AbstractDatabaseSSOSessionStore Class
AbstractDatabaseSSOSessionStore Overload
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore Constructor (String, String)

Constructs a AbstractDatabaseSSOSessionStore.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AbstractDatabaseSSOSessionStore(
    string connectionStringName,
    string tableName
)
Public Sub New (
    connectionStringName As String,
    tableName As String
)
public:
AbstractDatabaseSSOSessionStore(
    String^ connectionStringName,
    String^ tableName
)
new :
        connectionStringName : string *
        tableName : string -> AbstractDatabaseSSOSessionStore

Parameters

connectionStringName
Type: SystemString
The database connection string name configured in web.config.
tableName
Type: SystemString
The database table name or null to use the default name.
See Also

Reference

AbstractDatabaseSSOSessionStore Class
AbstractDatabaseSSOSessionStore Overload
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore Constructor (String, String, String)

Constructs a AbstractDatabaseSSOSessionStore.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AbstractDatabaseSSOSessionStore(
    string providerName,
    string connectionString,
    string tableName
)
Public Sub New (
    providerName As String,
    connectionString As String,
    tableName As String
)
public:
AbstractDatabaseSSOSessionStore(
    String^ providerName,
    String^ connectionString,
    String^ tableName
)
new :
        providerName : string *
        connectionString : string *
        tableName : string -> AbstractDatabaseSSOSessionStore

Parameters

providerName
Type: SystemString
The database provider name.
connectionString
Type: SystemString
The database connection string.
tableName
Type: SystemString
The database table name or null to use the default name.
See Also

Reference

AbstractDatabaseSSOSessionStore Class
AbstractDatabaseSSOSessionStore Overload
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore Properties

The AbstractDatabaseSSOSessionStore type exposes the following members.

Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier. (Inherited from AbstractSSOSessionStore.)
Public property | SessionIDColumnName | Gets or sets the name of the session ID column. The default name is SessionID.
Public property | SessionIDDelegate | Gets or sets the session ID delegate. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session. If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled. (Inherited from AbstractSSOSessionStore.)
Public property | SessionObjectColumnName | Gets or sets the name of the session object column. The default name is SessionObject.
Public property | UpdateDateTimeColumnName | Gets or sets the name of the update date/time column. The default name is UpdateDateTime.
Top
See Also

Reference

AbstractDatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore.SessionIDColumnName Property

AbstractDatabaseSSOSessionStoreSessionIDColumnName Property

Gets or sets the name of the session ID column. The default name is SessionID.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SessionIDColumnName { get; set; }
Public Property SessionIDColumnName As String
    Get
    Set
public:
property String^ SessionIDColumnName {
    String^ get ();
    void set (String^ value);
}
member SessionIDColumnName : string with get, set

Property Value

Type: String
The name of the session ID column.
See Also

Reference

AbstractDatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore.SessionObjectColumnName Property

AbstractDatabaseSSOSessionStoreSessionObjectColumnName Property

Gets or sets the name of the session object column. The default name is SessionObject.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SessionObjectColumnName { get; set; }
Public Property SessionObjectColumnName As String
    Get
    Set
public:
property String^ SessionObjectColumnName {
    String^ get ();
    void set (String^ value);
}
member SessionObjectColumnName : string with get, set

Property Value

Type: String
The name of the session object column.
See Also

Reference

AbstractDatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore.UpdateDateTimeColumnName Property

AbstractDatabaseSSOSessionStoreUpdateDateTimeColumnName Property

Gets or sets the name of the update date/time column. The default name is UpdateDateTime.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string UpdateDateTimeColumnName { get; set; }
Public Property UpdateDateTimeColumnName As String
    Get
    Set
public:
property String^ UpdateDateTimeColumnName {
    String^ get ();
    void set (String^ value);
}
member UpdateDateTimeColumnName : string with get, set

Property Value

Type: String
The name of the update date/time column.
See Also

Reference

AbstractDatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore Methods

The AbstractDatabaseSSOSessionStore type exposes the following members.

Methods
 | Name | Description
Public method | CreateSessionIDForType | Creates a unique session ID for the specified type from the session ID and session object type. (Inherited from AbstractSSOSessionStore.)
Public method | Delete | Deletes any SSO session objects for the specified session from the database.
Public method | DeleteExpired | Deletes any expired SSO session objects from the database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the SSO session object. (Overrides AbstractSSOSessionStoreLoad(Type).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the SSO session object. (Overrides AbstractSSOSessionStoreSave(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AbstractDatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore.Delete Method

AbstractDatabaseSSOSessionStoreDelete Method

Deletes any SSO session objects for the specified session from the database.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int Delete(
    string sessionID
)
Public Function Delete (
    sessionID As String
) As Integer
public:
int Delete(
    String^ sessionID
)
member Delete :
        sessionID : string -> int

Parameters

sessionID
Type: SystemString
The session ID.

Return Value

Type: Int32
The number of SSO session objects deleted from the database.
See Also

Reference

AbstractDatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore.DeleteExpired Method

AbstractDatabaseSSOSessionStoreDeleteExpired Method

Deletes any expired SSO session objects from the database.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int DeleteExpired(
    DateTime expirationDateTime
)
Public Function DeleteExpired (
    expirationDateTime As DateTime
) As Integer
public:
int DeleteExpired(
    DateTime expirationDateTime
)
member DeleteExpired :
        expirationDateTime : DateTime -> int

Parameters

expirationDateTime
Type: SystemDateTime
The expiration UTC date/time.

Return Value

Type: Int32
The number of expired SSO session objects deleted from the database.
See Also

Reference

AbstractDatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore.Load Method

AbstractDatabaseSSOSessionStoreLoad Method

Loads the SSO session object.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override Object Load(
    Type type
)
Public Overrides Function Load (
    type As Type
) As Object
public:
virtual Object^ Load(
    Type^ type
) override
abstract Load :
        type : Type -> Object
override Load :
        type : Type -> Object

Parameters

type
Type: SystemType
The SSO session object type.

Return Value

Type: Object
The SSO session object or null if none.

Implements

ISSOSessionStoreLoad(Type)
See Also

Reference

AbstractDatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractDatabaseSSOSessionStore.Save Method

AbstractDatabaseSSOSessionStoreSave Method

Saves the SSO session object.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void Save(
    Object ssoSession
)
Public Overrides Sub Save (
    ssoSession As Object
)
public:
virtual void Save(
    Object^ ssoSession
) override
abstract Save :
        ssoSession : Object -> unit
override Save :
        ssoSession : Object -> unit

Parameters

ssoSession
Type: SystemObject
The serializable SSO session object.

Implements

ISSOSessionStoreSave(Object)
See Also

Reference

AbstractDatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore Class

The single sign-on session store provides common functionality for storing single sign-on session state.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.DataAbstractSSOSessionStore
ComponentSpace.SAML2.DataAbstractDatabaseSSOSessionStore
ComponentSpace.SAML2.DataHttpSSOSessionStore
ComponentSpace.SAML2.DataInMemorySSOSessionStore

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class AbstractSSOSessionStore : ISSOSessionStore
Public MustInherit Class AbstractSSOSessionStore
    Implements ISSOSessionStore
public ref class AbstractSSOSessionStore abstract : ISSOSessionStore
[<AbstractClassAttribute>]
type AbstractSSOSessionStore =
    class
        interface ISSOSessionStore
    end

The AbstractSSOSessionStore type exposes the following members.

Constructors
 | Name | Description
Protected method | AbstractSSOSessionStore | Initializes a new instance of the AbstractSSOSessionStore class
Top
Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier.
Public property | SessionIDDelegate | Gets or sets the session ID delegate. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session. If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled.
Top
Methods
 | Name | Description
Public method | CreateSessionIDForType | Creates a unique session ID for the specified type from the session ID and session object type.
 | Deserialize | Deserializes the binary data to an SSO session.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the SSO session object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the SSO session object.
 | Serialize | Serializes the SSO session to binary data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore Constructor

Initializes a new instance of the AbstractSSOSessionStore class

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
protected AbstractSSOSessionStore()
Protected Sub New
protected:
AbstractSSOSessionStore()
new : unit -> AbstractSSOSessionStore
See Also

Reference

AbstractSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore Properties

The AbstractSSOSessionStore type exposes the following members.

Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier.
Public property | SessionIDDelegate | Gets or sets the session ID delegate. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session. If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled.
Top
See Also

Reference

AbstractSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore.SessionID Property

AbstractSSOSessionStoreSessionID Property

Gets the unique SSO session identifier.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual string SessionID { get; }
Public Overridable ReadOnly Property SessionID As String
    Get
public:
virtual property String^ SessionID {
    String^ get ();
}
abstract SessionID : string with get
override SessionID : string with get

Property Value

Type: String
The unique SSO session identifier.

Implements

ISSOSessionStoreSessionID
See Also

Reference

AbstractSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore.SessionIDDelegate Property

AbstractSSOSessionStoreSessionIDDelegate Property

Gets or sets the session ID delegate.

The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session.

If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SessionIDDelegate SessionIDDelegate { get; set; }
Public Property SessionIDDelegate As SessionIDDelegate
    Get
    Set
public:
property SessionIDDelegate^ SessionIDDelegate {
    SessionIDDelegate^ get ();
    void set (SessionIDDelegate^ value);
}
member SessionIDDelegate : SessionIDDelegate with get, set

Property Value

Type: SessionIDDelegate
The session ID delegate or null if none.
See Also

Reference

AbstractSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore Methods

The AbstractSSOSessionStore type exposes the following members.

Methods
 | Name | Description
Public method | CreateSessionIDForType | Creates a unique session ID for the specified type from the session ID and session object type.
 | Deserialize | Deserializes the binary data to an SSO session.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the SSO session object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the SSO session object.
 | Serialize | Serializes the SSO session to binary data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AbstractSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore.CreateSessionIDForType Method

AbstractSSOSessionStoreCreateSessionIDForType Method

Creates a unique session ID for the specified type from the session ID and session object type.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual string CreateSessionIDForType(
    Type type
)
Public Overridable Function CreateSessionIDForType (
    type As Type
) As String
public:
virtual String^ CreateSessionIDForType(
    Type^ type
)
abstract CreateSessionIDForType :
        type : Type -> string
override CreateSessionIDForType :
        type : Type -> string

Parameters

type
Type: SystemType
The session object type.

Return Value

Type: String
The unique SSO session ID for the session object type.
See Also

Reference

AbstractSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore.Deserialize Method

AbstractSSOSessionStoreDeserialize Method

Deserializes the binary data to an SSO session.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static Object Deserialize(
    byte[] bytes
)
Public Shared Function Deserialize (
    bytes As Byte()
) As Object
public:
static Object^ Deserialize(
    array<unsigned char>^ bytes
)
static member Deserialize :
        bytes : byte[] -> Object

Parameters

bytes
Type: SystemByte
The binary data.

Return Value

Type: Object
The SSO session.
See Also

Reference

AbstractSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore.Load Method

AbstractSSOSessionStoreLoad Method

Loads the SSO session object.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract Object Load(
    Type type
)
Public MustOverride Function Load (
    type As Type
) As Object
public:
virtual Object^ Load(
    Type^ type
) abstract
abstract Load :
        type : Type -> Object

Parameters

type
Type: SystemType
The SSO session object type.

Return Value

Type: Object
The SSO session object or null if none.

Implements

ISSOSessionStoreLoad(Type)
See Also

Reference

AbstractSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore.Save Method

AbstractSSOSessionStoreSave Method

Saves the SSO session object.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract void Save(
    Object ssoSession
)
Public MustOverride Sub Save (
    ssoSession As Object
)
public:
virtual void Save(
    Object^ ssoSession
) abstract
abstract Save :
        ssoSession : Object -> unit

Parameters

ssoSession
Type: SystemObject
The serializable SSO session object.

Implements

ISSOSessionStoreSave(Object)
See Also

Reference

AbstractSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


AbstractSSOSessionStore.Serialize Method

AbstractSSOSessionStoreSerialize Method

Serializes the SSO session to binary data.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static byte[] Serialize(
    Object ssoSession
)
Public Shared Function Serialize (
    ssoSession As Object
) As Byte()
public:
static array<unsigned char>^ Serialize(
    Object^ ssoSession
)
static member Serialize :
        ssoSession : Object -> byte[]

Parameters

ssoSession
Type: SystemObject
The serializable SSO session.

Return Value

Type: Byte
The SSO session serialized to binary data.
See Also

Reference

AbstractSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache Class

The database ID cache stores IDs in a database.

The database ID cache is suitable for applications deployed to a web farm.

Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.DataDatabaseIDCache

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class DatabaseIDCache : IIDCache,
    IDisposable
Public Class DatabaseIDCache
    Implements IIDCache, IDisposable
public ref class DatabaseIDCache : IIDCache,
    IDisposable
type DatabaseIDCache =
    class
        interface IIDCache
        interface IDisposable
    end

The DatabaseIDCache type exposes the following members.

Constructors
 | Name | Description
Public method | DatabaseIDCache | Constructs a DatabaseIDCache. The default database connection string name is assumed to be configured in web.config.
Public method | DatabaseIDCache(String) | Constructs a DatabaseIDCache.
Public method | DatabaseIDCache(String, String) | Constructs a DatabaseIDCache.
Public method | DatabaseIDCache(String, String, String) | Constructs a DatabaseIDCache.
Top
Properties
 | Name | Description
Public property | DeleteExpiredPriorToAdd | Gets or sets the flag indicating whether expired entries should be deleted prior to adding an entry.
Public property | ExpirationDateTimeColumnName | Gets or sets the name of the expiration date/time column. The default name is ExpirationDateTime.
Public property | IDColumnName | Gets or sets the name of the ID column. The default name is ID.
Top
Methods
 | Name | Description
Public method | Add | Adds the ID with an associated expiration time to the cache.
Public method | DeleteExpired | Deletes any expired IDs from the cache.
Public method | Dispose | Dispose of the database ID cache.
Protected method | Dispose(Boolean) | Dispose of the database ID cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartDeletingExpired | Schedules the deletion of expired IDs starting at the due time and repeating periodically.
Public method | StopDeletingExpired | Stops any scheduled deletion of expired IDs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Data Namespace


DatabaseIDCache Constructor

Overload List
 | Name | Description
Public method | DatabaseIDCache | Constructs a DatabaseIDCache. The default database connection string name is assumed to be configured in web.config.
Public method | DatabaseIDCache(String) | Constructs a DatabaseIDCache.
Public method | DatabaseIDCache(String, String) | Constructs a DatabaseIDCache.
Public method | DatabaseIDCache(String, String, String) | Constructs a DatabaseIDCache.
Top
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache Constructor

Constructs a DatabaseIDCache.

The default database connection string name is assumed to be configured in web.config.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DatabaseIDCache()
Public Sub New
public:
DatabaseIDCache()
new : unit -> DatabaseIDCache
See Also

Reference

DatabaseIDCache Class
DatabaseIDCache Overload
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache Constructor (String)

Constructs a DatabaseIDCache.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DatabaseIDCache(
    string connectionStringName
)
Public Sub New (
    connectionStringName As String
)
public:
DatabaseIDCache(
    String^ connectionStringName
)
new :
        connectionStringName : string -> DatabaseIDCache

Parameters

connectionStringName
Type: SystemString
The database connection string name configured in web.config.
See Also

Reference

DatabaseIDCache Class
DatabaseIDCache Overload
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache Constructor (String, String)

Constructs a DatabaseIDCache.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DatabaseIDCache(
    string connectionStringName,
    string tableName
)
Public Sub New (
    connectionStringName As String,
    tableName As String
)
public:
DatabaseIDCache(
    String^ connectionStringName,
    String^ tableName
)
new :
        connectionStringName : string *
        tableName : string -> DatabaseIDCache

Parameters

connectionStringName
Type: SystemString
The database connection string name configured in web.config.
tableName
Type: SystemString
The database table name or null to use the default name.
See Also

Reference

DatabaseIDCache Class
DatabaseIDCache Overload
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache Constructor (String, String, String)

Constructs a DatabaseIDCache.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DatabaseIDCache(
    string providerName,
    string connectionString,
    string tableName
)
Public Sub New (
    providerName As String,
    connectionString As String,
    tableName As String
)
public:
DatabaseIDCache(
    String^ providerName,
    String^ connectionString,
    String^ tableName
)
new :
        providerName : string *
        connectionString : string *
        tableName : string -> DatabaseIDCache

Parameters

providerName
Type: SystemString
The database provider name.
connectionString
Type: SystemString
The database connection string.
tableName
Type: SystemString
The database table name or null to use the default name.
See Also

Reference

DatabaseIDCache Class
DatabaseIDCache Overload
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache Properties

The DatabaseIDCache type exposes the following members.

Properties
 | Name | Description
Public property | DeleteExpiredPriorToAdd | Gets or sets the flag indicating whether expired entries should be deleted prior to adding an entry.
Public property | ExpirationDateTimeColumnName | Gets or sets the name of the expiration date/time column. The default name is ExpirationDateTime.
Public property | IDColumnName | Gets or sets the name of the ID column. The default name is ID.
Top
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache.DeleteExpiredPriorToAdd Property

DatabaseIDCacheDeleteExpiredPriorToAdd Property

Gets or sets the flag indicating whether expired entries should be deleted prior to adding an entry.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool DeleteExpiredPriorToAdd { get; set; }
Public Property DeleteExpiredPriorToAdd As Boolean
    Get
    Set
public:
property bool DeleteExpiredPriorToAdd {
    bool get ();
    void set (bool value);
}
member DeleteExpiredPriorToAdd : bool with get, set

Property Value

Type: Boolean
The flag indicating whether expired entries should be deleted prior to adding an entry.
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache.ExpirationDateTimeColumnName Property

DatabaseIDCacheExpirationDateTimeColumnName Property

Gets or sets the name of the expiration date/time column. The default name is ExpirationDateTime.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ExpirationDateTimeColumnName { get; set; }
Public Property ExpirationDateTimeColumnName As String
    Get
    Set
public:
property String^ ExpirationDateTimeColumnName {
    String^ get ();
    void set (String^ value);
}
member ExpirationDateTimeColumnName : string with get, set

Property Value

Type: String
The name of the expiration date/time column.
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache.IDColumnName Property

DatabaseIDCacheIDColumnName Property

Gets or sets the name of the ID column. The default name is ID.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string IDColumnName { get; set; }
Public Property IDColumnName As String
    Get
    Set
public:
property String^ IDColumnName {
    String^ get ();
    void set (String^ value);
}
member IDColumnName : string with get, set

Property Value

Type: String
The name of the ID column.
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache Methods

The DatabaseIDCache type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the ID with an associated expiration time to the cache.
Public method | DeleteExpired | Deletes any expired IDs from the cache.
Public method | Dispose | Dispose of the database ID cache.
Protected method | Dispose(Boolean) | Dispose of the database ID cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartDeletingExpired | Schedules the deletion of expired IDs starting at the due time and repeating periodically.
Public method | StopDeletingExpired | Stops any scheduled deletion of expired IDs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache.Add Method

DatabaseIDCacheAdd Method

Adds the ID with an associated expiration time to the cache.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool Add(
    string id,
    DateTime expirationDateTime
)
Public Function Add (
    id As String,
    expirationDateTime As DateTime
) As Boolean
public:
virtual bool Add(
    String^ id,
    DateTime expirationDateTime
) sealed
abstract Add :
        id : string *
        expirationDateTime : DateTime -> bool
override Add :
        id : string *
        expirationDateTime : DateTime -> bool

Parameters

id
Type: SystemString
The ID.
expirationDateTime
Type: SystemDateTime
The expiration time or null if none.

Return Value

Type: Boolean
true if the ID doesn't already exist in the cache; otherwise false.

Implements

IIDCacheAdd(String, DateTime)
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache.DeleteExpired Method

DatabaseIDCacheDeleteExpired Method

Deletes any expired IDs from the cache.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int DeleteExpired()
Public Function DeleteExpired As Integer
public:
int DeleteExpired()
member DeleteExpired : unit -> int

Return Value

Type: Int32
The number of expired IDs deleted from the cache.
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache.Dispose Method

DatabaseIDCacheDispose Method

Overload List
 | Name | Description
Public method | Dispose | Dispose of the database ID cache.
Protected method | Dispose(Boolean) | Dispose of the database ID cache.
Top
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache.Dispose Method

DatabaseIDCacheDispose Method

Dispose of the database ID cache.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DatabaseIDCache Class
Dispose Overload
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache.Dispose Method (Boolean)

DatabaseIDCacheDispose Method (Boolean)

Dispose of the database ID cache.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if called by user code; false if called by the runtime from within the finalizer
See Also

Reference

DatabaseIDCache Class
Dispose Overload
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache.StartDeletingExpired Method

DatabaseIDCacheStartDeletingExpired Method

Schedules the deletion of expired IDs starting at the due time and repeating periodically.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void StartDeletingExpired(
    TimeSpan dueTime,
    TimeSpan period
)
Public Sub StartDeletingExpired (
    dueTime As TimeSpan,
    period As TimeSpan
)
public:
void StartDeletingExpired(
    TimeSpan dueTime,
    TimeSpan period
)
member StartDeletingExpired :
        dueTime : TimeSpan *
        period : TimeSpan -> unit

Parameters

dueTime
Type: SystemTimeSpan
The due time to start deleting expired IDs.
period
Type: SystemTimeSpan
The period to wait before next deleting expired IDs.
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseIDCache.StopDeletingExpired Method

DatabaseIDCacheStopDeletingExpired Method

Stops any scheduled deletion of expired IDs.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void StopDeletingExpired()
Public Sub StopDeletingExpired
public:
void StopDeletingExpired()
member StopDeletingExpired : unit -> unit
See Also

Reference

DatabaseIDCache Class
ComponentSpace.SAML2.Data Namespace


DatabaseSSOSessionStore Class

The single sign-on session store stores single sign-on session state in a database.

The HTTP session ID is used to uniquely identify SSO sessions.

Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.DataAbstractSSOSessionStore
ComponentSpace.SAML2.DataAbstractDatabaseSSOSessionStore
ComponentSpace.SAML2.DataDatabaseSSOSessionStore

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class DatabaseSSOSessionStore : AbstractDatabaseSSOSessionStore
Public Class DatabaseSSOSessionStore
    Inherits AbstractDatabaseSSOSessionStore
public ref class DatabaseSSOSessionStore : public AbstractDatabaseSSOSessionStore
type DatabaseSSOSessionStore =
    class
        inherit AbstractDatabaseSSOSessionStore
    end

The DatabaseSSOSessionStore type exposes the following members.

Constructors
 | Name | Description
Public method | DatabaseSSOSessionStore | Constructs a DatabaseSSOSessionStore. The default database connection string name is assumed to be configured in web.config.
Public method | DatabaseSSOSessionStore(String) | Constructs a DatabaseSSOSessionStore.
Public method | DatabaseSSOSessionStore(String, String) | Constructs a DatabaseSSOSessionStore.
Public method | DatabaseSSOSessionStore(String, String, String) | Constructs a DatabaseSSOSessionStore.
Top
Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier. (Inherited from AbstractSSOSessionStore.)
Public property | SessionIDColumnName | Gets or sets the name of the session ID column. The default name is SessionID. (Inherited from AbstractDatabaseSSOSessionStore.)
Public property | SessionIDDelegate | Gets or sets the session ID delegate. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session. If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled. (Inherited from AbstractSSOSessionStore.)
Public property | SessionObjectColumnName | Gets or sets the name of the session object column. The default name is SessionObject. (Inherited from AbstractDatabaseSSOSessionStore.)
Public property | UpdateDateTimeColumnName | Gets or sets the name of the update date/time column. The default name is UpdateDateTime. (Inherited from AbstractDatabaseSSOSessionStore.)
Top
Methods
 | Name | Description
Public method | CreateSessionIDForType | Creates a unique session ID for the specified type from the session ID and session object type. (Inherited from AbstractSSOSessionStore.)
Public method | Delete | Deletes any SSO session objects for the specified session from the database. (Inherited from AbstractDatabaseSSOSessionStore.)
Public method | DeleteExpired | Deletes any expired SSO session objects from the database. (Inherited from AbstractDatabaseSSOSessionStore.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the SSO session object. (Inherited from AbstractDatabaseSSOSessionStore.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the SSO session object. (Inherited from AbstractDatabaseSSOSessionStore.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Data Namespace


DatabaseSSOSessionStore Constructor

Overload List
 | Name | Description
Public method | DatabaseSSOSessionStore | Constructs a DatabaseSSOSessionStore. The default database connection string name is assumed to be configured in web.config.
Public method | DatabaseSSOSessionStore(String) | Constructs a DatabaseSSOSessionStore.
Public method | DatabaseSSOSessionStore(String, String) | Constructs a DatabaseSSOSessionStore.
Public method | DatabaseSSOSessionStore(String, String, String) | Constructs a DatabaseSSOSessionStore.
Top
See Also

Reference

DatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


DatabaseSSOSessionStore Constructor

Constructs a DatabaseSSOSessionStore.

The default database connection string name is assumed to be configured in web.config.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DatabaseSSOSessionStore()
Public Sub New
public:
DatabaseSSOSessionStore()
new : unit -> DatabaseSSOSessionStore
See Also

Reference

DatabaseSSOSessionStore Class
DatabaseSSOSessionStore Overload
ComponentSpace.SAML2.Data Namespace


DatabaseSSOSessionStore Constructor (String)

Constructs a DatabaseSSOSessionStore.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DatabaseSSOSessionStore(
    string connectionStringName
)
Public Sub New (
    connectionStringName As String
)
public:
DatabaseSSOSessionStore(
    String^ connectionStringName
)
new :
        connectionStringName : string -> DatabaseSSOSessionStore

Parameters

connectionStringName
Type: SystemString
The database connection string name configured in web.config.
See Also

Reference

DatabaseSSOSessionStore Class
DatabaseSSOSessionStore Overload
ComponentSpace.SAML2.Data Namespace


DatabaseSSOSessionStore Constructor (String, String)

Constructs a DatabaseSSOSessionStore.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DatabaseSSOSessionStore(
    string connectionStringName,
    string tableName
)
Public Sub New (
    connectionStringName As String,
    tableName As String
)
public:
DatabaseSSOSessionStore(
    String^ connectionStringName,
    String^ tableName
)
new :
        connectionStringName : string *
        tableName : string -> DatabaseSSOSessionStore

Parameters

connectionStringName
Type: SystemString
The database connection string name configured in web.config.
tableName
Type: SystemString
The database table name or null to use the default name.
See Also

Reference

DatabaseSSOSessionStore Class
DatabaseSSOSessionStore Overload
ComponentSpace.SAML2.Data Namespace


DatabaseSSOSessionStore Constructor (String, String, String)

Constructs a DatabaseSSOSessionStore.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DatabaseSSOSessionStore(
    string providerName,
    string connectionString,
    string tableName
)
Public Sub New (
    providerName As String,
    connectionString As String,
    tableName As String
)
public:
DatabaseSSOSessionStore(
    String^ providerName,
    String^ connectionString,
    String^ tableName
)
new :
        providerName : string *
        connectionString : string *
        tableName : string -> DatabaseSSOSessionStore

Parameters

providerName
Type: SystemString
The database provider name.
connectionString
Type: SystemString
The database connection string.
tableName
Type: SystemString
The database table name or null to use the default name.
See Also

Reference

DatabaseSSOSessionStore Class
DatabaseSSOSessionStore Overload
ComponentSpace.SAML2.Data Namespace


DatabaseSSOSessionStore Properties

The DatabaseSSOSessionStore type exposes the following members.

Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier. (Inherited from AbstractSSOSessionStore.)
Public property | SessionIDColumnName | Gets or sets the name of the session ID column. The default name is SessionID. (Inherited from AbstractDatabaseSSOSessionStore.)
Public property | SessionIDDelegate | Gets or sets the session ID delegate. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session. If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled. (Inherited from AbstractSSOSessionStore.)
Public property | SessionObjectColumnName | Gets or sets the name of the session object column. The default name is SessionObject. (Inherited from AbstractDatabaseSSOSessionStore.)
Public property | UpdateDateTimeColumnName | Gets or sets the name of the update date/time column. The default name is UpdateDateTime. (Inherited from AbstractDatabaseSSOSessionStore.)
Top
See Also

Reference

DatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


DatabaseSSOSessionStore Methods

The DatabaseSSOSessionStore type exposes the following members.

Methods
 | Name | Description
Public method | CreateSessionIDForType | Creates a unique session ID for the specified type from the session ID and session object type. (Inherited from AbstractSSOSessionStore.)
Public method | Delete | Deletes any SSO session objects for the specified session from the database. (Inherited from AbstractDatabaseSSOSessionStore.)
Public method | DeleteExpired | Deletes any expired SSO session objects from the database. (Inherited from AbstractDatabaseSSOSessionStore.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the SSO session object. (Inherited from AbstractDatabaseSSOSessionStore.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the SSO session object. (Inherited from AbstractDatabaseSSOSessionStore.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DatabaseSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


HttpSSOSessionStore Class

The single sign-on session store stores single sign-on session state in the HTTP session.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.DataAbstractSSOSessionStore
ComponentSpace.SAML2.DataHttpSSOSessionStore

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class HttpSSOSessionStore : AbstractSSOSessionStore
Public Class HttpSSOSessionStore
    Inherits AbstractSSOSessionStore
public ref class HttpSSOSessionStore : public AbstractSSOSessionStore
type HttpSSOSessionStore =
    class
        inherit AbstractSSOSessionStore
    end

The HttpSSOSessionStore type exposes the following members.

Constructors
 | Name | Description
Public method | HttpSSOSessionStore | Initializes a new instance of the HttpSSOSessionStore class
Top
Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier. (Inherited from AbstractSSOSessionStore.)
Public property | SessionIDDelegate | Gets or sets the session ID delegate. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session. If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled. (Inherited from AbstractSSOSessionStore.)
Top
Methods
 | Name | Description
Public method | CreateSessionIDForType | Creates a unique session ID for the specified type from the session ID and session object type. (Inherited from AbstractSSOSessionStore.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the SSO session object. (Overrides AbstractSSOSessionStoreLoad(Type).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the SSO session object. (Overrides AbstractSSOSessionStoreSave(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Data Namespace


HttpSSOSessionStore Constructor

Initializes a new instance of the HttpSSOSessionStore class

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HttpSSOSessionStore()
Public Sub New
public:
HttpSSOSessionStore()
new : unit -> HttpSSOSessionStore
See Also

Reference

HttpSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


HttpSSOSessionStore Properties

The HttpSSOSessionStore type exposes the following members.

Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier. (Inherited from AbstractSSOSessionStore.)
Public property | SessionIDDelegate | Gets or sets the session ID delegate. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session. If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled. (Inherited from AbstractSSOSessionStore.)
Top
See Also

Reference

HttpSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


HttpSSOSessionStore Methods

The HttpSSOSessionStore type exposes the following members.

Methods
 | Name | Description
Public method | CreateSessionIDForType | Creates a unique session ID for the specified type from the session ID and session object type. (Inherited from AbstractSSOSessionStore.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the SSO session object. (Overrides AbstractSSOSessionStoreLoad(Type).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the SSO session object. (Overrides AbstractSSOSessionStoreSave(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HttpSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


HttpSSOSessionStore.Load Method

HttpSSOSessionStoreLoad Method

Loads the SSO session object.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override Object Load(
    Type type
)
Public Overrides Function Load (
    type As Type
) As Object
public:
virtual Object^ Load(
    Type^ type
) override
abstract Load :
        type : Type -> Object
override Load :
        type : Type -> Object

Parameters

type
Type: SystemType
The SSO session object type.

Return Value

Type: Object
The SSO session object or null if none.

Implements

ISSOSessionStoreLoad(Type)
See Also

Reference

HttpSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


HttpSSOSessionStore.Save Method

HttpSSOSessionStoreSave Method

Saves the SSO session object.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void Save(
    Object ssoSession
)
Public Overrides Sub Save (
    ssoSession As Object
)
public:
virtual void Save(
    Object^ ssoSession
) override
abstract Save :
        ssoSession : Object -> unit
override Save :
        ssoSession : Object -> unit

Parameters

ssoSession
Type: SystemObject
The serializable SSO session object.

Implements

ISSOSessionStoreSave(Object)
See Also

Reference

HttpSSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


IIDCache Interface

The ID cache manages IDs.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public interface IIDCache
Public Interface IIDCache
public interface class IIDCache
type IIDCache =  interface end

The IIDCache type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the ID with an associated expiration time to the cache.
Top
See Also

Reference

ComponentSpace.SAML2.Data Namespace


IIDCache Methods

The IIDCache type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the ID with an associated expiration time to the cache.
Top
See Also

Reference

IIDCache Interface
ComponentSpace.SAML2.Data Namespace


IIDCache.Add Method

IIDCacheAdd Method

Adds the ID with an associated expiration time to the cache.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
bool Add(
    string id,
    DateTime expirationDateTime
)
Function Add (
    id As String,
    expirationDateTime As DateTime
) As Boolean
bool Add(
    String^ id,
    DateTime expirationDateTime
)
abstract Add :
        id : string *
        expirationDateTime : DateTime -> bool

Parameters

id
Type: SystemString
The ID.
expirationDateTime
Type: SystemDateTime
The expiration time or null if none.

Return Value

Type: Boolean
true if the ID doesn't already exist in the cache; otherwise false.
See Also

Reference

IIDCache Interface
ComponentSpace.SAML2.Data Namespace


InMemoryIDCache Class

The in-memory ID cache stores IDs in-memory.

The in-memory ID cache is suitable for applications deployed to a single server. For applications deployed to a web farm, an ID cache implemented using a database or shared state server is required.

Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.DataInMemoryIDCache

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class InMemoryIDCache : IIDCache
Public Class InMemoryIDCache
    Implements IIDCache
public ref class InMemoryIDCache : IIDCache
type InMemoryIDCache =
    class
        interface IIDCache
    end

The InMemoryIDCache type exposes the following members.

Constructors
 | Name | Description
Public method | InMemoryIDCache | Initializes a new instance of the InMemoryIDCache class
Top
Methods
 | Name | Description
Public method | Add | Adds the ID with an associated expiration time to the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Data Namespace


InMemoryIDCache Constructor

Initializes a new instance of the InMemoryIDCache class

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public InMemoryIDCache()
Public Sub New
public:
InMemoryIDCache()
new : unit -> InMemoryIDCache
See Also

Reference

InMemoryIDCache Class
ComponentSpace.SAML2.Data Namespace


InMemoryIDCache Methods

The InMemoryIDCache type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the ID with an associated expiration time to the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InMemoryIDCache Class
ComponentSpace.SAML2.Data Namespace


InMemoryIDCache.Add Method

InMemoryIDCacheAdd Method

Adds the ID with an associated expiration time to the cache.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool Add(
    string id,
    DateTime expirationDateTime
)
Public Function Add (
    id As String,
    expirationDateTime As DateTime
) As Boolean
public:
virtual bool Add(
    String^ id,
    DateTime expirationDateTime
) sealed
abstract Add :
        id : string *
        expirationDateTime : DateTime -> bool
override Add :
        id : string *
        expirationDateTime : DateTime -> bool

Parameters

id
Type: SystemString
The ID.
expirationDateTime
Type: SystemDateTime
The expiration time or null if none.

Return Value

Type: Boolean
true if the ID doesn't already exist in the cache; otherwise false.

Implements

IIDCacheAdd(String, DateTime)
See Also

Reference

InMemoryIDCache Class
ComponentSpace.SAML2.Data Namespace


InMemorySSOSessionStore Class

The single sign-on session store stores single sign-on session state in memory.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.DataAbstractSSOSessionStore
ComponentSpace.SAML2.DataInMemorySSOSessionStore

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class InMemorySSOSessionStore : AbstractSSOSessionStore
Public Class InMemorySSOSessionStore
    Inherits AbstractSSOSessionStore
public ref class InMemorySSOSessionStore : public AbstractSSOSessionStore
type InMemorySSOSessionStore =
    class
        inherit AbstractSSOSessionStore
    end

The InMemorySSOSessionStore type exposes the following members.

Constructors
 | Name | Description
Public method | InMemorySSOSessionStore | Initializes a new instance of the InMemorySSOSessionStore class
Top
Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier. (Inherited from AbstractSSOSessionStore.)
Public property | SessionIDDelegate | Gets or sets the session ID delegate. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session. If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled. (Inherited from AbstractSSOSessionStore.)
Top
Methods
 | Name | Description
Public method | CreateSessionIDForType | Creates a unique session ID for the specified type from the session ID and session object type. (Inherited from AbstractSSOSessionStore.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the SSO session object. (Overrides AbstractSSOSessionStoreLoad(Type).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the SSO session object. (Overrides AbstractSSOSessionStoreSave(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Data Namespace


InMemorySSOSessionStore Constructor

Initializes a new instance of the InMemorySSOSessionStore class

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public InMemorySSOSessionStore()
Public Sub New
public:
InMemorySSOSessionStore()
new : unit -> InMemorySSOSessionStore
See Also

Reference

InMemorySSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


InMemorySSOSessionStore Properties

The InMemorySSOSessionStore type exposes the following members.

Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier. (Inherited from AbstractSSOSessionStore.)
Public property | SessionIDDelegate | Gets or sets the session ID delegate. The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session. If a delegate isn't specified then the ASP.NET session identifier is used. This requires ASP.NET session cookies to be enabled. (Inherited from AbstractSSOSessionStore.)
Top
See Also

Reference

InMemorySSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


InMemorySSOSessionStore Methods

The InMemorySSOSessionStore type exposes the following members.

Methods
 | Name | Description
Public method | CreateSessionIDForType | Creates a unique session ID for the specified type from the session ID and session object type. (Inherited from AbstractSSOSessionStore.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the SSO session object. (Overrides AbstractSSOSessionStoreLoad(Type).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the SSO session object. (Overrides AbstractSSOSessionStoreSave(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InMemorySSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


InMemorySSOSessionStore.Load Method

InMemorySSOSessionStoreLoad Method

Loads the SSO session object.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override Object Load(
    Type type
)
Public Overrides Function Load (
    type As Type
) As Object
public:
virtual Object^ Load(
    Type^ type
) override
abstract Load :
        type : Type -> Object
override Load :
        type : Type -> Object

Parameters

type
Type: SystemType
The SSO session object type.

Return Value

Type: Object
The SSO session object or null if none.

Implements

ISSOSessionStoreLoad(Type)
See Also

Reference

InMemorySSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


InMemorySSOSessionStore.Save Method

InMemorySSOSessionStoreSave Method

Saves the SSO session object.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void Save(
    Object ssoSession
)
Public Overrides Sub Save (
    ssoSession As Object
)
public:
virtual void Save(
    Object^ ssoSession
) override
abstract Save :
        ssoSession : Object -> unit
override Save :
        ssoSession : Object -> unit

Parameters

ssoSession
Type: SystemObject
The serializable SSO session object.

Implements

ISSOSessionStoreSave(Object)
See Also

Reference

InMemorySSOSessionStore Class
ComponentSpace.SAML2.Data Namespace


ISSOSessionStore Interface

The single sign-on session store.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public interface ISSOSessionStore
Public Interface ISSOSessionStore
public interface class ISSOSessionStore
type ISSOSessionStore =  interface end

The ISSOSessionStore type exposes the following members.

Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier.
Top
Methods
 | Name | Description
Public method | Load | Loads the SSO session object.
Public method | Save | Saves the SSO session object.
Top
See Also

Reference

ComponentSpace.SAML2.Data Namespace


ISSOSessionStore Properties

The ISSOSessionStore type exposes the following members.

Properties
 | Name | Description
Public property | SessionID | Gets the unique SSO session identifier.
Top
See Also

Reference

ISSOSessionStore Interface
ComponentSpace.SAML2.Data Namespace


ISSOSessionStore.SessionID Property

ISSOSessionStoreSessionID Property

Gets the unique SSO session identifier.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
string SessionID { get; }
ReadOnly Property SessionID As String
    Get
property String^ SessionID {
    String^ get ();
}
abstract SessionID : string with get

Property Value

Type: String
The unique SSO session identifier.
See Also

Reference

ISSOSessionStore Interface
ComponentSpace.SAML2.Data Namespace


ISSOSessionStore Methods

The ISSOSessionStore type exposes the following members.

Methods
 | Name | Description
Public method | Load | Loads the SSO session object.
Public method | Save | Saves the SSO session object.
Top
See Also

Reference

ISSOSessionStore Interface
ComponentSpace.SAML2.Data Namespace


ISSOSessionStore.Load Method

ISSOSessionStoreLoad Method

Loads the SSO session object.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
Object Load(
    Type type
)
Function Load (
    type As Type
) As Object
Object^ Load(
    Type^ type
)
abstract Load :
        type : Type -> Object

Parameters

type
Type: SystemType
The SSO session object type.

Return Value

Type: Object
The SSO session object or null if none.
See Also

Reference

ISSOSessionStore Interface
ComponentSpace.SAML2.Data Namespace


ISSOSessionStore.Save Method

ISSOSessionStoreSave Method

Saves the SSO session object.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void Save(
    Object ssoSession
)
Sub Save (
    ssoSession As Object
)
void Save(
    Object^ ssoSession
)
abstract Save :
        ssoSession : Object -> unit

Parameters

ssoSession
Type: SystemObject
The serializable SSO session object.
See Also

Reference

ISSOSessionStore Interface
ComponentSpace.SAML2.Data Namespace


SessionIDDelegate Delegate

The session ID delegate returns a unique SSO session identifier.

The SSO session identifier must be unique for the user's browser session. It's used to identify which SSO session information is specific to the user's browser session.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public delegate string SessionIDDelegate()
Public Delegate Function SessionIDDelegate As String
public delegate String^ SessionIDDelegate()
type SessionIDDelegate =
    delegate of unit -> string

Return Value

Type: String
The unique SSO session identifier.
See Also

Reference

ComponentSpace.SAML2.Data Namespace


SessionIDDelegates Class

The standard session ID delegates.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.DataSessionIDDelegates

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SessionIDDelegates
Public NotInheritable Class SessionIDDelegates
public ref class SessionIDDelegates abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SessionIDDelegates =  class end

The SessionIDDelegates type exposes the following members.

Methods
Name | Description
GetSessionIDFromAnonymousID | Gets the SSO session identifier by returning the ASP.NET anonymous identifier. This is the System.Web.HttpContext.Request.AnonymousID. ASP.NET anonymous identification must be enabled. The web.config must include <anonymousIdentification enabled="true"/>.
GetSessionIDFromHttpSessionState | Gets the SSO session identifier by returning the ASP.NET session state identifier. This is the System.Web.HttpSessionState.SessionID. ASP.NET session state must be enabled. The default setting of <sessionState cookieless="UseCookies"/> in web.config is required.
Top
See Also

Reference

ComponentSpace.SAML2.Data Namespace


SessionIDDelegates Methods

The SessionIDDelegates type exposes the following members.

Methods
Name | Description
GetSessionIDFromAnonymousID | Gets the SSO session identifier by returning the ASP.NET anonymous identifier. This is the System.Web.HttpContext.Request.AnonymousID. ASP.NET anonymous identification must be enabled. The web.config must include <anonymousIdentification enabled="true"/>.
GetSessionIDFromHttpSessionState | Gets the SSO session identifier by returning the ASP.NET session state identifier. This is the System.Web.HttpSessionState.SessionID. ASP.NET session state must be enabled. The default setting of <sessionState cookieless="UseCookies"/> in web.config is required.
Top
See Also

Reference

SessionIDDelegates Class
ComponentSpace.SAML2.Data Namespace


SessionIDDelegates.GetSessionIDFromAnonymousID Method

SessionIDDelegatesGetSessionIDFromAnonymousID Method

Gets the SSO session identifier by returning the ASP.NET anonymous identifier.

This is the System.Web.HttpContext.Request.AnonymousID.

ASP.NET anonymous identification must be enabled.

The web.config must include <anonymousIdentification enabled="true"/>.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetSessionIDFromAnonymousID()
Public Shared Function GetSessionIDFromAnonymousID As String
public:
static String^ GetSessionIDFromAnonymousID()
static member GetSessionIDFromAnonymousID : unit -> string

Return Value

Type: String
The SSO session identifier.
See Also

Reference

SessionIDDelegates Class
ComponentSpace.SAML2.Data Namespace


SessionIDDelegates.GetSessionIDFromHttpSessionState Method

SessionIDDelegatesGetSessionIDFromHttpSessionState Method

Gets the SSO session identifier by returning the ASP.NET session state identifier.

This is the System.Web.HttpSessionState.SessionID.

ASP.NET session state must be enabled.

The default setting of <sessionState cookieless="UseCookies"/> in web.config is required.

Namespace: ComponentSpace.SAML2.Data
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetSessionIDFromHttpSessionState()
Public Shared Function GetSessionIDFromHttpSessionState As String
public:
static String^ GetSessionIDFromHttpSessionState()
static member GetSessionIDFromHttpSessionState : unit -> string

Return Value

Type: String
The SSO session identifier.
See Also

Reference

SessionIDDelegates Class
ComponentSpace.SAML2.Data Namespace


ComponentSpace.SAML2.Exceptions Namespace

The ComponentSpace.SAML2.Exceptions namespace contains the exceptions thrown by the class library.
Classes
 | Class | Description
Public class | SAMLBindingException | The exception that is thrown when a SAML binding error occurs.
Public class | SAMLCertificateException | The exception that is thrown when a SAML X.509 certificate error occurs.
Public class | SAMLConfigurationException | The exception that is thrown when a SAML configuration error occurs.
Public class | SAMLDatabaseException | The exception that is thrown when a SAML database error occurs.
Public class | SAMLEncryptionException | The exception that is thrown when a SAML encryption or decryption fails.
Public class | SAMLEnvironmentException | The exception that is thrown when a SAML environment error occurs.
Public class | SAMLErrorStatusException | The exception that is thrown when a SAML error status is returned in a response message.
Public class | SAMLException | The exception that is thrown when a SAML operation fails.
Public class | SAMLLicenseException | The exception that is thrown when a license error occurs.
Public class | SAMLProfileException | The exception that is thrown when a SAML profile error occurs.
Public class | SAMLProtocolException | The exception that is thrown when a SAML protocol error occurs.
Public class | SAMLSchemaValidationException | The exception that is thrown when a SAML schema validation error occurs.
Public class | SAMLSerializationException | The exception that is thrown when a SAML serialization or deserialization operation fails.
Public class | SAMLSignatureException | The exception that is thrown when a SAML signature generation or verification fails.


SAMLBindingException Class

The exception that is thrown when a SAML binding error occurs.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLBindingException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLBindingException : SAMLException
<SerializableAttribute>
Public Class SAMLBindingException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLBindingException : public SAMLException
[<SerializableAttribute>]
type SAMLBindingException =
    class
        inherit SAMLException
    end

The SAMLBindingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLBindingException Properties

The SAMLBindingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLBindingException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLBindingException Methods

The SAMLBindingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLBindingException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLBindingException Events

The SAMLBindingException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLBindingException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLCertificateException Class

The exception that is thrown when a SAML X.509 certificate error occurs.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLCertificateException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLCertificateException : SAMLException
<SerializableAttribute>
Public Class SAMLCertificateException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLCertificateException : public SAMLException
[<SerializableAttribute>]
type SAMLCertificateException =
    class
        inherit SAMLException
    end

The SAMLCertificateException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLCertificateException Properties

The SAMLCertificateException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLCertificateException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLCertificateException Methods

The SAMLCertificateException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLCertificateException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLCertificateException Events

The SAMLCertificateException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLCertificateException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLConfigurationException Class

The exception that is thrown when a SAML configuration error occurs.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLConfigurationException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLConfigurationException : SAMLException
<SerializableAttribute>
Public Class SAMLConfigurationException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLConfigurationException : public SAMLException
[<SerializableAttribute>]
type SAMLConfigurationException =
    class
        inherit SAMLException
    end

The SAMLConfigurationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLConfigurationException Properties

The SAMLConfigurationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLConfigurationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLConfigurationException Methods

The SAMLConfigurationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLConfigurationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLConfigurationException Events

The SAMLConfigurationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLConfigurationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLDatabaseException Class

The exception that is thrown when a SAML database error occurs.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLDatabaseException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLDatabaseException : SAMLException
<SerializableAttribute>
Public Class SAMLDatabaseException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLDatabaseException : public SAMLException
[<SerializableAttribute>]
type SAMLDatabaseException =
    class
        inherit SAMLException
    end

The SAMLDatabaseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLDatabaseException Properties

The SAMLDatabaseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLDatabaseException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLDatabaseException Methods

The SAMLDatabaseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLDatabaseException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLDatabaseException Events

The SAMLDatabaseException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLDatabaseException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLEncryptionException Class

The exception that is thrown when a SAML encryption or decryption fails.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLEncryptionException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLEncryptionException : SAMLException
<SerializableAttribute>
Public Class SAMLEncryptionException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLEncryptionException : public SAMLException
[<SerializableAttribute>]
type SAMLEncryptionException =
    class
        inherit SAMLException
    end

The SAMLEncryptionException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLEncryptionException Properties

The SAMLEncryptionException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLEncryptionException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLEncryptionException Methods

The SAMLEncryptionException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLEncryptionException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLEncryptionException Events

The SAMLEncryptionException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLEncryptionException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLEnvironmentException Class

The exception that is thrown when a SAML environment error occurs.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLEnvironmentException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLEnvironmentException : SAMLException
<SerializableAttribute>
Public Class SAMLEnvironmentException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLEnvironmentException : public SAMLException
[<SerializableAttribute>]
type SAMLEnvironmentException =
    class
        inherit SAMLException
    end

The SAMLEnvironmentException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLEnvironmentException Properties

The SAMLEnvironmentException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLEnvironmentException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLEnvironmentException Methods

The SAMLEnvironmentException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLEnvironmentException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLEnvironmentException Events

The SAMLEnvironmentException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLEnvironmentException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLErrorStatusException Class

The exception that is thrown when a SAML error status is returned in a response message.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLErrorStatusException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLErrorStatusException : SAMLException
<SerializableAttribute>
Public Class SAMLErrorStatusException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLErrorStatusException : public SAMLException
[<SerializableAttribute>]
type SAMLErrorStatusException =
    class
        inherit SAMLException
    end

The SAMLErrorStatusException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | Status | Gets the status code.
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Serialize the SAML assertion. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLErrorStatusException Properties

The SAMLErrorStatusException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | Status | Gets the status code.
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLErrorStatusException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLErrorStatusException.Status Property

SAMLErrorStatusExceptionStatus Property

Gets the status code.

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Status Status { get; }
Public ReadOnly Property Status As Status
    Get
public:
property Status^ Status {
    Status^ get ();
}
member Status : Status with get

Property Value

Type: Status
The status code.
See Also

Reference

SAMLErrorStatusException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLErrorStatusException Methods

The SAMLErrorStatusException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Serialize the SAML assertion. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLErrorStatusException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLErrorStatusException.GetObjectData Method

SAMLErrorStatusExceptionGetObjectData Method

Serialize the SAML assertion.

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information.
context
Type: System.Runtime.SerializationStreamingContext
The streaming context.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SAMLErrorStatusException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLErrorStatusException Events

The SAMLErrorStatusException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLErrorStatusException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLException Class

The exception that is thrown when a SAML operation fails.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
More...

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLException : ApplicationException
<SerializableAttribute>
Public Class SAMLException
    Inherits ApplicationException
[SerializableAttribute]
public ref class SAMLException : public ApplicationException
[<SerializableAttribute>]
type SAMLException =
    class
        inherit ApplicationException
    end

The SAMLException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLBindingException
ComponentSpace.SAML2.ExceptionsSAMLCertificateException
ComponentSpace.SAML2.ExceptionsSAMLConfigurationException
ComponentSpace.SAML2.ExceptionsSAMLDatabaseException
ComponentSpace.SAML2.ExceptionsSAMLEncryptionException
ComponentSpace.SAML2.ExceptionsSAMLEnvironmentException
ComponentSpace.SAML2.ExceptionsSAMLErrorStatusException
ComponentSpace.SAML2.ExceptionsSAMLLicenseException
ComponentSpace.SAML2.ExceptionsSAMLProfileException
ComponentSpace.SAML2.ExceptionsSAMLProtocolException
ComponentSpace.SAML2.ExceptionsSAMLSchemaValidationException
ComponentSpace.SAML2.ExceptionsSAMLSerializationException
ComponentSpace.SAML2.ExceptionsSAMLSignatureException


SAMLException Properties

The SAMLException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLException Methods

The SAMLException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLException Events

The SAMLException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLLicenseException Class

The exception that is thrown when a license error occurs.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLLicenseException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLLicenseException : SAMLException
<SerializableAttribute>
Public Class SAMLLicenseException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLLicenseException : public SAMLException
[<SerializableAttribute>]
type SAMLLicenseException =
    class
        inherit SAMLException
    end

The SAMLLicenseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLLicenseException Properties

The SAMLLicenseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLLicenseException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLLicenseException Methods

The SAMLLicenseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLLicenseException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLLicenseException Events

The SAMLLicenseException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLLicenseException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLProfileException Class

The exception that is thrown when a SAML profile error occurs.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLProfileException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLProfileException : SAMLException
<SerializableAttribute>
Public Class SAMLProfileException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLProfileException : public SAMLException
[<SerializableAttribute>]
type SAMLProfileException =
    class
        inherit SAMLException
    end

The SAMLProfileException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLProfileException Properties

The SAMLProfileException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLProfileException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLProfileException Methods

The SAMLProfileException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLProfileException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLProfileException Events

The SAMLProfileException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLProfileException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLProtocolException Class

The exception that is thrown when a SAML protocol error occurs.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLProtocolException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLProtocolException : SAMLException
<SerializableAttribute>
Public Class SAMLProtocolException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLProtocolException : public SAMLException
[<SerializableAttribute>]
type SAMLProtocolException =
    class
        inherit SAMLException
    end

The SAMLProtocolException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLProtocolException Properties

The SAMLProtocolException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLProtocolException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLProtocolException Methods

The SAMLProtocolException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLProtocolException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLProtocolException Events

The SAMLProtocolException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLProtocolException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSchemaValidationException Class

The exception that is thrown when a SAML schema validation error occurs.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLSchemaValidationException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLSchemaValidationException : SAMLException
<SerializableAttribute>
Public Class SAMLSchemaValidationException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLSchemaValidationException : public SAMLException
[<SerializableAttribute>]
type SAMLSchemaValidationException =
    class
        inherit SAMLException
    end

The SAMLSchemaValidationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Errors | Gets the list of XML schema errors.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | Warnings | Gets the list of XML schema warnings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLSchemaValidationException Properties

The SAMLSchemaValidationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Errors | Gets the list of XML schema errors.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | Warnings | Gets the list of XML schema warnings.
Top
See Also

Reference

SAMLSchemaValidationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSchemaValidationException.Errors Property

SAMLSchemaValidationExceptionErrors Property

Gets the list of XML schema errors.

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<XmlSchemaException> Errors { get; }
Public ReadOnly Property Errors As IList(Of XmlSchemaException)
    Get
public:
property IList<XmlSchemaException^>^ Errors {
    IList<XmlSchemaException^>^ get ();
}
member Errors : IList<XmlSchemaException> with get

Property Value

Type: IList XmlSchemaException
The list of XML schema errors.
See Also

Reference

SAMLSchemaValidationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSchemaValidationException.Warnings Property

SAMLSchemaValidationExceptionWarnings Property

Gets the list of XML schema warnings.

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<XmlSchemaException> Warnings { get; }
Public ReadOnly Property Warnings As IList(Of XmlSchemaException)
    Get
public:
property IList<XmlSchemaException^>^ Warnings {
    IList<XmlSchemaException^>^ get ();
}
member Warnings : IList<XmlSchemaException> with get

Property Value

Type: IList XmlSchemaException
The list of XML schema warnings.
See Also

Reference

SAMLSchemaValidationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSchemaValidationException Methods

The SAMLSchemaValidationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLSchemaValidationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSchemaValidationException Events

The SAMLSchemaValidationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLSchemaValidationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSerializationException Class

The exception that is thrown when a SAML serialization or deserialization operation fails.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLSerializationException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLSerializationException : SAMLException
<SerializableAttribute>
Public Class SAMLSerializationException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLSerializationException : public SAMLException
[<SerializableAttribute>]
type SAMLSerializationException =
    class
        inherit SAMLException
    end

The SAMLSerializationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLSerializationException Properties

The SAMLSerializationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLSerializationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSerializationException Methods

The SAMLSerializationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLSerializationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSerializationException Events

The SAMLSerializationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLSerializationException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSignatureException Class

The exception that is thrown when a SAML signature generation or verification fails.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
ComponentSpace.SAML2.ExceptionsSAMLException
ComponentSpace.SAML2.ExceptionsSAMLSignatureException

Namespace: ComponentSpace.SAML2.Exceptions
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SAMLSignatureException : SAMLException
<SerializableAttribute>
Public Class SAMLSignatureException
    Inherits SAMLException
[SerializableAttribute]
public ref class SAMLSignatureException : public SAMLException
[<SerializableAttribute>]
type SAMLSignatureException =
    class
        inherit SAMLException
    end

The SAMLSignatureException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ComponentSpace.SAML2.Exceptions Namespace


SAMLSignatureException Properties

The SAMLSignatureException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLSignatureException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSignatureException Methods

The SAMLSignatureException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLSignatureException Class
ComponentSpace.SAML2.Exceptions Namespace


SAMLSignatureException Events

The SAMLSignatureException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SAMLSignatureException Class
ComponentSpace.SAML2.Exceptions Namespace


ComponentSpace.SAML2.Metadata Namespace

The ComponentSpace.SAML2.Metadata namespace contains classes associated with the SAML v2.0 metadata.
Classes
 | Class | Description
Public class | AdditionalMetadataLocation | Represents an additional metadata location.
Public class | AffiliationDescriptor | Represents an affiliation descriptor.
Public class | AttributeAuthorityDescriptor | Represents an attribute authority descriptor.
Public class | AttributeConsumingService | Represents an attribute consuming service.
Public class | AuthnAuthorityDescriptor | Represents an authentication authority descriptor.
Public class | ContactPerson | Represents a contact person.
Public class | ContactType | Represents the contact type.
Public class | ContactTypeContactTypeValues | The contact types.
Public class | Duration | Represents the XML schema duration type.
Public class | EndpointType | Represents the endpoint type.
Public class | EntitiesDescriptor | Represents an entities descriptor.
Public class | EntityDescriptor | Represents an entity descriptor.
Public class | EntityIDType | Represents the entity ID type.
Public class | Extensions | Represents an extensions.
Public class | IDPSSODescriptor | Represents an IdP SSO descriptor.
Public class | IndexedEndpointType | Represents the indexed endpoint type.
Public class | KeyDescriptor | Represents a key descriptor.
Public class | KeyDescriptorKeyTypes | The key types.
Public class | LocalizedNameType | Represents the localized name type.
Public class | LocalizedURIType | Represents the localized URI type.
Public class | Organization | Represents an organization.
Public class | OrganizationDisplayName | Represents an organization display name.
Public class | OrganizationName | Represents an organization name.
Public class | OrganizationURL | Represents an organization URL.
Public class | PDPDescriptor | Represents a PDP descriptor.
Public class | RequestedAttribute | Represents a requested attribute.
Public class | RoleDescriptor | Represents a role descriptor.
Public class | RoleDescriptorType | Represents the role descriptor type.
Public class | SAMLMetadataSignature | Permits XML signature generation and verification for SAML metadata.
Public class | SPSSODescriptor | Represents an SP SSO descriptor.
Public class | SSODescriptorType | Represents the SSO descriptor type.


AdditionalMetadataLocation Class

Represents an additional metadata location.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataAdditionalMetadataLocation

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AdditionalMetadataLocation
Public Class AdditionalMetadataLocation
public ref class AdditionalMetadataLocation
type AdditionalMetadataLocation =  class end

The AdditionalMetadataLocation type exposes the following members.

Constructors
 | Name | Description
Public method | AdditionalMetadataLocation | Initializes a new instance of the AdditionalMetadataLocation class.
Public method | AdditionalMetadataLocation(XmlElement) | Initializes a new instance of the AdditionalMetadataLocation class from XML.
Public method | AdditionalMetadataLocation(String, String) | Initializes a new instance of the AdditionalMetadataLocation class.
Top
Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Public property | XmlNamespace | Gets or sets the XML namespace.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an additional metadata location.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the additional metadata location to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


AdditionalMetadataLocation Constructor

Overload List
 | Name | Description
Public method | AdditionalMetadataLocation | Initializes a new instance of the AdditionalMetadataLocation class.
Public method | AdditionalMetadataLocation(XmlElement) | Initializes a new instance of the AdditionalMetadataLocation class from XML.
Public method | AdditionalMetadataLocation(String, String) | Initializes a new instance of the AdditionalMetadataLocation class.
Top
See Also

Reference

AdditionalMetadataLocation Class
ComponentSpace.SAML2.Metadata Namespace


AdditionalMetadataLocation Constructor

Initializes a new instance of the AdditionalMetadataLocation class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AdditionalMetadataLocation()
Public Sub New
public:
AdditionalMetadataLocation()
new : unit -> AdditionalMetadataLocation
See Also

Reference

AdditionalMetadataLocation Class
AdditionalMetadataLocation Overload
ComponentSpace.SAML2.Metadata Namespace


AdditionalMetadataLocation Constructor (XmlElement)

Initializes a new instance of the AdditionalMetadataLocation class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AdditionalMetadataLocation(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AdditionalMetadataLocation(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AdditionalMetadataLocation

Parameters

xmlElement
Type: System.XmlXmlElement
The additional metadata location XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AdditionalMetadataLocation Class
AdditionalMetadataLocation Overload
ComponentSpace.SAML2.Metadata Namespace


AdditionalMetadataLocation Constructor (String, String)

Initializes a new instance of the AdditionalMetadataLocation class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AdditionalMetadataLocation(
    string xmlNamespace,
    string uri
)
Public Sub New (
    xmlNamespace As String,
    uri As String
)
public:
AdditionalMetadataLocation(
    String^ xmlNamespace,
    String^ uri
)
new :
        xmlNamespace : string *
        uri : string -> AdditionalMetadataLocation

Parameters

xmlNamespace
Type: SystemString
The XML namespace.
uri
Type: SystemString
The location URI.
See Also

Reference

AdditionalMetadataLocation Class
AdditionalMetadataLocation Overload
ComponentSpace.SAML2.Metadata Namespace


AdditionalMetadataLocation Properties

The AdditionalMetadataLocation type exposes the following members.

Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Public property | XmlNamespace | Gets or sets the XML namespace.
Top
See Also

Reference

AdditionalMetadataLocation Class
ComponentSpace.SAML2.Metadata Namespace


AdditionalMetadataLocation.URI Property

AdditionalMetadataLocationURI Property

Gets or sets the URI.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string URI { get; set; }
Public Property URI As String
    Get
    Set
public:
property String^ URI {
    String^ get ();
    void set (String^ value);
}
member URI : string with get, set

Property Value

Type: String
The URI.
See Also

Reference

AdditionalMetadataLocation Class
ComponentSpace.SAML2.Metadata Namespace


AdditionalMetadataLocation.XmlNamespace Property

AdditionalMetadataLocationXmlNamespace Property

Gets or sets the XML namespace.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string XmlNamespace { get; set; }
Public Property XmlNamespace As String
    Get
    Set
public:
property String^ XmlNamespace {
    String^ get ();
    void set (String^ value);
}
member XmlNamespace : string with get, set

Property Value

Type: String
The XML namespace.
See Also

Reference

AdditionalMetadataLocation Class
ComponentSpace.SAML2.Metadata Namespace


AdditionalMetadataLocation Methods

The AdditionalMetadataLocation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an additional metadata location.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the additional metadata location to XML.
Top
See Also

Reference

AdditionalMetadataLocation Class
ComponentSpace.SAML2.Metadata Namespace


AdditionalMetadataLocation.IsValid Method

AdditionalMetadataLocationIsValid Method

Indicates whether the XML is an additional metadata location.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an organization; otherwise false.
See Also

Reference

AdditionalMetadataLocation Class
ComponentSpace.SAML2.Metadata Namespace


AdditionalMetadataLocation.ToXml Method

AdditionalMetadataLocationToXml Method

Serializes the additional metadata location to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The additional metadata location as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AdditionalMetadataLocation Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor Class

Represents an affiliation descriptor.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataAffiliationDescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AffiliationDescriptor
Public Class AffiliationDescriptor
public ref class AffiliationDescriptor
type AffiliationDescriptor =  class end

The AffiliationDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | AffiliationDescriptor | Initializes a new instance of the AffiliationDescriptor class.
Public method | AffiliationDescriptor(XmlElement) | Initializes a new instance of the AffiliationDescriptor class from XML.
Top
Properties
 | Name | Description
Public property | AffiliateMembers | Gets or sets the list of affiliate members.
Public property | AffiliationOwnerID | Gets or sets the affiliation owner ID.
Public property | CacheDuration | Gets or sets the cache duration.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | KeyDescriptors | Gets or sets the list of key descriptors.
Public property | Signature | Gets or sets the digital signature.
Public property | ValidUntil | Gets or sets the valid until date/time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an affiliation descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the affiliation descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the affiliation descriptor to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor Constructor

Overload List
 | Name | Description
Public method | AffiliationDescriptor | Initializes a new instance of the AffiliationDescriptor class.
Public method | AffiliationDescriptor(XmlElement) | Initializes a new instance of the AffiliationDescriptor class from XML.
Top
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor Constructor

Initializes a new instance of the AffiliationDescriptor class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AffiliationDescriptor()
Public Sub New
public:
AffiliationDescriptor()
new : unit -> AffiliationDescriptor
See Also

Reference

AffiliationDescriptor Class
AffiliationDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor Constructor (XmlElement)

Initializes a new instance of the AffiliationDescriptor class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AffiliationDescriptor(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AffiliationDescriptor(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AffiliationDescriptor

Parameters

xmlElement
Type: System.XmlXmlElement
The affiliation descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AffiliationDescriptor Class
AffiliationDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor Properties

The AffiliationDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | AffiliateMembers | Gets or sets the list of affiliate members.
Public property | AffiliationOwnerID | Gets or sets the affiliation owner ID.
Public property | CacheDuration | Gets or sets the cache duration.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | KeyDescriptors | Gets or sets the list of key descriptors.
Public property | Signature | Gets or sets the digital signature.
Public property | ValidUntil | Gets or sets the valid until date/time.
Top
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.AffiliateMembers Property

AffiliationDescriptorAffiliateMembers Property

Gets or sets the list of affiliate members.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EntityIDType> AffiliateMembers { get; set; }
Public Property AffiliateMembers As IList(Of EntityIDType)
    Get
    Set
public:
property IList<EntityIDType^>^ AffiliateMembers {
    IList<EntityIDType^>^ get ();
    void set (IList<EntityIDType^>^ value);
}
member AffiliateMembers : IList<EntityIDType> with get, set

Property Value

Type: IList EntityIDType
The list of affiliate members.
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.AffiliationOwnerID Property

AffiliationDescriptorAffiliationOwnerID Property

Gets or sets the affiliation owner ID.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string AffiliationOwnerID { get; set; }
Public Property AffiliationOwnerID As String
    Get
    Set
public:
property String^ AffiliationOwnerID {
    String^ get ();
    void set (String^ value);
}
member AffiliationOwnerID : string with get, set

Property Value

Type: String
The affiliation owner ID.
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.CacheDuration Property

AffiliationDescriptorCacheDuration Property

Gets or sets the cache duration.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Duration CacheDuration { get; set; }
Public Property CacheDuration As Duration
    Get
    Set
public:
property Duration^ CacheDuration {
    Duration^ get ();
    void set (Duration^ value);
}
member CacheDuration : Duration with get, set

Property Value

Type: Duration
The cache duration.
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.Extensions Property

AffiliationDescriptorExtensions Property

Gets or sets the extensions.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions Extensions { get; set; }
Public Property Extensions As Extensions
    Get
    Set
public:
property Extensions^ Extensions {
    Extensions^ get ();
    void set (Extensions^ value);
}
member Extensions : Extensions with get, set

Property Value

Type: Extensions
The extensions.
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.ID Property

AffiliationDescriptorID Property

Gets or sets the ID.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
The ID.
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.KeyDescriptors Property

AffiliationDescriptorKeyDescriptors Property

Gets or sets the list of key descriptors.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<KeyDescriptor> KeyDescriptors { get; set; }
Public Property KeyDescriptors As IList(Of KeyDescriptor)
    Get
    Set
public:
property IList<KeyDescriptor^>^ KeyDescriptors {
    IList<KeyDescriptor^>^ get ();
    void set (IList<KeyDescriptor^>^ value);
}
member KeyDescriptors : IList<KeyDescriptor> with get, set

Property Value

Type: IList KeyDescriptor
The list of key descriptors.
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.Signature Property

AffiliationDescriptorSignature Property

Gets or sets the digital signature.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement Signature { get; set; }
Public Property Signature As XmlElement
    Get
    Set
public:
property XmlElement^ Signature {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member Signature : XmlElement with get, set

Property Value

Type: XmlElement
The digital signature.
Remarks
To generate or verify signatures, use SAMLMetadataSignature.
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace
ComponentSpace.SAML2.MetadataSAMLMetadataSignature


AffiliationDescriptor.ValidUntil Property

AffiliationDescriptorValidUntil Property

Gets or sets the valid until date/time.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime ValidUntil { get; set; }
Public Property ValidUntil As DateTime
    Get
    Set
public:
property DateTime ValidUntil {
    DateTime get ();
    void set (DateTime value);
}
member ValidUntil : DateTime with get, set

Property Value

Type: DateTime
The valid until date/time.
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor Methods

The AffiliationDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an affiliation descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the affiliation descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the affiliation descriptor to XML.
Top
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.IsValid Method

AffiliationDescriptorIsValid Method

Indicates whether the XML is an affiliation descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an affiliation descriptor; otherwise false.
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.ToXml Method

AffiliationDescriptorToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the affiliation descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the affiliation descriptor to XML.
Top
See Also

Reference

AffiliationDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.ToXml Method

AffiliationDescriptorToXml Method

Serializes the affiliation descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The affiliation descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

AffiliationDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


AffiliationDescriptor.ToXml Method (XmlDocument)

AffiliationDescriptorToXml Method (XmlDocument)

Serializes the affiliation descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The affiliation descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AffiliationDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor Class

Represents an attribute authority descriptor.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataRoleDescriptorType
ComponentSpace.SAML2.MetadataAttributeAuthorityDescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AttributeAuthorityDescriptor : RoleDescriptorType
Public Class AttributeAuthorityDescriptor
    Inherits RoleDescriptorType
public ref class AttributeAuthorityDescriptor : public RoleDescriptorType
type AttributeAuthorityDescriptor =
    class
        inherit RoleDescriptorType
    end

The AttributeAuthorityDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeAuthorityDescriptor | Initializes a new instance of the AttributeAuthorityDescriptor class.
Public method | AttributeAuthorityDescriptor(XmlElement) | Initializes a new instance of the AttributeAuthorityDescriptor class from XML.
Top
Properties
 | Name | Description
Public property | AssertionIDRequestServices | Gets or sets the list of assertion ID request services.
Public property | AttributeProfiles | Gets or sets the list of attribute profiles.
Public property | Attributes | Gets or sets the list of attributes.
Public property | AttributeServices | Gets or sets the list of attribute services.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | NameIDFormats | Gets or sets the list of name ID formats.
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an attribute authority descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the attribute authority descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor Constructor

Overload List
 | Name | Description
Public method | AttributeAuthorityDescriptor | Initializes a new instance of the AttributeAuthorityDescriptor class.
Public method | AttributeAuthorityDescriptor(XmlElement) | Initializes a new instance of the AttributeAuthorityDescriptor class from XML.
Top
See Also

Reference

AttributeAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor Constructor

Initializes a new instance of the AttributeAuthorityDescriptor class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeAuthorityDescriptor()
Public Sub New
public:
AttributeAuthorityDescriptor()
new : unit -> AttributeAuthorityDescriptor
See Also

Reference

AttributeAuthorityDescriptor Class
AttributeAuthorityDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor Constructor (XmlElement)

Initializes a new instance of the AttributeAuthorityDescriptor class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeAuthorityDescriptor(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AttributeAuthorityDescriptor(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AttributeAuthorityDescriptor

Parameters

xmlElement
Type: System.XmlXmlElement
The attribute authority descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AttributeAuthorityDescriptor Class
AttributeAuthorityDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor Properties

The AttributeAuthorityDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | AssertionIDRequestServices | Gets or sets the list of assertion ID request services.
Public property | AttributeProfiles | Gets or sets the list of attribute profiles.
Public property | Attributes | Gets or sets the list of attributes.
Public property | AttributeServices | Gets or sets the list of attribute services.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | NameIDFormats | Gets or sets the list of name ID formats.
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

AttributeAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor.AssertionIDRequestServices Property

AttributeAuthorityDescriptorAssertionIDRequestServices Property

Gets or sets the list of assertion ID request services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> AssertionIDRequestServices { get; set; }
Public Property AssertionIDRequestServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ AssertionIDRequestServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member AssertionIDRequestServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of assertion ID request services.
See Also

Reference

AttributeAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor.AttributeProfiles Property

AttributeAuthorityDescriptorAttributeProfiles Property

Gets or sets the list of attribute profiles.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<string> AttributeProfiles { get; set; }
Public Property AttributeProfiles As IList(Of String)
    Get
    Set
public:
property IList<String^>^ AttributeProfiles {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member AttributeProfiles : IList<string> with get, set

Property Value

Type: IList String
The list of attribute profiles.
See Also

Reference

AttributeAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor.Attributes Property

AttributeAuthorityDescriptorAttributes Property

Gets or sets the list of attributes.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<SAMLAttribute> Attributes { get; set; }
Public Property Attributes As IList(Of SAMLAttribute)
    Get
    Set
public:
property IList<SAMLAttribute^>^ Attributes {
    IList<SAMLAttribute^>^ get ();
    void set (IList<SAMLAttribute^>^ value);
}
member Attributes : IList<SAMLAttribute> with get, set

Property Value

Type: IList SAMLAttribute
The list of attributes.
See Also

Reference

AttributeAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor.AttributeServices Property

AttributeAuthorityDescriptorAttributeServices Property

Gets or sets the list of attribute services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> AttributeServices { get; set; }
Public Property AttributeServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ AttributeServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member AttributeServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of attribute services.
See Also

Reference

AttributeAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor.NameIDFormats Property

AttributeAuthorityDescriptorNameIDFormats Property

Gets or sets the list of name ID formats.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<string> NameIDFormats { get; set; }
Public Property NameIDFormats As IList(Of String)
    Get
    Set
public:
property IList<String^>^ NameIDFormats {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member NameIDFormats : IList<string> with get, set

Property Value

Type: IList String
The list of name ID formats.
See Also

Reference

AttributeAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor Methods

The AttributeAuthorityDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an attribute authority descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the attribute authority descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

AttributeAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor.IsValid Method

AttributeAuthorityDescriptorIsValid Method

Indicates whether the XML is an attribute authority descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an attribute authority descriptor; otherwise false.
See Also

Reference

AttributeAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor.ToXml Method

AttributeAuthorityDescriptorToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlDocument) | Serializes the attribute authority descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

AttributeAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AttributeAuthorityDescriptor.ToXml Method (XmlDocument)

AttributeAuthorityDescriptorToXml Method (XmlDocument)

Serializes the attribute authority descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The attribute authority descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AttributeAuthorityDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService Class

Represents an attribute consuming service.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataAttributeConsumingService

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AttributeConsumingService
Public Class AttributeConsumingService
public ref class AttributeConsumingService
type AttributeConsumingService =  class end

The AttributeConsumingService type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeConsumingService | Initializes a new instance of the AttributeConsumingService class.
Public method | AttributeConsumingService(XmlElement) | Initializes a new instance of the AttributeConsumingService class from XML.
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index.
Public property | IsDefault | Gets or sets the is default flag.
Public property | RequestedAttributes | Gets or sets the list of requested attributes.
Public property | ServiceDescriptions | Gets or sets the list of service descriptions.
Public property | ServiceNames | Gets or sets the list of service names.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an attribute consuming service.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the attribute consuming service to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService Constructor

Overload List
 | Name | Description
Public method | AttributeConsumingService | Initializes a new instance of the AttributeConsumingService class.
Public method | AttributeConsumingService(XmlElement) | Initializes a new instance of the AttributeConsumingService class from XML.
Top
See Also

Reference

AttributeConsumingService Class
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService Constructor

Initializes a new instance of the AttributeConsumingService class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeConsumingService()
Public Sub New
public:
AttributeConsumingService()
new : unit -> AttributeConsumingService
See Also

Reference

AttributeConsumingService Class
AttributeConsumingService Overload
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService Constructor (XmlElement)

Initializes a new instance of the AttributeConsumingService class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeConsumingService(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AttributeConsumingService(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AttributeConsumingService

Parameters

xmlElement
Type: System.XmlXmlElement
The attribute consuming service XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AttributeConsumingService Class
AttributeConsumingService Overload
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService Properties

The AttributeConsumingService type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index.
Public property | IsDefault | Gets or sets the is default flag.
Public property | RequestedAttributes | Gets or sets the list of requested attributes.
Public property | ServiceDescriptions | Gets or sets the list of service descriptions.
Public property | ServiceNames | Gets or sets the list of service names.
Top
See Also

Reference

AttributeConsumingService Class
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService.Index Property

AttributeConsumingServiceIndex Property

Gets or sets the index.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
The index.
See Also

Reference

AttributeConsumingService Class
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService.IsDefault Property

AttributeConsumingServiceIsDefault Property

Gets or sets the is default flag.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool IsDefault { get; set; }
Public Property IsDefault As Boolean
    Get
    Set
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}
member IsDefault : bool with get, set

Property Value

Type: Boolean
The is default flag.
See Also

Reference

AttributeConsumingService Class
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService.RequestedAttributes Property

AttributeConsumingServiceRequestedAttributes Property

Gets or sets the list of requested attributes.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<RequestedAttribute> RequestedAttributes { get; set; }
Public Property RequestedAttributes As IList(Of RequestedAttribute)
    Get
    Set
public:
property IList<RequestedAttribute^>^ RequestedAttributes {
    IList<RequestedAttribute^>^ get ();
    void set (IList<RequestedAttribute^>^ value);
}
member RequestedAttributes : IList<RequestedAttribute> with get, set

Property Value

Type: IList RequestedAttribute
The list of requested attributes.
See Also

Reference

AttributeConsumingService Class
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService.ServiceDescriptions Property

AttributeConsumingServiceServiceDescriptions Property

Gets or sets the list of service descriptions.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<LocalizedNameType> ServiceDescriptions { get; set; }
Public Property ServiceDescriptions As IList(Of LocalizedNameType)
    Get
    Set
public:
property IList<LocalizedNameType^>^ ServiceDescriptions {
    IList<LocalizedNameType^>^ get ();
    void set (IList<LocalizedNameType^>^ value);
}
member ServiceDescriptions : IList<LocalizedNameType> with get, set

Property Value

Type: IList LocalizedNameType
The list of service descriptions.
See Also

Reference

AttributeConsumingService Class
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService.ServiceNames Property

AttributeConsumingServiceServiceNames Property

Gets or sets the list of service names.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<LocalizedNameType> ServiceNames { get; set; }
Public Property ServiceNames As IList(Of LocalizedNameType)
    Get
    Set
public:
property IList<LocalizedNameType^>^ ServiceNames {
    IList<LocalizedNameType^>^ get ();
    void set (IList<LocalizedNameType^>^ value);
}
member ServiceNames : IList<LocalizedNameType> with get, set

Property Value

Type: IList LocalizedNameType
The list of service names.
See Also

Reference

AttributeConsumingService Class
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService Methods

The AttributeConsumingService type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an attribute consuming service.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the attribute consuming service to XML.
Top
See Also

Reference

AttributeConsumingService Class
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService.IsValid Method

AttributeConsumingServiceIsValid Method

Indicates whether the XML is an attribute consuming service.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an attribute consuming service; otherwise false.
See Also

Reference

AttributeConsumingService Class
ComponentSpace.SAML2.Metadata Namespace


AttributeConsumingService.ToXml Method

AttributeConsumingServiceToXml Method

Serializes the attribute consuming service to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The attribute consuming service as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AttributeConsumingService Class
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor Class

Represents an authentication authority descriptor.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataRoleDescriptorType
ComponentSpace.SAML2.MetadataAuthnAuthorityDescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthnAuthorityDescriptor : RoleDescriptorType
Public Class AuthnAuthorityDescriptor
    Inherits RoleDescriptorType
public ref class AuthnAuthorityDescriptor : public RoleDescriptorType
type AuthnAuthorityDescriptor =
    class
        inherit RoleDescriptorType
    end

The AuthnAuthorityDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | AuthnAuthorityDescriptor | Initializes a new instance of the AuthnAuthorityDescriptor class.
Public method | AuthnAuthorityDescriptor(XmlElement) | Initializes a new instance of the AuthnAuthorityDescriptor class from XML.
Top
Properties
 | Name | Description
Public property | AssertionIDRequestServices | Gets or sets the list of assertion ID request services.
Public property | AuthnQueryServices | Gets or sets the list of authentication query services.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | NameIDFormats | Gets or sets the list of name ID formats.
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication authority descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the authentication authority descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor Constructor

Overload List
 | Name | Description
Public method | AuthnAuthorityDescriptor | Initializes a new instance of the AuthnAuthorityDescriptor class.
Public method | AuthnAuthorityDescriptor(XmlElement) | Initializes a new instance of the AuthnAuthorityDescriptor class from XML.
Top
See Also

Reference

AuthnAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor Constructor

Initializes a new instance of the AuthnAuthorityDescriptor class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnAuthorityDescriptor()
Public Sub New
public:
AuthnAuthorityDescriptor()
new : unit -> AuthnAuthorityDescriptor
See Also

Reference

AuthnAuthorityDescriptor Class
AuthnAuthorityDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor Constructor (XmlElement)

Initializes a new instance of the AuthnAuthorityDescriptor class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnAuthorityDescriptor(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthnAuthorityDescriptor(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthnAuthorityDescriptor

Parameters

xmlElement
Type: System.XmlXmlElement
The authentication authority descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthnAuthorityDescriptor Class
AuthnAuthorityDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor Properties

The AuthnAuthorityDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | AssertionIDRequestServices | Gets or sets the list of assertion ID request services.
Public property | AuthnQueryServices | Gets or sets the list of authentication query services.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | NameIDFormats | Gets or sets the list of name ID formats.
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

AuthnAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor.AssertionIDRequestServices Property

AuthnAuthorityDescriptorAssertionIDRequestServices Property

Gets or sets the list of assertion ID request services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> AssertionIDRequestServices { get; set; }
Public Property AssertionIDRequestServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ AssertionIDRequestServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member AssertionIDRequestServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of assertion ID request services.
See Also

Reference

AuthnAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor.AuthnQueryServices Property

AuthnAuthorityDescriptorAuthnQueryServices Property

Gets or sets the list of authentication query services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> AuthnQueryServices { get; set; }
Public Property AuthnQueryServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ AuthnQueryServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member AuthnQueryServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of authentication query services.
See Also

Reference

AuthnAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor.NameIDFormats Property

AuthnAuthorityDescriptorNameIDFormats Property

Gets or sets the list of name ID formats.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<string> NameIDFormats { get; set; }
Public Property NameIDFormats As IList(Of String)
    Get
    Set
public:
property IList<String^>^ NameIDFormats {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member NameIDFormats : IList<string> with get, set

Property Value

Type: IList String
The list of name ID formats.
See Also

Reference

AuthnAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor Methods

The AuthnAuthorityDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication authority descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the authentication authority descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

AuthnAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor.IsValid Method

AuthnAuthorityDescriptorIsValid Method

Indicates whether the XML is an authentication authority descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an authentication authority descriptor; otherwise false.
See Also

Reference

AuthnAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor.ToXml Method

AuthnAuthorityDescriptorToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlDocument) | Serializes the authentication authority descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

AuthnAuthorityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


AuthnAuthorityDescriptor.ToXml Method (XmlDocument)

AuthnAuthorityDescriptorToXml Method (XmlDocument)

Serializes the authentication authority descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authentication authority descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthnAuthorityDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


ContactPerson Class

Represents a contact person.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataContactType
ComponentSpace.SAML2.MetadataContactPerson

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class ContactPerson : ContactType
Public Class ContactPerson
    Inherits ContactType
public ref class ContactPerson : public ContactType
type ContactPerson =
    class
        inherit ContactType
    end

The ContactPerson type exposes the following members.

Constructors
 | Name | Description
Public method | ContactPerson | Initializes a new instance of the ContactPerson class.
Public method | ContactPerson(XmlElement) | Initializes a new instance of the ContactPerson class from XML.
Top
Properties
 | Name | Description
Public property | Company | Gets or sets the company name. (Inherited from ContactType.)
Public property | ContactTypeValue | Gets or sets the contact type. (Inherited from ContactType.)
Public property | EmailAddresses | Gets or sets the list of email addresses. (Inherited from ContactType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from ContactType.)
Public property | GivenName | Gets or sets the given name. (Inherited from ContactType.)
Public property | Surname | Gets or sets the surname. (Inherited from ContactType.)
Public property | TelephoneNumbers | Gets or sets the list of telephone numbers. (Inherited from ContactType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a contact person.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the contact person to XML.
Public method | ToXml(XmlElement) | Serializes the contact type to XML. (Inherited from ContactType.)
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


ContactPerson Constructor

Overload List
 | Name | Description
Public method | ContactPerson | Initializes a new instance of the ContactPerson class.
Public method | ContactPerson(XmlElement) | Initializes a new instance of the ContactPerson class from XML.
Top
See Also

Reference

ContactPerson Class
ComponentSpace.SAML2.Metadata Namespace


ContactPerson Constructor

Initializes a new instance of the ContactPerson class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ContactPerson()
Public Sub New
public:
ContactPerson()
new : unit -> ContactPerson
See Also

Reference

ContactPerson Class
ContactPerson Overload
ComponentSpace.SAML2.Metadata Namespace


ContactPerson Constructor (XmlElement)

Initializes a new instance of the ContactPerson class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ContactPerson(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
ContactPerson(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> ContactPerson

Parameters

xmlElement
Type: System.XmlXmlElement
The contact person XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

ContactPerson Class
ContactPerson Overload
ComponentSpace.SAML2.Metadata Namespace


ContactPerson Properties

The ContactPerson type exposes the following members.

Properties
 | Name | Description
Public property | Company | Gets or sets the company name. (Inherited from ContactType.)
Public property | ContactTypeValue | Gets or sets the contact type. (Inherited from ContactType.)
Public property | EmailAddresses | Gets or sets the list of email addresses. (Inherited from ContactType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from ContactType.)
Public property | GivenName | Gets or sets the given name. (Inherited from ContactType.)
Public property | Surname | Gets or sets the surname. (Inherited from ContactType.)
Public property | TelephoneNumbers | Gets or sets the list of telephone numbers. (Inherited from ContactType.)
Top
See Also

Reference

ContactPerson Class
ComponentSpace.SAML2.Metadata Namespace


ContactPerson Methods

The ContactPerson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a contact person.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the contact person to XML.
Public method | ToXml(XmlElement) | Serializes the contact type to XML. (Inherited from ContactType.)
Top
See Also

Reference

ContactPerson Class
ComponentSpace.SAML2.Metadata Namespace


ContactPerson.IsValid Method

ContactPersonIsValid Method

Indicates whether the XML is a contact person.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a contact person; otherwise false.
See Also

Reference

ContactPerson Class
ComponentSpace.SAML2.Metadata Namespace


ContactPerson.ToXml Method

ContactPersonToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlDocument) | Serializes the contact person to XML.
Public method | ToXml(XmlElement) | Serializes the contact type to XML. (Inherited from ContactType.)
Top
See Also

Reference

ContactPerson Class
ComponentSpace.SAML2.Metadata Namespace


ContactPerson.ToXml Method (XmlDocument)

ContactPersonToXml Method (XmlDocument)

Serializes the contact person to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The contact person as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

ContactPerson Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


ContactType Class

Represents the contact type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataContactType
ComponentSpace.SAML2.MetadataContactPerson

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class ContactType
Public Class ContactType
public ref class ContactType
type ContactType =  class end

The ContactType type exposes the following members.

Constructors
 | Name | Description
Public method | ContactType | Initializes a new instance of the ContactType class.
Public method | ContactType(XmlElement) | Initializes a new instance of the ContactType class from XML.
Top
Properties
 | Name | Description
Public property | Company | Gets or sets the company name.
Public property | ContactTypeValue | Gets or sets the contact type.
Public property | EmailAddresses | Gets or sets the list of email addresses.
Public property | Extensions | Gets or sets the extensions.
Public property | GivenName | Gets or sets the given name.
Public property | Surname | Gets or sets the surname.
Public property | TelephoneNumbers | Gets or sets the list of telephone numbers.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the contact type to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


ContactType Constructor

Overload List
 | Name | Description
Public method | ContactType | Initializes a new instance of the ContactType class.
Public method | ContactType(XmlElement) | Initializes a new instance of the ContactType class from XML.
Top
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace


ContactType Constructor

Initializes a new instance of the ContactType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ContactType()
Public Sub New
public:
ContactType()
new : unit -> ContactType
See Also

Reference

ContactType Class
ContactType Overload
ComponentSpace.SAML2.Metadata Namespace


ContactType Constructor (XmlElement)

Initializes a new instance of the ContactType class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ContactType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
ContactType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> ContactType

Parameters

xmlElement
Type: System.XmlXmlElement
The contact type XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

ContactType Class
ContactType Overload
ComponentSpace.SAML2.Metadata Namespace


ContactType Properties

The ContactType type exposes the following members.

Properties
 | Name | Description
Public property | Company | Gets or sets the company name.
Public property | ContactTypeValue | Gets or sets the contact type.
Public property | EmailAddresses | Gets or sets the list of email addresses.
Public property | Extensions | Gets or sets the extensions.
Public property | GivenName | Gets or sets the given name.
Public property | Surname | Gets or sets the surname.
Public property | TelephoneNumbers | Gets or sets the list of telephone numbers.
Top
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.Company Property

ContactTypeCompany Property

Gets or sets the company name.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Company { get; set; }
Public Property Company As String
    Get
    Set
public:
property String^ Company {
    String^ get ();
    void set (String^ value);
}
member Company : string with get, set

Property Value

Type: String
The company name.
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.ContactTypeValue Property

ContactTypeContactTypeValue Property

Gets or sets the contact type.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ContactTypeValue { get; set; }
Public Property ContactTypeValue As String
    Get
    Set
public:
property String^ ContactTypeValue {
    String^ get ();
    void set (String^ value);
}
member ContactTypeValue : string with get, set

Property Value

Type: String
The contact type.
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace
ContactTypeContactTypeValue


ContactType.EmailAddresses Property

ContactTypeEmailAddresses Property

Gets or sets the list of email addresses.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<string> EmailAddresses { get; set; }
Public Property EmailAddresses As IList(Of String)
    Get
    Set
public:
property IList<String^>^ EmailAddresses {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member EmailAddresses : IList<string> with get, set

Property Value

Type: IList String
The list of email addresses.
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.Extensions Property

ContactTypeExtensions Property

Gets or sets the extensions.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions Extensions { get; set; }
Public Property Extensions As Extensions
    Get
    Set
public:
property Extensions^ Extensions {
    Extensions^ get ();
    void set (Extensions^ value);
}
member Extensions : Extensions with get, set

Property Value

Type: Extensions
The extensions.
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.GivenName Property

ContactTypeGivenName Property

Gets or sets the given name.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string GivenName { get; set; }
Public Property GivenName As String
    Get
    Set
public:
property String^ GivenName {
    String^ get ();
    void set (String^ value);
}
member GivenName : string with get, set

Property Value

Type: String
The company name.
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.Surname Property

ContactTypeSurname Property

Gets or sets the surname.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Surname { get; set; }
Public Property Surname As String
    Get
    Set
public:
property String^ Surname {
    String^ get ();
    void set (String^ value);
}
member Surname : string with get, set

Property Value

Type: String
The surname.
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.TelephoneNumbers Property

ContactTypeTelephoneNumbers Property

Gets or sets the list of telephone numbers.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<string> TelephoneNumbers { get; set; }
Public Property TelephoneNumbers As IList(Of String)
    Get
    Set
public:
property IList<String^>^ TelephoneNumbers {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member TelephoneNumbers : IList<string> with get, set

Property Value

Type: IList String
The list of telephone numbers.
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace


ContactType Methods

The ContactType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the contact type to XML.
Top
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.ToXml Method

ContactTypeToXml Method

Serializes the contact type to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void ToXml(
    XmlElement xmlElement
)
Public Sub ToXml (
    xmlElement As XmlElement
)
public:
void ToXml(
    XmlElement^ xmlElement
)
member ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

ContactType Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.ContactTypeValues Class

ContactTypeContactTypeValues Class

The contact types.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataContactTypeContactTypeValues

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class ContactTypeValues
Public NotInheritable Class ContactTypeValues
public ref class ContactTypeValues abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ContactTypeValues =  class end

The ContactTypeContactTypeValues type exposes the following members.

Fields
Name | Description
Administrative | Administrative.
Billing | Billing.
Other | Other.
Support | Support.
Technical | Technical.
Top
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


ContactTypeValues Fields

The ContactTypeContactTypeValues type exposes the following members.

Fields
Name | Description
Administrative | Administrative.
Billing | Billing.
Other | Other.
Support | Support.
Technical | Technical.
Top
See Also

Reference

ContactTypeContactTypeValues Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.ContactTypeValues.Administrative Field

ContactTypeContactTypeValuesAdministrative Field

Administrative.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Administrative = "administrative"
Public Const Administrative As String = "administrative"
public:
literal String^ Administrative = "administrative"
static val mutable Administrative: string

Field Value

Type: String
See Also

Reference

ContactTypeContactTypeValues Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.ContactTypeValues.Billing Field

ContactTypeContactTypeValuesBilling Field

Billing.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Billing = "billing"
Public Const Billing As String = "billing"
public:
literal String^ Billing = "billing"
static val mutable Billing: string

Field Value

Type: String
See Also

Reference

ContactTypeContactTypeValues Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.ContactTypeValues.Other Field

ContactTypeContactTypeValuesOther Field

Other.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Other = "other"
Public Const Other As String = "other"
public:
literal String^ Other = "other"
static val mutable Other: string

Field Value

Type: String
See Also

Reference

ContactTypeContactTypeValues Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.ContactTypeValues.Support Field

ContactTypeContactTypeValuesSupport Field

Support.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Support = "support"
Public Const Support As String = "support"
public:
literal String^ Support = "support"
static val mutable Support: string

Field Value

Type: String
See Also

Reference

ContactTypeContactTypeValues Class
ComponentSpace.SAML2.Metadata Namespace


ContactType.ContactTypeValues.Technical Field

ContactTypeContactTypeValuesTechnical Field

Technical.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Technical = "technical"
Public Const Technical As String = "technical"
public:
literal String^ Technical = "technical"
static val mutable Technical: string

Field Value

Type: String
See Also

Reference

ContactTypeContactTypeValues Class
ComponentSpace.SAML2.Metadata Namespace


Duration Class

Represents the XML schema duration type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataDuration

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Duration
Public Class Duration
public ref class Duration
type Duration =  class end

The Duration type exposes the following members.

Constructors
 | Name | Description
Public method | Duration | Initializes a new instance of the Duration class.
Public method | Duration(String) | Initializes a new instance of the Duration class.
Public method | Duration(Boolean, Int32, Int32, Int32, Int32, Int32, Decimal) | Initializes a new instance of the Duration class.
Top
Properties
 | Name | Description
Public property | Days | Gets or sets the number of days.
Public property | Hours | Gets or sets the number of hours.
Public property | Minutes | Gets or sets the number of minutes.
Public property | Months | Gets or sets the number of months.
Public property | Negative | Gets or sets the negative duration flag.
Public property | Seconds | Gets or sets the number of seconds.
Public property | Years | Gets or sets the number of years.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the duration. (Overrides ObjectToString.)
Top
Remarks
Refer to the XML Schema specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


Duration Constructor

Overload List
 | Name | Description
Public method | Duration | Initializes a new instance of the Duration class.
Public method | Duration(String) | Initializes a new instance of the Duration class.
Public method | Duration(Boolean, Int32, Int32, Int32, Int32, Int32, Decimal) | Initializes a new instance of the Duration class.
Top
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


Duration Constructor

Initializes a new instance of the Duration class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Duration()
Public Sub New
public:
Duration()
new : unit -> Duration
See Also

Reference

Duration Class
Duration Overload
ComponentSpace.SAML2.Metadata Namespace


Duration Constructor (String)

Initializes a new instance of the Duration class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Duration(
    string duration
)
Public Sub New (
    duration As String
)
public:
Duration(
    String^ duration
)
new :
        duration : string -> Duration

Parameters

duration
Type: SystemString
The duration as a string.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the string format is invalid.
Remarks
The format of the string is: [-]PnYnMnDTnHnMnS.
See Also

Reference

Duration Class
Duration Overload
ComponentSpace.SAML2.Metadata Namespace


Duration Constructor (Boolean, Int32, Int32, Int32, Int32, Int32, Decimal)

Initializes a new instance of the Duration class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Duration(
    bool negative,
    int years,
    int months,
    int days,
    int hours,
    int minutes,
    decimal seconds
)
Public Sub New (
    negative As Boolean,
    years As Integer,
    months As Integer,
    days As Integer,
    hours As Integer,
    minutes As Integer,
    seconds As Decimal
)
public:
Duration(
    bool negative,
    int years,
    int months,
    int days,
    int hours,
    int minutes,
    Decimal seconds
)
new :
        negative : bool *
        years : int *
        months : int *
        days : int *
        hours : int *
        minutes : int *
        seconds : decimal -> Duration

Parameters

negative
Type: SystemBoolean
true if the duration is negative; otherwise false.
years
Type: SystemInt32
The number of years.
months
Type: SystemInt32
The number of months.
days
Type: SystemInt32
The number of days.
hours
Type: SystemInt32
The number of hours.
minutes
Type: SystemInt32
The number of minutes.
seconds
Type: SystemDecimal
The number of seconds.
See Also

Reference

Duration Class
Duration Overload
ComponentSpace.SAML2.Metadata Namespace


Duration Properties

The Duration type exposes the following members.

Properties
 | Name | Description
Public property | Days | Gets or sets the number of days.
Public property | Hours | Gets or sets the number of hours.
Public property | Minutes | Gets or sets the number of minutes.
Public property | Months | Gets or sets the number of months.
Public property | Negative | Gets or sets the negative duration flag.
Public property | Seconds | Gets or sets the number of seconds.
Public property | Years | Gets or sets the number of years.
Top
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


Duration.Days Property

DurationDays Property

Gets or sets the number of days.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int Days { get; set; }
Public Property Days As Integer
    Get
    Set
public:
property int Days {
    int get ();
    void set (int value);
}
member Days : int with get, set

Property Value

Type: Int32
The number of days.
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


Duration.Hours Property

DurationHours Property

Gets or sets the number of hours.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int Hours { get; set; }
Public Property Hours As Integer
    Get
    Set
public:
property int Hours {
    int get ();
    void set (int value);
}
member Hours : int with get, set

Property Value

Type: Int32
The number of hours.
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


Duration.Minutes Property

DurationMinutes Property

Gets or sets the number of minutes.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int Minutes { get; set; }
Public Property Minutes As Integer
    Get
    Set
public:
property int Minutes {
    int get ();
    void set (int value);
}
member Minutes : int with get, set

Property Value

Type: Int32
The number of minutes.
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


Duration.Months Property

DurationMonths Property

Gets or sets the number of months.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int Months { get; set; }
Public Property Months As Integer
    Get
    Set
public:
property int Months {
    int get ();
    void set (int value);
}
member Months : int with get, set

Property Value

Type: Int32
The number of months.
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


Duration.Negative Property

DurationNegative Property

Gets or sets the negative duration flag.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool Negative { get; set; }
Public Property Negative As Boolean
    Get
    Set
public:
property bool Negative {
    bool get ();
    void set (bool value);
}
member Negative : bool with get, set

Property Value

Type: Boolean
The negative duration flag.
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


Duration.Seconds Property

DurationSeconds Property

Gets or sets the number of seconds.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public decimal Seconds { get; set; }
Public Property Seconds As Decimal
    Get
    Set
public:
property Decimal Seconds {
    Decimal get ();
    void set (Decimal value);
}
member Seconds : decimal with get, set

Property Value

Type: Decimal
The number of seconds.
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


Duration.Years Property

DurationYears Property

Gets or sets the number of years.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int Years { get; set; }
Public Property Years As Integer
    Get
    Set
public:
property int Years {
    int get ();
    void set (int value);
}
member Years : int with get, set

Property Value

Type: Int32
The number of years.
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


Duration Methods

The Duration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the duration. (Overrides ObjectToString.)
Top
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


Duration.ToString Method

DurationToString Method

Returns a string that represents the duration.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A string that represents the duration.
Remarks
The format of the string is: [-]PnYnMnDTnHnMnS.
See Also

Reference

Duration Class
ComponentSpace.SAML2.Metadata Namespace


EndpointType Class

Represents the endpoint type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataEndpointType
ComponentSpace.SAML2.MetadataIndexedEndpointType

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class EndpointType
Public Class EndpointType
public ref class EndpointType
type EndpointType =  class end

The EndpointType type exposes the following members.

Constructors
 | Name | Description
Public method | EndpointType | Initializes a new instance of the EndpointType class.
Public method | EndpointType(XmlElement) | Initializes a new instance of the EndpointType class from XML.
Public method | EndpointType(String, String, String) | Initializes a new instance of the EndpointType class.
Top
Properties
 | Name | Description
Public property | Binding | Gets or sets the binding.
Public property | Location | Gets or sets the location.
Public property | ResponseLocation | Gets or sets the response location.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the endpoint to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


EndpointType Constructor

Overload List
 | Name | Description
Public method | EndpointType | Initializes a new instance of the EndpointType class.
Public method | EndpointType(XmlElement) | Initializes a new instance of the EndpointType class from XML.
Public method | EndpointType(String, String, String) | Initializes a new instance of the EndpointType class.
Top
See Also

Reference

EndpointType Class
ComponentSpace.SAML2.Metadata Namespace


EndpointType Constructor

Initializes a new instance of the EndpointType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EndpointType()
Public Sub New
public:
EndpointType()
new : unit -> EndpointType
See Also

Reference

EndpointType Class
EndpointType Overload
ComponentSpace.SAML2.Metadata Namespace


EndpointType Constructor (XmlElement)

Initializes a new instance of the EndpointType class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EndpointType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
EndpointType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> EndpointType

Parameters

xmlElement
Type: System.XmlXmlElement
The endpoint XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

EndpointType Class
EndpointType Overload
ComponentSpace.SAML2.Metadata Namespace


EndpointType Constructor (String, String, String)

Initializes a new instance of the EndpointType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EndpointType(
    string binding,
    string location,
    string responseLocation
)
Public Sub New (
    binding As String,
    location As String,
    responseLocation As String
)
public:
EndpointType(
    String^ binding,
    String^ location,
    String^ responseLocation
)
new :
        binding : string *
        location : string *
        responseLocation : string -> EndpointType

Parameters

binding
Type: SystemString
The binding.
location
Type: SystemString
The location.
responseLocation
Type: SystemString
The response location.
See Also

Reference

EndpointType Class
EndpointType Overload
ComponentSpace.SAML2.Metadata Namespace


EndpointType Properties

The EndpointType type exposes the following members.

Properties
 | Name | Description
Public property | Binding | Gets or sets the binding.
Public property | Location | Gets or sets the location.
Public property | ResponseLocation | Gets or sets the response location.
Top
See Also

Reference

EndpointType Class
ComponentSpace.SAML2.Metadata Namespace


EndpointType.Binding Property

EndpointTypeBinding Property

Gets or sets the binding.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Binding { get; set; }
Public Property Binding As String
    Get
    Set
public:
property String^ Binding {
    String^ get ();
    void set (String^ value);
}
member Binding : string with get, set

Property Value

Type: String
The binding.
See Also

Reference

EndpointType Class
ComponentSpace.SAML2.Metadata Namespace


EndpointType.Location Property

EndpointTypeLocation Property

Gets or sets the location.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
The location.
See Also

Reference

EndpointType Class
ComponentSpace.SAML2.Metadata Namespace


EndpointType.ResponseLocation Property

EndpointTypeResponseLocation Property

Gets or sets the response location.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ResponseLocation { get; set; }
Public Property ResponseLocation As String
    Get
    Set
public:
property String^ ResponseLocation {
    String^ get ();
    void set (String^ value);
}
member ResponseLocation : string with get, set

Property Value

Type: String
The response location.
See Also

Reference

EndpointType Class
ComponentSpace.SAML2.Metadata Namespace


EndpointType Methods

The EndpointType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the endpoint to XML.
Top
See Also

Reference

EndpointType Class
ComponentSpace.SAML2.Metadata Namespace


EndpointType.ToXml Method

EndpointTypeToXml Method

Serializes the endpoint to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void ToXml(
    XmlElement xmlElement
)
Public Overridable Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
)
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

EndpointType Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor Class

Represents an entities descriptor.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataEntitiesDescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class EntitiesDescriptor
Public Class EntitiesDescriptor
public ref class EntitiesDescriptor
type EntitiesDescriptor =  class end

The EntitiesDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | EntitiesDescriptor | Initializes a new instance of the EntitiesDescriptor class.
Public method | EntitiesDescriptor(XmlElement) | Initializes a new instance of the EntitiesDescriptor class from XML.
Top
Properties
 | Name | Description
Public property | CacheDuration | Gets or sets the cache duration.
Public property | EntitiesDescriptors | Gets or sets the list of entities descriptors.
Public property | EntityDescriptors | Gets or sets the list of entity descriptors.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | Name | Gets or sets the name.
Public property | Signature | Gets or sets the digital signature.
Public property | ValidUntil | Gets or sets the valid until date/time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntityDescriptor | Gets the entity descriptor identified by the entity ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an entities descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the entities descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the entities descriptor to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor Constructor

Overload List
 | Name | Description
Public method | EntitiesDescriptor | Initializes a new instance of the EntitiesDescriptor class.
Public method | EntitiesDescriptor(XmlElement) | Initializes a new instance of the EntitiesDescriptor class from XML.
Top
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor Constructor

Initializes a new instance of the EntitiesDescriptor class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EntitiesDescriptor()
Public Sub New
public:
EntitiesDescriptor()
new : unit -> EntitiesDescriptor
See Also

Reference

EntitiesDescriptor Class
EntitiesDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor Constructor (XmlElement)

Initializes a new instance of the EntitiesDescriptor class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EntitiesDescriptor(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
EntitiesDescriptor(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> EntitiesDescriptor

Parameters

xmlElement
Type: System.XmlXmlElement
The entities descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

EntitiesDescriptor Class
EntitiesDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor Properties

The EntitiesDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | CacheDuration | Gets or sets the cache duration.
Public property | EntitiesDescriptors | Gets or sets the list of entities descriptors.
Public property | EntityDescriptors | Gets or sets the list of entity descriptors.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | Name | Gets or sets the name.
Public property | Signature | Gets or sets the digital signature.
Public property | ValidUntil | Gets or sets the valid until date/time.
Top
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.CacheDuration Property

EntitiesDescriptorCacheDuration Property

Gets or sets the cache duration.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Duration CacheDuration { get; set; }
Public Property CacheDuration As Duration
    Get
    Set
public:
property Duration^ CacheDuration {
    Duration^ get ();
    void set (Duration^ value);
}
member CacheDuration : Duration with get, set

Property Value

Type: Duration
The cache duration.
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.EntitiesDescriptors Property

EntitiesDescriptorEntitiesDescriptors Property

Gets or sets the list of entities descriptors.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EntitiesDescriptor> EntitiesDescriptors { get; set; }
Public Property EntitiesDescriptors As IList(Of EntitiesDescriptor)
    Get
    Set
public:
property IList<EntitiesDescriptor^>^ EntitiesDescriptors {
    IList<EntitiesDescriptor^>^ get ();
    void set (IList<EntitiesDescriptor^>^ value);
}
member EntitiesDescriptors : IList<EntitiesDescriptor> with get, set

Property Value

Type: IList EntitiesDescriptor
The list of entities descriptors.
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.EntityDescriptors Property

EntitiesDescriptorEntityDescriptors Property

Gets or sets the list of entity descriptors.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EntityDescriptor> EntityDescriptors { get; set; }
Public Property EntityDescriptors As IList(Of EntityDescriptor)
    Get
    Set
public:
property IList<EntityDescriptor^>^ EntityDescriptors {
    IList<EntityDescriptor^>^ get ();
    void set (IList<EntityDescriptor^>^ value);
}
member EntityDescriptors : IList<EntityDescriptor> with get, set

Property Value

Type: IList EntityDescriptor
The list of entity descriptors.
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.Extensions Property

EntitiesDescriptorExtensions Property

Gets or sets the extensions.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions Extensions { get; set; }
Public Property Extensions As Extensions
    Get
    Set
public:
property Extensions^ Extensions {
    Extensions^ get ();
    void set (Extensions^ value);
}
member Extensions : Extensions with get, set

Property Value

Type: Extensions
The extensions.
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.ID Property

EntitiesDescriptorID Property

Gets or sets the ID.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
The ID.
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.Name Property

EntitiesDescriptorName Property

Gets or sets the name.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.Signature Property

EntitiesDescriptorSignature Property

Gets or sets the digital signature.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement Signature { get; set; }
Public Property Signature As XmlElement
    Get
    Set
public:
property XmlElement^ Signature {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member Signature : XmlElement with get, set

Property Value

Type: XmlElement
The digital signature.
Remarks
To generate or verify signatures, use SAMLMetadataSignature.
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace
ComponentSpace.SAML2.MetadataSAMLMetadataSignature


EntitiesDescriptor.ValidUntil Property

EntitiesDescriptorValidUntil Property

Gets or sets the valid until date/time.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime ValidUntil { get; set; }
Public Property ValidUntil As DateTime
    Get
    Set
public:
property DateTime ValidUntil {
    DateTime get ();
    void set (DateTime value);
}
member ValidUntil : DateTime with get, set

Property Value

Type: DateTime
The valid until date/time.
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor Methods

The EntitiesDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntityDescriptor | Gets the entity descriptor identified by the entity ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an entities descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the entities descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the entities descriptor to XML.
Top
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.GetEntityDescriptor Method

EntitiesDescriptorGetEntityDescriptor Method

Gets the entity descriptor identified by the entity ID.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EntityDescriptor GetEntityDescriptor(
    string entityID
)
Public Function GetEntityDescriptor (
    entityID As String
) As EntityDescriptor
public:
EntityDescriptor^ GetEntityDescriptor(
    String^ entityID
)
member GetEntityDescriptor :
        entityID : string -> EntityDescriptor

Parameters

entityID
Type: SystemString
The entity ID of the entity descriptor.

Return Value

Type: EntityDescriptor
The entity descriptor of null if none.
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.IsValid Method

EntitiesDescriptorIsValid Method

Indicates whether the XML is an entities descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an entities descriptor; otherwise false.
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.ToXml Method

EntitiesDescriptorToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the entities descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the entities descriptor to XML.
Top
See Also

Reference

EntitiesDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.ToXml Method

EntitiesDescriptorToXml Method

Serializes the entities descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The entities descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

EntitiesDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


EntitiesDescriptor.ToXml Method (XmlDocument)

EntitiesDescriptorToXml Method (XmlDocument)

Serializes the entities descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The entities descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

EntitiesDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor Class

Represents an entity descriptor.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataEntityDescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class EntityDescriptor
Public Class EntityDescriptor
public ref class EntityDescriptor
type EntityDescriptor =  class end

The EntityDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | EntityDescriptor | Initializes a new instance of the EntityDescriptor class.
Public method | EntityDescriptor(XmlElement) | Initializes a new instance of the EntityDescriptor class from XML.
Top
Properties
 | Name | Description
Public property | AdditionalMetadataLocations | Gets or sets the list of additional metadata locations.
Public property | AffiliationDescriptor | Gets or sets the affiliation descriptor.
Public property | AttributeAuthorityDescriptors | Gets or sets the list of attribute authority descriptors.
Public property | AuthnAuthorityDescriptors | Gets or sets the list of authentication authority descriptors.
Public property | CacheDuration | Gets or sets the cache duration.
Public property | ContactPeople | Gets or sets the list of contact people.
Public property | EntityID | Gets or sets the entity ID.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | IDPSSODescriptors | Gets or sets the list of IdP SSO descriptors.
Public property | Organization | Gets or sets the organization.
Public property | PDPDescriptors | Gets or sets the list of PDP descriptors.
Public property | RoleDescriptors | Gets or sets the list of role descriptors.
Public property | Signature | Gets or sets the digital signature.
Public property | SPSSODescriptors | Gets or sets the list of SP SSO descriptors.
Public property | ValidUntil | Gets or sets the valid until date/time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an entity descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the entities descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the entity descriptor to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor Constructor

Overload List
 | Name | Description
Public method | EntityDescriptor | Initializes a new instance of the EntityDescriptor class.
Public method | EntityDescriptor(XmlElement) | Initializes a new instance of the EntityDescriptor class from XML.
Top
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor Constructor

Initializes a new instance of the EntityDescriptor class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EntityDescriptor()
Public Sub New
public:
EntityDescriptor()
new : unit -> EntityDescriptor
See Also

Reference

EntityDescriptor Class
EntityDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor Constructor (XmlElement)

Initializes a new instance of the EntityDescriptor class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EntityDescriptor(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
EntityDescriptor(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> EntityDescriptor

Parameters

xmlElement
Type: System.XmlXmlElement
The entity descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

EntityDescriptor Class
EntityDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor Properties

The EntityDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalMetadataLocations | Gets or sets the list of additional metadata locations.
Public property | AffiliationDescriptor | Gets or sets the affiliation descriptor.
Public property | AttributeAuthorityDescriptors | Gets or sets the list of attribute authority descriptors.
Public property | AuthnAuthorityDescriptors | Gets or sets the list of authentication authority descriptors.
Public property | CacheDuration | Gets or sets the cache duration.
Public property | ContactPeople | Gets or sets the list of contact people.
Public property | EntityID | Gets or sets the entity ID.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | IDPSSODescriptors | Gets or sets the list of IdP SSO descriptors.
Public property | Organization | Gets or sets the organization.
Public property | PDPDescriptors | Gets or sets the list of PDP descriptors.
Public property | RoleDescriptors | Gets or sets the list of role descriptors.
Public property | Signature | Gets or sets the digital signature.
Public property | SPSSODescriptors | Gets or sets the list of SP SSO descriptors.
Public property | ValidUntil | Gets or sets the valid until date/time.
Top
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.AdditionalMetadataLocations Property

EntityDescriptorAdditionalMetadataLocations Property

Gets or sets the list of additional metadata locations.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<AdditionalMetadataLocation> AdditionalMetadataLocations { get; set; }
Public Property AdditionalMetadataLocations As IList(Of AdditionalMetadataLocation)
    Get
    Set
public:
property IList<AdditionalMetadataLocation^>^ AdditionalMetadataLocations {
    IList<AdditionalMetadataLocation^>^ get ();
    void set (IList<AdditionalMetadataLocation^>^ value);
}
member AdditionalMetadataLocations : IList<AdditionalMetadataLocation> with get, set

Property Value

Type: IList AdditionalMetadataLocation
The list of additional metadata locations.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.AffiliationDescriptor Property

EntityDescriptorAffiliationDescriptor Property

Gets or sets the affiliation descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AffiliationDescriptor AffiliationDescriptor { get; set; }
Public Property AffiliationDescriptor As AffiliationDescriptor
    Get
    Set
public:
property AffiliationDescriptor^ AffiliationDescriptor {
    AffiliationDescriptor^ get ();
    void set (AffiliationDescriptor^ value);
}
member AffiliationDescriptor : AffiliationDescriptor with get, set

Property Value

Type: AffiliationDescriptor
The affiliation descriptor.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.AttributeAuthorityDescriptors Property

EntityDescriptorAttributeAuthorityDescriptors Property

Gets or sets the list of attribute authority descriptors.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<AttributeAuthorityDescriptor> AttributeAuthorityDescriptors { get; set; }
Public Property AttributeAuthorityDescriptors As IList(Of AttributeAuthorityDescriptor)
    Get
    Set
public:
property IList<AttributeAuthorityDescriptor^>^ AttributeAuthorityDescriptors {
    IList<AttributeAuthorityDescriptor^>^ get ();
    void set (IList<AttributeAuthorityDescriptor^>^ value);
}
member AttributeAuthorityDescriptors : IList<AttributeAuthorityDescriptor> with get, set

Property Value

Type: IList AttributeAuthorityDescriptor
The list of attribute authority descriptors.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.AuthnAuthorityDescriptors Property

EntityDescriptorAuthnAuthorityDescriptors Property

Gets or sets the list of authentication authority descriptors.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<AuthnAuthorityDescriptor> AuthnAuthorityDescriptors { get; set; }
Public Property AuthnAuthorityDescriptors As IList(Of AuthnAuthorityDescriptor)
    Get
    Set
public:
property IList<AuthnAuthorityDescriptor^>^ AuthnAuthorityDescriptors {
    IList<AuthnAuthorityDescriptor^>^ get ();
    void set (IList<AuthnAuthorityDescriptor^>^ value);
}
member AuthnAuthorityDescriptors : IList<AuthnAuthorityDescriptor> with get, set

Property Value

Type: IList AuthnAuthorityDescriptor
The list of authentication authority descriptors.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.CacheDuration Property

EntityDescriptorCacheDuration Property

Gets or sets the cache duration.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Duration CacheDuration { get; set; }
Public Property CacheDuration As Duration
    Get
    Set
public:
property Duration^ CacheDuration {
    Duration^ get ();
    void set (Duration^ value);
}
member CacheDuration : Duration with get, set

Property Value

Type: Duration
The cache duration.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.ContactPeople Property

EntityDescriptorContactPeople Property

Gets or sets the list of contact people.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<ContactPerson> ContactPeople { get; set; }
Public Property ContactPeople As IList(Of ContactPerson)
    Get
    Set
public:
property IList<ContactPerson^>^ ContactPeople {
    IList<ContactPerson^>^ get ();
    void set (IList<ContactPerson^>^ value);
}
member ContactPeople : IList<ContactPerson> with get, set

Property Value

Type: IList ContactPerson
The list of contact people.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.EntityID Property

EntityDescriptorEntityID Property

Gets or sets the entity ID.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EntityIDType EntityID { get; set; }
Public Property EntityID As EntityIDType
    Get
    Set
public:
property EntityIDType^ EntityID {
    EntityIDType^ get ();
    void set (EntityIDType^ value);
}
member EntityID : EntityIDType with get, set

Property Value

Type: EntityIDType
The entity ID.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.Extensions Property

EntityDescriptorExtensions Property

Gets or sets the extensions.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions Extensions { get; set; }
Public Property Extensions As Extensions
    Get
    Set
public:
property Extensions^ Extensions {
    Extensions^ get ();
    void set (Extensions^ value);
}
member Extensions : Extensions with get, set

Property Value

Type: Extensions
The extensions.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.ID Property

EntityDescriptorID Property

Gets or sets the ID.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
The ID.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.IDPSSODescriptors Property

EntityDescriptorIDPSSODescriptors Property

Gets or sets the list of IdP SSO descriptors.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<IDPSSODescriptor> IDPSSODescriptors { get; set; }
Public Property IDPSSODescriptors As IList(Of IDPSSODescriptor)
    Get
    Set
public:
property IList<IDPSSODescriptor^>^ IDPSSODescriptors {
    IList<IDPSSODescriptor^>^ get ();
    void set (IList<IDPSSODescriptor^>^ value);
}
member IDPSSODescriptors : IList<IDPSSODescriptor> with get, set

Property Value

Type: IList IDPSSODescriptor
The list of IdP SSO descriptors.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.Organization Property

EntityDescriptorOrganization Property

Gets or sets the organization.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Organization Organization { get; set; }
Public Property Organization As Organization
    Get
    Set
public:
property Organization^ Organization {
    Organization^ get ();
    void set (Organization^ value);
}
member Organization : Organization with get, set

Property Value

Type: Organization
The organization.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.PDPDescriptors Property

EntityDescriptorPDPDescriptors Property

Gets or sets the list of PDP descriptors.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<PDPDescriptor> PDPDescriptors { get; set; }
Public Property PDPDescriptors As IList(Of PDPDescriptor)
    Get
    Set
public:
property IList<PDPDescriptor^>^ PDPDescriptors {
    IList<PDPDescriptor^>^ get ();
    void set (IList<PDPDescriptor^>^ value);
}
member PDPDescriptors : IList<PDPDescriptor> with get, set

Property Value

Type: IList PDPDescriptor
The list of PDP descriptors.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.RoleDescriptors Property

EntityDescriptorRoleDescriptors Property

Gets or sets the list of role descriptors.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<RoleDescriptor> RoleDescriptors { get; set; }
Public Property RoleDescriptors As IList(Of RoleDescriptor)
    Get
    Set
public:
property IList<RoleDescriptor^>^ RoleDescriptors {
    IList<RoleDescriptor^>^ get ();
    void set (IList<RoleDescriptor^>^ value);
}
member RoleDescriptors : IList<RoleDescriptor> with get, set

Property Value

Type: IList RoleDescriptor
The list of role descriptors.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.Signature Property

EntityDescriptorSignature Property

Gets or sets the digital signature.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement Signature { get; set; }
Public Property Signature As XmlElement
    Get
    Set
public:
property XmlElement^ Signature {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member Signature : XmlElement with get, set

Property Value

Type: XmlElement
The digital signature.
Remarks
To generate or verify signatures, use SAMLMetadataSignature.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace
ComponentSpace.SAML2.MetadataSAMLMetadataSignature


EntityDescriptor.SPSSODescriptors Property

EntityDescriptorSPSSODescriptors Property

Gets or sets the list of SP SSO descriptors.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<SPSSODescriptor> SPSSODescriptors { get; set; }
Public Property SPSSODescriptors As IList(Of SPSSODescriptor)
    Get
    Set
public:
property IList<SPSSODescriptor^>^ SPSSODescriptors {
    IList<SPSSODescriptor^>^ get ();
    void set (IList<SPSSODescriptor^>^ value);
}
member SPSSODescriptors : IList<SPSSODescriptor> with get, set

Property Value

Type: IList SPSSODescriptor
The list of SP SSO descriptors.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.ValidUntil Property

EntityDescriptorValidUntil Property

Gets or sets the valid until date/time.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime ValidUntil { get; set; }
Public Property ValidUntil As DateTime
    Get
    Set
public:
property DateTime ValidUntil {
    DateTime get ();
    void set (DateTime value);
}
member ValidUntil : DateTime with get, set

Property Value

Type: DateTime
The valid until date/time.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor Methods

The EntityDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an entity descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the entities descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the entity descriptor to XML.
Top
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.IsValid Method

EntityDescriptorIsValid Method

Indicates whether the XML is an entity descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an entity descriptor; otherwise false.
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.ToXml Method

EntityDescriptorToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the entities descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the entity descriptor to XML.
Top
See Also

Reference

EntityDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.ToXml Method

EntityDescriptorToXml Method

Serializes the entities descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The entities descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

EntityDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


EntityDescriptor.ToXml Method (XmlDocument)

EntityDescriptorToXml Method (XmlDocument)

Serializes the entity descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The entity descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

EntityDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


EntityIDType Class

Represents the entity ID type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataEntityIDType

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class EntityIDType
Public Class EntityIDType
public ref class EntityIDType
type EntityIDType =  class end

The EntityIDType type exposes the following members.

Constructors
 | Name | Description
Public method | EntityIDType | Initializes a new instance of the EntityIDType class.
Public method | EntityIDType(String) | Initializes a new instance of the EntityIDType class.
Top
Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the entity ID. (Overrides ObjectToString.)
Top
Fields
Name | Description
MaxLength | The maximum length of an entity ID.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


EntityIDType Constructor

Overload List
 | Name | Description
Public method | EntityIDType | Initializes a new instance of the EntityIDType class.
Public method | EntityIDType(String) | Initializes a new instance of the EntityIDType class.
Top
See Also

Reference

EntityIDType Class
ComponentSpace.SAML2.Metadata Namespace


EntityIDType Constructor

Initializes a new instance of the EntityIDType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EntityIDType()
Public Sub New
public:
EntityIDType()
new : unit -> EntityIDType
See Also

Reference

EntityIDType Class
EntityIDType Overload
ComponentSpace.SAML2.Metadata Namespace


EntityIDType Constructor (String)

Initializes a new instance of the EntityIDType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EntityIDType(
    string uri
)
Public Sub New (
    uri As String
)
public:
EntityIDType(
    String^ uri
)
new :
        uri : string -> EntityIDType

Parameters

uri
Type: SystemString
The URI.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the URI length is invalid.
See Also

Reference

EntityIDType Class
EntityIDType Overload
ComponentSpace.SAML2.Metadata Namespace


EntityIDType Properties

The EntityIDType type exposes the following members.

Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
See Also

Reference

EntityIDType Class
ComponentSpace.SAML2.Metadata Namespace


EntityIDType.URI Property

EntityIDTypeURI Property

Gets or sets the URI.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string URI { get; set; }
Public Property URI As String
    Get
    Set
public:
property String^ URI {
    String^ get ();
    void set (String^ value);
}
member URI : string with get, set

Property Value

Type: String
The URI.
See Also

Reference

EntityIDType Class
ComponentSpace.SAML2.Metadata Namespace


EntityIDType Methods

The EntityIDType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the entity ID. (Overrides ObjectToString.)
Top
See Also

Reference

EntityIDType Class
ComponentSpace.SAML2.Metadata Namespace


EntityIDType.ToString Method

EntityIDTypeToString Method

Returns a string that represents the entity ID.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A string that represents the entity ID.
See Also

Reference

EntityIDType Class
ComponentSpace.SAML2.Metadata Namespace


EntityIDType Fields

The EntityIDType type exposes the following members.

Fields
Name | Description
MaxLength | The maximum length of an entity ID.
Top
See Also

Reference

EntityIDType Class
ComponentSpace.SAML2.Metadata Namespace


EntityIDType.MaxLength Field

EntityIDTypeMaxLength Field

The maximum length of an entity ID.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const int MaxLength = 1024
Public Const MaxLength As Integer = 1024
public:
literal int MaxLength = 1024
static val mutable MaxLength: int

Field Value

Type: Int32
See Also

Reference

EntityIDType Class
ComponentSpace.SAML2.Metadata Namespace


Extensions Class

Represents an extensions.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataExtensions

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Extensions
Public Class Extensions
public ref class Extensions
type Extensions =  class end

The Extensions type exposes the following members.

Constructors
 | Name | Description
Public method | Extensions | Initializes a new instance of the Extensions class.
Public method | Extensions(XmlElement) | Initializes a new instance of the Extensions class from XML.
Top
Properties
 | Name | Description
Public property | AnyElements | Gets or sets the list of XML elements.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an extensions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the extensions to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


Extensions Constructor

Overload List
 | Name | Description
Public method | Extensions | Initializes a new instance of the Extensions class.
Public method | Extensions(XmlElement) | Initializes a new instance of the Extensions class from XML.
Top
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Metadata Namespace


Extensions Constructor

Initializes a new instance of the Extensions class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions()
Public Sub New
public:
Extensions()
new : unit -> Extensions
See Also

Reference

Extensions Class
Extensions Overload
ComponentSpace.SAML2.Metadata Namespace


Extensions Constructor (XmlElement)

Initializes a new instance of the Extensions class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Extensions(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Extensions

Parameters

xmlElement
Type: System.XmlXmlElement
The extensions XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Extensions Class
Extensions Overload
ComponentSpace.SAML2.Metadata Namespace


Extensions Properties

The Extensions type exposes the following members.

Properties
 | Name | Description
Public property | AnyElements | Gets or sets the list of XML elements.
Top
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Metadata Namespace


Extensions.AnyElements Property

ExtensionsAnyElements Property

Gets or sets the list of XML elements.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<XmlElement> AnyElements { get; set; }
Public Property AnyElements As IList(Of XmlElement)
    Get
    Set
public:
property IList<XmlElement^>^ AnyElements {
    IList<XmlElement^>^ get ();
    void set (IList<XmlElement^>^ value);
}
member AnyElements : IList<XmlElement> with get, set

Property Value

Type: IList XmlElement
The list of XML elements.
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Metadata Namespace


Extensions Methods

The Extensions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an extensions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the extensions to XML.
Top
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Metadata Namespace


Extensions.IsValid Method

ExtensionsIsValid Method

Indicates whether the XML is an extensions.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an extensions; otherwise false.
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Metadata Namespace


Extensions.ToXml Method

ExtensionsToXml Method

Serializes the extensions to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The extensions as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor Class

Represents an IdP SSO descriptor.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataRoleDescriptorType
ComponentSpace.SAML2.MetadataSSODescriptorType
ComponentSpace.SAML2.MetadataIDPSSODescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class IDPSSODescriptor : SSODescriptorType
Public Class IDPSSODescriptor
    Inherits SSODescriptorType
public ref class IDPSSODescriptor : public SSODescriptorType
type IDPSSODescriptor =
    class
        inherit SSODescriptorType
    end

The IDPSSODescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | IDPSSODescriptor | Initializes a new instance of the IDPSSODescriptor class.
Public method | IDPSSODescriptor(XmlElement) | Initializes a new instance of the IDPSSODescriptor class from XML.
Top
Properties
 | Name | Description
Public property | ArtifactResolutionServices | Gets or sets the list of artifact resolution services. (Inherited from SSODescriptorType.)
Public property | AssertionIDRequestServices | Gets or sets the list of assertion ID request services.
Public property | AttributeProfiles | Gets or sets the list of attribute profiles.
Public property | Attributes | Gets or sets the list of attributes.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | ManageNameIDServices | Gets or sets the list of manage name ID services. (Inherited from SSODescriptorType.)
Public property | NameIDFormats | Gets or sets the list of name ID formats. (Inherited from SSODescriptorType.)
Public property | NameIDMappingServices | Gets or sets the list of name ID mapping services.
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | SingleLogoutServices | Gets or sets the list of single logout services. (Inherited from SSODescriptorType.)
Public property | SingleSignOnServices | Gets or sets the list of single sign-on services.
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Public property | WantAuthnRequestsSigned | Gets or sets the flag indicating whether want authentication requests signed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an IdP SSO descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the IdP SSO descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the IdP SSO descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the SSO descriptor to XML. (Inherited from SSODescriptorType.)
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor Constructor

Overload List
 | Name | Description
Public method | IDPSSODescriptor | Initializes a new instance of the IDPSSODescriptor class.
Public method | IDPSSODescriptor(XmlElement) | Initializes a new instance of the IDPSSODescriptor class from XML.
Top
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor Constructor

Initializes a new instance of the IDPSSODescriptor class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDPSSODescriptor()
Public Sub New
public:
IDPSSODescriptor()
new : unit -> IDPSSODescriptor
See Also

Reference

IDPSSODescriptor Class
IDPSSODescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor Constructor (XmlElement)

Initializes a new instance of the IDPSSODescriptor class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDPSSODescriptor(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
IDPSSODescriptor(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> IDPSSODescriptor

Parameters

xmlElement
Type: System.XmlXmlElement
The IdP SSO descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

IDPSSODescriptor Class
IDPSSODescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor Properties

The IDPSSODescriptor type exposes the following members.

Properties
 | Name | Description
Public property | ArtifactResolutionServices | Gets or sets the list of artifact resolution services. (Inherited from SSODescriptorType.)
Public property | AssertionIDRequestServices | Gets or sets the list of assertion ID request services.
Public property | AttributeProfiles | Gets or sets the list of attribute profiles.
Public property | Attributes | Gets or sets the list of attributes.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | ManageNameIDServices | Gets or sets the list of manage name ID services. (Inherited from SSODescriptorType.)
Public property | NameIDFormats | Gets or sets the list of name ID formats. (Inherited from SSODescriptorType.)
Public property | NameIDMappingServices | Gets or sets the list of name ID mapping services.
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | SingleLogoutServices | Gets or sets the list of single logout services. (Inherited from SSODescriptorType.)
Public property | SingleSignOnServices | Gets or sets the list of single sign-on services.
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Public property | WantAuthnRequestsSigned | Gets or sets the flag indicating whether want authentication requests signed.
Top
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor.AssertionIDRequestServices Property

IDPSSODescriptorAssertionIDRequestServices Property

Gets or sets the list of assertion ID request services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> AssertionIDRequestServices { get; set; }
Public Property AssertionIDRequestServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ AssertionIDRequestServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member AssertionIDRequestServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of assertion ID request services.
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor.AttributeProfiles Property

IDPSSODescriptorAttributeProfiles Property

Gets or sets the list of attribute profiles.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<string> AttributeProfiles { get; set; }
Public Property AttributeProfiles As IList(Of String)
    Get
    Set
public:
property IList<String^>^ AttributeProfiles {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member AttributeProfiles : IList<string> with get, set

Property Value

Type: IList String
The list of attribute profiles.
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor.Attributes Property

IDPSSODescriptorAttributes Property

Gets or sets the list of attributes.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<SAMLAttribute> Attributes { get; set; }
Public Property Attributes As IList(Of SAMLAttribute)
    Get
    Set
public:
property IList<SAMLAttribute^>^ Attributes {
    IList<SAMLAttribute^>^ get ();
    void set (IList<SAMLAttribute^>^ value);
}
member Attributes : IList<SAMLAttribute> with get, set

Property Value

Type: IList SAMLAttribute
The list of attributes.
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor.NameIDMappingServices Property

IDPSSODescriptorNameIDMappingServices Property

Gets or sets the list of name ID mapping services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> NameIDMappingServices { get; set; }
Public Property NameIDMappingServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ NameIDMappingServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member NameIDMappingServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of name ID mapping services.
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor.SingleSignOnServices Property

IDPSSODescriptorSingleSignOnServices Property

Gets or sets the list of single sign-on services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> SingleSignOnServices { get; set; }
Public Property SingleSignOnServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ SingleSignOnServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member SingleSignOnServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of single sign-on services.
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor.WantAuthnRequestsSigned Property

IDPSSODescriptorWantAuthnRequestsSigned Property

Gets or sets the flag indicating whether want authentication requests signed.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool WantAuthnRequestsSigned { get; set; }
Public Property WantAuthnRequestsSigned As Boolean
    Get
    Set
public:
property bool WantAuthnRequestsSigned {
    bool get ();
    void set (bool value);
}
member WantAuthnRequestsSigned : bool with get, set

Property Value

Type: Boolean
The flag indicating whether want authentication requests signed.
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor Methods

The IDPSSODescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an IdP SSO descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the IdP SSO descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the IdP SSO descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the SSO descriptor to XML. (Inherited from SSODescriptorType.)
Top
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor.IsValid Method

IDPSSODescriptorIsValid Method

Indicates whether the XML is an IdP SSO descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an IdP SSO descriptor; otherwise false.
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor.ToXml Method

IDPSSODescriptorToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the IdP SSO descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the IdP SSO descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the SSO descriptor to XML. (Inherited from SSODescriptorType.)
Top
See Also

Reference

IDPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor.ToXml Method

IDPSSODescriptorToXml Method

Serializes the IdP SSO descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The IdP SSO descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

IDPSSODescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


IDPSSODescriptor.ToXml Method (XmlDocument)

IDPSSODescriptorToXml Method (XmlDocument)

Serializes the IdP SSO descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The IdP SSO descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

IDPSSODescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType Class

Represents the indexed endpoint type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataEndpointType
ComponentSpace.SAML2.MetadataIndexedEndpointType

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class IndexedEndpointType : EndpointType
Public Class IndexedEndpointType
    Inherits EndpointType
public ref class IndexedEndpointType : public EndpointType
type IndexedEndpointType =
    class
        inherit EndpointType
    end

The IndexedEndpointType type exposes the following members.

Constructors
 | Name | Description
Public method | IndexedEndpointType | Initializes a new instance of the IndexedEndpointType class.
Public method | IndexedEndpointType(XmlElement) | Initializes a new instance of the IndexedEndpointType class from XML.
Public method | IndexedEndpointType(Int32, Boolean) | Initializes a new instance of the IndexedEndpointType class.
Public method | IndexedEndpointType(String, String, String, Int32, Boolean) | Initializes a new instance of the IndexedEndpointType class.
Top
Properties
 | Name | Description
Public property | Binding | Gets or sets the binding. (Inherited from EndpointType.)
Public property | Index | Gets or sets the index.
Public property | IsDefault | Gets or sets the is default flag.
Public property | Location | Gets or sets the location. (Inherited from EndpointType.)
Public property | ResponseLocation | Gets or sets the response location. (Inherited from EndpointType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the index endpoint to XML. (Overrides EndpointTypeToXml(XmlElement).)
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType Constructor

Overload List
 | Name | Description
Public method | IndexedEndpointType | Initializes a new instance of the IndexedEndpointType class.
Public method | IndexedEndpointType(XmlElement) | Initializes a new instance of the IndexedEndpointType class from XML.
Public method | IndexedEndpointType(Int32, Boolean) | Initializes a new instance of the IndexedEndpointType class.
Public method | IndexedEndpointType(String, String, String, Int32, Boolean) | Initializes a new instance of the IndexedEndpointType class.
Top
See Also

Reference

IndexedEndpointType Class
ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType Constructor

Initializes a new instance of the IndexedEndpointType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IndexedEndpointType()
Public Sub New
public:
IndexedEndpointType()
new : unit -> IndexedEndpointType
See Also

Reference

IndexedEndpointType Class
IndexedEndpointType Overload
ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType Constructor (XmlElement)

Initializes a new instance of the IndexedEndpointType class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IndexedEndpointType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
IndexedEndpointType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> IndexedEndpointType

Parameters

xmlElement
Type: System.XmlXmlElement
The endpoint XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

IndexedEndpointType Class
IndexedEndpointType Overload
ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType Constructor (Int32, Boolean)

Initializes a new instance of the IndexedEndpointType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IndexedEndpointType(
    int index,
    bool isDefault
)
Public Sub New (
    index As Integer,
    isDefault As Boolean
)
public:
IndexedEndpointType(
    int index,
    bool isDefault
)
new :
        index : int *
        isDefault : bool -> IndexedEndpointType

Parameters

index
Type: SystemInt32
The index.
isDefault
Type: SystemBoolean
The is default flag.
See Also

Reference

IndexedEndpointType Class
IndexedEndpointType Overload
ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType Constructor (String, String, String, Int32, Boolean)

Initializes a new instance of the IndexedEndpointType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IndexedEndpointType(
    string binding,
    string location,
    string responseLocation,
    int index,
    bool isDefault
)
Public Sub New (
    binding As String,
    location As String,
    responseLocation As String,
    index As Integer,
    isDefault As Boolean
)
public:
IndexedEndpointType(
    String^ binding,
    String^ location,
    String^ responseLocation,
    int index,
    bool isDefault
)
new :
        binding : string *
        location : string *
        responseLocation : string *
        index : int *
        isDefault : bool -> IndexedEndpointType

Parameters

binding
Type: SystemString
The binding.
location
Type: SystemString
The location.
responseLocation
Type: SystemString
The response location.
index
Type: SystemInt32
The index.
isDefault
Type: SystemBoolean
The is default flag.
See Also

Reference

IndexedEndpointType Class
IndexedEndpointType Overload
ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType Properties

The IndexedEndpointType type exposes the following members.

Properties
 | Name | Description
Public property | Binding | Gets or sets the binding. (Inherited from EndpointType.)
Public property | Index | Gets or sets the index.
Public property | IsDefault | Gets or sets the is default flag.
Public property | Location | Gets or sets the location. (Inherited from EndpointType.)
Public property | ResponseLocation | Gets or sets the response location. (Inherited from EndpointType.)
Top
See Also

Reference

IndexedEndpointType Class
ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType.Index Property

IndexedEndpointTypeIndex Property

Gets or sets the index.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
The index.
See Also

Reference

IndexedEndpointType Class
ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType.IsDefault Property

IndexedEndpointTypeIsDefault Property

Gets or sets the is default flag.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool IsDefault { get; set; }
Public Property IsDefault As Boolean
    Get
    Set
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}
member IsDefault : bool with get, set

Property Value

Type: Boolean
The is default flag.
See Also

Reference

IndexedEndpointType Class
ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType Methods

The IndexedEndpointType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the index endpoint to XML. (Overrides EndpointTypeToXml(XmlElement).)
Top
See Also

Reference

IndexedEndpointType Class
ComponentSpace.SAML2.Metadata Namespace


IndexedEndpointType.ToXml Method

IndexedEndpointTypeToXml Method

Serializes the index endpoint to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    XmlElement xmlElement
)
Public Overrides Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
) override
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

IndexedEndpointType Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor Class

Represents a key descriptor.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataKeyDescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class KeyDescriptor
Public Class KeyDescriptor
public ref class KeyDescriptor
type KeyDescriptor =  class end

The KeyDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | KeyDescriptor | Initializes a new instance of the KeyDescriptor class.
Public method | KeyDescriptor(XmlElement) | Initializes a new instance of the KeyDescriptor class from XML.
Top
Properties
 | Name | Description
Public property | EncryptionMethods | Gets or sets the list of encryption methods.
Public property | KeyInfo | Gets or sets the key info.
Public property | Use | Gets or sets the use.
Top
Methods
 | Name | Description
Public method | AddEncryptionMethod | Adds an encryption method with the specified algorithm.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEncryptionMethodAlgorithm | Gets the encryption method algorithm.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a key descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the entities descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the key descriptor to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor Constructor

Overload List
 | Name | Description
Public method | KeyDescriptor | Initializes a new instance of the KeyDescriptor class.
Public method | KeyDescriptor(XmlElement) | Initializes a new instance of the KeyDescriptor class from XML.
Top
See Also

Reference

KeyDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor Constructor

Initializes a new instance of the KeyDescriptor class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public KeyDescriptor()
Public Sub New
public:
KeyDescriptor()
new : unit -> KeyDescriptor
See Also

Reference

KeyDescriptor Class
KeyDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor Constructor (XmlElement)

Initializes a new instance of the KeyDescriptor class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public KeyDescriptor(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
KeyDescriptor(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> KeyDescriptor

Parameters

xmlElement
Type: System.XmlXmlElement
The key descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

KeyDescriptor Class
KeyDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor Properties

The KeyDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | EncryptionMethods | Gets or sets the list of encryption methods.
Public property | KeyInfo | Gets or sets the key info.
Public property | Use | Gets or sets the use.
Top
See Also

Reference

KeyDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.EncryptionMethods Property

KeyDescriptorEncryptionMethods Property

Gets or sets the list of encryption methods.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<XmlElement> EncryptionMethods { get; set; }
Public Property EncryptionMethods As IList(Of XmlElement)
    Get
    Set
public:
property IList<XmlElement^>^ EncryptionMethods {
    IList<XmlElement^>^ get ();
    void set (IList<XmlElement^>^ value);
}
member EncryptionMethods : IList<XmlElement> with get, set

Property Value

Type: IList XmlElement
The list of encryption methods.
See Also

Reference

KeyDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.KeyInfo Property

KeyDescriptorKeyInfo Property

Gets or sets the key info.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement KeyInfo { get; set; }
Public Property KeyInfo As XmlElement
    Get
    Set
public:
property XmlElement^ KeyInfo {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member KeyInfo : XmlElement with get, set

Property Value

Type: XmlElement
The key info.
See Also

Reference

KeyDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.Use Property

KeyDescriptorUse Property

Gets or sets the use.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Use { get; set; }
Public Property Use As String
    Get
    Set
public:
property String^ Use {
    String^ get ();
    void set (String^ value);
}
member Use : string with get, set

Property Value

Type: String
The use.
See Also

Reference

KeyDescriptor Class
ComponentSpace.SAML2.Metadata Namespace
ComponentSpace.SAML2.MetadataKeyDescriptorKeyTypes


KeyDescriptor Methods

The KeyDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | AddEncryptionMethod | Adds an encryption method with the specified algorithm.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEncryptionMethodAlgorithm | Gets the encryption method algorithm.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a key descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the entities descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the key descriptor to XML.
Top
See Also

Reference

KeyDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.AddEncryptionMethod Method

KeyDescriptorAddEncryptionMethod Method

Adds an encryption method with the specified algorithm.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void AddEncryptionMethod(
    string encryptionMethodAlgorithm
)
Public Sub AddEncryptionMethod (
    encryptionMethodAlgorithm As String
)
public:
void AddEncryptionMethod(
    String^ encryptionMethodAlgorithm
)
member AddEncryptionMethod :
        encryptionMethodAlgorithm : string -> unit

Parameters

encryptionMethodAlgorithm
Type: SystemString
The encryption method algorithm.
See Also

Reference

KeyDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.GetEncryptionMethodAlgorithm Method

KeyDescriptorGetEncryptionMethodAlgorithm Method

Gets the encryption method algorithm.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetEncryptionMethodAlgorithm(
    XmlElement xmlElement
)
Public Shared Function GetEncryptionMethodAlgorithm (
    xmlElement As XmlElement
) As String
public:
static String^ GetEncryptionMethodAlgorithm(
    XmlElement^ xmlElement
)
static member GetEncryptionMethodAlgorithm :
        xmlElement : XmlElement -> string

Parameters

xmlElement
Type: System.XmlXmlElement
The encryption method element.

Return Value

Type: String
The encryption method algorithm.
See Also

Reference

KeyDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.IsValid Method

KeyDescriptorIsValid Method

Indicates whether the XML is a key descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a key descriptor; otherwise false.
See Also

Reference

KeyDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.ToXml Method

KeyDescriptorToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the entities descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the key descriptor to XML.
Top
See Also

Reference

KeyDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.ToXml Method

KeyDescriptorToXml Method

Serializes the entities descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The entities descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

KeyDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.ToXml Method (XmlDocument)

KeyDescriptorToXml Method (XmlDocument)

Serializes the key descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The key descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

KeyDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.KeyTypes Class

KeyDescriptorKeyTypes Class

The key types.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataKeyDescriptorKeyTypes

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class KeyTypes
Public NotInheritable Class KeyTypes
public ref class KeyTypes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KeyTypes =  class end

The KeyDescriptorKeyTypes type exposes the following members.

Fields
Name | Description
Encryption | Encryption.
Signing | Signing.
Top
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


KeyTypes Fields

The KeyDescriptorKeyTypes type exposes the following members.

Fields
Name | Description
Encryption | Encryption.
Signing | Signing.
Top
See Also

Reference

KeyDescriptorKeyTypes Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.KeyTypes.Encryption Field

KeyDescriptorKeyTypesEncryption Field

Encryption.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Encryption = "encryption"
Public Const Encryption As String = "encryption"
public:
literal String^ Encryption = "encryption"
static val mutable Encryption: string

Field Value

Type: String
See Also

Reference

KeyDescriptorKeyTypes Class
ComponentSpace.SAML2.Metadata Namespace


KeyDescriptor.KeyTypes.Signing Field

KeyDescriptorKeyTypesSigning Field

Signing.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Signing = "signing"
Public Const Signing As String = "signing"
public:
literal String^ Signing = "signing"
static val mutable Signing: string

Field Value

Type: String
See Also

Reference

KeyDescriptorKeyTypes Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedNameType Class

Represents the localized name type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataLocalizedNameType
ComponentSpace.SAML2.MetadataOrganizationDisplayName
ComponentSpace.SAML2.MetadataOrganizationName

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class LocalizedNameType
Public Class LocalizedNameType
public ref class LocalizedNameType
type LocalizedNameType =  class end

The LocalizedNameType type exposes the following members.

Constructors
 | Name | Description
Public method | LocalizedNameType | Initializes a new instance of the LocalizedNameType class.
Public method | LocalizedNameType(XmlElement) | Initializes a new instance of the LocalizedNameType class from XML.
Public method | LocalizedNameType(String, String) | Initializes a new instance of the LocalizedNameType class.
Top
Properties
 | Name | Description
Public property | Language | Gets or sets the language.
Public property | Name | Gets or sets the name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the localized name to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


LocalizedNameType Constructor

Overload List
 | Name | Description
Public method | LocalizedNameType | Initializes a new instance of the LocalizedNameType class.
Public method | LocalizedNameType(XmlElement) | Initializes a new instance of the LocalizedNameType class from XML.
Public method | LocalizedNameType(String, String) | Initializes a new instance of the LocalizedNameType class.
Top
See Also

Reference

LocalizedNameType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedNameType Constructor

Initializes a new instance of the LocalizedNameType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalizedNameType()
Public Sub New
public:
LocalizedNameType()
new : unit -> LocalizedNameType
See Also

Reference

LocalizedNameType Class
LocalizedNameType Overload
ComponentSpace.SAML2.Metadata Namespace


LocalizedNameType Constructor (XmlElement)

Initializes a new instance of the LocalizedNameType class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalizedNameType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
LocalizedNameType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> LocalizedNameType

Parameters

xmlElement
Type: System.XmlXmlElement
The localized name XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

LocalizedNameType Class
LocalizedNameType Overload
ComponentSpace.SAML2.Metadata Namespace


LocalizedNameType Constructor (String, String)

Initializes a new instance of the LocalizedNameType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalizedNameType(
    string name,
    string language
)
Public Sub New (
    name As String,
    language As String
)
public:
LocalizedNameType(
    String^ name,
    String^ language
)
new :
        name : string *
        language : string -> LocalizedNameType

Parameters

name
Type: SystemString
The name.
language
Type: SystemString
The language.
See Also

Reference

LocalizedNameType Class
LocalizedNameType Overload
ComponentSpace.SAML2.Metadata Namespace


LocalizedNameType Properties

The LocalizedNameType type exposes the following members.

Properties
 | Name | Description
Public property | Language | Gets or sets the language.
Public property | Name | Gets or sets the name.
Top
See Also

Reference

LocalizedNameType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedNameType.Language Property

LocalizedNameTypeLanguage Property

Gets or sets the language.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}
member Language : string with get, set

Property Value

Type: String
The language.
See Also

Reference

LocalizedNameType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedNameType.Name Property

LocalizedNameTypeName Property

Gets or sets the name.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

LocalizedNameType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedNameType Methods

The LocalizedNameType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the localized name to XML.
Top
See Also

Reference

LocalizedNameType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedNameType.ToXml Method

LocalizedNameTypeToXml Method

Serializes the localized name to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void ToXml(
    XmlElement xmlElement
)
Public Sub ToXml (
    xmlElement As XmlElement
)
public:
void ToXml(
    XmlElement^ xmlElement
)
member ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

LocalizedNameType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedURIType Class

Represents the localized URI type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataLocalizedURIType
ComponentSpace.SAML2.MetadataOrganizationURL

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class LocalizedURIType
Public Class LocalizedURIType
public ref class LocalizedURIType
type LocalizedURIType =  class end

The LocalizedURIType type exposes the following members.

Constructors
 | Name | Description
Public method | LocalizedURIType | Initializes a new instance of the LocalizedURIType class.
Public method | LocalizedURIType(XmlElement) | Initializes a new instance of the LocalizedURIType class from XML.
Public method | LocalizedURIType(String, String) | Initializes a new instance of the LocalizedURIType class.
Top
Properties
 | Name | Description
Public property | Language | Gets or sets the language.
Public property | URI | Gets or sets the URI.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the localized URI to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


LocalizedURIType Constructor

Overload List
 | Name | Description
Public method | LocalizedURIType | Initializes a new instance of the LocalizedURIType class.
Public method | LocalizedURIType(XmlElement) | Initializes a new instance of the LocalizedURIType class from XML.
Public method | LocalizedURIType(String, String) | Initializes a new instance of the LocalizedURIType class.
Top
See Also

Reference

LocalizedURIType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedURIType Constructor

Initializes a new instance of the LocalizedURIType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalizedURIType()
Public Sub New
public:
LocalizedURIType()
new : unit -> LocalizedURIType
See Also

Reference

LocalizedURIType Class
LocalizedURIType Overload
ComponentSpace.SAML2.Metadata Namespace


LocalizedURIType Constructor (XmlElement)

Initializes a new instance of the LocalizedURIType class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalizedURIType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
LocalizedURIType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> LocalizedURIType

Parameters

xmlElement
Type: System.XmlXmlElement
The localized URI XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

LocalizedURIType Class
LocalizedURIType Overload
ComponentSpace.SAML2.Metadata Namespace


LocalizedURIType Constructor (String, String)

Initializes a new instance of the LocalizedURIType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LocalizedURIType(
    string uri,
    string language
)
Public Sub New (
    uri As String,
    language As String
)
public:
LocalizedURIType(
    String^ uri,
    String^ language
)
new :
        uri : string *
        language : string -> LocalizedURIType

Parameters

uri
Type: SystemString
The URI.
language
Type: SystemString
The language.
See Also

Reference

LocalizedURIType Class
LocalizedURIType Overload
ComponentSpace.SAML2.Metadata Namespace


LocalizedURIType Properties

The LocalizedURIType type exposes the following members.

Properties
 | Name | Description
Public property | Language | Gets or sets the language.
Public property | URI | Gets or sets the URI.
Top
See Also

Reference

LocalizedURIType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedURIType.Language Property

LocalizedURITypeLanguage Property

Gets or sets the language.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}
member Language : string with get, set

Property Value

Type: String
The language.
See Also

Reference

LocalizedURIType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedURIType.URI Property

LocalizedURITypeURI Property

Gets or sets the URI.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string URI { get; set; }
Public Property URI As String
    Get
    Set
public:
property String^ URI {
    String^ get ();
    void set (String^ value);
}
member URI : string with get, set

Property Value

Type: String
The URI.
See Also

Reference

LocalizedURIType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedURIType Methods

The LocalizedURIType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the localized URI to XML.
Top
See Also

Reference

LocalizedURIType Class
ComponentSpace.SAML2.Metadata Namespace


LocalizedURIType.ToXml Method

LocalizedURITypeToXml Method

Serializes the localized URI to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void ToXml(
    XmlElement xmlElement
)
Public Sub ToXml (
    xmlElement As XmlElement
)
public:
void ToXml(
    XmlElement^ xmlElement
)
member ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

LocalizedURIType Class
ComponentSpace.SAML2.Metadata Namespace


Organization Class

Represents an organization.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataOrganization

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Organization
Public Class Organization
public ref class Organization
type Organization =  class end

The Organization type exposes the following members.

Constructors
 | Name | Description
Public method | Organization | Initializes a new instance of the Organization class.
Public method | Organization(XmlElement) | Initializes a new instance of the Organization class from XML.
Top
Properties
 | Name | Description
Public property | Extensions | Gets or sets the extensions.
Public property | OrganizationDisplayNames | Gets or sets the list of organization display names.
Public property | OrganizationNames | Gets or sets the list of organization names.
Public property | OrganizationURLs | Gets or sets the list of organization URLs.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an organization.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the organization to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


Organization Constructor

Overload List
 | Name | Description
Public method | Organization | Initializes a new instance of the Organization class.
Public method | Organization(XmlElement) | Initializes a new instance of the Organization class from XML.
Top
See Also

Reference

Organization Class
ComponentSpace.SAML2.Metadata Namespace


Organization Constructor

Initializes a new instance of the Organization class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Organization()
Public Sub New
public:
Organization()
new : unit -> Organization
See Also

Reference

Organization Class
Organization Overload
ComponentSpace.SAML2.Metadata Namespace


Organization Constructor (XmlElement)

Initializes a new instance of the Organization class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Organization(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Organization(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Organization

Parameters

xmlElement
Type: System.XmlXmlElement
The organization XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Organization Class
Organization Overload
ComponentSpace.SAML2.Metadata Namespace


Organization Properties

The Organization type exposes the following members.

Properties
 | Name | Description
Public property | Extensions | Gets or sets the extensions.
Public property | OrganizationDisplayNames | Gets or sets the list of organization display names.
Public property | OrganizationNames | Gets or sets the list of organization names.
Public property | OrganizationURLs | Gets or sets the list of organization URLs.
Top
See Also

Reference

Organization Class
ComponentSpace.SAML2.Metadata Namespace


Organization.Extensions Property

OrganizationExtensions Property

Gets or sets the extensions.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions Extensions { get; set; }
Public Property Extensions As Extensions
    Get
    Set
public:
property Extensions^ Extensions {
    Extensions^ get ();
    void set (Extensions^ value);
}
member Extensions : Extensions with get, set

Property Value

Type: Extensions
The extensions.
See Also

Reference

Organization Class
ComponentSpace.SAML2.Metadata Namespace


Organization.OrganizationDisplayNames Property

OrganizationOrganizationDisplayNames Property

Gets or sets the list of organization display names.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<OrganizationDisplayName> OrganizationDisplayNames { get; set; }
Public Property OrganizationDisplayNames As IList(Of OrganizationDisplayName)
    Get
    Set
public:
property IList<OrganizationDisplayName^>^ OrganizationDisplayNames {
    IList<OrganizationDisplayName^>^ get ();
    void set (IList<OrganizationDisplayName^>^ value);
}
member OrganizationDisplayNames : IList<OrganizationDisplayName> with get, set

Property Value

Type: IList OrganizationDisplayName
The list of organization display names.
See Also

Reference

Organization Class
ComponentSpace.SAML2.Metadata Namespace


Organization.OrganizationNames Property

OrganizationOrganizationNames Property

Gets or sets the list of organization names.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<OrganizationName> OrganizationNames { get; set; }
Public Property OrganizationNames As IList(Of OrganizationName)
    Get
    Set
public:
property IList<OrganizationName^>^ OrganizationNames {
    IList<OrganizationName^>^ get ();
    void set (IList<OrganizationName^>^ value);
}
member OrganizationNames : IList<OrganizationName> with get, set

Property Value

Type: IList OrganizationName
The list of organization names.
See Also

Reference

Organization Class
ComponentSpace.SAML2.Metadata Namespace


Organization.OrganizationURLs Property

OrganizationOrganizationURLs Property

Gets or sets the list of organization URLs.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<OrganizationURL> OrganizationURLs { get; set; }
Public Property OrganizationURLs As IList(Of OrganizationURL)
    Get
    Set
public:
property IList<OrganizationURL^>^ OrganizationURLs {
    IList<OrganizationURL^>^ get ();
    void set (IList<OrganizationURL^>^ value);
}
member OrganizationURLs : IList<OrganizationURL> with get, set

Property Value

Type: IList OrganizationURL
The list of organization URLs.
See Also

Reference

Organization Class
ComponentSpace.SAML2.Metadata Namespace


Organization Methods

The Organization type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an organization.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the organization to XML.
Top
See Also

Reference

Organization Class
ComponentSpace.SAML2.Metadata Namespace


Organization.IsValid Method

OrganizationIsValid Method

Indicates whether the XML is an organization.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an organization; otherwise false.
See Also

Reference

Organization Class
ComponentSpace.SAML2.Metadata Namespace


Organization.ToXml Method

OrganizationToXml Method

Serializes the organization to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The organization as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Organization Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationDisplayName Class

Represents an organization display name.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataLocalizedNameType
ComponentSpace.SAML2.MetadataOrganizationDisplayName

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class OrganizationDisplayName : LocalizedNameType
Public Class OrganizationDisplayName
    Inherits LocalizedNameType
public ref class OrganizationDisplayName : public LocalizedNameType
type OrganizationDisplayName =
    class
        inherit LocalizedNameType
    end

The OrganizationDisplayName type exposes the following members.

Constructors
 | Name | Description
Public method | OrganizationDisplayName | Initializes a new instance of the OrganizationDisplayName class.
Public method | OrganizationDisplayName(XmlElement) | Initializes a new instance of the OrganizationDisplayName class from XML.
Public method | OrganizationDisplayName(String, String) | Initializes a new instance of the OrganizationDisplayName class.
Top
Properties
 | Name | Description
Public property | Language | Gets or sets the language. (Inherited from LocalizedNameType.)
Public property | Name | Gets or sets the name. (Inherited from LocalizedNameType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an organization display name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the localized name to XML. (Inherited from LocalizedNameType.)
Public method | ToXml(XmlDocument) | Serializes the organization display name to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


OrganizationDisplayName Constructor

Overload List
 | Name | Description
Public method | OrganizationDisplayName | Initializes a new instance of the OrganizationDisplayName class.
Public method | OrganizationDisplayName(XmlElement) | Initializes a new instance of the OrganizationDisplayName class from XML.
Public method | OrganizationDisplayName(String, String) | Initializes a new instance of the OrganizationDisplayName class.
Top
See Also

Reference

OrganizationDisplayName Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationDisplayName Constructor

Initializes a new instance of the OrganizationDisplayName class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OrganizationDisplayName()
Public Sub New
public:
OrganizationDisplayName()
new : unit -> OrganizationDisplayName
See Also

Reference

OrganizationDisplayName Class
OrganizationDisplayName Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationDisplayName Constructor (XmlElement)

Initializes a new instance of the OrganizationDisplayName class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OrganizationDisplayName(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
OrganizationDisplayName(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> OrganizationDisplayName

Parameters

xmlElement
Type: System.XmlXmlElement
The organization display name XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

OrganizationDisplayName Class
OrganizationDisplayName Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationDisplayName Constructor (String, String)

Initializes a new instance of the OrganizationDisplayName class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OrganizationDisplayName(
    string name,
    string language
)
Public Sub New (
    name As String,
    language As String
)
public:
OrganizationDisplayName(
    String^ name,
    String^ language
)
new :
        name : string *
        language : string -> OrganizationDisplayName

Parameters

name
Type: SystemString
The name.
language
Type: SystemString
The language.
See Also

Reference

OrganizationDisplayName Class
OrganizationDisplayName Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationDisplayName Properties

The OrganizationDisplayName type exposes the following members.

Properties
 | Name | Description
Public property | Language | Gets or sets the language. (Inherited from LocalizedNameType.)
Public property | Name | Gets or sets the name. (Inherited from LocalizedNameType.)
Top
See Also

Reference

OrganizationDisplayName Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationDisplayName Methods

The OrganizationDisplayName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an organization display name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the localized name to XML. (Inherited from LocalizedNameType.)
Public method | ToXml(XmlDocument) | Serializes the organization display name to XML.
Top
See Also

Reference

OrganizationDisplayName Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationDisplayName.IsValid Method

OrganizationDisplayNameIsValid Method

Indicates whether the XML is an organization display name.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an organization display name; otherwise false.
See Also

Reference

OrganizationDisplayName Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationDisplayName.ToXml Method

OrganizationDisplayNameToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlElement) | Serializes the localized name to XML. (Inherited from LocalizedNameType.)
Public method | ToXml(XmlDocument) | Serializes the organization display name to XML.
Top
See Also

Reference

OrganizationDisplayName Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationDisplayName.ToXml Method (XmlDocument)

OrganizationDisplayNameToXml Method (XmlDocument)

Serializes the organization display name to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The organization display name as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

OrganizationDisplayName Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationName Class

Represents an organization name.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataLocalizedNameType
ComponentSpace.SAML2.MetadataOrganizationName

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class OrganizationName : LocalizedNameType
Public Class OrganizationName
    Inherits LocalizedNameType
public ref class OrganizationName : public LocalizedNameType
type OrganizationName =
    class
        inherit LocalizedNameType
    end

The OrganizationName type exposes the following members.

Constructors
 | Name | Description
Public method | OrganizationName | Initializes a new instance of the OrganizationName class.
Public method | OrganizationName(XmlElement) | Initializes a new instance of the OrganizationName class from XML.
Public method | OrganizationName(String, String) | Initializes a new instance of the OrganizationName class.
Top
Properties
 | Name | Description
Public property | Language | Gets or sets the language. (Inherited from LocalizedNameType.)
Public property | Name | Gets or sets the name. (Inherited from LocalizedNameType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an organization name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the localized name to XML. (Inherited from LocalizedNameType.)
Public method | ToXml(XmlDocument) | Serializes the organization name to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


OrganizationName Constructor

Overload List
 | Name | Description
Public method | OrganizationName | Initializes a new instance of the OrganizationName class.
Public method | OrganizationName(XmlElement) | Initializes a new instance of the OrganizationName class from XML.
Public method | OrganizationName(String, String) | Initializes a new instance of the OrganizationName class.
Top
See Also

Reference

OrganizationName Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationName Constructor

Initializes a new instance of the OrganizationName class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OrganizationName()
Public Sub New
public:
OrganizationName()
new : unit -> OrganizationName
See Also

Reference

OrganizationName Class
OrganizationName Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationName Constructor (XmlElement)

Initializes a new instance of the OrganizationName class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OrganizationName(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
OrganizationName(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> OrganizationName

Parameters

xmlElement
Type: System.XmlXmlElement
The organization name XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

OrganizationName Class
OrganizationName Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationName Constructor (String, String)

Initializes a new instance of the OrganizationName class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OrganizationName(
    string name,
    string language
)
Public Sub New (
    name As String,
    language As String
)
public:
OrganizationName(
    String^ name,
    String^ language
)
new :
        name : string *
        language : string -> OrganizationName

Parameters

name
Type: SystemString
The name.
language
Type: SystemString
The language.
See Also

Reference

OrganizationName Class
OrganizationName Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationName Properties

The OrganizationName type exposes the following members.

Properties
 | Name | Description
Public property | Language | Gets or sets the language. (Inherited from LocalizedNameType.)
Public property | Name | Gets or sets the name. (Inherited from LocalizedNameType.)
Top
See Also

Reference

OrganizationName Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationName Methods

The OrganizationName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an organization name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the localized name to XML. (Inherited from LocalizedNameType.)
Public method | ToXml(XmlDocument) | Serializes the organization name to XML.
Top
See Also

Reference

OrganizationName Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationName.IsValid Method

OrganizationNameIsValid Method

Indicates whether the XML is an organization name.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an organization name; otherwise false.
See Also

Reference

OrganizationName Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationName.ToXml Method

OrganizationNameToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlElement) | Serializes the localized name to XML. (Inherited from LocalizedNameType.)
Public method | ToXml(XmlDocument) | Serializes the organization name to XML.
Top
See Also

Reference

OrganizationName Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationName.ToXml Method (XmlDocument)

OrganizationNameToXml Method (XmlDocument)

Serializes the organization name to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The organization name as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

OrganizationName Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationURL Class

Represents an organization URL.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataLocalizedURIType
ComponentSpace.SAML2.MetadataOrganizationURL

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class OrganizationURL : LocalizedURIType
Public Class OrganizationURL
    Inherits LocalizedURIType
public ref class OrganizationURL : public LocalizedURIType
type OrganizationURL =
    class
        inherit LocalizedURIType
    end

The OrganizationURL type exposes the following members.

Constructors
 | Name | Description
Public method | OrganizationURL | Initializes a new instance of the OrganizationURL class.
Public method | OrganizationURL(XmlElement) | Initializes a new instance of the OrganizationURL class from XML.
Public method | OrganizationURL(String, String) | Initializes a new instance of the OrganizationURL class.
Top
Properties
 | Name | Description
Public property | Language | Gets or sets the language. (Inherited from LocalizedURIType.)
Public property | URI | Gets or sets the URI. (Inherited from LocalizedURIType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an organization URL.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the localized URI to XML. (Inherited from LocalizedURIType.)
Public method | ToXml(XmlDocument) | Serializes the organization URL to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


OrganizationURL Constructor

Overload List
 | Name | Description
Public method | OrganizationURL | Initializes a new instance of the OrganizationURL class.
Public method | OrganizationURL(XmlElement) | Initializes a new instance of the OrganizationURL class from XML.
Public method | OrganizationURL(String, String) | Initializes a new instance of the OrganizationURL class.
Top
See Also

Reference

OrganizationURL Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationURL Constructor

Initializes a new instance of the OrganizationURL class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OrganizationURL()
Public Sub New
public:
OrganizationURL()
new : unit -> OrganizationURL
See Also

Reference

OrganizationURL Class
OrganizationURL Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationURL Constructor (XmlElement)

Initializes a new instance of the OrganizationURL class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OrganizationURL(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
OrganizationURL(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> OrganizationURL

Parameters

xmlElement
Type: System.XmlXmlElement
The organization URL XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

OrganizationURL Class
OrganizationURL Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationURL Constructor (String, String)

Initializes a new instance of the OrganizationURL class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public OrganizationURL(
    string uri,
    string language
)
Public Sub New (
    uri As String,
    language As String
)
public:
OrganizationURL(
    String^ uri,
    String^ language
)
new :
        uri : string *
        language : string -> OrganizationURL

Parameters

uri
Type: SystemString
The URI.
language
Type: SystemString
The language.
See Also

Reference

OrganizationURL Class
OrganizationURL Overload
ComponentSpace.SAML2.Metadata Namespace


OrganizationURL Properties

The OrganizationURL type exposes the following members.

Properties
 | Name | Description
Public property | Language | Gets or sets the language. (Inherited from LocalizedURIType.)
Public property | URI | Gets or sets the URI. (Inherited from LocalizedURIType.)
Top
See Also

Reference

OrganizationURL Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationURL Methods

The OrganizationURL type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an organization URL.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the localized URI to XML. (Inherited from LocalizedURIType.)
Public method | ToXml(XmlDocument) | Serializes the organization URL to XML.
Top
See Also

Reference

OrganizationURL Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationURL.IsValid Method

OrganizationURLIsValid Method

Indicates whether the XML is an organization URL.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an organization URL; otherwise false.
See Also

Reference

OrganizationURL Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationURL.ToXml Method

OrganizationURLToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlElement) | Serializes the localized URI to XML. (Inherited from LocalizedURIType.)
Public method | ToXml(XmlDocument) | Serializes the organization URL to XML.
Top
See Also

Reference

OrganizationURL Class
ComponentSpace.SAML2.Metadata Namespace


OrganizationURL.ToXml Method (XmlDocument)

OrganizationURLToXml Method (XmlDocument)

Serializes the organization URL to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The organization URL as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

OrganizationURL Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor Class

Represents a PDP descriptor.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataRoleDescriptorType
ComponentSpace.SAML2.MetadataPDPDescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class PDPDescriptor : RoleDescriptorType
Public Class PDPDescriptor
    Inherits RoleDescriptorType
public ref class PDPDescriptor : public RoleDescriptorType
type PDPDescriptor =
    class
        inherit RoleDescriptorType
    end

The PDPDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | PDPDescriptor | Initializes a new instance of the PDPDescriptor class.
Public method | PDPDescriptor(XmlElement) | Initializes a new instance of the PDPDescriptor class from XML.
Top
Properties
 | Name | Description
Public property | AssertionIDRequestServices | Gets or sets the list of assertion ID request services.
Public property | AuthzServices | Gets or sets the list of authorization services.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | NameIDFormats | Gets or sets the list of name ID formats.
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a PDP descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the PDP descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor Constructor

Overload List
 | Name | Description
Public method | PDPDescriptor | Initializes a new instance of the PDPDescriptor class.
Public method | PDPDescriptor(XmlElement) | Initializes a new instance of the PDPDescriptor class from XML.
Top
See Also

Reference

PDPDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor Constructor

Initializes a new instance of the PDPDescriptor class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public PDPDescriptor()
Public Sub New
public:
PDPDescriptor()
new : unit -> PDPDescriptor
See Also

Reference

PDPDescriptor Class
PDPDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor Constructor (XmlElement)

Initializes a new instance of the PDPDescriptor class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public PDPDescriptor(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
PDPDescriptor(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> PDPDescriptor

Parameters

xmlElement
Type: System.XmlXmlElement
The PDP descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

PDPDescriptor Class
PDPDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor Properties

The PDPDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | AssertionIDRequestServices | Gets or sets the list of assertion ID request services.
Public property | AuthzServices | Gets or sets the list of authorization services.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | NameIDFormats | Gets or sets the list of name ID formats.
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

PDPDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor.AssertionIDRequestServices Property

PDPDescriptorAssertionIDRequestServices Property

Gets or sets the list of assertion ID request services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> AssertionIDRequestServices { get; set; }
Public Property AssertionIDRequestServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ AssertionIDRequestServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member AssertionIDRequestServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of assertion ID request services.
See Also

Reference

PDPDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor.AuthzServices Property

PDPDescriptorAuthzServices Property

Gets or sets the list of authorization services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> AuthzServices { get; set; }
Public Property AuthzServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ AuthzServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member AuthzServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of authorization query services.
See Also

Reference

PDPDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor.NameIDFormats Property

PDPDescriptorNameIDFormats Property

Gets or sets the list of name ID formats.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<string> NameIDFormats { get; set; }
Public Property NameIDFormats As IList(Of String)
    Get
    Set
public:
property IList<String^>^ NameIDFormats {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member NameIDFormats : IList<string> with get, set

Property Value

Type: IList String
The list of name ID formats.
See Also

Reference

PDPDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor Methods

The PDPDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a PDP descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlDocument) | Serializes the PDP descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

PDPDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor.IsValid Method

PDPDescriptorIsValid Method

Indicates whether the XML is a PDP descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a PDP descriptor; otherwise false.
See Also

Reference

PDPDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor.ToXml Method

PDPDescriptorToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlDocument) | Serializes the PDP descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

PDPDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


PDPDescriptor.ToXml Method (XmlDocument)

PDPDescriptorToXml Method (XmlDocument)

Serializes the PDP descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The PDP descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

PDPDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


RequestedAttribute Class

Represents a requested attribute.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.AssertionsAttributeType
ComponentSpace.SAML2.MetadataRequestedAttribute

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class RequestedAttribute : AttributeType
Public Class RequestedAttribute
    Inherits AttributeType
public ref class RequestedAttribute : public AttributeType
type RequestedAttribute =
    class
        inherit AttributeType
    end

The RequestedAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RequestedAttribute | Initializes a new instance of the RequestedAttribute class.
Public method | RequestedAttribute(XmlElement) | Initializes a new instance of the RequestedAttribute class from XML.
Top
Properties
 | Name | Description
Public property | FriendlyName | Gets or sets the attribute's friendly name. (Inherited from AttributeType.)
Public property | IsRequired | Gets or sets the is required flag.
Public property | Name | Gets or sets the attribute's name. (Inherited from AttributeType.)
Public property | NameFormat | Gets or sets the attribute's name format. (Inherited from AttributeType.)
Public property | Values | Gets or sets the attribute values. (Inherited from AttributeType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a requested attribute.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the attribute type to XML. (Inherited from AttributeType.)
Public method | ToXml(XmlDocument) | Serializes the requested attribute to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


RequestedAttribute Constructor

Overload List
 | Name | Description
Public method | RequestedAttribute | Initializes a new instance of the RequestedAttribute class.
Public method | RequestedAttribute(XmlElement) | Initializes a new instance of the RequestedAttribute class from XML.
Top
See Also

Reference

RequestedAttribute Class
ComponentSpace.SAML2.Metadata Namespace


RequestedAttribute Constructor

Initializes a new instance of the RequestedAttribute class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequestedAttribute()
Public Sub New
public:
RequestedAttribute()
new : unit -> RequestedAttribute
See Also

Reference

RequestedAttribute Class
RequestedAttribute Overload
ComponentSpace.SAML2.Metadata Namespace


RequestedAttribute Constructor (XmlElement)

Initializes a new instance of the RequestedAttribute class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequestedAttribute(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
RequestedAttribute(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> RequestedAttribute

Parameters

xmlElement
Type: System.XmlXmlElement
The requested attribute XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

RequestedAttribute Class
RequestedAttribute Overload
ComponentSpace.SAML2.Metadata Namespace


RequestedAttribute Properties

The RequestedAttribute type exposes the following members.

Properties
 | Name | Description
Public property | FriendlyName | Gets or sets the attribute's friendly name. (Inherited from AttributeType.)
Public property | IsRequired | Gets or sets the is required flag.
Public property | Name | Gets or sets the attribute's name. (Inherited from AttributeType.)
Public property | NameFormat | Gets or sets the attribute's name format. (Inherited from AttributeType.)
Public property | Values | Gets or sets the attribute values. (Inherited from AttributeType.)
Top
See Also

Reference

RequestedAttribute Class
ComponentSpace.SAML2.Metadata Namespace


RequestedAttribute.IsRequired Property

RequestedAttributeIsRequired Property

Gets or sets the is required flag.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool IsRequired { get; set; }
Public Property IsRequired As Boolean
    Get
    Set
public:
property bool IsRequired {
    bool get ();
    void set (bool value);
}
member IsRequired : bool with get, set

Property Value

Type: Boolean
The is required flag.
See Also

Reference

RequestedAttribute Class
ComponentSpace.SAML2.Metadata Namespace


RequestedAttribute Methods

The RequestedAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a requested attribute.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml(XmlElement) | Serializes the attribute type to XML. (Inherited from AttributeType.)
Public method | ToXml(XmlDocument) | Serializes the requested attribute to XML.
Top
See Also

Reference

RequestedAttribute Class
ComponentSpace.SAML2.Metadata Namespace


RequestedAttribute.IsValid Method

RequestedAttributeIsValid Method

Indicates whether the XML is a requested attribute.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an attribute consuming service; otherwise false.
See Also

Reference

RequestedAttribute Class
ComponentSpace.SAML2.Metadata Namespace


RequestedAttribute.ToXml Method

RequestedAttributeToXml Method

Overload List
 | Name | Description
Public method | ToXml(XmlElement) | Serializes the attribute type to XML. (Inherited from AttributeType.)
Public method | ToXml(XmlDocument) | Serializes the requested attribute to XML.
Top
See Also

Reference

RequestedAttribute Class
ComponentSpace.SAML2.Metadata Namespace


RequestedAttribute.ToXml Method (XmlDocument)

RequestedAttributeToXml Method (XmlDocument)

Serializes the requested attribute to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The requested attribute as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

RequestedAttribute Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptor Class

Represents a role descriptor.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataRoleDescriptorType
ComponentSpace.SAML2.MetadataRoleDescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class RoleDescriptor : RoleDescriptorType
Public Class RoleDescriptor
    Inherits RoleDescriptorType
public ref class RoleDescriptor : public RoleDescriptorType
type RoleDescriptor =
    class
        inherit RoleDescriptorType
    end

The RoleDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | RoleDescriptor | Initializes a new instance of the RoleDescriptor class.
Public method | RoleDescriptor(XmlElement) | Initializes a new instance of the RoleDescriptor class from XML.
Top
Properties
 | Name | Description
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a role descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the role descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the role descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


RoleDescriptor Constructor

Overload List
 | Name | Description
Public method | RoleDescriptor | Initializes a new instance of the RoleDescriptor class.
Public method | RoleDescriptor(XmlElement) | Initializes a new instance of the RoleDescriptor class from XML.
Top
See Also

Reference

RoleDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptor Constructor

Initializes a new instance of the RoleDescriptor class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RoleDescriptor()
Public Sub New
public:
RoleDescriptor()
new : unit -> RoleDescriptor
See Also

Reference

RoleDescriptor Class
RoleDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptor Constructor (XmlElement)

Initializes a new instance of the RoleDescriptor class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RoleDescriptor(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
RoleDescriptor(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> RoleDescriptor

Parameters

xmlElement
Type: System.XmlXmlElement
The role descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

RoleDescriptor Class
RoleDescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptor Properties

The RoleDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

RoleDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptor Methods

The RoleDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a role descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the role descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the role descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

RoleDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptor.IsValid Method

RoleDescriptorIsValid Method

Indicates whether the XML is a role descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a role descriptor; otherwise false.
See Also

Reference

RoleDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptor.ToXml Method

RoleDescriptorToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the role descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the role descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the role descriptor to XML. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

RoleDescriptor Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptor.ToXml Method

RoleDescriptorToXml Method

Serializes the role descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The role descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

RoleDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptor.ToXml Method (XmlDocument)

RoleDescriptorToXml Method (XmlDocument)

Serializes the role descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The role descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

RoleDescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType Class

Represents the role descriptor type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataRoleDescriptorType
ComponentSpace.SAML2.MetadataAttributeAuthorityDescriptor
ComponentSpace.SAML2.MetadataAuthnAuthorityDescriptor
ComponentSpace.SAML2.MetadataPDPDescriptor
ComponentSpace.SAML2.MetadataRoleDescriptor
ComponentSpace.SAML2.MetadataSSODescriptorType

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class RoleDescriptorType
Public MustInherit Class RoleDescriptorType
public ref class RoleDescriptorType abstract
[<AbstractClassAttribute>]
type RoleDescriptorType =  class end

The RoleDescriptorType type exposes the following members.

Constructors
 | Name | Description
Public method | RoleDescriptorType | Initializes a new instance of the RoleDescriptorType class.
Public method | RoleDescriptorType(XmlElement) | Initializes a new instance of the RoleDescriptorType class from XML.
Top
Properties
 | Name | Description
Public property | CacheDuration | Gets or sets the cache duration.
Public property | ContactPeople | Gets or sets the list of contact people.
Public property | ErrorURL | Gets or sets the error URL.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | KeyDescriptors | Gets or sets the list of key descriptors.
Public property | Organization | Gets or sets the organization.
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration.
Public property | Signature | Gets or sets the digital signature.
Public property | ValidUntil | Gets or sets the valid until date/time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the role descriptor to XML.
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType Constructor

Overload List
 | Name | Description
Public method | RoleDescriptorType | Initializes a new instance of the RoleDescriptorType class.
Public method | RoleDescriptorType(XmlElement) | Initializes a new instance of the RoleDescriptorType class from XML.
Top
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType Constructor

Initializes a new instance of the RoleDescriptorType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RoleDescriptorType()
Public Sub New
public:
RoleDescriptorType()
new : unit -> RoleDescriptorType
See Also

Reference

RoleDescriptorType Class
RoleDescriptorType Overload
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType Constructor (XmlElement)

Initializes a new instance of the RoleDescriptorType class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RoleDescriptorType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
RoleDescriptorType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> RoleDescriptorType

Parameters

xmlElement
Type: System.XmlXmlElement
The role descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

RoleDescriptorType Class
RoleDescriptorType Overload
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType Properties

The RoleDescriptorType type exposes the following members.

Properties
 | Name | Description
Public property | CacheDuration | Gets or sets the cache duration.
Public property | ContactPeople | Gets or sets the list of contact people.
Public property | ErrorURL | Gets or sets the error URL.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | KeyDescriptors | Gets or sets the list of key descriptors.
Public property | Organization | Gets or sets the organization.
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration.
Public property | Signature | Gets or sets the digital signature.
Public property | ValidUntil | Gets or sets the valid until date/time.
Top
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType.CacheDuration Property

RoleDescriptorTypeCacheDuration Property

Gets or sets the cache duration.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Duration CacheDuration { get; set; }
Public Property CacheDuration As Duration
    Get
    Set
public:
property Duration^ CacheDuration {
    Duration^ get ();
    void set (Duration^ value);
}
member CacheDuration : Duration with get, set

Property Value

Type: Duration
The cache duration.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType.ContactPeople Property

RoleDescriptorTypeContactPeople Property

Gets or sets the list of contact people.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<ContactPerson> ContactPeople { get; set; }
Public Property ContactPeople As IList(Of ContactPerson)
    Get
    Set
public:
property IList<ContactPerson^>^ ContactPeople {
    IList<ContactPerson^>^ get ();
    void set (IList<ContactPerson^>^ value);
}
member ContactPeople : IList<ContactPerson> with get, set

Property Value

Type: IList ContactPerson
The list of contact people.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType.ErrorURL Property

RoleDescriptorTypeErrorURL Property

Gets or sets the error URL.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ErrorURL { get; set; }
Public Property ErrorURL As String
    Get
    Set
public:
property String^ ErrorURL {
    String^ get ();
    void set (String^ value);
}
member ErrorURL : string with get, set

Property Value

Type: String
The error URL.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType.Extensions Property

RoleDescriptorTypeExtensions Property

Gets or sets the extensions.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions Extensions { get; set; }
Public Property Extensions As Extensions
    Get
    Set
public:
property Extensions^ Extensions {
    Extensions^ get ();
    void set (Extensions^ value);
}
member Extensions : Extensions with get, set

Property Value

Type: Extensions
The extensions.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType.ID Property

RoleDescriptorTypeID Property

Gets or sets the ID.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
The ID.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType.KeyDescriptors Property

RoleDescriptorTypeKeyDescriptors Property

Gets or sets the list of key descriptors.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<KeyDescriptor> KeyDescriptors { get; set; }
Public Property KeyDescriptors As IList(Of KeyDescriptor)
    Get
    Set
public:
property IList<KeyDescriptor^>^ KeyDescriptors {
    IList<KeyDescriptor^>^ get ();
    void set (IList<KeyDescriptor^>^ value);
}
member KeyDescriptors : IList<KeyDescriptor> with get, set

Property Value

Type: IList KeyDescriptor
The list of key descriptors.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType.Organization Property

RoleDescriptorTypeOrganization Property

Gets or sets the organization.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Organization Organization { get; set; }
Public Property Organization As Organization
    Get
    Set
public:
property Organization^ Organization {
    Organization^ get ();
    void set (Organization^ value);
}
member Organization : Organization with get, set

Property Value

Type: Organization
The organization.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType.ProtocolSupportEnumeration Property

RoleDescriptorTypeProtocolSupportEnumeration Property

Gets or sets the protocol support enumeration.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ProtocolSupportEnumeration { get; set; }
Public Property ProtocolSupportEnumeration As String
    Get
    Set
public:
property String^ ProtocolSupportEnumeration {
    String^ get ();
    void set (String^ value);
}
member ProtocolSupportEnumeration : string with get, set

Property Value

Type: String
The protocol support enumeration.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType.Signature Property

RoleDescriptorTypeSignature Property

Gets or sets the digital signature.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement Signature { get; set; }
Public Property Signature As XmlElement
    Get
    Set
public:
property XmlElement^ Signature {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member Signature : XmlElement with get, set

Property Value

Type: XmlElement
The digital signature.
Remarks
To generate or verify signatures, use SAMLMetadataSignature.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace
ComponentSpace.SAML2.MetadataSAMLMetadataSignature


RoleDescriptorType.ValidUntil Property

RoleDescriptorTypeValidUntil Property

Gets or sets the valid until date/time.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime ValidUntil { get; set; }
Public Property ValidUntil As DateTime
    Get
    Set
public:
property DateTime ValidUntil {
    DateTime get ();
    void set (DateTime value);
}
member ValidUntil : DateTime with get, set

Property Value

Type: DateTime
The valid until date/time.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType Methods

The RoleDescriptorType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the role descriptor to XML.
Top
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


RoleDescriptorType.ToXml Method

RoleDescriptorTypeToXml Method

Serializes the role descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void ToXml(
    XmlElement xmlElement
)
Public Overridable Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
)
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

RoleDescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature Class

Permits XML signature generation and verification for SAML metadata.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataSAMLMetadataSignature

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAMLMetadataSignature
Public NotInheritable Class SAMLMetadataSignature
public ref class SAMLMetadataSignature abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAMLMetadataSignature =  class end

The SAMLMetadataSignature type exposes the following members.

Methods
Name | Description
Generate(XmlElement, AsymmetricAlgorithm) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String) | Generates an XML signature and adds it to the metadata.
GetCertificate | Gets the X.509 certificate embedded in the XML signature or null if none.
GetKeyInfo | Gets the key info embedded in the XML signature or null if none.
IsSigned | Indicates whether the metadata contains an XML signature.
RemoveSignature | Removes the XML signature, if any, from the metadata.
Verify(XmlElement) | Verifies the XML signature.
Verify(XmlElement, AsymmetricAlgorithm) | Verifies the XML signature.
Verify(XmlElement, X509Certificate2) | Verifies the XML signature.
Verify(XmlElement, KeyInfo) | Verifies the XML signature.
Verify(XmlElement, KeyInfoX509Data) | Verifies the XML signature.
Top
Fields
Name | Description
DefaultInclusiveNamespacesPrefixList | The default inclusive namespace prefix list.
Top
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature Methods

The SAMLMetadataSignature type exposes the following members.

Methods
Name | Description
Generate(XmlElement, AsymmetricAlgorithm) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String) | Generates an XML signature and adds it to the metadata.
GetCertificate | Gets the X.509 certificate embedded in the XML signature or null if none.
GetKeyInfo | Gets the key info embedded in the XML signature or null if none.
IsSigned | Indicates whether the metadata contains an XML signature.
RemoveSignature | Removes the XML signature, if any, from the metadata.
Verify(XmlElement) | Verifies the XML signature.
Verify(XmlElement, AsymmetricAlgorithm) | Verifies the XML signature.
Verify(XmlElement, X509Certificate2) | Verifies the XML signature.
Verify(XmlElement, KeyInfo) | Verifies the XML signature.
Verify(XmlElement, KeyInfoX509Data) | Verifies the XML signature.
Top
See Also

Reference

SAMLMetadataSignature Class
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method

SAMLMetadataSignatureGenerate Method

Overload List
Name | Description
Generate(XmlElement, AsymmetricAlgorithm) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String) | Generates an XML signature and adds it to the metadata.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String) | Generates an XML signature and adds it to the metadata.
Top
See Also

Reference

SAMLMetadataSignature Class
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method (XmlElement, AsymmetricAlgorithm)

SAMLMetadataSignatureGenerate Method (XmlElement, AsymmetricAlgorithm)

Generates an XML signature and adds it to the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the metadata. The signature is created using the supplied signing key.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMetadataSignature Class
Generate Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2)

SAMLMetadataSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2)

Generates an XML signature and adds it to the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2 x509Certificate
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificate As X509Certificate2
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2^ x509Certificate
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificate : X509Certificate2 -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate to include in the key info.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the metadata. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificate, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMetadataSignature Class
Generate Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection)

SAMLMetadataSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection)

Generates an XML signature and adds it to the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2Collection x509Certificates
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificates As X509Certificate2Collection
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2Collection^ x509Certificates
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificates : X509Certificate2Collection -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificates
Type: System.Security.Cryptography.X509CertificatesX509Certificate2Collection
The list of X.509 certificate to include in the key info.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the metadata. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificates, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMetadataSignature Class
Generate Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfo)

SAMLMetadataSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfo)

Generates an XML signature and adds it to the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfo keyInfo
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfo As KeyInfo
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfo^ keyInfo
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfo : KeyInfo -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include in the signature.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the metadata. The signature is created using the supplied signing key. The key info will be included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMetadataSignature Class
Generate Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data)

SAMLMetadataSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data)

Generates an XML signature and adds it to the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfoX509Data keyInfoX509Data
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfoX509Data As KeyInfoX509Data
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfoX509Data^ keyInfoX509Data
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfoX509Data : KeyInfoX509Data -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfoX509Data
Type: System.Security.Cryptography.XmlKeyInfoX509Data
The X.509 data to include in the signature.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the metadata. The signature is created using the supplied signing key. Key info, using the supplied X.509 data, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMetadataSignature Class
Generate Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method (XmlElement, AsymmetricAlgorithm, String, String, String)

SAMLMetadataSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, String, String, String)

Generates an XML signature and adds it to the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default md saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the metadata. The signature is created using the supplied signing key.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMetadataSignature Class
Generate Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String)

SAMLMetadataSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String)

Generates an XML signature and adds it to the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2 x509Certificate,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificate As X509Certificate2,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2^ x509Certificate,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificate : X509Certificate2 *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate to include in the key info.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default md saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the metadata. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificate, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMetadataSignature Class
Generate Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String)

SAMLMetadataSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String)

Generates an XML signature and adds it to the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2Collection x509Certificates,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificates As X509Certificate2Collection,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2Collection^ x509Certificates,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificates : X509Certificate2Collection *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificates
Type: System.Security.Cryptography.X509CertificatesX509Certificate2Collection
The list of X.509 certificate to include in the key info.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default md saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the metadata. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificates, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMetadataSignature Class
Generate Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String)

SAMLMetadataSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String)

Generates an XML signature and adds it to the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfo keyInfo,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfo As KeyInfo,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfo^ keyInfo,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfo : KeyInfo *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include in the signature.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default md saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the metadata. The signature is created using the supplied signing key. The key info will be included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMetadataSignature Class
Generate Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String)

SAMLMetadataSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String)

Generates an XML signature and adds it to the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfoX509Data keyInfoX509Data,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfoX509Data As KeyInfoX509Data,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfoX509Data^ keyInfoX509Data,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfoX509Data : KeyInfoX509Data *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfoX509Data
Type: System.Security.Cryptography.XmlKeyInfoX509Data
The X.509 data to include in the signature.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default md saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the metadata. The signature is created using the supplied signing key. Key info, using the supplied X.509 data, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMetadataSignature Class
Generate Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.GetCertificate Method

SAMLMetadataSignatureGetCertificate Method

Gets the X.509 certificate embedded in the XML signature or null if none.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static X509Certificate2 GetCertificate(
    XmlElement xmlElement
)
Public Shared Function GetCertificate (
    xmlElement As XmlElement
) As X509Certificate2
public:
static X509Certificate2^ GetCertificate(
    XmlElement^ xmlElement
)
static member GetCertificate :
        xmlElement : XmlElement -> X509Certificate2

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata containing the signature with X.509 certificate.

Return Value

Type: X509Certificate2
The X.509 certificate embedded in the XML signature or null if none.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the X.509 certificate retrieval fails.
See Also

Reference

SAMLMetadataSignature Class
ComponentSpace.SAML2.Metadata Namespace
SAMLMetadataSignatureGetKeyInfo(XmlElement)


SAMLMetadataSignature.GetKeyInfo Method

SAMLMetadataSignatureGetKeyInfo Method

Gets the key info embedded in the XML signature or null if none.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static KeyInfo GetKeyInfo(
    XmlElement xmlElement
)
Public Shared Function GetKeyInfo (
    xmlElement As XmlElement
) As KeyInfo
public:
static KeyInfo^ GetKeyInfo(
    XmlElement^ xmlElement
)
static member GetKeyInfo :
        xmlElement : XmlElement -> KeyInfo

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata containing the signature with key info.

Return Value

Type: KeyInfo
The key info embedded in the XML signature or null if none.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the key info retrieval fails.
See Also

Reference

SAMLMetadataSignature Class
ComponentSpace.SAML2.Metadata Namespace
SAMLMetadataSignatureGetCertificate(XmlElement)


SAMLMetadataSignature.IsSigned Method

SAMLMetadataSignatureIsSigned Method

Indicates whether the metadata contains an XML signature.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSigned(
    XmlElement xmlElement
)
Public Shared Function IsSigned (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsSigned(
    XmlElement^ xmlElement
)
static member IsSigned :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata.

Return Value

Type: Boolean
true if the XML contains an XML signature; otherwise false.
See Also

Reference

SAMLMetadataSignature Class
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.RemoveSignature Method

SAMLMetadataSignatureRemoveSignature Method

Removes the XML signature, if any, from the metadata.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void RemoveSignature(
    XmlElement xmlElement
)
Public Shared Sub RemoveSignature (
    xmlElement As XmlElement
)
public:
static void RemoveSignature(
    XmlElement^ xmlElement
)
static member RemoveSignature :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata.
See Also

Reference

SAMLMetadataSignature Class
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Verify Method

SAMLMetadataSignatureVerify Method

Overload List
Name | Description
Verify(XmlElement) | Verifies the XML signature.
Verify(XmlElement, AsymmetricAlgorithm) | Verifies the XML signature.
Verify(XmlElement, X509Certificate2) | Verifies the XML signature.
Verify(XmlElement, KeyInfo) | Verifies the XML signature.
Verify(XmlElement, KeyInfoX509Data) | Verifies the XML signature.
Top
See Also

Reference

SAMLMetadataSignature Class
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Verify Method (XmlElement)

SAMLMetadataSignatureVerify Method (XmlElement)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement
)
Public Shared Function Verify (
    xmlElement As XmlElement
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement
)
static member Verify :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata containing the signature to verify.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The key info included with the signature is used to perform the verification.
See Also

Reference

SAMLMetadataSignature Class
Verify Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Verify Method (XmlElement, AsymmetricAlgorithm)

SAMLMetadataSignatureVerify Method (XmlElement, AsymmetricAlgorithm)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey
)
static member Verify :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata containing the signature to verify.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The public key used to perform the verification or null if none.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied public key is used to perform the verification.
See Also

Reference

SAMLMetadataSignature Class
Verify Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Verify Method (XmlElement, X509Certificate2)

SAMLMetadataSignatureVerify Method (XmlElement, X509Certificate2)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    X509Certificate2 x509Certificate
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    x509Certificate As X509Certificate2
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    X509Certificate2^ x509Certificate
)
static member Verify :
        xmlElement : XmlElement *
        x509Certificate : X509Certificate2 -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata containing the signature to verify.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used to perform the verification.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied X.509 certificate is used to perform the verification.
See Also

Reference

SAMLMetadataSignature Class
Verify Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Verify Method (XmlElement, KeyInfo)

SAMLMetadataSignatureVerify Method (XmlElement, KeyInfo)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    KeyInfo keyInfo
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    keyInfo As KeyInfo
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    KeyInfo^ keyInfo
)
static member Verify :
        xmlElement : XmlElement *
        keyInfo : KeyInfo -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata containing the signature to verify.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info used to perform the verification or null if none.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied key info is used to perform the verification.
See Also

Reference

SAMLMetadataSignature Class
Verify Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.Verify Method (XmlElement, KeyInfoX509Data)

SAMLMetadataSignatureVerify Method (XmlElement, KeyInfoX509Data)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    KeyInfoX509Data keyInfoX509Data
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    keyInfoX509Data As KeyInfoX509Data
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    KeyInfoX509Data^ keyInfoX509Data
)
static member Verify :
        xmlElement : XmlElement *
        keyInfoX509Data : KeyInfoX509Data -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The metadata containing the signature to verify.
keyInfoX509Data
Type: System.Security.Cryptography.XmlKeyInfoX509Data
The X.509 data used to perform the verification or null if none.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied X.509 data is used to perform the verification.
See Also

Reference

SAMLMetadataSignature Class
Verify Overload
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature Fields

The SAMLMetadataSignature type exposes the following members.

Fields
Name | Description
DefaultInclusiveNamespacesPrefixList | The default inclusive namespace prefix list.
Top
See Also

Reference

SAMLMetadataSignature Class
ComponentSpace.SAML2.Metadata Namespace


SAMLMetadataSignature.DefaultInclusiveNamespacesPrefixList Field

SAMLMetadataSignatureDefaultInclusiveNamespacesPrefixList Field

The default inclusive namespace prefix list.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string DefaultInclusiveNamespacesPrefixList = "#default md saml ds xs xsi"
Public Const DefaultInclusiveNamespacesPrefixList As String = "#default md saml ds xs xsi"
public:
literal String^ DefaultInclusiveNamespacesPrefixList = "#default md saml ds xs xsi"
static val mutable DefaultInclusiveNamespacesPrefixList: string

Field Value

Type: String
See Also

Reference

SAMLMetadataSignature Class
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor Class

Represents an SP SSO descriptor.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataRoleDescriptorType
ComponentSpace.SAML2.MetadataSSODescriptorType
ComponentSpace.SAML2.MetadataSPSSODescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SPSSODescriptor : SSODescriptorType
Public Class SPSSODescriptor
    Inherits SSODescriptorType
public ref class SPSSODescriptor : public SSODescriptorType
type SPSSODescriptor =
    class
        inherit SSODescriptorType
    end

The SPSSODescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | SPSSODescriptor | Initializes a new instance of the SPSSODescriptor class.
Public method | SPSSODescriptor(XmlElement) | Initializes a new instance of the SPSSODescriptor class from XML.
Top
Properties
 | Name | Description
Public property | ArtifactResolutionServices | Gets or sets the list of artifact resolution services. (Inherited from SSODescriptorType.)
Public property | AssertionConsumerServices | Gets or sets the list of assertion consumer services.
Public property | AttributeConsumingServices | Gets or sets the list of attribute consuming services.
Public property | AuthnRequestsSigned | Gets or sets the flag indicating authentication requests are signed.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | ManageNameIDServices | Gets or sets the list of manage name ID services. (Inherited from SSODescriptorType.)
Public property | NameIDFormats | Gets or sets the list of name ID formats. (Inherited from SSODescriptorType.)
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | SingleLogoutServices | Gets or sets the list of single logout services. (Inherited from SSODescriptorType.)
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Public property | WantAssertionsSigned | Gets or sets the flag indicating whether want assertions signed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an SP SSO descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the SP SSO descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the SP SSO descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the SSO descriptor to XML. (Inherited from SSODescriptorType.)
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor Constructor

Overload List
 | Name | Description
Public method | SPSSODescriptor | Initializes a new instance of the SPSSODescriptor class.
Public method | SPSSODescriptor(XmlElement) | Initializes a new instance of the SPSSODescriptor class from XML.
Top
See Also

Reference

SPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor Constructor

Initializes a new instance of the SPSSODescriptor class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SPSSODescriptor()
Public Sub New
public:
SPSSODescriptor()
new : unit -> SPSSODescriptor
See Also

Reference

SPSSODescriptor Class
SPSSODescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor Constructor (XmlElement)

Initializes a new instance of the SPSSODescriptor class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SPSSODescriptor(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SPSSODescriptor(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SPSSODescriptor

Parameters

xmlElement
Type: System.XmlXmlElement
The SP SSO descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SPSSODescriptor Class
SPSSODescriptor Overload
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor Properties

The SPSSODescriptor type exposes the following members.

Properties
 | Name | Description
Public property | ArtifactResolutionServices | Gets or sets the list of artifact resolution services. (Inherited from SSODescriptorType.)
Public property | AssertionConsumerServices | Gets or sets the list of assertion consumer services.
Public property | AttributeConsumingServices | Gets or sets the list of attribute consuming services.
Public property | AuthnRequestsSigned | Gets or sets the flag indicating authentication requests are signed.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | ManageNameIDServices | Gets or sets the list of manage name ID services. (Inherited from SSODescriptorType.)
Public property | NameIDFormats | Gets or sets the list of name ID formats. (Inherited from SSODescriptorType.)
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | SingleLogoutServices | Gets or sets the list of single logout services. (Inherited from SSODescriptorType.)
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Public property | WantAssertionsSigned | Gets or sets the flag indicating whether want assertions signed.
Top
See Also

Reference

SPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor.AssertionConsumerServices Property

SPSSODescriptorAssertionConsumerServices Property

Gets or sets the list of assertion consumer services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<IndexedEndpointType> AssertionConsumerServices { get; set; }
Public Property AssertionConsumerServices As IList(Of IndexedEndpointType)
    Get
    Set
public:
property IList<IndexedEndpointType^>^ AssertionConsumerServices {
    IList<IndexedEndpointType^>^ get ();
    void set (IList<IndexedEndpointType^>^ value);
}
member AssertionConsumerServices : IList<IndexedEndpointType> with get, set

Property Value

Type: IList IndexedEndpointType
The list of assertion consumer services.
See Also

Reference

SPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor.AttributeConsumingServices Property

SPSSODescriptorAttributeConsumingServices Property

Gets or sets the list of attribute consuming services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<AttributeConsumingService> AttributeConsumingServices { get; set; }
Public Property AttributeConsumingServices As IList(Of AttributeConsumingService)
    Get
    Set
public:
property IList<AttributeConsumingService^>^ AttributeConsumingServices {
    IList<AttributeConsumingService^>^ get ();
    void set (IList<AttributeConsumingService^>^ value);
}
member AttributeConsumingServices : IList<AttributeConsumingService> with get, set

Property Value

Type: IList AttributeConsumingService
The list of attribute consuming services.
See Also

Reference

SPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor.AuthnRequestsSigned Property

SPSSODescriptorAuthnRequestsSigned Property

Gets or sets the flag indicating authentication requests are signed.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool AuthnRequestsSigned { get; set; }
Public Property AuthnRequestsSigned As Boolean
    Get
    Set
public:
property bool AuthnRequestsSigned {
    bool get ();
    void set (bool value);
}
member AuthnRequestsSigned : bool with get, set

Property Value

Type: Boolean
The flag indicating authentication requests are signed.
See Also

Reference

SPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor.WantAssertionsSigned Property

SPSSODescriptorWantAssertionsSigned Property

Gets or sets the flag indicating whether want assertions signed.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool WantAssertionsSigned { get; set; }
Public Property WantAssertionsSigned As Boolean
    Get
    Set
public:
property bool WantAssertionsSigned {
    bool get ();
    void set (bool value);
}
member WantAssertionsSigned : bool with get, set

Property Value

Type: Boolean
The flag indicating whether want assertions signed.
See Also

Reference

SPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor Methods

The SPSSODescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an SP SSO descriptor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the SP SSO descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the SP SSO descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the SSO descriptor to XML. (Inherited from SSODescriptorType.)
Top
See Also

Reference

SPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor.IsValid Method

SPSSODescriptorIsValid Method

Indicates whether the XML is an SP SSO descriptor.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an SP SSO descriptor; otherwise false.
See Also

Reference

SPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor.ToXml Method

SPSSODescriptorToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the SP SSO descriptor to XML.
Public method | ToXml(XmlDocument) | Serializes the SP SSO descriptor to XML.
Public method | ToXml(XmlElement) | Serializes the SSO descriptor to XML. (Inherited from SSODescriptorType.)
Top
See Also

Reference

SPSSODescriptor Class
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor.ToXml Method

SPSSODescriptorToXml Method

Serializes the SP SSO descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The SP SSO descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

SPSSODescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


SPSSODescriptor.ToXml Method (XmlDocument)

SPSSODescriptorToXml Method (XmlDocument)

Serializes the SP SSO descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The SP SSO descriptor as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SPSSODescriptor Class
ToXml Overload
ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType Class

Represents the SSO descriptor type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.MetadataRoleDescriptorType
ComponentSpace.SAML2.MetadataSSODescriptorType
ComponentSpace.SAML2.MetadataIDPSSODescriptor
ComponentSpace.SAML2.MetadataSPSSODescriptor

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class SSODescriptorType : RoleDescriptorType
Public MustInherit Class SSODescriptorType
    Inherits RoleDescriptorType
public ref class SSODescriptorType abstract : public RoleDescriptorType
[<AbstractClassAttribute>]
type SSODescriptorType =
    class
        inherit RoleDescriptorType
    end

The SSODescriptorType type exposes the following members.

Constructors
 | Name | Description
Public method | SSODescriptorType | Initializes a new instance of the SSODescriptorType class.
Public method | SSODescriptorType(XmlElement) | Initializes a new instance of the SSODescriptorType class from XML.
Top
Properties
 | Name | Description
Public property | ArtifactResolutionServices | Gets or sets the list of artifact resolution services.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | ManageNameIDServices | Gets or sets the list of manage name ID services.
Public property | NameIDFormats | Gets or sets the list of name ID formats.
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | SingleLogoutServices | Gets or sets the list of single logout services.
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the SSO descriptor to XML. (Overrides RoleDescriptorTypeToXml(XmlElement).)
Top
Remarks
Refer to the Metadata for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType Constructor

Overload List
 | Name | Description
Public method | SSODescriptorType | Initializes a new instance of the SSODescriptorType class.
Public method | SSODescriptorType(XmlElement) | Initializes a new instance of the SSODescriptorType class from XML.
Top
See Also

Reference

SSODescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType Constructor

Initializes a new instance of the SSODescriptorType class.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SSODescriptorType()
Public Sub New
public:
SSODescriptorType()
new : unit -> SSODescriptorType
See Also

Reference

SSODescriptorType Class
SSODescriptorType Overload
ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType Constructor (XmlElement)

Initializes a new instance of the SSODescriptorType class from XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SSODescriptorType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SSODescriptorType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SSODescriptorType

Parameters

xmlElement
Type: System.XmlXmlElement
The SSO descriptor XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SSODescriptorType Class
SSODescriptorType Overload
ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType Properties

The SSODescriptorType type exposes the following members.

Properties
 | Name | Description
Public property | ArtifactResolutionServices | Gets or sets the list of artifact resolution services.
Public property | CacheDuration | Gets or sets the cache duration. (Inherited from RoleDescriptorType.)
Public property | ContactPeople | Gets or sets the list of contact people. (Inherited from RoleDescriptorType.)
Public property | ErrorURL | Gets or sets the error URL. (Inherited from RoleDescriptorType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RoleDescriptorType.)
Public property | ID | Gets or sets the ID. (Inherited from RoleDescriptorType.)
Public property | KeyDescriptors | Gets or sets the list of key descriptors. (Inherited from RoleDescriptorType.)
Public property | ManageNameIDServices | Gets or sets the list of manage name ID services.
Public property | NameIDFormats | Gets or sets the list of name ID formats.
Public property | Organization | Gets or sets the organization. (Inherited from RoleDescriptorType.)
Public property | ProtocolSupportEnumeration | Gets or sets the protocol support enumeration. (Inherited from RoleDescriptorType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RoleDescriptorType.)
Public property | SingleLogoutServices | Gets or sets the list of single logout services.
Public property | ValidUntil | Gets or sets the valid until date/time. (Inherited from RoleDescriptorType.)
Top
See Also

Reference

SSODescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType.ArtifactResolutionServices Property

SSODescriptorTypeArtifactResolutionServices Property

Gets or sets the list of artifact resolution services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<IndexedEndpointType> ArtifactResolutionServices { get; set; }
Public Property ArtifactResolutionServices As IList(Of IndexedEndpointType)
    Get
    Set
public:
property IList<IndexedEndpointType^>^ ArtifactResolutionServices {
    IList<IndexedEndpointType^>^ get ();
    void set (IList<IndexedEndpointType^>^ value);
}
member ArtifactResolutionServices : IList<IndexedEndpointType> with get, set

Property Value

Type: IList IndexedEndpointType
The list of artifact resolution services.
See Also

Reference

SSODescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType.ManageNameIDServices Property

SSODescriptorTypeManageNameIDServices Property

Gets or sets the list of manage name ID services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> ManageNameIDServices { get; set; }
Public Property ManageNameIDServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ ManageNameIDServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member ManageNameIDServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of manage name ID services.
See Also

Reference

SSODescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType.NameIDFormats Property

SSODescriptorTypeNameIDFormats Property

Gets or sets the list of name ID formats.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<string> NameIDFormats { get; set; }
Public Property NameIDFormats As IList(Of String)
    Get
    Set
public:
property IList<String^>^ NameIDFormats {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member NameIDFormats : IList<string> with get, set

Property Value

Type: IList String
The list of name ID formats.
See Also

Reference

SSODescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType.SingleLogoutServices Property

SSODescriptorTypeSingleLogoutServices Property

Gets or sets the list of single logout services.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EndpointType> SingleLogoutServices { get; set; }
Public Property SingleLogoutServices As IList(Of EndpointType)
    Get
    Set
public:
property IList<EndpointType^>^ SingleLogoutServices {
    IList<EndpointType^>^ get ();
    void set (IList<EndpointType^>^ value);
}
member SingleLogoutServices : IList<EndpointType> with get, set

Property Value

Type: IList EndpointType
The list of single logout services.
See Also

Reference

SSODescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType Methods

The SSODescriptorType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the SSO descriptor to XML. (Overrides RoleDescriptorTypeToXml(XmlElement).)
Top
See Also

Reference

SSODescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


SSODescriptorType.ToXml Method

SSODescriptorTypeToXml Method

Serializes the SSO descriptor to XML.

Namespace: ComponentSpace.SAML2.Metadata
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    XmlElement xmlElement
)
Public Overrides Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
) override
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SSODescriptorType Class
ComponentSpace.SAML2.Metadata Namespace


ComponentSpace.SAML2.Notifications Namespace

The ComponentSpace.SAML2.Notifications namespace contains classes to support observers receiving notifications associated with SAML SSO and logout.
Classes
 | Class | Description
Public class | AbstractSAMLObserver | A SAML observer receives notifications as part of SAML single sign-on and logout.
Public class | SAMLObservable | A SAML observable sends notifications to observers as part of SAML single sign-on and logout.
Public class | TraceSAMLObserver | A trace SAML observer writes notifications to the trace log.
Interfaces
 | Interface | Description
Public interface | ISAMLObserver | A SAML observer receives notifications as part of SAML single sign-on and logout.


AbstractSAMLObserver Class

A SAML observer receives notifications as part of SAML single sign-on and logout.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.NotificationsAbstractSAMLObserver
ComponentSpace.SAML2.NotificationsTraceSAMLObserver

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class AbstractSAMLObserver : ISAMLObserver
Public MustInherit Class AbstractSAMLObserver
    Implements ISAMLObserver
public ref class AbstractSAMLObserver abstract : ISAMLObserver
[<AbstractClassAttribute>]
type AbstractSAMLObserver =
    class
        interface ISAMLObserver
    end

The AbstractSAMLObserver type exposes the following members.

Constructors
 | Name | Description
Protected method | AbstractSAMLObserver | Initializes a new instance of the AbstractSAMLObserver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAuthnRequestReceived | Notifies the observer that an authn request has been received.
Public method | OnAuthnRequestSent | Notifies the observer that an authn request has been sent.
Public method | OnCreateSAMLAssertion | Notifies the observer that a SAML assertion has been constructed. The observer may return an updated SAML assertion.
Public method | OnCreateSAMLMessage | Notifies the observer that a SAML message has been constructed. The observer may return an updated SAML message.
Public method | OnLogoutRequestReceived | Notifies the observer that a logout request has been received.
Public method | OnLogoutRequestSent | Notifies the observer that a logout request has been sent.
Public method | OnLogoutResponseReceived | Notifies the observer that a logout response has been received.
Public method | OnLogoutResponseSent | Notifies the observer that a logout response has been sent.
Public method | OnSAMLAssertionReceived | Notifies the observer that a SAML assertion has been received.
Public method | OnSAMLResponseReceived | Notifies the observer that a SAML response has been received.
Public method | OnSAMLResponseSent | Notifies the observer that a SAML response has been sent.
Public method | OnSendSAMLMessage | Notifies the observer that a SAML message is ready for transmission. The observer may return an updated destination URL.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver Constructor

Initializes a new instance of the AbstractSAMLObserver class

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
protected AbstractSAMLObserver()
Protected Sub New
protected:
AbstractSAMLObserver()
new : unit -> AbstractSAMLObserver
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver Methods

The AbstractSAMLObserver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAuthnRequestReceived | Notifies the observer that an authn request has been received.
Public method | OnAuthnRequestSent | Notifies the observer that an authn request has been sent.
Public method | OnCreateSAMLAssertion | Notifies the observer that a SAML assertion has been constructed. The observer may return an updated SAML assertion.
Public method | OnCreateSAMLMessage | Notifies the observer that a SAML message has been constructed. The observer may return an updated SAML message.
Public method | OnLogoutRequestReceived | Notifies the observer that a logout request has been received.
Public method | OnLogoutRequestSent | Notifies the observer that a logout request has been sent.
Public method | OnLogoutResponseReceived | Notifies the observer that a logout response has been received.
Public method | OnLogoutResponseSent | Notifies the observer that a logout response has been sent.
Public method | OnSAMLAssertionReceived | Notifies the observer that a SAML assertion has been received.
Public method | OnSAMLResponseReceived | Notifies the observer that a SAML response has been received.
Public method | OnSAMLResponseSent | Notifies the observer that a SAML response has been sent.
Public method | OnSendSAMLMessage | Notifies the observer that a SAML message is ready for transmission. The observer may return an updated destination URL.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnAuthnRequestReceived Method

AbstractSAMLObserverOnAuthnRequestReceived Method

Notifies the observer that an authn request has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void OnAuthnRequestReceived(
    string partnerName,
    XmlElement authnRequest,
    string relayState
)
Public Overridable Sub OnAuthnRequestReceived (
    partnerName As String,
    authnRequest As XmlElement,
    relayState As String
)
public:
virtual void OnAuthnRequestReceived(
    String^ partnerName,
    XmlElement^ authnRequest,
    String^ relayState
)
abstract OnAuthnRequestReceived :
        partnerName : string *
        authnRequest : XmlElement *
        relayState : string -> unit
override OnAuthnRequestReceived :
        partnerName : string *
        authnRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
authnRequest
Type: System.XmlXmlElement
The authn request.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnAuthnRequestReceived(String, XmlElement, String)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnAuthnRequestSent Method

AbstractSAMLObserverOnAuthnRequestSent Method

Notifies the observer that an authn request has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void OnAuthnRequestSent(
    string partnerName,
    XmlElement authnRequest,
    string relayState
)
Public Overridable Sub OnAuthnRequestSent (
    partnerName As String,
    authnRequest As XmlElement,
    relayState As String
)
public:
virtual void OnAuthnRequestSent(
    String^ partnerName,
    XmlElement^ authnRequest,
    String^ relayState
)
abstract OnAuthnRequestSent :
        partnerName : string *
        authnRequest : XmlElement *
        relayState : string -> unit
override OnAuthnRequestSent :
        partnerName : string *
        authnRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
authnRequest
Type: System.XmlXmlElement
The authn request.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnAuthnRequestSent(String, XmlElement, String)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnCreateSAMLAssertion Method

AbstractSAMLObserverOnCreateSAMLAssertion Method

Notifies the observer that a SAML assertion has been constructed.

The observer may return an updated SAML assertion.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement OnCreateSAMLAssertion(
    string partnerName,
    XmlElement samlAssertion
)
Public Overridable Function OnCreateSAMLAssertion (
    partnerName As String,
    samlAssertion As XmlElement
) As XmlElement
public:
virtual XmlElement^ OnCreateSAMLAssertion(
    String^ partnerName,
    XmlElement^ samlAssertion
)
abstract OnCreateSAMLAssertion :
        partnerName : string *
        samlAssertion : XmlElement -> XmlElement
override OnCreateSAMLAssertion :
        partnerName : string *
        samlAssertion : XmlElement -> XmlElement

Parameters

partnerName
Type: SystemString
The partner name.
samlAssertion
Type: System.XmlXmlElement
The SAML assertion.

Return Value

Type: XmlElement
The SAML assertion.

Implements

ISAMLObserverOnCreateSAMLAssertion(String, XmlElement)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnCreateSAMLMessage Method

AbstractSAMLObserverOnCreateSAMLMessage Method

Notifies the observer that a SAML message has been constructed.

The observer may return an updated SAML message.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual XmlElement OnCreateSAMLMessage(
    string partnerName,
    XmlElement samlMessage
)
Public Overridable Function OnCreateSAMLMessage (
    partnerName As String,
    samlMessage As XmlElement
) As XmlElement
public:
virtual XmlElement^ OnCreateSAMLMessage(
    String^ partnerName,
    XmlElement^ samlMessage
)
abstract OnCreateSAMLMessage :
        partnerName : string *
        samlMessage : XmlElement -> XmlElement
override OnCreateSAMLMessage :
        partnerName : string *
        samlMessage : XmlElement -> XmlElement

Parameters

partnerName
Type: SystemString
The partner name.
samlMessage
Type: System.XmlXmlElement
The SAML message.

Return Value

Type: XmlElement
The SAML message.

Implements

ISAMLObserverOnCreateSAMLMessage(String, XmlElement)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnLogoutRequestReceived Method

AbstractSAMLObserverOnLogoutRequestReceived Method

Notifies the observer that a logout request has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void OnLogoutRequestReceived(
    string partnerName,
    XmlElement logoutRequest,
    string relayState
)
Public Overridable Sub OnLogoutRequestReceived (
    partnerName As String,
    logoutRequest As XmlElement,
    relayState As String
)
public:
virtual void OnLogoutRequestReceived(
    String^ partnerName,
    XmlElement^ logoutRequest,
    String^ relayState
)
abstract OnLogoutRequestReceived :
        partnerName : string *
        logoutRequest : XmlElement *
        relayState : string -> unit
override OnLogoutRequestReceived :
        partnerName : string *
        logoutRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutRequest
Type: System.XmlXmlElement
The logout request.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnLogoutRequestReceived(String, XmlElement, String)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnLogoutRequestSent Method

AbstractSAMLObserverOnLogoutRequestSent Method

Notifies the observer that a logout request has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void OnLogoutRequestSent(
    string partnerName,
    XmlElement logoutRequest,
    string relayState
)
Public Overridable Sub OnLogoutRequestSent (
    partnerName As String,
    logoutRequest As XmlElement,
    relayState As String
)
public:
virtual void OnLogoutRequestSent(
    String^ partnerName,
    XmlElement^ logoutRequest,
    String^ relayState
)
abstract OnLogoutRequestSent :
        partnerName : string *
        logoutRequest : XmlElement *
        relayState : string -> unit
override OnLogoutRequestSent :
        partnerName : string *
        logoutRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutRequest
Type: System.XmlXmlElement
The logout request.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnLogoutRequestSent(String, XmlElement, String)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnLogoutResponseReceived Method

AbstractSAMLObserverOnLogoutResponseReceived Method

Notifies the observer that a logout response has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void OnLogoutResponseReceived(
    string partnerName,
    XmlElement logoutResponse,
    string relayState
)
Public Overridable Sub OnLogoutResponseReceived (
    partnerName As String,
    logoutResponse As XmlElement,
    relayState As String
)
public:
virtual void OnLogoutResponseReceived(
    String^ partnerName,
    XmlElement^ logoutResponse,
    String^ relayState
)
abstract OnLogoutResponseReceived :
        partnerName : string *
        logoutResponse : XmlElement *
        relayState : string -> unit
override OnLogoutResponseReceived :
        partnerName : string *
        logoutResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutResponse
Type: System.XmlXmlElement
The logout response.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnLogoutResponseReceived(String, XmlElement, String)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnLogoutResponseSent Method

AbstractSAMLObserverOnLogoutResponseSent Method

Notifies the observer that a logout response has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void OnLogoutResponseSent(
    string partnerName,
    XmlElement logoutResponse,
    string relayState
)
Public Overridable Sub OnLogoutResponseSent (
    partnerName As String,
    logoutResponse As XmlElement,
    relayState As String
)
public:
virtual void OnLogoutResponseSent(
    String^ partnerName,
    XmlElement^ logoutResponse,
    String^ relayState
)
abstract OnLogoutResponseSent :
        partnerName : string *
        logoutResponse : XmlElement *
        relayState : string -> unit
override OnLogoutResponseSent :
        partnerName : string *
        logoutResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutResponse
Type: System.XmlXmlElement
The logout response.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnLogoutResponseSent(String, XmlElement, String)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnSAMLAssertionReceived Method

AbstractSAMLObserverOnSAMLAssertionReceived Method

Notifies the observer that a SAML assertion has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void OnSAMLAssertionReceived(
    string partnerName,
    XmlElement samlAssertion
)
Public Overridable Sub OnSAMLAssertionReceived (
    partnerName As String,
    samlAssertion As XmlElement
)
public:
virtual void OnSAMLAssertionReceived(
    String^ partnerName,
    XmlElement^ samlAssertion
)
abstract OnSAMLAssertionReceived :
        partnerName : string *
        samlAssertion : XmlElement -> unit
override OnSAMLAssertionReceived :
        partnerName : string *
        samlAssertion : XmlElement -> unit

Parameters

partnerName
Type: SystemString
The partner name.
samlAssertion
Type: System.XmlXmlElement
The SAML assertion.

Implements

ISAMLObserverOnSAMLAssertionReceived(String, XmlElement)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnSAMLResponseReceived Method

AbstractSAMLObserverOnSAMLResponseReceived Method

Notifies the observer that a SAML response has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void OnSAMLResponseReceived(
    string partnerName,
    XmlElement samlResponse,
    string relayState
)
Public Overridable Sub OnSAMLResponseReceived (
    partnerName As String,
    samlResponse As XmlElement,
    relayState As String
)
public:
virtual void OnSAMLResponseReceived(
    String^ partnerName,
    XmlElement^ samlResponse,
    String^ relayState
)
abstract OnSAMLResponseReceived :
        partnerName : string *
        samlResponse : XmlElement *
        relayState : string -> unit
override OnSAMLResponseReceived :
        partnerName : string *
        samlResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
samlResponse
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnSAMLResponseReceived(String, XmlElement, String)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnSAMLResponseSent Method

AbstractSAMLObserverOnSAMLResponseSent Method

Notifies the observer that a SAML response has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void OnSAMLResponseSent(
    string partnerName,
    XmlElement samlResponse,
    string relayState
)
Public Overridable Sub OnSAMLResponseSent (
    partnerName As String,
    samlResponse As XmlElement,
    relayState As String
)
public:
virtual void OnSAMLResponseSent(
    String^ partnerName,
    XmlElement^ samlResponse,
    String^ relayState
)
abstract OnSAMLResponseSent :
        partnerName : string *
        samlResponse : XmlElement *
        relayState : string -> unit
override OnSAMLResponseSent :
        partnerName : string *
        samlResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
samlResponse
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnSAMLResponseSent(String, XmlElement, String)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


AbstractSAMLObserver.OnSendSAMLMessage Method

AbstractSAMLObserverOnSendSAMLMessage Method

Notifies the observer that a SAML message is ready for transmission.

The observer may return an updated destination URL.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual string OnSendSAMLMessage(
    string partnerName,
    XmlElement samlMessage,
    string destinationUrl
)
Public Overridable Function OnSendSAMLMessage (
    partnerName As String,
    samlMessage As XmlElement,
    destinationUrl As String
) As String
public:
virtual String^ OnSendSAMLMessage(
    String^ partnerName,
    XmlElement^ samlMessage,
    String^ destinationUrl
)
abstract OnSendSAMLMessage :
        partnerName : string *
        samlMessage : XmlElement *
        destinationUrl : string -> string
override OnSendSAMLMessage :
        partnerName : string *
        samlMessage : XmlElement *
        destinationUrl : string -> string

Parameters

partnerName
Type: SystemString
The partner name.
samlMessage
Type: System.XmlXmlElement
The SAML message.
destinationUrl
Type: SystemString
The destination URL.

Return Value

Type: String
The SAML response.

Implements

ISAMLObserverOnSendSAMLMessage(String, XmlElement, String)
See Also

Reference

AbstractSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver Interface

A SAML observer receives notifications as part of SAML single sign-on and logout.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public interface ISAMLObserver
Public Interface ISAMLObserver
public interface class ISAMLObserver
type ISAMLObserver =  interface end

The ISAMLObserver type exposes the following members.

Methods
 | Name | Description
Public method | OnAuthnRequestReceived | Notifies the observer that an authn request has been received.
Public method | OnAuthnRequestSent | Notifies the observer that an authn request has been sent.
Public method | OnCreateSAMLAssertion | Notifies the observer that a SAML assertion has been constructed. The observer may return an updated SAML assertion.
Public method | OnCreateSAMLMessage | Notifies the observer that a SAML message has been constructed. The observer may return an updated SAML message.
Public method | OnLogoutRequestReceived | Notifies the observer that a logout request has been received.
Public method | OnLogoutRequestSent | Notifies the observer that a logout request has been sent.
Public method | OnLogoutResponseReceived | Notifies the observer that a logout response has been received.
Public method | OnLogoutResponseSent | Notifies the observer that a logout response has been sent.
Public method | OnSAMLAssertionReceived | Notifies the observer that a SAML assertion has been received.
Public method | OnSAMLResponseReceived | Notifies the observer that a SAML response has been received.
Public method | OnSAMLResponseSent | Notifies the observer that a SAML response has been sent.
Public method | OnSendSAMLMessage | Notifies the observer that a SAML message is ready for transmission. The observer may return an updated destination URL.
Top
See Also

Reference

ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver Methods

The ISAMLObserver type exposes the following members.

Methods
 | Name | Description
Public method | OnAuthnRequestReceived | Notifies the observer that an authn request has been received.
Public method | OnAuthnRequestSent | Notifies the observer that an authn request has been sent.
Public method | OnCreateSAMLAssertion | Notifies the observer that a SAML assertion has been constructed. The observer may return an updated SAML assertion.
Public method | OnCreateSAMLMessage | Notifies the observer that a SAML message has been constructed. The observer may return an updated SAML message.
Public method | OnLogoutRequestReceived | Notifies the observer that a logout request has been received.
Public method | OnLogoutRequestSent | Notifies the observer that a logout request has been sent.
Public method | OnLogoutResponseReceived | Notifies the observer that a logout response has been received.
Public method | OnLogoutResponseSent | Notifies the observer that a logout response has been sent.
Public method | OnSAMLAssertionReceived | Notifies the observer that a SAML assertion has been received.
Public method | OnSAMLResponseReceived | Notifies the observer that a SAML response has been received.
Public method | OnSAMLResponseSent | Notifies the observer that a SAML response has been sent.
Public method | OnSendSAMLMessage | Notifies the observer that a SAML message is ready for transmission. The observer may return an updated destination URL.
Top
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnAuthnRequestReceived Method

ISAMLObserverOnAuthnRequestReceived Method

Notifies the observer that an authn request has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void OnAuthnRequestReceived(
    string partnerName,
    XmlElement authnRequest,
    string relayState
)
Sub OnAuthnRequestReceived (
    partnerName As String,
    authnRequest As XmlElement,
    relayState As String
)
void OnAuthnRequestReceived(
    String^ partnerName,
    XmlElement^ authnRequest,
    String^ relayState
)
abstract OnAuthnRequestReceived :
        partnerName : string *
        authnRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
authnRequest
Type: System.XmlXmlElement
The authn request.
relayState
Type: SystemString
The relay state.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnAuthnRequestSent Method

ISAMLObserverOnAuthnRequestSent Method

Notifies the observer that an authn request has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void OnAuthnRequestSent(
    string partnerName,
    XmlElement authnRequest,
    string relayState
)
Sub OnAuthnRequestSent (
    partnerName As String,
    authnRequest As XmlElement,
    relayState As String
)
void OnAuthnRequestSent(
    String^ partnerName,
    XmlElement^ authnRequest,
    String^ relayState
)
abstract OnAuthnRequestSent :
        partnerName : string *
        authnRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
authnRequest
Type: System.XmlXmlElement
The authn request.
relayState
Type: SystemString
The relay state.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnCreateSAMLAssertion Method

ISAMLObserverOnCreateSAMLAssertion Method

Notifies the observer that a SAML assertion has been constructed.

The observer may return an updated SAML assertion.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
XmlElement OnCreateSAMLAssertion(
    string partnerName,
    XmlElement samlAssertion
)
Function OnCreateSAMLAssertion (
    partnerName As String,
    samlAssertion As XmlElement
) As XmlElement
XmlElement^ OnCreateSAMLAssertion(
    String^ partnerName,
    XmlElement^ samlAssertion
)
abstract OnCreateSAMLAssertion :
        partnerName : string *
        samlAssertion : XmlElement -> XmlElement

Parameters

partnerName
Type: SystemString
The partner name.
samlAssertion
Type: System.XmlXmlElement
The SAML assertion.

Return Value

Type: XmlElement
The SAML assertion.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnCreateSAMLMessage Method

ISAMLObserverOnCreateSAMLMessage Method

Notifies the observer that a SAML message has been constructed.

The observer may return an updated SAML message.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
XmlElement OnCreateSAMLMessage(
    string partnerName,
    XmlElement samlMessage
)
Function OnCreateSAMLMessage (
    partnerName As String,
    samlMessage As XmlElement
) As XmlElement
XmlElement^ OnCreateSAMLMessage(
    String^ partnerName,
    XmlElement^ samlMessage
)
abstract OnCreateSAMLMessage :
        partnerName : string *
        samlMessage : XmlElement -> XmlElement

Parameters

partnerName
Type: SystemString
The partner name.
samlMessage
Type: System.XmlXmlElement
The SAML message.

Return Value

Type: XmlElement
The SAML message.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnLogoutRequestReceived Method

ISAMLObserverOnLogoutRequestReceived Method

Notifies the observer that a logout request has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void OnLogoutRequestReceived(
    string partnerName,
    XmlElement logoutRequest,
    string relayState
)
Sub OnLogoutRequestReceived (
    partnerName As String,
    logoutRequest As XmlElement,
    relayState As String
)
void OnLogoutRequestReceived(
    String^ partnerName,
    XmlElement^ logoutRequest,
    String^ relayState
)
abstract OnLogoutRequestReceived :
        partnerName : string *
        logoutRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutRequest
Type: System.XmlXmlElement
The logout request.
relayState
Type: SystemString
The relay state.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnLogoutRequestSent Method

ISAMLObserverOnLogoutRequestSent Method

Notifies the observer that a logout request has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void OnLogoutRequestSent(
    string partnerName,
    XmlElement logoutRequest,
    string relayState
)
Sub OnLogoutRequestSent (
    partnerName As String,
    logoutRequest As XmlElement,
    relayState As String
)
void OnLogoutRequestSent(
    String^ partnerName,
    XmlElement^ logoutRequest,
    String^ relayState
)
abstract OnLogoutRequestSent :
        partnerName : string *
        logoutRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutRequest
Type: System.XmlXmlElement
The logout request.
relayState
Type: SystemString
The relay state.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnLogoutResponseReceived Method

ISAMLObserverOnLogoutResponseReceived Method

Notifies the observer that a logout response has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void OnLogoutResponseReceived(
    string partnerName,
    XmlElement logoutResponse,
    string relayState
)
Sub OnLogoutResponseReceived (
    partnerName As String,
    logoutResponse As XmlElement,
    relayState As String
)
void OnLogoutResponseReceived(
    String^ partnerName,
    XmlElement^ logoutResponse,
    String^ relayState
)
abstract OnLogoutResponseReceived :
        partnerName : string *
        logoutResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutResponse
Type: System.XmlXmlElement
The logout response.
relayState
Type: SystemString
The relay state.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnLogoutResponseSent Method

ISAMLObserverOnLogoutResponseSent Method

Notifies the observer that a logout response has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void OnLogoutResponseSent(
    string partnerName,
    XmlElement logoutResponse,
    string relayState
)
Sub OnLogoutResponseSent (
    partnerName As String,
    logoutResponse As XmlElement,
    relayState As String
)
void OnLogoutResponseSent(
    String^ partnerName,
    XmlElement^ logoutResponse,
    String^ relayState
)
abstract OnLogoutResponseSent :
        partnerName : string *
        logoutResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutResponse
Type: System.XmlXmlElement
The logout response.
relayState
Type: SystemString
The relay state.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnSAMLAssertionReceived Method

ISAMLObserverOnSAMLAssertionReceived Method

Notifies the observer that a SAML assertion has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void OnSAMLAssertionReceived(
    string partnerName,
    XmlElement samlAssertion
)
Sub OnSAMLAssertionReceived (
    partnerName As String,
    samlAssertion As XmlElement
)
void OnSAMLAssertionReceived(
    String^ partnerName,
    XmlElement^ samlAssertion
)
abstract OnSAMLAssertionReceived :
        partnerName : string *
        samlAssertion : XmlElement -> unit

Parameters

partnerName
Type: SystemString
The partner name.
samlAssertion
Type: System.XmlXmlElement
The SAML assertion.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnSAMLResponseReceived Method

ISAMLObserverOnSAMLResponseReceived Method

Notifies the observer that a SAML response has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void OnSAMLResponseReceived(
    string partnerName,
    XmlElement samlResponse,
    string relayState
)
Sub OnSAMLResponseReceived (
    partnerName As String,
    samlResponse As XmlElement,
    relayState As String
)
void OnSAMLResponseReceived(
    String^ partnerName,
    XmlElement^ samlResponse,
    String^ relayState
)
abstract OnSAMLResponseReceived :
        partnerName : string *
        samlResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
samlResponse
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnSAMLResponseSent Method

ISAMLObserverOnSAMLResponseSent Method

Notifies the observer that a SAML response has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
void OnSAMLResponseSent(
    string partnerName,
    XmlElement samlResponse,
    string relayState
)
Sub OnSAMLResponseSent (
    partnerName As String,
    samlResponse As XmlElement,
    relayState As String
)
void OnSAMLResponseSent(
    String^ partnerName,
    XmlElement^ samlResponse,
    String^ relayState
)
abstract OnSAMLResponseSent :
        partnerName : string *
        samlResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
samlResponse
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


ISAMLObserver.OnSendSAMLMessage Method

ISAMLObserverOnSendSAMLMessage Method

Notifies the observer that a SAML message is ready for transmission.

The observer may return an updated destination URL.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
string OnSendSAMLMessage(
    string partnerName,
    XmlElement samlMessage,
    string destinationUrl
)
Function OnSendSAMLMessage (
    partnerName As String,
    samlMessage As XmlElement,
    destinationUrl As String
) As String
String^ OnSendSAMLMessage(
    String^ partnerName,
    XmlElement^ samlMessage,
    String^ destinationUrl
)
abstract OnSendSAMLMessage :
        partnerName : string *
        samlMessage : XmlElement *
        destinationUrl : string -> string

Parameters

partnerName
Type: SystemString
The partner name.
samlMessage
Type: System.XmlXmlElement
The SAML message.
destinationUrl
Type: SystemString
The destination URL.

Return Value

Type: String
The updated destination URL.
See Also

Reference

ISAMLObserver Interface
ComponentSpace.SAML2.Notifications Namespace


SAMLObservable Class

A SAML observable sends notifications to observers as part of SAML single sign-on and logout.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.NotificationsSAMLObservable

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAMLObservable
Public NotInheritable Class SAMLObservable
public ref class SAMLObservable abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAMLObservable =  class end

The SAMLObservable type exposes the following members.

Methods
Name | Description
Subscribe | Subscribe the SAML observer to receive notifications.
Unsubscribe | Unsubscribe the SAML observer so events are no longer received.
Top
See Also

Reference

ComponentSpace.SAML2.Notifications Namespace


SAMLObservable Methods

The SAMLObservable type exposes the following members.

Methods
Name | Description
Subscribe | Subscribe the SAML observer to receive notifications.
Unsubscribe | Unsubscribe the SAML observer so events are no longer received.
Top
See Also

Reference

SAMLObservable Class
ComponentSpace.SAML2.Notifications Namespace


SAMLObservable.Subscribe Method

SAMLObservableSubscribe Method

Subscribe the SAML observer to receive notifications.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Subscribe(
    ISAMLObserver samlObserver
)
Public Shared Sub Subscribe (
    samlObserver As ISAMLObserver
)
public:
static void Subscribe(
    ISAMLObserver^ samlObserver
)
static member Subscribe :
        samlObserver : ISAMLObserver -> unit

Parameters

samlObserver
Type: ComponentSpace.SAML2.NotificationsISAMLObserver
The SAML observer.
See Also

Reference

SAMLObservable Class
ComponentSpace.SAML2.Notifications Namespace


SAMLObservable.Unsubscribe Method

SAMLObservableUnsubscribe Method

Unsubscribe the SAML observer so events are no longer received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Unsubscribe(
    ISAMLObserver samlObserver
)
Public Shared Sub Unsubscribe (
    samlObserver As ISAMLObserver
)
public:
static void Unsubscribe(
    ISAMLObserver^ samlObserver
)
static member Unsubscribe :
        samlObserver : ISAMLObserver -> unit

Parameters

samlObserver
Type: ComponentSpace.SAML2.NotificationsISAMLObserver
The SAML observer.
See Also

Reference

SAMLObservable Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver Class

A trace SAML observer writes notifications to the trace log.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.NotificationsAbstractSAMLObserver
ComponentSpace.SAML2.NotificationsTraceSAMLObserver

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class TraceSAMLObserver : AbstractSAMLObserver
Public Class TraceSAMLObserver
    Inherits AbstractSAMLObserver
public ref class TraceSAMLObserver : public AbstractSAMLObserver
type TraceSAMLObserver =
    class
        inherit AbstractSAMLObserver
    end

The TraceSAMLObserver type exposes the following members.

Constructors
 | Name | Description
Public method | TraceSAMLObserver | Initializes a new instance of the TraceSAMLObserver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAuthnRequestReceived | Trace that an authn request has been received. (Overrides AbstractSAMLObserverOnAuthnRequestReceived(String, XmlElement, String).)
Public method | OnAuthnRequestSent | Trace that an authn request has been sent. (Overrides AbstractSAMLObserverOnAuthnRequestSent(String, XmlElement, String).)
Public method | OnCreateSAMLAssertion | Trace that a SAML assertion has been constructed. (Overrides AbstractSAMLObserverOnCreateSAMLAssertion(String, XmlElement).)
Public method | OnCreateSAMLMessage | Trace that a SAML response has been constructed. (Overrides AbstractSAMLObserverOnCreateSAMLMessage(String, XmlElement).)
Public method | OnLogoutRequestReceived | Trace that a logout request has been received. (Overrides AbstractSAMLObserverOnLogoutRequestReceived(String, XmlElement, String).)
Public method | OnLogoutRequestSent | Trace that a logout request has been sent. (Overrides AbstractSAMLObserverOnLogoutRequestSent(String, XmlElement, String).)
Public method | OnLogoutResponseReceived | Trace that a logout response has been received. (Overrides AbstractSAMLObserverOnLogoutResponseReceived(String, XmlElement, String).)
Public method | OnLogoutResponseSent | Trace that a logout response has been sent. (Overrides AbstractSAMLObserverOnLogoutResponseSent(String, XmlElement, String).)
Public method | OnSAMLAssertionReceived | Trace that a SAML assertion has been received. (Overrides AbstractSAMLObserverOnSAMLAssertionReceived(String, XmlElement).)
Public method | OnSAMLResponseReceived | Trace that a SAML response has been received. (Overrides AbstractSAMLObserverOnSAMLResponseReceived(String, XmlElement, String).)
Public method | OnSAMLResponseSent | Trace that a SAML response has been sent. (Overrides AbstractSAMLObserverOnSAMLResponseSent(String, XmlElement, String).)
Public method | OnSendSAMLMessage | Trace that a SAML message is ready for transmission. (Overrides AbstractSAMLObserverOnSendSAMLMessage(String, XmlElement, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver Constructor

Initializes a new instance of the TraceSAMLObserver class

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public TraceSAMLObserver()
Public Sub New
public:
TraceSAMLObserver()
new : unit -> TraceSAMLObserver
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver Methods

The TraceSAMLObserver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAuthnRequestReceived | Trace that an authn request has been received. (Overrides AbstractSAMLObserverOnAuthnRequestReceived(String, XmlElement, String).)
Public method | OnAuthnRequestSent | Trace that an authn request has been sent. (Overrides AbstractSAMLObserverOnAuthnRequestSent(String, XmlElement, String).)
Public method | OnCreateSAMLAssertion | Trace that a SAML assertion has been constructed. (Overrides AbstractSAMLObserverOnCreateSAMLAssertion(String, XmlElement).)
Public method | OnCreateSAMLMessage | Trace that a SAML response has been constructed. (Overrides AbstractSAMLObserverOnCreateSAMLMessage(String, XmlElement).)
Public method | OnLogoutRequestReceived | Trace that a logout request has been received. (Overrides AbstractSAMLObserverOnLogoutRequestReceived(String, XmlElement, String).)
Public method | OnLogoutRequestSent | Trace that a logout request has been sent. (Overrides AbstractSAMLObserverOnLogoutRequestSent(String, XmlElement, String).)
Public method | OnLogoutResponseReceived | Trace that a logout response has been received. (Overrides AbstractSAMLObserverOnLogoutResponseReceived(String, XmlElement, String).)
Public method | OnLogoutResponseSent | Trace that a logout response has been sent. (Overrides AbstractSAMLObserverOnLogoutResponseSent(String, XmlElement, String).)
Public method | OnSAMLAssertionReceived | Trace that a SAML assertion has been received. (Overrides AbstractSAMLObserverOnSAMLAssertionReceived(String, XmlElement).)
Public method | OnSAMLResponseReceived | Trace that a SAML response has been received. (Overrides AbstractSAMLObserverOnSAMLResponseReceived(String, XmlElement, String).)
Public method | OnSAMLResponseSent | Trace that a SAML response has been sent. (Overrides AbstractSAMLObserverOnSAMLResponseSent(String, XmlElement, String).)
Public method | OnSendSAMLMessage | Trace that a SAML message is ready for transmission. (Overrides AbstractSAMLObserverOnSendSAMLMessage(String, XmlElement, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnAuthnRequestReceived Method

TraceSAMLObserverOnAuthnRequestReceived Method

Trace that an authn request has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void OnAuthnRequestReceived(
    string partnerName,
    XmlElement authnRequest,
    string relayState
)
Public Overrides Sub OnAuthnRequestReceived (
    partnerName As String,
    authnRequest As XmlElement,
    relayState As String
)
public:
virtual void OnAuthnRequestReceived(
    String^ partnerName,
    XmlElement^ authnRequest,
    String^ relayState
) override
abstract OnAuthnRequestReceived :
        partnerName : string *
        authnRequest : XmlElement *
        relayState : string -> unit
override OnAuthnRequestReceived :
        partnerName : string *
        authnRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
authnRequest
Type: System.XmlXmlElement
The authn request.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnAuthnRequestReceived(String, XmlElement, String)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnAuthnRequestSent Method

TraceSAMLObserverOnAuthnRequestSent Method

Trace that an authn request has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void OnAuthnRequestSent(
    string partnerName,
    XmlElement authnRequest,
    string relayState
)
Public Overrides Sub OnAuthnRequestSent (
    partnerName As String,
    authnRequest As XmlElement,
    relayState As String
)
public:
virtual void OnAuthnRequestSent(
    String^ partnerName,
    XmlElement^ authnRequest,
    String^ relayState
) override
abstract OnAuthnRequestSent :
        partnerName : string *
        authnRequest : XmlElement *
        relayState : string -> unit
override OnAuthnRequestSent :
        partnerName : string *
        authnRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
authnRequest
Type: System.XmlXmlElement
The authn request.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnAuthnRequestSent(String, XmlElement, String)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnCreateSAMLAssertion Method

TraceSAMLObserverOnCreateSAMLAssertion Method

Trace that a SAML assertion has been constructed.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override XmlElement OnCreateSAMLAssertion(
    string partnerName,
    XmlElement samlAssertion
)
Public Overrides Function OnCreateSAMLAssertion (
    partnerName As String,
    samlAssertion As XmlElement
) As XmlElement
public:
virtual XmlElement^ OnCreateSAMLAssertion(
    String^ partnerName,
    XmlElement^ samlAssertion
) override
abstract OnCreateSAMLAssertion :
        partnerName : string *
        samlAssertion : XmlElement -> XmlElement
override OnCreateSAMLAssertion :
        partnerName : string *
        samlAssertion : XmlElement -> XmlElement

Parameters

partnerName
Type: SystemString
The partner name.
samlAssertion
Type: System.XmlXmlElement
The SAML assertion.

Return Value

Type: XmlElement
The SAML assertion.

Implements

ISAMLObserverOnCreateSAMLAssertion(String, XmlElement)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnCreateSAMLMessage Method

TraceSAMLObserverOnCreateSAMLMessage Method

Trace that a SAML response has been constructed.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override XmlElement OnCreateSAMLMessage(
    string partnerName,
    XmlElement samlMessage
)
Public Overrides Function OnCreateSAMLMessage (
    partnerName As String,
    samlMessage As XmlElement
) As XmlElement
public:
virtual XmlElement^ OnCreateSAMLMessage(
    String^ partnerName,
    XmlElement^ samlMessage
) override
abstract OnCreateSAMLMessage :
        partnerName : string *
        samlMessage : XmlElement -> XmlElement
override OnCreateSAMLMessage :
        partnerName : string *
        samlMessage : XmlElement -> XmlElement

Parameters

partnerName
Type: SystemString
The partner name.
samlMessage
Type: System.XmlXmlElement
The SAML response.

Return Value

Type: XmlElement
The SAML response.

Implements

ISAMLObserverOnCreateSAMLMessage(String, XmlElement)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnLogoutRequestReceived Method

TraceSAMLObserverOnLogoutRequestReceived Method

Trace that a logout request has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void OnLogoutRequestReceived(
    string partnerName,
    XmlElement logoutRequest,
    string relayState
)
Public Overrides Sub OnLogoutRequestReceived (
    partnerName As String,
    logoutRequest As XmlElement,
    relayState As String
)
public:
virtual void OnLogoutRequestReceived(
    String^ partnerName,
    XmlElement^ logoutRequest,
    String^ relayState
) override
abstract OnLogoutRequestReceived :
        partnerName : string *
        logoutRequest : XmlElement *
        relayState : string -> unit
override OnLogoutRequestReceived :
        partnerName : string *
        logoutRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutRequest
Type: System.XmlXmlElement
The logout request.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnLogoutRequestReceived(String, XmlElement, String)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnLogoutRequestSent Method

TraceSAMLObserverOnLogoutRequestSent Method

Trace that a logout request has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void OnLogoutRequestSent(
    string partnerName,
    XmlElement logoutRequest,
    string relayState
)
Public Overrides Sub OnLogoutRequestSent (
    partnerName As String,
    logoutRequest As XmlElement,
    relayState As String
)
public:
virtual void OnLogoutRequestSent(
    String^ partnerName,
    XmlElement^ logoutRequest,
    String^ relayState
) override
abstract OnLogoutRequestSent :
        partnerName : string *
        logoutRequest : XmlElement *
        relayState : string -> unit
override OnLogoutRequestSent :
        partnerName : string *
        logoutRequest : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutRequest
Type: System.XmlXmlElement
The logout request.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnLogoutRequestSent(String, XmlElement, String)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnLogoutResponseReceived Method

TraceSAMLObserverOnLogoutResponseReceived Method

Trace that a logout response has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void OnLogoutResponseReceived(
    string partnerName,
    XmlElement logoutResponse,
    string relayState
)
Public Overrides Sub OnLogoutResponseReceived (
    partnerName As String,
    logoutResponse As XmlElement,
    relayState As String
)
public:
virtual void OnLogoutResponseReceived(
    String^ partnerName,
    XmlElement^ logoutResponse,
    String^ relayState
) override
abstract OnLogoutResponseReceived :
        partnerName : string *
        logoutResponse : XmlElement *
        relayState : string -> unit
override OnLogoutResponseReceived :
        partnerName : string *
        logoutResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutResponse
Type: System.XmlXmlElement
The logout response.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnLogoutResponseReceived(String, XmlElement, String)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnLogoutResponseSent Method

TraceSAMLObserverOnLogoutResponseSent Method

Trace that a logout response has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void OnLogoutResponseSent(
    string partnerName,
    XmlElement logoutResponse,
    string relayState
)
Public Overrides Sub OnLogoutResponseSent (
    partnerName As String,
    logoutResponse As XmlElement,
    relayState As String
)
public:
virtual void OnLogoutResponseSent(
    String^ partnerName,
    XmlElement^ logoutResponse,
    String^ relayState
) override
abstract OnLogoutResponseSent :
        partnerName : string *
        logoutResponse : XmlElement *
        relayState : string -> unit
override OnLogoutResponseSent :
        partnerName : string *
        logoutResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
logoutResponse
Type: System.XmlXmlElement
The logout response.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnLogoutResponseSent(String, XmlElement, String)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnSAMLAssertionReceived Method

TraceSAMLObserverOnSAMLAssertionReceived Method

Trace that a SAML assertion has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void OnSAMLAssertionReceived(
    string partnerName,
    XmlElement samlAssertion
)
Public Overrides Sub OnSAMLAssertionReceived (
    partnerName As String,
    samlAssertion As XmlElement
)
public:
virtual void OnSAMLAssertionReceived(
    String^ partnerName,
    XmlElement^ samlAssertion
) override
abstract OnSAMLAssertionReceived :
        partnerName : string *
        samlAssertion : XmlElement -> unit
override OnSAMLAssertionReceived :
        partnerName : string *
        samlAssertion : XmlElement -> unit

Parameters

partnerName
Type: SystemString
The partner name.
samlAssertion
Type: System.XmlXmlElement
The SAML assertion.

Implements

ISAMLObserverOnSAMLAssertionReceived(String, XmlElement)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnSAMLResponseReceived Method

TraceSAMLObserverOnSAMLResponseReceived Method

Trace that a SAML response has been received.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void OnSAMLResponseReceived(
    string partnerName,
    XmlElement samlResponse,
    string relayState
)
Public Overrides Sub OnSAMLResponseReceived (
    partnerName As String,
    samlResponse As XmlElement,
    relayState As String
)
public:
virtual void OnSAMLResponseReceived(
    String^ partnerName,
    XmlElement^ samlResponse,
    String^ relayState
) override
abstract OnSAMLResponseReceived :
        partnerName : string *
        samlResponse : XmlElement *
        relayState : string -> unit
override OnSAMLResponseReceived :
        partnerName : string *
        samlResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
samlResponse
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnSAMLResponseReceived(String, XmlElement, String)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnSAMLResponseSent Method

TraceSAMLObserverOnSAMLResponseSent Method

Trace that a SAML response has been sent.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void OnSAMLResponseSent(
    string partnerName,
    XmlElement samlResponse,
    string relayState
)
Public Overrides Sub OnSAMLResponseSent (
    partnerName As String,
    samlResponse As XmlElement,
    relayState As String
)
public:
virtual void OnSAMLResponseSent(
    String^ partnerName,
    XmlElement^ samlResponse,
    String^ relayState
) override
abstract OnSAMLResponseSent :
        partnerName : string *
        samlResponse : XmlElement *
        relayState : string -> unit
override OnSAMLResponseSent :
        partnerName : string *
        samlResponse : XmlElement *
        relayState : string -> unit

Parameters

partnerName
Type: SystemString
The partner name.
samlResponse
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state.

Implements

ISAMLObserverOnSAMLResponseSent(String, XmlElement, String)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


TraceSAMLObserver.OnSendSAMLMessage Method

TraceSAMLObserverOnSendSAMLMessage Method

Trace that a SAML message is ready for transmission.

Namespace: ComponentSpace.SAML2.Notifications
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string OnSendSAMLMessage(
    string partnerName,
    XmlElement samlMessage,
    string destinationUrl
)
Public Overrides Function OnSendSAMLMessage (
    partnerName As String,
    samlMessage As XmlElement,
    destinationUrl As String
) As String
public:
virtual String^ OnSendSAMLMessage(
    String^ partnerName,
    XmlElement^ samlMessage,
    String^ destinationUrl
) override
abstract OnSendSAMLMessage :
        partnerName : string *
        samlMessage : XmlElement *
        destinationUrl : string -> string
override OnSendSAMLMessage :
        partnerName : string *
        samlMessage : XmlElement *
        destinationUrl : string -> string

Parameters

partnerName
Type: SystemString
The partner name.
samlMessage
Type: System.XmlXmlElement
The SAML message.
destinationUrl
Type: SystemString
The destination URL.

Return Value

Type: String
The SAML response.

Implements

ISAMLObserverOnSendSAMLMessage(String, XmlElement, String)
See Also

Reference

TraceSAMLObserver Class
ComponentSpace.SAML2.Notifications Namespace


ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace

The ComponentSpace.SAML2.Profiles.ArtifactResolution namespace contains classes associated with the SAML v2.0 artifact resolution profile.
Classes
 | Class | Description
Public class | ArtifactResolver | Supports the artifact resolution profile.


ArtifactResolver Class

Supports the artifact resolution profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.ArtifactResolutionArtifactResolver

Namespace: ComponentSpace.SAML2.Profiles.ArtifactResolution
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class ArtifactResolver
Public NotInheritable Class ArtifactResolver
public ref class ArtifactResolver abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ArtifactResolver =  class end
Methods
Name | Description
ReceiveArtifactResolve(HttpRequest) | Receives an artifact resolve request.
ReceiveArtifactResolve(HttpRequestBase) | Receives an artifact resolve request.
SendArtifactResponse(HttpResponse, XmlElement) | Sends an artifact response containing the SAML message associated with the artifact.
SendArtifactResponse(HttpResponseBase, XmlElement) | Sends an artifact response containing the SAML message associated with the artifact.
SendRequestReceiveResponse(WebRequest, XmlElement) | Sends an artifact resolve request and receives an artifact response over SOAP.
SendRequestReceiveResponse(String, XmlElement) | Sends an artifact resolve request and receives an artifact response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ArtifactResolver Methods

Methods
Name | Description
ReceiveArtifactResolve(HttpRequest) | Receives an artifact resolve request.
ReceiveArtifactResolve(HttpRequestBase) | Receives an artifact resolve request.
SendArtifactResponse(HttpResponse, XmlElement) | Sends an artifact response containing the SAML message associated with the artifact.
SendArtifactResponse(HttpResponseBase, XmlElement) | Sends an artifact response containing the SAML message associated with the artifact.
SendRequestReceiveResponse(WebRequest, XmlElement) | Sends an artifact resolve request and receives an artifact response over SOAP.
SendRequestReceiveResponse(String, XmlElement) | Sends an artifact resolve request and receives an artifact response over SOAP.
Top
See Also

Reference

ArtifactResolver Class
ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ArtifactResolver.ReceiveArtifactResolve Method

ArtifactResolverReceiveArtifactResolve Method

Overload List
Name | Description
ReceiveArtifactResolve(HttpRequest) | Receives an artifact resolve request.
ReceiveArtifactResolve(HttpRequestBase) | Receives an artifact resolve request.
Top
See Also

Reference

ArtifactResolver Class
ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ArtifactResolver.ReceiveArtifactResolve Method (HttpRequest)

ArtifactResolverReceiveArtifactResolve Method (HttpRequest)

Receives an artifact resolve request.

Namespace: ComponentSpace.SAML2.Profiles.ArtifactResolution
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveArtifactResolve(
    HttpRequest httpRequest
)
Public Shared Function ReceiveArtifactResolve (
    httpRequest As HttpRequest
) As XmlElement
public:
static XmlElement^ ReceiveArtifactResolve(
    HttpRequest^ httpRequest
)
static member ReceiveArtifactResolve :
        httpRequest : HttpRequest -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request on which to receive the artifact resolve request.

Return Value

Type: XmlElement
The artifact resolve request.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ArtifactResolver Class
ReceiveArtifactResolve Overload
ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ArtifactResolver.ReceiveArtifactResolve Method (HttpRequestBase)

ArtifactResolverReceiveArtifactResolve Method (HttpRequestBase)

Receives an artifact resolve request.

Namespace: ComponentSpace.SAML2.Profiles.ArtifactResolution
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveArtifactResolve(
    HttpRequestBase httpRequest
)
Public Shared Function ReceiveArtifactResolve (
    httpRequest As HttpRequestBase
) As XmlElement
public:
static XmlElement^ ReceiveArtifactResolve(
    HttpRequestBase^ httpRequest
)
static member ReceiveArtifactResolve :
        httpRequest : HttpRequestBase -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request on which to receive the artifact resolve request.

Return Value

Type: XmlElement
The artifact resolve request.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ArtifactResolver Class
ReceiveArtifactResolve Overload
ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ArtifactResolver.SendArtifactResponse Method

ArtifactResolverSendArtifactResponse Method

Overload List
Name | Description
SendArtifactResponse(HttpResponse, XmlElement) | Sends an artifact response containing the SAML message associated with the artifact.
SendArtifactResponse(HttpResponseBase, XmlElement) | Sends an artifact response containing the SAML message associated with the artifact.
Top
See Also

Reference

ArtifactResolver Class
ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ArtifactResolver.SendArtifactResponse Method (HttpResponse, XmlElement)

ArtifactResolverSendArtifactResponse Method (HttpResponse, XmlElement)

Sends an artifact response containing the SAML message associated with the artifact.

Namespace: ComponentSpace.SAML2.Profiles.ArtifactResolution
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactResponse(
    HttpResponse httpResponse,
    XmlElement artifactResponse
)
Public Shared Sub SendArtifactResponse (
    httpResponse As HttpResponse,
    artifactResponse As XmlElement
)
public:
static void SendArtifactResponse(
    HttpResponse^ httpResponse,
    XmlElement^ artifactResponse
)
static member SendArtifactResponse :
        httpResponse : HttpResponse *
        artifactResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to send the SAML response.
artifactResponse
Type: System.XmlXmlElement
The artifact response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ArtifactResolver Class
SendArtifactResponse Overload
ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ArtifactResolver.SendArtifactResponse Method (HttpResponseBase, XmlElement)

ArtifactResolverSendArtifactResponse Method (HttpResponseBase, XmlElement)

Sends an artifact response containing the SAML message associated with the artifact.

Namespace: ComponentSpace.SAML2.Profiles.ArtifactResolution
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactResponse(
    HttpResponseBase httpResponse,
    XmlElement artifactResponse
)
Public Shared Sub SendArtifactResponse (
    httpResponse As HttpResponseBase,
    artifactResponse As XmlElement
)
public:
static void SendArtifactResponse(
    HttpResponseBase^ httpResponse,
    XmlElement^ artifactResponse
)
static member SendArtifactResponse :
        httpResponse : HttpResponseBase *
        artifactResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to send the SAML response.
artifactResponse
Type: System.XmlXmlElement
The artifact response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ArtifactResolver Class
SendArtifactResponse Overload
ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ArtifactResolver.SendRequestReceiveResponse Method

ArtifactResolverSendRequestReceiveResponse Method

Overload List
Name | Description
SendRequestReceiveResponse(WebRequest, XmlElement) | Sends an artifact resolve request and receives an artifact response over SOAP.
SendRequestReceiveResponse(String, XmlElement) | Sends an artifact resolve request and receives an artifact response over SOAP.
Top
See Also

Reference

ArtifactResolver Class
ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ArtifactResolver.SendRequestReceiveResponse Method (WebRequest, XmlElement)

ArtifactResolverSendRequestReceiveResponse Method (WebRequest, XmlElement)

Sends an artifact resolve request and receives an artifact response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.ArtifactResolution
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendRequestReceiveResponse(
    WebRequest webRequest,
    XmlElement artifactResolve
)
Public Shared Function SendRequestReceiveResponse (
    webRequest As WebRequest,
    artifactResolve As XmlElement
) As XmlElement
public:
static XmlElement^ SendRequestReceiveResponse(
    WebRequest^ webRequest,
    XmlElement^ artifactResolve
)
static member SendRequestReceiveResponse :
        webRequest : WebRequest *
        artifactResolve : XmlElement -> XmlElement

Parameters

webRequest
Type: System.NetWebRequest
The WebRequest used to send the request and receive the response.
artifactResolve
Type: System.XmlXmlElement
The artifact resolve request.

Return Value

Type: XmlElement
The artifact response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send/receive fails.
See Also

Reference

ArtifactResolver Class
SendRequestReceiveResponse Overload
ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ArtifactResolver.SendRequestReceiveResponse Method (String, XmlElement)

ArtifactResolverSendRequestReceiveResponse Method (String, XmlElement)

Sends an artifact resolve request and receives an artifact response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.ArtifactResolution
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendRequestReceiveResponse(
    string destinationURL,
    XmlElement artifactResolve
)
Public Shared Function SendRequestReceiveResponse (
    destinationURL As String,
    artifactResolve As XmlElement
) As XmlElement
public:
static XmlElement^ SendRequestReceiveResponse(
    String^ destinationURL,
    XmlElement^ artifactResolve
)
static member SendRequestReceiveResponse :
        destinationURL : string *
        artifactResolve : XmlElement -> XmlElement

Parameters

destinationURL
Type: SystemString
The destination URL.
artifactResolve
Type: System.XmlXmlElement
The artifact resolve request.

Return Value

Type: XmlElement
The artifact response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send/receive fails.
See Also

Reference

ArtifactResolver Class
SendRequestReceiveResponse Overload
ComponentSpace.SAML2.Profiles.ArtifactResolution Namespace


ComponentSpace.SAML2.Profiles.AttributeQuery Namespace

The ComponentSpace.SAML2.Profiles.AttributeQuery namespace contains classes associated with the SAML v2.0 attribute query profile.
Classes
 | Class | Description
Public class | AttributeQueryRequester | Supports the attribute query profile.
Public class | AttributeQueryResponder | Supports the attribute query profile.


AttributeQueryRequester Class

Supports the attribute query profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.AttributeQueryAttributeQueryRequester

Namespace: ComponentSpace.SAML2.Profiles.AttributeQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AttributeQueryRequester
Public NotInheritable Class AttributeQueryRequester
public ref class AttributeQueryRequester abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AttributeQueryRequester =  class end
Methods
Name | Description
SendAttributeQueryReceiveResponseBySOAP(WebRequest, XmlElement) | Sends the attribute query and receives a SAML response over SOAP.
SendAttributeQueryReceiveResponseBySOAP(String, XmlElement) | Sends the attribute query and receives a SAML response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryRequester Methods

Methods
Name | Description
SendAttributeQueryReceiveResponseBySOAP(WebRequest, XmlElement) | Sends the attribute query and receives a SAML response over SOAP.
SendAttributeQueryReceiveResponseBySOAP(String, XmlElement) | Sends the attribute query and receives a SAML response over SOAP.
Top
See Also

Reference

AttributeQueryRequester Class
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryRequester.SendAttributeQueryReceiveResponseBySOAP Method

AttributeQueryRequesterSendAttributeQueryReceiveResponseBySOAP Method

Overload List
Name | Description
SendAttributeQueryReceiveResponseBySOAP(WebRequest, XmlElement) | Sends the attribute query and receives a SAML response over SOAP.
SendAttributeQueryReceiveResponseBySOAP(String, XmlElement) | Sends the attribute query and receives a SAML response over SOAP.
Top
See Also

Reference

AttributeQueryRequester Class
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryRequester.SendAttributeQueryReceiveResponseBySOAP Method (WebRequest, XmlElement)

AttributeQueryRequesterSendAttributeQueryReceiveResponseBySOAP Method (WebRequest, XmlElement)

Sends the attribute query and receives a SAML response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AttributeQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendAttributeQueryReceiveResponseBySOAP(
    WebRequest webRequest,
    XmlElement attributeQuery
)
Public Shared Function SendAttributeQueryReceiveResponseBySOAP (
    webRequest As WebRequest,
    attributeQuery As XmlElement
) As XmlElement
public:
static XmlElement^ SendAttributeQueryReceiveResponseBySOAP(
    WebRequest^ webRequest,
    XmlElement^ attributeQuery
)
static member SendAttributeQueryReceiveResponseBySOAP :
        webRequest : WebRequest *
        attributeQuery : XmlElement -> XmlElement

Parameters

webRequest
Type: System.NetWebRequest
The WebRequest used to send the request and receive the response.
attributeQuery
Type: System.XmlXmlElement
The attribute query.

Return Value

Type: XmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send/receive fails.
See Also

Reference

AttributeQueryRequester Class
SendAttributeQueryReceiveResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryRequester.SendAttributeQueryReceiveResponseBySOAP Method (String, XmlElement)

AttributeQueryRequesterSendAttributeQueryReceiveResponseBySOAP Method (String, XmlElement)

Sends the attribute query and receives a SAML response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AttributeQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendAttributeQueryReceiveResponseBySOAP(
    string destinationURL,
    XmlElement attributeQuery
)
Public Shared Function SendAttributeQueryReceiveResponseBySOAP (
    destinationURL As String,
    attributeQuery As XmlElement
) As XmlElement
public:
static XmlElement^ SendAttributeQueryReceiveResponseBySOAP(
    String^ destinationURL,
    XmlElement^ attributeQuery
)
static member SendAttributeQueryReceiveResponseBySOAP :
        destinationURL : string *
        attributeQuery : XmlElement -> XmlElement

Parameters

destinationURL
Type: SystemString
The destination URL.
attributeQuery
Type: System.XmlXmlElement
The attribute query.

Return Value

Type: XmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send/receive fails.
See Also

Reference

AttributeQueryRequester Class
SendAttributeQueryReceiveResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryResponder Class

Supports the attribute query profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.AttributeQueryAttributeQueryResponder

Namespace: ComponentSpace.SAML2.Profiles.AttributeQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AttributeQueryResponder
Public NotInheritable Class AttributeQueryResponder
public ref class AttributeQueryResponder abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AttributeQueryResponder =  class end
Methods
Name | Description
ReceiveAttributeQueryBySOAP(HttpRequest) | Receives the attribute query over SOAP.
ReceiveAttributeQueryBySOAP(HttpRequestBase) | Receives the attribute query over SOAP.
SendSAMLResponseBySOAP(HttpResponse, XmlElement) | Sends the SAML response over SOAP.
SendSAMLResponseBySOAP(HttpResponseBase, XmlElement) | Sends the SAML response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryResponder Methods

Methods
Name | Description
ReceiveAttributeQueryBySOAP(HttpRequest) | Receives the attribute query over SOAP.
ReceiveAttributeQueryBySOAP(HttpRequestBase) | Receives the attribute query over SOAP.
SendSAMLResponseBySOAP(HttpResponse, XmlElement) | Sends the SAML response over SOAP.
SendSAMLResponseBySOAP(HttpResponseBase, XmlElement) | Sends the SAML response over SOAP.
Top
See Also

Reference

AttributeQueryResponder Class
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryResponder.ReceiveAttributeQueryBySOAP Method

AttributeQueryResponderReceiveAttributeQueryBySOAP Method

Overload List
Name | Description
ReceiveAttributeQueryBySOAP(HttpRequest) | Receives the attribute query over SOAP.
ReceiveAttributeQueryBySOAP(HttpRequestBase) | Receives the attribute query over SOAP.
Top
See Also

Reference

AttributeQueryResponder Class
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryResponder.ReceiveAttributeQueryBySOAP Method (HttpRequest)

AttributeQueryResponderReceiveAttributeQueryBySOAP Method (HttpRequest)

Receives the attribute query over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AttributeQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveAttributeQueryBySOAP(
    HttpRequest httpRequest
)
Public Shared Function ReceiveAttributeQueryBySOAP (
    httpRequest As HttpRequest
) As XmlElement
public:
static XmlElement^ ReceiveAttributeQueryBySOAP(
    HttpRequest^ httpRequest
)
static member ReceiveAttributeQueryBySOAP :
        httpRequest : HttpRequest -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the attribute query.

Return Value

Type: XmlElement
The attribute query.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

AttributeQueryResponder Class
ReceiveAttributeQueryBySOAP Overload
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryResponder.ReceiveAttributeQueryBySOAP Method (HttpRequestBase)

AttributeQueryResponderReceiveAttributeQueryBySOAP Method (HttpRequestBase)

Receives the attribute query over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AttributeQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveAttributeQueryBySOAP(
    HttpRequestBase httpRequest
)
Public Shared Function ReceiveAttributeQueryBySOAP (
    httpRequest As HttpRequestBase
) As XmlElement
public:
static XmlElement^ ReceiveAttributeQueryBySOAP(
    HttpRequestBase^ httpRequest
)
static member ReceiveAttributeQueryBySOAP :
        httpRequest : HttpRequestBase -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the attribute query.

Return Value

Type: XmlElement
The attribute query.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

AttributeQueryResponder Class
ReceiveAttributeQueryBySOAP Overload
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryResponder.SendSAMLResponseBySOAP Method

AttributeQueryResponderSendSAMLResponseBySOAP Method

Overload List
Name | Description
SendSAMLResponseBySOAP(HttpResponse, XmlElement) | Sends the SAML response over SOAP.
SendSAMLResponseBySOAP(HttpResponseBase, XmlElement) | Sends the SAML response over SOAP.
Top
See Also

Reference

AttributeQueryResponder Class
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryResponder.SendSAMLResponseBySOAP Method (HttpResponse, XmlElement)

AttributeQueryResponderSendSAMLResponseBySOAP Method (HttpResponse, XmlElement)

Sends the SAML response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AttributeQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSAMLResponseBySOAP(
    HttpResponse httpResponse,
    XmlElement samlResponse
)
Public Shared Sub SendSAMLResponseBySOAP (
    httpResponse As HttpResponse,
    samlResponse As XmlElement
)
public:
static void SendSAMLResponseBySOAP(
    HttpResponse^ httpResponse,
    XmlElement^ samlResponse
)
static member SendSAMLResponseBySOAP :
        httpResponse : HttpResponse *
        samlResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to send the SAML response.
samlResponse
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

AttributeQueryResponder Class
SendSAMLResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


AttributeQueryResponder.SendSAMLResponseBySOAP Method (HttpResponseBase, XmlElement)

AttributeQueryResponderSendSAMLResponseBySOAP Method (HttpResponseBase, XmlElement)

Sends the SAML response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AttributeQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSAMLResponseBySOAP(
    HttpResponseBase httpResponse,
    XmlElement samlResponse
)
Public Shared Sub SendSAMLResponseBySOAP (
    httpResponse As HttpResponseBase,
    samlResponse As XmlElement
)
public:
static void SendSAMLResponseBySOAP(
    HttpResponseBase^ httpResponse,
    XmlElement^ samlResponse
)
static member SendSAMLResponseBySOAP :
        httpResponse : HttpResponseBase *
        samlResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to send the SAML response.
samlResponse
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

AttributeQueryResponder Class
SendSAMLResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.AttributeQuery Namespace


ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace

The ComponentSpace.SAML2.Profiles.AuthenticationQuery namespace contains classes associated with the SAML v2.0 authentication query profile.
Classes
 | Class | Description
Public class | AuthenticationQueryRequester | Supports the authentication query profile.
Public class | AuthenticationQueryResponder | Supports the authentication query profile.


AuthenticationQueryRequester Class

Supports the authentication query profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.AuthenticationQueryAuthenticationQueryRequester

Namespace: ComponentSpace.SAML2.Profiles.AuthenticationQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AuthenticationQueryRequester
Public NotInheritable Class AuthenticationQueryRequester
public ref class AuthenticationQueryRequester abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AuthenticationQueryRequester =  class end

The AuthenticationQueryRequester type exposes the following members.

Methods
Name | Description
SendAuthenticationQueryReceiveResponseBySOAP | Sends the authentication query and receives a SAML response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


AuthenticationQueryRequester Methods

The AuthenticationQueryRequester type exposes the following members.

Methods
Name | Description
SendAuthenticationQueryReceiveResponseBySOAP | Sends the authentication query and receives a SAML response over SOAP.
Top
See Also

Reference

AuthenticationQueryRequester Class
ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


AuthenticationQueryRequester.SendAuthenticationQueryReceiveResponseBySOAP Method

AuthenticationQueryRequesterSendAuthenticationQueryReceiveResponseBySOAP Method

Sends the authentication query and receives a SAML response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AuthenticationQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendAuthenticationQueryReceiveResponseBySOAP(
    string destinationURL,
    XmlElement authenticationQuery
)
Public Shared Function SendAuthenticationQueryReceiveResponseBySOAP (
    destinationURL As String,
    authenticationQuery As XmlElement
) As XmlElement
public:
static XmlElement^ SendAuthenticationQueryReceiveResponseBySOAP(
    String^ destinationURL,
    XmlElement^ authenticationQuery
)
static member SendAuthenticationQueryReceiveResponseBySOAP :
        destinationURL : string *
        authenticationQuery : XmlElement -> XmlElement

Parameters

destinationURL
Type: SystemString
The destination URL.
authenticationQuery
Type: System.XmlXmlElement
The authentication query.

Return Value

Type: XmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send/receive fails.
See Also

Reference

AuthenticationQueryRequester Class
ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


AuthenticationQueryResponder Class

Supports the authentication query profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.AuthenticationQueryAuthenticationQueryResponder

Namespace: ComponentSpace.SAML2.Profiles.AuthenticationQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AuthenticationQueryResponder
Public NotInheritable Class AuthenticationQueryResponder
public ref class AuthenticationQueryResponder abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AuthenticationQueryResponder =  class end
Methods
Name | Description
ReceiveAuthenticationQueryBySOAP(HttpRequest) | Receives the authentication query over SOAP.
ReceiveAuthenticationQueryBySOAP(HttpRequestBase) | Receives the authentication query over SOAP.
SendSAMLResponseBySOAP(HttpResponse, XmlElement) | Sends the SAML response over SOAP.
SendSAMLResponseBySOAP(HttpResponseBase, XmlElement) | Sends the SAML response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


AuthenticationQueryResponder Methods

Methods
Name | Description
ReceiveAuthenticationQueryBySOAP(HttpRequest) | Receives the authentication query over SOAP.
ReceiveAuthenticationQueryBySOAP(HttpRequestBase) | Receives the authentication query over SOAP.
SendSAMLResponseBySOAP(HttpResponse, XmlElement) | Sends the SAML response over SOAP.
SendSAMLResponseBySOAP(HttpResponseBase, XmlElement) | Sends the SAML response over SOAP.
Top
See Also

Reference

AuthenticationQueryResponder Class
ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


AuthenticationQueryResponder.ReceiveAuthenticationQueryBySOAP Method

AuthenticationQueryResponderReceiveAuthenticationQueryBySOAP Method

Overload List
Name | Description
ReceiveAuthenticationQueryBySOAP(HttpRequest) | Receives the authentication query over SOAP.
ReceiveAuthenticationQueryBySOAP(HttpRequestBase) | Receives the authentication query over SOAP.
Top
See Also

Reference

AuthenticationQueryResponder Class
ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


AuthenticationQueryResponder.ReceiveAuthenticationQueryBySOAP Method (HttpRequest)

AuthenticationQueryResponderReceiveAuthenticationQueryBySOAP Method (HttpRequest)

Receives the authentication query over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AuthenticationQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveAuthenticationQueryBySOAP(
    HttpRequest httpRequest
)
Public Shared Function ReceiveAuthenticationQueryBySOAP (
    httpRequest As HttpRequest
) As XmlElement
public:
static XmlElement^ ReceiveAuthenticationQueryBySOAP(
    HttpRequest^ httpRequest
)
static member ReceiveAuthenticationQueryBySOAP :
        httpRequest : HttpRequest -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the authentication query.

Return Value

Type: XmlElement
The authentication query.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

AuthenticationQueryResponder Class
ReceiveAuthenticationQueryBySOAP Overload
ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


AuthenticationQueryResponder.ReceiveAuthenticationQueryBySOAP Method (HttpRequestBase)

AuthenticationQueryResponderReceiveAuthenticationQueryBySOAP Method (HttpRequestBase)

Receives the authentication query over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AuthenticationQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveAuthenticationQueryBySOAP(
    HttpRequestBase httpRequest
)
Public Shared Function ReceiveAuthenticationQueryBySOAP (
    httpRequest As HttpRequestBase
) As XmlElement
public:
static XmlElement^ ReceiveAuthenticationQueryBySOAP(
    HttpRequestBase^ httpRequest
)
static member ReceiveAuthenticationQueryBySOAP :
        httpRequest : HttpRequestBase -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the authentication query.

Return Value

Type: XmlElement
The authentication query.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

AuthenticationQueryResponder Class
ReceiveAuthenticationQueryBySOAP Overload
ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


AuthenticationQueryResponder.SendSAMLResponseBySOAP Method

AuthenticationQueryResponderSendSAMLResponseBySOAP Method

Overload List
Name | Description
SendSAMLResponseBySOAP(HttpResponse, XmlElement) | Sends the SAML response over SOAP.
SendSAMLResponseBySOAP(HttpResponseBase, XmlElement) | Sends the SAML response over SOAP.
Top
See Also

Reference

AuthenticationQueryResponder Class
ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


AuthenticationQueryResponder.SendSAMLResponseBySOAP Method (HttpResponse, XmlElement)

AuthenticationQueryResponderSendSAMLResponseBySOAP Method (HttpResponse, XmlElement)

Sends the SAML response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AuthenticationQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSAMLResponseBySOAP(
    HttpResponse httpResponse,
    XmlElement samlResponse
)
Public Shared Sub SendSAMLResponseBySOAP (
    httpResponse As HttpResponse,
    samlResponse As XmlElement
)
public:
static void SendSAMLResponseBySOAP(
    HttpResponse^ httpResponse,
    XmlElement^ samlResponse
)
static member SendSAMLResponseBySOAP :
        httpResponse : HttpResponse *
        samlResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to send the SAML response.
samlResponse
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

AuthenticationQueryResponder Class
SendSAMLResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


AuthenticationQueryResponder.SendSAMLResponseBySOAP Method (HttpResponseBase, XmlElement)

AuthenticationQueryResponderSendSAMLResponseBySOAP Method (HttpResponseBase, XmlElement)

Sends the SAML response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.AuthenticationQuery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSAMLResponseBySOAP(
    HttpResponseBase httpResponse,
    XmlElement samlResponse
)
Public Shared Sub SendSAMLResponseBySOAP (
    httpResponse As HttpResponseBase,
    samlResponse As XmlElement
)
public:
static void SendSAMLResponseBySOAP(
    HttpResponseBase^ httpResponse,
    XmlElement^ samlResponse
)
static member SendSAMLResponseBySOAP :
        httpResponse : HttpResponseBase *
        samlResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to send the SAML response.
samlResponse
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

AuthenticationQueryResponder Class
SendSAMLResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.AuthenticationQuery Namespace


ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace

The ComponentSpace.SAML2.Profiles.IdPDiscovery namespace contains classes associated with the SAML v2.0 IdP discovery profile.
Classes
 | Class | Description
Public class | CommonDomainCookie | Provides common domain cookie (CDC) functionality in the identity provider discovery profile.


CommonDomainCookie Class

Provides common domain cookie (CDC) functionality in the identity provider discovery profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.IdPDiscoveryCommonDomainCookie

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class CommonDomainCookie
Public Class CommonDomainCookie
public ref class CommonDomainCookie
type CommonDomainCookie =  class end

The CommonDomainCookie type exposes the following members.

Constructors
 | Name | Description
Public method | CommonDomainCookie | Initializes a new instance of the CommonDomainCookie class.
Public method | CommonDomainCookie(HttpRequest) | Initializes a new instance of the CommonDomainCookie class from an HTTP request.
Public method | CommonDomainCookie(HttpRequestBase) | Initializes a new instance of the CommonDomainCookie class from an HTTP request.
Public method | CommonDomainCookie(String, String) | Initializes a new instance of the CommonDomainCookie class from a cookie value.
Top
Properties
 | Name | Description
Public property | CommonDomain | Gets or sets the common domain name.
Public property | IdPIdentifiers | Gets or sets the list of identity provider IDs.
Top
Methods
 | Name | Description
Public method | AddIdPIdentifier | Adds the identity provider ID to the list of identity provider IDs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCookie(HttpResponse) | Sets the CDC in the HTTP response.
Public method | SetCookie(HttpResponseBase) | Sets the CDC in the HTTP response.
Public method | ToCookie | Converts the CommonDomainCookie to an HttpCookie.
Public method | ToString | Returns the cookie value. (Overrides ObjectToString.)
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie Constructor

Overload List
 | Name | Description
Public method | CommonDomainCookie | Initializes a new instance of the CommonDomainCookie class.
Public method | CommonDomainCookie(HttpRequest) | Initializes a new instance of the CommonDomainCookie class from an HTTP request.
Public method | CommonDomainCookie(HttpRequestBase) | Initializes a new instance of the CommonDomainCookie class from an HTTP request.
Public method | CommonDomainCookie(String, String) | Initializes a new instance of the CommonDomainCookie class from a cookie value.
Top
See Also

Reference

CommonDomainCookie Class
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie Constructor

Initializes a new instance of the CommonDomainCookie class.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public CommonDomainCookie()
Public Sub New
public:
CommonDomainCookie()
new : unit -> CommonDomainCookie
See Also

Reference

CommonDomainCookie Class
CommonDomainCookie Overload
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie Constructor (HttpRequest)

Initializes a new instance of the CommonDomainCookie class from an HTTP request.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public CommonDomainCookie(
    HttpRequest httpRequest
)
Public Sub New (
    httpRequest As HttpRequest
)
public:
CommonDomainCookie(
    HttpRequest^ httpRequest
)
new :
        httpRequest : HttpRequest -> CommonDomainCookie

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request.
See Also

Reference

CommonDomainCookie Class
CommonDomainCookie Overload
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie Constructor (HttpRequestBase)

Initializes a new instance of the CommonDomainCookie class from an HTTP request.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public CommonDomainCookie(
    HttpRequestBase httpRequest
)
Public Sub New (
    httpRequest As HttpRequestBase
)
public:
CommonDomainCookie(
    HttpRequestBase^ httpRequest
)
new :
        httpRequest : HttpRequestBase -> CommonDomainCookie

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request.
See Also

Reference

CommonDomainCookie Class
CommonDomainCookie Overload
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie Constructor (String, String)

Initializes a new instance of the CommonDomainCookie class from a cookie value.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public CommonDomainCookie(
    string commonDomain,
    string cookieValue
)
Public Sub New (
    commonDomain As String,
    cookieValue As String
)
public:
CommonDomainCookie(
    String^ commonDomain,
    String^ cookieValue
)
new :
        commonDomain : string *
        cookieValue : string -> CommonDomainCookie

Parameters

commonDomain
Type: SystemString
The common domain.
cookieValue
Type: SystemString
The cookie value.
See Also

Reference

CommonDomainCookie Class
CommonDomainCookie Overload
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie Properties

The CommonDomainCookie type exposes the following members.

Properties
 | Name | Description
Public property | CommonDomain | Gets or sets the common domain name.
Public property | IdPIdentifiers | Gets or sets the list of identity provider IDs.
Top
See Also

Reference

CommonDomainCookie Class
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie.CommonDomain Property

CommonDomainCookieCommonDomain Property

Gets or sets the common domain name.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string CommonDomain { get; set; }
Public Property CommonDomain As String
    Get
    Set
public:
property String^ CommonDomain {
    String^ get ();
    void set (String^ value);
}
member CommonDomain : string with get, set

Property Value

Type: String
The common domain name.
See Also

Reference

CommonDomainCookie Class
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie.IdPIdentifiers Property

CommonDomainCookieIdPIdentifiers Property

Gets or sets the list of identity provider IDs.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<string> IdPIdentifiers { get; set; }
Public Property IdPIdentifiers As IList(Of String)
    Get
    Set
public:
property IList<String^>^ IdPIdentifiers {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member IdPIdentifiers : IList<string> with get, set

Property Value

Type: IList String
The list of identity provider IDs.
See Also

Reference

CommonDomainCookie Class
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie Methods

The CommonDomainCookie type exposes the following members.

Methods
 | Name | Description
Public method | AddIdPIdentifier | Adds the identity provider ID to the list of identity provider IDs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCookie(HttpResponse) | Sets the CDC in the HTTP response.
Public method | SetCookie(HttpResponseBase) | Sets the CDC in the HTTP response.
Public method | ToCookie | Converts the CommonDomainCookie to an HttpCookie.
Public method | ToString | Returns the cookie value. (Overrides ObjectToString.)
Top
See Also

Reference

CommonDomainCookie Class
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie.AddIdPIdentifier Method

CommonDomainCookieAddIdPIdentifier Method

Adds the identity provider ID to the list of identity provider IDs.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void AddIdPIdentifier(
    string idpIdentifier
)
Public Sub AddIdPIdentifier (
    idpIdentifier As String
)
public:
void AddIdPIdentifier(
    String^ idpIdentifier
)
member AddIdPIdentifier :
        idpIdentifier : string -> unit

Parameters

idpIdentifier
Type: SystemString
The identity provider ID.
See Also

Reference

CommonDomainCookie Class
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie.SetCookie Method

CommonDomainCookieSetCookie Method

Overload List
 | Name | Description
Public method | SetCookie(HttpResponse) | Sets the CDC in the HTTP response.
Public method | SetCookie(HttpResponseBase) | Sets the CDC in the HTTP response.
Top
See Also

Reference

CommonDomainCookie Class
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie.SetCookie Method (HttpResponse)

CommonDomainCookieSetCookie Method (HttpResponse)

Sets the CDC in the HTTP response.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void SetCookie(
    HttpResponse httpResponse
)
Public Sub SetCookie (
    httpResponse As HttpResponse
)
public:
void SetCookie(
    HttpResponse^ httpResponse
)
member SetCookie :
        httpResponse : HttpResponse -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response.
See Also

Reference

CommonDomainCookie Class
SetCookie Overload
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie.SetCookie Method (HttpResponseBase)

CommonDomainCookieSetCookie Method (HttpResponseBase)

Sets the CDC in the HTTP response.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void SetCookie(
    HttpResponseBase httpResponse
)
Public Sub SetCookie (
    httpResponse As HttpResponseBase
)
public:
void SetCookie(
    HttpResponseBase^ httpResponse
)
member SetCookie :
        httpResponse : HttpResponseBase -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response.
See Also

Reference

CommonDomainCookie Class
SetCookie Overload
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie.ToCookie Method

CommonDomainCookieToCookie Method

Converts the CommonDomainCookie to an HttpCookie.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public HttpCookie ToCookie()
Public Function ToCookie As HttpCookie
public:
HttpCookie^ ToCookie()
member ToCookie : unit -> HttpCookie

Return Value

Type: HttpCookie
The HttpCookie.
See Also

Reference

CommonDomainCookie Class
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


CommonDomainCookie.ToString Method

CommonDomainCookieToString Method

Returns the cookie value.

Namespace: ComponentSpace.SAML2.Profiles.IdPDiscovery
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The cookie value.
See Also

Reference

CommonDomainCookie Class
ComponentSpace.SAML2.Profiles.IdPDiscovery Namespace


ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace

The ComponentSpace.SAML2.Profiles.NameIdentifierManagement namespace contains classes associated with the SAML v2.0 name identifier management profile.
Classes
 | Class | Description
Public class | ManageNameIDRequester | Supports the name identifier management profile.
Public class | ManageNameIDResponder | Supports the name identifier management profile.
Public class | NameIDMappingResponder | Supports the name identifier mapping profile.


ManageNameIDRequester Class

Supports the name identifier management profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.NameIdentifierManagementManageNameIDRequester

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class ManageNameIDRequester
Public NotInheritable Class ManageNameIDRequester
public ref class ManageNameIDRequester abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ManageNameIDRequester =  class end

The ManageNameIDRequester type exposes the following members.

Methods
Name | Description
ReceiveManageNameIDResponseByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier response using HTTP redirect.
ReceiveManageNameIDResponseByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier response using HTTP redirect.
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
SendManageNameIDRequestByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the manage name identifier request using HTTP post.
SendManageNameIDRequestByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the manage name identifier request using HTTP post.
SendManageNameIDRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier request using HTTP redirect.
SendManageNameIDRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier request using HTTP redirect.
SendManageNameIDRequestReceiveResponseBySOAP | Sends the manage name identifier request and receives a manage name identifier response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester Methods

The ManageNameIDRequester type exposes the following members.

Methods
Name | Description
ReceiveManageNameIDResponseByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier response using HTTP redirect.
ReceiveManageNameIDResponseByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier response using HTTP redirect.
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
SendManageNameIDRequestByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the manage name identifier request using HTTP post.
SendManageNameIDRequestByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the manage name identifier request using HTTP post.
SendManageNameIDRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier request using HTTP redirect.
SendManageNameIDRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier request using HTTP redirect.
SendManageNameIDRequestReceiveResponseBySOAP | Sends the manage name identifier request and receives a manage name identifier response over SOAP.
Top
See Also

Reference

ManageNameIDRequester Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.ReceiveManageNameIDResponseByHTTPRedirect Method

ManageNameIDRequesterReceiveManageNameIDResponseByHTTPRedirect Method

Overload List
Name | Description
ReceiveManageNameIDResponseByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier response using HTTP redirect.
ReceiveManageNameIDResponseByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier response using HTTP redirect.
Top
See Also

Reference

ManageNameIDRequester Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.ReceiveManageNameIDResponseByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

ManageNameIDRequesterReceiveManageNameIDResponseByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the manage name identifier response using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveManageNameIDResponseByHTTPRedirect(
    HttpRequest httpRequest,
    out XmlElement manageNameIDResponse,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveManageNameIDResponseByHTTPRedirect (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef manageNameIDResponse As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveManageNameIDResponseByHTTPRedirect(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% manageNameIDResponse,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveManageNameIDResponseByHTTPRedirect :
        httpRequest : HttpRequest *
        manageNameIDResponse : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
manageNameIDResponse
Type: System.XmlXmlElement
The returned manage name identifier response.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ManageNameIDRequester Class
ReceiveManageNameIDResponseByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.ReceiveManageNameIDResponseByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

ManageNameIDRequesterReceiveManageNameIDResponseByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the manage name identifier response using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveManageNameIDResponseByHTTPRedirect(
    HttpRequestBase httpRequest,
    out XmlElement manageNameIDResponse,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveManageNameIDResponseByHTTPRedirect (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef manageNameIDResponse As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveManageNameIDResponseByHTTPRedirect(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% manageNameIDResponse,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveManageNameIDResponseByHTTPRedirect :
        httpRequest : HttpRequestBase *
        manageNameIDResponse : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
manageNameIDResponse
Type: System.XmlXmlElement
The returned manage name identifier response.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ManageNameIDRequester Class
ReceiveManageNameIDResponseByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.SendArtifactByHTTPArtifact Method

ManageNameIDRequesterSendArtifactByHTTPArtifact Method

Overload List
Name | Description
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
Top
See Also

Reference

ManageNameIDRequester Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.SendArtifactByHTTPArtifact Method (HttpResponse, String, HTTPArtifact, String, Boolean)

ManageNameIDRequesterSendArtifactByHTTPArtifact Method (HttpResponse, String, HTTPArtifact, String, Boolean)

Sends an artifact using the HTTP artifact binding.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactByHTTPArtifact(
    HttpResponse httpResponse,
    string destinationURL,
    HTTPArtifact httpArtifact,
    string relayState,
    bool sendArtifactInForm
)
Public Shared Sub SendArtifactByHTTPArtifact (
    httpResponse As HttpResponse,
    destinationURL As String,
    httpArtifact As HTTPArtifact,
    relayState As String,
    sendArtifactInForm As Boolean
)
public:
static void SendArtifactByHTTPArtifact(
    HttpResponse^ httpResponse,
    String^ destinationURL,
    HTTPArtifact^ httpArtifact,
    String^ relayState,
    bool sendArtifactInForm
)
static member SendArtifactByHTTPArtifact :
        httpResponse : HttpResponse *
        destinationURL : string *
        httpArtifact : HTTPArtifact *
        relayState : string *
        sendArtifactInForm : bool -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will send the artifact.
destinationURL
Type: SystemString
The destination URL.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact.
relayState
Type: SystemString
The relay state or null if none.
sendArtifactInForm
Type: SystemBoolean
If true the artifact is sent in a form; otherwise it's sent in a query string.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ManageNameIDRequester Class
SendArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.SendArtifactByHTTPArtifact Method (HttpResponseBase, String, HTTPArtifact, String, Boolean)

ManageNameIDRequesterSendArtifactByHTTPArtifact Method (HttpResponseBase, String, HTTPArtifact, String, Boolean)

Sends an artifact using the HTTP artifact binding.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactByHTTPArtifact(
    HttpResponseBase httpResponse,
    string destinationURL,
    HTTPArtifact httpArtifact,
    string relayState,
    bool sendArtifactInForm
)
Public Shared Sub SendArtifactByHTTPArtifact (
    httpResponse As HttpResponseBase,
    destinationURL As String,
    httpArtifact As HTTPArtifact,
    relayState As String,
    sendArtifactInForm As Boolean
)
public:
static void SendArtifactByHTTPArtifact(
    HttpResponseBase^ httpResponse,
    String^ destinationURL,
    HTTPArtifact^ httpArtifact,
    String^ relayState,
    bool sendArtifactInForm
)
static member SendArtifactByHTTPArtifact :
        httpResponse : HttpResponseBase *
        destinationURL : string *
        httpArtifact : HTTPArtifact *
        relayState : string *
        sendArtifactInForm : bool -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will send the artifact.
destinationURL
Type: SystemString
The destination URL.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact.
relayState
Type: SystemString
The relay state or null if none.
sendArtifactInForm
Type: SystemBoolean
If true the artifact is sent in a form; otherwise it's sent in a query string.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ManageNameIDRequester Class
SendArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.SendManageNameIDRequestByHTTPPost Method

ManageNameIDRequesterSendManageNameIDRequestByHTTPPost Method

Overload List
Name | Description
SendManageNameIDRequestByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the manage name identifier request using HTTP post.
SendManageNameIDRequestByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the manage name identifier request using HTTP post.
Top
See Also

Reference

ManageNameIDRequester Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.SendManageNameIDRequestByHTTPPost Method (HttpResponse, String, XmlElement, String)

ManageNameIDRequesterSendManageNameIDRequestByHTTPPost Method (HttpResponse, String, XmlElement, String)

Sends the manage name identifier request using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendManageNameIDRequestByHTTPPost(
    HttpResponse httpResponse,
    string destinationURL,
    XmlElement manageNameIDRequest,
    string relayState
)
Public Shared Sub SendManageNameIDRequestByHTTPPost (
    httpResponse As HttpResponse,
    destinationURL As String,
    manageNameIDRequest As XmlElement,
    relayState As String
)
public:
static void SendManageNameIDRequestByHTTPPost(
    HttpResponse^ httpResponse,
    String^ destinationURL,
    XmlElement^ manageNameIDRequest,
    String^ relayState
)
static member SendManageNameIDRequestByHTTPPost :
        httpResponse : HttpResponse *
        destinationURL : string *
        manageNameIDRequest : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will return the form to post.
destinationURL
Type: SystemString
The destination URL.
manageNameIDRequest
Type: System.XmlXmlElement
The manage name identifier request.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ManageNameIDRequester Class
SendManageNameIDRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.SendManageNameIDRequestByHTTPPost Method (HttpResponseBase, String, XmlElement, String)

ManageNameIDRequesterSendManageNameIDRequestByHTTPPost Method (HttpResponseBase, String, XmlElement, String)

Sends the manage name identifier request using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendManageNameIDRequestByHTTPPost(
    HttpResponseBase httpResponse,
    string destinationURL,
    XmlElement manageNameIDRequest,
    string relayState
)
Public Shared Sub SendManageNameIDRequestByHTTPPost (
    httpResponse As HttpResponseBase,
    destinationURL As String,
    manageNameIDRequest As XmlElement,
    relayState As String
)
public:
static void SendManageNameIDRequestByHTTPPost(
    HttpResponseBase^ httpResponse,
    String^ destinationURL,
    XmlElement^ manageNameIDRequest,
    String^ relayState
)
static member SendManageNameIDRequestByHTTPPost :
        httpResponse : HttpResponseBase *
        destinationURL : string *
        manageNameIDRequest : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will return the form to post.
destinationURL
Type: SystemString
The destination URL.
manageNameIDRequest
Type: System.XmlXmlElement
The manage name identifier request.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ManageNameIDRequester Class
SendManageNameIDRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.SendManageNameIDRequestByHTTPRedirect Method

ManageNameIDRequesterSendManageNameIDRequestByHTTPRedirect Method

Overload List
Name | Description
SendManageNameIDRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier request using HTTP redirect.
SendManageNameIDRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier request using HTTP redirect.
Top
See Also

Reference

ManageNameIDRequester Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.SendManageNameIDRequestByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm)

ManageNameIDRequesterSendManageNameIDRequestByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm)

Sends the manage name identifier request using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendManageNameIDRequestByHTTPRedirect(
    HttpResponse httpResponse,
    string destinationURL,
    XmlElement manageNameIDRequest,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Sub SendManageNameIDRequestByHTTPRedirect (
    httpResponse As HttpResponse,
    destinationURL As String,
    manageNameIDRequest As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
)
public:
static void SendManageNameIDRequestByHTTPRedirect(
    HttpResponse^ httpResponse,
    String^ destinationURL,
    XmlElement^ manageNameIDRequest,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member SendManageNameIDRequestByHTTPRedirect :
        httpResponse : HttpResponse *
        destinationURL : string *
        manageNameIDRequest : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
destinationURL
Type: SystemString
The destination URL.
manageNameIDRequest
Type: System.XmlXmlElement
The manage name identifier request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ManageNameIDRequester Class
SendManageNameIDRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.SendManageNameIDRequestByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm)

ManageNameIDRequesterSendManageNameIDRequestByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm)

Sends the manage name identifier request using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendManageNameIDRequestByHTTPRedirect(
    HttpResponseBase httpResponse,
    string destinationURL,
    XmlElement manageNameIDRequest,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Sub SendManageNameIDRequestByHTTPRedirect (
    httpResponse As HttpResponseBase,
    destinationURL As String,
    manageNameIDRequest As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
)
public:
static void SendManageNameIDRequestByHTTPRedirect(
    HttpResponseBase^ httpResponse,
    String^ destinationURL,
    XmlElement^ manageNameIDRequest,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member SendManageNameIDRequestByHTTPRedirect :
        httpResponse : HttpResponseBase *
        destinationURL : string *
        manageNameIDRequest : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
destinationURL
Type: SystemString
The destination URL.
manageNameIDRequest
Type: System.XmlXmlElement
The manage name identifier request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ManageNameIDRequester Class
SendManageNameIDRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDRequester.SendManageNameIDRequestReceiveResponseBySOAP Method

ManageNameIDRequesterSendManageNameIDRequestReceiveResponseBySOAP Method

Sends the manage name identifier request and receives a manage name identifier response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendManageNameIDRequestReceiveResponseBySOAP(
    string destinationURL,
    XmlElement manageNameIDRequest
)
Public Shared Function SendManageNameIDRequestReceiveResponseBySOAP (
    destinationURL As String,
    manageNameIDRequest As XmlElement
) As XmlElement
public:
static XmlElement^ SendManageNameIDRequestReceiveResponseBySOAP(
    String^ destinationURL,
    XmlElement^ manageNameIDRequest
)
static member SendManageNameIDRequestReceiveResponseBySOAP :
        destinationURL : string *
        manageNameIDRequest : XmlElement -> XmlElement

Parameters

destinationURL
Type: SystemString
The destination URL.
manageNameIDRequest
Type: System.XmlXmlElement
The manage name identifier request.

Return Value

Type: XmlElement
The manage name identifier response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send/receive fails.
See Also

Reference

ManageNameIDRequester Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder Class

Supports the name identifier management profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.NameIdentifierManagementManageNameIDResponder

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class ManageNameIDResponder
Public NotInheritable Class ManageNameIDResponder
public ref class ManageNameIDResponder abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ManageNameIDResponder =  class end
Methods
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
ReceiveManageNameIDRequestByHTTPPost(HttpRequest, XmlElement, String) | Receives the manage name identifier request using HTTP post.
ReceiveManageNameIDRequestByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the manage name identifier request using HTTP post.
ReceiveManageNameIDRequestByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier request using HTTP redirect.
ReceiveManageNameIDRequestByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier request using HTTP redirect.
ReceiveManageNameIDRequestBySOAP(HttpRequest) | Receives the manage name identifier request over SOAP.
ReceiveManageNameIDRequestBySOAP(HttpRequestBase) | Receives the manage name identifier request over SOAP.
SendManageNameIDResponseByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier response using HTTP redirect.
SendManageNameIDResponseByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier response using HTTP redirect.
SendManageNameIDResponseBySOAP(HttpResponse, XmlElement) | Sends the manage name identifier response over SOAP.
SendManageNameIDResponseBySOAP(HttpResponseBase, XmlElement) | Sends the manage name identifier response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder Methods

Methods
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
ReceiveManageNameIDRequestByHTTPPost(HttpRequest, XmlElement, String) | Receives the manage name identifier request using HTTP post.
ReceiveManageNameIDRequestByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the manage name identifier request using HTTP post.
ReceiveManageNameIDRequestByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier request using HTTP redirect.
ReceiveManageNameIDRequestByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier request using HTTP redirect.
ReceiveManageNameIDRequestBySOAP(HttpRequest) | Receives the manage name identifier request over SOAP.
ReceiveManageNameIDRequestBySOAP(HttpRequestBase) | Receives the manage name identifier request over SOAP.
SendManageNameIDResponseByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier response using HTTP redirect.
SendManageNameIDResponseByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier response using HTTP redirect.
SendManageNameIDResponseBySOAP(HttpResponse, XmlElement) | Sends the manage name identifier response over SOAP.
SendManageNameIDResponseBySOAP(HttpResponseBase, XmlElement) | Sends the manage name identifier response over SOAP.
Top
See Also

Reference

ManageNameIDResponder Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveArtifactByHTTPArtifact Method

ManageNameIDResponderReceiveArtifactByHTTPArtifact Method

Overload List
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
Top
See Also

Reference

ManageNameIDResponder Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveArtifactByHTTPArtifact Method (HttpRequest, Boolean, HTTPArtifact, String)

ManageNameIDResponderReceiveArtifactByHTTPArtifact Method (HttpRequest, Boolean, HTTPArtifact, String)

Receives the artifact using HTTP artifact with the artifact being in a form or query string.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactByHTTPArtifact(
    HttpRequest httpRequest,
    bool artifactInForm,
    out HTTPArtifact httpArtifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactByHTTPArtifact (
    httpRequest As HttpRequest,
    artifactInForm As Boolean,
    <OutAttribute> ByRef httpArtifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactByHTTPArtifact(
    HttpRequest^ httpRequest,
    bool artifactInForm,
    [OutAttribute] HTTPArtifact^% httpArtifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactByHTTPArtifact :
        httpRequest : HttpRequest *
        artifactInForm : bool *
        httpArtifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the artifact.
artifactInForm
Type: SystemBoolean
If true the artifact is received in a form; otherwise it's received in a query string.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ManageNameIDResponder Class
ReceiveArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveArtifactByHTTPArtifact Method (HttpRequestBase, Boolean, HTTPArtifact, String)

ManageNameIDResponderReceiveArtifactByHTTPArtifact Method (HttpRequestBase, Boolean, HTTPArtifact, String)

Receives the artifact using HTTP artifact with the artifact being in a form or query string.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactByHTTPArtifact(
    HttpRequestBase httpRequest,
    bool artifactInForm,
    out HTTPArtifact httpArtifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactByHTTPArtifact (
    httpRequest As HttpRequestBase,
    artifactInForm As Boolean,
    <OutAttribute> ByRef httpArtifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactByHTTPArtifact(
    HttpRequestBase^ httpRequest,
    bool artifactInForm,
    [OutAttribute] HTTPArtifact^% httpArtifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactByHTTPArtifact :
        httpRequest : HttpRequestBase *
        artifactInForm : bool *
        httpArtifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the artifact.
artifactInForm
Type: SystemBoolean
If true the artifact is received in a form; otherwise it's received in a query string.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ManageNameIDResponder Class
ReceiveArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveManageNameIDRequestByHTTPPost Method

ManageNameIDResponderReceiveManageNameIDRequestByHTTPPost Method

Overload List
Name | Description
ReceiveManageNameIDRequestByHTTPPost(HttpRequest, XmlElement, String) | Receives the manage name identifier request using HTTP post.
ReceiveManageNameIDRequestByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the manage name identifier request using HTTP post.
Top
See Also

Reference

ManageNameIDResponder Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveManageNameIDRequestByHTTPPost Method (HttpRequest, XmlElement, String)

ManageNameIDResponderReceiveManageNameIDRequestByHTTPPost Method (HttpRequest, XmlElement, String)

Receives the manage name identifier request using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveManageNameIDRequestByHTTPPost(
    HttpRequest httpRequest,
    out XmlElement manageNameIDRequest,
    out string relayState
)
Public Shared Sub ReceiveManageNameIDRequestByHTTPPost (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef manageNameIDRequest As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveManageNameIDRequestByHTTPPost(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% manageNameIDRequest,
    [OutAttribute] String^% relayState
)
static member ReceiveManageNameIDRequestByHTTPPost :
        httpRequest : HttpRequest *
        manageNameIDRequest : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
manageNameIDRequest
Type: System.XmlXmlElement
The returned manage name identifier request.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ManageNameIDResponder Class
ReceiveManageNameIDRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveManageNameIDRequestByHTTPPost Method (HttpRequestBase, XmlElement, String)

ManageNameIDResponderReceiveManageNameIDRequestByHTTPPost Method (HttpRequestBase, XmlElement, String)

Receives the manage name identifier request using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveManageNameIDRequestByHTTPPost(
    HttpRequestBase httpRequest,
    out XmlElement manageNameIDRequest,
    out string relayState
)
Public Shared Sub ReceiveManageNameIDRequestByHTTPPost (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef manageNameIDRequest As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveManageNameIDRequestByHTTPPost(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% manageNameIDRequest,
    [OutAttribute] String^% relayState
)
static member ReceiveManageNameIDRequestByHTTPPost :
        httpRequest : HttpRequestBase *
        manageNameIDRequest : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
manageNameIDRequest
Type: System.XmlXmlElement
The returned manage name identifier request.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ManageNameIDResponder Class
ReceiveManageNameIDRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveManageNameIDRequestByHTTPRedirect Method

ManageNameIDResponderReceiveManageNameIDRequestByHTTPRedirect Method

Overload List
Name | Description
ReceiveManageNameIDRequestByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier request using HTTP redirect.
ReceiveManageNameIDRequestByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the manage name identifier request using HTTP redirect.
Top
See Also

Reference

ManageNameIDResponder Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveManageNameIDRequestByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

ManageNameIDResponderReceiveManageNameIDRequestByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the manage name identifier request using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveManageNameIDRequestByHTTPRedirect(
    HttpRequest httpRequest,
    out XmlElement manageNameIDRequest,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveManageNameIDRequestByHTTPRedirect (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef manageNameIDRequest As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveManageNameIDRequestByHTTPRedirect(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% manageNameIDRequest,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveManageNameIDRequestByHTTPRedirect :
        httpRequest : HttpRequest *
        manageNameIDRequest : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
manageNameIDRequest
Type: System.XmlXmlElement
The returned manage name identifier request.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ManageNameIDResponder Class
ReceiveManageNameIDRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveManageNameIDRequestByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

ManageNameIDResponderReceiveManageNameIDRequestByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the manage name identifier request using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveManageNameIDRequestByHTTPRedirect(
    HttpRequestBase httpRequest,
    out XmlElement manageNameIDRequest,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveManageNameIDRequestByHTTPRedirect (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef manageNameIDRequest As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveManageNameIDRequestByHTTPRedirect(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% manageNameIDRequest,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveManageNameIDRequestByHTTPRedirect :
        httpRequest : HttpRequestBase *
        manageNameIDRequest : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
manageNameIDRequest
Type: System.XmlXmlElement
The returned manage name identifier request.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ManageNameIDResponder Class
ReceiveManageNameIDRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveManageNameIDRequestBySOAP Method

ManageNameIDResponderReceiveManageNameIDRequestBySOAP Method

Overload List
Name | Description
ReceiveManageNameIDRequestBySOAP(HttpRequest) | Receives the manage name identifier request over SOAP.
ReceiveManageNameIDRequestBySOAP(HttpRequestBase) | Receives the manage name identifier request over SOAP.
Top
See Also

Reference

ManageNameIDResponder Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveManageNameIDRequestBySOAP Method (HttpRequest)

ManageNameIDResponderReceiveManageNameIDRequestBySOAP Method (HttpRequest)

Receives the manage name identifier request over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveManageNameIDRequestBySOAP(
    HttpRequest httpRequest
)
Public Shared Function ReceiveManageNameIDRequestBySOAP (
    httpRequest As HttpRequest
) As XmlElement
public:
static XmlElement^ ReceiveManageNameIDRequestBySOAP(
    HttpRequest^ httpRequest
)
static member ReceiveManageNameIDRequestBySOAP :
        httpRequest : HttpRequest -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the manage name identifier request.

Return Value

Type: XmlElement
The manage name identifier request.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ManageNameIDResponder Class
ReceiveManageNameIDRequestBySOAP Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.ReceiveManageNameIDRequestBySOAP Method (HttpRequestBase)

ManageNameIDResponderReceiveManageNameIDRequestBySOAP Method (HttpRequestBase)

Receives the manage name identifier request over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveManageNameIDRequestBySOAP(
    HttpRequestBase httpRequest
)
Public Shared Function ReceiveManageNameIDRequestBySOAP (
    httpRequest As HttpRequestBase
) As XmlElement
public:
static XmlElement^ ReceiveManageNameIDRequestBySOAP(
    HttpRequestBase^ httpRequest
)
static member ReceiveManageNameIDRequestBySOAP :
        httpRequest : HttpRequestBase -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the manage name identifier request.

Return Value

Type: XmlElement
The manage name identifier request.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ManageNameIDResponder Class
ReceiveManageNameIDRequestBySOAP Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.SendManageNameIDResponseByHTTPRedirect Method

ManageNameIDResponderSendManageNameIDResponseByHTTPRedirect Method

Overload List
Name | Description
SendManageNameIDResponseByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier response using HTTP redirect.
SendManageNameIDResponseByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the manage name identifier response using HTTP redirect.
Top
See Also

Reference

ManageNameIDResponder Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.SendManageNameIDResponseByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm)

ManageNameIDResponderSendManageNameIDResponseByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm)

Sends the manage name identifier response using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendManageNameIDResponseByHTTPRedirect(
    HttpResponse httpResponse,
    string destinationURL,
    XmlElement manageNameIDResponse,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Sub SendManageNameIDResponseByHTTPRedirect (
    httpResponse As HttpResponse,
    destinationURL As String,
    manageNameIDResponse As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
)
public:
static void SendManageNameIDResponseByHTTPRedirect(
    HttpResponse^ httpResponse,
    String^ destinationURL,
    XmlElement^ manageNameIDResponse,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member SendManageNameIDResponseByHTTPRedirect :
        httpResponse : HttpResponse *
        destinationURL : string *
        manageNameIDResponse : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
destinationURL
Type: SystemString
The destination URL.
manageNameIDResponse
Type: System.XmlXmlElement
The manage name identifier response.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ManageNameIDResponder Class
SendManageNameIDResponseByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.SendManageNameIDResponseByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm)

ManageNameIDResponderSendManageNameIDResponseByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm)

Sends the manage name identifier response using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendManageNameIDResponseByHTTPRedirect(
    HttpResponseBase httpResponse,
    string destinationURL,
    XmlElement manageNameIDResponse,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Sub SendManageNameIDResponseByHTTPRedirect (
    httpResponse As HttpResponseBase,
    destinationURL As String,
    manageNameIDResponse As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
)
public:
static void SendManageNameIDResponseByHTTPRedirect(
    HttpResponseBase^ httpResponse,
    String^ destinationURL,
    XmlElement^ manageNameIDResponse,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member SendManageNameIDResponseByHTTPRedirect :
        httpResponse : HttpResponseBase *
        destinationURL : string *
        manageNameIDResponse : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
destinationURL
Type: SystemString
The destination URL.
manageNameIDResponse
Type: System.XmlXmlElement
The manage name identifier response.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ManageNameIDResponder Class
SendManageNameIDResponseByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.SendManageNameIDResponseBySOAP Method

ManageNameIDResponderSendManageNameIDResponseBySOAP Method

Overload List
Name | Description
SendManageNameIDResponseBySOAP(HttpResponse, XmlElement) | Sends the manage name identifier response over SOAP.
SendManageNameIDResponseBySOAP(HttpResponseBase, XmlElement) | Sends the manage name identifier response over SOAP.
Top
See Also

Reference

ManageNameIDResponder Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.SendManageNameIDResponseBySOAP Method (HttpResponse, XmlElement)

ManageNameIDResponderSendManageNameIDResponseBySOAP Method (HttpResponse, XmlElement)

Sends the manage name identifier response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendManageNameIDResponseBySOAP(
    HttpResponse httpResponse,
    XmlElement manageNameIDResponse
)
Public Shared Sub SendManageNameIDResponseBySOAP (
    httpResponse As HttpResponse,
    manageNameIDResponse As XmlElement
)
public:
static void SendManageNameIDResponseBySOAP(
    HttpResponse^ httpResponse,
    XmlElement^ manageNameIDResponse
)
static member SendManageNameIDResponseBySOAP :
        httpResponse : HttpResponse *
        manageNameIDResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to send the manage name identifier response.
manageNameIDResponse
Type: System.XmlXmlElement
The manage name identifier response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ManageNameIDResponder Class
SendManageNameIDResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ManageNameIDResponder.SendManageNameIDResponseBySOAP Method (HttpResponseBase, XmlElement)

ManageNameIDResponderSendManageNameIDResponseBySOAP Method (HttpResponseBase, XmlElement)

Sends the manage name identifier response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendManageNameIDResponseBySOAP(
    HttpResponseBase httpResponse,
    XmlElement manageNameIDResponse
)
Public Shared Sub SendManageNameIDResponseBySOAP (
    httpResponse As HttpResponseBase,
    manageNameIDResponse As XmlElement
)
public:
static void SendManageNameIDResponseBySOAP(
    HttpResponseBase^ httpResponse,
    XmlElement^ manageNameIDResponse
)
static member SendManageNameIDResponseBySOAP :
        httpResponse : HttpResponseBase *
        manageNameIDResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to send the manage name identifier response.
manageNameIDResponse
Type: System.XmlXmlElement
The manage name identifier response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ManageNameIDResponder Class
SendManageNameIDResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


NameIDMappingResponder Class

Supports the name identifier mapping profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.NameIdentifierManagementNameIDMappingResponder

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class NameIDMappingResponder
Public NotInheritable Class NameIDMappingResponder
public ref class NameIDMappingResponder abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NameIDMappingResponder =  class end
Methods
Name | Description
ReceiveNameIDMappingRequestBySOAP(HttpRequest) | Receives the name identifier mapping request over SOAP.
ReceiveNameIDMappingRequestBySOAP(HttpRequestBase) | Receives the name identifier mapping request over SOAP.
SendNameIDMappingResponseBySOAP(HttpResponse, XmlElement) | Sends the name identifier mapping response over SOAP.
SendNameIDMappingResponseBySOAP(HttpResponseBase, XmlElement) | Sends the name identifier mapping response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


NameIDMappingResponder Methods

Methods
Name | Description
ReceiveNameIDMappingRequestBySOAP(HttpRequest) | Receives the name identifier mapping request over SOAP.
ReceiveNameIDMappingRequestBySOAP(HttpRequestBase) | Receives the name identifier mapping request over SOAP.
SendNameIDMappingResponseBySOAP(HttpResponse, XmlElement) | Sends the name identifier mapping response over SOAP.
SendNameIDMappingResponseBySOAP(HttpResponseBase, XmlElement) | Sends the name identifier mapping response over SOAP.
Top
See Also

Reference

NameIDMappingResponder Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


NameIDMappingResponder.ReceiveNameIDMappingRequestBySOAP Method

NameIDMappingResponderReceiveNameIDMappingRequestBySOAP Method

Overload List
Name | Description
ReceiveNameIDMappingRequestBySOAP(HttpRequest) | Receives the name identifier mapping request over SOAP.
ReceiveNameIDMappingRequestBySOAP(HttpRequestBase) | Receives the name identifier mapping request over SOAP.
Top
See Also

Reference

NameIDMappingResponder Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


NameIDMappingResponder.ReceiveNameIDMappingRequestBySOAP Method (HttpRequest)

NameIDMappingResponderReceiveNameIDMappingRequestBySOAP Method (HttpRequest)

Receives the name identifier mapping request over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveNameIDMappingRequestBySOAP(
    HttpRequest httpRequest
)
Public Shared Function ReceiveNameIDMappingRequestBySOAP (
    httpRequest As HttpRequest
) As XmlElement
public:
static XmlElement^ ReceiveNameIDMappingRequestBySOAP(
    HttpRequest^ httpRequest
)
static member ReceiveNameIDMappingRequestBySOAP :
        httpRequest : HttpRequest -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the name identifier mapping request.

Return Value

Type: XmlElement
The name identifier mapping request.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

NameIDMappingResponder Class
ReceiveNameIDMappingRequestBySOAP Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


NameIDMappingResponder.ReceiveNameIDMappingRequestBySOAP Method (HttpRequestBase)

NameIDMappingResponderReceiveNameIDMappingRequestBySOAP Method (HttpRequestBase)

Receives the name identifier mapping request over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveNameIDMappingRequestBySOAP(
    HttpRequestBase httpRequest
)
Public Shared Function ReceiveNameIDMappingRequestBySOAP (
    httpRequest As HttpRequestBase
) As XmlElement
public:
static XmlElement^ ReceiveNameIDMappingRequestBySOAP(
    HttpRequestBase^ httpRequest
)
static member ReceiveNameIDMappingRequestBySOAP :
        httpRequest : HttpRequestBase -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the name identifier mapping request.

Return Value

Type: XmlElement
The name identifier mapping request.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

NameIDMappingResponder Class
ReceiveNameIDMappingRequestBySOAP Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


NameIDMappingResponder.SendNameIDMappingResponseBySOAP Method

NameIDMappingResponderSendNameIDMappingResponseBySOAP Method

Overload List
Name | Description
SendNameIDMappingResponseBySOAP(HttpResponse, XmlElement) | Sends the name identifier mapping response over SOAP.
SendNameIDMappingResponseBySOAP(HttpResponseBase, XmlElement) | Sends the name identifier mapping response over SOAP.
Top
See Also

Reference

NameIDMappingResponder Class
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


NameIDMappingResponder.SendNameIDMappingResponseBySOAP Method (HttpResponse, XmlElement)

NameIDMappingResponderSendNameIDMappingResponseBySOAP Method (HttpResponse, XmlElement)

Sends the name identifier mapping response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendNameIDMappingResponseBySOAP(
    HttpResponse httpResponse,
    XmlElement nameIDMappingResponse
)
Public Shared Sub SendNameIDMappingResponseBySOAP (
    httpResponse As HttpResponse,
    nameIDMappingResponse As XmlElement
)
public:
static void SendNameIDMappingResponseBySOAP(
    HttpResponse^ httpResponse,
    XmlElement^ nameIDMappingResponse
)
static member SendNameIDMappingResponseBySOAP :
        httpResponse : HttpResponse *
        nameIDMappingResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to send the name identifier mapping response.
nameIDMappingResponse
Type: System.XmlXmlElement
The name identifier mapping response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

NameIDMappingResponder Class
SendNameIDMappingResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


NameIDMappingResponder.SendNameIDMappingResponseBySOAP Method (HttpResponseBase, XmlElement)

NameIDMappingResponderSendNameIDMappingResponseBySOAP Method (HttpResponseBase, XmlElement)

Sends the name identifier mapping response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierManagement
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendNameIDMappingResponseBySOAP(
    HttpResponseBase httpResponse,
    XmlElement nameIDMappingResponse
)
Public Shared Sub SendNameIDMappingResponseBySOAP (
    httpResponse As HttpResponseBase,
    nameIDMappingResponse As XmlElement
)
public:
static void SendNameIDMappingResponseBySOAP(
    HttpResponseBase^ httpResponse,
    XmlElement^ nameIDMappingResponse
)
static member SendNameIDMappingResponseBySOAP :
        httpResponse : HttpResponseBase *
        nameIDMappingResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to send the name identifier mapping response.
nameIDMappingResponse
Type: System.XmlXmlElement
The name identifier mapping response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

NameIDMappingResponder Class
SendNameIDMappingResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.NameIdentifierManagement Namespace


ComponentSpace.SAML2.Profiles.NameIdentifierMapping Namespace

The ComponentSpace.SAML2.Profiles.NameIdentifierMapping namespace contains classes associated with the SAML v2.0 name identifier mapping profile.
Classes
 | Class | Description
Public class | NameIDMappingRequester | Supports the name identifier mapping profile.


NameIDMappingRequester Class

Supports the name identifier mapping profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.NameIdentifierMappingNameIDMappingRequester

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierMapping
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class NameIDMappingRequester
Public NotInheritable Class NameIDMappingRequester
public ref class NameIDMappingRequester abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NameIDMappingRequester =  class end

The NameIDMappingRequester type exposes the following members.

Methods
Name | Description
SendNameIDMappingRequestReceiveResponseBySOAP | Sends the name identifier mapping request and receives a name identifier mapping response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.NameIdentifierMapping Namespace


NameIDMappingRequester Methods

The NameIDMappingRequester type exposes the following members.

Methods
Name | Description
SendNameIDMappingRequestReceiveResponseBySOAP | Sends the name identifier mapping request and receives a name identifier mapping response over SOAP.
Top
See Also

Reference

NameIDMappingRequester Class
ComponentSpace.SAML2.Profiles.NameIdentifierMapping Namespace


NameIDMappingRequester.SendNameIDMappingRequestReceiveResponseBySOAP Method

NameIDMappingRequesterSendNameIDMappingRequestReceiveResponseBySOAP Method

Sends the name identifier mapping request and receives a name identifier mapping response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.NameIdentifierMapping
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendNameIDMappingRequestReceiveResponseBySOAP(
    string destinationURL,
    XmlElement nameIDMappingRequest
)
Public Shared Function SendNameIDMappingRequestReceiveResponseBySOAP (
    destinationURL As String,
    nameIDMappingRequest As XmlElement
) As XmlElement
public:
static XmlElement^ SendNameIDMappingRequestReceiveResponseBySOAP(
    String^ destinationURL,
    XmlElement^ nameIDMappingRequest
)
static member SendNameIDMappingRequestReceiveResponseBySOAP :
        destinationURL : string *
        nameIDMappingRequest : XmlElement -> XmlElement

Parameters

destinationURL
Type: SystemString
The destination URL.
nameIDMappingRequest
Type: System.XmlXmlElement
The name identifier mapping request.

Return Value

Type: XmlElement
The name identifier mapping response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send/receive fails.
See Also

Reference

NameIDMappingRequester Class
ComponentSpace.SAML2.Profiles.NameIdentifierMapping Namespace


ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace

The ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier namespace contains classes associated with the SAML v2.0 request assertion by identifier profile.
Classes
 | Class | Description
Public class | AssertionByIDRequester | Supports the request assertion by identifier profile.
Public class | AssertionByIDResponder | Supports the request assertion by identifier profile.


AssertionByIDRequester Class

Supports the request assertion by identifier profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifierAssertionByIDRequester

Namespace: ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AssertionByIDRequester
Public NotInheritable Class AssertionByIDRequester
public ref class AssertionByIDRequester abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AssertionByIDRequester =  class end

The AssertionByIDRequester type exposes the following members.

Methods
Name | Description
SendAssertionByIDRequestReceiveResponseBySOAP | Sends the assertion by identifier request and receives a SAML response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


AssertionByIDRequester Methods

The AssertionByIDRequester type exposes the following members.

Methods
Name | Description
SendAssertionByIDRequestReceiveResponseBySOAP | Sends the assertion by identifier request and receives a SAML response over SOAP.
Top
See Also

Reference

AssertionByIDRequester Class
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


AssertionByIDRequester.SendAssertionByIDRequestReceiveResponseBySOAP Method

AssertionByIDRequesterSendAssertionByIDRequestReceiveResponseBySOAP Method

Sends the assertion by identifier request and receives a SAML response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendAssertionByIDRequestReceiveResponseBySOAP(
    string destinationURL,
    XmlElement assertionByIDRequest
)
Public Shared Function SendAssertionByIDRequestReceiveResponseBySOAP (
    destinationURL As String,
    assertionByIDRequest As XmlElement
) As XmlElement
public:
static XmlElement^ SendAssertionByIDRequestReceiveResponseBySOAP(
    String^ destinationURL,
    XmlElement^ assertionByIDRequest
)
static member SendAssertionByIDRequestReceiveResponseBySOAP :
        destinationURL : string *
        assertionByIDRequest : XmlElement -> XmlElement

Parameters

destinationURL
Type: SystemString
The destination URL.
assertionByIDRequest
Type: System.XmlXmlElement
The assertion by identifier request.

Return Value

Type: XmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send/receive fails.
See Also

Reference

AssertionByIDRequester Class
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


AssertionByIDResponder Class

Supports the request assertion by identifier profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifierAssertionByIDResponder

Namespace: ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class AssertionByIDResponder
Public NotInheritable Class AssertionByIDResponder
public ref class AssertionByIDResponder abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AssertionByIDResponder =  class end
Methods
Name | Description
ReceiveAssertionByIDRequestBySOAP(HttpRequest) | Receives the assertion by identifier request over SOAP.
ReceiveAssertionByIDRequestBySOAP(HttpRequestBase) | Receives the assertion by identifier request over SOAP.
SendSAMLResponseBySOAP(HttpResponse, XmlElement) | Sends the SAML response over SOAP.
SendSAMLResponseBySOAP(HttpResponseBase, XmlElement) | Sends the SAML response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


AssertionByIDResponder Methods

Methods
Name | Description
ReceiveAssertionByIDRequestBySOAP(HttpRequest) | Receives the assertion by identifier request over SOAP.
ReceiveAssertionByIDRequestBySOAP(HttpRequestBase) | Receives the assertion by identifier request over SOAP.
SendSAMLResponseBySOAP(HttpResponse, XmlElement) | Sends the SAML response over SOAP.
SendSAMLResponseBySOAP(HttpResponseBase, XmlElement) | Sends the SAML response over SOAP.
Top
See Also

Reference

AssertionByIDResponder Class
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


AssertionByIDResponder.ReceiveAssertionByIDRequestBySOAP Method

AssertionByIDResponderReceiveAssertionByIDRequestBySOAP Method

Overload List
Name | Description
ReceiveAssertionByIDRequestBySOAP(HttpRequest) | Receives the assertion by identifier request over SOAP.
ReceiveAssertionByIDRequestBySOAP(HttpRequestBase) | Receives the assertion by identifier request over SOAP.
Top
See Also

Reference

AssertionByIDResponder Class
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


AssertionByIDResponder.ReceiveAssertionByIDRequestBySOAP Method (HttpRequest)

AssertionByIDResponderReceiveAssertionByIDRequestBySOAP Method (HttpRequest)

Receives the assertion by identifier request over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveAssertionByIDRequestBySOAP(
    HttpRequest httpRequest
)
Public Shared Function ReceiveAssertionByIDRequestBySOAP (
    httpRequest As HttpRequest
) As XmlElement
public:
static XmlElement^ ReceiveAssertionByIDRequestBySOAP(
    HttpRequest^ httpRequest
)
static member ReceiveAssertionByIDRequestBySOAP :
        httpRequest : HttpRequest -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the assertion by identifier request.

Return Value

Type: XmlElement
The assertion by identifier request.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

AssertionByIDResponder Class
ReceiveAssertionByIDRequestBySOAP Overload
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


AssertionByIDResponder.ReceiveAssertionByIDRequestBySOAP Method (HttpRequestBase)

AssertionByIDResponderReceiveAssertionByIDRequestBySOAP Method (HttpRequestBase)

Receives the assertion by identifier request over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveAssertionByIDRequestBySOAP(
    HttpRequestBase httpRequest
)
Public Shared Function ReceiveAssertionByIDRequestBySOAP (
    httpRequest As HttpRequestBase
) As XmlElement
public:
static XmlElement^ ReceiveAssertionByIDRequestBySOAP(
    HttpRequestBase^ httpRequest
)
static member ReceiveAssertionByIDRequestBySOAP :
        httpRequest : HttpRequestBase -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the assertion by identifier request.

Return Value

Type: XmlElement
The assertion by identifier request.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

AssertionByIDResponder Class
ReceiveAssertionByIDRequestBySOAP Overload
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


AssertionByIDResponder.SendSAMLResponseBySOAP Method

AssertionByIDResponderSendSAMLResponseBySOAP Method

Overload List
Name | Description
SendSAMLResponseBySOAP(HttpResponse, XmlElement) | Sends the SAML response over SOAP.
SendSAMLResponseBySOAP(HttpResponseBase, XmlElement) | Sends the SAML response over SOAP.
Top
See Also

Reference

AssertionByIDResponder Class
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


AssertionByIDResponder.SendSAMLResponseBySOAP Method (HttpResponse, XmlElement)

AssertionByIDResponderSendSAMLResponseBySOAP Method (HttpResponse, XmlElement)

Sends the SAML response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSAMLResponseBySOAP(
    HttpResponse httpResponse,
    XmlElement samlResponse
)
Public Shared Sub SendSAMLResponseBySOAP (
    httpResponse As HttpResponse,
    samlResponse As XmlElement
)
public:
static void SendSAMLResponseBySOAP(
    HttpResponse^ httpResponse,
    XmlElement^ samlResponse
)
static member SendSAMLResponseBySOAP :
        httpResponse : HttpResponse *
        samlResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to send the SAML response.
samlResponse
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

AssertionByIDResponder Class
SendSAMLResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


AssertionByIDResponder.SendSAMLResponseBySOAP Method (HttpResponseBase, XmlElement)

AssertionByIDResponderSendSAMLResponseBySOAP Method (HttpResponseBase, XmlElement)

Sends the SAML response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSAMLResponseBySOAP(
    HttpResponseBase httpResponse,
    XmlElement samlResponse
)
Public Shared Sub SendSAMLResponseBySOAP (
    httpResponse As HttpResponseBase,
    samlResponse As XmlElement
)
public:
static void SendSAMLResponseBySOAP(
    HttpResponseBase^ httpResponse,
    XmlElement^ samlResponse
)
static member SendSAMLResponseBySOAP :
        httpResponse : HttpResponseBase *
        samlResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to send the SAML response.
samlResponse
Type: System.XmlXmlElement
The SAML response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

AssertionByIDResponder Class
SendSAMLResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.RequestAssertionByIdentifier Namespace


ComponentSpace.SAML2.Profiles.SingleLogout Namespace

The ComponentSpace.SAML2.Profiles.SingleLogout namespace contains classes associated with the SAML v2.0 single logout profile.
Classes
 | Class | Description
Public class | SingleLogoutService | Supports the single logout profile.


SingleLogoutService Class

Supports the single logout profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.SingleLogoutSingleLogoutService

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SingleLogoutService
Public NotInheritable Class SingleLogoutService
public ref class SingleLogoutService abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SingleLogoutService =  class end

The SingleLogoutService type exposes the following members.

Methods
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
ReceiveLogoutMessageByHTTPPost(HttpRequest, XmlElement, String, Boolean) | Receives the logout request or response using HTTP post.
ReceiveLogoutMessageByHTTPPost(HttpRequestBase, XmlElement, String, Boolean) | Receives the logout request or response using HTTP post.
ReceiveLogoutMessageByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the logout request or response using HTTP redirect.
ReceiveLogoutMessageByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the logout request or response using HTTP redirect.
ReceiveLogoutRequestByHTTPPost(HttpRequest, XmlElement, String) | Receives the logout request using HTTP post.
ReceiveLogoutRequestByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the logout request using HTTP post.
ReceiveLogoutRequestByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout request using HTTP redirect.
ReceiveLogoutRequestByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout request using HTTP redirect.
ReceiveLogoutRequestBySOAP(HttpRequest) | Receives the logout request over SOAP.
ReceiveLogoutRequestBySOAP(HttpRequestBase) | Receives the logout request over SOAP.
ReceiveLogoutResponseByHTTPPost(HttpRequest, XmlElement, String) | Receives the logout response using HTTP post.
ReceiveLogoutResponseByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the logout response using HTTP post.
ReceiveLogoutResponseByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout response using HTTP redirect.
ReceiveLogoutResponseByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout response using HTTP redirect.
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
SendLogoutRequestByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the logout request using HTTP post.
SendLogoutRequestByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the logout request using HTTP post.
SendLogoutRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout request using HTTP redirect.
SendLogoutRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout request using HTTP redirect.
SendLogoutRequestReceiveLogoutResponseBySOAP | Sends the logout request and receives a logout response over SOAP.
SendLogoutResponseByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the logout response using HTTP post.
SendLogoutResponseByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the logout response using HTTP post.
SendLogoutResponseByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout response using HTTP redirect.
SendLogoutResponseByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout response using HTTP redirect.
SendLogoutResponseBySOAP(HttpResponse, XmlElement) | Sends the logout response over SOAP.
SendLogoutResponseBySOAP(HttpResponseBase, XmlElement) | Sends the logout response over SOAP.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService Methods

The SingleLogoutService type exposes the following members.

Methods
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
ReceiveLogoutMessageByHTTPPost(HttpRequest, XmlElement, String, Boolean) | Receives the logout request or response using HTTP post.
ReceiveLogoutMessageByHTTPPost(HttpRequestBase, XmlElement, String, Boolean) | Receives the logout request or response using HTTP post.
ReceiveLogoutMessageByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the logout request or response using HTTP redirect.
ReceiveLogoutMessageByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the logout request or response using HTTP redirect.
ReceiveLogoutRequestByHTTPPost(HttpRequest, XmlElement, String) | Receives the logout request using HTTP post.
ReceiveLogoutRequestByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the logout request using HTTP post.
ReceiveLogoutRequestByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout request using HTTP redirect.
ReceiveLogoutRequestByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout request using HTTP redirect.
ReceiveLogoutRequestBySOAP(HttpRequest) | Receives the logout request over SOAP.
ReceiveLogoutRequestBySOAP(HttpRequestBase) | Receives the logout request over SOAP.
ReceiveLogoutResponseByHTTPPost(HttpRequest, XmlElement, String) | Receives the logout response using HTTP post.
ReceiveLogoutResponseByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the logout response using HTTP post.
ReceiveLogoutResponseByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout response using HTTP redirect.
ReceiveLogoutResponseByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout response using HTTP redirect.
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
SendLogoutRequestByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the logout request using HTTP post.
SendLogoutRequestByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the logout request using HTTP post.
SendLogoutRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout request using HTTP redirect.
SendLogoutRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout request using HTTP redirect.
SendLogoutRequestReceiveLogoutResponseBySOAP | Sends the logout request and receives a logout response over SOAP.
SendLogoutResponseByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the logout response using HTTP post.
SendLogoutResponseByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the logout response using HTTP post.
SendLogoutResponseByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout response using HTTP redirect.
SendLogoutResponseByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout response using HTTP redirect.
SendLogoutResponseBySOAP(HttpResponse, XmlElement) | Sends the logout response over SOAP.
SendLogoutResponseBySOAP(HttpResponseBase, XmlElement) | Sends the logout response over SOAP.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveArtifactByHTTPArtifact Method

SingleLogoutServiceReceiveArtifactByHTTPArtifact Method

Overload List
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact using HTTP artifact with the artifact being in a form or query string.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveArtifactByHTTPArtifact Method (HttpRequest, Boolean, HTTPArtifact, String)

SingleLogoutServiceReceiveArtifactByHTTPArtifact Method (HttpRequest, Boolean, HTTPArtifact, String)

Receives the artifact using HTTP artifact with the artifact being in a form or query string.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactByHTTPArtifact(
    HttpRequest httpRequest,
    bool artifactInForm,
    out HTTPArtifact httpArtifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactByHTTPArtifact (
    httpRequest As HttpRequest,
    artifactInForm As Boolean,
    <OutAttribute> ByRef httpArtifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactByHTTPArtifact(
    HttpRequest^ httpRequest,
    bool artifactInForm,
    [OutAttribute] HTTPArtifact^% httpArtifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactByHTTPArtifact :
        httpRequest : HttpRequest *
        artifactInForm : bool *
        httpArtifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the artifact.
artifactInForm
Type: SystemBoolean
If true the artifact is received in a form; otherwise it's received in a query string.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveArtifactByHTTPArtifact Method (HttpRequestBase, Boolean, HTTPArtifact, String)

SingleLogoutServiceReceiveArtifactByHTTPArtifact Method (HttpRequestBase, Boolean, HTTPArtifact, String)

Receives the artifact using HTTP artifact with the artifact being in a form or query string.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactByHTTPArtifact(
    HttpRequestBase httpRequest,
    bool artifactInForm,
    out HTTPArtifact httpArtifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactByHTTPArtifact (
    httpRequest As HttpRequestBase,
    artifactInForm As Boolean,
    <OutAttribute> ByRef httpArtifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactByHTTPArtifact(
    HttpRequestBase^ httpRequest,
    bool artifactInForm,
    [OutAttribute] HTTPArtifact^% httpArtifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactByHTTPArtifact :
        httpRequest : HttpRequestBase *
        artifactInForm : bool *
        httpArtifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the artifact.
artifactInForm
Type: SystemBoolean
If true the artifact is received in a form; otherwise it's received in a query string.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutMessageByHTTPPost Method

SingleLogoutServiceReceiveLogoutMessageByHTTPPost Method

Overload List
Name | Description
ReceiveLogoutMessageByHTTPPost(HttpRequest, XmlElement, String, Boolean) | Receives the logout request or response using HTTP post.
ReceiveLogoutMessageByHTTPPost(HttpRequestBase, XmlElement, String, Boolean) | Receives the logout request or response using HTTP post.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutMessageByHTTPPost Method (HttpRequest, XmlElement, String, Boolean)

SingleLogoutServiceReceiveLogoutMessageByHTTPPost Method (HttpRequest, XmlElement, String, Boolean)

Receives the logout request or response using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutMessageByHTTPPost(
    HttpRequest httpRequest,
    out XmlElement logoutMessage,
    out string relayState,
    out bool isRequest
)
Public Shared Sub ReceiveLogoutMessageByHTTPPost (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef logoutMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef isRequest As Boolean
)
public:
static void ReceiveLogoutMessageByHTTPPost(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% logoutMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% isRequest
)
static member ReceiveLogoutMessageByHTTPPost :
        httpRequest : HttpRequest *
        logoutMessage : XmlElement byref *
        relayState : string byref *
        isRequest : bool byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
logoutMessage
Type: System.XmlXmlElement
The returned logout request or response.
relayState
Type: SystemString
The returned relay state or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutMessageByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutMessageByHTTPPost Method (HttpRequestBase, XmlElement, String, Boolean)

SingleLogoutServiceReceiveLogoutMessageByHTTPPost Method (HttpRequestBase, XmlElement, String, Boolean)

Receives the logout request or response using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutMessageByHTTPPost(
    HttpRequestBase httpRequest,
    out XmlElement logoutMessage,
    out string relayState,
    out bool isRequest
)
Public Shared Sub ReceiveLogoutMessageByHTTPPost (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef logoutMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef isRequest As Boolean
)
public:
static void ReceiveLogoutMessageByHTTPPost(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% logoutMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% isRequest
)
static member ReceiveLogoutMessageByHTTPPost :
        httpRequest : HttpRequestBase *
        logoutMessage : XmlElement byref *
        relayState : string byref *
        isRequest : bool byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
logoutMessage
Type: System.XmlXmlElement
The returned logout request or response.
relayState
Type: SystemString
The returned relay state or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutMessageByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutMessageByHTTPRedirect Method

SingleLogoutServiceReceiveLogoutMessageByHTTPRedirect Method

Overload List
Name | Description
ReceiveLogoutMessageByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the logout request or response using HTTP redirect.
ReceiveLogoutMessageByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm) | Receives the logout request or response using HTTP redirect.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutMessageByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm)

SingleLogoutServiceReceiveLogoutMessageByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm)

Receives the logout request or response using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutMessageByHTTPRedirect(
    HttpRequest httpRequest,
    out XmlElement logoutMessage,
    out string relayState,
    out bool isRequest,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveLogoutMessageByHTTPRedirect (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef logoutMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef isRequest As Boolean,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveLogoutMessageByHTTPRedirect(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% logoutMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% isRequest,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveLogoutMessageByHTTPRedirect :
        httpRequest : HttpRequest *
        logoutMessage : XmlElement byref *
        relayState : string byref *
        isRequest : bool byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
logoutMessage
Type: System.XmlXmlElement
The returned logout request or response.
relayState
Type: SystemString
The returned relay state or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutMessageByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutMessageByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm)

SingleLogoutServiceReceiveLogoutMessageByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, Boolean, AsymmetricAlgorithm)

Receives the logout request or response using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutMessageByHTTPRedirect(
    HttpRequestBase httpRequest,
    out XmlElement logoutMessage,
    out string relayState,
    out bool isRequest,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveLogoutMessageByHTTPRedirect (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef logoutMessage As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef isRequest As Boolean,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveLogoutMessageByHTTPRedirect(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% logoutMessage,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% isRequest,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveLogoutMessageByHTTPRedirect :
        httpRequest : HttpRequestBase *
        logoutMessage : XmlElement byref *
        relayState : string byref *
        isRequest : bool byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
logoutMessage
Type: System.XmlXmlElement
The returned logout request or response.
relayState
Type: SystemString
The returned relay state or null if none.
isRequest
Type: SystemBoolean
true if the message is a request; false if the message is a response.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutMessageByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutRequestByHTTPPost Method

SingleLogoutServiceReceiveLogoutRequestByHTTPPost Method

Overload List
Name | Description
ReceiveLogoutRequestByHTTPPost(HttpRequest, XmlElement, String) | Receives the logout request using HTTP post.
ReceiveLogoutRequestByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the logout request using HTTP post.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutRequestByHTTPPost Method (HttpRequest, XmlElement, String)

SingleLogoutServiceReceiveLogoutRequestByHTTPPost Method (HttpRequest, XmlElement, String)

Receives the logout request using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutRequestByHTTPPost(
    HttpRequest httpRequest,
    out XmlElement logoutRequest,
    out string relayState
)
Public Shared Sub ReceiveLogoutRequestByHTTPPost (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef logoutRequest As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveLogoutRequestByHTTPPost(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% logoutRequest,
    [OutAttribute] String^% relayState
)
static member ReceiveLogoutRequestByHTTPPost :
        httpRequest : HttpRequest *
        logoutRequest : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
logoutRequest
Type: System.XmlXmlElement
The returned logout request.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutRequestByHTTPPost Method (HttpRequestBase, XmlElement, String)

SingleLogoutServiceReceiveLogoutRequestByHTTPPost Method (HttpRequestBase, XmlElement, String)

Receives the logout request using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutRequestByHTTPPost(
    HttpRequestBase httpRequest,
    out XmlElement logoutRequest,
    out string relayState
)
Public Shared Sub ReceiveLogoutRequestByHTTPPost (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef logoutRequest As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveLogoutRequestByHTTPPost(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% logoutRequest,
    [OutAttribute] String^% relayState
)
static member ReceiveLogoutRequestByHTTPPost :
        httpRequest : HttpRequestBase *
        logoutRequest : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
logoutRequest
Type: System.XmlXmlElement
The returned logout request.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutRequestByHTTPRedirect Method

SingleLogoutServiceReceiveLogoutRequestByHTTPRedirect Method

Overload List
Name | Description
ReceiveLogoutRequestByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout request using HTTP redirect.
ReceiveLogoutRequestByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout request using HTTP redirect.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutRequestByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

SingleLogoutServiceReceiveLogoutRequestByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the logout request using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutRequestByHTTPRedirect(
    HttpRequest httpRequest,
    out XmlElement logoutRequest,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveLogoutRequestByHTTPRedirect (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef logoutRequest As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveLogoutRequestByHTTPRedirect(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% logoutRequest,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveLogoutRequestByHTTPRedirect :
        httpRequest : HttpRequest *
        logoutRequest : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
logoutRequest
Type: System.XmlXmlElement
The returned logout request.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutRequestByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

SingleLogoutServiceReceiveLogoutRequestByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the logout request using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutRequestByHTTPRedirect(
    HttpRequestBase httpRequest,
    out XmlElement logoutRequest,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveLogoutRequestByHTTPRedirect (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef logoutRequest As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveLogoutRequestByHTTPRedirect(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% logoutRequest,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveLogoutRequestByHTTPRedirect :
        httpRequest : HttpRequestBase *
        logoutRequest : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
logoutRequest
Type: System.XmlXmlElement
The returned logout request.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutRequestBySOAP Method

SingleLogoutServiceReceiveLogoutRequestBySOAP Method

Overload List
Name | Description
ReceiveLogoutRequestBySOAP(HttpRequest) | Receives the logout request over SOAP.
ReceiveLogoutRequestBySOAP(HttpRequestBase) | Receives the logout request over SOAP.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutRequestBySOAP Method (HttpRequest)

SingleLogoutServiceReceiveLogoutRequestBySOAP Method (HttpRequest)

Receives the logout request over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveLogoutRequestBySOAP(
    HttpRequest httpRequest
)
Public Shared Function ReceiveLogoutRequestBySOAP (
    httpRequest As HttpRequest
) As XmlElement
public:
static XmlElement^ ReceiveLogoutRequestBySOAP(
    HttpRequest^ httpRequest
)
static member ReceiveLogoutRequestBySOAP :
        httpRequest : HttpRequest -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the logout request.

Return Value

Type: XmlElement
The logout request.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutRequestBySOAP Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutRequestBySOAP Method (HttpRequestBase)

SingleLogoutServiceReceiveLogoutRequestBySOAP Method (HttpRequestBase)

Receives the logout request over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ReceiveLogoutRequestBySOAP(
    HttpRequestBase httpRequest
)
Public Shared Function ReceiveLogoutRequestBySOAP (
    httpRequest As HttpRequestBase
) As XmlElement
public:
static XmlElement^ ReceiveLogoutRequestBySOAP(
    HttpRequestBase^ httpRequest
)
static member ReceiveLogoutRequestBySOAP :
        httpRequest : HttpRequestBase -> XmlElement

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the logout request.

Return Value

Type: XmlElement
The logout request.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutRequestBySOAP Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutResponseByHTTPPost Method

SingleLogoutServiceReceiveLogoutResponseByHTTPPost Method

Overload List
Name | Description
ReceiveLogoutResponseByHTTPPost(HttpRequest, XmlElement, String) | Receives the logout response using HTTP post.
ReceiveLogoutResponseByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the logout response using HTTP post.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutResponseByHTTPPost Method (HttpRequest, XmlElement, String)

SingleLogoutServiceReceiveLogoutResponseByHTTPPost Method (HttpRequest, XmlElement, String)

Receives the logout response using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutResponseByHTTPPost(
    HttpRequest httpRequest,
    out XmlElement logoutResponse,
    out string relayState
)
Public Shared Sub ReceiveLogoutResponseByHTTPPost (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef logoutResponse As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveLogoutResponseByHTTPPost(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% logoutResponse,
    [OutAttribute] String^% relayState
)
static member ReceiveLogoutResponseByHTTPPost :
        httpRequest : HttpRequest *
        logoutResponse : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
logoutResponse
Type: System.XmlXmlElement
The returned logout response.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutResponseByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutResponseByHTTPPost Method (HttpRequestBase, XmlElement, String)

SingleLogoutServiceReceiveLogoutResponseByHTTPPost Method (HttpRequestBase, XmlElement, String)

Receives the logout response using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutResponseByHTTPPost(
    HttpRequestBase httpRequest,
    out XmlElement logoutResponse,
    out string relayState
)
Public Shared Sub ReceiveLogoutResponseByHTTPPost (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef logoutResponse As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveLogoutResponseByHTTPPost(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% logoutResponse,
    [OutAttribute] String^% relayState
)
static member ReceiveLogoutResponseByHTTPPost :
        httpRequest : HttpRequestBase *
        logoutResponse : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
logoutResponse
Type: System.XmlXmlElement
The returned logout response.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutResponseByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutResponseByHTTPRedirect Method

SingleLogoutServiceReceiveLogoutResponseByHTTPRedirect Method

Overload List
Name | Description
ReceiveLogoutResponseByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout response using HTTP redirect.
ReceiveLogoutResponseByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the logout response using HTTP redirect.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutResponseByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

SingleLogoutServiceReceiveLogoutResponseByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the logout response using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutResponseByHTTPRedirect(
    HttpRequest httpRequest,
    out XmlElement logoutResponse,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveLogoutResponseByHTTPRedirect (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef logoutResponse As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveLogoutResponseByHTTPRedirect(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% logoutResponse,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveLogoutResponseByHTTPRedirect :
        httpRequest : HttpRequest *
        logoutResponse : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
logoutResponse
Type: System.XmlXmlElement
The returned logout response.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutResponseByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.ReceiveLogoutResponseByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

SingleLogoutServiceReceiveLogoutResponseByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the logout response using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveLogoutResponseByHTTPRedirect(
    HttpRequestBase httpRequest,
    out XmlElement logoutResponse,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveLogoutResponseByHTTPRedirect (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef logoutResponse As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveLogoutResponseByHTTPRedirect(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% logoutResponse,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveLogoutResponseByHTTPRedirect :
        httpRequest : HttpRequestBase *
        logoutResponse : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
logoutResponse
Type: System.XmlXmlElement
The returned logout response.
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML message is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

SingleLogoutService Class
ReceiveLogoutResponseByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendArtifactByHTTPArtifact Method

SingleLogoutServiceSendArtifactByHTTPArtifact Method

Overload List
Name | Description
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact using the HTTP artifact binding.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendArtifactByHTTPArtifact Method (HttpResponse, String, HTTPArtifact, String, Boolean)

SingleLogoutServiceSendArtifactByHTTPArtifact Method (HttpResponse, String, HTTPArtifact, String, Boolean)

Sends an artifact using the HTTP artifact binding.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactByHTTPArtifact(
    HttpResponse httpResponse,
    string destinationURL,
    HTTPArtifact httpArtifact,
    string relayState,
    bool sendArtifactInForm
)
Public Shared Sub SendArtifactByHTTPArtifact (
    httpResponse As HttpResponse,
    destinationURL As String,
    httpArtifact As HTTPArtifact,
    relayState As String,
    sendArtifactInForm As Boolean
)
public:
static void SendArtifactByHTTPArtifact(
    HttpResponse^ httpResponse,
    String^ destinationURL,
    HTTPArtifact^ httpArtifact,
    String^ relayState,
    bool sendArtifactInForm
)
static member SendArtifactByHTTPArtifact :
        httpResponse : HttpResponse *
        destinationURL : string *
        httpArtifact : HTTPArtifact *
        relayState : string *
        sendArtifactInForm : bool -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will send the artifact.
destinationURL
Type: SystemString
The destination URL.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact.
relayState
Type: SystemString
The relay state or null if none.
sendArtifactInForm
Type: SystemBoolean
If true the artifact is sent in a form; otherwise it's sent in a query string.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendArtifactByHTTPArtifact Method (HttpResponseBase, String, HTTPArtifact, String, Boolean)

SingleLogoutServiceSendArtifactByHTTPArtifact Method (HttpResponseBase, String, HTTPArtifact, String, Boolean)

Sends an artifact using the HTTP artifact binding.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactByHTTPArtifact(
    HttpResponseBase httpResponse,
    string destinationURL,
    HTTPArtifact httpArtifact,
    string relayState,
    bool sendArtifactInForm
)
Public Shared Sub SendArtifactByHTTPArtifact (
    httpResponse As HttpResponseBase,
    destinationURL As String,
    httpArtifact As HTTPArtifact,
    relayState As String,
    sendArtifactInForm As Boolean
)
public:
static void SendArtifactByHTTPArtifact(
    HttpResponseBase^ httpResponse,
    String^ destinationURL,
    HTTPArtifact^ httpArtifact,
    String^ relayState,
    bool sendArtifactInForm
)
static member SendArtifactByHTTPArtifact :
        httpResponse : HttpResponseBase *
        destinationURL : string *
        httpArtifact : HTTPArtifact *
        relayState : string *
        sendArtifactInForm : bool -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will send the artifact.
destinationURL
Type: SystemString
The destination URL.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact.
relayState
Type: SystemString
The relay state or null if none.
sendArtifactInForm
Type: SystemBoolean
If true the artifact is sent in a form; otherwise it's sent in a query string.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutRequestByHTTPPost Method

SingleLogoutServiceSendLogoutRequestByHTTPPost Method

Overload List
Name | Description
SendLogoutRequestByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the logout request using HTTP post.
SendLogoutRequestByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the logout request using HTTP post.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutRequestByHTTPPost Method (HttpResponse, String, XmlElement, String)

SingleLogoutServiceSendLogoutRequestByHTTPPost Method (HttpResponse, String, XmlElement, String)

Sends the logout request using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendLogoutRequestByHTTPPost(
    HttpResponse httpResponse,
    string destinationURL,
    XmlElement logoutRequest,
    string relayState
)
Public Shared Sub SendLogoutRequestByHTTPPost (
    httpResponse As HttpResponse,
    destinationURL As String,
    logoutRequest As XmlElement,
    relayState As String
)
public:
static void SendLogoutRequestByHTTPPost(
    HttpResponse^ httpResponse,
    String^ destinationURL,
    XmlElement^ logoutRequest,
    String^ relayState
)
static member SendLogoutRequestByHTTPPost :
        httpResponse : HttpResponse *
        destinationURL : string *
        logoutRequest : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will return the form to post.
destinationURL
Type: SystemString
The destination URL.
logoutRequest
Type: System.XmlXmlElement
The logout request.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendLogoutRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutRequestByHTTPPost Method (HttpResponseBase, String, XmlElement, String)

SingleLogoutServiceSendLogoutRequestByHTTPPost Method (HttpResponseBase, String, XmlElement, String)

Sends the logout request using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendLogoutRequestByHTTPPost(
    HttpResponseBase httpResponse,
    string destinationURL,
    XmlElement logoutRequest,
    string relayState
)
Public Shared Sub SendLogoutRequestByHTTPPost (
    httpResponse As HttpResponseBase,
    destinationURL As String,
    logoutRequest As XmlElement,
    relayState As String
)
public:
static void SendLogoutRequestByHTTPPost(
    HttpResponseBase^ httpResponse,
    String^ destinationURL,
    XmlElement^ logoutRequest,
    String^ relayState
)
static member SendLogoutRequestByHTTPPost :
        httpResponse : HttpResponseBase *
        destinationURL : string *
        logoutRequest : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will return the form to post.
destinationURL
Type: SystemString
The destination URL.
logoutRequest
Type: System.XmlXmlElement
The logout request.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendLogoutRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutRequestByHTTPRedirect Method

SingleLogoutServiceSendLogoutRequestByHTTPRedirect Method

Overload List
Name | Description
SendLogoutRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout request using HTTP redirect.
SendLogoutRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout request using HTTP redirect.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutRequestByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String)

SingleLogoutServiceSendLogoutRequestByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String)

Sends the logout request using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendLogoutRequestByHTTPRedirect(
    HttpResponse httpResponse,
    string destinationURL,
    XmlElement logoutRequest,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Sub SendLogoutRequestByHTTPRedirect (
    httpResponse As HttpResponse,
    destinationURL As String,
    logoutRequest As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
static void SendLogoutRequestByHTTPRedirect(
    HttpResponse^ httpResponse,
    String^ destinationURL,
    XmlElement^ logoutRequest,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member SendLogoutRequestByHTTPRedirect :
        httpResponse : HttpResponse *
        destinationURL : string *
        logoutRequest : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
destinationURL
Type: SystemString
The destination URL.
logoutRequest
Type: System.XmlXmlElement
The logout request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendLogoutRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutRequestByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String)

SingleLogoutServiceSendLogoutRequestByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String)

Sends the logout request using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendLogoutRequestByHTTPRedirect(
    HttpResponseBase httpResponse,
    string destinationURL,
    XmlElement logoutRequest,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Sub SendLogoutRequestByHTTPRedirect (
    httpResponse As HttpResponseBase,
    destinationURL As String,
    logoutRequest As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
static void SendLogoutRequestByHTTPRedirect(
    HttpResponseBase^ httpResponse,
    String^ destinationURL,
    XmlElement^ logoutRequest,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member SendLogoutRequestByHTTPRedirect :
        httpResponse : HttpResponseBase *
        destinationURL : string *
        logoutRequest : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
destinationURL
Type: SystemString
The destination URL.
logoutRequest
Type: System.XmlXmlElement
The logout request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendLogoutRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutRequestReceiveLogoutResponseBySOAP Method

SingleLogoutServiceSendLogoutRequestReceiveLogoutResponseBySOAP Method

Sends the logout request and receives a logout response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement SendLogoutRequestReceiveLogoutResponseBySOAP(
    string destinationURL,
    XmlElement logoutRequest
)
Public Shared Function SendLogoutRequestReceiveLogoutResponseBySOAP (
    destinationURL As String,
    logoutRequest As XmlElement
) As XmlElement
public:
static XmlElement^ SendLogoutRequestReceiveLogoutResponseBySOAP(
    String^ destinationURL,
    XmlElement^ logoutRequest
)
static member SendLogoutRequestReceiveLogoutResponseBySOAP :
        destinationURL : string *
        logoutRequest : XmlElement -> XmlElement

Parameters

destinationURL
Type: SystemString
The destination URL.
logoutRequest
Type: System.XmlXmlElement
The logout request.

Return Value

Type: XmlElement
The logout response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send/receive fails.
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutResponseByHTTPPost Method

SingleLogoutServiceSendLogoutResponseByHTTPPost Method

Overload List
Name | Description
SendLogoutResponseByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the logout response using HTTP post.
SendLogoutResponseByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the logout response using HTTP post.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutResponseByHTTPPost Method (HttpResponse, String, XmlElement, String)

SingleLogoutServiceSendLogoutResponseByHTTPPost Method (HttpResponse, String, XmlElement, String)

Sends the logout response using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendLogoutResponseByHTTPPost(
    HttpResponse httpResponse,
    string destinationURL,
    XmlElement logoutResponse,
    string relayState
)
Public Shared Sub SendLogoutResponseByHTTPPost (
    httpResponse As HttpResponse,
    destinationURL As String,
    logoutResponse As XmlElement,
    relayState As String
)
public:
static void SendLogoutResponseByHTTPPost(
    HttpResponse^ httpResponse,
    String^ destinationURL,
    XmlElement^ logoutResponse,
    String^ relayState
)
static member SendLogoutResponseByHTTPPost :
        httpResponse : HttpResponse *
        destinationURL : string *
        logoutResponse : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will return the form to post.
destinationURL
Type: SystemString
The destination URL.
logoutResponse
Type: System.XmlXmlElement
The logout response.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendLogoutResponseByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutResponseByHTTPPost Method (HttpResponseBase, String, XmlElement, String)

SingleLogoutServiceSendLogoutResponseByHTTPPost Method (HttpResponseBase, String, XmlElement, String)

Sends the logout response using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendLogoutResponseByHTTPPost(
    HttpResponseBase httpResponse,
    string destinationURL,
    XmlElement logoutResponse,
    string relayState
)
Public Shared Sub SendLogoutResponseByHTTPPost (
    httpResponse As HttpResponseBase,
    destinationURL As String,
    logoutResponse As XmlElement,
    relayState As String
)
public:
static void SendLogoutResponseByHTTPPost(
    HttpResponseBase^ httpResponse,
    String^ destinationURL,
    XmlElement^ logoutResponse,
    String^ relayState
)
static member SendLogoutResponseByHTTPPost :
        httpResponse : HttpResponseBase *
        destinationURL : string *
        logoutResponse : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will return the form to post.
destinationURL
Type: SystemString
The destination URL.
logoutResponse
Type: System.XmlXmlElement
The logout response.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendLogoutResponseByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutResponseByHTTPRedirect Method

SingleLogoutServiceSendLogoutResponseByHTTPRedirect Method

Overload List
Name | Description
SendLogoutResponseByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout response using HTTP redirect.
SendLogoutResponseByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the logout response using HTTP redirect.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutResponseByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String)

SingleLogoutServiceSendLogoutResponseByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String)

Sends the logout response using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendLogoutResponseByHTTPRedirect(
    HttpResponse httpResponse,
    string destinationURL,
    XmlElement logoutResponse,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Sub SendLogoutResponseByHTTPRedirect (
    httpResponse As HttpResponse,
    destinationURL As String,
    logoutResponse As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
static void SendLogoutResponseByHTTPRedirect(
    HttpResponse^ httpResponse,
    String^ destinationURL,
    XmlElement^ logoutResponse,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member SendLogoutResponseByHTTPRedirect :
        httpResponse : HttpResponse *
        destinationURL : string *
        logoutResponse : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
destinationURL
Type: SystemString
The destination URL.
logoutResponse
Type: System.XmlXmlElement
The logout response.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendLogoutResponseByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutResponseByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String)

SingleLogoutServiceSendLogoutResponseByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String)

Sends the logout response using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendLogoutResponseByHTTPRedirect(
    HttpResponseBase httpResponse,
    string destinationURL,
    XmlElement logoutResponse,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Sub SendLogoutResponseByHTTPRedirect (
    httpResponse As HttpResponseBase,
    destinationURL As String,
    logoutResponse As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
static void SendLogoutResponseByHTTPRedirect(
    HttpResponseBase^ httpResponse,
    String^ destinationURL,
    XmlElement^ logoutResponse,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member SendLogoutResponseByHTTPRedirect :
        httpResponse : HttpResponseBase *
        destinationURL : string *
        logoutResponse : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
destinationURL
Type: SystemString
The destination URL.
logoutResponse
Type: System.XmlXmlElement
The logout response.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendLogoutResponseByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutResponseBySOAP Method

SingleLogoutServiceSendLogoutResponseBySOAP Method

Overload List
Name | Description
SendLogoutResponseBySOAP(HttpResponse, XmlElement) | Sends the logout response over SOAP.
SendLogoutResponseBySOAP(HttpResponseBase, XmlElement) | Sends the logout response over SOAP.
Top
See Also

Reference

SingleLogoutService Class
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutResponseBySOAP Method (HttpResponse, XmlElement)

SingleLogoutServiceSendLogoutResponseBySOAP Method (HttpResponse, XmlElement)

Sends the logout response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendLogoutResponseBySOAP(
    HttpResponse httpResponse,
    XmlElement logoutResponse
)
Public Shared Sub SendLogoutResponseBySOAP (
    httpResponse As HttpResponse,
    logoutResponse As XmlElement
)
public:
static void SendLogoutResponseBySOAP(
    HttpResponse^ httpResponse,
    XmlElement^ logoutResponse
)
static member SendLogoutResponseBySOAP :
        httpResponse : HttpResponse *
        logoutResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to send the logout response.
logoutResponse
Type: System.XmlXmlElement
The logout response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendLogoutResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


SingleLogoutService.SendLogoutResponseBySOAP Method (HttpResponseBase, XmlElement)

SingleLogoutServiceSendLogoutResponseBySOAP Method (HttpResponseBase, XmlElement)

Sends the logout response over SOAP.

Namespace: ComponentSpace.SAML2.Profiles.SingleLogout
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendLogoutResponseBySOAP(
    HttpResponseBase httpResponse,
    XmlElement logoutResponse
)
Public Shared Sub SendLogoutResponseBySOAP (
    httpResponse As HttpResponseBase,
    logoutResponse As XmlElement
)
public:
static void SendLogoutResponseBySOAP(
    HttpResponseBase^ httpResponse,
    XmlElement^ logoutResponse
)
static member SendLogoutResponseBySOAP :
        httpResponse : HttpResponseBase *
        logoutResponse : XmlElement -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to send the logout response.
logoutResponse
Type: System.XmlXmlElement
The logout response.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

SingleLogoutService Class
SendLogoutResponseBySOAP Overload
ComponentSpace.SAML2.Profiles.SingleLogout Namespace


ComponentSpace.SAML2.Profiles.SSOBrowser Namespace

The ComponentSpace.SAML2.Profiles.SSOBrowser namespace contains classes associated with the SAML v2.0 SSO browser profile.
Classes
 | Class | Description
Public class | IdentityProvider | Provides Identity Provider functionality in the SSO browser profile.
Public class | ServiceProvider | Provides Service Provider functionality in the SSO browser profile.


IdentityProvider Class

Provides Identity Provider functionality in the SSO browser profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.SSOBrowserIdentityProvider

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class IdentityProvider
Public NotInheritable Class IdentityProvider
public ref class IdentityProvider abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IdentityProvider =  class end
Methods
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact from the SP using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact from the SP using HTTP artifact with the artifact being in a form or query string.
ReceiveAuthnRequestByHTTPPost(HttpRequest, XmlElement, String) | Receives the authentication request from the SP using HTTP post.
ReceiveAuthnRequestByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the authentication request from the SP using HTTP post.
ReceiveAuthnRequestByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the authentication request from the SP using HTTP redirect.
ReceiveAuthnRequestByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the authentication request from the SP using HTTP redirect.
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact to the SP using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact to the SP using the HTTP artifact binding.
SendSAMLResponseByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the SAML response to the SP using HTTP post.
SendSAMLResponseByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the SAML response to the SP using HTTP post.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider Methods

Methods
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact from the SP using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact from the SP using HTTP artifact with the artifact being in a form or query string.
ReceiveAuthnRequestByHTTPPost(HttpRequest, XmlElement, String) | Receives the authentication request from the SP using HTTP post.
ReceiveAuthnRequestByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the authentication request from the SP using HTTP post.
ReceiveAuthnRequestByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the authentication request from the SP using HTTP redirect.
ReceiveAuthnRequestByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the authentication request from the SP using HTTP redirect.
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact to the SP using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact to the SP using the HTTP artifact binding.
SendSAMLResponseByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the SAML response to the SP using HTTP post.
SendSAMLResponseByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the SAML response to the SP using HTTP post.
Top
See Also

Reference

IdentityProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.ReceiveArtifactByHTTPArtifact Method

IdentityProviderReceiveArtifactByHTTPArtifact Method

Overload List
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact from the SP using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact from the SP using HTTP artifact with the artifact being in a form or query string.
Top
See Also

Reference

IdentityProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.ReceiveArtifactByHTTPArtifact Method (HttpRequest, Boolean, HTTPArtifact, String)

IdentityProviderReceiveArtifactByHTTPArtifact Method (HttpRequest, Boolean, HTTPArtifact, String)

Receives the artifact from the SP using HTTP artifact with the artifact being in a form or query string.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactByHTTPArtifact(
    HttpRequest httpRequest,
    bool artifactInForm,
    out HTTPArtifact httpArtifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactByHTTPArtifact (
    httpRequest As HttpRequest,
    artifactInForm As Boolean,
    <OutAttribute> ByRef httpArtifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactByHTTPArtifact(
    HttpRequest^ httpRequest,
    bool artifactInForm,
    [OutAttribute] HTTPArtifact^% httpArtifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactByHTTPArtifact :
        httpRequest : HttpRequest *
        artifactInForm : bool *
        httpArtifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the artifact.
artifactInForm
Type: SystemBoolean
If true the artifact is received in a form; otherwise it's received in a query string.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

IdentityProvider Class
ReceiveArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.ReceiveArtifactByHTTPArtifact Method (HttpRequestBase, Boolean, HTTPArtifact, String)

IdentityProviderReceiveArtifactByHTTPArtifact Method (HttpRequestBase, Boolean, HTTPArtifact, String)

Receives the artifact from the SP using HTTP artifact with the artifact being in a form or query string.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactByHTTPArtifact(
    HttpRequestBase httpRequest,
    bool artifactInForm,
    out HTTPArtifact httpArtifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactByHTTPArtifact (
    httpRequest As HttpRequestBase,
    artifactInForm As Boolean,
    <OutAttribute> ByRef httpArtifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactByHTTPArtifact(
    HttpRequestBase^ httpRequest,
    bool artifactInForm,
    [OutAttribute] HTTPArtifact^% httpArtifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactByHTTPArtifact :
        httpRequest : HttpRequestBase *
        artifactInForm : bool *
        httpArtifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the artifact.
artifactInForm
Type: SystemBoolean
If true the artifact is received in a form; otherwise it's received in a query string.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

IdentityProvider Class
ReceiveArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.ReceiveAuthnRequestByHTTPPost Method

IdentityProviderReceiveAuthnRequestByHTTPPost Method

Overload List
Name | Description
ReceiveAuthnRequestByHTTPPost(HttpRequest, XmlElement, String) | Receives the authentication request from the SP using HTTP post.
ReceiveAuthnRequestByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the authentication request from the SP using HTTP post.
Top
See Also

Reference

IdentityProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.ReceiveAuthnRequestByHTTPPost Method (HttpRequest, XmlElement, String)

IdentityProviderReceiveAuthnRequestByHTTPPost Method (HttpRequest, XmlElement, String)

Receives the authentication request from the SP using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveAuthnRequestByHTTPPost(
    HttpRequest httpRequest,
    out XmlElement authnRequest,
    out string relayState
)
Public Shared Sub ReceiveAuthnRequestByHTTPPost (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef authnRequest As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveAuthnRequestByHTTPPost(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% authnRequest,
    [OutAttribute] String^% relayState
)
static member ReceiveAuthnRequestByHTTPPost :
        httpRequest : HttpRequest *
        authnRequest : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
authnRequest
Type: System.XmlXmlElement
The returned authentication request message
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

IdentityProvider Class
ReceiveAuthnRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.ReceiveAuthnRequestByHTTPPost Method (HttpRequestBase, XmlElement, String)

IdentityProviderReceiveAuthnRequestByHTTPPost Method (HttpRequestBase, XmlElement, String)

Receives the authentication request from the SP using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveAuthnRequestByHTTPPost(
    HttpRequestBase httpRequest,
    out XmlElement authnRequest,
    out string relayState
)
Public Shared Sub ReceiveAuthnRequestByHTTPPost (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef authnRequest As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveAuthnRequestByHTTPPost(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% authnRequest,
    [OutAttribute] String^% relayState
)
static member ReceiveAuthnRequestByHTTPPost :
        httpRequest : HttpRequestBase *
        authnRequest : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
authnRequest
Type: System.XmlXmlElement
The returned authentication request message
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

IdentityProvider Class
ReceiveAuthnRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.ReceiveAuthnRequestByHTTPRedirect Method

IdentityProviderReceiveAuthnRequestByHTTPRedirect Method

Overload List
Name | Description
ReceiveAuthnRequestByHTTPRedirect(HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the authentication request from the SP using HTTP redirect.
ReceiveAuthnRequestByHTTPRedirect(HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm) | Receives the authentication request from the SP using HTTP redirect.
Top
See Also

Reference

IdentityProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.ReceiveAuthnRequestByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

IdentityProviderReceiveAuthnRequestByHTTPRedirect Method (HttpRequest, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the authentication request from the SP using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveAuthnRequestByHTTPRedirect(
    HttpRequest httpRequest,
    out XmlElement authnRequest,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveAuthnRequestByHTTPRedirect (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef authnRequest As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveAuthnRequestByHTTPRedirect(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% authnRequest,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveAuthnRequestByHTTPRedirect :
        httpRequest : HttpRequest *
        authnRequest : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the query string.
authnRequest
Type: System.XmlXmlElement
The returned authentication request message
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML request is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

IdentityProvider Class
ReceiveAuthnRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.ReceiveAuthnRequestByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

IdentityProviderReceiveAuthnRequestByHTTPRedirect Method (HttpRequestBase, XmlElement, String, Boolean, AsymmetricAlgorithm)

Receives the authentication request from the SP using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveAuthnRequestByHTTPRedirect(
    HttpRequestBase httpRequest,
    out XmlElement authnRequest,
    out string relayState,
    out bool signed,
    AsymmetricAlgorithm key
)
Public Shared Sub ReceiveAuthnRequestByHTTPRedirect (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef authnRequest As XmlElement,
    <OutAttribute> ByRef relayState As String,
    <OutAttribute> ByRef signed As Boolean,
    key As AsymmetricAlgorithm
)
public:
static void ReceiveAuthnRequestByHTTPRedirect(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% authnRequest,
    [OutAttribute] String^% relayState,
    [OutAttribute] bool% signed,
    AsymmetricAlgorithm^ key
)
static member ReceiveAuthnRequestByHTTPRedirect :
        httpRequest : HttpRequestBase *
        authnRequest : XmlElement byref *
        relayState : string byref *
        signed : bool byref *
        key : AsymmetricAlgorithm -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the query string.
authnRequest
Type: System.XmlXmlElement
The returned authentication request message
relayState
Type: SystemString
The returned relay state or null if none.
signed
Type: SystemBoolean
Indicates whether the SAML request is signed.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to verify the signature or null if no signature is to be verified.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

IdentityProvider Class
ReceiveAuthnRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.SendArtifactByHTTPArtifact Method

IdentityProviderSendArtifactByHTTPArtifact Method

Overload List
Name | Description
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact to the SP using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact to the SP using the HTTP artifact binding.
Top
See Also

Reference

IdentityProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.SendArtifactByHTTPArtifact Method (HttpResponse, String, HTTPArtifact, String, Boolean)

IdentityProviderSendArtifactByHTTPArtifact Method (HttpResponse, String, HTTPArtifact, String, Boolean)

Sends an artifact to the SP using the HTTP artifact binding.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactByHTTPArtifact(
    HttpResponse httpResponse,
    string spURL,
    HTTPArtifact httpArtifact,
    string relayState,
    bool sendArtifactInForm
)
Public Shared Sub SendArtifactByHTTPArtifact (
    httpResponse As HttpResponse,
    spURL As String,
    httpArtifact As HTTPArtifact,
    relayState As String,
    sendArtifactInForm As Boolean
)
public:
static void SendArtifactByHTTPArtifact(
    HttpResponse^ httpResponse,
    String^ spURL,
    HTTPArtifact^ httpArtifact,
    String^ relayState,
    bool sendArtifactInForm
)
static member SendArtifactByHTTPArtifact :
        httpResponse : HttpResponse *
        spURL : string *
        httpArtifact : HTTPArtifact *
        relayState : string *
        sendArtifactInForm : bool -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will send the artifact.
spURL
Type: SystemString
The SP URL.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact.
relayState
Type: SystemString
The relay state or null if none.
sendArtifactInForm
Type: SystemBoolean
If true the artifact is sent in a form; otherwise it's sent in a query string.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

IdentityProvider Class
SendArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.SendArtifactByHTTPArtifact Method (HttpResponseBase, String, HTTPArtifact, String, Boolean)

IdentityProviderSendArtifactByHTTPArtifact Method (HttpResponseBase, String, HTTPArtifact, String, Boolean)

Sends an artifact to the SP using the HTTP artifact binding.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactByHTTPArtifact(
    HttpResponseBase httpResponse,
    string spURL,
    HTTPArtifact httpArtifact,
    string relayState,
    bool sendArtifactInForm
)
Public Shared Sub SendArtifactByHTTPArtifact (
    httpResponse As HttpResponseBase,
    spURL As String,
    httpArtifact As HTTPArtifact,
    relayState As String,
    sendArtifactInForm As Boolean
)
public:
static void SendArtifactByHTTPArtifact(
    HttpResponseBase^ httpResponse,
    String^ spURL,
    HTTPArtifact^ httpArtifact,
    String^ relayState,
    bool sendArtifactInForm
)
static member SendArtifactByHTTPArtifact :
        httpResponse : HttpResponseBase *
        spURL : string *
        httpArtifact : HTTPArtifact *
        relayState : string *
        sendArtifactInForm : bool -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will send the artifact.
spURL
Type: SystemString
The SP URL.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact.
relayState
Type: SystemString
The relay state or null if none.
sendArtifactInForm
Type: SystemBoolean
If true the artifact is sent in a form; otherwise it's sent in a query string.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

IdentityProvider Class
SendArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.SendSAMLResponseByHTTPPost Method

IdentityProviderSendSAMLResponseByHTTPPost Method

Overload List
Name | Description
SendSAMLResponseByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the SAML response to the SP using HTTP post.
SendSAMLResponseByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the SAML response to the SP using HTTP post.
Top
See Also

Reference

IdentityProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.SendSAMLResponseByHTTPPost Method (HttpResponse, String, XmlElement, String)

IdentityProviderSendSAMLResponseByHTTPPost Method (HttpResponse, String, XmlElement, String)

Sends the SAML response to the SP using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSAMLResponseByHTTPPost(
    HttpResponse httpResponse,
    string spURL,
    XmlElement samlResponse,
    string relayState
)
Public Shared Sub SendSAMLResponseByHTTPPost (
    httpResponse As HttpResponse,
    spURL As String,
    samlResponse As XmlElement,
    relayState As String
)
public:
static void SendSAMLResponseByHTTPPost(
    HttpResponse^ httpResponse,
    String^ spURL,
    XmlElement^ samlResponse,
    String^ relayState
)
static member SendSAMLResponseByHTTPPost :
        httpResponse : HttpResponse *
        spURL : string *
        samlResponse : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will return the form to post.
spURL
Type: SystemString
The SP URL.
samlResponse
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

IdentityProvider Class
SendSAMLResponseByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


IdentityProvider.SendSAMLResponseByHTTPPost Method (HttpResponseBase, String, XmlElement, String)

IdentityProviderSendSAMLResponseByHTTPPost Method (HttpResponseBase, String, XmlElement, String)

Sends the SAML response to the SP using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendSAMLResponseByHTTPPost(
    HttpResponseBase httpResponse,
    string spURL,
    XmlElement samlResponse,
    string relayState
)
Public Shared Sub SendSAMLResponseByHTTPPost (
    httpResponse As HttpResponseBase,
    spURL As String,
    samlResponse As XmlElement,
    relayState As String
)
public:
static void SendSAMLResponseByHTTPPost(
    HttpResponseBase^ httpResponse,
    String^ spURL,
    XmlElement^ samlResponse,
    String^ relayState
)
static member SendSAMLResponseByHTTPPost :
        httpResponse : HttpResponseBase *
        spURL : string *
        samlResponse : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will return the form to post.
spURL
Type: SystemString
The SP URL.
samlResponse
Type: System.XmlXmlElement
The SAML response.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

IdentityProvider Class
SendSAMLResponseByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider Class

Provides Service Provider functionality in the SSO browser profile.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.Profiles.SSOBrowserServiceProvider

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class ServiceProvider
Public NotInheritable Class ServiceProvider
public ref class ServiceProvider abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ServiceProvider =  class end
Methods
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact from the IdP using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact from the IdP using HTTP artifact with the artifact being in a form or query string.
ReceiveSAMLResponseByHTTPPost(HttpRequest, XmlElement, String) | Receives the SAML response from the IdP using HTTP post.
ReceiveSAMLResponseByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the SAML response from the IdP using HTTP post.
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact to the IdP using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact to the IdP using the HTTP artifact binding.
SendAuthnRequestByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the authentication request to the IdP using HTTP post.
SendAuthnRequestByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the authentication request to the IdP using HTTP post.
SendAuthnRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the authentication request to the IdP using HTTP redirect.
SendAuthnRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the authentication request to the IdP using HTTP redirect.
SendAuthnRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the authentication request to the IdP using HTTP redirect.
SendAuthnRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the authentication request to the IdP using HTTP redirect.
Top
Remarks
Refer to the Profiles for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider Methods

Methods
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact from the IdP using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact from the IdP using HTTP artifact with the artifact being in a form or query string.
ReceiveSAMLResponseByHTTPPost(HttpRequest, XmlElement, String) | Receives the SAML response from the IdP using HTTP post.
ReceiveSAMLResponseByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the SAML response from the IdP using HTTP post.
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact to the IdP using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact to the IdP using the HTTP artifact binding.
SendAuthnRequestByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the authentication request to the IdP using HTTP post.
SendAuthnRequestByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the authentication request to the IdP using HTTP post.
SendAuthnRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the authentication request to the IdP using HTTP redirect.
SendAuthnRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the authentication request to the IdP using HTTP redirect.
SendAuthnRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the authentication request to the IdP using HTTP redirect.
SendAuthnRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the authentication request to the IdP using HTTP redirect.
Top
See Also

Reference

ServiceProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.ReceiveArtifactByHTTPArtifact Method

ServiceProviderReceiveArtifactByHTTPArtifact Method

Overload List
Name | Description
ReceiveArtifactByHTTPArtifact(HttpRequest, Boolean, HTTPArtifact, String) | Receives the artifact from the IdP using HTTP artifact with the artifact being in a form or query string.
ReceiveArtifactByHTTPArtifact(HttpRequestBase, Boolean, HTTPArtifact, String) | Receives the artifact from the IdP using HTTP artifact with the artifact being in a form or query string.
Top
See Also

Reference

ServiceProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.ReceiveArtifactByHTTPArtifact Method (HttpRequest, Boolean, HTTPArtifact, String)

ServiceProviderReceiveArtifactByHTTPArtifact Method (HttpRequest, Boolean, HTTPArtifact, String)

Receives the artifact from the IdP using HTTP artifact with the artifact being in a form or query string.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactByHTTPArtifact(
    HttpRequest httpRequest,
    bool artifactInForm,
    out HTTPArtifact httpArtifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactByHTTPArtifact (
    httpRequest As HttpRequest,
    artifactInForm As Boolean,
    <OutAttribute> ByRef httpArtifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactByHTTPArtifact(
    HttpRequest^ httpRequest,
    bool artifactInForm,
    [OutAttribute] HTTPArtifact^% httpArtifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactByHTTPArtifact :
        httpRequest : HttpRequest *
        artifactInForm : bool *
        httpArtifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the artifact.
artifactInForm
Type: SystemBoolean
If true the artifact is received in a form; otherwise it's received in a query string.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ServiceProvider Class
ReceiveArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.ReceiveArtifactByHTTPArtifact Method (HttpRequestBase, Boolean, HTTPArtifact, String)

ServiceProviderReceiveArtifactByHTTPArtifact Method (HttpRequestBase, Boolean, HTTPArtifact, String)

Receives the artifact from the IdP using HTTP artifact with the artifact being in a form or query string.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveArtifactByHTTPArtifact(
    HttpRequestBase httpRequest,
    bool artifactInForm,
    out HTTPArtifact httpArtifact,
    out string relayState
)
Public Shared Sub ReceiveArtifactByHTTPArtifact (
    httpRequest As HttpRequestBase,
    artifactInForm As Boolean,
    <OutAttribute> ByRef httpArtifact As HTTPArtifact,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveArtifactByHTTPArtifact(
    HttpRequestBase^ httpRequest,
    bool artifactInForm,
    [OutAttribute] HTTPArtifact^% httpArtifact,
    [OutAttribute] String^% relayState
)
static member ReceiveArtifactByHTTPArtifact :
        httpRequest : HttpRequestBase *
        artifactInForm : bool *
        httpArtifact : HTTPArtifact byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the artifact.
artifactInForm
Type: SystemBoolean
If true the artifact is received in a form; otherwise it's received in a query string.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The returned artifact.
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ServiceProvider Class
ReceiveArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.ReceiveSAMLResponseByHTTPPost Method

ServiceProviderReceiveSAMLResponseByHTTPPost Method

Overload List
Name | Description
ReceiveSAMLResponseByHTTPPost(HttpRequest, XmlElement, String) | Receives the SAML response from the IdP using HTTP post.
ReceiveSAMLResponseByHTTPPost(HttpRequestBase, XmlElement, String) | Receives the SAML response from the IdP using HTTP post.
Top
See Also

Reference

ServiceProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.ReceiveSAMLResponseByHTTPPost Method (HttpRequest, XmlElement, String)

ServiceProviderReceiveSAMLResponseByHTTPPost Method (HttpRequest, XmlElement, String)

Receives the SAML response from the IdP using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSAMLResponseByHTTPPost(
    HttpRequest httpRequest,
    out XmlElement samlResponse,
    out string relayState
)
Public Shared Sub ReceiveSAMLResponseByHTTPPost (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef samlResponse As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveSAMLResponseByHTTPPost(
    HttpRequest^ httpRequest,
    [OutAttribute] XmlElement^% samlResponse,
    [OutAttribute] String^% relayState
)
static member ReceiveSAMLResponseByHTTPPost :
        httpRequest : HttpRequest *
        samlResponse : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request containing the posted form.
samlResponse
Type: System.XmlXmlElement
The returned SAML response message
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ServiceProvider Class
ReceiveSAMLResponseByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.ReceiveSAMLResponseByHTTPPost Method (HttpRequestBase, XmlElement, String)

ServiceProviderReceiveSAMLResponseByHTTPPost Method (HttpRequestBase, XmlElement, String)

Receives the SAML response from the IdP using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void ReceiveSAMLResponseByHTTPPost(
    HttpRequestBase httpRequest,
    out XmlElement samlResponse,
    out string relayState
)
Public Shared Sub ReceiveSAMLResponseByHTTPPost (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef samlResponse As XmlElement,
    <OutAttribute> ByRef relayState As String
)
public:
static void ReceiveSAMLResponseByHTTPPost(
    HttpRequestBase^ httpRequest,
    [OutAttribute] XmlElement^% samlResponse,
    [OutAttribute] String^% relayState
)
static member ReceiveSAMLResponseByHTTPPost :
        httpRequest : HttpRequestBase *
        samlResponse : XmlElement byref *
        relayState : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request containing the posted form.
samlResponse
Type: System.XmlXmlElement
The returned SAML response message
relayState
Type: SystemString
The returned relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the receive fails.
See Also

Reference

ServiceProvider Class
ReceiveSAMLResponseByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendArtifactByHTTPArtifact Method

ServiceProviderSendArtifactByHTTPArtifact Method

Overload List
Name | Description
SendArtifactByHTTPArtifact(HttpResponse, String, HTTPArtifact, String, Boolean) | Sends an artifact to the IdP using the HTTP artifact binding.
SendArtifactByHTTPArtifact(HttpResponseBase, String, HTTPArtifact, String, Boolean) | Sends an artifact to the IdP using the HTTP artifact binding.
Top
See Also

Reference

ServiceProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendArtifactByHTTPArtifact Method (HttpResponse, String, HTTPArtifact, String, Boolean)

ServiceProviderSendArtifactByHTTPArtifact Method (HttpResponse, String, HTTPArtifact, String, Boolean)

Sends an artifact to the IdP using the HTTP artifact binding.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactByHTTPArtifact(
    HttpResponse httpResponse,
    string idpURL,
    HTTPArtifact httpArtifact,
    string relayState,
    bool sendArtifactInForm
)
Public Shared Sub SendArtifactByHTTPArtifact (
    httpResponse As HttpResponse,
    idpURL As String,
    httpArtifact As HTTPArtifact,
    relayState As String,
    sendArtifactInForm As Boolean
)
public:
static void SendArtifactByHTTPArtifact(
    HttpResponse^ httpResponse,
    String^ idpURL,
    HTTPArtifact^ httpArtifact,
    String^ relayState,
    bool sendArtifactInForm
)
static member SendArtifactByHTTPArtifact :
        httpResponse : HttpResponse *
        idpURL : string *
        httpArtifact : HTTPArtifact *
        relayState : string *
        sendArtifactInForm : bool -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will send the artifact.
idpURL
Type: SystemString
The IdP URL.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact.
relayState
Type: SystemString
The relay state or null if none.
sendArtifactInForm
Type: SystemBoolean
If true the artifact is sent in a form; otherwise it's sent in a query string.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ServiceProvider Class
SendArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendArtifactByHTTPArtifact Method (HttpResponseBase, String, HTTPArtifact, String, Boolean)

ServiceProviderSendArtifactByHTTPArtifact Method (HttpResponseBase, String, HTTPArtifact, String, Boolean)

Sends an artifact to the IdP using the HTTP artifact binding.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendArtifactByHTTPArtifact(
    HttpResponseBase httpResponse,
    string idpURL,
    HTTPArtifact httpArtifact,
    string relayState,
    bool sendArtifactInForm
)
Public Shared Sub SendArtifactByHTTPArtifact (
    httpResponse As HttpResponseBase,
    idpURL As String,
    httpArtifact As HTTPArtifact,
    relayState As String,
    sendArtifactInForm As Boolean
)
public:
static void SendArtifactByHTTPArtifact(
    HttpResponseBase^ httpResponse,
    String^ idpURL,
    HTTPArtifact^ httpArtifact,
    String^ relayState,
    bool sendArtifactInForm
)
static member SendArtifactByHTTPArtifact :
        httpResponse : HttpResponseBase *
        idpURL : string *
        httpArtifact : HTTPArtifact *
        relayState : string *
        sendArtifactInForm : bool -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will send the artifact.
idpURL
Type: SystemString
The IdP URL.
httpArtifact
Type: ComponentSpace.SAML2.BindingsHTTPArtifact
The artifact.
relayState
Type: SystemString
The relay state or null if none.
sendArtifactInForm
Type: SystemBoolean
If true the artifact is sent in a form; otherwise it's sent in a query string.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ServiceProvider Class
SendArtifactByHTTPArtifact Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendAuthnRequestByHTTPPost Method

ServiceProviderSendAuthnRequestByHTTPPost Method

Overload List
Name | Description
SendAuthnRequestByHTTPPost(HttpResponse, String, XmlElement, String) | Sends the authentication request to the IdP using HTTP post.
SendAuthnRequestByHTTPPost(HttpResponseBase, String, XmlElement, String) | Sends the authentication request to the IdP using HTTP post.
Top
See Also

Reference

ServiceProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendAuthnRequestByHTTPPost Method (HttpResponse, String, XmlElement, String)

ServiceProviderSendAuthnRequestByHTTPPost Method (HttpResponse, String, XmlElement, String)

Sends the authentication request to the IdP using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendAuthnRequestByHTTPPost(
    HttpResponse httpResponse,
    string idpURL,
    XmlElement authnRequest,
    string relayState
)
Public Shared Sub SendAuthnRequestByHTTPPost (
    httpResponse As HttpResponse,
    idpURL As String,
    authnRequest As XmlElement,
    relayState As String
)
public:
static void SendAuthnRequestByHTTPPost(
    HttpResponse^ httpResponse,
    String^ idpURL,
    XmlElement^ authnRequest,
    String^ relayState
)
static member SendAuthnRequestByHTTPPost :
        httpResponse : HttpResponse *
        idpURL : string *
        authnRequest : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response that will return the form to post.
idpURL
Type: SystemString
The IdP URL.
authnRequest
Type: System.XmlXmlElement
The authentication request.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ServiceProvider Class
SendAuthnRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendAuthnRequestByHTTPPost Method (HttpResponseBase, String, XmlElement, String)

ServiceProviderSendAuthnRequestByHTTPPost Method (HttpResponseBase, String, XmlElement, String)

Sends the authentication request to the IdP using HTTP post.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendAuthnRequestByHTTPPost(
    HttpResponseBase httpResponse,
    string idpURL,
    XmlElement authnRequest,
    string relayState
)
Public Shared Sub SendAuthnRequestByHTTPPost (
    httpResponse As HttpResponseBase,
    idpURL As String,
    authnRequest As XmlElement,
    relayState As String
)
public:
static void SendAuthnRequestByHTTPPost(
    HttpResponseBase^ httpResponse,
    String^ idpURL,
    XmlElement^ authnRequest,
    String^ relayState
)
static member SendAuthnRequestByHTTPPost :
        httpResponse : HttpResponseBase *
        idpURL : string *
        authnRequest : XmlElement *
        relayState : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response that will return the form to post.
idpURL
Type: SystemString
The IdP URL.
authnRequest
Type: System.XmlXmlElement
The authentication request.
relayState
Type: SystemString
The relay state or null if none.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ServiceProvider Class
SendAuthnRequestByHTTPPost Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendAuthnRequestByHTTPRedirect Method

ServiceProviderSendAuthnRequestByHTTPRedirect Method

Overload List
Name | Description
SendAuthnRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm) | Sends the authentication request to the IdP using HTTP redirect.
SendAuthnRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm) | Sends the authentication request to the IdP using HTTP redirect.
SendAuthnRequestByHTTPRedirect(HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the authentication request to the IdP using HTTP redirect.
SendAuthnRequestByHTTPRedirect(HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String) | Sends the authentication request to the IdP using HTTP redirect.
Top
See Also

Reference

ServiceProvider Class
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendAuthnRequestByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm)

ServiceProviderSendAuthnRequestByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm)

Sends the authentication request to the IdP using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendAuthnRequestByHTTPRedirect(
    HttpResponse httpResponse,
    string idpURL,
    XmlElement authnRequest,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Sub SendAuthnRequestByHTTPRedirect (
    httpResponse As HttpResponse,
    idpURL As String,
    authnRequest As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
)
public:
static void SendAuthnRequestByHTTPRedirect(
    HttpResponse^ httpResponse,
    String^ idpURL,
    XmlElement^ authnRequest,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member SendAuthnRequestByHTTPRedirect :
        httpResponse : HttpResponse *
        idpURL : string *
        authnRequest : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
idpURL
Type: SystemString
The IdP URL.
authnRequest
Type: System.XmlXmlElement
The authentication request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ServiceProvider Class
SendAuthnRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendAuthnRequestByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm)

ServiceProviderSendAuthnRequestByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm)

Sends the authentication request to the IdP using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendAuthnRequestByHTTPRedirect(
    HttpResponseBase httpResponse,
    string idpURL,
    XmlElement authnRequest,
    string relayState,
    AsymmetricAlgorithm key
)
Public Shared Sub SendAuthnRequestByHTTPRedirect (
    httpResponse As HttpResponseBase,
    idpURL As String,
    authnRequest As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm
)
public:
static void SendAuthnRequestByHTTPRedirect(
    HttpResponseBase^ httpResponse,
    String^ idpURL,
    XmlElement^ authnRequest,
    String^ relayState,
    AsymmetricAlgorithm^ key
)
static member SendAuthnRequestByHTTPRedirect :
        httpResponse : HttpResponseBase *
        idpURL : string *
        authnRequest : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
idpURL
Type: SystemString
The IdP URL.
authnRequest
Type: System.XmlXmlElement
The authentication request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ServiceProvider Class
SendAuthnRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendAuthnRequestByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String)

ServiceProviderSendAuthnRequestByHTTPRedirect Method (HttpResponse, String, XmlElement, String, AsymmetricAlgorithm, String)

Sends the authentication request to the IdP using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendAuthnRequestByHTTPRedirect(
    HttpResponse httpResponse,
    string idpURL,
    XmlElement authnRequest,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Sub SendAuthnRequestByHTTPRedirect (
    httpResponse As HttpResponse,
    idpURL As String,
    authnRequest As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
static void SendAuthnRequestByHTTPRedirect(
    HttpResponse^ httpResponse,
    String^ idpURL,
    XmlElement^ authnRequest,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member SendAuthnRequestByHTTPRedirect :
        httpResponse : HttpResponse *
        idpURL : string *
        authnRequest : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponse
The HTTP response used to perform the redirect.
idpURL
Type: SystemString
The IdP URL.
authnRequest
Type: System.XmlXmlElement
The authentication request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ServiceProvider Class
SendAuthnRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ServiceProvider.SendAuthnRequestByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String)

ServiceProviderSendAuthnRequestByHTTPRedirect Method (HttpResponseBase, String, XmlElement, String, AsymmetricAlgorithm, String)

Sends the authentication request to the IdP using HTTP redirect.

Namespace: ComponentSpace.SAML2.Profiles.SSOBrowser
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void SendAuthnRequestByHTTPRedirect(
    HttpResponseBase httpResponse,
    string idpURL,
    XmlElement authnRequest,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Shared Sub SendAuthnRequestByHTTPRedirect (
    httpResponse As HttpResponseBase,
    idpURL As String,
    authnRequest As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
static void SendAuthnRequestByHTTPRedirect(
    HttpResponseBase^ httpResponse,
    String^ idpURL,
    XmlElement^ authnRequest,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
static member SendAuthnRequestByHTTPRedirect :
        httpResponse : HttpResponseBase *
        idpURL : string *
        authnRequest : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> unit

Parameters

httpResponse
Type: System.WebHttpResponseBase
The HTTP response used to perform the redirect.
idpURL
Type: SystemString
The IdP URL.
authnRequest
Type: System.XmlXmlElement
The authentication request.
relayState
Type: SystemString
The relay state or null if none.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLProfileException | Thrown when the send fails.
See Also

Reference

ServiceProvider Class
SendAuthnRequestByHTTPRedirect Overload
ComponentSpace.SAML2.Profiles.SSOBrowser Namespace


ComponentSpace.SAML2.Protocols Namespace

The ComponentSpace.SAML2.Protocols namespace contains classes for manipulating SAML v2.0 request and response messages.
Classes
 | Class | Description
Public class | Artifact | Represents an artifact.
Public class | ArtifactResolve | Represents an artifact resolve request.
Public class | ArtifactResponse | Represents an artifact response.
Public class | AssertionIDRequest | Represents an assertion ID request.
Public class | AttributeQuery | Represents an attribute query.
Public class | AuthnQuery | Represents an authentication query.
Public class | AuthnRequest | Represents an authentication request.
Public class | AuthzDecisionQuery | Represents an authorization decision query.
Public class | Extensions | Represents extensions.
Public class | GetComplete | Represents a get complete URI.
Public class | IDPEntry | Represents an IDP entry.
Public class | IDPList | Represents an IDP list.
Public class | LogoutRequest | Represents a logout request.
Public class | LogoutResponse | Represents a logout response.
Public class | ManageNameIDRequest | Represents a manage name ID request.
Public class | ManageNameIDResponse | Represents a manage name ID response.
Public class | NameIDMappingRequest | Represents a name ID mapping request.
Public class | NameIDMappingResponse | Represents a name ID mapping response.
Public class | NameIDPolicy | Represents a name ID policy.
Public class | NewID | Represents new ID.
Public class | RequestAbstractType | Represents the request abstract type.
Public class | RequestedAuthnContext | Represents a requested authentication context.
Public class | RequesterID | Represents a requester ID.
Public class | SAMLMessageSignature | Permits XML signature generation and verification for SAML protocol request and response messages.
Public class | SAMLResponse | Represents a SAML response.
Public class | Scoping | Represents a scoping.
Public class | SessionIndex | Represents a session index.
Public class | Status | Represents a status.
Public class | StatusCode | Represents a status code.
Public class | StatusDetail | Represents status detail.
Public class | StatusMessage | Represents a status message.
Public class | StatusResponseType | Represents the status response type.
Public class | SubjectQuery | Represents a subject query.
Public class | SubjectQueryAbstractType | Represents the subject query abstract type.
Public class | Terminate | Represents a terminate.


Artifact Class

Represents an artifact.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsArtifact

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Artifact
Public Class Artifact
public ref class Artifact
type Artifact =  class end

The Artifact type exposes the following members.

Constructors
 | Name | Description
Public method | Artifact | Initializes a new instance of the Artifact class.
Public method | Artifact(String) | Initializes a new instance of the Artifact class.
Public method | Artifact(XmlElement) | Initializes a new instance of the Artifact class from XML.
Top
Properties
 | Name | Description
Public property | ArtifactValue | Gets or sets the artifact value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an artifact.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the artifact value. (Overrides ObjectToString.)
Public method | ToXml | Serializes the artifact to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


Artifact Constructor

Overload List
 | Name | Description
Public method | Artifact | Initializes a new instance of the Artifact class.
Public method | Artifact(String) | Initializes a new instance of the Artifact class.
Public method | Artifact(XmlElement) | Initializes a new instance of the Artifact class from XML.
Top
See Also

Reference

Artifact Class
ComponentSpace.SAML2.Protocols Namespace


Artifact Constructor

Initializes a new instance of the Artifact class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Artifact()
Public Sub New
public:
Artifact()
new : unit -> Artifact
See Also

Reference

Artifact Class
Artifact Overload
ComponentSpace.SAML2.Protocols Namespace


Artifact Constructor (String)

Initializes a new instance of the Artifact class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Artifact(
    string artifactValue
)
Public Sub New (
    artifactValue As String
)
public:
Artifact(
    String^ artifactValue
)
new :
        artifactValue : string -> Artifact

Parameters

artifactValue
Type: SystemString
The artifact value.
See Also

Reference

Artifact Class
Artifact Overload
ComponentSpace.SAML2.Protocols Namespace


Artifact Constructor (XmlElement)

Initializes a new instance of the Artifact class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Artifact(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Artifact(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Artifact

Parameters

xmlElement
Type: System.XmlXmlElement
The artifact XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Artifact Class
Artifact Overload
ComponentSpace.SAML2.Protocols Namespace


Artifact Properties

The Artifact type exposes the following members.

Properties
 | Name | Description
Public property | ArtifactValue | Gets or sets the artifact value.
Top
See Also

Reference

Artifact Class
ComponentSpace.SAML2.Protocols Namespace


Artifact.ArtifactValue Property

ArtifactArtifactValue Property

Gets or sets the artifact value.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ArtifactValue { get; set; }
Public Property ArtifactValue As String
    Get
    Set
public:
property String^ ArtifactValue {
    String^ get ();
    void set (String^ value);
}
member ArtifactValue : string with get, set

Property Value

Type: String
The artifact value.
See Also

Reference

Artifact Class
ComponentSpace.SAML2.Protocols Namespace


Artifact Methods

The Artifact type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an artifact.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the artifact value. (Overrides ObjectToString.)
Public method | ToXml | Serializes the artifact to XML.
Top
See Also

Reference

Artifact Class
ComponentSpace.SAML2.Protocols Namespace


Artifact.IsValid Method

ArtifactIsValid Method

Indicates whether the XML is an artifact.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an artifact; otherwise false.
See Also

Reference

Artifact Class
ComponentSpace.SAML2.Protocols Namespace


Artifact.ToString Method

ArtifactToString Method

Returns the artifact value.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The artifact value
See Also

Reference

Artifact Class
ComponentSpace.SAML2.Protocols Namespace


Artifact.ToXml Method

ArtifactToXml Method

Serializes the artifact to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The artifact as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Artifact Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve Class

Represents an artifact resolve request.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsArtifactResolve

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class ArtifactResolve : RequestAbstractType
Public Class ArtifactResolve
    Inherits RequestAbstractType
public ref class ArtifactResolve : public RequestAbstractType
type ArtifactResolve =
    class
        inherit RequestAbstractType
    end

The ArtifactResolve type exposes the following members.

Constructors
 | Name | Description
Public method | ArtifactResolve | Initializes a new instance of the ArtifactResolve class.
Public method | ArtifactResolve(XmlElement) | Initializes a new instance of the ArtifactResolve class from XML.
Top
Properties
 | Name | Description
Public property | Artifact | Gets or sets the artifact.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an artifact resolve request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the artifact resolve request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the artifact resolve request to XML.
Public method | ToXml(XmlDocument) | Serializes the artifact resolve request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve Constructor

Overload List
 | Name | Description
Public method | ArtifactResolve | Initializes a new instance of the ArtifactResolve class.
Public method | ArtifactResolve(XmlElement) | Initializes a new instance of the ArtifactResolve class from XML.
Top
See Also

Reference

ArtifactResolve Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve Constructor

Initializes a new instance of the ArtifactResolve class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ArtifactResolve()
Public Sub New
public:
ArtifactResolve()
new : unit -> ArtifactResolve
See Also

Reference

ArtifactResolve Class
ArtifactResolve Overload
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve Constructor (XmlElement)

Initializes a new instance of the ArtifactResolve class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ArtifactResolve(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
ArtifactResolve(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> ArtifactResolve

Parameters

xmlElement
Type: System.XmlXmlElement
The artifact resolve request XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

ArtifactResolve Class
ArtifactResolve Overload
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve Properties

The ArtifactResolve type exposes the following members.

Properties
 | Name | Description
Public property | Artifact | Gets or sets the artifact.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

ArtifactResolve Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve.Artifact Property

ArtifactResolveArtifact Property

Gets or sets the artifact.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Artifact Artifact { get; set; }
Public Property Artifact As Artifact
    Get
    Set
public:
property Artifact^ Artifact {
    Artifact^ get ();
    void set (Artifact^ value);
}
member Artifact : Artifact with get, set

Property Value

Type: Artifact
The artifact.
See Also

Reference

ArtifactResolve Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve Methods

The ArtifactResolve type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an artifact resolve request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the artifact resolve request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the artifact resolve request to XML.
Public method | ToXml(XmlDocument) | Serializes the artifact resolve request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

ArtifactResolve Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve.IsValid Method

ArtifactResolveIsValid Method

Indicates whether the XML is an artifact resolve request.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an artifact resolve request; otherwise false.
See Also

Reference

ArtifactResolve Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve.ToString Method

ArtifactResolveToString Method

Converts the artifact resolve request to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The artifact resolve request as a string.
See Also

Reference

ArtifactResolve Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve.ToXml Method

ArtifactResolveToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the artifact resolve request to XML.
Public method | ToXml(XmlDocument) | Serializes the artifact resolve request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

ArtifactResolve Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve.ToXml Method

ArtifactResolveToXml Method

Serializes the artifact resolve request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The artifact resolve request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

ArtifactResolve Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


ArtifactResolve.ToXml Method (XmlDocument)

ArtifactResolveToXml Method (XmlDocument)

Serializes the artifact resolve request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The artifact resolve request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

ArtifactResolve Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse Class

Represents an artifact response.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsStatusResponseType
ComponentSpace.SAML2.ProtocolsArtifactResponse

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class ArtifactResponse : StatusResponseType
Public Class ArtifactResponse
    Inherits StatusResponseType
public ref class ArtifactResponse : public StatusResponseType
type ArtifactResponse =
    class
        inherit StatusResponseType
    end

The ArtifactResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ArtifactResponse | Initializes a new instance of the ArtifactResponse class.
Public method | ArtifactResponse(XmlElement) | Initializes a new instance of the ArtifactResponse class from XML.
Top
Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from StatusResponseType.)
Public property | Destination | Gets or sets the destination. (Inherited from StatusResponseType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from StatusResponseType.)
Public property | ID | Gets or sets the ID. (Inherited from StatusResponseType.)
Public property | InResponseTo | Gets or sets the in response to. (Inherited from StatusResponseType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from StatusResponseType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from StatusResponseType.)
Public property | SAMLMessage | Gets or sets the SAML message.
Public property | Signature | Gets or sets the digital signature. (Inherited from StatusResponseType.)
Public property | Status | Gets or sets the status. (Inherited from StatusResponseType.)
Public property | Version | Gets or sets the version. (Inherited from StatusResponseType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSuccess | Indicates whether the status indicates success or not. (Inherited from StatusResponseType.)
 | IsValid | Indicates whether the XML is an artifact response.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the artifact response to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the artifact response to XML.
Public method | ToXml(XmlDocument) | Serializes the artifact response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse Constructor

Overload List
 | Name | Description
Public method | ArtifactResponse | Initializes a new instance of the ArtifactResponse class.
Public method | ArtifactResponse(XmlElement) | Initializes a new instance of the ArtifactResponse class from XML.
Top
See Also

Reference

ArtifactResponse Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse Constructor

Initializes a new instance of the ArtifactResponse class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ArtifactResponse()
Public Sub New
public:
ArtifactResponse()
new : unit -> ArtifactResponse
See Also

Reference

ArtifactResponse Class
ArtifactResponse Overload
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse Constructor (XmlElement)

Initializes a new instance of the ArtifactResponse class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ArtifactResponse(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
ArtifactResponse(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> ArtifactResponse

Parameters

xmlElement
Type: System.XmlXmlElement
The artifact response XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

ArtifactResponse Class
ArtifactResponse Overload
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse Properties

The ArtifactResponse type exposes the following members.

Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from StatusResponseType.)
Public property | Destination | Gets or sets the destination. (Inherited from StatusResponseType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from StatusResponseType.)
Public property | ID | Gets or sets the ID. (Inherited from StatusResponseType.)
Public property | InResponseTo | Gets or sets the in response to. (Inherited from StatusResponseType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from StatusResponseType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from StatusResponseType.)
Public property | SAMLMessage | Gets or sets the SAML message.
Public property | Signature | Gets or sets the digital signature. (Inherited from StatusResponseType.)
Public property | Status | Gets or sets the status. (Inherited from StatusResponseType.)
Public property | Version | Gets or sets the version. (Inherited from StatusResponseType.)
Top
See Also

Reference

ArtifactResponse Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse.SAMLMessage Property

ArtifactResponseSAMLMessage Property

Gets or sets the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement SAMLMessage { get; set; }
Public Property SAMLMessage As XmlElement
    Get
    Set
public:
property XmlElement^ SAMLMessage {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member SAMLMessage : XmlElement with get, set

Property Value

Type: XmlElement
The SAML message or null if none.
See Also

Reference

ArtifactResponse Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse Methods

The ArtifactResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSuccess | Indicates whether the status indicates success or not. (Inherited from StatusResponseType.)
 | IsValid | Indicates whether the XML is an artifact response.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the artifact response to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the artifact response to XML.
Public method | ToXml(XmlDocument) | Serializes the artifact response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
See Also

Reference

ArtifactResponse Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse.IsValid Method

ArtifactResponseIsValid Method

Indicates whether the XML is an artifact response.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an artifact response; otherwise false.
See Also

Reference

ArtifactResponse Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse.ToString Method

ArtifactResponseToString Method

Converts the artifact response to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The artifact response as a string.
See Also

Reference

ArtifactResponse Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse.ToXml Method

ArtifactResponseToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the artifact response to XML.
Public method | ToXml(XmlDocument) | Serializes the artifact response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
See Also

Reference

ArtifactResponse Class
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse.ToXml Method

ArtifactResponseToXml Method

Serializes the artifact response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The artifact response as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

ArtifactResponse Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


ArtifactResponse.ToXml Method (XmlDocument)

ArtifactResponseToXml Method (XmlDocument)

Serializes the artifact response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The artifact response as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

ArtifactResponse Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest Class

Represents an assertion ID request.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsAssertionIDRequest

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AssertionIDRequest : RequestAbstractType
Public Class AssertionIDRequest
    Inherits RequestAbstractType
public ref class AssertionIDRequest : public RequestAbstractType
type AssertionIDRequest =
    class
        inherit RequestAbstractType
    end

The AssertionIDRequest type exposes the following members.

Constructors
 | Name | Description
Public method | AssertionIDRequest | Initializes a new instance of the AssertionIDRequest class.
Public method | AssertionIDRequest(XmlElement) | Initializes a new instance of the AssertionIDRequest class from XML.
Top
Properties
 | Name | Description
Public property | AssertionIDRefs | Gets or sets the assertion ID refs.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an assertion ID request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the assertion ID request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the assertion ID request to XML.
Public method | ToXml(XmlDocument) | Serializes the assertion ID request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest Constructor

Overload List
 | Name | Description
Public method | AssertionIDRequest | Initializes a new instance of the AssertionIDRequest class.
Public method | AssertionIDRequest(XmlElement) | Initializes a new instance of the AssertionIDRequest class from XML.
Top
See Also

Reference

AssertionIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest Constructor

Initializes a new instance of the AssertionIDRequest class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AssertionIDRequest()
Public Sub New
public:
AssertionIDRequest()
new : unit -> AssertionIDRequest
See Also

Reference

AssertionIDRequest Class
AssertionIDRequest Overload
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest Constructor (XmlElement)

Initializes a new instance of the AssertionIDRequest class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AssertionIDRequest(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AssertionIDRequest(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AssertionIDRequest

Parameters

xmlElement
Type: System.XmlXmlElement
The assertion ID request XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AssertionIDRequest Class
AssertionIDRequest Overload
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest Properties

The AssertionIDRequest type exposes the following members.

Properties
 | Name | Description
Public property | AssertionIDRefs | Gets or sets the assertion ID refs.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

AssertionIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest.AssertionIDRefs Property

AssertionIDRequestAssertionIDRefs Property

Gets or sets the assertion ID refs.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<AssertionIDRef> AssertionIDRefs { get; set; }
Public Property AssertionIDRefs As IList(Of AssertionIDRef)
    Get
    Set
public:
property IList<AssertionIDRef^>^ AssertionIDRefs {
    IList<AssertionIDRef^>^ get ();
    void set (IList<AssertionIDRef^>^ value);
}
member AssertionIDRefs : IList<AssertionIDRef> with get, set

Property Value

Type: IList AssertionIDRef
The assertion ID refs.
See Also

Reference

AssertionIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest Methods

The AssertionIDRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an assertion ID request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the assertion ID request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the assertion ID request to XML.
Public method | ToXml(XmlDocument) | Serializes the assertion ID request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

AssertionIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest.IsValid Method

AssertionIDRequestIsValid Method

Indicates whether the XML is an assertion ID request.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an assertion ID request; otherwise false.
See Also

Reference

AssertionIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest.ToString Method

AssertionIDRequestToString Method

Converts the assertion ID request to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The assertion ID request as a string.
See Also

Reference

AssertionIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest.ToXml Method

AssertionIDRequestToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the assertion ID request to XML.
Public method | ToXml(XmlDocument) | Serializes the assertion ID request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

AssertionIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest.ToXml Method

AssertionIDRequestToXml Method

Serializes the assertion ID request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The assertion ID request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

AssertionIDRequest Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


AssertionIDRequest.ToXml Method (XmlDocument)

AssertionIDRequestToXml Method (XmlDocument)

Serializes the assertion ID request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The assertion ID request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AssertionIDRequest Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery Class

Represents an attribute query.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsSubjectQueryAbstractType
ComponentSpace.SAML2.ProtocolsAttributeQuery

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AttributeQuery : SubjectQueryAbstractType
Public Class AttributeQuery
    Inherits SubjectQueryAbstractType
public ref class AttributeQuery : public SubjectQueryAbstractType
type AttributeQuery =
    class
        inherit SubjectQueryAbstractType
    end

The AttributeQuery type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeQuery | Initializes a new instance of the AttributeQuery class.
Public method | AttributeQuery(XmlElement) | Initializes a new instance of the AttributeQuery class from XML.
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets the attributes.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject. (Inherited from SubjectQueryAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an attribute query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the attribute query to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the attribute query to XML.
Public method | ToXml(XmlDocument) | Serializes the attribute query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


AttributeQuery Constructor

Overload List
 | Name | Description
Public method | AttributeQuery | Initializes a new instance of the AttributeQuery class.
Public method | AttributeQuery(XmlElement) | Initializes a new instance of the AttributeQuery class from XML.
Top
See Also

Reference

AttributeQuery Class
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery Constructor

Initializes a new instance of the AttributeQuery class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeQuery()
Public Sub New
public:
AttributeQuery()
new : unit -> AttributeQuery
See Also

Reference

AttributeQuery Class
AttributeQuery Overload
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery Constructor (XmlElement)

Initializes a new instance of the AttributeQuery class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AttributeQuery(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AttributeQuery(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AttributeQuery

Parameters

xmlElement
Type: System.XmlXmlElement
The attribute query XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AttributeQuery Class
AttributeQuery Overload
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery Properties

The AttributeQuery type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets the attributes.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject. (Inherited from SubjectQueryAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

AttributeQuery Class
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery.Attributes Property

AttributeQueryAttributes Property

Gets or sets the attributes.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<SAMLAttribute> Attributes { get; set; }
Public Property Attributes As IList(Of SAMLAttribute)
    Get
    Set
public:
property IList<SAMLAttribute^>^ Attributes {
    IList<SAMLAttribute^>^ get ();
    void set (IList<SAMLAttribute^>^ value);
}
member Attributes : IList<SAMLAttribute> with get, set

Property Value

Type: IList SAMLAttribute
The attributes.
See Also

Reference

AttributeQuery Class
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery Methods

The AttributeQuery type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an attribute query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the attribute query to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the attribute query to XML.
Public method | ToXml(XmlDocument) | Serializes the attribute query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
See Also

Reference

AttributeQuery Class
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery.IsValid Method

AttributeQueryIsValid Method

Indicates whether the XML is an attribute query.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an attribute query; otherwise false.
See Also

Reference

AttributeQuery Class
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery.ToString Method

AttributeQueryToString Method

Converts the attribute query to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The attribute query as a string.
See Also

Reference

AttributeQuery Class
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery.ToXml Method

AttributeQueryToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the attribute query to XML.
Public method | ToXml(XmlDocument) | Serializes the attribute query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
See Also

Reference

AttributeQuery Class
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery.ToXml Method

AttributeQueryToXml Method

Serializes the attribute query to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The attribute query as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

AttributeQuery Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


AttributeQuery.ToXml Method (XmlDocument)

AttributeQueryToXml Method (XmlDocument)

Serializes the attribute query to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The attribute query as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AttributeQuery Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery Class

Represents an authentication query.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsSubjectQueryAbstractType
ComponentSpace.SAML2.ProtocolsAuthnQuery

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthnQuery : SubjectQueryAbstractType
Public Class AuthnQuery
    Inherits SubjectQueryAbstractType
public ref class AuthnQuery : public SubjectQueryAbstractType
type AuthnQuery =
    class
        inherit SubjectQueryAbstractType
    end

The AuthnQuery type exposes the following members.

Constructors
 | Name | Description
Public method | AuthnQuery | Initializes a new instance of the AuthnQuery class.
Public method | AuthnQuery(XmlElement) | Initializes a new instance of the AuthnQuery class from XML.
Top
Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | RequestedAuthnContext | Gets or sets the requested authentication context.
Public property | SessionIndex | Gets or sets the session index.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject. (Inherited from SubjectQueryAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the authentication query to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the authentication query to XML.
Public method | ToXml(XmlDocument) | Serializes the authentication query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


AuthnQuery Constructor

Overload List
 | Name | Description
Public method | AuthnQuery | Initializes a new instance of the AuthnQuery class.
Public method | AuthnQuery(XmlElement) | Initializes a new instance of the AuthnQuery class from XML.
Top
See Also

Reference

AuthnQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery Constructor

Initializes a new instance of the AuthnQuery class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnQuery()
Public Sub New
public:
AuthnQuery()
new : unit -> AuthnQuery
See Also

Reference

AuthnQuery Class
AuthnQuery Overload
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery Constructor (XmlElement)

Initializes a new instance of the AuthnQuery class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnQuery(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthnQuery(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthnQuery

Parameters

xmlElement
Type: System.XmlXmlElement
The authentication query XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthnQuery Class
AuthnQuery Overload
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery Properties

The AuthnQuery type exposes the following members.

Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | RequestedAuthnContext | Gets or sets the requested authentication context.
Public property | SessionIndex | Gets or sets the session index.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject. (Inherited from SubjectQueryAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

AuthnQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery.RequestedAuthnContext Property

AuthnQueryRequestedAuthnContext Property

Gets or sets the requested authentication context.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequestedAuthnContext RequestedAuthnContext { get; set; }
Public Property RequestedAuthnContext As RequestedAuthnContext
    Get
    Set
public:
property RequestedAuthnContext^ RequestedAuthnContext {
    RequestedAuthnContext^ get ();
    void set (RequestedAuthnContext^ value);
}
member RequestedAuthnContext : RequestedAuthnContext with get, set

Property Value

Type: RequestedAuthnContext
The session index.
See Also

Reference

AuthnQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery.SessionIndex Property

AuthnQuerySessionIndex Property

Gets or sets the session index.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SessionIndex { get; set; }
Public Property SessionIndex As String
    Get
    Set
public:
property String^ SessionIndex {
    String^ get ();
    void set (String^ value);
}
member SessionIndex : string with get, set

Property Value

Type: String
The session index.
See Also

Reference

AuthnQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery Methods

The AuthnQuery type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the authentication query to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the authentication query to XML.
Public method | ToXml(XmlDocument) | Serializes the authentication query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
See Also

Reference

AuthnQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery.IsValid Method

AuthnQueryIsValid Method

Indicates whether the XML is an authentication query.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an authentication query; otherwise false.
See Also

Reference

AuthnQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery.ToString Method

AuthnQueryToString Method

Converts the authentication query to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The authentication query as a string.
See Also

Reference

AuthnQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery.ToXml Method

AuthnQueryToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the authentication query to XML.
Public method | ToXml(XmlDocument) | Serializes the authentication query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
See Also

Reference

AuthnQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery.ToXml Method

AuthnQueryToXml Method

Serializes the authentication query to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The authentication query as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

AuthnQuery Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


AuthnQuery.ToXml Method (XmlDocument)

AuthnQueryToXml Method (XmlDocument)

Serializes the authentication query to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authentication query as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthnQuery Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest Class

Represents an authentication request.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsAuthnRequest

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthnRequest : RequestAbstractType
Public Class AuthnRequest
    Inherits RequestAbstractType
public ref class AuthnRequest : public RequestAbstractType
type AuthnRequest =
    class
        inherit RequestAbstractType
    end

The AuthnRequest type exposes the following members.

Constructors
 | Name | Description
Public method | AuthnRequest | Initializes a new instance of the AuthnRequest class.
Public method | AuthnRequest(XmlElement) | Initializes a new instance of the AuthnRequest class from XML.
Top
Properties
 | Name | Description
Public property | AssertionConsumerServiceIndex | Gets or sets the assertion consumer service index.
Public property | AssertionConsumerServiceURL | Gets or sets the assertion consumer service URL.
Public property | AttributeConsumingServiceIndex | Gets or sets the attribute consuming service index.
Public property | Conditions | Gets or sets the conditions.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ForceAuthn | Gets or sets the force authentication flag.
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IsPassive | Gets or sets the is passive flag.
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | NameIDPolicy | Gets or sets the name ID policy.
Public property | ProtocolBinding | Gets or sets the protocol binding.
Public property | ProviderName | Gets or sets the provider name.
Public property | RequestedAuthnContext | Gets or sets the requested authentication context.
Public property | Scoping | Gets or sets the scoping.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject.
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the authentication request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the authentication request to XML.
Public method | ToXml(XmlDocument) | Serializes the authentication request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


AuthnRequest Constructor

Overload List
 | Name | Description
Public method | AuthnRequest | Initializes a new instance of the AuthnRequest class.
Public method | AuthnRequest(XmlElement) | Initializes a new instance of the AuthnRequest class from XML.
Top
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest Constructor

Initializes a new instance of the AuthnRequest class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnRequest()
Public Sub New
public:
AuthnRequest()
new : unit -> AuthnRequest
See Also

Reference

AuthnRequest Class
AuthnRequest Overload
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest Constructor (XmlElement)

Initializes a new instance of the AuthnRequest class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthnRequest(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthnRequest(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthnRequest

Parameters

xmlElement
Type: System.XmlXmlElement
The authentication request XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthnRequest Class
AuthnRequest Overload
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest Properties

The AuthnRequest type exposes the following members.

Properties
 | Name | Description
Public property | AssertionConsumerServiceIndex | Gets or sets the assertion consumer service index.
Public property | AssertionConsumerServiceURL | Gets or sets the assertion consumer service URL.
Public property | AttributeConsumingServiceIndex | Gets or sets the attribute consuming service index.
Public property | Conditions | Gets or sets the conditions.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ForceAuthn | Gets or sets the force authentication flag.
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IsPassive | Gets or sets the is passive flag.
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | NameIDPolicy | Gets or sets the name ID policy.
Public property | ProtocolBinding | Gets or sets the protocol binding.
Public property | ProviderName | Gets or sets the provider name.
Public property | RequestedAuthnContext | Gets or sets the requested authentication context.
Public property | Scoping | Gets or sets the scoping.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject.
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.AssertionConsumerServiceIndex Property

AuthnRequestAssertionConsumerServiceIndex Property

Gets or sets the assertion consumer service index.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int AssertionConsumerServiceIndex { get; set; }
Public Property AssertionConsumerServiceIndex As Integer
    Get
    Set
public:
property int AssertionConsumerServiceIndex {
    int get ();
    void set (int value);
}
member AssertionConsumerServiceIndex : int with get, set

Property Value

Type: Int32
The assertion consumer service index or negative if none.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.AssertionConsumerServiceURL Property

AuthnRequestAssertionConsumerServiceURL Property

Gets or sets the assertion consumer service URL.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string AssertionConsumerServiceURL { get; set; }
Public Property AssertionConsumerServiceURL As String
    Get
    Set
public:
property String^ AssertionConsumerServiceURL {
    String^ get ();
    void set (String^ value);
}
member AssertionConsumerServiceURL : string with get, set

Property Value

Type: String
The assertion consumer service URL.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.AttributeConsumingServiceIndex Property

AuthnRequestAttributeConsumingServiceIndex Property

Gets or sets the attribute consuming service index.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int AttributeConsumingServiceIndex { get; set; }
Public Property AttributeConsumingServiceIndex As Integer
    Get
    Set
public:
property int AttributeConsumingServiceIndex {
    int get ();
    void set (int value);
}
member AttributeConsumingServiceIndex : int with get, set

Property Value

Type: Int32
The attribute consuming service index or negative if none.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.Conditions Property

AuthnRequestConditions Property

Gets or sets the conditions.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Conditions Conditions { get; set; }
Public Property Conditions As Conditions
    Get
    Set
public:
property Conditions^ Conditions {
    Conditions^ get ();
    void set (Conditions^ value);
}
member Conditions : Conditions with get, set

Property Value

Type: Conditions
The conditions.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.ForceAuthn Property

AuthnRequestForceAuthn Property

Gets or sets the force authentication flag.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool ForceAuthn { get; set; }
Public Property ForceAuthn As Boolean
    Get
    Set
public:
property bool ForceAuthn {
    bool get ();
    void set (bool value);
}
member ForceAuthn : bool with get, set

Property Value

Type: Boolean
The force authentication flag.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.IsPassive Property

AuthnRequestIsPassive Property

Gets or sets the is passive flag.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool IsPassive { get; set; }
Public Property IsPassive As Boolean
    Get
    Set
public:
property bool IsPassive {
    bool get ();
    void set (bool value);
}
member IsPassive : bool with get, set

Property Value

Type: Boolean
The is passive flag.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.NameIDPolicy Property

AuthnRequestNameIDPolicy Property

Gets or sets the name ID policy.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDPolicy NameIDPolicy { get; set; }
Public Property NameIDPolicy As NameIDPolicy
    Get
    Set
public:
property NameIDPolicy^ NameIDPolicy {
    NameIDPolicy^ get ();
    void set (NameIDPolicy^ value);
}
member NameIDPolicy : NameIDPolicy with get, set

Property Value

Type: NameIDPolicy
The name ID policy.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.ProtocolBinding Property

AuthnRequestProtocolBinding Property

Gets or sets the protocol binding.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ProtocolBinding { get; set; }
Public Property ProtocolBinding As String
    Get
    Set
public:
property String^ ProtocolBinding {
    String^ get ();
    void set (String^ value);
}
member ProtocolBinding : string with get, set

Property Value

Type: String
The protocol binding.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.ProviderName Property

AuthnRequestProviderName Property

Gets or sets the provider name.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ProviderName { get; set; }
Public Property ProviderName As String
    Get
    Set
public:
property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
member ProviderName : string with get, set

Property Value

Type: String
The provider name.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.RequestedAuthnContext Property

AuthnRequestRequestedAuthnContext Property

Gets or sets the requested authentication context.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequestedAuthnContext RequestedAuthnContext { get; set; }
Public Property RequestedAuthnContext As RequestedAuthnContext
    Get
    Set
public:
property RequestedAuthnContext^ RequestedAuthnContext {
    RequestedAuthnContext^ get ();
    void set (RequestedAuthnContext^ value);
}
member RequestedAuthnContext : RequestedAuthnContext with get, set

Property Value

Type: RequestedAuthnContext
The requested authentication context.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.Scoping Property

AuthnRequestScoping Property

Gets or sets the scoping.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Scoping Scoping { get; set; }
Public Property Scoping As Scoping
    Get
    Set
public:
property Scoping^ Scoping {
    Scoping^ get ();
    void set (Scoping^ value);
}
member Scoping : Scoping with get, set

Property Value

Type: Scoping
The scoping.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.Subject Property

AuthnRequestSubject Property

Gets or sets the subject.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Subject Subject { get; set; }
Public Property Subject As Subject
    Get
    Set
public:
property Subject^ Subject {
    Subject^ get ();
    void set (Subject^ value);
}
member Subject : Subject with get, set

Property Value

Type: Subject
The subject.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest Methods

The AuthnRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authentication request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the authentication request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the authentication request to XML.
Public method | ToXml(XmlDocument) | Serializes the authentication request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.IsValid Method

AuthnRequestIsValid Method

Indicates whether the XML is an authentication request.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an authentication request; otherwise false.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.ToString Method

AuthnRequestToString Method

Converts the authentication request to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The authentication request as a string.
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.ToXml Method

AuthnRequestToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the authentication request to XML.
Public method | ToXml(XmlDocument) | Serializes the authentication request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

AuthnRequest Class
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.ToXml Method

AuthnRequestToXml Method

Serializes the authentication request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The authentication request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

AuthnRequest Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


AuthnRequest.ToXml Method (XmlDocument)

AuthnRequestToXml Method (XmlDocument)

Serializes the authentication request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authentication request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthnRequest Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery Class

Represents an authorization decision query.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsSubjectQueryAbstractType
ComponentSpace.SAML2.ProtocolsAuthzDecisionQuery

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class AuthzDecisionQuery : SubjectQueryAbstractType
Public Class AuthzDecisionQuery
    Inherits SubjectQueryAbstractType
public ref class AuthzDecisionQuery : public SubjectQueryAbstractType
type AuthzDecisionQuery =
    class
        inherit SubjectQueryAbstractType
    end

The AuthzDecisionQuery type exposes the following members.

Constructors
 | Name | Description
Public method | AuthzDecisionQuery | Initializes a new instance of the AuthzDecisionQuery class.
Public method | AuthzDecisionQuery(XmlElement) | Initializes a new instance of the AuthzDecisionQuery class from XML.
Top
Properties
 | Name | Description
Public property | Actions | Gets or sets the actions.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Evidence | Gets or sets the evidence.
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Resource | Gets or sets the resource.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject. (Inherited from SubjectQueryAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authorization decision query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the authorization decision query to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the authorization decision query to XML.
Public method | ToXml(XmlDocument) | Serializes the authorization decision query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery Constructor

Overload List
 | Name | Description
Public method | AuthzDecisionQuery | Initializes a new instance of the AuthzDecisionQuery class.
Public method | AuthzDecisionQuery(XmlElement) | Initializes a new instance of the AuthzDecisionQuery class from XML.
Top
See Also

Reference

AuthzDecisionQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery Constructor

Initializes a new instance of the AuthzDecisionQuery class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthzDecisionQuery()
Public Sub New
public:
AuthzDecisionQuery()
new : unit -> AuthzDecisionQuery
See Also

Reference

AuthzDecisionQuery Class
AuthzDecisionQuery Overload
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery Constructor (XmlElement)

Initializes a new instance of the AuthzDecisionQuery class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public AuthzDecisionQuery(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
AuthzDecisionQuery(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> AuthzDecisionQuery

Parameters

xmlElement
Type: System.XmlXmlElement
The authorization decision query XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

AuthzDecisionQuery Class
AuthzDecisionQuery Overload
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery Properties

The AuthzDecisionQuery type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Gets or sets the actions.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Evidence | Gets or sets the evidence.
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Resource | Gets or sets the resource.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject. (Inherited from SubjectQueryAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

AuthzDecisionQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery.Actions Property

AuthzDecisionQueryActions Property

Gets or sets the actions.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<Action> Actions { get; set; }
Public Property Actions As IList(Of Action)
    Get
    Set
public:
property IList<Action^>^ Actions {
    IList<Action^>^ get ();
    void set (IList<Action^>^ value);
}
member Actions : IList<Action> with get, set

Property Value

Type: IList Action
The actions.
See Also

Reference

AuthzDecisionQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery.Evidence Property

AuthzDecisionQueryEvidence Property

Gets or sets the evidence.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Evidence Evidence { get; set; }
Public Property Evidence As Evidence
    Get
    Set
public:
property Evidence^ Evidence {
    Evidence^ get ();
    void set (Evidence^ value);
}
member Evidence : Evidence with get, set

Property Value

Type: Evidence
The evidence.
See Also

Reference

AuthzDecisionQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery.Resource Property

AuthzDecisionQueryResource Property

Gets or sets the resource.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Resource { get; set; }
Public Property Resource As String
    Get
    Set
public:
property String^ Resource {
    String^ get ();
    void set (String^ value);
}
member Resource : string with get, set

Property Value

Type: String
The resource.
See Also

Reference

AuthzDecisionQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery Methods

The AuthzDecisionQuery type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an authorization decision query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the authorization decision query to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the authorization decision query to XML.
Public method | ToXml(XmlDocument) | Serializes the authorization decision query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
See Also

Reference

AuthzDecisionQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery.IsValid Method

AuthzDecisionQueryIsValid Method

Indicates whether the XML is an authorization decision query.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an authorization decision query; otherwise false.
See Also

Reference

AuthzDecisionQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery.ToString Method

AuthzDecisionQueryToString Method

Converts the authorization decision query to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The authorization decision query as a string.
See Also

Reference

AuthzDecisionQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery.ToXml Method

AuthzDecisionQueryToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the authorization decision query to XML.
Public method | ToXml(XmlDocument) | Serializes the authorization decision query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
See Also

Reference

AuthzDecisionQuery Class
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery.ToXml Method

AuthzDecisionQueryToXml Method

Serializes the authorization decision query to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The authorization decision query as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

AuthzDecisionQuery Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


AuthzDecisionQuery.ToXml Method (XmlDocument)

AuthzDecisionQueryToXml Method (XmlDocument)

Serializes the authorization decision query to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The authorization decision query as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

AuthzDecisionQuery Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


Extensions Class

Represents extensions.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsExtensions

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Extensions
Public Class Extensions
public ref class Extensions
type Extensions =  class end

The Extensions type exposes the following members.

Constructors
 | Name | Description
Public method | Extensions | Initializes a new instance of the Extensions class.
Public method | Extensions(XmlElement) | Initializes a new instance of the Extensions class from XML.
Public method | Extensions(XmlNodeList) | Initializes a new instance of the Extensions class.
Top
Properties
 | Name | Description
Public property | Data | Gets or sets the data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an extensions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the extensions to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


Extensions Constructor

Overload List
 | Name | Description
Public method | Extensions | Initializes a new instance of the Extensions class.
Public method | Extensions(XmlElement) | Initializes a new instance of the Extensions class from XML.
Public method | Extensions(XmlNodeList) | Initializes a new instance of the Extensions class.
Top
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Protocols Namespace


Extensions Constructor

Initializes a new instance of the Extensions class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions()
Public Sub New
public:
Extensions()
new : unit -> Extensions
See Also

Reference

Extensions Class
Extensions Overload
ComponentSpace.SAML2.Protocols Namespace


Extensions Constructor (XmlElement)

Initializes a new instance of the Extensions class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Extensions(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Extensions

Parameters

xmlElement
Type: System.XmlXmlElement
The extensions element XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Extensions Class
Extensions Overload
ComponentSpace.SAML2.Protocols Namespace


Extensions Constructor (XmlNodeList)

Initializes a new instance of the Extensions class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions(
    XmlNodeList data
)
Public Sub New (
    data As XmlNodeList
)
public:
Extensions(
    XmlNodeList^ data
)
new :
        data : XmlNodeList -> Extensions

Parameters

data
Type: System.XmlXmlNodeList
The extensions data.
See Also

Reference

Extensions Class
Extensions Overload
ComponentSpace.SAML2.Protocols Namespace


Extensions Properties

The Extensions type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets or sets the data.
Top
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Protocols Namespace


Extensions.Data Property

ExtensionsData Property

Gets or sets the data.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlNodeList Data { get; set; }
Public Property Data As XmlNodeList
    Get
    Set
public:
property XmlNodeList^ Data {
    XmlNodeList^ get ();
    void set (XmlNodeList^ value);
}
member Data : XmlNodeList with get, set

Property Value

Type: XmlNodeList
The data.
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Protocols Namespace


Extensions Methods

The Extensions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an extensions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the extensions to XML.
Top
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Protocols Namespace


Extensions.IsValid Method

ExtensionsIsValid Method

Indicates whether the XML is an extensions.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an extensions; otherwise false.
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Protocols Namespace


Extensions.ToXml Method

ExtensionsToXml Method

Serializes the extensions to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The extensions as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Extensions Class
ComponentSpace.SAML2.Protocols Namespace


GetComplete Class

Represents a get complete URI.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsGetComplete

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class GetComplete
Public Class GetComplete
public ref class GetComplete
type GetComplete =  class end

The GetComplete type exposes the following members.

Constructors
 | Name | Description
Public method | GetComplete | Initializes a new instance of the GetComplete class.
Public method | GetComplete(String) | Initializes a new instance of the GetComplete class.
Public method | GetComplete(XmlElement) | Initializes a new instance of the GetComplete class from XML.
Top
Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a get complete URI.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the URI. (Overrides ObjectToString.)
Public method | ToXml | Serializes the get complete URI to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


GetComplete Constructor

Overload List
 | Name | Description
Public method | GetComplete | Initializes a new instance of the GetComplete class.
Public method | GetComplete(String) | Initializes a new instance of the GetComplete class.
Public method | GetComplete(XmlElement) | Initializes a new instance of the GetComplete class from XML.
Top
See Also

Reference

GetComplete Class
ComponentSpace.SAML2.Protocols Namespace


GetComplete Constructor

Initializes a new instance of the GetComplete class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public GetComplete()
Public Sub New
public:
GetComplete()
new : unit -> GetComplete
See Also

Reference

GetComplete Class
GetComplete Overload
ComponentSpace.SAML2.Protocols Namespace


GetComplete Constructor (String)

Initializes a new instance of the GetComplete class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public GetComplete(
    string uri
)
Public Sub New (
    uri As String
)
public:
GetComplete(
    String^ uri
)
new :
        uri : string -> GetComplete

Parameters

uri
Type: SystemString
The URI.
See Also

Reference

GetComplete Class
GetComplete Overload
ComponentSpace.SAML2.Protocols Namespace


GetComplete Constructor (XmlElement)

Initializes a new instance of the GetComplete class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public GetComplete(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
GetComplete(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> GetComplete

Parameters

xmlElement
Type: System.XmlXmlElement
The get complete URI XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

GetComplete Class
GetComplete Overload
ComponentSpace.SAML2.Protocols Namespace


GetComplete Properties

The GetComplete type exposes the following members.

Properties
 | Name | Description
Public property | URI | Gets or sets the URI.
Top
See Also

Reference

GetComplete Class
ComponentSpace.SAML2.Protocols Namespace


GetComplete.URI Property

GetCompleteURI Property

Gets or sets the URI.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string URI { get; set; }
Public Property URI As String
    Get
    Set
public:
property String^ URI {
    String^ get ();
    void set (String^ value);
}
member URI : string with get, set

Property Value

Type: String
The URI.
See Also

Reference

GetComplete Class
ComponentSpace.SAML2.Protocols Namespace


GetComplete Methods

The GetComplete type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a get complete URI.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the URI. (Overrides ObjectToString.)
Public method | ToXml | Serializes the get complete URI to XML.
Top
See Also

Reference

GetComplete Class
ComponentSpace.SAML2.Protocols Namespace


GetComplete.IsValid Method

GetCompleteIsValid Method

Indicates whether the XML is a get complete URI.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a get complete URI; otherwise false.
See Also

Reference

GetComplete Class
ComponentSpace.SAML2.Protocols Namespace


GetComplete.ToString Method

GetCompleteToString Method

Returns the URI.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The URI
See Also

Reference

GetComplete Class
ComponentSpace.SAML2.Protocols Namespace


GetComplete.ToXml Method

GetCompleteToXml Method

Serializes the get complete URI to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The get complete URI as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

GetComplete Class
ComponentSpace.SAML2.Protocols Namespace


IDPEntry Class

Represents an IDP entry.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsIDPEntry

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class IDPEntry
Public Class IDPEntry
public ref class IDPEntry
type IDPEntry =  class end

The IDPEntry type exposes the following members.

Constructors
 | Name | Description
Public method | IDPEntry | Initializes a new instance of the IDPEntry class.
Public method | IDPEntry(XmlElement) | Initializes a new instance of the IDPEntry class from XML.
Top
Properties
 | Name | Description
Public property | Location | Gets or sets the location.
Public property | Name | Gets or sets the name.
Public property | ProviderID | Gets or sets the provider ID.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an IDP entry.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the IDP entry to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


IDPEntry Constructor

Overload List
 | Name | Description
Public method | IDPEntry | Initializes a new instance of the IDPEntry class.
Public method | IDPEntry(XmlElement) | Initializes a new instance of the IDPEntry class from XML.
Top
See Also

Reference

IDPEntry Class
ComponentSpace.SAML2.Protocols Namespace


IDPEntry Constructor

Initializes a new instance of the IDPEntry class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDPEntry()
Public Sub New
public:
IDPEntry()
new : unit -> IDPEntry
See Also

Reference

IDPEntry Class
IDPEntry Overload
ComponentSpace.SAML2.Protocols Namespace


IDPEntry Constructor (XmlElement)

Initializes a new instance of the IDPEntry class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDPEntry(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
IDPEntry(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> IDPEntry

Parameters

xmlElement
Type: System.XmlXmlElement
The IDP entry XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

IDPEntry Class
IDPEntry Overload
ComponentSpace.SAML2.Protocols Namespace


IDPEntry Properties

The IDPEntry type exposes the following members.

Properties
 | Name | Description
Public property | Location | Gets or sets the location.
Public property | Name | Gets or sets the name.
Public property | ProviderID | Gets or sets the provider ID.
Top
See Also

Reference

IDPEntry Class
ComponentSpace.SAML2.Protocols Namespace


IDPEntry.Location Property

IDPEntryLocation Property

Gets or sets the location.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
The location.
See Also

Reference

IDPEntry Class
ComponentSpace.SAML2.Protocols Namespace


IDPEntry.Name Property

IDPEntryName Property

Gets or sets the name.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

IDPEntry Class
ComponentSpace.SAML2.Protocols Namespace


IDPEntry.ProviderID Property

IDPEntryProviderID Property

Gets or sets the provider ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ProviderID { get; set; }
Public Property ProviderID As String
    Get
    Set
public:
property String^ ProviderID {
    String^ get ();
    void set (String^ value);
}
member ProviderID : string with get, set

Property Value

Type: String
The provider ID.
See Also

Reference

IDPEntry Class
ComponentSpace.SAML2.Protocols Namespace


IDPEntry Methods

The IDPEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an IDP entry.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the IDP entry to XML.
Top
See Also

Reference

IDPEntry Class
ComponentSpace.SAML2.Protocols Namespace


IDPEntry.IsValid Method

IDPEntryIsValid Method

Indicates whether the XML is an IDP entry.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an IDP entry; otherwise false.
See Also

Reference

IDPEntry Class
ComponentSpace.SAML2.Protocols Namespace


IDPEntry.ToXml Method

IDPEntryToXml Method

Serializes the IDP entry to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The IDP entry as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

IDPEntry Class
ComponentSpace.SAML2.Protocols Namespace


IDPList Class

Represents an IDP list.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsIDPList

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class IDPList
Public Class IDPList
public ref class IDPList
type IDPList =  class end

The IDPList type exposes the following members.

Constructors
 | Name | Description
Public method | IDPList | Initializes a new instance of the IDPList class.
Public method | IDPList(XmlElement) | Initializes a new instance of the IDPList class from XML.
Top
Properties
 | Name | Description
Public property | GetComplete | Gets or sets the get complete URI.
Public property | IDPEntries | Gets or sets the IDP entries.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an IDP list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the IDP list to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


IDPList Constructor

Overload List
 | Name | Description
Public method | IDPList | Initializes a new instance of the IDPList class.
Public method | IDPList(XmlElement) | Initializes a new instance of the IDPList class from XML.
Top
See Also

Reference

IDPList Class
ComponentSpace.SAML2.Protocols Namespace


IDPList Constructor

Initializes a new instance of the IDPList class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDPList()
Public Sub New
public:
IDPList()
new : unit -> IDPList
See Also

Reference

IDPList Class
IDPList Overload
ComponentSpace.SAML2.Protocols Namespace


IDPList Constructor (XmlElement)

Initializes a new instance of the IDPList class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDPList(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
IDPList(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> IDPList

Parameters

xmlElement
Type: System.XmlXmlElement
The IDP list XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

IDPList Class
IDPList Overload
ComponentSpace.SAML2.Protocols Namespace


IDPList Properties

The IDPList type exposes the following members.

Properties
 | Name | Description
Public property | GetComplete | Gets or sets the get complete URI.
Public property | IDPEntries | Gets or sets the IDP entries.
Top
See Also

Reference

IDPList Class
ComponentSpace.SAML2.Protocols Namespace


IDPList.GetComplete Property

IDPListGetComplete Property

Gets or sets the get complete URI.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public GetComplete GetComplete { get; set; }
Public Property GetComplete As GetComplete
    Get
    Set
public:
property GetComplete^ GetComplete {
    GetComplete^ get ();
    void set (GetComplete^ value);
}
member GetComplete : GetComplete with get, set

Property Value

Type: GetComplete
The get complete URI.
See Also

Reference

IDPList Class
ComponentSpace.SAML2.Protocols Namespace


IDPList.IDPEntries Property

IDPListIDPEntries Property

Gets or sets the IDP entries.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<IDPEntry> IDPEntries { get; set; }
Public Property IDPEntries As IList(Of IDPEntry)
    Get
    Set
public:
property IList<IDPEntry^>^ IDPEntries {
    IList<IDPEntry^>^ get ();
    void set (IList<IDPEntry^>^ value);
}
member IDPEntries : IList<IDPEntry> with get, set

Property Value

Type: IList IDPEntry
The IDP entries.
See Also

Reference

IDPList Class
ComponentSpace.SAML2.Protocols Namespace


IDPList Methods

The IDPList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an IDP list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the IDP list to XML.
Top
See Also

Reference

IDPList Class
ComponentSpace.SAML2.Protocols Namespace


IDPList.IsValid Method

IDPListIsValid Method

Indicates whether the XML is an IDP list.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an IDP list; otherwise false.
See Also

Reference

IDPList Class
ComponentSpace.SAML2.Protocols Namespace


IDPList.ToXml Method

IDPListToXml Method

Serializes the IDP list to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The IDP list as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

IDPList Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest Class

Represents a logout request.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsLogoutRequest

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class LogoutRequest : RequestAbstractType
Public Class LogoutRequest
    Inherits RequestAbstractType
public ref class LogoutRequest : public RequestAbstractType
type LogoutRequest =
    class
        inherit RequestAbstractType
    end

The LogoutRequest type exposes the following members.

Constructors
 | Name | Description
Public method | LogoutRequest | Initializes a new instance of the LogoutRequest class.
Public method | LogoutRequest(XmlElement) | Initializes a new instance of the LogoutRequest class from XML.
Top
Properties
 | Name | Description
Public property | BaseID | Gets or sets the base ID.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | EncryptedID | Gets or sets the encrypted ID.
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | NameID | Gets or sets the name ID.
Public property | NotOnOrAfter | Gets or sets the not on or after time.
Public property | Reason | Gets or sets the reason.
Public property | SessionIndexes | Gets or sets the session indexes.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a logout request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the logout request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the logout request to XML.
Public method | ToXml(XmlDocument) | Serializes the logout request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


LogoutRequest Constructor

Overload List
 | Name | Description
Public method | LogoutRequest | Initializes a new instance of the LogoutRequest class.
Public method | LogoutRequest(XmlElement) | Initializes a new instance of the LogoutRequest class from XML.
Top
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest Constructor

Initializes a new instance of the LogoutRequest class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LogoutRequest()
Public Sub New
public:
LogoutRequest()
new : unit -> LogoutRequest
See Also

Reference

LogoutRequest Class
LogoutRequest Overload
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest Constructor (XmlElement)

Initializes a new instance of the LogoutRequest class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LogoutRequest(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
LogoutRequest(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> LogoutRequest

Parameters

xmlElement
Type: System.XmlXmlElement
The logout request XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

LogoutRequest Class
LogoutRequest Overload
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest Properties

The LogoutRequest type exposes the following members.

Properties
 | Name | Description
Public property | BaseID | Gets or sets the base ID.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | EncryptedID | Gets or sets the encrypted ID.
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | NameID | Gets or sets the name ID.
Public property | NotOnOrAfter | Gets or sets the not on or after time.
Public property | Reason | Gets or sets the reason.
Public property | SessionIndexes | Gets or sets the session indexes.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.BaseID Property

LogoutRequestBaseID Property

Gets or sets the base ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public BaseID BaseID { get; set; }
Public Property BaseID As BaseID
    Get
    Set
public:
property BaseID^ BaseID {
    BaseID^ get ();
    void set (BaseID^ value);
}
member BaseID : BaseID with get, set

Property Value

Type: BaseID
The base ID.
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.EncryptedID Property

LogoutRequestEncryptedID Property

Gets or sets the encrypted ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID EncryptedID { get; set; }
Public Property EncryptedID As EncryptedID
    Get
    Set
public:
property EncryptedID^ EncryptedID {
    EncryptedID^ get ();
    void set (EncryptedID^ value);
}
member EncryptedID : EncryptedID with get, set

Property Value

Type: EncryptedID
The encrypted ID.
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.NameID Property

LogoutRequestNameID Property

Gets or sets the name ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID NameID { get; set; }
Public Property NameID As NameID
    Get
    Set
public:
property NameID^ NameID {
    NameID^ get ();
    void set (NameID^ value);
}
member NameID : NameID with get, set

Property Value

Type: NameID
The name ID.
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.NotOnOrAfter Property

LogoutRequestNotOnOrAfter Property

Gets or sets the not on or after time.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime NotOnOrAfter { get; set; }
Public Property NotOnOrAfter As DateTime
    Get
    Set
public:
property DateTime NotOnOrAfter {
    DateTime get ();
    void set (DateTime value);
}
member NotOnOrAfter : DateTime with get, set

Property Value

Type: DateTime
The not on or after time as coordinated universal time (UTC). A value of DateTime.MaxValue indicates the value has not been set.
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.Reason Property

LogoutRequestReason Property

Gets or sets the reason.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Reason { get; set; }
Public Property Reason As String
    Get
    Set
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}
member Reason : string with get, set

Property Value

Type: String
The reason.
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.SessionIndexes Property

LogoutRequestSessionIndexes Property

Gets or sets the session indexes.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<SessionIndex> SessionIndexes { get; set; }
Public Property SessionIndexes As IList(Of SessionIndex)
    Get
    Set
public:
property IList<SessionIndex^>^ SessionIndexes {
    IList<SessionIndex^>^ get ();
    void set (IList<SessionIndex^>^ value);
}
member SessionIndexes : IList<SessionIndex> with get, set

Property Value

Type: IList SessionIndex
The session indexes.
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest Methods

The LogoutRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a logout request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the logout request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the logout request to XML.
Public method | ToXml(XmlDocument) | Serializes the logout request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.IsValid Method

LogoutRequestIsValid Method

Indicates whether the XML is a logout request.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a logout request; otherwise false.
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.ToString Method

LogoutRequestToString Method

Converts the logout request to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The logout request as a string.
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.ToXml Method

LogoutRequestToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the logout request to XML.
Public method | ToXml(XmlDocument) | Serializes the logout request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

LogoutRequest Class
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.ToXml Method

LogoutRequestToXml Method

Serializes the logout request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The logout request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

LogoutRequest Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


LogoutRequest.ToXml Method (XmlDocument)

LogoutRequestToXml Method (XmlDocument)

Serializes the logout request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The logout request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

LogoutRequest Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


LogoutResponse Class

Represents a logout response.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsStatusResponseType
ComponentSpace.SAML2.ProtocolsLogoutResponse

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class LogoutResponse : StatusResponseType
Public Class LogoutResponse
    Inherits StatusResponseType
public ref class LogoutResponse : public StatusResponseType
type LogoutResponse =
    class
        inherit StatusResponseType
    end

The LogoutResponse type exposes the following members.

Constructors
 | Name | Description
Public method | LogoutResponse | Initializes a new instance of the LogoutResponse class.
Public method | LogoutResponse(XmlElement) | Initializes a new instance of the LogoutResponse class from XML.
Top
Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from StatusResponseType.)
Public property | Destination | Gets or sets the destination. (Inherited from StatusResponseType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from StatusResponseType.)
Public property | ID | Gets or sets the ID. (Inherited from StatusResponseType.)
Public property | InResponseTo | Gets or sets the in response to. (Inherited from StatusResponseType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from StatusResponseType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from StatusResponseType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from StatusResponseType.)
Public property | Status | Gets or sets the status. (Inherited from StatusResponseType.)
Public property | Version | Gets or sets the version. (Inherited from StatusResponseType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSuccess | Indicates whether the status indicates success or not. (Inherited from StatusResponseType.)
 | IsValid | Indicates whether the XML is a logout response.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the logout response to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the logout response to XML.
Public method | ToXml(XmlDocument) | Serializes the logout response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


LogoutResponse Constructor

Overload List
 | Name | Description
Public method | LogoutResponse | Initializes a new instance of the LogoutResponse class.
Public method | LogoutResponse(XmlElement) | Initializes a new instance of the LogoutResponse class from XML.
Top
See Also

Reference

LogoutResponse Class
ComponentSpace.SAML2.Protocols Namespace


LogoutResponse Constructor

Initializes a new instance of the LogoutResponse class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LogoutResponse()
Public Sub New
public:
LogoutResponse()
new : unit -> LogoutResponse
See Also

Reference

LogoutResponse Class
LogoutResponse Overload
ComponentSpace.SAML2.Protocols Namespace


LogoutResponse Constructor (XmlElement)

Initializes a new instance of the LogoutResponse class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public LogoutResponse(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
LogoutResponse(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> LogoutResponse

Parameters

xmlElement
Type: System.XmlXmlElement
The logout response XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

LogoutResponse Class
LogoutResponse Overload
ComponentSpace.SAML2.Protocols Namespace


LogoutResponse Properties

The LogoutResponse type exposes the following members.

Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from StatusResponseType.)
Public property | Destination | Gets or sets the destination. (Inherited from StatusResponseType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from StatusResponseType.)
Public property | ID | Gets or sets the ID. (Inherited from StatusResponseType.)
Public property | InResponseTo | Gets or sets the in response to. (Inherited from StatusResponseType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from StatusResponseType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from StatusResponseType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from StatusResponseType.)
Public property | Status | Gets or sets the status. (Inherited from StatusResponseType.)
Public property | Version | Gets or sets the version. (Inherited from StatusResponseType.)
Top
See Also

Reference

LogoutResponse Class
ComponentSpace.SAML2.Protocols Namespace


LogoutResponse Methods

The LogoutResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSuccess | Indicates whether the status indicates success or not. (Inherited from StatusResponseType.)
 | IsValid | Indicates whether the XML is a logout response.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the logout response to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the logout response to XML.
Public method | ToXml(XmlDocument) | Serializes the logout response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
See Also

Reference

LogoutResponse Class
ComponentSpace.SAML2.Protocols Namespace


LogoutResponse.IsValid Method

LogoutResponseIsValid Method

Indicates whether the XML is a logout response.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a logout response; otherwise false.
See Also

Reference

LogoutResponse Class
ComponentSpace.SAML2.Protocols Namespace


LogoutResponse.ToString Method

LogoutResponseToString Method

Converts the logout response to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The logout response as a string.
See Also

Reference

LogoutResponse Class
ComponentSpace.SAML2.Protocols Namespace


LogoutResponse.ToXml Method

LogoutResponseToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the logout response to XML.
Public method | ToXml(XmlDocument) | Serializes the logout response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
See Also

Reference

LogoutResponse Class
ComponentSpace.SAML2.Protocols Namespace


LogoutResponse.ToXml Method

LogoutResponseToXml Method

Serializes the logout response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The logout response as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

LogoutResponse Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


LogoutResponse.ToXml Method (XmlDocument)

LogoutResponseToXml Method (XmlDocument)

Serializes the logout response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The logout response as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

LogoutResponse Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest Class

Represents a manage name ID request.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsManageNameIDRequest

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class ManageNameIDRequest : RequestAbstractType
Public Class ManageNameIDRequest
    Inherits RequestAbstractType
public ref class ManageNameIDRequest : public RequestAbstractType
type ManageNameIDRequest =
    class
        inherit RequestAbstractType
    end

The ManageNameIDRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ManageNameIDRequest | Initializes a new instance of the ManageNameIDRequest class.
Public method | ManageNameIDRequest(XmlElement) | Initializes a new instance of the ManageNameIDRequest class from XML.
Top
Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | EncryptedID | Gets or sets the encrypted ID.
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | NameID | Gets or sets the name ID.
Public property | NewEncryptedID | Gets or sets the new encrypted ID.
Public property | NewID | Gets or sets the new ID.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Terminate | Gets or sets the terminate.
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a manage name ID request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the manage name ID request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the manage name ID request to XML.
Public method | ToXml(XmlDocument) | Serializes the manage name ID request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest Constructor

Overload List
 | Name | Description
Public method | ManageNameIDRequest | Initializes a new instance of the ManageNameIDRequest class.
Public method | ManageNameIDRequest(XmlElement) | Initializes a new instance of the ManageNameIDRequest class from XML.
Top
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest Constructor

Initializes a new instance of the ManageNameIDRequest class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ManageNameIDRequest()
Public Sub New
public:
ManageNameIDRequest()
new : unit -> ManageNameIDRequest
See Also

Reference

ManageNameIDRequest Class
ManageNameIDRequest Overload
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest Constructor (XmlElement)

Initializes a new instance of the ManageNameIDRequest class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ManageNameIDRequest(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
ManageNameIDRequest(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> ManageNameIDRequest

Parameters

xmlElement
Type: System.XmlXmlElement
The manage name ID request XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

ManageNameIDRequest Class
ManageNameIDRequest Overload
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest Properties

The ManageNameIDRequest type exposes the following members.

Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | EncryptedID | Gets or sets the encrypted ID.
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | NameID | Gets or sets the name ID.
Public property | NewEncryptedID | Gets or sets the new encrypted ID.
Public property | NewID | Gets or sets the new ID.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Terminate | Gets or sets the terminate.
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest.EncryptedID Property

ManageNameIDRequestEncryptedID Property

Gets or sets the encrypted ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID EncryptedID { get; set; }
Public Property EncryptedID As EncryptedID
    Get
    Set
public:
property EncryptedID^ EncryptedID {
    EncryptedID^ get ();
    void set (EncryptedID^ value);
}
member EncryptedID : EncryptedID with get, set

Property Value

Type: EncryptedID
The encrypted ID.
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest.NameID Property

ManageNameIDRequestNameID Property

Gets or sets the name ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID NameID { get; set; }
Public Property NameID As NameID
    Get
    Set
public:
property NameID^ NameID {
    NameID^ get ();
    void set (NameID^ value);
}
member NameID : NameID with get, set

Property Value

Type: NameID
The name ID.
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest.NewEncryptedID Property

ManageNameIDRequestNewEncryptedID Property

Gets or sets the new encrypted ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewEncryptedID NewEncryptedID { get; set; }
Public Property NewEncryptedID As NewEncryptedID
    Get
    Set
public:
property NewEncryptedID^ NewEncryptedID {
    NewEncryptedID^ get ();
    void set (NewEncryptedID^ value);
}
member NewEncryptedID : NewEncryptedID with get, set

Property Value

Type: NewEncryptedID
The new encrypted ID.
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest.NewID Property

ManageNameIDRequestNewID Property

Gets or sets the new ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewID NewID { get; set; }
Public Property NewID As NewID
    Get
    Set
public:
property NewID^ NewID {
    NewID^ get ();
    void set (NewID^ value);
}
member NewID : NewID with get, set

Property Value

Type: NewID
The new ID.
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest.Terminate Property

ManageNameIDRequestTerminate Property

Gets or sets the terminate.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Terminate Terminate { get; set; }
Public Property Terminate As Terminate
    Get
    Set
public:
property Terminate^ Terminate {
    Terminate^ get ();
    void set (Terminate^ value);
}
member Terminate : Terminate with get, set

Property Value

Type: Terminate
The terminate.
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest Methods

The ManageNameIDRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a manage name ID request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the manage name ID request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the manage name ID request to XML.
Public method | ToXml(XmlDocument) | Serializes the manage name ID request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest.IsValid Method

ManageNameIDRequestIsValid Method

Indicates whether the XML is a manage name ID request.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a manage name ID request; otherwise false.
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest.ToString Method

ManageNameIDRequestToString Method

Converts the manage name ID request to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The manage name ID request as a string.
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest.ToXml Method

ManageNameIDRequestToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the manage name ID request to XML.
Public method | ToXml(XmlDocument) | Serializes the manage name ID request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

ManageNameIDRequest Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest.ToXml Method

ManageNameIDRequestToXml Method

Serializes the manage name ID request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The manage name ID request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

ManageNameIDRequest Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDRequest.ToXml Method (XmlDocument)

ManageNameIDRequestToXml Method (XmlDocument)

Serializes the manage name ID request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The manage name ID request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

ManageNameIDRequest Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse Class

Represents a manage name ID response.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsStatusResponseType
ComponentSpace.SAML2.ProtocolsManageNameIDResponse

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class ManageNameIDResponse : StatusResponseType
Public Class ManageNameIDResponse
    Inherits StatusResponseType
public ref class ManageNameIDResponse : public StatusResponseType
type ManageNameIDResponse =
    class
        inherit StatusResponseType
    end

The ManageNameIDResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ManageNameIDResponse | Initializes a new instance of the ManageNameIDResponse class.
Public method | ManageNameIDResponse(XmlElement) | Initializes a new instance of the ManageNameIDResponse class from XML.
Top
Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from StatusResponseType.)
Public property | Destination | Gets or sets the destination. (Inherited from StatusResponseType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from StatusResponseType.)
Public property | ID | Gets or sets the ID. (Inherited from StatusResponseType.)
Public property | InResponseTo | Gets or sets the in response to. (Inherited from StatusResponseType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from StatusResponseType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from StatusResponseType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from StatusResponseType.)
Public property | Status | Gets or sets the status. (Inherited from StatusResponseType.)
Public property | Version | Gets or sets the version. (Inherited from StatusResponseType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSuccess | Indicates whether the status indicates success or not. (Inherited from StatusResponseType.)
 | IsValid | Indicates whether the XML is a manage name ID response.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the manage name ID response to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the manage name ID response to XML.
Public method | ToXml(XmlDocument) | Serializes the manage name ID response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse Constructor

Overload List
 | Name | Description
Public method | ManageNameIDResponse | Initializes a new instance of the ManageNameIDResponse class.
Public method | ManageNameIDResponse(XmlElement) | Initializes a new instance of the ManageNameIDResponse class from XML.
Top
See Also

Reference

ManageNameIDResponse Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse Constructor

Initializes a new instance of the ManageNameIDResponse class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ManageNameIDResponse()
Public Sub New
public:
ManageNameIDResponse()
new : unit -> ManageNameIDResponse
See Also

Reference

ManageNameIDResponse Class
ManageNameIDResponse Overload
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse Constructor (XmlElement)

Initializes a new instance of the ManageNameIDResponse class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public ManageNameIDResponse(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
ManageNameIDResponse(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> ManageNameIDResponse

Parameters

xmlElement
Type: System.XmlXmlElement
The manage name ID response XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

ManageNameIDResponse Class
ManageNameIDResponse Overload
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse Properties

The ManageNameIDResponse type exposes the following members.

Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from StatusResponseType.)
Public property | Destination | Gets or sets the destination. (Inherited from StatusResponseType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from StatusResponseType.)
Public property | ID | Gets or sets the ID. (Inherited from StatusResponseType.)
Public property | InResponseTo | Gets or sets the in response to. (Inherited from StatusResponseType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from StatusResponseType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from StatusResponseType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from StatusResponseType.)
Public property | Status | Gets or sets the status. (Inherited from StatusResponseType.)
Public property | Version | Gets or sets the version. (Inherited from StatusResponseType.)
Top
See Also

Reference

ManageNameIDResponse Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse Methods

The ManageNameIDResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSuccess | Indicates whether the status indicates success or not. (Inherited from StatusResponseType.)
 | IsValid | Indicates whether the XML is a manage name ID response.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the manage name ID response to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the manage name ID response to XML.
Public method | ToXml(XmlDocument) | Serializes the manage name ID response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
See Also

Reference

ManageNameIDResponse Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse.IsValid Method

ManageNameIDResponseIsValid Method

Indicates whether the XML is a manage name ID response.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a manage name ID response; otherwise false.
See Also

Reference

ManageNameIDResponse Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse.ToString Method

ManageNameIDResponseToString Method

Converts the manage name ID response to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The manage name ID response as a string.
See Also

Reference

ManageNameIDResponse Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse.ToXml Method

ManageNameIDResponseToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the manage name ID response to XML.
Public method | ToXml(XmlDocument) | Serializes the manage name ID response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
See Also

Reference

ManageNameIDResponse Class
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse.ToXml Method

ManageNameIDResponseToXml Method

Serializes the manage name ID response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The manage name ID response as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

ManageNameIDResponse Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


ManageNameIDResponse.ToXml Method (XmlDocument)

ManageNameIDResponseToXml Method (XmlDocument)

Serializes the manage name ID response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The manage name ID response as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

ManageNameIDResponse Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest Class

Represents a name ID mapping request.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsNameIDMappingRequest

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class NameIDMappingRequest : RequestAbstractType
Public Class NameIDMappingRequest
    Inherits RequestAbstractType
public ref class NameIDMappingRequest : public RequestAbstractType
type NameIDMappingRequest =
    class
        inherit RequestAbstractType
    end

The NameIDMappingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | NameIDMappingRequest | Initializes a new instance of the NameIDMappingRequest class.
Public method | NameIDMappingRequest(XmlElement) | Initializes a new instance of the NameIDMappingRequest class from XML.
Top
Properties
 | Name | Description
Public property | BaseID | Gets or sets the base ID.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | EncryptedID | Gets or sets the encrypted ID.
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | NameID | Gets or sets the name ID.
Public property | NameIDPolicy | Gets or sets the name ID policy.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an artifact resolve request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the name ID mapping request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the name ID mapping request to XML.
Public method | ToXml(XmlDocument) | Serializes the name ID mapping request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest Constructor

Overload List
 | Name | Description
Public method | NameIDMappingRequest | Initializes a new instance of the NameIDMappingRequest class.
Public method | NameIDMappingRequest(XmlElement) | Initializes a new instance of the NameIDMappingRequest class from XML.
Top
See Also

Reference

NameIDMappingRequest Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest Constructor

Initializes a new instance of the NameIDMappingRequest class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDMappingRequest()
Public Sub New
public:
NameIDMappingRequest()
new : unit -> NameIDMappingRequest
See Also

Reference

NameIDMappingRequest Class
NameIDMappingRequest Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest Constructor (XmlElement)

Initializes a new instance of the NameIDMappingRequest class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDMappingRequest(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
NameIDMappingRequest(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> NameIDMappingRequest

Parameters

xmlElement
Type: System.XmlXmlElement
The name ID mapping request XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

NameIDMappingRequest Class
NameIDMappingRequest Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest Properties

The NameIDMappingRequest type exposes the following members.

Properties
 | Name | Description
Public property | BaseID | Gets or sets the base ID.
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | EncryptedID | Gets or sets the encrypted ID.
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | NameID | Gets or sets the name ID.
Public property | NameIDPolicy | Gets or sets the name ID policy.
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

NameIDMappingRequest Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest.BaseID Property

NameIDMappingRequestBaseID Property

Gets or sets the base ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public BaseID BaseID { get; set; }
Public Property BaseID As BaseID
    Get
    Set
public:
property BaseID^ BaseID {
    BaseID^ get ();
    void set (BaseID^ value);
}
member BaseID : BaseID with get, set

Property Value

Type: BaseID
The base ID.
See Also

Reference

NameIDMappingRequest Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest.EncryptedID Property

NameIDMappingRequestEncryptedID Property

Gets or sets the encrypted ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID EncryptedID { get; set; }
Public Property EncryptedID As EncryptedID
    Get
    Set
public:
property EncryptedID^ EncryptedID {
    EncryptedID^ get ();
    void set (EncryptedID^ value);
}
member EncryptedID : EncryptedID with get, set

Property Value

Type: EncryptedID
The encrypted ID.
See Also

Reference

NameIDMappingRequest Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest.NameID Property

NameIDMappingRequestNameID Property

Gets or sets the name ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID NameID { get; set; }
Public Property NameID As NameID
    Get
    Set
public:
property NameID^ NameID {
    NameID^ get ();
    void set (NameID^ value);
}
member NameID : NameID with get, set

Property Value

Type: NameID
The name ID.
See Also

Reference

NameIDMappingRequest Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest.NameIDPolicy Property

NameIDMappingRequestNameIDPolicy Property

Gets or sets the name ID policy.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDPolicy NameIDPolicy { get; set; }
Public Property NameIDPolicy As NameIDPolicy
    Get
    Set
public:
property NameIDPolicy^ NameIDPolicy {
    NameIDPolicy^ get ();
    void set (NameIDPolicy^ value);
}
member NameIDPolicy : NameIDPolicy with get, set

Property Value

Type: NameIDPolicy
The name ID policy.
See Also

Reference

NameIDMappingRequest Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest Methods

The NameIDMappingRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an artifact resolve request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the name ID mapping request to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the name ID mapping request to XML.
Public method | ToXml(XmlDocument) | Serializes the name ID mapping request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

NameIDMappingRequest Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest.IsValid Method

NameIDMappingRequestIsValid Method

Indicates whether the XML is an artifact resolve request.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is an artifact resolve request; otherwise false.
See Also

Reference

NameIDMappingRequest Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest.ToString Method

NameIDMappingRequestToString Method

Converts the name ID mapping request to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The name ID mapping request as a string.
See Also

Reference

NameIDMappingRequest Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest.ToXml Method

NameIDMappingRequestToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the name ID mapping request to XML.
Public method | ToXml(XmlDocument) | Serializes the name ID mapping request to XML.
Public method | ToXml(XmlElement) | Serializes the request to XML. (Inherited from RequestAbstractType.)
Top
See Also

Reference

NameIDMappingRequest Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest.ToXml Method

NameIDMappingRequestToXml Method

Serializes the name ID mapping request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The name ID mapping request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

NameIDMappingRequest Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingRequest.ToXml Method (XmlDocument)

NameIDMappingRequestToXml Method (XmlDocument)

Serializes the name ID mapping request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The name ID mapping request as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

NameIDMappingRequest Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse Class

Represents a name ID mapping response.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsStatusResponseType
ComponentSpace.SAML2.ProtocolsNameIDMappingResponse

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class NameIDMappingResponse : StatusResponseType
Public Class NameIDMappingResponse
    Inherits StatusResponseType
public ref class NameIDMappingResponse : public StatusResponseType
type NameIDMappingResponse =
    class
        inherit StatusResponseType
    end

The NameIDMappingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | NameIDMappingResponse | Initializes a new instance of the NameIDMappingResponse class.
Public method | NameIDMappingResponse(XmlElement) | Initializes a new instance of the NameIDMappingResponse class from XML.
Top
Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from StatusResponseType.)
Public property | Destination | Gets or sets the destination. (Inherited from StatusResponseType.)
Public property | EncryptedID | Gets or sets the encrypted ID.
Public property | Extensions | Gets or sets the extensions. (Inherited from StatusResponseType.)
Public property | ID | Gets or sets the ID. (Inherited from StatusResponseType.)
Public property | InResponseTo | Gets or sets the in response to. (Inherited from StatusResponseType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from StatusResponseType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from StatusResponseType.)
Public property | NameID | Gets or sets the name ID.
Public property | Signature | Gets or sets the digital signature. (Inherited from StatusResponseType.)
Public property | Status | Gets or sets the status. (Inherited from StatusResponseType.)
Public property | Version | Gets or sets the version. (Inherited from StatusResponseType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSuccess | Indicates whether the status indicates success or not. (Inherited from StatusResponseType.)
 | IsValid | Indicates whether the XML is a name ID mapping response.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the name ID mapping response to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the name ID mapping response to XML.
Public method | ToXml(XmlDocument) | Serializes the name ID mapping response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse Constructor

Overload List
 | Name | Description
Public method | NameIDMappingResponse | Initializes a new instance of the NameIDMappingResponse class.
Public method | NameIDMappingResponse(XmlElement) | Initializes a new instance of the NameIDMappingResponse class from XML.
Top
See Also

Reference

NameIDMappingResponse Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse Constructor

Initializes a new instance of the NameIDMappingResponse class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDMappingResponse()
Public Sub New
public:
NameIDMappingResponse()
new : unit -> NameIDMappingResponse
See Also

Reference

NameIDMappingResponse Class
NameIDMappingResponse Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse Constructor (XmlElement)

Initializes a new instance of the NameIDMappingResponse class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDMappingResponse(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
NameIDMappingResponse(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> NameIDMappingResponse

Parameters

xmlElement
Type: System.XmlXmlElement
The name ID mapping response XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

NameIDMappingResponse Class
NameIDMappingResponse Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse Properties

The NameIDMappingResponse type exposes the following members.

Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from StatusResponseType.)
Public property | Destination | Gets or sets the destination. (Inherited from StatusResponseType.)
Public property | EncryptedID | Gets or sets the encrypted ID.
Public property | Extensions | Gets or sets the extensions. (Inherited from StatusResponseType.)
Public property | ID | Gets or sets the ID. (Inherited from StatusResponseType.)
Public property | InResponseTo | Gets or sets the in response to. (Inherited from StatusResponseType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from StatusResponseType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from StatusResponseType.)
Public property | NameID | Gets or sets the name ID.
Public property | Signature | Gets or sets the digital signature. (Inherited from StatusResponseType.)
Public property | Status | Gets or sets the status. (Inherited from StatusResponseType.)
Public property | Version | Gets or sets the version. (Inherited from StatusResponseType.)
Top
See Also

Reference

NameIDMappingResponse Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse.EncryptedID Property

NameIDMappingResponseEncryptedID Property

Gets or sets the encrypted ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedID EncryptedID { get; set; }
Public Property EncryptedID As EncryptedID
    Get
    Set
public:
property EncryptedID^ EncryptedID {
    EncryptedID^ get ();
    void set (EncryptedID^ value);
}
member EncryptedID : EncryptedID with get, set

Property Value

Type: EncryptedID
The encrypted ID.
See Also

Reference

NameIDMappingResponse Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse.NameID Property

NameIDMappingResponseNameID Property

Gets or sets the name ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameID NameID { get; set; }
Public Property NameID As NameID
    Get
    Set
public:
property NameID^ NameID {
    NameID^ get ();
    void set (NameID^ value);
}
member NameID : NameID with get, set

Property Value

Type: NameID
The name ID.
See Also

Reference

NameIDMappingResponse Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse Methods

The NameIDMappingResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSuccess | Indicates whether the status indicates success or not. (Inherited from StatusResponseType.)
 | IsValid | Indicates whether the XML is a name ID mapping response.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the name ID mapping response to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the name ID mapping response to XML.
Public method | ToXml(XmlDocument) | Serializes the name ID mapping response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
See Also

Reference

NameIDMappingResponse Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse.IsValid Method

NameIDMappingResponseIsValid Method

Indicates whether the XML is a name ID mapping response.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a name ID mapping response; otherwise false.
See Also

Reference

NameIDMappingResponse Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse.ToString Method

NameIDMappingResponseToString Method

Converts the name ID mapping response to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The name ID mapping response as a string.
See Also

Reference

NameIDMappingResponse Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse.ToXml Method

NameIDMappingResponseToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the name ID mapping response to XML.
Public method | ToXml(XmlDocument) | Serializes the name ID mapping response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
See Also

Reference

NameIDMappingResponse Class
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse.ToXml Method

NameIDMappingResponseToXml Method

Serializes the name ID mapping response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The name ID mapping response as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

NameIDMappingResponse Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDMappingResponse.ToXml Method (XmlDocument)

NameIDMappingResponseToXml Method (XmlDocument)

Serializes the name ID mapping response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The name ID mapping response as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

NameIDMappingResponse Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy Class

Represents a name ID policy.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsNameIDPolicy

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class NameIDPolicy
Public Class NameIDPolicy
public ref class NameIDPolicy
type NameIDPolicy =  class end

The NameIDPolicy type exposes the following members.

Constructors
 | Name | Description
Public method | NameIDPolicy | Initializes a new instance of the NameIDPolicy class.
Public method | NameIDPolicy(XmlElement) | Initializes a new instance of the NameIDPolicy class from XML.
Public method | NameIDPolicy(String, String, Boolean) | Initializes a new instance of the NameIDPolicy class.
Top
Properties
 | Name | Description
Public property | AllowCreate | Gets or sets the allow create flag.
Public property | Format | Gets or sets the format.
Public property | SPNameQualifier | Gets or sets the SP name qualifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a name ID policy.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the name ID policy to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy Constructor

Overload List
 | Name | Description
Public method | NameIDPolicy | Initializes a new instance of the NameIDPolicy class.
Public method | NameIDPolicy(XmlElement) | Initializes a new instance of the NameIDPolicy class from XML.
Public method | NameIDPolicy(String, String, Boolean) | Initializes a new instance of the NameIDPolicy class.
Top
See Also

Reference

NameIDPolicy Class
ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy Constructor

Initializes a new instance of the NameIDPolicy class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDPolicy()
Public Sub New
public:
NameIDPolicy()
new : unit -> NameIDPolicy
See Also

Reference

NameIDPolicy Class
NameIDPolicy Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy Constructor (XmlElement)

Initializes a new instance of the NameIDPolicy class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDPolicy(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
NameIDPolicy(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> NameIDPolicy

Parameters

xmlElement
Type: System.XmlXmlElement
The name ID policy XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

NameIDPolicy Class
NameIDPolicy Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy Constructor (String, String, Boolean)

Initializes a new instance of the NameIDPolicy class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NameIDPolicy(
    string format,
    string spNameQualifier,
    bool allowCreate
)
Public Sub New (
    format As String,
    spNameQualifier As String,
    allowCreate As Boolean
)
public:
NameIDPolicy(
    String^ format,
    String^ spNameQualifier,
    bool allowCreate
)
new :
        format : string *
        spNameQualifier : string *
        allowCreate : bool -> NameIDPolicy

Parameters

format
Type: SystemString
The format.
spNameQualifier
Type: SystemString
The SP name qualifier
allowCreate
Type: SystemBoolean
The allow create flag
See Also

Reference

NameIDPolicy Class
NameIDPolicy Overload
ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy Properties

The NameIDPolicy type exposes the following members.

Properties
 | Name | Description
Public property | AllowCreate | Gets or sets the allow create flag.
Public property | Format | Gets or sets the format.
Public property | SPNameQualifier | Gets or sets the SP name qualifier.
Top
See Also

Reference

NameIDPolicy Class
ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy.AllowCreate Property

NameIDPolicyAllowCreate Property

Gets or sets the allow create flag.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool AllowCreate { get; set; }
Public Property AllowCreate As Boolean
    Get
    Set
public:
property bool AllowCreate {
    bool get ();
    void set (bool value);
}
member AllowCreate : bool with get, set

Property Value

Type: Boolean
The allow create flag.
See Also

Reference

NameIDPolicy Class
ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy.Format Property

NameIDPolicyFormat Property

Gets or sets the format.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
member Format : string with get, set

Property Value

Type: String
The format.
See Also

Reference

NameIDPolicy Class
ComponentSpace.SAML2.Protocols Namespace
ComponentSpace.SAML2SAMLIdentifiersNameIdentifierFormats


NameIDPolicy.SPNameQualifier Property

NameIDPolicySPNameQualifier Property

Gets or sets the SP name qualifier.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string SPNameQualifier { get; set; }
Public Property SPNameQualifier As String
    Get
    Set
public:
property String^ SPNameQualifier {
    String^ get ();
    void set (String^ value);
}
member SPNameQualifier : string with get, set

Property Value

Type: String
The SP name qualifier.
See Also

Reference

NameIDPolicy Class
ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy Methods

The NameIDPolicy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a name ID policy.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the name ID policy to XML.
Top
See Also

Reference

NameIDPolicy Class
ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy.IsValid Method

NameIDPolicyIsValid Method

Indicates whether the XML is a name ID policy.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a name ID policy; otherwise false.
See Also

Reference

NameIDPolicy Class
ComponentSpace.SAML2.Protocols Namespace


NameIDPolicy.ToXml Method

NameIDPolicyToXml Method

Serializes the name ID policy to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The name ID policy as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

NameIDPolicy Class
ComponentSpace.SAML2.Protocols Namespace


NewID Class

Represents new ID.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsNewID

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class NewID
Public Class NewID
public ref class NewID
type NewID =  class end

The NewID type exposes the following members.

Constructors
 | Name | Description
Public method | NewID | Initializes a new instance of the NewID class.
Public method | NewID(String) | Initializes a new instance of the NewID class.
Public method | NewID(XmlElement) | Initializes a new instance of the NewID class from XML.
Top
Properties
 | Name | Description
Public property | ID | Gets or sets the ID.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an artifact.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the ID. (Overrides ObjectToString.)
Public method | ToXml | Serializes the new ID to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


NewID Constructor

Overload List
 | Name | Description
Public method | NewID | Initializes a new instance of the NewID class.
Public method | NewID(String) | Initializes a new instance of the NewID class.
Public method | NewID(XmlElement) | Initializes a new instance of the NewID class from XML.
Top
See Also

Reference

NewID Class
ComponentSpace.SAML2.Protocols Namespace


NewID Constructor

Initializes a new instance of the NewID class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewID()
Public Sub New
public:
NewID()
new : unit -> NewID
See Also

Reference

NewID Class
NewID Overload
ComponentSpace.SAML2.Protocols Namespace


NewID Constructor (String)

Initializes a new instance of the NewID class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewID(
    string id
)
Public Sub New (
    id As String
)
public:
NewID(
    String^ id
)
new :
        id : string -> NewID

Parameters

id
Type: SystemString
The ID.
See Also

Reference

NewID Class
NewID Overload
ComponentSpace.SAML2.Protocols Namespace


NewID Constructor (XmlElement)

Initializes a new instance of the NewID class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public NewID(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
NewID(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> NewID

Parameters

xmlElement
Type: System.XmlXmlElement
The new ID XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

NewID Class
NewID Overload
ComponentSpace.SAML2.Protocols Namespace


NewID Properties

The NewID type exposes the following members.

Properties
 | Name | Description
Public property | ID | Gets or sets the ID.
Top
See Also

Reference

NewID Class
ComponentSpace.SAML2.Protocols Namespace


NewID.ID Property

NewIDID Property

Gets or sets the ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
The ID.
See Also

Reference

NewID Class
ComponentSpace.SAML2.Protocols Namespace


NewID Methods

The NewID type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is an artifact.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the ID. (Overrides ObjectToString.)
Public method | ToXml | Serializes the new ID to XML.
Top
See Also

Reference

NewID Class
ComponentSpace.SAML2.Protocols Namespace


NewID.IsValid Method

NewIDIsValid Method

Indicates whether the XML is an artifact.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a new ID; otherwise false.
See Also

Reference

NewID Class
ComponentSpace.SAML2.Protocols Namespace


NewID.ToString Method

NewIDToString Method

Returns the ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The ID
See Also

Reference

NewID Class
ComponentSpace.SAML2.Protocols Namespace


NewID.ToXml Method

NewIDToXml Method

Serializes the new ID to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The new ID as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

NewID Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType Class

Represents the request abstract type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
More...

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class RequestAbstractType
Public MustInherit Class RequestAbstractType
public ref class RequestAbstractType abstract
[<AbstractClassAttribute>]
type RequestAbstractType =  class end

The RequestAbstractType type exposes the following members.

Constructors
 | Name | Description
Public method | RequestAbstractType | Initializes a new instance of the RequestAbstractType class.
Public method | RequestAbstractType(XmlElement) | Initializes a new instance of the RequestAbstractType class from XML.
Top
Properties
 | Name | Description
Public property | Consent | Gets or sets the consent.
Public property | Destination | Gets or sets the destination.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | IssueInstant | Gets or sets the issue instant.
Public property | Issuer | Gets or sets the issuer.
Public property | Signature | Gets or sets the digital signature.
Public property | Version | Gets or sets the version.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIssuer | Gets the issuer.
 | GetIssuerName | Gets the issuer name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the request to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsArtifactResolve
ComponentSpace.SAML2.ProtocolsAssertionIDRequest
ComponentSpace.SAML2.ProtocolsAuthnRequest
ComponentSpace.SAML2.ProtocolsLogoutRequest
ComponentSpace.SAML2.ProtocolsManageNameIDRequest
ComponentSpace.SAML2.ProtocolsNameIDMappingRequest
ComponentSpace.SAML2.ProtocolsSubjectQueryAbstractType


RequestAbstractType Constructor

Overload List
 | Name | Description
Public method | RequestAbstractType | Initializes a new instance of the RequestAbstractType class.
Public method | RequestAbstractType(XmlElement) | Initializes a new instance of the RequestAbstractType class from XML.
Top
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType Constructor

Initializes a new instance of the RequestAbstractType class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequestAbstractType()
Public Sub New
public:
RequestAbstractType()
new : unit -> RequestAbstractType
Remarks
The request is initialized with a version number of 2.0, a random identifier, and the issue instant of now.
See Also

Reference

RequestAbstractType Class
RequestAbstractType Overload
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType Constructor (XmlElement)

Initializes a new instance of the RequestAbstractType class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequestAbstractType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
RequestAbstractType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> RequestAbstractType

Parameters

xmlElement
Type: System.XmlXmlElement
The request XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

RequestAbstractType Class
RequestAbstractType Overload
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType Properties

The RequestAbstractType type exposes the following members.

Properties
 | Name | Description
Public property | Consent | Gets or sets the consent.
Public property | Destination | Gets or sets the destination.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | IssueInstant | Gets or sets the issue instant.
Public property | Issuer | Gets or sets the issuer.
Public property | Signature | Gets or sets the digital signature.
Public property | Version | Gets or sets the version.
Top
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType.Consent Property

RequestAbstractTypeConsent Property

Gets or sets the consent.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Consent { get; set; }
Public Property Consent As String
    Get
    Set
public:
property String^ Consent {
    String^ get ();
    void set (String^ value);
}
member Consent : string with get, set

Property Value

Type: String
The consent.
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace
ComponentSpace.SAML2SAMLIdentifiersConsentIdentifiers


RequestAbstractType.Destination Property

RequestAbstractTypeDestination Property

Gets or sets the destination.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Destination { get; set; }
Public Property Destination As String
    Get
    Set
public:
property String^ Destination {
    String^ get ();
    void set (String^ value);
}
member Destination : string with get, set

Property Value

Type: String
The destination.
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType.Extensions Property

RequestAbstractTypeExtensions Property

Gets or sets the extensions.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions Extensions { get; set; }
Public Property Extensions As Extensions
    Get
    Set
public:
property Extensions^ Extensions {
    Extensions^ get ();
    void set (Extensions^ value);
}
member Extensions : Extensions with get, set

Property Value

Type: Extensions
The extensions.
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType.ID Property

RequestAbstractTypeID Property

Gets or sets the ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
The ID.
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType.IssueInstant Property

RequestAbstractTypeIssueInstant Property

Gets or sets the issue instant.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime IssueInstant { get; set; }
Public Property IssueInstant As DateTime
    Get
    Set
public:
property DateTime IssueInstant {
    DateTime get ();
    void set (DateTime value);
}
member IssueInstant : DateTime with get, set

Property Value

Type: DateTime
The issue instant as coordinated universal time (UTC).
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType.Issuer Property

RequestAbstractTypeIssuer Property

Gets or sets the issuer.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Issuer Issuer { get; set; }
Public Property Issuer As Issuer
    Get
    Set
public:
property Issuer^ Issuer {
    Issuer^ get ();
    void set (Issuer^ value);
}
member Issuer : Issuer with get, set

Property Value

Type: Issuer
The issuer.
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType.Signature Property

RequestAbstractTypeSignature Property

Gets or sets the digital signature.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement Signature { get; set; }
Public Property Signature As XmlElement
    Get
    Set
public:
property XmlElement^ Signature {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member Signature : XmlElement with get, set

Property Value

Type: XmlElement
The digital signature.
Remarks
To generate or verify signatures, use SAMLMessageSignature.
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace
ComponentSpace.SAML2.ProtocolsSAMLMessageSignature


RequestAbstractType.Version Property

RequestAbstractTypeVersion Property

Gets or sets the version.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
The version. The default is 2.0.
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType Methods

The RequestAbstractType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIssuer | Gets the issuer.
 | GetIssuerName | Gets the issuer name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the request to XML.
Top
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType.GetIssuer Method

RequestAbstractTypeGetIssuer Method

Gets the issuer.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static Issuer GetIssuer(
    XmlElement xmlElement
)
Public Shared Function GetIssuer (
    xmlElement As XmlElement
) As Issuer
public:
static Issuer^ GetIssuer(
    XmlElement^ xmlElement
)
static member GetIssuer :
        xmlElement : XmlElement -> Issuer

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element containing the issuer as an offspring element.

Return Value

Type: Issuer
The issuer or null if none.
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType.GetIssuerName Method

RequestAbstractTypeGetIssuerName Method

Gets the issuer name.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetIssuerName(
    XmlElement xmlElement
)
Public Shared Function GetIssuerName (
    xmlElement As XmlElement
) As String
public:
static String^ GetIssuerName(
    XmlElement^ xmlElement
)
static member GetIssuerName :
        xmlElement : XmlElement -> string

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element containing the issuer as an offspring element.

Return Value

Type: String
The issuer name or null if none.
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestAbstractType.ToXml Method

RequestAbstractTypeToXml Method

Serializes the request to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public virtual void ToXml(
    XmlElement xmlElement
)
Public Overridable Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
)
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

RequestAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


RequestedAuthnContext Class

Represents a requested authentication context.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestedAuthnContext

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class RequestedAuthnContext
Public Class RequestedAuthnContext
public ref class RequestedAuthnContext
type RequestedAuthnContext =  class end

The RequestedAuthnContext type exposes the following members.

Constructors
 | Name | Description
Public method | RequestedAuthnContext | Initializes a new instance of the RequestedAuthnContext class.
Public method | RequestedAuthnContext(XmlElement) | Initializes a new instance of the RequestedAuthnContext class from XML.
Top
Properties
 | Name | Description
Public property | AuthenticationContexts | Gets or sets the authentication contexts.
Public property | Comparison | Gets or sets the authentication context comparison.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a requested authentication context.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the requested authentication context to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


RequestedAuthnContext Constructor

Overload List
 | Name | Description
Public method | RequestedAuthnContext | Initializes a new instance of the RequestedAuthnContext class.
Public method | RequestedAuthnContext(XmlElement) | Initializes a new instance of the RequestedAuthnContext class from XML.
Top
See Also

Reference

RequestedAuthnContext Class
ComponentSpace.SAML2.Protocols Namespace


RequestedAuthnContext Constructor

Initializes a new instance of the RequestedAuthnContext class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequestedAuthnContext()
Public Sub New
public:
RequestedAuthnContext()
new : unit -> RequestedAuthnContext
See Also

Reference

RequestedAuthnContext Class
RequestedAuthnContext Overload
ComponentSpace.SAML2.Protocols Namespace


RequestedAuthnContext Constructor (XmlElement)

Initializes a new instance of the RequestedAuthnContext class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequestedAuthnContext(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
RequestedAuthnContext(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> RequestedAuthnContext

Parameters

xmlElement
Type: System.XmlXmlElement
The requested authentication context XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

RequestedAuthnContext Class
RequestedAuthnContext Overload
ComponentSpace.SAML2.Protocols Namespace


RequestedAuthnContext Properties

The RequestedAuthnContext type exposes the following members.

Properties
 | Name | Description
Public property | AuthenticationContexts | Gets or sets the authentication contexts.
Public property | Comparison | Gets or sets the authentication context comparison.
Top
See Also

Reference

RequestedAuthnContext Class
ComponentSpace.SAML2.Protocols Namespace


RequestedAuthnContext.AuthenticationContexts Property

RequestedAuthnContextAuthenticationContexts Property

Gets or sets the authentication contexts.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList AuthenticationContexts { get; set; }
Public Property AuthenticationContexts As IList
    Get
    Set
public:
property IList^ AuthenticationContexts {
    IList^ get ();
    void set (IList^ value);
}
member AuthenticationContexts : IList with get, set

Property Value

Type: IList
The authentication contexts.
See Also

Reference

RequestedAuthnContext Class
ComponentSpace.SAML2.Protocols Namespace
ComponentSpace.SAML2.AssertionsAuthnContextClassRef
ComponentSpace.SAML2.AssertionsAuthnContextDeclRef


RequestedAuthnContext.Comparison Property

RequestedAuthnContextComparison Property

Gets or sets the authentication context comparison.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Comparison { get; set; }
Public Property Comparison As String
    Get
    Set
public:
property String^ Comparison {
    String^ get ();
    void set (String^ value);
}
member Comparison : string with get, set

Property Value

Type: String
The authentication context comparison.
See Also

Reference

RequestedAuthnContext Class
ComponentSpace.SAML2.Protocols Namespace
ComponentSpace.SAML2SAMLIdentifiersAuthnContextComparison


RequestedAuthnContext Methods

The RequestedAuthnContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a requested authentication context.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the requested authentication context to XML.
Top
See Also

Reference

RequestedAuthnContext Class
ComponentSpace.SAML2.Protocols Namespace


RequestedAuthnContext.IsValid Method

RequestedAuthnContextIsValid Method

Indicates whether the XML is a requested authentication context.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a requested authentication context; otherwise false.
See Also

Reference

RequestedAuthnContext Class
ComponentSpace.SAML2.Protocols Namespace


RequestedAuthnContext.ToXml Method

RequestedAuthnContextToXml Method

Serializes the requested authentication context to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The requested authentication context as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

RequestedAuthnContext Class
ComponentSpace.SAML2.Protocols Namespace


RequesterID Class

Represents a requester ID.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequesterID

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class RequesterID
Public Class RequesterID
public ref class RequesterID
type RequesterID =  class end

The RequesterID type exposes the following members.

Constructors
 | Name | Description
Public method | RequesterID | Initializes a new instance of the RequesterID class.
Public method | RequesterID(String) | Initializes a new instance of the RequesterID class.
Public method | RequesterID(XmlElement) | Initializes a new instance of the RequesterID class from XML.
Top
Properties
 | Name | Description
Public property | ID | Gets or sets the ID.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a requester ID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the requester ID. (Overrides ObjectToString.)
Public method | ToXml | Serializes the requester ID to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


RequesterID Constructor

Overload List
 | Name | Description
Public method | RequesterID | Initializes a new instance of the RequesterID class.
Public method | RequesterID(String) | Initializes a new instance of the RequesterID class.
Public method | RequesterID(XmlElement) | Initializes a new instance of the RequesterID class from XML.
Top
See Also

Reference

RequesterID Class
ComponentSpace.SAML2.Protocols Namespace


RequesterID Constructor

Initializes a new instance of the RequesterID class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequesterID()
Public Sub New
public:
RequesterID()
new : unit -> RequesterID
See Also

Reference

RequesterID Class
RequesterID Overload
ComponentSpace.SAML2.Protocols Namespace


RequesterID Constructor (String)

Initializes a new instance of the RequesterID class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequesterID(
    string id
)
Public Sub New (
    id As String
)
public:
RequesterID(
    String^ id
)
new :
        id : string -> RequesterID

Parameters

id
Type: SystemString
The requester ID.
See Also

Reference

RequesterID Class
RequesterID Overload
ComponentSpace.SAML2.Protocols Namespace


RequesterID Constructor (XmlElement)

Initializes a new instance of the RequesterID class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RequesterID(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
RequesterID(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> RequesterID

Parameters

xmlElement
Type: System.XmlXmlElement
The requester ID XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

RequesterID Class
RequesterID Overload
ComponentSpace.SAML2.Protocols Namespace


RequesterID Properties

The RequesterID type exposes the following members.

Properties
 | Name | Description
Public property | ID | Gets or sets the ID.
Top
See Also

Reference

RequesterID Class
ComponentSpace.SAML2.Protocols Namespace


RequesterID.ID Property

RequesterIDID Property

Gets or sets the ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
The ID.
See Also

Reference

RequesterID Class
ComponentSpace.SAML2.Protocols Namespace


RequesterID Methods

The RequesterID type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a requester ID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the requester ID. (Overrides ObjectToString.)
Public method | ToXml | Serializes the requester ID to XML.
Top
See Also

Reference

RequesterID Class
ComponentSpace.SAML2.Protocols Namespace


RequesterID.IsValid Method

RequesterIDIsValid Method

Indicates whether the XML is a requester ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a requester ID; otherwise false.
See Also

Reference

RequesterID Class
ComponentSpace.SAML2.Protocols Namespace


RequesterID.ToString Method

RequesterIDToString Method

Returns the requester ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The requester ID
See Also

Reference

RequesterID Class
ComponentSpace.SAML2.Protocols Namespace


RequesterID.ToXml Method

RequesterIDToXml Method

Serializes the requester ID to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The requester ID as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

RequesterID Class
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature Class

Permits XML signature generation and verification for SAML protocol request and response messages.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsSAMLMessageSignature

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAMLMessageSignature
Public NotInheritable Class SAMLMessageSignature
public ref class SAMLMessageSignature abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAMLMessageSignature =  class end

The SAMLMessageSignature type exposes the following members.

Methods
Name | Description
Generate(XmlElement, AsymmetricAlgorithm) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String) | Generates an XML signature and adds it to the SAML message.
GetCertificate | Gets the X.509 certificate embedded in the XML signature or null if none.
GetKeyInfo | Gets the key info embedded in the XML signature or null if none.
IsSigned | Indicates whether the SAML message contains an XML signature.
RemoveSignature | Removes the XML signature, if any, from the SAML message.
Verify(XmlElement) | Verifies the XML signature.
Verify(XmlElement, AsymmetricAlgorithm) | Verifies the XML signature.
Verify(XmlElement, X509Certificate2) | Verifies the XML signature.
Verify(XmlElement, KeyInfo) | Verifies the XML signature.
Verify(XmlElement, KeyInfoX509Data) | Verifies the XML signature.
Top
Fields
Name | Description
DefaultInclusiveNamespacesPrefixList | The default inclusive namespace prefix list.
Top
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature Methods

The SAMLMessageSignature type exposes the following members.

Methods
Name | Description
Generate(XmlElement, AsymmetricAlgorithm) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String) | Generates an XML signature and adds it to the SAML message.
GetCertificate | Gets the X.509 certificate embedded in the XML signature or null if none.
GetKeyInfo | Gets the key info embedded in the XML signature or null if none.
IsSigned | Indicates whether the SAML message contains an XML signature.
RemoveSignature | Removes the XML signature, if any, from the SAML message.
Verify(XmlElement) | Verifies the XML signature.
Verify(XmlElement, AsymmetricAlgorithm) | Verifies the XML signature.
Verify(XmlElement, X509Certificate2) | Verifies the XML signature.
Verify(XmlElement, KeyInfo) | Verifies the XML signature.
Verify(XmlElement, KeyInfoX509Data) | Verifies the XML signature.
Top
See Also

Reference

SAMLMessageSignature Class
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method

SAMLMessageSignatureGenerate Method

Overload List
Name | Description
Generate(XmlElement, AsymmetricAlgorithm) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String) | Generates an XML signature and adds it to the SAML message.
Generate(XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String) | Generates an XML signature and adds it to the SAML message.
Top
See Also

Reference

SAMLMessageSignature Class
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method (XmlElement, AsymmetricAlgorithm)

SAMLMessageSignatureGenerate Method (XmlElement, AsymmetricAlgorithm)

Generates an XML signature and adds it to the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML message. The signature is created using the supplied signing key.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMessageSignature Class
Generate Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2)

SAMLMessageSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2)

Generates an XML signature and adds it to the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2 x509Certificate
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificate As X509Certificate2
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2^ x509Certificate
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificate : X509Certificate2 -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate to include in the key info.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML message. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificate, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMessageSignature Class
Generate Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection)

SAMLMessageSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection)

Generates an XML signature and adds it to the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2Collection x509Certificates
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificates As X509Certificate2Collection
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2Collection^ x509Certificates
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificates : X509Certificate2Collection -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificates
Type: System.Security.Cryptography.X509CertificatesX509Certificate2Collection
The list of X.509 certificate to include in the key info.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML message. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificates, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMessageSignature Class
Generate Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfo)

SAMLMessageSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfo)

Generates an XML signature and adds it to the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfo keyInfo
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfo As KeyInfo
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfo^ keyInfo
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfo : KeyInfo -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include in the signature.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML message. The signature is created using the supplied signing key. The key info will be included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMessageSignature Class
Generate Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data)

SAMLMessageSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data)

Generates an XML signature and adds it to the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfoX509Data keyInfoX509Data
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfoX509Data As KeyInfoX509Data
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfoX509Data^ keyInfoX509Data
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfoX509Data : KeyInfoX509Data -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfoX509Data
Type: System.Security.Cryptography.XmlKeyInfoX509Data
The X.509 data to include in the signature.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML message. The signature is created using the supplied signing key. Key info, using the supplied X.509 data, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMessageSignature Class
Generate Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method (XmlElement, AsymmetricAlgorithm, String, String, String)

SAMLMessageSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, String, String, String)

Generates an XML signature and adds it to the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default samlp saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML message. The signature is created using the supplied signing key.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMessageSignature Class
Generate Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String)

SAMLMessageSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2, String, String, String)

Generates an XML signature and adds it to the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2 x509Certificate,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificate As X509Certificate2,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2^ x509Certificate,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificate : X509Certificate2 *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate to include in the key info.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default samlp saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML message. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificate, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMessageSignature Class
Generate Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String)

SAMLMessageSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, X509Certificate2Collection, String, String, String)

Generates an XML signature and adds it to the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    X509Certificate2Collection x509Certificates,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    x509Certificates As X509Certificate2Collection,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    X509Certificate2Collection^ x509Certificates,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        x509Certificates : X509Certificate2Collection *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
x509Certificates
Type: System.Security.Cryptography.X509CertificatesX509Certificate2Collection
The list of X.509 certificate to include in the key info.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default samlp saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML message. The signature is created using the supplied signing key. Key info, using the supplied X.509 certificates, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMessageSignature Class
Generate Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String)

SAMLMessageSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfo, String, String, String)

Generates an XML signature and adds it to the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfo keyInfo,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfo As KeyInfo,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfo^ keyInfo,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfo : KeyInfo *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info to include in the signature.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default samlp saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML message. The signature is created using the supplied signing key. The key info will be included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMessageSignature Class
Generate Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Generate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String)

SAMLMessageSignatureGenerate Method (XmlElement, AsymmetricAlgorithm, KeyInfoX509Data, String, String, String)

Generates an XML signature and adds it to the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void Generate(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey,
    KeyInfoX509Data keyInfoX509Data,
    string inclusiveNamespacesPrefixList,
    string digestMethod,
    string signatureMethod
)
Public Shared Sub Generate (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm,
    keyInfoX509Data As KeyInfoX509Data,
    inclusiveNamespacesPrefixList As String,
    digestMethod As String,
    signatureMethod As String
)
public:
static void Generate(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey,
    KeyInfoX509Data^ keyInfoX509Data,
    String^ inclusiveNamespacesPrefixList,
    String^ digestMethod,
    String^ signatureMethod
)
static member Generate :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm *
        keyInfoX509Data : KeyInfoX509Data *
        inclusiveNamespacesPrefixList : string *
        digestMethod : string *
        signatureMethod : string -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message to sign.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The signing key.
keyInfoX509Data
Type: System.Security.Cryptography.XmlKeyInfoX509Data
The X.509 data to include in the signature.
inclusiveNamespacesPrefixList
Type: SystemString
The inclusive namespace prefix list or null to default to #default samlp saml ds xs xsi.
digestMethod
Type: SystemString
The digest method or null to default to http://www.w3.org/2001/04/xmlenc#sha256.
signatureMethod
Type: SystemString
The signature method or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature generation fails.
Remarks
An XML signature with the constraints specified in the SAML specification is generated and added to the SAML message. The signature is created using the supplied signing key. Key info, using the supplied X.509 data, is included in the signature.

The generated signature is added to the supplied XML element.

See Also

Reference

SAMLMessageSignature Class
Generate Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.GetCertificate Method

SAMLMessageSignatureGetCertificate Method

Gets the X.509 certificate embedded in the XML signature or null if none.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static X509Certificate2 GetCertificate(
    XmlElement xmlElement
)
Public Shared Function GetCertificate (
    xmlElement As XmlElement
) As X509Certificate2
public:
static X509Certificate2^ GetCertificate(
    XmlElement^ xmlElement
)
static member GetCertificate :
        xmlElement : XmlElement -> X509Certificate2

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message containing the signature with X.509 certificate.

Return Value

Type: X509Certificate2
The X.509 certificate embedded in the XML signature or null if none.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the X.509 certificate retrieval fails.
See Also

Reference

SAMLMessageSignature Class
ComponentSpace.SAML2.Protocols Namespace
SAMLMessageSignatureGetKeyInfo(XmlElement)


SAMLMessageSignature.GetKeyInfo Method

SAMLMessageSignatureGetKeyInfo Method

Gets the key info embedded in the XML signature or null if none.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static KeyInfo GetKeyInfo(
    XmlElement xmlElement
)
Public Shared Function GetKeyInfo (
    xmlElement As XmlElement
) As KeyInfo
public:
static KeyInfo^ GetKeyInfo(
    XmlElement^ xmlElement
)
static member GetKeyInfo :
        xmlElement : XmlElement -> KeyInfo

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message containing the signature with key info.

Return Value

Type: KeyInfo
The key info embedded in the XML signature or null if none.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the key info retrieval fails.
See Also

Reference

SAMLMessageSignature Class
ComponentSpace.SAML2.Protocols Namespace
SAMLMessageSignatureGetCertificate(XmlElement)


SAMLMessageSignature.IsSigned Method

SAMLMessageSignatureIsSigned Method

Indicates whether the SAML message contains an XML signature.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSigned(
    XmlElement xmlElement
)
Public Shared Function IsSigned (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsSigned(
    XmlElement^ xmlElement
)
static member IsSigned :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message.

Return Value

Type: Boolean
true if the XML contains an XML signature; otherwise false.
See Also

Reference

SAMLMessageSignature Class
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.RemoveSignature Method

SAMLMessageSignatureRemoveSignature Method

Removes the XML signature, if any, from the SAML message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void RemoveSignature(
    XmlElement xmlElement
)
Public Shared Sub RemoveSignature (
    xmlElement As XmlElement
)
public:
static void RemoveSignature(
    XmlElement^ xmlElement
)
static member RemoveSignature :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message.
See Also

Reference

SAMLMessageSignature Class
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Verify Method

SAMLMessageSignatureVerify Method

Overload List
Name | Description
Verify(XmlElement) | Verifies the XML signature.
Verify(XmlElement, AsymmetricAlgorithm) | Verifies the XML signature.
Verify(XmlElement, X509Certificate2) | Verifies the XML signature.
Verify(XmlElement, KeyInfo) | Verifies the XML signature.
Verify(XmlElement, KeyInfoX509Data) | Verifies the XML signature.
Top
See Also

Reference

SAMLMessageSignature Class
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Verify Method (XmlElement)

SAMLMessageSignatureVerify Method (XmlElement)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement
)
Public Shared Function Verify (
    xmlElement As XmlElement
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement
)
static member Verify :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message containing the signature to verify.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The key info included with the signature is used to perform the verification.
See Also

Reference

SAMLMessageSignature Class
Verify Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Verify Method (XmlElement, AsymmetricAlgorithm)

SAMLMessageSignatureVerify Method (XmlElement, AsymmetricAlgorithm)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    AsymmetricAlgorithm signingKey
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    signingKey As AsymmetricAlgorithm
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    AsymmetricAlgorithm^ signingKey
)
static member Verify :
        xmlElement : XmlElement *
        signingKey : AsymmetricAlgorithm -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message containing the signature to verify.
signingKey
Type: System.Security.CryptographyAsymmetricAlgorithm
The public key used to perform the verification or null if none.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied public key is used to perform the verification.
See Also

Reference

SAMLMessageSignature Class
Verify Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Verify Method (XmlElement, X509Certificate2)

SAMLMessageSignatureVerify Method (XmlElement, X509Certificate2)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    X509Certificate2 x509Certificate
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    x509Certificate As X509Certificate2
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    X509Certificate2^ x509Certificate
)
static member Verify :
        xmlElement : XmlElement *
        x509Certificate : X509Certificate2 -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message containing the signature to verify.
x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used to perform the verification.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied X.509 certificate is used to perform the verification.
See Also

Reference

SAMLMessageSignature Class
Verify Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Verify Method (XmlElement, KeyInfo)

SAMLMessageSignatureVerify Method (XmlElement, KeyInfo)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    KeyInfo keyInfo
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    keyInfo As KeyInfo
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    KeyInfo^ keyInfo
)
static member Verify :
        xmlElement : XmlElement *
        keyInfo : KeyInfo -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message containing the signature to verify.
keyInfo
Type: System.Security.Cryptography.XmlKeyInfo
The key info used to perform the verification or null if none.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied key info is used to perform the verification.
See Also

Reference

SAMLMessageSignature Class
Verify Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.Verify Method (XmlElement, KeyInfoX509Data)

SAMLMessageSignatureVerify Method (XmlElement, KeyInfoX509Data)

Verifies the XML signature.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool Verify(
    XmlElement xmlElement,
    KeyInfoX509Data keyInfoX509Data
)
Public Shared Function Verify (
    xmlElement As XmlElement,
    keyInfoX509Data As KeyInfoX509Data
) As Boolean
public:
static bool Verify(
    XmlElement^ xmlElement,
    KeyInfoX509Data^ keyInfoX509Data
)
static member Verify :
        xmlElement : XmlElement *
        keyInfoX509Data : KeyInfoX509Data -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message containing the signature to verify.
keyInfoX509Data
Type: System.Security.Cryptography.XmlKeyInfoX509Data
The X.509 data used to perform the verification or null if none.

Return Value

Type: Boolean
true if the XML signature is correct; otherwise false.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
Remarks
The supplied X.509 data is used to perform the verification.
See Also

Reference

SAMLMessageSignature Class
Verify Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature Fields

The SAMLMessageSignature type exposes the following members.

Fields
Name | Description
DefaultInclusiveNamespacesPrefixList | The default inclusive namespace prefix list.
Top
See Also

Reference

SAMLMessageSignature Class
ComponentSpace.SAML2.Protocols Namespace


SAMLMessageSignature.DefaultInclusiveNamespacesPrefixList Field

SAMLMessageSignatureDefaultInclusiveNamespacesPrefixList Field

The default inclusive namespace prefix list.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string DefaultInclusiveNamespacesPrefixList = "#default samlp saml ds xs xsi"
Public Const DefaultInclusiveNamespacesPrefixList As String = "#default samlp saml ds xs xsi"
public:
literal String^ DefaultInclusiveNamespacesPrefixList = "#default samlp saml ds xs xsi"
static val mutable DefaultInclusiveNamespacesPrefixList: string

Field Value

Type: String
See Also

Reference

SAMLMessageSignature Class
ComponentSpace.SAML2.Protocols Namespace


SAMLResponse Class

Represents a SAML response.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsStatusResponseType
ComponentSpace.SAML2.ProtocolsSAMLResponse

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SAMLResponse : StatusResponseType
Public Class SAMLResponse
    Inherits StatusResponseType
public ref class SAMLResponse : public StatusResponseType
type SAMLResponse =
    class
        inherit StatusResponseType
    end

The SAMLResponse type exposes the following members.

Constructors
 | Name | Description
Public method | SAMLResponse | Initializes a new instance of the SAMLResponse class.
Public method | SAMLResponse(XmlElement) | Initializes a new instance of the SAMLResponse class from XML.
Top
Properties
 | Name | Description
Public property | Assertions | Gets or sets the assertions. This includes all unsigned, signed and encrypted assertions. The list may contain unencrypted and unsigned SAML assertions as SAMLAssertion objects, signed SAML assertions as XmlElement objects, and encrypted SAML assertions as EncryptedAssertion objects. To get just the unencrypted, unsigned assertions use GetUnsignedAssertions. To get just the signed assertions use GetSignedAssertions. To get just the encrypted assertions use GetEncryptedAssertions.
Public property | Consent | Gets or sets the consent. (Inherited from StatusResponseType.)
Public property | Destination | Gets or sets the destination. (Inherited from StatusResponseType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from StatusResponseType.)
Public property | ID | Gets or sets the ID. (Inherited from StatusResponseType.)
Public property | InResponseTo | Gets or sets the in response to. (Inherited from StatusResponseType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from StatusResponseType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from StatusResponseType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from StatusResponseType.)
Public property | Status | Gets or sets the status. (Inherited from StatusResponseType.)
Public property | Version | Gets or sets the version. (Inherited from StatusResponseType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEncryptedAssertion | Returns the encrypted SAML assertion. It's assumed the SAML response contains a single encrypted SAML assertion. To get the unencrypted, unsigned assertion use GetUnsignedAssertion. To get the signed assertion use GetSignedAssertion.
Public method | GetEncryptedAssertions | Returns all encrypted assertions. To get the unencrypted, unsigned assertions use GetUnsignedAssertions. To get the signed assertions use GetSignedAssertions.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSignedAssertion | Returns the SAML assertion. It's assumed the SAML response contains a single signed SAML assertion. To get the unencrypted, unsigned assertion use GetUnsignedAssertion. To get the encrypted assertion use GetEncryptedAssertion.
Public method | GetSignedAssertions | Returns all signed assertions. To get the unencrypted, unsigned assertions use GetUnsignedAssertions. To get the encrypted assertions use GetEncryptedAssertions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnsignedAssertion | Returns the SAML assertion. It's assumed the SAML response contains a single unencrypted, unsigned SAML assertion. To get the signed assertion use GetSignedAssertion. To get the encrypted assertion use GetEncryptedAssertion.
Public method | GetUnsignedAssertions | Returns all unencrypted, unsigned assertions. To get the signed assertions use GetSignedAssertions. To get the encrypted assertions use GetEncryptedAssertions.
Public method | IsSuccess | Indicates whether the status indicates success or not. (Inherited from StatusResponseType.)
 | IsValid | Indicates whether the XML is a SAML response.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the SAML response to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the SAML response to XML.
Public method | ToXml(XmlDocument) | Serializes the SAML response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


SAMLResponse Constructor

Overload List
 | Name | Description
Public method | SAMLResponse | Initializes a new instance of the SAMLResponse class.
Public method | SAMLResponse(XmlElement) | Initializes a new instance of the SAMLResponse class from XML.
Top
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace


SAMLResponse Constructor

Initializes a new instance of the SAMLResponse class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLResponse()
Public Sub New
public:
SAMLResponse()
new : unit -> SAMLResponse
See Also

Reference

SAMLResponse Class
SAMLResponse Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLResponse Constructor (XmlElement)

Initializes a new instance of the SAMLResponse class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLResponse(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SAMLResponse(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SAMLResponse

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML response XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SAMLResponse Class
SAMLResponse Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLResponse Properties

The SAMLResponse type exposes the following members.

Properties
 | Name | Description
Public property | Assertions | Gets or sets the assertions. This includes all unsigned, signed and encrypted assertions. The list may contain unencrypted and unsigned SAML assertions as SAMLAssertion objects, signed SAML assertions as XmlElement objects, and encrypted SAML assertions as EncryptedAssertion objects. To get just the unencrypted, unsigned assertions use GetUnsignedAssertions. To get just the signed assertions use GetSignedAssertions. To get just the encrypted assertions use GetEncryptedAssertions.
Public property | Consent | Gets or sets the consent. (Inherited from StatusResponseType.)
Public property | Destination | Gets or sets the destination. (Inherited from StatusResponseType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from StatusResponseType.)
Public property | ID | Gets or sets the ID. (Inherited from StatusResponseType.)
Public property | InResponseTo | Gets or sets the in response to. (Inherited from StatusResponseType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from StatusResponseType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from StatusResponseType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from StatusResponseType.)
Public property | Status | Gets or sets the status. (Inherited from StatusResponseType.)
Public property | Version | Gets or sets the version. (Inherited from StatusResponseType.)
Top
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace


SAMLResponse.Assertions Property

SAMLResponseAssertions Property

Gets or sets the assertions.

This includes all unsigned, signed and encrypted assertions.

The list may contain unencrypted and unsigned SAML assertions as SAMLAssertion objects, signed SAML assertions as XmlElement objects, and encrypted SAML assertions as EncryptedAssertion objects.

To get just the unencrypted, unsigned assertions use GetUnsignedAssertions. To get just the signed assertions use GetSignedAssertions. To get just the encrypted assertions use GetEncryptedAssertions.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList Assertions { get; set; }
Public Property Assertions As IList
    Get
    Set
public:
property IList^ Assertions {
    IList^ get ();
    void set (IList^ value);
}
member Assertions : IList with get, set

Property Value

Type: IList
The assertions.
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace
ComponentSpace.SAML2.AssertionsSAMLAssertion
ComponentSpace.SAML2.AssertionsEncryptedAssertion
SAMLResponseGetUnsignedAssertion
SAMLResponseGetUnsignedAssertions
SAMLResponseGetSignedAssertion(X509Certificate2)
SAMLResponseGetSignedAssertions
SAMLResponseGetEncryptedAssertions


SAMLResponse Methods

The SAMLResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEncryptedAssertion | Returns the encrypted SAML assertion. It's assumed the SAML response contains a single encrypted SAML assertion. To get the unencrypted, unsigned assertion use GetUnsignedAssertion. To get the signed assertion use GetSignedAssertion.
Public method | GetEncryptedAssertions | Returns all encrypted assertions. To get the unencrypted, unsigned assertions use GetUnsignedAssertions. To get the signed assertions use GetSignedAssertions.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSignedAssertion | Returns the SAML assertion. It's assumed the SAML response contains a single signed SAML assertion. To get the unencrypted, unsigned assertion use GetUnsignedAssertion. To get the encrypted assertion use GetEncryptedAssertion.
Public method | GetSignedAssertions | Returns all signed assertions. To get the unencrypted, unsigned assertions use GetUnsignedAssertions. To get the encrypted assertions use GetEncryptedAssertions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnsignedAssertion | Returns the SAML assertion. It's assumed the SAML response contains a single unencrypted, unsigned SAML assertion. To get the signed assertion use GetSignedAssertion. To get the encrypted assertion use GetEncryptedAssertion.
Public method | GetUnsignedAssertions | Returns all unencrypted, unsigned assertions. To get the signed assertions use GetSignedAssertions. To get the encrypted assertions use GetEncryptedAssertions.
Public method | IsSuccess | Indicates whether the status indicates success or not. (Inherited from StatusResponseType.)
 | IsValid | Indicates whether the XML is a SAML response.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the SAML response to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the SAML response to XML.
Public method | ToXml(XmlDocument) | Serializes the SAML response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace


SAMLResponse.GetEncryptedAssertion Method

SAMLResponseGetEncryptedAssertion Method

Returns the encrypted SAML assertion.

It's assumed the SAML response contains a single encrypted SAML assertion.

To get the unencrypted, unsigned assertion use GetUnsignedAssertion. To get the signed assertion use GetSignedAssertion.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public EncryptedAssertion GetEncryptedAssertion()
Public Function GetEncryptedAssertion As EncryptedAssertion
public:
EncryptedAssertion^ GetEncryptedAssertion()
member GetEncryptedAssertion : unit -> EncryptedAssertion

Return Value

Type: EncryptedAssertion
The encrypted assertion or null if none.
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace
SAMLResponseAssertions
SAMLResponseGetUnsignedAssertion
SAMLResponseGetSignedAssertion(X509Certificate2)
SAMLResponseGetSignedAssertions
SAMLResponseGetEncryptedAssertions
ComponentSpace.SAML2.AssertionsEncryptedAssertion


SAMLResponse.GetEncryptedAssertions Method

SAMLResponseGetEncryptedAssertions Method

Returns all encrypted assertions.

To get the unencrypted, unsigned assertions use GetUnsignedAssertions. To get the signed assertions use GetSignedAssertions.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<EncryptedAssertion> GetEncryptedAssertions()
Public Function GetEncryptedAssertions As IList(Of EncryptedAssertion)
public:
IList<EncryptedAssertion^>^ GetEncryptedAssertions()
member GetEncryptedAssertions : unit -> IList<EncryptedAssertion>

Return Value

Type: IList EncryptedAssertion
The encrypted assertions.
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace
SAMLResponseAssertions
SAMLResponseGetUnsignedAssertion
SAMLResponseGetUnsignedAssertions
SAMLResponseGetSignedAssertion(X509Certificate2)
SAMLResponseGetSignedAssertions
SAMLResponseGetEncryptedAssertion
ComponentSpace.SAML2.AssertionsEncryptedAssertion


SAMLResponse.GetSignedAssertion Method

SAMLResponseGetSignedAssertion Method

Returns the SAML assertion.

It's assumed the SAML response contains a single signed SAML assertion.

To get the unencrypted, unsigned assertion use GetUnsignedAssertion. To get the encrypted assertion use GetEncryptedAssertion.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion GetSignedAssertion(
    X509Certificate2 x509Certificate
)
Public Function GetSignedAssertion (
    x509Certificate As X509Certificate2
) As SAMLAssertion
public:
SAMLAssertion^ GetSignedAssertion(
    X509Certificate2^ x509Certificate
)
member GetSignedAssertion :
        x509Certificate : X509Certificate2 -> SAMLAssertion

Parameters

x509Certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The X.509 certificate used to verify the XML signature.

Return Value

Type: SAMLAssertion
The SAML assertion or null if none.
Exceptions
Exception | Condition
SAMLSignatureException | Thrown when the signature verification fails.
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace
SAMLResponseAssertions
SAMLResponseGetUnsignedAssertion
SAMLResponseGetSignedAssertions
SAMLResponseGetEncryptedAssertion
SAMLResponseGetEncryptedAssertions
ComponentSpace.SAML2.AssertionsSAMLAssertion


SAMLResponse.GetSignedAssertions Method

SAMLResponseGetSignedAssertions Method

Returns all signed assertions.

To get the unencrypted, unsigned assertions use GetUnsignedAssertions. To get the encrypted assertions use GetEncryptedAssertions.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<XmlElement> GetSignedAssertions()
Public Function GetSignedAssertions As IList(Of XmlElement)
public:
IList<XmlElement^>^ GetSignedAssertions()
member GetSignedAssertions : unit -> IList<XmlElement>

Return Value

Type: IList XmlElement
The signed assertions.
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace
SAMLResponseAssertions
SAMLResponseGetUnsignedAssertion
SAMLResponseGetUnsignedAssertions
SAMLResponseGetSignedAssertion(X509Certificate2)
SAMLResponseGetEncryptedAssertion
SAMLResponseGetEncryptedAssertions


SAMLResponse.GetUnsignedAssertion Method

SAMLResponseGetUnsignedAssertion Method

Returns the SAML assertion.

It's assumed the SAML response contains a single unencrypted, unsigned SAML assertion.

To get the signed assertion use GetSignedAssertion. To get the encrypted assertion use GetEncryptedAssertion.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLAssertion GetUnsignedAssertion()
Public Function GetUnsignedAssertion As SAMLAssertion
public:
SAMLAssertion^ GetUnsignedAssertion()
member GetUnsignedAssertion : unit -> SAMLAssertion

Return Value

Type: SAMLAssertion
The SAML assertion or null if none.
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace
SAMLResponseAssertions
SAMLResponseGetSignedAssertion(X509Certificate2)
SAMLResponseGetSignedAssertions
SAMLResponseGetEncryptedAssertion
SAMLResponseGetEncryptedAssertions
ComponentSpace.SAML2.AssertionsSAMLAssertion


SAMLResponse.GetUnsignedAssertions Method

SAMLResponseGetUnsignedAssertions Method

Returns all unencrypted, unsigned assertions.

To get the signed assertions use GetSignedAssertions. To get the encrypted assertions use GetEncryptedAssertions.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<SAMLAssertion> GetUnsignedAssertions()
Public Function GetUnsignedAssertions As IList(Of SAMLAssertion)
public:
IList<SAMLAssertion^>^ GetUnsignedAssertions()
member GetUnsignedAssertions : unit -> IList<SAMLAssertion>

Return Value

Type: IList SAMLAssertion
The assertions.
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace
SAMLResponseAssertions
SAMLResponseGetUnsignedAssertion
SAMLResponseGetSignedAssertion(X509Certificate2)
SAMLResponseGetSignedAssertions
SAMLResponseGetEncryptedAssertion
SAMLResponseGetEncryptedAssertions
ComponentSpace.SAML2.AssertionsSAMLAssertion


SAMLResponse.IsValid Method

SAMLResponseIsValid Method

Indicates whether the XML is a SAML response.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a SAML response; otherwise false.
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace


SAMLResponse.ToString Method

SAMLResponseToString Method

Converts the SAML response to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The SAML response as a string.
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace


SAMLResponse.ToXml Method

SAMLResponseToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the SAML response to XML.
Public method | ToXml(XmlDocument) | Serializes the SAML response to XML.
Public method | ToXml(XmlElement) | Serializes the status response to XML. (Inherited from StatusResponseType.)
Top
See Also

Reference

SAMLResponse Class
ComponentSpace.SAML2.Protocols Namespace


SAMLResponse.ToXml Method

SAMLResponseToXml Method

Serializes the SAML response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The SAML response as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

SAMLResponse Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


SAMLResponse.ToXml Method (XmlDocument)

SAMLResponseToXml Method (XmlDocument)

Serializes the SAML response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The SAML response as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SAMLResponse Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


Scoping Class

Represents a scoping.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsScoping

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Scoping
Public Class Scoping
public ref class Scoping
type Scoping =  class end

The Scoping type exposes the following members.

Constructors
 | Name | Description
Public method | Scoping | Initializes a new instance of the Scoping class.
Public method | Scoping(XmlElement) | Initializes a new instance of the Scoping class from XML.
Top
Properties
 | Name | Description
Public property | IDPList | Gets or sets the IDP list.
Public property | ProxyCount | Gets or sets the proxy count.
Public property | RequesterIDs | Gets or sets the requester IDs.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a scoping.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the scoping to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


Scoping Constructor

Overload List
 | Name | Description
Public method | Scoping | Initializes a new instance of the Scoping class.
Public method | Scoping(XmlElement) | Initializes a new instance of the Scoping class from XML.
Top
See Also

Reference

Scoping Class
ComponentSpace.SAML2.Protocols Namespace


Scoping Constructor

Initializes a new instance of the Scoping class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Scoping()
Public Sub New
public:
Scoping()
new : unit -> Scoping
See Also

Reference

Scoping Class
Scoping Overload
ComponentSpace.SAML2.Protocols Namespace


Scoping Constructor (XmlElement)

Initializes a new instance of the Scoping class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Scoping(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Scoping(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Scoping

Parameters

xmlElement
Type: System.XmlXmlElement
The scoping XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Scoping Class
Scoping Overload
ComponentSpace.SAML2.Protocols Namespace


Scoping Properties

The Scoping type exposes the following members.

Properties
 | Name | Description
Public property | IDPList | Gets or sets the IDP list.
Public property | ProxyCount | Gets or sets the proxy count.
Public property | RequesterIDs | Gets or sets the requester IDs.
Top
See Also

Reference

Scoping Class
ComponentSpace.SAML2.Protocols Namespace


Scoping.IDPList Property

ScopingIDPList Property

Gets or sets the IDP list.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IDPList IDPList { get; set; }
Public Property IDPList As IDPList
    Get
    Set
public:
property IDPList^ IDPList {
    IDPList^ get ();
    void set (IDPList^ value);
}
member IDPList : IDPList with get, set

Property Value

Type: IDPList
The IDP list.
See Also

Reference

Scoping Class
ComponentSpace.SAML2.Protocols Namespace


Scoping.ProxyCount Property

ScopingProxyCount Property

Gets or sets the proxy count.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public int ProxyCount { get; set; }
Public Property ProxyCount As Integer
    Get
    Set
public:
property int ProxyCount {
    int get ();
    void set (int value);
}
member ProxyCount : int with get, set

Property Value

Type: Int32
The proxy count.
See Also

Reference

Scoping Class
ComponentSpace.SAML2.Protocols Namespace


Scoping.RequesterIDs Property

ScopingRequesterIDs Property

Gets or sets the requester IDs.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<RequesterID> RequesterIDs { get; set; }
Public Property RequesterIDs As IList(Of RequesterID)
    Get
    Set
public:
property IList<RequesterID^>^ RequesterIDs {
    IList<RequesterID^>^ get ();
    void set (IList<RequesterID^>^ value);
}
member RequesterIDs : IList<RequesterID> with get, set

Property Value

Type: IList RequesterID
The requester IDs.
See Also

Reference

Scoping Class
ComponentSpace.SAML2.Protocols Namespace


Scoping Methods

The Scoping type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a scoping.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the scoping to XML.
Top
See Also

Reference

Scoping Class
ComponentSpace.SAML2.Protocols Namespace


Scoping.IsValid Method

ScopingIsValid Method

Indicates whether the XML is a scoping.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is scoping; otherwise false.
See Also

Reference

Scoping Class
ComponentSpace.SAML2.Protocols Namespace


Scoping.ToXml Method

ScopingToXml Method

Serializes the scoping to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The scoping as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Scoping Class
ComponentSpace.SAML2.Protocols Namespace


SessionIndex Class

Represents a session index.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsSessionIndex

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SessionIndex
Public Class SessionIndex
public ref class SessionIndex
type SessionIndex =  class end

The SessionIndex type exposes the following members.

Constructors
 | Name | Description
Public method | SessionIndex | Initializes a new instance of the SessionIndex class.
Public method | SessionIndex(String) | Initializes a new instance of the SessionIndex class.
Public method | SessionIndex(XmlElement) | Initializes a new instance of the SessionIndex class from XML.
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the session index.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a session index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the session index. (Overrides ObjectToString.)
Public method | ToXml | Serializes the session index to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


SessionIndex Constructor

Overload List
 | Name | Description
Public method | SessionIndex | Initializes a new instance of the SessionIndex class.
Public method | SessionIndex(String) | Initializes a new instance of the SessionIndex class.
Public method | SessionIndex(XmlElement) | Initializes a new instance of the SessionIndex class from XML.
Top
See Also

Reference

SessionIndex Class
ComponentSpace.SAML2.Protocols Namespace


SessionIndex Constructor

Initializes a new instance of the SessionIndex class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SessionIndex()
Public Sub New
public:
SessionIndex()
new : unit -> SessionIndex
See Also

Reference

SessionIndex Class
SessionIndex Overload
ComponentSpace.SAML2.Protocols Namespace


SessionIndex Constructor (String)

Initializes a new instance of the SessionIndex class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SessionIndex(
    string index
)
Public Sub New (
    index As String
)
public:
SessionIndex(
    String^ index
)
new :
        index : string -> SessionIndex

Parameters

index
Type: SystemString
The session index.
See Also

Reference

SessionIndex Class
SessionIndex Overload
ComponentSpace.SAML2.Protocols Namespace


SessionIndex Constructor (XmlElement)

Initializes a new instance of the SessionIndex class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SessionIndex(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SessionIndex(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SessionIndex

Parameters

xmlElement
Type: System.XmlXmlElement
The session index XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SessionIndex Class
SessionIndex Overload
ComponentSpace.SAML2.Protocols Namespace


SessionIndex Properties

The SessionIndex type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the session index.
Top
See Also

Reference

SessionIndex Class
ComponentSpace.SAML2.Protocols Namespace


SessionIndex.Index Property

SessionIndexIndex Property

Gets or sets the session index.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Index { get; set; }
Public Property Index As String
    Get
    Set
public:
property String^ Index {
    String^ get ();
    void set (String^ value);
}
member Index : string with get, set

Property Value

Type: String
The session index.
See Also

Reference

SessionIndex Class
ComponentSpace.SAML2.Protocols Namespace


SessionIndex Methods

The SessionIndex type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a session index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the session index. (Overrides ObjectToString.)
Public method | ToXml | Serializes the session index to XML.
Top
See Also

Reference

SessionIndex Class
ComponentSpace.SAML2.Protocols Namespace


SessionIndex.IsValid Method

SessionIndexIsValid Method

Indicates whether the XML is a session index.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a session index; otherwise false.
See Also

Reference

SessionIndex Class
ComponentSpace.SAML2.Protocols Namespace


SessionIndex.ToString Method

SessionIndexToString Method

Returns the session index.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The session index
See Also

Reference

SessionIndex Class
ComponentSpace.SAML2.Protocols Namespace


SessionIndex.ToXml Method

SessionIndexToXml Method

Serializes the session index to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The session index as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SessionIndex Class
ComponentSpace.SAML2.Protocols Namespace


Status Class

Represents a status.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsStatus

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Status
Public Class Status
public ref class Status
type Status =  class end

The Status type exposes the following members.

Constructors
 | Name | Description
Public method | Status | Initializes a new instance of the Status class.
Public method | Status(XmlElement) | Initializes a new instance of the Status class from XML.
Public method | Status(String, String) | Initializes a new instance of the Status class.
Public method | Status(String, String, String) | Initializes a new instance of the Status class.
Top
Properties
 | Name | Description
Public property | StatusCode | Gets or sets the status code.
Public property | StatusDetail | Gets or sets the status detail.
Public property | StatusMessage | Gets or sets the status message.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a status.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the status. (Overrides ObjectToString.)
Public method | ToXml | Serializes the status to XML.
Public method | ToXml(XmlDocument) | Serializes the status to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


Status Constructor

Overload List
 | Name | Description
Public method | Status | Initializes a new instance of the Status class.
Public method | Status(XmlElement) | Initializes a new instance of the Status class from XML.
Public method | Status(String, String) | Initializes a new instance of the Status class.
Public method | Status(String, String, String) | Initializes a new instance of the Status class.
Top
See Also

Reference

Status Class
ComponentSpace.SAML2.Protocols Namespace


Status Constructor

Initializes a new instance of the Status class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Status()
Public Sub New
public:
Status()
new : unit -> Status
See Also

Reference

Status Class
Status Overload
ComponentSpace.SAML2.Protocols Namespace


Status Constructor (XmlElement)

Initializes a new instance of the Status class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Status(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Status(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Status

Parameters

xmlElement
Type: System.XmlXmlElement
The status XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Status Class
Status Overload
ComponentSpace.SAML2.Protocols Namespace


Status Constructor (String, String)

Initializes a new instance of the Status class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Status(
    string statusCode,
    string statusMessage
)
Public Sub New (
    statusCode As String,
    statusMessage As String
)
public:
Status(
    String^ statusCode,
    String^ statusMessage
)
new :
        statusCode : string *
        statusMessage : string -> Status

Parameters

statusCode
Type: SystemString
The status code.
statusMessage
Type: SystemString
The status message or null if none.
See Also

Reference

Status Class
Status Overload
ComponentSpace.SAML2.Protocols Namespace


Status Constructor (String, String, String)

Initializes a new instance of the Status class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Status(
    string statusCode,
    string subordinateStatusCode,
    string statusMessage
)
Public Sub New (
    statusCode As String,
    subordinateStatusCode As String,
    statusMessage As String
)
public:
Status(
    String^ statusCode,
    String^ subordinateStatusCode,
    String^ statusMessage
)
new :
        statusCode : string *
        subordinateStatusCode : string *
        statusMessage : string -> Status

Parameters

statusCode
Type: SystemString
The status code.
subordinateStatusCode
Type: SystemString
The subordinate status code or null if none.
statusMessage
Type: SystemString
The status message or null if none.
See Also

Reference

Status Class
Status Overload
ComponentSpace.SAML2.Protocols Namespace


Status Properties

The Status type exposes the following members.

Properties
 | Name | Description
Public property | StatusCode | Gets or sets the status code.
Public property | StatusDetail | Gets or sets the status detail.
Public property | StatusMessage | Gets or sets the status message.
Top
See Also

Reference

Status Class
ComponentSpace.SAML2.Protocols Namespace


Status.StatusCode Property

StatusStatusCode Property

Gets or sets the status code.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusCode StatusCode { get; set; }
Public Property StatusCode As StatusCode
    Get
    Set
public:
property StatusCode^ StatusCode {
    StatusCode^ get ();
    void set (StatusCode^ value);
}
member StatusCode : StatusCode with get, set

Property Value

Type: StatusCode
The status code.
See Also

Reference

Status Class
ComponentSpace.SAML2.Protocols Namespace


Status.StatusDetail Property

StatusStatusDetail Property

Gets or sets the status detail.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusDetail StatusDetail { get; set; }
Public Property StatusDetail As StatusDetail
    Get
    Set
public:
property StatusDetail^ StatusDetail {
    StatusDetail^ get ();
    void set (StatusDetail^ value);
}
member StatusDetail : StatusDetail with get, set

Property Value

Type: StatusDetail
The status detail.
See Also

Reference

Status Class
ComponentSpace.SAML2.Protocols Namespace


Status.StatusMessage Property

StatusStatusMessage Property

Gets or sets the status message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusMessage StatusMessage { get; set; }
Public Property StatusMessage As StatusMessage
    Get
    Set
public:
property StatusMessage^ StatusMessage {
    StatusMessage^ get ();
    void set (StatusMessage^ value);
}
member StatusMessage : StatusMessage with get, set

Property Value

Type: StatusMessage
The status message.
See Also

Reference

Status Class
ComponentSpace.SAML2.Protocols Namespace


Status Methods

The Status type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a status.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the status. (Overrides ObjectToString.)
Public method | ToXml | Serializes the status to XML.
Public method | ToXml(XmlDocument) | Serializes the status to XML.
Top
See Also

Reference

Status Class
ComponentSpace.SAML2.Protocols Namespace


Status.IsValid Method

StatusIsValid Method

Indicates whether the XML is a status.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is status; otherwise false.
See Also

Reference

Status Class
ComponentSpace.SAML2.Protocols Namespace


Status.ToString Method

StatusToString Method

Returns the status.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The status
See Also

Reference

Status Class
ComponentSpace.SAML2.Protocols Namespace


Status.ToXml Method

StatusToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the status to XML.
Public method | ToXml(XmlDocument) | Serializes the status to XML.
Top
See Also

Reference

Status Class
ComponentSpace.SAML2.Protocols Namespace


Status.ToXml Method

StatusToXml Method

Serializes the status to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The status as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Status Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


Status.ToXml Method (XmlDocument)

StatusToXml Method (XmlDocument)

Serializes the status to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The status as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Status Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


StatusCode Class

Represents a status code.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsStatusCode

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class StatusCode
Public Class StatusCode
public ref class StatusCode
type StatusCode =  class end

The StatusCode type exposes the following members.

Constructors
 | Name | Description
Public method | StatusCode | Initializes a new instance of the StatusCode class.
Public method | StatusCode(String) | Initializes a new instance of the StatusCode class.
Public method | StatusCode(XmlElement) | Initializes a new instance of the StatusCode class from XML.
Top
Properties
 | Name | Description
Public property | Code | Gets or sets the status code.
Public property | SubordinateStatusCode | Gets or sets the subordinate status code.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a status code.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the status code. (Overrides ObjectToString.)
Public method | ToXml | Serializes the status code to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


StatusCode Constructor

Overload List
 | Name | Description
Public method | StatusCode | Initializes a new instance of the StatusCode class.
Public method | StatusCode(String) | Initializes a new instance of the StatusCode class.
Public method | StatusCode(XmlElement) | Initializes a new instance of the StatusCode class from XML.
Top
See Also

Reference

StatusCode Class
ComponentSpace.SAML2.Protocols Namespace


StatusCode Constructor

Initializes a new instance of the StatusCode class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusCode()
Public Sub New
public:
StatusCode()
new : unit -> StatusCode
See Also

Reference

StatusCode Class
StatusCode Overload
ComponentSpace.SAML2.Protocols Namespace


StatusCode Constructor (String)

Initializes a new instance of the StatusCode class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusCode(
    string code
)
Public Sub New (
    code As String
)
public:
StatusCode(
    String^ code
)
new :
        code : string -> StatusCode

Parameters

code
Type: SystemString
The status code.
See Also

Reference

StatusCode Class
StatusCode Overload
ComponentSpace.SAML2.Protocols Namespace
ComponentSpace.SAML2SAMLIdentifiersPrimaryStatusCodes
ComponentSpace.SAML2SAMLIdentifiersSecondaryStatusCodes


StatusCode Constructor (XmlElement)

Initializes a new instance of the StatusCode class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusCode(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
StatusCode(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> StatusCode

Parameters

xmlElement
Type: System.XmlXmlElement
The status code XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

StatusCode Class
StatusCode Overload
ComponentSpace.SAML2.Protocols Namespace


StatusCode Properties

The StatusCode type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets or sets the status code.
Public property | SubordinateStatusCode | Gets or sets the subordinate status code.
Top
See Also

Reference

StatusCode Class
ComponentSpace.SAML2.Protocols Namespace


StatusCode.Code Property

StatusCodeCode Property

Gets or sets the status code.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set

Property Value

Type: String
The status code.
See Also

Reference

StatusCode Class
ComponentSpace.SAML2.Protocols Namespace
ComponentSpace.SAML2SAMLIdentifiersPrimaryStatusCodes
ComponentSpace.SAML2SAMLIdentifiersSecondaryStatusCodes


StatusCode.SubordinateStatusCode Property

StatusCodeSubordinateStatusCode Property

Gets or sets the subordinate status code.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusCode SubordinateStatusCode { get; set; }
Public Property SubordinateStatusCode As StatusCode
    Get
    Set
public:
property StatusCode^ SubordinateStatusCode {
    StatusCode^ get ();
    void set (StatusCode^ value);
}
member SubordinateStatusCode : StatusCode with get, set

Property Value

Type: StatusCode
The subordinate status code.
See Also

Reference

StatusCode Class
ComponentSpace.SAML2.Protocols Namespace


StatusCode Methods

The StatusCode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a status code.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the status code. (Overrides ObjectToString.)
Public method | ToXml | Serializes the status code to XML.
Top
See Also

Reference

StatusCode Class
ComponentSpace.SAML2.Protocols Namespace


StatusCode.IsValid Method

StatusCodeIsValid Method

Indicates whether the XML is a status code.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is status code; otherwise false.
See Also

Reference

StatusCode Class
ComponentSpace.SAML2.Protocols Namespace


StatusCode.ToString Method

StatusCodeToString Method

Returns the status code.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The status code
See Also

Reference

StatusCode Class
ComponentSpace.SAML2.Protocols Namespace


StatusCode.ToXml Method

StatusCodeToXml Method

Serializes the status code to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The status code as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

StatusCode Class
ComponentSpace.SAML2.Protocols Namespace


StatusDetail Class

Represents status detail.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsStatusDetail

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class StatusDetail
Public Class StatusDetail
public ref class StatusDetail
type StatusDetail =  class end

The StatusDetail type exposes the following members.

Constructors
 | Name | Description
Public method | StatusDetail | Initializes a new instance of the StatusDetail class.
Public method | StatusDetail(XmlElement) | Initializes a new instance of the StatusDetail class from XML.
Top
Properties
 | Name | Description
Public property | Details | Gets or sets the details.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a status detail.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the status detail to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


StatusDetail Constructor

Overload List
 | Name | Description
Public method | StatusDetail | Initializes a new instance of the StatusDetail class.
Public method | StatusDetail(XmlElement) | Initializes a new instance of the StatusDetail class from XML.
Top
See Also

Reference

StatusDetail Class
ComponentSpace.SAML2.Protocols Namespace


StatusDetail Constructor

Initializes a new instance of the StatusDetail class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusDetail()
Public Sub New
public:
StatusDetail()
new : unit -> StatusDetail
See Also

Reference

StatusDetail Class
StatusDetail Overload
ComponentSpace.SAML2.Protocols Namespace


StatusDetail Constructor (XmlElement)

Initializes a new instance of the StatusDetail class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusDetail(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
StatusDetail(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> StatusDetail

Parameters

xmlElement
Type: System.XmlXmlElement
The status detail XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

StatusDetail Class
StatusDetail Overload
ComponentSpace.SAML2.Protocols Namespace


StatusDetail Properties

The StatusDetail type exposes the following members.

Properties
 | Name | Description
Public property | Details | Gets or sets the details.
Top
See Also

Reference

StatusDetail Class
ComponentSpace.SAML2.Protocols Namespace


StatusDetail.Details Property

StatusDetailDetails Property

Gets or sets the details.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlNodeList Details { get; set; }
Public Property Details As XmlNodeList
    Get
    Set
public:
property XmlNodeList^ Details {
    XmlNodeList^ get ();
    void set (XmlNodeList^ value);
}
member Details : XmlNodeList with get, set

Property Value

Type: XmlNodeList
The details.
See Also

Reference

StatusDetail Class
ComponentSpace.SAML2.Protocols Namespace


StatusDetail Methods

The StatusDetail type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a status detail.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the status detail to XML.
Top
See Also

Reference

StatusDetail Class
ComponentSpace.SAML2.Protocols Namespace


StatusDetail.IsValid Method

StatusDetailIsValid Method

Indicates whether the XML is a status detail.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a status detail; otherwise false.
See Also

Reference

StatusDetail Class
ComponentSpace.SAML2.Protocols Namespace


StatusDetail.ToXml Method

StatusDetailToXml Method

Serializes the status detail to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The status detail as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

StatusDetail Class
ComponentSpace.SAML2.Protocols Namespace


StatusMessage Class

Represents a status message.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsStatusMessage

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class StatusMessage
Public Class StatusMessage
public ref class StatusMessage
type StatusMessage =  class end

The StatusMessage type exposes the following members.

Constructors
 | Name | Description
Public method | StatusMessage | Initializes a new instance of the StatusMessage class.
Public method | StatusMessage(String) | Initializes a new instance of the StatusMessage class.
Public method | StatusMessage(XmlElement) | Initializes a new instance of the StatusMessage class from XML.
Top
Properties
 | Name | Description
Public property | Message | Gets or sets the status message.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a status message.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the status message. (Overrides ObjectToString.)
Public method | ToXml | Serializes the status message to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


StatusMessage Constructor

Overload List
 | Name | Description
Public method | StatusMessage | Initializes a new instance of the StatusMessage class.
Public method | StatusMessage(String) | Initializes a new instance of the StatusMessage class.
Public method | StatusMessage(XmlElement) | Initializes a new instance of the StatusMessage class from XML.
Top
See Also

Reference

StatusMessage Class
ComponentSpace.SAML2.Protocols Namespace


StatusMessage Constructor

Initializes a new instance of the StatusMessage class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusMessage()
Public Sub New
public:
StatusMessage()
new : unit -> StatusMessage
See Also

Reference

StatusMessage Class
StatusMessage Overload
ComponentSpace.SAML2.Protocols Namespace


StatusMessage Constructor (String)

Initializes a new instance of the StatusMessage class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusMessage(
    string message
)
Public Sub New (
    message As String
)
public:
StatusMessage(
    String^ message
)
new :
        message : string -> StatusMessage

Parameters

message
Type: SystemString
The status message.
See Also

Reference

StatusMessage Class
StatusMessage Overload
ComponentSpace.SAML2.Protocols Namespace


StatusMessage Constructor (XmlElement)

Initializes a new instance of the StatusMessage class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusMessage(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
StatusMessage(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> StatusMessage

Parameters

xmlElement
Type: System.XmlXmlElement
The status message XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

StatusMessage Class
StatusMessage Overload
ComponentSpace.SAML2.Protocols Namespace


StatusMessage Properties

The StatusMessage type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets or sets the status message.
Top
See Also

Reference

StatusMessage Class
ComponentSpace.SAML2.Protocols Namespace


StatusMessage.Message Property

StatusMessageMessage Property

Gets or sets the status message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
The status message.
See Also

Reference

StatusMessage Class
ComponentSpace.SAML2.Protocols Namespace


StatusMessage Methods

The StatusMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a status message.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the status message. (Overrides ObjectToString.)
Public method | ToXml | Serializes the status message to XML.
Top
See Also

Reference

StatusMessage Class
ComponentSpace.SAML2.Protocols Namespace


StatusMessage.IsValid Method

StatusMessageIsValid Method

Indicates whether the XML is a status message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a status message; otherwise false.
See Also

Reference

StatusMessage Class
ComponentSpace.SAML2.Protocols Namespace


StatusMessage.ToString Method

StatusMessageToString Method

Returns the status message.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The status message
See Also

Reference

StatusMessage Class
ComponentSpace.SAML2.Protocols Namespace


StatusMessage.ToXml Method

StatusMessageToXml Method

Serializes the status message to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The status message as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

StatusMessage Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType Class

Represents the status response type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsStatusResponseType
ComponentSpace.SAML2.ProtocolsArtifactResponse
ComponentSpace.SAML2.ProtocolsLogoutResponse
ComponentSpace.SAML2.ProtocolsManageNameIDResponse
ComponentSpace.SAML2.ProtocolsNameIDMappingResponse
ComponentSpace.SAML2.ProtocolsSAMLResponse

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class StatusResponseType
Public Class StatusResponseType
public ref class StatusResponseType
type StatusResponseType =  class end

The StatusResponseType type exposes the following members.

Constructors
 | Name | Description
Public method | StatusResponseType | Initializes a new instance of the StatusResponseType class.
Public method | StatusResponseType(XmlElement) | Initializes a new instance of the StatusResponseType class from XML.
Top
Properties
 | Name | Description
Public property | Consent | Gets or sets the consent.
Public property | Destination | Gets or sets the destination.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | InResponseTo | Gets or sets the in response to.
Public property | IssueInstant | Gets or sets the issue instant.
Public property | Issuer | Gets or sets the issuer.
Public property | Signature | Gets or sets the digital signature.
Public property | Status | Gets or sets the status.
Public property | Version | Gets or sets the version.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIssuer | Gets the issuer.
 | GetIssuerName | Gets the issuer name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSuccess | Indicates whether the status indicates success or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the status response to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


StatusResponseType Constructor

Overload List
 | Name | Description
Public method | StatusResponseType | Initializes a new instance of the StatusResponseType class.
Public method | StatusResponseType(XmlElement) | Initializes a new instance of the StatusResponseType class from XML.
Top
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType Constructor

Initializes a new instance of the StatusResponseType class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusResponseType()
Public Sub New
public:
StatusResponseType()
new : unit -> StatusResponseType
Remarks
The status response is initialized with a version number of 2.0, a random identifier, and the issue instant of now.
See Also

Reference

StatusResponseType Class
StatusResponseType Overload
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType Constructor (XmlElement)

Initializes a new instance of the StatusResponseType class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public StatusResponseType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
StatusResponseType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> StatusResponseType

Parameters

xmlElement
Type: System.XmlXmlElement
The response XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

StatusResponseType Class
StatusResponseType Overload
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType Properties

The StatusResponseType type exposes the following members.

Properties
 | Name | Description
Public property | Consent | Gets or sets the consent.
Public property | Destination | Gets or sets the destination.
Public property | Extensions | Gets or sets the extensions.
Public property | ID | Gets or sets the ID.
Public property | InResponseTo | Gets or sets the in response to.
Public property | IssueInstant | Gets or sets the issue instant.
Public property | Issuer | Gets or sets the issuer.
Public property | Signature | Gets or sets the digital signature.
Public property | Status | Gets or sets the status.
Public property | Version | Gets or sets the version.
Top
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.Consent Property

StatusResponseTypeConsent Property

Gets or sets the consent.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Consent { get; set; }
Public Property Consent As String
    Get
    Set
public:
property String^ Consent {
    String^ get ();
    void set (String^ value);
}
member Consent : string with get, set

Property Value

Type: String
The consent.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace
ComponentSpace.SAML2SAMLIdentifiersConsentIdentifiers


StatusResponseType.Destination Property

StatusResponseTypeDestination Property

Gets or sets the destination.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Destination { get; set; }
Public Property Destination As String
    Get
    Set
public:
property String^ Destination {
    String^ get ();
    void set (String^ value);
}
member Destination : string with get, set

Property Value

Type: String
The destination.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.Extensions Property

StatusResponseTypeExtensions Property

Gets or sets the extensions.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Extensions Extensions { get; set; }
Public Property Extensions As Extensions
    Get
    Set
public:
property Extensions^ Extensions {
    Extensions^ get ();
    void set (Extensions^ value);
}
member Extensions : Extensions with get, set

Property Value

Type: Extensions
The extensions.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.ID Property

StatusResponseTypeID Property

Gets or sets the ID.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
The ID.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.InResponseTo Property

StatusResponseTypeInResponseTo Property

Gets or sets the in response to.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string InResponseTo { get; set; }
Public Property InResponseTo As String
    Get
    Set
public:
property String^ InResponseTo {
    String^ get ();
    void set (String^ value);
}
member InResponseTo : string with get, set

Property Value

Type: String
The in response to.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.IssueInstant Property

StatusResponseTypeIssueInstant Property

Gets or sets the issue instant.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public DateTime IssueInstant { get; set; }
Public Property IssueInstant As DateTime
    Get
    Set
public:
property DateTime IssueInstant {
    DateTime get ();
    void set (DateTime value);
}
member IssueInstant : DateTime with get, set

Property Value

Type: DateTime
The issue instant as coordinated universal time (UTC).
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.Issuer Property

StatusResponseTypeIssuer Property

Gets or sets the issuer.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Issuer Issuer { get; set; }
Public Property Issuer As Issuer
    Get
    Set
public:
property Issuer^ Issuer {
    Issuer^ get ();
    void set (Issuer^ value);
}
member Issuer : Issuer with get, set

Property Value

Type: Issuer
The issuer.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.Signature Property

StatusResponseTypeSignature Property

Gets or sets the digital signature.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement Signature { get; set; }
Public Property Signature As XmlElement
    Get
    Set
public:
property XmlElement^ Signature {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
member Signature : XmlElement with get, set

Property Value

Type: XmlElement
The digital signature.
Remarks
To generate or verify signatures, use SAMLMessageSignature.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace
ComponentSpace.SAML2.ProtocolsSAMLMessageSignature


StatusResponseType.Status Property

StatusResponseTypeStatus Property

Gets or sets the status.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Status Status { get; set; }
Public Property Status As Status
    Get
    Set
public:
property Status^ Status {
    Status^ get ();
    void set (Status^ value);
}
member Status : Status with get, set

Property Value

Type: Status
The status.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.Version Property

StatusResponseTypeVersion Property

Gets or sets the version.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
The version. The default is 2.0.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType Methods

The StatusResponseType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIssuer | Gets the issuer.
 | GetIssuerName | Gets the issuer name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSuccess | Indicates whether the status indicates success or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the status response to XML.
Top
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.GetIssuer Method

StatusResponseTypeGetIssuer Method

Gets the issuer.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static Issuer GetIssuer(
    XmlElement xmlElement
)
Public Shared Function GetIssuer (
    xmlElement As XmlElement
) As Issuer
public:
static Issuer^ GetIssuer(
    XmlElement^ xmlElement
)
static member GetIssuer :
        xmlElement : XmlElement -> Issuer

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element containing the issuer as an offspring element.

Return Value

Type: Issuer
The issuer or null if none.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.GetIssuerName Method

StatusResponseTypeGetIssuerName Method

Gets the issuer name.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetIssuerName(
    XmlElement xmlElement
)
Public Shared Function GetIssuerName (
    xmlElement As XmlElement
) As String
public:
static String^ GetIssuerName(
    XmlElement^ xmlElement
)
static member GetIssuerName :
        xmlElement : XmlElement -> string

Parameters

xmlElement
Type: System.XmlXmlElement
The XML element containing the issuer as an offspring element.

Return Value

Type: String
The issuer name or null if none.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.IsSuccess Method

StatusResponseTypeIsSuccess Method

Indicates whether the status indicates success or not.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool IsSuccess()
Public Function IsSuccess As Boolean
public:
bool IsSuccess()
member IsSuccess : unit -> bool

Return Value

Type: Boolean
true if the status indicates success; otherwise false.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


StatusResponseType.ToXml Method

StatusResponseTypeToXml Method

Serializes the status response to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public void ToXml(
    XmlElement xmlElement
)
Public Sub ToXml (
    xmlElement As XmlElement
)
public:
void ToXml(
    XmlElement^ xmlElement
)
member ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

StatusResponseType Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery Class

Represents a subject query.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsSubjectQueryAbstractType
ComponentSpace.SAML2.ProtocolsSubjectQuery

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SubjectQuery : SubjectQueryAbstractType
Public Class SubjectQuery
    Inherits SubjectQueryAbstractType
public ref class SubjectQuery : public SubjectQueryAbstractType
type SubjectQuery =
    class
        inherit SubjectQueryAbstractType
    end

The SubjectQuery type exposes the following members.

Constructors
 | Name | Description
Public method | SubjectQuery | Initializes a new instance of the SubjectQuery class.
Public method | SubjectQuery(XmlElement) | Initializes a new instance of the SubjectQuery class from XML.
Public method | SubjectQuery(Subject) | Initializes a new instance of the SubjectQuery class.
Top
Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject. (Inherited from SubjectQueryAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a subject query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the subject query to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the subject query to XML.
Public method | ToXml(XmlDocument) | Serializes the subject query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


SubjectQuery Constructor

Overload List
 | Name | Description
Public method | SubjectQuery | Initializes a new instance of the SubjectQuery class.
Public method | SubjectQuery(XmlElement) | Initializes a new instance of the SubjectQuery class from XML.
Public method | SubjectQuery(Subject) | Initializes a new instance of the SubjectQuery class.
Top
See Also

Reference

SubjectQuery Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery Constructor

Initializes a new instance of the SubjectQuery class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectQuery()
Public Sub New
public:
SubjectQuery()
new : unit -> SubjectQuery
See Also

Reference

SubjectQuery Class
SubjectQuery Overload
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery Constructor (XmlElement)

Initializes a new instance of the SubjectQuery class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectQuery(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SubjectQuery(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SubjectQuery

Parameters

xmlElement
Type: System.XmlXmlElement
The subject query XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SubjectQuery Class
SubjectQuery Overload
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery Constructor (Subject)

Initializes a new instance of the SubjectQuery class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectQuery(
    Subject subject
)
Public Sub New (
    subject As Subject
)
public:
SubjectQuery(
    Subject^ subject
)
new :
        subject : Subject -> SubjectQuery

Parameters

subject
Type: ComponentSpace.SAML2.AssertionsSubject
The subject.
See Also

Reference

SubjectQuery Class
SubjectQuery Overload
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery Properties

The SubjectQuery type exposes the following members.

Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject. (Inherited from SubjectQueryAbstractType.)
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

SubjectQuery Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery Methods

The SubjectQuery type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a subject query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the subject query to a string. (Overrides ObjectToString.)
Public method | ToXml | Serializes the subject query to XML.
Public method | ToXml(XmlDocument) | Serializes the subject query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
See Also

Reference

SubjectQuery Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery.IsValid Method

SubjectQueryIsValid Method

Indicates whether the XML is a subject query.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a subject query; otherwise false.
See Also

Reference

SubjectQuery Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery.ToString Method

SubjectQueryToString Method

Converts the subject query to a string.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The subject query as a string.
See Also

Reference

SubjectQuery Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery.ToXml Method

SubjectQueryToXml Method

Overload List
 | Name | Description
Public method | ToXml | Serializes the subject query to XML.
Public method | ToXml(XmlDocument) | Serializes the subject query to XML.
Public method | ToXml(XmlElement) | Serializes the subject query to XML. (Inherited from SubjectQueryAbstractType.)
Top
See Also

Reference

SubjectQuery Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery.ToXml Method

SubjectQueryToXml Method

Serializes the subject query to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml()
Public Function ToXml As XmlElement
public:
XmlElement^ ToXml()
member ToXml : unit -> XmlElement

Return Value

Type: XmlElement
The subject query as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
Remarks
An XML document is created.
See Also

Reference

SubjectQuery Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


SubjectQuery.ToXml Method (XmlDocument)

SubjectQueryToXml Method (XmlDocument)

Serializes the subject query to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The subject query as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SubjectQuery Class
ToXml Overload
ComponentSpace.SAML2.Protocols Namespace


SubjectQueryAbstractType Class

Represents the subject query abstract type.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsRequestAbstractType
ComponentSpace.SAML2.ProtocolsSubjectQueryAbstractType
ComponentSpace.SAML2.ProtocolsAttributeQuery
ComponentSpace.SAML2.ProtocolsAuthnQuery
ComponentSpace.SAML2.ProtocolsAuthzDecisionQuery
ComponentSpace.SAML2.ProtocolsSubjectQuery

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public abstract class SubjectQueryAbstractType : RequestAbstractType
Public MustInherit Class SubjectQueryAbstractType
    Inherits RequestAbstractType
public ref class SubjectQueryAbstractType abstract : public RequestAbstractType
[<AbstractClassAttribute>]
type SubjectQueryAbstractType =
    class
        inherit RequestAbstractType
    end

The SubjectQueryAbstractType type exposes the following members.

Constructors
 | Name | Description
Public method | SubjectQueryAbstractType | Initializes a new instance of the SubjectQueryAbstractType class.
Public method | SubjectQueryAbstractType(XmlElement) | Initializes a new instance of the SubjectQueryAbstractType class from XML.
Public method | SubjectQueryAbstractType(Subject) | Initializes a new instance of the SubjectQueryAbstractType class.
Top
Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject.
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the subject query to XML. (Overrides RequestAbstractTypeToXml(XmlElement).)
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


SubjectQueryAbstractType Constructor

Overload List
 | Name | Description
Public method | SubjectQueryAbstractType | Initializes a new instance of the SubjectQueryAbstractType class.
Public method | SubjectQueryAbstractType(XmlElement) | Initializes a new instance of the SubjectQueryAbstractType class from XML.
Public method | SubjectQueryAbstractType(Subject) | Initializes a new instance of the SubjectQueryAbstractType class.
Top
See Also

Reference

SubjectQueryAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQueryAbstractType Constructor

Initializes a new instance of the SubjectQueryAbstractType class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectQueryAbstractType()
Public Sub New
public:
SubjectQueryAbstractType()
new : unit -> SubjectQueryAbstractType
See Also

Reference

SubjectQueryAbstractType Class
SubjectQueryAbstractType Overload
ComponentSpace.SAML2.Protocols Namespace


SubjectQueryAbstractType Constructor (XmlElement)

Initializes a new instance of the SubjectQueryAbstractType class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectQueryAbstractType(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
SubjectQueryAbstractType(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> SubjectQueryAbstractType

Parameters

xmlElement
Type: System.XmlXmlElement
The subject query XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SubjectQueryAbstractType Class
SubjectQueryAbstractType Overload
ComponentSpace.SAML2.Protocols Namespace


SubjectQueryAbstractType Constructor (Subject)

Initializes a new instance of the SubjectQueryAbstractType class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SubjectQueryAbstractType(
    Subject subject
)
Public Sub New (
    subject As Subject
)
public:
SubjectQueryAbstractType(
    Subject^ subject
)
new :
        subject : Subject -> SubjectQueryAbstractType

Parameters

subject
Type: ComponentSpace.SAML2.AssertionsSubject
The subject.
See Also

Reference

SubjectQueryAbstractType Class
SubjectQueryAbstractType Overload
ComponentSpace.SAML2.Protocols Namespace


SubjectQueryAbstractType Properties

The SubjectQueryAbstractType type exposes the following members.

Properties
 | Name | Description
Public property | Consent | Gets or sets the consent. (Inherited from RequestAbstractType.)
Public property | Destination | Gets or sets the destination. (Inherited from RequestAbstractType.)
Public property | Extensions | Gets or sets the extensions. (Inherited from RequestAbstractType.)
Public property | ID | Gets or sets the ID. (Inherited from RequestAbstractType.)
Public property | IssueInstant | Gets or sets the issue instant. (Inherited from RequestAbstractType.)
Public property | Issuer | Gets or sets the issuer. (Inherited from RequestAbstractType.)
Public property | Signature | Gets or sets the digital signature. (Inherited from RequestAbstractType.)
Public property | Subject | Gets or sets the subject.
Public property | Version | Gets or sets the version. (Inherited from RequestAbstractType.)
Top
See Also

Reference

SubjectQueryAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQueryAbstractType.Subject Property

SubjectQueryAbstractTypeSubject Property

Gets or sets the subject.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Subject Subject { get; set; }
Public Property Subject As Subject
    Get
    Set
public:
property Subject^ Subject {
    Subject^ get ();
    void set (Subject^ value);
}
member Subject : Subject with get, set

Property Value

Type: Subject
The subject.
See Also

Reference

SubjectQueryAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQueryAbstractType Methods

The SubjectQueryAbstractType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the subject query to XML. (Overrides RequestAbstractTypeToXml(XmlElement).)
Top
See Also

Reference

SubjectQueryAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


SubjectQueryAbstractType.ToXml Method

SubjectQueryAbstractTypeToXml Method

Serializes the subject query to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    XmlElement xmlElement
)
Public Overrides Sub ToXml (
    xmlElement As XmlElement
)
public:
virtual void ToXml(
    XmlElement^ xmlElement
) override
abstract ToXml :
        xmlElement : XmlElement -> unit
override ToXml :
        xmlElement : XmlElement -> unit

Parameters

xmlElement
Type: System.XmlXmlElement
The owning XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

SubjectQueryAbstractType Class
ComponentSpace.SAML2.Protocols Namespace


Terminate Class

Represents a terminate.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.ProtocolsTerminate

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class Terminate
Public Class Terminate
public ref class Terminate
type Terminate =  class end

The Terminate type exposes the following members.

Constructors
 | Name | Description
Public method | Terminate | Initializes a new instance of the Terminate class.
Public method | Terminate(XmlElement) | Initializes a new instance of the Terminate class from XML.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a terminate.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the terminate to XML.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Protocols Namespace


Terminate Constructor

Overload List
 | Name | Description
Public method | Terminate | Initializes a new instance of the Terminate class.
Public method | Terminate(XmlElement) | Initializes a new instance of the Terminate class from XML.
Top
See Also

Reference

Terminate Class
ComponentSpace.SAML2.Protocols Namespace


Terminate Constructor

Initializes a new instance of the Terminate class.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Terminate()
Public Sub New
public:
Terminate()
new : unit -> Terminate
See Also

Reference

Terminate Class
Terminate Overload
ComponentSpace.SAML2.Protocols Namespace


Terminate Constructor (XmlElement)

Initializes a new instance of the Terminate class from XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public Terminate(
    XmlElement xmlElement
)
Public Sub New (
    xmlElement As XmlElement
)
public:
Terminate(
    XmlElement^ xmlElement
)
new :
        xmlElement : XmlElement -> Terminate

Parameters

xmlElement
Type: System.XmlXmlElement
The terminate XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

Terminate Class
Terminate Overload
ComponentSpace.SAML2.Protocols Namespace


Terminate Methods

The Terminate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Indicates whether the XML is a terminate.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | Serializes the terminate to XML.
Top
See Also

Reference

Terminate Class
ComponentSpace.SAML2.Protocols Namespace


Terminate.IsValid Method

TerminateIsValid Method

Indicates whether the XML is a terminate.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsValid(
    XmlElement xmlElement
)
Public Shared Function IsValid (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsValid(
    XmlElement^ xmlElement
)
static member IsValid :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to test.

Return Value

Type: Boolean
true if the XML is a terminate; otherwise false.
See Also

Reference

Terminate Class
ComponentSpace.SAML2.Protocols Namespace


Terminate.ToXml Method

TerminateToXml Method

Serializes the terminate to XML.

Namespace: ComponentSpace.SAML2.Protocols
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public XmlElement ToXml(
    XmlDocument xmlDocument
)
Public Function ToXml (
    xmlDocument As XmlDocument
) As XmlElement
public:
XmlElement^ ToXml(
    XmlDocument^ xmlDocument
)
member ToXml :
        xmlDocument : XmlDocument -> XmlElement

Parameters

xmlDocument
Type: System.XmlXmlDocument
The owning XML document.

Return Value

Type: XmlElement
The terminate as XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML serialization fails.
See Also

Reference

Terminate Class
ComponentSpace.SAML2.Protocols Namespace


ComponentSpace.SAML2.Schemas Namespace

The ComponentSpace.SAML2.Schemas namespace contains classes for validating XML against the SAML v2.0 XML schemas.
Classes
 | Class | Description
Public class | SAMLValidator | Provides methods for validating SAML assertion, protocol and metadata XML against the SAML, XML signature and XML encryption schemas.


SAMLValidator Class

Provides methods for validating SAML assertion, protocol and metadata XML against the SAML, XML signature and XML encryption schemas.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.SchemasSAMLValidator

Namespace: ComponentSpace.SAML2.Schemas
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SAMLValidator
Public Class SAMLValidator
public ref class SAMLValidator
type SAMLValidator =  class end

The SAMLValidator type exposes the following members.

Constructors
 | Name | Description
Public method | SAMLValidator | Initializes a new instance of the SAMLValidator class
Top
Properties
 | Name | Description
Public property | Errors | Gets the errors associated with the last validation.
Public property | Warnings | Gets the warnings associated with the last validation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(XmlDocument) | Validates the SAML assertion, protocol or metadata XML against the SAML, XML signature and XML encryption schemas.
Public method | Validate(XmlElement) | Validates the SAML assertion, protocol or metadata XML against the SAML, XML signature and XML encryption schemas.
Top
See Also

Reference

ComponentSpace.SAML2.Schemas Namespace


SAMLValidator Constructor

Initializes a new instance of the SAMLValidator class

Namespace: ComponentSpace.SAML2.Schemas
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLValidator()
Public Sub New
public:
SAMLValidator()
new : unit -> SAMLValidator
See Also

Reference

SAMLValidator Class
ComponentSpace.SAML2.Schemas Namespace


SAMLValidator Properties

The SAMLValidator type exposes the following members.

Properties
 | Name | Description
Public property | Errors | Gets the errors associated with the last validation.
Public property | Warnings | Gets the warnings associated with the last validation.
Top
See Also

Reference

SAMLValidator Class
ComponentSpace.SAML2.Schemas Namespace


SAMLValidator.Errors Property

SAMLValidatorErrors Property

Gets the errors associated with the last validation.

Namespace: ComponentSpace.SAML2.Schemas
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<XmlSchemaException> Errors { get; }
Public ReadOnly Property Errors As IList(Of XmlSchemaException)
    Get
public:
property IList<XmlSchemaException^>^ Errors {
    IList<XmlSchemaException^>^ get ();
}
member Errors : IList<XmlSchemaException> with get

Property Value

Type: IList XmlSchemaException
The errors.
See Also

Reference

SAMLValidator Class
ComponentSpace.SAML2.Schemas Namespace


SAMLValidator.Warnings Property

SAMLValidatorWarnings Property

Gets the warnings associated with the last validation.

Namespace: ComponentSpace.SAML2.Schemas
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public IList<XmlSchemaException> Warnings { get; }
Public ReadOnly Property Warnings As IList(Of XmlSchemaException)
    Get
public:
property IList<XmlSchemaException^>^ Warnings {
    IList<XmlSchemaException^>^ get ();
}
member Warnings : IList<XmlSchemaException> with get

Property Value

Type: IList XmlSchemaException
The warnings.
See Also

Reference

SAMLValidator Class
ComponentSpace.SAML2.Schemas Namespace


SAMLValidator Methods

The SAMLValidator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(XmlDocument) | Validates the SAML assertion, protocol or metadata XML against the SAML, XML signature and XML encryption schemas.
Public method | Validate(XmlElement) | Validates the SAML assertion, protocol or metadata XML against the SAML, XML signature and XML encryption schemas.
Top
See Also

Reference

SAMLValidator Class
ComponentSpace.SAML2.Schemas Namespace


SAMLValidator.Validate Method

SAMLValidatorValidate Method

Overload List
 | Name | Description
Public method | Validate(XmlDocument) | Validates the SAML assertion, protocol or metadata XML against the SAML, XML signature and XML encryption schemas.
Public method | Validate(XmlElement) | Validates the SAML assertion, protocol or metadata XML against the SAML, XML signature and XML encryption schemas.
Top
See Also

Reference

SAMLValidator Class
ComponentSpace.SAML2.Schemas Namespace


SAMLValidator.Validate Method (XmlDocument)

SAMLValidatorValidate Method (XmlDocument)

Validates the SAML assertion, protocol or metadata XML against the SAML, XML signature and XML encryption schemas.

Namespace: ComponentSpace.SAML2.Schemas
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool Validate(
    XmlDocument xmlDocument
)
Public Function Validate (
    xmlDocument As XmlDocument
) As Boolean
public:
bool Validate(
    XmlDocument^ xmlDocument
)
member Validate :
        xmlDocument : XmlDocument -> bool

Parameters

xmlDocument
Type: System.XmlXmlDocument
The XML to validate

Return Value

Type: Boolean
true if the XML validates against the SAML schemas; otherwise false.
Exceptions
Exception | Condition
SAMLException | Thrown when the validation fails.
See Also

Reference

SAMLValidator Class
Validate Overload
ComponentSpace.SAML2.Schemas Namespace


SAMLValidator.Validate Method (XmlElement)

SAMLValidatorValidate Method (XmlElement)

Validates the SAML assertion, protocol or metadata XML against the SAML, XML signature and XML encryption schemas.

Namespace: ComponentSpace.SAML2.Schemas
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public bool Validate(
    XmlElement xmlElement
)
Public Function Validate (
    xmlElement As XmlElement
) As Boolean
public:
bool Validate(
    XmlElement^ xmlElement
)
member Validate :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The XML to validate

Return Value

Type: Boolean
true if the XML validates against the SAML schemas; otherwise false.
Exceptions
Exception | Condition
SAMLException | Thrown when the validation fails.
See Also

Reference

SAMLValidator Class
Validate Overload
ComponentSpace.SAML2.Schemas Namespace


ComponentSpace.SAML2.Utility Namespace

The ComponentSpace.SAML2.Utility namespace contains utility classes.
Classes
 | Class | Description
Public class | HttpBasicAuthentication | Provides methods for HTTP basic authentication (BA).
Public class | License | Provides licensing information.
Public class | SAML | Provides common SAML definitions and helper methods.
Public class | SAMLNamespaceURIs | The XML namespace URIs.
Public class | SAMLPrefixes | The XML prefixes.
Public class | SAMLHttpContext | Supports sending and receiving SAML protocol messages through non-standard HTTP requests and responses.
Public class | SAMLHttpRequest | Provides a mechanism for receiving a SAML protocol message through a non-standard HTTP request.
Public class | SAMLHttpResponse | Provides a mechanism for sending a SAML protocol message through a non-standard HTTP response.
Public class | SAMLHttpSessionState | Supports sending and receiving SAML protocol messages through non-standard HTTP requests and responses.
Public class | XmlSchema | Provides common XML schema definitions and helper methods.
Public class | XmlSchemaNamespaceURIs | The XML namespace URIs.
Public class | XmlSchemaPrefixes | The XML prefixes.
Public class | XmlSchemaSimpleTypes | Simple types built into XML schema.
Public class | XMLSignatureDescriptions | Included are XML signature descriptions for the SHA-256, SHA-384 and SHA-512 algorithms.
Public class | XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription | Describes the SHA-256 XML signature algorithm.
Public class | XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription | Describes the SHA-384 XML signature algorithm.
Public class | XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription | Describes the SHA-512 XML signature algorithm.


HttpBasicAuthentication Class

Provides methods for HTTP basic authentication (BA).
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.UtilityHttpBasicAuthentication

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class HttpBasicAuthentication
Public NotInheritable Class HttpBasicAuthentication
public ref class HttpBasicAuthentication abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HttpBasicAuthentication =  class end

The HttpBasicAuthentication type exposes the following members.

Methods
Name | Description
AddAuthorizationHeader | Adds an authorization header to a web request.
CreateAuthorizationHeader | Creates an authorization header.
GetAuthorizationHeader(HttpRequest) | Gets the authorization header from the request.
GetAuthorizationHeader(HttpRequestBase) | Gets the authorization header from the request.
GetAuthorizationHeader(String, String, String) | Gets the authorization header's user name and password from the request.
GetAuthorizationHeader(HttpRequest, String, String) | Gets the authorization header's user name and password from the request.
GetAuthorizationHeader(HttpRequestBase, String, String) | Gets the authorization header's user name and password from the request.
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


HttpBasicAuthentication Methods

The HttpBasicAuthentication type exposes the following members.

Methods
Name | Description
AddAuthorizationHeader | Adds an authorization header to a web request.
CreateAuthorizationHeader | Creates an authorization header.
GetAuthorizationHeader(HttpRequest) | Gets the authorization header from the request.
GetAuthorizationHeader(HttpRequestBase) | Gets the authorization header from the request.
GetAuthorizationHeader(String, String, String) | Gets the authorization header's user name and password from the request.
GetAuthorizationHeader(HttpRequest, String, String) | Gets the authorization header's user name and password from the request.
GetAuthorizationHeader(HttpRequestBase, String, String) | Gets the authorization header's user name and password from the request.
Top
See Also

Reference

HttpBasicAuthentication Class
ComponentSpace.SAML2.Utility Namespace


HttpBasicAuthentication.AddAuthorizationHeader Method

HttpBasicAuthenticationAddAuthorizationHeader Method

Adds an authorization header to a web request.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void AddAuthorizationHeader(
    HttpWebRequest httpWebRequest,
    string userName,
    string password
)
Public Shared Sub AddAuthorizationHeader (
    httpWebRequest As HttpWebRequest,
    userName As String,
    password As String
)
public:
static void AddAuthorizationHeader(
    HttpWebRequest^ httpWebRequest,
    String^ userName,
    String^ password
)
static member AddAuthorizationHeader :
        httpWebRequest : HttpWebRequest *
        userName : string *
        password : string -> unit

Parameters

httpWebRequest
Type: System.NetHttpWebRequest
The HTTP web request.
userName
Type: SystemString
The user name.
password
Type: SystemString
The password.
See Also

Reference

HttpBasicAuthentication Class
ComponentSpace.SAML2.Utility Namespace


HttpBasicAuthentication.CreateAuthorizationHeader Method

HttpBasicAuthenticationCreateAuthorizationHeader Method

Creates an authorization header.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string CreateAuthorizationHeader(
    string userName,
    string password
)
Public Shared Function CreateAuthorizationHeader (
    userName As String,
    password As String
) As String
public:
static String^ CreateAuthorizationHeader(
    String^ userName,
    String^ password
)
static member CreateAuthorizationHeader :
        userName : string *
        password : string -> string

Parameters

userName
Type: SystemString
The user name.
password
Type: SystemString
The password.

Return Value

Type: String
The authorization header.
See Also

Reference

HttpBasicAuthentication Class
ComponentSpace.SAML2.Utility Namespace


HttpBasicAuthentication.GetAuthorizationHeader Method

HttpBasicAuthenticationGetAuthorizationHeader Method

Overload List
Name | Description
GetAuthorizationHeader(HttpRequest) | Gets the authorization header from the request.
GetAuthorizationHeader(HttpRequestBase) | Gets the authorization header from the request.
GetAuthorizationHeader(String, String, String) | Gets the authorization header's user name and password from the request.
GetAuthorizationHeader(HttpRequest, String, String) | Gets the authorization header's user name and password from the request.
GetAuthorizationHeader(HttpRequestBase, String, String) | Gets the authorization header's user name and password from the request.
Top
See Also

Reference

HttpBasicAuthentication Class
ComponentSpace.SAML2.Utility Namespace


HttpBasicAuthentication.GetAuthorizationHeader Method (HttpRequest)

HttpBasicAuthenticationGetAuthorizationHeader Method (HttpRequest)

Gets the authorization header from the request.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetAuthorizationHeader(
    HttpRequest httpRequest
)
Public Shared Function GetAuthorizationHeader (
    httpRequest As HttpRequest
) As String
public:
static String^ GetAuthorizationHeader(
    HttpRequest^ httpRequest
)
static member GetAuthorizationHeader :
        httpRequest : HttpRequest -> string

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request.

Return Value

Type: String
The authorization header.
See Also

Reference

HttpBasicAuthentication Class
GetAuthorizationHeader Overload
ComponentSpace.SAML2.Utility Namespace


HttpBasicAuthentication.GetAuthorizationHeader Method (HttpRequestBase)

HttpBasicAuthenticationGetAuthorizationHeader Method (HttpRequestBase)

Gets the authorization header from the request.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetAuthorizationHeader(
    HttpRequestBase httpRequest
)
Public Shared Function GetAuthorizationHeader (
    httpRequest As HttpRequestBase
) As String
public:
static String^ GetAuthorizationHeader(
    HttpRequestBase^ httpRequest
)
static member GetAuthorizationHeader :
        httpRequest : HttpRequestBase -> string

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request.

Return Value

Type: String
The authorization header.
See Also

Reference

HttpBasicAuthentication Class
GetAuthorizationHeader Overload
ComponentSpace.SAML2.Utility Namespace


HttpBasicAuthentication.GetAuthorizationHeader Method (String, String, String)

HttpBasicAuthenticationGetAuthorizationHeader Method (String, String, String)

Gets the authorization header's user name and password from the request.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void GetAuthorizationHeader(
    string header,
    out string userName,
    out string password
)
Public Shared Sub GetAuthorizationHeader (
    header As String,
    <OutAttribute> ByRef userName As String,
    <OutAttribute> ByRef password As String
)
public:
static void GetAuthorizationHeader(
    String^ header,
    [OutAttribute] String^% userName,
    [OutAttribute] String^% password
)
static member GetAuthorizationHeader :
        header : string *
        userName : string byref *
        password : string byref -> unit

Parameters

header
Type: SystemString
The authorization header.
userName
Type: SystemString
The user name.
password
Type: SystemString
The password.
Exceptions
Exception | Condition
SAMLException | Thrown when the header cannot be retrieved.
See Also

Reference

HttpBasicAuthentication Class
GetAuthorizationHeader Overload
ComponentSpace.SAML2.Utility Namespace


HttpBasicAuthentication.GetAuthorizationHeader Method (HttpRequest, String, String)

HttpBasicAuthenticationGetAuthorizationHeader Method (HttpRequest, String, String)

Gets the authorization header's user name and password from the request.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void GetAuthorizationHeader(
    HttpRequest httpRequest,
    out string userName,
    out string password
)
Public Shared Sub GetAuthorizationHeader (
    httpRequest As HttpRequest,
    <OutAttribute> ByRef userName As String,
    <OutAttribute> ByRef password As String
)
public:
static void GetAuthorizationHeader(
    HttpRequest^ httpRequest,
    [OutAttribute] String^% userName,
    [OutAttribute] String^% password
)
static member GetAuthorizationHeader :
        httpRequest : HttpRequest *
        userName : string byref *
        password : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequest
The HTTP request.
userName
Type: SystemString
The user name.
password
Type: SystemString
The password.
Exceptions
Exception | Condition
SAMLException | Thrown when the header cannot be retrieved.
See Also

Reference

HttpBasicAuthentication Class
GetAuthorizationHeader Overload
ComponentSpace.SAML2.Utility Namespace


HttpBasicAuthentication.GetAuthorizationHeader Method (HttpRequestBase, String, String)

HttpBasicAuthenticationGetAuthorizationHeader Method (HttpRequestBase, String, String)

Gets the authorization header's user name and password from the request.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void GetAuthorizationHeader(
    HttpRequestBase httpRequest,
    out string userName,
    out string password
)
Public Shared Sub GetAuthorizationHeader (
    httpRequest As HttpRequestBase,
    <OutAttribute> ByRef userName As String,
    <OutAttribute> ByRef password As String
)
public:
static void GetAuthorizationHeader(
    HttpRequestBase^ httpRequest,
    [OutAttribute] String^% userName,
    [OutAttribute] String^% password
)
static member GetAuthorizationHeader :
        httpRequest : HttpRequestBase *
        userName : string byref *
        password : string byref -> unit

Parameters

httpRequest
Type: System.WebHttpRequestBase
The HTTP request.
userName
Type: SystemString
The user name.
password
Type: SystemString
The password.
Exceptions
Exception | Condition
SAMLException | Thrown when the header cannot be retrieved.
See Also

Reference

HttpBasicAuthentication Class
GetAuthorizationHeader Overload
ComponentSpace.SAML2.Utility Namespace


License Class

Provides licensing information.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.UtilityLicense

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class License
Public NotInheritable Class License
public ref class License abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type License =  class end

The License type exposes the following members.

Methods
Name | Description
GetVersion | Gets the version information for the component.
IsLicensed | Indicates whether this is a licensed or evaluation version.
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


License Methods

The License type exposes the following members.

Methods
Name | Description
GetVersion | Gets the version information for the component.
IsLicensed | Indicates whether this is a licensed or evaluation version.
Top
See Also

Reference

License Class
ComponentSpace.SAML2.Utility Namespace


License.GetVersion Method

LicenseGetVersion Method

Gets the version information for the component.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetVersion()
Public Shared Function GetVersion As String
public:
static String^ GetVersion()
static member GetVersion : unit -> string

Return Value

Type: String
The version information for the component.
See Also

Reference

License Class
ComponentSpace.SAML2.Utility Namespace


License.IsLicensed Method

LicenseIsLicensed Method

Indicates whether this is a licensed or evaluation version.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsLicensed()
Public Shared Function IsLicensed As Boolean
public:
static bool IsLicensed()
static member IsLicensed : unit -> bool

Return Value

Type: Boolean
true if a licensed version; false if an evaluation version.
See Also

Reference

License Class
ComponentSpace.SAML2.Utility Namespace


SAML Class

Provides common SAML definitions and helper methods.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.UtilitySAML

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SAML
Public NotInheritable Class SAML
public ref class SAML abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SAML =  class end

The SAML type exposes the following members.

Properties
Name | Description
HttpContext | Gets or sets the HTTP context.
HttpSessionState | Gets or sets the HTTP session state.
MillisecondPrecision | Gets or sets the flag indicating whether or not times should have millisecond precision when being serialized to XML. For example, a time with millisecond precision is 06:33:14.729 whereas a time without millisecond precision is 06:33:14. The default is true.
Top
Methods
Name | Description
CreateID | Creates an identifier by prefixing a generated GUID with an underscore.
FromBase64String | Converts the base-64 encoded string into XML.
GetSAMLMessageType | Returns the SAML message type.
IsSAMLRequest(XmlElement) | Indicates whether the SAML message is a request or response.
IsSAMLRequest(SAMLIdentifiersMessageType) | Indicates whether the SAML message is a request or response.
RemoveUnicodeMarkerCharacters | Removes unicode marker characters from the string. 0x200E is the left-to-right marker. 0x200F is the right-to-left marker.
ToAbsoluteURL | Converts a rooted URL to an absolute URL. A rooted URL starts with the tilde (~) character. The call must be made in the context of processing an HTTP request.
ToBase64String | Converts the XML into a base-64 encoded string.
ToBoolean | Returns the boolean value represented by a string.
ToDateTime | Returns the DateTime represented by the formatted date/time string.
ToDateTimeString | Returns the current UTC date/time formatted as: yyyy-mm-ddThh:mm:ssZ.
ToDateTimeString(DateTime) | Returns a date/time string formatted as: yyyy-mm-ddThh:mm:ss.sssZ.
ToXmlElement | Loads an XML element from an XML string.
Top
Fields
Name | Description
Version | The SAML version.
Top
Remarks
Refer to the Assertions and Protocol for the OASIS Security Assertion Markup Language (SAML) V2.0 specification for further details.
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


SAML Properties

The SAML type exposes the following members.

Properties
Name | Description
HttpContext | Gets or sets the HTTP context.
HttpSessionState | Gets or sets the HTTP session state.
MillisecondPrecision | Gets or sets the flag indicating whether or not times should have millisecond precision when being serialized to XML. For example, a time with millisecond precision is 06:33:14.729 whereas a time without millisecond precision is 06:33:14. The default is true.
Top
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.HttpContext Property

SAMLHttpContext Property

Gets or sets the HTTP context.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static HttpContextBase HttpContext { get; set; }
Public Shared Property HttpContext As HttpContextBase
    Get
    Set
public:
static property HttpContextBase^ HttpContext {
    HttpContextBase^ get ();
    void set (HttpContextBase^ value);
}
static member HttpContext : HttpContextBase with get, set

Property Value

Type: HttpContextBase
The HTTP context.
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.HttpSessionState Property

SAMLHttpSessionState Property

Gets or sets the HTTP session state.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static HttpSessionStateBase HttpSessionState { get; set; }
Public Shared Property HttpSessionState As HttpSessionStateBase
    Get
    Set
public:
static property HttpSessionStateBase^ HttpSessionState {
    HttpSessionStateBase^ get ();
    void set (HttpSessionStateBase^ value);
}
static member HttpSessionState : HttpSessionStateBase with get, set

Property Value

Type: HttpSessionStateBase
The HTTP session state.
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.MillisecondPrecision Property

SAMLMillisecondPrecision Property

Gets or sets the flag indicating whether or not times should have millisecond precision when being serialized to XML.

For example, a time with millisecond precision is 06:33:14.729 whereas a time without millisecond precision is 06:33:14.

The default is true.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool MillisecondPrecision { get; set; }
Public Shared Property MillisecondPrecision As Boolean
    Get
    Set
public:
static property bool MillisecondPrecision {
    bool get ();
    void set (bool value);
}
static member MillisecondPrecision : bool with get, set

Property Value

Type: Boolean
The flag indicating whether or not times should have millisecond precision.
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML Methods

The SAML type exposes the following members.

Methods
Name | Description
CreateID | Creates an identifier by prefixing a generated GUID with an underscore.
FromBase64String | Converts the base-64 encoded string into XML.
GetSAMLMessageType | Returns the SAML message type.
IsSAMLRequest(XmlElement) | Indicates whether the SAML message is a request or response.
IsSAMLRequest(SAMLIdentifiersMessageType) | Indicates whether the SAML message is a request or response.
RemoveUnicodeMarkerCharacters | Removes unicode marker characters from the string. 0x200E is the left-to-right marker. 0x200F is the right-to-left marker.
ToAbsoluteURL | Converts a rooted URL to an absolute URL. A rooted URL starts with the tilde (~) character. The call must be made in the context of processing an HTTP request.
ToBase64String | Converts the XML into a base-64 encoded string.
ToBoolean | Returns the boolean value represented by a string.
ToDateTime | Returns the DateTime represented by the formatted date/time string.
ToDateTimeString | Returns the current UTC date/time formatted as: yyyy-mm-ddThh:mm:ssZ.
ToDateTimeString(DateTime) | Returns a date/time string formatted as: yyyy-mm-ddThh:mm:ss.sssZ.
ToXmlElement | Loads an XML element from an XML string.
Top
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.CreateID Method

SAMLCreateID Method

Creates an identifier by prefixing a generated GUID with an underscore.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string CreateID()
Public Shared Function CreateID As String
public:
static String^ CreateID()
static member CreateID : unit -> string

Return Value

Type: String
The identifier.
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.FromBase64String Method

SAMLFromBase64String Method

Converts the base-64 encoded string into XML.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement FromBase64String(
    string text
)
Public Shared Function FromBase64String (
    text As String
) As XmlElement
public:
static XmlElement^ FromBase64String(
    String^ text
)
static member FromBase64String :
        text : string -> XmlElement

Parameters

text
Type: SystemString
The base-64 encoded string.

Return Value

Type: XmlElement
The XML.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the conversion fails.
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.GetSAMLMessageType Method

SAMLGetSAMLMessageType Method

Returns the SAML message type.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static SAMLIdentifiersMessageType GetSAMLMessageType(
    XmlElement xmlElement
)
Public Shared Function GetSAMLMessageType (
    xmlElement As XmlElement
) As SAMLIdentifiersMessageType
public:
static SAMLIdentifiersMessageType GetSAMLMessageType(
    XmlElement^ xmlElement
)
static member GetSAMLMessageType :
        xmlElement : XmlElement -> SAMLIdentifiersMessageType

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message XML.

Return Value

Type: SAMLIdentifiersMessageType
The SAML message type.
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.IsSAMLRequest Method

SAMLIsSAMLRequest Method

Overload List
Name | Description
IsSAMLRequest(XmlElement) | Indicates whether the SAML message is a request or response.
IsSAMLRequest(SAMLIdentifiersMessageType) | Indicates whether the SAML message is a request or response.
Top
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.IsSAMLRequest Method (XmlElement)

SAMLIsSAMLRequest Method (XmlElement)

Indicates whether the SAML message is a request or response.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSAMLRequest(
    XmlElement xmlElement
)
Public Shared Function IsSAMLRequest (
    xmlElement As XmlElement
) As Boolean
public:
static bool IsSAMLRequest(
    XmlElement^ xmlElement
)
static member IsSAMLRequest :
        xmlElement : XmlElement -> bool

Parameters

xmlElement
Type: System.XmlXmlElement
The SAML message XML.

Return Value

Type: Boolean
true if the SAML message is a request; otherwise false.
See Also

Reference

SAML Class
IsSAMLRequest Overload
ComponentSpace.SAML2.Utility Namespace


SAML.IsSAMLRequest Method (SAMLIdentifiers.MessageType)

SAMLIsSAMLRequest Method (SAMLIdentifiersMessageType)

Indicates whether the SAML message is a request or response.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool IsSAMLRequest(
    SAMLIdentifiersMessageType messageType
)
Public Shared Function IsSAMLRequest (
    messageType As SAMLIdentifiersMessageType
) As Boolean
public:
static bool IsSAMLRequest(
    SAMLIdentifiersMessageType messageType
)
static member IsSAMLRequest :
        messageType : SAMLIdentifiersMessageType -> bool

Parameters

messageType
Type: ComponentSpace.SAML2SAMLIdentifiersMessageType
The SAML message type.

Return Value

Type: Boolean
true if the SAML message is a request; otherwise false.
See Also

Reference

SAML Class
IsSAMLRequest Overload
ComponentSpace.SAML2.Utility Namespace


SAML.RemoveUnicodeMarkerCharacters Method

SAMLRemoveUnicodeMarkerCharacters Method

Removes unicode marker characters from the string.

0x200E is the left-to-right marker.

0x200F is the right-to-left marker.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string RemoveUnicodeMarkerCharacters(
    string text
)
Public Shared Function RemoveUnicodeMarkerCharacters (
    text As String
) As String
public:
static String^ RemoveUnicodeMarkerCharacters(
    String^ text
)
static member RemoveUnicodeMarkerCharacters :
        text : string -> string

Parameters

text
Type: SystemString
The string.

Return Value

Type: String
The string with unicode marker characters stripped.
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.ToAbsoluteURL Method

SAMLToAbsoluteURL Method

Converts a rooted URL to an absolute URL.

A rooted URL starts with the tilde (~) character.

The call must be made in the context of processing an HTTP request.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string ToAbsoluteURL(
    string url
)
Public Shared Function ToAbsoluteURL (
    url As String
) As String
public:
static String^ ToAbsoluteURL(
    String^ url
)
static member ToAbsoluteURL :
        url : string -> string

Parameters

url
Type: SystemString
The rooted URL.

Return Value

Type: String
The absolute URL.
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.ToBase64String Method

SAMLToBase64String Method

Converts the XML into a base-64 encoded string.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string ToBase64String(
    XmlElement xmlElement
)
Public Shared Function ToBase64String (
    xmlElement As XmlElement
) As String
public:
static String^ ToBase64String(
    XmlElement^ xmlElement
)
static member ToBase64String :
        xmlElement : XmlElement -> string

Parameters

xmlElement
Type: System.XmlXmlElement
The XML.

Return Value

Type: String
The base-64 encoded string.
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.ToBoolean Method

SAMLToBoolean Method

Returns the boolean value represented by a string.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool ToBoolean(
    string booleanString
)
Public Shared Function ToBoolean (
    booleanString As String
) As Boolean
public:
static bool ToBoolean(
    String^ booleanString
)
static member ToBoolean :
        booleanString : string -> bool

Parameters

booleanString
Type: SystemString
The boolean string.

Return Value

Type: Boolean
The boolean.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the boolean string value is illegal.
Remarks
Valid values, as defined by the XML schema specification, are "true", "false", "1", "0".
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.ToDateTime Method

SAMLToDateTime Method

Returns the DateTime represented by the formatted date/time string.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static DateTime ToDateTime(
    string dateTimeString
)
Public Shared Function ToDateTime (
    dateTimeString As String
) As DateTime
public:
static DateTime ToDateTime(
    String^ dateTimeString
)
static member ToDateTime :
        dateTimeString : string -> DateTime

Parameters

dateTimeString
Type: SystemString
The date/time string.

Return Value

Type: DateTime
The DateTime.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the conversion fails.
Remarks
The date/time string should be formatted as: yyyy-mm-ddThh:mm:ssZ.

As per the SAML specification, all date/time values should be coordinated universal time (UTC).

See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.ToDateTimeString Method

SAMLToDateTimeString Method

Overload List
Name | Description
ToDateTimeString | Returns the current UTC date/time formatted as: yyyy-mm-ddThh:mm:ssZ.
ToDateTimeString(DateTime) | Returns a date/time string formatted as: yyyy-mm-ddThh:mm:ss.sssZ.
Top
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.ToDateTimeString Method

SAMLToDateTimeString Method

Returns the current UTC date/time formatted as: yyyy-mm-ddThh:mm:ssZ.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string ToDateTimeString()
Public Shared Function ToDateTimeString As String
public:
static String^ ToDateTimeString()
static member ToDateTimeString : unit -> string

Return Value

Type: String
The formatted string.
See Also

Reference

SAML Class
ToDateTimeString Overload
ComponentSpace.SAML2.Utility Namespace


SAML.ToDateTimeString Method (DateTime)

SAMLToDateTimeString Method (DateTime)

Returns a date/time string formatted as: yyyy-mm-ddThh:mm:ss.sssZ.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string ToDateTimeString(
    DateTime dateTime
)
Public Shared Function ToDateTimeString (
    dateTime As DateTime
) As String
public:
static String^ ToDateTimeString(
    DateTime dateTime
)
static member ToDateTimeString :
        dateTime : DateTime -> string

Parameters

dateTime
Type: SystemDateTime
The date/time.

Return Value

Type: String
The formatted string.
Remarks
As per the SAML specification, all date/time values should be coordinated universal time (UTC).
See Also

Reference

SAML Class
ToDateTimeString Overload
ComponentSpace.SAML2.Utility Namespace


SAML.ToXmlElement Method

SAMLToXmlElement Method

Loads an XML element from an XML string.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static XmlElement ToXmlElement(
    string xmlString
)
Public Shared Function ToXmlElement (
    xmlString As String
) As XmlElement
public:
static XmlElement^ ToXmlElement(
    String^ xmlString
)
static member ToXmlElement :
        xmlString : string -> XmlElement

Parameters

xmlString
Type: SystemString
The XML string

Return Value

Type: XmlElement
The XML element.
Exceptions
Exception | Condition
SAMLSerializationException | Thrown when the XML deserialization fails.
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML Fields

The SAML type exposes the following members.

Fields
Name | Description
Version | The SAML version.
Top
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.Version Field

SAMLVersion Field

The SAML version.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Version = "2.0"
Public Const Version As String = "2.0"
public:
literal String^ Version = "2.0"
static val mutable Version: string

Field Value

Type: String
See Also

Reference

SAML Class
ComponentSpace.SAML2.Utility Namespace


SAML.NamespaceURIs Class

SAMLNamespaceURIs Class

The XML namespace URIs.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.UtilitySAMLNamespaceURIs

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class NamespaceURIs
Public NotInheritable Class NamespaceURIs
public ref class NamespaceURIs abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NamespaceURIs =  class end

The SAMLNamespaceURIs type exposes the following members.

Fields
Name | Description
Assertion | The SAML assertion namespace URI.
Metadata | The SAML metadata namespace URI.
Protocol | The SAML protocol namespace URI.
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


NamespaceURIs Fields

The SAMLNamespaceURIs type exposes the following members.

Fields
Name | Description
Assertion | The SAML assertion namespace URI.
Metadata | The SAML metadata namespace URI.
Protocol | The SAML protocol namespace URI.
Top
See Also

Reference

SAMLNamespaceURIs Class
ComponentSpace.SAML2.Utility Namespace


SAML.NamespaceURIs.Assertion Field

SAMLNamespaceURIsAssertion Field

The SAML assertion namespace URI.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Assertion = "urn:oasis:names:tc:SAML:2.0:assertion"
Public Const Assertion As String = "urn:oasis:names:tc:SAML:2.0:assertion"
public:
literal String^ Assertion = "urn:oasis:names:tc:SAML:2.0:assertion"
static val mutable Assertion: string

Field Value

Type: String
See Also

Reference

SAMLNamespaceURIs Class
ComponentSpace.SAML2.Utility Namespace


SAML.NamespaceURIs.Metadata Field

SAMLNamespaceURIsMetadata Field

The SAML metadata namespace URI.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Metadata = "urn:oasis:names:tc:SAML:2.0:metadata"
Public Const Metadata As String = "urn:oasis:names:tc:SAML:2.0:metadata"
public:
literal String^ Metadata = "urn:oasis:names:tc:SAML:2.0:metadata"
static val mutable Metadata: string

Field Value

Type: String
See Also

Reference

SAMLNamespaceURIs Class
ComponentSpace.SAML2.Utility Namespace


SAML.NamespaceURIs.Protocol Field

SAMLNamespaceURIsProtocol Field

The SAML protocol namespace URI.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Protocol = "urn:oasis:names:tc:SAML:2.0:protocol"
Public Const Protocol As String = "urn:oasis:names:tc:SAML:2.0:protocol"
public:
literal String^ Protocol = "urn:oasis:names:tc:SAML:2.0:protocol"
static val mutable Protocol: string

Field Value

Type: String
See Also

Reference

SAMLNamespaceURIs Class
ComponentSpace.SAML2.Utility Namespace


SAML.Prefixes Class

SAMLPrefixes Class

The XML prefixes.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.UtilitySAMLPrefixes

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class Prefixes
Public NotInheritable Class Prefixes
public ref class Prefixes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Prefixes =  class end

The SAMLPrefixes type exposes the following members.

Fields
Name | Description
MD | The SAML metadata prefix.
SAML | The SAML prefix.
SAMLP | The SAML protocol prefix.
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


Prefixes Fields

The SAMLPrefixes type exposes the following members.

Fields
Name | Description
MD | The SAML metadata prefix.
SAML | The SAML prefix.
SAMLP | The SAML protocol prefix.
Top
See Also

Reference

SAMLPrefixes Class
ComponentSpace.SAML2.Utility Namespace


SAML.Prefixes.MD Field

SAMLPrefixesMD Field

The SAML metadata prefix.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string MD = "md"
Public Const MD As String = "md"
public:
literal String^ MD = "md"
static val mutable MD: string

Field Value

Type: String
See Also

Reference

SAMLPrefixes Class
ComponentSpace.SAML2.Utility Namespace


SAML.Prefixes.SAML Field

SAMLPrefixesSAML Field

The SAML prefix.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SAML = "saml"
Public Const SAML As String = "saml"
public:
literal String^ SAML = "saml"
static val mutable SAML: string

Field Value

Type: String
See Also

Reference

SAMLPrefixes Class
ComponentSpace.SAML2.Utility Namespace


SAML.Prefixes.SAMLP Field

SAMLPrefixesSAMLP Field

The SAML protocol prefix.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string SAMLP = "samlp"
Public Const SAMLP As String = "samlp"
public:
literal String^ SAMLP = "samlp"
static val mutable SAMLP: string

Field Value

Type: String
See Also

Reference

SAMLPrefixes Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpContext Class

Supports sending and receiving SAML protocol messages through non-standard HTTP requests and responses.
Inheritance Hierarchy
SystemObject
System.WebHttpContextBase
ComponentSpace.SAML2.UtilitySAMLHttpContext

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SAMLHttpContext : HttpContextBase
Public Class SAMLHttpContext
    Inherits HttpContextBase
public ref class SAMLHttpContext : public HttpContextBase
type SAMLHttpContext =
    class
        inherit HttpContextBase
    end

The SAMLHttpContext type exposes the following members.

Constructors
 | Name | Description
Public method | SAMLHttpContext | Initializes a new instance of the SAMLHttpContext class.
Top
Properties
 | Name | Description
Public property | AllErrors | When overridden in a derived class, gets an array of errors (if any) that accumulated when an HTTP request was being processed. (Inherited from HttpContextBase.)
Public property | Application | When overridden in a derived class, gets the HttpApplicationState object for the current HTTP request. (Inherited from HttpContextBase.)
Public property | ApplicationInstance | When overridden in a derived class, gets or sets the HttpApplication object for the current HTTP request. (Inherited from HttpContextBase.)
Public property | Cache | When overridden in a derived class, gets the Cache object for the current application domain. (Inherited from HttpContextBase.)
Public property | CurrentHandler | When overridden in a derived class, gets the IHttpHandler object that represents the handler that is currently executing. (Inherited from HttpContextBase.)
Public property | CurrentNotification | When overridden in a derived class, gets a RequestNotification value that indicates the HttpApplication event that is currently processing. (Inherited from HttpContextBase.)
Public property | Error | When overridden in a derived class, gets the first error (if any) that accumulated when an HTTP request was being processed. (Inherited from HttpContextBase.)
Public property | Handler | When overridden in a derived class, gets or sets the IHttpHandler object that is responsible for processing the HTTP request. (Inherited from HttpContextBase.)
Public property | IsCustomErrorEnabled | When overridden in a derived class, gets a value that indicates whether custom errors are enabled for the current HTTP request. (Inherited from HttpContextBase.)
Public property | IsDebuggingEnabled | When overridden in a derived class, gets a value that indicates whether the current HTTP request is in debug mode. (Inherited from HttpContextBase.)
Public property | IsPostNotification | When overridden in a derived class, gets a value that indicates whether an HttpApplication event has finished processing. (Inherited from HttpContextBase.)
Public property | Items | When overridden in a derived class, gets a key/value collection that can be used to organize and share data between a module and a handler during an HTTP request. (Inherited from HttpContextBase.)
Public property | PreviousHandler | When overridden in a derived class, gets the IHttpHandler object for the parent handler. (Inherited from HttpContextBase.)
Public property | Profile | When overridden in a derived class, gets the ProfileBase object for the current user profile. (Inherited from HttpContextBase.)
Public property | Request | When overridden in a derived class, gets the HttpRequest object for the current HTTP request. (Inherited from HttpContextBase.)
Public property | Response | When overridden in a derived class, gets the HttpResponse object for the current HTTP response. (Inherited from HttpContextBase.)
Public property | Server | When overridden in a derived class, gets the HttpServerUtility object that provides methods that are used when Web requests are being processed. (Inherited from HttpContextBase.)
Public property | Session | Gets the HTTP session. (Overrides HttpContextBaseSession.)
Public property | SkipAuthorization | When overridden in a derived class, gets or sets a value that specifies whether the UrlAuthorizationModule object should skip the authorization check for the current request. (Inherited from HttpContextBase.)
Public property | Timestamp | When overridden in a derived class, gets the initial timestamp of the current HTTP request. (Inherited from HttpContextBase.)
Public property | Trace | When overridden in a derived class, gets the TraceContext object for the current HTTP response. (Inherited from HttpContextBase.)
Public property | User | When overridden in a derived class, gets or sets security information for the current HTTP request. (Inherited from HttpContextBase.)
Top
Methods
 | Name | Description
Public method | AddError | When overridden in a derived class, adds an exception to the exception collection for the current HTTP request. (Inherited from HttpContextBase.)
Public method | ClearError | When overridden in a derived class, clears all errors for the current HTTP request. (Inherited from HttpContextBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetGlobalResourceObject(String, String) | When overridden in a derived class, gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from HttpContextBase.)
Public method | GetGlobalResourceObject(String, String, CultureInfo) | When overridden in a derived class, gets an application-level resource object based on the specified ClassKey and ResourceKey properties, and on the CultureInfo object. (Inherited from HttpContextBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalResourceObject(String, String) | When overridden in a derived class, gets a page-level resource object based on the specified VirtualPath and ResourceKey properties. (Inherited from HttpContextBase.)
Public method | GetLocalResourceObject(String, String, CultureInfo) | When overridden in a derived class, gets a page-level resource object based on the specified VirtualPath and ResourceKey properties, and on the CultureInfo object. (Inherited from HttpContextBase.)
Public method | GetSection | When overridden in a derived class, gets the specified configuration section of the current application's default configuration. (Inherited from HttpContextBase.)
Public method | GetService | When overridden in a derived class, returns an object for the current service type. (Inherited from HttpContextBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemapHandler | When overridden in a derived class, specifies a handler for the request. (Inherited from HttpContextBase.)
Public method | RewritePath(String) | When overridden in a derived class, rewrites the URL by using the specified path. (Inherited from HttpContextBase.)
Public method | RewritePath(String, Boolean) | When overridden in a derived class, rewrites the URL by using the specified path and a value that specifies whether the virtual path for server resources is modified. (Inherited from HttpContextBase.)
Public method | RewritePath(String, String, String) | When overridden in a derived class, rewrites the URL by using the specified path, path information, and query string information. (Inherited from HttpContextBase.)
Public method | RewritePath(String, String, String, Boolean) | When overridden in a derived class, rewrites the URL by using the specified path, path information, query string information, and a value that specifies whether the client file path is set to the rewrite path. (Inherited from HttpContextBase.)
Public method | SetSessionStateBehavior | When overridden in a derived class, sets the type of session state behavior that is required to support an HTTP request. (Inherited from HttpContextBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


SAMLHttpContext Constructor

Initializes a new instance of the SAMLHttpContext class.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpContext()
Public Sub New
public:
SAMLHttpContext()
new : unit -> SAMLHttpContext
See Also

Reference

SAMLHttpContext Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpContext Properties

The SAMLHttpContext type exposes the following members.

Properties
 | Name | Description
Public property | AllErrors | When overridden in a derived class, gets an array of errors (if any) that accumulated when an HTTP request was being processed. (Inherited from HttpContextBase.)
Public property | Application | When overridden in a derived class, gets the HttpApplicationState object for the current HTTP request. (Inherited from HttpContextBase.)
Public property | ApplicationInstance | When overridden in a derived class, gets or sets the HttpApplication object for the current HTTP request. (Inherited from HttpContextBase.)
Public property | Cache | When overridden in a derived class, gets the Cache object for the current application domain. (Inherited from HttpContextBase.)
Public property | CurrentHandler | When overridden in a derived class, gets the IHttpHandler object that represents the handler that is currently executing. (Inherited from HttpContextBase.)
Public property | CurrentNotification | When overridden in a derived class, gets a RequestNotification value that indicates the HttpApplication event that is currently processing. (Inherited from HttpContextBase.)
Public property | Error | When overridden in a derived class, gets the first error (if any) that accumulated when an HTTP request was being processed. (Inherited from HttpContextBase.)
Public property | Handler | When overridden in a derived class, gets or sets the IHttpHandler object that is responsible for processing the HTTP request. (Inherited from HttpContextBase.)
Public property | IsCustomErrorEnabled | When overridden in a derived class, gets a value that indicates whether custom errors are enabled for the current HTTP request. (Inherited from HttpContextBase.)
Public property | IsDebuggingEnabled | When overridden in a derived class, gets a value that indicates whether the current HTTP request is in debug mode. (Inherited from HttpContextBase.)
Public property | IsPostNotification | When overridden in a derived class, gets a value that indicates whether an HttpApplication event has finished processing. (Inherited from HttpContextBase.)
Public property | Items | When overridden in a derived class, gets a key/value collection that can be used to organize and share data between a module and a handler during an HTTP request. (Inherited from HttpContextBase.)
Public property | PreviousHandler | When overridden in a derived class, gets the IHttpHandler object for the parent handler. (Inherited from HttpContextBase.)
Public property | Profile | When overridden in a derived class, gets the ProfileBase object for the current user profile. (Inherited from HttpContextBase.)
Public property | Request | When overridden in a derived class, gets the HttpRequest object for the current HTTP request. (Inherited from HttpContextBase.)
Public property | Response | When overridden in a derived class, gets the HttpResponse object for the current HTTP response. (Inherited from HttpContextBase.)
Public property | Server | When overridden in a derived class, gets the HttpServerUtility object that provides methods that are used when Web requests are being processed. (Inherited from HttpContextBase.)
Public property | Session | Gets the HTTP session. (Overrides HttpContextBaseSession.)
Public property | SkipAuthorization | When overridden in a derived class, gets or sets a value that specifies whether the UrlAuthorizationModule object should skip the authorization check for the current request. (Inherited from HttpContextBase.)
Public property | Timestamp | When overridden in a derived class, gets the initial timestamp of the current HTTP request. (Inherited from HttpContextBase.)
Public property | Trace | When overridden in a derived class, gets the TraceContext object for the current HTTP response. (Inherited from HttpContextBase.)
Public property | User | When overridden in a derived class, gets or sets security information for the current HTTP request. (Inherited from HttpContextBase.)
Top
See Also

Reference

SAMLHttpContext Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpContext.Session Property

SAMLHttpContextSession Property

Gets the HTTP session.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override HttpSessionStateBase Session { get; }
Public Overrides ReadOnly Property Session As HttpSessionStateBase
    Get
public:
virtual property HttpSessionStateBase^ Session {
    HttpSessionStateBase^ get () override;
}
abstract Session : HttpSessionStateBase with get
override Session : HttpSessionStateBase with get

Property Value

Type: HttpSessionStateBase
The HTTP session.
See Also

Reference

SAMLHttpContext Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpContext Methods

The SAMLHttpContext type exposes the following members.

Methods
 | Name | Description
Public method | AddError | When overridden in a derived class, adds an exception to the exception collection for the current HTTP request. (Inherited from HttpContextBase.)
Public method | ClearError | When overridden in a derived class, clears all errors for the current HTTP request. (Inherited from HttpContextBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetGlobalResourceObject(String, String) | When overridden in a derived class, gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from HttpContextBase.)
Public method | GetGlobalResourceObject(String, String, CultureInfo) | When overridden in a derived class, gets an application-level resource object based on the specified ClassKey and ResourceKey properties, and on the CultureInfo object. (Inherited from HttpContextBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalResourceObject(String, String) | When overridden in a derived class, gets a page-level resource object based on the specified VirtualPath and ResourceKey properties. (Inherited from HttpContextBase.)
Public method | GetLocalResourceObject(String, String, CultureInfo) | When overridden in a derived class, gets a page-level resource object based on the specified VirtualPath and ResourceKey properties, and on the CultureInfo object. (Inherited from HttpContextBase.)
Public method | GetSection | When overridden in a derived class, gets the specified configuration section of the current application's default configuration. (Inherited from HttpContextBase.)
Public method | GetService | When overridden in a derived class, returns an object for the current service type. (Inherited from HttpContextBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemapHandler | When overridden in a derived class, specifies a handler for the request. (Inherited from HttpContextBase.)
Public method | RewritePath(String) | When overridden in a derived class, rewrites the URL by using the specified path. (Inherited from HttpContextBase.)
Public method | RewritePath(String, Boolean) | When overridden in a derived class, rewrites the URL by using the specified path and a value that specifies whether the virtual path for server resources is modified. (Inherited from HttpContextBase.)
Public method | RewritePath(String, String, String) | When overridden in a derived class, rewrites the URL by using the specified path, path information, and query string information. (Inherited from HttpContextBase.)
Public method | RewritePath(String, String, String, Boolean) | When overridden in a derived class, rewrites the URL by using the specified path, path information, query string information, and a value that specifies whether the client file path is set to the rewrite path. (Inherited from HttpContextBase.)
Public method | SetSessionStateBehavior | When overridden in a derived class, sets the type of session state behavior that is required to support an HTTP request. (Inherited from HttpContextBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SAMLHttpContext Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Class

Provides a mechanism for receiving a SAML protocol message through a non-standard HTTP request.
Inheritance Hierarchy
SystemObject
System.WebHttpRequestBase
ComponentSpace.SAML2.UtilitySAMLHttpRequest

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SAMLHttpRequest : HttpRequestBase
Public Class SAMLHttpRequest
    Inherits HttpRequestBase
public ref class SAMLHttpRequest : public HttpRequestBase
type SAMLHttpRequest =
    class
        inherit HttpRequestBase
    end

The SAMLHttpRequest type exposes the following members.

Constructors
 | Name | Description
Public method | SAMLHttpRequest(String) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Redirect binding.
Public method | SAMLHttpRequest(String, String) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Post binding.
Public method | SAMLHttpRequest(XmlElement, String) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Post binding.
Public method | SAMLHttpRequest(String, String, Boolean) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Post binding.
Public method | SAMLHttpRequest(XmlElement, String, Boolean) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Post binding.
Public method | SAMLHttpRequest(XmlElement, String, AsymmetricAlgorithm, String) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Redirect binding.
Public method | SAMLHttpRequest(XmlElement, String, Boolean, AsymmetricAlgorithm, String) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Redirect binding.
Top
Properties
 | Name | Description
Public property | AcceptTypes | When overridden in a derived class, gets an array of client-supported MIME accept types. (Inherited from HttpRequestBase.)
Public property | AnonymousID | When overridden in a derived class, gets the anonymous identifier for the user, if it is available. (Inherited from HttpRequestBase.)
Public property | ApplicationPath | When overridden in a derived class, gets the virtual root path of the ASP.NET application on the server. (Inherited from HttpRequestBase.)
Public property | AppRelativeCurrentExecutionFilePath | When overridden in a derived class, gets the virtual path of the application root and makes it relative by using the tilde (~) notation for the application root (as in "~/page.aspx"). (Inherited from HttpRequestBase.)
Public property | Browser | When overridden in a derived class, gets information about the requesting client's browser capabilities. (Inherited from HttpRequestBase.)
Public property | ClientCertificate | When overridden in a derived class, gets the current request's client security certificate. (Inherited from HttpRequestBase.)
Public property | ContentEncoding | When overridden in a derived class, gets or sets the character set of the data that is provided by the client. (Inherited from HttpRequestBase.)
Public property | ContentLength | Gets the content length of the HTTP request used to receive the SAML message. (Overrides HttpRequestBaseContentLength.)
Public property | ContentType | When overridden in a derived class, gets or sets the MIME content type of the request. (Inherited from HttpRequestBase.)
Public property | Cookies | When overridden in a derived class, gets the collection of cookies that were sent by the client. (Inherited from HttpRequestBase.)
Public property | CurrentExecutionFilePath | When overridden in a derived class, gets the virtual path of the current request. (Inherited from HttpRequestBase.)
Public property | FilePath | When overridden in a derived class, gets the virtual path of the current request. (Inherited from HttpRequestBase.)
Public property | Files | When overridden in a derived class, gets the collection of files that were uploaded by the client, in multipart MIME format. (Inherited from HttpRequestBase.)
Public property | Filter | When overridden in a derived class, gets or sets the filter to use when the current input stream is being read. (Inherited from HttpRequestBase.)
Public property | Form | Gets the form variables used to receive the SAML message. (Overrides HttpRequestBaseForm.)
Public property | Headers | When overridden in a derived class, gets the collection of HTTP headers that were sent by the client. (Inherited from HttpRequestBase.)
Public property | HttpChannelBinding | When overridden in a derived class, gets the ChannelBinding object of the current HttpWorkerRequest instance. (Inherited from HttpRequestBase.)
Public property | HttpMethod | Gets the HTTP method (Get or Post) used to receive the SAML message. (Overrides HttpRequestBaseHttpMethod.)
Public property | InputStream | Gets the input stream used to receive the SAML message. (Overrides HttpRequestBaseInputStream.)
Public property | IsAuthenticated | When overridden in a derived class, gets a value that indicates whether the request has been authenticated. (Inherited from HttpRequestBase.)
Public property | IsLocal | When overridden in a derived class, gets a value that indicates whether the request is from the local computer. (Inherited from HttpRequestBase.)
Public property | IsSecureConnection | When overridden in a derived class, gets a value that indicates whether the HTTP connection uses secure sockets (HTTPS protocol). (Inherited from HttpRequestBase.)
Public property | Item | When overridden in a derived class, gets the specified object from the Cookies, Form, QueryString, or ServerVariables collections. (Inherited from HttpRequestBase.)
Public property | LogonUserIdentity | When overridden in a derived class, gets the WindowsIdentity type for the current user. (Inherited from HttpRequestBase.)
Public property | Params | When overridden in a derived class, gets a combined collection of QueryString, Form, ServerVariables, and Cookies items. (Inherited from HttpRequestBase.)
Public property | Path | Gets the path used to receive the SAML message. (Overrides HttpRequestBasePath.)
Public property | PathInfo | When overridden in a derived class, gets additional path information for a resource that has a URL extension. (Inherited from HttpRequestBase.)
Public property | PhysicalApplicationPath | When overridden in a derived class, gets the physical file-system path of the current application's root directory. (Inherited from HttpRequestBase.)
Public property | PhysicalPath | When overridden in a derived class, gets the physical file-system path of the requested resource. (Inherited from HttpRequestBase.)
Public property | QueryString | Gets the query string variables used to receive the SAML message. (Overrides HttpRequestBaseQueryString.)
Public property | RawUrl | Gets the raw URL used to receive the SAML message. (Overrides HttpRequestBaseRawUrl.)
Public property | RequestContext | When overridden in a derived class, gets the RequestContext instance of the current request. (Inherited from HttpRequestBase.)
Public property | RequestType | Gets the request type (Get or Post) used to receive the SAML message. (Overrides HttpRequestBaseRequestType.)
Public property | ServerVariables | Gets the server variables used to receive the SAML message. (Overrides HttpRequestBaseServerVariables.)
Public property | TotalBytes | When overridden in a derived class, gets the number of bytes in the current input stream. (Inherited from HttpRequestBase.)
Public property | Url | Gets the URL used to receive the SAML message. (Overrides HttpRequestBaseUrl.)
Public property | UrlReferrer | When overridden in a derived class, gets information about the URL of the client request that linked to the current URL. (Inherited from HttpRequestBase.)
Public property | UserAgent | When overridden in a derived class, gets the complete user-agent string of the client. (Inherited from HttpRequestBase.)
Public property | UserHostAddress | When overridden in a derived class, gets the IP host address of the client. (Inherited from HttpRequestBase.)
Public property | UserHostName | When overridden in a derived class, gets the DNS name of the client. (Inherited from HttpRequestBase.)
Public property | UserLanguages | When overridden in a derived class, gets a sorted array of client language preferences. (Inherited from HttpRequestBase.)
Top
Methods
 | Name | Description
Public method | BinaryRead | When overridden in a derived class, performs a binary read of a specified number of bytes from the current input stream. (Inherited from HttpRequestBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MapImageCoordinates | When overridden in a derived class, maps an incoming image-field form parameter to appropriate x-coordinate and y-coordinate values. (Inherited from HttpRequestBase.)
Public method | MapPath(String) | When overridden in a derived class, maps the specified virtual path to a physical path on the server. (Inherited from HttpRequestBase.)
Public method | MapPath(String, String, Boolean) | When overridden in a derived class, maps the specified virtual path to a physical path on the server. (Inherited from HttpRequestBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveAs | When overridden in a derived class, saves an HTTP request to disk. (Inherited from HttpRequestBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateInput | When overridden in a derived class, causes validation to occur for the collections that are accessed through the Cookies, Form, and QueryString properties. (Inherited from HttpRequestBase.)
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Constructor

Overload List
 | Name | Description
Public method | SAMLHttpRequest(String) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Redirect binding.
Public method | SAMLHttpRequest(String, String) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Post binding.
Public method | SAMLHttpRequest(XmlElement, String) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Post binding.
Public method | SAMLHttpRequest(String, String, Boolean) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Post binding.
Public method | SAMLHttpRequest(XmlElement, String, Boolean) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Post binding.
Public method | SAMLHttpRequest(XmlElement, String, AsymmetricAlgorithm, String) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Redirect binding.
Public method | SAMLHttpRequest(XmlElement, String, Boolean, AsymmetricAlgorithm, String) | Initializes a new instance of the SAMLHttpRequest class. The SAML message is received using the HTTP-Redirect binding.
Top
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Constructor (String)

Initializes a new instance of the SAMLHttpRequest class.

The SAML message is received using the HTTP-Redirect binding.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpRequest(
    string url
)
Public Sub New (
    url As String
)
public:
SAMLHttpRequest(
    String^ url
)
new :
        url : string -> SAMLHttpRequest

Parameters

url
Type: SystemString
The URL including the SAML query string parameters.
See Also

Reference

SAMLHttpRequest Class
SAMLHttpRequest Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Constructor (String, String)

Initializes a new instance of the SAMLHttpRequest class.

The SAML message is received using the HTTP-Post binding.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpRequest(
    string samlMessage,
    string relayState
)
Public Sub New (
    samlMessage As String,
    relayState As String
)
public:
SAMLHttpRequest(
    String^ samlMessage,
    String^ relayState
)
new :
        samlMessage : string *
        relayState : string -> SAMLHttpRequest

Parameters

samlMessage
Type: SystemString
The SAML message base-64 encoded string.
relayState
Type: SystemString
The relay state or null if none
See Also

Reference

SAMLHttpRequest Class
SAMLHttpRequest Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Constructor (XmlElement, String)

Initializes a new instance of the SAMLHttpRequest class.

The SAML message is received using the HTTP-Post binding.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpRequest(
    XmlElement samlMessage,
    string relayState
)
Public Sub New (
    samlMessage As XmlElement,
    relayState As String
)
public:
SAMLHttpRequest(
    XmlElement^ samlMessage,
    String^ relayState
)
new :
        samlMessage : XmlElement *
        relayState : string -> SAMLHttpRequest

Parameters

samlMessage
Type: System.XmlXmlElement
The SAML message XML.
relayState
Type: SystemString
The relay state or null if none
See Also

Reference

SAMLHttpRequest Class
SAMLHttpRequest Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Constructor (String, String, Boolean)

Initializes a new instance of the SAMLHttpRequest class.

The SAML message is received using the HTTP-Post binding.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpRequest(
    string samlMessage,
    string relayState,
    bool isSAMLRequest
)
Public Sub New (
    samlMessage As String,
    relayState As String,
    isSAMLRequest As Boolean
)
public:
SAMLHttpRequest(
    String^ samlMessage,
    String^ relayState,
    bool isSAMLRequest
)
new :
        samlMessage : string *
        relayState : string *
        isSAMLRequest : bool -> SAMLHttpRequest

Parameters

samlMessage
Type: SystemString
The SAML message base-64 encoded string.
relayState
Type: SystemString
The relay state or null if none
isSAMLRequest
Type: SystemBoolean
The flag indicating whether this is a SAML request or response.
See Also

Reference

SAMLHttpRequest Class
SAMLHttpRequest Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Constructor (XmlElement, String, Boolean)

Initializes a new instance of the SAMLHttpRequest class.

The SAML message is received using the HTTP-Post binding.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpRequest(
    XmlElement samlMessage,
    string relayState,
    bool isSAMLRequest
)
Public Sub New (
    samlMessage As XmlElement,
    relayState As String,
    isSAMLRequest As Boolean
)
public:
SAMLHttpRequest(
    XmlElement^ samlMessage,
    String^ relayState,
    bool isSAMLRequest
)
new :
        samlMessage : XmlElement *
        relayState : string *
        isSAMLRequest : bool -> SAMLHttpRequest

Parameters

samlMessage
Type: System.XmlXmlElement
The SAML message XML.
relayState
Type: SystemString
The relay state or null if none
isSAMLRequest
Type: SystemBoolean
The flag indicating whether this is a SAML request or response.
See Also

Reference

SAMLHttpRequest Class
SAMLHttpRequest Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Constructor (XmlElement, String, AsymmetricAlgorithm, String)

Initializes a new instance of the SAMLHttpRequest class.

The SAML message is received using the HTTP-Redirect binding.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpRequest(
    XmlElement samlMessage,
    string relayState,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Sub New (
    samlMessage As XmlElement,
    relayState As String,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
SAMLHttpRequest(
    XmlElement^ samlMessage,
    String^ relayState,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
new :
        samlMessage : XmlElement *
        relayState : string *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> SAMLHttpRequest

Parameters

samlMessage
Type: System.XmlXmlElement
The SAML message XML.
relayState
Type: SystemString
The relay state or null if none
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
See Also

Reference

SAMLHttpRequest Class
SAMLHttpRequest Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Constructor (XmlElement, String, Boolean, AsymmetricAlgorithm, String)

Initializes a new instance of the SAMLHttpRequest class.

The SAML message is received using the HTTP-Redirect binding.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpRequest(
    XmlElement samlMessage,
    string relayState,
    bool isSAMLRequest,
    AsymmetricAlgorithm key,
    string signatureAlgorithm
)
Public Sub New (
    samlMessage As XmlElement,
    relayState As String,
    isSAMLRequest As Boolean,
    key As AsymmetricAlgorithm,
    signatureAlgorithm As String
)
public:
SAMLHttpRequest(
    XmlElement^ samlMessage,
    String^ relayState,
    bool isSAMLRequest,
    AsymmetricAlgorithm^ key,
    String^ signatureAlgorithm
)
new :
        samlMessage : XmlElement *
        relayState : string *
        isSAMLRequest : bool *
        key : AsymmetricAlgorithm *
        signatureAlgorithm : string -> SAMLHttpRequest

Parameters

samlMessage
Type: System.XmlXmlElement
The SAML message XML.
relayState
Type: SystemString
The relay state or null if none
isSAMLRequest
Type: SystemBoolean
The flag indicating whether this is a SAML request or response.
key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key to generate the signature or null if no signature is to be generated.
signatureAlgorithm
Type: SystemString
The signature algorithm or null to default to http://www.w3.org/2001/04/xmldsig-more#rsa-sha256.
See Also

Reference

SAMLHttpRequest Class
SAMLHttpRequest Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Properties

The SAMLHttpRequest type exposes the following members.

Properties
 | Name | Description
Public property | AcceptTypes | When overridden in a derived class, gets an array of client-supported MIME accept types. (Inherited from HttpRequestBase.)
Public property | AnonymousID | When overridden in a derived class, gets the anonymous identifier for the user, if it is available. (Inherited from HttpRequestBase.)
Public property | ApplicationPath | When overridden in a derived class, gets the virtual root path of the ASP.NET application on the server. (Inherited from HttpRequestBase.)
Public property | AppRelativeCurrentExecutionFilePath | When overridden in a derived class, gets the virtual path of the application root and makes it relative by using the tilde (~) notation for the application root (as in "~/page.aspx"). (Inherited from HttpRequestBase.)
Public property | Browser | When overridden in a derived class, gets information about the requesting client's browser capabilities. (Inherited from HttpRequestBase.)
Public property | ClientCertificate | When overridden in a derived class, gets the current request's client security certificate. (Inherited from HttpRequestBase.)
Public property | ContentEncoding | When overridden in a derived class, gets or sets the character set of the data that is provided by the client. (Inherited from HttpRequestBase.)
Public property | ContentLength | Gets the content length of the HTTP request used to receive the SAML message. (Overrides HttpRequestBaseContentLength.)
Public property | ContentType | When overridden in a derived class, gets or sets the MIME content type of the request. (Inherited from HttpRequestBase.)
Public property | Cookies | When overridden in a derived class, gets the collection of cookies that were sent by the client. (Inherited from HttpRequestBase.)
Public property | CurrentExecutionFilePath | When overridden in a derived class, gets the virtual path of the current request. (Inherited from HttpRequestBase.)
Public property | FilePath | When overridden in a derived class, gets the virtual path of the current request. (Inherited from HttpRequestBase.)
Public property | Files | When overridden in a derived class, gets the collection of files that were uploaded by the client, in multipart MIME format. (Inherited from HttpRequestBase.)
Public property | Filter | When overridden in a derived class, gets or sets the filter to use when the current input stream is being read. (Inherited from HttpRequestBase.)
Public property | Form | Gets the form variables used to receive the SAML message. (Overrides HttpRequestBaseForm.)
Public property | Headers | When overridden in a derived class, gets the collection of HTTP headers that were sent by the client. (Inherited from HttpRequestBase.)
Public property | HttpChannelBinding | When overridden in a derived class, gets the ChannelBinding object of the current HttpWorkerRequest instance. (Inherited from HttpRequestBase.)
Public property | HttpMethod | Gets the HTTP method (Get or Post) used to receive the SAML message. (Overrides HttpRequestBaseHttpMethod.)
Public property | InputStream | Gets the input stream used to receive the SAML message. (Overrides HttpRequestBaseInputStream.)
Public property | IsAuthenticated | When overridden in a derived class, gets a value that indicates whether the request has been authenticated. (Inherited from HttpRequestBase.)
Public property | IsLocal | When overridden in a derived class, gets a value that indicates whether the request is from the local computer. (Inherited from HttpRequestBase.)
Public property | IsSecureConnection | When overridden in a derived class, gets a value that indicates whether the HTTP connection uses secure sockets (HTTPS protocol). (Inherited from HttpRequestBase.)
Public property | Item | When overridden in a derived class, gets the specified object from the Cookies, Form, QueryString, or ServerVariables collections. (Inherited from HttpRequestBase.)
Public property | LogonUserIdentity | When overridden in a derived class, gets the WindowsIdentity type for the current user. (Inherited from HttpRequestBase.)
Public property | Params | When overridden in a derived class, gets a combined collection of QueryString, Form, ServerVariables, and Cookies items. (Inherited from HttpRequestBase.)
Public property | Path | Gets the path used to receive the SAML message. (Overrides HttpRequestBasePath.)
Public property | PathInfo | When overridden in a derived class, gets additional path information for a resource that has a URL extension. (Inherited from HttpRequestBase.)
Public property | PhysicalApplicationPath | When overridden in a derived class, gets the physical file-system path of the current application's root directory. (Inherited from HttpRequestBase.)
Public property | PhysicalPath | When overridden in a derived class, gets the physical file-system path of the requested resource. (Inherited from HttpRequestBase.)
Public property | QueryString | Gets the query string variables used to receive the SAML message. (Overrides HttpRequestBaseQueryString.)
Public property | RawUrl | Gets the raw URL used to receive the SAML message. (Overrides HttpRequestBaseRawUrl.)
Public property | RequestContext | When overridden in a derived class, gets the RequestContext instance of the current request. (Inherited from HttpRequestBase.)
Public property | RequestType | Gets the request type (Get or Post) used to receive the SAML message. (Overrides HttpRequestBaseRequestType.)
Public property | ServerVariables | Gets the server variables used to receive the SAML message. (Overrides HttpRequestBaseServerVariables.)
Public property | TotalBytes | When overridden in a derived class, gets the number of bytes in the current input stream. (Inherited from HttpRequestBase.)
Public property | Url | Gets the URL used to receive the SAML message. (Overrides HttpRequestBaseUrl.)
Public property | UrlReferrer | When overridden in a derived class, gets information about the URL of the client request that linked to the current URL. (Inherited from HttpRequestBase.)
Public property | UserAgent | When overridden in a derived class, gets the complete user-agent string of the client. (Inherited from HttpRequestBase.)
Public property | UserHostAddress | When overridden in a derived class, gets the IP host address of the client. (Inherited from HttpRequestBase.)
Public property | UserHostName | When overridden in a derived class, gets the DNS name of the client. (Inherited from HttpRequestBase.)
Public property | UserLanguages | When overridden in a derived class, gets a sorted array of client language preferences. (Inherited from HttpRequestBase.)
Top
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest.ContentLength Property

SAMLHttpRequestContentLength Property

Gets the content length of the HTTP request used to receive the SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override int ContentLength { get; }
Public Overrides ReadOnly Property ContentLength As Integer
    Get
public:
virtual property int ContentLength {
    int get () override;
}
abstract ContentLength : int with get
override ContentLength : int with get

Property Value

Type: Int32
The content length of the HTTP request used to receive the SAML message.
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest.Form Property

SAMLHttpRequestForm Property

Gets the form variables used to receive the SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override NameValueCollection Form { get; }
Public Overrides ReadOnly Property Form As NameValueCollection
    Get
public:
virtual property NameValueCollection^ Form {
    NameValueCollection^ get () override;
}
abstract Form : NameValueCollection with get
override Form : NameValueCollection with get

Property Value

Type: NameValueCollection
The form variables used to receive the SAML message.
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest.HttpMethod Property

SAMLHttpRequestHttpMethod Property

Gets the HTTP method (Get or Post) used to receive the SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string HttpMethod { get; }
Public Overrides ReadOnly Property HttpMethod As String
    Get
public:
virtual property String^ HttpMethod {
    String^ get () override;
}
abstract HttpMethod : string with get
override HttpMethod : string with get

Property Value

Type: String
The HTTP method used to receive the SAML message.
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest.InputStream Property

SAMLHttpRequestInputStream Property

Gets the input stream used to receive the SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override Stream InputStream { get; }
Public Overrides ReadOnly Property InputStream As Stream
    Get
public:
virtual property Stream^ InputStream {
    Stream^ get () override;
}
abstract InputStream : Stream with get
override InputStream : Stream with get

Property Value

Type: Stream
The input stream used to receive the SAML message.
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest.Path Property

SAMLHttpRequestPath Property

Gets the path used to receive the SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string Path { get; }
Public Overrides ReadOnly Property Path As String
    Get
public:
virtual property String^ Path {
    String^ get () override;
}
abstract Path : string with get
override Path : string with get

Property Value

Type: String
The path used to receive the SAML message.
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest.QueryString Property

SAMLHttpRequestQueryString Property

Gets the query string variables used to receive the SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override NameValueCollection QueryString { get; }
Public Overrides ReadOnly Property QueryString As NameValueCollection
    Get
public:
virtual property NameValueCollection^ QueryString {
    NameValueCollection^ get () override;
}
abstract QueryString : NameValueCollection with get
override QueryString : NameValueCollection with get

Property Value

Type: NameValueCollection
The query string variables used to receive the SAML message.
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest.RawUrl Property

SAMLHttpRequestRawUrl Property

Gets the raw URL used to receive the SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string RawUrl { get; }
Public Overrides ReadOnly Property RawUrl As String
    Get
public:
virtual property String^ RawUrl {
    String^ get () override;
}
abstract RawUrl : string with get
override RawUrl : string with get

Property Value

Type: String
The raw URL used to receive the SAML message.
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest.RequestType Property

SAMLHttpRequestRequestType Property

Gets the request type (Get or Post) used to receive the SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string RequestType { get; set; }
Public Overrides Property RequestType As String
    Get
    Set
public:
virtual property String^ RequestType {
    String^ get () override;
    void set (String^ value) override;
}
abstract RequestType : string with get, set
override RequestType : string with get, set

Property Value

Type: String
The request type used to receive the SAML message.
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest.ServerVariables Property

SAMLHttpRequestServerVariables Property

Gets the server variables used to receive the SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override NameValueCollection ServerVariables { get; }
Public Overrides ReadOnly Property ServerVariables As NameValueCollection
    Get
public:
virtual property NameValueCollection^ ServerVariables {
    NameValueCollection^ get () override;
}
abstract ServerVariables : NameValueCollection with get
override ServerVariables : NameValueCollection with get

Property Value

Type: NameValueCollection
The server variables used to receive the SAML message.
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest.Url Property

SAMLHttpRequestUrl Property

Gets the URL used to receive the SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override Uri Url { get; }
Public Overrides ReadOnly Property Url As Uri
    Get
public:
virtual property Uri^ Url {
    Uri^ get () override;
}
abstract Url : Uri with get
override Url : Uri with get

Property Value

Type: Uri
The URL used to receive the SAML message.
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpRequest Methods

The SAMLHttpRequest type exposes the following members.

Methods
 | Name | Description
Public method | BinaryRead | When overridden in a derived class, performs a binary read of a specified number of bytes from the current input stream. (Inherited from HttpRequestBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MapImageCoordinates | When overridden in a derived class, maps an incoming image-field form parameter to appropriate x-coordinate and y-coordinate values. (Inherited from HttpRequestBase.)
Public method | MapPath(String) | When overridden in a derived class, maps the specified virtual path to a physical path on the server. (Inherited from HttpRequestBase.)
Public method | MapPath(String, String, Boolean) | When overridden in a derived class, maps the specified virtual path to a physical path on the server. (Inherited from HttpRequestBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveAs | When overridden in a derived class, saves an HTTP request to disk. (Inherited from HttpRequestBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateInput | When overridden in a derived class, causes validation to occur for the collections that are accessed through the Cookies, Form, and QueryString properties. (Inherited from HttpRequestBase.)
Top
See Also

Reference

SAMLHttpRequest Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse Class

Provides a mechanism for sending a SAML protocol message through a non-standard HTTP response.
Inheritance Hierarchy
SystemObject
System.WebHttpResponseBase
ComponentSpace.SAML2.UtilitySAMLHttpResponse

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SAMLHttpResponse : HttpResponseBase
Public Class SAMLHttpResponse
    Inherits HttpResponseBase
public ref class SAMLHttpResponse : public HttpResponseBase
type SAMLHttpResponse =
    class
        inherit HttpResponseBase
    end

The SAMLHttpResponse type exposes the following members.

Constructors
 | Name | Description
Public method | SAMLHttpResponse | Initializes a new instance of the SAMLHttpResponse class.
Public method | SAMLHttpResponse(Stream) | Initializes a new instance of the SAMLHttpResponse class.
Top
Properties
 | Name | Description
Public property | Buffer | When overridden in a derived class, gets or sets a value that indicates whether to buffer output and send it after the complete response has finished processing. (Inherited from HttpResponseBase.)
Public property | BufferOutput | When overridden in a derived class, gets or sets a value that indicates whether to buffer output and send it after the complete page has finished processing. (Inherited from HttpResponseBase.)
Public property | Cache | When overridden in a derived class, gets the caching policy (such as expiration time, privacy settings, and vary clauses) of the current Web page. (Inherited from HttpResponseBase.)
Public property | CacheControl | When overridden in a derived class, gets or sets the Cache-Control HTTP header that matches one of the HttpCacheability enumeration values. (Inherited from HttpResponseBase.)
Public property | Charset | When overridden in a derived class, gets or sets the HTTP character set of the current response. (Inherited from HttpResponseBase.)
Public property | ContentEncoding | When overridden in a derived class, gets or sets the content encoding of the current response. (Inherited from HttpResponseBase.)
Public property | ContentType | When overridden in a derived class, gets or sets the HTTP MIME type of the current response. (Inherited from HttpResponseBase.)
Public property | Cookies | When overridden in a derived class, gets the response cookie collection. (Inherited from HttpResponseBase.)
Public property | Expires | When overridden in a derived class, gets or sets the number of minutes before a page that is cached on the client or proxy expires. If the user returns to the same page before it expires, the cached version is displayed. Expires is provided for compatibility with earlier versions of Active Server Pages (ASP). (Inherited from HttpResponseBase.)
Public property | ExpiresAbsolute | When overridden in a derived class, gets or sets the absolute date and time at which cached information expires in the cache. ExpiresAbsolute is provided for compatibility with earlier versions of Active Server Pages (ASP). (Inherited from HttpResponseBase.)
Public property | Filter | When overridden in a derived class, gets or sets a filter object that is used to modify the HTTP entity body before transmission. (Inherited from HttpResponseBase.)
Public property | HeaderEncoding | When overridden in a derived class, gets or sets the encoding for the header of the current response. (Inherited from HttpResponseBase.)
Public property | Headers | When overridden in a derived class, gets the collection of response headers. (Inherited from HttpResponseBase.)
Public property | IsClientConnected | When overridden in a derived class, gets a value that indicates whether the client is connected to the server. (Inherited from HttpResponseBase.)
Public property | IsRequestBeingRedirected | When overridden in a derived class, gets a value that indicates whether the client is being redirected to a new location. (Inherited from HttpResponseBase.)
Public property | Output | When overridden in a derived class, gets the object that enables text output to the HTTP response stream. (Inherited from HttpResponseBase.)
Public property | OutputStream | Gets the output stream used to send the SAML message. For the SAML HTTP-Post binding, the output stream contains the encoded SAML message wrapped in an HTML form. (Overrides HttpResponseBaseOutputStream.)
Public property | RedirectLocation | When overridden in a derived class, gets or sets the value of the HTTP Location header. (Inherited from HttpResponseBase.)
Public property | Status | When overridden in a derived class, gets or sets the Status value that is returned to the client. (Inherited from HttpResponseBase.)
Public property | StatusCode | When overridden in a derived class, gets or sets the HTTP status code of the output that is returned to the client. (Inherited from HttpResponseBase.)
Public property | StatusDescription | When overridden in a derived class, gets or sets the HTTP status message of the output that is returned to the client. (Inherited from HttpResponseBase.)
Public property | SubStatusCode | When overridden in a derived class, gets or sets a value that qualifies the status code of the response. (Inherited from HttpResponseBase.)
Public property | SuppressContent | When overridden in a derived class, gets or sets a value that indicates whether to send HTTP content to the client. (Inherited from HttpResponseBase.)
Public property | TrySkipIisCustomErrors | When overridden in a derived class, gets or sets a value that specifies whether IIS 7.0 custom errors are disabled. (Inherited from HttpResponseBase.)
Public property | URL | Gets the redirect URL. For the SAML HTTP-Redirect binding, the URL includes the encoded SAML message.
Top
Methods
 | Name | Description
Public method | AddCacheDependency | When overridden in a derived class, associates cache dependencies with the response that enable the response to be invalidated if it is cached and if the specified dependencies change. (Inherited from HttpResponseBase.)
Public method | AddCacheItemDependencies(ArrayList) | When overridden in a derived class, makes the validity of a cached response dependent on the specified items in the cache. (Inherited from HttpResponseBase.)
Public method | AddCacheItemDependencies(String) | When overridden in a derived class, makes the validity of a cached item dependent on the specified items in the cache. (Inherited from HttpResponseBase.)
Public method | AddCacheItemDependency | When overridden in a derived class, makes the validity of a cached response dependent on the specified item in the cache. (Inherited from HttpResponseBase.)
Public method | AddFileDependencies(ArrayList) | When overridden in a derived class, adds file names to the collection of file names on which the current response is dependent. (Inherited from HttpResponseBase.)
Public method | AddFileDependencies(String) | When overridden in a derived class, adds an array of file names to the collection of file names on which the current response is dependent. (Inherited from HttpResponseBase.)
Public method | AddFileDependency | When overridden in a derived class, adds a single file name to the collection of file names on which the current response is dependent. (Inherited from HttpResponseBase.)
Public method | AddHeader | When overridden in a derived class, adds an HTTP header to the current response. This method is provided for compatibility with earlier versions of ASP. (Inherited from HttpResponseBase.)
Public method | AppendCookie | When overridden in a derived class, adds an HTTP cookie to the HTTP response cookie collection. (Inherited from HttpResponseBase.)
Public method | AppendHeader | When overridden in a derived class, adds an HTTP header to the current response. (Inherited from HttpResponseBase.)
Public method | AppendToLog | When overridden in a derived class, adds custom log information to the Internet Information Services (IIS) log file. (Inherited from HttpResponseBase.)
Public method | ApplyAppPathModifier | When overridden in a derived class, adds a session ID to the virtual path if the session is using Cookieless session state, and returns the combined path. (Inherited from HttpResponseBase.)
Public method | BinaryWrite | When overridden in a derived class, writes a string of binary characters to the HTTP output stream. (Inherited from HttpResponseBase.)
Public method | Clear | When overridden in a derived class, clears all headers and content output from the current response. (Inherited from HttpResponseBase.)
Public method | ClearContent | When overridden in a derived class, clears all content from the current response. (Inherited from HttpResponseBase.)
Public method | ClearHeaders | When overridden in a derived class, clears all headers from the current response. (Inherited from HttpResponseBase.)
Public method | Close | When overridden in a derived class, closes the socket connection to a client. (Inherited from HttpResponseBase.)
Public method | DisableKernelCache | When overridden in a derived class, disables kernel caching for the current response. (Inherited from HttpResponseBase.)
Public method | End | When overridden in a derived class, sends all currently buffered output to the client, stops execution of the requested process, and raises the EndRequest event. (Inherited from HttpResponseBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, sends all currently buffered output to the client. (Inherited from HttpResponseBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOutputAsString | Reads the output stream as a string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pics | When overridden in a derived class, appends an HTTP PICS-Label header to the current response. (Inherited from HttpResponseBase.)
Public method | Redirect(String) | When overridden in a derived class, redirects a request to the specified URL. (Inherited from HttpResponseBase.)
Public method | Redirect(String, Boolean) | Redirects to the specified URL. (Overrides HttpResponseBaseRedirect(String, Boolean).)
Public method | RedirectPermanent(String) | When overridden in a derived class, performs a permanent redirect from the requested URL to the specified URL. (Inherited from HttpResponseBase.)
Public method | RedirectPermanent(String, Boolean) | When overridden in a derived class, performs a permanent redirect from the requested URL to the specified URL, and provides the option to complete the response. (Inherited from HttpResponseBase.)
Public method | RedirectToRoute(Object) | When overridden in a derived class, redirects the request to a new URL by using route parameter values. (Inherited from HttpResponseBase.)
Public method | RedirectToRoute(String) | When overridden in a derived class, redirects the request to a new URL by using a route name. (Inherited from HttpResponseBase.)
Public method | RedirectToRoute(RouteValueDictionary) | When overridden in a derived class, redirects the request to a new URL by using route parameter values. (Inherited from HttpResponseBase.)
Public method | RedirectToRoute(String, Object) | When overridden in a derived class, redirects the request to a new URL by using route parameter values and a route name. (Inherited from HttpResponseBase.)
Public method | RedirectToRoute(String, RouteValueDictionary) | When overridden in a derived class, redirects the request to a new URL by using route parameter values and a route name. (Inherited from HttpResponseBase.)
Public method | RedirectToRoutePermanent(Object) | When overridden in a derived class, performs a permanent redirection from the requested URL to a new URL by using route parameter values. (Inherited from HttpResponseBase.)
Public method | RedirectToRoutePermanent(String) | When overridden in a derived class, performs a permanent redirection from the requested URL to a new URL by using a route name. (Inherited from HttpResponseBase.)
Public method | RedirectToRoutePermanent(RouteValueDictionary) | When overridden in a derived class, performs a permanent redirection from the requested URL to a new URL by using route parameter values. (Inherited from HttpResponseBase.)
Public method | RedirectToRoutePermanent(String, Object) | When overridden in a derived class, performs a permanent redirection from the requested URL to a new URL by using the route parameter values and the name of the route that correspond to the new URL. (Inherited from HttpResponseBase.)
Public method | RedirectToRoutePermanent(String, RouteValueDictionary) | When overridden in a derived class, performs a permanent redirection from the requested URL to a new URL by using route parameter values and a route name. (Inherited from HttpResponseBase.)
Public method | RemoveOutputCacheItem(String) | When overridden in a derived class, removes from the cache all cached items that are associated with the specified path. (Inherited from HttpResponseBase.)
Public method | RemoveOutputCacheItem(String, String) | When overridden in a derived class, uses the specified output-cache provider to remove all output-cache artifacts that are associated with the specified path. (Inherited from HttpResponseBase.)
Public method | SetCookie | When overridden in a derived class, updates an existing cookie in the cookie collection. (Inherited from HttpResponseBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransmitFile(String) | When overridden in a derived class, writes the specified file to the HTTP response output stream, without buffering it in memory. (Inherited from HttpResponseBase.)
Public method | TransmitFile(String, Int64, Int64) | When overridden in a derived class, writes the specified part of a file to the HTTP response output stream, without buffering it in memory. (Inherited from HttpResponseBase.)
Public method | Write(Char) | When overridden in a derived class, writes a character to an HTTP response output stream. (Inherited from HttpResponseBase.)
Public method | Write(Object) | When overridden in a derived class, writes the specified object to the HTTP response stream. (Inherited from HttpResponseBase.)
Public method | Write(String) | When overridden in a derived class, writes the specified string to the HTTP response output stream. (Inherited from HttpResponseBase.)
Public method | Write(Char, Int32, Int32) | When overridden in a derived class, writes the specified array of characters to the HTTP response output stream. (Inherited from HttpResponseBase.)
Public method | WriteFile(String) | When overridden in a derived class, writes the contents of the specified file to the HTTP response output stream as a file block. (Inherited from HttpResponseBase.)
Public method | WriteFile(String, Boolean) | When overridden in a derived class, writes the contents of the specified file to the HTTP response output stream and specifies whether the content is written as a memory block. (Inherited from HttpResponseBase.)
Public method | WriteFile(String, Int64, Int64) | When overridden in a derived class, writes the specified file to the HTTP response output stream. (Inherited from HttpResponseBase.)
Public method | WriteFile(IntPtr, Int64, Int64) | When overridden in a derived class, writes the specified file to the HTTP response output stream. (Inherited from HttpResponseBase.)
Public method | WriteSubstitution | When overridden in a derived class, inserts substitution blocks into the response, which enables dynamic generation of regions for cached output responses. (Inherited from HttpResponseBase.)
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse Constructor

Overload List
 | Name | Description
Public method | SAMLHttpResponse | Initializes a new instance of the SAMLHttpResponse class.
Public method | SAMLHttpResponse(Stream) | Initializes a new instance of the SAMLHttpResponse class.
Top
See Also

Reference

SAMLHttpResponse Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse Constructor

Initializes a new instance of the SAMLHttpResponse class.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpResponse()
Public Sub New
public:
SAMLHttpResponse()
new : unit -> SAMLHttpResponse
See Also

Reference

SAMLHttpResponse Class
SAMLHttpResponse Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse Constructor (Stream)

Initializes a new instance of the SAMLHttpResponse class.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpResponse(
    Stream outputStream
)
Public Sub New (
    outputStream As Stream
)
public:
SAMLHttpResponse(
    Stream^ outputStream
)
new :
        outputStream : Stream -> SAMLHttpResponse

Parameters

outputStream
Type: System.IOStream
The stream used to output the SAML message.
See Also

Reference

SAMLHttpResponse Class
SAMLHttpResponse Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse Properties

The SAMLHttpResponse type exposes the following members.

Properties
 | Name | Description
Public property | Buffer | When overridden in a derived class, gets or sets a value that indicates whether to buffer output and send it after the complete response has finished processing. (Inherited from HttpResponseBase.)
Public property | BufferOutput | When overridden in a derived class, gets or sets a value that indicates whether to buffer output and send it after the complete page has finished processing. (Inherited from HttpResponseBase.)
Public property | Cache | When overridden in a derived class, gets the caching policy (such as expiration time, privacy settings, and vary clauses) of the current Web page. (Inherited from HttpResponseBase.)
Public property | CacheControl | When overridden in a derived class, gets or sets the Cache-Control HTTP header that matches one of the HttpCacheability enumeration values. (Inherited from HttpResponseBase.)
Public property | Charset | When overridden in a derived class, gets or sets the HTTP character set of the current response. (Inherited from HttpResponseBase.)
Public property | ContentEncoding | When overridden in a derived class, gets or sets the content encoding of the current response. (Inherited from HttpResponseBase.)
Public property | ContentType | When overridden in a derived class, gets or sets the HTTP MIME type of the current response. (Inherited from HttpResponseBase.)
Public property | Cookies | When overridden in a derived class, gets the response cookie collection. (Inherited from HttpResponseBase.)
Public property | Expires | When overridden in a derived class, gets or sets the number of minutes before a page that is cached on the client or proxy expires. If the user returns to the same page before it expires, the cached version is displayed. Expires is provided for compatibility with earlier versions of Active Server Pages (ASP). (Inherited from HttpResponseBase.)
Public property | ExpiresAbsolute | When overridden in a derived class, gets or sets the absolute date and time at which cached information expires in the cache. ExpiresAbsolute is provided for compatibility with earlier versions of Active Server Pages (ASP). (Inherited from HttpResponseBase.)
Public property | Filter | When overridden in a derived class, gets or sets a filter object that is used to modify the HTTP entity body before transmission. (Inherited from HttpResponseBase.)
Public property | HeaderEncoding | When overridden in a derived class, gets or sets the encoding for the header of the current response. (Inherited from HttpResponseBase.)
Public property | Headers | When overridden in a derived class, gets the collection of response headers. (Inherited from HttpResponseBase.)
Public property | IsClientConnected | When overridden in a derived class, gets a value that indicates whether the client is connected to the server. (Inherited from HttpResponseBase.)
Public property | IsRequestBeingRedirected | When overridden in a derived class, gets a value that indicates whether the client is being redirected to a new location. (Inherited from HttpResponseBase.)
Public property | Output | When overridden in a derived class, gets the object that enables text output to the HTTP response stream. (Inherited from HttpResponseBase.)
Public property | OutputStream | Gets the output stream used to send the SAML message. For the SAML HTTP-Post binding, the output stream contains the encoded SAML message wrapped in an HTML form. (Overrides HttpResponseBaseOutputStream.)
Public property | RedirectLocation | When overridden in a derived class, gets or sets the value of the HTTP Location header. (Inherited from HttpResponseBase.)
Public property | Status | When overridden in a derived class, gets or sets the Status value that is returned to the client. (Inherited from HttpResponseBase.)
Public property | StatusCode | When overridden in a derived class, gets or sets the HTTP status code of the output that is returned to the client. (Inherited from HttpResponseBase.)
Public property | StatusDescription | When overridden in a derived class, gets or sets the HTTP status message of the output that is returned to the client. (Inherited from HttpResponseBase.)
Public property | SubStatusCode | When overridden in a derived class, gets or sets a value that qualifies the status code of the response. (Inherited from HttpResponseBase.)
Public property | SuppressContent | When overridden in a derived class, gets or sets a value that indicates whether to send HTTP content to the client. (Inherited from HttpResponseBase.)
Public property | TrySkipIisCustomErrors | When overridden in a derived class, gets or sets a value that specifies whether IIS 7.0 custom errors are disabled. (Inherited from HttpResponseBase.)
Public property | URL | Gets the redirect URL. For the SAML HTTP-Redirect binding, the URL includes the encoded SAML message.
Top
See Also

Reference

SAMLHttpResponse Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse.OutputStream Property

SAMLHttpResponseOutputStream Property

Gets the output stream used to send the SAML message.

For the SAML HTTP-Post binding, the output stream contains the encoded SAML message wrapped in an HTML form.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override Stream OutputStream { get; }
Public Overrides ReadOnly Property OutputStream As Stream
    Get
public:
virtual property Stream^ OutputStream {
    Stream^ get () override;
}
abstract OutputStream : Stream with get
override OutputStream : Stream with get

Property Value

Type: Stream
The output stream used to send the SAML message.
See Also

Reference

SAMLHttpResponse Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse.URL Property

SAMLHttpResponseURL Property

Gets the redirect URL.

For the SAML HTTP-Redirect binding, the URL includes the encoded SAML message.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string URL { get; }
Public ReadOnly Property URL As String
    Get
public:
property String^ URL {
    String^ get ();
}
member URL : string with get

Property Value

Type: String
The redirect URL.
See Also

Reference

SAMLHttpResponse Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse Methods

The SAMLHttpResponse type exposes the following members.

Methods
 | Name | Description
Public method | AddCacheDependency | When overridden in a derived class, associates cache dependencies with the response that enable the response to be invalidated if it is cached and if the specified dependencies change. (Inherited from HttpResponseBase.)
Public method | AddCacheItemDependencies(ArrayList) | When overridden in a derived class, makes the validity of a cached response dependent on the specified items in the cache. (Inherited from HttpResponseBase.)
Public method | AddCacheItemDependencies(String) | When overridden in a derived class, makes the validity of a cached item dependent on the specified items in the cache. (Inherited from HttpResponseBase.)
Public method | AddCacheItemDependency | When overridden in a derived class, makes the validity of a cached response dependent on the specified item in the cache. (Inherited from HttpResponseBase.)
Public method | AddFileDependencies(ArrayList) | When overridden in a derived class, adds file names to the collection of file names on which the current response is dependent. (Inherited from HttpResponseBase.)
Public method | AddFileDependencies(String) | When overridden in a derived class, adds an array of file names to the collection of file names on which the current response is dependent. (Inherited from HttpResponseBase.)
Public method | AddFileDependency | When overridden in a derived class, adds a single file name to the collection of file names on which the current response is dependent. (Inherited from HttpResponseBase.)
Public method | AddHeader | When overridden in a derived class, adds an HTTP header to the current response. This method is provided for compatibility with earlier versions of ASP. (Inherited from HttpResponseBase.)
Public method | AppendCookie | When overridden in a derived class, adds an HTTP cookie to the HTTP response cookie collection. (Inherited from HttpResponseBase.)
Public method | AppendHeader | When overridden in a derived class, adds an HTTP header to the current response. (Inherited from HttpResponseBase.)
Public method | AppendToLog | When overridden in a derived class, adds custom log information to the Internet Information Services (IIS) log file. (Inherited from HttpResponseBase.)
Public method | ApplyAppPathModifier | When overridden in a derived class, adds a session ID to the virtual path if the session is using Cookieless session state, and returns the combined path. (Inherited from HttpResponseBase.)
Public method | BinaryWrite | When overridden in a derived class, writes a string of binary characters to the HTTP output stream. (Inherited from HttpResponseBase.)
Public method | Clear | When overridden in a derived class, clears all headers and content output from the current response. (Inherited from HttpResponseBase.)
Public method | ClearContent | When overridden in a derived class, clears all content from the current response. (Inherited from HttpResponseBase.)
Public method | ClearHeaders | When overridden in a derived class, clears all headers from the current response. (Inherited from HttpResponseBase.)
Public method | Close | When overridden in a derived class, closes the socket connection to a client. (Inherited from HttpResponseBase.)
Public method | DisableKernelCache | When overridden in a derived class, disables kernel caching for the current response. (Inherited from HttpResponseBase.)
Public method | End | When overridden in a derived class, sends all currently buffered output to the client, stops execution of the requested process, and raises the EndRequest event. (Inherited from HttpResponseBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, sends all currently buffered output to the client. (Inherited from HttpResponseBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOutputAsString | Reads the output stream as a string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pics | When overridden in a derived class, appends an HTTP PICS-Label header to the current response. (Inherited from HttpResponseBase.)
Public method | Redirect(String) | When overridden in a derived class, redirects a request to the specified URL. (Inherited from HttpResponseBase.)
Public method | Redirect(String, Boolean) | Redirects to the specified URL. (Overrides HttpResponseBaseRedirect(String, Boolean).)
Public method | RedirectPermanent(String) | When overridden in a derived class, performs a permanent redirect from the requested URL to the specified URL. (Inherited from HttpResponseBase.)
Public method | RedirectPermanent(String, Boolean) | When overridden in a derived class, performs a permanent redirect from the requested URL to the specified URL, and provides the option to complete the response. (Inherited from HttpResponseBase.)
Public method | RedirectToRoute(Object) | When overridden in a derived class, redirects the request to a new URL by using route parameter values. (Inherited from HttpResponseBase.)
Public method | RedirectToRoute(String) | When overridden in a derived class, redirects the request to a new URL by using a route name. (Inherited from HttpResponseBase.)
Public method | RedirectToRoute(RouteValueDictionary) | When overridden in a derived class, redirects the request to a new URL by using route parameter values. (Inherited from HttpResponseBase.)
Public method | RedirectToRoute(String, Object) | When overridden in a derived class, redirects the request to a new URL by using route parameter values and a route name. (Inherited from HttpResponseBase.)
Public method | RedirectToRoute(String, RouteValueDictionary) | When overridden in a derived class, redirects the request to a new URL by using route parameter values and a route name. (Inherited from HttpResponseBase.)
Public method | RedirectToRoutePermanent(Object) | When overridden in a derived class, performs a permanent redirection from the requested URL to a new URL by using route parameter values. (Inherited from HttpResponseBase.)
Public method | RedirectToRoutePermanent(String) | When overridden in a derived class, performs a permanent redirection from the requested URL to a new URL by using a route name. (Inherited from HttpResponseBase.)
Public method | RedirectToRoutePermanent(RouteValueDictionary) | When overridden in a derived class, performs a permanent redirection from the requested URL to a new URL by using route parameter values. (Inherited from HttpResponseBase.)
Public method | RedirectToRoutePermanent(String, Object) | When overridden in a derived class, performs a permanent redirection from the requested URL to a new URL by using the route parameter values and the name of the route that correspond to the new URL. (Inherited from HttpResponseBase.)
Public method | RedirectToRoutePermanent(String, RouteValueDictionary) | When overridden in a derived class, performs a permanent redirection from the requested URL to a new URL by using route parameter values and a route name. (Inherited from HttpResponseBase.)
Public method | RemoveOutputCacheItem(String) | When overridden in a derived class, removes from the cache all cached items that are associated with the specified path. (Inherited from HttpResponseBase.)
Public method | RemoveOutputCacheItem(String, String) | When overridden in a derived class, uses the specified output-cache provider to remove all output-cache artifacts that are associated with the specified path. (Inherited from HttpResponseBase.)
Public method | SetCookie | When overridden in a derived class, updates an existing cookie in the cookie collection. (Inherited from HttpResponseBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransmitFile(String) | When overridden in a derived class, writes the specified file to the HTTP response output stream, without buffering it in memory. (Inherited from HttpResponseBase.)
Public method | TransmitFile(String, Int64, Int64) | When overridden in a derived class, writes the specified part of a file to the HTTP response output stream, without buffering it in memory. (Inherited from HttpResponseBase.)
Public method | Write(Char) | When overridden in a derived class, writes a character to an HTTP response output stream. (Inherited from HttpResponseBase.)
Public method | Write(Object) | When overridden in a derived class, writes the specified object to the HTTP response stream. (Inherited from HttpResponseBase.)
Public method | Write(String) | When overridden in a derived class, writes the specified string to the HTTP response output stream. (Inherited from HttpResponseBase.)
Public method | Write(Char, Int32, Int32) | When overridden in a derived class, writes the specified array of characters to the HTTP response output stream. (Inherited from HttpResponseBase.)
Public method | WriteFile(String) | When overridden in a derived class, writes the contents of the specified file to the HTTP response output stream as a file block. (Inherited from HttpResponseBase.)
Public method | WriteFile(String, Boolean) | When overridden in a derived class, writes the contents of the specified file to the HTTP response output stream and specifies whether the content is written as a memory block. (Inherited from HttpResponseBase.)
Public method | WriteFile(String, Int64, Int64) | When overridden in a derived class, writes the specified file to the HTTP response output stream. (Inherited from HttpResponseBase.)
Public method | WriteFile(IntPtr, Int64, Int64) | When overridden in a derived class, writes the specified file to the HTTP response output stream. (Inherited from HttpResponseBase.)
Public method | WriteSubstitution | When overridden in a derived class, inserts substitution blocks into the response, which enables dynamic generation of regions for cached output responses. (Inherited from HttpResponseBase.)
Top
See Also

Reference

SAMLHttpResponse Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse.GetOutputAsString Method

SAMLHttpResponseGetOutputAsString Method

Reads the output stream as a string.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public string GetOutputAsString()
Public Function GetOutputAsString As String
public:
String^ GetOutputAsString()
member GetOutputAsString : unit -> string

Return Value

Type: String
The output as a string.
See Also

Reference

SAMLHttpResponse Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse.Redirect Method

SAMLHttpResponseRedirect Method

Overload List
 | Name | Description
Public method | Redirect(String) | When overridden in a derived class, redirects a request to the specified URL. (Inherited from HttpResponseBase.)
Public method | Redirect(String, Boolean) | Redirects to the specified URL. (Overrides HttpResponseBaseRedirect(String, Boolean).)
Top
See Also

Reference

SAMLHttpResponse Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpResponse.Redirect Method (String, Boolean)

SAMLHttpResponseRedirect Method (String, Boolean)

Redirects to the specified URL.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override void Redirect(
    string url,
    bool endResponse
)
Public Overrides Sub Redirect (
    url As String,
    endResponse As Boolean
)
public:
virtual void Redirect(
    String^ url,
    bool endResponse
) override
abstract Redirect :
        url : string *
        endResponse : bool -> unit
override Redirect :
        url : string *
        endResponse : bool -> unit

Parameters

url
Type: SystemString
The target location.
endResponse
Type: SystemBoolean
The flag indicating whether to terminate the current process.
See Also

Reference

SAMLHttpResponse Class
Redirect Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpSessionState Class

Supports sending and receiving SAML protocol messages through non-standard HTTP requests and responses.
Inheritance Hierarchy
SystemObject
System.WebHttpSessionStateBase
ComponentSpace.SAML2.UtilitySAMLHttpSessionState

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class SAMLHttpSessionState : HttpSessionStateBase
Public Class SAMLHttpSessionState
    Inherits HttpSessionStateBase
public ref class SAMLHttpSessionState : public HttpSessionStateBase
type SAMLHttpSessionState =
    class
        inherit HttpSessionStateBase
    end

The SAMLHttpSessionState type exposes the following members.

Constructors
 | Name | Description
Public method | SAMLHttpSessionState | Initializes a new instance of the SAMLHttpSessionState class.
Top
Properties
 | Name | Description
Public property | CodePage | When overridden in a derived class, gets or sets the character-set identifier for the current session. (Inherited from HttpSessionStateBase.)
Public property | Contents | When overridden in a derived class, gets a reference to the current session-state object. (Inherited from HttpSessionStateBase.)
Public property | CookieMode | When overridden in a derived class, gets a value that indicates whether the application is configured for cookieless sessions. (Inherited from HttpSessionStateBase.)
Public property | Count | When overridden in a derived class, gets the number of items in the session-state collection. (Inherited from HttpSessionStateBase.)
Public property | IsCookieless | When overridden in a derived class, gets a value that indicates whether the session ID is embedded in the URL. (Inherited from HttpSessionStateBase.)
Public property | IsNewSession | When overridden in a derived class, gets a value that indicates whether the session was created during the current request. (Inherited from HttpSessionStateBase.)
Public property | IsReadOnly | When overridden in a derived class, gets a value that indicates whether the session is read-only. (Inherited from HttpSessionStateBase.)
Public property | IsSynchronized | When overridden in a derived class, gets a value that indicates whether access to the collection of session-state values is synchronized (thread safe). (Inherited from HttpSessionStateBase.)
Public property | ItemInt32 | When overridden in a derived class, gets or sets a session value by using the specified index. (Inherited from HttpSessionStateBase.)
Public property | ItemString | Gets or sets the session value using the specified name. (Overrides HttpSessionStateBaseItemString.)
Public property | Keys | When overridden in a derived class, gets a collection of the keys for all values that are stored in the session-state collection. (Inherited from HttpSessionStateBase.)
Public property | LCID | When overridden in a derived class, gets or sets the locale identifier (LCID) of the current session. (Inherited from HttpSessionStateBase.)
Public property | Mode | When overridden in a derived class, gets the current session-state mode. (Inherited from HttpSessionStateBase.)
Public property | SessionID | Gets the session ID. (Overrides HttpSessionStateBaseSessionID.)
Public property | StaticObjects | When overridden in a derived class, gets a collection of objects that are declared by object elements that are marked as server controls and scoped to the current session in the application's Global.asax file. (Inherited from HttpSessionStateBase.)
Public property | SyncRoot | When overridden in a derived class, gets an object that can be used to synchronize access to the collection of session-state values. (Inherited from HttpSessionStateBase.)
Public property | Timeout | When overridden in a derived class, gets or sets the time, in minutes, that can elapse between requests before the session-state provider ends the session. (Inherited from HttpSessionStateBase.)
Top
Methods
 | Name | Description
Public method | Abandon | When overridden in a derived class, cancels the current session. (Inherited from HttpSessionStateBase.)
Public method | Add | When overridden in a derived class, adds an item to the session-state collection. (Inherited from HttpSessionStateBase.)
Public method | Clear | When overridden in a derived class, removes all keys and values from the session-state collection. (Inherited from HttpSessionStateBase.)
Public method | CopyTo | When overridden in a derived class, copies the collection of session-state values to a one-dimensional array, starting at the specified index in the array. (Inherited from HttpSessionStateBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | When overridden in a derived class, returns an enumerator that can be used to read all the session-state variable names in the current session. (Inherited from HttpSessionStateBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | When overridden in a derived class, deletes an item from the session-state collection. (Inherited from HttpSessionStateBase.)
Public method | RemoveAll | When overridden in a derived class, removes all keys and values from the session-state collection. (Inherited from HttpSessionStateBase.)
Public method | RemoveAt | When overridden in a derived class, deletes the item at the specified index from the session-state collection. (Inherited from HttpSessionStateBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


SAMLHttpSessionState Constructor

Initializes a new instance of the SAMLHttpSessionState class.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public SAMLHttpSessionState()
Public Sub New
public:
SAMLHttpSessionState()
new : unit -> SAMLHttpSessionState
See Also

Reference

SAMLHttpSessionState Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpSessionState Properties

The SAMLHttpSessionState type exposes the following members.

Properties
 | Name | Description
Public property | CodePage | When overridden in a derived class, gets or sets the character-set identifier for the current session. (Inherited from HttpSessionStateBase.)
Public property | Contents | When overridden in a derived class, gets a reference to the current session-state object. (Inherited from HttpSessionStateBase.)
Public property | CookieMode | When overridden in a derived class, gets a value that indicates whether the application is configured for cookieless sessions. (Inherited from HttpSessionStateBase.)
Public property | Count | When overridden in a derived class, gets the number of items in the session-state collection. (Inherited from HttpSessionStateBase.)
Public property | IsCookieless | When overridden in a derived class, gets a value that indicates whether the session ID is embedded in the URL. (Inherited from HttpSessionStateBase.)
Public property | IsNewSession | When overridden in a derived class, gets a value that indicates whether the session was created during the current request. (Inherited from HttpSessionStateBase.)
Public property | IsReadOnly | When overridden in a derived class, gets a value that indicates whether the session is read-only. (Inherited from HttpSessionStateBase.)
Public property | IsSynchronized | When overridden in a derived class, gets a value that indicates whether access to the collection of session-state values is synchronized (thread safe). (Inherited from HttpSessionStateBase.)
Public property | ItemInt32 | When overridden in a derived class, gets or sets a session value by using the specified index. (Inherited from HttpSessionStateBase.)
Public property | ItemString | Gets or sets the session value using the specified name. (Overrides HttpSessionStateBaseItemString.)
Public property | Keys | When overridden in a derived class, gets a collection of the keys for all values that are stored in the session-state collection. (Inherited from HttpSessionStateBase.)
Public property | LCID | When overridden in a derived class, gets or sets the locale identifier (LCID) of the current session. (Inherited from HttpSessionStateBase.)
Public property | Mode | When overridden in a derived class, gets the current session-state mode. (Inherited from HttpSessionStateBase.)
Public property | SessionID | Gets the session ID. (Overrides HttpSessionStateBaseSessionID.)
Public property | StaticObjects | When overridden in a derived class, gets a collection of objects that are declared by object elements that are marked as server controls and scoped to the current session in the application's Global.asax file. (Inherited from HttpSessionStateBase.)
Public property | SyncRoot | When overridden in a derived class, gets an object that can be used to synchronize access to the collection of session-state values. (Inherited from HttpSessionStateBase.)
Public property | Timeout | When overridden in a derived class, gets or sets the time, in minutes, that can elapse between requests before the session-state provider ends the session. (Inherited from HttpSessionStateBase.)
Top
See Also

Reference

SAMLHttpSessionState Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpSessionState.Item Property

SAMLHttpSessionStateItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | When overridden in a derived class, gets or sets a session value by using the specified index. (Inherited from HttpSessionStateBase.)
Public property | ItemString | Gets or sets the session value using the specified name. (Overrides HttpSessionStateBaseItemString.)
Top
See Also

Reference

SAMLHttpSessionState Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpSessionState.Item Property (String)

SAMLHttpSessionStateItem Property (String)

Gets or sets the session value using the specified name.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override Object this[
    string name
] { get; set; }
Public Overrides Default Property Item (
    name As String
) As Object
    Get
    Set
public:
virtual property Object^ default[String^ name] {
    Object^ get (String^ name) override;
    void set (String^ name, Object^ value) override;
}
abstract Item : Object with get, set
override Item : Object with get, set

Parameters

name
Type: SystemString
The session item name.

Return Value

Type: Object
The session value or null if none.
See Also

Reference

SAMLHttpSessionState Class
Item Overload
ComponentSpace.SAML2.Utility Namespace


SAMLHttpSessionState.SessionID Property

SAMLHttpSessionStateSessionID Property

Gets the session ID.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override string SessionID { get; }
Public Overrides ReadOnly Property SessionID As String
    Get
public:
virtual property String^ SessionID {
    String^ get () override;
}
abstract SessionID : string with get
override SessionID : string with get

Property Value

Type: String
The session ID.
See Also

Reference

SAMLHttpSessionState Class
ComponentSpace.SAML2.Utility Namespace


SAMLHttpSessionState Methods

The SAMLHttpSessionState type exposes the following members.

Methods
 | Name | Description
Public method | Abandon | When overridden in a derived class, cancels the current session. (Inherited from HttpSessionStateBase.)
Public method | Add | When overridden in a derived class, adds an item to the session-state collection. (Inherited from HttpSessionStateBase.)
Public method | Clear | When overridden in a derived class, removes all keys and values from the session-state collection. (Inherited from HttpSessionStateBase.)
Public method | CopyTo | When overridden in a derived class, copies the collection of session-state values to a one-dimensional array, starting at the specified index in the array. (Inherited from HttpSessionStateBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | When overridden in a derived class, returns an enumerator that can be used to read all the session-state variable names in the current session. (Inherited from HttpSessionStateBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | When overridden in a derived class, deletes an item from the session-state collection. (Inherited from HttpSessionStateBase.)
Public method | RemoveAll | When overridden in a derived class, removes all keys and values from the session-state collection. (Inherited from HttpSessionStateBase.)
Public method | RemoveAt | When overridden in a derived class, deletes the item at the specified index from the session-state collection. (Inherited from HttpSessionStateBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SAMLHttpSessionState Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema Class

Provides common XML schema definitions and helper methods.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.UtilityXmlSchema

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class XmlSchema
Public NotInheritable Class XmlSchema
public ref class XmlSchema abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XmlSchema =  class end

The XmlSchema type exposes the following members.

Methods
Name | Description
GetQualifiedSimpleType | Gets the qualified simple type by prefixing it with the XML schema prefix. For example, the qualified simple type for "string" is "xs:string".
GetSimpleType | Gets the simple type by removing the XML schema prefix from the qualified name. For example, the simple type for "xs:string" is "string".
Top
Remarks
Refer to the W3C XML Schema specification for further details.
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


XmlSchema Methods

The XmlSchema type exposes the following members.

Methods
Name | Description
GetQualifiedSimpleType | Gets the qualified simple type by prefixing it with the XML schema prefix. For example, the qualified simple type for "string" is "xs:string".
GetSimpleType | Gets the simple type by removing the XML schema prefix from the qualified name. For example, the simple type for "xs:string" is "string".
Top
See Also

Reference

XmlSchema Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.GetQualifiedSimpleType Method

XmlSchemaGetQualifiedSimpleType Method

Gets the qualified simple type by prefixing it with the XML schema prefix. For example, the qualified simple type for "string" is "xs:string".

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetQualifiedSimpleType(
    string simpleType
)
Public Shared Function GetQualifiedSimpleType (
    simpleType As String
) As String
public:
static String^ GetQualifiedSimpleType(
    String^ simpleType
)
static member GetQualifiedSimpleType :
        simpleType : string -> string

Parameters

simpleType
Type: SystemString
The simple type to be qualified.

Return Value

Type: String
The qualified simple type.
See Also

Reference

XmlSchema Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.GetSimpleType Method

XmlSchemaGetSimpleType Method

Gets the simple type by removing the XML schema prefix from the qualified name. For example, the simple type for "xs:string" is "string".

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static string GetSimpleType(
    string qualifiedSimpleType
)
Public Shared Function GetSimpleType (
    qualifiedSimpleType As String
) As String
public:
static String^ GetSimpleType(
    String^ qualifiedSimpleType
)
static member GetSimpleType :
        qualifiedSimpleType : string -> string

Parameters

qualifiedSimpleType
Type: SystemString
The qualfied simple type.

Return Value

Type: String
The simple type.
See Also

Reference

XmlSchema Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.NamespaceURIs Class

XmlSchemaNamespaceURIs Class

The XML namespace URIs.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.UtilityXmlSchemaNamespaceURIs

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class NamespaceURIs
Public NotInheritable Class NamespaceURIs
public ref class NamespaceURIs abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NamespaceURIs =  class end

The XmlSchemaNamespaceURIs type exposes the following members.

Fields
Name | Description
XMLSchema | The XML schema namespace URI.
XMLSchemaInstance | The XML schema instance namespace URI.
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


NamespaceURIs Fields

The XmlSchemaNamespaceURIs type exposes the following members.

Fields
Name | Description
XMLSchema | The XML schema namespace URI.
XMLSchemaInstance | The XML schema instance namespace URI.
Top
See Also

Reference

XmlSchemaNamespaceURIs Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.NamespaceURIs.XMLSchema Field

XmlSchemaNamespaceURIsXMLSchema Field

The XML schema namespace URI.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string XMLSchema = "http://www.w3.org/2001/XMLSchema"
Public Const XMLSchema As String = "http://www.w3.org/2001/XMLSchema"
public:
literal String^ XMLSchema = "http://www.w3.org/2001/XMLSchema"
static val mutable XMLSchema: string

Field Value

Type: String
See Also

Reference

XmlSchemaNamespaceURIs Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.NamespaceURIs.XMLSchemaInstance Field

XmlSchemaNamespaceURIsXMLSchemaInstance Field

The XML schema instance namespace URI.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string XMLSchemaInstance = "http://www.w3.org/2001/XMLSchema-instance"
Public Const XMLSchemaInstance As String = "http://www.w3.org/2001/XMLSchema-instance"
public:
literal String^ XMLSchemaInstance = "http://www.w3.org/2001/XMLSchema-instance"
static val mutable XMLSchemaInstance: string

Field Value

Type: String
See Also

Reference

XmlSchemaNamespaceURIs Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.Prefixes Class

XmlSchemaPrefixes Class

The XML prefixes.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.UtilityXmlSchemaPrefixes

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class Prefixes
Public NotInheritable Class Prefixes
public ref class Prefixes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Prefixes =  class end

The XmlSchemaPrefixes type exposes the following members.

Fields
Name | Description
XS | The XML schema prefix.
XSI | The XML schema instance prefix.
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


Prefixes Fields

The XmlSchemaPrefixes type exposes the following members.

Fields
Name | Description
XS | The XML schema prefix.
XSI | The XML schema instance prefix.
Top
See Also

Reference

XmlSchemaPrefixes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.Prefixes.XS Field

XmlSchemaPrefixesXS Field

The XML schema prefix.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string XS = "xs"
Public Const XS As String = "xs"
public:
literal String^ XS = "xs"
static val mutable XS: string

Field Value

Type: String
See Also

Reference

XmlSchemaPrefixes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.Prefixes.XSI Field

XmlSchemaPrefixesXSI Field

The XML schema instance prefix.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string XSI = "xsi"
Public Const XSI As String = "xsi"
public:
literal String^ XSI = "xsi"
static val mutable XSI: string

Field Value

Type: String
See Also

Reference

XmlSchemaPrefixes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes Class

XmlSchemaSimpleTypes Class

Simple types built into XML schema.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.UtilityXmlSchemaSimpleTypes

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class SimpleTypes
Public NotInheritable Class SimpleTypes
public ref class SimpleTypes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SimpleTypes =  class end

The XmlSchemaSimpleTypes type exposes the following members.

Fields
Name | Description
AnyURI | Any URI.
Base64Binary | Base 64 binary.
Boolean | Boolean.
Byte | Byte.
Date | Date.
DateTime | Date/time.
Decimal | Decimal.
Double | Double.
Duration | Duration.
ENTITIES | ENTITIES.
ENTITY | ENTITY.
Float | Float.
GregorianDay | Gregorian day.
GregorianMonth | Gregorian month.
GregorianMonthDay | Gregorian month/day.
GregorianYear | Gregorian year.
GregorianYearMonth | Gregorian year/month.
HexBinary | Hex binary.
ID | ID.
IDREF | IDREF.
IDREFS | IDREFS.
Int | Int.
Integer | Integer.
Language | Language.
Long | Long.
Name | Name.
NCName | Non-colonized name.
NegativeInteger | Negative integer.
NMTOKEN | NMTOKEN.
NMTOKENS | NMTOKENS.
NonNegativeInteger | Non-negative integer.
NonPostiveInteger | Non-positive integer.
NormalizedString | Normalized string.
NOTATION | NOTATION.
PositiveInteger | Positive integer.
QualifiedName | Qualified name.
Short | Short.
String | String.
Time | Time.
Token | Token.
UnsignedByte | Unsigned byte.
UnsignedInt | Unsigned int.
UnsignedLong | Unsigned long.
UnsignedShort | Unsigned short.
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


SimpleTypes Fields

The XmlSchemaSimpleTypes type exposes the following members.

Fields
Name | Description
AnyURI | Any URI.
Base64Binary | Base 64 binary.
Boolean | Boolean.
Byte | Byte.
Date | Date.
DateTime | Date/time.
Decimal | Decimal.
Double | Double.
Duration | Duration.
ENTITIES | ENTITIES.
ENTITY | ENTITY.
Float | Float.
GregorianDay | Gregorian day.
GregorianMonth | Gregorian month.
GregorianMonthDay | Gregorian month/day.
GregorianYear | Gregorian year.
GregorianYearMonth | Gregorian year/month.
HexBinary | Hex binary.
ID | ID.
IDREF | IDREF.
IDREFS | IDREFS.
Int | Int.
Integer | Integer.
Language | Language.
Long | Long.
Name | Name.
NCName | Non-colonized name.
NegativeInteger | Negative integer.
NMTOKEN | NMTOKEN.
NMTOKENS | NMTOKENS.
NonNegativeInteger | Non-negative integer.
NonPostiveInteger | Non-positive integer.
NormalizedString | Normalized string.
NOTATION | NOTATION.
PositiveInteger | Positive integer.
QualifiedName | Qualified name.
Short | Short.
String | String.
Time | Time.
Token | Token.
UnsignedByte | Unsigned byte.
UnsignedInt | Unsigned int.
UnsignedLong | Unsigned long.
UnsignedShort | Unsigned short.
Top
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.AnyURI Field

XmlSchemaSimpleTypesAnyURI Field

Any URI.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string AnyURI = "anyURI"
Public Const AnyURI As String = "anyURI"
public:
literal String^ AnyURI = "anyURI"
static val mutable AnyURI: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Base64Binary Field

XmlSchemaSimpleTypesBase64Binary Field

Base 64 binary.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Base64Binary = "base64Binary"
Public Const Base64Binary As String = "base64Binary"
public:
literal String^ Base64Binary = "base64Binary"
static val mutable Base64Binary: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Boolean Field

XmlSchemaSimpleTypesBoolean Field

Boolean.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Boolean = "boolean"
Public Const Boolean As String = "boolean"
public:
literal String^ Boolean = "boolean"
static val mutable Boolean: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Byte Field

XmlSchemaSimpleTypesByte Field

Byte.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Byte = "byte"
Public Const Byte As String = "byte"
public:
literal String^ Byte = "byte"
static val mutable Byte: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Date Field

XmlSchemaSimpleTypesDate Field

Date.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Date = "date"
Public Const Date As String = "date"
public:
literal String^ Date = "date"
static val mutable Date: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.DateTime Field

XmlSchemaSimpleTypesDateTime Field

Date/time.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string DateTime = "dateTime"
Public Const DateTime As String = "dateTime"
public:
literal String^ DateTime = "dateTime"
static val mutable DateTime: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Decimal Field

XmlSchemaSimpleTypesDecimal Field

Decimal.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Decimal = "decimal"
Public Const Decimal As String = "decimal"
public:
literal String^ Decimal = "decimal"
static val mutable Decimal: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Double Field

XmlSchemaSimpleTypesDouble Field

Double.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Double = "double"
Public Const Double As String = "double"
public:
literal String^ Double = "double"
static val mutable Double: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Duration Field

XmlSchemaSimpleTypesDuration Field

Duration.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Duration = "duration"
Public Const Duration As String = "duration"
public:
literal String^ Duration = "duration"
static val mutable Duration: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.ENTITIES Field

XmlSchemaSimpleTypesENTITIES Field

ENTITIES.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string ENTITIES = "ENTITIES"
Public Const ENTITIES As String = "ENTITIES"
public:
literal String^ ENTITIES = "ENTITIES"
static val mutable ENTITIES: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.ENTITY Field

XmlSchemaSimpleTypesENTITY Field

ENTITY.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string ENTITY = "ENTITY"
Public Const ENTITY As String = "ENTITY"
public:
literal String^ ENTITY = "ENTITY"
static val mutable ENTITY: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Float Field

XmlSchemaSimpleTypesFloat Field

Float.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Float = "float"
Public Const Float As String = "float"
public:
literal String^ Float = "float"
static val mutable Float: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.GregorianDay Field

XmlSchemaSimpleTypesGregorianDay Field

Gregorian day.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string GregorianDay = "gDay"
Public Const GregorianDay As String = "gDay"
public:
literal String^ GregorianDay = "gDay"
static val mutable GregorianDay: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.GregorianMonth Field

XmlSchemaSimpleTypesGregorianMonth Field

Gregorian month.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string GregorianMonth = "gmonth"
Public Const GregorianMonth As String = "gmonth"
public:
literal String^ GregorianMonth = "gmonth"
static val mutable GregorianMonth: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.GregorianMonthDay Field

XmlSchemaSimpleTypesGregorianMonthDay Field

Gregorian month/day.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string GregorianMonthDay = "gMonthDay"
Public Const GregorianMonthDay As String = "gMonthDay"
public:
literal String^ GregorianMonthDay = "gMonthDay"
static val mutable GregorianMonthDay: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.GregorianYear Field

XmlSchemaSimpleTypesGregorianYear Field

Gregorian year.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string GregorianYear = "gYear"
Public Const GregorianYear As String = "gYear"
public:
literal String^ GregorianYear = "gYear"
static val mutable GregorianYear: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.GregorianYearMonth Field

XmlSchemaSimpleTypesGregorianYearMonth Field

Gregorian year/month.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string GregorianYearMonth = "gYearMonth"
Public Const GregorianYearMonth As String = "gYearMonth"
public:
literal String^ GregorianYearMonth = "gYearMonth"
static val mutable GregorianYearMonth: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.HexBinary Field

XmlSchemaSimpleTypesHexBinary Field

Hex binary.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string HexBinary = "hexBinary"
Public Const HexBinary As String = "hexBinary"
public:
literal String^ HexBinary = "hexBinary"
static val mutable HexBinary: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.ID Field

XmlSchemaSimpleTypesID Field

ID.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string ID = "ID"
Public Const ID As String = "ID"
public:
literal String^ ID = "ID"
static val mutable ID: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.IDREF Field

XmlSchemaSimpleTypesIDREF Field

IDREF.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string IDREF = "IDREF"
Public Const IDREF As String = "IDREF"
public:
literal String^ IDREF = "IDREF"
static val mutable IDREF: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.IDREFS Field

XmlSchemaSimpleTypesIDREFS Field

IDREFS.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string IDREFS = "IDREFS"
Public Const IDREFS As String = "IDREFS"
public:
literal String^ IDREFS = "IDREFS"
static val mutable IDREFS: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Int Field

XmlSchemaSimpleTypesInt Field

Int.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Int = "int"
Public Const Int As String = "int"
public:
literal String^ Int = "int"
static val mutable Int: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Integer Field

XmlSchemaSimpleTypesInteger Field

Integer.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Integer = "integer"
Public Const Integer As String = "integer"
public:
literal String^ Integer = "integer"
static val mutable Integer: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Language Field

XmlSchemaSimpleTypesLanguage Field

Language.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Language = "language"
Public Const Language As String = "language"
public:
literal String^ Language = "language"
static val mutable Language: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Long Field

XmlSchemaSimpleTypesLong Field

Long.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Long = "long"
Public Const Long As String = "long"
public:
literal String^ Long = "long"
static val mutable Long: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Name Field

XmlSchemaSimpleTypesName Field

Name.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Name = "Name"
Public Const Name As String = "Name"
public:
literal String^ Name = "Name"
static val mutable Name: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.NCName Field

XmlSchemaSimpleTypesNCName Field

Non-colonized name.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NCName = "NCName"
Public Const NCName As String = "NCName"
public:
literal String^ NCName = "NCName"
static val mutable NCName: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.NegativeInteger Field

XmlSchemaSimpleTypesNegativeInteger Field

Negative integer.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NegativeInteger = "negativeInteger"
Public Const NegativeInteger As String = "negativeInteger"
public:
literal String^ NegativeInteger = "negativeInteger"
static val mutable NegativeInteger: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.NMTOKEN Field

XmlSchemaSimpleTypesNMTOKEN Field

NMTOKEN.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NMTOKEN = "NMTOKEN"
Public Const NMTOKEN As String = "NMTOKEN"
public:
literal String^ NMTOKEN = "NMTOKEN"
static val mutable NMTOKEN: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.NMTOKENS Field

XmlSchemaSimpleTypesNMTOKENS Field

NMTOKENS.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NMTOKENS = "NMTOKENS"
Public Const NMTOKENS As String = "NMTOKENS"
public:
literal String^ NMTOKENS = "NMTOKENS"
static val mutable NMTOKENS: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.NonNegativeInteger Field

XmlSchemaSimpleTypesNonNegativeInteger Field

Non-negative integer.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NonNegativeInteger = "nonNegativeInteger"
Public Const NonNegativeInteger As String = "nonNegativeInteger"
public:
literal String^ NonNegativeInteger = "nonNegativeInteger"
static val mutable NonNegativeInteger: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.NonPostiveInteger Field

XmlSchemaSimpleTypesNonPostiveInteger Field

Non-positive integer.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NonPostiveInteger = "nonPositiveInteger"
Public Const NonPostiveInteger As String = "nonPositiveInteger"
public:
literal String^ NonPostiveInteger = "nonPositiveInteger"
static val mutable NonPostiveInteger: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.NormalizedString Field

XmlSchemaSimpleTypesNormalizedString Field

Normalized string.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NormalizedString = "normalizedString"
Public Const NormalizedString As String = "normalizedString"
public:
literal String^ NormalizedString = "normalizedString"
static val mutable NormalizedString: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.NOTATION Field

XmlSchemaSimpleTypesNOTATION Field

NOTATION.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string NOTATION = "NOTATION"
Public Const NOTATION As String = "NOTATION"
public:
literal String^ NOTATION = "NOTATION"
static val mutable NOTATION: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.PositiveInteger Field

XmlSchemaSimpleTypesPositiveInteger Field

Positive integer.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string PositiveInteger = "positiveInteger"
Public Const PositiveInteger As String = "positiveInteger"
public:
literal String^ PositiveInteger = "positiveInteger"
static val mutable PositiveInteger: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.QualifiedName Field

XmlSchemaSimpleTypesQualifiedName Field

Qualified name.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string QualifiedName = "QName"
Public Const QualifiedName As String = "QName"
public:
literal String^ QualifiedName = "QName"
static val mutable QualifiedName: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Short Field

XmlSchemaSimpleTypesShort Field

Short.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Short = "short"
Public Const Short As String = "short"
public:
literal String^ Short = "short"
static val mutable Short: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.String Field

XmlSchemaSimpleTypesString Field

String.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string String = "string"
Public Const String As String = "string"
public:
literal String^ String = "string"
static val mutable String: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Time Field

XmlSchemaSimpleTypesTime Field

Time.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Time = "time"
Public Const Time As String = "time"
public:
literal String^ Time = "time"
static val mutable Time: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.Token Field

XmlSchemaSimpleTypesToken Field

Token.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string Token = "token"
Public Const Token As String = "token"
public:
literal String^ Token = "token"
static val mutable Token: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.UnsignedByte Field

XmlSchemaSimpleTypesUnsignedByte Field

Unsigned byte.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string UnsignedByte = "unsignedByte"
Public Const UnsignedByte As String = "unsignedByte"
public:
literal String^ UnsignedByte = "unsignedByte"
static val mutable UnsignedByte: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.UnsignedInt Field

XmlSchemaSimpleTypesUnsignedInt Field

Unsigned int.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string UnsignedInt = "unsignedInt"
Public Const UnsignedInt As String = "unsignedInt"
public:
literal String^ UnsignedInt = "unsignedInt"
static val mutable UnsignedInt: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.UnsignedLong Field

XmlSchemaSimpleTypesUnsignedLong Field

Unsigned long.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string UnsignedLong = "unsignedLong"
Public Const UnsignedLong As String = "unsignedLong"
public:
literal String^ UnsignedLong = "unsignedLong"
static val mutable UnsignedLong: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XmlSchema.SimpleTypes.UnsignedShort Field

XmlSchemaSimpleTypesUnsignedShort Field

Unsigned short.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public const string UnsignedShort = "unsignedShort"
Public Const UnsignedShort As String = "unsignedShort"
public:
literal String^ UnsignedShort = "unsignedShort"
static val mutable UnsignedShort: string

Field Value

Type: String
See Also

Reference

XmlSchemaSimpleTypes Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions Class

Included are XML signature descriptions for the SHA-256, SHA-384 and SHA-512 algorithms.
Inheritance Hierarchy
SystemObject
ComponentSpace.SAML2.UtilityXMLSignatureDescriptions

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static class XMLSignatureDescriptions
Public NotInheritable Class XMLSignatureDescriptions
public ref class XMLSignatureDescriptions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XMLSignatureDescriptions =  class end

The XMLSignatureDescriptions type exposes the following members.

Properties
Name | Description
SHA2Enabled | Gets or sets the flag indicating whether SHA-2 signature support is enabled. The default is true.
Top
Methods
Name | Description
AddAlgorithms | Adds the SHA-256, SHA-384 and SHA-512 XML signature algorithms to the system so they're available for subsequent use.
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions Properties

The XMLSignatureDescriptions type exposes the following members.

Properties
Name | Description
SHA2Enabled | Gets or sets the flag indicating whether SHA-2 signature support is enabled. The default is true.
Top
See Also

Reference

XMLSignatureDescriptions Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.SHA2Enabled Property

XMLSignatureDescriptionsSHA2Enabled Property

Gets or sets the flag indicating whether SHA-2 signature support is enabled.

The default is true.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static bool SHA2Enabled { get; set; }
Public Shared Property SHA2Enabled As Boolean
    Get
    Set
public:
static property bool SHA2Enabled {
    bool get ();
    void set (bool value);
}
static member SHA2Enabled : bool with get, set

Property Value

Type: Boolean
The flag indicating whether SHA-2 signature support is enabled.
See Also

Reference

XMLSignatureDescriptions Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions Methods

The XMLSignatureDescriptions type exposes the following members.

Methods
Name | Description
AddAlgorithms | Adds the SHA-256, SHA-384 and SHA-512 XML signature algorithms to the system so they're available for subsequent use.
Top
See Also

Reference

XMLSignatureDescriptions Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.AddAlgorithms Method

XMLSignatureDescriptionsAddAlgorithms Method

Adds the SHA-256, SHA-384 and SHA-512 XML signature algorithms to the system so they're available for subsequent use.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public static void AddAlgorithms()
Public Shared Sub AddAlgorithms
public:
static void AddAlgorithms()
static member AddAlgorithms : unit -> unit
See Also

Reference

XMLSignatureDescriptions Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA256SignatureDescription Class

XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription Class

Describes the SHA-256 XML signature algorithm.
Inheritance Hierarchy
SystemObject
System.Security.CryptographySignatureDescription
ComponentSpace.SAML2.UtilityXMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class RSAPKCS1SHA256SignatureDescription : SignatureDescription
Public Class RSAPKCS1SHA256SignatureDescription
    Inherits SignatureDescription
public ref class RSAPKCS1SHA256SignatureDescription : public SignatureDescription
type RSAPKCS1SHA256SignatureDescription =
    class
        inherit SignatureDescription
    end

The XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription type exposes the following members.

Constructors
 | Name | Description
Public method | XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription | Constructs the SHA-256 XML signature algorithm description.
Top
Properties
 | Name | Description
Public property | DeformatterAlgorithm | Gets or sets the deformatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | DigestAlgorithm | Gets or sets the digest algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | FormatterAlgorithm | Gets or sets the formatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | KeyAlgorithm | Gets or sets the key algorithm for the signature description. (Inherited from SignatureDescription.)
Top
Methods
 | Name | Description
Public method | CreateDeformatter | Creates the deformatter. (Overrides SignatureDescriptionCreateDeformatter(AsymmetricAlgorithm).)
Public method | CreateDigest | Creates a HashAlgorithm instance using the DigestAlgorithm property. (Inherited from SignatureDescription.)
Public method | CreateFormatter | Creates the formatter. (Overrides SignatureDescriptionCreateFormatter(AsymmetricAlgorithm).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA256SignatureDescription Constructor

XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription Constructor

Constructs the SHA-256 XML signature algorithm description.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RSAPKCS1SHA256SignatureDescription()
Public Sub New
public:
RSAPKCS1SHA256SignatureDescription()
new : unit -> RSAPKCS1SHA256SignatureDescription
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


RSAPKCS1SHA256SignatureDescription Properties

The XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription type exposes the following members.

Properties
 | Name | Description
Public property | DeformatterAlgorithm | Gets or sets the deformatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | DigestAlgorithm | Gets or sets the digest algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | FormatterAlgorithm | Gets or sets the formatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | KeyAlgorithm | Gets or sets the key algorithm for the signature description. (Inherited from SignatureDescription.)
Top
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


RSAPKCS1SHA256SignatureDescription Methods

The XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription type exposes the following members.

Methods
 | Name | Description
Public method | CreateDeformatter | Creates the deformatter. (Overrides SignatureDescriptionCreateDeformatter(AsymmetricAlgorithm).)
Public method | CreateDigest | Creates a HashAlgorithm instance using the DigestAlgorithm property. (Inherited from SignatureDescription.)
Public method | CreateFormatter | Creates the formatter. (Overrides SignatureDescriptionCreateFormatter(AsymmetricAlgorithm).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA256SignatureDescription.CreateDeformatter Method

XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescriptionCreateDeformatter Method

Creates the deformatter.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override AsymmetricSignatureDeformatter CreateDeformatter(
    AsymmetricAlgorithm key
)
Public Overrides Function CreateDeformatter (
    key As AsymmetricAlgorithm
) As AsymmetricSignatureDeformatter
public:
virtual AsymmetricSignatureDeformatter^ CreateDeformatter(
    AsymmetricAlgorithm^ key
) override
abstract CreateDeformatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureDeformatter
override CreateDeformatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureDeformatter

Parameters

key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key.

Return Value

Type: AsymmetricSignatureDeformatter
The deformatter.
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA256SignatureDescription.CreateFormatter Method

XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescriptionCreateFormatter Method

Creates the formatter.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override AsymmetricSignatureFormatter CreateFormatter(
    AsymmetricAlgorithm key
)
Public Overrides Function CreateFormatter (
    key As AsymmetricAlgorithm
) As AsymmetricSignatureFormatter
public:
virtual AsymmetricSignatureFormatter^ CreateFormatter(
    AsymmetricAlgorithm^ key
) override
abstract CreateFormatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureFormatter
override CreateFormatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureFormatter

Parameters

key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key.

Return Value

Type: AsymmetricSignatureFormatter
The formatter.
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA256SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA384SignatureDescription Class

XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription Class

Describes the SHA-384 XML signature algorithm.
Inheritance Hierarchy
SystemObject
System.Security.CryptographySignatureDescription
ComponentSpace.SAML2.UtilityXMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class RSAPKCS1SHA384SignatureDescription : SignatureDescription
Public Class RSAPKCS1SHA384SignatureDescription
    Inherits SignatureDescription
public ref class RSAPKCS1SHA384SignatureDescription : public SignatureDescription
type RSAPKCS1SHA384SignatureDescription =
    class
        inherit SignatureDescription
    end

The XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription type exposes the following members.

Constructors
 | Name | Description
Public method | XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription | Constructs the SHA-384 XML signature algorithm description.
Top
Properties
 | Name | Description
Public property | DeformatterAlgorithm | Gets or sets the deformatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | DigestAlgorithm | Gets or sets the digest algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | FormatterAlgorithm | Gets or sets the formatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | KeyAlgorithm | Gets or sets the key algorithm for the signature description. (Inherited from SignatureDescription.)
Top
Methods
 | Name | Description
Public method | CreateDeformatter | Creates the deformatter. (Overrides SignatureDescriptionCreateDeformatter(AsymmetricAlgorithm).)
Public method | CreateDigest | Creates a HashAlgorithm instance using the DigestAlgorithm property. (Inherited from SignatureDescription.)
Public method | CreateFormatter | Creates the formatter. (Overrides SignatureDescriptionCreateFormatter(AsymmetricAlgorithm).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA384SignatureDescription Constructor

XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription Constructor

Constructs the SHA-384 XML signature algorithm description.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RSAPKCS1SHA384SignatureDescription()
Public Sub New
public:
RSAPKCS1SHA384SignatureDescription()
new : unit -> RSAPKCS1SHA384SignatureDescription
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


RSAPKCS1SHA384SignatureDescription Properties

The XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription type exposes the following members.

Properties
 | Name | Description
Public property | DeformatterAlgorithm | Gets or sets the deformatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | DigestAlgorithm | Gets or sets the digest algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | FormatterAlgorithm | Gets or sets the formatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | KeyAlgorithm | Gets or sets the key algorithm for the signature description. (Inherited from SignatureDescription.)
Top
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


RSAPKCS1SHA384SignatureDescription Methods

The XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription type exposes the following members.

Methods
 | Name | Description
Public method | CreateDeformatter | Creates the deformatter. (Overrides SignatureDescriptionCreateDeformatter(AsymmetricAlgorithm).)
Public method | CreateDigest | Creates a HashAlgorithm instance using the DigestAlgorithm property. (Inherited from SignatureDescription.)
Public method | CreateFormatter | Creates the formatter. (Overrides SignatureDescriptionCreateFormatter(AsymmetricAlgorithm).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA384SignatureDescription.CreateDeformatter Method

XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescriptionCreateDeformatter Method

Creates the deformatter.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override AsymmetricSignatureDeformatter CreateDeformatter(
    AsymmetricAlgorithm key
)
Public Overrides Function CreateDeformatter (
    key As AsymmetricAlgorithm
) As AsymmetricSignatureDeformatter
public:
virtual AsymmetricSignatureDeformatter^ CreateDeformatter(
    AsymmetricAlgorithm^ key
) override
abstract CreateDeformatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureDeformatter
override CreateDeformatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureDeformatter

Parameters

key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key.

Return Value

Type: AsymmetricSignatureDeformatter
The deformatter.
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA384SignatureDescription.CreateFormatter Method

XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescriptionCreateFormatter Method

Creates the formatter.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override AsymmetricSignatureFormatter CreateFormatter(
    AsymmetricAlgorithm key
)
Public Overrides Function CreateFormatter (
    key As AsymmetricAlgorithm
) As AsymmetricSignatureFormatter
public:
virtual AsymmetricSignatureFormatter^ CreateFormatter(
    AsymmetricAlgorithm^ key
) override
abstract CreateFormatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureFormatter
override CreateFormatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureFormatter

Parameters

key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key.

Return Value

Type: AsymmetricSignatureFormatter
The formatter.
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA384SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA512SignatureDescription Class

XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription Class

Describes the SHA-512 XML signature algorithm.
Inheritance Hierarchy
SystemObject
System.Security.CryptographySignatureDescription
ComponentSpace.SAML2.UtilityXMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public class RSAPKCS1SHA512SignatureDescription : SignatureDescription
Public Class RSAPKCS1SHA512SignatureDescription
    Inherits SignatureDescription
public ref class RSAPKCS1SHA512SignatureDescription : public SignatureDescription
type RSAPKCS1SHA512SignatureDescription =
    class
        inherit SignatureDescription
    end

The XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription type exposes the following members.

Constructors
 | Name | Description
Public method | XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription | Constructs the SHA-512 XML signature algorithm description.
Top
Properties
 | Name | Description
Public property | DeformatterAlgorithm | Gets or sets the deformatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | DigestAlgorithm | Gets or sets the digest algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | FormatterAlgorithm | Gets or sets the formatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | KeyAlgorithm | Gets or sets the key algorithm for the signature description. (Inherited from SignatureDescription.)
Top
Methods
 | Name | Description
Public method | CreateDeformatter | Creates the deformatter. (Overrides SignatureDescriptionCreateDeformatter(AsymmetricAlgorithm).)
Public method | CreateDigest | Creates a HashAlgorithm instance using the DigestAlgorithm property. (Inherited from SignatureDescription.)
Public method | CreateFormatter | Creates the formatter. (Overrides SignatureDescriptionCreateFormatter(AsymmetricAlgorithm).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA512SignatureDescription Constructor

XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription Constructor

Constructs the SHA-512 XML signature algorithm description.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public RSAPKCS1SHA512SignatureDescription()
Public Sub New
public:
RSAPKCS1SHA512SignatureDescription()
new : unit -> RSAPKCS1SHA512SignatureDescription
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


RSAPKCS1SHA512SignatureDescription Properties

The XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription type exposes the following members.

Properties
 | Name | Description
Public property | DeformatterAlgorithm | Gets or sets the deformatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | DigestAlgorithm | Gets or sets the digest algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | FormatterAlgorithm | Gets or sets the formatter algorithm for the signature description. (Inherited from SignatureDescription.)
Public property | KeyAlgorithm | Gets or sets the key algorithm for the signature description. (Inherited from SignatureDescription.)
Top
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


RSAPKCS1SHA512SignatureDescription Methods

The XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription type exposes the following members.

Methods
 | Name | Description
Public method | CreateDeformatter | Creates the deformatter. (Overrides SignatureDescriptionCreateDeformatter(AsymmetricAlgorithm).)
Public method | CreateDigest | Creates a HashAlgorithm instance using the DigestAlgorithm property. (Inherited from SignatureDescription.)
Public method | CreateFormatter | Creates the formatter. (Overrides SignatureDescriptionCreateFormatter(AsymmetricAlgorithm).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA512SignatureDescription.CreateDeformatter Method

XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescriptionCreateDeformatter Method

Creates the deformatter.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override AsymmetricSignatureDeformatter CreateDeformatter(
    AsymmetricAlgorithm key
)
Public Overrides Function CreateDeformatter (
    key As AsymmetricAlgorithm
) As AsymmetricSignatureDeformatter
public:
virtual AsymmetricSignatureDeformatter^ CreateDeformatter(
    AsymmetricAlgorithm^ key
) override
abstract CreateDeformatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureDeformatter
override CreateDeformatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureDeformatter

Parameters

key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key.

Return Value

Type: AsymmetricSignatureDeformatter
The deformatter.
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace


XMLSignatureDescriptions.RSAPKCS1SHA512SignatureDescription.CreateFormatter Method

XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescriptionCreateFormatter Method

Creates the formatter.

Namespace: ComponentSpace.SAML2.Utility
Assembly: ComponentSpace.SAML2 (in ComponentSpace.SAML2.dll) Version: 2.6.0.19
Syntax
C#
VB
C++
F#
Copy
public override AsymmetricSignatureFormatter CreateFormatter(
    AsymmetricAlgorithm key
)
Public Overrides Function CreateFormatter (
    key As AsymmetricAlgorithm
) As AsymmetricSignatureFormatter
public:
virtual AsymmetricSignatureFormatter^ CreateFormatter(
    AsymmetricAlgorithm^ key
) override
abstract CreateFormatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureFormatter
override CreateFormatter :
        key : AsymmetricAlgorithm -> AsymmetricSignatureFormatter

Parameters

key
Type: System.Security.CryptographyAsymmetricAlgorithm
The key.

Return Value

Type: AsymmetricSignatureFormatter
The formatter.
See Also

Reference

XMLSignatureDescriptionsRSAPKCS1SHA512SignatureDescription Class
ComponentSpace.SAML2.Utility Namespace