PLUSManaged API

PLUSManaged API Reference
PLUSManaged API

Welcome to the PLUSManaged API reference. This reference acts as a supplement for the Protection PLUS 5 SDK manual, and is meant to provide very detailed documentation specifically for the PLUSManaged and PLUSManagedGui APIs/libraries.

Note Note
If you need content which is more instructional, or describes how to use the PLUSManaged and/or PLUSManagedGui APIs at a higher level, please refer to the Protection PLUS 5 manual instead.
Trademark Acknowledgments

Concept Software, Inc.

  • SoftwareKey
  • SoftwareKey System
  • Protection PLUS
  • PLUSManaged
  • PLUSManagedGui
  • Instant PLUS
  • Instant SOLO
  • Instant SOLO Server
  • SOLO Server
  • Electronic License Activation
  • ELA
  • Electronic License Management
  • ELM

Microsoft Corporation

  • Microsoft
  • Windows
  • Visual Basic
  • Visual Basic .NET
  • VB.NET
  • Visual C#
  • C#
  • Visual C++
  • ActiveX
  • .NET
  • .NET Framework

RSA Security, Inc.

  • RSA
See Also

Other Resources

Protection PLUS 5 SDK manual
Technical support

Copyright © 2017 Concept Software, Inc.

Send comments on this topic to support@softwarekey.com


PLUSManaged API Namespaces

PLUSManaged API Namespaces
Namespaces
Namespace | Description
com.softwarekey.Client.Compatibility.ProtectionPLUS4 | Contains classes and data for Protection PLUS 4 compatibility
com.softwarekey.Client.Encryption | Contains routines for implementing encryption used for License Files and web service calls.
com.softwarekey.Client.Gui | Contains classes and data for licensing GUIs, such as the PLUSManagedGui Windows Forms component.
com.softwarekey.Client.Licensing | Contains classes and data for licensing.
com.softwarekey.Client.Licensing.Network | Contains classes and data for network licensing.
com.softwarekey.Client.Utils | Contains utility classes.
com.softwarekey.Client.Utils.SystemComponent | Contains classes used to identify various system/hardware components.
com.softwarekey.Client.WebService | Contains classes and data for making calls to SOLO Server web services.
com.softwarekey.Client.WebService.XmlActivationService | Contains classes and data for making calls to the XmlActivationService web service.
com.softwarekey.Client.WebService.XmlLicenseFileService | Contains classes and data for making calls to the XmlLicenseFileService web service.
com.softwarekey.Client.WebService.XmlLicenseService | Contains classes and data for making calls to the XmlLicenseService web service.
com.softwarekey.Client.WebService.XmlNetworkFloatingService | Contains classes and data for making calls to the XmlNetworkFloatingService web service. Direct use of these objects is atypical, as it would normally be used through a [com.softwarekey.Client.Licensing.Network.NetworkSession] object.


com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace

com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace
Contains classes and data for Protection PLUS 4 compatibility
Classes
Class Description
Public class AutomationClientWebFormCall
Base implementation for Automation Client web form calls.
Public class GetLicenseStatus

Implementation for calling server-side scripts which were originally designed to work with the Automation Client's SK_GetLicenseStatus and SK_GetLicenseStatusEx functions.

Public class GetRegData

Implementation for calling server-side scripts which were originally designed to with with the Automation Client's SK_GetRegData and SK_GetRegDataEx functions.

Public class GetTcData

Implementation for calling server-side scripts which were originally designed to with with the Automation Client's SK_GetTCData and SK_GetTCDataEx functions.

Public class PLUS4Methods
Static methods for Protection PLUS 4 compatibility.
PostEvalData

Implementation for calling server-side scripts which were originally designed to with with the Automation Client's SK_PostEvalData and SK_PostEvalDataEx functions.

Note Note

Before calling the CallWebForm method, the following properties must be set:

  • ProductID (In most cases, this should match the value used in License.ThisProductID.)
  • Email

Before calling the CallWebForm method, the following properties may be set:

  • CompanyName
  • DistributorID
  • FirstName
  • LastName
  • Address1
  • Address2
  • City
  • StateProvince
  • PostalCode
  • Country
  • Phone
  • Source
  • UserDefinedString1
  • UserDefinedString2
  • UserDefinedString3
  • UserDefinedString4
  • UserDefinedString5
  • UserDefinedString6
  • UserDefinedString7

Your application is responsible for enforcing what data your users are required to enter.

Examples
This example shows how to make a typical activation call for a PLUSManaged license:
C#
VB
C++
Copy
public bool PostEvaluationData(int productID, string email, string companyName, string firstName, string lastName, string phone, out int registrationID)
{
    //TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL or SOLO Server.
    PostEvalData evalCall = new PostEvalData("https://secure.softwarekey.com/solo/products/trialsignup.asp");
    evalCall.ProductID = productID;
    evalCall.Email = email;
    evalCall.CompanyName = companyName;
    evalCall.FirstName = firstName;
    evalCall.LastName = lastName;
    evalCall.Phone = phone;
    //TODO: Add additional arguments to this function and initialize additional properties here as needed.

    //TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    bool successful = evalCall.CallWebForm();
    if (successful)
    {
        registrationID = evalCall.RegistrationID;
    }
    else
    {
        registrationID = 0;
        //TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    }

    return successful;
}
Public Function PostEvaluationData(ByVal productID As Integer, ByVal email As String, ByVal companyName As String, ByVal firstName As String, ByVal lastName As String, ByVal phone As String, ByRef registrationID As Integer) As Boolean
    'TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL or SOLO Server.
    Dim evalCall As New PostEvalData("https://secure.softwarekey.com/solo/unlock/getcode.asp")
    evalCall.ProductID = productID
    evalCall.Email = email
    evalCall.CompanyName = companyName
    evalCall.FirstName = firstName
    evalCall.LastName = lastName
    evalCall.Phone = phone
    'TODO: Add additional arguments to this function and initialize additional properties here as needed.

    'TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    Dim successful As Boolean = evalCall.CallWebForm()
    If successful Then
        registrationID = evalCall.RegistrationID
    Else
        registrationID = 0
        'TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    End If

    Return successful
End Function

No code example is currently available or this language may not be supported.

PostRegData

Implementation for calling server-side scripts which were originally designed to with with the Automation Client's SK_PostRegData function. If you are using SOLO Server (including Instant SOLO Server and Instant SOLO Server Dedicated URL), then you should use UpdateRegistration.

Note Note

Before calling the CallWebForm method, the following properties must be set:

  • LicenseID
  • Password

Before calling the CallWebForm method, the following properties may be set:

  • CompanyName
  • FirstName
  • LastName
  • Address1
  • Address2
  • City
  • StateProvince
  • PostalCode
  • Country
  • Phone
  • Fax
  • Email
  • Overwrite
  • NotifyProduct
  • NotifyPartners

Your application is responsible for enforcing what data your users are required to enter.

Caution note Caution

It is important to note that leaving any of the optional fields empty above will result in an empty value being stored. This is especially something to be aware of when setting the Overwrite property to true.

Examples
This example shows how to make a typical activation call for a PLUSManaged license:
C#
VB
C++
Copy
public bool PostRegistrationData(int licenseID, string password, string email, string companyName, string firstName, string lastName, string phone)
{
    //TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL, or SOLO Server.
    PostRegData registrationCall = new PostRegData("https://secure.softwarekey.com/solo/postings/postregdata.asp");
    registrationCall.LicenseID = licenseID;
    registrationCall.Password = password;
    registrationCall.Email = email;
    registrationCall.CompanyName = companyName;
    registrationCall.FirstName = firstName;
    registrationCall.LastName = lastName;
    registrationCall.Phone = phone;
    //TODO: Add additional arguments to this function and initialize additional properties here as needed.

    //TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    bool successful = registrationCall.CallWebForm();
    if (!successful)
    {
        //TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    }

    return successful;
}
Public Function PostRegistrationData(ByVal licenseID As Integer, ByVal password As String, ByVal email As String, ByVal companyName As String, ByVal firstName As String, ByVal lastName As String, ByVal phone As String, ByRef registrationID As Integer) As Boolean
    'TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL, or SOLO Server.
    Dim registrationCall As New PostRegData("https://secure.softwarekey.com/solo/postings/postregdata.asp")
    registrationCall.LicenseID = licenseID
    registrationCall.Password = password
    registrationCall.Email = email
    registrationCall.CompanyName = companyName
    registrationCall.FirstName = firstName
    registrationCall.LastName = lastName
    registrationCall.Phone = phone
    'TODO: Add additional arguments to this function and initialize additional properties here as needed.

    'TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    Dim successful As Boolean = registrationCall.CallWebForm()
    If Not successful Then
        'TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    End If

    Return successful
End Function

No code example is currently available or this language may not be supported.

Enumerations
 | Enumeration | Description
Public enumeration | AutomationClientError | Automation Client errors.


AutomationClientError Enumeration

AutomationClientError Enumeration
Automation Client errors.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum AutomationClientError
Public Enumeration AutomationClientError
public enum class AutomationClientError
Members
Member name | Value | Description
SWKERR_NONE | 0 | No error occurred. The operation was successful.
SWKERR_WINSOCK_STARTUP_ERROR | 1 | (Not applicable to PLUSManaged) Winsock could not be started.
SWKERR_WINSOCK_CANNOT_RESOLVE_HOST | 2 | (Not applicable to PLUSManaged, which will instead have an Exception object held in a property.) The specified server could not be found. Verify the computer is connected to the Internet, and that any firewall/proxy present is configured properly.
SWKERR_WINSOCK_CANNOT_CREATE_SOCKET | 3 | (Not applicable to PLUSManaged) This is an internal problem that is normally fixed by either rebooting the computer, or installing the latest version of Internet Explorer.
SWKERR_WINSOCK_CANNOT_CONNECT_TO_SERVER | 4 | (Not applicable to PLUSManaged, which will instead have an Exception object held in a property.) Could not connect to the specified server. Verify the computer is connected to the Internet, and that any firewall/proxy present is configured properly.
SWKERR_WINSOCK_CANNOT_SEND_DATA | 5 | (Not applicable to PLUSManaged) This is an internal problem that is normally fixed by either rebooting the computer, or installing the latest version of Internet Explorer.
SWKERR_WINSOCK_CANNOT_READ_DATA | 6 | (Not applicable to PLUSManaged) This is an internal problem that is normally fixed by either rebooting the computer, or installing the latest version of Internet Explorer.
SWKERR_NO_MORE_SOFTWARE_KEYS_AVAILABLE | 7 | The License ID has no (zero) activations left.
SWKERR_INVALID_SERVER_RESPONSE | 8 | The response received from the server is not in the expected format. This can sometimes indicate a response from something like a proxy sever, or an error on the server.
SWKERR_CANNOT_ALLOCATE_MEMORY | 9 | (Not applicable to PLUSManaged) This is an internal error, and you should contact technical support for assistance.
SWKERR_WINSOCK_CANNOT_RESOLVE_PROXY | 10 | (Not applicable to PLUSManaged) This is an internal error. Please contact technical support.
SWKERR_WININET_UNAVAILABLE | 11 | (Not applicable to PLUSManaged) When specifying WinInet only flags, WinInet is unavailable on the target system.
SWKERR_WININET_FUNCTION_UNAVAILABLE | 12 | (Not applicable to PLUSManaged) This is an internal error. Please contact technical support.
SWKERR_NO_CONNECTION | 13 | (Not applicable to PLUSManaged, which will instead have an Exception object held in a property.) No Internet connection is available.
SWKERR_INTERNAL_ERROR | 14 | (Not applicable to PLUSManaged) This is an internal error. Please contact technical support.
SWKERR_WINSOCK_CONNECT_ERROR | 15 | (Not applicable to PLUSManaged) Cannot connect to internet. Verify internet connection.
SWKERR_WINSOCK_BUFFER_OVERFLOW | 16 | (Not applicable to PLUSManaged) This is an internal error. Please contact technical support.
SWKERR_PARTIAL_CONNECTION | 17 | (Not applicable to PLUSManaged) This is an internal error. Please contact technical support.
SWKERR_INVALID_PROXY_LOGIN | 18 | (Not applicable to PLUSManaged) Verify that the proxy information entered by user is valid.
SWKERR_SERVER_DOWN | 19 | (Not applicable to PLUSManaged) The server is non-responsive, or the page is formatted improperly.
SWKERR_FILE_ERROR | 20 | (Not applicable to PLUSManaged) Could not create or open the file.
SWKERR_FTP_FILENOTFOUND | 21 | (Not applicable to PLUSManaged) File could not be found on FTP server.
SWKERR_CANCEL | 22 | (Not applicable to PLUSManaged) The user clicked "Cancel".
SWKERR_ERROR_CREATING_WINDOW | 23 | (Not applicable to PLUSManaged) While downloading a file, the "Download Dialog box" could not be created.
SWKERR_COULD_NOT_CREATE_FILE | 24 | (Not applicable to PLUSManaged) The file could not be created.
SWKERR_ITEMNOTFOUND | 25 | (Not applicable to PLUSManaged) The item specified is invalid, or non-existent.
SWKERR_INVALIDPASSWORD | 26 | (Not applicable to PLUSManaged) The "password" specified could not be validated.
SWKERR_UPLOADFAILED | 27 | (Not applicable to PLUSManaged) This is an internal error. Please contact technical support.
SWKERR_CONNECTION_TIMEOUT | 28 | (Not applicable to PLUSManaged) No longer used.
SWKERR_OS_INVALID | 29 | (Not applicable to PLUSManaged) The operating system does not support this functionality.
SWKERR_INVALID_PARAMETERS | 30 | (Not applicable to PLUSManaged) The parameter specified is invalid or out of range.
SWKERR_HTTP_FILENOTFOUND | 31 | (Not applicable to PLUSManaged) File could not be found on HTTP server.
SWKERR_ENCRYPTION_FAILED | 32 | (Not applicable to PLUSManaged - See WebServiceCall implementations and methods available in the License class.) Failed to encrypt web service request.
SWKERR_SIGNING_FAILED | 33 | (Not applicable to PLUSManaged - See WebServiceCall implementations and methods available in the License class.) Failed to sign web service request.
SWKERR_DECRYPTION_FAILED | 34 | (Not applicable to PLUSManaged - See WebServiceCall implementations and methods available in the License class.) Failed to decrypt web service response.
SWKERR_VERIFICATION_FAILED | 35 | (Not applicable to PLUSManaged - See WebServiceCall implementations and methods available in the License class.) Failed to verify signature of web service response.
SWKERR_CANONICALIZATION_FAILED | 36 | (Not applicable to PLUSManaged - See WebServiceCall implementations and methods available in the License class.) Failed to canonicalize web service response.
SWKERR_WEBSERVICE_RETURNED_FAILURE | 37 | (Not applicable to PLUSManaged - See WebServiceCall implementations and methods available in the License class.) Call succeeded but web service returned an error.
SWKERR_LOG_ENTRYNOTFOUND | 38 | (Not applicable to PLUSManaged) Previous usage log entry no found.
SWKERR_LOG_CANNOT_ERASE | 39 | (Not applicable to PLUSManaged) Failed to delete usage log.
SWKERR_LOG_CANNOT_OPEN | 40 | (Not applicable to PLUSManaged) Failed to open usage log.
SWKERR_CANNOT_PARSE_RESPONSE | 41 | (Not applicable to PLUSManaged - See WebServiceCall implementations and methods available in the License class.) Failed to parse a web service response.
See Also

Reference

com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


AutomationClientWebFormCall Class

AutomationClientWebFormCall Class
Base implementation for Automation Client web form calls.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4AutomationClientWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4GetLicenseStatus
com.softwarekey.Client.Compatibility.ProtectionPLUS4GetRegData
com.softwarekey.Client.Compatibility.ProtectionPLUS4GetTcData
com.softwarekey.Client.Compatibility.ProtectionPLUS4PostEvalData
com.softwarekey.Client.Compatibility.ProtectionPLUS4PostRegData

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class AutomationClientWebFormCall : WebFormCall
Public MustInherit Class AutomationClientWebFormCall
    Inherits WebFormCall
public ref class AutomationClientWebFormCall abstract : public WebFormCall

The AutomationClientWebFormCall type exposes the following members.

Constructors
 | Name | Description
Public method | AutomationClientWebFormCall | Creates a new AutomationClientWebFormCall object.
Top
Properties
 | Name | Description
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code.
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Top
Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides WebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response.
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response.
Top
See Also

Reference

com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


AutomationClientWebFormCall Constructor

AutomationClientWebFormCall Constructor
Creates a new AutomationClientWebFormCall object.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public AutomationClientWebFormCall(
    string url,
    WebFormCallHttpMethod method
)
Public Sub New (
    url As String,
    method As WebFormCallHttpMethod
)
public:
AutomationClientWebFormCall(
    String^ url,
    WebFormCallHttpMethod method
)

Parameters

url
Type: SystemString
The URL to the web form.
method
Type: com.softwarekey.Client.WebServiceWebFormCallHttpMethod
The WebFormCallHttpMethod that will be used for this object.
See Also

Reference

AutomationClientWebFormCall Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


AutomationClientWebFormCall Properties

AutomationClientWebFormCall Properties

The AutomationClientWebFormCall type exposes the following members.

Properties
 | Name | Description
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code.
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Top
See Also

Reference

AutomationClientWebFormCall Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


AutomationClientWebFormCall.AutomationClientErrorCode Property

AutomationClientWebFormCallAutomationClientErrorCode Property
Gets or sets the Automation Client error code.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int AutomationClientErrorCode { get; set; }
Public Property AutomationClientErrorCode As Integer
    Get
    Set
public:
property int AutomationClientErrorCode {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AutomationClientWebFormCall Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


AutomationClientWebFormCall Methods

AutomationClientWebFormCall Methods

The AutomationClientWebFormCall type exposes the following members.

Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides WebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response.
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response.
Top
See Also

Reference

AutomationClientWebFormCall Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


AutomationClientWebFormCall.CallWebForm Method

AutomationClientWebFormCallCallWebForm Method
Calls the Automation Client web page.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool CallWebForm()
Public Overrides Function CallWebForm As Boolean
public:
virtual bool CallWebForm() override

Return Value

Type: Boolean
Returns true if successful. If false is returned, check the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
See Also

Reference

AutomationClientWebFormCall Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


AutomationClientWebFormCall.TryParseValueFromResponse Method

AutomationClientWebFormCallTryParseValueFromResponse Method
Overload List
 | Name | Description
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response.
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response.
Top
See Also

Reference

AutomationClientWebFormCall Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


AutomationClientWebFormCall.TryParseValueFromResponse Method (String, Int32)

AutomationClientWebFormCallTryParseValueFromResponse Method (String, Int32)
Tries to parse a 32 bit integer value from the Response.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool TryParseValueFromResponse(
    string searchString,
    out int value
)
Public Function TryParseValueFromResponse (
    searchString As String,
    <OutAttribute> ByRef value As Integer
) As Boolean
public:
bool TryParseValueFromResponse(
    String^ searchString,
    [OutAttribute] int% value
)

Parameters

searchString
Type: SystemString
The search string used to locate the value in the Response.
value
Type: SystemInt32
The parsed value.

Return Value

Type: Boolean
Returns true if the value was successfully parsed. If false was returned, check the LastException property for a possible cause.
See Also

Reference

AutomationClientWebFormCall Class
TryParseValueFromResponse Overload
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


AutomationClientWebFormCall.TryParseValueFromResponse Method (String, String)

AutomationClientWebFormCallTryParseValueFromResponse Method (String, String)
Tries to parse a string value from the Response.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool TryParseValueFromResponse(
    string searchString,
    out string value
)
Public Function TryParseValueFromResponse (
    searchString As String,
    <OutAttribute> ByRef value As String
) As Boolean
public:
bool TryParseValueFromResponse(
    String^ searchString,
    [OutAttribute] String^% value
)

Parameters

searchString
Type: SystemString
The search string used to locate the value in the Response.
value
Type: SystemString
The parsed value.

Return Value

Type: Boolean
Returns true if the value was successfully parsed. If false was returned, check the LastException property for a possible cause.
See Also

Reference

AutomationClientWebFormCall Class
TryParseValueFromResponse Overload
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus Class

GetLicenseStatus Class

Implementation for calling server-side scripts which were originally designed to work with the Automation Client's SK_GetLicenseStatus and SK_GetLicenseStatusEx functions.

Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4AutomationClientWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4GetLicenseStatus

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class GetLicenseStatus : AutomationClientWebFormCall
Public Class GetLicenseStatus
    Inherits AutomationClientWebFormCall
public ref class GetLicenseStatus : public AutomationClientWebFormCall

The GetLicenseStatus type exposes the following members.

Constructors
 | Name | Description
Public method | GetLicenseStatus | Creates a new GetLicenseStatus object.
Top
Properties
 | Name | Description
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code. (Inherited from AutomationClientWebFormCall.)
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | LicenseID | Gets or sets the License ID (required).
Public property | LicenseUpdate | Gets the License Update data.
Public property | Password | Gets or sets password (required).
Public property | ProductID | Gets or sets the Product ID. When specified, the License ID must be for the Product ID specified.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | ReplacedBy | Gets the License ID which replaced the License ID which was validated by this object.
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | Status | Gets the status of the License ID.
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Top
Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides AutomationClientWebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response. (Inherited from AutomationClientWebFormCall.)
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response. (Inherited from AutomationClientWebFormCall.)
Top
Remarks

In general, if you are using SOLO Server, you should be using License.CheckInstallationStatus or the WebServiceCall implementation for status checks. The same information can also be retrieved from SOLO Server using InfoCheck.

Note Note

Before calling the CallWebForm method, the following properties must be set:

  • LicenseID

Optional fields that may be populated before calling CallWebForm method include:

  • Password
  • ProductID - When set, the License ID specified must be for the specified Product ID. (In most cases, this should match the value used in License.ThisProductID.)
Examples
This example shows how to make a typical activation call for a PLUSManaged license:
C#
VB
C++
Copy
public bool RetrieveLicenseStatus(int licenseID, string password, int productID, out string status, out int replacedBy, out string licenseUpdate)
{
    //TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL, or SOLO Server.
    GetLicenseStatus statusCall = new GetLicenseStatus("https://secure.softwarekey.com/solo/customers/getlicensestatus.asp");
    statusCall.LicenseID = licenseID;
    statusCall.Password = password;
    statusCall.ProductID = productID;

    //TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    bool successful = statusCall.CallWebForm();
    if (successful)
    {
        status = statusCall.Status;
        replacedBy = statusCall.ReplacedBy;
        licenseUpdate = statusCall.LicenseUpdate;
    }
    else
    {
        status = "";
        replacedBy = 0;
        licenseUpdate = "";
        //TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    }

    return successful;
}
Public Function RetrieveLicenseStatus(ByVal licenseID As Integer, ByVal password As String, ByVal productID As Integer, ByRef status As String, ByRef replacedBy As Integer, ByRef LicenseUpdate As String) As Boolean
    'TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL, or SOLO Server.
    Dim statusCall As New GetLicenseStatus("https://secure.softwarekey.com/solo/customers/getlicensestatus.asp")
    statusCall.LicenseID = licenseID
    statusCall.Password = password
    statusCall.ProductID = productID

    'TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    Dim successful As Boolean = statusCall.CallWebForm()
    If successful Then
        status = statusCall.Status
        replacedBy = statusCall.ReplacedBy
        licenseUpdate = statusCall.LicenseUpdate
    Else
        status = ""
        replacedBy = 0
        licenseUpdate = ""
        'TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    End If

    Return successful
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus Constructor

GetLicenseStatus Constructor
Creates a new GetLicenseStatus object.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public GetLicenseStatus(
    string url
)
Public Sub New (
    url As String
)
public:
GetLicenseStatus(
    String^ url
)

Parameters

url
Type: SystemString
The URL to the web form.
See Also

Reference

GetLicenseStatus Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus Properties

GetLicenseStatus Properties

The GetLicenseStatus type exposes the following members.

Properties
 | Name | Description
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code. (Inherited from AutomationClientWebFormCall.)
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | LicenseID | Gets or sets the License ID (required).
Public property | LicenseUpdate | Gets the License Update data.
Public property | Password | Gets or sets password (required).
Public property | ProductID | Gets or sets the Product ID. When specified, the License ID must be for the Product ID specified.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | ReplacedBy | Gets the License ID which replaced the License ID which was validated by this object.
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | Status | Gets the status of the License ID.
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Top
See Also

Reference

GetLicenseStatus Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus.LicenseID Property

GetLicenseStatusLicenseID Property
Gets or sets the License ID (required).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GetLicenseStatus Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus.LicenseUpdate Property

GetLicenseStatusLicenseUpdate Property
Gets the License Update data.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseUpdate { get; }
Public ReadOnly Property LicenseUpdate As String
    Get
public:
property String^ LicenseUpdate {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetLicenseStatus Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus.Password Property

GetLicenseStatusPassword Property
Gets or sets password (required).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GetLicenseStatus Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus.ProductID Property

GetLicenseStatusProductID Property
Gets or sets the Product ID. When specified, the License ID must be for the Product ID specified.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; set; }
Public Property ProductID As Integer
    Get
    Set
public:
property int ProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GetLicenseStatus Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus.ReplacedBy Property

GetLicenseStatusReplacedBy Property
Gets the License ID which replaced the License ID which was validated by this object.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ReplacedBy { get; }
Public ReadOnly Property ReplacedBy As Integer
    Get
public:
property int ReplacedBy {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

GetLicenseStatus Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus.Status Property

GetLicenseStatusStatus Property
Gets the status of the License ID.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Status { get; }
Public ReadOnly Property Status As String
    Get
public:
property String^ Status {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetLicenseStatus Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus Methods

GetLicenseStatus Methods

The GetLicenseStatus type exposes the following members.

Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides AutomationClientWebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response. (Inherited from AutomationClientWebFormCall.)
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response. (Inherited from AutomationClientWebFormCall.)
Top
See Also

Reference

GetLicenseStatus Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetLicenseStatus.CallWebForm Method

GetLicenseStatusCallWebForm Method
Calls the Automation Client web page.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool CallWebForm()
Public Overrides Function CallWebForm As Boolean
public:
virtual bool CallWebForm() override

Return Value

Type: Boolean
Returns true if successful. If false is returned, check the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
See Also

Reference

GetLicenseStatus Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData Class

GetRegData Class

Implementation for calling server-side scripts which were originally designed to with with the Automation Client's SK_GetRegData and SK_GetRegDataEx functions.

Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4AutomationClientWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4GetRegData

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class GetRegData : AutomationClientWebFormCall
Public Class GetRegData
    Inherits AutomationClientWebFormCall
public ref class GetRegData : public AutomationClientWebFormCall

The GetRegData type exposes the following members.

Constructors
 | Name | Description
Public method | GetRegData | Creates a new GetRegData object.
Top
Properties
 | Name | Description
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code. (Inherited from AutomationClientWebFormCall.)
Public property | CompanyName | Gets the customer's company name.
Public property | ContactName | Gets the customer's name.
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | Email | Gets the customer's email address.
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | LicenseID | Gets or sets the License ID (required).
Public property | Password | Gets or sets password (required).
Public property | Phone | Gets the customer's phone number.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Public property | UserDefinedString1 | Gets the User Defined String 1 value, which often contains the customer's street address (or line 1 of the customer's address).
Public property | UserDefinedString2 | Gets the User Defined String 2 value, which often contains the customer's second address line (i.e. apartment or suite number).
Public property | UserDefinedString3 | Gets the User Defined String 3 value, which often contains the customer's third address line (usually including City, State/Province, and Zip/Postal Code).
Public property | UserDefinedString4 | Gets the User Defined String 4 value, which often contains the country of the customer's address.
Public property | UserDefinedString5 | Gets the User Defined String 5 value, which often contains the customer's fax number.
Top
Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides AutomationClientWebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response. (Inherited from AutomationClientWebFormCall.)
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response. (Inherited from AutomationClientWebFormCall.)
Top
Remarks

In general, if you are using SOLO Server, all of the information provided by this script is included with the license files returned by SOLO Server when using License.ActivateInstallationLicenseFile or the WebServiceCall implementation for activation. Additionally, InfoCheck may be used to retrieve registration data from SOLO Server as well.

Note Note

Before calling the CallWebForm method, the following properties must be set:

  • LicenseID
  • Password
Examples
This example shows how to make a typical call:
C#
VB
C++
Copy
public bool RetrieveRegistrationData(int licenseID, string password, out string companyName, out string contactName, out string email)
{
    //TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL, or SOLO Server.
    GetRegData registrationCall = new GetRegData("https://secure.softwarekey.com/solo/customers/getregdata.asp");
    registrationCall.LicenseID = licenseID;
    registrationCall.Password = password;

    //TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    bool successful = registrationCall.CallWebForm();
    if (successful)
    {
        companyName = registrationCall.CompanyName;
        contactName = registrationCall.ContactName;
        email = registrationCall.Email;
    }
    else
    {
        companyName = "";
        contactName = "";
        email = "";
        //TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    }

    //TODO: This sample function's prototype only supports a subset of values returned by a GetRegData call.  You may add additional parameters and update the function as needed.

    return successful;
}
Public Function RetrieveRegistrationData(ByVal licenseID As Integer, ByVal password As String, ByRef companyName As String, ByRef contactName As String, ByRef email As String) As Boolean
    'TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL, or SOLO Server.
    Dim registrationCall As New GetRegData("https://secure.softwarekey.com/solo/customers/getregdata.asp")
    registrationCall.LicenseID = licenseID
    registrationCall.Password = password

    'TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    Dim successful As Boolean = registrationCall.CallWebForm()
    If successful Then
        companyName = registrationCall.CompanyName
        contactName = registrationCall.ContactName
        email = registrationCall.Email
    Else
        companyName = ""
        contactName = ""
        email = ""
        'TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    End If

    'TODO: This sample function's prototype only supports a subset of values returned by a GetRegData call.  You may add additional parameters and update the function as needed.

    Return successful
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData Constructor

GetRegData Constructor
Creates a new GetRegData object.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public GetRegData(
    string url
)
Public Sub New (
    url As String
)
public:
GetRegData(
    String^ url
)

Parameters

url
Type: SystemString
The URL to the web form.
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData Properties

GetRegData Properties

The GetRegData type exposes the following members.

Properties
 | Name | Description
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code. (Inherited from AutomationClientWebFormCall.)
Public property | CompanyName | Gets the customer's company name.
Public property | ContactName | Gets the customer's name.
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | Email | Gets the customer's email address.
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | LicenseID | Gets or sets the License ID (required).
Public property | Password | Gets or sets password (required).
Public property | Phone | Gets the customer's phone number.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Public property | UserDefinedString1 | Gets the User Defined String 1 value, which often contains the customer's street address (or line 1 of the customer's address).
Public property | UserDefinedString2 | Gets the User Defined String 2 value, which often contains the customer's second address line (i.e. apartment or suite number).
Public property | UserDefinedString3 | Gets the User Defined String 3 value, which often contains the customer's third address line (usually including City, State/Province, and Zip/Postal Code).
Public property | UserDefinedString4 | Gets the User Defined String 4 value, which often contains the country of the customer's address.
Public property | UserDefinedString5 | Gets the User Defined String 5 value, which often contains the customer's fax number.
Top
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.CompanyName Property

GetRegDataCompanyName Property
Gets the customer's company name.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CompanyName { get; }
Public ReadOnly Property CompanyName As String
    Get
public:
property String^ CompanyName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.ContactName Property

GetRegDataContactName Property
Gets the customer's name.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ContactName { get; }
Public ReadOnly Property ContactName As String
    Get
public:
property String^ ContactName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.Email Property

GetRegDataEmail Property
Gets the customer's email address.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Email { get; }
Public ReadOnly Property Email As String
    Get
public:
property String^ Email {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.LicenseID Property

GetRegDataLicenseID Property
Gets or sets the License ID (required).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.Password Property

GetRegDataPassword Property
Gets or sets password (required).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.Phone Property

GetRegDataPhone Property
Gets the customer's phone number.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Phone { get; }
Public ReadOnly Property Phone As String
    Get
public:
property String^ Phone {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.UserDefinedString1 Property

GetRegDataUserDefinedString1 Property
Gets the User Defined String 1 value, which often contains the customer's street address (or line 1 of the customer's address).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString1 { get; }
Public ReadOnly Property UserDefinedString1 As String
    Get
public:
property String^ UserDefinedString1 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.UserDefinedString2 Property

GetRegDataUserDefinedString2 Property
Gets the User Defined String 2 value, which often contains the customer's second address line (i.e. apartment or suite number).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString2 { get; }
Public ReadOnly Property UserDefinedString2 As String
    Get
public:
property String^ UserDefinedString2 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.UserDefinedString3 Property

GetRegDataUserDefinedString3 Property
Gets the User Defined String 3 value, which often contains the customer's third address line (usually including City, State/Province, and Zip/Postal Code).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString3 { get; }
Public ReadOnly Property UserDefinedString3 As String
    Get
public:
property String^ UserDefinedString3 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.UserDefinedString4 Property

GetRegDataUserDefinedString4 Property
Gets the User Defined String 4 value, which often contains the country of the customer's address.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString4 { get; }
Public ReadOnly Property UserDefinedString4 As String
    Get
public:
property String^ UserDefinedString4 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.UserDefinedString5 Property

GetRegDataUserDefinedString5 Property
Gets the User Defined String 5 value, which often contains the customer's fax number.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString5 { get; }
Public ReadOnly Property UserDefinedString5 As String
    Get
public:
property String^ UserDefinedString5 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData Methods

GetRegData Methods

The GetRegData type exposes the following members.

Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides AutomationClientWebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response. (Inherited from AutomationClientWebFormCall.)
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response. (Inherited from AutomationClientWebFormCall.)
Top
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetRegData.CallWebForm Method

GetRegDataCallWebForm Method
Calls the Automation Client web page.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool CallWebForm()
Public Overrides Function CallWebForm As Boolean
public:
virtual bool CallWebForm() override

Return Value

Type: Boolean
Returns true if successful. If false is returned, check the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
See Also

Reference

GetRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData Class

GetTcData Class

Implementation for calling server-side scripts which were originally designed to with with the Automation Client's SK_GetTCData and SK_GetTCDataEx functions.

Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4AutomationClientWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4GetTcData

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class GetTcData : AutomationClientWebFormCall
Public Class GetTcData
    Inherits AutomationClientWebFormCall
public ref class GetTcData : public AutomationClientWebFormCall

The GetTcData type exposes the following members.

Constructors
 | Name | Description
Public method | GetTcData | Creates a new GetTcData object.
Top
Properties
 | Name | Description
Public property | ActivationCode1 | Gets Activation Code 1. This is also known as "RegKey1" in Protection PLUS 4, and will be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the codes using ValidateTriggerCode(Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32).
Public property | ActivationCode2 | Gets or sets Activation Code 2. This is also known as "RegKey2" in Protection PLUS 4, and may be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the codes using ValidateTriggerCode(Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32).
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code. (Inherited from AutomationClientWebFormCall.)
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | LicenseID | Gets or sets the License ID (required).
Public property | LicenseUpdate | Gets the License Update data.
Public property | Password | Gets or sets password (required).
Public property | ProductID | Gets or sets the Product ID. When specified, the License ID must be for the Product ID specified.
Public property | ProductOptionID | Gets or sets the Product Option ID. When set, the License ID must be for the Product Option ID specified.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Public property | UserCode1 | Gets or sets User Code 1 (required). In Protection PLUS 4, this is also referred to as the "Session Code" or "cenum". This value can be generated using PLUS4Methods.GenerateUserCode1Value.
Public property | UserCode2 | Gets or sets User Code 2 (required). In Protection PLUS, this is also referred to as the "Computer ID". This value can be generated using PLUS4Methods.GenerateUserCode2Value.
Top
Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides AutomationClientWebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response. (Inherited from AutomationClientWebFormCall.)
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response. (Inherited from AutomationClientWebFormCall.)
Top
Remarks

In general, if you are using SOLO Server, you should be using License.ActivateInstallationLicenseFile or the WebServiceCall implementation for activation.

Note Note

Before calling the CallWebForm method, the following properties must be set:

  • LicenseID
  • Password
  • UserCode1, which is also referred to as the "Session Code" or "cenum" in Protection PLUS 4.
  • UserCode2, which is also referred to as the Computer ID in Protection PLUS 4.

Optional fields that may be populated before calling CallWebForm method include:

  • ProductID - When set, the License ID specified must be for the specified Product ID. In most cases, this should match the value used in License.ThisProductID.
  • ProductOptionID - When set, the License ID specified must be for the specified Product Option ID.
Examples
This example shows how to make a typical activation call for a PLUSManaged license:
C#
VB
C++
Copy
public bool ActivateOnline(int licenseID, string password, int userCode1, int userCode2, int productID, out int activationCode1, out int activationCode2, out string licenseUpdate)
{
    //TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL, or SOLO Server.
    GetTcData activationCall = new GetTcData("https://secure.softwarekey.com/solo/unlock/getcode.asp");
    activationCall.LicenseID = licenseID;
    activationCall.Password = password;
    activationCall.UserCode1 = userCode1;
    activationCall.UserCode2 = userCode2;
    activationCall.ProductID = productID;

    //TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    bool successful = activationCall.CallWebForm();
    if (successful)
    {
        activationCode1 = activationCall.ActivationCode1;
        activationCode2 = activationCall.ActivationCode2;
        licenseUpdate = activationCall.LicenseUpdate;
    }
    else
    {
        activationCode1 = 0;
        activationCode2 = 0;
        licenseUpdate = "";
        //TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    }

    return successful;
}
Public Function ActivateOnline (ByVal licenseID As Integer, ByVal password As String, ByVal userCode1 As Integer, ByVal userCode2 As Integer, ByVal productID As Integer, ByRef activationCode1 As Integer, ByRef activationCode2 As Integer, ByRef LicenseUpdate As String) As Boolean
    'TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL, or SOLO Server.
    Dim activationCall As New GetTcData("https://secure.softwarekey.com/solo/unlock/getcode.asp")
    activationCall.LicenseID = licenseID
    activationCall.Password = password
    activationCall.UserCode1 = userCode1
    activationCall.UserCode2 = userCode2
    activationCall.ProductID = productID

    'TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    Dim successful As Boolean = activationCall.CallWebForm()
    If successful Then
        activationCode1 = activationCall.ActivationCode1
        activationCode2 = activationCall.ActivationCode2
        licenseUpdate = activationCall.LicenseUpdate
    Else
        activationCode1 = 0
        activationCode2 = 0
        licenseUpdate = ""
        'TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    End If

    Return successful
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData Constructor

GetTcData Constructor
Creates a new GetTcData object.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public GetTcData(
    string url
)
Public Sub New (
    url As String
)
public:
GetTcData(
    String^ url
)

Parameters

url
Type: SystemString
The URL to the web form.
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData Properties

GetTcData Properties

The GetTcData type exposes the following members.

Properties
 | Name | Description
Public property | ActivationCode1 | Gets Activation Code 1. This is also known as "RegKey1" in Protection PLUS 4, and will be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the codes using ValidateTriggerCode(Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32).
Public property | ActivationCode2 | Gets or sets Activation Code 2. This is also known as "RegKey2" in Protection PLUS 4, and may be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the codes using ValidateTriggerCode(Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32).
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code. (Inherited from AutomationClientWebFormCall.)
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | LicenseID | Gets or sets the License ID (required).
Public property | LicenseUpdate | Gets the License Update data.
Public property | Password | Gets or sets password (required).
Public property | ProductID | Gets or sets the Product ID. When specified, the License ID must be for the Product ID specified.
Public property | ProductOptionID | Gets or sets the Product Option ID. When set, the License ID must be for the Product Option ID specified.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Public property | UserCode1 | Gets or sets User Code 1 (required). In Protection PLUS 4, this is also referred to as the "Session Code" or "cenum". This value can be generated using PLUS4Methods.GenerateUserCode1Value.
Public property | UserCode2 | Gets or sets User Code 2 (required). In Protection PLUS, this is also referred to as the "Computer ID". This value can be generated using PLUS4Methods.GenerateUserCode2Value.
Top
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData.ActivationCode1 Property

GetTcDataActivationCode1 Property
Gets Activation Code 1. This is also known as "RegKey1" in Protection PLUS 4, and will be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the codes using ValidateTriggerCode(Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ActivationCode1 { get; }
Public ReadOnly Property ActivationCode1 As Integer
    Get
public:
property int ActivationCode1 {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData.ActivationCode2 Property

GetTcDataActivationCode2 Property
Gets or sets Activation Code 2. This is also known as "RegKey2" in Protection PLUS 4, and may be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the codes using ValidateTriggerCode(Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ActivationCode2 { get; }
Public ReadOnly Property ActivationCode2 As Integer
    Get
public:
property int ActivationCode2 {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData.LicenseID Property

GetTcDataLicenseID Property
Gets or sets the License ID (required).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData.LicenseUpdate Property

GetTcDataLicenseUpdate Property
Gets the License Update data.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseUpdate { get; }
Public ReadOnly Property LicenseUpdate As String
    Get
public:
property String^ LicenseUpdate {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData.Password Property

GetTcDataPassword Property
Gets or sets password (required).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData.ProductID Property

GetTcDataProductID Property
Gets or sets the Product ID. When specified, the License ID must be for the Product ID specified.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; set; }
Public Property ProductID As Integer
    Get
    Set
public:
property int ProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData.ProductOptionID Property

GetTcDataProductOptionID Property
Gets or sets the Product Option ID. When set, the License ID must be for the Product Option ID specified.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductOptionID { get; set; }
Public Property ProductOptionID As Integer
    Get
    Set
public:
property int ProductOptionID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData.UserCode1 Property

GetTcDataUserCode1 Property
Gets or sets User Code 1 (required). In Protection PLUS 4, this is also referred to as the "Session Code" or "cenum". This value can be generated using PLUS4Methods.GenerateUserCode1Value.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UserCode1 { get; set; }
Public Property UserCode1 As Integer
    Get
    Set
public:
property int UserCode1 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData.UserCode2 Property

GetTcDataUserCode2 Property
Gets or sets User Code 2 (required). In Protection PLUS, this is also referred to as the "Computer ID". This value can be generated using PLUS4Methods.GenerateUserCode2Value.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UserCode2 { get; set; }
Public Property UserCode2 As Integer
    Get
    Set
public:
property int UserCode2 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData Methods

GetTcData Methods

The GetTcData type exposes the following members.

Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides AutomationClientWebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response. (Inherited from AutomationClientWebFormCall.)
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response. (Inherited from AutomationClientWebFormCall.)
Top
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


GetTcData.CallWebForm Method

GetTcDataCallWebForm Method
Calls the Automation Client web page.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool CallWebForm()
Public Overrides Function CallWebForm As Boolean
public:
virtual bool CallWebForm() override

Return Value

Type: Boolean
Returns true if successful. If false is returned, check the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
See Also

Reference

GetTcData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PLUS4Methods Class

PLUS4Methods Class
Static methods for Protection PLUS 4 compatibility.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Compatibility.ProtectionPLUS4PLUS4Methods

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static class PLUS4Methods
Public NotInheritable Class PLUS4Methods
public ref class PLUS4Methods abstract sealed

The PLUS4Methods type exposes the following members.

Methods
Name | Description
GenerateUserCode1Value | Generates a Protection PLUS 4 compatible "User Code 1" (or Session Code) value, which may be used to make each activation attempt and each trigger code issued for a system unique.
GenerateUserCode2Value(String) | Generates a Protection PLUS 4 Trigger Code "User Code 2" (or "Computer ID") value from a string which contains data that uniquely identifies the system.
GenerateUserCode2Value(ListSystemIdentifier) | Generates a Protection PLUS 4 Trigger Code "User Code 2" (or "Computer ID") value from a list of SystemIdentifier objects.
NDecrypt | Decrypts a number or RegKey2 value (compatible with pp_ndecrypt).
NEncrypt | Encrypts a number or RegKey2 value (compatible with pp_nencrypt).
TCode | Decrypts an activation code (compatible with pp_tcode). Note this does not process the trigger code or modify the license file in any way.
ValidateTriggerCode | Determines whether or not a trigger code is valid. Note this does not process the trigger code or modify the license file in any way.
Top
See Also

Reference

com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PLUS4Methods Methods

PLUS4Methods Methods

The PLUS4Methods type exposes the following members.

Methods
Name | Description
GenerateUserCode1Value | Generates a Protection PLUS 4 compatible "User Code 1" (or Session Code) value, which may be used to make each activation attempt and each trigger code issued for a system unique.
GenerateUserCode2Value(String) | Generates a Protection PLUS 4 Trigger Code "User Code 2" (or "Computer ID") value from a string which contains data that uniquely identifies the system.
GenerateUserCode2Value(ListSystemIdentifier) | Generates a Protection PLUS 4 Trigger Code "User Code 2" (or "Computer ID") value from a list of SystemIdentifier objects.
NDecrypt | Decrypts a number or RegKey2 value (compatible with pp_ndecrypt).
NEncrypt | Encrypts a number or RegKey2 value (compatible with pp_nencrypt).
TCode | Decrypts an activation code (compatible with pp_tcode). Note this does not process the trigger code or modify the license file in any way.
ValidateTriggerCode | Determines whether or not a trigger code is valid. Note this does not process the trigger code or modify the license file in any way.
Top
See Also

Reference

PLUS4Methods Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PLUS4Methods.GenerateUserCode1Value Method

PLUS4MethodsGenerateUserCode1Value Method
Generates a Protection PLUS 4 compatible "User Code 1" (or Session Code) value, which may be used to make each activation attempt and each trigger code issued for a system unique.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static int GenerateUserCode1Value()
Public Shared Function GenerateUserCode1Value As Integer
public:
static int GenerateUserCode1Value()

Return Value

Type: Int32
Returns a Protection PLUS 4 compatible "User Code 1" (or Session Code) value.
Remarks

This generates values compatible with pp_cenum.

See Also

Reference

PLUS4Methods Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PLUS4Methods.GenerateUserCode2Value Method

PLUS4MethodsGenerateUserCode2Value Method
Overload List
Name | Description
GenerateUserCode2Value(String) | Generates a Protection PLUS 4 Trigger Code "User Code 2" (or "Computer ID") value from a string which contains data that uniquely identifies the system.
GenerateUserCode2Value(ListSystemIdentifier) | Generates a Protection PLUS 4 Trigger Code "User Code 2" (or "Computer ID") value from a list of SystemIdentifier objects.
Top
See Also

Reference

PLUS4Methods Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PLUS4Methods.GenerateUserCode2Value Method (String)

PLUS4MethodsGenerateUserCode2Value Method (String)
Generates a Protection PLUS 4 Trigger Code "User Code 2" (or "Computer ID") value from a string which contains data that uniquely identifies the system.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static int GenerateUserCode2Value(
    string identifiers
)
Public Shared Function GenerateUserCode2Value (
    identifiers As String
) As Integer
public:
static int GenerateUserCode2Value(
    String^ identifiers
)

Parameters

identifiers
Type: SystemString
The string which uniquely identifies the system being activated.

Return Value

Type: Int32
Returns a 32-bit integer value representing a Protection PLUS 4 compatible "Computer ID" or "User Code 2" value.
Remarks
Caution note Caution

The Protection PLUS 4 compatible "User Code 2" or "Computer ID" generated by this method are NOT designed to match Computer ID values generated by Protection PLUS 4, and are also NOT designed to work with the Protection PLUS 4 Computer ID thresholds. This method only provides a simple way to generate a Protection PLUS 4 compatible Computer ID to use with activation, and is NOT designed for any purpose other than providing a reasonable, compatible means of ensuring a Protection PLUS 4 trigger code is only processed for the appropriate system.

See Also

Reference

PLUS4Methods Class
GenerateUserCode2Value Overload
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PLUS4Methods.GenerateUserCode2Value Method (List(SystemIdentifier))

PLUS4MethodsGenerateUserCode2Value Method (ListSystemIdentifier)
Generates a Protection PLUS 4 Trigger Code "User Code 2" (or "Computer ID") value from a list of SystemIdentifier objects.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static int GenerateUserCode2Value(
    List<SystemIdentifier> identifiers
)
Public Shared Function GenerateUserCode2Value (
    identifiers As List(Of SystemIdentifier)
) As Integer
public:
static int GenerateUserCode2Value(
    List<SystemIdentifier^>^ identifiers
)

Parameters

identifiers
Type: System.Collections.GenericList SystemIdentifier
The SystemIdentifier objects which identify the system being activated.

Return Value

Type: Int32
Returns a 32-bit integer value representing a Protection PLUS 4 compatible "Computer ID" or "User Code 2" value.
Remarks
Caution note Caution

The Protection PLUS 4 compatible "User Code 2" or "Computer ID" generated by this method are NOT designed to match Computer ID values generated by Protection PLUS 4, and are also NOT designed to work with the Protection PLUS 4 Computer ID thresholds. This method only provides a simple way to generate a Protection PLUS 4 compatible Computer ID to use with activation, and is NOT designed for any purpose other than providing a reasonable, compatible means of ensuring a Protection PLUS 4 trigger code is only processed for the appropriate system.

See Also

Reference

PLUS4Methods Class
GenerateUserCode2Value Overload
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PLUS4Methods.NDecrypt Method

PLUS4MethodsNDecrypt Method
Decrypts a number or RegKey2 value (compatible with pp_ndecrypt).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static int NDecrypt(
    int number,
    int seed
)
Public Shared Function NDecrypt (
    number As Integer,
    seed As Integer
) As Integer
public:
static int NDecrypt(
    int number,
    int seed
)

Parameters

number
Type: SystemInt32
The number to decrypt.
seed
Type: SystemInt32
The encryption seed, which must be a value between 1 and 255.

Return Value

Type: Int32
Returns the decrypted number, or -1 if decryption failed.
Remarks
Note Note

If the return value is -1, then the value is considered invalid. This can be caused for several reasons, including, but not limited to:

  • The user mistyped the value being decrypted (usually called Activation Code 2 or RegKey2).
  • The seed (also known as the RegKey2 seed) is not an acceptable value, between 1 and 255.
  • The seed (also known as the RegKey2 seed) is not the same value used when encrypting the number value.
  • The number value encrypted (or the value used when generating RegKey2) was too large (or greater than 16383).
See Also

Reference

PLUS4Methods Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PLUS4Methods.NEncrypt Method

PLUS4MethodsNEncrypt Method
Encrypts a number or RegKey2 value (compatible with pp_nencrypt).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static int NEncrypt(
    int number,
    int seed
)
Public Shared Function NEncrypt (
    number As Integer,
    seed As Integer
) As Integer
public:
static int NEncrypt(
    int number,
    int seed
)

Parameters

number
Type: SystemInt32
The numeric value (between 0 and 16383) to encrypt.
seed
Type: SystemInt32
The encryption seed, which must be a value between 1 and 255.

Return Value

Type: Int32
Returns the encrypted number, or -1 if encryption failed.
Remarks
Note Note

If the return value is -1, then the value or seed is considered invalid. This can be caused for several reasons, including, but not limited to:

  • The seed (often the RegKey2 Seed in this case) is not an acceptable value, between 1 and 255.
  • The number being encrypted is too large (or greater than 16383).
See Also

Reference

PLUS4Methods Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PLUS4Methods.TCode Method

PLUS4MethodsTCode Method
Decrypts an activation code (compatible with pp_tcode). Note this does not process the trigger code or modify the license file in any way.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static int TCode(
    int activationCode1,
    int userCode1,
    int userCode2,
    int seed
)
Public Shared Function TCode (
    activationCode1 As Integer,
    userCode1 As Integer,
    userCode2 As Integer,
    seed As Integer
) As Integer
public:
static int TCode(
    int activationCode1,
    int userCode1,
    int userCode2,
    int seed
)

Parameters

activationCode1
Type: SystemInt32
Activation Code 1 (RegKey 1)
userCode1
Type: SystemInt32
User Code 1 (Session Code/Code Entry Number)
userCode2
Type: SystemInt32
User Code 2 (Computer ID)
seed
Type: SystemInt32
Trigger Code Seed

Return Value

Type: Int32
Returns the Trigger Code number, or 0 if the Trigger Code number could not be determined.
Remarks
Note Note

If the return value is zero, then the Trigger Code is considered invalid. This can be caused for several reasons, including, but not limited to:

  • The user mistyped one of the values.
  • The Trigger Code Seed used in the application does not match the seed used when generating the trigger code. Check the Product Option configuration in SOLO Server or the Product Definition settings in LFEdit to verify if this is the issue.
  • The session code (User Code 1) is now different from the one used when generating the Trigger Code.
See Also

Reference

PLUS4Methods Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PLUS4Methods.ValidateTriggerCode Method

PLUS4MethodsValidateTriggerCode Method
Determines whether or not a trigger code is valid. Note this does not process the trigger code or modify the license file in any way.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static bool ValidateTriggerCode(
    int activationCode1,
    int activationCode2,
    int userCode1,
    int userCode2,
    int tcSeed,
    int dataSeed,
    out int code,
    out int tcData
)
Public Shared Function ValidateTriggerCode (
    activationCode1 As Integer,
    activationCode2 As Integer,
    userCode1 As Integer,
    userCode2 As Integer,
    tcSeed As Integer,
    dataSeed As Integer,
    <OutAttribute> ByRef code As Integer,
    <OutAttribute> ByRef tcData As Integer
) As Boolean
public:
static bool ValidateTriggerCode(
    int activationCode1,
    int activationCode2,
    int userCode1,
    int userCode2,
    int tcSeed,
    int dataSeed,
    [OutAttribute] int% code,
    [OutAttribute] int% tcData
)

Parameters

activationCode1
Type: SystemInt32
Activation Code 1 (RegKey 1).
activationCode2
Type: SystemInt32
Activation Code 2 (RegKey 2). Pass zero to omit.
userCode1
Type: SystemInt32
User Code 1 (Session Code/Code Entry Number).
userCode2
Type: SystemInt32
User Code 2 (Computer ID).
tcSeed
Type: SystemInt32
Trigger Code Seed.
dataSeed
Type: SystemInt32
Event Data Seed (RegKey2 Seed, which must be a value between 1 and 255).
code
Type: SystemInt32
Trigger Code Number, which will receive a value between 1 and 50 when successful.
tcData
Type: SystemInt32
Trigger Code Event Data, which will receive a value between 0 and 16383 when successful.

Return Value

Type: Boolean
If the trigger code is valid, this method returns true and specifies the trigger code and event data in the code and tcData arguments, respectively.
Remarks
Note Note

If the return value is false, then the Trigger Code is considered invalid. This can be caused for several reasons, including, but not limited to:

  • The user mistyped one or more of the user code and/or activation code values.
  • The Trigger Code Seed used in the application does not match the seed used when generating the trigger code. Check the Product Option configuration in SOLO Server or the Product Definition settings in LFEdit to verify if this is the issue.
  • The session code (User Code 1) is now different from the one used when generating the Trigger Code.
  • The dataSeed (also known as the RegKey2 seed) is not an acceptable value, between 1 and 255.
  • The dataSeed (also known as the RegKey2 seed) is not the same value used when encrypting the tcData value (or when generating activationCode2).
  • The tcData value encrypted (or the value used when generating activationCode2) was too large (or greater than 16383).
See Also

Reference

PLUS4Methods Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData Class

PostEvalData Class

Implementation for calling server-side scripts which were originally designed to with with the Automation Client's SK_PostEvalData and SK_PostEvalDataEx functions.

Note Note

Before calling the CallWebForm method, the following properties must be set:

  • ProductID (In most cases, this should match the value used in License.ThisProductID.)
  • Email

Before calling the CallWebForm method, the following properties may be set:

  • CompanyName
  • DistributorID
  • FirstName
  • LastName
  • Address1
  • Address2
  • City
  • StateProvince
  • PostalCode
  • Country
  • Phone
  • Source
  • UserDefinedString1
  • UserDefinedString2
  • UserDefinedString3
  • UserDefinedString4
  • UserDefinedString5
  • UserDefinedString6
  • UserDefinedString7

Your application is responsible for enforcing what data your users are required to enter.

Examples
This example shows how to make a typical activation call for a PLUSManaged license:
C#
VB
C++
Copy
public bool PostEvaluationData(int productID, string email, string companyName, string firstName, string lastName, string phone, out int registrationID)
{
    //TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL or SOLO Server.
    PostEvalData evalCall = new PostEvalData("https://secure.softwarekey.com/solo/products/trialsignup.asp");
    evalCall.ProductID = productID;
    evalCall.Email = email;
    evalCall.CompanyName = companyName;
    evalCall.FirstName = firstName;
    evalCall.LastName = lastName;
    evalCall.Phone = phone;
    //TODO: Add additional arguments to this function and initialize additional properties here as needed.

    //TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    bool successful = evalCall.CallWebForm();
    if (successful)
    {
        registrationID = evalCall.RegistrationID;
    }
    else
    {
        registrationID = 0;
        //TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    }

    return successful;
}
Public Function PostEvaluationData(ByVal productID As Integer, ByVal email As String, ByVal companyName As String, ByVal firstName As String, ByVal lastName As String, ByVal phone As String, ByRef registrationID As Integer) As Boolean
    'TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL or SOLO Server.
    Dim evalCall As New PostEvalData("https://secure.softwarekey.com/solo/unlock/getcode.asp")
    evalCall.ProductID = productID
    evalCall.Email = email
    evalCall.CompanyName = companyName
    evalCall.FirstName = firstName
    evalCall.LastName = lastName
    evalCall.Phone = phone
    'TODO: Add additional arguments to this function and initialize additional properties here as needed.

    'TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    Dim successful As Boolean = evalCall.CallWebForm()
    If successful Then
        registrationID = evalCall.RegistrationID
    Else
        registrationID = 0
        'TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    End If

    Return successful
End Function

No code example is currently available or this language may not be supported.

Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4AutomationClientWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4PostEvalData

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class PostEvalData : AutomationClientWebFormCall
Public Class PostEvalData
    Inherits AutomationClientWebFormCall
public ref class PostEvalData : public AutomationClientWebFormCall

The PostEvalData type exposes the following members.

Constructors
 | Name | Description
Public method | PostEvalData | Creates a new PostEvalData object.
Top
Properties
 | Name | Description
Public property | Address1 | Gets or sets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets or sets the customer's second address line (i.e. apartment or suite number).
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code. (Inherited from AutomationClientWebFormCall.)
Public property | City | Gets or sets the city of the customer's address.
Public property | CompanyName | Gets or sets the customer's company name.
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | Country | Gets or sets the country of the customer's address.
Public property | DistributorID | Gets or sets the distributor's unique ID.
Public property | Email | Gets or sets the customer's email address.
Public property | FirstName | Gets or sets the customer's first name.
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | LastName | Gets or sets the customer's last name.
Public property | Phone | Gets or sets the customer's phone number.
Public property | PostalCode | Gets or sets the customer's zip/postal code.
Public property | ProductID | Gets or sets the Product ID designated by SOLO Server for the application being evaluated.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | RegistrationID | Gets the registration/evaluation ID returned after successfully registering with SOLO Server.
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | Source | Gets or sets the customer's fax number.
Public property | StateProvince | Gets or sets the state/province of the customer's address.
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Public property | UserDefinedString1 | Gets or sets the User Defined String (Misc) Field 1 value.
Public property | UserDefinedString2 | Gets or sets the User Defined String (Misc) Field 2 value.
Public property | UserDefinedString3 | Gets or sets the User Defined String (Misc) Field 3 value.
Public property | UserDefinedString4 | Gets or sets the User Defined String (Misc) Field 4 value.
Public property | UserDefinedString5 | Gets or sets the User Defined String (Misc) Field 5 value.
Public property | UserDefinedString6 | Gets or sets the User Defined String (Misc) Field 6 value.
Public property | UserDefinedString7 | Gets or sets the User Defined String (Misc) Field 7 value.
Top
Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides AutomationClientWebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response. (Inherited from AutomationClientWebFormCall.)
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response. (Inherited from AutomationClientWebFormCall.)
Top
See Also

Reference

com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData Constructor

PostEvalData Constructor
Creates a new PostEvalData object.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public PostEvalData(
    string url
)
Public Sub New (
    url As String
)
public:
PostEvalData(
    String^ url
)

Parameters

url
Type: SystemString
The URL to the web form.
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData Properties

PostEvalData Properties

The PostEvalData type exposes the following members.

Properties
 | Name | Description
Public property | Address1 | Gets or sets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets or sets the customer's second address line (i.e. apartment or suite number).
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code. (Inherited from AutomationClientWebFormCall.)
Public property | City | Gets or sets the city of the customer's address.
Public property | CompanyName | Gets or sets the customer's company name.
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | Country | Gets or sets the country of the customer's address.
Public property | DistributorID | Gets or sets the distributor's unique ID.
Public property | Email | Gets or sets the customer's email address.
Public property | FirstName | Gets or sets the customer's first name.
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | LastName | Gets or sets the customer's last name.
Public property | Phone | Gets or sets the customer's phone number.
Public property | PostalCode | Gets or sets the customer's zip/postal code.
Public property | ProductID | Gets or sets the Product ID designated by SOLO Server for the application being evaluated.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | RegistrationID | Gets the registration/evaluation ID returned after successfully registering with SOLO Server.
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | Source | Gets or sets the customer's fax number.
Public property | StateProvince | Gets or sets the state/province of the customer's address.
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Public property | UserDefinedString1 | Gets or sets the User Defined String (Misc) Field 1 value.
Public property | UserDefinedString2 | Gets or sets the User Defined String (Misc) Field 2 value.
Public property | UserDefinedString3 | Gets or sets the User Defined String (Misc) Field 3 value.
Public property | UserDefinedString4 | Gets or sets the User Defined String (Misc) Field 4 value.
Public property | UserDefinedString5 | Gets or sets the User Defined String (Misc) Field 5 value.
Public property | UserDefinedString6 | Gets or sets the User Defined String (Misc) Field 6 value.
Public property | UserDefinedString7 | Gets or sets the User Defined String (Misc) Field 7 value.
Top
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.Address1 Property

PostEvalDataAddress1 Property
Gets or sets the customer's street address (or line 1 of the customer's address).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.Address2 Property

PostEvalDataAddress2 Property
Gets or sets the customer's second address line (i.e. apartment or suite number).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address2 { get; set; }
Public Property Address2 As String
    Get
    Set
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.City Property

PostEvalDataCity Property
Gets or sets the city of the customer's address.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string City { get; set; }
Public Property City As String
    Get
    Set
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.CompanyName Property

PostEvalDataCompanyName Property
Gets or sets the customer's company name.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CompanyName { get; set; }
Public Property CompanyName As String
    Get
    Set
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.Country Property

PostEvalDataCountry Property
Gets or sets the country of the customer's address.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.DistributorID Property

PostEvalDataDistributorID Property
Gets or sets the distributor's unique ID.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int DistributorID { get; set; }
Public Property DistributorID As Integer
    Get
    Set
public:
property int DistributorID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.Email Property

PostEvalDataEmail Property
Gets or sets the customer's email address.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.FirstName Property

PostEvalDataFirstName Property
Gets or sets the customer's first name.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string FirstName { get; set; }
Public Property FirstName As String
    Get
    Set
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.LastName Property

PostEvalDataLastName Property
Gets or sets the customer's last name.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LastName { get; set; }
Public Property LastName As String
    Get
    Set
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.Phone Property

PostEvalDataPhone Property
Gets or sets the customer's phone number.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Phone { get; set; }
Public Property Phone As String
    Get
    Set
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.PostalCode Property

PostEvalDataPostalCode Property
Gets or sets the customer's zip/postal code.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.ProductID Property

PostEvalDataProductID Property
Gets or sets the Product ID designated by SOLO Server for the application being evaluated.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; set; }
Public Property ProductID As Integer
    Get
    Set
public:
property int ProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.RegistrationID Property

PostEvalDataRegistrationID Property
Gets the registration/evaluation ID returned after successfully registering with SOLO Server.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int RegistrationID { get; }
Public ReadOnly Property RegistrationID As Integer
    Get
public:
property int RegistrationID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.Source Property

PostEvalDataSource Property
Gets or sets the customer's fax number.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.StateProvince Property

PostEvalDataStateProvince Property
Gets or sets the state/province of the customer's address.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string StateProvince { get; set; }
Public Property StateProvince As String
    Get
    Set
public:
property String^ StateProvince {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.UserDefinedString1 Property

PostEvalDataUserDefinedString1 Property
Gets or sets the User Defined String (Misc) Field 1 value.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString1 { get; set; }
Public Property UserDefinedString1 As String
    Get
    Set
public:
property String^ UserDefinedString1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.UserDefinedString2 Property

PostEvalDataUserDefinedString2 Property
Gets or sets the User Defined String (Misc) Field 2 value.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString2 { get; set; }
Public Property UserDefinedString2 As String
    Get
    Set
public:
property String^ UserDefinedString2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.UserDefinedString3 Property

PostEvalDataUserDefinedString3 Property
Gets or sets the User Defined String (Misc) Field 3 value.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString3 { get; set; }
Public Property UserDefinedString3 As String
    Get
    Set
public:
property String^ UserDefinedString3 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.UserDefinedString4 Property

PostEvalDataUserDefinedString4 Property
Gets or sets the User Defined String (Misc) Field 4 value.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString4 { get; set; }
Public Property UserDefinedString4 As String
    Get
    Set
public:
property String^ UserDefinedString4 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.UserDefinedString5 Property

PostEvalDataUserDefinedString5 Property
Gets or sets the User Defined String (Misc) Field 5 value.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString5 { get; set; }
Public Property UserDefinedString5 As String
    Get
    Set
public:
property String^ UserDefinedString5 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.UserDefinedString6 Property

PostEvalDataUserDefinedString6 Property
Gets or sets the User Defined String (Misc) Field 6 value.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString6 { get; set; }
Public Property UserDefinedString6 As String
    Get
    Set
public:
property String^ UserDefinedString6 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.UserDefinedString7 Property

PostEvalDataUserDefinedString7 Property
Gets or sets the User Defined String (Misc) Field 7 value.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UserDefinedString7 { get; set; }
Public Property UserDefinedString7 As String
    Get
    Set
public:
property String^ UserDefinedString7 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData Methods

PostEvalData Methods

The PostEvalData type exposes the following members.

Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides AutomationClientWebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response. (Inherited from AutomationClientWebFormCall.)
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response. (Inherited from AutomationClientWebFormCall.)
Top
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostEvalData.CallWebForm Method

PostEvalDataCallWebForm Method
Calls the Automation Client web page.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool CallWebForm()
Public Overrides Function CallWebForm As Boolean
public:
virtual bool CallWebForm() override

Return Value

Type: Boolean
Returns true if successful. If false is returned, check the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
See Also

Reference

PostEvalData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData Class

PostRegData Class

Implementation for calling server-side scripts which were originally designed to with with the Automation Client's SK_PostRegData function. If you are using SOLO Server (including Instant SOLO Server and Instant SOLO Server Dedicated URL), then you should use UpdateRegistration.

Note Note

Before calling the CallWebForm method, the following properties must be set:

  • LicenseID
  • Password

Before calling the CallWebForm method, the following properties may be set:

  • CompanyName
  • FirstName
  • LastName
  • Address1
  • Address2
  • City
  • StateProvince
  • PostalCode
  • Country
  • Phone
  • Fax
  • Email
  • Overwrite
  • NotifyProduct
  • NotifyPartners

Your application is responsible for enforcing what data your users are required to enter.

Caution note Caution

It is important to note that leaving any of the optional fields empty above will result in an empty value being stored. This is especially something to be aware of when setting the Overwrite property to true.

Examples
This example shows how to make a typical activation call for a PLUSManaged license:
C#
VB
C++
Copy
public bool PostRegistrationData(int licenseID, string password, string email, string companyName, string firstName, string lastName, string phone)
{
    //TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL, or SOLO Server.
    PostRegData registrationCall = new PostRegData("https://secure.softwarekey.com/solo/postings/postregdata.asp");
    registrationCall.LicenseID = licenseID;
    registrationCall.Password = password;
    registrationCall.Email = email;
    registrationCall.CompanyName = companyName;
    registrationCall.FirstName = firstName;
    registrationCall.LastName = lastName;
    registrationCall.Phone = phone;
    //TODO: Add additional arguments to this function and initialize additional properties here as needed.

    //TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    bool successful = registrationCall.CallWebForm();
    if (!successful)
    {
        //TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    }

    return successful;
}
Public Function PostRegistrationData(ByVal licenseID As Integer, ByVal password As String, ByVal email As String, ByVal companyName As String, ByVal firstName As String, ByVal lastName As String, ByVal phone As String, ByRef registrationID As Integer) As Boolean
    'TODO: The URL used below is for Instant SOLO Server.  You will need to update this URL if you are using Instant SOLO Server Dedicated URL, or SOLO Server.
    Dim registrationCall As New PostRegData("https://secure.softwarekey.com/solo/postings/postregdata.asp")
    registrationCall.LicenseID = licenseID
    registrationCall.Password = password
    registrationCall.Email = email
    registrationCall.CompanyName = companyName
    registrationCall.FirstName = firstName
    registrationCall.LastName = lastName
    registrationCall.Phone = phone
    'TODO: Add additional arguments to this function and initialize additional properties here as needed.

    'TODO: Initialize the Proxy property here as appropriate if you need to support proxy server authentication.

    Dim successful As Boolean = registrationCall.CallWebForm()
    If Not successful Then
        'TODO: Evaluate the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
    End If

    Return successful
End Function

No code example is currently available or this language may not be supported.

Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4AutomationClientWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4PostRegData

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class PostRegData : AutomationClientWebFormCall
Public Class PostRegData
    Inherits AutomationClientWebFormCall
public ref class PostRegData : public AutomationClientWebFormCall

The PostRegData type exposes the following members.

Constructors
 | Name | Description
Public method | PostRegData | Creates a new PostRegData object.
Top
Properties
 | Name | Description
Public property | Address1 | Gets or sets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets or sets the customer's second address line (i.e. apartment or suite number).
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code. (Inherited from AutomationClientWebFormCall.)
Public property | City | Gets or sets the city of the customer's address.
Public property | CompanyName | Gets or sets the customer's company name.
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | Country | Gets or sets the country of the customer's address.
Public property | Email | Gets or sets the customer's email address.
Public property | Fax | Gets or sets the customer's fax number.
Public property | FirstName | Gets or sets the customer's first name.
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | LastName | Gets or sets the customer's last name.
Public property | LicenseID | Gets or sets the License ID (required).
Public property | NotifyPartners | Gets or sets whether the customer should be notified of partner promotions.
Public property | NotifyProduct | Gets or sets whether the customer should be notified of product-related events, releases, and promotions.
Public property | Overwrite | Gets or sets whether prior registration data should be overwritten when present.
Public property | Password | Gets or sets password (required).
Public property | Phone | Gets or sets the customer's phone number.
Public property | PostalCode | Gets or sets the customer's zip/postal code.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | StateProvince | Gets or sets the state/province of the customer's address.
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Top
Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides AutomationClientWebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response. (Inherited from AutomationClientWebFormCall.)
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response. (Inherited from AutomationClientWebFormCall.)
Top
See Also

Reference

com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData Constructor

PostRegData Constructor
Creates a new PostRegData object.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public PostRegData(
    string url
)
Public Sub New (
    url As String
)
public:
PostRegData(
    String^ url
)

Parameters

url
Type: SystemString
The URL to the web form.
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData Properties

PostRegData Properties

The PostRegData type exposes the following members.

Properties
 | Name | Description
Public property | Address1 | Gets or sets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets or sets the customer's second address line (i.e. apartment or suite number).
Public property | AutomationClientErrorCode | Gets or sets the Automation Client error code. (Inherited from AutomationClientWebFormCall.)
Public property | City | Gets or sets the city of the customer's address.
Public property | CompanyName | Gets or sets the customer's company name.
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default). (Inherited from WebFormCall.)
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default). (Inherited from WebFormCall.)
Public property | Country | Gets or sets the country of the customer's address.
Public property | Email | Gets or sets the customer's email address.
Public property | Fax | Gets or sets the customer's fax number.
Public property | FirstName | Gets or sets the customer's first name.
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form. (Inherited from WebFormCall.)
Public property | LastName | Gets or sets the customer's last name.
Public property | LicenseID | Gets or sets the License ID (required).
Public property | NotifyPartners | Gets or sets whether the customer should be notified of partner promotions.
Public property | NotifyProduct | Gets or sets whether the customer should be notified of product-related events, releases, and promotions.
Public property | Overwrite | Gets or sets whether prior registration data should be overwritten when present.
Public property | Password | Gets or sets password (required).
Public property | Phone | Gets or sets the customer's phone number.
Public property | PostalCode | Gets or sets the customer's zip/postal code.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings. (Inherited from WebFormCall.)
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication. (Inherited from WebFormCall.)
Public property | RequireSsl | Gets or sets whether or not SSL is required. (Inherited from WebFormCall.)
Public property | Response | Gets or sets the response returned from the server. (Inherited from WebFormCall.)
Public property | StateProvince | Gets or sets the state/province of the customer's address.
Public property | StatusCode | Gets or sets the status code of the response returned from the server. (Inherited from WebFormCall.)
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds). (Inherited from WebFormCall.)
Top
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.Address1 Property

PostRegDataAddress1 Property
Gets or sets the customer's street address (or line 1 of the customer's address).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.Address2 Property

PostRegDataAddress2 Property
Gets or sets the customer's second address line (i.e. apartment or suite number).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address2 { get; set; }
Public Property Address2 As String
    Get
    Set
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.City Property

PostRegDataCity Property
Gets or sets the city of the customer's address.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string City { get; set; }
Public Property City As String
    Get
    Set
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.CompanyName Property

PostRegDataCompanyName Property
Gets or sets the customer's company name.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CompanyName { get; set; }
Public Property CompanyName As String
    Get
    Set
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.Country Property

PostRegDataCountry Property
Gets or sets the country of the customer's address.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.Email Property

PostRegDataEmail Property
Gets or sets the customer's email address.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.Fax Property

PostRegDataFax Property
Gets or sets the customer's fax number.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Fax { get; set; }
Public Property Fax As String
    Get
    Set
public:
property String^ Fax {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.FirstName Property

PostRegDataFirstName Property
Gets or sets the customer's first name.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string FirstName { get; set; }
Public Property FirstName As String
    Get
    Set
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.LastName Property

PostRegDataLastName Property
Gets or sets the customer's last name.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LastName { get; set; }
Public Property LastName As String
    Get
    Set
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.LicenseID Property

PostRegDataLicenseID Property
Gets or sets the License ID (required).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.NotifyPartners Property

PostRegDataNotifyPartners Property
Gets or sets whether the customer should be notified of partner promotions.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool NotifyPartners { get; set; }
Public Property NotifyPartners As Boolean
    Get
    Set
public:
property bool NotifyPartners {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.NotifyProduct Property

PostRegDataNotifyProduct Property
Gets or sets whether the customer should be notified of product-related events, releases, and promotions.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool NotifyProduct { get; set; }
Public Property NotifyProduct As Boolean
    Get
    Set
public:
property bool NotifyProduct {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.Overwrite Property

PostRegDataOverwrite Property
Gets or sets whether prior registration data should be overwritten when present.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool Overwrite { get; set; }
Public Property Overwrite As Boolean
    Get
    Set
public:
property bool Overwrite {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.Password Property

PostRegDataPassword Property
Gets or sets password (required).

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.Phone Property

PostRegDataPhone Property
Gets or sets the customer's phone number.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Phone { get; set; }
Public Property Phone As String
    Get
    Set
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.PostalCode Property

PostRegDataPostalCode Property
Gets or sets the customer's zip/postal code.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.StateProvince Property

PostRegDataStateProvince Property
Gets or sets the state/province of the customer's address.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string StateProvince { get; set; }
Public Property StateProvince As String
    Get
    Set
public:
property String^ StateProvince {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData Methods

PostRegData Methods

The PostRegData type exposes the following members.

Methods
 | Name | Description
Public method | CallWebForm | Calls the Automation Client web page. (Overrides AutomationClientWebFormCallCallWebForm.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryParseValueFromResponse(String, Int32) | Tries to parse a 32 bit integer value from the Response. (Inherited from AutomationClientWebFormCall.)
Public method | TryParseValueFromResponse(String, String) | Tries to parse a string value from the Response. (Inherited from AutomationClientWebFormCall.)
Top
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


PostRegData.CallWebForm Method

PostRegDataCallWebForm Method
Calls the Automation Client web page.

Namespace: com.softwarekey.Client.Compatibility.ProtectionPLUS4
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool CallWebForm()
Public Overrides Function CallWebForm As Boolean
public:
virtual bool CallWebForm() override

Return Value

Type: Boolean
Returns true if successful. If false is returned, check the AutomationClientErrorCode, LastException, and ProxyAuthenticationRequired properties for possible reasons why the call failed.
See Also

Reference

PostRegData Class
com.softwarekey.Client.Compatibility.ProtectionPLUS4 Namespace


com.softwarekey.Client.Encryption Namespace

com.softwarekey.Client.Encryption Namespace
Contains routines for implementing encryption used for License Files and web service calls.
Classes
 | Class | Description
Public class | XmlRsaDecryption | Performs RSA Algorithm decryption and verification on XML documents.
Public class | XmlRsaEncryption | Performs RSA Algorithm signing and encryption on XML documents.
Public class | XmlRsaEncryptionBase | Base class from which XML, RSA Algorithm cryptographic routines are implemented.
Enumerations
 | Enumeration | Description
Public enumeration | XmlRsaEncryptionOptions | Encryption and Decryption Options.
Public enumeration | XmlRsaSignatureOptions | Digital Signature Options.


XmlRsaDecryption Class

XmlRsaDecryption Class
Performs RSA Algorithm decryption and verification on XML documents.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.EncryptionXmlRsaEncryptionBase
com.softwarekey.Client.EncryptionXmlRsaDecryption

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class XmlRsaDecryption : XmlRsaEncryptionBase
Public Class XmlRsaDecryption
    Inherits XmlRsaEncryptionBase
public ref class XmlRsaDecryption : public XmlRsaEncryptionBase

The XmlRsaDecryption type exposes the following members.

Constructors
 | Name | Description
Public method | XmlRsaDecryption | Creates a new XmlRsaDecryption object. (Requires the EncryptionKey and InputDocument properties to be set before calling the Process method!)
Public method | XmlRsaDecryption(AuthorEncryptionKey, String) | Creates a new XmlRsaDecryption object, initialized with the encryption data and input XML document string.
Public method | XmlRsaDecryption(AuthorEncryptionKey, XmlDocument) | Creates a new XmlRsaDecryption object, initialized with the encryption data and input document.
Public method | XmlRsaDecryption(AuthorEncryptionKey, XmlNode) | Creates a new XmlRsaDecryption object, initialized with the encryption data and input XML root node.
Top
Properties
 | Name | Description
Public property | EncryptionKey | Gets or sets the Encryption Key data required for cryptographic routines. (Inherited from XmlRsaEncryptionBase.)
Public property | EncryptionOptions | Gets or sets options used when encrypting or decrypting. (Inherited from XmlRsaEncryptionBase.)
Public property | InputDocument | Gets or sets the input XmlDocument. (Inherited from XmlRsaEncryptionBase.)
Public property | InputDocumentString | Gets or sets the input XML string. (Changing the InputDocument property affects this property, and setting this property updates the InputDocument property.) (Inherited from XmlRsaEncryptionBase.)
Public property | LastError | Gets or sets the last error that occurred. (Inherited from XmlRsaEncryptionBase.)
Public property | OutputDocument | Gets or sets the output XmlDocument (null when processing has not been or completed, or failed). (Inherited from XmlRsaEncryptionBase.)
Public property | OutputDocumentString | Gets the output XML string (derived from the OutputDocument property, this is an empty string null when processing has not been or completed, or failed). (Inherited from XmlRsaEncryptionBase.)
Public property | Recursive | Gets or sets whether all elements are decrypted recursively (recommended for most web service calls). Setting this property to false will result in only the first level being decrypted.
Public property | SignatureOptions | Gets or sets options used when creating or verifying digital signatures. (Inherited from XmlRsaEncryptionBase.)
Public property | UseEncryption | Gets whether encryption or decryption is required. (Inherited from XmlRsaEncryptionBase.)
Public property | UseSignatures | Gets whether digital signatures need to be created or verified. (Inherited from XmlRsaEncryptionBase.)
Public property | VerifyWithBothKeys | Gets or sets whether verification will be attempted with both keys. (If true, the behavior specified in the SignatureOptions property is overridden. This is helpful for special cases, such as writable license files.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Process | Processes the input document. (Overrides XmlRsaEncryptionBaseProcess.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Caution note Caution

Use of this class directly is atypical and generally not recommended. This is available to make it easier to use customized License File and Web service request formats.

See Also

Reference

com.softwarekey.Client.Encryption Namespace


XmlRsaDecryption Constructor

XmlRsaDecryption Constructor
Overload List
 | Name | Description
Public method | XmlRsaDecryption | Creates a new XmlRsaDecryption object. (Requires the EncryptionKey and InputDocument properties to be set before calling the Process method!)
Public method | XmlRsaDecryption(AuthorEncryptionKey, String) | Creates a new XmlRsaDecryption object, initialized with the encryption data and input XML document string.
Public method | XmlRsaDecryption(AuthorEncryptionKey, XmlDocument) | Creates a new XmlRsaDecryption object, initialized with the encryption data and input document.
Public method | XmlRsaDecryption(AuthorEncryptionKey, XmlNode) | Creates a new XmlRsaDecryption object, initialized with the encryption data and input XML root node.
Top
See Also

Reference

XmlRsaDecryption Class
com.softwarekey.Client.Encryption Namespace


XmlRsaDecryption Constructor

XmlRsaDecryption Constructor
Creates a new XmlRsaDecryption object. (Requires the EncryptionKey and InputDocument properties to be set before calling the Process method!)

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaDecryption()
Public Sub New
public:
XmlRsaDecryption()
See Also

Reference

XmlRsaDecryption Class
XmlRsaDecryption Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaDecryption Constructor (AuthorEncryptionKey, String)

XmlRsaDecryption Constructor (AuthorEncryptionKey, String)
Creates a new XmlRsaDecryption object, initialized with the encryption data and input XML document string.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaDecryption(
    AuthorEncryptionKey encryptionKey,
    string input
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    input As String
)
public:
XmlRsaDecryption(
    AuthorEncryptionKey^ encryptionKey,
    String^ input
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object pre-initialized with the encryption data.
input
Type: SystemString
The XML string data to decrypt and verify.
See Also

Reference

XmlRsaDecryption Class
XmlRsaDecryption Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaDecryption Constructor (AuthorEncryptionKey, XmlDocument)

XmlRsaDecryption Constructor (AuthorEncryptionKey, XmlDocument)
Creates a new XmlRsaDecryption object, initialized with the encryption data and input document.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaDecryption(
    AuthorEncryptionKey encryptionKey,
    XmlDocument input
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    input As XmlDocument
)
public:
XmlRsaDecryption(
    AuthorEncryptionKey^ encryptionKey,
    XmlDocument^ input
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object pre-initialized with the encryption data.
input
Type: System.XmlXmlDocument
The XmlDocument object to decrypt and verify.
See Also

Reference

XmlRsaDecryption Class
XmlRsaDecryption Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaDecryption Constructor (AuthorEncryptionKey, XmlNode)

XmlRsaDecryption Constructor (AuthorEncryptionKey, XmlNode)
Creates a new XmlRsaDecryption object, initialized with the encryption data and input XML root node.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaDecryption(
    AuthorEncryptionKey encryptionKey,
    XmlNode input
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    input As XmlNode
)
public:
XmlRsaDecryption(
    AuthorEncryptionKey^ encryptionKey,
    XmlNode^ input
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object pre-initialized with the encryption data.
input
Type: System.XmlXmlNode
The XmlNode object referencing the root/document node to decrypt and verify.
See Also

Reference

XmlRsaDecryption Class
XmlRsaDecryption Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaDecryption Properties

XmlRsaDecryption Properties

The XmlRsaDecryption type exposes the following members.

Properties
 | Name | Description
Public property | EncryptionKey | Gets or sets the Encryption Key data required for cryptographic routines. (Inherited from XmlRsaEncryptionBase.)
Public property | EncryptionOptions | Gets or sets options used when encrypting or decrypting. (Inherited from XmlRsaEncryptionBase.)
Public property | InputDocument | Gets or sets the input XmlDocument. (Inherited from XmlRsaEncryptionBase.)
Public property | InputDocumentString | Gets or sets the input XML string. (Changing the InputDocument property affects this property, and setting this property updates the InputDocument property.) (Inherited from XmlRsaEncryptionBase.)
Public property | LastError | Gets or sets the last error that occurred. (Inherited from XmlRsaEncryptionBase.)
Public property | OutputDocument | Gets or sets the output XmlDocument (null when processing has not been or completed, or failed). (Inherited from XmlRsaEncryptionBase.)
Public property | OutputDocumentString | Gets the output XML string (derived from the OutputDocument property, this is an empty string null when processing has not been or completed, or failed). (Inherited from XmlRsaEncryptionBase.)
Public property | Recursive | Gets or sets whether all elements are decrypted recursively (recommended for most web service calls). Setting this property to false will result in only the first level being decrypted.
Public property | SignatureOptions | Gets or sets options used when creating or verifying digital signatures. (Inherited from XmlRsaEncryptionBase.)
Public property | UseEncryption | Gets whether encryption or decryption is required. (Inherited from XmlRsaEncryptionBase.)
Public property | UseSignatures | Gets whether digital signatures need to be created or verified. (Inherited from XmlRsaEncryptionBase.)
Public property | VerifyWithBothKeys | Gets or sets whether verification will be attempted with both keys. (If true, the behavior specified in the SignatureOptions property is overridden. This is helpful for special cases, such as writable license files.)
Top
See Also

Reference

XmlRsaDecryption Class
com.softwarekey.Client.Encryption Namespace


XmlRsaDecryption.Recursive Property

XmlRsaDecryptionRecursive Property
Gets or sets whether all elements are decrypted recursively (recommended for most web service calls). Setting this property to false will result in only the first level being decrypted.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool Recursive { get; set; }
Public Property Recursive As Boolean
    Get
    Set
public:
property bool Recursive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

XmlRsaDecryption Class
com.softwarekey.Client.Encryption Namespace


XmlRsaDecryption.VerifyWithBothKeys Property

XmlRsaDecryptionVerifyWithBothKeys Property
Gets or sets whether verification will be attempted with both keys. (If true, the behavior specified in the SignatureOptions property is overridden. This is helpful for special cases, such as writable license files.)

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool VerifyWithBothKeys { get; set; }
Public Property VerifyWithBothKeys As Boolean
    Get
    Set
public:
property bool VerifyWithBothKeys {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

XmlRsaDecryption Class
com.softwarekey.Client.Encryption Namespace


XmlRsaDecryption Methods

XmlRsaDecryption Methods

The XmlRsaDecryption type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Process | Processes the input document. (Overrides XmlRsaEncryptionBaseProcess.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlRsaDecryption Class
com.softwarekey.Client.Encryption Namespace


XmlRsaDecryption.Process Method

XmlRsaDecryptionProcess Method
Processes the input document.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Process()
Public Overrides Function Process As Boolean
public:
virtual bool Process() override

Return Value

Type: Boolean
Returns true and stores the result in the OutputDocument property if successful. If it is not successful, check the LastError property for details.
See Also

Reference

XmlRsaDecryption Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryption Class

XmlRsaEncryption Class
Performs RSA Algorithm signing and encryption on XML documents.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.EncryptionXmlRsaEncryptionBase
com.softwarekey.Client.EncryptionXmlRsaEncryption

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class XmlRsaEncryption : XmlRsaEncryptionBase
Public Class XmlRsaEncryption
    Inherits XmlRsaEncryptionBase
public ref class XmlRsaEncryption : public XmlRsaEncryptionBase

The XmlRsaEncryption type exposes the following members.

Constructors
 | Name | Description
Public method | XmlRsaEncryption | Creates a new XmlRsaEncryption object. (Requires the EncryptionKey and InputDocument properties to be set before calling the Process method!)
Public method | XmlRsaEncryption(AuthorEncryptionKey, String) | Creates a new XmlRsaEncryption object, initialized with the encryption data and input XML document string.
Public method | XmlRsaEncryption(AuthorEncryptionKey, XmlDocument) | Creates a new XmlRsaEncryption object, initialized with the encryption data and input document.
Public method | XmlRsaEncryption(AuthorEncryptionKey, XmlNode) | Creates a new XmlRsaEncryption object, initialized with the encryption data and input XML root node.
Top
Properties
 | Name | Description
Public property | EncryptionKey | Gets or sets the Encryption Key data required for cryptographic routines. (Inherited from XmlRsaEncryptionBase.)
Public property | EncryptionOptions | Gets or sets options used when encrypting or decrypting. (Inherited from XmlRsaEncryptionBase.)
Public property | InputDocument | Gets or sets the input XmlDocument. (Inherited from XmlRsaEncryptionBase.)
Public property | InputDocumentString | Gets or sets the input XML string. (Changing the InputDocument property affects this property, and setting this property updates the InputDocument property.) (Inherited from XmlRsaEncryptionBase.)
Public property | LastError | Gets or sets the last error that occurred. (Inherited from XmlRsaEncryptionBase.)
Public property | OutputDocument | Gets or sets the output XmlDocument (null when processing has not been or completed, or failed). (Inherited from XmlRsaEncryptionBase.)
Public property | OutputDocumentString | Gets the output XML string (derived from the OutputDocument property, this is an empty string null when processing has not been or completed, or failed). (Inherited from XmlRsaEncryptionBase.)
Public property | SignatureOptions | Gets or sets options used when creating or verifying digital signatures. (Inherited from XmlRsaEncryptionBase.)
Public property | UseEncryption | Gets whether encryption or decryption is required. (Inherited from XmlRsaEncryptionBase.)
Public property | UseSignatures | Gets whether digital signatures need to be created or verified. (Inherited from XmlRsaEncryptionBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Process | Processes the input document. (Overrides XmlRsaEncryptionBaseProcess.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Caution note Caution

Use of this class directly is atypical and generally not recommended. This is available to make it easier to use customized License File and Web service request formats.

See Also

Reference

com.softwarekey.Client.Encryption Namespace


XmlRsaEncryption Constructor

XmlRsaEncryption Constructor
Overload List
 | Name | Description
Public method | XmlRsaEncryption | Creates a new XmlRsaEncryption object. (Requires the EncryptionKey and InputDocument properties to be set before calling the Process method!)
Public method | XmlRsaEncryption(AuthorEncryptionKey, String) | Creates a new XmlRsaEncryption object, initialized with the encryption data and input XML document string.
Public method | XmlRsaEncryption(AuthorEncryptionKey, XmlDocument) | Creates a new XmlRsaEncryption object, initialized with the encryption data and input document.
Public method | XmlRsaEncryption(AuthorEncryptionKey, XmlNode) | Creates a new XmlRsaEncryption object, initialized with the encryption data and input XML root node.
Top
See Also

Reference

XmlRsaEncryption Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryption Constructor

XmlRsaEncryption Constructor
Creates a new XmlRsaEncryption object. (Requires the EncryptionKey and InputDocument properties to be set before calling the Process method!)

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaEncryption()
Public Sub New
public:
XmlRsaEncryption()
See Also

Reference

XmlRsaEncryption Class
XmlRsaEncryption Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryption Constructor (AuthorEncryptionKey, String)

XmlRsaEncryption Constructor (AuthorEncryptionKey, String)
Creates a new XmlRsaEncryption object, initialized with the encryption data and input XML document string.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaEncryption(
    AuthorEncryptionKey encryptionKey,
    string input
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    input As String
)
public:
XmlRsaEncryption(
    AuthorEncryptionKey^ encryptionKey,
    String^ input
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object pre-initialized with the encryption data.
input
Type: SystemString
The XML string data to sign and encrypt.
See Also

Reference

XmlRsaEncryption Class
XmlRsaEncryption Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryption Constructor (AuthorEncryptionKey, XmlDocument)

XmlRsaEncryption Constructor (AuthorEncryptionKey, XmlDocument)
Creates a new XmlRsaEncryption object, initialized with the encryption data and input document.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaEncryption(
    AuthorEncryptionKey encryptionKey,
    XmlDocument input
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    input As XmlDocument
)
public:
XmlRsaEncryption(
    AuthorEncryptionKey^ encryptionKey,
    XmlDocument^ input
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object pre-initialized with the encryption data.
input
Type: System.XmlXmlDocument
The XmlDocument object to sign and encrypt.
See Also

Reference

XmlRsaEncryption Class
XmlRsaEncryption Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryption Constructor (AuthorEncryptionKey, XmlNode)

XmlRsaEncryption Constructor (AuthorEncryptionKey, XmlNode)
Creates a new XmlRsaEncryption object, initialized with the encryption data and input XML root node.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaEncryption(
    AuthorEncryptionKey encryptionKey,
    XmlNode input
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    input As XmlNode
)
public:
XmlRsaEncryption(
    AuthorEncryptionKey^ encryptionKey,
    XmlNode^ input
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object pre-initialized with the encryption data.
input
Type: System.XmlXmlNode
The XmlNode object referencing the root/document node to sign and encrypt.
See Also

Reference

XmlRsaEncryption Class
XmlRsaEncryption Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryption Properties

XmlRsaEncryption Properties

The XmlRsaEncryption type exposes the following members.

Properties
 | Name | Description
Public property | EncryptionKey | Gets or sets the Encryption Key data required for cryptographic routines. (Inherited from XmlRsaEncryptionBase.)
Public property | EncryptionOptions | Gets or sets options used when encrypting or decrypting. (Inherited from XmlRsaEncryptionBase.)
Public property | InputDocument | Gets or sets the input XmlDocument. (Inherited from XmlRsaEncryptionBase.)
Public property | InputDocumentString | Gets or sets the input XML string. (Changing the InputDocument property affects this property, and setting this property updates the InputDocument property.) (Inherited from XmlRsaEncryptionBase.)
Public property | LastError | Gets or sets the last error that occurred. (Inherited from XmlRsaEncryptionBase.)
Public property | OutputDocument | Gets or sets the output XmlDocument (null when processing has not been or completed, or failed). (Inherited from XmlRsaEncryptionBase.)
Public property | OutputDocumentString | Gets the output XML string (derived from the OutputDocument property, this is an empty string null when processing has not been or completed, or failed). (Inherited from XmlRsaEncryptionBase.)
Public property | SignatureOptions | Gets or sets options used when creating or verifying digital signatures. (Inherited from XmlRsaEncryptionBase.)
Public property | UseEncryption | Gets whether encryption or decryption is required. (Inherited from XmlRsaEncryptionBase.)
Public property | UseSignatures | Gets whether digital signatures need to be created or verified. (Inherited from XmlRsaEncryptionBase.)
Top
See Also

Reference

XmlRsaEncryption Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryption Methods

XmlRsaEncryption Methods

The XmlRsaEncryption type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Process | Processes the input document. (Overrides XmlRsaEncryptionBaseProcess.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlRsaEncryption Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryption.Process Method

XmlRsaEncryptionProcess Method
Processes the input document.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Process()
Public Overrides Function Process As Boolean
public:
virtual bool Process() override

Return Value

Type: Boolean
Returns true and and stores the result in the OutputDocument property if successful. If it is not successful, check the LastError property for details.
See Also

Reference

XmlRsaEncryption Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase Class

XmlRsaEncryptionBase Class
Base class from which XML, RSA Algorithm cryptographic routines are implemented.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.EncryptionXmlRsaEncryptionBase
com.softwarekey.Client.EncryptionXmlRsaDecryption
com.softwarekey.Client.EncryptionXmlRsaEncryption

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class XmlRsaEncryptionBase
Public MustInherit Class XmlRsaEncryptionBase
public ref class XmlRsaEncryptionBase abstract

The XmlRsaEncryptionBase type exposes the following members.

Constructors
 | Name | Description
Public method | XmlRsaEncryptionBase | Creates a new XmlRsaEncryptionBase object. (Requires the EncryptionKey and InputDocument properties to be set before calling the Process method!)
Public method | XmlRsaEncryptionBase(AuthorEncryptionKey, String) | Creates a new XmlRsaEncryptionBase object, initialized with the encryption data and input XML document string.
Public method | XmlRsaEncryptionBase(AuthorEncryptionKey, XmlDocument) | Creates a new XmlRsaEncryptionBase object, initialized with the encryption data and input document.
Public method | XmlRsaEncryptionBase(AuthorEncryptionKey, XmlNode) | Creates a new XmlRsaEncryptionBase object, initialized with the encryption data and input XML root node.
Top
Properties
 | Name | Description
Public property | EncryptionKey | Gets or sets the Encryption Key data required for cryptographic routines.
Public property | EncryptionOptions | Gets or sets options used when encrypting or decrypting.
Public property | InputDocument | Gets or sets the input XmlDocument.
Public property | InputDocumentString | Gets or sets the input XML string. (Changing the InputDocument property affects this property, and setting this property updates the InputDocument property.)
Public property | LastError | Gets or sets the last error that occurred.
Public property | OutputDocument | Gets or sets the output XmlDocument (null when processing has not been or completed, or failed).
Public property | OutputDocumentString | Gets the output XML string (derived from the OutputDocument property, this is an empty string null when processing has not been or completed, or failed).
Public property | SignatureOptions | Gets or sets options used when creating or verifying digital signatures.
Public property | UseEncryption | Gets whether encryption or decryption is required.
Public property | UseSignatures | Gets whether digital signatures need to be created or verified.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Process | Processes the input document.
Public method | ToString | (Inherited from Object.)
Top
Remarks
Caution note Caution

Use of this class directly is atypical and generally not recommended. This is available to make it easier to use customized License File and Web service request formats.

See Also

Reference

com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase Constructor

XmlRsaEncryptionBase Constructor
Overload List
 | Name | Description
Public method | XmlRsaEncryptionBase | Creates a new XmlRsaEncryptionBase object. (Requires the EncryptionKey and InputDocument properties to be set before calling the Process method!)
Public method | XmlRsaEncryptionBase(AuthorEncryptionKey, String) | Creates a new XmlRsaEncryptionBase object, initialized with the encryption data and input XML document string.
Public method | XmlRsaEncryptionBase(AuthorEncryptionKey, XmlDocument) | Creates a new XmlRsaEncryptionBase object, initialized with the encryption data and input document.
Public method | XmlRsaEncryptionBase(AuthorEncryptionKey, XmlNode) | Creates a new XmlRsaEncryptionBase object, initialized with the encryption data and input XML root node.
Top
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase Constructor

XmlRsaEncryptionBase Constructor
Creates a new XmlRsaEncryptionBase object. (Requires the EncryptionKey and InputDocument properties to be set before calling the Process method!)

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaEncryptionBase()
Public Sub New
public:
XmlRsaEncryptionBase()
See Also

Reference

XmlRsaEncryptionBase Class
XmlRsaEncryptionBase Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase Constructor (AuthorEncryptionKey, String)

XmlRsaEncryptionBase Constructor (AuthorEncryptionKey, String)
Creates a new XmlRsaEncryptionBase object, initialized with the encryption data and input XML document string.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaEncryptionBase(
    AuthorEncryptionKey encryptionKey,
    string input
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    input As String
)
public:
XmlRsaEncryptionBase(
    AuthorEncryptionKey^ encryptionKey,
    String^ input
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object pre-initialized with the encryption data.
input
Type: SystemString
The XML string data to process.
See Also

Reference

XmlRsaEncryptionBase Class
XmlRsaEncryptionBase Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase Constructor (AuthorEncryptionKey, XmlDocument)

XmlRsaEncryptionBase Constructor (AuthorEncryptionKey, XmlDocument)
Creates a new XmlRsaEncryptionBase object, initialized with the encryption data and input document.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaEncryptionBase(
    AuthorEncryptionKey encryptionKey,
    XmlDocument input
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    input As XmlDocument
)
public:
XmlRsaEncryptionBase(
    AuthorEncryptionKey^ encryptionKey,
    XmlDocument^ input
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object pre-initialized with the encryption data.
input
Type: System.XmlXmlDocument
The XmlDocument object to process.
See Also

Reference

XmlRsaEncryptionBase Class
XmlRsaEncryptionBase Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase Constructor (AuthorEncryptionKey, XmlNode)

XmlRsaEncryptionBase Constructor (AuthorEncryptionKey, XmlNode)
Creates a new XmlRsaEncryptionBase object, initialized with the encryption data and input XML root node.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaEncryptionBase(
    AuthorEncryptionKey encryptionKey,
    XmlNode input
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    input As XmlNode
)
public:
XmlRsaEncryptionBase(
    AuthorEncryptionKey^ encryptionKey,
    XmlNode^ input
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object pre-initialized with the encryption data.
input
Type: System.XmlXmlNode
The XmlNode object referencing the root/document node to process.
See Also

Reference

XmlRsaEncryptionBase Class
XmlRsaEncryptionBase Overload
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase Properties

XmlRsaEncryptionBase Properties

The XmlRsaEncryptionBase type exposes the following members.

Properties
 | Name | Description
Public property | EncryptionKey | Gets or sets the Encryption Key data required for cryptographic routines.
Public property | EncryptionOptions | Gets or sets options used when encrypting or decrypting.
Public property | InputDocument | Gets or sets the input XmlDocument.
Public property | InputDocumentString | Gets or sets the input XML string. (Changing the InputDocument property affects this property, and setting this property updates the InputDocument property.)
Public property | LastError | Gets or sets the last error that occurred.
Public property | OutputDocument | Gets or sets the output XmlDocument (null when processing has not been or completed, or failed).
Public property | OutputDocumentString | Gets the output XML string (derived from the OutputDocument property, this is an empty string null when processing has not been or completed, or failed).
Public property | SignatureOptions | Gets or sets options used when creating or verifying digital signatures.
Public property | UseEncryption | Gets whether encryption or decryption is required.
Public property | UseSignatures | Gets whether digital signatures need to be created or verified.
Top
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.EncryptionKey Property

XmlRsaEncryptionBaseEncryptionKey Property
Gets or sets the Encryption Key data required for cryptographic routines.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public AuthorEncryptionKey EncryptionKey { get; set; }
Public Property EncryptionKey As AuthorEncryptionKey
    Get
    Set
public:
property AuthorEncryptionKey^ EncryptionKey {
    AuthorEncryptionKey^ get ();
    void set (AuthorEncryptionKey^ value);
}

Property Value

Type: AuthorEncryptionKey
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.EncryptionOptions Property

XmlRsaEncryptionBaseEncryptionOptions Property
Gets or sets options used when encrypting or decrypting.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaEncryptionOptions EncryptionOptions { get; set; }
Public Property EncryptionOptions As XmlRsaEncryptionOptions
    Get
    Set
public:
property XmlRsaEncryptionOptions EncryptionOptions {
    XmlRsaEncryptionOptions get ();
    void set (XmlRsaEncryptionOptions value);
}

Property Value

Type: XmlRsaEncryptionOptions
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.InputDocument Property

XmlRsaEncryptionBaseInputDocument Property
Gets or sets the input XmlDocument.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlDocument InputDocument { get; set; }
Public Property InputDocument As XmlDocument
    Get
    Set
public:
property XmlDocument^ InputDocument {
    XmlDocument^ get ();
    void set (XmlDocument^ value);
}

Property Value

Type: XmlDocument
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.InputDocumentString Property

XmlRsaEncryptionBaseInputDocumentString Property
Gets or sets the input XML string. (Changing the InputDocument property affects this property, and setting this property updates the InputDocument property.)

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InputDocumentString { get; set; }
Public Property InputDocumentString As String
    Get
    Set
public:
property String^ InputDocumentString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.LastError Property

XmlRsaEncryptionBaseLastError Property
Gets or sets the last error that occurred.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError LastError { get; set; }
Public Property LastError As LicenseError
    Get
    Set
public:
property LicenseError^ LastError {
    LicenseError^ get ();
    void set (LicenseError^ value);
}

Property Value

Type: LicenseError
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.OutputDocument Property

XmlRsaEncryptionBaseOutputDocument Property
Gets or sets the output XmlDocument (null when processing has not been or completed, or failed).

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlDocument OutputDocument { get; set; }
Public Property OutputDocument As XmlDocument
    Get
    Set
public:
property XmlDocument^ OutputDocument {
    XmlDocument^ get ();
    void set (XmlDocument^ value);
}

Property Value

Type: XmlDocument
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.OutputDocumentString Property

XmlRsaEncryptionBaseOutputDocumentString Property
Gets the output XML string (derived from the OutputDocument property, this is an empty string null when processing has not been or completed, or failed).

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string OutputDocumentString { get; }
Public ReadOnly Property OutputDocumentString As String
    Get
public:
property String^ OutputDocumentString {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.SignatureOptions Property

XmlRsaEncryptionBaseSignatureOptions Property
Gets or sets options used when creating or verifying digital signatures.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlRsaSignatureOptions SignatureOptions { get; set; }
Public Property SignatureOptions As XmlRsaSignatureOptions
    Get
    Set
public:
property XmlRsaSignatureOptions SignatureOptions {
    XmlRsaSignatureOptions get ();
    void set (XmlRsaSignatureOptions value);
}

Property Value

Type: XmlRsaSignatureOptions
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.UseEncryption Property

XmlRsaEncryptionBaseUseEncryption Property
Gets whether encryption or decryption is required.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool UseEncryption { get; }
Public Overridable ReadOnly Property UseEncryption As Boolean
    Get
public:
virtual property bool UseEncryption {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.UseSignatures Property

XmlRsaEncryptionBaseUseSignatures Property
Gets whether digital signatures need to be created or verified.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool UseSignatures { get; }
Public Overridable ReadOnly Property UseSignatures As Boolean
    Get
public:
virtual property bool UseSignatures {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase Methods

XmlRsaEncryptionBase Methods

The XmlRsaEncryptionBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Process | Processes the input document.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionBase.Process Method

XmlRsaEncryptionBaseProcess Method
Processes the input document.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract bool Process()
Public MustOverride Function Process As Boolean
public:
virtual bool Process() abstract

Return Value

Type: Boolean
Returns true and stores the result in the OutputDocument property if successful. If it is not successful, check the LastError property for details.
See Also

Reference

XmlRsaEncryptionBase Class
com.softwarekey.Client.Encryption Namespace


XmlRsaEncryptionOptions Enumeration

XmlRsaEncryptionOptions Enumeration
Encryption and Decryption Options.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum XmlRsaEncryptionOptions
Public Enumeration XmlRsaEncryptionOptions
public enum class XmlRsaEncryptionOptions
Members
Member name | Value | Description
OmitEncryption | 0 | Omit encryption and decryption
UseClientKey | 1 | Use the Client Key
UseServerKey | 2 | Use the Server Key
Default | 3 | Use the key pair as appropriate
See Also

Reference

com.softwarekey.Client.Encryption Namespace


XmlRsaSignatureOptions Enumeration

XmlRsaSignatureOptions Enumeration
Digital Signature Options.

Namespace: com.softwarekey.Client.Encryption
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum XmlRsaSignatureOptions
Public Enumeration XmlRsaSignatureOptions
public enum class XmlRsaSignatureOptions
Members
Member name | Value | Description
OmitSignature | 0 | Omit signing or verifying digital signatures.
UseClientKey | 1 | Use the Client Key.
UseServerKey | 2 | Use the Server Key.
EncryptionDefault | 1 | Use the key pair as appropriate for encryption.
DecryptionDefault | 2 | Use the key pair as appropriate for decryption.
See Also

Reference

com.softwarekey.Client.Encryption Namespace


com.softwarekey.Client.Gui Namespace

com.softwarekey.Client.Gui Namespace
Contains classes and data for licensing GUIs, such as the PLUSManagedGui Windows Forms component.
Classes
 | Class | Description
Public class | LicenseManagementActionCompleteEventArgs | Contains properties with data about a completed license management action.
Public class | LicenseStatusEntry | Represents a license status entry.
Public class | LicensingGui | Contains settings for a licensed application.
Public class | ManualActionLoadRequestedEventArgs | Contains event arguments for the ManualActionLoadRequested event.
Public class | ManualActionSaveRequestedEventArgs | Contains event arguments for the ManualActionSaveRequested event.
Enumerations
 | Enumeration | Description
Public enumeration | LicenseManagementActionTypes | Types of license management actions which may occur.
Public enumeration | LicenseStatusIcon | Different status icons.
Public enumeration | LicensingGuiDialog | License dialogs which may be displayed through the ShowDialog(LicensingGuiDialog, IWin32Window) method.


LicenseManagementActionCompleteEventArgs Class

LicenseManagementActionCompleteEventArgs Class
Contains properties with data about a completed license management action.
Inheritance Hierarchy
SystemObject
SystemEventArgs
com.softwarekey.Client.GuiLicenseManagementActionCompleteEventArgs

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseManagementActionCompleteEventArgs : EventArgs
Public Class LicenseManagementActionCompleteEventArgs
    Inherits EventArgs
public ref class LicenseManagementActionCompleteEventArgs : public EventArgs

The LicenseManagementActionCompleteEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the type of action.
Public property | LastError | Gets the last error that occurred.
Public property | LicenseID | Gets the License ID entered by the user.
Public property | NewLicenseContent | Gets whether or not the action was processed successfully and resulted in new license content, this property contains that new license content.
Public property | Password | Gets the password entered by the user.
Public property | PostProcessingSuccessful | Gets or sets whether or not action post-processing has been completed successfully.
Public property | ProcessedSuccessfully | Gets whether or not the action has been completed successfully.
Public property | TriggerCodeEventData | Gets the trigger code event data (if applicable/if an "Activation Code 2" is required/entered).
Public property | TriggerCodeNumber | Gets the trigger code number to process (if a trigger code was validated successfully).
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | A string representation of the action's result. (Overrides ObjectToString.)
Top
See Also

Reference

com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs Properties

LicenseManagementActionCompleteEventArgs Properties

The LicenseManagementActionCompleteEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ActionType | Gets the type of action.
Public property | LastError | Gets the last error that occurred.
Public property | LicenseID | Gets the License ID entered by the user.
Public property | NewLicenseContent | Gets whether or not the action was processed successfully and resulted in new license content, this property contains that new license content.
Public property | Password | Gets the password entered by the user.
Public property | PostProcessingSuccessful | Gets or sets whether or not action post-processing has been completed successfully.
Public property | ProcessedSuccessfully | Gets whether or not the action has been completed successfully.
Public property | TriggerCodeEventData | Gets the trigger code event data (if applicable/if an "Activation Code 2" is required/entered).
Public property | TriggerCodeNumber | Gets the trigger code number to process (if a trigger code was validated successfully).
Top
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs.ActionType Property

LicenseManagementActionCompleteEventArgsActionType Property
Gets the type of action.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseManagementActionTypes ActionType { get; }
Public ReadOnly Property ActionType As LicenseManagementActionTypes
    Get
public:
property LicenseManagementActionTypes ActionType {
    LicenseManagementActionTypes get ();
}

Property Value

Type: LicenseManagementActionTypes
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs.LastError Property

LicenseManagementActionCompleteEventArgsLastError Property
Gets the last error that occurred.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError LastError { get; set; }
Public Property LastError As LicenseError
    Get
    Set
public:
property LicenseError^ LastError {
    LicenseError^ get ();
    void set (LicenseError^ value);
}

Property Value

Type: LicenseError
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs.LicenseID Property

LicenseManagementActionCompleteEventArgsLicenseID Property
Gets the License ID entered by the user.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; }
Public ReadOnly Property LicenseID As Integer
    Get
public:
property int LicenseID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs.NewLicenseContent Property

LicenseManagementActionCompleteEventArgsNewLicenseContent Property
Gets whether or not the action was processed successfully and resulted in new license content, this property contains that new license content.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string NewLicenseContent { get; }
Public ReadOnly Property NewLicenseContent As String
    Get
public:
property String^ NewLicenseContent {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs.Password Property

LicenseManagementActionCompleteEventArgsPassword Property
Gets the password entered by the user.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; }
Public ReadOnly Property Password As String
    Get
public:
property String^ Password {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs.PostProcessingSuccessful Property

LicenseManagementActionCompleteEventArgsPostProcessingSuccessful Property
Gets or sets whether or not action post-processing has been completed successfully.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool PostProcessingSuccessful { get; set; }
Public Property PostProcessingSuccessful As Boolean
    Get
    Set
public:
property bool PostProcessingSuccessful {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs.ProcessedSuccessfully Property

LicenseManagementActionCompleteEventArgsProcessedSuccessfully Property
Gets whether or not the action has been completed successfully.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool ProcessedSuccessfully { get; }
Public ReadOnly Property ProcessedSuccessfully As Boolean
    Get
public:
property bool ProcessedSuccessfully {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs.TriggerCodeEventData Property

LicenseManagementActionCompleteEventArgsTriggerCodeEventData Property
Gets the trigger code event data (if applicable/if an "Activation Code 2" is required/entered).

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int TriggerCodeEventData { get; }
Public ReadOnly Property TriggerCodeEventData As Integer
    Get
public:
property int TriggerCodeEventData {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs.TriggerCodeNumber Property

LicenseManagementActionCompleteEventArgsTriggerCodeNumber Property
Gets the trigger code number to process (if a trigger code was validated successfully).

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int TriggerCodeNumber { get; }
Public ReadOnly Property TriggerCodeNumber As Integer
    Get
public:
property int TriggerCodeNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs Methods

LicenseManagementActionCompleteEventArgs Methods

The LicenseManagementActionCompleteEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | A string representation of the action's result. (Overrides ObjectToString.)
Top
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionCompleteEventArgs.ToString Method

LicenseManagementActionCompleteEventArgsToString Method
A string representation of the action's result.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
Returns a string describing the result of the action.
See Also

Reference

LicenseManagementActionCompleteEventArgs Class
com.softwarekey.Client.Gui Namespace


LicenseManagementActionTypes Enumeration

LicenseManagementActionTypes Enumeration
Types of license management actions which may occur.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum LicenseManagementActionTypes
<FlagsAttribute>
Public Enumeration LicenseManagementActionTypes
[FlagsAttribute]
public enum class LicenseManagementActionTypes
Members
Member name | Value | Description
All | 127 | Mask for all actions.
AllManualActions | 56 | Mask for all manual actions (excluding ManualTriggerCode).
AllOnlineActions | 7 | Mask for all online actions.
None | 0 | Mask for no actions.
OnlineActivation | 1 | Activate the license using a direct Internet connection.
OnlineRefresh | 2 | Refresh the license using a direct Internet connection.
OnlineDeactivation | 4 | Deactivate the license using a direct Internet connection.
ManualActivation | 8 | Activate manually using a web browser on any computer with an Internet connection.
ManualRefresh | 16 | Refresh manually using a web browser on any computer with an Internet connection.
ManualDeactivation | 32 | Deactivate manually using a web browser on any computer with an Internet connection.
ManualTriggerCode | 64 | Activate manually using Protection PLUS 4 compatible trigger codes.
See Also

Reference

com.softwarekey.Client.Gui Namespace


LicenseStatusEntry Class

LicenseStatusEntry Class
Represents a license status entry.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.GuiLicenseStatusEntry

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseStatusEntry
Public Class LicenseStatusEntry
public ref class LicenseStatusEntry

The LicenseStatusEntry type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseStatusEntry | Creates a new LicenseStatusEntry
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Generates a string containing the name and status. (Overrides ObjectToString.)
Top
See Also

Reference

com.softwarekey.Client.Gui Namespace


LicenseStatusEntry Constructor

LicenseStatusEntry Constructor
Creates a new LicenseStatusEntry

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseStatusEntry(
    LicenseStatusIcon statusIcon,
    string displayName,
    string displayStatus
)
Public Sub New (
    statusIcon As LicenseStatusIcon,
    displayName As String,
    displayStatus As String
)
public:
LicenseStatusEntry(
    LicenseStatusIcon statusIcon,
    String^ displayName,
    String^ displayStatus
)

Parameters

statusIcon
Type: com.softwarekey.Client.GuiLicenseStatusIcon
The icon to display in the list.
displayName
Type: SystemString
The name of the status entry. This can be "License" or the name of a particular application module, feature, or license parameter.
displayStatus
Type: SystemString
The status text to display.
See Also

Reference

LicenseStatusEntry Class
com.softwarekey.Client.Gui Namespace


LicenseStatusEntry Methods

LicenseStatusEntry Methods

The LicenseStatusEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Generates a string containing the name and status. (Overrides ObjectToString.)
Top
See Also

Reference

LicenseStatusEntry Class
com.softwarekey.Client.Gui Namespace


LicenseStatusEntry.ToString Method

LicenseStatusEntryToString Method
Generates a string containing the name and status.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
Returns a string containing the DisplayName and DisplayStatus.
See Also

Reference

LicenseStatusEntry Class
com.softwarekey.Client.Gui Namespace


LicenseStatusIcon Enumeration

LicenseStatusIcon Enumeration
Different status icons.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum LicenseStatusIcon
Public Enumeration LicenseStatusIcon
public enum class LicenseStatusIcon
Members
Member name | Value | Description
None | -1 | Don't display any icon in the list for this entry.
Ok | 0 | The status of the entry is Ok.
Error | 1 | The entry's status is invalid, possibly due to an error.
Information | 2 | The entry's status is Ok, but may include some additional information worth informing the user about.
Unavailable | 3 | The item, module, or feature is unavailable or disabled.
Warning | 4 | The entry's status is Ok, but requires the user's attention.
See Also

Reference

com.softwarekey.Client.Gui Namespace


LicensingGui Class

LicensingGui Class
Contains settings for a licensed application.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
com.softwarekey.Client.GuiLicensingGui

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicensingGui : Component
Public Class LicensingGui
    Inherits Component
public ref class LicensingGui : public Component

The LicensingGui type exposes the following members.

Constructors
 | Name | Description
Public method | LicensingGui | Creates a new LicensingGui object.
Top
Properties
 | Name | Description
Public property | AllowManualActivation | Gets or sets whether or not a user may activate manually using the license management dialog.
Public property | AllowManualDeactivation | Gets or sets whether or not a user may deactivate manually using the license management dialog.
Public property | AllowManualRefresh | Gets or sets whether or not a user may refresh manually using the license management dialog.
Public property | AllowManualTriggerCode | Gets or sets whether or not a user may manually alter the license using Protection PLUS 4 compatible trigger codes.
Public property | AllowOnlineActivation | Gets or sets whether or not a user may activate online using the license management dialog.
Public property | AllowOnlineDeactivation | Gets or sets whether or not a user may deactivate online using the license management dialog.
Public property | AllowOnlineRefresh | Gets or sets whether or not a user may refresh online using the license management dialog.
Public property | ApplicationLicense | Gets or sets the application's License.
Protected property | CanRaiseEvents | (Inherited from Component.)
Public property | ConnectionInformation | Gets automatically detected Internet connection information.
Public property | Container | (Inherited from Component.)
Public property | DefaultRequestFileName | Gets or sets the default request file name (Request.html by default).
Protected property | DesignMode | (Inherited from Component.)
Protected property | Events | (Inherited from Component.)
Public property | InitialLicenseID | Gets or sets the initial License ID displayed on the license management dialog.
Public property | InitialPassword | Gets or sets the initial password displayed on the license management dialog.
Public property | InternetAutoDetectionTimeout | Gets or sets the maximum amount of time (in milliseconds) an automatic detection tests to run.
Public property | InternetAutoDetectionUri | The URL to use for automatic detection tests.
Public property | InternetEnableAutoDetection | Set to true to enable automatic detection, or false to disable this feature.
Public property | LicenseManagementActionsAllowed | Gets or sets the license management actions allowed. You may manually add the integer values from the LicenseManagementActionTypes enumeration and add select values together to only enable certain actions, or you may use one of the enumeration's masks (such as All or None).
Public property | LicenseStatusEntries | Gets the collection of license status entries, which are displayed on the license management form.
Public property | ManagementDialogCustomIcon | Gets or sets a custom icon (which overrides the default if set) for the license management dialog.
Public property | ManagementDialogTitle | Gets or sets the title of the license management dialog.
Public property | ManualRequestUri | The URL to access SOLO Server's manual request processing page.
Public property | ProxyAuthenticationCredentials | Gets proxy server authentication credentials entered by the user.
Public property | RegKey2Seed | Gets or sets the seed value used to decode "Activation Code 2" values when activating manually. The decoded value will contain 14 bits of additional numeric data.
Public property | Site | (Inherited from Component.)
Public property | SplashBackgroundColor | Gets or sets the splash screen's background color that is used when no splash image is used.
Public property | SplashImage | Gets or sets the image to display on the splash screen.
Public property | SplashMinimumDuration | Gets or sets the minimum duration which the splash screen should be displayed. It may be displayed for a longer time if work is being done asynchronously.
Public property | SplashTopMost | Gets or sets whether to splash screen shows on top of all other windows.
Public property | TriggerCodeSeed | Gets or sets the seed value used for validating "Activation Code 1" values when activating manually.
Public property | TriggerCodesRequireLicenseID | Gets or sets whether or not users will be required to enter a License ID when activating via the manual exchange of trigger/activation codes.
Public property | TriggerCodesRequirePassword | Gets or sets whether or not users will be required to enter a password when activating via the manual exchange of trigger/activation codes. Requiring a password will also require a License ID.
Public property | XmlActivationServiceUri | The URL to access SOLO Server's XmlActivationService web service.
Public property | XmlLicenseFileServiceUri | The URL to access SOLO Server's XmlLicenseFileService web service.
Public property | XmlLicenseServiceUri | The URL to access SOLO Server's XmlLicenseService web service.
Public property | XmlNetworkFloatingServiceUri | The URL to access SOLO Server's XmlNetworkFloatingService web service.
Top
Methods
 | Name | Description
Public method | CreateNewXmlActivationServiceObject | Creates a new XmlActivationService object, which may be used for processing web service methods centered around activation.
Public method | CreateNewXmlLicenseFileServiceObject | Creates a new XmlLicenseFileService object, which may be used for processing web service methods centered around XML license file calls to SOLO Server.
Public method | CreateNewXmlLicenseServiceObject | Creates a new XmlLicenseService object, which may be used for processing web service methods centered around XML license calls to SOLO Server (such as update checks).
Public method | CreateNewXmlNetworkFloatingServiceObject | Creates a new XmlNetworkFloatingService object, which may be used for processing web service methods centered around network floating licensing via SOLO Server.
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ComponentDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | GetService | (Inherited from Component.)
Public method | GetType | (Inherited from Object.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Public method | InternetAutoDetect | Runs Internet and proxy auto-detection, regardless of the value in the InternetEnableAutoDetection property.
Public method | LoadSplashImageFile | Loads the SplashImage from a file.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Public method | ShowDialog(LicensingGuiDialog) | Displays the specified LicensingGuiDialog.
Public method | ShowDialog(LicensingGuiDialog, IWin32Window) | Displays the specified LicensingGuiDialog.
Public method | ShowDialog(LicensingGuiDialog, IWin32Window, FormStartPosition) | Displays the specified LicensingGuiDialog.
Public method | ToString | (Inherited from Component.)
Top
Events
 | Name | Description
Public event | Disposed | (Inherited from Component.)
Public event | LicenseManagementActionComplete | Occurs when the user has completed an action on the license management form.
Public event | ManualActionLoadRequested | Occurs when a saved manual request should be restored so that it may be completed.
Public event | ManualActionSaveRequested | Occurs when the user requests to complete a manual request later (in case the application is closed).
Public event | SplashDoWork | Occurs when the splash screen is ready to perform some arbitrary work asynchronously.
Public event | SplashWorkCompleteEvent | Occurs when the splash screen has completed some arbitrary work asynchronously.
Top
See Also

Reference

com.softwarekey.Client.Gui Namespace


LicensingGui Constructor

LicensingGui Constructor
Creates a new LicensingGui object.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicensingGui()
Public Sub New
public:
LicensingGui()
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui Properties

LicensingGui Properties

The LicensingGui type exposes the following members.

Properties
 | Name | Description
Public property | AllowManualActivation | Gets or sets whether or not a user may activate manually using the license management dialog.
Public property | AllowManualDeactivation | Gets or sets whether or not a user may deactivate manually using the license management dialog.
Public property | AllowManualRefresh | Gets or sets whether or not a user may refresh manually using the license management dialog.
Public property | AllowManualTriggerCode | Gets or sets whether or not a user may manually alter the license using Protection PLUS 4 compatible trigger codes.
Public property | AllowOnlineActivation | Gets or sets whether or not a user may activate online using the license management dialog.
Public property | AllowOnlineDeactivation | Gets or sets whether or not a user may deactivate online using the license management dialog.
Public property | AllowOnlineRefresh | Gets or sets whether or not a user may refresh online using the license management dialog.
Public property | ApplicationLicense | Gets or sets the application's License.
Protected property | CanRaiseEvents | (Inherited from Component.)
Public property | ConnectionInformation | Gets automatically detected Internet connection information.
Public property | Container | (Inherited from Component.)
Public property | DefaultRequestFileName | Gets or sets the default request file name (Request.html by default).
Protected property | DesignMode | (Inherited from Component.)
Protected property | Events | (Inherited from Component.)
Public property | InitialLicenseID | Gets or sets the initial License ID displayed on the license management dialog.
Public property | InitialPassword | Gets or sets the initial password displayed on the license management dialog.
Public property | InternetAutoDetectionTimeout | Gets or sets the maximum amount of time (in milliseconds) an automatic detection tests to run.
Public property | InternetAutoDetectionUri | The URL to use for automatic detection tests.
Public property | InternetEnableAutoDetection | Set to true to enable automatic detection, or false to disable this feature.
Public property | LicenseManagementActionsAllowed | Gets or sets the license management actions allowed. You may manually add the integer values from the LicenseManagementActionTypes enumeration and add select values together to only enable certain actions, or you may use one of the enumeration's masks (such as All or None).
Public property | LicenseStatusEntries | Gets the collection of license status entries, which are displayed on the license management form.
Public property | ManagementDialogCustomIcon | Gets or sets a custom icon (which overrides the default if set) for the license management dialog.
Public property | ManagementDialogTitle | Gets or sets the title of the license management dialog.
Public property | ManualRequestUri | The URL to access SOLO Server's manual request processing page.
Public property | ProxyAuthenticationCredentials | Gets proxy server authentication credentials entered by the user.
Public property | RegKey2Seed | Gets or sets the seed value used to decode "Activation Code 2" values when activating manually. The decoded value will contain 14 bits of additional numeric data.
Public property | Site | (Inherited from Component.)
Public property | SplashBackgroundColor | Gets or sets the splash screen's background color that is used when no splash image is used.
Public property | SplashImage | Gets or sets the image to display on the splash screen.
Public property | SplashMinimumDuration | Gets or sets the minimum duration which the splash screen should be displayed. It may be displayed for a longer time if work is being done asynchronously.
Public property | SplashTopMost | Gets or sets whether to splash screen shows on top of all other windows.
Public property | TriggerCodeSeed | Gets or sets the seed value used for validating "Activation Code 1" values when activating manually.
Public property | TriggerCodesRequireLicenseID | Gets or sets whether or not users will be required to enter a License ID when activating via the manual exchange of trigger/activation codes.
Public property | TriggerCodesRequirePassword | Gets or sets whether or not users will be required to enter a password when activating via the manual exchange of trigger/activation codes. Requiring a password will also require a License ID.
Public property | XmlActivationServiceUri | The URL to access SOLO Server's XmlActivationService web service.
Public property | XmlLicenseFileServiceUri | The URL to access SOLO Server's XmlLicenseFileService web service.
Public property | XmlLicenseServiceUri | The URL to access SOLO Server's XmlLicenseService web service.
Public property | XmlNetworkFloatingServiceUri | The URL to access SOLO Server's XmlNetworkFloatingService web service.
Top
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.AllowManualActivation Property

LicensingGuiAllowManualActivation Property
Gets or sets whether or not a user may activate manually using the license management dialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool AllowManualActivation { get; set; }
Public Property AllowManualActivation As Boolean
    Get
    Set
public:
property bool AllowManualActivation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.AllowManualDeactivation Property

LicensingGuiAllowManualDeactivation Property
Gets or sets whether or not a user may deactivate manually using the license management dialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool AllowManualDeactivation { get; set; }
Public Property AllowManualDeactivation As Boolean
    Get
    Set
public:
property bool AllowManualDeactivation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.AllowManualRefresh Property

LicensingGuiAllowManualRefresh Property
Gets or sets whether or not a user may refresh manually using the license management dialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool AllowManualRefresh { get; set; }
Public Property AllowManualRefresh As Boolean
    Get
    Set
public:
property bool AllowManualRefresh {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.AllowManualTriggerCode Property

LicensingGuiAllowManualTriggerCode Property
Gets or sets whether or not a user may manually alter the license using Protection PLUS 4 compatible trigger codes.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool AllowManualTriggerCode { get; set; }
Public Property AllowManualTriggerCode As Boolean
    Get
    Set
public:
property bool AllowManualTriggerCode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks

This option only works with WritableLicense implementations, and is implied when supporting Downloadable License Files with Trigger Code Validation.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.AllowOnlineActivation Property

LicensingGuiAllowOnlineActivation Property
Gets or sets whether or not a user may activate online using the license management dialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool AllowOnlineActivation { get; set; }
Public Property AllowOnlineActivation As Boolean
    Get
    Set
public:
property bool AllowOnlineActivation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.AllowOnlineDeactivation Property

LicensingGuiAllowOnlineDeactivation Property
Gets or sets whether or not a user may deactivate online using the license management dialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool AllowOnlineDeactivation { get; set; }
Public Property AllowOnlineDeactivation As Boolean
    Get
    Set
public:
property bool AllowOnlineDeactivation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.AllowOnlineRefresh Property

LicensingGuiAllowOnlineRefresh Property
Gets or sets whether or not a user may refresh online using the license management dialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool AllowOnlineRefresh { get; set; }
Public Property AllowOnlineRefresh As Boolean
    Get
    Set
public:
property bool AllowOnlineRefresh {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.ApplicationLicense Property

LicensingGuiApplicationLicense Property
Gets or sets the application's License.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public License ApplicationLicense { get; set; }
Public Property ApplicationLicense As License
    Get
    Set
public:
property License^ ApplicationLicense {
    License^ get ();
    void set (License^ value);
}

Property Value

Type: License
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.ConnectionInformation Property

LicensingGuiConnectionInformation Property
Gets automatically detected Internet connection information.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public InternetConnectionInformation ConnectionInformation { get; }
Public ReadOnly Property ConnectionInformation As InternetConnectionInformation
    Get
public:
property InternetConnectionInformation^ ConnectionInformation {
    InternetConnectionInformation^ get ();
}

Property Value

Type: InternetConnectionInformation
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.DefaultRequestFileName Property

LicensingGuiDefaultRequestFileName Property
Gets or sets the default request file name (Request.html by default).

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string DefaultRequestFileName { get; set; }
Public Property DefaultRequestFileName As String
    Get
    Set
public:
property String^ DefaultRequestFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.InitialLicenseID Property

LicensingGuiInitialLicenseID Property
Gets or sets the initial License ID displayed on the license management dialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int InitialLicenseID { get; set; }
Public Property InitialLicenseID As Integer
    Get
    Set
public:
property int InitialLicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks

When this property is set to a value greater than zero, the license management dialog will always show this License ID.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.InitialPassword Property

LicensingGuiInitialPassword Property
Gets or sets the initial password displayed on the license management dialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InitialPassword { get; set; }
Public Property InitialPassword As String
    Get
    Set
public:
property String^ InitialPassword {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

This initial password is only applied when the InitialLicenseID property is set to a value greater than zero.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.InternetAutoDetectionTimeout Property

LicensingGuiInternetAutoDetectionTimeout Property
Gets or sets the maximum amount of time (in milliseconds) an automatic detection tests to run.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int InternetAutoDetectionTimeout { get; set; }
Public Property InternetAutoDetectionTimeout As Integer
    Get
    Set
public:
property int InternetAutoDetectionTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks

This property is only applicable when InternetEnableAutoDetection is set to true.

Caution note Caution

Automatic proxy detection is a convenient way to detect Internet and proxy server requirements, but can cause delays, as this feature relies on test requests. Delays will occur more frequently when a system is using a slow Internet connection, or lacks Internet connectivity entirely.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.InternetAutoDetectionUri Property

LicensingGuiInternetAutoDetectionUri Property
The URL to use for automatic detection tests.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Uri InternetAutoDetectionUri { get; set; }
Public Property InternetAutoDetectionUri As Uri
    Get
    Set
public:
property Uri^ InternetAutoDetectionUri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
Remarks
Caution note Caution

This URL should match one of the web service URLs, and uses the default XmlActivationServiceUri value for tests unless another URL is specified.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.InternetEnableAutoDetection Property

LicensingGuiInternetEnableAutoDetection Property
Set to true to enable automatic detection, or false to disable this feature.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool InternetEnableAutoDetection { get; set; }
Public Property InternetEnableAutoDetection As Boolean
    Get
    Set
public:
property bool InternetEnableAutoDetection {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Caution note Caution

Automatic proxy detection is a convenient way to detect Internet and proxy server requirements, but can cause delays, as this feature relies on test requests. Delays will occur more frequently when a system is using a slow Internet connection, or lacks Internet connectivity entirely.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.LicenseManagementActionsAllowed Property

LicensingGuiLicenseManagementActionsAllowed Property
Gets or sets the license management actions allowed. You may manually add the integer values from the LicenseManagementActionTypes enumeration and add select values together to only enable certain actions, or you may use one of the enumeration's masks (such as All or None).

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseManagementActionsAllowed { get; set; }
Public Property LicenseManagementActionsAllowed As Integer
    Get
    Set
public:
property int LicenseManagementActionsAllowed {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.LicenseStatusEntries Property

LicensingGuiLicenseStatusEntries Property
Gets the collection of license status entries, which are displayed on the license management form.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Collection<LicenseStatusEntry> LicenseStatusEntries { get; }
Public ReadOnly Property LicenseStatusEntries As Collection(Of LicenseStatusEntry)
    Get
public:
property Collection<LicenseStatusEntry^>^ LicenseStatusEntries {
    Collection<LicenseStatusEntry^>^ get ();
}

Property Value

Type: Collection LicenseStatusEntry
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.ManagementDialogCustomIcon Property

LicensingGuiManagementDialogCustomIcon Property
Gets or sets a custom icon (which overrides the default if set) for the license management dialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Icon ManagementDialogCustomIcon { get; set; }
Public Property ManagementDialogCustomIcon As Icon
    Get
    Set
public:
property Icon^ ManagementDialogCustomIcon {
    Icon^ get ();
    void set (Icon^ value);
}

Property Value

Type: Icon
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.ManagementDialogTitle Property

LicensingGuiManagementDialogTitle Property
Gets or sets the title of the license management dialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ManagementDialogTitle { get; set; }
Public Property ManagementDialogTitle As String
    Get
    Set
public:
property String^ ManagementDialogTitle {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.ManualRequestUri Property

LicensingGuiManualRequestUri Property
The URL to access SOLO Server's manual request processing page.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Uri ManualRequestUri { get; set; }
Public Property ManualRequestUri As Uri
    Get
    Set
public:
property Uri^ ManualRequestUri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.ProxyAuthenticationCredentials Property

LicensingGuiProxyAuthenticationCredentials Property
Gets proxy server authentication credentials entered by the user.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkCredential ProxyAuthenticationCredentials { get; }
Public ReadOnly Property ProxyAuthenticationCredentials As NetworkCredential
    Get
public:
property NetworkCredential^ ProxyAuthenticationCredentials {
    NetworkCredential^ get ();
}

Property Value

Type: NetworkCredential
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.RegKey2Seed Property

LicensingGuiRegKey2Seed Property
Gets or sets the seed value used to decode "Activation Code 2" values when activating manually. The decoded value will contain 14 bits of additional numeric data.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int RegKey2Seed { get; set; }
Public Property RegKey2Seed As Integer
    Get
    Set
public:
property int RegKey2Seed {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.SplashBackgroundColor Property

LicensingGuiSplashBackgroundColor Property
Gets or sets the splash screen's background color that is used when no splash image is used.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Color SplashBackgroundColor { get; set; }
Public Property SplashBackgroundColor As Color
    Get
    Set
public:
property Color SplashBackgroundColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.SplashImage Property

LicensingGuiSplashImage Property
Gets or sets the image to display on the splash screen.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Image SplashImage { get; set; }
Public Property SplashImage As Image
    Get
    Set
public:
property Image^ SplashImage {
    Image^ get ();
    void set (Image^ value);
}

Property Value

Type: Image
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.SplashMinimumDuration Property

LicensingGuiSplashMinimumDuration Property
Gets or sets the minimum duration which the splash screen should be displayed. It may be displayed for a longer time if work is being done asynchronously.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int SplashMinimumDuration { get; set; }
Public Property SplashMinimumDuration As Integer
    Get
    Set
public:
property int SplashMinimumDuration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.SplashTopMost Property

LicensingGuiSplashTopMost Property
Gets or sets whether to splash screen shows on top of all other windows.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool SplashTopMost { get; set; }
Public Property SplashTopMost As Boolean
    Get
    Set
public:
property bool SplashTopMost {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.TriggerCodeSeed Property

LicensingGuiTriggerCodeSeed Property
Gets or sets the seed value used for validating "Activation Code 1" values when activating manually.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int TriggerCodeSeed { get; set; }
Public Property TriggerCodeSeed As Integer
    Get
    Set
public:
property int TriggerCodeSeed {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.TriggerCodesRequireLicenseID Property

LicensingGuiTriggerCodesRequireLicenseID Property
Gets or sets whether or not users will be required to enter a License ID when activating via the manual exchange of trigger/activation codes.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool TriggerCodesRequireLicenseID { get; set; }
Public Property TriggerCodesRequireLicenseID As Boolean
    Get
    Set
public:
property bool TriggerCodesRequireLicenseID {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.TriggerCodesRequirePassword Property

LicensingGuiTriggerCodesRequirePassword Property
Gets or sets whether or not users will be required to enter a password when activating via the manual exchange of trigger/activation codes. Requiring a password will also require a License ID.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool TriggerCodesRequirePassword { get; set; }
Public Property TriggerCodesRequirePassword As Boolean
    Get
    Set
public:
property bool TriggerCodesRequirePassword {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.XmlActivationServiceUri Property

LicensingGuiXmlActivationServiceUri Property
The URL to access SOLO Server's XmlActivationService web service.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Uri XmlActivationServiceUri { get; set; }
Public Property XmlActivationServiceUri As Uri
    Get
    Set
public:
property Uri^ XmlActivationServiceUri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.XmlLicenseFileServiceUri Property

LicensingGuiXmlLicenseFileServiceUri Property
The URL to access SOLO Server's XmlLicenseFileService web service.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Uri XmlLicenseFileServiceUri { get; set; }
Public Property XmlLicenseFileServiceUri As Uri
    Get
    Set
public:
property Uri^ XmlLicenseFileServiceUri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.XmlLicenseServiceUri Property

LicensingGuiXmlLicenseServiceUri Property
The URL to access SOLO Server's XmlLicenseService web service.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Uri XmlLicenseServiceUri { get; set; }
Public Property XmlLicenseServiceUri As Uri
    Get
    Set
public:
property Uri^ XmlLicenseServiceUri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.XmlNetworkFloatingServiceUri Property

LicensingGuiXmlNetworkFloatingServiceUri Property
The URL to access SOLO Server's XmlNetworkFloatingService web service.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Uri XmlNetworkFloatingServiceUri { get; set; }
Public Property XmlNetworkFloatingServiceUri As Uri
    Get
    Set
public:
property Uri^ XmlNetworkFloatingServiceUri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui Methods

LicensingGui Methods

The LicensingGui type exposes the following members.

Methods
 | Name | Description
Public method | CreateNewXmlActivationServiceObject | Creates a new XmlActivationService object, which may be used for processing web service methods centered around activation.
Public method | CreateNewXmlLicenseFileServiceObject | Creates a new XmlLicenseFileService object, which may be used for processing web service methods centered around XML license file calls to SOLO Server.
Public method | CreateNewXmlLicenseServiceObject | Creates a new XmlLicenseService object, which may be used for processing web service methods centered around XML license calls to SOLO Server (such as update checks).
Public method | CreateNewXmlNetworkFloatingServiceObject | Creates a new XmlNetworkFloatingService object, which may be used for processing web service methods centered around network floating licensing via SOLO Server.
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ComponentDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | GetService | (Inherited from Component.)
Public method | GetType | (Inherited from Object.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Public method | InternetAutoDetect | Runs Internet and proxy auto-detection, regardless of the value in the InternetEnableAutoDetection property.
Public method | LoadSplashImageFile | Loads the SplashImage from a file.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Public method | ShowDialog(LicensingGuiDialog) | Displays the specified LicensingGuiDialog.
Public method | ShowDialog(LicensingGuiDialog, IWin32Window) | Displays the specified LicensingGuiDialog.
Public method | ShowDialog(LicensingGuiDialog, IWin32Window, FormStartPosition) | Displays the specified LicensingGuiDialog.
Public method | ToString | (Inherited from Component.)
Top
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.CreateNewXmlActivationServiceObject Method

LicensingGuiCreateNewXmlActivationServiceObject Method
Creates a new XmlActivationService object, which may be used for processing web service methods centered around activation.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlActivationService CreateNewXmlActivationServiceObject()
Public Function CreateNewXmlActivationServiceObject As XmlActivationService
public:
XmlActivationService^ CreateNewXmlActivationServiceObject()

Return Value

Type: XmlActivationService
Returns a new XmlActivationService object.
Remarks
Caution note Caution

If InternetEnableAutoDetection is set to true, an automatic detection test may be run to test connectivity and detect proxy settings, which can cause delays.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.CreateNewXmlLicenseFileServiceObject Method

LicensingGuiCreateNewXmlLicenseFileServiceObject Method
Creates a new XmlLicenseFileService object, which may be used for processing web service methods centered around XML license file calls to SOLO Server.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlLicenseFileService CreateNewXmlLicenseFileServiceObject()
Public Function CreateNewXmlLicenseFileServiceObject As XmlLicenseFileService
public:
XmlLicenseFileService^ CreateNewXmlLicenseFileServiceObject()

Return Value

Type: XmlLicenseFileService
Returns a new XmlLicenseFileService object.
Remarks
Caution note Caution

If InternetEnableAutoDetection is set to true, an automatic detection test may be run to test connectivity and detect proxy settings, which can cause delays.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.CreateNewXmlLicenseServiceObject Method

LicensingGuiCreateNewXmlLicenseServiceObject Method
Creates a new XmlLicenseService object, which may be used for processing web service methods centered around XML license calls to SOLO Server (such as update checks).

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlLicenseService CreateNewXmlLicenseServiceObject()
Public Function CreateNewXmlLicenseServiceObject As XmlLicenseService
public:
XmlLicenseService^ CreateNewXmlLicenseServiceObject()

Return Value

Type: XmlLicenseService
Returns a new XmlLicenseService object.
Remarks
Caution note Caution

If InternetEnableAutoDetection is set to true, an automatic detection test may be run to test connectivity and detect proxy settings, which can cause delays.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.CreateNewXmlNetworkFloatingServiceObject Method

LicensingGuiCreateNewXmlNetworkFloatingServiceObject Method
Creates a new XmlNetworkFloatingService object, which may be used for processing web service methods centered around network floating licensing via SOLO Server.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNetworkFloatingService CreateNewXmlNetworkFloatingServiceObject()
Public Function CreateNewXmlNetworkFloatingServiceObject As XmlNetworkFloatingService
public:
XmlNetworkFloatingService^ CreateNewXmlNetworkFloatingServiceObject()

Return Value

Type: XmlNetworkFloatingService
Returns a new XmlNetworkFloatingService object.
Remarks
Caution note Caution

If InternetEnableAutoDetection is set to true, an automatic detection test may be run to test connectivity and detect proxy settings, which can cause delays.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.Dispose Method

LicensingGuiDispose Method
Overload List
 | Name | Description
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.Dispose Method (Boolean)

LicensingGuiDispose Method (Boolean)
Clean up any resources being used.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

LicensingGui Class
Dispose Overload
com.softwarekey.Client.Gui Namespace


LicensingGui.InternetAutoDetect Method

LicensingGuiInternetAutoDetect Method
Runs Internet and proxy auto-detection, regardless of the value in the InternetEnableAutoDetection property.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool InternetAutoDetect()
Public Function InternetAutoDetect As Boolean
public:
bool InternetAutoDetect()

Return Value

Type: Boolean
Returns true if an Internet connection is present. If false is returned, check the ConnectionInformation.LastError property for details.
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.LoadSplashImageFile Method

LicensingGuiLoadSplashImageFile Method
Loads the SplashImage from a file.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void LoadSplashImageFile(
    string path
)
Public Sub LoadSplashImageFile (
    path As String
)
public:
void LoadSplashImageFile(
    String^ path
)

Parameters

path
Type: SystemString
The absolute path to the image file to load.
Remarks

If the splash screen image cannot be loaded, the splash screen will still be displayed without the image.

See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.ShowDialog Method

LicensingGuiShowDialog Method
Overload List
 | Name | Description
Public method | ShowDialog(LicensingGuiDialog) | Displays the specified LicensingGuiDialog.
Public method | ShowDialog(LicensingGuiDialog, IWin32Window) | Displays the specified LicensingGuiDialog.
Public method | ShowDialog(LicensingGuiDialog, IWin32Window, FormStartPosition) | Displays the specified LicensingGuiDialog.
Top
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.ShowDialog Method (LicensingGuiDialog)

LicensingGuiShowDialog Method (LicensingGuiDialog)
Displays the specified LicensingGuiDialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ShowDialog(
    LicensingGuiDialog dialog
)
Public Sub ShowDialog (
    dialog As LicensingGuiDialog
)
public:
void ShowDialog(
    LicensingGuiDialog dialog
)

Parameters

dialog
Type: com.softwarekey.Client.GuiLicensingGuiDialog
The LicensingGuiDialog to display.

Return Value

Type:
Returns a DialogResult.
See Also

Reference

LicensingGui Class
ShowDialog Overload
com.softwarekey.Client.Gui Namespace


LicensingGui.ShowDialog Method (LicensingGuiDialog, IWin32Window)

LicensingGuiShowDialog Method (LicensingGuiDialog, IWin32Window)
Displays the specified LicensingGuiDialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ShowDialog(
    LicensingGuiDialog dialog,
    IWin32Window owner
)
Public Sub ShowDialog (
    dialog As LicensingGuiDialog,
    owner As IWin32Window
)
public:
void ShowDialog(
    LicensingGuiDialog dialog,
    IWin32Window^ owner
)

Parameters

dialog
Type: com.softwarekey.Client.GuiLicensingGuiDialog
The LicensingGuiDialog to display.
owner
Type: System.Windows.FormsIWin32Window
The window which will own the modal dialog.

Return Value

Type:
Returns a DialogResult.
See Also

Reference

LicensingGui Class
ShowDialog Overload
com.softwarekey.Client.Gui Namespace


LicensingGui.ShowDialog Method (LicensingGuiDialog, IWin32Window, FormStartPosition)

LicensingGuiShowDialog Method (LicensingGuiDialog, IWin32Window, FormStartPosition)
Displays the specified LicensingGuiDialog.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DialogResult ShowDialog(
    LicensingGuiDialog dialog,
    IWin32Window owner,
    FormStartPosition position
)
Public Function ShowDialog (
    dialog As LicensingGuiDialog,
    owner As IWin32Window,
    position As FormStartPosition
) As DialogResult
public:
DialogResult ShowDialog(
    LicensingGuiDialog dialog,
    IWin32Window^ owner,
    FormStartPosition position
)

Parameters

dialog
Type: com.softwarekey.Client.GuiLicensingGuiDialog
The LicensingGuiDialog to display.
owner
Type: System.Windows.FormsIWin32Window
The window which will own the modal dialog.
position
Type: System.Windows.FormsFormStartPosition
The dialog's start position.

Return Value

Type: DialogResult
Returns a DialogResult.
See Also

Reference

LicensingGui Class
ShowDialog Overload
com.softwarekey.Client.Gui Namespace


LicensingGui Events

LicensingGui Events

The LicensingGui type exposes the following members.

Events
 | Name | Description
Public event | Disposed | (Inherited from Component.)
Public event | LicenseManagementActionComplete | Occurs when the user has completed an action on the license management form.
Public event | ManualActionLoadRequested | Occurs when a saved manual request should be restored so that it may be completed.
Public event | ManualActionSaveRequested | Occurs when the user requests to complete a manual request later (in case the application is closed).
Public event | SplashDoWork | Occurs when the splash screen is ready to perform some arbitrary work asynchronously.
Public event | SplashWorkCompleteEvent | Occurs when the splash screen has completed some arbitrary work asynchronously.
Top
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.LicenseManagementActionComplete Event

LicensingGuiLicenseManagementActionComplete Event
Occurs when the user has completed an action on the license management form.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event EventHandler<LicenseManagementActionCompleteEventArgs> LicenseManagementActionComplete
Public Event LicenseManagementActionComplete As EventHandler(Of LicenseManagementActionCompleteEventArgs)
public:
 event EventHandler<LicenseManagementActionCompleteEventArgs^>^ LicenseManagementActionComplete {
    void add (EventHandler<LicenseManagementActionCompleteEventArgs^>^ value);
    void remove (EventHandler<LicenseManagementActionCompleteEventArgs^>^ value);
}

Value

Type: SystemEventHandler LicenseManagementActionCompleteEventArgs
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.ManualActionLoadRequested Event

LicensingGuiManualActionLoadRequested Event
Occurs when a saved manual request should be restored so that it may be completed.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ManualActionLoadRequestedEventArgs> ManualActionLoadRequested
Public Event ManualActionLoadRequested As EventHandler(Of ManualActionLoadRequestedEventArgs)
public:
 event EventHandler<ManualActionLoadRequestedEventArgs^>^ ManualActionLoadRequested {
    void add (EventHandler<ManualActionLoadRequestedEventArgs^>^ value);
    void remove (EventHandler<ManualActionLoadRequestedEventArgs^>^ value);
}

Value

Type: SystemEventHandler ManualActionLoadRequestedEventArgs
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.ManualActionSaveRequested Event

LicensingGuiManualActionSaveRequested Event
Occurs when the user requests to complete a manual request later (in case the application is closed).

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ManualActionSaveRequestedEventArgs> ManualActionSaveRequested
Public Event ManualActionSaveRequested As EventHandler(Of ManualActionSaveRequestedEventArgs)
public:
 event EventHandler<ManualActionSaveRequestedEventArgs^>^ ManualActionSaveRequested {
    void add (EventHandler<ManualActionSaveRequestedEventArgs^>^ value);
    void remove (EventHandler<ManualActionSaveRequestedEventArgs^>^ value);
}

Value

Type: SystemEventHandler ManualActionSaveRequestedEventArgs
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.SplashDoWork Event

LicensingGuiSplashDoWork Event
Occurs when the splash screen is ready to perform some arbitrary work asynchronously.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event EventHandler<EventArgs> SplashDoWork
Public Event SplashDoWork As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ SplashDoWork {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandler EventArgs
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGui.SplashWorkCompleteEvent Event

LicensingGuiSplashWorkCompleteEvent Event
Occurs when the splash screen has completed some arbitrary work asynchronously.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event EventHandler<EventArgs> SplashWorkCompleteEvent
Public Event SplashWorkCompleteEvent As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ SplashWorkCompleteEvent {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandler EventArgs
See Also

Reference

LicensingGui Class
com.softwarekey.Client.Gui Namespace


LicensingGuiDialog Enumeration

LicensingGuiDialog Enumeration
License dialogs which may be displayed through the ShowDialog(LicensingGuiDialog, IWin32Window) method.

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum LicensingGuiDialog
Public Enumeration LicensingGuiDialog
public enum class LicensingGuiDialog
Members
Member name | Value | Description
LicenseManagement | 0 | The license management dialog, which shows the license status and allows the user to perform actions on the license (such as activating, refreshing, and deactivating).
ProxyCredentials | 1 | Dialog for prompting a user for proxy server authentication credentials.
SplashScreen | 2 | Splash screen dialog, which may be used for initialization.
See Also

Reference

com.softwarekey.Client.Gui Namespace


ManualActionLoadRequestedEventArgs Class

ManualActionLoadRequestedEventArgs Class
Contains event arguments for the ManualActionLoadRequested event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
com.softwarekey.Client.GuiManualActionLoadRequestedEventArgs

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ManualActionLoadRequestedEventArgs : EventArgs
Public Class ManualActionLoadRequestedEventArgs
    Inherits EventArgs
public ref class ManualActionLoadRequestedEventArgs : public EventArgs

The ManualActionLoadRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Contents | Gets or sets the contents that have been loaded (from a file or registry key, for example).
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Gui Namespace


ManualActionLoadRequestedEventArgs Properties

ManualActionLoadRequestedEventArgs Properties

The ManualActionLoadRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Contents | Gets or sets the contents that have been loaded (from a file or registry key, for example).
Top
See Also

Reference

ManualActionLoadRequestedEventArgs Class
com.softwarekey.Client.Gui Namespace


ManualActionLoadRequestedEventArgs.Contents Property

ManualActionLoadRequestedEventArgsContents Property
Gets or sets the contents that have been loaded (from a file or registry key, for example).

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Contents { get; set; }
Public Property Contents As String
    Get
    Set
public:
property String^ Contents {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ManualActionLoadRequestedEventArgs Class
com.softwarekey.Client.Gui Namespace


ManualActionLoadRequestedEventArgs Methods

ManualActionLoadRequestedEventArgs Methods

The ManualActionLoadRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ManualActionLoadRequestedEventArgs Class
com.softwarekey.Client.Gui Namespace


ManualActionSaveRequestedEventArgs Class

ManualActionSaveRequestedEventArgs Class
Contains event arguments for the ManualActionSaveRequested event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
com.softwarekey.Client.GuiManualActionSaveRequestedEventArgs

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ManualActionSaveRequestedEventArgs : EventArgs
Public Class ManualActionSaveRequestedEventArgs
    Inherits EventArgs
public ref class ManualActionSaveRequestedEventArgs : public EventArgs

The ManualActionSaveRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Contents | Gets the contents that should be saved (to a file or registry key, for example).
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Gui Namespace


ManualActionSaveRequestedEventArgs Properties

ManualActionSaveRequestedEventArgs Properties

The ManualActionSaveRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Contents | Gets the contents that should be saved (to a file or registry key, for example).
Top
See Also

Reference

ManualActionSaveRequestedEventArgs Class
com.softwarekey.Client.Gui Namespace


ManualActionSaveRequestedEventArgs.Contents Property

ManualActionSaveRequestedEventArgsContents Property
Gets the contents that should be saved (to a file or registry key, for example).

Namespace: com.softwarekey.Client.Gui
Assembly: PLUSManagedGui (in PLUSManagedGui.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Contents { get; }
Public ReadOnly Property Contents As String
    Get
public:
property String^ Contents {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ManualActionSaveRequestedEventArgs Class
com.softwarekey.Client.Gui Namespace


ManualActionSaveRequestedEventArgs Methods

ManualActionSaveRequestedEventArgs Methods

The ManualActionSaveRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ManualActionSaveRequestedEventArgs Class
com.softwarekey.Client.Gui Namespace


com.softwarekey.Client.Licensing Namespace

com.softwarekey.Client.Licensing Namespace
Contains classes and data for licensing.
Classes
 | Class | Description
Public class | BiosUuidIdentifier | SystemIdentifier implementation for a motherboard's BIOS UUID. These identifiers are generated by BiosUuidIdentifierAlgorithm.
Public class | BiosUuidIdentifierAlgorithm | SystemIdentifierAlgorithm implementation for identifying a motherboard's BIOS UUID.
Public class | ComputerNameIdentifier | SystemIdentifier implementation for a computer name. These identifiers are generated by ComputerNameIdentifierAlgorithm.
Public class | ComputerNameIdentifierAlgorithm | SystemIdentifierAlgorithm implementation for identifying a system based on the computer's name.
Public class | CustomSystemIdentifier | Class used when parsing custom SystemIdentifier objects from a license's authorized identifiers.
Public class | DomainNameIdentifier | SystemIdentifier implementation for a user's domain name. These identifiers are generated by DomainNameIdentifierAlgorithm.
Public class | DomainNameIdentifierAlgorithm | SystemIdentifierAlgorithm implementation for identifying a system based on the computer's domain.
Public class | HardDiskVolumeSerialIdentifier | SystemIdentifier implementation for a hard disk volume format serial number. These identifiers are generated by HardDiskVolumeSerialIdentifierAlgorithm.
Public class | HardDiskVolumeSerialIdentifierAlgorithm | SystemIdentifierAlgorithm implementation for identifying hard disk volume format serial numbers on fixed disks.
Public class | License | The base License class, from which all PLUSManaged application license implementations are derived.
Public class | LicenseAlias | Base, abstract class for implementing License File aliases.
Public class | LicenseAliasValidation | Validates the aliases for a WritableLicense.
Public class | LicenseAuthor | Contains data about the SOLO Server Author which issued the license.
Public class | LicenseCustomer | Contains data about the SOLO Server Customer to which the license belongs.
Public class | LicenseDataObject | Abstract class used for implement objects which hold supplemental license data.
Public class | LicenseDistributor | Contains data about the SOLO Server Distributor with which the license is associated.
Public class | LicenseEffectiveDateValidation | Validates a time-limited license to verify it is within the effective date/time period.
Public class | LicenseError | Class used for licensing errors, which may occur in a variety of operations performed by this library.
Public class | LicenseFileSystemAlias | Enables creation and management of License File aliases located in the file-system.
Public class | LicenseIDIdentifier | SystemIdentifier implementation for identifying/authorizing a system based on License ID. This is typically only used for volume licensing, and these identifiers are generated by LicenseIDIdentifierAlgorithm.
Public class | LicenseIDIdentifierAlgorithm | SystemIdentifierAlgorithm implementation for identifying/authorizing a system based on the License ID. This is typically only used for volume licensing.
Public class | LicenseImageAlias | Enables creation and management of License File aliases hidden within an image file.
Public class | LicenseProduct | Contains data about the SOLO Server Product for which the license was issued.
Public class | LicenseProductOption | Contains data about the SOLO Server Product Option for which the license was issued.
Public class | LicenseProductValidation | SystemValidation implementation for validating the Product ID and Product Option ID in the license file.
Public class | LicenseWindowsRegistryAlias | Enables creation and management of License File aliases located in the Windows registry.
Public class | NetworkNameIdentifier | SystemIdentifier implementation for a network path. These identifiers are generated by NetworkNameIdentifierAlgorithm.
Public class | NetworkNameIdentifierAlgorithm | SystemIdentifierAlgorithm implementation for identifying a network path.
Public class | NicIdentifier | SystemIdentifier implementation for a Network Interface Card (NIC). These identifiers are generated by NicIdentifierAlgorithm.
Public class | NicIdentifierAlgorithm | SystemIdentifierAlgorithm implementation for identifying a system based on installed Network Interface Cards (NICs).
Public class | ProcessorIdentifierAlgorithm | SystemIdentifierAlgorithm implementation for identifying a system based on its processor/CPU.
Public class | ProcessorNameIdentifier | SystemIdentifier implementation for a processor's name. These identifiers are generated by ProcessorIdentifierAlgorithm.
Public class | ProcessorVendorIdentifier | SystemIdentifier implementation for a processor's vendor or manufacturer. These identifiers are generated by ProcessorIdentifierAlgorithm.
Public class | ProcessorVersionIdentifier | SystemIdentifier implementation for a processor's version. These identifiers are generated by ProcessorIdentifierAlgorithm.
Public class | RemoteSessionValidation | Attempts to determine whether or not the application is running in a known type of remote session. See the RemoteSessionValidationRemoteSessionTypes enumeration for a list of supported session types.
Public class | ServerHostNameIdentifier | SystemIdentifier implementation for a computer's fully qualified host name. These identifiers are generated by ServerHostNameIdentifierAlgorithm.
Public class | ServerHostNameIdentifierAlgorithm | SystemIdentifierAlgorithm implementation for identifying a system based on the computer's fully qualified host name.
Public class | SystemClockValidation | Validates the system's clock to help ensure it is not being tampered with actively.
Public class | SystemDateTimeValidation | Facilitates validating the date/time of the current system against Internet time servers (via Simple Network Time Protocol, or SNTP).
Public class | SystemIdentifier | Abstract System Identifier class, from which all SystemIdentifiers are implemented
Public class | SystemIdentifierAlgorithm | Abstract class from which all SystemIdentifierAlgorithm implementations are derived.
Public class | SystemIdentifierValidation | Implements basic validation of authorized system identification information against the current system's identification information.
Public class | SystemValidation | Base class from which for all system validations are implemented.
Public class | UserNameIdentifier | SystemIdentifier implementation for a user name. These identifiers are generated by UserNameIdentifierAlgorithm.
Public class | UserNameIdentifierAlgorithm | SystemIdentifierAlgorithm implementation for identifying a username on a system.
Public class | VirtualMachineValidation | Attempts to determine whether or not the application is running in a known virtual machine guest environment. See the VirtualMachineValidationVirtualMachineType enumeration for a list of supported hypervisors.
Public class | WritableLicense | This is the base class from which all license implementations which must allow the application to write to the license file are derived.
Enumerations
 | Enumeration | Description
Public enumeration | HardDiskVolumeSerialFilterType | Enumeration defining the different types of supported filters used when retrieving the HardDiskVolumeSerialIdentifierAlgorithm output from the GetIdentifiers method.
Public enumeration | LicenseAliasLocationType | The type of location in which the alias is to be stored
Public enumeration | LicenseProductOptionProductOptionType | Supported SOLO Server product option types.
Public enumeration | ProcessorIdentifierAlgorithmTypes | Types of identifiers that may be generated using the ProcessorIdentifierAlgorithm.
Public enumeration | RemoteSessionValidationRemoteSessionTypes | Enumeration for types of remote sessions.
Public enumeration | VirtualMachineValidationVirtualMachineType | Virtual Machine Types


BiosUuidIdentifier Class

BiosUuidIdentifier Class
SystemIdentifier implementation for a motherboard's BIOS UUID. These identifiers are generated by BiosUuidIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingBiosUuidIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class BiosUuidIdentifier : SystemIdentifier
Public Class BiosUuidIdentifier
    Inherits SystemIdentifier
public ref class BiosUuidIdentifier : public SystemIdentifier

The BiosUuidIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | BiosUuidIdentifier | Creates a new BiosUuidIdentifier object.
Public method | BiosUuidIdentifier(String) | Creates a new BiosUuidIdentifier object, initialized with the value.
Public method | BiosUuidIdentifier(String, String) | Creates a new BiosUuidIdentifier object, initialized with the name and value
Public method | BiosUuidIdentifier(String, String, String) | Creates a new BiosUuidIdentifier object, initialized with the name, value, and hash
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("BiosUuidIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifier Constructor

BiosUuidIdentifier Constructor
Overload List
 | Name | Description
Public method | BiosUuidIdentifier | Creates a new BiosUuidIdentifier object.
Public method | BiosUuidIdentifier(String) | Creates a new BiosUuidIdentifier object, initialized with the value.
Public method | BiosUuidIdentifier(String, String) | Creates a new BiosUuidIdentifier object, initialized with the name and value
Public method | BiosUuidIdentifier(String, String, String) | Creates a new BiosUuidIdentifier object, initialized with the name, value, and hash
Top
See Also

Reference

BiosUuidIdentifier Class
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifier Constructor

BiosUuidIdentifier Constructor
Creates a new BiosUuidIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public BiosUuidIdentifier()
Public Sub New
public:
BiosUuidIdentifier()
See Also

Reference

BiosUuidIdentifier Class
BiosUuidIdentifier Overload
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifier Constructor (String)

BiosUuidIdentifier Constructor (String)
Creates a new BiosUuidIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public BiosUuidIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
BiosUuidIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The BIOS UUID.
See Also

Reference

BiosUuidIdentifier Class
BiosUuidIdentifier Overload
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifier Constructor (String, String)

BiosUuidIdentifier Constructor (String, String)
Creates a new BiosUuidIdentifier object, initialized with the name and value

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public BiosUuidIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
BiosUuidIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the BiosUuidIdentifier object.
value
Type: SystemString
The BIOS UUID.
See Also

Reference

BiosUuidIdentifier Class
BiosUuidIdentifier Overload
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifier Constructor (String, String, String)

BiosUuidIdentifier Constructor (String, String, String)
Creates a new BiosUuidIdentifier object, initialized with the name, value, and hash

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public BiosUuidIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
BiosUuidIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the BiosUuidIdentifier object.
value
Type: SystemString
The BIOS UUID.
hash
Type: SystemString
Hash of the BIOS UUID.
See Also

Reference

BiosUuidIdentifier Class
BiosUuidIdentifier Overload
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifier Properties

BiosUuidIdentifier Properties

The BiosUuidIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("BiosUuidIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

BiosUuidIdentifier Class
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifier.Type Property

BiosUuidIdentifierType Property
Gets this system identifier's type ("BiosUuidIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

BiosUuidIdentifier Class
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifier Methods

BiosUuidIdentifier Methods

The BiosUuidIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

BiosUuidIdentifier Class
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifier Fields

BiosUuidIdentifier Fields

The BiosUuidIdentifier type exposes the following members.

Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

BiosUuidIdentifier Class
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifierAlgorithm Class

BiosUuidIdentifierAlgorithm Class
SystemIdentifierAlgorithm implementation for identifying a motherboard's BIOS UUID.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingBiosUuidIdentifierAlgorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class BiosUuidIdentifierAlgorithm : SystemIdentifierAlgorithm
Public Class BiosUuidIdentifierAlgorithm
    Inherits SystemIdentifierAlgorithm
public ref class BiosUuidIdentifierAlgorithm : public SystemIdentifierAlgorithm

The BiosUuidIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | BiosUuidIdentifierAlgorithm | Creates a new BiosUuidIdentifierAlgorithm object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of BiosUuidIdentifier objects, which should only ever contain a single entry (or no entries if the BIOS UUID could not be retrieved). (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
Top
Remarks
Caution note Caution

This algorithm is presently only supported on Windows. Any attempt to use it on other platforms will cause a PlatformNotSupportedException to be thrown.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifierAlgorithm Constructor

BiosUuidIdentifierAlgorithm Constructor
Creates a new BiosUuidIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public BiosUuidIdentifierAlgorithm()
Public Sub New
public:
BiosUuidIdentifierAlgorithm()
See Also

Reference

BiosUuidIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifierAlgorithm Methods

BiosUuidIdentifierAlgorithm Methods

The BiosUuidIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of BiosUuidIdentifier objects, which should only ever contain a single entry (or no entries if the BIOS UUID could not be retrieved). (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BiosUuidIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifierAlgorithm.GetIdentifiers Method

BiosUuidIdentifierAlgorithmGetIdentifiers Method
Generates a generic list of BiosUuidIdentifier objects, which should only ever contain a single entry (or no entries if the BIOS UUID could not be retrieved).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override List<SystemIdentifier> GetIdentifiers()
Public Overrides Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() override

Return Value

Type: List SystemIdentifier
Returns a generic list of BiosUuidIdentifier objects, which should only ever contain a single entry (or no entries if the BIOS UUID could not be retrieved).
Remarks

The list contains a single BiosUuidIdentifier object, which contains an identifier based on the motherboard BIOS UUID on the computer running the application.

Caution note Caution

Though it is not generally a frequent occurrence, this value will change when a user changes or replaces his or her motherboard.

See Also

Reference

BiosUuidIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


BiosUuidIdentifierAlgorithm Fields

BiosUuidIdentifierAlgorithm Fields

The BiosUuidIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
Top
See Also

Reference

BiosUuidIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier Class

ComputerNameIdentifier Class
SystemIdentifier implementation for a computer name. These identifiers are generated by ComputerNameIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingComputerNameIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ComputerNameIdentifier : SystemIdentifier
Public Class ComputerNameIdentifier
    Inherits SystemIdentifier
public ref class ComputerNameIdentifier : public SystemIdentifier

The ComputerNameIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | ComputerNameIdentifier | Creates a new ComputerNameIdentifier object.
Public method | ComputerNameIdentifier(String) | Creates a new ComputerNameIdentifier object, initialized with the value.
Public method | ComputerNameIdentifier(String, String) | Creates a new ComputerNameIdentifier object, initialized with the name and value.
Public method | ComputerNameIdentifier(String, String, String) | Creates a new ComputerNameIdentifier object, initialized with the name, value, and hash
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("ComputerNameIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
 | m_computerNameIdentifierId | The static member for tracking default identifiers generated.
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier Constructor

ComputerNameIdentifier Constructor
Overload List
 | Name | Description
Public method | ComputerNameIdentifier | Creates a new ComputerNameIdentifier object.
Public method | ComputerNameIdentifier(String) | Creates a new ComputerNameIdentifier object, initialized with the value.
Public method | ComputerNameIdentifier(String, String) | Creates a new ComputerNameIdentifier object, initialized with the name and value.
Public method | ComputerNameIdentifier(String, String, String) | Creates a new ComputerNameIdentifier object, initialized with the name, value, and hash
Top
See Also

Reference

ComputerNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier Constructor

ComputerNameIdentifier Constructor
Creates a new ComputerNameIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ComputerNameIdentifier()
Public Sub New
public:
ComputerNameIdentifier()
See Also

Reference

ComputerNameIdentifier Class
ComputerNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier Constructor (String)

ComputerNameIdentifier Constructor (String)
Creates a new ComputerNameIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ComputerNameIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
ComputerNameIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The computer's name.
See Also

Reference

ComputerNameIdentifier Class
ComputerNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier Constructor (String, String)

ComputerNameIdentifier Constructor (String, String)
Creates a new ComputerNameIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ComputerNameIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
ComputerNameIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the ComputerNameIdentifier object.
value
Type: SystemString
The computer's name.
See Also

Reference

ComputerNameIdentifier Class
ComputerNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier Constructor (String, String, String)

ComputerNameIdentifier Constructor (String, String, String)
Creates a new ComputerNameIdentifier object, initialized with the name, value, and hash

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ComputerNameIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
ComputerNameIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the ComputerNameIdentifier object.
value
Type: SystemString
The computer's name.
hash
Type: SystemString
Hash of the computer's name.
See Also

Reference

ComputerNameIdentifier Class
ComputerNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier Properties

ComputerNameIdentifier Properties

The ComputerNameIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("ComputerNameIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

ComputerNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier.Type Property

ComputerNameIdentifierType Property
Gets this system identifier's type ("ComputerNameIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

ComputerNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier Methods

ComputerNameIdentifier Methods

The ComputerNameIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

ComputerNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier Fields

ComputerNameIdentifier Fields

The ComputerNameIdentifier type exposes the following members.

Fields
 | Name | Description
 | m_computerNameIdentifierId | The static member for tracking default identifiers generated.
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

ComputerNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifier.m_computerNameIdentifierId Field

ComputerNameIdentifierm_computerNameIdentifierId Field
The static member for tracking default identifiers generated.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected static int m_computerNameIdentifierId
Protected Shared m_computerNameIdentifierId As Integer
protected:
static int m_computerNameIdentifierId

Field Value

Type: Int32
See Also

Reference

ComputerNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifierAlgorithm Class

ComputerNameIdentifierAlgorithm Class
SystemIdentifierAlgorithm implementation for identifying a system based on the computer's name.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingComputerNameIdentifierAlgorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ComputerNameIdentifierAlgorithm : SystemIdentifierAlgorithm
Public Class ComputerNameIdentifierAlgorithm
    Inherits SystemIdentifierAlgorithm
public ref class ComputerNameIdentifierAlgorithm : public SystemIdentifierAlgorithm

The ComputerNameIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | ComputerNameIdentifierAlgorithm | Creates a new ComputerNameIdentifierAlgorithm object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of ComputerNameIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | thisAlgorithmId | The name of this algorithm
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifierAlgorithm Constructor

ComputerNameIdentifierAlgorithm Constructor
Creates a new ComputerNameIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ComputerNameIdentifierAlgorithm()
Public Sub New
public:
ComputerNameIdentifierAlgorithm()
See Also

Reference

ComputerNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifierAlgorithm Methods

ComputerNameIdentifierAlgorithm Methods

The ComputerNameIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of ComputerNameIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ComputerNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifierAlgorithm.GetIdentifiers Method

ComputerNameIdentifierAlgorithmGetIdentifiers Method
Generates a generic list of ComputerNameIdentifier objects.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override List<SystemIdentifier> GetIdentifiers()
Public Overrides Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() override

Return Value

Type: List SystemIdentifier
Returns a generic list of ComputerNameIdentifier objects.
Remarks

The list contains a single ComputerNameIdentifier object, which contains an identifier based on the name of the computer running the application. The computer's name is obtained from the System.Environment.MachineName property.

Caution note Caution

Though it is not generally a frequent occurrence, users with administrative access to computers can change its name, which will change the identifier generated.

See Also

Reference

ComputerNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifierAlgorithm Fields

ComputerNameIdentifierAlgorithm Fields

The ComputerNameIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | thisAlgorithmId | The name of this algorithm
Top
See Also

Reference

ComputerNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ComputerNameIdentifierAlgorithm.thisAlgorithmId Field

ComputerNameIdentifierAlgorithmthisAlgorithmId Field
The name of this algorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected const string thisAlgorithmId = "ComputerName"
Protected Const thisAlgorithmId As String = "ComputerName"
protected:
literal String^ thisAlgorithmId = "ComputerName"

Field Value

Type: String
See Also

Reference

ComputerNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


CustomSystemIdentifier Class

CustomSystemIdentifier Class
Class used when parsing custom SystemIdentifier objects from a license's authorized identifiers.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingCustomSystemIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public sealed class CustomSystemIdentifier : SystemIdentifier
Public NotInheritable Class CustomSystemIdentifier
    Inherits SystemIdentifier
public ref class CustomSystemIdentifier sealed : public SystemIdentifier

The CustomSystemIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | CustomSystemIdentifier | Creates a new CustomSystemIdentifier object.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets the type of CustomSystemIdentifier created. (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


CustomSystemIdentifier Constructor

CustomSystemIdentifier Constructor
Creates a new CustomSystemIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CustomSystemIdentifier(
    string name,
    string value,
    string hash,
    string type
)
Public Sub New (
    name As String,
    value As String,
    hash As String,
    type As String
)
public:
CustomSystemIdentifier(
    String^ name,
    String^ value,
    String^ hash,
    String^ type
)

Parameters

name
Type: SystemString
The name of the CustomSystemIdentifier object.
value
Type: SystemString
The custom identifier data.
hash
Type: SystemString
Hash of the custom identifier data.
type
Type: SystemString
The type of CustomSystemIdentifier created.
See Also

Reference

CustomSystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


CustomSystemIdentifier Properties

CustomSystemIdentifier Properties

The CustomSystemIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets the type of CustomSystemIdentifier created. (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

CustomSystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


CustomSystemIdentifier.Type Property

CustomSystemIdentifierType Property
Gets the type of CustomSystemIdentifier created.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

CustomSystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


CustomSystemIdentifier Methods

CustomSystemIdentifier Methods

The CustomSystemIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

CustomSystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


CustomSystemIdentifier Fields

CustomSystemIdentifier Fields

The CustomSystemIdentifier type exposes the following members.

Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

CustomSystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier Class

DomainNameIdentifier Class
SystemIdentifier implementation for a user's domain name. These identifiers are generated by DomainNameIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingDomainNameIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class DomainNameIdentifier : SystemIdentifier
Public Class DomainNameIdentifier
    Inherits SystemIdentifier
public ref class DomainNameIdentifier : public SystemIdentifier

The DomainNameIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | DomainNameIdentifier | DefaultCreates a new DomainNameIdentifier object.
Public method | DomainNameIdentifier(String) | Creates a new DomainNameIdentifier object, initialized with the value.
Public method | DomainNameIdentifier(String, String) | Creates a new DomainNameIdentifier object, initialized with the name and value.
Public method | DomainNameIdentifier(String, String, String) | Creates a new DomainNameIdentifier object, initialized with the name, value, and hash.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("DomainNameIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
 | m_domainNameIdentifierId | The static member for tracking default identifiers generated
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier Constructor

DomainNameIdentifier Constructor
Overload List
 | Name | Description
Public method | DomainNameIdentifier | DefaultCreates a new DomainNameIdentifier object.
Public method | DomainNameIdentifier(String) | Creates a new DomainNameIdentifier object, initialized with the value.
Public method | DomainNameIdentifier(String, String) | Creates a new DomainNameIdentifier object, initialized with the name and value.
Public method | DomainNameIdentifier(String, String, String) | Creates a new DomainNameIdentifier object, initialized with the name, value, and hash.
Top
See Also

Reference

DomainNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier Constructor

DomainNameIdentifier Constructor
DefaultCreates a new DomainNameIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DomainNameIdentifier()
Public Sub New
public:
DomainNameIdentifier()
See Also

Reference

DomainNameIdentifier Class
DomainNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier Constructor (String)

DomainNameIdentifier Constructor (String)
Creates a new DomainNameIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DomainNameIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
DomainNameIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The user's domain name (or the computer name, if not attached to a domain).
See Also

Reference

DomainNameIdentifier Class
DomainNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier Constructor (String, String)

DomainNameIdentifier Constructor (String, String)
Creates a new DomainNameIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DomainNameIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
DomainNameIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the DomainNameIdentifier object.
value
Type: SystemString
The user's domain name (or the computer name, if not attached to a domain).
See Also

Reference

DomainNameIdentifier Class
DomainNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier Constructor (String, String, String)

DomainNameIdentifier Constructor (String, String, String)
Creates a new DomainNameIdentifier object, initialized with the name, value, and hash.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DomainNameIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
DomainNameIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the DomainNameIdentifier object.
value
Type: SystemString
The user's domain name (or the computer name, if not attached to a domain).
hash
Type: SystemString
Hash of the user's domain name (or the computer name, if not attached to a domain).
See Also

Reference

DomainNameIdentifier Class
DomainNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier Properties

DomainNameIdentifier Properties

The DomainNameIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("DomainNameIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

DomainNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier.Type Property

DomainNameIdentifierType Property
Gets this system identifier's type ("DomainNameIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

DomainNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier Methods

DomainNameIdentifier Methods

The DomainNameIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

DomainNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier Fields

DomainNameIdentifier Fields

The DomainNameIdentifier type exposes the following members.

Fields
 | Name | Description
 | m_domainNameIdentifierId | The static member for tracking default identifiers generated
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

DomainNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifier.m_domainNameIdentifierId Field

DomainNameIdentifierm_domainNameIdentifierId Field
The static member for tracking default identifiers generated

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected static int m_domainNameIdentifierId
Protected Shared m_domainNameIdentifierId As Integer
protected:
static int m_domainNameIdentifierId

Field Value

Type: Int32
See Also

Reference

DomainNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifierAlgorithm Class

DomainNameIdentifierAlgorithm Class
SystemIdentifierAlgorithm implementation for identifying a system based on the computer's domain.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingDomainNameIdentifierAlgorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class DomainNameIdentifierAlgorithm : SystemIdentifierAlgorithm
Public Class DomainNameIdentifierAlgorithm
    Inherits SystemIdentifierAlgorithm
public ref class DomainNameIdentifierAlgorithm : public SystemIdentifierAlgorithm

The DomainNameIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | DomainNameIdentifierAlgorithm | Creates a new DomainNameIdentifierAlgorithm object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of DomainNameIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | thisAlgorithmId | The name of this algorithm
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


DomainNameIdentifierAlgorithm Constructor

DomainNameIdentifierAlgorithm Constructor
Creates a new DomainNameIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DomainNameIdentifierAlgorithm()
Public Sub New
public:
DomainNameIdentifierAlgorithm()
See Also

Reference

DomainNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifierAlgorithm Methods

DomainNameIdentifierAlgorithm Methods

The DomainNameIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of DomainNameIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DomainNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifierAlgorithm.GetIdentifiers Method

DomainNameIdentifierAlgorithmGetIdentifiers Method
Generates a generic list of DomainNameIdentifier objects.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override List<SystemIdentifier> GetIdentifiers()
Public Overrides Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() override

Return Value

Type: List SystemIdentifier
Returns a generic list of DomainNameIdentifier objects.
Remarks

The list contains a single DomainNameIdentifier object, which contains an identifier based on the name of the domain the user running the application is authenticated with.

Caution note Caution

Though it is not generally a frequent occurrence, users with administrative access to computers can change domain associations and user account names, which will change the identifier generated. If the computer is not associated with a domain, then the computer's name is used instead.

See Also

Reference

DomainNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifierAlgorithm Fields

DomainNameIdentifierAlgorithm Fields

The DomainNameIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | thisAlgorithmId | The name of this algorithm
Top
See Also

Reference

DomainNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


DomainNameIdentifierAlgorithm.thisAlgorithmId Field

DomainNameIdentifierAlgorithmthisAlgorithmId Field
The name of this algorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected const string thisAlgorithmId = "DomainName"
Protected Const thisAlgorithmId As String = "DomainName"
protected:
literal String^ thisAlgorithmId = "DomainName"

Field Value

Type: String
See Also

Reference

DomainNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialFilterType Enumeration

HardDiskVolumeSerialFilterType Enumeration
Enumeration defining the different types of supported filters used when retrieving the HardDiskVolumeSerialIdentifierAlgorithm output from the GetIdentifiers method.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum HardDiskVolumeSerialFilterType
Public Enumeration HardDiskVolumeSerialFilterType
public enum class HardDiskVolumeSerialFilterType
Members
Member name | Value | Description
NoFilter | 0 | Omits all filtering and returns identifiers for all drives/mount points. This can include removable storage devices, mapped network drives, etc...
OperatingSystemRootVolume | 1 | Only generates an identifier for the drive or mount point on which the operating system is installed. This is typically the C:\ drive on Microsoft Windows, and is always / (root) for Unix platforms. This is the default filter on Linux and macOS.
StandardFixedOnly | 2 | This filters out drives that report themselves as anything other than fixed. This is the default filter on Microsoft Windows, and is backward compatible versions of PLUSManaged earlier than 1.11.3.0. Since many removable drives report themselves as fixed, you should consider using the WmiFixedVolume or OperatingSystemRootVolume filters on Windows, and you should use the OperatingSystemRootVolume filter on Linux and macOS.
WmiFixedOnly | 3 | If using Windows Management Instrumentation queries (WMI) is an option for you, this provides the most information with the most reliable filtering. Unlike StandardFixedOnly, this is not mislead by USB drives that still report themselves as fixed drives. Any attempt to use this on platforms other than Windows will cause a PlatformNotSupportedException to be thrown.
Remarks
Caution note Caution

When using a filter other than OperatingSystemRootVolume, it is possible for your users to experience noticeably sluggish performance. This is because every filter except OperatingSystemRootVolume must query information on all drives, which can take some time when a system has many drives installed (especially if some or all of these drives power-down to minimize energy consumption).

Caution note Caution

On Microsoft Windows, the StandardFixedOnly is the default filter, and produces behavior which is backward-compatible with versions of PLUSManaged earlier than 1.11.3.0. However, this filter relies strictly on whether the drive reports itself as fixed or not, and many removable drives (particularly internal drives placed in removable/USB enclosures) report themselves as fixed drives. If this is cause for concern or problems, please consider using the OperatingSystemRootVolume on any supported platform, or the WmiFixedOnly filter on Windows.

In Linux and macOS, OperatingSystemRootVolume is the default filter. Our testing has found that many removable drives are reported as fixed in these platforms (even when the same drive shows as removable in Windows). Since this makes the StandardFixedOnly filter rather unreliable in this scenario, we strongly recommend using only the OperatingSystemRootVolume filter in Linux and macOS.

Caution note Caution

The WmiFixedOnly filter is only supported on Windows. Attempting to use it on other platforms cause a PlatformNotSupportedException to be thrown. You can leverage the System.Environment.OSVersion.Platform property to conditionally use this filter and avoid this exception.

Caution note Caution

On macOS, this algorithm is only supported while targeting the 4.0 (v4.0.30319) framework or later, and requires the presence of the MonoMac.dll assembly to function. Any attempt to use it without this assembly present, or while targeting older framework versions, will result in unhandled exceptions being thrown.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier Class

HardDiskVolumeSerialIdentifier Class
SystemIdentifier implementation for a hard disk volume format serial number. These identifiers are generated by HardDiskVolumeSerialIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingHardDiskVolumeSerialIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class HardDiskVolumeSerialIdentifier : SystemIdentifier
Public Class HardDiskVolumeSerialIdentifier
    Inherits SystemIdentifier
public ref class HardDiskVolumeSerialIdentifier : public SystemIdentifier

The HardDiskVolumeSerialIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | HardDiskVolumeSerialIdentifier | Creates a new HardDiskVolumeSerialIdentifier object.
Public method | HardDiskVolumeSerialIdentifier(String) | Creates a new HardDiskVolumeSerialIdentifier object, initialized with the value.
Public method | HardDiskVolumeSerialIdentifier(String, String) | Creates a new HardDiskVolumeSerialIdentifier object, initialized with the name and value
Public method | HardDiskVolumeSerialIdentifier(String, String, String) | Creates a new HardDiskVolumeSerialIdentifier object, initialized with the name, value, and hash
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("HardDiskVolumeSerialIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
 | m_HardDiskVolumeSerialIdentifierId | The static member for tracking default identifiers generated
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier Constructor

HardDiskVolumeSerialIdentifier Constructor
Overload List
 | Name | Description
Public method | HardDiskVolumeSerialIdentifier | Creates a new HardDiskVolumeSerialIdentifier object.
Public method | HardDiskVolumeSerialIdentifier(String) | Creates a new HardDiskVolumeSerialIdentifier object, initialized with the value.
Public method | HardDiskVolumeSerialIdentifier(String, String) | Creates a new HardDiskVolumeSerialIdentifier object, initialized with the name and value
Public method | HardDiskVolumeSerialIdentifier(String, String, String) | Creates a new HardDiskVolumeSerialIdentifier object, initialized with the name, value, and hash
Top
See Also

Reference

HardDiskVolumeSerialIdentifier Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier Constructor

HardDiskVolumeSerialIdentifier Constructor
Creates a new HardDiskVolumeSerialIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public HardDiskVolumeSerialIdentifier()
Public Sub New
public:
HardDiskVolumeSerialIdentifier()
See Also

Reference

HardDiskVolumeSerialIdentifier Class
HardDiskVolumeSerialIdentifier Overload
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier Constructor (String)

HardDiskVolumeSerialIdentifier Constructor (String)
Creates a new HardDiskVolumeSerialIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public HardDiskVolumeSerialIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
HardDiskVolumeSerialIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The hard disk volume format serial.
See Also

Reference

HardDiskVolumeSerialIdentifier Class
HardDiskVolumeSerialIdentifier Overload
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier Constructor (String, String)

HardDiskVolumeSerialIdentifier Constructor (String, String)
Creates a new HardDiskVolumeSerialIdentifier object, initialized with the name and value

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public HardDiskVolumeSerialIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
HardDiskVolumeSerialIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the HardDiskVolumeSerialIdentifier object.
value
Type: SystemString
The hard disk volume format serial.
See Also

Reference

HardDiskVolumeSerialIdentifier Class
HardDiskVolumeSerialIdentifier Overload
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier Constructor (String, String, String)

HardDiskVolumeSerialIdentifier Constructor (String, String, String)
Creates a new HardDiskVolumeSerialIdentifier object, initialized with the name, value, and hash

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public HardDiskVolumeSerialIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
HardDiskVolumeSerialIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the HardDiskVolumeSerialIdentifier object.
value
Type: SystemString
The hard disk volume format serial.
hash
Type: SystemString
Hash of the hard disk volume format serial.
See Also

Reference

HardDiskVolumeSerialIdentifier Class
HardDiskVolumeSerialIdentifier Overload
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier Properties

HardDiskVolumeSerialIdentifier Properties

The HardDiskVolumeSerialIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("HardDiskVolumeSerialIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

HardDiskVolumeSerialIdentifier Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier.Type Property

HardDiskVolumeSerialIdentifierType Property
Gets this system identifier's type ("HardDiskVolumeSerialIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

HardDiskVolumeSerialIdentifier Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier Methods

HardDiskVolumeSerialIdentifier Methods

The HardDiskVolumeSerialIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

HardDiskVolumeSerialIdentifier Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier Fields

HardDiskVolumeSerialIdentifier Fields

The HardDiskVolumeSerialIdentifier type exposes the following members.

Fields
 | Name | Description
 | m_HardDiskVolumeSerialIdentifierId | The static member for tracking default identifiers generated
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

HardDiskVolumeSerialIdentifier Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifier.m_HardDiskVolumeSerialIdentifierId Field

HardDiskVolumeSerialIdentifierm_HardDiskVolumeSerialIdentifierId Field
The static member for tracking default identifiers generated

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected static int m_HardDiskVolumeSerialIdentifierId
Protected Shared m_HardDiskVolumeSerialIdentifierId As Integer
protected:
static int m_HardDiskVolumeSerialIdentifierId

Field Value

Type: Int32
See Also

Reference

HardDiskVolumeSerialIdentifier Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm Class

HardDiskVolumeSerialIdentifierAlgorithm Class
SystemIdentifierAlgorithm implementation for identifying hard disk volume format serial numbers on fixed disks.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingHardDiskVolumeSerialIdentifierAlgorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class HardDiskVolumeSerialIdentifierAlgorithm : SystemIdentifierAlgorithm
Public Class HardDiskVolumeSerialIdentifierAlgorithm
    Inherits SystemIdentifierAlgorithm
public ref class HardDiskVolumeSerialIdentifierAlgorithm : public SystemIdentifierAlgorithm

The HardDiskVolumeSerialIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | HardDiskVolumeSerialIdentifierAlgorithm | Creates a new HardDiskVolumeSerialIdentifierAlgorithm object.
Public method | HardDiskVolumeSerialIdentifierAlgorithm(HardDiskVolumeSerialFilterType) | Creates a new HardDiskVolumeSerialIdentifierAlgorithm object, initialized with a specified HardDiskVolumeSerialFilterType.
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the Filter type used when generating the identifiers in the GetIdentifiers method.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifier | Generates a HardDiskVolumeSerialIdentifier for a specified drive letter.
Public method | GetIdentifiers | Generates a generic list of HardDiskVolumeSerialIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetIdentifiers(String) | Generates a generic list of HardDiskVolumeSerialIdentifier objects. (No additional filtering is applied to specified drives.)
Public method | GetIdentifiers(HardDiskVolumeSerialFilterType) | Generates a generic list of HardDiskVolumeSerialIdentifier objects with the specified filter. This overrides the value in the Filter poperty (but does not change this property's value).
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
Top
Remarks
Caution note Caution

This algorithm is presently only supported on Windows, macOS, and Linux. Any attempt to use it on other platforms will cause a PlatformNotSupportedException to be thrown.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm Constructor

HardDiskVolumeSerialIdentifierAlgorithm Constructor
Overload List
 | Name | Description
Public method | HardDiskVolumeSerialIdentifierAlgorithm | Creates a new HardDiskVolumeSerialIdentifierAlgorithm object.
Public method | HardDiskVolumeSerialIdentifierAlgorithm(HardDiskVolumeSerialFilterType) | Creates a new HardDiskVolumeSerialIdentifierAlgorithm object, initialized with a specified HardDiskVolumeSerialFilterType.
Top
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm Constructor

HardDiskVolumeSerialIdentifierAlgorithm Constructor
Creates a new HardDiskVolumeSerialIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public HardDiskVolumeSerialIdentifierAlgorithm()
Public Sub New
public:
HardDiskVolumeSerialIdentifierAlgorithm()
Exceptions
Exception | Condition
PlatformNotSupportedException |
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
HardDiskVolumeSerialIdentifierAlgorithm Overload
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm Constructor (HardDiskVolumeSerialFilterType)

HardDiskVolumeSerialIdentifierAlgorithm Constructor (HardDiskVolumeSerialFilterType)
Creates a new HardDiskVolumeSerialIdentifierAlgorithm object, initialized with a specified HardDiskVolumeSerialFilterType.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public HardDiskVolumeSerialIdentifierAlgorithm(
    HardDiskVolumeSerialFilterType filter
)
Public Sub New (
    filter As HardDiskVolumeSerialFilterType
)
public:
HardDiskVolumeSerialIdentifierAlgorithm(
    HardDiskVolumeSerialFilterType filter
)

Parameters

filter
Type: com.softwarekey.Client.LicensingHardDiskVolumeSerialFilterType

[Missing <param name="filter"/> documentation for "M:com.softwarekey.Client.Licensing.HardDiskVolumeSerialIdentifierAlgorithm.#ctor(com.softwarekey.Client.Licensing.HardDiskVolumeSerialFilterType)"]

Exceptions
Exception | Condition
PlatformNotSupportedException |
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
HardDiskVolumeSerialIdentifierAlgorithm Overload
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm Properties

HardDiskVolumeSerialIdentifierAlgorithm Properties

The HardDiskVolumeSerialIdentifierAlgorithm type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the Filter type used when generating the identifiers in the GetIdentifiers method.
Top
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm.Filter Property

HardDiskVolumeSerialIdentifierAlgorithmFilter Property
Gets or sets the Filter type used when generating the identifiers in the GetIdentifiers method.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public HardDiskVolumeSerialFilterType Filter { get; set; }
Public Property Filter As HardDiskVolumeSerialFilterType
    Get
    Set
public:
property HardDiskVolumeSerialFilterType Filter {
    HardDiskVolumeSerialFilterType get ();
    void set (HardDiskVolumeSerialFilterType value);
}

Property Value

Type: HardDiskVolumeSerialFilterType
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm Methods

HardDiskVolumeSerialIdentifierAlgorithm Methods

The HardDiskVolumeSerialIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifier | Generates a HardDiskVolumeSerialIdentifier for a specified drive letter.
Public method | GetIdentifiers | Generates a generic list of HardDiskVolumeSerialIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetIdentifiers(String) | Generates a generic list of HardDiskVolumeSerialIdentifier objects. (No additional filtering is applied to specified drives.)
Public method | GetIdentifiers(HardDiskVolumeSerialFilterType) | Generates a generic list of HardDiskVolumeSerialIdentifier objects with the specified filter. This overrides the value in the Filter poperty (but does not change this property's value).
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm.GetIdentifier Method

HardDiskVolumeSerialIdentifierAlgorithmGetIdentifier Method
Generates a HardDiskVolumeSerialIdentifier for a specified drive letter.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemIdentifier GetIdentifier(
    string drive
)
Public Function GetIdentifier (
    drive As String
) As SystemIdentifier
public:
SystemIdentifier^ GetIdentifier(
    String^ drive
)

Parameters

drive
Type: SystemString
The drive letter to for which a HardDiskVolumeSerialIdentifier will be generated.

Return Value

Type: SystemIdentifier
Returns the generated HardDiskVolumeSerialIdentifier object.
Exceptions
Exception | Condition
ArgumentNullException | The specified drive may not be null.
ArgumentException | The first letter of the specified drive is not a letter from 'a' to 'z' (not case sensitive), or the specified drive does not refer to a valid drive.
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm.GetIdentifiers Method

HardDiskVolumeSerialIdentifierAlgorithmGetIdentifiers Method
Overload List
 | Name | Description
Public method | GetIdentifiers | Generates a generic list of HardDiskVolumeSerialIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetIdentifiers(String) | Generates a generic list of HardDiskVolumeSerialIdentifier objects. (No additional filtering is applied to specified drives.)
Public method | GetIdentifiers(HardDiskVolumeSerialFilterType) | Generates a generic list of HardDiskVolumeSerialIdentifier objects with the specified filter. This overrides the value in the Filter poperty (but does not change this property's value).
Top
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm.GetIdentifiers Method

HardDiskVolumeSerialIdentifierAlgorithmGetIdentifiers Method
Generates a generic list of HardDiskVolumeSerialIdentifier objects.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override List<SystemIdentifier> GetIdentifiers()
Public Overrides Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() override

Return Value

Type: List SystemIdentifier
Returns a generic list of HardDiskVolumeSerialIdentifier objects.
Remarks

The list of HardDiskVolumeSerialIdentifier objects contains an identifier for each drive letter not omitted by the Filter property.

Caution note Caution

The volume format serial is generated when a partition is formatted, which means you should be mindful of the following possibilities when considering use of this algorithm:

  • The volume format serial is generated for a given partition. A fixed drive may contain multiple partitions, so this does not directly identify a physical drive. Partitions may be duplicated onto other computers via system imaging tools such as Norton Ghost, which may result in this information staying the same, even on dissimilar hardware.
  • Formatting a drive or partition will result in a new volume format serial being generated.
  • If the software is running in a virtual machine guest environment, it may be possible for that environment to be replicated and run in multiple copies. This would result in this information remaining the same across all copies of a given guest environment. The VirtualMachineValidation class can help detect this kind of environment.
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
GetIdentifiers Overload
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm.GetIdentifiers Method (String[])

HardDiskVolumeSerialIdentifierAlgorithmGetIdentifiers Method (String)
Generates a generic list of HardDiskVolumeSerialIdentifier objects. (No additional filtering is applied to specified drives.)

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<SystemIdentifier> GetIdentifiers(
    string[] drives
)
Public Function GetIdentifiers (
    drives As String()
) As List(Of SystemIdentifier)
public:
List<SystemIdentifier^>^ GetIdentifiers(
    array<String^>^ drives
)

Parameters

drives
Type: SystemString
The array of drives, for each of which a HardDiskVolumeSerialIdentifier will be generated.

Return Value

Type: List SystemIdentifier
Returns a generic list of HardDiskVolumeSerialIdentifier objects.
Remarks

The list of HardDiskVolumeSerialIdentifier objects contains an identifier for each specified drive letter.

Caution note Caution

The volume format serial is generated when a partition is formatted, which means you should be mindful of the following possibilities when considering use of this algorithm:

  • The volume format serial is generated for a given partition. A fixed drive may contain multiple partitions, so this does not directly identify a physical drive. Partitions may be duplicated onto other computers via system imaging tools such as Norton Ghost, which may result in this information staying the same, even on dissimilar hardware.
  • Formatting a drive or partition will result in a new volume format serial being generated.
  • If the software is running in a virtual machine guest environment, it may be possible for that environment to be replicated and run in multiple copies. This would result in this information remaining the same across all copies of a given guest environment. The VirtualMachineValidation class can help detect this kind of environment.
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
GetIdentifiers Overload
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm.GetIdentifiers Method (HardDiskVolumeSerialFilterType)

HardDiskVolumeSerialIdentifierAlgorithmGetIdentifiers Method (HardDiskVolumeSerialFilterType)
Generates a generic list of HardDiskVolumeSerialIdentifier objects with the specified filter. This overrides the value in the Filter poperty (but does not change this property's value).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<SystemIdentifier> GetIdentifiers(
    HardDiskVolumeSerialFilterType filter
)
Public Function GetIdentifiers (
    filter As HardDiskVolumeSerialFilterType
) As List(Of SystemIdentifier)
public:
List<SystemIdentifier^>^ GetIdentifiers(
    HardDiskVolumeSerialFilterType filter
)

Parameters

filter
Type: com.softwarekey.Client.LicensingHardDiskVolumeSerialFilterType
The filter used to omit unwanted identifiers.

Return Value

Type: List SystemIdentifier
Returns a generic list of HardDiskVolumeSerialIdentifier objects.
Remarks

The list of HardDiskVolumeSerialIdentifier objects contains an identifier for each drive letter not omitted by the specified filter. See HardDiskVolumeSerialFilterType for a list of supported filter types, and notes on the behavior for each.

Caution note Caution

The volume format serial is generated when a partition is formatted, which means you should be mindful of the following possibilities when considering use of this algorithm:

  • The volume format serial is generated for a given partition. A fixed drive may contain multiple partitions, so this does not directly identify a physical drive. Partitions may be duplicated onto other computers via system imaging tools such as Norton Ghost, which may result in this information staying the same, even on dissimilar hardware.
  • Formatting a drive or partition will result in a new volume format serial being generated.
  • If the software is running in a virtual machine guest environment, it may be possible for that environment to be replicated and run in multiple copies. This would result in this information remaining the same across all copies of a given guest environment. The VirtualMachineValidation class can help detect this kind of environment.
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
GetIdentifiers Overload
com.softwarekey.Client.Licensing Namespace


HardDiskVolumeSerialIdentifierAlgorithm Fields

HardDiskVolumeSerialIdentifierAlgorithm Fields

The HardDiskVolumeSerialIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
Top
See Also

Reference

HardDiskVolumeSerialIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


License Class

License Class
The base License class, from which all PLUSManaged application license implementations are derived.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicense
com.softwarekey.Client.LicensingWritableLicense

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class License
Public Class License
public ref class License

The License type exposes the following members.

Constructors
 | Name | Description
Public method | License | Creates a new License object with the cryptographic keys already set in an AuthorEncryptionKey object
Top
Properties
 | Name | Description
Public property | ActivationPassword | Gets the activation password, which is usually randomly generated by SOLO Server.
Public property | Author | Gets the Author that issued this License.
Public property | AuthorizedIdentifiers | Gets a generic list of authorized/activated system identifiers.
Public property | CurrentIdentifiers | Gets a generic list of the current system's identifiers.
Public property | CurrentSessionCode | Gets or sets the current session code, which prevents replay attacks in manual request processing.
Public property | Customer | Gets the Customer to which this License was issued.
Public property | Distributor | Gets the Distributor with which this License is associated.
Public property | EffectiveEndDate | Gets the date in which the license expires.
Public property | EffectiveStartDate | Gets the date in which the license becomes effective.
Public property | EncryptionKeyID | Gets or sets the Encryption Key identifier.
Public property | ExternalReference1 | Gets the External Reference 1 value, which is a unique identifier generated by a third-party system or service.
Public property | ExternalReference1Source | Gets the source of the ExternalReference1 value.
Public property | ExternalReference2 | Gets the External Reference 2 value, which is a unique identifier generated by a third-party system or service.
Public property | ExternalReference2Source | Gets the source of the ExternalReference2 value.
Public property | FormatVersion | Gets the format version of the license file.
Public property | InstallationID | Gets the Installation ID which uniquely identifies the activation of the current system
Public property | InstallationName | Gets or sets the name of the installation.
Public property | IsTestLicense | Gets whether or not the license file was generated from a test license. IMPORTANT: Test licenses may eventually be deleted from SOLO Server's database!
Public property | LastError | Gets or sets the last error encountered
Public property | LatestVersion | Gets the latest version of the product available.
Public property | LicenseCounter | Gets the License Counter value.
Public property | LicenseCustomData | Gets the License Custom Data, which contains custom XML or alphanumeric data.
Public property | LicenseeEmail | Gets the licensee's email address.
Public property | LicenseeName | Gets the licensee's name.
Public property | LicenseID | Gets the License ID of the license purchased and activated.
Public property | LicenseUpdate | Gets the License Update data.
Public property | NumberOfMatchingIdentifiers | Gets the the number of authorized system identifiers with matching current system identifiers.
Public property | Product | Gets the Product for which the License was issued.
Public property | ProductOption | Gets the Product Option for which the License was issued.
Public property | ProductVersion | Gets or sets the version of this product.
Public property | QuantityOrdered | Gets the quantity of licenses ordered.
Public property | SerialNumber | Gets the Serial Number value
Public property | SignatureDate | Gets the date in which the license file itself was created and signed.
Public property | ThisProductID | Gets or sets the Product ID (usually generated by SOLO Server) of this product/application.
Public property | TriggerCode | Gets the Trigger Code number issued by SOLO Server.
Public property | TriggerCodeFixedValue | Gets the Trigger Code Fixed Value issued by SOLO Server.
Public property | UserDefinedDate1 | Gets the User Defined Date-Time Field 1 value.
Public property | UserDefinedDate2 | Gets the User Defined Date-Time Field 2 value.
Public property | UserDefinedDate3 | Gets the User Defined Date-Time Field 3 value.
Public property | UserDefinedDate4 | Gets the User Defined Date-Time Field 4 value.
Public property | UserDefinedDate5 | Gets the User Defined Date-Time Field 5 value.
Public property | UserDefinedFloat1 | Gets the User Defined Float Field 1 value.
Public property | UserDefinedFloat2 | Gets the User Defined Float Field 2 value.
Public property | UserDefinedFloat3 | Gets the User Defined Float Field 3 value.
Public property | UserDefinedFloat4 | Gets the User Defined Float Field 4 value.
Public property | UserDefinedFloat5 | Gets the User Defined Float Field 5 value.
Public property | UserDefinedNumber1 | Gets the User Defined Number Field 1 value.
Public property | UserDefinedNumber2 | Gets the User Defined Number Field 2 value.
Public property | UserDefinedNumber3 | Gets the User Defined Number Field 3 value.
Public property | UserDefinedNumber4 | Gets the User Defined Number Field 4 value.
Public property | UserDefinedNumber5 | Gets the User Defined Number Field 5 value.
Public property | UserDefinedString1 | Gets the User Defined String Field 1 value.
Public property | UserDefinedString10 | Gets the User Defined String Field 10 value.
Public property | UserDefinedString2 | Gets the User Defined String Field 2 value.
Public property | UserDefinedString3 | Gets the User Defined String Field 3 value.
Public property | UserDefinedString4 | Gets the User Defined String Field 4 value.
Public property | UserDefinedString5 | Gets the User Defined String Field 5 value.
Public property | UserDefinedString6 | Gets the User Defined String Field 6 value.
Public property | UserDefinedString7 | Gets the User Defined String Field 7 value.
Public property | UserDefinedString8 | Gets the User Defined String Field 8 value.
Public property | UserDefinedString9 | Gets the User Defined String Field 9 value.
Top
Methods
 | Name | Description
Public method | ActivateInstallationLicenseFile(Int32, String, String) | Activates online using a specified License ID, and customer password or activation password
Public method | ActivateInstallationLicenseFile(String, XmlActivationService, String) | Activates online using a specified License ID, customer password or activation password, and endpoint URL
Public method | ActivateInstallationLicenseFile(String, String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL
Public method | ActivateInstallationLicenseFile(Int32, String, XmlActivationService, String) | Activates online using a specified License ID, customer password or activation password, and endpoint URL
Public method | ActivateInstallationLicenseFile(Int32, String, String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL
Public method | ActivateOnline(String, XmlActivationService) | Activates online using the license's current License ID, the specified customer password or activation password, and SoapHttpClientProtocol object
Public method | ActivateOnline(String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL
Public method | ActivateOnline(Int32, String, XmlActivationService) | Activates online using the specified License ID, customer password or activation password, and SoapHttpClientProtocol object.
Public method | ActivateOnline(Int32, String, String) | Activates online using the specified License ID, customer password or activation password, and endpoint URL.
Public method | AddIdentifierAlgorithm | Adds a SystemIdentifierAlgorithm implementation to use for system identification and verification.
Public method | AddTimeServerCheck(String) | Add an SNTP server to the list of servers to check
Public method | AddTimeServerCheck(String, Int32) | Add an SNTP server to the list of servers to check
Public method | AddTimeServerCheck(String, Int32, Int32, Int32) | Add an SNTP server to the list of servers to check
Public method | CheckInstallationStatus | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property.
Public method | CheckInstallationStatus(String) | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint.
Public method | CheckInstallationStatus(XmlActivationService) | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint.
Public method | CheckTimeAgainstServers | Checks the system time against multiple time servers/sntp requests, allowing up to a 5 minute difference.
Public method | CheckTimeAgainstServers(Double) | Checks the system time against multiple time servers/sntp requests
Public method | DeactivateInstallation | Deactivates the license with SOLO Server using the InstallationID property.
Public method | DeactivateInstallation(String) | Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint.
Public method | DeactivateInstallation(XmlActivationService) | Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetActivationInstallationLicenseFileRequest | Builds a manual activation XML request string
Public method | GetActivationRequest | Builds a manual activation XML request string
Public method | GetCheckInstallationStatusRequest | Builds a manual status check XML request string using the current value in the InstallationID property
Public method | GetDeactivateInstallationRequest | Builds a manual status check XML request string using the current value in the InstallationID property
Protected method | GetEncryptionKey | Gets the AuthorEncryptionKey object used for cryptographic routines.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLicenseRefreshRequest | Builds a manual license refresh XML request string using the current value in the InstallationID property
Public method | GetType | (Inherited from Object.)
Public method | InitializeCurrentIdentifiers | Initializes the CurrentIdentifiers property using the algorithms added using the AddIdentifierAlgorithm(SystemIdentifierAlgorithm) method.
Protected method | initializeFromXml | Initializes properties from a plain-text XML license document.
Public method | Load | Loads a License File from a String in memory.
Public method | LoadFile | Loads a License File from the file system and returns true if successful
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessActivateInstallationLicenseFileResponse(String, String) | Processes an activation XML response string
Public method | ProcessActivateInstallationLicenseFileResponse(XmlNode, String) | Processes an activation XML response
Public method | ProcessActivationResponse(String) | Processes an activation XML response string
Public method | ProcessActivationResponse(XmlNode) | Processes an activation XML response.
Public method | ProcessCheckInstallationStatusResponse(String) | Processes a CheckInstallationStatus XML response string
Public method | ProcessCheckInstallationStatusResponse(XmlNode) | Processes a CheckInstallationStatus XML response string
Public method | ProcessDeactivateInstallationResponse(String) | Processes a DeactivateInstallation XML response string
Public method | ProcessDeactivateInstallationResponse(XmlNode) | Processes a DeactivateInstallation XML response string
Public method | ProcessLicenseRefreshResponse(String, String) | Processes an activation XML response string
Public method | ProcessLicenseRefreshResponse(XmlNode, String) | Processes an License Refresh XML response
Public method | RefreshLicense(String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property.
Public method | RefreshLicense(String, String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property.
Public method | RefreshLicense(XmlLicenseFileService, String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property.
Public method | ResetSessionCode | Creates a new session code in the CurrentSessionCode property
Public method | ToString | (Inherited from Object.)
Public method | WriteLicenseFile | Writes a License File to the file system.
Top
Remarks
Note Note

This is the base class from which all PLUSManaged application licensing implementations are derived. Inheriting from this class directly is ideal for using read-only License Files which are signed by SOLO Server. If you wish to use a License File that is writable and does not require SOLO Server, your implementation should inherit from the WritableLicense class instead

See Also

Reference

com.softwarekey.Client.Licensing Namespace
com.softwarekey.Client.LicensingWritableLicense


License Constructor

License Constructor
Creates a new License object with the cryptographic keys already set in an AuthorEncryptionKey object

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public License(
    AuthorEncryptionKey encryptionKey,
    bool useEncryptedFile,
    bool useWebServiceEncryption,
    int productId,
    string productVersion,
    List<SystemIdentifierAlgorithm> identifierAlgorithms
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    useEncryptedFile As Boolean,
    useWebServiceEncryption As Boolean,
    productId As Integer,
    productVersion As String,
    identifierAlgorithms As List(Of SystemIdentifierAlgorithm)
)
public:
License(
    AuthorEncryptionKey^ encryptionKey,
    bool useEncryptedFile,
    bool useWebServiceEncryption,
    int productId,
    String^ productVersion,
    List<SystemIdentifierAlgorithm^>^ identifierAlgorithms
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
useEncryptedFile
Type: SystemBoolean
Whether or not the license file should be encrypted. Encryption is strongly recommended.
useWebServiceEncryption
Type: SystemBoolean
Whether or not web service requests should be encrypted. Encryption is strongly recommended.
productId
Type: SystemInt32
The Product ID (usually defined by SOLO Server) of the protected product/application.
productVersion
Type: SystemString
The current version of the product/application. IOHelper.GetAssemblyFileVersion can be used to retrieve the version number of your assembly.
identifierAlgorithms
Type: System.Collections.GenericList SystemIdentifierAlgorithm
Generic List of SystemIdentifierAlgorithm objects
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License Properties

License Properties

The License type exposes the following members.

Properties
 | Name | Description
Public property | ActivationPassword | Gets the activation password, which is usually randomly generated by SOLO Server.
Public property | Author | Gets the Author that issued this License.
Public property | AuthorizedIdentifiers | Gets a generic list of authorized/activated system identifiers.
Public property | CurrentIdentifiers | Gets a generic list of the current system's identifiers.
Public property | CurrentSessionCode | Gets or sets the current session code, which prevents replay attacks in manual request processing.
Public property | Customer | Gets the Customer to which this License was issued.
Public property | Distributor | Gets the Distributor with which this License is associated.
Public property | EffectiveEndDate | Gets the date in which the license expires.
Public property | EffectiveStartDate | Gets the date in which the license becomes effective.
Public property | EncryptionKeyID | Gets or sets the Encryption Key identifier.
Public property | ExternalReference1 | Gets the External Reference 1 value, which is a unique identifier generated by a third-party system or service.
Public property | ExternalReference1Source | Gets the source of the ExternalReference1 value.
Public property | ExternalReference2 | Gets the External Reference 2 value, which is a unique identifier generated by a third-party system or service.
Public property | ExternalReference2Source | Gets the source of the ExternalReference2 value.
Public property | FormatVersion | Gets the format version of the license file.
Public property | InstallationID | Gets the Installation ID which uniquely identifies the activation of the current system
Public property | InstallationName | Gets or sets the name of the installation.
Public property | IsTestLicense | Gets whether or not the license file was generated from a test license. IMPORTANT: Test licenses may eventually be deleted from SOLO Server's database!
Public property | LastError | Gets or sets the last error encountered
Public property | LatestVersion | Gets the latest version of the product available.
Public property | LicenseCounter | Gets the License Counter value.
Public property | LicenseCustomData | Gets the License Custom Data, which contains custom XML or alphanumeric data.
Public property | LicenseeEmail | Gets the licensee's email address.
Public property | LicenseeName | Gets the licensee's name.
Public property | LicenseID | Gets the License ID of the license purchased and activated.
Public property | LicenseUpdate | Gets the License Update data.
Public property | NumberOfMatchingIdentifiers | Gets the the number of authorized system identifiers with matching current system identifiers.
Public property | Product | Gets the Product for which the License was issued.
Public property | ProductOption | Gets the Product Option for which the License was issued.
Public property | ProductVersion | Gets or sets the version of this product.
Public property | QuantityOrdered | Gets the quantity of licenses ordered.
Public property | SerialNumber | Gets the Serial Number value
Public property | SignatureDate | Gets the date in which the license file itself was created and signed.
Public property | ThisProductID | Gets or sets the Product ID (usually generated by SOLO Server) of this product/application.
Public property | TriggerCode | Gets the Trigger Code number issued by SOLO Server.
Public property | TriggerCodeFixedValue | Gets the Trigger Code Fixed Value issued by SOLO Server.
Public property | UserDefinedDate1 | Gets the User Defined Date-Time Field 1 value.
Public property | UserDefinedDate2 | Gets the User Defined Date-Time Field 2 value.
Public property | UserDefinedDate3 | Gets the User Defined Date-Time Field 3 value.
Public property | UserDefinedDate4 | Gets the User Defined Date-Time Field 4 value.
Public property | UserDefinedDate5 | Gets the User Defined Date-Time Field 5 value.
Public property | UserDefinedFloat1 | Gets the User Defined Float Field 1 value.
Public property | UserDefinedFloat2 | Gets the User Defined Float Field 2 value.
Public property | UserDefinedFloat3 | Gets the User Defined Float Field 3 value.
Public property | UserDefinedFloat4 | Gets the User Defined Float Field 4 value.
Public property | UserDefinedFloat5 | Gets the User Defined Float Field 5 value.
Public property | UserDefinedNumber1 | Gets the User Defined Number Field 1 value.
Public property | UserDefinedNumber2 | Gets the User Defined Number Field 2 value.
Public property | UserDefinedNumber3 | Gets the User Defined Number Field 3 value.
Public property | UserDefinedNumber4 | Gets the User Defined Number Field 4 value.
Public property | UserDefinedNumber5 | Gets the User Defined Number Field 5 value.
Public property | UserDefinedString1 | Gets the User Defined String Field 1 value.
Public property | UserDefinedString10 | Gets the User Defined String Field 10 value.
Public property | UserDefinedString2 | Gets the User Defined String Field 2 value.
Public property | UserDefinedString3 | Gets the User Defined String Field 3 value.
Public property | UserDefinedString4 | Gets the User Defined String Field 4 value.
Public property | UserDefinedString5 | Gets the User Defined String Field 5 value.
Public property | UserDefinedString6 | Gets the User Defined String Field 6 value.
Public property | UserDefinedString7 | Gets the User Defined String Field 7 value.
Public property | UserDefinedString8 | Gets the User Defined String Field 8 value.
Public property | UserDefinedString9 | Gets the User Defined String Field 9 value.
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ActivationPassword Property

LicenseActivationPassword Property
Gets the activation password, which is usually randomly generated by SOLO Server.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string ActivationPassword { get; set; }
Public Overridable Property ActivationPassword As String
    Get
    Set
public:
virtual property String^ ActivationPassword {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.Author Property

LicenseAuthor Property
Gets the Author that issued this License.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual LicenseAuthor Author { get; set; }
Public Overridable Property Author As LicenseAuthor
    Get
    Set
public:
virtual property LicenseAuthor^ Author {
    LicenseAuthor^ get ();
    void set (LicenseAuthor^ value);
}

Property Value

Type: LicenseAuthor
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.AuthorizedIdentifiers Property

LicenseAuthorizedIdentifiers Property
Gets a generic list of authorized/activated system identifiers.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<SystemIdentifier> AuthorizedIdentifiers { get; }
Public ReadOnly Property AuthorizedIdentifiers As List(Of SystemIdentifier)
    Get
public:
property List<SystemIdentifier^>^ AuthorizedIdentifiers {
    List<SystemIdentifier^>^ get ();
}

Property Value

Type: List SystemIdentifier
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.CurrentIdentifiers Property

LicenseCurrentIdentifiers Property
Gets a generic list of the current system's identifiers.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<SystemIdentifier> CurrentIdentifiers { get; }
Public ReadOnly Property CurrentIdentifiers As List(Of SystemIdentifier)
    Get
public:
property List<SystemIdentifier^>^ CurrentIdentifiers {
    List<SystemIdentifier^>^ get ();
}

Property Value

Type: List SystemIdentifier
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.CurrentSessionCode Property

LicenseCurrentSessionCode Property
Gets or sets the current session code, which prevents replay attacks in manual request processing.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CurrentSessionCode { get; set; }
Public Property CurrentSessionCode As String
    Get
    Set
public:
property String^ CurrentSessionCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.Customer Property

LicenseCustomer Property
Gets the Customer to which this License was issued.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual LicenseCustomer Customer { get; set; }
Public Overridable Property Customer As LicenseCustomer
    Get
    Set
public:
virtual property LicenseCustomer^ Customer {
    LicenseCustomer^ get ();
    void set (LicenseCustomer^ value);
}

Property Value

Type: LicenseCustomer
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.Distributor Property

LicenseDistributor Property
Gets the Distributor with which this License is associated.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual LicenseDistributor Distributor { get; set; }
Public Overridable Property Distributor As LicenseDistributor
    Get
    Set
public:
virtual property LicenseDistributor^ Distributor {
    LicenseDistributor^ get ();
    void set (LicenseDistributor^ value);
}

Property Value

Type: LicenseDistributor
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.EffectiveEndDate Property

LicenseEffectiveEndDate Property
Gets the date in which the license expires.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual DateTime EffectiveEndDate { get; set; }
Public Overridable Property EffectiveEndDate As DateTime
    Get
    Set
public:
virtual property DateTime EffectiveEndDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.EffectiveStartDate Property

LicenseEffectiveStartDate Property
Gets the date in which the license becomes effective.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual DateTime EffectiveStartDate { get; set; }
Public Overridable Property EffectiveStartDate As DateTime
    Get
    Set
public:
virtual property DateTime EffectiveStartDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.EncryptionKeyID Property

LicenseEncryptionKeyID Property
Gets or sets the Encryption Key identifier.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string EncryptionKeyID { get; set; }
Public Property EncryptionKeyID As String
    Get
    Set
public:
property String^ EncryptionKeyID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ExternalReference1 Property

LicenseExternalReference1 Property
Gets the External Reference 1 value, which is a unique identifier generated by a third-party system or service.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string ExternalReference1 { get; set; }
Public Overridable Property ExternalReference1 As String
    Get
    Set
public:
virtual property String^ ExternalReference1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ExternalReference1Source Property

LicenseExternalReference1Source Property
Gets the source of the ExternalReference1 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string ExternalReference1Source { get; set; }
Public Overridable Property ExternalReference1Source As String
    Get
    Set
public:
virtual property String^ ExternalReference1Source {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ExternalReference2 Property

LicenseExternalReference2 Property
Gets the External Reference 2 value, which is a unique identifier generated by a third-party system or service.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string ExternalReference2 { get; set; }
Public Overridable Property ExternalReference2 As String
    Get
    Set
public:
virtual property String^ ExternalReference2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ExternalReference2Source Property

LicenseExternalReference2Source Property
Gets the source of the ExternalReference2 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string ExternalReference2Source { get; set; }
Public Overridable Property ExternalReference2Source As String
    Get
    Set
public:
virtual property String^ ExternalReference2Source {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.FormatVersion Property

LicenseFormatVersion Property
Gets the format version of the license file.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string FormatVersion { get; set; }
Public Overridable Property FormatVersion As String
    Get
    Set
public:
virtual property String^ FormatVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.InstallationID Property

LicenseInstallationID Property
Gets the Installation ID which uniquely identifies the activation of the current system

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string InstallationID { get; set; }
Public Overridable Property InstallationID As String
    Get
    Set
public:
virtual property String^ InstallationID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.InstallationName Property

LicenseInstallationName Property
Gets or sets the name of the installation.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InstallationName { get; set; }
Public Property InstallationName As String
    Get
    Set
public:
property String^ InstallationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.IsTestLicense Property

LicenseIsTestLicense Property
Gets whether or not the license file was generated from a test license. IMPORTANT: Test licenses may eventually be deleted from SOLO Server's database!

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool IsTestLicense { get; set; }
Public Overridable Property IsTestLicense As Boolean
    Get
    Set
public:
virtual property bool IsTestLicense {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.LastError Property

LicenseLastError Property
Gets or sets the last error encountered

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual LicenseError LastError { get; set; }
Public Overridable Property LastError As LicenseError
    Get
    Set
public:
virtual property LicenseError^ LastError {
    LicenseError^ get ();
    void set (LicenseError^ value);
}

Property Value

Type: LicenseError
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.LatestVersion Property

LicenseLatestVersion Property
Gets the latest version of the product available.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string LatestVersion { get; set; }
Public Overridable Property LatestVersion As String
    Get
    Set
public:
virtual property String^ LatestVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.LicenseCounter Property

LicenseLicenseCounter Property
Gets the License Counter value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int LicenseCounter { get; set; }
Public Overridable Property LicenseCounter As Integer
    Get
    Set
public:
virtual property int LicenseCounter {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.LicenseCustomData Property

LicenseLicenseCustomData Property
Gets the License Custom Data, which contains custom XML or alphanumeric data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string LicenseCustomData { get; set; }
Public Overridable Property LicenseCustomData As String
    Get
    Set
public:
virtual property String^ LicenseCustomData {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.LicenseeEmail Property

LicenseLicenseeEmail Property
Gets the licensee's email address.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string LicenseeEmail { get; set; }
Public Overridable Property LicenseeEmail As String
    Get
    Set
public:
virtual property String^ LicenseeEmail {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.LicenseeName Property

LicenseLicenseeName Property
Gets the licensee's name.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string LicenseeName { get; set; }
Public Overridable Property LicenseeName As String
    Get
    Set
public:
virtual property String^ LicenseeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.LicenseID Property

LicenseLicenseID Property
Gets the License ID of the license purchased and activated.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int LicenseID { get; set; }
Public Overridable Property LicenseID As Integer
    Get
    Set
public:
virtual property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.LicenseUpdate Property

LicenseLicenseUpdate Property
Gets the License Update data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string LicenseUpdate { get; set; }
Public Overridable Property LicenseUpdate As String
    Get
    Set
public:
virtual property String^ LicenseUpdate {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.NumberOfMatchingIdentifiers Property

LicenseNumberOfMatchingIdentifiers Property
Gets the the number of authorized system identifiers with matching current system identifiers.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int NumberOfMatchingIdentifiers { get; }
Public ReadOnly Property NumberOfMatchingIdentifiers As Integer
    Get
public:
property int NumberOfMatchingIdentifiers {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.Product Property

LicenseProduct Property
Gets the Product for which the License was issued.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual LicenseProduct Product { get; set; }
Public Overridable Property Product As LicenseProduct
    Get
    Set
public:
virtual property LicenseProduct^ Product {
    LicenseProduct^ get ();
    void set (LicenseProduct^ value);
}

Property Value

Type: LicenseProduct
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ProductOption Property

LicenseProductOption Property
Gets the Product Option for which the License was issued.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual LicenseProductOption ProductOption { get; set; }
Public Overridable Property ProductOption As LicenseProductOption
    Get
    Set
public:
virtual property LicenseProductOption^ ProductOption {
    LicenseProductOption^ get ();
    void set (LicenseProductOption^ value);
}

Property Value

Type: LicenseProductOption
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ProductVersion Property

LicenseProductVersion Property
Gets or sets the version of this product.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProductVersion { get; set; }
Public Property ProductVersion As String
    Get
    Set
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.QuantityOrdered Property

LicenseQuantityOrdered Property
Gets the quantity of licenses ordered.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int QuantityOrdered { get; set; }
Public Overridable Property QuantityOrdered As Integer
    Get
    Set
public:
virtual property int QuantityOrdered {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.SerialNumber Property

LicenseSerialNumber Property
Gets the Serial Number value

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string SerialNumber { get; set; }
Public Overridable Property SerialNumber As String
    Get
    Set
public:
virtual property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.SignatureDate Property

LicenseSignatureDate Property
Gets the date in which the license file itself was created and signed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual DateTime SignatureDate { get; set; }
Public Overridable Property SignatureDate As DateTime
    Get
    Set
public:
virtual property DateTime SignatureDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ThisProductID Property

LicenseThisProductID Property
Gets or sets the Product ID (usually generated by SOLO Server) of this product/application.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ThisProductID { get; set; }
Public Property ThisProductID As Integer
    Get
    Set
public:
property int ThisProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.TriggerCode Property

LicenseTriggerCode Property
Gets the Trigger Code number issued by SOLO Server.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int TriggerCode { get; set; }
Public Overridable Property TriggerCode As Integer
    Get
    Set
public:
virtual property int TriggerCode {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.TriggerCodeFixedValue Property

LicenseTriggerCodeFixedValue Property
Gets the Trigger Code Fixed Value issued by SOLO Server.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int TriggerCodeFixedValue { get; set; }
Public Overridable Property TriggerCodeFixedValue As Integer
    Get
    Set
public:
virtual property int TriggerCodeFixedValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedDate1 Property

LicenseUserDefinedDate1 Property
Gets the User Defined Date-Time Field 1 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual DateTime UserDefinedDate1 { get; set; }
Public Overridable Property UserDefinedDate1 As DateTime
    Get
    Set
public:
virtual property DateTime UserDefinedDate1 {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedDate2 Property

LicenseUserDefinedDate2 Property
Gets the User Defined Date-Time Field 2 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual DateTime UserDefinedDate2 { get; set; }
Public Overridable Property UserDefinedDate2 As DateTime
    Get
    Set
public:
virtual property DateTime UserDefinedDate2 {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedDate3 Property

LicenseUserDefinedDate3 Property
Gets the User Defined Date-Time Field 3 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual DateTime UserDefinedDate3 { get; set; }
Public Overridable Property UserDefinedDate3 As DateTime
    Get
    Set
public:
virtual property DateTime UserDefinedDate3 {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedDate4 Property

LicenseUserDefinedDate4 Property
Gets the User Defined Date-Time Field 4 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual DateTime UserDefinedDate4 { get; set; }
Public Overridable Property UserDefinedDate4 As DateTime
    Get
    Set
public:
virtual property DateTime UserDefinedDate4 {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedDate5 Property

LicenseUserDefinedDate5 Property
Gets the User Defined Date-Time Field 5 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual DateTime UserDefinedDate5 { get; set; }
Public Overridable Property UserDefinedDate5 As DateTime
    Get
    Set
public:
virtual property DateTime UserDefinedDate5 {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedFloat1 Property

LicenseUserDefinedFloat1 Property
Gets the User Defined Float Field 1 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual decimal UserDefinedFloat1 { get; set; }
Public Overridable Property UserDefinedFloat1 As Decimal
    Get
    Set
public:
virtual property Decimal UserDefinedFloat1 {
    Decimal get ();
    void set (Decimal value);
}

Property Value

Type: Decimal
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedFloat2 Property

LicenseUserDefinedFloat2 Property
Gets the User Defined Float Field 2 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual decimal UserDefinedFloat2 { get; set; }
Public Overridable Property UserDefinedFloat2 As Decimal
    Get
    Set
public:
virtual property Decimal UserDefinedFloat2 {
    Decimal get ();
    void set (Decimal value);
}

Property Value

Type: Decimal
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedFloat3 Property

LicenseUserDefinedFloat3 Property
Gets the User Defined Float Field 3 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual decimal UserDefinedFloat3 { get; set; }
Public Overridable Property UserDefinedFloat3 As Decimal
    Get
    Set
public:
virtual property Decimal UserDefinedFloat3 {
    Decimal get ();
    void set (Decimal value);
}

Property Value

Type: Decimal
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedFloat4 Property

LicenseUserDefinedFloat4 Property
Gets the User Defined Float Field 4 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual decimal UserDefinedFloat4 { get; set; }
Public Overridable Property UserDefinedFloat4 As Decimal
    Get
    Set
public:
virtual property Decimal UserDefinedFloat4 {
    Decimal get ();
    void set (Decimal value);
}

Property Value

Type: Decimal
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedFloat5 Property

LicenseUserDefinedFloat5 Property
Gets the User Defined Float Field 5 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual decimal UserDefinedFloat5 { get; set; }
Public Overridable Property UserDefinedFloat5 As Decimal
    Get
    Set
public:
virtual property Decimal UserDefinedFloat5 {
    Decimal get ();
    void set (Decimal value);
}

Property Value

Type: Decimal
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedNumber1 Property

LicenseUserDefinedNumber1 Property
Gets the User Defined Number Field 1 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int UserDefinedNumber1 { get; set; }
Public Overridable Property UserDefinedNumber1 As Integer
    Get
    Set
public:
virtual property int UserDefinedNumber1 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedNumber2 Property

LicenseUserDefinedNumber2 Property
Gets the User Defined Number Field 2 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int UserDefinedNumber2 { get; set; }
Public Overridable Property UserDefinedNumber2 As Integer
    Get
    Set
public:
virtual property int UserDefinedNumber2 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedNumber3 Property

LicenseUserDefinedNumber3 Property
Gets the User Defined Number Field 3 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int UserDefinedNumber3 { get; set; }
Public Overridable Property UserDefinedNumber3 As Integer
    Get
    Set
public:
virtual property int UserDefinedNumber3 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedNumber4 Property

LicenseUserDefinedNumber4 Property
Gets the User Defined Number Field 4 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int UserDefinedNumber4 { get; set; }
Public Overridable Property UserDefinedNumber4 As Integer
    Get
    Set
public:
virtual property int UserDefinedNumber4 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedNumber5 Property

LicenseUserDefinedNumber5 Property
Gets the User Defined Number Field 5 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int UserDefinedNumber5 { get; set; }
Public Overridable Property UserDefinedNumber5 As Integer
    Get
    Set
public:
virtual property int UserDefinedNumber5 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedString1 Property

LicenseUserDefinedString1 Property
Gets the User Defined String Field 1 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string UserDefinedString1 { get; set; }
Public Overridable Property UserDefinedString1 As String
    Get
    Set
public:
virtual property String^ UserDefinedString1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedString10 Property

LicenseUserDefinedString10 Property
Gets the User Defined String Field 10 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string UserDefinedString10 { get; set; }
Public Overridable Property UserDefinedString10 As String
    Get
    Set
public:
virtual property String^ UserDefinedString10 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedString2 Property

LicenseUserDefinedString2 Property
Gets the User Defined String Field 2 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string UserDefinedString2 { get; set; }
Public Overridable Property UserDefinedString2 As String
    Get
    Set
public:
virtual property String^ UserDefinedString2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedString3 Property

LicenseUserDefinedString3 Property
Gets the User Defined String Field 3 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string UserDefinedString3 { get; set; }
Public Overridable Property UserDefinedString3 As String
    Get
    Set
public:
virtual property String^ UserDefinedString3 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedString4 Property

LicenseUserDefinedString4 Property
Gets the User Defined String Field 4 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string UserDefinedString4 { get; set; }
Public Overridable Property UserDefinedString4 As String
    Get
    Set
public:
virtual property String^ UserDefinedString4 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedString5 Property

LicenseUserDefinedString5 Property
Gets the User Defined String Field 5 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string UserDefinedString5 { get; set; }
Public Overridable Property UserDefinedString5 As String
    Get
    Set
public:
virtual property String^ UserDefinedString5 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedString6 Property

LicenseUserDefinedString6 Property
Gets the User Defined String Field 6 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string UserDefinedString6 { get; set; }
Public Overridable Property UserDefinedString6 As String
    Get
    Set
public:
virtual property String^ UserDefinedString6 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedString7 Property

LicenseUserDefinedString7 Property
Gets the User Defined String Field 7 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string UserDefinedString7 { get; set; }
Public Overridable Property UserDefinedString7 As String
    Get
    Set
public:
virtual property String^ UserDefinedString7 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedString8 Property

LicenseUserDefinedString8 Property
Gets the User Defined String Field 8 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string UserDefinedString8 { get; set; }
Public Overridable Property UserDefinedString8 As String
    Get
    Set
public:
virtual property String^ UserDefinedString8 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.UserDefinedString9 Property

LicenseUserDefinedString9 Property
Gets the User Defined String Field 9 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string UserDefinedString9 { get; set; }
Public Overridable Property UserDefinedString9 As String
    Get
    Set
public:
virtual property String^ UserDefinedString9 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License Methods

License Methods

The License type exposes the following members.

Methods
 | Name | Description
Public method | ActivateInstallationLicenseFile(Int32, String, String) | Activates online using a specified License ID, and customer password or activation password
Public method | ActivateInstallationLicenseFile(String, XmlActivationService, String) | Activates online using a specified License ID, customer password or activation password, and endpoint URL
Public method | ActivateInstallationLicenseFile(String, String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL
Public method | ActivateInstallationLicenseFile(Int32, String, XmlActivationService, String) | Activates online using a specified License ID, customer password or activation password, and endpoint URL
Public method | ActivateInstallationLicenseFile(Int32, String, String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL
Public method | ActivateOnline(String, XmlActivationService) | Activates online using the license's current License ID, the specified customer password or activation password, and SoapHttpClientProtocol object
Public method | ActivateOnline(String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL
Public method | ActivateOnline(Int32, String, XmlActivationService) | Activates online using the specified License ID, customer password or activation password, and SoapHttpClientProtocol object.
Public method | ActivateOnline(Int32, String, String) | Activates online using the specified License ID, customer password or activation password, and endpoint URL.
Public method | AddIdentifierAlgorithm | Adds a SystemIdentifierAlgorithm implementation to use for system identification and verification.
Public method | AddTimeServerCheck(String) | Add an SNTP server to the list of servers to check
Public method | AddTimeServerCheck(String, Int32) | Add an SNTP server to the list of servers to check
Public method | AddTimeServerCheck(String, Int32, Int32, Int32) | Add an SNTP server to the list of servers to check
Public method | CheckInstallationStatus | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property.
Public method | CheckInstallationStatus(String) | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint.
Public method | CheckInstallationStatus(XmlActivationService) | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint.
Public method | CheckTimeAgainstServers | Checks the system time against multiple time servers/sntp requests, allowing up to a 5 minute difference.
Public method | CheckTimeAgainstServers(Double) | Checks the system time against multiple time servers/sntp requests
Public method | DeactivateInstallation | Deactivates the license with SOLO Server using the InstallationID property.
Public method | DeactivateInstallation(String) | Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint.
Public method | DeactivateInstallation(XmlActivationService) | Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetActivationInstallationLicenseFileRequest | Builds a manual activation XML request string
Public method | GetActivationRequest | Builds a manual activation XML request string
Public method | GetCheckInstallationStatusRequest | Builds a manual status check XML request string using the current value in the InstallationID property
Public method | GetDeactivateInstallationRequest | Builds a manual status check XML request string using the current value in the InstallationID property
Protected method | GetEncryptionKey | Gets the AuthorEncryptionKey object used for cryptographic routines.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLicenseRefreshRequest | Builds a manual license refresh XML request string using the current value in the InstallationID property
Public method | GetType | (Inherited from Object.)
Public method | InitializeCurrentIdentifiers | Initializes the CurrentIdentifiers property using the algorithms added using the AddIdentifierAlgorithm(SystemIdentifierAlgorithm) method.
Protected method | initializeFromXml | Initializes properties from a plain-text XML license document.
Public method | Load | Loads a License File from a String in memory.
Public method | LoadFile | Loads a License File from the file system and returns true if successful
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessActivateInstallationLicenseFileResponse(String, String) | Processes an activation XML response string
Public method | ProcessActivateInstallationLicenseFileResponse(XmlNode, String) | Processes an activation XML response
Public method | ProcessActivationResponse(String) | Processes an activation XML response string
Public method | ProcessActivationResponse(XmlNode) | Processes an activation XML response.
Public method | ProcessCheckInstallationStatusResponse(String) | Processes a CheckInstallationStatus XML response string
Public method | ProcessCheckInstallationStatusResponse(XmlNode) | Processes a CheckInstallationStatus XML response string
Public method | ProcessDeactivateInstallationResponse(String) | Processes a DeactivateInstallation XML response string
Public method | ProcessDeactivateInstallationResponse(XmlNode) | Processes a DeactivateInstallation XML response string
Public method | ProcessLicenseRefreshResponse(String, String) | Processes an activation XML response string
Public method | ProcessLicenseRefreshResponse(XmlNode, String) | Processes an License Refresh XML response
Public method | RefreshLicense(String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property.
Public method | RefreshLicense(String, String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property.
Public method | RefreshLicense(XmlLicenseFileService, String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property.
Public method | ResetSessionCode | Creates a new session code in the CurrentSessionCode property
Public method | ToString | (Inherited from Object.)
Public method | WriteLicenseFile | Writes a License File to the file system.
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ActivateInstallationLicenseFile Method

LicenseActivateInstallationLicenseFile Method
Overload List
 | Name | Description
Public method | ActivateInstallationLicenseFile(Int32, String, String) | Activates online using a specified License ID, and customer password or activation password
Public method | ActivateInstallationLicenseFile(String, XmlActivationService, String) | Activates online using a specified License ID, customer password or activation password, and endpoint URL
Public method | ActivateInstallationLicenseFile(String, String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL
Public method | ActivateInstallationLicenseFile(Int32, String, XmlActivationService, String) | Activates online using a specified License ID, customer password or activation password, and endpoint URL
Public method | ActivateInstallationLicenseFile(Int32, String, String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ActivateInstallationLicenseFile Method (Int32, String, String)

LicenseActivateInstallationLicenseFile Method (Int32, String, String)
Activates online using a specified License ID, and customer password or activation password

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ActivateInstallationLicenseFile(
    int licenseId,
    string password,
    ref string licenseContent
)
Public Overridable Function ActivateInstallationLicenseFile (
    licenseId As Integer,
    password As String,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ActivateInstallationLicenseFile(
    int licenseId,
    String^ password,
    String^% licenseContent
)

Parameters

licenseId
Type: SystemInt32
The License ID (from SOLO Server) to activate.
password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.
licenseContent
Type: SystemString
The License File content returned by SOLO Server

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This processes an online activation using SOLO Server's XmlActivationService web service's ActivateInstallationLicenseFile method, which processes the activation and retrieves the License File from SOLO Server at the same time.

See Also

Reference

License Class
ActivateInstallationLicenseFile Overload
com.softwarekey.Client.Licensing Namespace


License.ActivateInstallationLicenseFile Method (String, XmlActivationService, String)

LicenseActivateInstallationLicenseFile Method (String, XmlActivationService, String)
Activates online using a specified License ID, customer password or activation password, and endpoint URL

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ActivateInstallationLicenseFile(
    string password,
    XmlActivationService client,
    ref string licenseContent
)
Public Overridable Function ActivateInstallationLicenseFile (
    password As String,
    client As XmlActivationService,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ActivateInstallationLicenseFile(
    String^ password,
    XmlActivationService^ client,
    String^% licenseContent
)

Parameters

password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.
client
Type: com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService
The SoapHttpClientProtocol derived object used to perform the web service call
licenseContent
Type: SystemString
The License File content returned by SOLO Server

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This processes an online activation using SOLO Server's XmlActivationService web service's ActivateInstallationLicenseFile method, which processes the activation and retrieves the License File from SOLO Server at the same time.

See Also

Reference

License Class
ActivateInstallationLicenseFile Overload
com.softwarekey.Client.Licensing Namespace


License.ActivateInstallationLicenseFile Method (String, String, String)

LicenseActivateInstallationLicenseFile Method (String, String, String)
Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ActivateInstallationLicenseFile(
    string password,
    string endpoint,
    ref string licenseContent
)
Public Overridable Function ActivateInstallationLicenseFile (
    password As String,
    endpoint As String,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ActivateInstallationLicenseFile(
    String^ password,
    String^ endpoint,
    String^% licenseContent
)

Parameters

password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.
endpoint
Type: SystemString
The full URL to the web service (XmlActivationService) endpoint
licenseContent
Type: SystemString
The License File content returned by SOLO Server

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This processes an online activation using SOLO Server's XmlActivationService web service's ActivateInstallationLicenseFile method, which processes the activation and retrieves the License File from SOLO Server at the same time.

See Also

Reference

License Class
ActivateInstallationLicenseFile Overload
com.softwarekey.Client.Licensing Namespace


License.ActivateInstallationLicenseFile Method (Int32, String, XmlActivationService, String)

LicenseActivateInstallationLicenseFile Method (Int32, String, XmlActivationService, String)
Activates online using a specified License ID, customer password or activation password, and endpoint URL

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ActivateInstallationLicenseFile(
    int licenseId,
    string password,
    XmlActivationService client,
    ref string licenseContent
)
Public Overridable Function ActivateInstallationLicenseFile (
    licenseId As Integer,
    password As String,
    client As XmlActivationService,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ActivateInstallationLicenseFile(
    int licenseId,
    String^ password,
    XmlActivationService^ client,
    String^% licenseContent
)

Parameters

licenseId
Type: SystemInt32
The License ID (from SOLO Server) to activate.
password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.
client
Type: com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService
The SoapHttpClientProtocol derived object used to perform the web service call
licenseContent
Type: SystemString
The License File content returned by SOLO Server

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This processes an online activation using SOLO Server's XmlActivationService web service's ActivateInstallationLicenseFile method, which processes the activation and retrieves the License File from SOLO Server at the same time.

See Also

Reference

License Class
ActivateInstallationLicenseFile Overload
com.softwarekey.Client.Licensing Namespace


License.ActivateInstallationLicenseFile Method (Int32, String, String, String)

LicenseActivateInstallationLicenseFile Method (Int32, String, String, String)
Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ActivateInstallationLicenseFile(
    int licenseId,
    string password,
    string endpoint,
    ref string licenseContent
)
Public Overridable Function ActivateInstallationLicenseFile (
    licenseId As Integer,
    password As String,
    endpoint As String,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ActivateInstallationLicenseFile(
    int licenseId,
    String^ password,
    String^ endpoint,
    String^% licenseContent
)

Parameters

licenseId
Type: SystemInt32
The License ID (from SOLO Server) to activate.
password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.
endpoint
Type: SystemString
The full URL to the web service (XmlActivationService) endpoint
licenseContent
Type: SystemString
The License File content returned by SOLO Server

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This processes an online activation using SOLO Server's XmlActivationService web service's ActivateInstallationLicenseFile method, which processes the activation and retrieves the License File from SOLO Server at the same time.

See Also

Reference

License Class
ActivateInstallationLicenseFile Overload
com.softwarekey.Client.Licensing Namespace


License.ActivateOnline Method

LicenseActivateOnline Method
Overload List
 | Name | Description
Public method | ActivateOnline(String, XmlActivationService) | Activates online using the license's current License ID, the specified customer password or activation password, and SoapHttpClientProtocol object
Public method | ActivateOnline(String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL
Public method | ActivateOnline(Int32, String, XmlActivationService) | Activates online using the specified License ID, customer password or activation password, and SoapHttpClientProtocol object.
Public method | ActivateOnline(Int32, String, String) | Activates online using the specified License ID, customer password or activation password, and endpoint URL.
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ActivateOnline Method (String, XmlActivationService)

LicenseActivateOnline Method (String, XmlActivationService)
Activates online using the license's current License ID, the specified customer password or activation password, and SoapHttpClientProtocol object

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ActivateOnline(
    string password,
    XmlActivationService client
)
Public Overridable Function ActivateOnline (
    password As String,
    client As XmlActivationService
) As Boolean
public:
virtual bool ActivateOnline(
    String^ password,
    XmlActivationService^ client
)

Parameters

password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.
client
Type: com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService
The SoapHttpClientProtocol derived object used to perform the web service call

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes an online activation using SOLO Server's XmlActivationService web service's ActivateInstallation method. This method will only process activation codes and set the InstallationID property. To get the License File contents from SOLO Server after calling this method, you would need to call the RefreshLicense method. A more efficient alternative is to call the ActivateInstallationLicenseFile method instead, which processes the activation and retrieves the License File from SOLO Server at the same time.

See Also

Reference

License Class
ActivateOnline Overload
com.softwarekey.Client.Licensing Namespace


License.ActivateOnline Method (String, String)

LicenseActivateOnline Method (String, String)
Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ActivateOnline(
    string password,
    string endpoint
)
Public Overridable Function ActivateOnline (
    password As String,
    endpoint As String
) As Boolean
public:
virtual bool ActivateOnline(
    String^ password,
    String^ endpoint
)

Parameters

password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.
endpoint
Type: SystemString
The full URL to the web service (XmlActivationService) endpoint

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This processes an online activation using SOLO Server's XmlActivationService web service's ActivateInstallation method. This method will only process activation codes and set the InstallationID property. To get the License File contents from SOLO Server after calling this method, you would need to call the RefreshLicense method. A more efficient alternative is to call the ActivateInstallationLicenseFile method instead, which processes the activation and retrieves the License File from SOLO Server at the same time.

See Also

Reference

License Class
ActivateOnline Overload
com.softwarekey.Client.Licensing Namespace


License.ActivateOnline Method (Int32, String, XmlActivationService)

LicenseActivateOnline Method (Int32, String, XmlActivationService)
Activates online using the specified License ID, customer password or activation password, and SoapHttpClientProtocol object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ActivateOnline(
    int licenseId,
    string password,
    XmlActivationService client
)
Public Overridable Function ActivateOnline (
    licenseId As Integer,
    password As String,
    client As XmlActivationService
) As Boolean
public:
virtual bool ActivateOnline(
    int licenseId,
    String^ password,
    XmlActivationService^ client
)

Parameters

licenseId
Type: SystemInt32
The License ID (from SOLO Server) to activate.
password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.
client
Type: com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService
The SoapHttpClientProtocol derived object used to perform the web service call

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes an online activation using SOLO Server's XmlActivationService web service's ActivateInstallation method. This method will only process activation codes and set the InstallationID property. To get the License File contents from SOLO Server after calling this method, you would need to call the RefreshLicense method. A more efficient alternative is to call the ActivateInstallationLicenseFile method instead, which processes the activation and retrieves the License File from SOLO Server at the same time.

See Also

Reference

License Class
ActivateOnline Overload
com.softwarekey.Client.Licensing Namespace


License.ActivateOnline Method (Int32, String, String)

LicenseActivateOnline Method (Int32, String, String)
Activates online using the specified License ID, customer password or activation password, and endpoint URL.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ActivateOnline(
    int licenseId,
    string password,
    string endpoint
)
Public Overridable Function ActivateOnline (
    licenseId As Integer,
    password As String,
    endpoint As String
) As Boolean
public:
virtual bool ActivateOnline(
    int licenseId,
    String^ password,
    String^ endpoint
)

Parameters

licenseId
Type: SystemInt32
The License ID (from SOLO Server) to activate.
password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.
endpoint
Type: SystemString
The full URL to the web service (XmlActivationService) endpoint

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes an online activation using SOLO Server's XmlActivationService web service's ActivateInstallation method. This method will only process activation codes and set the InstallationID property. To get the License File contents from SOLO Server after calling this method, you would need to call the RefreshLicense method. A more efficient alternative is to call the ActivateInstallationLicenseFile method instead, which processes the activation and retrieves the License File from SOLO Server at the same time.

See Also

Reference

License Class
ActivateOnline Overload
com.softwarekey.Client.Licensing Namespace


License.AddIdentifierAlgorithm Method

LicenseAddIdentifierAlgorithm Method
Adds a SystemIdentifierAlgorithm implementation to use for system identification and verification.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddIdentifierAlgorithm(
    SystemIdentifierAlgorithm algorithm
)
Public Sub AddIdentifierAlgorithm (
    algorithm As SystemIdentifierAlgorithm
)
public:
void AddIdentifierAlgorithm(
    SystemIdentifierAlgorithm^ algorithm
)

Parameters

algorithm
Type: com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
The SystemIdentifierAlgorithm to use when initializing the CurrentIdentifiers property (initialized by the InitializeCurrentIdentifiers method).
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.AddTimeServerCheck Method

LicenseAddTimeServerCheck Method
Overload List
 | Name | Description
Public method | AddTimeServerCheck(String) | Add an SNTP server to the list of servers to check
Public method | AddTimeServerCheck(String, Int32) | Add an SNTP server to the list of servers to check
Public method | AddTimeServerCheck(String, Int32, Int32, Int32) | Add an SNTP server to the list of servers to check
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.AddTimeServerCheck Method (String)

LicenseAddTimeServerCheck Method (String)
Add an SNTP server to the list of servers to check

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddTimeServerCheck(
    string host
)
Public Sub AddTimeServerCheck (
    host As String
)
public:
void AddTimeServerCheck(
    String^ host
)

Parameters

host
Type: SystemString
The NTP server host name.
Remarks
Caution note Caution

This allows you to verify a system's time has not be altered by comparing it to the time on a specified Internet time server. Sometimes, the availability of time servers may be somewhat unreliable (which is why this class allows you to specify multiple servers as fallbacks), and it is common for SNTP requests to be blocked by firewalls and proxy servers.

Additionally, although it is technically possible to perform SNTP requests against public NTP servers in your application, we strongly recommend you get approval from the time server's administrators/owners first (as this could cause unexpected load on their time servers, which could cause problems for you and everyone else who might rely on them).

See Also

Reference

License Class
AddTimeServerCheck Overload
com.softwarekey.Client.Licensing Namespace


License.AddTimeServerCheck Method (String, Int32)

LicenseAddTimeServerCheck Method (String, Int32)
Add an SNTP server to the list of servers to check

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddTimeServerCheck(
    string host,
    int port
)
Public Sub AddTimeServerCheck (
    host As String,
    port As Integer
)
public:
void AddTimeServerCheck(
    String^ host,
    int port
)

Parameters

host
Type: SystemString
The NTP server host name.
port
Type: SystemInt32
The NTP server port.
Remarks
Caution note Caution

This allows you to verify a system's time has not be altered by comparing it to the time on a specified Internet time server. Sometimes, the availability of time servers may be somewhat unreliable (which is why this class allows you to specify multiple servers as fallbacks), and it is common for SNTP requests to be blocked by firewalls and proxy servers.

Additionally, although it is technically possible to perform SNTP requests against public NTP servers in your application, we strongly recommend you get approval from the time server's administrators/owners first (as this could cause unexpected load on their time servers, which could cause problems for you and everyone else who might rely on them).

See Also

Reference

License Class
AddTimeServerCheck Overload
com.softwarekey.Client.Licensing Namespace


License.AddTimeServerCheck Method (String, Int32, Int32, Int32)

LicenseAddTimeServerCheck Method (String, Int32, Int32, Int32)
Add an SNTP server to the list of servers to check

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddTimeServerCheck(
    string host,
    int port,
    int sendTimeout,
    int receiveTimeout
)
Public Sub AddTimeServerCheck (
    host As String,
    port As Integer,
    sendTimeout As Integer,
    receiveTimeout As Integer
)
public:
void AddTimeServerCheck(
    String^ host,
    int port,
    int sendTimeout,
    int receiveTimeout
)

Parameters

host
Type: SystemString
The NTP server host name.
port
Type: SystemInt32
The NTP server port.
sendTimeout
Type: SystemInt32
The maximum amount of time (in milliseconds) which can be spent sending the NTP request.
receiveTimeout
Type: SystemInt32
The maximum amount of time (in milliseconds) which can be spent waiting to receive a response to the NTP request.
Remarks
Caution note Caution

This allows you to verify a system's time has not be altered by comparing it to the time on a specified Internet time server. Sometimes, the availability of time servers may be somewhat unreliable (which is why this class allows you to specify multiple servers as fallbacks), and it is common for SNTP requests to be blocked by firewalls and proxy servers.

Additionally, although it is technically possible to perform SNTP requests against public NTP servers in your application, we strongly recommend you get approval from the time server's administrators/owners first (as this could cause unexpected load on their time servers, which could cause problems for you and everyone else who might rely on them).

See Also

Reference

License Class
AddTimeServerCheck Overload
com.softwarekey.Client.Licensing Namespace


License.CheckInstallationStatus Method

LicenseCheckInstallationStatus Method
Overload List
 | Name | Description
Public method | CheckInstallationStatus | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property.
Public method | CheckInstallationStatus(String) | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint.
Public method | CheckInstallationStatus(XmlActivationService) | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint.
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.CheckInstallationStatus Method

LicenseCheckInstallationStatus Method
Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool CheckInstallationStatus()
Public Overridable Function CheckInstallationStatus As Boolean
public:
virtual bool CheckInstallationStatus()

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes license status check request using SOLO Server's XmlActivationService web service's CheckInstallationStatus method using the current value in the InstallationID property. If the Installation ID is not set or is invalid, the ActivateOnline may be used to get one, or you can call the ActivateInstallationLicenseFile method to get the Installation ID and License File at the same time.

Note Note

If you need to check the status of the Installation ID or License ID in SOLO Server and refresh the License File at the same time, use the RefreshLicense method instead.

See Also

Reference

License Class
CheckInstallationStatus Overload
com.softwarekey.Client.Licensing Namespace


License.CheckInstallationStatus Method (String)

LicenseCheckInstallationStatus Method (String)
Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool CheckInstallationStatus(
    string endpoint
)
Public Overridable Function CheckInstallationStatus (
    endpoint As String
) As Boolean
public:
virtual bool CheckInstallationStatus(
    String^ endpoint
)

Parameters

endpoint
Type: SystemString
The full URL to the web service (XmlActivationService) endpoint

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes license status check request using SOLO Server's XmlActivationService web service's CheckInstallationStatus method. InstallationID property. If the Installation ID is not set or is invalid, the ActivateOnline may be used to get one, or you can call the ActivateInstallationLicenseFile method to get the Installation ID and License File at the same time.

Note Note

If you need to check the status of the Installation ID or License ID in SOLO Server and refresh the License File at the same time, use the RefreshLicense method instead.

See Also

Reference

License Class
CheckInstallationStatus Overload
com.softwarekey.Client.Licensing Namespace


License.CheckInstallationStatus Method (XmlActivationService)

LicenseCheckInstallationStatus Method (XmlActivationService)
Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool CheckInstallationStatus(
    XmlActivationService client
)
Public Overridable Function CheckInstallationStatus (
    client As XmlActivationService
) As Boolean
public:
virtual bool CheckInstallationStatus(
    XmlActivationService^ client
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService
The SoapHttpClientProtocol derived object used to perform the web service call

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes license status check request using SOLO Server's XmlActivationService web service's CheckInstallationStatus method. InstallationID property. If the Installation ID is not set or is invalid, the ActivateOnline may be used to get one, or you can call the ActivateInstallationLicenseFile method to get the Installation ID and License File at the same time.

Note Note

If you need to check the status of the Installation ID or License ID in SOLO Server and refresh the License File at the same time, use the RefreshLicense method instead.

See Also

Reference

License Class
CheckInstallationStatus Overload
com.softwarekey.Client.Licensing Namespace


License.CheckTimeAgainstServers Method

LicenseCheckTimeAgainstServers Method
Overload List
 | Name | Description
Public method | CheckTimeAgainstServers | Checks the system time against multiple time servers/sntp requests, allowing up to a 5 minute difference.
Public method | CheckTimeAgainstServers(Double) | Checks the system time against multiple time servers/sntp requests
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.CheckTimeAgainstServers Method

LicenseCheckTimeAgainstServers Method
Checks the system time against multiple time servers/sntp requests, allowing up to a 5 minute difference.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool CheckTimeAgainstServers()
Public Function CheckTimeAgainstServers As Boolean
public:
bool CheckTimeAgainstServers()

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks
Caution note Caution

This allows you to verify a system's time has not be altered by comparing it to the time on a specified Internet time server. Sometimes, the availability of time servers may be somewhat unreliable (which is why this class allows you to specify multiple servers as fallbacks), and it is common for SNTP requests to be blocked by firewalls and proxy servers.

Additionally, although it is technically possible to perform SNTP requests against public NTP servers in your application, we strongly recommend you get approval from the time server's administrators/owners first (as this could cause unexpected load on their time servers, which could cause problems for you and everyone else who might rely on them).

See Also

Reference

License Class
CheckTimeAgainstServers Overload
com.softwarekey.Client.Licensing Namespace


License.CheckTimeAgainstServers Method (Double)

LicenseCheckTimeAgainstServers Method (Double)
Checks the system time against multiple time servers/sntp requests

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool CheckTimeAgainstServers(
    double minuteThreshold
)
Public Function CheckTimeAgainstServers (
    minuteThreshold As Double
) As Boolean
public:
bool CheckTimeAgainstServers(
    double minuteThreshold
)

Parameters

minuteThreshold
Type: SystemDouble
The maximum amount of allowable difference in time (in minutes) between the system and the NTP server.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks
Caution note Caution

This allows you to verify a system's time has not be altered by comparing it to the time on a specified Internet time server. Sometimes, the availability of time servers may be somewhat unreliable (which is why this class allows you to specify multiple servers as fallbacks), and it is common for SNTP requests to be blocked by firewalls and proxy servers.

Additionally, although it is technically possible to perform SNTP requests against public NTP servers in your application, we strongly recommend you get approval from the time server's administrators/owners first (as this could cause unexpected load on their time servers, which could cause problems for you and everyone else who might rely on them).

See Also

Reference

License Class
CheckTimeAgainstServers Overload
com.softwarekey.Client.Licensing Namespace


License.DeactivateInstallation Method

LicenseDeactivateInstallation Method
Overload List
 | Name | Description
Public method | DeactivateInstallation | Deactivates the license with SOLO Server using the InstallationID property.
Public method | DeactivateInstallation(String) | Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint.
Public method | DeactivateInstallation(XmlActivationService) | Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint.
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.DeactivateInstallation Method

LicenseDeactivateInstallation Method
Deactivates the license with SOLO Server using the InstallationID property.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool DeactivateInstallation()
Public Overridable Function DeactivateInstallation As Boolean
public:
virtual bool DeactivateInstallation()

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes license deactivation request using SOLO Server's XmlActivationService web service's DeactivateInstallation method using the current value of the InstallationID property. If the Installation ID is not set or is invalid, the ActivateOnline may be used to get one, or you can call the ActivateInstallationLicenseFile method to get the Installation ID and License File at the same time.

See Also

Reference

License Class
DeactivateInstallation Overload
com.softwarekey.Client.Licensing Namespace


License.DeactivateInstallation Method (String)

LicenseDeactivateInstallation Method (String)
Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool DeactivateInstallation(
    string endpoint
)
Public Overridable Function DeactivateInstallation (
    endpoint As String
) As Boolean
public:
virtual bool DeactivateInstallation(
    String^ endpoint
)

Parameters

endpoint
Type: SystemString
The full URL to the web service (XmlActivationService) endpoint

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes license deactivation request using SOLO Server's XmlActivationService web service's DeactivateInstallation method using the current value of the InstallationID property. If the Installation ID is not set or is invalid, the ActivateOnline may be used to get one, or you can call the ActivateInstallationLicenseFile method to get the Installation ID and License File at the same time.

See Also

Reference

License Class
DeactivateInstallation Overload
com.softwarekey.Client.Licensing Namespace


License.DeactivateInstallation Method (XmlActivationService)

LicenseDeactivateInstallation Method (XmlActivationService)
Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool DeactivateInstallation(
    XmlActivationService client
)
Public Overridable Function DeactivateInstallation (
    client As XmlActivationService
) As Boolean
public:
virtual bool DeactivateInstallation(
    XmlActivationService^ client
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService
The SoapHttpClientProtocol derived object used to perform the web service call

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes license deactivation request using SOLO Server's XmlActivationService web service's DeactivateInstallation method using the current value of the InstallationID property. If the Installation ID is not set or is invalid, the ActivateOnline may be used to get one, or you can call the ActivateInstallationLicenseFile method to get the Installation ID and License File at the same time.

See Also

Reference

License Class
DeactivateInstallation Overload
com.softwarekey.Client.Licensing Namespace


License.GetActivationInstallationLicenseFileRequest Method

LicenseGetActivationInstallationLicenseFileRequest Method
Builds a manual activation XML request string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string GetActivationInstallationLicenseFileRequest(
    int licenseId,
    string password
)
Public Overridable Function GetActivationInstallationLicenseFileRequest (
    licenseId As Integer,
    password As String
) As String
public:
virtual String^ GetActivationInstallationLicenseFileRequest(
    int licenseId,
    String^ password
)

Parameters

licenseId
Type: SystemInt32
The License ID of the customer's license in SOLO Server
password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.

Return Value

Type: String
Returns a string which contains the XML request string the user an post/upload to SOLO Server's manual request processing page. If an empty string is returned, check the LastError property for details.
Remarks

This method generates an XML request string which may be used for manual activation processing, which is where the requests may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, the ResetSessionCode method should be called, as this will help prevent your end-users from replaying requests. Once the response has been generated and sent to the user, the user may then open a response file or paste its contents in your application, which can then set the CurrentSessionCode property (if the application needs to support resuming the manual activation processing after having been closed) and use the ProcessActivateInstallationLicenseFileResponse method to process the response.

See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.GetActivationRequest Method

LicenseGetActivationRequest Method
Builds a manual activation XML request string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string GetActivationRequest(
    int licenseId,
    string password
)
Public Overridable Function GetActivationRequest (
    licenseId As Integer,
    password As String
) As String
public:
virtual String^ GetActivationRequest(
    int licenseId,
    String^ password
)

Parameters

licenseId
Type: SystemInt32
The License ID of the customer's license in SOLO Server
password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.

Return Value

Type: String
Returns a string which contains the XML request string the user an post/upload to SOLO Server's manual request processing page. If an empty string is returned, check the LastError property for details.
Remarks

This method generates an XML request string which may be used for manual activation processing, which is where the requests may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity). Before calling this method, the ResetSessionCode method should be called, as this will help prevent your end-users from replaying requests. Once the response has been generated and sent to the user, the user may then open a response file or paste its contents in your application, which can then set the CurrentSessionCode property (if the application needs to support resuming the manual activation processing after having been closed) and use the ProcessActivationResponse method to process the response.

See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.GetCheckInstallationStatusRequest Method

LicenseGetCheckInstallationStatusRequest Method
Builds a manual status check XML request string using the current value in the InstallationID property

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string GetCheckInstallationStatusRequest()
Public Overridable Function GetCheckInstallationStatusRequest As String
public:
virtual String^ GetCheckInstallationStatusRequest()

Return Value

Type: String
Returns a string which contains the XML request string the user an post/upload to SOLO Server's manual request processing page. If an empty string is returned, check the LastError property for details.
Remarks

This method generates an XML request string which may be used for manual status check processing, which is where the requests may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, the ResetSessionCode method should be called, as this will help prevent your end-users from replaying requests. Once the response has been generated and sent to the user, the user may then open a response file or paste its contents in your application, which can then set the CurrentSessionCode property (if the application needs to support resuming the manual status check processing after having been closed) and use the ProcessCheckInstallationStatusResponse method to process the response.

Note Note

If you need to check the status of the Installation ID or License ID in SOLO Server and refresh the License File at the same time, use the GetLicenseRefreshRequest method to generate a license refresh request instead.

See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.GetDeactivateInstallationRequest Method

LicenseGetDeactivateInstallationRequest Method
Builds a manual status check XML request string using the current value in the InstallationID property

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string GetDeactivateInstallationRequest()
Public Overridable Function GetDeactivateInstallationRequest As String
public:
virtual String^ GetDeactivateInstallationRequest()

Return Value

Type: String
Returns a string which contains the XML request string the user an post/upload to SOLO Server's manual request processing page. If an empty string is returned, check the LastError property for details.
Remarks

This method generates an XML request string which may be used for manual deactivation processing, which is where the requests may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, the ResetSessionCode method should be called, as this will help prevent your end-users from replaying requests. Once the response has been generated and sent to the user, the user may then open a response file or paste its contents in your application, which can then set the CurrentSessionCode property (if the application needs to support resuming the manual deactivation processing after having been closed) and use the ProcessDeactivateInstallationResponse method to process the response.

See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.GetEncryptionKey Method

LicenseGetEncryptionKey Method
Gets the AuthorEncryptionKey object used for cryptographic routines.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected AuthorEncryptionKey GetEncryptionKey()
Protected Function GetEncryptionKey As AuthorEncryptionKey
protected:
AuthorEncryptionKey^ GetEncryptionKey()

Return Value

Type: AuthorEncryptionKey
Returns an AuthorEncryptionKey object, which includes data required for cryptographic routines.
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.GetLicenseRefreshRequest Method

LicenseGetLicenseRefreshRequest Method
Builds a manual license refresh XML request string using the current value in the InstallationID property

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string GetLicenseRefreshRequest()
Public Overridable Function GetLicenseRefreshRequest As String
public:
virtual String^ GetLicenseRefreshRequest()

Return Value

Type: String
Returns a string which contains the XML request string the user an post/upload to SOLO Server's manual request processing page. If an empty string is returned, check the LastError property for details.
Remarks

This method generates an XML request string which may be used for manual license refresh processing, which is where the requests may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, the ResetSessionCode method should be called, as this will help prevent your end-users from replaying requests. Once the response has been generated and sent to the user, the user may then open a response file or paste its contents in your application, which can then set the CurrentSessionCode property (if the application needs to support resuming the manual license refresh processing after having been closed) and use the ProcessLicenseRefreshResponse method to process the response.

See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.InitializeCurrentIdentifiers Method

LicenseInitializeCurrentIdentifiers Method
Initializes the CurrentIdentifiers property using the algorithms added using the AddIdentifierAlgorithm(SystemIdentifierAlgorithm) method.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void InitializeCurrentIdentifiers()
Public Sub InitializeCurrentIdentifiers
public:
void InitializeCurrentIdentifiers()
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.initializeFromXml Method

LicenseinitializeFromXml Method
Initializes properties from a plain-text XML license document.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected virtual bool initializeFromXml(
    XmlDocument xml
)
Protected Overridable Function initializeFromXml (
    xml As XmlDocument
) As Boolean
protected:
virtual bool initializeFromXml(
    XmlDocument^ xml
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument object with the initialization data

Return Value

Type: Boolean
Returns true if successful.
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.Load Method

LicenseLoad Method
Loads a License File from a String in memory.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool Load(
    string data
)
Public Overridable Function Load (
    data As String
) As Boolean
public:
virtual bool Load(
    String^ data
)

Parameters

data
Type: SystemString
The License File data.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.LoadFile Method

LicenseLoadFile Method
Loads a License File from the file system and returns true if successful

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool LoadFile(
    string path
)
Public Function LoadFile (
    path As String
) As Boolean
public:
bool LoadFile(
    String^ path
)

Parameters

path
Type: SystemString
The absolute path to the file on the local file-system.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ProcessActivateInstallationLicenseFileResponse Method

LicenseProcessActivateInstallationLicenseFileResponse Method
Overload List
 | Name | Description
Public method | ProcessActivateInstallationLicenseFileResponse(String, String) | Processes an activation XML response string
Public method | ProcessActivateInstallationLicenseFileResponse(XmlNode, String) | Processes an activation XML response
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ProcessActivateInstallationLicenseFileResponse Method (String, String)

LicenseProcessActivateInstallationLicenseFileResponse Method (String, String)
Processes an activation XML response string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessActivateInstallationLicenseFileResponse(
    string response,
    ref string licenseContent
)
Public Overridable Function ProcessActivateInstallationLicenseFileResponse (
    response As String,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ProcessActivateInstallationLicenseFileResponse(
    String^ response,
    String^% licenseContent
)

Parameters

response
Type: SystemString
The XML response string
licenseContent
Type: SystemString
The License File content returned from SOLO Server

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual activation processing, which is where the requests (generated from the GetActivationInstallationLicenseFileRequest(Int32, String) method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual activation processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

License Class
ProcessActivateInstallationLicenseFileResponse Overload
com.softwarekey.Client.Licensing Namespace


License.ProcessActivateInstallationLicenseFileResponse Method (XmlNode, String)

LicenseProcessActivateInstallationLicenseFileResponse Method (XmlNode, String)
Processes an activation XML response

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessActivateInstallationLicenseFileResponse(
    XmlNode response,
    ref string licenseContent
)
Public Overridable Function ProcessActivateInstallationLicenseFileResponse (
    response As XmlNode,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ProcessActivateInstallationLicenseFileResponse(
    XmlNode^ response,
    String^% licenseContent
)

Parameters

response
Type: System.XmlXmlNode
The XmlNode or XmlDocument object containing the response XML
licenseContent
Type: SystemString
The License File content returned from SOLO Server

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual activation processing, which is where the requests (generated from the GetActivationInstallationLicenseFileRequest(Int32, String) method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual activation processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

License Class
ProcessActivateInstallationLicenseFileResponse Overload
com.softwarekey.Client.Licensing Namespace


License.ProcessActivationResponse Method

LicenseProcessActivationResponse Method
Overload List
 | Name | Description
Public method | ProcessActivationResponse(String) | Processes an activation XML response string
Public method | ProcessActivationResponse(XmlNode) | Processes an activation XML response.
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ProcessActivationResponse Method (String)

LicenseProcessActivationResponse Method (String)
Processes an activation XML response string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessActivationResponse(
    string response
)
Public Overridable Function ProcessActivationResponse (
    response As String
) As Boolean
public:
virtual bool ProcessActivationResponse(
    String^ response
)

Parameters

response
Type: SystemString
The XML response string

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual activation processing, which is where the requests (generated from the GetActivationRequest(Int32, String) method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual activation processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

License Class
ProcessActivationResponse Overload
com.softwarekey.Client.Licensing Namespace


License.ProcessActivationResponse Method (XmlNode)

LicenseProcessActivationResponse Method (XmlNode)
Processes an activation XML response.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessActivationResponse(
    XmlNode response
)
Public Overridable Function ProcessActivationResponse (
    response As XmlNode
) As Boolean
public:
virtual bool ProcessActivationResponse(
    XmlNode^ response
)

Parameters

response
Type: System.XmlXmlNode
The XmlNode or XmlDocument object containing the response XML

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual activation processing, which is where the requests (generated from the GetActivationRequest(Int32, String) method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual activation processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

License Class
ProcessActivationResponse Overload
com.softwarekey.Client.Licensing Namespace


License.ProcessCheckInstallationStatusResponse Method

LicenseProcessCheckInstallationStatusResponse Method
Overload List
 | Name | Description
Public method | ProcessCheckInstallationStatusResponse(String) | Processes a CheckInstallationStatus XML response string
Public method | ProcessCheckInstallationStatusResponse(XmlNode) | Processes a CheckInstallationStatus XML response string
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ProcessCheckInstallationStatusResponse Method (String)

LicenseProcessCheckInstallationStatusResponse Method (String)
Processes a CheckInstallationStatus XML response string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessCheckInstallationStatusResponse(
    string response
)
Public Overridable Function ProcessCheckInstallationStatusResponse (
    response As String
) As Boolean
public:
virtual bool ProcessCheckInstallationStatusResponse(
    String^ response
)

Parameters

response
Type: SystemString
The XmlNode or XmlDocument object containing the response XML

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual status check processing, which is where the requests (generated from the GetCheckInstallationStatusRequest method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual status check processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

License Class
ProcessCheckInstallationStatusResponse Overload
com.softwarekey.Client.Licensing Namespace


License.ProcessCheckInstallationStatusResponse Method (XmlNode)

LicenseProcessCheckInstallationStatusResponse Method (XmlNode)
Processes a CheckInstallationStatus XML response string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessCheckInstallationStatusResponse(
    XmlNode response
)
Public Overridable Function ProcessCheckInstallationStatusResponse (
    response As XmlNode
) As Boolean
public:
virtual bool ProcessCheckInstallationStatusResponse(
    XmlNode^ response
)

Parameters

response
Type: System.XmlXmlNode
The XmlNode or XmlDocument object containing the response XML

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual status check processing, which is where the requests (generated from the GetCheckInstallationStatusRequest method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual status check processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

License Class
ProcessCheckInstallationStatusResponse Overload
com.softwarekey.Client.Licensing Namespace


License.ProcessDeactivateInstallationResponse Method

LicenseProcessDeactivateInstallationResponse Method
Overload List
 | Name | Description
Public method | ProcessDeactivateInstallationResponse(String) | Processes a DeactivateInstallation XML response string
Public method | ProcessDeactivateInstallationResponse(XmlNode) | Processes a DeactivateInstallation XML response string
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ProcessDeactivateInstallationResponse Method (String)

LicenseProcessDeactivateInstallationResponse Method (String)
Processes a DeactivateInstallation XML response string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessDeactivateInstallationResponse(
    string response
)
Public Overridable Function ProcessDeactivateInstallationResponse (
    response As String
) As Boolean
public:
virtual bool ProcessDeactivateInstallationResponse(
    String^ response
)

Parameters

response
Type: SystemString
The XML response string

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual deactivation processing, which is where the requests (generated from the GetDeactivateInstallationRequest method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual status check processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

License Class
ProcessDeactivateInstallationResponse Overload
com.softwarekey.Client.Licensing Namespace


License.ProcessDeactivateInstallationResponse Method (XmlNode)

LicenseProcessDeactivateInstallationResponse Method (XmlNode)
Processes a DeactivateInstallation XML response string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessDeactivateInstallationResponse(
    XmlNode response
)
Public Overridable Function ProcessDeactivateInstallationResponse (
    response As XmlNode
) As Boolean
public:
virtual bool ProcessDeactivateInstallationResponse(
    XmlNode^ response
)

Parameters

response
Type: System.XmlXmlNode
The XmlNode or XmlDocument object containing the response XML.

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual deactivation processing, which is where the requests (generated from the GetDeactivateInstallationRequest method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual status check processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

License Class
ProcessDeactivateInstallationResponse Overload
com.softwarekey.Client.Licensing Namespace


License.ProcessLicenseRefreshResponse Method

LicenseProcessLicenseRefreshResponse Method
Overload List
 | Name | Description
Public method | ProcessLicenseRefreshResponse(String, String) | Processes an activation XML response string
Public method | ProcessLicenseRefreshResponse(XmlNode, String) | Processes an License Refresh XML response
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.ProcessLicenseRefreshResponse Method (String, String)

LicenseProcessLicenseRefreshResponse Method (String, String)
Processes an activation XML response string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessLicenseRefreshResponse(
    string response,
    ref string licenseContent
)
Public Overridable Function ProcessLicenseRefreshResponse (
    response As String,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ProcessLicenseRefreshResponse(
    String^ response,
    String^% licenseContent
)

Parameters

response
Type: SystemString
The XML response string.
licenseContent
Type: SystemString
The License File content returned from SOLO Server.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual license refresh processing, which is where the requests (generated from the GetLicenseRefreshRequest method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual activation processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

License Class
ProcessLicenseRefreshResponse Overload
com.softwarekey.Client.Licensing Namespace


License.ProcessLicenseRefreshResponse Method (XmlNode, String)

LicenseProcessLicenseRefreshResponse Method (XmlNode, String)
Processes an License Refresh XML response

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessLicenseRefreshResponse(
    XmlNode response,
    ref string licenseContent
)
Public Overridable Function ProcessLicenseRefreshResponse (
    response As XmlNode,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ProcessLicenseRefreshResponse(
    XmlNode^ response,
    String^% licenseContent
)

Parameters

response
Type: System.XmlXmlNode
The XmlNode or DocumentElement object containing the response XML.
licenseContent
Type: SystemString
The License File content returned from SOLO Server.

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual license refresh processing, which is where the requests (generated from the GetLicenseRefreshRequest method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual license refresh processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

License Class
ProcessLicenseRefreshResponse Overload
com.softwarekey.Client.Licensing Namespace


License.RefreshLicense Method

LicenseRefreshLicense Method
Overload List
 | Name | Description
Public method | RefreshLicense(String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property.
Public method | RefreshLicense(String, String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property.
Public method | RefreshLicense(XmlLicenseFileService, String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property.
Top
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.RefreshLicense Method (String)

LicenseRefreshLicense Method (String)
Returns the current license file contents from SOLO Server using the current value in the InstallationID property.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool RefreshLicense(
    ref string licenseContent
)
Public Overridable Function RefreshLicense (
    ByRef licenseContent As String
) As Boolean
public:
virtual bool RefreshLicense(
    String^% licenseContent
)

Parameters

licenseContent
Type: SystemString
The contents of the License File

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes license refresh request using SOLO Server's XmlLicenseFileService web service's GetLicenseFile method. InstallationID property. If the Installation ID is not set or is invalid, the ActivateOnline may be used to get one, or you can call the ActivateInstallationLicenseFile method to get the Installation ID and License File at the same time.

See Also

Reference

License Class
RefreshLicense Overload
com.softwarekey.Client.Licensing Namespace


License.RefreshLicense Method (String, String)

LicenseRefreshLicense Method (String, String)
Returns the current license file contents from SOLO Server using the current value in the InstallationID property.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool RefreshLicense(
    string endpoint,
    ref string licenseContent
)
Public Overridable Function RefreshLicense (
    endpoint As String,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool RefreshLicense(
    String^ endpoint,
    String^% licenseContent
)

Parameters

endpoint
Type: SystemString
The full URL to the web service (XmlLicenseFileService) endpoint
licenseContent
Type: SystemString
The contents of the License File

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes license refresh request using SOLO Server's XmlLicenseFileService web service's GetLicenseFile method. InstallationID property. If the Installation ID is not set or is invalid, the ActivateOnline may be used to get one, or you can call the ActivateInstallationLicenseFile method to get the Installation ID and License File at the same time.

See Also

Reference

License Class
RefreshLicense Overload
com.softwarekey.Client.Licensing Namespace


License.RefreshLicense Method (XmlLicenseFileService, String)

LicenseRefreshLicense Method (XmlLicenseFileService, String)
Returns the current license file contents from SOLO Server using the current value in the InstallationID property.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool RefreshLicense(
    XmlLicenseFileService client,
    ref string licenseContent
)
Public Overridable Function RefreshLicense (
    client As XmlLicenseFileService,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool RefreshLicense(
    XmlLicenseFileService^ client,
    String^% licenseContent
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlLicenseFileServiceXmlLicenseFileService
The SoapHttpClientProtocol derived object used to perform the web service call
licenseContent
Type: SystemString
The contents of the License File

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This processes license refresh request using SOLO Server's XmlLicenseFileService web service's GetLicenseFile method. InstallationID property. If the Installation ID is not set or is invalid, the ActivateOnline may be used to get one, or you can call the ActivateInstallationLicenseFile method to get the Installation ID and License File at the same time.

See Also

Reference

License Class
RefreshLicense Overload
com.softwarekey.Client.Licensing Namespace


License.ResetSessionCode Method

LicenseResetSessionCode Method
Creates a new session code in the CurrentSessionCode property

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ResetSessionCode()
Public Sub ResetSessionCode
public:
void ResetSessionCode()
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


License.WriteLicenseFile Method

LicenseWriteLicenseFile Method
Writes a License File to the file system.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool WriteLicenseFile(
    string path,
    string lfContent
)
Public Overridable Function WriteLicenseFile (
    path As String,
    lfContent As String
) As Boolean
public:
virtual bool WriteLicenseFile(
    String^ path,
    String^ lfContent
)

Parameters

path
Type: SystemString
The absolute path to the License File
lfContent
Type: SystemString
The XML content of the license.

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
See Also

Reference

License Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias Class

LicenseAlias Class
Base, abstract class for implementing License File aliases.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseAlias
com.softwarekey.Client.LicensingLicenseFileSystemAlias
com.softwarekey.Client.LicensingLicenseImageAlias
com.softwarekey.Client.LicensingLicenseWindowsRegistryAlias

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class LicenseAlias
Public MustInherit Class LicenseAlias
public ref class LicenseAlias abstract

The LicenseAlias type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseAlias | Creates a new LicenseAlias object.
Top
Properties
 | Name | Description
Public property | Contents | Gets the contents of the alias file.
Public property | LastError | Gets the last error that occurred.
Public property | LastUpdated | Gets the date the alias was last updated.
Public property | Location | Gets the location of the alias.
Public property | Type | Gets the type location in which the alias is stored.
Top
Methods
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias.
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date.
Public method | DeleteAlias | Deletes the current alias.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetMostCurrentAlias | Gets the most current alias from a list.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | WriteAlias | Updates the alias with the most current license file data.
Top
Fields
 | Name | Description
Protected field | m_lastError | The last error that occurred
Top
Remarks

Aliases are simply hidden copies of the License file. Though these may technically exist anywhere you see fit (through custom implementation), currently supported implementations only support use of the file-system and the Windows Registry. The currently supported implementations are listed below:

Name | Description
LicenseFileSystemAlias | Implements file-system based aliases, which are hidden copies of the License File which reside on the system's file-system.
LicenseWindowsRegistryAlias | Implements Windows Registry based aliases, which are hidden copies of the License File which reside on the system's Registry.
LicenseImageAlias | Implements Image based aliases, which are hidden copies of the License File which reside within image pixel data.
Caution note Caution

When aliases are written, this library attempts to write the license file alias to disk, and also attempts to give full permissions everyone access to this file (using WellKnownSidType.WorldSid). This is done to help avoid UAC issues with Windows Vista/2008 and later, and is the same behavior performed by Protection PLUS 4 libraries and Instant PLUS. Please see our knowledge-base for additional information.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseAlias Constructor

LicenseAlias Constructor
Creates a new LicenseAlias object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseAlias(
    string location,
    LicenseAliasLocationType type,
    AuthorEncryptionKey encryptionKey,
    bool useEncryption
)
Public Sub New (
    location As String,
    type As LicenseAliasLocationType,
    encryptionKey As AuthorEncryptionKey,
    useEncryption As Boolean
)
public:
LicenseAlias(
    String^ location,
    LicenseAliasLocationType type,
    AuthorEncryptionKey^ encryptionKey,
    bool useEncryption
)

Parameters

location
Type: SystemString
The full/absolute path or location to the alias.
type
Type: com.softwarekey.Client.LicensingLicenseAliasLocationType
The type of location.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object containing the required encryption data.
useEncryption
Type: SystemBoolean
Whether or not to use encryption. (Set to true if unsure.)
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias Properties

LicenseAlias Properties

The LicenseAlias type exposes the following members.

Properties
 | Name | Description
Public property | Contents | Gets the contents of the alias file.
Public property | LastError | Gets the last error that occurred.
Public property | LastUpdated | Gets the date the alias was last updated.
Public property | Location | Gets the location of the alias.
Public property | Type | Gets the type location in which the alias is stored.
Top
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.Contents Property

LicenseAliasContents Property
Gets the contents of the alias file.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Contents { get; }
Public ReadOnly Property Contents As String
    Get
public:
property String^ Contents {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.LastError Property

LicenseAliasLastError Property
Gets the last error that occurred.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError LastError { get; }
Public ReadOnly Property LastError As LicenseError
    Get
public:
property LicenseError^ LastError {
    LicenseError^ get ();
}

Property Value

Type: LicenseError
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.LastUpdated Property

LicenseAliasLastUpdated Property
Gets the date the alias was last updated.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime LastUpdated { get; }
Public ReadOnly Property LastUpdated As DateTime
    Get
public:
property DateTime LastUpdated {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.Location Property

LicenseAliasLocation Property
Gets the location of the alias.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Location { get; }
Public ReadOnly Property Location As String
    Get
public:
property String^ Location {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.Type Property

LicenseAliasType Property
Gets the type location in which the alias is stored.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseAliasLocationType Type { get; }
Public ReadOnly Property Type As LicenseAliasLocationType
    Get
public:
property LicenseAliasLocationType Type {
    LicenseAliasLocationType get ();
}

Property Value

Type: LicenseAliasLocationType
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias Methods

LicenseAlias Methods

The LicenseAlias type exposes the following members.

Methods
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias.
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date.
Public method | DeleteAlias | Deletes the current alias.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetMostCurrentAlias | Gets the most current alias from a list.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | WriteAlias | Updates the alias with the most current license file data.
Top
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.CheckAlias Method

LicenseAliasCheckAlias Method
Overload List
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias.
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date.
Top
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.CheckAlias Method

LicenseAliasCheckAlias Method
Compares the current license to the alias.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract bool CheckAlias()
Public MustOverride Function CheckAlias As Boolean
public:
virtual bool CheckAlias() abstract

Return Value

Type: Boolean
Returns true if the alias is found to be valid. If it is not valid, check the LastError property for details.
See Also

Reference

LicenseAlias Class
CheckAlias Overload
com.softwarekey.Client.Licensing Namespace


LicenseAlias.CheckAlias Method (String)

LicenseAliasCheckAlias Method (String)
Decrypts and verifies the alias document, and checks its last updated date.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected virtual bool CheckAlias(
    string alias
)
Protected Overridable Function CheckAlias (
    alias As String
) As Boolean
protected:
virtual bool CheckAlias(
    String^ alias
)

Parameters

alias
Type: SystemString
The contents of the alias to validate.

Return Value

Type: Boolean
Returns true if the alias is valid. If false is returned, check the LastError property for details.
See Also

Reference

LicenseAlias Class
CheckAlias Overload
com.softwarekey.Client.Licensing Namespace


LicenseAlias.DeleteAlias Method

LicenseAliasDeleteAlias Method
Deletes the current alias.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract bool DeleteAlias()
Public MustOverride Function DeleteAlias As Boolean
public:
virtual bool DeleteAlias() abstract

Return Value

Type: Boolean
Returns true if the alias is deleted successfully. If it is not successful, check the LastError property for details.
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.GetMostCurrentAlias Method

LicenseAliasGetMostCurrentAlias Method
Gets the most current alias from a list.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static LicenseAlias GetMostCurrentAlias(
    List<LicenseAlias> aliases
)
Public Shared Function GetMostCurrentAlias (
    aliases As List(Of LicenseAlias)
) As LicenseAlias
public:
static LicenseAlias^ GetMostCurrentAlias(
    List<LicenseAlias^>^ aliases
)

Parameters

aliases
Type: System.Collections.GenericList LicenseAlias
Generic list of LicenseAlias objects.

Return Value

Type: LicenseAlias
Returns the most current LicenseAlias object.
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.WriteAlias Method

LicenseAliasWriteAlias Method
Updates the alias with the most current license file data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract bool WriteAlias(
    string license
)
Public MustOverride Function WriteAlias (
    license As String
) As Boolean
public:
virtual bool WriteAlias(
    String^ license
) abstract

Parameters

license
Type: SystemString
The license contents to write.

Return Value

Type: Boolean
Returns true if the alias was written successfully. If it failed to write, check the LastError property for details.
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias Fields

LicenseAlias Fields

The LicenseAlias type exposes the following members.

Fields
 | Name | Description
Protected field | m_lastError | The last error that occurred
Top
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.m_lastError Field

LicenseAliasm_lastError Field
The last error that occurred

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected LicenseError m_lastError
Protected m_lastError As LicenseError
protected:
LicenseError^ m_lastError

Field Value

Type: LicenseError
See Also

Reference

LicenseAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseAlias.LocationType Enumeration

LicenseAliasLocationType Enumeration
The type of location in which the alias is to be stored

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum LocationType
Public Enumeration LocationType
public enum class LocationType
Members
Member name | Value | Description
Unknown | 0 | Unknown type of alias location
FileSystem | 1 | The alias is located on a file system accessible by the computer
WindowsRegistry | 2 | The alias is located in the Windows registry on the current computer
See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation Class

LicenseAliasValidation Class
Validates the aliases for a WritableLicense.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
com.softwarekey.Client.LicensingLicenseAliasValidation

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseAliasValidation : SystemValidation
Public Class LicenseAliasValidation
    Inherits SystemValidation
public ref class LicenseAliasValidation : public SystemValidation

The LicenseAliasValidation type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseAliasValidation | Creates a new LicenseAliasValidation object for validating aliases for a WritableLicense.
Top
Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | LicenseFilePath | Gets or sets the absolute path to the writable license file.
Public property | NumberOfValidAliasesRequired | Gets or sets the number of valid aliases required for validation to pass (REQUIRE_ALL_ALIASES by default).
Public property | OverwriteOlder | Gets or sets whether or not the license file and other aliases should be overwritten if an alias appears to be newer (true by default).
Public property | WriteMissingAliases | Gets or sets whether or not missing aliases should be written while being checked.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Implements standard LicenseAlias validation. (Overrides SystemValidationValidate.)
Top
Fields
Name | Description
REQUIRE_ALL_ALIASES | This constant value may be used when setting the NumberOfValidAliasesRequired property to require all aliases to pass validation.
Top
Remarks

See the constructor for implementation details.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation Constructor

LicenseAliasValidation Constructor
Creates a new LicenseAliasValidation object for validating aliases for a WritableLicense.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseAliasValidation(
    WritableLicense license
)
Public Sub New (
    license As WritableLicense
)
public:
LicenseAliasValidation(
    WritableLicense^ license
)

Parameters

license
Type: com.softwarekey.Client.LicensingWritableLicense
The WritableLicense which needs to have its aliases validated.
Remarks
Caution note Caution
By default, OverwriteOlder option is set to true. When this is enabled, any aliases that is newer than the license file and the rest of the aliases will be used to overwrite the license file and the other aliases.
Caution note Caution
When OverwriteOlder is set to true, a valid, absolute path to your application's license file must be specified in the LicenseFilePath property. If LicenseFilePath is not set properly, the WritableLicense object will load the latest alias, but will not automatically save it to the file system.
Caution note Caution
By default, all aliases configured for your WritableLicense implementation will be required to pass validation, and at least one aliases must be configured. See the NumberOfValidAliasesRequired property for additional information.

After initializing your LicenseAliasValidation object and its properties, call the Validate method to validate the aliases configured in the WritableLicense (these are configured via the AddAlias(LicenseAlias) method.

See Also

Reference

LicenseAliasValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation Properties

LicenseAliasValidation Properties

The LicenseAliasValidation type exposes the following members.

Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | LicenseFilePath | Gets or sets the absolute path to the writable license file.
Public property | NumberOfValidAliasesRequired | Gets or sets the number of valid aliases required for validation to pass (REQUIRE_ALL_ALIASES by default).
Public property | OverwriteOlder | Gets or sets whether or not the license file and other aliases should be overwritten if an alias appears to be newer (true by default).
Public property | WriteMissingAliases | Gets or sets whether or not missing aliases should be written while being checked.
Top
See Also

Reference

LicenseAliasValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation.LicenseFilePath Property

LicenseAliasValidationLicenseFilePath Property
Gets or sets the absolute path to the writable license file.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseFilePath { get; set; }
Public Property LicenseFilePath As String
    Get
    Set
public:
property String^ LicenseFilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseAliasValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation.NumberOfValidAliasesRequired Property

LicenseAliasValidationNumberOfValidAliasesRequired Property
Gets or sets the number of valid aliases required for validation to pass (REQUIRE_ALL_ALIASES by default).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int NumberOfValidAliasesRequired { get; set; }
Public Property NumberOfValidAliasesRequired As Integer
    Get
    Set
public:
property int NumberOfValidAliasesRequired {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks

Using a value of REQUIRE_ALL_ALIASES to require all configured aliases to pass validation is recommended. This value implicitly requires at least one alias to pass validation (meaning validation will fail when no aliases are configured and REQUIRE_ALL_ALIASES is used).

You may set this property to 0 (zero) to not require any aliases to pass validation, though this is not recommended.

Alternatively, you may set this property's value to a minimum number of aliases that must pass validation. So for example, if you have configured 5 aliases for your license, you can set this property to 3 to require at least 3 out of the 5 to pass validation. An example of where this can be useful is in a scenario where you have 2 aliases stored in user-specific locations, and the other 3 in global locations. The two user-specific locations should not encounter any issues, whereas the global locations might. So setting the value to 3 essentially makes it so that in the worst-case scenario with permissions, the two user-aliases will pass validation, and you are implicitly requiring at least 1 global alias to pass validation.

See Also

Reference

LicenseAliasValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation.OverwriteOlder Property

LicenseAliasValidationOverwriteOlder Property
Gets or sets whether or not the license file and other aliases should be overwritten if an alias appears to be newer (true by default).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool OverwriteOlder { get; set; }
Public Property OverwriteOlder As Boolean
    Get
    Set
public:
property bool OverwriteOlder {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicenseAliasValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation.WriteMissingAliases Property

LicenseAliasValidationWriteMissingAliases Property
Gets or sets whether or not missing aliases should be written while being checked.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool WriteMissingAliases { get; set; }
Public Property WriteMissingAliases As Boolean
    Get
    Set
public:
property bool WriteMissingAliases {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicenseAliasValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation Methods

LicenseAliasValidation Methods

The LicenseAliasValidation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Implements standard LicenseAlias validation. (Overrides SystemValidationValidate.)
Top
See Also

Reference

LicenseAliasValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation.Validate Method

LicenseAliasValidationValidate Method
Implements standard LicenseAlias validation.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Validate()
Public Overrides Function Validate As Boolean
public:
virtual bool Validate() override

Return Value

Type: Boolean
Returns true if validation is successful, which would indicate the license aliases passed validation. If it is not successful, check the LastError property for details.
See Also

Reference

LicenseAliasValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation Fields

LicenseAliasValidation Fields

The LicenseAliasValidation type exposes the following members.

Fields
Name | Description
REQUIRE_ALL_ALIASES | This constant value may be used when setting the NumberOfValidAliasesRequired property to require all aliases to pass validation.
Top
See Also

Reference

LicenseAliasValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseAliasValidation.REQUIRE_ALL_ALIASES Field

LicenseAliasValidationREQUIRE_ALL_ALIASES Field
This constant value may be used when setting the NumberOfValidAliasesRequired property to require all aliases to pass validation.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int REQUIRE_ALL_ALIASES = -1
Public Const REQUIRE_ALL_ALIASES As Integer = -1
public:
literal int REQUIRE_ALL_ALIASES = -1

Field Value

Type: Int32
See Also

Reference

LicenseAliasValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseAuthor Class

LicenseAuthor Class
Contains data about the SOLO Server Author which issued the license.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseDataObject
com.softwarekey.Client.LicensingLicenseAuthor

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseAuthor : LicenseDataObject
Public Class LicenseAuthor
    Inherits LicenseDataObject
public ref class LicenseAuthor : public LicenseDataObject

The LicenseAuthor type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseAuthor | Creates a new LicenseAuthor object.
Top
Properties
 | Name | Description
Public property | AuthorID | Gets or sets the Author ID.
Public property | CompanyName | Gets or sets the Author Company Name.
Public property | CustomData | Gets or sets the Author Custom Data, which contains custom XML or alphanumeric data.
Public property | SupportEmail | Gets or sets the Author Support Email Address.
Public property | SupportPhone | Gets or sets the Author Support Phone Number.
Public property | SupportSite | Gets or sets the Author Support Web Site Address.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

This object's data is available in the License class's Author property.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseAuthor Constructor

LicenseAuthor Constructor
Creates a new LicenseAuthor object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseAuthor()
Public Sub New
public:
LicenseAuthor()
See Also

Reference

LicenseAuthor Class
com.softwarekey.Client.Licensing Namespace


LicenseAuthor Properties

LicenseAuthor Properties

The LicenseAuthor type exposes the following members.

Properties
 | Name | Description
Public property | AuthorID | Gets or sets the Author ID.
Public property | CompanyName | Gets or sets the Author Company Name.
Public property | CustomData | Gets or sets the Author Custom Data, which contains custom XML or alphanumeric data.
Public property | SupportEmail | Gets or sets the Author Support Email Address.
Public property | SupportPhone | Gets or sets the Author Support Phone Number.
Public property | SupportSite | Gets or sets the Author Support Web Site Address.
Top
See Also

Reference

LicenseAuthor Class
com.softwarekey.Client.Licensing Namespace


LicenseAuthor.AuthorID Property

LicenseAuthorAuthorID Property
Gets or sets the Author ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int AuthorID { get; set; }
Public Property AuthorID As Integer
    Get
    Set
public:
property int AuthorID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LicenseAuthor Class
com.softwarekey.Client.Licensing Namespace


LicenseAuthor.CompanyName Property

LicenseAuthorCompanyName Property
Gets or sets the Author Company Name.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CompanyName { get; set; }
Public Property CompanyName As String
    Get
    Set
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseAuthor Class
com.softwarekey.Client.Licensing Namespace


LicenseAuthor.CustomData Property

LicenseAuthorCustomData Property
Gets or sets the Author Custom Data, which contains custom XML or alphanumeric data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CustomData { get; set; }
Public Property CustomData As String
    Get
    Set
public:
property String^ CustomData {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseAuthor Class
com.softwarekey.Client.Licensing Namespace


LicenseAuthor.SupportEmail Property

LicenseAuthorSupportEmail Property
Gets or sets the Author Support Email Address.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SupportEmail { get; set; }
Public Property SupportEmail As String
    Get
    Set
public:
property String^ SupportEmail {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseAuthor Class
com.softwarekey.Client.Licensing Namespace


LicenseAuthor.SupportPhone Property

LicenseAuthorSupportPhone Property
Gets or sets the Author Support Phone Number.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SupportPhone { get; set; }
Public Property SupportPhone As String
    Get
    Set
public:
property String^ SupportPhone {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseAuthor Class
com.softwarekey.Client.Licensing Namespace


LicenseAuthor.SupportSite Property

LicenseAuthorSupportSite Property
Gets or sets the Author Support Web Site Address.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SupportSite { get; set; }
Public Property SupportSite As String
    Get
    Set
public:
property String^ SupportSite {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseAuthor Class
com.softwarekey.Client.Licensing Namespace


LicenseAuthor Methods

LicenseAuthor Methods

The LicenseAuthor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LicenseAuthor Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer Class

LicenseCustomer Class
Contains data about the SOLO Server Customer to which the license belongs.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseDataObject
com.softwarekey.Client.LicensingLicenseCustomer

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseCustomer : LicenseDataObject
Public Class LicenseCustomer
    Inherits LicenseDataObject
public ref class LicenseCustomer : public LicenseDataObject

The LicenseCustomer type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseCustomer | Creates a new LicenseCustomer object.
Top
Properties
 | Name | Description
Public property | Address1 | Gets or sets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets or sets the customer's second address line (i.e. apartment or suite number).
Public property | City | Gets or sets the city of the customer's address.
Public property | CompanyName | Gets or sets the customer's company name.
Public property | Country | Gets or sets the country of the customer's address.
Public property | CustomerID | Gets or sets the unique Customer ID (typically issued by SOLO Server) for this customer.
Public property | Email | Gets or sets the customer's email address.
Public property | ExcludeFromAll | Gets or sets whether or not the customer has opted to be excluded from all marketing and product communications.
Public property | Fax | Gets or sets the customer's fax number.
Public property | FirstName | Gets or sets the customer's first name.
Public property | LastName | Gets or sets the customer's last name.
Public property | NotifyPartners | Gets or sets whether the customer will receive email alerts from trusted partners.
Public property | NotifyProducts | Gets or sets whether the customer will receive email alerts for products updates.
Public property | Phone | Gets or sets the customer's phone number.
Public property | PostalCode | Gets or sets the customer's zip/postal code.
Public property | StateProvince | Gets or sets the state/province of the customer's address.
Public property | Unregistered | Gets or sets whether or not the customer is unregistered.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

This object's data is available in the License class's Customer property.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseCustomer Constructor

LicenseCustomer Constructor
Creates a new LicenseCustomer object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseCustomer()
Public Sub New
public:
LicenseCustomer()
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer Properties

LicenseCustomer Properties

The LicenseCustomer type exposes the following members.

Properties
 | Name | Description
Public property | Address1 | Gets or sets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets or sets the customer's second address line (i.e. apartment or suite number).
Public property | City | Gets or sets the city of the customer's address.
Public property | CompanyName | Gets or sets the customer's company name.
Public property | Country | Gets or sets the country of the customer's address.
Public property | CustomerID | Gets or sets the unique Customer ID (typically issued by SOLO Server) for this customer.
Public property | Email | Gets or sets the customer's email address.
Public property | ExcludeFromAll | Gets or sets whether or not the customer has opted to be excluded from all marketing and product communications.
Public property | Fax | Gets or sets the customer's fax number.
Public property | FirstName | Gets or sets the customer's first name.
Public property | LastName | Gets or sets the customer's last name.
Public property | NotifyPartners | Gets or sets whether the customer will receive email alerts from trusted partners.
Public property | NotifyProducts | Gets or sets whether the customer will receive email alerts for products updates.
Public property | Phone | Gets or sets the customer's phone number.
Public property | PostalCode | Gets or sets the customer's zip/postal code.
Public property | StateProvince | Gets or sets the state/province of the customer's address.
Public property | Unregistered | Gets or sets whether or not the customer is unregistered.
Top
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.Address1 Property

LicenseCustomerAddress1 Property
Gets or sets the customer's street address (or line 1 of the customer's address).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.Address2 Property

LicenseCustomerAddress2 Property
Gets or sets the customer's second address line (i.e. apartment or suite number).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address2 { get; set; }
Public Property Address2 As String
    Get
    Set
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.City Property

LicenseCustomerCity Property
Gets or sets the city of the customer's address.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string City { get; set; }
Public Property City As String
    Get
    Set
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.CompanyName Property

LicenseCustomerCompanyName Property
Gets or sets the customer's company name.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CompanyName { get; set; }
Public Property CompanyName As String
    Get
    Set
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.Country Property

LicenseCustomerCountry Property
Gets or sets the country of the customer's address.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.CustomerID Property

LicenseCustomerCustomerID Property
Gets or sets the unique Customer ID (typically issued by SOLO Server) for this customer.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int CustomerID { get; set; }
Public Property CustomerID As Integer
    Get
    Set
public:
property int CustomerID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.Email Property

LicenseCustomerEmail Property
Gets or sets the customer's email address.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.ExcludeFromAll Property

LicenseCustomerExcludeFromAll Property
Gets or sets whether or not the customer has opted to be excluded from all marketing and product communications.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool ExcludeFromAll { get; set; }
Public Property ExcludeFromAll As Boolean
    Get
    Set
public:
property bool ExcludeFromAll {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.Fax Property

LicenseCustomerFax Property
Gets or sets the customer's fax number.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Fax { get; set; }
Public Property Fax As String
    Get
    Set
public:
property String^ Fax {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.FirstName Property

LicenseCustomerFirstName Property
Gets or sets the customer's first name.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string FirstName { get; set; }
Public Property FirstName As String
    Get
    Set
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.LastName Property

LicenseCustomerLastName Property
Gets or sets the customer's last name.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LastName { get; set; }
Public Property LastName As String
    Get
    Set
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.NotifyPartners Property

LicenseCustomerNotifyPartners Property
Gets or sets whether the customer will receive email alerts from trusted partners.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool NotifyPartners { get; set; }
Public Property NotifyPartners As Boolean
    Get
    Set
public:
property bool NotifyPartners {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.NotifyProducts Property

LicenseCustomerNotifyProducts Property
Gets or sets whether the customer will receive email alerts for products updates.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool NotifyProducts { get; set; }
Public Property NotifyProducts As Boolean
    Get
    Set
public:
property bool NotifyProducts {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.Phone Property

LicenseCustomerPhone Property
Gets or sets the customer's phone number.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Phone { get; set; }
Public Property Phone As String
    Get
    Set
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.PostalCode Property

LicenseCustomerPostalCode Property
Gets or sets the customer's zip/postal code.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.StateProvince Property

LicenseCustomerStateProvince Property
Gets or sets the state/province of the customer's address.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string StateProvince { get; set; }
Public Property StateProvince As String
    Get
    Set
public:
property String^ StateProvince {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer.Unregistered Property

LicenseCustomerUnregistered Property
Gets or sets whether or not the customer is unregistered.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool Unregistered { get; set; }
Public Property Unregistered As Boolean
    Get
    Set
public:
property bool Unregistered {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseCustomer Methods

LicenseCustomer Methods

The LicenseCustomer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LicenseCustomer Class
com.softwarekey.Client.Licensing Namespace


LicenseDataObject Class

LicenseDataObject Class
Abstract class used for implement objects which hold supplemental license data.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseDataObject
com.softwarekey.Client.LicensingLicenseAuthor
com.softwarekey.Client.LicensingLicenseCustomer
com.softwarekey.Client.LicensingLicenseDistributor
com.softwarekey.Client.LicensingLicenseProduct
com.softwarekey.Client.LicensingLicenseProductOption

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class LicenseDataObject
Public MustInherit Class LicenseDataObject
public ref class LicenseDataObject abstract

The LicenseDataObject type exposes the following members.

Constructors
 | Name | Description
Protected method | LicenseDataObject | Initializes a new instance of the LicenseDataObject class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

This class is used to implement a variety of license data objects, including:

  • LicenseAuthor
  • LicenseCustomer
  • LicenseDistributor
  • LicenseProduct
  • LicenseProductOption
See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseDataObject Constructor

LicenseDataObject Constructor
Initializes a new instance of the LicenseDataObject class

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected LicenseDataObject()
Protected Sub New
protected:
LicenseDataObject()
See Also

Reference

LicenseDataObject Class
com.softwarekey.Client.Licensing Namespace


LicenseDataObject Methods

LicenseDataObject Methods

The LicenseDataObject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LicenseDataObject Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor Class

LicenseDistributor Class
Contains data about the SOLO Server Distributor with which the license is associated.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseDataObject
com.softwarekey.Client.LicensingLicenseDistributor

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseDistributor : LicenseDataObject
Public Class LicenseDistributor
    Inherits LicenseDataObject
public ref class LicenseDistributor : public LicenseDataObject

The LicenseDistributor type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseDistributor | Creates a new LicenseDistributor object.
Top
Properties
 | Name | Description
Public property | Address1 | Gets or sets the distributor's address (line 1).
Public property | Address2 | Gets or sets the distributor's address (line 2).
Public property | Address3 | Gets or sets the distributor's address (line 3).
Public property | CompanyName | Gets or sets the distributor's company name.
Public property | Country | Gets or sets the country where the distributor is located.
Public property | DistributorID | Gets or sets the distributor's unique ID.
Public property | Email | Gets or sets the distributor's email address.
Public property | Phone | Gets or sets the distributor's phone number.
Public property | Type | Gets or sets the type of distributor.
Public property | WebSite | Gets or sets the distributor's web site.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

This object's data is available in the License class's Distributor property.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseDistributor Constructor

LicenseDistributor Constructor
Creates a new LicenseDistributor object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseDistributor()
Public Sub New
public:
LicenseDistributor()
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor Properties

LicenseDistributor Properties

The LicenseDistributor type exposes the following members.

Properties
 | Name | Description
Public property | Address1 | Gets or sets the distributor's address (line 1).
Public property | Address2 | Gets or sets the distributor's address (line 2).
Public property | Address3 | Gets or sets the distributor's address (line 3).
Public property | CompanyName | Gets or sets the distributor's company name.
Public property | Country | Gets or sets the country where the distributor is located.
Public property | DistributorID | Gets or sets the distributor's unique ID.
Public property | Email | Gets or sets the distributor's email address.
Public property | Phone | Gets or sets the distributor's phone number.
Public property | Type | Gets or sets the type of distributor.
Public property | WebSite | Gets or sets the distributor's web site.
Top
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor.Address1 Property

LicenseDistributorAddress1 Property
Gets or sets the distributor's address (line 1).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor.Address2 Property

LicenseDistributorAddress2 Property
Gets or sets the distributor's address (line 2).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address2 { get; set; }
Public Property Address2 As String
    Get
    Set
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor.Address3 Property

LicenseDistributorAddress3 Property
Gets or sets the distributor's address (line 3).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address3 { get; set; }
Public Property Address3 As String
    Get
    Set
public:
property String^ Address3 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor.CompanyName Property

LicenseDistributorCompanyName Property
Gets or sets the distributor's company name.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CompanyName { get; set; }
Public Property CompanyName As String
    Get
    Set
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor.Country Property

LicenseDistributorCountry Property
Gets or sets the country where the distributor is located.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor.DistributorID Property

LicenseDistributorDistributorID Property
Gets or sets the distributor's unique ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int DistributorID { get; set; }
Public Property DistributorID As Integer
    Get
    Set
public:
property int DistributorID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor.Email Property

LicenseDistributorEmail Property
Gets or sets the distributor's email address.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor.Phone Property

LicenseDistributorPhone Property
Gets or sets the distributor's phone number.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Phone { get; set; }
Public Property Phone As String
    Get
    Set
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor.Type Property

LicenseDistributorType Property
Gets or sets the type of distributor.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor.WebSite Property

LicenseDistributorWebSite Property
Gets or sets the distributor's web site.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string WebSite { get; set; }
Public Property WebSite As String
    Get
    Set
public:
property String^ WebSite {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseDistributor Methods

LicenseDistributor Methods

The LicenseDistributor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LicenseDistributor Class
com.softwarekey.Client.Licensing Namespace


LicenseEffectiveDateValidation Class

LicenseEffectiveDateValidation Class
Validates a time-limited license to verify it is within the effective date/time period.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
com.softwarekey.Client.LicensingLicenseEffectiveDateValidation

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseEffectiveDateValidation : SystemValidation
Public Class LicenseEffectiveDateValidation
    Inherits SystemValidation
public ref class LicenseEffectiveDateValidation : public SystemValidation

The LicenseEffectiveDateValidation type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseEffectiveDateValidation | Creates a new LicenseEffectiveDateValidation object.
Top
Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates the license's effective dates. (Overrides SystemValidationValidate.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseEffectiveDateValidation Constructor

LicenseEffectiveDateValidation Constructor
Creates a new LicenseEffectiveDateValidation object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseEffectiveDateValidation(
    License license
)
Public Sub New (
    license As License
)
public:
LicenseEffectiveDateValidation(
    License^ license
)

Parameters

license
Type: com.softwarekey.Client.LicensingLicense
The License to validate.
See Also

Reference

LicenseEffectiveDateValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseEffectiveDateValidation Properties

LicenseEffectiveDateValidation Properties

The LicenseEffectiveDateValidation type exposes the following members.

Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Top
See Also

Reference

LicenseEffectiveDateValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseEffectiveDateValidation Methods

LicenseEffectiveDateValidation Methods

The LicenseEffectiveDateValidation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates the license's effective dates. (Overrides SystemValidationValidate.)
Top
See Also

Reference

LicenseEffectiveDateValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseEffectiveDateValidation.Validate Method

LicenseEffectiveDateValidationValidate Method
Validates the license's effective dates.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Validate()
Public Overrides Function Validate As Boolean
public:
virtual bool Validate() override

Return Value

Type: Boolean
Returns true if the time-limited license is within the effective date/time period. If false is returned, check the LastError property for details.
See Also

Reference

LicenseEffectiveDateValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseError Class

LicenseError Class
Class used for licensing errors, which may occur in a variety of operations performed by this library.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseError

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseError
Public Class LicenseError
public ref class LicenseError

The LicenseError type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseError | Creates a new LicenseError object.
Public method | LicenseError(Int32) | Creates a new LicenseError object with the specified error.
Public method | LicenseError(Int32, Exception) | Creates a new LicenseError object with a given error number and exception
Public method | LicenseError(Int32, Int32) | Creates a new LicenseError object with a specified error and extended error
Public method | LicenseError(Int32, Int32, Exception) | Creates a new LicenseError object with a given error number, extended error number, and exception
Top
Properties
 | Name | Description
Public property | ErrorException | The Exception associated with the error (may be null).
Public property | ErrorNumber | The error number/code.
Public property | ErrorString | The human-readable description of the error.
Public property | ExtendedErrorNumber | The extended error number/code. This may be returned by an external source, such as a SOLO Server web service.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | GetWebServiceErrorMessage(Int32) | Gets a friendly web service error message for display.
 | GetWebServiceErrorMessage(LicenseError) | Gets a friendly web service error message for display.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Gets a human-readable description of the error (exactly the same as the value given by the ErrorString property). (Overrides ObjectToString.)
Top
Fields
Name | Description
ERROR_CONTEXT_INVALID | Error number for when the API context is invalid.
ERROR_COULD_NOT_DELETE_FILE | Error number for when an attempt to delete a license file failed.
ERROR_COULD_NOT_LOAD_LICENSE | Error number for when an attempt to load a license file failed.
ERROR_COULD_NOT_LOAD_VOLUME_DOWNLOADABLE_LICENSE | Error number for when an attempt to load a volume or downloadable license file failed.
ERROR_COULD_NOT_OPEN_FILE | Error number for when an attempt to open a file failed.
ERROR_COULD_NOT_OPEN_REGISTRY_KEY | Error number for when an attempt to open a registry key failed.
ERROR_COULD_NOT_READ_FILE | Error number for when an attempt to read a file failed.
ERROR_COULD_NOT_READ_PERMISSIONS | Error number for when an attempt to read a file or registry key's permissions failed.
ERROR_COULD_NOT_READ_REGISTRY_KEY | Error number for when an attempt to read a registry key value failed.
ERROR_COULD_NOT_SAVE_LICENSE | Error number for when an attempt to save a new license file failed.
ERROR_COULD_NOT_SAVE_NETWORK_CERTIFICATE | Error number for when an attempt to save a NetworkSessionCertificate file failed.
ERROR_COULD_NOT_SET_PERMISSIONS | Error number for when an attempt to set a file or registry key's permissions failed.
ERROR_COULD_NOT_WRITE_FILE | Error number for when an attempt to write a file failed.
ERROR_COULD_NOT_WRITE_REGISTRY_KEY | Error number for when an attempt to write a registry key value failed.
ERROR_DATETIME_CONVERSION_FAILED | Error number for when a date-time conversion operation fails.
ERROR_DECRYPTION_FAILED | Error number for when decrypting a document fails.
ERROR_ENCRYPTION_FAILED | Error number for when encrypting a document fails.
ERROR_ENVELOPE_TYPE_INVALID | The envelope is not valid or not for application use.
ERROR_HTTP_CONNECTION_FAILED | Error number for when an HTTP connection fails.
ERROR_HTTP_COULD_NOT_RESOLVE_HOST | Error number for when the specified host could not be resolved.
ERROR_HTTP_INITIALIZATION_FAILED | Error number for when the HTTP client fails to initialize.
ERROR_INSTALLATIONID_REQUIRED | An Installation ID is required, but not present.
ERROR_INSUFFICIENT_IMAGE_SIZE | The license image is either too small to hold the license data or is under the minimum image size required.
ERROR_INVALID_ARGUMENTS | Error number for when some or all of the function arguments are invalid.
ERROR_INVALID_CLIENT_KEY | Error number for when an invalid client key is provided.
ERROR_INVALID_DATA | Error number for when invalid data is provided.
ERROR_INVALID_IMAGE | The license image is not valid.
ERROR_INVALID_LICENSE_TYPE | Error number for when a license type is invalid or not supported.
ERROR_INVALID_PRODUCTID | The Product ID authorized in the license is invalid or not for this application.
ERROR_INVALID_PRODUCTOPTIONID | The Product Option ID authorized in the license is invalid or not for this application.
ERROR_INVALID_SERVER_KEY | Error number for when an invalid server key is provided.
ERROR_IO_OPERATION_FAILED | Error number when an attempt to perform an I/O operation failed.
ERROR_LIBRARY_FUNCTION_UNAVAILABLE | Error number for when a required library function is missing.
ERROR_LIBRARY_UNAVAILABLE | Error number for when a required system library is missing for failed to load.
ERROR_LICENSE_ALIAS_VALIDATION_FAILED | Error number for when an alias's LastUpdated date could not be validated.
ERROR_LICENSE_ALIAS_VALIDATION_TIME_MISMATCH | Error number for when an alias has a LastUpdated date in the future.
ERROR_LICENSE_EXPIRED | Error number for when the license is expired.
ERROR_LICENSE_NOT_EFFECTIVE_YET | Error number for when the license is not effective yet.
ERROR_LICENSE_SYSTEM_IDENTIFIERS_DONT_MATCH | Error number for when system identifiers do not match.
ERROR_MEMORY_ALLOCATION | Error number for when an attempt to allocate memory fails.
ERROR_MODULE_NOT_ACTIVE | Error number for when use of the application or module is not permitted.
ERROR_NETWORK_CERTIFICATE_INVALID_PATH | Error number for when a NetworkSessionCertificate file's path is invalid.
ERROR_NETWORK_CERTIFICATE_REQUIRED | Error number for when a NetworkSessionCertificate is not present, but is required.
ERROR_NETWORK_LICENSE_FULL | Error number for when the number of allowed concurrent users has been reached.
ERROR_NETWORK_SEMAPHORE_INVALID_PATH | Error number for when a NetworkSemaphore file's path is invalid.
ERROR_NETWORK_SEMAPHORE_LOCK_FAILED | Error number for when network semaphore file creation fails.
ERROR_NONE | Error number for when there is no error.
ERROR_PLATFORM_ERROR | Error number for when a platform specific API or system call fails.
ERROR_PLUS_EVALUATION_INVALID | The Protection PLUS 5 SDK evaluation is invalid or expired.
ERROR_PLUS_EVALUATION_WARNING | No error actually occurred, but that an evaluation envelope is being used.
ERROR_REMOTE_SESSION_DETECTED | Error number for when a remote session is detected.
ERROR_REQUIRED_SERVER_VALIDATION_FAILED | Error number for when a any kind of validation against SOLO Server is required, but could not be completed.
ERROR_SESSION_VERIFICATION_FAILED | Error number for when session code verification fails.
ERROR_SIGNING_FAILED | Error number for when signing a document fails.
ERROR_SSL_CERTIFICATE_EXPORT_FAILED | Error number for when an attempt to export the SSL certificate bundle failed.
ERROR_SSL_CERTIFICATE_UNAVAILABLE | Error number for when an HTTPS request fails due to a problem with the certificate bundle.
ERROR_SSL_FAILED | Error number for when an HTTPS request fails due to an SSL related problem.
ERROR_STRING_CONVERSION_FAILED | Error number for when a string conversion operation fails.
ERROR_SYSTEM_TIME_INVALID | Error number for when the system time is invalid.
ERROR_SYSTEM_TIME_VERIFICATION_FAILED | Error number for when system time verification failed.
ERROR_TRIGGER_CODE_EVENT_DATA_INVALID | Error number for when an invalid "Activation Code 2" value is entered by the user.
ERROR_TRIGGER_CODE_INVALID | Error number for when an invalid "Activation Code 1" value is entered by the user.
ERROR_UNSUPPORTED_OS | Error number for when an attempt to perform an unsupported operation occurs.
ERROR_VERIFICATION_FAILED | Error number for when verifying the signature of a document fails.
ERROR_VIRTUAL_MACHINE_DETECTED | Error number for when a virtual machine is detected.
ERROR_WEBSERVICE_CALL_FAILED | Error number for when a web service call failed.
ERROR_WEBSERVICE_INVALID_CONFIGURATION | Error number for when an invalid web service configuration is provided.
ERROR_WEBSERVICE_RETURNED_FAILURE | Error number for when a web service call returned an error.
ERROR_XML_NODE_MISSING | Error number for when the specified node is not present in the document.
ERROR_XML_PARSER_FAILED | Error number for when the XML parser fails.
Top
Remarks

Throughout the PLUSManaged library, a common paradigm in its objects is to return a Boolean value to indicate success (true) or some kind of failure (false). When a failure is indicated, a LicenseError object may typically be referenced (through a "LastError" property) to obtain more details on the failure. The type of failure can be uniquely identified via the ErrorNumber property, and the description of this error is available through the ErrorString property. Additionally, when the failure occurs within this library and involves an Exception, the ErrorException property contains the Exception object.

When the operation which generated a failure is processed through a system outside of this library (such as a a call to a SOLO Server web service method), the ExtendedErrorNumber property is populated with that system's error number or result code. In the case of a call to SOLO Server web service methods, the GetWebServiceErrorMessage(Int32) method may be used to retrieve a description of the error.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseError Constructor

LicenseError Constructor
Overload List
 | Name | Description
Public method | LicenseError | Creates a new LicenseError object.
Public method | LicenseError(Int32) | Creates a new LicenseError object with the specified error.
Public method | LicenseError(Int32, Exception) | Creates a new LicenseError object with a given error number and exception
Public method | LicenseError(Int32, Int32) | Creates a new LicenseError object with a specified error and extended error
Public method | LicenseError(Int32, Int32, Exception) | Creates a new LicenseError object with a given error number, extended error number, and exception
Top
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError Constructor

LicenseError Constructor
Creates a new LicenseError object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError()
Public Sub New
public:
LicenseError()
See Also

Reference

LicenseError Class
LicenseError Overload
com.softwarekey.Client.Licensing Namespace


LicenseError Constructor (Int32)

LicenseError Constructor (Int32)
Creates a new LicenseError object with the specified error.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError(
    int e
)
Public Sub New (
    e As Integer
)
public:
LicenseError(
    int e
)

Parameters

e
Type: SystemInt32
The error number/code.
See Also

Reference

LicenseError Class
LicenseError Overload
com.softwarekey.Client.Licensing Namespace


LicenseError Constructor (Int32, Exception)

LicenseError Constructor (Int32, Exception)
Creates a new LicenseError object with a given error number and exception

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError(
    int e,
    Exception ex
)
Public Sub New (
    e As Integer,
    ex As Exception
)
public:
LicenseError(
    int e,
    Exception^ ex
)

Parameters

e
Type: SystemInt32
The error number/code.
ex
Type: SystemException
The Exception associated with the error.
See Also

Reference

LicenseError Class
LicenseError Overload
com.softwarekey.Client.Licensing Namespace


LicenseError Constructor (Int32, Int32)

LicenseError Constructor (Int32, Int32)
Creates a new LicenseError object with a specified error and extended error

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError(
    int e,
    int ee
)
Public Sub New (
    e As Integer,
    ee As Integer
)
public:
LicenseError(
    int e,
    int ee
)

Parameters

e
Type: SystemInt32
The error number/code.
ee
Type: SystemInt32
The extended error number/code, which originated from a source other than PLUSManaged.
See Also

Reference

LicenseError Class
LicenseError Overload
com.softwarekey.Client.Licensing Namespace


LicenseError Constructor (Int32, Int32, Exception)

LicenseError Constructor (Int32, Int32, Exception)
Creates a new LicenseError object with a given error number, extended error number, and exception

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError(
    int e,
    int ee,
    Exception ex
)
Public Sub New (
    e As Integer,
    ee As Integer,
    ex As Exception
)
public:
LicenseError(
    int e,
    int ee,
    Exception^ ex
)

Parameters

e
Type: SystemInt32
The error number/code.
ee
Type: SystemInt32
The extended error number/code, which originated from a source other than PLUSManaged.
ex
Type: SystemException
The Exception associated with the error.
See Also

Reference

LicenseError Class
LicenseError Overload
com.softwarekey.Client.Licensing Namespace


LicenseError Properties

LicenseError Properties

The LicenseError type exposes the following members.

Properties
 | Name | Description
Public property | ErrorException | The Exception associated with the error (may be null).
Public property | ErrorNumber | The error number/code.
Public property | ErrorString | The human-readable description of the error.
Public property | ExtendedErrorNumber | The extended error number/code. This may be returned by an external source, such as a SOLO Server web service.
Top
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ErrorException Property

LicenseErrorErrorException Property
The Exception associated with the error (may be null).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Exception ErrorException { get; }
Public ReadOnly Property ErrorException As Exception
    Get
public:
property Exception^ ErrorException {
    Exception^ get ();
}

Property Value

Type: Exception
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ErrorNumber Property

LicenseErrorErrorNumber Property
The error number/code.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ErrorNumber { get; }
Public ReadOnly Property ErrorNumber As Integer
    Get
public:
property int ErrorNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ErrorString Property

LicenseErrorErrorString Property
The human-readable description of the error.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ErrorString { get; }
Public ReadOnly Property ErrorString As String
    Get
public:
property String^ ErrorString {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ExtendedErrorNumber Property

LicenseErrorExtendedErrorNumber Property
The extended error number/code. This may be returned by an external source, such as a SOLO Server web service.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ExtendedErrorNumber { get; }
Public ReadOnly Property ExtendedErrorNumber As Integer
    Get
public:
property int ExtendedErrorNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError Methods

LicenseError Methods

The LicenseError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | GetWebServiceErrorMessage(Int32) | Gets a friendly web service error message for display.
 | GetWebServiceErrorMessage(LicenseError) | Gets a friendly web service error message for display.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Gets a human-readable description of the error (exactly the same as the value given by the ErrorString property). (Overrides ObjectToString.)
Top
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.GetWebServiceErrorMessage Method

LicenseErrorGetWebServiceErrorMessage Method
Overload List
Name | Description
GetWebServiceErrorMessage(Int32) | Gets a friendly web service error message for display.
GetWebServiceErrorMessage(LicenseError) | Gets a friendly web service error message for display.
Top
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.GetWebServiceErrorMessage Method (Int32)

LicenseErrorGetWebServiceErrorMessage Method (Int32)
Gets a friendly web service error message for display.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static string GetWebServiceErrorMessage(
    int extendedErrorCode
)
Public Shared Function GetWebServiceErrorMessage (
    extendedErrorCode As Integer
) As String
public:
static String^ GetWebServiceErrorMessage(
    int extendedErrorCode
)

Parameters

extendedErrorCode
Type: SystemInt32
The Web Service Error/Result Code received.

Return Value

Type: String
Returns a human-readable web service error description.
See Also

Reference

LicenseError Class
GetWebServiceErrorMessage Overload
com.softwarekey.Client.Licensing Namespace


LicenseError.GetWebServiceErrorMessage Method (LicenseError)

LicenseErrorGetWebServiceErrorMessage Method (LicenseError)
Gets a friendly web service error message for display.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static string GetWebServiceErrorMessage(
    LicenseError lastError
)
Public Shared Function GetWebServiceErrorMessage (
    lastError As LicenseError
) As String
public:
static String^ GetWebServiceErrorMessage(
    LicenseError^ lastError
)

Parameters

lastError
Type: com.softwarekey.Client.LicensingLicenseError
The LicenseError object which contains the error received.

Return Value

Type: String
Returns a human-readable web service error description.
See Also

Reference

LicenseError Class
GetWebServiceErrorMessage Overload
com.softwarekey.Client.Licensing Namespace


LicenseError.ToString Method

LicenseErrorToString Method
Gets a human-readable description of the error (exactly the same as the value given by the ErrorString property).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
Returns the human-readable description of the error (exactly the same as the value given by the ErrorString property).
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError Fields

LicenseError Fields

The LicenseError type exposes the following members.

Fields
Name | Description
ERROR_CONTEXT_INVALID | Error number for when the API context is invalid.
ERROR_COULD_NOT_DELETE_FILE | Error number for when an attempt to delete a license file failed.
ERROR_COULD_NOT_LOAD_LICENSE | Error number for when an attempt to load a license file failed.
ERROR_COULD_NOT_LOAD_VOLUME_DOWNLOADABLE_LICENSE | Error number for when an attempt to load a volume or downloadable license file failed.
ERROR_COULD_NOT_OPEN_FILE | Error number for when an attempt to open a file failed.
ERROR_COULD_NOT_OPEN_REGISTRY_KEY | Error number for when an attempt to open a registry key failed.
ERROR_COULD_NOT_READ_FILE | Error number for when an attempt to read a file failed.
ERROR_COULD_NOT_READ_PERMISSIONS | Error number for when an attempt to read a file or registry key's permissions failed.
ERROR_COULD_NOT_READ_REGISTRY_KEY | Error number for when an attempt to read a registry key value failed.
ERROR_COULD_NOT_SAVE_LICENSE | Error number for when an attempt to save a new license file failed.
ERROR_COULD_NOT_SAVE_NETWORK_CERTIFICATE | Error number for when an attempt to save a NetworkSessionCertificate file failed.
ERROR_COULD_NOT_SET_PERMISSIONS | Error number for when an attempt to set a file or registry key's permissions failed.
ERROR_COULD_NOT_WRITE_FILE | Error number for when an attempt to write a file failed.
ERROR_COULD_NOT_WRITE_REGISTRY_KEY | Error number for when an attempt to write a registry key value failed.
ERROR_DATETIME_CONVERSION_FAILED | Error number for when a date-time conversion operation fails.
ERROR_DECRYPTION_FAILED | Error number for when decrypting a document fails.
ERROR_ENCRYPTION_FAILED | Error number for when encrypting a document fails.
ERROR_ENVELOPE_TYPE_INVALID | The envelope is not valid or not for application use.
ERROR_HTTP_CONNECTION_FAILED | Error number for when an HTTP connection fails.
ERROR_HTTP_COULD_NOT_RESOLVE_HOST | Error number for when the specified host could not be resolved.
ERROR_HTTP_INITIALIZATION_FAILED | Error number for when the HTTP client fails to initialize.
ERROR_INSTALLATIONID_REQUIRED | An Installation ID is required, but not present.
ERROR_INSUFFICIENT_IMAGE_SIZE | The license image is either too small to hold the license data or is under the minimum image size required.
ERROR_INVALID_ARGUMENTS | Error number for when some or all of the function arguments are invalid.
ERROR_INVALID_CLIENT_KEY | Error number for when an invalid client key is provided.
ERROR_INVALID_DATA | Error number for when invalid data is provided.
ERROR_INVALID_IMAGE | The license image is not valid.
ERROR_INVALID_LICENSE_TYPE | Error number for when a license type is invalid or not supported.
ERROR_INVALID_PRODUCTID | The Product ID authorized in the license is invalid or not for this application.
ERROR_INVALID_PRODUCTOPTIONID | The Product Option ID authorized in the license is invalid or not for this application.
ERROR_INVALID_SERVER_KEY | Error number for when an invalid server key is provided.
ERROR_IO_OPERATION_FAILED | Error number when an attempt to perform an I/O operation failed.
ERROR_LIBRARY_FUNCTION_UNAVAILABLE | Error number for when a required library function is missing.
ERROR_LIBRARY_UNAVAILABLE | Error number for when a required system library is missing for failed to load.
ERROR_LICENSE_ALIAS_VALIDATION_FAILED | Error number for when an alias's LastUpdated date could not be validated.
ERROR_LICENSE_ALIAS_VALIDATION_TIME_MISMATCH | Error number for when an alias has a LastUpdated date in the future.
ERROR_LICENSE_EXPIRED | Error number for when the license is expired.
ERROR_LICENSE_NOT_EFFECTIVE_YET | Error number for when the license is not effective yet.
ERROR_LICENSE_SYSTEM_IDENTIFIERS_DONT_MATCH | Error number for when system identifiers do not match.
ERROR_MEMORY_ALLOCATION | Error number for when an attempt to allocate memory fails.
ERROR_MODULE_NOT_ACTIVE | Error number for when use of the application or module is not permitted.
ERROR_NETWORK_CERTIFICATE_INVALID_PATH | Error number for when a NetworkSessionCertificate file's path is invalid.
ERROR_NETWORK_CERTIFICATE_REQUIRED | Error number for when a NetworkSessionCertificate is not present, but is required.
ERROR_NETWORK_LICENSE_FULL | Error number for when the number of allowed concurrent users has been reached.
ERROR_NETWORK_SEMAPHORE_INVALID_PATH | Error number for when a NetworkSemaphore file's path is invalid.
ERROR_NETWORK_SEMAPHORE_LOCK_FAILED | Error number for when network semaphore file creation fails.
ERROR_NONE | Error number for when there is no error.
ERROR_PLATFORM_ERROR | Error number for when a platform specific API or system call fails.
ERROR_PLUS_EVALUATION_INVALID | The Protection PLUS 5 SDK evaluation is invalid or expired.
ERROR_PLUS_EVALUATION_WARNING | No error actually occurred, but that an evaluation envelope is being used.
ERROR_REMOTE_SESSION_DETECTED | Error number for when a remote session is detected.
ERROR_REQUIRED_SERVER_VALIDATION_FAILED | Error number for when a any kind of validation against SOLO Server is required, but could not be completed.
ERROR_SESSION_VERIFICATION_FAILED | Error number for when session code verification fails.
ERROR_SIGNING_FAILED | Error number for when signing a document fails.
ERROR_SSL_CERTIFICATE_EXPORT_FAILED | Error number for when an attempt to export the SSL certificate bundle failed.
ERROR_SSL_CERTIFICATE_UNAVAILABLE | Error number for when an HTTPS request fails due to a problem with the certificate bundle.
ERROR_SSL_FAILED | Error number for when an HTTPS request fails due to an SSL related problem.
ERROR_STRING_CONVERSION_FAILED | Error number for when a string conversion operation fails.
ERROR_SYSTEM_TIME_INVALID | Error number for when the system time is invalid.
ERROR_SYSTEM_TIME_VERIFICATION_FAILED | Error number for when system time verification failed.
ERROR_TRIGGER_CODE_EVENT_DATA_INVALID | Error number for when an invalid "Activation Code 2" value is entered by the user.
ERROR_TRIGGER_CODE_INVALID | Error number for when an invalid "Activation Code 1" value is entered by the user.
ERROR_UNSUPPORTED_OS | Error number for when an attempt to perform an unsupported operation occurs.
ERROR_VERIFICATION_FAILED | Error number for when verifying the signature of a document fails.
ERROR_VIRTUAL_MACHINE_DETECTED | Error number for when a virtual machine is detected.
ERROR_WEBSERVICE_CALL_FAILED | Error number for when a web service call failed.
ERROR_WEBSERVICE_INVALID_CONFIGURATION | Error number for when an invalid web service configuration is provided.
ERROR_WEBSERVICE_RETURNED_FAILURE | Error number for when a web service call returned an error.
ERROR_XML_NODE_MISSING | Error number for when the specified node is not present in the document.
ERROR_XML_PARSER_FAILED | Error number for when the XML parser fails.
Top
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_CONTEXT_INVALID Field

LicenseErrorERROR_CONTEXT_INVALID Field
Error number for when the API context is invalid.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_CONTEXT_INVALID = 9016
Public Const ERROR_CONTEXT_INVALID As Integer = 9016
public:
literal int ERROR_CONTEXT_INVALID = 9016

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_DELETE_FILE Field

LicenseErrorERROR_COULD_NOT_DELETE_FILE Field
Error number for when an attempt to delete a license file failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_DELETE_FILE = 9209
Public Const ERROR_COULD_NOT_DELETE_FILE As Integer = 9209
public:
literal int ERROR_COULD_NOT_DELETE_FILE = 9209

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_LOAD_LICENSE Field

LicenseErrorERROR_COULD_NOT_LOAD_LICENSE Field
Error number for when an attempt to load a license file failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_LOAD_LICENSE = 9200
Public Const ERROR_COULD_NOT_LOAD_LICENSE As Integer = 9200
public:
literal int ERROR_COULD_NOT_LOAD_LICENSE = 9200

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_LOAD_VOLUME_DOWNLOADABLE_LICENSE Field

LicenseErrorERROR_COULD_NOT_LOAD_VOLUME_DOWNLOADABLE_LICENSE Field
Error number for when an attempt to load a volume or downloadable license file failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_LOAD_VOLUME_DOWNLOADABLE_LICENSE = 9225
Public Const ERROR_COULD_NOT_LOAD_VOLUME_DOWNLOADABLE_LICENSE As Integer = 9225
public:
literal int ERROR_COULD_NOT_LOAD_VOLUME_DOWNLOADABLE_LICENSE = 9225

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_OPEN_FILE Field

LicenseErrorERROR_COULD_NOT_OPEN_FILE Field
Error number for when an attempt to open a file failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_OPEN_FILE = 9214
Public Const ERROR_COULD_NOT_OPEN_FILE As Integer = 9214
public:
literal int ERROR_COULD_NOT_OPEN_FILE = 9214

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_OPEN_REGISTRY_KEY Field

LicenseErrorERROR_COULD_NOT_OPEN_REGISTRY_KEY Field
Error number for when an attempt to open a registry key failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_OPEN_REGISTRY_KEY = 9217
Public Const ERROR_COULD_NOT_OPEN_REGISTRY_KEY As Integer = 9217
public:
literal int ERROR_COULD_NOT_OPEN_REGISTRY_KEY = 9217

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_READ_FILE Field

LicenseErrorERROR_COULD_NOT_READ_FILE Field
Error number for when an attempt to read a file failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_READ_FILE = 9215
Public Const ERROR_COULD_NOT_READ_FILE As Integer = 9215
public:
literal int ERROR_COULD_NOT_READ_FILE = 9215

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_READ_PERMISSIONS Field

LicenseErrorERROR_COULD_NOT_READ_PERMISSIONS Field
Error number for when an attempt to read a file or registry key's permissions failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_READ_PERMISSIONS = 9221
Public Const ERROR_COULD_NOT_READ_PERMISSIONS As Integer = 9221
public:
literal int ERROR_COULD_NOT_READ_PERMISSIONS = 9221

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_READ_REGISTRY_KEY Field

LicenseErrorERROR_COULD_NOT_READ_REGISTRY_KEY Field
Error number for when an attempt to read a registry key value failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_READ_REGISTRY_KEY = 9218
Public Const ERROR_COULD_NOT_READ_REGISTRY_KEY As Integer = 9218
public:
literal int ERROR_COULD_NOT_READ_REGISTRY_KEY = 9218

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_SAVE_LICENSE Field

LicenseErrorERROR_COULD_NOT_SAVE_LICENSE Field
Error number for when an attempt to save a new license file failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_SAVE_LICENSE = 9201
Public Const ERROR_COULD_NOT_SAVE_LICENSE As Integer = 9201
public:
literal int ERROR_COULD_NOT_SAVE_LICENSE = 9201

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_SAVE_NETWORK_CERTIFICATE Field

LicenseErrorERROR_COULD_NOT_SAVE_NETWORK_CERTIFICATE Field
Error number for when an attempt to save a NetworkSessionCertificate file failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_SAVE_NETWORK_CERTIFICATE = 9206
Public Const ERROR_COULD_NOT_SAVE_NETWORK_CERTIFICATE As Integer = 9206
public:
literal int ERROR_COULD_NOT_SAVE_NETWORK_CERTIFICATE = 9206

Field Value

Type: Int32
Remarks

Only used in PLUSManaged.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_SET_PERMISSIONS Field

LicenseErrorERROR_COULD_NOT_SET_PERMISSIONS Field
Error number for when an attempt to set a file or registry key's permissions failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_SET_PERMISSIONS = 9222
Public Const ERROR_COULD_NOT_SET_PERMISSIONS As Integer = 9222
public:
literal int ERROR_COULD_NOT_SET_PERMISSIONS = 9222

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_WRITE_FILE Field

LicenseErrorERROR_COULD_NOT_WRITE_FILE Field
Error number for when an attempt to write a file failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_WRITE_FILE = 9216
Public Const ERROR_COULD_NOT_WRITE_FILE As Integer = 9216
public:
literal int ERROR_COULD_NOT_WRITE_FILE = 9216

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_COULD_NOT_WRITE_REGISTRY_KEY Field

LicenseErrorERROR_COULD_NOT_WRITE_REGISTRY_KEY Field
Error number for when an attempt to write a registry key value failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_COULD_NOT_WRITE_REGISTRY_KEY = 9219
Public Const ERROR_COULD_NOT_WRITE_REGISTRY_KEY As Integer = 9219
public:
literal int ERROR_COULD_NOT_WRITE_REGISTRY_KEY = 9219

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_DATETIME_CONVERSION_FAILED Field

LicenseErrorERROR_DATETIME_CONVERSION_FAILED Field
Error number for when a date-time conversion operation fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_DATETIME_CONVERSION_FAILED = 9018
Public Const ERROR_DATETIME_CONVERSION_FAILED As Integer = 9018
public:
literal int ERROR_DATETIME_CONVERSION_FAILED = 9018

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_DECRYPTION_FAILED Field

LicenseErrorERROR_DECRYPTION_FAILED Field
Error number for when decrypting a document fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_DECRYPTION_FAILED = 9004
Public Const ERROR_DECRYPTION_FAILED As Integer = 9004
public:
literal int ERROR_DECRYPTION_FAILED = 9004

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_ENCRYPTION_FAILED Field

LicenseErrorERROR_ENCRYPTION_FAILED Field
Error number for when encrypting a document fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_ENCRYPTION_FAILED = 9006
Public Const ERROR_ENCRYPTION_FAILED As Integer = 9006
public:
literal int ERROR_ENCRYPTION_FAILED = 9006

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_ENVELOPE_TYPE_INVALID Field

LicenseErrorERROR_ENVELOPE_TYPE_INVALID Field
The envelope is not valid or not for application use.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_ENVELOPE_TYPE_INVALID = 9023
Public Const ERROR_ENVELOPE_TYPE_INVALID As Integer = 9023
public:
literal int ERROR_ENVELOPE_TYPE_INVALID = 9023

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_HTTP_CONNECTION_FAILED Field

LicenseErrorERROR_HTTP_CONNECTION_FAILED Field
Error number for when an HTTP connection fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_HTTP_CONNECTION_FAILED = 9105
Public Const ERROR_HTTP_CONNECTION_FAILED As Integer = 9105
public:
literal int ERROR_HTTP_CONNECTION_FAILED = 9105

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_HTTP_COULD_NOT_RESOLVE_HOST Field

LicenseErrorERROR_HTTP_COULD_NOT_RESOLVE_HOST Field
Error number for when the specified host could not be resolved.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_HTTP_COULD_NOT_RESOLVE_HOST = 9106
Public Const ERROR_HTTP_COULD_NOT_RESOLVE_HOST As Integer = 9106
public:
literal int ERROR_HTTP_COULD_NOT_RESOLVE_HOST = 9106

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_HTTP_INITIALIZATION_FAILED Field

LicenseErrorERROR_HTTP_INITIALIZATION_FAILED Field
Error number for when the HTTP client fails to initialize.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_HTTP_INITIALIZATION_FAILED = 9104
Public Const ERROR_HTTP_INITIALIZATION_FAILED As Integer = 9104
public:
literal int ERROR_HTTP_INITIALIZATION_FAILED = 9104

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_INSTALLATIONID_REQUIRED Field

LicenseErrorERROR_INSTALLATIONID_REQUIRED Field
An Installation ID is required, but not present.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_INSTALLATIONID_REQUIRED = 9009
Public Const ERROR_INSTALLATIONID_REQUIRED As Integer = 9009
public:
literal int ERROR_INSTALLATIONID_REQUIRED = 9009

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_INSUFFICIENT_IMAGE_SIZE Field

LicenseErrorERROR_INSUFFICIENT_IMAGE_SIZE Field
The license image is either too small to hold the license data or is under the minimum image size required.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_INSUFFICIENT_IMAGE_SIZE = 9024
Public Const ERROR_INSUFFICIENT_IMAGE_SIZE As Integer = 9024
public:
literal int ERROR_INSUFFICIENT_IMAGE_SIZE = 9024

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_INVALID_ARGUMENTS Field

LicenseErrorERROR_INVALID_ARGUMENTS Field
Error number for when some or all of the function arguments are invalid.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_INVALID_ARGUMENTS = 9015
Public Const ERROR_INVALID_ARGUMENTS As Integer = 9015
public:
literal int ERROR_INVALID_ARGUMENTS = 9015

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_INVALID_CLIENT_KEY Field

LicenseErrorERROR_INVALID_CLIENT_KEY Field
Error number for when an invalid client key is provided.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_INVALID_CLIENT_KEY = 9003
Public Const ERROR_INVALID_CLIENT_KEY As Integer = 9003
public:
literal int ERROR_INVALID_CLIENT_KEY = 9003

Field Value

Type: Int32
Remarks

Only used in PLUSManaged.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_INVALID_DATA Field

LicenseErrorERROR_INVALID_DATA Field
Error number for when invalid data is provided.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_INVALID_DATA = 9001
Public Const ERROR_INVALID_DATA As Integer = 9001
public:
literal int ERROR_INVALID_DATA = 9001

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_INVALID_IMAGE Field

LicenseErrorERROR_INVALID_IMAGE Field
The license image is not valid.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_INVALID_IMAGE = 9025
Public Const ERROR_INVALID_IMAGE As Integer = 9025
public:
literal int ERROR_INVALID_IMAGE = 9025

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_INVALID_LICENSE_TYPE Field

LicenseErrorERROR_INVALID_LICENSE_TYPE Field
Error number for when a license type is invalid or not supported.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_INVALID_LICENSE_TYPE = 9012
Public Const ERROR_INVALID_LICENSE_TYPE As Integer = 9012
public:
literal int ERROR_INVALID_LICENSE_TYPE = 9012

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_INVALID_PRODUCTID Field

LicenseErrorERROR_INVALID_PRODUCTID Field
The Product ID authorized in the license is invalid or not for this application.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_INVALID_PRODUCTID = 9021
Public Const ERROR_INVALID_PRODUCTID As Integer = 9021
public:
literal int ERROR_INVALID_PRODUCTID = 9021

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_INVALID_PRODUCTOPTIONID Field

LicenseErrorERROR_INVALID_PRODUCTOPTIONID Field
The Product Option ID authorized in the license is invalid or not for this application.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_INVALID_PRODUCTOPTIONID = 9022
Public Const ERROR_INVALID_PRODUCTOPTIONID As Integer = 9022
public:
literal int ERROR_INVALID_PRODUCTOPTIONID = 9022

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_INVALID_SERVER_KEY Field

LicenseErrorERROR_INVALID_SERVER_KEY Field
Error number for when an invalid server key is provided.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_INVALID_SERVER_KEY = 9002
Public Const ERROR_INVALID_SERVER_KEY As Integer = 9002
public:
literal int ERROR_INVALID_SERVER_KEY = 9002

Field Value

Type: Int32
Remarks

Only used in PLUSManaged.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_IO_OPERATION_FAILED Field

LicenseErrorERROR_IO_OPERATION_FAILED Field
Error number when an attempt to perform an I/O operation failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_IO_OPERATION_FAILED = 9220
Public Const ERROR_IO_OPERATION_FAILED As Integer = 9220
public:
literal int ERROR_IO_OPERATION_FAILED = 9220

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_LIBRARY_FUNCTION_UNAVAILABLE Field

LicenseErrorERROR_LIBRARY_FUNCTION_UNAVAILABLE Field
Error number for when a required library function is missing.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_LIBRARY_FUNCTION_UNAVAILABLE = 9405
Public Const ERROR_LIBRARY_FUNCTION_UNAVAILABLE As Integer = 9405
public:
literal int ERROR_LIBRARY_FUNCTION_UNAVAILABLE = 9405

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_LIBRARY_UNAVAILABLE Field

LicenseErrorERROR_LIBRARY_UNAVAILABLE Field
Error number for when a required system library is missing for failed to load.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_LIBRARY_UNAVAILABLE = 9404
Public Const ERROR_LIBRARY_UNAVAILABLE As Integer = 9404
public:
literal int ERROR_LIBRARY_UNAVAILABLE = 9404

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_LICENSE_ALIAS_VALIDATION_FAILED Field

LicenseErrorERROR_LICENSE_ALIAS_VALIDATION_FAILED Field
Error number for when an alias's LastUpdated date could not be validated.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_LICENSE_ALIAS_VALIDATION_FAILED = 9204
Public Const ERROR_LICENSE_ALIAS_VALIDATION_FAILED As Integer = 9204
public:
literal int ERROR_LICENSE_ALIAS_VALIDATION_FAILED = 9204

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_LICENSE_ALIAS_VALIDATION_TIME_MISMATCH Field

LicenseErrorERROR_LICENSE_ALIAS_VALIDATION_TIME_MISMATCH Field
Error number for when an alias has a LastUpdated date in the future.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_LICENSE_ALIAS_VALIDATION_TIME_MISMATCH = 9205
Public Const ERROR_LICENSE_ALIAS_VALIDATION_TIME_MISMATCH As Integer = 9205
public:
literal int ERROR_LICENSE_ALIAS_VALIDATION_TIME_MISMATCH = 9205

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_LICENSE_EXPIRED Field

LicenseErrorERROR_LICENSE_EXPIRED Field
Error number for when the license is expired.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_LICENSE_EXPIRED = 9203
Public Const ERROR_LICENSE_EXPIRED As Integer = 9203
public:
literal int ERROR_LICENSE_EXPIRED = 9203

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_LICENSE_NOT_EFFECTIVE_YET Field

LicenseErrorERROR_LICENSE_NOT_EFFECTIVE_YET Field
Error number for when the license is not effective yet.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_LICENSE_NOT_EFFECTIVE_YET = 9202
Public Const ERROR_LICENSE_NOT_EFFECTIVE_YET As Integer = 9202
public:
literal int ERROR_LICENSE_NOT_EFFECTIVE_YET = 9202

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_LICENSE_SYSTEM_IDENTIFIERS_DONT_MATCH Field

LicenseErrorERROR_LICENSE_SYSTEM_IDENTIFIERS_DONT_MATCH Field
Error number for when system identifiers do not match.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_LICENSE_SYSTEM_IDENTIFIERS_DONT_MATCH = 9400
Public Const ERROR_LICENSE_SYSTEM_IDENTIFIERS_DONT_MATCH As Integer = 9400
public:
literal int ERROR_LICENSE_SYSTEM_IDENTIFIERS_DONT_MATCH = 9400

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_MEMORY_ALLOCATION Field

LicenseErrorERROR_MEMORY_ALLOCATION Field
Error number for when an attempt to allocate memory fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_MEMORY_ALLOCATION = 9403
Public Const ERROR_MEMORY_ALLOCATION As Integer = 9403
public:
literal int ERROR_MEMORY_ALLOCATION = 9403

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_MODULE_NOT_ACTIVE Field

LicenseErrorERROR_MODULE_NOT_ACTIVE Field
Error number for when use of the application or module is not permitted.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_MODULE_NOT_ACTIVE = 9213
Public Const ERROR_MODULE_NOT_ACTIVE As Integer = 9213
public:
literal int ERROR_MODULE_NOT_ACTIVE = 9213

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_NETWORK_CERTIFICATE_INVALID_PATH Field

LicenseErrorERROR_NETWORK_CERTIFICATE_INVALID_PATH Field
Error number for when a NetworkSessionCertificate file's path is invalid.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_NETWORK_CERTIFICATE_INVALID_PATH = 9207
Public Const ERROR_NETWORK_CERTIFICATE_INVALID_PATH As Integer = 9207
public:
literal int ERROR_NETWORK_CERTIFICATE_INVALID_PATH = 9207

Field Value

Type: Int32
Remarks

Only used in PLUSManaged.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_NETWORK_CERTIFICATE_REQUIRED Field

LicenseErrorERROR_NETWORK_CERTIFICATE_REQUIRED Field
Error number for when a NetworkSessionCertificate is not present, but is required.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_NETWORK_CERTIFICATE_REQUIRED = 9208
Public Const ERROR_NETWORK_CERTIFICATE_REQUIRED As Integer = 9208
public:
literal int ERROR_NETWORK_CERTIFICATE_REQUIRED = 9208

Field Value

Type: Int32
Remarks

Only used in PLUSManaged.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_NETWORK_LICENSE_FULL Field

LicenseErrorERROR_NETWORK_LICENSE_FULL Field
Error number for when the number of allowed concurrent users has been reached.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_NETWORK_LICENSE_FULL = 9211
Public Const ERROR_NETWORK_LICENSE_FULL As Integer = 9211
public:
literal int ERROR_NETWORK_LICENSE_FULL = 9211

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_NETWORK_SEMAPHORE_INVALID_PATH Field

LicenseErrorERROR_NETWORK_SEMAPHORE_INVALID_PATH Field
Error number for when a NetworkSemaphore file's path is invalid.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_NETWORK_SEMAPHORE_INVALID_PATH = 9210
Public Const ERROR_NETWORK_SEMAPHORE_INVALID_PATH As Integer = 9210
public:
literal int ERROR_NETWORK_SEMAPHORE_INVALID_PATH = 9210

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_NETWORK_SEMAPHORE_LOCK_FAILED Field

LicenseErrorERROR_NETWORK_SEMAPHORE_LOCK_FAILED Field
Error number for when network semaphore file creation fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_NETWORK_SEMAPHORE_LOCK_FAILED = 9212
Public Const ERROR_NETWORK_SEMAPHORE_LOCK_FAILED As Integer = 9212
public:
literal int ERROR_NETWORK_SEMAPHORE_LOCK_FAILED = 9212

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_NONE Field

LicenseErrorERROR_NONE Field
Error number for when there is no error.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_NONE = 0
Public Const ERROR_NONE As Integer = 0
public:
literal int ERROR_NONE = 0

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_PLATFORM_ERROR Field

LicenseErrorERROR_PLATFORM_ERROR Field
Error number for when a platform specific API or system call fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_PLATFORM_ERROR = 9401
Public Const ERROR_PLATFORM_ERROR As Integer = 9401
public:
literal int ERROR_PLATFORM_ERROR = 9401

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_PLUS_EVALUATION_INVALID Field

LicenseErrorERROR_PLUS_EVALUATION_INVALID Field
The Protection PLUS 5 SDK evaluation is invalid or expired.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_PLUS_EVALUATION_INVALID = 9020
Public Const ERROR_PLUS_EVALUATION_INVALID As Integer = 9020
public:
literal int ERROR_PLUS_EVALUATION_INVALID = 9020

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_PLUS_EVALUATION_WARNING Field

LicenseErrorERROR_PLUS_EVALUATION_WARNING Field
No error actually occurred, but that an evaluation envelope is being used.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_PLUS_EVALUATION_WARNING = 9019
Public Const ERROR_PLUS_EVALUATION_WARNING As Integer = 9019
public:
literal int ERROR_PLUS_EVALUATION_WARNING = 9019

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_REMOTE_SESSION_DETECTED Field

LicenseErrorERROR_REMOTE_SESSION_DETECTED Field
Error number for when a remote session is detected.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_REMOTE_SESSION_DETECTED = 9303
Public Const ERROR_REMOTE_SESSION_DETECTED As Integer = 9303
public:
literal int ERROR_REMOTE_SESSION_DETECTED = 9303

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_REQUIRED_SERVER_VALIDATION_FAILED Field

LicenseErrorERROR_REQUIRED_SERVER_VALIDATION_FAILED Field
Error number for when a any kind of validation against SOLO Server is required, but could not be completed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_REQUIRED_SERVER_VALIDATION_FAILED = 9103
Public Const ERROR_REQUIRED_SERVER_VALIDATION_FAILED As Integer = 9103
public:
literal int ERROR_REQUIRED_SERVER_VALIDATION_FAILED = 9103

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_SESSION_VERIFICATION_FAILED Field

LicenseErrorERROR_SESSION_VERIFICATION_FAILED Field
Error number for when session code verification fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_SESSION_VERIFICATION_FAILED = 9008
Public Const ERROR_SESSION_VERIFICATION_FAILED As Integer = 9008
public:
literal int ERROR_SESSION_VERIFICATION_FAILED = 9008

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_SIGNING_FAILED Field

LicenseErrorERROR_SIGNING_FAILED Field
Error number for when signing a document fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_SIGNING_FAILED = 9007
Public Const ERROR_SIGNING_FAILED As Integer = 9007
public:
literal int ERROR_SIGNING_FAILED = 9007

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_SSL_CERTIFICATE_EXPORT_FAILED Field

LicenseErrorERROR_SSL_CERTIFICATE_EXPORT_FAILED Field
Error number for when an attempt to export the SSL certificate bundle failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_SSL_CERTIFICATE_EXPORT_FAILED = 9223
Public Const ERROR_SSL_CERTIFICATE_EXPORT_FAILED As Integer = 9223
public:
literal int ERROR_SSL_CERTIFICATE_EXPORT_FAILED = 9223

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_SSL_CERTIFICATE_UNAVAILABLE Field

LicenseErrorERROR_SSL_CERTIFICATE_UNAVAILABLE Field
Error number for when an HTTPS request fails due to a problem with the certificate bundle.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_SSL_CERTIFICATE_UNAVAILABLE = 9224
Public Const ERROR_SSL_CERTIFICATE_UNAVAILABLE As Integer = 9224
public:
literal int ERROR_SSL_CERTIFICATE_UNAVAILABLE = 9224

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_SSL_FAILED Field

LicenseErrorERROR_SSL_FAILED Field
Error number for when an HTTPS request fails due to an SSL related problem.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_SSL_FAILED = 9107
Public Const ERROR_SSL_FAILED As Integer = 9107
public:
literal int ERROR_SSL_FAILED = 9107

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_STRING_CONVERSION_FAILED Field

LicenseErrorERROR_STRING_CONVERSION_FAILED Field
Error number for when a string conversion operation fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_STRING_CONVERSION_FAILED = 9017
Public Const ERROR_STRING_CONVERSION_FAILED As Integer = 9017
public:
literal int ERROR_STRING_CONVERSION_FAILED = 9017

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_SYSTEM_TIME_INVALID Field

LicenseErrorERROR_SYSTEM_TIME_INVALID Field
Error number for when the system time is invalid.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_SYSTEM_TIME_INVALID = 9301
Public Const ERROR_SYSTEM_TIME_INVALID As Integer = 9301
public:
literal int ERROR_SYSTEM_TIME_INVALID = 9301

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_SYSTEM_TIME_VERIFICATION_FAILED Field

LicenseErrorERROR_SYSTEM_TIME_VERIFICATION_FAILED Field
Error number for when system time verification failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_SYSTEM_TIME_VERIFICATION_FAILED = 9300
Public Const ERROR_SYSTEM_TIME_VERIFICATION_FAILED As Integer = 9300
public:
literal int ERROR_SYSTEM_TIME_VERIFICATION_FAILED = 9300

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_TRIGGER_CODE_EVENT_DATA_INVALID Field

LicenseErrorERROR_TRIGGER_CODE_EVENT_DATA_INVALID Field
Error number for when an invalid "Activation Code 2" value is entered by the user.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_TRIGGER_CODE_EVENT_DATA_INVALID = 9011
Public Const ERROR_TRIGGER_CODE_EVENT_DATA_INVALID As Integer = 9011
public:
literal int ERROR_TRIGGER_CODE_EVENT_DATA_INVALID = 9011

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_TRIGGER_CODE_INVALID Field

LicenseErrorERROR_TRIGGER_CODE_INVALID Field
Error number for when an invalid "Activation Code 1" value is entered by the user.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_TRIGGER_CODE_INVALID = 9010
Public Const ERROR_TRIGGER_CODE_INVALID As Integer = 9010
public:
literal int ERROR_TRIGGER_CODE_INVALID = 9010

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_UNSUPPORTED_OS Field

LicenseErrorERROR_UNSUPPORTED_OS Field
Error number for when an attempt to perform an unsupported operation occurs.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_UNSUPPORTED_OS = 9402
Public Const ERROR_UNSUPPORTED_OS As Integer = 9402
public:
literal int ERROR_UNSUPPORTED_OS = 9402

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_VERIFICATION_FAILED Field

LicenseErrorERROR_VERIFICATION_FAILED Field
Error number for when verifying the signature of a document fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_VERIFICATION_FAILED = 9005
Public Const ERROR_VERIFICATION_FAILED As Integer = 9005
public:
literal int ERROR_VERIFICATION_FAILED = 9005

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_VIRTUAL_MACHINE_DETECTED Field

LicenseErrorERROR_VIRTUAL_MACHINE_DETECTED Field
Error number for when a virtual machine is detected.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_VIRTUAL_MACHINE_DETECTED = 9302
Public Const ERROR_VIRTUAL_MACHINE_DETECTED As Integer = 9302
public:
literal int ERROR_VIRTUAL_MACHINE_DETECTED = 9302

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_WEBSERVICE_CALL_FAILED Field

LicenseErrorERROR_WEBSERVICE_CALL_FAILED Field
Error number for when a web service call failed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_WEBSERVICE_CALL_FAILED = 9101
Public Const ERROR_WEBSERVICE_CALL_FAILED As Integer = 9101
public:
literal int ERROR_WEBSERVICE_CALL_FAILED = 9101

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_WEBSERVICE_INVALID_CONFIGURATION Field

LicenseErrorERROR_WEBSERVICE_INVALID_CONFIGURATION Field
Error number for when an invalid web service configuration is provided.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_WEBSERVICE_INVALID_CONFIGURATION = 9100
Public Const ERROR_WEBSERVICE_INVALID_CONFIGURATION As Integer = 9100
public:
literal int ERROR_WEBSERVICE_INVALID_CONFIGURATION = 9100

Field Value

Type: Int32
Remarks

Only used in PLUSManaged.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_WEBSERVICE_RETURNED_FAILURE Field

LicenseErrorERROR_WEBSERVICE_RETURNED_FAILURE Field
Error number for when a web service call returned an error.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_WEBSERVICE_RETURNED_FAILURE = 9102
Public Const ERROR_WEBSERVICE_RETURNED_FAILURE As Integer = 9102
public:
literal int ERROR_WEBSERVICE_RETURNED_FAILURE = 9102

Field Value

Type: Int32
See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_XML_NODE_MISSING Field

LicenseErrorERROR_XML_NODE_MISSING Field
Error number for when the specified node is not present in the document.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_XML_NODE_MISSING = 9014
Public Const ERROR_XML_NODE_MISSING As Integer = 9014
public:
literal int ERROR_XML_NODE_MISSING = 9014

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseError.ERROR_XML_PARSER_FAILED Field

LicenseErrorERROR_XML_PARSER_FAILED Field
Error number for when the XML parser fails.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int ERROR_XML_PARSER_FAILED = 9013
Public Const ERROR_XML_PARSER_FAILED As Integer = 9013
public:
literal int ERROR_XML_PARSER_FAILED = 9013

Field Value

Type: Int32
Remarks

Only used in PLUSNative.

See Also

Reference

LicenseError Class
com.softwarekey.Client.Licensing Namespace


LicenseFileSystemAlias Class

LicenseFileSystemAlias Class
Enables creation and management of License File aliases located in the file-system.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseAlias
com.softwarekey.Client.LicensingLicenseFileSystemAlias

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseFileSystemAlias : LicenseAlias
Public Class LicenseFileSystemAlias
    Inherits LicenseAlias
public ref class LicenseFileSystemAlias : public LicenseAlias

The LicenseFileSystemAlias type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseFileSystemAlias | Constructor for managing a License File alias located on the file-system.
Top
Properties
 | Name | Description
Public property | Contents | Gets the contents of the alias file. (Inherited from LicenseAlias.)
Public property | LastError | Gets the last error that occurred. (Inherited from LicenseAlias.)
Public property | LastUpdated | Gets the date the alias was last updated. (Inherited from LicenseAlias.)
Public property | Location | Gets the location of the alias. (Inherited from LicenseAlias.)
Public property | Type | Gets the type location in which the alias is stored. (Inherited from LicenseAlias.)
Top
Methods
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias. (Overrides LicenseAliasCheckAlias.)
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date. (Inherited from LicenseAlias.)
Public method | DeleteAlias | Deletes the current alias file. (Overrides LicenseAliasDeleteAlias.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | WriteAlias | Updates the alias with the most current license file data. (Overrides LicenseAliasWriteAlias(String).)
Top
Fields
 | Name | Description
Protected field | m_lastError | The last error that occurred (Inherited from LicenseAlias.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseFileSystemAlias Constructor

LicenseFileSystemAlias Constructor
Constructor for managing a License File alias located on the file-system.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseFileSystemAlias(
    string location,
    AuthorEncryptionKey encryptionKey,
    bool useEncryption
)
Public Sub New (
    location As String,
    encryptionKey As AuthorEncryptionKey,
    useEncryption As Boolean
)
public:
LicenseFileSystemAlias(
    String^ location,
    AuthorEncryptionKey^ encryptionKey,
    bool useEncryption
)

Parameters

location
Type: SystemString
The absolute path to the alias file.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The client encryption key CSP blob.
useEncryption
Type: SystemBoolean
Set to true to use encrypted alias files.
See Also

Reference

LicenseFileSystemAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseFileSystemAlias Properties

LicenseFileSystemAlias Properties

The LicenseFileSystemAlias type exposes the following members.

Properties
 | Name | Description
Public property | Contents | Gets the contents of the alias file. (Inherited from LicenseAlias.)
Public property | LastError | Gets the last error that occurred. (Inherited from LicenseAlias.)
Public property | LastUpdated | Gets the date the alias was last updated. (Inherited from LicenseAlias.)
Public property | Location | Gets the location of the alias. (Inherited from LicenseAlias.)
Public property | Type | Gets the type location in which the alias is stored. (Inherited from LicenseAlias.)
Top
See Also

Reference

LicenseFileSystemAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseFileSystemAlias Methods

LicenseFileSystemAlias Methods

The LicenseFileSystemAlias type exposes the following members.

Methods
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias. (Overrides LicenseAliasCheckAlias.)
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date. (Inherited from LicenseAlias.)
Public method | DeleteAlias | Deletes the current alias file. (Overrides LicenseAliasDeleteAlias.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | WriteAlias | Updates the alias with the most current license file data. (Overrides LicenseAliasWriteAlias(String).)
Top
See Also

Reference

LicenseFileSystemAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseFileSystemAlias.CheckAlias Method

LicenseFileSystemAliasCheckAlias Method
Overload List
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias. (Overrides LicenseAliasCheckAlias.)
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date. (Inherited from LicenseAlias.)
Top
See Also

Reference

LicenseFileSystemAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseFileSystemAlias.CheckAlias Method

LicenseFileSystemAliasCheckAlias Method
Compares the current license to the alias.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool CheckAlias()
Public Overrides Function CheckAlias As Boolean
public:
virtual bool CheckAlias() override

Return Value

Type: Boolean
Returns true if the alias is found to be valid. If it is not valid, check the LastError property for details.
See Also

Reference

LicenseFileSystemAlias Class
CheckAlias Overload
com.softwarekey.Client.Licensing Namespace


LicenseFileSystemAlias.DeleteAlias Method

LicenseFileSystemAliasDeleteAlias Method
Deletes the current alias file.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool DeleteAlias()
Public Overrides Function DeleteAlias As Boolean
public:
virtual bool DeleteAlias() override

Return Value

Type: Boolean
Returns true if the alias is deleted successfully. If it is not successful, check the LastError property for details.
See Also

Reference

LicenseFileSystemAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseFileSystemAlias.WriteAlias Method

LicenseFileSystemAliasWriteAlias Method
Updates the alias with the most current license file data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool WriteAlias(
    string license
)
Public Overrides Function WriteAlias (
    license As String
) As Boolean
public:
virtual bool WriteAlias(
    String^ license
) override

Parameters

license
Type: SystemString
The license contents to write to the alias.

Return Value

Type: Boolean
Returns true if the alias is deleted successfully. If it is not successful, check the LastError property for details.
Remarks
Caution note Caution

This method uses the GrantControlToWorld(String) to try to give all users full control of the alias file. This helps avoid problems with the UAC in Windows, and helps avoid problems that can often be encountered when your application stores alias files in a location that is shared by all users.

See Also

Reference

LicenseFileSystemAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseFileSystemAlias Fields

LicenseFileSystemAlias Fields

The LicenseFileSystemAlias type exposes the following members.

Fields
 | Name | Description
Protected field | m_lastError | The last error that occurred (Inherited from LicenseAlias.)
Top
See Also

Reference

LicenseFileSystemAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifier Class

LicenseIDIdentifier Class
SystemIdentifier implementation for identifying/authorizing a system based on License ID. This is typically only used for volume licensing, and these identifiers are generated by LicenseIDIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingLicenseIDIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseIDIdentifier : SystemIdentifier
Public Class LicenseIDIdentifier
    Inherits SystemIdentifier
public ref class LicenseIDIdentifier : public SystemIdentifier

The LicenseIDIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseIDIdentifier | Creates a new LicenseIDIdentifier object.
Public method | LicenseIDIdentifier(Int32) | Creates a new LicenseIDIdentifier object, initialized with the value.
Public method | LicenseIDIdentifier(String, Int32) | Creates a new LicenseIDIdentifier object, initialized with the name and value.
Public method | LicenseIDIdentifier(String, Int32, String) | Creates a new LicenseIDIdentifier object, initialized with the name, value, and hash.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Returns this system identifier's type ("LicenseIDIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifier Constructor

LicenseIDIdentifier Constructor
Overload List
 | Name | Description
Public method | LicenseIDIdentifier | Creates a new LicenseIDIdentifier object.
Public method | LicenseIDIdentifier(Int32) | Creates a new LicenseIDIdentifier object, initialized with the value.
Public method | LicenseIDIdentifier(String, Int32) | Creates a new LicenseIDIdentifier object, initialized with the name and value.
Public method | LicenseIDIdentifier(String, Int32, String) | Creates a new LicenseIDIdentifier object, initialized with the name, value, and hash.
Top
See Also

Reference

LicenseIDIdentifier Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifier Constructor

LicenseIDIdentifier Constructor
Creates a new LicenseIDIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseIDIdentifier()
Public Sub New
public:
LicenseIDIdentifier()
See Also

Reference

LicenseIDIdentifier Class
LicenseIDIdentifier Overload
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifier Constructor (Int32)

LicenseIDIdentifier Constructor (Int32)
Creates a new LicenseIDIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseIDIdentifier(
    int value
)
Public Sub New (
    value As Integer
)
public:
LicenseIDIdentifier(
    int value
)

Parameters

value
Type: SystemInt32
The computer's fully qualified host name.
See Also

Reference

LicenseIDIdentifier Class
LicenseIDIdentifier Overload
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifier Constructor (String, Int32)

LicenseIDIdentifier Constructor (String, Int32)
Creates a new LicenseIDIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseIDIdentifier(
    string name,
    int value
)
Public Sub New (
    name As String,
    value As Integer
)
public:
LicenseIDIdentifier(
    String^ name,
    int value
)

Parameters

name
Type: SystemString
The name of the LicenseIDIdentifier object.
value
Type: SystemInt32
The License ID.
See Also

Reference

LicenseIDIdentifier Class
LicenseIDIdentifier Overload
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifier Constructor (String, Int32, String)

LicenseIDIdentifier Constructor (String, Int32, String)
Creates a new LicenseIDIdentifier object, initialized with the name, value, and hash.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseIDIdentifier(
    string name,
    int value,
    string hash
)
Public Sub New (
    name As String,
    value As Integer,
    hash As String
)
public:
LicenseIDIdentifier(
    String^ name,
    int value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the LicenseIDIdentifier object.
value
Type: SystemInt32
The License ID.
hash
Type: SystemString
Hash of the License ID.
See Also

Reference

LicenseIDIdentifier Class
LicenseIDIdentifier Overload
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifier Properties

LicenseIDIdentifier Properties

The LicenseIDIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Returns this system identifier's type ("LicenseIDIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

LicenseIDIdentifier Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifier.Type Property

LicenseIDIdentifierType Property
Returns this system identifier's type ("LicenseIDIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

LicenseIDIdentifier Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifier Methods

LicenseIDIdentifier Methods

The LicenseIDIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

LicenseIDIdentifier Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifier Fields

LicenseIDIdentifier Fields

The LicenseIDIdentifier type exposes the following members.

Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

LicenseIDIdentifier Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifierAlgorithm Class

LicenseIDIdentifierAlgorithm Class
SystemIdentifierAlgorithm implementation for identifying/authorizing a system based on the License ID. This is typically only used for volume licensing.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingLicenseIDIdentifierAlgorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseIDIdentifierAlgorithm : SystemIdentifierAlgorithm
Public Class LicenseIDIdentifierAlgorithm
    Inherits SystemIdentifierAlgorithm
public ref class LicenseIDIdentifierAlgorithm : public SystemIdentifierAlgorithm

The LicenseIDIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseIDIdentifierAlgorithm | Creates a new LicenseIDIdentifierAlgorithm object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifier | Generates a generic list with one LicenseIDIdentifier object for the specified License ID.
Public method | GetIdentifiers | Generates an empty, generic list of LicenseIDIdentifier objects. Use the GetIdentifier(Int32) method to get a list for a specified License ID. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | ThisAlgorithmId | The name of this algorithm
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifierAlgorithm Constructor

LicenseIDIdentifierAlgorithm Constructor
Creates a new LicenseIDIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseIDIdentifierAlgorithm()
Public Sub New
public:
LicenseIDIdentifierAlgorithm()
See Also

Reference

LicenseIDIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifierAlgorithm Methods

LicenseIDIdentifierAlgorithm Methods

The LicenseIDIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifier | Generates a generic list with one LicenseIDIdentifier object for the specified License ID.
Public method | GetIdentifiers | Generates an empty, generic list of LicenseIDIdentifier objects. Use the GetIdentifier(Int32) method to get a list for a specified License ID. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LicenseIDIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifierAlgorithm.GetIdentifier Method

LicenseIDIdentifierAlgorithmGetIdentifier Method
Generates a generic list with one LicenseIDIdentifier object for the specified License ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<SystemIdentifier> GetIdentifier(
    int licenseID
)
Public Function GetIdentifier (
    licenseID As Integer
) As List(Of SystemIdentifier)
public:
List<SystemIdentifier^>^ GetIdentifier(
    int licenseID
)

Parameters

licenseID
Type: SystemInt32
The License ID.

Return Value

Type: List SystemIdentifier
Returns a generic list with one LicenseIDIdentifier object for the specified License ID.
See Also

Reference

LicenseIDIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifierAlgorithm.GetIdentifiers Method

LicenseIDIdentifierAlgorithmGetIdentifiers Method
Generates an empty, generic list of LicenseIDIdentifier objects. Use the GetIdentifier(Int32) method to get a list for a specified License ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override List<SystemIdentifier> GetIdentifiers()
Public Overrides Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() override

Return Value

Type: List SystemIdentifier
Returns an empty, generic list of LicenseIDIdentifier objects.
See Also

Reference

LicenseIDIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifierAlgorithm Fields

LicenseIDIdentifierAlgorithm Fields

The LicenseIDIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | ThisAlgorithmId | The name of this algorithm
Top
See Also

Reference

LicenseIDIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


LicenseIDIdentifierAlgorithm.ThisAlgorithmId Field

LicenseIDIdentifierAlgorithmThisAlgorithmId Field
The name of this algorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected const string ThisAlgorithmId = "LicenseID"
Protected Const ThisAlgorithmId As String = "LicenseID"
protected:
literal String^ ThisAlgorithmId = "LicenseID"

Field Value

Type: String
See Also

Reference

LicenseIDIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


LicenseImageAlias Class

LicenseImageAlias Class
Enables creation and management of License File aliases hidden within an image file.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseAlias
com.softwarekey.Client.LicensingLicenseImageAlias

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseImageAlias : LicenseAlias
Public Class LicenseImageAlias
    Inherits LicenseAlias
public ref class LicenseImageAlias : public LicenseAlias

The LicenseImageAlias type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseImageAlias | Constructor for managing a License File alias located within the image data of an image file.
Top
Properties
 | Name | Description
Public property | Contents | Gets the contents of the alias file. (Inherited from LicenseAlias.)
Public property | LastError | Gets the last error that occurred. (Inherited from LicenseAlias.)
Public property | LastUpdated | Gets the date the alias was last updated. (Inherited from LicenseAlias.)
Public property | Location | Gets the location of the alias. (Inherited from LicenseAlias.)
Public property | Type | Gets the type location in which the alias is stored. (Inherited from LicenseAlias.)
Top
Methods
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias. (Overrides LicenseAliasCheckAlias.)
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date. (Inherited from LicenseAlias.)
Public method | DeleteAlias | Deletes the current alias file. (Overrides LicenseAliasDeleteAlias.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | WriteAlias | Updates the alias with the most current license file data. (Overrides LicenseAliasWriteAlias(String).)
Top
Fields
 | Name | Description
Protected field | m_lastError | The last error that occurred (Inherited from LicenseAlias.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseImageAlias Constructor

LicenseImageAlias Constructor
Constructor for managing a License File alias located within the image data of an image file.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseImageAlias(
    string location,
    AuthorEncryptionKey encryptionKey,
    bool useEncryption
)
Public Sub New (
    location As String,
    encryptionKey As AuthorEncryptionKey,
    useEncryption As Boolean
)
public:
LicenseImageAlias(
    String^ location,
    AuthorEncryptionKey^ encryptionKey,
    bool useEncryption
)

Parameters

location
Type: SystemString
The absolute path to the alias file.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The client encryption key CSP blob.
useEncryption
Type: SystemBoolean
Set to true to use encrypted alias files.
See Also

Reference

LicenseImageAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseImageAlias Properties

LicenseImageAlias Properties

The LicenseImageAlias type exposes the following members.

Properties
 | Name | Description
Public property | Contents | Gets the contents of the alias file. (Inherited from LicenseAlias.)
Public property | LastError | Gets the last error that occurred. (Inherited from LicenseAlias.)
Public property | LastUpdated | Gets the date the alias was last updated. (Inherited from LicenseAlias.)
Public property | Location | Gets the location of the alias. (Inherited from LicenseAlias.)
Public property | Type | Gets the type location in which the alias is stored. (Inherited from LicenseAlias.)
Top
See Also

Reference

LicenseImageAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseImageAlias Methods

LicenseImageAlias Methods

The LicenseImageAlias type exposes the following members.

Methods
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias. (Overrides LicenseAliasCheckAlias.)
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date. (Inherited from LicenseAlias.)
Public method | DeleteAlias | Deletes the current alias file. (Overrides LicenseAliasDeleteAlias.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | WriteAlias | Updates the alias with the most current license file data. (Overrides LicenseAliasWriteAlias(String).)
Top
See Also

Reference

LicenseImageAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseImageAlias.CheckAlias Method

LicenseImageAliasCheckAlias Method
Overload List
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias. (Overrides LicenseAliasCheckAlias.)
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date. (Inherited from LicenseAlias.)
Top
See Also

Reference

LicenseImageAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseImageAlias.CheckAlias Method

LicenseImageAliasCheckAlias Method
Compares the current license to the alias.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool CheckAlias()
Public Overrides Function CheckAlias As Boolean
public:
virtual bool CheckAlias() override

Return Value

Type: Boolean
Returns true if the alias is found to be valid. If it is not valid, check the LastError property for details.
See Also

Reference

LicenseImageAlias Class
CheckAlias Overload
com.softwarekey.Client.Licensing Namespace


LicenseImageAlias.DeleteAlias Method

LicenseImageAliasDeleteAlias Method
Deletes the current alias file.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool DeleteAlias()
Public Overrides Function DeleteAlias As Boolean
public:
virtual bool DeleteAlias() override

Return Value

Type: Boolean
Returns true if the alias is deleted successfully. If it is not successful, check the LastError property for details.
See Also

Reference

LicenseImageAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseImageAlias.WriteAlias Method

LicenseImageAliasWriteAlias Method
Updates the alias with the most current license file data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool WriteAlias(
    string license
)
Public Overrides Function WriteAlias (
    license As String
) As Boolean
public:
virtual bool WriteAlias(
    String^ license
) override

Parameters

license
Type: SystemString
The license contents to write to the alias.

Return Value

Type: Boolean
Returns true if the alias is written successfully. If it is not successful, check the LastError property for details.
Remarks
Caution note Caution

This method uses the GrantControlToWorld(String) to try to give all users full control of the alias file. This helps avoid problems with the UAC in Windows, and helps avoid problems that can often be encountered when your application stores alias files in a location that is shared by all users.

See Also

Reference

LicenseImageAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseImageAlias Fields

LicenseImageAlias Fields

The LicenseImageAlias type exposes the following members.

Fields
 | Name | Description
Protected field | m_lastError | The last error that occurred (Inherited from LicenseAlias.)
Top
See Also

Reference

LicenseImageAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseProduct Class

LicenseProduct Class
Contains data about the SOLO Server Product for which the license was issued.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseDataObject
com.softwarekey.Client.LicensingLicenseProduct

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseProduct : LicenseDataObject
Public Class LicenseProduct
    Inherits LicenseDataObject
public ref class LicenseProduct : public LicenseDataObject

The LicenseProduct type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseProduct | Creates a new LicenseProduct object.
Top
Properties
 | Name | Description
Public property | CustomData | Gets or sets the Product Custom Data, which contains custom XML or alphanumeric data.
Public property | ProductID | Gets or sets the Product ID.
Public property | ProductName | Gets or sets the Product Name.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

This object's data is available in the License class's Product property.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseProduct Constructor

LicenseProduct Constructor
Creates a new LicenseProduct object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseProduct()
Public Sub New
public:
LicenseProduct()
See Also

Reference

LicenseProduct Class
com.softwarekey.Client.Licensing Namespace


LicenseProduct Properties

LicenseProduct Properties

The LicenseProduct type exposes the following members.

Properties
 | Name | Description
Public property | CustomData | Gets or sets the Product Custom Data, which contains custom XML or alphanumeric data.
Public property | ProductID | Gets or sets the Product ID.
Public property | ProductName | Gets or sets the Product Name.
Top
See Also

Reference

LicenseProduct Class
com.softwarekey.Client.Licensing Namespace


LicenseProduct.CustomData Property

LicenseProductCustomData Property
Gets or sets the Product Custom Data, which contains custom XML or alphanumeric data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CustomData { get; set; }
Public Property CustomData As String
    Get
    Set
public:
property String^ CustomData {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseProduct Class
com.softwarekey.Client.Licensing Namespace


LicenseProduct.ProductID Property

LicenseProductProductID Property
Gets or sets the Product ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; set; }
Public Property ProductID As Integer
    Get
    Set
public:
property int ProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LicenseProduct Class
com.softwarekey.Client.Licensing Namespace


LicenseProduct.ProductName Property

LicenseProductProductName Property
Gets or sets the Product Name.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProductName { get; set; }
Public Property ProductName As String
    Get
    Set
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseProduct Class
com.softwarekey.Client.Licensing Namespace


LicenseProduct Methods

LicenseProduct Methods

The LicenseProduct type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LicenseProduct Class
com.softwarekey.Client.Licensing Namespace


LicenseProductOption Class

LicenseProductOption Class
Contains data about the SOLO Server Product Option for which the license was issued.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseDataObject
com.softwarekey.Client.LicensingLicenseProductOption

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseProductOption : LicenseDataObject
Public Class LicenseProductOption
    Inherits LicenseDataObject
public ref class LicenseProductOption : public LicenseDataObject

The LicenseProductOption type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseProductOption | Creates a new LicenseProductOption object.
Top
Properties
 | Name | Description
Public property | CustomData | Gets or sets the Product Option Custom Data, which contains custom XML or alphanumeric data.
Public property | OptionName | Gets or sets the Product Option Name.
Public property | OptionType | Gets or sets the Product Option Type.
Public property | OptionTypeString | Gets or sets the Product Option Type string value.
Public property | ProdOptionID | Gets or sets the Product Option ID.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

This object's data is available in the License class's ProductOption property.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseProductOption Constructor

LicenseProductOption Constructor
Creates a new LicenseProductOption object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseProductOption()
Public Sub New
public:
LicenseProductOption()
See Also

Reference

LicenseProductOption Class
com.softwarekey.Client.Licensing Namespace


LicenseProductOption Properties

LicenseProductOption Properties

The LicenseProductOption type exposes the following members.

Properties
 | Name | Description
Public property | CustomData | Gets or sets the Product Option Custom Data, which contains custom XML or alphanumeric data.
Public property | OptionName | Gets or sets the Product Option Name.
Public property | OptionType | Gets or sets the Product Option Type.
Public property | OptionTypeString | Gets or sets the Product Option Type string value.
Public property | ProdOptionID | Gets or sets the Product Option ID.
Top
See Also

Reference

LicenseProductOption Class
com.softwarekey.Client.Licensing Namespace


LicenseProductOption.CustomData Property

LicenseProductOptionCustomData Property
Gets or sets the Product Option Custom Data, which contains custom XML or alphanumeric data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CustomData { get; set; }
Public Property CustomData As String
    Get
    Set
public:
property String^ CustomData {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseProductOption Class
com.softwarekey.Client.Licensing Namespace


LicenseProductOption.OptionName Property

LicenseProductOptionOptionName Property
Gets or sets the Product Option Name.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string OptionName { get; set; }
Public Property OptionName As String
    Get
    Set
public:
property String^ OptionName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseProductOption Class
com.softwarekey.Client.Licensing Namespace


LicenseProductOption.OptionType Property

LicenseProductOptionOptionType Property
Gets or sets the Product Option Type.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseProductOptionProductOptionType OptionType { get; set; }
Public Property OptionType As LicenseProductOptionProductOptionType
    Get
    Set
public:
property LicenseProductOptionProductOptionType OptionType {
    LicenseProductOptionProductOptionType get ();
    void set (LicenseProductOptionProductOptionType value);
}

Property Value

Type: LicenseProductOptionProductOptionType
Remarks
Setting this property will also change the value returned by OptionTypeString.
See Also

Reference

LicenseProductOption Class
com.softwarekey.Client.Licensing Namespace


LicenseProductOption.OptionTypeString Property

LicenseProductOptionOptionTypeString Property
Gets or sets the Product Option Type string value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string OptionTypeString { get; set; }
Public Property OptionTypeString As String
    Get
    Set
public:
property String^ OptionTypeString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LicenseProductOption Class
com.softwarekey.Client.Licensing Namespace


LicenseProductOption.ProdOptionID Property

LicenseProductOptionProdOptionID Property
Gets or sets the Product Option ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProdOptionID { get; set; }
Public Property ProdOptionID As Integer
    Get
    Set
public:
property int ProdOptionID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LicenseProductOption Class
com.softwarekey.Client.Licensing Namespace


LicenseProductOption Methods

LicenseProductOption Methods

The LicenseProductOption type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LicenseProductOption Class
com.softwarekey.Client.Licensing Namespace


LicenseProductOption.ProductOptionType Enumeration

LicenseProductOptionProductOptionType Enumeration
Supported SOLO Server product option types.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum ProductOptionType
Public Enumeration ProductOptionType
public enum class ProductOptionType
Members
Member name | Value | Description
ActivationCode | 0 | Standard Protection PLUS 4 and 5 activation code.
ActivationCodeWithQuantity | 1 | Protection PLUS 4 and 5 activation code with the quantity of items ordered.
ActivationCodeWithFixedValue | 2 | Protection PLUS 4 and 5 activation code with an additional, fixed value.
ActivationCodeWithDaysLeft | 3 | Protection PLUS 4 and 5 activation code with the number of days left until the license expires.
VolumeLicense | 4 | Protection PLUS 5 volume license.
DownloadableLicenseWithTriggerCodeValidation | 5 | Protection PLUS 5 downloadable license with Protection PLUS 4 compatible trigger code validation.
Custom | 6 | An unknown or Custom value. See the OptionTypeString property.
See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseProductValidation Class

LicenseProductValidation Class
SystemValidation implementation for validating the Product ID and Product Option ID in the license file.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
com.softwarekey.Client.LicensingLicenseProductValidation

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseProductValidation : SystemValidation
Public Class LicenseProductValidation
    Inherits SystemValidation
public ref class LicenseProductValidation : public SystemValidation

The LicenseProductValidation type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseProductValidation(License, IEnumerableInt32) | Creates a new LicenseProductValidation object that may be used to verify a license's Product ID.
Public method | LicenseProductValidation(License, Int32) | Creates a new LicenseProductValidation object that may be used to verify a license's Product ID.
Public method | LicenseProductValidation(License, IEnumerableInt32, IEnumerableInt32) | Creates a new LicenseProductValidation object that may be used to verify a license's Product ID and Product Option ID.
Public method | LicenseProductValidation(License, Int32, IEnumerableInt32) | Creates a new LicenseProductValidation object that may be used to verify a license's Product ID and Product Option ID.
Public method | LicenseProductValidation(License, Int32, Int32) | Creates a new LicenseProductValidation object that may be used to verify a license's Product ID and Product Option ID.
Top
Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates the Product ID and Product Option ID authorized in the license file. (Overrides SystemValidationValidate.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseProductValidation Constructor

LicenseProductValidation Constructor
Overload List
 | Name | Description
Public method | LicenseProductValidation(License, IEnumerableInt32) | Creates a new LicenseProductValidation object that may be used to verify a license's Product ID.
Public method | LicenseProductValidation(License, Int32) | Creates a new LicenseProductValidation object that may be used to verify a license's Product ID.
Public method | LicenseProductValidation(License, IEnumerableInt32, IEnumerableInt32) | Creates a new LicenseProductValidation object that may be used to verify a license's Product ID and Product Option ID.
Public method | LicenseProductValidation(License, Int32, IEnumerableInt32) | Creates a new LicenseProductValidation object that may be used to verify a license's Product ID and Product Option ID.
Public method | LicenseProductValidation(License, Int32, Int32) | Creates a new LicenseProductValidation object that may be used to verify a license's Product ID and Product Option ID.
Top
See Also

Reference

LicenseProductValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseProductValidation Constructor (License, IEnumerable(Int32))

LicenseProductValidation Constructor (License, IEnumerableInt32)
Creates a new LicenseProductValidation object that may be used to verify a license's Product ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseProductValidation(
    License license,
    IEnumerable<int> validProductIDs
)
Public Sub New (
    license As License,
    validProductIDs As IEnumerable(Of Integer)
)
public:
LicenseProductValidation(
    License^ license,
    IEnumerable<int>^ validProductIDs
)

Parameters

license
Type: com.softwarekey.Client.LicensingLicense
The license which will be validated.
validProductIDs
Type: System.Collections.GenericIEnumerable Int32
A collection of valid Product IDs.
See Also

Reference

LicenseProductValidation Class
LicenseProductValidation Overload
com.softwarekey.Client.Licensing Namespace


LicenseProductValidation Constructor (License, Int32)

LicenseProductValidation Constructor (License, Int32)
Creates a new LicenseProductValidation object that may be used to verify a license's Product ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseProductValidation(
    License license,
    int validProductID
)
Public Sub New (
    license As License,
    validProductID As Integer
)
public:
LicenseProductValidation(
    License^ license,
    int validProductID
)

Parameters

license
Type: com.softwarekey.Client.LicensingLicense
The license which will be validated.
validProductID
Type: SystemInt32
A valid Product ID.
See Also

Reference

LicenseProductValidation Class
LicenseProductValidation Overload
com.softwarekey.Client.Licensing Namespace


LicenseProductValidation Constructor (License, IEnumerable(Int32), IEnumerable(Int32))

LicenseProductValidation Constructor (License, IEnumerableInt32, IEnumerableInt32)
Creates a new LicenseProductValidation object that may be used to verify a license's Product ID and Product Option ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseProductValidation(
    License license,
    IEnumerable<int> validProductIDs,
    IEnumerable<int> validProductOptionIDs
)
Public Sub New (
    license As License,
    validProductIDs As IEnumerable(Of Integer),
    validProductOptionIDs As IEnumerable(Of Integer)
)
public:
LicenseProductValidation(
    License^ license,
    IEnumerable<int>^ validProductIDs,
    IEnumerable<int>^ validProductOptionIDs
)

Parameters

license
Type: com.softwarekey.Client.LicensingLicense
The license which will be validated.
validProductIDs
Type: System.Collections.GenericIEnumerable Int32
A collection of valid Product IDs.
validProductOptionIDs
Type: System.Collections.GenericIEnumerable Int32
A collection of valid Product IDs.
See Also

Reference

LicenseProductValidation Class
LicenseProductValidation Overload
com.softwarekey.Client.Licensing Namespace


LicenseProductValidation Constructor (License, Int32, IEnumerable(Int32))

LicenseProductValidation Constructor (License, Int32, IEnumerableInt32)
Creates a new LicenseProductValidation object that may be used to verify a license's Product ID and Product Option ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseProductValidation(
    License license,
    int validProductID,
    IEnumerable<int> validProductOptionIDs
)
Public Sub New (
    license As License,
    validProductID As Integer,
    validProductOptionIDs As IEnumerable(Of Integer)
)
public:
LicenseProductValidation(
    License^ license,
    int validProductID,
    IEnumerable<int>^ validProductOptionIDs
)

Parameters

license
Type: com.softwarekey.Client.LicensingLicense
The license which will be validated.
validProductID
Type: SystemInt32
A valid Product ID.
validProductOptionIDs
Type: System.Collections.GenericIEnumerable Int32
A collection of valid Product IDs.
See Also

Reference

LicenseProductValidation Class
LicenseProductValidation Overload
com.softwarekey.Client.Licensing Namespace


LicenseProductValidation Constructor (License, Int32, Int32)

LicenseProductValidation Constructor (License, Int32, Int32)
Creates a new LicenseProductValidation object that may be used to verify a license's Product ID and Product Option ID.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseProductValidation(
    License license,
    int validProductID,
    int validProductOptionID
)
Public Sub New (
    license As License,
    validProductID As Integer,
    validProductOptionID As Integer
)
public:
LicenseProductValidation(
    License^ license,
    int validProductID,
    int validProductOptionID
)

Parameters

license
Type: com.softwarekey.Client.LicensingLicense
The license which will be validated.
validProductID
Type: SystemInt32
A valid Product ID.
validProductOptionID
Type: SystemInt32
A valid Product Option ID.
See Also

Reference

LicenseProductValidation Class
LicenseProductValidation Overload
com.softwarekey.Client.Licensing Namespace


LicenseProductValidation Properties

LicenseProductValidation Properties

The LicenseProductValidation type exposes the following members.

Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Top
See Also

Reference

LicenseProductValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseProductValidation Methods

LicenseProductValidation Methods

The LicenseProductValidation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates the Product ID and Product Option ID authorized in the license file. (Overrides SystemValidationValidate.)
Top
See Also

Reference

LicenseProductValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseProductValidation.Validate Method

LicenseProductValidationValidate Method
Validates the Product ID and Product Option ID authorized in the license file.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Validate()
Public Overrides Function Validate As Boolean
public:
virtual bool Validate() override

Return Value

Type: Boolean
Returns true if the Product ID and Product Option ID is valid. If false is returned, examine the LastError property for details.
See Also

Reference

LicenseProductValidation Class
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias Class

LicenseWindowsRegistryAlias Class
Enables creation and management of License File aliases located in the Windows registry.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicenseAlias
com.softwarekey.Client.LicensingLicenseWindowsRegistryAlias

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class LicenseWindowsRegistryAlias : LicenseAlias
Public Class LicenseWindowsRegistryAlias
    Inherits LicenseAlias
public ref class LicenseWindowsRegistryAlias : public LicenseAlias

The LicenseWindowsRegistryAlias type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseWindowsRegistryAlias(String, AuthorEncryptionKey, Boolean, String) | Creates a new LicenseWindowsRegistryAlias object, which may be used for managing a license file alias located in the Windows registry.
Public method | LicenseWindowsRegistryAlias(String, AuthorEncryptionKey, Boolean, RegistryHive, String) | Creates a new LicenseWindowsRegistryAlias object, which may be used for managing a license file alias located in the Windows registry in a specified root key/hive.
Public method | LicenseWindowsRegistryAlias(String, AuthorEncryptionKey, Boolean, RegistryHive, RegistryViews, String) | Creates a new LicenseWindowsRegistryAlias object, which may be used for managing a license file alias located in the Windows registry in a specified root key/hive, using a specified view.
Top
Properties
 | Name | Description
Public property | Contents | Gets the contents of the alias file. (Inherited from LicenseAlias.)
Public property | LastError | Gets the last error that occurred. (Inherited from LicenseAlias.)
Public property | LastUpdated | Gets the date the alias was last updated. (Inherited from LicenseAlias.)
Public property | Location | Gets the location of the alias. (Inherited from LicenseAlias.)
Public property | Type | Gets the type location in which the alias is stored. (Inherited from LicenseAlias.)
Top
Methods
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias. (Overrides LicenseAliasCheckAlias.)
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date. (Inherited from LicenseAlias.)
Public method | DeleteAlias | Deletes the current alias, and returns true if successful (Overrides LicenseAliasDeleteAlias.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | WriteAlias | Updates the alias with the latest and greatest license data, returns true if successful (Overrides LicenseAliasWriteAlias(String).)
Top
Fields
 | Name | Description
Protected field | m_lastError | The last error that occurred (Inherited from LicenseAlias.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias Constructor

LicenseWindowsRegistryAlias Constructor
Overload List
 | Name | Description
Public method | LicenseWindowsRegistryAlias(String, AuthorEncryptionKey, Boolean, String) | Creates a new LicenseWindowsRegistryAlias object, which may be used for managing a license file alias located in the Windows registry.
Public method | LicenseWindowsRegistryAlias(String, AuthorEncryptionKey, Boolean, RegistryHive, String) | Creates a new LicenseWindowsRegistryAlias object, which may be used for managing a license file alias located in the Windows registry in a specified root key/hive.
Public method | LicenseWindowsRegistryAlias(String, AuthorEncryptionKey, Boolean, RegistryHive, RegistryViews, String) | Creates a new LicenseWindowsRegistryAlias object, which may be used for managing a license file alias located in the Windows registry in a specified root key/hive, using a specified view.
Top
See Also

Reference

LicenseWindowsRegistryAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias Constructor (String, AuthorEncryptionKey, Boolean, String)

LicenseWindowsRegistryAlias Constructor (String, AuthorEncryptionKey, Boolean, String)
Creates a new LicenseWindowsRegistryAlias object, which may be used for managing a license file alias located in the Windows registry.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseWindowsRegistryAlias(
    string location,
    AuthorEncryptionKey encryptionKey,
    bool useEncryption,
    string value
)
Public Sub New (
    location As String,
    encryptionKey As AuthorEncryptionKey,
    useEncryption As Boolean,
    value As String
)
public:
LicenseWindowsRegistryAlias(
    String^ location,
    AuthorEncryptionKey^ encryptionKey,
    bool useEncryption,
    String^ value
)

Parameters

location
Type: SystemString
The full registry key path.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The client encryption key.
useEncryption
Type: SystemBoolean
Set to true to use encrypted alias files.
value
Type: SystemString
The name of the registry value (e.g. "Version").
Remarks

Assumes HKEY_LOCAL_MACHINE (RegistryHive.LocalMachine) is the root/hive to which the path is relative.

See Also

Reference

LicenseWindowsRegistryAlias Class
LicenseWindowsRegistryAlias Overload
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias Constructor (String, AuthorEncryptionKey, Boolean, RegistryHive, String)

LicenseWindowsRegistryAlias Constructor (String, AuthorEncryptionKey, Boolean, RegistryHive, String)
Creates a new LicenseWindowsRegistryAlias object, which may be used for managing a license file alias located in the Windows registry in a specified root key/hive.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseWindowsRegistryAlias(
    string location,
    AuthorEncryptionKey encryptionKey,
    bool useEncryption,
    RegistryHive root,
    string value
)
Public Sub New (
    location As String,
    encryptionKey As AuthorEncryptionKey,
    useEncryption As Boolean,
    root As RegistryHive,
    value As String
)
public:
LicenseWindowsRegistryAlias(
    String^ location,
    AuthorEncryptionKey^ encryptionKey,
    bool useEncryption,
    RegistryHive root,
    String^ value
)

Parameters

location
Type: SystemString
The full registry key path.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The client encryption key.
useEncryption
Type: SystemBoolean
Set to true to use encrypted aliases.
root
Type: Microsoft.Win32RegistryHive
The root key/hive (i.e. RegistryHive.LocalMachine).
value
Type: SystemString
The name of the registry value (e.g. "Version").
Remarks
Caution note Caution

The only root registry key/hive locations supported include HKEY_LOCAL_MACHINE, HKEY_CURRENT_USER, and HKEY_CLASSES_ROOT. Consequently, the only values supported from the RegistryHive enumeration include LocalMachine, CurrentUser, and ClassesRoot, respectively.

See Also

Reference

LicenseWindowsRegistryAlias Class
LicenseWindowsRegistryAlias Overload
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias Constructor (String, AuthorEncryptionKey, Boolean, RegistryHive, RegistryViews, String)

LicenseWindowsRegistryAlias Constructor (String, AuthorEncryptionKey, Boolean, RegistryHive, RegistryViews, String)
Creates a new LicenseWindowsRegistryAlias object, which may be used for managing a license file alias located in the Windows registry in a specified root key/hive, using a specified view.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseWindowsRegistryAlias(
    string location,
    AuthorEncryptionKey encryptionKey,
    bool useEncryption,
    RegistryHive root,
    RegistryViews registryView,
    string value
)
Public Sub New (
    location As String,
    encryptionKey As AuthorEncryptionKey,
    useEncryption As Boolean,
    root As RegistryHive,
    registryView As RegistryViews,
    value As String
)
public:
LicenseWindowsRegistryAlias(
    String^ location,
    AuthorEncryptionKey^ encryptionKey,
    bool useEncryption,
    RegistryHive root,
    RegistryViews registryView,
    String^ value
)

Parameters

location
Type: SystemString
The full registry key path.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The client encryption key.
useEncryption
Type: SystemBoolean
Set to true to use encrypted aliases.
root
Type: Microsoft.Win32RegistryHive
The root key/hive (i.e. RegistryHive.LocalMachine).
registryView
Type: com.softwarekey.Client.UtilsRegistryViews
The registry view to use. IMPORTANT: RegistryViews.DefaultView is required for applications targeting versions of the .NET Framework prior to 4.0.
value
Type: SystemString
The name of the registry value (e.g. "Version").
Remarks
Caution note Caution

The only root registry key/hive locations supported include HKEY_LOCAL_MACHINE, HKEY_CURRENT_USER, and HKEY_CLASSES_ROOT. Consequently, the only values supported from the RegistryHive enumeration include LocalMachine, CurrentUser, and ClassesRoot, respectively.

Caution note Caution

Specifying anything other than DefaultView will require your application to target .NET Framework 4.0 or later. If you use anything other than DefaultView while targeting earlier versions of the .NET Framework, this alias object will fail to function, and will contain a corresponding error in the LastError property.

See Also

Reference

LicenseWindowsRegistryAlias Class
LicenseWindowsRegistryAlias Overload
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias Properties

LicenseWindowsRegistryAlias Properties

The LicenseWindowsRegistryAlias type exposes the following members.

Properties
 | Name | Description
Public property | Contents | Gets the contents of the alias file. (Inherited from LicenseAlias.)
Public property | LastError | Gets the last error that occurred. (Inherited from LicenseAlias.)
Public property | LastUpdated | Gets the date the alias was last updated. (Inherited from LicenseAlias.)
Public property | Location | Gets the location of the alias. (Inherited from LicenseAlias.)
Public property | Type | Gets the type location in which the alias is stored. (Inherited from LicenseAlias.)
Top
See Also

Reference

LicenseWindowsRegistryAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias Methods

LicenseWindowsRegistryAlias Methods

The LicenseWindowsRegistryAlias type exposes the following members.

Methods
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias. (Overrides LicenseAliasCheckAlias.)
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date. (Inherited from LicenseAlias.)
Public method | DeleteAlias | Deletes the current alias, and returns true if successful (Overrides LicenseAliasDeleteAlias.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | WriteAlias | Updates the alias with the latest and greatest license data, returns true if successful (Overrides LicenseAliasWriteAlias(String).)
Top
See Also

Reference

LicenseWindowsRegistryAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias.CheckAlias Method

LicenseWindowsRegistryAliasCheckAlias Method
Overload List
 | Name | Description
Public method | CheckAlias | Compares the current license to the alias. (Overrides LicenseAliasCheckAlias.)
Protected method | CheckAlias(String) | Decrypts and verifies the alias document, and checks its last updated date. (Inherited from LicenseAlias.)
Top
See Also

Reference

LicenseWindowsRegistryAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias.CheckAlias Method

LicenseWindowsRegistryAliasCheckAlias Method
Compares the current license to the alias.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool CheckAlias()
Public Overrides Function CheckAlias As Boolean
public:
virtual bool CheckAlias() override

Return Value

Type: Boolean
Returns true if the alias is found to be valid. If it is not valid, check the LastError property for details.
See Also

Reference

LicenseWindowsRegistryAlias Class
CheckAlias Overload
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias.DeleteAlias Method

LicenseWindowsRegistryAliasDeleteAlias Method
Deletes the current alias, and returns true if successful

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool DeleteAlias()
Public Overrides Function DeleteAlias As Boolean
public:
virtual bool DeleteAlias() override

Return Value

Type: Boolean
Returns true if the alias is deleted successfully. If it is not successful, check the LastError property for details.
See Also

Reference

LicenseWindowsRegistryAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias.WriteAlias Method

LicenseWindowsRegistryAliasWriteAlias Method
Updates the alias with the latest and greatest license data, returns true if successful

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool WriteAlias(
    string license
)
Public Overrides Function WriteAlias (
    license As String
) As Boolean
public:
virtual bool WriteAlias(
    String^ license
) override

Parameters

license
Type: SystemString
The license contents to write

Return Value

Type: Boolean
Returns true if the alias is deleted successfully. If it is not successful, check the LastError property for details.
Remarks
Caution note Caution

This method attempts to write the license file alias to the Windows Registry, and also attempts to give full permissions everyone access to this registry key (using WellKnownSidType.WorldSid). This is done to help avoid UAC issues, and is the same behavior performed by Protection PLUS 4 libraries and Instant PLUS. Please see our knowledge-base for additional information.

See Also

Reference

LicenseWindowsRegistryAlias Class
com.softwarekey.Client.Licensing Namespace


LicenseWindowsRegistryAlias Fields

LicenseWindowsRegistryAlias Fields

The LicenseWindowsRegistryAlias type exposes the following members.

Fields
 | Name | Description
Protected field | m_lastError | The last error that occurred (Inherited from LicenseAlias.)
Top
See Also

Reference

LicenseWindowsRegistryAlias Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier Class

NetworkNameIdentifier Class
SystemIdentifier implementation for a network path. These identifiers are generated by NetworkNameIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingNetworkNameIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class NetworkNameIdentifier : SystemIdentifier
Public Class NetworkNameIdentifier
    Inherits SystemIdentifier
public ref class NetworkNameIdentifier : public SystemIdentifier

The NetworkNameIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkNameIdentifier | Creates a new NetworkNameIdentifier object.
Public method | NetworkNameIdentifier(String) | Creates a new NetworkNameIdentifier object, initialized with the value
Public method | NetworkNameIdentifier(String, String) | Creates a new NetworkNameIdentifier object, initialized with the name and value
Public method | NetworkNameIdentifier(String, String, String) | Creates a new NetworkNameIdentifier object, initialized with the name, value, and hash
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets the system identifier's type (NetworkNameIdentifier). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
 | m_netNameIdentifierId | The static member for tracking default identifiers generated
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier Constructor

NetworkNameIdentifier Constructor
Overload List
 | Name | Description
Public method | NetworkNameIdentifier | Creates a new NetworkNameIdentifier object.
Public method | NetworkNameIdentifier(String) | Creates a new NetworkNameIdentifier object, initialized with the value
Public method | NetworkNameIdentifier(String, String) | Creates a new NetworkNameIdentifier object, initialized with the name and value
Public method | NetworkNameIdentifier(String, String, String) | Creates a new NetworkNameIdentifier object, initialized with the name, value, and hash
Top
See Also

Reference

NetworkNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier Constructor

NetworkNameIdentifier Constructor
Creates a new NetworkNameIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkNameIdentifier()
Public Sub New
public:
NetworkNameIdentifier()
See Also

Reference

NetworkNameIdentifier Class
NetworkNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier Constructor (String)

NetworkNameIdentifier Constructor (String)
Creates a new NetworkNameIdentifier object, initialized with the value

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkNameIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
NetworkNameIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The absolute path to a network location.
See Also

Reference

NetworkNameIdentifier Class
NetworkNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier Constructor (String, String)

NetworkNameIdentifier Constructor (String, String)
Creates a new NetworkNameIdentifier object, initialized with the name and value

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkNameIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
NetworkNameIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the NetworkNameIdentifier object.
value
Type: SystemString
The absolute path to a network location.
See Also

Reference

NetworkNameIdentifier Class
NetworkNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier Constructor (String, String, String)

NetworkNameIdentifier Constructor (String, String, String)
Creates a new NetworkNameIdentifier object, initialized with the name, value, and hash

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkNameIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
NetworkNameIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the NetworkNameIdentifier object.
value
Type: SystemString
The absolute path to a network location.
hash
Type: SystemString
Hash of the absolute path to a network location.
See Also

Reference

NetworkNameIdentifier Class
NetworkNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier Properties

NetworkNameIdentifier Properties

The NetworkNameIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets the system identifier's type (NetworkNameIdentifier). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

NetworkNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier.Type Property

NetworkNameIdentifierType Property
Gets the system identifier's type (NetworkNameIdentifier).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

NetworkNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier Methods

NetworkNameIdentifier Methods

The NetworkNameIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

NetworkNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier Fields

NetworkNameIdentifier Fields

The NetworkNameIdentifier type exposes the following members.

Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
 | m_netNameIdentifierId | The static member for tracking default identifiers generated
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

NetworkNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifier.m_netNameIdentifierId Field

NetworkNameIdentifierm_netNameIdentifierId Field
The static member for tracking default identifiers generated

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected static int m_netNameIdentifierId
Protected Shared m_netNameIdentifierId As Integer
protected:
static int m_netNameIdentifierId

Field Value

Type: Int32
See Also

Reference

NetworkNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifierAlgorithm Class

NetworkNameIdentifierAlgorithm Class
SystemIdentifierAlgorithm implementation for identifying a network path.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingNetworkNameIdentifierAlgorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class NetworkNameIdentifierAlgorithm : SystemIdentifierAlgorithm
Public Class NetworkNameIdentifierAlgorithm
    Inherits SystemIdentifierAlgorithm
public ref class NetworkNameIdentifierAlgorithm : public SystemIdentifierAlgorithm

The NetworkNameIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkNameIdentifierAlgorithm | Creates a new NetworkNameIdentifierAlgorithm object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of ComputerNameIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | thisAlgorithmId | The name of this algorithm
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifierAlgorithm Constructor

NetworkNameIdentifierAlgorithm Constructor
Creates a new NetworkNameIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkNameIdentifierAlgorithm(
    string networkPath
)
Public Sub New (
    networkPath As String
)
public:
NetworkNameIdentifierAlgorithm(
    String^ networkPath
)

Parameters

networkPath
Type: SystemString
The absolute path to a network location. Use a UNC-formatted path or a path which uses a mapped drive letter.
See Also

Reference

NetworkNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifierAlgorithm Methods

NetworkNameIdentifierAlgorithm Methods

The NetworkNameIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of ComputerNameIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NetworkNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifierAlgorithm.GetIdentifiers Method

NetworkNameIdentifierAlgorithmGetIdentifiers Method
Generates a generic list of ComputerNameIdentifier objects.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override List<SystemIdentifier> GetIdentifiers()
Public Overrides Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() override

Return Value

Type: List SystemIdentifier
Returns a generic list of NetworkNameIdentifier objects.
Remarks

The list contains a single NetworkNameIdentifier object, which contains an identifier based on the UNC-formatted network path. Non-UNC-formatted paths (such as ones which use a mapped drive letter) are automatically formatted using the IOHelper.ToUncPath method.

Caution note Caution

This algorithm is not meant to be used on the same machine which is hosting the share. For these machines (which you may want to support via Citrix/Remote Desktop services), we recommend using algorithms that target machine/hardware-specific details (such as NicIdentifierAlgorithm, HardDiskVolumeSerialIdentifierAlgorithm, or ComputerNameIdentifierAlgorithm).

Caution note Caution

Although it is not officially supported, it is possible to use Microsoft's WebDAV redirector. When doing so, you should expect the identifiers generated when accessing the share from a remote network to differ from the identifiers generated when accessing from the same/local network where the share is hosted.

See Also

Reference

NetworkNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifierAlgorithm Fields

NetworkNameIdentifierAlgorithm Fields

The NetworkNameIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | thisAlgorithmId | The name of this algorithm
Top
See Also

Reference

NetworkNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


NetworkNameIdentifierAlgorithm.thisAlgorithmId Field

NetworkNameIdentifierAlgorithmthisAlgorithmId Field
The name of this algorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected const string thisAlgorithmId = "NetworkName"
Protected Const thisAlgorithmId As String = "NetworkName"
protected:
literal String^ thisAlgorithmId = "NetworkName"

Field Value

Type: String
See Also

Reference

NetworkNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


NicIdentifier Class

NicIdentifier Class
SystemIdentifier implementation for a Network Interface Card (NIC). These identifiers are generated by NicIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingNicIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class NicIdentifier : SystemIdentifier
Public Class NicIdentifier
    Inherits SystemIdentifier
public ref class NicIdentifier : public SystemIdentifier

The NicIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | NicIdentifier | Creates a new NicIdentifier object.
Public method | NicIdentifier(NetworkInterface) | Creates a new NicIdentifier object, initialized with the value.
Public method | NicIdentifier(PhysicalAddress) | Creates a new NicIdentifier object, initialized with the value.
Public method | NicIdentifier(String) | Creates a new NicIdentifier object, initialized with the value
Public method | NicIdentifier(String, String) | Creates a new NicIdentifier object, initialized with the name and value.
Public method | NicIdentifier(String, String, String) | Creates a new NicIdentifier object, initialized with the name, value, and hash.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("NicIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
 | m_nicIdentifierId | Static member for tracking default ID's generated
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


NicIdentifier Constructor

NicIdentifier Constructor
Overload List
 | Name | Description
Public method | NicIdentifier | Creates a new NicIdentifier object.
Public method | NicIdentifier(NetworkInterface) | Creates a new NicIdentifier object, initialized with the value.
Public method | NicIdentifier(PhysicalAddress) | Creates a new NicIdentifier object, initialized with the value.
Public method | NicIdentifier(String) | Creates a new NicIdentifier object, initialized with the value
Public method | NicIdentifier(String, String) | Creates a new NicIdentifier object, initialized with the name and value.
Public method | NicIdentifier(String, String, String) | Creates a new NicIdentifier object, initialized with the name, value, and hash.
Top
See Also

Reference

NicIdentifier Class
com.softwarekey.Client.Licensing Namespace


NicIdentifier Constructor

NicIdentifier Constructor
Creates a new NicIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NicIdentifier()
Public Sub New
public:
NicIdentifier()
See Also

Reference

NicIdentifier Class
NicIdentifier Overload
com.softwarekey.Client.Licensing Namespace


NicIdentifier Constructor (NetworkInterface)

NicIdentifier Constructor (NetworkInterface)
Creates a new NicIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NicIdentifier(
    NetworkInterface value
)
Public Sub New (
    value As NetworkInterface
)
public:
NicIdentifier(
    NetworkInterface^ value
)

Parameters

value
Type: System.Net.NetworkInformationNetworkInterface
The Network Interface Card (NIC).
See Also

Reference

NicIdentifier Class
NicIdentifier Overload
com.softwarekey.Client.Licensing Namespace


NicIdentifier Constructor (PhysicalAddress)

NicIdentifier Constructor (PhysicalAddress)
Creates a new NicIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NicIdentifier(
    PhysicalAddress value
)
Public Sub New (
    value As PhysicalAddress
)
public:
NicIdentifier(
    PhysicalAddress^ value
)

Parameters

value
Type: System.Net.NetworkInformationPhysicalAddress
The MAC Address/Physical Address of the Network Interface Card (NIC).
See Also

Reference

NicIdentifier Class
NicIdentifier Overload
com.softwarekey.Client.Licensing Namespace


NicIdentifier Constructor (String)

NicIdentifier Constructor (String)
Creates a new NicIdentifier object, initialized with the value

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NicIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
NicIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The MAC Address/Physical Address of the Network Interface Card (NIC).
See Also

Reference

NicIdentifier Class
NicIdentifier Overload
com.softwarekey.Client.Licensing Namespace


NicIdentifier Constructor (String, String)

NicIdentifier Constructor (String, String)
Creates a new NicIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NicIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
NicIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the NicIdentifier object.
value
Type: SystemString
The MAC Address/Physical Address of the Network Interface Card (NIC).
See Also

Reference

NicIdentifier Class
NicIdentifier Overload
com.softwarekey.Client.Licensing Namespace


NicIdentifier Constructor (String, String, String)

NicIdentifier Constructor (String, String, String)
Creates a new NicIdentifier object, initialized with the name, value, and hash.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NicIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
NicIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the NicIdentifier object.
value
Type: SystemString
The MAC Address/Physical Address of the Network Interface Card (NIC).
hash
Type: SystemString
Hash of the MAC Address/Physical Address of the Network Interface Card (NIC).
See Also

Reference

NicIdentifier Class
NicIdentifier Overload
com.softwarekey.Client.Licensing Namespace


NicIdentifier Properties

NicIdentifier Properties

The NicIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("NicIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

NicIdentifier Class
com.softwarekey.Client.Licensing Namespace


NicIdentifier.Type Property

NicIdentifierType Property
Gets this system identifier's type ("NicIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

NicIdentifier Class
com.softwarekey.Client.Licensing Namespace


NicIdentifier Methods

NicIdentifier Methods

The NicIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

NicIdentifier Class
com.softwarekey.Client.Licensing Namespace


NicIdentifier Fields

NicIdentifier Fields

The NicIdentifier type exposes the following members.

Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
 | m_nicIdentifierId | Static member for tracking default ID's generated
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

NicIdentifier Class
com.softwarekey.Client.Licensing Namespace


NicIdentifier.m_nicIdentifierId Field

NicIdentifierm_nicIdentifierId Field
Static member for tracking default ID's generated

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected static int m_nicIdentifierId
Protected Shared m_nicIdentifierId As Integer
protected:
static int m_nicIdentifierId

Field Value

Type: Int32
See Also

Reference

NicIdentifier Class
com.softwarekey.Client.Licensing Namespace


NicIdentifierAlgorithm Class

NicIdentifierAlgorithm Class
SystemIdentifierAlgorithm implementation for identifying a system based on installed Network Interface Cards (NICs).
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingNicIdentifierAlgorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class NicIdentifierAlgorithm : SystemIdentifierAlgorithm
Public Class NicIdentifierAlgorithm
    Inherits SystemIdentifierAlgorithm
public ref class NicIdentifierAlgorithm : public SystemIdentifierAlgorithm

The NicIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | NicIdentifierAlgorithm | Creates a new NicIdentifierAlgorithm object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of NicIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | ShouldBeIgnored | Determines whether or not a network interface should be ignored.
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


NicIdentifierAlgorithm Constructor

NicIdentifierAlgorithm Constructor
Creates a new NicIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NicIdentifierAlgorithm()
Public Sub New
public:
NicIdentifierAlgorithm()
See Also

Reference

NicIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


NicIdentifierAlgorithm Methods

NicIdentifierAlgorithm Methods

The NicIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of NicIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | ShouldBeIgnored | Determines whether or not a network interface should be ignored.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NicIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


NicIdentifierAlgorithm.GetIdentifiers Method

NicIdentifierAlgorithmGetIdentifiers Method
Generates a generic list of NicIdentifier objects.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override List<SystemIdentifier> GetIdentifiers()
Public Overrides Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() override

Return Value

Type: List SystemIdentifier
Returns a generic list of NicIdentifier objects.
Remarks

The list contains NicIdentifier objects, each identifying a given NIC's MAC/physical address. (You can view the MAC Address/Physical Address by running the "ipconfig /all" command in a command prompt.) NICs excluded by this algorithms implementation include PPP/dial-up adapters (modems), tunnel adapters (VPN adapters), and loopback adapters. Additionally, some known virtual adapters are ignored, such as VMWare virtual adapters (which are installed on VMWare hosts), and certain virtual adapters installed by various VPN products.

Caution note Caution

When a network adapter is disabled through the control panel, or a device is removed entirely, the device's driver is no longer enabled. This causes the device to no longer show up in the list of generated identifiers. If you need to support removable Network Interface Cards, you should consider this and implement logic which allows what you find to be an acceptable amount of variation.

See Also

Reference

NicIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


NicIdentifierAlgorithm.ShouldBeIgnored Method

NicIdentifierAlgorithmShouldBeIgnored Method
Determines whether or not a network interface should be ignored.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected static bool ShouldBeIgnored(
    NetworkInterface iface
)
Protected Shared Function ShouldBeIgnored (
    iface As NetworkInterface
) As Boolean
protected:
static bool ShouldBeIgnored(
    NetworkInterface^ iface
)

Parameters

iface
Type: System.Net.NetworkInformationNetworkInterface
The NetworkInterface object to evaluate.

Return Value

Type: Boolean
Returns true if the NetworkInterface should be ignored when generating NicIdentifier objects.
See Also

Reference

NicIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


NicIdentifierAlgorithm Fields

NicIdentifierAlgorithm Fields

The NicIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
Top
See Also

Reference

NicIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ProcessorIdentifierAlgorithm Class

ProcessorIdentifierAlgorithm Class
SystemIdentifierAlgorithm implementation for identifying a system based on its processor/CPU.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingProcessorIdentifierAlgorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ProcessorIdentifierAlgorithm : SystemIdentifierAlgorithm
Public Class ProcessorIdentifierAlgorithm
    Inherits SystemIdentifierAlgorithm
public ref class ProcessorIdentifierAlgorithm : public SystemIdentifierAlgorithm

The ProcessorIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessorIdentifierAlgorithm | Creates a new ProcessorIdentifierAlgorithm object.
Top
Properties
 | Name | Description
Public property | ExcludeClockSpeedFromProcessorName | Gets or sets whether or not the clock speed should be omitted when generating ProcessorNameIdentifier objects. IMPORTANT: Setting this to true will require some users to reactivate.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of ProcessorNameIdentifier, ProcessorVersionIdentifier, and ProcessorVendorIdentifier objects (based on the ProcessorIdentifierAlgorithmTypes specified in the constructor). (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


ProcessorIdentifierAlgorithm Constructor

ProcessorIdentifierAlgorithm Constructor
Creates a new ProcessorIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorIdentifierAlgorithm(
    ProcessorIdentifierAlgorithmTypes[] identifierTypes
)
Public Sub New (
    identifierTypes As ProcessorIdentifierAlgorithmTypes()
)
public:
ProcessorIdentifierAlgorithm(
    array<ProcessorIdentifierAlgorithmTypes>^ identifierTypes
)

Parameters

identifierTypes
Type: com.softwarekey.Client.LicensingProcessorIdentifierAlgorithmTypes
The types of identifiers to include when calling GetIdentifiers.
See Also

Reference

ProcessorIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ProcessorIdentifierAlgorithm Properties

ProcessorIdentifierAlgorithm Properties

The ProcessorIdentifierAlgorithm type exposes the following members.

Properties
 | Name | Description
Public property | ExcludeClockSpeedFromProcessorName | Gets or sets whether or not the clock speed should be omitted when generating ProcessorNameIdentifier objects. IMPORTANT: Setting this to true will require some users to reactivate.
Top
See Also

Reference

ProcessorIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ProcessorIdentifierAlgorithm.ExcludeClockSpeedFromProcessorName Property

ProcessorIdentifierAlgorithmExcludeClockSpeedFromProcessorName Property
Gets or sets whether or not the clock speed should be omitted when generating ProcessorNameIdentifier objects. IMPORTANT: Setting this to true will require some users to reactivate.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool ExcludeClockSpeedFromProcessorName { get; set; }
Public Property ExcludeClockSpeedFromProcessorName As Boolean
    Get
    Set
public:
property bool ExcludeClockSpeedFromProcessorName {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Caution note Caution

Setting this property to true will change the resulting ProcessorNameIdentifier values generated. As a consequence, computers which have already been activated and include the clock speed in the processor name will require reactivation. However, it may be possible to compensate for this change using customized validation and fuzzy matching.

As with any identifier algorithm that derives its value from hardware information, the processor name comes from the driver provided by the manufacturer. In some/many cases (Intel processors in particular), the processor name may include the clock speed. Some examples of processor name values with and without the clock speed included by the driver is below.

  • Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
  • AMD FX(tm)-8120 Eight-Core Processor
Note Note

With virtualization software, it is possible for the clock speed to change when settings change in the hypervisor.

See Also

Reference

ProcessorIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ProcessorIdentifierAlgorithm Methods

ProcessorIdentifierAlgorithm Methods

The ProcessorIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of ProcessorNameIdentifier, ProcessorVersionIdentifier, and ProcessorVendorIdentifier objects (based on the ProcessorIdentifierAlgorithmTypes specified in the constructor). (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ProcessorIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ProcessorIdentifierAlgorithm.GetIdentifiers Method

ProcessorIdentifierAlgorithmGetIdentifiers Method
Generates a generic list of ProcessorNameIdentifier, ProcessorVersionIdentifier, and ProcessorVendorIdentifier objects (based on the ProcessorIdentifierAlgorithmTypes specified in the constructor).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override List<SystemIdentifier> GetIdentifiers()
Public Overrides Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() override

Return Value

Type: List SystemIdentifier
Returns a generic list of ProcessorNameIdentifier, ProcessorVersionIdentifier, and ProcessorVendorIdentifier objects (based on the ProcessorIdentifierAlgorithmTypes specified in the constructor).
Remarks
Caution note Caution

Some processors may include the clock speed with the processor name. You may set ExcludeClockSpeedFromProcessorName to prevent this from affecting the resulting ProcessorNameIdentifier objects generated.

The number of each type of identifier generated typically varies

See Also

Reference

ProcessorIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ProcessorIdentifierAlgorithm Fields

ProcessorIdentifierAlgorithm Fields

The ProcessorIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
Top
See Also

Reference

ProcessorIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ProcessorIdentifierAlgorithmTypes Enumeration

ProcessorIdentifierAlgorithmTypes Enumeration
Types of identifiers that may be generated using the ProcessorIdentifierAlgorithm.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum ProcessorIdentifierAlgorithmTypes
<FlagsAttribute>
Public Enumeration ProcessorIdentifierAlgorithmTypes
[FlagsAttribute]
public enum class ProcessorIdentifierAlgorithmTypes
Members
Member name | Value | Description
ProcessorName | 1 | The processor name.
ProcessorVendor | 2 | The processor vendor or manufacturer.
ProcessorVersion | 4 | The processor version, which includes the model and the stepping.
See Also

Reference

com.softwarekey.Client.Licensing Namespace


ProcessorNameIdentifier Class

ProcessorNameIdentifier Class
SystemIdentifier implementation for a processor's name. These identifiers are generated by ProcessorIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingProcessorNameIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ProcessorNameIdentifier : SystemIdentifier
Public Class ProcessorNameIdentifier
    Inherits SystemIdentifier
public ref class ProcessorNameIdentifier : public SystemIdentifier

The ProcessorNameIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessorNameIdentifier | Creates a new ProcessorNameIdentifier object.
Public method | ProcessorNameIdentifier(String) | Creates a new ProcessorNameIdentifier object, initialized with the value.
Public method | ProcessorNameIdentifier(String, String) | Creates a new ProcessorNameIdentifier object, initialized with the name and value.
Public method | ProcessorNameIdentifier(String, String, String) | Creates a new ProcessorNameIdentifier object, initialized with the name, value, and hash.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("ProcessorNameIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


ProcessorNameIdentifier Constructor

ProcessorNameIdentifier Constructor
Overload List
 | Name | Description
Public method | ProcessorNameIdentifier | Creates a new ProcessorNameIdentifier object.
Public method | ProcessorNameIdentifier(String) | Creates a new ProcessorNameIdentifier object, initialized with the value.
Public method | ProcessorNameIdentifier(String, String) | Creates a new ProcessorNameIdentifier object, initialized with the name and value.
Public method | ProcessorNameIdentifier(String, String, String) | Creates a new ProcessorNameIdentifier object, initialized with the name, value, and hash.
Top
See Also

Reference

ProcessorNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorNameIdentifier Constructor

ProcessorNameIdentifier Constructor
Creates a new ProcessorNameIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorNameIdentifier()
Public Sub New
public:
ProcessorNameIdentifier()
See Also

Reference

ProcessorNameIdentifier Class
ProcessorNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorNameIdentifier Constructor (String)

ProcessorNameIdentifier Constructor (String)
Creates a new ProcessorNameIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorNameIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
ProcessorNameIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The processor's name.
See Also

Reference

ProcessorNameIdentifier Class
ProcessorNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorNameIdentifier Constructor (String, String)

ProcessorNameIdentifier Constructor (String, String)
Creates a new ProcessorNameIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorNameIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
ProcessorNameIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the ProcessorNameIdentifier object.
value
Type: SystemString
The processor's name.
See Also

Reference

ProcessorNameIdentifier Class
ProcessorNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorNameIdentifier Constructor (String, String, String)

ProcessorNameIdentifier Constructor (String, String, String)
Creates a new ProcessorNameIdentifier object, initialized with the name, value, and hash.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorNameIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
ProcessorNameIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the ProcessorNameIdentifier object.
value
Type: SystemString
The processor's name.
hash
Type: SystemString
Hash of the processor's name.
See Also

Reference

ProcessorNameIdentifier Class
ProcessorNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorNameIdentifier Properties

ProcessorNameIdentifier Properties

The ProcessorNameIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("ProcessorNameIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

ProcessorNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorNameIdentifier.Type Property

ProcessorNameIdentifierType Property
Gets this system identifier's type ("ProcessorNameIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

ProcessorNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorNameIdentifier Methods

ProcessorNameIdentifier Methods

The ProcessorNameIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

ProcessorNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorNameIdentifier Fields

ProcessorNameIdentifier Fields

The ProcessorNameIdentifier type exposes the following members.

Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

ProcessorNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorVendorIdentifier Class

ProcessorVendorIdentifier Class
SystemIdentifier implementation for a processor's vendor or manufacturer. These identifiers are generated by ProcessorIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingProcessorVendorIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ProcessorVendorIdentifier : SystemIdentifier
Public Class ProcessorVendorIdentifier
    Inherits SystemIdentifier
public ref class ProcessorVendorIdentifier : public SystemIdentifier

The ProcessorVendorIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessorVendorIdentifier | Creates a new ProcessorVendorIdentifier object.
Public method | ProcessorVendorIdentifier(String) | Creates a new ProcessorVendorIdentifier object, initialized with the value.
Public method | ProcessorVendorIdentifier(String, String) | Creates a new ProcessorVendorIdentifier object, initialized with the name and value.
Public method | ProcessorVendorIdentifier(String, String, String) | Creates a new ProcessorVendorIdentifier object, initialized with the name, value, and hash.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("ProcessorVendorIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


ProcessorVendorIdentifier Constructor

ProcessorVendorIdentifier Constructor
Overload List
 | Name | Description
Public method | ProcessorVendorIdentifier | Creates a new ProcessorVendorIdentifier object.
Public method | ProcessorVendorIdentifier(String) | Creates a new ProcessorVendorIdentifier object, initialized with the value.
Public method | ProcessorVendorIdentifier(String, String) | Creates a new ProcessorVendorIdentifier object, initialized with the name and value.
Public method | ProcessorVendorIdentifier(String, String, String) | Creates a new ProcessorVendorIdentifier object, initialized with the name, value, and hash.
Top
See Also

Reference

ProcessorVendorIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorVendorIdentifier Constructor

ProcessorVendorIdentifier Constructor
Creates a new ProcessorVendorIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorVendorIdentifier()
Public Sub New
public:
ProcessorVendorIdentifier()
See Also

Reference

ProcessorVendorIdentifier Class
ProcessorVendorIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorVendorIdentifier Constructor (String)

ProcessorVendorIdentifier Constructor (String)
Creates a new ProcessorVendorIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorVendorIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
ProcessorVendorIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The processor's vendor or manufacturer.
See Also

Reference

ProcessorVendorIdentifier Class
ProcessorVendorIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorVendorIdentifier Constructor (String, String)

ProcessorVendorIdentifier Constructor (String, String)
Creates a new ProcessorVendorIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorVendorIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
ProcessorVendorIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the ProcessorVendorIdentifier object.
value
Type: SystemString
The processor's vendor or manufacturer.
See Also

Reference

ProcessorVendorIdentifier Class
ProcessorVendorIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorVendorIdentifier Constructor (String, String, String)

ProcessorVendorIdentifier Constructor (String, String, String)
Creates a new ProcessorVendorIdentifier object, initialized with the name, value, and hash.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorVendorIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
ProcessorVendorIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the ProcessorVendorIdentifier object.
value
Type: SystemString
The processor's vendor or manufacturer.
hash
Type: SystemString
Hash of the processor's vendor or manufacturer.
See Also

Reference

ProcessorVendorIdentifier Class
ProcessorVendorIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorVendorIdentifier Properties

ProcessorVendorIdentifier Properties

The ProcessorVendorIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("ProcessorVendorIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

ProcessorVendorIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorVendorIdentifier.Type Property

ProcessorVendorIdentifierType Property
Gets this system identifier's type ("ProcessorVendorIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

ProcessorVendorIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorVendorIdentifier Methods

ProcessorVendorIdentifier Methods

The ProcessorVendorIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

ProcessorVendorIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorVendorIdentifier Fields

ProcessorVendorIdentifier Fields

The ProcessorVendorIdentifier type exposes the following members.

Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

ProcessorVendorIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorVersionIdentifier Class

ProcessorVersionIdentifier Class
SystemIdentifier implementation for a processor's version. These identifiers are generated by ProcessorIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingProcessorVersionIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ProcessorVersionIdentifier : SystemIdentifier
Public Class ProcessorVersionIdentifier
    Inherits SystemIdentifier
public ref class ProcessorVersionIdentifier : public SystemIdentifier

The ProcessorVersionIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessorVersionIdentifier | Creates a new ProcessorVersionIdentifier object.
Public method | ProcessorVersionIdentifier(String) | Creates a new ProcessorVersionIdentifier object, initialized with the value.
Public method | ProcessorVersionIdentifier(String, String) | Creates a new ProcessorVersionIdentifier object, initialized with the name and value.
Public method | ProcessorVersionIdentifier(String, String, String) | Creates a new ProcessorVersionIdentifier object, initialized with the name, value, and hash.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("ProcessorVersionIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


ProcessorVersionIdentifier Constructor

ProcessorVersionIdentifier Constructor
Overload List
 | Name | Description
Public method | ProcessorVersionIdentifier | Creates a new ProcessorVersionIdentifier object.
Public method | ProcessorVersionIdentifier(String) | Creates a new ProcessorVersionIdentifier object, initialized with the value.
Public method | ProcessorVersionIdentifier(String, String) | Creates a new ProcessorVersionIdentifier object, initialized with the name and value.
Public method | ProcessorVersionIdentifier(String, String, String) | Creates a new ProcessorVersionIdentifier object, initialized with the name, value, and hash.
Top
See Also

Reference

ProcessorVersionIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorVersionIdentifier Constructor

ProcessorVersionIdentifier Constructor
Creates a new ProcessorVersionIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorVersionIdentifier()
Public Sub New
public:
ProcessorVersionIdentifier()
See Also

Reference

ProcessorVersionIdentifier Class
ProcessorVersionIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorVersionIdentifier Constructor (String)

ProcessorVersionIdentifier Constructor (String)
Creates a new ProcessorVersionIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorVersionIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
ProcessorVersionIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The processor's version.
See Also

Reference

ProcessorVersionIdentifier Class
ProcessorVersionIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorVersionIdentifier Constructor (String, String)

ProcessorVersionIdentifier Constructor (String, String)
Creates a new ProcessorVersionIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorVersionIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
ProcessorVersionIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the ProcessorVersionIdentifier object.
value
Type: SystemString
The processor's version.
See Also

Reference

ProcessorVersionIdentifier Class
ProcessorVersionIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorVersionIdentifier Constructor (String, String, String)

ProcessorVersionIdentifier Constructor (String, String, String)
Creates a new ProcessorVersionIdentifier object, initialized with the name, value, and hash.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorVersionIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
ProcessorVersionIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the ProcessorVersionIdentifier object.
value
Type: SystemString
The processor's version.
hash
Type: SystemString
Hash of the processor's version.
See Also

Reference

ProcessorVersionIdentifier Class
ProcessorVersionIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ProcessorVersionIdentifier Properties

ProcessorVersionIdentifier Properties

The ProcessorVersionIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("ProcessorVersionIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

ProcessorVersionIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorVersionIdentifier.Type Property

ProcessorVersionIdentifierType Property
Gets this system identifier's type ("ProcessorVersionIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

ProcessorVersionIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorVersionIdentifier Methods

ProcessorVersionIdentifier Methods

The ProcessorVersionIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

ProcessorVersionIdentifier Class
com.softwarekey.Client.Licensing Namespace


ProcessorVersionIdentifier Fields

ProcessorVersionIdentifier Fields

The ProcessorVersionIdentifier type exposes the following members.

Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

ProcessorVersionIdentifier Class
com.softwarekey.Client.Licensing Namespace


RemoteSessionValidation Class

RemoteSessionValidation Class
Attempts to determine whether or not the application is running in a known type of remote session. See the RemoteSessionValidationRemoteSessionTypes enumeration for a list of supported session types.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
com.softwarekey.Client.LicensingRemoteSessionValidation

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class RemoteSessionValidation : SystemValidation
Public Class RemoteSessionValidation
    Inherits SystemValidation
public ref class RemoteSessionValidation : public SystemValidation

The RemoteSessionValidation type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteSessionValidation | Initializes a new instance of the RemoteSessionValidation class
Top
Properties
 | Name | Description
Public property | IsRemoteSession | Gets whether the protected application is running in a remote session. (This property should only be referenced after calling the Validate method once.)
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | Type | Gets the type of remote session on which the protected application is running. (This property should only be referenced after calling the Validate method once.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Determines if the protected application is running in a remote session via something like Terminal Services/Remote Desktop. (Overrides SystemValidationValidate.)
Top
Remarks
Presently, this class only detects if an application is running in a Terminal Services/Remote Desktop session.
See Also

Reference

com.softwarekey.Client.Licensing Namespace


RemoteSessionValidation Constructor

RemoteSessionValidation Constructor
Initializes a new instance of the RemoteSessionValidation class

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public RemoteSessionValidation()
Public Sub New
public:
RemoteSessionValidation()
See Also

Reference

RemoteSessionValidation Class
com.softwarekey.Client.Licensing Namespace


RemoteSessionValidation Properties

RemoteSessionValidation Properties

The RemoteSessionValidation type exposes the following members.

Properties
 | Name | Description
Public property | IsRemoteSession | Gets whether the protected application is running in a remote session. (This property should only be referenced after calling the Validate method once.)
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | Type | Gets the type of remote session on which the protected application is running. (This property should only be referenced after calling the Validate method once.)
Top
See Also

Reference

RemoteSessionValidation Class
com.softwarekey.Client.Licensing Namespace


RemoteSessionValidation.IsRemoteSession Property

RemoteSessionValidationIsRemoteSession Property
Gets whether the protected application is running in a remote session. (This property should only be referenced after calling the Validate method once.)

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool IsRemoteSession { get; }
Public ReadOnly Property IsRemoteSession As Boolean
    Get
public:
property bool IsRemoteSession {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

RemoteSessionValidation Class
com.softwarekey.Client.Licensing Namespace


RemoteSessionValidation.Type Property

RemoteSessionValidationType Property
Gets the type of remote session on which the protected application is running. (This property should only be referenced after calling the Validate method once.)

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public RemoteSessionValidationRemoteSessionTypes Type { get; }
Public ReadOnly Property Type As RemoteSessionValidationRemoteSessionTypes
    Get
public:
property RemoteSessionValidationRemoteSessionTypes Type {
    RemoteSessionValidationRemoteSessionTypes get ();
}

Property Value

Type: RemoteSessionValidationRemoteSessionTypes
See Also

Reference

RemoteSessionValidation Class
com.softwarekey.Client.Licensing Namespace


RemoteSessionValidation Methods

RemoteSessionValidation Methods

The RemoteSessionValidation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Determines if the protected application is running in a remote session via something like Terminal Services/Remote Desktop. (Overrides SystemValidationValidate.)
Top
See Also

Reference

RemoteSessionValidation Class
com.softwarekey.Client.Licensing Namespace


RemoteSessionValidation.Validate Method

RemoteSessionValidationValidate Method
Determines if the protected application is running in a remote session via something like Terminal Services/Remote Desktop.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Validate()
Public Overrides Function Validate As Boolean
public:
virtual bool Validate() override

Return Value

Type: Boolean
Returns true if the application is not running in a remote session. If a remote session was detected (or false is returned), check the Type property to find which type of remote session was detected.
See Also

Reference

RemoteSessionValidation Class
com.softwarekey.Client.Licensing Namespace


RemoteSessionValidation.RemoteSessionTypes Enumeration

RemoteSessionValidationRemoteSessionTypes Enumeration
Enumeration for types of remote sessions.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum RemoteSessionTypes
<FlagsAttribute>
Public Enumeration RemoteSessionTypes
[FlagsAttribute]
public enum class RemoteSessionTypes
Members
Member name | Value | Description
None | 0 | None
TerminalServices | 1 | Terminal Services / Remote Desktop
See Also

Reference

com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifier Class

ServerHostNameIdentifier Class
SystemIdentifier implementation for a computer's fully qualified host name. These identifiers are generated by ServerHostNameIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingServerHostNameIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ServerHostNameIdentifier : SystemIdentifier
Public Class ServerHostNameIdentifier
    Inherits SystemIdentifier
public ref class ServerHostNameIdentifier : public SystemIdentifier

The ServerHostNameIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | ServerHostNameIdentifier | Creates a new ServerHostNameIdentifier object.
Public method | ServerHostNameIdentifier(String) | Creates a new ServerHostNameIdentifier object, initialized with the value.
Public method | ServerHostNameIdentifier(String, String) | Creates a new ServerHostNameIdentifier object, initialized with the name and value.
Public method | ServerHostNameIdentifier(String, String, String) | Creates a new ServerHostNameIdentifier object, initialized with the name, value, and hash.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("ServerHostNameIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifier Constructor

ServerHostNameIdentifier Constructor
Overload List
 | Name | Description
Public method | ServerHostNameIdentifier | Creates a new ServerHostNameIdentifier object.
Public method | ServerHostNameIdentifier(String) | Creates a new ServerHostNameIdentifier object, initialized with the value.
Public method | ServerHostNameIdentifier(String, String) | Creates a new ServerHostNameIdentifier object, initialized with the name and value.
Public method | ServerHostNameIdentifier(String, String, String) | Creates a new ServerHostNameIdentifier object, initialized with the name, value, and hash.
Top
See Also

Reference

ServerHostNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifier Constructor

ServerHostNameIdentifier Constructor
Creates a new ServerHostNameIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ServerHostNameIdentifier()
Public Sub New
public:
ServerHostNameIdentifier()
See Also

Reference

ServerHostNameIdentifier Class
ServerHostNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifier Constructor (String)

ServerHostNameIdentifier Constructor (String)
Creates a new ServerHostNameIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ServerHostNameIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
ServerHostNameIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The computer's fully qualified host name.
See Also

Reference

ServerHostNameIdentifier Class
ServerHostNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifier Constructor (String, String)

ServerHostNameIdentifier Constructor (String, String)
Creates a new ServerHostNameIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ServerHostNameIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
ServerHostNameIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the ServerHostNameIdentifier object.
value
Type: SystemString
The computer's fully qualified host name.
See Also

Reference

ServerHostNameIdentifier Class
ServerHostNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifier Constructor (String, String, String)

ServerHostNameIdentifier Constructor (String, String, String)
Creates a new ServerHostNameIdentifier object, initialized with the name, value, and hash.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ServerHostNameIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
ServerHostNameIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the ServerHostNameIdentifier object.
value
Type: SystemString
The computer's fully qualified host name.
hash
Type: SystemString
Hash of the computer's fully qualified host name.
See Also

Reference

ServerHostNameIdentifier Class
ServerHostNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifier Properties

ServerHostNameIdentifier Properties

The ServerHostNameIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("ServerHostNameIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

ServerHostNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifier.Type Property

ServerHostNameIdentifierType Property
Gets this system identifier's type ("ServerHostNameIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

ServerHostNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifier Methods

ServerHostNameIdentifier Methods

The ServerHostNameIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

ServerHostNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifier Fields

ServerHostNameIdentifier Fields

The ServerHostNameIdentifier type exposes the following members.

Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

ServerHostNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifierAlgorithm Class

ServerHostNameIdentifierAlgorithm Class
SystemIdentifierAlgorithm implementation for identifying a system based on the computer's fully qualified host name.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingServerHostNameIdentifierAlgorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ServerHostNameIdentifierAlgorithm : SystemIdentifierAlgorithm
Public Class ServerHostNameIdentifierAlgorithm
    Inherits SystemIdentifierAlgorithm
public ref class ServerHostNameIdentifierAlgorithm : public SystemIdentifierAlgorithm

The ServerHostNameIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | ServerHostNameIdentifierAlgorithm | Creates a new ServerHostNameIdentifierAlgorithm object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of ServerHostNameIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | ThisAlgorithmId | The name of this algorithm
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifierAlgorithm Constructor

ServerHostNameIdentifierAlgorithm Constructor
Creates a new ServerHostNameIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ServerHostNameIdentifierAlgorithm()
Public Sub New
public:
ServerHostNameIdentifierAlgorithm()
See Also

Reference

ServerHostNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifierAlgorithm Methods

ServerHostNameIdentifierAlgorithm Methods

The ServerHostNameIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of ServerHostNameIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ServerHostNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifierAlgorithm.GetIdentifiers Method

ServerHostNameIdentifierAlgorithmGetIdentifiers Method
Generates a generic list of ServerHostNameIdentifier objects.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override List<SystemIdentifier> GetIdentifiers()
Public Overrides Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() override

Return Value

Type: List SystemIdentifier
Returns a generic list of ServerHostNameIdentifier objects.
Exceptions
Exception | Condition
SocketException |
Remarks

The list contains a single ServerHostNameIdentifier object, which contains an identifier based on the fully qualified host name of the computer running the application.

Caution note Caution

Though it is not generally a frequent occurrence, users with administrative access to computers can change their name, which will change the identifier generated.

Caution note Caution

It is possible for this method to throw an System.Net.Sockets.SocketException if the system's host name cannot be resolved. This can be resolved by either adding an entry in the DNS server's zone file for the host running your application (if the DNS server used by the host can be managed by the same person or company using the host system), or by updating the hosts file (C:\Windows\System32\drivers\etc\hosts on Windows or /etc/hosts on Unix) to contain a fixed IP address for the system's host name. If you opt to edit the hosts file, adding the system's host name to an existing line could result in that line's first entry being returned for this algorithm. (For example, adding your system's host name to the end of the line for localhost would likely cause the algorithm to use localhost as the server host name.)

See Also

Reference

ServerHostNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifierAlgorithm Fields

ServerHostNameIdentifierAlgorithm Fields

The ServerHostNameIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | ThisAlgorithmId | The name of this algorithm
Top
See Also

Reference

ServerHostNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


ServerHostNameIdentifierAlgorithm.ThisAlgorithmId Field

ServerHostNameIdentifierAlgorithmThisAlgorithmId Field
The name of this algorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected const string ThisAlgorithmId = "ServerHostName"
Protected Const ThisAlgorithmId As String = "ServerHostName"
protected:
literal String^ ThisAlgorithmId = "ServerHostName"

Field Value

Type: String
See Also

Reference

ServerHostNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


SystemClockValidation Class

SystemClockValidation Class
Validates the system's clock to help ensure it is not being tampered with actively.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
com.softwarekey.Client.LicensingSystemClockValidation

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class SystemClockValidation : SystemValidation
Public Class SystemClockValidation
    Inherits SystemValidation
public ref class SystemClockValidation : public SystemValidation

The SystemClockValidation type exposes the following members.

Constructors
 | Name | Description
Public method | SystemClockValidation | Creates a new SystemClockValidation object.
Top
Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | TestDuration | Gets or sets the amount of time (in milliseconds) to allow for the test to complete. The default is 100 milliseconds.
Public property | ThresholdPercent | Gets or sets the percentage of the test duration time which must pass for the validation to succeed. The value specified must be between 1 and 100. The default value is 75.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates the system clock to ensure it is not being tampered with actively. (Overrides SystemValidationValidate.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


SystemClockValidation Constructor

SystemClockValidation Constructor
Creates a new SystemClockValidation object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemClockValidation()
Public Sub New
public:
SystemClockValidation()
See Also

Reference

SystemClockValidation Class
com.softwarekey.Client.Licensing Namespace


SystemClockValidation Properties

SystemClockValidation Properties

The SystemClockValidation type exposes the following members.

Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | TestDuration | Gets or sets the amount of time (in milliseconds) to allow for the test to complete. The default is 100 milliseconds.
Public property | ThresholdPercent | Gets or sets the percentage of the test duration time which must pass for the validation to succeed. The value specified must be between 1 and 100. The default value is 75.
Top
See Also

Reference

SystemClockValidation Class
com.softwarekey.Client.Licensing Namespace


SystemClockValidation.TestDuration Property

SystemClockValidationTestDuration Property
Gets or sets the amount of time (in milliseconds) to allow for the test to complete. The default is 100 milliseconds.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int TestDuration { get; set; }
Public Property TestDuration As Integer
    Get
    Set
public:
property int TestDuration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SystemClockValidation Class
com.softwarekey.Client.Licensing Namespace


SystemClockValidation.ThresholdPercent Property

SystemClockValidationThresholdPercent Property
Gets or sets the percentage of the test duration time which must pass for the validation to succeed. The value specified must be between 1 and 100. The default value is 75.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ThresholdPercent { get; set; }
Public Property ThresholdPercent As Integer
    Get
    Set
public:
property int ThresholdPercent {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Caution note Caution

Setting this value to anything above 90 is risky, as the actual amount of time passed while waiting will likely vary depending on the operating system and the processor.

See Also

Reference

SystemClockValidation Class
com.softwarekey.Client.Licensing Namespace


SystemClockValidation Methods

SystemClockValidation Methods

The SystemClockValidation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates the system clock to ensure it is not being tampered with actively. (Overrides SystemValidationValidate.)
Top
See Also

Reference

SystemClockValidation Class
com.softwarekey.Client.Licensing Namespace


SystemClockValidation.Validate Method

SystemClockValidationValidate Method
Validates the system clock to ensure it is not being tampered with actively.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Validate()
Public Overrides Function Validate As Boolean
public:
virtual bool Validate() override

Return Value

Type: Boolean
Returns true if the system clock is valid. Otherwise, if false is returned, the system clock is likely being tampered with actively, and error information is available in the LastError property.
See Also

Reference

SystemClockValidation Class
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation Class

SystemDateTimeValidation Class
Facilitates validating the date/time of the current system against Internet time servers (via Simple Network Time Protocol, or SNTP).
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
com.softwarekey.Client.LicensingSystemDateTimeValidation

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class SystemDateTimeValidation : SystemValidation
Public Class SystemDateTimeValidation
    Inherits SystemValidation
public ref class SystemDateTimeValidation : public SystemValidation

The SystemDateTimeValidation type exposes the following members.

Constructors
 | Name | Description
Public method | SystemDateTimeValidation | Creates a new SystemDateTimeValidation object which requires successful validation with an Internet time server (requires Internet connectivity). The AddTimeServerCheck(String) method will need to be called at least once to allow validation to occur.
Public method | SystemDateTimeValidation(Boolean) | Creates a new SystemDateTimeValidation object. The AddTimeServerCheck(String) method will need to be called at least once to allow validation to occur.
Public method | SystemDateTimeValidation(Boolean, Double) | Creates a new SystemDateTimeValidation object. The AddTimeServerCheck(String) method will need to be called at least once to allow validation to occur.
Top
Properties
 | Name | Description
Public property | AllowedVariation | Gets or sets the amount of time (in minutes) of acceptable variation between the current system's date/time versus the Internet time server's date/time. (5.0 by default)
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | ValidationRequired | Gets or sets whether or not validation with an Internet time server is required. Internet connectivity is required if true. (True by default)
Top
Methods
 | Name | Description
Public method | AddTimeServerCheck(String) | Adds an SNTP server to the list of servers to check.
Public method | AddTimeServerCheck(String, Int32) | Add an SNTP server to the list of servers to check.
Public method | AddTimeServerCheck(String, Int32, Int32, Int32) | Add an SNTP server to the list of servers to check.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates the current system's Date/Time against that of Internet time servers. (Overrides SystemValidationValidate.)
Top
Remarks
Caution note Caution

This class allows you to verify a system's time has not be altered by comparing it to the time on a specified Internet time server. Sometimes, the availability of time servers may be somewhat unreliable (which is why this class allows you to specify multiple servers as fallbacks), and it is common for SNTP requests to be blocked by firewalls and proxy servers.

Additionally, although it is technically possible to perform SNTP requests against public NTP servers in your application, we strongly recommend you get approval from the time server's administrators/owners first (as this could cause unexpected load on their time servers, which could cause problems for you and everyone else who might rely on them).

See Also

Reference

com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation Constructor

SystemDateTimeValidation Constructor
Overload List
 | Name | Description
Public method | SystemDateTimeValidation | Creates a new SystemDateTimeValidation object which requires successful validation with an Internet time server (requires Internet connectivity). The AddTimeServerCheck(String) method will need to be called at least once to allow validation to occur.
Public method | SystemDateTimeValidation(Boolean) | Creates a new SystemDateTimeValidation object. The AddTimeServerCheck(String) method will need to be called at least once to allow validation to occur.
Public method | SystemDateTimeValidation(Boolean, Double) | Creates a new SystemDateTimeValidation object. The AddTimeServerCheck(String) method will need to be called at least once to allow validation to occur.
Top
See Also

Reference

SystemDateTimeValidation Class
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation Constructor

SystemDateTimeValidation Constructor
Creates a new SystemDateTimeValidation object which requires successful validation with an Internet time server (requires Internet connectivity). The AddTimeServerCheck(String) method will need to be called at least once to allow validation to occur.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemDateTimeValidation()
Public Sub New
public:
SystemDateTimeValidation()
See Also

Reference

SystemDateTimeValidation Class
SystemDateTimeValidation Overload
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation Constructor (Boolean)

SystemDateTimeValidation Constructor (Boolean)
Creates a new SystemDateTimeValidation object. The AddTimeServerCheck(String) method will need to be called at least once to allow validation to occur.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemDateTimeValidation(
    bool validationRequired
)
Public Sub New (
    validationRequired As Boolean
)
public:
SystemDateTimeValidation(
    bool validationRequired
)

Parameters

validationRequired
Type: SystemBoolean
Set to false if failure to reach an Internet time server is acceptable. Otherwise, set to true if validation (and consequently, Internet access) is required.
See Also

Reference

SystemDateTimeValidation Class
SystemDateTimeValidation Overload
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation Constructor (Boolean, Double)

SystemDateTimeValidation Constructor (Boolean, Double)
Creates a new SystemDateTimeValidation object. The AddTimeServerCheck(String) method will need to be called at least once to allow validation to occur.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemDateTimeValidation(
    bool validationRequired,
    double allowedVariation
)
Public Sub New (
    validationRequired As Boolean,
    allowedVariation As Double
)
public:
SystemDateTimeValidation(
    bool validationRequired,
    double allowedVariation
)

Parameters

validationRequired
Type: SystemBoolean
Set to false if failure to reach an Internet time server is acceptable. Otherwise, set to true if validation (and consequently, Internet access) is absolutely required.
allowedVariation
Type: SystemDouble
The amount of time (in minutes) found acceptable for variation between the current systems date/time versus the Internet time server's date/time
See Also

Reference

SystemDateTimeValidation Class
SystemDateTimeValidation Overload
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation Properties

SystemDateTimeValidation Properties

The SystemDateTimeValidation type exposes the following members.

Properties
 | Name | Description
Public property | AllowedVariation | Gets or sets the amount of time (in minutes) of acceptable variation between the current system's date/time versus the Internet time server's date/time. (5.0 by default)
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | ValidationRequired | Gets or sets whether or not validation with an Internet time server is required. Internet connectivity is required if true. (True by default)
Top
See Also

Reference

SystemDateTimeValidation Class
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation.AllowedVariation Property

SystemDateTimeValidationAllowedVariation Property
Gets or sets the amount of time (in minutes) of acceptable variation between the current system's date/time versus the Internet time server's date/time. (5.0 by default)

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public double AllowedVariation { get; set; }
Public Property AllowedVariation As Double
    Get
    Set
public:
property double AllowedVariation {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SystemDateTimeValidation Class
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation.ValidationRequired Property

SystemDateTimeValidationValidationRequired Property
Gets or sets whether or not validation with an Internet time server is required. Internet connectivity is required if true. (True by default)

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool ValidationRequired { get; set; }
Public Property ValidationRequired As Boolean
    Get
    Set
public:
property bool ValidationRequired {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SystemDateTimeValidation Class
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation Methods

SystemDateTimeValidation Methods

The SystemDateTimeValidation type exposes the following members.

Methods
 | Name | Description
Public method | AddTimeServerCheck(String) | Adds an SNTP server to the list of servers to check.
Public method | AddTimeServerCheck(String, Int32) | Add an SNTP server to the list of servers to check.
Public method | AddTimeServerCheck(String, Int32, Int32, Int32) | Add an SNTP server to the list of servers to check.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates the current system's Date/Time against that of Internet time servers. (Overrides SystemValidationValidate.)
Top
See Also

Reference

SystemDateTimeValidation Class
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation.AddTimeServerCheck Method

SystemDateTimeValidationAddTimeServerCheck Method
Overload List
 | Name | Description
Public method | AddTimeServerCheck(String) | Adds an SNTP server to the list of servers to check.
Public method | AddTimeServerCheck(String, Int32) | Add an SNTP server to the list of servers to check.
Public method | AddTimeServerCheck(String, Int32, Int32, Int32) | Add an SNTP server to the list of servers to check.
Top
See Also

Reference

SystemDateTimeValidation Class
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation.AddTimeServerCheck Method (String)

SystemDateTimeValidationAddTimeServerCheck Method (String)
Adds an SNTP server to the list of servers to check.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddTimeServerCheck(
    string host
)
Public Sub AddTimeServerCheck (
    host As String
)
public:
void AddTimeServerCheck(
    String^ host
)

Parameters

host
Type: SystemString
The host name or IP address of the Internet time server.
See Also

Reference

SystemDateTimeValidation Class
AddTimeServerCheck Overload
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation.AddTimeServerCheck Method (String, Int32)

SystemDateTimeValidationAddTimeServerCheck Method (String, Int32)
Add an SNTP server to the list of servers to check.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddTimeServerCheck(
    string host,
    int port
)
Public Sub AddTimeServerCheck (
    host As String,
    port As Integer
)
public:
void AddTimeServerCheck(
    String^ host,
    int port
)

Parameters

host
Type: SystemString
The host name or IP address of the Internet time server.
port
Type: SystemInt32
The port from which the time server's NTP service may be reach (default is 123).
See Also

Reference

SystemDateTimeValidation Class
AddTimeServerCheck Overload
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation.AddTimeServerCheck Method (String, Int32, Int32, Int32)

SystemDateTimeValidationAddTimeServerCheck Method (String, Int32, Int32, Int32)
Add an SNTP server to the list of servers to check.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddTimeServerCheck(
    string host,
    int port,
    int sendTimeout,
    int receiveTimeout
)
Public Sub AddTimeServerCheck (
    host As String,
    port As Integer,
    sendTimeout As Integer,
    receiveTimeout As Integer
)
public:
void AddTimeServerCheck(
    String^ host,
    int port,
    int sendTimeout,
    int receiveTimeout
)

Parameters

host
Type: SystemString
The host name or IP address of the Internet time server.
port
Type: SystemInt32
The port from which the time server's NTP service may be reach (default is 123).
sendTimeout
Type: SystemInt32
The amount of time(in milliseconds) before the attempt to send the request times out (default is 1000).
receiveTimeout
Type: SystemInt32
The amount of time(in milliseconds) before the attempt to receive the request times out (default is 2000).
See Also

Reference

SystemDateTimeValidation Class
AddTimeServerCheck Overload
com.softwarekey.Client.Licensing Namespace


SystemDateTimeValidation.Validate Method

SystemDateTimeValidationValidate Method
Validates the current system's Date/Time against that of Internet time servers.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Validate()
Public Overrides Function Validate As Boolean
public:
virtual bool Validate() override

Return Value

Type: Boolean
Returns true if validation is successful. If validation does not pass, check the LastError property for details.
See Also

Reference

SystemDateTimeValidation Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier Class

SystemIdentifier Class
Abstract System Identifier class, from which all SystemIdentifiers are implemented
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
More...

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class SystemIdentifier
Public MustInherit Class SystemIdentifier
public ref class SystemIdentifier abstract

The SystemIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | SystemIdentifier | Creates a new SystemIdentifier object.
Public method | SystemIdentifier(String) | Creates a new SystemIdentifier object, initialized with the value.
Public method | SystemIdentifier(String, String) | Creates a new SystemIdentifier object, initialized with the name and value.
Public method | SystemIdentifier(String, String, String, String) | Creates a new SystemIdentifier object, initialized with the name, value, and hash.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier.
Public property | Type | Gets the system identifier's type.
Public property | Value | Gets or sets the plain-text value of the system identifier.
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value.
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | GenerateActivationDataXml | Generates an Activation Data XML document from a specified list of SystemIdentifier objects.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service.
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Overrides ObjectToString.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier.
 | TryParse | Parses an XML string representation of a System Identifier.
Top
Operators
Name | Description
Equality | Compares two SystemIdentifier objects to see if they identify a the same component.
Inequality | Compares two SystemIdentifier objects to see if they identify a different component.
Top
Fields
 | Name | Description
 | m_defaultIdNumber | The static member for tracking default identifiers generated
Protected field | m_name | The unique identifier name
Protected field | m_type | The type of identifier
Protected field | m_value | The identifier value
Protected field | m_valueHash | The hash of the identifier value
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingBiosUuidIdentifier
com.softwarekey.Client.LicensingComputerNameIdentifier
com.softwarekey.Client.LicensingCustomSystemIdentifier
com.softwarekey.Client.LicensingDomainNameIdentifier
com.softwarekey.Client.LicensingHardDiskVolumeSerialIdentifier
com.softwarekey.Client.LicensingLicenseIDIdentifier
com.softwarekey.Client.LicensingNetworkNameIdentifier
com.softwarekey.Client.LicensingNicIdentifier
com.softwarekey.Client.LicensingProcessorNameIdentifier
com.softwarekey.Client.LicensingProcessorVendorIdentifier
com.softwarekey.Client.LicensingProcessorVersionIdentifier
com.softwarekey.Client.LicensingServerHostNameIdentifier
com.softwarekey.Client.LicensingUserNameIdentifier


SystemIdentifier Constructor

SystemIdentifier Constructor
Overload List
 | Name | Description
Public method | SystemIdentifier | Creates a new SystemIdentifier object.
Public method | SystemIdentifier(String) | Creates a new SystemIdentifier object, initialized with the value.
Public method | SystemIdentifier(String, String) | Creates a new SystemIdentifier object, initialized with the name and value.
Public method | SystemIdentifier(String, String, String, String) | Creates a new SystemIdentifier object, initialized with the name, value, and hash.
Top
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier Constructor

SystemIdentifier Constructor
Creates a new SystemIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemIdentifier()
Public Sub New
public:
SystemIdentifier()
See Also

Reference

SystemIdentifier Class
SystemIdentifier Overload
com.softwarekey.Client.Licensing Namespace


SystemIdentifier Constructor (String)

SystemIdentifier Constructor (String)
Creates a new SystemIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
SystemIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The identifier's value.
See Also

Reference

SystemIdentifier Class
SystemIdentifier Overload
com.softwarekey.Client.Licensing Namespace


SystemIdentifier Constructor (String, String)

SystemIdentifier Constructor (String, String)
Creates a new SystemIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
SystemIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the SystemIdentifier (i.e. NicIdentifier1).
value
Type: SystemString
The identifier's value.
See Also

Reference

SystemIdentifier Class
SystemIdentifier Overload
com.softwarekey.Client.Licensing Namespace


SystemIdentifier Constructor (String, String, String, String)

SystemIdentifier Constructor (String, String, String, String)
Creates a new SystemIdentifier object, initialized with the name, value, and hash.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemIdentifier(
    string name,
    string value,
    string hash,
    string type
)
Public Sub New (
    name As String,
    value As String,
    hash As String,
    type As String
)
public:
SystemIdentifier(
    String^ name,
    String^ value,
    String^ hash,
    String^ type
)

Parameters

name
Type: SystemString
The name of the SystemIdentifier (i.e. NicIdentifier1).
value
Type: SystemString
The identifier's value.
hash
Type: SystemString
A hash of the identifier's value.
type
Type: SystemString
The type of system identifier (i.e. NicIdentifier).
See Also

Reference

SystemIdentifier Class
SystemIdentifier Overload
com.softwarekey.Client.Licensing Namespace


SystemIdentifier Properties

SystemIdentifier Properties

The SystemIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier.
Public property | Type | Gets the system identifier's type.
Public property | Value | Gets or sets the plain-text value of the system identifier.
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value.
Top
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.Name Property

SystemIdentifierName Property
Gets or sets the name of the system identifier.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.Type Property

SystemIdentifierType Property
Gets the system identifier's type.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract string Type { get; }
Public MustOverride ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () abstract;
}

Property Value

Type: String
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.Value Property

SystemIdentifierValue Property
Gets or sets the plain-text value of the system identifier.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.ValueHash Property

SystemIdentifierValueHash Property
Gets or sets the SHA-512 hash generated from the Value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ValueHash { get; set; }
Public Property ValueHash As String
    Get
    Set
public:
property String^ ValueHash {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier Methods

SystemIdentifier Methods

The SystemIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | GenerateActivationDataXml | Generates an Activation Data XML document from a specified list of SystemIdentifier objects.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service.
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Overrides ObjectToString.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier.
 | TryParse | Parses an XML string representation of a System Identifier.
Top
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.Equals Method

SystemIdentifierEquals Method
Compares two SystemIdentifier objects to see if they identify a the same component.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The SystemIdentifier object to compare.

Return Value

Type: Boolean
Returns true if the objects identify the same component. This is determined by the Type and ValueHash properties.
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.GenerateActivationDataXml Method

SystemIdentifierGenerateActivationDataXml Method
Generates an Activation Data XML document from a specified list of SystemIdentifier objects.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlDocument GenerateActivationDataXml(
    List<SystemIdentifier> identifiers
)
Public Shared Function GenerateActivationDataXml (
    identifiers As List(Of SystemIdentifier)
) As XmlDocument
public:
static XmlDocument^ GenerateActivationDataXml(
    List<SystemIdentifier^>^ identifiers
)

Parameters

identifiers
Type: System.Collections.GenericList SystemIdentifier
A generic list of SystemIdentifier objects.

Return Value

Type: XmlDocument
Returns an XmlDocument with the SystemIdentifier data, which may be used for activation requests.
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.GetHashCode Method

SystemIdentifierGetHashCode Method
Serves as a hash function for a particular type.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override

Return Value

Type: Int32
Returns the hash code for the current object.
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.ToActivationDataString Method

SystemIdentifierToActivationDataString Method
Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ToActivationDataString()
Public Function ToActivationDataString As String
public:
String^ ToActivationDataString()

Return Value

Type: String
Returns an XML formatted string.
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.ToString Method

SystemIdentifierToString Method
Generates an XML formatted string of the SystemIdentifier.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
Returns an XML formatted string.
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.ToXml Method

SystemIdentifierToXml Method
Generates an XmlDocument of the SystemIdentifier.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlDocument ToXml()
Public Function ToXml As XmlDocument
public:
XmlDocument^ ToXml()

Return Value

Type: XmlDocument
Returns an XmlDocument composed of the SystemIdentifier data.
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.TryParse Method

SystemIdentifierTryParse Method
Parses an XML string representation of a System Identifier.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static bool TryParse(
    string value,
    out SystemIdentifier identifier
)
Public Shared Function TryParse (
    value As String,
    <OutAttribute> ByRef identifier As SystemIdentifier
) As Boolean
public:
static bool TryParse(
    String^ value,
    [OutAttribute] SystemIdentifier^% identifier
)

Parameters

value
Type: SystemString
The string to try to parse.
identifier
Type: com.softwarekey.Client.LicensingSystemIdentifier
The resulting SystemIdentifier.

Return Value

Type: Boolean
Returns true if the value was parsed successfully.
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier Operators

SystemIdentifier Operators

The SystemIdentifier type exposes the following members.

Operators
Name | Description
Equality | Compares two SystemIdentifier objects to see if they identify a the same component.
Inequality | Compares two SystemIdentifier objects to see if they identify a different component.
Top
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.Equality Operator

SystemIdentifierEquality Operator
Compares two SystemIdentifier objects to see if they identify a the same component.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static bool operator ==(
    SystemIdentifier a,
    SystemIdentifier b
)
Public Shared Operator = (
    a As SystemIdentifier,
    b As SystemIdentifier
) As Boolean
public:
static bool operator ==(
    SystemIdentifier^ a,
    SystemIdentifier^ b
)

Parameters

a
Type: com.softwarekey.Client.LicensingSystemIdentifier
The first SystemIdentifier object to compare.
b
Type: com.softwarekey.Client.LicensingSystemIdentifier
The second SystemIdentifier object to compare.

Return Value

Type: Boolean
Returns true if the objects identify the same component. This is determined by the Type and ValueHash properties.
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.Inequality Operator

SystemIdentifierInequality Operator
Compares two SystemIdentifier objects to see if they identify a different component.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static bool operator !=(
    SystemIdentifier a,
    SystemIdentifier b
)
Public Shared Operator <> (
    a As SystemIdentifier,
    b As SystemIdentifier
) As Boolean
public:
static bool operator !=(
    SystemIdentifier^ a,
    SystemIdentifier^ b
)

Parameters

a
Type: com.softwarekey.Client.LicensingSystemIdentifier
The first SystemIdentifier object to compare.
b
Type: com.softwarekey.Client.LicensingSystemIdentifier
The second SystemIdentifier object to compare.

Return Value

Type: Boolean
Returns true if the objects do not identify the same component. This is determined by the Type and ValueHash properties.
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier Fields

SystemIdentifier Fields

The SystemIdentifier type exposes the following members.

Fields
 | Name | Description
 | m_defaultIdNumber | The static member for tracking default identifiers generated
Protected field | m_name | The unique identifier name
Protected field | m_type | The type of identifier
Protected field | m_value | The identifier value
Protected field | m_valueHash | The hash of the identifier value
Top
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.m_defaultIdNumber Field

SystemIdentifierm_defaultIdNumber Field
The static member for tracking default identifiers generated

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected static int m_defaultIdNumber
Protected Shared m_defaultIdNumber As Integer
protected:
static int m_defaultIdNumber

Field Value

Type: Int32
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.m_name Field

SystemIdentifierm_name Field
The unique identifier name

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected string m_name
Protected m_name As String
protected:
String^ m_name

Field Value

Type: String
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.m_type Field

SystemIdentifierm_type Field
The type of identifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected string m_type
Protected m_type As String
protected:
String^ m_type

Field Value

Type: String
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.m_value Field

SystemIdentifierm_value Field
The identifier value

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected string m_value
Protected m_value As String
protected:
String^ m_value

Field Value

Type: String
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifier.m_valueHash Field

SystemIdentifierm_valueHash Field
The hash of the identifier value

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected string m_valueHash
Protected m_valueHash As String
protected:
String^ m_valueHash

Field Value

Type: String
See Also

Reference

SystemIdentifier Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierAlgorithm Class

SystemIdentifierAlgorithm Class
Abstract class from which all SystemIdentifierAlgorithm implementations are derived.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
More...

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class SystemIdentifierAlgorithm
Public MustInherit Class SystemIdentifierAlgorithm
public ref class SystemIdentifierAlgorithm abstract

The SystemIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | SystemIdentifierAlgorithm | Creates a new SystemIdentifierAlgorithm object.
Public method | SystemIdentifierAlgorithm(String) | SystemIdentifierAlgorithm constructor allowing a custom algorithm name to be specified.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of SystemIdentifier objects for the implemented algorithm.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingBiosUuidIdentifierAlgorithm
com.softwarekey.Client.LicensingComputerNameIdentifierAlgorithm
com.softwarekey.Client.LicensingDomainNameIdentifierAlgorithm
com.softwarekey.Client.LicensingHardDiskVolumeSerialIdentifierAlgorithm
com.softwarekey.Client.LicensingLicenseIDIdentifierAlgorithm
com.softwarekey.Client.LicensingNetworkNameIdentifierAlgorithm
com.softwarekey.Client.LicensingNicIdentifierAlgorithm
com.softwarekey.Client.LicensingProcessorIdentifierAlgorithm
com.softwarekey.Client.LicensingServerHostNameIdentifierAlgorithm
com.softwarekey.Client.LicensingUserNameIdentifierAlgorithm


SystemIdentifierAlgorithm Constructor

SystemIdentifierAlgorithm Constructor
Overload List
 | Name | Description
Public method | SystemIdentifierAlgorithm | Creates a new SystemIdentifierAlgorithm object.
Public method | SystemIdentifierAlgorithm(String) | SystemIdentifierAlgorithm constructor allowing a custom algorithm name to be specified.
Top
See Also

Reference

SystemIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierAlgorithm Constructor

SystemIdentifierAlgorithm Constructor
Creates a new SystemIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemIdentifierAlgorithm()
Public Sub New
public:
SystemIdentifierAlgorithm()
See Also

Reference

SystemIdentifierAlgorithm Class
SystemIdentifierAlgorithm Overload
com.softwarekey.Client.Licensing Namespace


SystemIdentifierAlgorithm Constructor (String)

SystemIdentifierAlgorithm Constructor (String)
SystemIdentifierAlgorithm constructor allowing a custom algorithm name to be specified.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemIdentifierAlgorithm(
    string algorithmId
)
Public Sub New (
    algorithmId As String
)
public:
SystemIdentifierAlgorithm(
    String^ algorithmId
)

Parameters

algorithmId
Type: SystemString
The name of the algorithm being used (i.e. "NicIdentifier").
See Also

Reference

SystemIdentifierAlgorithm Class
SystemIdentifierAlgorithm Overload
com.softwarekey.Client.Licensing Namespace


SystemIdentifierAlgorithm Methods

SystemIdentifierAlgorithm Methods

The SystemIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of SystemIdentifier objects for the implemented algorithm.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SystemIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierAlgorithm.GetIdentifiers Method

SystemIdentifierAlgorithmGetIdentifiers Method
Generates a generic list of SystemIdentifier objects for the implemented algorithm.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract List<SystemIdentifier> GetIdentifiers()
Public MustOverride Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() abstract

Return Value

Type: List SystemIdentifier
Returns a generic list of SystemIdentifier objects.
See Also

Reference

SystemIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierAlgorithm Fields

SystemIdentifierAlgorithm Fields

The SystemIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated
Top
See Also

Reference

SystemIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierAlgorithm.m_algorithmId Field

SystemIdentifierAlgorithmm_algorithmId Field
Static member for tracking default identifiers generated

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected string m_algorithmId
Protected m_algorithmId As String
protected:
String^ m_algorithmId

Field Value

Type: String
See Also

Reference

SystemIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation Class

SystemIdentifierValidation Class
Implements basic validation of authorized system identification information against the current system's identification information.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
com.softwarekey.Client.LicensingSystemIdentifierValidation

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class SystemIdentifierValidation : SystemValidation
Public Class SystemIdentifierValidation
    Inherits SystemValidation
public ref class SystemIdentifierValidation : public SystemValidation

The SystemIdentifierValidation type exposes the following members.

Constructors
 | Name | Description
Public method | SystemIdentifierValidation | Creates a new SystemIdentifierValidation object.
Public method | SystemIdentifierValidation(ListSystemIdentifier, ListSystemIdentifier, Int32) | Creates a new SystemIdentifierValidation object with all required validation data.
Top
Properties
 | Name | Description
Public property | AuthorizedIdentifiers | Gets or sets a generic list of authorized SystemIdentifier objects.
Public property | CurrentIdentifiers | Gets or sets a generic list of the current system's SystemIdentifier objects
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | RequiredMatches | Gets or sets the number of required matching system identifiers. Use SystemIdentifierValidation.REQUIRE_EXACT_MATCH to require an exact match (which is the default).
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Compares the current system identifiers against the authorized system identifiers, and returns true if it successfully validates and confirms the current system's identity. (Overrides SystemValidationValidate.)
Top
Fields
Name | Description
REQUIRE_EXACT_MATCH | Constant for the value to use to indicate that an exact match is required
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation Constructor

SystemIdentifierValidation Constructor
Overload List
 | Name | Description
Public method | SystemIdentifierValidation | Creates a new SystemIdentifierValidation object.
Public method | SystemIdentifierValidation(ListSystemIdentifier, ListSystemIdentifier, Int32) | Creates a new SystemIdentifierValidation object with all required validation data.
Top
See Also

Reference

SystemIdentifierValidation Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation Constructor

SystemIdentifierValidation Constructor
Creates a new SystemIdentifierValidation object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemIdentifierValidation()
Public Sub New
public:
SystemIdentifierValidation()
See Also

Reference

SystemIdentifierValidation Class
SystemIdentifierValidation Overload
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation Constructor (List(SystemIdentifier), List(SystemIdentifier), Int32)

SystemIdentifierValidation Constructor (ListSystemIdentifier, ListSystemIdentifier, Int32)
Creates a new SystemIdentifierValidation object with all required validation data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemIdentifierValidation(
    List<SystemIdentifier> authorizedIdentifiers,
    List<SystemIdentifier> currentIdentifiers,
    int requiredMatches
)
Public Sub New (
    authorizedIdentifiers As List(Of SystemIdentifier),
    currentIdentifiers As List(Of SystemIdentifier),
    requiredMatches As Integer
)
public:
SystemIdentifierValidation(
    List<SystemIdentifier^>^ authorizedIdentifiers,
    List<SystemIdentifier^>^ currentIdentifiers,
    int requiredMatches
)

Parameters

authorizedIdentifiers
Type: System.Collections.GenericList SystemIdentifier
Generic list of authorized SystemIdentifier objects.
currentIdentifiers
Type: System.Collections.GenericList SystemIdentifier
>Generic list of the current system's SystemIdentifier objects.
requiredMatches
Type: SystemInt32
The number of required matching system identifiers. Use SystemIdentifierValidation.REQUIRE_EXACT_MATCH to require an exact match (which is the default).
See Also

Reference

SystemIdentifierValidation Class
SystemIdentifierValidation Overload
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation Properties

SystemIdentifierValidation Properties

The SystemIdentifierValidation type exposes the following members.

Properties
 | Name | Description
Public property | AuthorizedIdentifiers | Gets or sets a generic list of authorized SystemIdentifier objects.
Public property | CurrentIdentifiers | Gets or sets a generic list of the current system's SystemIdentifier objects
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | RequiredMatches | Gets or sets the number of required matching system identifiers. Use SystemIdentifierValidation.REQUIRE_EXACT_MATCH to require an exact match (which is the default).
Top
See Also

Reference

SystemIdentifierValidation Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation.AuthorizedIdentifiers Property

SystemIdentifierValidationAuthorizedIdentifiers Property
Gets or sets a generic list of authorized SystemIdentifier objects.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<SystemIdentifier> AuthorizedIdentifiers { get; set; }
Public Property AuthorizedIdentifiers As List(Of SystemIdentifier)
    Get
    Set
public:
property List<SystemIdentifier^>^ AuthorizedIdentifiers {
    List<SystemIdentifier^>^ get ();
    void set (List<SystemIdentifier^>^ value);
}

Property Value

Type: List SystemIdentifier
See Also

Reference

SystemIdentifierValidation Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation.CurrentIdentifiers Property

SystemIdentifierValidationCurrentIdentifiers Property
Gets or sets a generic list of the current system's SystemIdentifier objects

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<SystemIdentifier> CurrentIdentifiers { get; set; }
Public Property CurrentIdentifiers As List(Of SystemIdentifier)
    Get
    Set
public:
property List<SystemIdentifier^>^ CurrentIdentifiers {
    List<SystemIdentifier^>^ get ();
    void set (List<SystemIdentifier^>^ value);
}

Property Value

Type: List SystemIdentifier
See Also

Reference

SystemIdentifierValidation Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation.RequiredMatches Property

SystemIdentifierValidationRequiredMatches Property
Gets or sets the number of required matching system identifiers. Use SystemIdentifierValidation.REQUIRE_EXACT_MATCH to require an exact match (which is the default).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int RequiredMatches { get; set; }
Public Property RequiredMatches As Integer
    Get
    Set
public:
property int RequiredMatches {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SystemIdentifierValidation Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation Methods

SystemIdentifierValidation Methods

The SystemIdentifierValidation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Compares the current system identifiers against the authorized system identifiers, and returns true if it successfully validates and confirms the current system's identity. (Overrides SystemValidationValidate.)
Top
See Also

Reference

SystemIdentifierValidation Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation.Validate Method

SystemIdentifierValidationValidate Method
Compares the current system identifiers against the authorized system identifiers, and returns true if it successfully validates and confirms the current system's identity.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Validate()
Public Overrides Function Validate As Boolean
public:
virtual bool Validate() override

Return Value

Type: Boolean
Returns true if validation is successful, which would indicate the current systems identity is that which was authorized. If it is not successful, check the LastError property for details.
See Also

Reference

SystemIdentifierValidation Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation Fields

SystemIdentifierValidation Fields

The SystemIdentifierValidation type exposes the following members.

Fields
Name | Description
REQUIRE_EXACT_MATCH | Constant for the value to use to indicate that an exact match is required
Top
See Also

Reference

SystemIdentifierValidation Class
com.softwarekey.Client.Licensing Namespace


SystemIdentifierValidation.REQUIRE_EXACT_MATCH Field

SystemIdentifierValidationREQUIRE_EXACT_MATCH Field
Constant for the value to use to indicate that an exact match is required

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public const int REQUIRE_EXACT_MATCH = -1
Public Const REQUIRE_EXACT_MATCH As Integer = -1
public:
literal int REQUIRE_EXACT_MATCH = -1

Field Value

Type: Int32
See Also

Reference

SystemIdentifierValidation Class
com.softwarekey.Client.Licensing Namespace


SystemValidation Class

SystemValidation Class
Base class from which for all system validations are implemented.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
More...

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class SystemValidation
Public MustInherit Class SystemValidation
public ref class SystemValidation abstract

The SystemValidation type exposes the following members.

Constructors
 | Name | Description
Protected method | SystemValidation | Initializes a new instance of the SystemValidation class
Top
Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Performs the system validation.
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
com.softwarekey.Client.LicensingLicenseAliasValidation
com.softwarekey.Client.LicensingLicenseEffectiveDateValidation
com.softwarekey.Client.LicensingLicenseProductValidation
com.softwarekey.Client.Licensing.NetworkNetworkSessionValidation
com.softwarekey.Client.LicensingRemoteSessionValidation
com.softwarekey.Client.LicensingSystemClockValidation
com.softwarekey.Client.LicensingSystemDateTimeValidation
com.softwarekey.Client.LicensingSystemIdentifierValidation
com.softwarekey.Client.LicensingVirtualMachineValidation


SystemValidation Constructor

SystemValidation Constructor
Initializes a new instance of the SystemValidation class

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected SystemValidation()
Protected Sub New
protected:
SystemValidation()
See Also

Reference

SystemValidation Class
com.softwarekey.Client.Licensing Namespace


SystemValidation Properties

SystemValidation Properties

The SystemValidation type exposes the following members.

Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object.
Top
See Also

Reference

SystemValidation Class
com.softwarekey.Client.Licensing Namespace


SystemValidation.LastError Property

SystemValidationLastError Property
Gets or sets the last error encountered in this object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual LicenseError LastError { get; set; }
Public Overridable Property LastError As LicenseError
    Get
    Set
public:
virtual property LicenseError^ LastError {
    LicenseError^ get ();
    void set (LicenseError^ value);
}

Property Value

Type: LicenseError
See Also

Reference

SystemValidation Class
com.softwarekey.Client.Licensing Namespace


SystemValidation Methods

SystemValidation Methods

The SystemValidation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Performs the system validation.
Top
See Also

Reference

SystemValidation Class
com.softwarekey.Client.Licensing Namespace


SystemValidation.Validate Method

SystemValidationValidate Method
Performs the system validation.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract bool Validate()
Public MustOverride Function Validate As Boolean
public:
virtual bool Validate() abstract

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

SystemValidation Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifier Class

UserNameIdentifier Class
SystemIdentifier implementation for a user name. These identifiers are generated by UserNameIdentifierAlgorithm.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifier
com.softwarekey.Client.LicensingUserNameIdentifier

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class UserNameIdentifier : SystemIdentifier
Public Class UserNameIdentifier
    Inherits SystemIdentifier
public ref class UserNameIdentifier : public SystemIdentifier

The UserNameIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | UserNameIdentifier | Creates a new UserNameIdentifier object.
Public method | UserNameIdentifier(String) | Creates a new UserNameIdentifier object, initialized with the value.
Public method | UserNameIdentifier(String, String) | Creates a new UserNameIdentifier object, initialized with the name and value.
Public method | UserNameIdentifier(String, String, String) | Creates a new UserNameIdentifier object, initialized with the name and value.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("UserNameIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
 | m_userNameIdentifierId | The static member for tracking default identifiers generated.
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


UserNameIdentifier Constructor

UserNameIdentifier Constructor
Overload List
 | Name | Description
Public method | UserNameIdentifier | Creates a new UserNameIdentifier object.
Public method | UserNameIdentifier(String) | Creates a new UserNameIdentifier object, initialized with the value.
Public method | UserNameIdentifier(String, String) | Creates a new UserNameIdentifier object, initialized with the name and value.
Public method | UserNameIdentifier(String, String, String) | Creates a new UserNameIdentifier object, initialized with the name and value.
Top
See Also

Reference

UserNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifier Constructor

UserNameIdentifier Constructor
Creates a new UserNameIdentifier object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UserNameIdentifier()
Public Sub New
public:
UserNameIdentifier()
See Also

Reference

UserNameIdentifier Class
UserNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


UserNameIdentifier Constructor (String)

UserNameIdentifier Constructor (String)
Creates a new UserNameIdentifier object, initialized with the value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UserNameIdentifier(
    string value
)
Public Sub New (
    value As String
)
public:
UserNameIdentifier(
    String^ value
)

Parameters

value
Type: SystemString
The username of the user running the application when the identifier was created.
See Also

Reference

UserNameIdentifier Class
UserNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


UserNameIdentifier Constructor (String, String)

UserNameIdentifier Constructor (String, String)
Creates a new UserNameIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UserNameIdentifier(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
UserNameIdentifier(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the UserNameIdentifier object.
value
Type: SystemString
The username of the user running the application when the identifier was created.
See Also

Reference

UserNameIdentifier Class
UserNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


UserNameIdentifier Constructor (String, String, String)

UserNameIdentifier Constructor (String, String, String)
Creates a new UserNameIdentifier object, initialized with the name and value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UserNameIdentifier(
    string name,
    string value,
    string hash
)
Public Sub New (
    name As String,
    value As String,
    hash As String
)
public:
UserNameIdentifier(
    String^ name,
    String^ value,
    String^ hash
)

Parameters

name
Type: SystemString
The name of the UserNameIdentifier object.
value
Type: SystemString
The username of the user running the application when the identifier was created.
hash
Type: SystemString
Hash of the username of the user running the application when the identifier was created.
See Also

Reference

UserNameIdentifier Class
UserNameIdentifier Overload
com.softwarekey.Client.Licensing Namespace


UserNameIdentifier Properties

UserNameIdentifier Properties

The UserNameIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the system identifier. (Inherited from SystemIdentifier.)
Public property | Type | Gets this system identifier's type ("UserNameIdentifier"). (Overrides SystemIdentifierType.)
Public property | Value | Gets or sets the plain-text value of the system identifier. (Inherited from SystemIdentifier.)
Public property | ValueHash | Gets or sets the SHA-512 hash generated from the Value. (Inherited from SystemIdentifier.)
Top
See Also

Reference

UserNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifier.Type Property

UserNameIdentifierType Property
Gets this system identifier's type ("UserNameIdentifier").

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string Type { get; }
Public Overrides ReadOnly Property Type As String
    Get
public:
virtual property String^ Type {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

UserNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifier Methods

UserNameIdentifier Methods

The UserNameIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two SystemIdentifier objects to see if they identify a the same component. (Inherited from SystemIdentifier.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from SystemIdentifier.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToActivationDataString | Generates an XML formatted string of the system identifier, formatted for SOLO Server's XmlActivationService web service. (Inherited from SystemIdentifier.)
Public method | ToString | Generates an XML formatted string of the SystemIdentifier. (Inherited from SystemIdentifier.)
Public method | ToXml | Generates an XmlDocument of the SystemIdentifier. (Inherited from SystemIdentifier.)
Top
See Also

Reference

UserNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifier Fields

UserNameIdentifier Fields

The UserNameIdentifier type exposes the following members.

Fields
 | Name | Description
Protected field | m_name | The unique identifier name (Inherited from SystemIdentifier.)
Protected field | m_type | The type of identifier (Inherited from SystemIdentifier.)
 | m_userNameIdentifierId | The static member for tracking default identifiers generated.
Protected field | m_value | The identifier value (Inherited from SystemIdentifier.)
Protected field | m_valueHash | The hash of the identifier value (Inherited from SystemIdentifier.)
Top
See Also

Reference

UserNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifier.m_userNameIdentifierId Field

UserNameIdentifierm_userNameIdentifierId Field
The static member for tracking default identifiers generated.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected static int m_userNameIdentifierId
Protected Shared m_userNameIdentifierId As Integer
protected:
static int m_userNameIdentifierId

Field Value

Type: Int32
See Also

Reference

UserNameIdentifier Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifierAlgorithm Class

UserNameIdentifierAlgorithm Class
SystemIdentifierAlgorithm implementation for identifying a username on a system.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemIdentifierAlgorithm
com.softwarekey.Client.LicensingUserNameIdentifierAlgorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class UserNameIdentifierAlgorithm : SystemIdentifierAlgorithm
Public Class UserNameIdentifierAlgorithm
    Inherits SystemIdentifierAlgorithm
public ref class UserNameIdentifierAlgorithm : public SystemIdentifierAlgorithm

The UserNameIdentifierAlgorithm type exposes the following members.

Constructors
 | Name | Description
Public method | UserNameIdentifierAlgorithm | Creates a new UserNameIdentifierAlgorithm object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of UserNameIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | thisAlgorithmId | The name of this algorithm
Top
See Also

Reference

com.softwarekey.Client.Licensing Namespace


UserNameIdentifierAlgorithm Constructor

UserNameIdentifierAlgorithm Constructor
Creates a new UserNameIdentifierAlgorithm object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UserNameIdentifierAlgorithm()
Public Sub New
public:
UserNameIdentifierAlgorithm()
See Also

Reference

UserNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifierAlgorithm Methods

UserNameIdentifierAlgorithm Methods

The UserNameIdentifierAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIdentifiers | Generates a generic list of UserNameIdentifier objects. (Overrides SystemIdentifierAlgorithmGetIdentifiers.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

UserNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifierAlgorithm.GetIdentifiers Method

UserNameIdentifierAlgorithmGetIdentifiers Method
Generates a generic list of UserNameIdentifier objects.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override List<SystemIdentifier> GetIdentifiers()
Public Overrides Function GetIdentifiers As List(Of SystemIdentifier)
public:
virtual List<SystemIdentifier^>^ GetIdentifiers() override

Return Value

Type: List SystemIdentifier
Returns a generic list of UserNameIdentifier objects, which will always contain only 1 object (representing the current user logged into the system, running the application).
See Also

Reference

UserNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifierAlgorithm Fields

UserNameIdentifierAlgorithm Fields

The UserNameIdentifierAlgorithm type exposes the following members.

Fields
 | Name | Description
Protected field | m_algorithmId | Static member for tracking default identifiers generated (Inherited from SystemIdentifierAlgorithm.)
 | thisAlgorithmId | The name of this algorithm
Top
See Also

Reference

UserNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


UserNameIdentifierAlgorithm.thisAlgorithmId Field

UserNameIdentifierAlgorithmthisAlgorithmId Field
The name of this algorithm

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected const string thisAlgorithmId = "UserName"
Protected Const thisAlgorithmId As String = "UserName"
protected:
literal String^ thisAlgorithmId = "UserName"

Field Value

Type: String
See Also

Reference

UserNameIdentifierAlgorithm Class
com.softwarekey.Client.Licensing Namespace


VirtualMachineValidation Class

VirtualMachineValidation Class
Attempts to determine whether or not the application is running in a known virtual machine guest environment. See the VirtualMachineValidationVirtualMachineType enumeration for a list of supported hypervisors.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
com.softwarekey.Client.LicensingVirtualMachineValidation

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class VirtualMachineValidation : SystemValidation
Public Class VirtualMachineValidation
    Inherits SystemValidation
public ref class VirtualMachineValidation : public SystemValidation

The VirtualMachineValidation type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualMachineValidation | Creates a new VirtualMachineValidation object.
Public method | VirtualMachineValidation(SystemComponentInformation) | Creates a new VirtualMachineValidation object.
Top
Properties
 | Name | Description
Public property | IsVirtual | Gets whether the system is running on a virtual machine guest environment. (This property should only be referenced after calling the Validate method once.)
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | Type | Gets the type of virtual machine guest environment on which the system is running. (This property should only be referenced after calling the Validate method once.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Determines if the system is running on a virtual machine. (Overrides SystemValidationValidate.)
Top
Remarks
Caution note Caution

This class can only detect supported hypervisors, which are documented in the VirtualMachineValidationVirtualMachineType enumeration.

Caution note Caution

It is not possible to guarantee the detection of a virtual machine guest environment, as many hypervisors have settings (which may or may not even be officially supported or documented by the manufacturer of the hypervisor) which allow the hypervisor to change its behavior in ways that could make it difficult to detect. Despite this, this class has been designed to avoid this kind of weakness as much as reasonably possible. Additionally, using these settings for day-to-day application use is typically problematic, which makes it unlikely to encounter this kind of behavior (as users would not typically use such undocumented, unsupported, problematic settings).

See Also

Reference

com.softwarekey.Client.Licensing Namespace


VirtualMachineValidation Constructor

VirtualMachineValidation Constructor
Overload List
 | Name | Description
Public method | VirtualMachineValidation | Creates a new VirtualMachineValidation object.
Public method | VirtualMachineValidation(SystemComponentInformation) | Creates a new VirtualMachineValidation object.
Top
See Also

Reference

VirtualMachineValidation Class
com.softwarekey.Client.Licensing Namespace


VirtualMachineValidation Constructor

VirtualMachineValidation Constructor
Creates a new VirtualMachineValidation object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public VirtualMachineValidation()
Public Sub New
public:
VirtualMachineValidation()
See Also

Reference

VirtualMachineValidation Class
VirtualMachineValidation Overload
com.softwarekey.Client.Licensing Namespace


VirtualMachineValidation Constructor (SystemComponentInformation)

VirtualMachineValidation Constructor (SystemComponentInformation)
Creates a new VirtualMachineValidation object.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public VirtualMachineValidation(
    SystemComponentInformation sysInfo
)
Public Sub New (
    sysInfo As SystemComponentInformation
)
public:
VirtualMachineValidation(
    SystemComponentInformation^ sysInfo
)

Parameters

sysInfo
Type: com.softwarekey.Client.Utils.SystemComponentSystemComponentInformation
An instance of the SystemComponentInformation class to evaluate (Windows only).
See Also

Reference

VirtualMachineValidation Class
VirtualMachineValidation Overload
com.softwarekey.Client.Licensing Namespace


VirtualMachineValidation Properties

VirtualMachineValidation Properties

The VirtualMachineValidation type exposes the following members.

Properties
 | Name | Description
Public property | IsVirtual | Gets whether the system is running on a virtual machine guest environment. (This property should only be referenced after calling the Validate method once.)
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | Type | Gets the type of virtual machine guest environment on which the system is running. (This property should only be referenced after calling the Validate method once.)
Top
See Also

Reference

VirtualMachineValidation Class
com.softwarekey.Client.Licensing Namespace


VirtualMachineValidation.IsVirtual Property

VirtualMachineValidationIsVirtual Property
Gets whether the system is running on a virtual machine guest environment. (This property should only be referenced after calling the Validate method once.)

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool IsVirtual { get; }
Public ReadOnly Property IsVirtual As Boolean
    Get
public:
property bool IsVirtual {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

VirtualMachineValidation Class
com.softwarekey.Client.Licensing Namespace


VirtualMachineValidation.Type Property

VirtualMachineValidationType Property
Gets the type of virtual machine guest environment on which the system is running. (This property should only be referenced after calling the Validate method once.)

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public VirtualMachineValidationVirtualMachineType Type { get; }
Public ReadOnly Property Type As VirtualMachineValidationVirtualMachineType
    Get
public:
property VirtualMachineValidationVirtualMachineType Type {
    VirtualMachineValidationVirtualMachineType get ();
}

Property Value

Type: VirtualMachineValidationVirtualMachineType
See Also

Reference

VirtualMachineValidation Class
com.softwarekey.Client.Licensing Namespace


VirtualMachineValidation Methods

VirtualMachineValidation Methods

The VirtualMachineValidation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Determines if the system is running on a virtual machine. (Overrides SystemValidationValidate.)
Top
See Also

Reference

VirtualMachineValidation Class
com.softwarekey.Client.Licensing Namespace


VirtualMachineValidation.Validate Method

VirtualMachineValidationValidate Method
Determines if the system is running on a virtual machine.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Validate()
Public Overrides Function Validate As Boolean
public:
virtual bool Validate() override

Return Value

Type: Boolean
Returns true if the application is not running in a virtual machine guest environment. If a virtual machine guest environment was detected (or false is returned), check the Type property to find which hypervisor was detected.
Remarks
Caution note Caution

This method runs WMI queries on Windows guests, which can take a while to run on some computers. If you run this (Validate) method once, and retain the reference to the VirtualMachineValidation object, you may then use the IsVirtual and Type properties as needed to avoid making further, unnecessary WMI queries.

Failure to detect a virtual machine guest environment does not guarantee that the application is not running in one. This function simply makes an effort to detect the most common hypervisors while avoiding the possibility of running into false-positives. The guest environments this can detect include:

  • Linux guests: HyperV, Parallels, VirtualBox, VMware, XenServer.
  • macOS guests: VirtualBox, VMware.
  • Windows guests: HyperV, Parallels, VirtualBox, VirtualPC, VMware, XenServer.
See Also

Reference

VirtualMachineValidation Class
com.softwarekey.Client.Licensing Namespace


VirtualMachineValidation.VirtualMachineType Enumeration

VirtualMachineValidationVirtualMachineType Enumeration
Virtual Machine Types

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum VirtualMachineType
Public Enumeration VirtualMachineType
public enum class VirtualMachineType
Members
Member name | Value | Description
MicrosoftHyperV | 0 | Microsoft Hyper V
VirtualPC | 1 | Virtual PC
VirtualBox | 2 | Virtual Box
VMWare | 3 | VMWare
Parallels | 4 | Parallels Workstation
XenServer | 5 | Xen Server
None | 6 | None
See Also

Reference

com.softwarekey.Client.Licensing Namespace


WritableLicense Class

WritableLicense Class
This is the base class from which all license implementations which must allow the application to write to the license file are derived.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingLicense
com.softwarekey.Client.LicensingWritableLicense

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class WritableLicense : License
Public MustInherit Class WritableLicense
    Inherits License
public ref class WritableLicense abstract : public License

The WritableLicense type exposes the following members.

Constructors
 | Name | Description
Public method | WritableLicense | Creates a new WritableLicense object with the cryptographic data (in the AuthorEncryptionKey object), encryption options, product information, and identifier algorithms.
Top
Properties
 | Name | Description
Public property | ActivationPassword | Gets or sets the activation password, which is usually randomly generated by SOLO Server. (Overrides LicenseActivationPassword.)
Public property | Aliases | Gets the list of aliases.
Public property | Author | Gets the Author that issued this License. (Inherited from License.)
Public property | AuthorizedIdentifiers | Gets a generic list of authorized/activated system identifiers. (Inherited from License.)
Public property | CurrentIdentifiers | Gets a generic list of the current system's identifiers. (Inherited from License.)
Public property | CurrentSessionCode | Gets or sets the current session code, which prevents replay attacks in manual request processing. (Inherited from License.)
Public property | Customer | Gets the Customer to which this License was issued. (Inherited from License.)
Public property | Distributor | Gets the Distributor with which this License is associated. (Inherited from License.)
Public property | EffectiveEndDate | Gets or sets the date in which the license expires. (Overrides LicenseEffectiveEndDate.)
Public property | EffectiveStartDate | Gets or sets the date in which the license becomes effective. (Overrides LicenseEffectiveStartDate.)
Public property | EncryptionKeyID | Gets or sets the Encryption Key identifier. (Inherited from License.)
Public property | ExternalReference1 | Gets or sets the External Reference 1 value, which is a unique identifier generated by a third-party system or service. (Overrides LicenseExternalReference1.)
Public property | ExternalReference1Source | Gets or sets the source of the ExternalReference1 value. (Overrides LicenseExternalReference1Source.)
Public property | ExternalReference2 | Gets or sets the External Reference 2 value, which is a unique identifier generated by a third-party system or service. (Overrides LicenseExternalReference2.)
Public property | ExternalReference2Source | Gets or sets the source of the ExternalReference2 value. (Overrides LicenseExternalReference2Source.)
Public property | FormatVersion | Gets the format version of the license file. (Inherited from License.)
Public property | InstallationID | Gets or sets the Installation ID which uniquely identifies the activation of the current system. (Overrides LicenseInstallationID.)
Public property | InstallationName | Gets or sets the name of the installation. (Inherited from License.)
Public property | IsTestLicense | Gets whether or not the license file was generated from a test license. IMPORTANT: Test licenses may eventually be deleted from SOLO Server's database! (Inherited from License.)
Public property | LastError | Gets or sets the last error encountered (Inherited from License.)
Public property | LastUpdated | Gets the last time the license was updated (in UTC time).
Public property | LatestVersion | Gets or sets the latest version of the product available. (Overrides LicenseLatestVersion.)
Public property | LicenseCounter | Gets or sets the License Counter value. (Overrides LicenseLicenseCounter.)
Public property | LicenseCustomData | Gets or sets the License Custom Data, which contains custom XML or alphanumeric data. (Overrides LicenseLicenseCustomData.)
Public property | LicenseeEmail | Gets or sets the licensee's email address. (Overrides LicenseLicenseeEmail.)
Public property | LicenseeName | Gets or sets the licensee's name. (Overrides LicenseLicenseeName.)
Public property | LicenseID | Gets or sets the License ID of the license purchased and activated. (Overrides LicenseLicenseID.)
Public property | LicenseUpdate | Gets or sets the License Update data. (Overrides LicenseLicenseUpdate.)
Public property | NumberOfMatchingIdentifiers | Gets the the number of authorized system identifiers with matching current system identifiers. (Inherited from License.)
Public property | Product | Gets the Product for which the License was issued. (Inherited from License.)
Public property | ProductOption | Gets the Product Option for which the License was issued. (Inherited from License.)
Public property | ProductVersion | Gets or sets the version of this product. (Inherited from License.)
Public property | QuantityOrdered | Gets or sets the latest version of the product available. (Overrides LicenseQuantityOrdered.)
Public property | SerialNumber | Gets the Serial Number value (Overrides LicenseSerialNumber.)
Public property | SignatureDate | Gets or sets the date in which the license file itself was created and signed. (Overrides LicenseSignatureDate.)
Public property | ThisProductID | Gets or sets the Product ID (usually generated by SOLO Server) of this product/application. (Inherited from License.)
Public property | TriggerCode | Gets or sets the Trigger Code number. (Overrides LicenseTriggerCode.)
Public property | TriggerCodeFixedValue | Gets or sets the Trigger Code Fixed Value. (Overrides LicenseTriggerCodeFixedValue.)
Public property | UserDefinedDate1 | Gets or sets the User Defined Date-Time Field 1 value. (Overrides LicenseUserDefinedDate1.)
Public property | UserDefinedDate2 | Gets or sets the User Defined Date-Time Field 2 value. (Overrides LicenseUserDefinedDate2.)
Public property | UserDefinedDate3 | Gets or sets the User Defined Date-Time Field 3 value. (Overrides LicenseUserDefinedDate3.)
Public property | UserDefinedDate4 | Gets or sets the User Defined Date-Time Field 4 value. (Overrides LicenseUserDefinedDate4.)
Public property | UserDefinedDate5 | Gets or sets the User Defined Date-Time Field 5 value. (Overrides LicenseUserDefinedDate5.)
Public property | UserDefinedFloat1 | Gets or sets the User Defined Float Field 1 value. (Overrides LicenseUserDefinedFloat1.)
Public property | UserDefinedFloat2 | Gets or sets the User Defined Float Field 2 value. (Overrides LicenseUserDefinedFloat2.)
Public property | UserDefinedFloat3 | Gets or sets the User Defined Float Field 3 value. (Overrides LicenseUserDefinedFloat3.)
Public property | UserDefinedFloat4 | Gets or sets the User Defined Float Field 4 value. (Overrides LicenseUserDefinedFloat4.)
Public property | UserDefinedFloat5 | Gets or sets the User Defined Float Field 5 value. (Overrides LicenseUserDefinedFloat5.)
Public property | UserDefinedNumber1 | Gets or sets the User Defined Number Field 1 value. (Overrides LicenseUserDefinedNumber1.)
Public property | UserDefinedNumber2 | Gets or sets the User Defined Number Field 2 value. (Overrides LicenseUserDefinedNumber2.)
Public property | UserDefinedNumber3 | Gets or sets the User Defined Number Field 3 value. (Overrides LicenseUserDefinedNumber3.)
Public property | UserDefinedNumber4 | Gets or sets the User Defined Number Field 4 value. (Overrides LicenseUserDefinedNumber4.)
Public property | UserDefinedNumber5 | Gets or sets the User Defined Number Field 5 value. (Overrides LicenseUserDefinedNumber5.)
Public property | UserDefinedString1 | Gets or sets the User Defined String Field 1 value. (Overrides LicenseUserDefinedString1.)
Public property | UserDefinedString10 | Gets or sets the User Defined String Field 10 value. (Overrides LicenseUserDefinedString10.)
Public property | UserDefinedString2 | Gets or sets the User Defined String Field 2 value. (Overrides LicenseUserDefinedString2.)
Public property | UserDefinedString3 | Gets or sets the User Defined String Field 3 value. (Overrides LicenseUserDefinedString3.)
Public property | UserDefinedString4 | Gets or sets the User Defined String Field 4 value. (Overrides LicenseUserDefinedString4.)
Public property | UserDefinedString5 | Gets or sets the User Defined String Field 5 value. (Overrides LicenseUserDefinedString5.)
Public property | UserDefinedString6 | Gets or sets the User Defined String Field 6 value. (Overrides LicenseUserDefinedString6.)
Public property | UserDefinedString7 | Gets or sets the User Defined String Field 7 value. (Overrides LicenseUserDefinedString7.)
Public property | UserDefinedString8 | Gets or sets the User Defined String Field 8 value. (Overrides LicenseUserDefinedString8.)
Public property | UserDefinedString9 | Gets or sets the User Defined String Field 9 value. (Overrides LicenseUserDefinedString9.)
Top
Methods
 | Name | Description
Public method | ActivateInstallationLicenseFile(Int32, String, String) | Activates online using a specified License ID, and customer password or activation password (Inherited from License.)
Public method | ActivateInstallationLicenseFile(String, XmlActivationService, String) | Activates online using a specified License ID, customer password or activation password, and endpoint URL (Inherited from License.)
Public method | ActivateInstallationLicenseFile(String, String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL (Inherited from License.)
Public method | ActivateInstallationLicenseFile(Int32, String, XmlActivationService, String) | Activates online using a specified License ID, customer password or activation password, and endpoint URL (Inherited from License.)
Public method | ActivateInstallationLicenseFile(Int32, String, String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL (Inherited from License.)
Public method | ActivateOnline(String, XmlActivationService) | Activates online using the license's current License ID, the specified customer password or activation password, and SoapHttpClientProtocol object (Inherited from License.)
Public method | ActivateOnline(String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL (Inherited from License.)
Public method | ActivateOnline(Int32, String, XmlActivationService) | Activates online using the specified License ID, customer password or activation password, and SoapHttpClientProtocol object. (Inherited from License.)
Public method | ActivateOnline(Int32, String, String) | Activates online using the specified License ID, customer password or activation password, and endpoint URL. (Inherited from License.)
Public method | AddAlias | Adds an alias, or a hidden copy of the writable License File.
Public method | AddIdentifierAlgorithm | Adds a SystemIdentifierAlgorithm implementation to use for system identification and verification. (Inherited from License.)
Public method | AddTimeServerCheck(String) | Add an SNTP server to the list of servers to check (Inherited from License.)
Public method | AddTimeServerCheck(String, Int32) | Add an SNTP server to the list of servers to check (Inherited from License.)
Public method | AddTimeServerCheck(String, Int32, Int32, Int32) | Add an SNTP server to the list of servers to check (Inherited from License.)
Public method | CheckAliases | Checks all License File aliases.
Public method | CheckInstallationStatus | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property. (Inherited from License.)
Public method | CheckInstallationStatus(String) | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint. (Inherited from License.)
Public method | CheckInstallationStatus(XmlActivationService) | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint. (Inherited from License.)
Public method | CheckTimeAgainstServers | Checks the system time against multiple time servers/sntp requests, allowing up to a 5 minute difference. (Inherited from License.)
Public method | CheckTimeAgainstServers(Double) | Checks the system time against multiple time servers/sntp requests (Inherited from License.)
Public method | DeactivateInstallation | Deactivates the license with SOLO Server using the InstallationID property. (Inherited from License.)
Public method | DeactivateInstallation(String) | Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint. (Inherited from License.)
Public method | DeactivateInstallation(XmlActivationService) | Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint. (Inherited from License.)
Public method | DeleteAliases | Attempts to delete all aliases.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetActivationInstallationLicenseFileRequest | Builds a manual activation XML request string (Inherited from License.)
Public method | GetActivationRequest | Builds a manual activation XML request string (Inherited from License.)
Public method | GetCheckInstallationStatusRequest | Builds a manual status check XML request string using the current value in the InstallationID property (Inherited from License.)
Public method | GetDeactivateInstallationRequest | Builds a manual status check XML request string using the current value in the InstallationID property (Inherited from License.)
Protected method | GetEncryptionKey | Gets the AuthorEncryptionKey object used for cryptographic routines. (Inherited from License.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLicenseRefreshRequest | Builds a manual license refresh XML request string using the current value in the InstallationID property (Inherited from License.)
Public method | GetType | (Inherited from Object.)
Public method | GetWritableLicenseFile | Creates a writable License File.
Public method | InitializeCurrentIdentifiers | Initializes the CurrentIdentifiers property using the algorithms added using the AddIdentifierAlgorithm(SystemIdentifierAlgorithm) method. (Inherited from License.)
Protected method | initializeFromXml | Initializes a WritableLicense from an XmlDocument (Overrides LicenseinitializeFromXml(XmlDocument).)
Public method | Load | Loads a License File from a String in memory. (Overrides LicenseLoad(String).)
Public method | LoadFile | Loads a License File from the file system and returns true if successful (Inherited from License.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessActivateInstallationLicenseFileResponse(String, String) | Processes an activation XML response string (Inherited from License.)
Public method | ProcessActivateInstallationLicenseFileResponse(XmlNode, String) | Processes an activation XML response string (Overrides LicenseProcessActivateInstallationLicenseFileResponse(XmlNode, String).)
Public method | ProcessActivationResponse(String) | Processes an activation XML response string (Inherited from License.)
Public method | ProcessActivationResponse(XmlNode) | Processes an activation XML response. (Inherited from License.)
Public method | ProcessCheckInstallationStatusResponse(String) | Processes a CheckInstallationStatus XML response string (Inherited from License.)
Public method | ProcessCheckInstallationStatusResponse(XmlNode) | Processes a CheckInstallationStatus XML response string (Inherited from License.)
Public method | ProcessDeactivateInstallationResponse(String) | Processes a DeactivateInstallation XML response string (Inherited from License.)
Public method | ProcessDeactivateInstallationResponse(XmlNode) | Processes a DeactivateInstallation XML response (Overrides LicenseProcessDeactivateInstallationResponse(XmlNode).)
Public method | ProcessLicenseRefreshResponse(String, String) | Processes an activation XML response string (Inherited from License.)
Public method | ProcessLicenseRefreshResponse(XmlNode, String) | Processes an activation XML response string (Overrides LicenseProcessLicenseRefreshResponse(XmlNode, String).)
Public method | RefreshLicense(String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property. (Inherited from License.)
Public method | RefreshLicense(String, String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property. (Inherited from License.)
Public method | RefreshLicense(XmlLicenseFileService, String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property. (Inherited from License.)
Public method | ResetSessionCode | Creates a new session code in the CurrentSessionCode property (Inherited from License.)
Public method | ToString | (Inherited from Object.)
Public method | WriteAliases(Int32, Int32) | Writes to all alias locations.
Public method | WriteAliases(Int32, Int32, Boolean) | Writes to all alias locations.
Public method | WriteAliasToLicenseFile | Overwrites a License File with an alias
Public method | WriteLicenseFile(String) | Writes a License File to the file system.
Public method | WriteLicenseFile(String, String) | Writes a License File to the file system. (Inherited from License.)
Top
Remarks
Caution note Caution

It is very important to note that this implementation is less secure since it uses encryption data known to your application. Implementing read-only License Files via the License class instead provides the highest level of security, as it uses encryption information only known to SOLO Server.

See Also

Reference

com.softwarekey.Client.Licensing Namespace


WritableLicense Constructor

WritableLicense Constructor
Creates a new WritableLicense object with the cryptographic data (in the AuthorEncryptionKey object), encryption options, product information, and identifier algorithms.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public WritableLicense(
    AuthorEncryptionKey encryptionKey,
    bool useEncryptedFile,
    bool useWebServiceEncryption,
    int productId,
    string productVersion,
    List<SystemIdentifierAlgorithm> identifierAlgorithms
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    useEncryptedFile As Boolean,
    useWebServiceEncryption As Boolean,
    productId As Integer,
    productVersion As String,
    identifierAlgorithms As List(Of SystemIdentifierAlgorithm)
)
public:
WritableLicense(
    AuthorEncryptionKey^ encryptionKey,
    bool useEncryptedFile,
    bool useWebServiceEncryption,
    int productId,
    String^ productVersion,
    List<SystemIdentifierAlgorithm^>^ identifierAlgorithms
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
useEncryptedFile
Type: SystemBoolean
When true, uses an encrypted License File. (Set to true if unsure.)
useWebServiceEncryption
Type: SystemBoolean
When try, XML web service requests are encrypted. (Set to true if unsure.)
productId
Type: SystemInt32
The Product ID for the Product which is being licensed from SOLO Server. (Set to zero (0) if you are not using SOLO Server.)
productVersion
Type: SystemString
The current version of the product (must be formatted like x.x.x.x, where each 'x' is a non-negative integer that is no longer than 5 digits). Use an empty string to ignore the version number.
identifierAlgorithms
Type: System.Collections.GenericList SystemIdentifierAlgorithm
A generic list of SystemIdentifierAlgorithm objects (typically one object for each algorithm being used) to use to automatically initialize the CurrentIdentifiers property.
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense Properties

WritableLicense Properties

The WritableLicense type exposes the following members.

Properties
 | Name | Description
Public property | ActivationPassword | Gets or sets the activation password, which is usually randomly generated by SOLO Server. (Overrides LicenseActivationPassword.)
Public property | Aliases | Gets the list of aliases.
Public property | Author | Gets the Author that issued this License. (Inherited from License.)
Public property | AuthorizedIdentifiers | Gets a generic list of authorized/activated system identifiers. (Inherited from License.)
Public property | CurrentIdentifiers | Gets a generic list of the current system's identifiers. (Inherited from License.)
Public property | CurrentSessionCode | Gets or sets the current session code, which prevents replay attacks in manual request processing. (Inherited from License.)
Public property | Customer | Gets the Customer to which this License was issued. (Inherited from License.)
Public property | Distributor | Gets the Distributor with which this License is associated. (Inherited from License.)
Public property | EffectiveEndDate | Gets or sets the date in which the license expires. (Overrides LicenseEffectiveEndDate.)
Public property | EffectiveStartDate | Gets or sets the date in which the license becomes effective. (Overrides LicenseEffectiveStartDate.)
Public property | EncryptionKeyID | Gets or sets the Encryption Key identifier. (Inherited from License.)
Public property | ExternalReference1 | Gets or sets the External Reference 1 value, which is a unique identifier generated by a third-party system or service. (Overrides LicenseExternalReference1.)
Public property | ExternalReference1Source | Gets or sets the source of the ExternalReference1 value. (Overrides LicenseExternalReference1Source.)
Public property | ExternalReference2 | Gets or sets the External Reference 2 value, which is a unique identifier generated by a third-party system or service. (Overrides LicenseExternalReference2.)
Public property | ExternalReference2Source | Gets or sets the source of the ExternalReference2 value. (Overrides LicenseExternalReference2Source.)
Public property | FormatVersion | Gets the format version of the license file. (Inherited from License.)
Public property | InstallationID | Gets or sets the Installation ID which uniquely identifies the activation of the current system. (Overrides LicenseInstallationID.)
Public property | InstallationName | Gets or sets the name of the installation. (Inherited from License.)
Public property | IsTestLicense | Gets whether or not the license file was generated from a test license. IMPORTANT: Test licenses may eventually be deleted from SOLO Server's database! (Inherited from License.)
Public property | LastError | Gets or sets the last error encountered (Inherited from License.)
Public property | LastUpdated | Gets the last time the license was updated (in UTC time).
Public property | LatestVersion | Gets or sets the latest version of the product available. (Overrides LicenseLatestVersion.)
Public property | LicenseCounter | Gets or sets the License Counter value. (Overrides LicenseLicenseCounter.)
Public property | LicenseCustomData | Gets or sets the License Custom Data, which contains custom XML or alphanumeric data. (Overrides LicenseLicenseCustomData.)
Public property | LicenseeEmail | Gets or sets the licensee's email address. (Overrides LicenseLicenseeEmail.)
Public property | LicenseeName | Gets or sets the licensee's name. (Overrides LicenseLicenseeName.)
Public property | LicenseID | Gets or sets the License ID of the license purchased and activated. (Overrides LicenseLicenseID.)
Public property | LicenseUpdate | Gets or sets the License Update data. (Overrides LicenseLicenseUpdate.)
Public property | NumberOfMatchingIdentifiers | Gets the the number of authorized system identifiers with matching current system identifiers. (Inherited from License.)
Public property | Product | Gets the Product for which the License was issued. (Inherited from License.)
Public property | ProductOption | Gets the Product Option for which the License was issued. (Inherited from License.)
Public property | ProductVersion | Gets or sets the version of this product. (Inherited from License.)
Public property | QuantityOrdered | Gets or sets the latest version of the product available. (Overrides LicenseQuantityOrdered.)
Public property | SerialNumber | Gets the Serial Number value (Overrides LicenseSerialNumber.)
Public property | SignatureDate | Gets or sets the date in which the license file itself was created and signed. (Overrides LicenseSignatureDate.)
Public property | ThisProductID | Gets or sets the Product ID (usually generated by SOLO Server) of this product/application. (Inherited from License.)
Public property | TriggerCode | Gets or sets the Trigger Code number. (Overrides LicenseTriggerCode.)
Public property | TriggerCodeFixedValue | Gets or sets the Trigger Code Fixed Value. (Overrides LicenseTriggerCodeFixedValue.)
Public property | UserDefinedDate1 | Gets or sets the User Defined Date-Time Field 1 value. (Overrides LicenseUserDefinedDate1.)
Public property | UserDefinedDate2 | Gets or sets the User Defined Date-Time Field 2 value. (Overrides LicenseUserDefinedDate2.)
Public property | UserDefinedDate3 | Gets or sets the User Defined Date-Time Field 3 value. (Overrides LicenseUserDefinedDate3.)
Public property | UserDefinedDate4 | Gets or sets the User Defined Date-Time Field 4 value. (Overrides LicenseUserDefinedDate4.)
Public property | UserDefinedDate5 | Gets or sets the User Defined Date-Time Field 5 value. (Overrides LicenseUserDefinedDate5.)
Public property | UserDefinedFloat1 | Gets or sets the User Defined Float Field 1 value. (Overrides LicenseUserDefinedFloat1.)
Public property | UserDefinedFloat2 | Gets or sets the User Defined Float Field 2 value. (Overrides LicenseUserDefinedFloat2.)
Public property | UserDefinedFloat3 | Gets or sets the User Defined Float Field 3 value. (Overrides LicenseUserDefinedFloat3.)
Public property | UserDefinedFloat4 | Gets or sets the User Defined Float Field 4 value. (Overrides LicenseUserDefinedFloat4.)
Public property | UserDefinedFloat5 | Gets or sets the User Defined Float Field 5 value. (Overrides LicenseUserDefinedFloat5.)
Public property | UserDefinedNumber1 | Gets or sets the User Defined Number Field 1 value. (Overrides LicenseUserDefinedNumber1.)
Public property | UserDefinedNumber2 | Gets or sets the User Defined Number Field 2 value. (Overrides LicenseUserDefinedNumber2.)
Public property | UserDefinedNumber3 | Gets or sets the User Defined Number Field 3 value. (Overrides LicenseUserDefinedNumber3.)
Public property | UserDefinedNumber4 | Gets or sets the User Defined Number Field 4 value. (Overrides LicenseUserDefinedNumber4.)
Public property | UserDefinedNumber5 | Gets or sets the User Defined Number Field 5 value. (Overrides LicenseUserDefinedNumber5.)
Public property | UserDefinedString1 | Gets or sets the User Defined String Field 1 value. (Overrides LicenseUserDefinedString1.)
Public property | UserDefinedString10 | Gets or sets the User Defined String Field 10 value. (Overrides LicenseUserDefinedString10.)
Public property | UserDefinedString2 | Gets or sets the User Defined String Field 2 value. (Overrides LicenseUserDefinedString2.)
Public property | UserDefinedString3 | Gets or sets the User Defined String Field 3 value. (Overrides LicenseUserDefinedString3.)
Public property | UserDefinedString4 | Gets or sets the User Defined String Field 4 value. (Overrides LicenseUserDefinedString4.)
Public property | UserDefinedString5 | Gets or sets the User Defined String Field 5 value. (Overrides LicenseUserDefinedString5.)
Public property | UserDefinedString6 | Gets or sets the User Defined String Field 6 value. (Overrides LicenseUserDefinedString6.)
Public property | UserDefinedString7 | Gets or sets the User Defined String Field 7 value. (Overrides LicenseUserDefinedString7.)
Public property | UserDefinedString8 | Gets or sets the User Defined String Field 8 value. (Overrides LicenseUserDefinedString8.)
Public property | UserDefinedString9 | Gets or sets the User Defined String Field 9 value. (Overrides LicenseUserDefinedString9.)
Top
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.ActivationPassword Property

WritableLicenseActivationPassword Property
Gets or sets the activation password, which is usually randomly generated by SOLO Server.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string ActivationPassword { get; set; }
Public Overrides Property ActivationPassword As String
    Get
    Set
public:
virtual property String^ ActivationPassword {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.Aliases Property

WritableLicenseAliases Property
Gets the list of aliases.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<LicenseAlias> Aliases { get; }
Public ReadOnly Property Aliases As List(Of LicenseAlias)
    Get
public:
property List<LicenseAlias^>^ Aliases {
    List<LicenseAlias^>^ get ();
}

Property Value

Type: List LicenseAlias
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.EffectiveEndDate Property

WritableLicenseEffectiveEndDate Property
Gets or sets the date in which the license expires.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override DateTime EffectiveEndDate { get; set; }
Public Overrides Property EffectiveEndDate As DateTime
    Get
    Set
public:
virtual property DateTime EffectiveEndDate {
    DateTime get () override;
    void set (DateTime value) override;
}

Property Value

Type: DateTime
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.EffectiveStartDate Property

WritableLicenseEffectiveStartDate Property
Gets or sets the date in which the license becomes effective.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override DateTime EffectiveStartDate { get; set; }
Public Overrides Property EffectiveStartDate As DateTime
    Get
    Set
public:
virtual property DateTime EffectiveStartDate {
    DateTime get () override;
    void set (DateTime value) override;
}

Property Value

Type: DateTime
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.ExternalReference1 Property

WritableLicenseExternalReference1 Property
Gets or sets the External Reference 1 value, which is a unique identifier generated by a third-party system or service.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string ExternalReference1 { get; set; }
Public Overrides Property ExternalReference1 As String
    Get
    Set
public:
virtual property String^ ExternalReference1 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.ExternalReference1Source Property

WritableLicenseExternalReference1Source Property
Gets or sets the source of the ExternalReference1 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string ExternalReference1Source { get; set; }
Public Overrides Property ExternalReference1Source As String
    Get
    Set
public:
virtual property String^ ExternalReference1Source {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.ExternalReference2 Property

WritableLicenseExternalReference2 Property
Gets or sets the External Reference 2 value, which is a unique identifier generated by a third-party system or service.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string ExternalReference2 { get; set; }
Public Overrides Property ExternalReference2 As String
    Get
    Set
public:
virtual property String^ ExternalReference2 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.ExternalReference2Source Property

WritableLicenseExternalReference2Source Property
Gets or sets the source of the ExternalReference2 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string ExternalReference2Source { get; set; }
Public Overrides Property ExternalReference2Source As String
    Get
    Set
public:
virtual property String^ ExternalReference2Source {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.InstallationID Property

WritableLicenseInstallationID Property
Gets or sets the Installation ID which uniquely identifies the activation of the current system.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string InstallationID { get; set; }
Public Overrides Property InstallationID As String
    Get
    Set
public:
virtual property String^ InstallationID {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.LastUpdated Property

WritableLicenseLastUpdated Property
Gets the last time the license was updated (in UTC time).

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime LastUpdated { get; }
Public ReadOnly Property LastUpdated As DateTime
    Get
public:
property DateTime LastUpdated {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.LatestVersion Property

WritableLicenseLatestVersion Property
Gets or sets the latest version of the product available.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string LatestVersion { get; set; }
Public Overrides Property LatestVersion As String
    Get
    Set
public:
virtual property String^ LatestVersion {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.LicenseCounter Property

WritableLicenseLicenseCounter Property
Gets or sets the License Counter value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int LicenseCounter { get; set; }
Public Overrides Property LicenseCounter As Integer
    Get
    Set
public:
virtual property int LicenseCounter {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.LicenseCustomData Property

WritableLicenseLicenseCustomData Property
Gets or sets the License Custom Data, which contains custom XML or alphanumeric data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string LicenseCustomData { get; set; }
Public Overrides Property LicenseCustomData As String
    Get
    Set
public:
virtual property String^ LicenseCustomData {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.LicenseeEmail Property

WritableLicenseLicenseeEmail Property
Gets or sets the licensee's email address.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string LicenseeEmail { get; set; }
Public Overrides Property LicenseeEmail As String
    Get
    Set
public:
virtual property String^ LicenseeEmail {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.LicenseeName Property

WritableLicenseLicenseeName Property
Gets or sets the licensee's name.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string LicenseeName { get; set; }
Public Overrides Property LicenseeName As String
    Get
    Set
public:
virtual property String^ LicenseeName {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.LicenseID Property

WritableLicenseLicenseID Property
Gets or sets the License ID of the license purchased and activated.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int LicenseID { get; set; }
Public Overrides Property LicenseID As Integer
    Get
    Set
public:
virtual property int LicenseID {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.LicenseUpdate Property

WritableLicenseLicenseUpdate Property
Gets or sets the License Update data.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string LicenseUpdate { get; set; }
Public Overrides Property LicenseUpdate As String
    Get
    Set
public:
virtual property String^ LicenseUpdate {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.QuantityOrdered Property

WritableLicenseQuantityOrdered Property
Gets or sets the latest version of the product available.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int QuantityOrdered { get; set; }
Public Overrides Property QuantityOrdered As Integer
    Get
    Set
public:
virtual property int QuantityOrdered {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.SerialNumber Property

WritableLicenseSerialNumber Property
Gets the Serial Number value

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string SerialNumber { get; set; }
Public Overrides Property SerialNumber As String
    Get
    Set
public:
virtual property String^ SerialNumber {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.SignatureDate Property

WritableLicenseSignatureDate Property
Gets or sets the date in which the license file itself was created and signed.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override DateTime SignatureDate { get; set; }
Public Overrides Property SignatureDate As DateTime
    Get
    Set
public:
virtual property DateTime SignatureDate {
    DateTime get () override;
    void set (DateTime value) override;
}

Property Value

Type: DateTime
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.TriggerCode Property

WritableLicenseTriggerCode Property
Gets or sets the Trigger Code number.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int TriggerCode { get; set; }
Public Overrides Property TriggerCode As Integer
    Get
    Set
public:
virtual property int TriggerCode {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.TriggerCodeFixedValue Property

WritableLicenseTriggerCodeFixedValue Property
Gets or sets the Trigger Code Fixed Value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int TriggerCodeFixedValue { get; set; }
Public Overrides Property TriggerCodeFixedValue As Integer
    Get
    Set
public:
virtual property int TriggerCodeFixedValue {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedDate1 Property

WritableLicenseUserDefinedDate1 Property
Gets or sets the User Defined Date-Time Field 1 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override DateTime UserDefinedDate1 { get; set; }
Public Overrides Property UserDefinedDate1 As DateTime
    Get
    Set
public:
virtual property DateTime UserDefinedDate1 {
    DateTime get () override;
    void set (DateTime value) override;
}

Property Value

Type: DateTime
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedDate2 Property

WritableLicenseUserDefinedDate2 Property
Gets or sets the User Defined Date-Time Field 2 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override DateTime UserDefinedDate2 { get; set; }
Public Overrides Property UserDefinedDate2 As DateTime
    Get
    Set
public:
virtual property DateTime UserDefinedDate2 {
    DateTime get () override;
    void set (DateTime value) override;
}

Property Value

Type: DateTime
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedDate3 Property

WritableLicenseUserDefinedDate3 Property
Gets or sets the User Defined Date-Time Field 3 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override DateTime UserDefinedDate3 { get; set; }
Public Overrides Property UserDefinedDate3 As DateTime
    Get
    Set
public:
virtual property DateTime UserDefinedDate3 {
    DateTime get () override;
    void set (DateTime value) override;
}

Property Value

Type: DateTime
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedDate4 Property

WritableLicenseUserDefinedDate4 Property
Gets or sets the User Defined Date-Time Field 4 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override DateTime UserDefinedDate4 { get; set; }
Public Overrides Property UserDefinedDate4 As DateTime
    Get
    Set
public:
virtual property DateTime UserDefinedDate4 {
    DateTime get () override;
    void set (DateTime value) override;
}

Property Value

Type: DateTime
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedDate5 Property

WritableLicenseUserDefinedDate5 Property
Gets or sets the User Defined Date-Time Field 5 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override DateTime UserDefinedDate5 { get; set; }
Public Overrides Property UserDefinedDate5 As DateTime
    Get
    Set
public:
virtual property DateTime UserDefinedDate5 {
    DateTime get () override;
    void set (DateTime value) override;
}

Property Value

Type: DateTime
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedFloat1 Property

WritableLicenseUserDefinedFloat1 Property
Gets or sets the User Defined Float Field 1 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override decimal UserDefinedFloat1 { get; set; }
Public Overrides Property UserDefinedFloat1 As Decimal
    Get
    Set
public:
virtual property Decimal UserDefinedFloat1 {
    Decimal get () override;
    void set (Decimal value) override;
}

Property Value

Type: Decimal
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedFloat2 Property

WritableLicenseUserDefinedFloat2 Property
Gets or sets the User Defined Float Field 2 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override decimal UserDefinedFloat2 { get; set; }
Public Overrides Property UserDefinedFloat2 As Decimal
    Get
    Set
public:
virtual property Decimal UserDefinedFloat2 {
    Decimal get () override;
    void set (Decimal value) override;
}

Property Value

Type: Decimal
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedFloat3 Property

WritableLicenseUserDefinedFloat3 Property
Gets or sets the User Defined Float Field 3 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override decimal UserDefinedFloat3 { get; set; }
Public Overrides Property UserDefinedFloat3 As Decimal
    Get
    Set
public:
virtual property Decimal UserDefinedFloat3 {
    Decimal get () override;
    void set (Decimal value) override;
}

Property Value

Type: Decimal
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedFloat4 Property

WritableLicenseUserDefinedFloat4 Property
Gets or sets the User Defined Float Field 4 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override decimal UserDefinedFloat4 { get; set; }
Public Overrides Property UserDefinedFloat4 As Decimal
    Get
    Set
public:
virtual property Decimal UserDefinedFloat4 {
    Decimal get () override;
    void set (Decimal value) override;
}

Property Value

Type: Decimal
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedFloat5 Property

WritableLicenseUserDefinedFloat5 Property
Gets or sets the User Defined Float Field 5 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override decimal UserDefinedFloat5 { get; set; }
Public Overrides Property UserDefinedFloat5 As Decimal
    Get
    Set
public:
virtual property Decimal UserDefinedFloat5 {
    Decimal get () override;
    void set (Decimal value) override;
}

Property Value

Type: Decimal
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedNumber1 Property

WritableLicenseUserDefinedNumber1 Property
Gets or sets the User Defined Number Field 1 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int UserDefinedNumber1 { get; set; }
Public Overrides Property UserDefinedNumber1 As Integer
    Get
    Set
public:
virtual property int UserDefinedNumber1 {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedNumber2 Property

WritableLicenseUserDefinedNumber2 Property
Gets or sets the User Defined Number Field 2 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int UserDefinedNumber2 { get; set; }
Public Overrides Property UserDefinedNumber2 As Integer
    Get
    Set
public:
virtual property int UserDefinedNumber2 {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedNumber3 Property

WritableLicenseUserDefinedNumber3 Property
Gets or sets the User Defined Number Field 3 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int UserDefinedNumber3 { get; set; }
Public Overrides Property UserDefinedNumber3 As Integer
    Get
    Set
public:
virtual property int UserDefinedNumber3 {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedNumber4 Property

WritableLicenseUserDefinedNumber4 Property
Gets or sets the User Defined Number Field 4 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int UserDefinedNumber4 { get; set; }
Public Overrides Property UserDefinedNumber4 As Integer
    Get
    Set
public:
virtual property int UserDefinedNumber4 {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedNumber5 Property

WritableLicenseUserDefinedNumber5 Property
Gets or sets the User Defined Number Field 5 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override int UserDefinedNumber5 { get; set; }
Public Overrides Property UserDefinedNumber5 As Integer
    Get
    Set
public:
virtual property int UserDefinedNumber5 {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedString1 Property

WritableLicenseUserDefinedString1 Property
Gets or sets the User Defined String Field 1 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string UserDefinedString1 { get; set; }
Public Overrides Property UserDefinedString1 As String
    Get
    Set
public:
virtual property String^ UserDefinedString1 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedString10 Property

WritableLicenseUserDefinedString10 Property
Gets or sets the User Defined String Field 10 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string UserDefinedString10 { get; set; }
Public Overrides Property UserDefinedString10 As String
    Get
    Set
public:
virtual property String^ UserDefinedString10 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedString2 Property

WritableLicenseUserDefinedString2 Property
Gets or sets the User Defined String Field 2 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string UserDefinedString2 { get; set; }
Public Overrides Property UserDefinedString2 As String
    Get
    Set
public:
virtual property String^ UserDefinedString2 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedString3 Property

WritableLicenseUserDefinedString3 Property
Gets or sets the User Defined String Field 3 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string UserDefinedString3 { get; set; }
Public Overrides Property UserDefinedString3 As String
    Get
    Set
public:
virtual property String^ UserDefinedString3 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedString4 Property

WritableLicenseUserDefinedString4 Property
Gets or sets the User Defined String Field 4 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string UserDefinedString4 { get; set; }
Public Overrides Property UserDefinedString4 As String
    Get
    Set
public:
virtual property String^ UserDefinedString4 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedString5 Property

WritableLicenseUserDefinedString5 Property
Gets or sets the User Defined String Field 5 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string UserDefinedString5 { get; set; }
Public Overrides Property UserDefinedString5 As String
    Get
    Set
public:
virtual property String^ UserDefinedString5 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedString6 Property

WritableLicenseUserDefinedString6 Property
Gets or sets the User Defined String Field 6 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string UserDefinedString6 { get; set; }
Public Overrides Property UserDefinedString6 As String
    Get
    Set
public:
virtual property String^ UserDefinedString6 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedString7 Property

WritableLicenseUserDefinedString7 Property
Gets or sets the User Defined String Field 7 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string UserDefinedString7 { get; set; }
Public Overrides Property UserDefinedString7 As String
    Get
    Set
public:
virtual property String^ UserDefinedString7 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedString8 Property

WritableLicenseUserDefinedString8 Property
Gets or sets the User Defined String Field 8 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string UserDefinedString8 { get; set; }
Public Overrides Property UserDefinedString8 As String
    Get
    Set
public:
virtual property String^ UserDefinedString8 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.UserDefinedString9 Property

WritableLicenseUserDefinedString9 Property
Gets or sets the User Defined String Field 9 value.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string UserDefinedString9 { get; set; }
Public Overrides Property UserDefinedString9 As String
    Get
    Set
public:
virtual property String^ UserDefinedString9 {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense Methods

WritableLicense Methods

The WritableLicense type exposes the following members.

Methods
 | Name | Description
Public method | ActivateInstallationLicenseFile(Int32, String, String) | Activates online using a specified License ID, and customer password or activation password (Inherited from License.)
Public method | ActivateInstallationLicenseFile(String, XmlActivationService, String) | Activates online using a specified License ID, customer password or activation password, and endpoint URL (Inherited from License.)
Public method | ActivateInstallationLicenseFile(String, String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL (Inherited from License.)
Public method | ActivateInstallationLicenseFile(Int32, String, XmlActivationService, String) | Activates online using a specified License ID, customer password or activation password, and endpoint URL (Inherited from License.)
Public method | ActivateInstallationLicenseFile(Int32, String, String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL (Inherited from License.)
Public method | ActivateOnline(String, XmlActivationService) | Activates online using the license's current License ID, the specified customer password or activation password, and SoapHttpClientProtocol object (Inherited from License.)
Public method | ActivateOnline(String, String) | Activates online using the license's current License ID, the specified customer password or activation password, and endpoint URL (Inherited from License.)
Public method | ActivateOnline(Int32, String, XmlActivationService) | Activates online using the specified License ID, customer password or activation password, and SoapHttpClientProtocol object. (Inherited from License.)
Public method | ActivateOnline(Int32, String, String) | Activates online using the specified License ID, customer password or activation password, and endpoint URL. (Inherited from License.)
Public method | AddAlias | Adds an alias, or a hidden copy of the writable License File.
Public method | AddIdentifierAlgorithm | Adds a SystemIdentifierAlgorithm implementation to use for system identification and verification. (Inherited from License.)
Public method | AddTimeServerCheck(String) | Add an SNTP server to the list of servers to check (Inherited from License.)
Public method | AddTimeServerCheck(String, Int32) | Add an SNTP server to the list of servers to check (Inherited from License.)
Public method | AddTimeServerCheck(String, Int32, Int32, Int32) | Add an SNTP server to the list of servers to check (Inherited from License.)
Public method | CheckAliases | Checks all License File aliases.
Public method | CheckInstallationStatus | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property. (Inherited from License.)
Public method | CheckInstallationStatus(String) | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint. (Inherited from License.)
Public method | CheckInstallationStatus(XmlActivationService) | Checks the installation status for the given Installation ID against SOLO Server using the current value in the InstallationID property and a specified endpoint. (Inherited from License.)
Public method | CheckTimeAgainstServers | Checks the system time against multiple time servers/sntp requests, allowing up to a 5 minute difference. (Inherited from License.)
Public method | CheckTimeAgainstServers(Double) | Checks the system time against multiple time servers/sntp requests (Inherited from License.)
Public method | DeactivateInstallation | Deactivates the license with SOLO Server using the InstallationID property. (Inherited from License.)
Public method | DeactivateInstallation(String) | Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint. (Inherited from License.)
Public method | DeactivateInstallation(XmlActivationService) | Deactivates the license with SOLO Server using the InstallationID property and the specified endpoint. (Inherited from License.)
Public method | DeleteAliases | Attempts to delete all aliases.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetActivationInstallationLicenseFileRequest | Builds a manual activation XML request string (Inherited from License.)
Public method | GetActivationRequest | Builds a manual activation XML request string (Inherited from License.)
Public method | GetCheckInstallationStatusRequest | Builds a manual status check XML request string using the current value in the InstallationID property (Inherited from License.)
Public method | GetDeactivateInstallationRequest | Builds a manual status check XML request string using the current value in the InstallationID property (Inherited from License.)
Protected method | GetEncryptionKey | Gets the AuthorEncryptionKey object used for cryptographic routines. (Inherited from License.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLicenseRefreshRequest | Builds a manual license refresh XML request string using the current value in the InstallationID property (Inherited from License.)
Public method | GetType | (Inherited from Object.)
Public method | GetWritableLicenseFile | Creates a writable License File.
Public method | InitializeCurrentIdentifiers | Initializes the CurrentIdentifiers property using the algorithms added using the AddIdentifierAlgorithm(SystemIdentifierAlgorithm) method. (Inherited from License.)
Protected method | initializeFromXml | Initializes a WritableLicense from an XmlDocument (Overrides LicenseinitializeFromXml(XmlDocument).)
Public method | Load | Loads a License File from a String in memory. (Overrides LicenseLoad(String).)
Public method | LoadFile | Loads a License File from the file system and returns true if successful (Inherited from License.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessActivateInstallationLicenseFileResponse(String, String) | Processes an activation XML response string (Inherited from License.)
Public method | ProcessActivateInstallationLicenseFileResponse(XmlNode, String) | Processes an activation XML response string (Overrides LicenseProcessActivateInstallationLicenseFileResponse(XmlNode, String).)
Public method | ProcessActivationResponse(String) | Processes an activation XML response string (Inherited from License.)
Public method | ProcessActivationResponse(XmlNode) | Processes an activation XML response. (Inherited from License.)
Public method | ProcessCheckInstallationStatusResponse(String) | Processes a CheckInstallationStatus XML response string (Inherited from License.)
Public method | ProcessCheckInstallationStatusResponse(XmlNode) | Processes a CheckInstallationStatus XML response string (Inherited from License.)
Public method | ProcessDeactivateInstallationResponse(String) | Processes a DeactivateInstallation XML response string (Inherited from License.)
Public method | ProcessDeactivateInstallationResponse(XmlNode) | Processes a DeactivateInstallation XML response (Overrides LicenseProcessDeactivateInstallationResponse(XmlNode).)
Public method | ProcessLicenseRefreshResponse(String, String) | Processes an activation XML response string (Inherited from License.)
Public method | ProcessLicenseRefreshResponse(XmlNode, String) | Processes an activation XML response string (Overrides LicenseProcessLicenseRefreshResponse(XmlNode, String).)
Public method | RefreshLicense(String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property. (Inherited from License.)
Public method | RefreshLicense(String, String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property. (Inherited from License.)
Public method | RefreshLicense(XmlLicenseFileService, String) | Returns the current license file contents from SOLO Server using the current value in the InstallationID property. (Inherited from License.)
Public method | ResetSessionCode | Creates a new session code in the CurrentSessionCode property (Inherited from License.)
Public method | ToString | (Inherited from Object.)
Public method | WriteAliases(Int32, Int32) | Writes to all alias locations.
Public method | WriteAliases(Int32, Int32, Boolean) | Writes to all alias locations.
Public method | WriteAliasToLicenseFile | Overwrites a License File with an alias
Public method | WriteLicenseFile(String) | Writes a License File to the file system.
Public method | WriteLicenseFile(String, String) | Writes a License File to the file system. (Inherited from License.)
Top
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.AddAlias Method

WritableLicenseAddAlias Method
Adds an alias, or a hidden copy of the writable License File.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddAlias(
    LicenseAlias alias
)
Public Sub AddAlias (
    alias As LicenseAlias
)
public:
void AddAlias(
    LicenseAlias^ alias
)

Parameters

alias
Type: com.softwarekey.Client.LicensingLicenseAlias
The LicenseAlias which will be written and validated with this writable license.
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.CheckAliases Method

WritableLicenseCheckAliases Method
Checks all License File aliases.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool CheckAliases(
    out int numToValidate,
    out int numValid
)
Public Function CheckAliases (
    <OutAttribute> ByRef numToValidate As Integer,
    <OutAttribute> ByRef numValid As Integer
) As Boolean
public:
bool CheckAliases(
    [OutAttribute] int% numToValidate,
    [OutAttribute] int% numValid
)

Parameters

numToValidate
Type: SystemInt32
The number of aliases to validate.
numValid
Type: SystemInt32
The number of valid aliases (which passed the checks).

Return Value

Type: Boolean
Returns true if all aliases passed validation. If false is returned, check the LastError property and the numToValidate and numValid arguments for details. Please note that each alias has its own LastError property, which may also contain additional details.
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.DeleteAliases Method

WritableLicenseDeleteAliases Method
Attempts to delete all aliases.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool DeleteAliases()
Public Function DeleteAliases As Boolean
public:
bool DeleteAliases()

Return Value

Type: Boolean
Returns true if all aliases passed validation. If false is returned, check the LastError property. Please note that each alias has its own LastError property, which may also contain additional details.
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.GetWritableLicenseFile Method

WritableLicenseGetWritableLicenseFile Method
Creates a writable License File.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool GetWritableLicenseFile(
    ref string lfContent
)
Public Overridable Function GetWritableLicenseFile (
    ByRef lfContent As String
) As Boolean
public:
virtual bool GetWritableLicenseFile(
    String^% lfContent
)

Parameters

lfContent
Type: SystemString
The contents of the writable License File.

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.initializeFromXml Method

WritableLicenseinitializeFromXml Method
Initializes a WritableLicense from an XmlDocument

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected override bool initializeFromXml(
    XmlDocument xml
)
Protected Overrides Function initializeFromXml (
    xml As XmlDocument
) As Boolean
protected:
virtual bool initializeFromXml(
    XmlDocument^ xml
) override

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument containing the license data

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.Load Method

WritableLicenseLoad Method
Loads a License File from a String in memory.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Load(
    string data
)
Public Overrides Function Load (
    data As String
) As Boolean
public:
virtual bool Load(
    String^ data
) override

Parameters

data
Type: SystemString
The License File data.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.ProcessActivateInstallationLicenseFileResponse Method

WritableLicenseProcessActivateInstallationLicenseFileResponse Method
Overload List
 | Name | Description
Public method | ProcessActivateInstallationLicenseFileResponse(String, String) | Processes an activation XML response string (Inherited from License.)
Public method | ProcessActivateInstallationLicenseFileResponse(XmlNode, String) | Processes an activation XML response string (Overrides LicenseProcessActivateInstallationLicenseFileResponse(XmlNode, String).)
Top
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.ProcessActivateInstallationLicenseFileResponse Method (XmlNode, String)

WritableLicenseProcessActivateInstallationLicenseFileResponse Method (XmlNode, String)
Processes an activation XML response string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessActivateInstallationLicenseFileResponse(
    XmlNode response,
    ref string licenseContent
)
Public Overrides Function ProcessActivateInstallationLicenseFileResponse (
    response As XmlNode,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ProcessActivateInstallationLicenseFileResponse(
    XmlNode^ response,
    String^% licenseContent
) override

Parameters

response
Type: System.XmlXmlNode
The XML response string
licenseContent
Type: SystemString
The License File content returned from SOLO Server

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual activation processing, which is where the requests (generated from the GetActivationInstallationLicenseFileRequest(Int32, String) method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual activation processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

WritableLicense Class
ProcessActivateInstallationLicenseFileResponse Overload
com.softwarekey.Client.Licensing Namespace


WritableLicense.ProcessDeactivateInstallationResponse Method

WritableLicenseProcessDeactivateInstallationResponse Method
Overload List
 | Name | Description
Public method | ProcessDeactivateInstallationResponse(String) | Processes a DeactivateInstallation XML response string (Inherited from License.)
Public method | ProcessDeactivateInstallationResponse(XmlNode) | Processes a DeactivateInstallation XML response (Overrides LicenseProcessDeactivateInstallationResponse(XmlNode).)
Top
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.ProcessDeactivateInstallationResponse Method (XmlNode)

WritableLicenseProcessDeactivateInstallationResponse Method (XmlNode)
Processes a DeactivateInstallation XML response

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessDeactivateInstallationResponse(
    XmlNode response
)
Public Overrides Function ProcessDeactivateInstallationResponse (
    response As XmlNode
) As Boolean
public:
virtual bool ProcessDeactivateInstallationResponse(
    XmlNode^ response
) override

Parameters

response
Type: System.XmlXmlNode
The XmlNode or XmlDocument object containing the response XML

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
Remarks

This method processes an XML response which may be used to complete manual deactivation processing, which is where the requests (generated from the GetDeactivateInstallationRequest method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual status check processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

WritableLicense Class
ProcessDeactivateInstallationResponse Overload
com.softwarekey.Client.Licensing Namespace


WritableLicense.ProcessLicenseRefreshResponse Method

WritableLicenseProcessLicenseRefreshResponse Method
Overload List
 | Name | Description
Public method | ProcessLicenseRefreshResponse(String, String) | Processes an activation XML response string (Inherited from License.)
Public method | ProcessLicenseRefreshResponse(XmlNode, String) | Processes an activation XML response string (Overrides LicenseProcessLicenseRefreshResponse(XmlNode, String).)
Top
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.ProcessLicenseRefreshResponse Method (XmlNode, String)

WritableLicenseProcessLicenseRefreshResponse Method (XmlNode, String)
Processes an activation XML response string

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessLicenseRefreshResponse(
    XmlNode response,
    ref string licenseContent
)
Public Overrides Function ProcessLicenseRefreshResponse (
    response As XmlNode,
    ByRef licenseContent As String
) As Boolean
public:
virtual bool ProcessLicenseRefreshResponse(
    XmlNode^ response,
    String^% licenseContent
) override

Parameters

response
Type: System.XmlXmlNode
The XmlNode or XmlDocument object containing the response XML
licenseContent
Type: SystemString
The License File content returned from SOLO Server

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
Remarks

This method processes an XML response string which may be used to complete manual activation processing, which is where the requests (generated from the GetActivationInstallationLicenseFileRequest(Int32, String) method) may be processed from another computer with Internet access (if the system being licensed has no or limited Internet connectivity).

Caution note Caution

Before calling this method, set the CurrentSessionCode property (if the application needs to support resuming the manual activation processing after having been closed). Immediately after calling this method, the ResetSessionCode method should be called to prevent replay attacks and brute-force attacks.

See Also

Reference

WritableLicense Class
ProcessLicenseRefreshResponse Overload
com.softwarekey.Client.Licensing Namespace


WritableLicense.WriteAliases Method

WritableLicenseWriteAliases Method
Overload List
 | Name | Description
Public method | WriteAliases(Int32, Int32) | Writes to all alias locations.
Public method | WriteAliases(Int32, Int32, Boolean) | Writes to all alias locations.
Top
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.WriteAliases Method (Int32, Int32)

WritableLicenseWriteAliases Method (Int32, Int32)
Writes to all alias locations.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool WriteAliases(
    out int filesToWrite,
    out int filesWritten
)
Public Overridable Function WriteAliases (
    <OutAttribute> ByRef filesToWrite As Integer,
    <OutAttribute> ByRef filesWritten As Integer
) As Boolean
public:
virtual bool WriteAliases(
    [OutAttribute] int% filesToWrite,
    [OutAttribute] int% filesWritten
)

Parameters

filesToWrite
Type: SystemInt32
The number of aliases.
filesWritten
Type: SystemInt32
The number of aliases written.

Return Value

Type: Boolean
Returns true if all aliases are written to successfully. If false is returned, check the LastError property and the filesToWrite and filesWritten arguments for details. Please note that each alias has its own LastError property, which may also contain additional details.
See Also

Reference

WritableLicense Class
WriteAliases Overload
com.softwarekey.Client.Licensing Namespace


WritableLicense.WriteAliases Method (Int32, Int32, Boolean)

WritableLicenseWriteAliases Method (Int32, Int32, Boolean)
Writes to all alias locations.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool WriteAliases(
    out int filesToWrite,
    out int filesWritten,
    bool forceUpdate
)
Public Overridable Function WriteAliases (
    <OutAttribute> ByRef filesToWrite As Integer,
    <OutAttribute> ByRef filesWritten As Integer,
    forceUpdate As Boolean
) As Boolean
public:
virtual bool WriteAliases(
    [OutAttribute] int% filesToWrite,
    [OutAttribute] int% filesWritten,
    bool forceUpdate
)

Parameters

filesToWrite
Type: SystemInt32
The number of aliases.
filesWritten
Type: SystemInt32
The number of aliases written.
forceUpdate
Type: SystemBoolean
Whether or not the aliases should be written to, even if the system appears to have been back-dated.

Return Value

Type: Boolean
Returns true if all aliases are written to successfully. If false is returned, check the LastError property and the filesToWrite and filesWritten arguments for details. Please note that each alias has its own LastError property, which may also contain additional details.
See Also

Reference

WritableLicense Class
WriteAliases Overload
com.softwarekey.Client.Licensing Namespace


WritableLicense.WriteAliasToLicenseFile Method

WritableLicenseWriteAliasToLicenseFile Method
Overwrites a License File with an alias

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool WriteAliasToLicenseFile(
    LicenseAlias alias,
    string path
)
Public Function WriteAliasToLicenseFile (
    alias As LicenseAlias,
    path As String
) As Boolean
public:
bool WriteAliasToLicenseFile(
    LicenseAlias^ alias,
    String^ path
)

Parameters

alias
Type: com.softwarekey.Client.LicensingLicenseAlias
The LicenseAlias object that will overwrite the License File
path
Type: SystemString
The absolute path of the License File

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.WriteLicenseFile Method

WritableLicenseWriteLicenseFile Method
Overload List
 | Name | Description
Public method | WriteLicenseFile(String) | Writes a License File to the file system.
Public method | WriteLicenseFile(String, String) | Writes a License File to the file system. (Inherited from License.)
Top
See Also

Reference

WritableLicense Class
com.softwarekey.Client.Licensing Namespace


WritableLicense.WriteLicenseFile Method (String)

WritableLicenseWriteLicenseFile Method (String)
Writes a License File to the file system.

Namespace: com.softwarekey.Client.Licensing
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool WriteLicenseFile(
    string path
)
Public Function WriteLicenseFile (
    path As String
) As Boolean
public:
bool WriteLicenseFile(
    String^ path
)

Parameters

path
Type: SystemString
The absolute path to the License File

Return Value

Type: Boolean
Returns true if successful. If this is not successful, check the LastError property for details.
See Also

Reference

WritableLicense Class
WriteLicenseFile Overload
com.softwarekey.Client.Licensing Namespace


com.softwarekey.Client.Licensing.Network Namespace

com.softwarekey.Client.Licensing.Network Namespace
Contains classes and data for network licensing.
Classes
 | Class | Description
Public class | NetworkSemaphore | Keeps track of concurrent users of an application on a network by using semaphore files in a shared network location.
Public class | NetworkSession | Implements support for Network Floating licensing / concurrency limit enforcement via SOLO Server.
Public class | NetworkSessionCertificate | Represents a certificate issued by SOLO Server for an authorized network session.
Public class | NetworkSessionValidation | Validates a NetworkSession.
Public class | SearchCompletedEventArgs | Contains data regarding progress made after completing a through semaphore files.
Public class | SearchProgressEventArgs | Contains data regarding progress made while searching for/through semaphore files.
Delegates
 | Delegate | Description
Public delegate | NetworkSemaphoreInvalidEventHandler | Delegate used for defining a handler method for the NetworkSemaphoreInvalidEventHandler event.
Public delegate | NetworkSemaphoreSearchCompletedEventHandler | Delegate used for defining a handler method for the SearchCompleted event.
Public delegate | NetworkSemaphoreSearchProgressEventHandler | Delegate used for defining a handler method for the SearchProgress event.
Enumerations
 | Enumeration | Description
Public enumeration | NetworkSessionValidationNetworkSessionTimeValidationType | The requirement type for system date/time validation.


NetworkSemaphore Class

NetworkSemaphore Class
Keeps track of concurrent users of an application on a network by using semaphore files in a shared network location.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Licensing.NetworkNetworkSemaphore

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class NetworkSemaphore
Public Class NetworkSemaphore
public ref class NetworkSemaphore

The NetworkSemaphore type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkSemaphore | Creates a new NetworkSemaphore object.
Top
Properties
 | Name | Description
Public property | CleanupThreadInterval | Gets or sets how frequently, in seconds, the cleanup thread tries to delete each semaphore file. The default is 10 seconds.
Public property | IsValid | Gets whether or not the network session is still valid.
Public property | LastError | Gets the last error that occurred.
Public property | SeatsActive | Gets the number of concurrent users.
Public property | SeatsAvailable | Gets the number of remaining seats available.
Public property | SeatsTotal | Gets or sets the number of allowed concurrent users.
Public property | SemaphoreName | Gets the name of the open semaphore file. Returns an empty string if no semaphore file is open.
Public property | SemaphorePath | Gets or sets the absolute path of the directory used to house the semaphore files.
Public property | SemaphorePrefix | Gets or sets the prefix used when creating semaphore files.
Public property | ValidationThreadInterval | Gets or sets how frequently, in seconds, the validation thread checks that the network session is still valid.
Top
Methods
 | Name | Description
Public method | CancelSearch | Cancels the search in progress.
Public method | Close | Closes an open network semaphore file.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Open | Opens a network semaphore file.
Public method | Search | Performs an asynchronous search for an unused network semaphore file. Requires handling the SearchCompleted and optionally the SearchProgress events.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Invalid | Occurs when the network session is no longer valid.
Public event | SearchCompleted | Occurs when the search for an unused seat/semaphore file has been completed.
Public event | SearchProgress | Occurs when progress is made in searching for an unused seat/semaphore file. The SearchProgress event may be used by your application to keep a user informed of the progress being made while searching through semaphore files.
Top
Remarks

A Network Semaphore File is a file, which contains no useful data, stored on a common network directory used to assist in enforcing a Network Floating License in an application. One file is created and locked exclusively for each active workstation or instance of your protected application. Other LAN users attempting to run the application will not be able to use any semaphore files that are locked, which is how this can enforce license compliance which limits the number of network "seats."

Caution note Caution

Any users who will use an application using this type of licensing will need access to read, write, modify, and delete the semaphore files.

Caution note Caution

This functionality is supported on environments where semaphore files are hosted on a Windows (SMB/CIFS) share, which functions best on a Local Area Network (LAN). While this may be used in a Wide Area Network (WAN) environment (which includes scenarios where a user access a given "LAN" over a Virtual Private Network [VPN] connection), it is strongly advised testing is done before deploying to any given WAN environment. This is because the performance of this feature is centered around that of the Windows (SMB/CIFS) shares being used to host the semaphore files (and WAN/VPN environments can see much slower performance than a typical LAN configuration).

Caution note Caution

The NetworkSemaphore class is only supported when the system hosting the Windows (SMB/CIFS) share which houses the semaphore files, and the clients which access the share, all run Windows Vista/Windows Server 2008 or later.

Note Note

The computer hosting the Windows (SMB/CIFS) share (the server) which houses the semaphore files is ultimately responsible for handling when a file is unlocked. In most cases, applications which are terminated gracefully will unlock and delete their semaphore files. If the application crashes, however, the server will eventually unlock the semaphore file, but it will not delete the file. Having many of these files present can lead to some performance degradation, as each of these orphaned files can take a while to try to lock or delete. For this reason, the NetworkSemaphore constructor has a "runCleanupThread" argument, which may be set to true to have active processes try to delete orphaned files quietly, in the background. Of course, this will increase the amount of bandwidth used, but can help increase performance keeping the share location clear of any orphaned files.

See Also

Reference

com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore Constructor

NetworkSemaphore Constructor
Creates a new NetworkSemaphore object.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkSemaphore(
    string semaphoreDirectory,
    string semaphorePrefix,
    int seatsTotal,
    bool runValidationThread,
    int validationThreadInterval,
    bool runCleanupThread
)
Public Sub New (
    semaphoreDirectory As String,
    semaphorePrefix As String,
    seatsTotal As Integer,
    runValidationThread As Boolean,
    validationThreadInterval As Integer,
    runCleanupThread As Boolean
)
public:
NetworkSemaphore(
    String^ semaphoreDirectory,
    String^ semaphorePrefix,
    int seatsTotal,
    bool runValidationThread,
    int validationThreadInterval,
    bool runCleanupThread
)

Parameters

semaphoreDirectory
Type: SystemString
The absolute path to a network share where all applicable workstations and/or users have read, write, modify, and delete access.
semaphorePrefix
Type: SystemString
The prefix to use for the names of the semaphore files.
seatsTotal
Type: SystemInt32
The maximum number of allowed, concurrent users.
runValidationThread
Type: SystemBoolean
Whether or not to run the validation thread once a network session is established.
validationThreadInterval
Type: SystemInt32
How frequently, in seconds, the validation thread should check that the network session is still valid.
runCleanupThread
Type: SystemBoolean
Whether or not to run a semaphore cleanup thread (which deletes orphaned semaphores to improve performance) once a network session is established.
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore Properties

NetworkSemaphore Properties

The NetworkSemaphore type exposes the following members.

Properties
 | Name | Description
Public property | CleanupThreadInterval | Gets or sets how frequently, in seconds, the cleanup thread tries to delete each semaphore file. The default is 10 seconds.
Public property | IsValid | Gets whether or not the network session is still valid.
Public property | LastError | Gets the last error that occurred.
Public property | SeatsActive | Gets the number of concurrent users.
Public property | SeatsAvailable | Gets the number of remaining seats available.
Public property | SeatsTotal | Gets or sets the number of allowed concurrent users.
Public property | SemaphoreName | Gets the name of the open semaphore file. Returns an empty string if no semaphore file is open.
Public property | SemaphorePath | Gets or sets the absolute path of the directory used to house the semaphore files.
Public property | SemaphorePrefix | Gets or sets the prefix used when creating semaphore files.
Public property | ValidationThreadInterval | Gets or sets how frequently, in seconds, the validation thread checks that the network session is still valid.
Top
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.CleanupThreadInterval Property

NetworkSemaphoreCleanupThreadInterval Property
Gets or sets how frequently, in seconds, the cleanup thread tries to delete each semaphore file. The default is 10 seconds.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int CleanupThreadInterval { get; set; }
Public Property CleanupThreadInterval As Integer
    Get
    Set
public:
property int CleanupThreadInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.IsValid Property

NetworkSemaphoreIsValid Property
Gets whether or not the network session is still valid.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool IsValid { get; }
Public Overridable ReadOnly Property IsValid As Boolean
    Get
public:
virtual property bool IsValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.LastError Property

NetworkSemaphoreLastError Property
Gets the last error that occurred.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError LastError { get; }
Public ReadOnly Property LastError As LicenseError
    Get
public:
property LicenseError^ LastError {
    LicenseError^ get ();
}

Property Value

Type: LicenseError
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.SeatsActive Property

NetworkSemaphoreSeatsActive Property
Gets the number of concurrent users.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int SeatsActive { get; }
Public ReadOnly Property SeatsActive As Integer
    Get
public:
property int SeatsActive {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.SeatsAvailable Property

NetworkSemaphoreSeatsAvailable Property
Gets the number of remaining seats available.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int SeatsAvailable { get; }
Public ReadOnly Property SeatsAvailable As Integer
    Get
public:
property int SeatsAvailable {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.SeatsTotal Property

NetworkSemaphoreSeatsTotal Property
Gets or sets the number of allowed concurrent users.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int SeatsTotal { get; set; }
Public Property SeatsTotal As Integer
    Get
    Set
public:
property int SeatsTotal {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.SemaphoreName Property

NetworkSemaphoreSemaphoreName Property
Gets the name of the open semaphore file. Returns an empty string if no semaphore file is open.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SemaphoreName { get; }
Public ReadOnly Property SemaphoreName As String
    Get
public:
property String^ SemaphoreName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.SemaphorePath Property

NetworkSemaphoreSemaphorePath Property
Gets or sets the absolute path of the directory used to house the semaphore files.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SemaphorePath { get; set; }
Public Property SemaphorePath As String
    Get
    Set
public:
property String^ SemaphorePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.SemaphorePrefix Property

NetworkSemaphoreSemaphorePrefix Property
Gets or sets the prefix used when creating semaphore files.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SemaphorePrefix { get; set; }
Public Property SemaphorePrefix As String
    Get
    Set
public:
property String^ SemaphorePrefix {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.ValidationThreadInterval Property

NetworkSemaphoreValidationThreadInterval Property
Gets or sets how frequently, in seconds, the validation thread checks that the network session is still valid.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ValidationThreadInterval { get; set; }
Public Property ValidationThreadInterval As Integer
    Get
    Set
public:
property int ValidationThreadInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore Methods

NetworkSemaphore Methods

The NetworkSemaphore type exposes the following members.

Methods
 | Name | Description
Public method | CancelSearch | Cancels the search in progress.
Public method | Close | Closes an open network semaphore file.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Open | Opens a network semaphore file.
Public method | Search | Performs an asynchronous search for an unused network semaphore file. Requires handling the SearchCompleted and optionally the SearchProgress events.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.CancelSearch Method

NetworkSemaphoreCancelSearch Method
Cancels the search in progress.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CancelSearch()
Public Sub CancelSearch
public:
void CancelSearch()
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.Close Method

NetworkSemaphoreClose Method
Closes an open network semaphore file.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual void Close()
Public Overridable Sub Close
public:
virtual void Close()

Return Value

Type:
Returns true if the network semaphore file was closed successfully. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.Open Method

NetworkSemaphoreOpen Method
Opens a network semaphore file.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool Open()
Public Overridable Function Open As Boolean
public:
virtual bool Open()

Return Value

Type: Boolean
Returns true if the network semaphore file was opened and locked successfully. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.Search Method

NetworkSemaphoreSearch Method
Performs an asynchronous search for an unused network semaphore file. Requires handling the SearchCompleted and optionally the SearchProgress events.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void Search()
Public Sub Search
public:
void Search()
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore Events

NetworkSemaphore Events

The NetworkSemaphore type exposes the following members.

Events
 | Name | Description
Public event | Invalid | Occurs when the network session is no longer valid.
Public event | SearchCompleted | Occurs when the search for an unused seat/semaphore file has been completed.
Public event | SearchProgress | Occurs when progress is made in searching for an unused seat/semaphore file. The SearchProgress event may be used by your application to keep a user informed of the progress being made while searching through semaphore files.
Top
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.Invalid Event

NetworkSemaphoreInvalid Event
Occurs when the network session is no longer valid.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual event NetworkSemaphoreInvalidEventHandler Invalid
Public Overridable Event Invalid As NetworkSemaphoreInvalidEventHandler
public:
virtual  event NetworkSemaphoreInvalidEventHandler^ Invalid {
    void add (NetworkSemaphoreInvalidEventHandler^ value);
    void remove (NetworkSemaphoreInvalidEventHandler^ value);
}

Value

Type: com.softwarekey.Client.Licensing.NetworkNetworkSemaphoreInvalidEventHandler
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.SearchCompleted Event

NetworkSemaphoreSearchCompleted Event
Occurs when the search for an unused seat/semaphore file has been completed.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event NetworkSemaphoreSearchCompletedEventHandler SearchCompleted
Public Event SearchCompleted As NetworkSemaphoreSearchCompletedEventHandler
public:
 event NetworkSemaphoreSearchCompletedEventHandler^ SearchCompleted {
    void add (NetworkSemaphoreSearchCompletedEventHandler^ value);
    void remove (NetworkSemaphoreSearchCompletedEventHandler^ value);
}

Value

Type: com.softwarekey.Client.Licensing.NetworkNetworkSemaphoreSearchCompletedEventHandler
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.SearchProgress Event

NetworkSemaphoreSearchProgress Event
Occurs when progress is made in searching for an unused seat/semaphore file. The SearchProgress event may be used by your application to keep a user informed of the progress being made while searching through semaphore files.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event NetworkSemaphoreSearchProgressEventHandler SearchProgress
Public Event SearchProgress As NetworkSemaphoreSearchProgressEventHandler
public:
 event NetworkSemaphoreSearchProgressEventHandler^ SearchProgress {
    void add (NetworkSemaphoreSearchProgressEventHandler^ value);
    void remove (NetworkSemaphoreSearchProgressEventHandler^ value);
}

Value

Type: com.softwarekey.Client.Licensing.NetworkNetworkSemaphoreSearchProgressEventHandler
See Also

Reference

NetworkSemaphore Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.InvalidEventHandler Delegate

NetworkSemaphoreInvalidEventHandler Delegate
Delegate used for defining a handler method for the NetworkSemaphoreInvalidEventHandler event.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public delegate void InvalidEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub InvalidEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void InvalidEventHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
The object that raised the event.
e
Type: SystemEventArgs
The event arguments/data.
See Also

Reference

com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.SearchCompletedEventHandler Delegate

NetworkSemaphoreSearchCompletedEventHandler Delegate
Delegate used for defining a handler method for the SearchCompleted event.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public delegate void SearchCompletedEventHandler(
    Object sender,
    SearchCompletedEventArgs e
)
Public Delegate Sub SearchCompletedEventHandler (
    sender As Object,
    e As SearchCompletedEventArgs
)
public delegate void SearchCompletedEventHandler(
    Object^ sender,
    SearchCompletedEventArgs^ e
)

Parameters

sender
Type: SystemObject
The object that raised the event.
e
Type: com.softwarekey.Client.Licensing.NetworkSearchCompletedEventArgs
The event arguments/data. SeatOpened property indicates whether or not an available seat could be found and opened.
See Also

Reference

com.softwarekey.Client.Licensing.Network Namespace


NetworkSemaphore.SearchProgressEventHandler Delegate

NetworkSemaphoreSearchProgressEventHandler Delegate
Delegate used for defining a handler method for the SearchProgress event.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public delegate void SearchProgressEventHandler(
    Object sender,
    SearchProgressEventArgs e
)
Public Delegate Sub SearchProgressEventHandler (
    sender As Object,
    e As SearchProgressEventArgs
)
public delegate void SearchProgressEventHandler(
    Object^ sender,
    SearchProgressEventArgs^ e
)

Parameters

sender
Type: SystemObject
The object that raised the event.
e
Type: com.softwarekey.Client.Licensing.NetworkSearchProgressEventArgs
The event arguments/data. ProgressPercentage property indicates the current search progress.
See Also

Reference

com.softwarekey.Client.Licensing.Network Namespace


NetworkSession Class

NetworkSession Class
This API is preliminary and subject to change.
Implements support for Network Floating licensing / concurrency limit enforcement via SOLO Server.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Licensing.NetworkNetworkSession

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class NetworkSession
Public Class NetworkSession
public ref class NetworkSession

The NetworkSession type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkSession | Creates a new NetworkSession object for loading a new or existing network session.
Top
Properties
 | Name | Description
Public property | Certificate | Gets the NetworkSessionCertificate object containing the data from the certificate issued by SOLO Server.
Public property | CertificateLock | Gets the FileLock object used for locking the certificate file to the process.
Public property | CertificatePath | Gets the absolute path to the certificate file used when restoring a checked-out session.
Public property | CurrentIdentifiers | Gets the list of SystemIdentifier objects used to identify the current system.
Public property | IdentifierAlgorithms | Gets the list of SystemIdentifierAlgorithm objects to use to bind the certificate to the system.
Public property | LastError | Gets the last error that occurred.
Top
Methods
 | Name | Description
Public method | CheckinSession | Checks a Network Floating session back in.
Public method | CheckinSession(XmlNetworkFloatingService) | Checks a Network Floating session back in.
Public method | CheckoutSession(Decimal) | Requests a session check-out for a given duration of time to enable offline use.
Public method | CheckoutSession(Decimal, XmlNetworkFloatingService) | Requests a session check-out for a given duration of time to enable offline use.
Public method | ClearSession | Abandons the current session, clears the current session data, unlocks the certificate, deletes the certificate file if present.
Public method | CloseSession | Closes a Network Floating Session.
Public method | CloseSession(XmlNetworkFloatingService) | Closes a Network Floating Session.
Public method | DeleteCertificate | Unlocks and deletes the certificate file.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | InitializeCurrentIdentifiers | Initializes the CurrentIdentifiers property with data using the algorithms specified in the IdentifierAlgorithms property.
Public method | LockCertificate | Locks the certificate file to the process.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OpenSession(Int32, String) | Opens a Network Floating Session.
Public method | OpenSession(Int32, String, XmlNetworkFloatingService) | Opens a Network Floating Session.
Public method | PollSession | Polls SOLO Server to validate and maintain the status of the Network Floating Session.
Public method | PollSession(XmlNetworkFloatingService) | Polls SOLO Server to validate and maintain the status of the Network Floating Session.
Public method | ToString | (Inherited from Object.)
Public method | UnlockCertificate | Unlocks the certificate file.
Top
See Also

Reference

com.softwarekey.Client.Licensing.Network Namespace


NetworkSession Constructor

NetworkSession Constructor
This API is preliminary and subject to change.
Creates a new NetworkSession object for loading a new or existing network session.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkSession(
    AuthorEncryptionKey encryptionKey,
    bool useEncryption,
    bool useSignatures,
    List<SystemIdentifierAlgorithm> identifierAlgorithms,
    string certificatePath,
    bool loadCertificateFromFile
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    useEncryption As Boolean,
    useSignatures As Boolean,
    identifierAlgorithms As List(Of SystemIdentifierAlgorithm),
    certificatePath As String,
    loadCertificateFromFile As Boolean
)
public:
NetworkSession(
    AuthorEncryptionKey^ encryptionKey,
    bool useEncryption,
    bool useSignatures,
    List<SystemIdentifierAlgorithm^>^ identifierAlgorithms,
    String^ certificatePath,
    bool loadCertificateFromFile
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object required for cryptographic routines.
useEncryption
Type: SystemBoolean
Whether or not to use encryption (set to true if unsure).
useSignatures
Type: SystemBoolean
Whether or not to use signatures (set to true if unsure).
identifierAlgorithms
Type: System.Collections.GenericList SystemIdentifierAlgorithm
A list of SystemIdentifierAlgorithm objects to use to bind the session to the current system.
certificatePath
Type: SystemString
The absolute path to the certificate file.
loadCertificateFromFile
Type: SystemBoolean
Whether or not the session should be initialized from an existing certificate file.
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession Properties

NetworkSession Properties
This API is preliminary and subject to change.

The NetworkSession type exposes the following members.

Properties
 | Name | Description
Public property | Certificate | Gets the NetworkSessionCertificate object containing the data from the certificate issued by SOLO Server.
Public property | CertificateLock | Gets the FileLock object used for locking the certificate file to the process.
Public property | CertificatePath | Gets the absolute path to the certificate file used when restoring a checked-out session.
Public property | CurrentIdentifiers | Gets the list of SystemIdentifier objects used to identify the current system.
Public property | IdentifierAlgorithms | Gets the list of SystemIdentifierAlgorithm objects to use to bind the certificate to the system.
Public property | LastError | Gets the last error that occurred.
Top
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.Certificate Property

NetworkSessionCertificate Property
This API is preliminary and subject to change.
Gets the NetworkSessionCertificate object containing the data from the certificate issued by SOLO Server.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkSessionCertificate Certificate { get; }
Public ReadOnly Property Certificate As NetworkSessionCertificate
    Get
public:
property NetworkSessionCertificate^ Certificate {
    NetworkSessionCertificate^ get ();
}

Property Value

Type: NetworkSessionCertificate
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CertificateLock Property

NetworkSessionCertificateLock Property
This API is preliminary and subject to change.
Gets the FileLock object used for locking the certificate file to the process.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public FileLock CertificateLock { get; }
Public ReadOnly Property CertificateLock As FileLock
    Get
public:
property FileLock^ CertificateLock {
    FileLock^ get ();
}

Property Value

Type: FileLock
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CertificatePath Property

NetworkSessionCertificatePath Property
This API is preliminary and subject to change.
Gets the absolute path to the certificate file used when restoring a checked-out session.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CertificatePath { get; }
Public ReadOnly Property CertificatePath As String
    Get
public:
property String^ CertificatePath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CurrentIdentifiers Property

NetworkSessionCurrentIdentifiers Property
This API is preliminary and subject to change.
Gets the list of SystemIdentifier objects used to identify the current system.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<SystemIdentifier> CurrentIdentifiers { get; }
Public ReadOnly Property CurrentIdentifiers As List(Of SystemIdentifier)
    Get
public:
property List<SystemIdentifier^>^ CurrentIdentifiers {
    List<SystemIdentifier^>^ get ();
}

Property Value

Type: List SystemIdentifier
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.IdentifierAlgorithms Property

NetworkSessionIdentifierAlgorithms Property
This API is preliminary and subject to change.
Gets the list of SystemIdentifierAlgorithm objects to use to bind the certificate to the system.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<SystemIdentifierAlgorithm> IdentifierAlgorithms { get; }
Public ReadOnly Property IdentifierAlgorithms As List(Of SystemIdentifierAlgorithm)
    Get
public:
property List<SystemIdentifierAlgorithm^>^ IdentifierAlgorithms {
    List<SystemIdentifierAlgorithm^>^ get ();
}

Property Value

Type: List SystemIdentifierAlgorithm
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.LastError Property

NetworkSessionLastError Property
This API is preliminary and subject to change.
Gets the last error that occurred.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError LastError { get; }
Public ReadOnly Property LastError As LicenseError
    Get
public:
property LicenseError^ LastError {
    LicenseError^ get ();
}

Property Value

Type: LicenseError
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession Methods

NetworkSession Methods
This API is preliminary and subject to change.

The NetworkSession type exposes the following members.

Methods
 | Name | Description
Public method | CheckinSession | Checks a Network Floating session back in.
Public method | CheckinSession(XmlNetworkFloatingService) | Checks a Network Floating session back in.
Public method | CheckoutSession(Decimal) | Requests a session check-out for a given duration of time to enable offline use.
Public method | CheckoutSession(Decimal, XmlNetworkFloatingService) | Requests a session check-out for a given duration of time to enable offline use.
Public method | ClearSession | Abandons the current session, clears the current session data, unlocks the certificate, deletes the certificate file if present.
Public method | CloseSession | Closes a Network Floating Session.
Public method | CloseSession(XmlNetworkFloatingService) | Closes a Network Floating Session.
Public method | DeleteCertificate | Unlocks and deletes the certificate file.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | InitializeCurrentIdentifiers | Initializes the CurrentIdentifiers property with data using the algorithms specified in the IdentifierAlgorithms property.
Public method | LockCertificate | Locks the certificate file to the process.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OpenSession(Int32, String) | Opens a Network Floating Session.
Public method | OpenSession(Int32, String, XmlNetworkFloatingService) | Opens a Network Floating Session.
Public method | PollSession | Polls SOLO Server to validate and maintain the status of the Network Floating Session.
Public method | PollSession(XmlNetworkFloatingService) | Polls SOLO Server to validate and maintain the status of the Network Floating Session.
Public method | ToString | (Inherited from Object.)
Public method | UnlockCertificate | Unlocks the certificate file.
Top
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CheckinSession Method

NetworkSessionCheckinSession Method
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | CheckinSession | Checks a Network Floating session back in.
Public method | CheckinSession(XmlNetworkFloatingService) | Checks a Network Floating session back in.
Top
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CheckinSession Method

NetworkSessionCheckinSession Method
This API is preliminary and subject to change.
Checks a Network Floating session back in.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool CheckinSession()
Public Function CheckinSession As Boolean
public:
bool CheckinSession()

Return Value

Type: Boolean
Returns true if successful or if the network session is not checked out. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSession Class
CheckinSession Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CheckinSession Method (XmlNetworkFloatingService)

NetworkSessionCheckinSession Method (XmlNetworkFloatingService)
This API is preliminary and subject to change.
Checks a Network Floating session back in.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool CheckinSession(
    XmlNetworkFloatingService client
)
Public Function CheckinSession (
    client As XmlNetworkFloatingService
) As Boolean
public:
bool CheckinSession(
    XmlNetworkFloatingService^ client
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService
The XmlNetworkFloatingService object to make the web service method call.

Return Value

Type: Boolean
Returns true if successful or if the network session is not checked out. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSession Class
CheckinSession Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CheckoutSession Method

NetworkSessionCheckoutSession Method
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | CheckoutSession(Decimal) | Requests a session check-out for a given duration of time to enable offline use.
Public method | CheckoutSession(Decimal, XmlNetworkFloatingService) | Requests a session check-out for a given duration of time to enable offline use.
Top
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CheckoutSession Method (Decimal)

NetworkSessionCheckoutSession Method (Decimal)
This API is preliminary and subject to change.
Requests a session check-out for a given duration of time to enable offline use.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool CheckoutSession(
    decimal requestedCheckoutDuration
)
Public Function CheckoutSession (
    requestedCheckoutDuration As Decimal
) As Boolean
public:
bool CheckoutSession(
    Decimal requestedCheckoutDuration
)

Parameters

requestedCheckoutDuration
Type: SystemDecimal
The amount of time (in hours) we would like the requested checkout to last.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSession Class
CheckoutSession Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CheckoutSession Method (Decimal, XmlNetworkFloatingService)

NetworkSessionCheckoutSession Method (Decimal, XmlNetworkFloatingService)
This API is preliminary and subject to change.
Requests a session check-out for a given duration of time to enable offline use.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool CheckoutSession(
    decimal requestedCheckoutDuration,
    XmlNetworkFloatingService client
)
Public Function CheckoutSession (
    requestedCheckoutDuration As Decimal,
    client As XmlNetworkFloatingService
) As Boolean
public:
bool CheckoutSession(
    Decimal requestedCheckoutDuration,
    XmlNetworkFloatingService^ client
)

Parameters

requestedCheckoutDuration
Type: SystemDecimal
The amount of time (in hours) we would like the requested checkout to last.
client
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService
The XmlNetworkFloatingService object to make the web service method call.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSession Class
CheckoutSession Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.ClearSession Method

NetworkSessionClearSession Method
This API is preliminary and subject to change.
Abandons the current session, clears the current session data, unlocks the certificate, deletes the certificate file if present.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ClearSession()
Public Sub ClearSession
public:
void ClearSession()
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CloseSession Method

NetworkSessionCloseSession Method
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | CloseSession | Closes a Network Floating Session.
Public method | CloseSession(XmlNetworkFloatingService) | Closes a Network Floating Session.
Top
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CloseSession Method

NetworkSessionCloseSession Method
This API is preliminary and subject to change.
Closes a Network Floating Session.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool CloseSession()
Public Function CloseSession As Boolean
public:
bool CloseSession()

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSession Class
CloseSession Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.CloseSession Method (XmlNetworkFloatingService)

NetworkSessionCloseSession Method (XmlNetworkFloatingService)
This API is preliminary and subject to change.
Closes a Network Floating Session.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool CloseSession(
    XmlNetworkFloatingService client
)
Public Function CloseSession (
    client As XmlNetworkFloatingService
) As Boolean
public:
bool CloseSession(
    XmlNetworkFloatingService^ client
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService
The XmlNetworkFloatingService object to make the web service method call.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSession Class
CloseSession Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.DeleteCertificate Method

NetworkSessionDeleteCertificate Method
This API is preliminary and subject to change.
Unlocks and deletes the certificate file.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void DeleteCertificate()
Public Sub DeleteCertificate
public:
void DeleteCertificate()
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.InitializeCurrentIdentifiers Method

NetworkSessionInitializeCurrentIdentifiers Method
This API is preliminary and subject to change.
Initializes the CurrentIdentifiers property with data using the algorithms specified in the IdentifierAlgorithms property.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void InitializeCurrentIdentifiers()
Public Sub InitializeCurrentIdentifiers
public:
void InitializeCurrentIdentifiers()
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.LockCertificate Method

NetworkSessionLockCertificate Method
This API is preliminary and subject to change.
Locks the certificate file to the process.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void LockCertificate()
Public Sub LockCertificate
public:
void LockCertificate()
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.OpenSession Method

NetworkSessionOpenSession Method
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | OpenSession(Int32, String) | Opens a Network Floating Session.
Public method | OpenSession(Int32, String, XmlNetworkFloatingService) | Opens a Network Floating Session.
Top
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.OpenSession Method (Int32, String)

NetworkSessionOpenSession Method (Int32, String)
This API is preliminary and subject to change.
Opens a Network Floating Session.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool OpenSession(
    int licenseId,
    string password
)
Public Function OpenSession (
    licenseId As Integer,
    password As String
) As Boolean
public:
bool OpenSession(
    int licenseId,
    String^ password
)

Parameters

licenseId
Type: SystemInt32
The License ID issued from SOLO Server.
password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSession Class
OpenSession Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.OpenSession Method (Int32, String, XmlNetworkFloatingService)

NetworkSessionOpenSession Method (Int32, String, XmlNetworkFloatingService)
This API is preliminary and subject to change.
Opens a Network Floating Session.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool OpenSession(
    int licenseId,
    string password,
    XmlNetworkFloatingService client
)
Public Function OpenSession (
    licenseId As Integer,
    password As String,
    client As XmlNetworkFloatingService
) As Boolean
public:
bool OpenSession(
    int licenseId,
    String^ password,
    XmlNetworkFloatingService^ client
)

Parameters

licenseId
Type: SystemInt32
The License ID issued from SOLO Server.
password
Type: SystemString
The activation password assigned to the license, or the customer password, in SOLO Server.
client
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService
The XmlNetworkFloatingService object to make the web service method call.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSession Class
OpenSession Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.PollSession Method

NetworkSessionPollSession Method
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | PollSession | Polls SOLO Server to validate and maintain the status of the Network Floating Session.
Public method | PollSession(XmlNetworkFloatingService) | Polls SOLO Server to validate and maintain the status of the Network Floating Session.
Top
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.PollSession Method

NetworkSessionPollSession Method
This API is preliminary and subject to change.
Polls SOLO Server to validate and maintain the status of the Network Floating Session.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool PollSession()
Public Function PollSession As Boolean
public:
bool PollSession()

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSession Class
PollSession Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.PollSession Method (XmlNetworkFloatingService)

NetworkSessionPollSession Method (XmlNetworkFloatingService)
This API is preliminary and subject to change.
Polls SOLO Server to validate and maintain the status of the Network Floating Session.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool PollSession(
    XmlNetworkFloatingService client
)
Public Function PollSession (
    client As XmlNetworkFloatingService
) As Boolean
public:
bool PollSession(
    XmlNetworkFloatingService^ client
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService
The XmlNetworkFloatingService object to make the web service method call.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSession Class
PollSession Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSession.UnlockCertificate Method

NetworkSessionUnlockCertificate Method
This API is preliminary and subject to change.
Unlocks the certificate file.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UnlockCertificate()
Public Sub UnlockCertificate
public:
void UnlockCertificate()
See Also

Reference

NetworkSession Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate Class

NetworkSessionCertificate Class
This API is preliminary and subject to change.
Represents a certificate issued by SOLO Server for an authorized network session.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Licensing.NetworkNetworkSessionCertificate

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class NetworkSessionCertificate
Public Class NetworkSessionCertificate
public ref class NetworkSessionCertificate

The NetworkSessionCertificate type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkSessionCertificate(AuthorEncryptionKey, String, Boolean, Boolean) | Creates a new NetworkSessionCertificate object initialized with data from an XML document on the file system.
Public method | NetworkSessionCertificate(AuthorEncryptionKey, XmlDocument, Boolean, Boolean) | Creates a new NetworkSessionCertificate object initialized with data from an XML document.
Top
Properties
 | Name | Description
Public property | AllocatedDate | Gets the date and time in which the Network Session was allocated/authorized.
Public property | AllocatedUntilDate | Gets the date and time in which the Network Session is no longer authorized - this is typically extended with Poll request or a Checkout request.
Public property | AuthorizedIdentifiers | Gets the of authorized SystemIdentifier objects.
Public property | CertificatePath | Gets the path to the certificate file. (Only applicable if CheckedOut is true.)
Public property | CertificateXml | Gets the XmlDocument object containing the certificate. If encryption is being used, this document is encrypted.
Public property | CheckedOut | Gets whether or not this Network Session has been checked out.
Public property | CheckoutDurationMaximum | Gets the maximum amount of time (in hours) a checkout request allows.
Public property | CheckoutDurationMinimum | Gets the minimum amount of time (in hours) a checkout request allows.
Public property | ComputerName | Gets the name of the computer authorized for the Network Session.
Public property | CustomerID | Gets the Customer ID in SOLO Server to which the License ID belongs.
Public property | LastError | Gets the last error that occurred while trying to initialize the certificate.
Public property | LastPollDate | Gets the last time this machine phoned home/polled against SOLO Server.
Public property | LicenseID | Gets the SOLO Server License ID to which the this Session ID belongs.
Public property | PollFrequency | Gets the amount of time (in seconds) that should pass before the application attempts to poll against SOLO Server.
Public property | PollRetryCount | Gets the number of times to retry polling against SOLO Server.
Public property | PollRetryFrequency | Gets the amount of time (in seconds) to wait between each retry for polling against SOLO Server.
Public property | ProductID | Gets the Product ID in SOLO Server to which the Product Option ID belongs.
Public property | ProductOptionID | Gets the Product Option ID in SOLO Server with which the License ID was issued.
Public property | SeatsAvailable | Gets the number of allowed Network Sessions not yet allocated.
Public property | SessionID | Gets the Network Session ID issued from SOLO Server.
Public property | TotalSeats | Gets the total number of Network Sessions allowed.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save | Saves the NetworkSessionCertificate to a file.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate Constructor

NetworkSessionCertificate Constructor
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | NetworkSessionCertificate(AuthorEncryptionKey, String, Boolean, Boolean) | Creates a new NetworkSessionCertificate object initialized with data from an XML document on the file system.
Public method | NetworkSessionCertificate(AuthorEncryptionKey, XmlDocument, Boolean, Boolean) | Creates a new NetworkSessionCertificate object initialized with data from an XML document.
Top
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate Constructor (AuthorEncryptionKey, String, Boolean, Boolean)

NetworkSessionCertificate Constructor (AuthorEncryptionKey, String, Boolean, Boolean)
This API is preliminary and subject to change.
Creates a new NetworkSessionCertificate object initialized with data from an XML document on the file system.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkSessionCertificate(
    AuthorEncryptionKey encryptionKey,
    string certificatePath,
    bool useEncryption,
    bool useSignatures
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    certificatePath As String,
    useEncryption As Boolean,
    useSignatures As Boolean
)
public:
NetworkSessionCertificate(
    AuthorEncryptionKey^ encryptionKey,
    String^ certificatePath,
    bool useEncryption,
    bool useSignatures
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object required for cryptographic routines.
certificatePath
Type: SystemString
The absolute path to the certificate XML file.
useEncryption
Type: SystemBoolean
Whether or not to use encryption (set to true if unsure).
useSignatures
Type: SystemBoolean
Whether or not to use signatures (set to true if unsure).
See Also

Reference

NetworkSessionCertificate Class
NetworkSessionCertificate Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate Constructor (AuthorEncryptionKey, XmlDocument, Boolean, Boolean)

NetworkSessionCertificate Constructor (AuthorEncryptionKey, XmlDocument, Boolean, Boolean)
This API is preliminary and subject to change.
Creates a new NetworkSessionCertificate object initialized with data from an XML document.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkSessionCertificate(
    AuthorEncryptionKey encryptionKey,
    XmlDocument certificate,
    bool useEncryption,
    bool useSignatures
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey,
    certificate As XmlDocument,
    useEncryption As Boolean,
    useSignatures As Boolean
)
public:
NetworkSessionCertificate(
    AuthorEncryptionKey^ encryptionKey,
    XmlDocument^ certificate,
    bool useEncryption,
    bool useSignatures
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object required for cryptographic routines.
certificate
Type: System.XmlXmlDocument
The XmlDocument object containing the certificate.
useEncryption
Type: SystemBoolean
Whether or not to use encryption (set to true if unsure).
useSignatures
Type: SystemBoolean
Whether or not to use signatures (set to true if unsure).
See Also

Reference

NetworkSessionCertificate Class
NetworkSessionCertificate Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate Properties

NetworkSessionCertificate Properties
This API is preliminary and subject to change.

The NetworkSessionCertificate type exposes the following members.

Properties
 | Name | Description
Public property | AllocatedDate | Gets the date and time in which the Network Session was allocated/authorized.
Public property | AllocatedUntilDate | Gets the date and time in which the Network Session is no longer authorized - this is typically extended with Poll request or a Checkout request.
Public property | AuthorizedIdentifiers | Gets the of authorized SystemIdentifier objects.
Public property | CertificatePath | Gets the path to the certificate file. (Only applicable if CheckedOut is true.)
Public property | CertificateXml | Gets the XmlDocument object containing the certificate. If encryption is being used, this document is encrypted.
Public property | CheckedOut | Gets whether or not this Network Session has been checked out.
Public property | CheckoutDurationMaximum | Gets the maximum amount of time (in hours) a checkout request allows.
Public property | CheckoutDurationMinimum | Gets the minimum amount of time (in hours) a checkout request allows.
Public property | ComputerName | Gets the name of the computer authorized for the Network Session.
Public property | CustomerID | Gets the Customer ID in SOLO Server to which the License ID belongs.
Public property | LastError | Gets the last error that occurred while trying to initialize the certificate.
Public property | LastPollDate | Gets the last time this machine phoned home/polled against SOLO Server.
Public property | LicenseID | Gets the SOLO Server License ID to which the this Session ID belongs.
Public property | PollFrequency | Gets the amount of time (in seconds) that should pass before the application attempts to poll against SOLO Server.
Public property | PollRetryCount | Gets the number of times to retry polling against SOLO Server.
Public property | PollRetryFrequency | Gets the amount of time (in seconds) to wait between each retry for polling against SOLO Server.
Public property | ProductID | Gets the Product ID in SOLO Server to which the Product Option ID belongs.
Public property | ProductOptionID | Gets the Product Option ID in SOLO Server with which the License ID was issued.
Public property | SeatsAvailable | Gets the number of allowed Network Sessions not yet allocated.
Public property | SessionID | Gets the Network Session ID issued from SOLO Server.
Public property | TotalSeats | Gets the total number of Network Sessions allowed.
Top
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.AllocatedDate Property

NetworkSessionCertificateAllocatedDate Property
This API is preliminary and subject to change.
Gets the date and time in which the Network Session was allocated/authorized.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime AllocatedDate { get; }
Public ReadOnly Property AllocatedDate As DateTime
    Get
public:
property DateTime AllocatedDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.AllocatedUntilDate Property

NetworkSessionCertificateAllocatedUntilDate Property
This API is preliminary and subject to change.
Gets the date and time in which the Network Session is no longer authorized - this is typically extended with Poll request or a Checkout request.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime AllocatedUntilDate { get; }
Public ReadOnly Property AllocatedUntilDate As DateTime
    Get
public:
property DateTime AllocatedUntilDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.AuthorizedIdentifiers Property

NetworkSessionCertificateAuthorizedIdentifiers Property
This API is preliminary and subject to change.
Gets the of authorized SystemIdentifier objects.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<SystemIdentifier> AuthorizedIdentifiers { get; }
Public ReadOnly Property AuthorizedIdentifiers As List(Of SystemIdentifier)
    Get
public:
property List<SystemIdentifier^>^ AuthorizedIdentifiers {
    List<SystemIdentifier^>^ get ();
}

Property Value

Type: List SystemIdentifier
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.CertificatePath Property

NetworkSessionCertificateCertificatePath Property
This API is preliminary and subject to change.
Gets the path to the certificate file. (Only applicable if CheckedOut is true.)

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CertificatePath { get; }
Public ReadOnly Property CertificatePath As String
    Get
public:
property String^ CertificatePath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.CertificateXml Property

NetworkSessionCertificateCertificateXml Property
This API is preliminary and subject to change.
Gets the XmlDocument object containing the certificate. If encryption is being used, this document is encrypted.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlDocument CertificateXml { get; }
Public ReadOnly Property CertificateXml As XmlDocument
    Get
public:
property XmlDocument^ CertificateXml {
    XmlDocument^ get ();
}

Property Value

Type: XmlDocument
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.CheckedOut Property

NetworkSessionCertificateCheckedOut Property
This API is preliminary and subject to change.
Gets whether or not this Network Session has been checked out.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool CheckedOut { get; }
Public ReadOnly Property CheckedOut As Boolean
    Get
public:
property bool CheckedOut {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.CheckoutDurationMaximum Property

NetworkSessionCertificateCheckoutDurationMaximum Property
This API is preliminary and subject to change.
Gets the maximum amount of time (in hours) a checkout request allows.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public decimal CheckoutDurationMaximum { get; }
Public ReadOnly Property CheckoutDurationMaximum As Decimal
    Get
public:
property Decimal CheckoutDurationMaximum {
    Decimal get ();
}

Property Value

Type: Decimal
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.CheckoutDurationMinimum Property

NetworkSessionCertificateCheckoutDurationMinimum Property
This API is preliminary and subject to change.
Gets the minimum amount of time (in hours) a checkout request allows.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public decimal CheckoutDurationMinimum { get; }
Public ReadOnly Property CheckoutDurationMinimum As Decimal
    Get
public:
property Decimal CheckoutDurationMinimum {
    Decimal get ();
}

Property Value

Type: Decimal
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.ComputerName Property

NetworkSessionCertificateComputerName Property
This API is preliminary and subject to change.
Gets the name of the computer authorized for the Network Session.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ComputerName { get; }
Public ReadOnly Property ComputerName As String
    Get
public:
property String^ ComputerName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.CustomerID Property

NetworkSessionCertificateCustomerID Property
This API is preliminary and subject to change.
Gets the Customer ID in SOLO Server to which the License ID belongs.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int CustomerID { get; }
Public ReadOnly Property CustomerID As Integer
    Get
public:
property int CustomerID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.LastError Property

NetworkSessionCertificateLastError Property
This API is preliminary and subject to change.
Gets the last error that occurred while trying to initialize the certificate.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError LastError { get; }
Public ReadOnly Property LastError As LicenseError
    Get
public:
property LicenseError^ LastError {
    LicenseError^ get ();
}

Property Value

Type: LicenseError
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.LastPollDate Property

NetworkSessionCertificateLastPollDate Property
This API is preliminary and subject to change.
Gets the last time this machine phoned home/polled against SOLO Server.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime LastPollDate { get; }
Public ReadOnly Property LastPollDate As DateTime
    Get
public:
property DateTime LastPollDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.LicenseID Property

NetworkSessionCertificateLicenseID Property
This API is preliminary and subject to change.
Gets the SOLO Server License ID to which the this Session ID belongs.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; }
Public ReadOnly Property LicenseID As Integer
    Get
public:
property int LicenseID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.PollFrequency Property

NetworkSessionCertificatePollFrequency Property
This API is preliminary and subject to change.
Gets the amount of time (in seconds) that should pass before the application attempts to poll against SOLO Server.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int PollFrequency { get; }
Public ReadOnly Property PollFrequency As Integer
    Get
public:
property int PollFrequency {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.PollRetryCount Property

NetworkSessionCertificatePollRetryCount Property
This API is preliminary and subject to change.
Gets the number of times to retry polling against SOLO Server.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int PollRetryCount { get; }
Public ReadOnly Property PollRetryCount As Integer
    Get
public:
property int PollRetryCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.PollRetryFrequency Property

NetworkSessionCertificatePollRetryFrequency Property
This API is preliminary and subject to change.
Gets the amount of time (in seconds) to wait between each retry for polling against SOLO Server.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int PollRetryFrequency { get; }
Public ReadOnly Property PollRetryFrequency As Integer
    Get
public:
property int PollRetryFrequency {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.ProductID Property

NetworkSessionCertificateProductID Property
This API is preliminary and subject to change.
Gets the Product ID in SOLO Server to which the Product Option ID belongs.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; }
Public ReadOnly Property ProductID As Integer
    Get
public:
property int ProductID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.ProductOptionID Property

NetworkSessionCertificateProductOptionID Property
This API is preliminary and subject to change.
Gets the Product Option ID in SOLO Server with which the License ID was issued.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductOptionID { get; }
Public ReadOnly Property ProductOptionID As Integer
    Get
public:
property int ProductOptionID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.SeatsAvailable Property

NetworkSessionCertificateSeatsAvailable Property
This API is preliminary and subject to change.
Gets the number of allowed Network Sessions not yet allocated.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int SeatsAvailable { get; }
Public ReadOnly Property SeatsAvailable As Integer
    Get
public:
property int SeatsAvailable {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.SessionID Property

NetworkSessionCertificateSessionID Property
This API is preliminary and subject to change.
Gets the Network Session ID issued from SOLO Server.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SessionID { get; }
Public ReadOnly Property SessionID As String
    Get
public:
property String^ SessionID {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.TotalSeats Property

NetworkSessionCertificateTotalSeats Property
This API is preliminary and subject to change.
Gets the total number of Network Sessions allowed.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int TotalSeats { get; }
Public ReadOnly Property TotalSeats As Integer
    Get
public:
property int TotalSeats {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate Methods

NetworkSessionCertificate Methods
This API is preliminary and subject to change.

The NetworkSessionCertificate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save | Saves the NetworkSessionCertificate to a file.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionCertificate.Save Method

NetworkSessionCertificateSave Method
This API is preliminary and subject to change.
Saves the NetworkSessionCertificate to a file.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool Save(
    string certificatePath
)
Public Function Save (
    certificatePath As String
) As Boolean
public:
bool Save(
    String^ certificatePath
)

Parameters

certificatePath
Type: SystemString
The absolute path specifying were to save the certificate file.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSessionCertificate Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation Class

NetworkSessionValidation Class
This API is preliminary and subject to change.
Validates a NetworkSession.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.LicensingSystemValidation
com.softwarekey.Client.Licensing.NetworkNetworkSessionValidation

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class NetworkSessionValidation : SystemValidation
Public Class NetworkSessionValidation
    Inherits SystemValidation
public ref class NetworkSessionValidation : public SystemValidation

The NetworkSessionValidation type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkSessionValidation(NetworkSession) | Creates a new NetworkSessionValidation object that can be used to validate a given network session's data, including time checks when possible, and requiring an exact match of System Identifier information.
Public method | NetworkSessionValidation(NetworkSession, SystemIdentifierValidation, SystemDateTimeValidation) | Creates a new NetworkSessionValidation object that can be used to validate a given network session's data, with specified validation objects.
Public method | NetworkSessionValidation(NetworkSession, Boolean, Int32, Boolean, NetworkSessionValidationNetworkSessionTimeValidationType) | Creates a new NetworkSessionValidation object that can be used to validate a given network session's data.
Top
Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | Session | Gets or sets the NetworkSession object which is to be validated.
Public property | SystemDateTimeThresholdMinutes | Gets or sets the allowed amount of difference in time (in minutes) between the licensed system's time and SOLO Server's time.
Public property | SystemDateTimeValidator | Gets or sets the SystemDateTimeValidation object which is to perform the validation of system's date and time (null if no date and time validation is to be done).
Public property | SystemIdentifierValidator | Gets or sets the SystemIdentifierValidator object which is to perform the validation of SystemIdentifier objects (null if no SystemIdentifier validation is to be done).
Public property | UseCertificatePathValidation | Gets or sets whether or not the certificate file's path is validated when the session is checked out.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates the NetworkSession. (Overrides SystemValidationValidate.)
Top
See Also

Reference

com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation Constructor

NetworkSessionValidation Constructor
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | NetworkSessionValidation(NetworkSession) | Creates a new NetworkSessionValidation object that can be used to validate a given network session's data, including time checks when possible, and requiring an exact match of System Identifier information.
Public method | NetworkSessionValidation(NetworkSession, SystemIdentifierValidation, SystemDateTimeValidation) | Creates a new NetworkSessionValidation object that can be used to validate a given network session's data, with specified validation objects.
Public method | NetworkSessionValidation(NetworkSession, Boolean, Int32, Boolean, NetworkSessionValidationNetworkSessionTimeValidationType) | Creates a new NetworkSessionValidation object that can be used to validate a given network session's data.
Top
See Also

Reference

NetworkSessionValidation Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation Constructor (NetworkSession)

NetworkSessionValidation Constructor (NetworkSession)
This API is preliminary and subject to change.
Creates a new NetworkSessionValidation object that can be used to validate a given network session's data, including time checks when possible, and requiring an exact match of System Identifier information.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkSessionValidation(
    NetworkSession session
)
Public Sub New (
    session As NetworkSession
)
public:
NetworkSessionValidation(
    NetworkSession^ session
)

Parameters

session
Type: com.softwarekey.Client.Licensing.NetworkNetworkSession
The NetworkSession object to validate.
See Also

Reference

NetworkSessionValidation Class
NetworkSessionValidation Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation Constructor (NetworkSession, SystemIdentifierValidation, SystemDateTimeValidation)

NetworkSessionValidation Constructor (NetworkSession, SystemIdentifierValidation, SystemDateTimeValidation)
This API is preliminary and subject to change.
Creates a new NetworkSessionValidation object that can be used to validate a given network session's data, with specified validation objects.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkSessionValidation(
    NetworkSession session,
    SystemIdentifierValidation identifierValidator,
    SystemDateTimeValidation dateTimeValidator
)
Public Sub New (
    session As NetworkSession,
    identifierValidator As SystemIdentifierValidation,
    dateTimeValidator As SystemDateTimeValidation
)
public:
NetworkSessionValidation(
    NetworkSession^ session,
    SystemIdentifierValidation^ identifierValidator,
    SystemDateTimeValidation^ dateTimeValidator
)

Parameters

session
Type: com.softwarekey.Client.Licensing.NetworkNetworkSession
The NetworkSession object to validate.
identifierValidator
Type: com.softwarekey.Client.LicensingSystemIdentifierValidation
The SystemIdentifierValidation object used to validate the CurrentIdentifiers.
dateTimeValidator
Type: com.softwarekey.Client.LicensingSystemDateTimeValidation
The SystemDateTimeValidation object used to validate the system's date and time via SNTP.
See Also

Reference

NetworkSessionValidation Class
NetworkSessionValidation Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation Constructor (NetworkSession, Boolean, Int32, Boolean, NetworkSessionValidation.NetworkSessionTimeValidationType)

NetworkSessionValidation Constructor (NetworkSession, Boolean, Int32, Boolean, NetworkSessionValidationNetworkSessionTimeValidationType)
This API is preliminary and subject to change.
Creates a new NetworkSessionValidation object that can be used to validate a given network session's data.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkSessionValidation(
    NetworkSession session,
    bool useSystemIdentifierValidation,
    int matchingIdentifiersRequired,
    bool useCertificatePathValidation,
    NetworkSessionValidationNetworkSessionTimeValidationType ntpValidationType
)
Public Sub New (
    session As NetworkSession,
    useSystemIdentifierValidation As Boolean,
    matchingIdentifiersRequired As Integer,
    useCertificatePathValidation As Boolean,
    ntpValidationType As NetworkSessionValidationNetworkSessionTimeValidationType
)
public:
NetworkSessionValidation(
    NetworkSession^ session,
    bool useSystemIdentifierValidation,
    int matchingIdentifiersRequired,
    bool useCertificatePathValidation,
    NetworkSessionValidationNetworkSessionTimeValidationType ntpValidationType
)

Parameters

session
Type: com.softwarekey.Client.Licensing.NetworkNetworkSession
The NetworkSession object to validate.
useSystemIdentifierValidation
Type: SystemBoolean
Set to true to bind network session certificates to the machines which request the sessions. (If you are unsure, set this to true.)
matchingIdentifiersRequired
Type: SystemInt32
The minimum number of matching identifiers required. (If you are unsure, set this to SystemIdentifierValidation.REQUIRE_EXACT_MATCH.)
useCertificatePathValidation
Type: SystemBoolean
Whether or not the certificate path should be validated (set to true if unsure).
ntpValidationType
Type: com.softwarekey.Client.Licensing.NetworkNetworkSessionValidationNetworkSessionTimeValidationType
The type of NTP validation to use (if unsure, set to NetworkSessionTimeValidationType.WhenAvailable).
See Also

Reference

NetworkSessionValidation Class
NetworkSessionValidation Overload
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation Properties

NetworkSessionValidation Properties
This API is preliminary and subject to change.

The NetworkSessionValidation type exposes the following members.

Properties
 | Name | Description
Public property | LastError | Gets or sets the last error encountered in this object. (Inherited from SystemValidation.)
Public property | Session | Gets or sets the NetworkSession object which is to be validated.
Public property | SystemDateTimeThresholdMinutes | Gets or sets the allowed amount of difference in time (in minutes) between the licensed system's time and SOLO Server's time.
Public property | SystemDateTimeValidator | Gets or sets the SystemDateTimeValidation object which is to perform the validation of system's date and time (null if no date and time validation is to be done).
Public property | SystemIdentifierValidator | Gets or sets the SystemIdentifierValidator object which is to perform the validation of SystemIdentifier objects (null if no SystemIdentifier validation is to be done).
Public property | UseCertificatePathValidation | Gets or sets whether or not the certificate file's path is validated when the session is checked out.
Top
See Also

Reference

NetworkSessionValidation Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation.Session Property

NetworkSessionValidationSession Property
This API is preliminary and subject to change.
Gets or sets the NetworkSession object which is to be validated.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkSession Session { get; set; }
Public Property Session As NetworkSession
    Get
    Set
public:
property NetworkSession^ Session {
    NetworkSession^ get ();
    void set (NetworkSession^ value);
}

Property Value

Type: NetworkSession
See Also

Reference

NetworkSessionValidation Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation.SystemDateTimeThresholdMinutes Property

NetworkSessionValidationSystemDateTimeThresholdMinutes Property
This API is preliminary and subject to change.
Gets or sets the allowed amount of difference in time (in minutes) between the licensed system's time and SOLO Server's time.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public double SystemDateTimeThresholdMinutes { get; set; }
Public Property SystemDateTimeThresholdMinutes As Double
    Get
    Set
public:
property double SystemDateTimeThresholdMinutes {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

NetworkSessionValidation Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation.SystemDateTimeValidator Property

NetworkSessionValidationSystemDateTimeValidator Property
This API is preliminary and subject to change.
Gets or sets the SystemDateTimeValidation object which is to perform the validation of system's date and time (null if no date and time validation is to be done).

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemDateTimeValidation SystemDateTimeValidator { get; set; }
Public Property SystemDateTimeValidator As SystemDateTimeValidation
    Get
    Set
public:
property SystemDateTimeValidation^ SystemDateTimeValidator {
    SystemDateTimeValidation^ get ();
    void set (SystemDateTimeValidation^ value);
}

Property Value

Type: SystemDateTimeValidation
See Also

Reference

NetworkSessionValidation Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation.SystemIdentifierValidator Property

NetworkSessionValidationSystemIdentifierValidator Property
This API is preliminary and subject to change.
Gets or sets the SystemIdentifierValidator object which is to perform the validation of SystemIdentifier objects (null if no SystemIdentifier validation is to be done).

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemIdentifierValidation SystemIdentifierValidator { get; set; }
Public Property SystemIdentifierValidator As SystemIdentifierValidation
    Get
    Set
public:
property SystemIdentifierValidation^ SystemIdentifierValidator {
    SystemIdentifierValidation^ get ();
    void set (SystemIdentifierValidation^ value);
}

Property Value

Type: SystemIdentifierValidation
See Also

Reference

NetworkSessionValidation Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation.UseCertificatePathValidation Property

NetworkSessionValidationUseCertificatePathValidation Property
This API is preliminary and subject to change.
Gets or sets whether or not the certificate file's path is validated when the session is checked out.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool UseCertificatePathValidation { get; set; }
Public Property UseCertificatePathValidation As Boolean
    Get
    Set
public:
property bool UseCertificatePathValidation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

NetworkSessionValidation Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation Methods

NetworkSessionValidation Methods
This API is preliminary and subject to change.

The NetworkSessionValidation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates the NetworkSession. (Overrides SystemValidationValidate.)
Top
See Also

Reference

NetworkSessionValidation Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation.Validate Method

NetworkSessionValidationValidate Method
This API is preliminary and subject to change.
Validates the NetworkSession.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool Validate()
Public Overrides Function Validate As Boolean
public:
virtual bool Validate() override

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.
See Also

Reference

NetworkSessionValidation Class
com.softwarekey.Client.Licensing.Network Namespace


NetworkSessionValidation.NetworkSessionTimeValidationType Enumeration

NetworkSessionValidationNetworkSessionTimeValidationType Enumeration
This API is preliminary and subject to change.
The requirement type for system date/time validation.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum NetworkSessionTimeValidationType
Public Enumeration NetworkSessionTimeValidationType
public enum class NetworkSessionTimeValidationType
Members
Member name | Value | Description
None | 0 | No date/time validation is done
WhenAvailable | 1 | Validation is only done when servers can be reached
AlwaysRequired | 2 | Validation is always required -- validation will fail if servers are not reached
See Also

Reference

com.softwarekey.Client.Licensing.Network Namespace


SearchCompletedEventArgs Class

SearchCompletedEventArgs Class
Contains data regarding progress made after completing a through semaphore files.
Inheritance Hierarchy
SystemObject
SystemEventArgs
com.softwarekey.Client.Licensing.NetworkSearchCompletedEventArgs

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class SearchCompletedEventArgs : EventArgs
Public Class SearchCompletedEventArgs
    Inherits EventArgs
public ref class SearchCompletedEventArgs : public EventArgs

The SearchCompletedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SearchCompletedEventArgs | Default SearchCompleteEventArgs constructor
Top
Properties
 | Name | Description
Public property | SeatOpened | Whether or not the search was able to find an open network seat.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This is used in the NetworkSemaphoreSearchCompletedEventHandler delegate, which you may use to handle progress updates (i.e. for showing a progress bar in your application) via the SearchCompleted event.
See Also

Reference

com.softwarekey.Client.Licensing.Network Namespace


SearchCompletedEventArgs Constructor

SearchCompletedEventArgs Constructor
Default SearchCompleteEventArgs constructor

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SearchCompletedEventArgs(
    bool seatOpened
)
Public Sub New (
    seatOpened As Boolean
)
public:
SearchCompletedEventArgs(
    bool seatOpened
)

Parameters

seatOpened
Type: SystemBoolean
Whether or not the search was able to find an open network seat.
See Also

Reference

SearchCompletedEventArgs Class
com.softwarekey.Client.Licensing.Network Namespace


SearchCompletedEventArgs Properties

SearchCompletedEventArgs Properties

The SearchCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SeatOpened | Whether or not the search was able to find an open network seat.
Top
See Also

Reference

SearchCompletedEventArgs Class
com.softwarekey.Client.Licensing.Network Namespace


SearchCompletedEventArgs.SeatOpened Property

SearchCompletedEventArgsSeatOpened Property
Whether or not the search was able to find an open network seat.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool SeatOpened { get; }
Public ReadOnly Property SeatOpened As Boolean
    Get
public:
property bool SeatOpened {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SearchCompletedEventArgs Class
com.softwarekey.Client.Licensing.Network Namespace


SearchCompletedEventArgs Methods

SearchCompletedEventArgs Methods

The SearchCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SearchCompletedEventArgs Class
com.softwarekey.Client.Licensing.Network Namespace


SearchProgressEventArgs Class

SearchProgressEventArgs Class
Contains data regarding progress made while searching for/through semaphore files.
Inheritance Hierarchy
SystemObject
SystemEventArgs
com.softwarekey.Client.Licensing.NetworkSearchProgressEventArgs

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class SearchProgressEventArgs : EventArgs
Public Class SearchProgressEventArgs
    Inherits EventArgs
public ref class SearchProgressEventArgs : public EventArgs

The SearchProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SearchProgressEventArgs | Default SearchProgressEventArgs constructor
Top
Properties
 | Name | Description
Public property | ProgressPercentage | Percent of search progress which has been completed.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This is used in the NetworkSemaphoreSearchProgressEventHandler delegate, which you may use to handle progress updates (i.e. for showing a progress bar in your application) via the SearchProgress event.
See Also

Reference

com.softwarekey.Client.Licensing.Network Namespace


SearchProgressEventArgs Constructor

SearchProgressEventArgs Constructor
Default SearchProgressEventArgs constructor

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SearchProgressEventArgs(
    int progressPercentage
)
Public Sub New (
    progressPercentage As Integer
)
public:
SearchProgressEventArgs(
    int progressPercentage
)

Parameters

progressPercentage
Type: SystemInt32
The percent of search progress which has been completed.
See Also

Reference

SearchProgressEventArgs Class
com.softwarekey.Client.Licensing.Network Namespace


SearchProgressEventArgs Properties

SearchProgressEventArgs Properties

The SearchProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ProgressPercentage | Percent of search progress which has been completed.
Top
See Also

Reference

SearchProgressEventArgs Class
com.softwarekey.Client.Licensing.Network Namespace


SearchProgressEventArgs.ProgressPercentage Property

SearchProgressEventArgsProgressPercentage Property
Percent of search progress which has been completed.

Namespace: com.softwarekey.Client.Licensing.Network
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProgressPercentage { get; }
Public ReadOnly Property ProgressPercentage As Integer
    Get
public:
property int ProgressPercentage {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

SearchProgressEventArgs Class
com.softwarekey.Client.Licensing.Network Namespace


SearchProgressEventArgs Methods

SearchProgressEventArgs Methods

The SearchProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SearchProgressEventArgs Class
com.softwarekey.Client.Licensing.Network Namespace


com.softwarekey.Client.Utils Namespace

com.softwarekey.Client.Utils Namespace
Contains utility classes.
Classes
 | Class | Description
Public class | AuthorEncryptionKey | Class for internal encryption key data storage and use.
Public class | FileLock | Utility class for locking files to the current process.
Public class | InternetConnectionInformation | Tests Internet Connectivity by making a test request.
Public class | IOHelper | Utility class for working with files, directories, and permissions.
Public class | ManualRequestFile | Utility class for creating HTML files to simplify client manual request processing.
Public class | SimpleNetworkTime | Class for performing SNTP queries.
Public class | XmlHelper | Contains common XML manipulation routines.
Enumerations
 | Enumeration | Description
Public enumeration | FileLockFileLockDeleteMode | Enumeration for specifying how and if file deletion is necessary after unlocking the file.
Public enumeration | RegistryViews | Windows registry views (requires .NET 4.0 and later)


AuthorEncryptionKey Class

AuthorEncryptionKey Class
Class for internal encryption key data storage and use.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.UtilsAuthorEncryptionKey

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class AuthorEncryptionKey
Public Class AuthorEncryptionKey
public ref class AuthorEncryptionKey

The AuthorEncryptionKey type exposes the following members.

Constructors
 | Name | Description
Public method | AuthorEncryptionKey(String, String) | Creates a new AuthorEncryptionKey object, initialized with the specified envelope and envelope key data.
Public method | AuthorEncryptionKey(String, String, Boolean) | Creates a new AuthorEncryptionKey object, initialized with the specified envelope and envelope key data.
Top
Properties
 | Name | Description
Public property | EncryptionKeyID | Gets the Encryption Key ID.
Public property | IsEvaluation | Gets whether or not the envelope being used is for an evaluation.
Public property | IsEvaluationExpired | Gets whether or not the envelope being used is for an evaluation which has expired.
Public property | LastError | Gets the last error (represented by a LicenseError object) which occurred in this object.
Top
Methods
 | Name | Description
Public method | Clear | Clears out previous data - THIS WILL MAKE THIS OBJECT INSTANCE UNUSABLE!
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils Namespace


AuthorEncryptionKey Constructor

AuthorEncryptionKey Constructor
Overload List
 | Name | Description
Public method | AuthorEncryptionKey(String, String) | Creates a new AuthorEncryptionKey object, initialized with the specified envelope and envelope key data.
Public method | AuthorEncryptionKey(String, String, Boolean) | Creates a new AuthorEncryptionKey object, initialized with the specified envelope and envelope key data.
Top
See Also

Reference

AuthorEncryptionKey Class
com.softwarekey.Client.Utils Namespace


AuthorEncryptionKey Constructor (String, String)

AuthorEncryptionKey Constructor (String, String)
Creates a new AuthorEncryptionKey object, initialized with the specified envelope and envelope key data.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public AuthorEncryptionKey(
    string envelopeKey,
    string envelope
)
Public Sub New (
    envelopeKey As String,
    envelope As String
)
public:
AuthorEncryptionKey(
    String^ envelopeKey,
    String^ envelope
)

Parameters

envelopeKey
Type: SystemString
The Envelope Key received from SOLO Server.
envelope
Type: SystemString
The Envelope received from SOLO Server.
See Also

Reference

AuthorEncryptionKey Class
AuthorEncryptionKey Overload
com.softwarekey.Client.Utils Namespace


AuthorEncryptionKey Constructor (String, String, Boolean)

AuthorEncryptionKey Constructor (String, String, Boolean)
Creates a new AuthorEncryptionKey object, initialized with the specified envelope and envelope key data.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public AuthorEncryptionKey(
    string envelopeKey,
    string envelope,
    bool useMachineKeyStore
)
Public Sub New (
    envelopeKey As String,
    envelope As String,
    useMachineKeyStore As Boolean
)
public:
AuthorEncryptionKey(
    String^ envelopeKey,
    String^ envelope,
    bool useMachineKeyStore
)

Parameters

envelopeKey
Type: SystemString
The Envelope Key received from SOLO Server.
envelope
Type: SystemString
The Envelope received from SOLO Server.
useMachineKeyStore
Type: SystemBoolean
Default is true; set to false to use the User Key Store instead. The User Key Store is typically best suited for desktop applications, while the machine key store is best suited for services and web applications.
See Also

Reference

AuthorEncryptionKey Class
AuthorEncryptionKey Overload
com.softwarekey.Client.Utils Namespace


AuthorEncryptionKey Properties

AuthorEncryptionKey Properties

The AuthorEncryptionKey type exposes the following members.

Properties
 | Name | Description
Public property | EncryptionKeyID | Gets the Encryption Key ID.
Public property | IsEvaluation | Gets whether or not the envelope being used is for an evaluation.
Public property | IsEvaluationExpired | Gets whether or not the envelope being used is for an evaluation which has expired.
Public property | LastError | Gets the last error (represented by a LicenseError object) which occurred in this object.
Top
See Also

Reference

AuthorEncryptionKey Class
com.softwarekey.Client.Utils Namespace


AuthorEncryptionKey.EncryptionKeyID Property

AuthorEncryptionKeyEncryptionKeyID Property
Gets the Encryption Key ID.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string EncryptionKeyID { get; }
Public ReadOnly Property EncryptionKeyID As String
    Get
public:
property String^ EncryptionKeyID {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AuthorEncryptionKey Class
com.softwarekey.Client.Utils Namespace


AuthorEncryptionKey.IsEvaluation Property

AuthorEncryptionKeyIsEvaluation Property
Gets whether or not the envelope being used is for an evaluation.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool IsEvaluation { get; }
Public ReadOnly Property IsEvaluation As Boolean
    Get
public:
property bool IsEvaluation {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AuthorEncryptionKey Class
com.softwarekey.Client.Utils Namespace


AuthorEncryptionKey.IsEvaluationExpired Property

AuthorEncryptionKeyIsEvaluationExpired Property
Gets whether or not the envelope being used is for an evaluation which has expired.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool IsEvaluationExpired { get; }
Public ReadOnly Property IsEvaluationExpired As Boolean
    Get
public:
property bool IsEvaluationExpired {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AuthorEncryptionKey Class
com.softwarekey.Client.Utils Namespace


AuthorEncryptionKey.LastError Property

AuthorEncryptionKeyLastError Property
Gets the last error (represented by a LicenseError object) which occurred in this object.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public LicenseError LastError { get; }
Public ReadOnly Property LastError As LicenseError
    Get
public:
property LicenseError^ LastError {
    LicenseError^ get ();
}

Property Value

Type: LicenseError
See Also

Reference

AuthorEncryptionKey Class
com.softwarekey.Client.Utils Namespace


AuthorEncryptionKey Methods

AuthorEncryptionKey Methods

The AuthorEncryptionKey type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears out previous data - THIS WILL MAKE THIS OBJECT INSTANCE UNUSABLE!
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AuthorEncryptionKey Class
com.softwarekey.Client.Utils Namespace


AuthorEncryptionKey.Clear Method

AuthorEncryptionKeyClear Method
Clears out previous data - THIS WILL MAKE THIS OBJECT INSTANCE UNUSABLE!

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
See Also

Reference

AuthorEncryptionKey Class
com.softwarekey.Client.Utils Namespace


FileLock Class

FileLock Class
Utility class for locking files to the current process.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.UtilsFileLock

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class FileLock
Public Class FileLock
public ref class FileLock

The FileLock type exposes the following members.

Constructors
 | Name | Description
Public method | FileLock(String) | Creates a new FileLock object.
Public method | FileLock(String, FileLockFileLockDeleteMode) | Creates a new FileLock object.
Public method | FileLock(String, Boolean, FileLockFileLockDeleteMode) | Creates a new FileLock object.
Top
Properties
 | Name | Description
Public property | FilePath | Gets the absolute path to the file which will be locked to this process.
Public property | IsLocked | Gets whether or not the target file is presently locked.
Public property | LastException | Gets the last Exception that occurred (null if none occurred).
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Lock | Locks the target file to the process.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Unlock | Unlocks the target file.
Top
See Also

Reference

com.softwarekey.Client.Utils Namespace


FileLock Constructor

FileLock Constructor
Overload List
 | Name | Description
Public method | FileLock(String) | Creates a new FileLock object.
Public method | FileLock(String, FileLockFileLockDeleteMode) | Creates a new FileLock object.
Public method | FileLock(String, Boolean, FileLockFileLockDeleteMode) | Creates a new FileLock object.
Top
See Also

Reference

FileLock Class
com.softwarekey.Client.Utils Namespace


FileLock Constructor (String)

FileLock Constructor (String)
Creates a new FileLock object.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public FileLock(
    string filePath
)
Public Sub New (
    filePath As String
)
public:
FileLock(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The absolute path to the file which will be locked to this process.
See Also

Reference

FileLock Class
FileLock Overload
com.softwarekey.Client.Utils Namespace


FileLock Constructor (String, FileLock.FileLockDeleteMode)

FileLock Constructor (String, FileLockFileLockDeleteMode)
Creates a new FileLock object.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public FileLock(
    string filePath,
    FileLockFileLockDeleteMode deleteMode
)
Public Sub New (
    filePath As String,
    deleteMode As FileLockFileLockDeleteMode
)
public:
FileLock(
    String^ filePath,
    FileLockFileLockDeleteMode deleteMode
)

Parameters

filePath
Type: SystemString
The absolute path to the file which will be locked to this process.
deleteMode
Type: com.softwarekey.Client.UtilsFileLockFileLockDeleteMode
How and if file deletion is necessary after unlocking the file (FileLockDeleteMode.Never is the default).
See Also

Reference

FileLock Class
FileLock Overload
com.softwarekey.Client.Utils Namespace


FileLock Constructor (String, Boolean, FileLock.FileLockDeleteMode)

FileLock Constructor (String, Boolean, FileLockFileLockDeleteMode)
Creates a new FileLock object.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public FileLock(
    string filePath,
    bool createMissing,
    FileLockFileLockDeleteMode deleteMode
)
Public Sub New (
    filePath As String,
    createMissing As Boolean,
    deleteMode As FileLockFileLockDeleteMode
)
public:
FileLock(
    String^ filePath,
    bool createMissing,
    FileLockFileLockDeleteMode deleteMode
)

Parameters

filePath
Type: SystemString
The absolute path to the file which will be locked to this process.
createMissing
Type: SystemBoolean
Whether or not to create the file if it is missing. Creation occurs when attempting to lock the file with the Lock method.
deleteMode
Type: com.softwarekey.Client.UtilsFileLockFileLockDeleteMode
How and if file deletion is necessary after unlocking the file (FileLockDeleteMode.Never is the default).
See Also

Reference

FileLock Class
FileLock Overload
com.softwarekey.Client.Utils Namespace


FileLock Properties

FileLock Properties

The FileLock type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | Gets the absolute path to the file which will be locked to this process.
Public property | IsLocked | Gets whether or not the target file is presently locked.
Public property | LastException | Gets the last Exception that occurred (null if none occurred).
Top
See Also

Reference

FileLock Class
com.softwarekey.Client.Utils Namespace


FileLock.FilePath Property

FileLockFilePath Property
Gets the absolute path to the file which will be locked to this process.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get
public:
property String^ FilePath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

FileLock Class
com.softwarekey.Client.Utils Namespace


FileLock.IsLocked Property

FileLockIsLocked Property
Gets whether or not the target file is presently locked.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get
public:
property bool IsLocked {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FileLock Class
com.softwarekey.Client.Utils Namespace


FileLock.LastException Property

FileLockLastException Property
Gets the last Exception that occurred (null if none occurred).

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Exception LastException { get; }
Public ReadOnly Property LastException As Exception
    Get
public:
property Exception^ LastException {
    Exception^ get ();
}

Property Value

Type: Exception
See Also

Reference

FileLock Class
com.softwarekey.Client.Utils Namespace


FileLock Methods

FileLock Methods

The FileLock type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Lock | Locks the target file to the process.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Unlock | Unlocks the target file.
Top
See Also

Reference

FileLock Class
com.softwarekey.Client.Utils Namespace


FileLock.Lock Method

FileLockLock Method
Locks the target file to the process.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool Lock()
Public Function Lock As Boolean
public:
bool Lock()

Return Value

Type: Boolean
Returns true if successful. If false is returned, refer to the LastException property for details.
See Also

Reference

FileLock Class
com.softwarekey.Client.Utils Namespace


FileLock.Unlock Method

FileLockUnlock Method
Unlocks the target file.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool Unlock()
Public Function Unlock As Boolean
public:
bool Unlock()

Return Value

Type: Boolean
Returns true if successful. If false is returned, refer to the LastException property for details.
See Also

Reference

FileLock Class
com.softwarekey.Client.Utils Namespace


FileLock.FileLockDeleteMode Enumeration

FileLockFileLockDeleteMode Enumeration
Enumeration for specifying how and if file deletion is necessary after unlocking the file.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum FileLockDeleteMode
Public Enumeration FileLockDeleteMode
public enum class FileLockDeleteMode
Members
Member name | Value | Description
Never | 0 | Never delete the file after unlocking it
WhenPossible | 1 | Only delete the file after unlocking it when possible
AlwaysRequired | 2 | Always require deletion of the file when unlocking it
See Also

Reference

com.softwarekey.Client.Utils Namespace


InternetConnectionInformation Class

InternetConnectionInformation Class
Tests Internet Connectivity by making a test request.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.UtilsInternetConnectionInformation

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class InternetConnectionInformation
Public Class InternetConnectionInformation
public ref class InternetConnectionInformation

The InternetConnectionInformation type exposes the following members.

Constructors
 | Name | Description
Public method | InternetConnectionInformation | Creates a new InternetConnectionInformation object.
Public method | InternetConnectionInformation(String) | Creates a new InternetConnectionInformation object with a specified test URL.
Public method | InternetConnectionInformation(String, Int32) | Creates a new InternetConnectionInformation object with a specified test URL and timeout.
Public method | InternetConnectionInformation(String, Int32, IWebProxy) | Creates a new InternetConnectionInformation object with a specified test URL, timeout, and proxy.
Top
Properties
 | Name | Description
Public property | IsConnected | Gets whether or not an Internet connection is present. Note that this will always be true when ProxyAuthenticationRequired is true (meaning connectivity to a specific server is not verified when proxy authentication is required).
Public property | Proxy | Gets the WebProxy object.
Public property | ProxyAddress | Gets the proxy server address (or an empty string if none is used).
Public property | ProxyAuthenticationRequired | Gets whether or not authentication is required by the proxy server configured for the system.
Public property | ProxyRequired | Gets whether or not this system is configured to use a proxy server.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RunTestRequest | Runs a test HTTP request.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils Namespace


InternetConnectionInformation Constructor

InternetConnectionInformation Constructor
Overload List
 | Name | Description
Public method | InternetConnectionInformation | Creates a new InternetConnectionInformation object.
Public method | InternetConnectionInformation(String) | Creates a new InternetConnectionInformation object with a specified test URL.
Public method | InternetConnectionInformation(String, Int32) | Creates a new InternetConnectionInformation object with a specified test URL and timeout.
Public method | InternetConnectionInformation(String, Int32, IWebProxy) | Creates a new InternetConnectionInformation object with a specified test URL, timeout, and proxy.
Top
See Also

Reference

InternetConnectionInformation Class
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation Constructor

InternetConnectionInformation Constructor
Creates a new InternetConnectionInformation object.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public InternetConnectionInformation()
Public Sub New
public:
InternetConnectionInformation()
See Also

Reference

InternetConnectionInformation Class
InternetConnectionInformation Overload
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation Constructor (String)

InternetConnectionInformation Constructor (String)
Creates a new InternetConnectionInformation object with a specified test URL.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public InternetConnectionInformation(
    string testUrl
)
Public Sub New (
    testUrl As String
)
public:
InternetConnectionInformation(
    String^ testUrl
)

Parameters

testUrl
Type: SystemString
A URL to use when testing whether or not proxy authentication is required.
See Also

Reference

InternetConnectionInformation Class
InternetConnectionInformation Overload
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation Constructor (String, Int32)

InternetConnectionInformation Constructor (String, Int32)
Creates a new InternetConnectionInformation object with a specified test URL and timeout.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public InternetConnectionInformation(
    string testUrl,
    int testTimeout
)
Public Sub New (
    testUrl As String,
    testTimeout As Integer
)
public:
InternetConnectionInformation(
    String^ testUrl,
    int testTimeout
)

Parameters

testUrl
Type: SystemString
A URL to use when testing whether or not proxy authentication is required.
testTimeout
Type: SystemInt32
The timeout (in milliseconds) for the test. The default is 10000 milliseconds (or 10 seconds).
See Also

Reference

InternetConnectionInformation Class
InternetConnectionInformation Overload
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation Constructor (String, Int32, IWebProxy)

InternetConnectionInformation Constructor (String, Int32, IWebProxy)
Creates a new InternetConnectionInformation object with a specified test URL, timeout, and proxy.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public InternetConnectionInformation(
    string testUrl,
    int testTimeout,
    IWebProxy proxy
)
Public Sub New (
    testUrl As String,
    testTimeout As Integer,
    proxy As IWebProxy
)
public:
InternetConnectionInformation(
    String^ testUrl,
    int testTimeout,
    IWebProxy^ proxy
)

Parameters

testUrl
Type: SystemString
A URL to use when testing whether or not proxy authentication is required.
testTimeout
Type: SystemInt32
The timeout (in milliseconds) for the test. The default is 10000 milliseconds (or 10 seconds).
proxy
Type: System.NetIWebProxy
The proxy server to use during the connection test. Leave this as null to use the default system proxy (or no proxy, if no default is configured on the system).
See Also

Reference

InternetConnectionInformation Class
InternetConnectionInformation Overload
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation Properties

InternetConnectionInformation Properties

The InternetConnectionInformation type exposes the following members.

Properties
 | Name | Description
Public property | IsConnected | Gets whether or not an Internet connection is present. Note that this will always be true when ProxyAuthenticationRequired is true (meaning connectivity to a specific server is not verified when proxy authentication is required).
Public property | Proxy | Gets the WebProxy object.
Public property | ProxyAddress | Gets the proxy server address (or an empty string if none is used).
Public property | ProxyAuthenticationRequired | Gets whether or not authentication is required by the proxy server configured for the system.
Public property | ProxyRequired | Gets whether or not this system is configured to use a proxy server.
Top
See Also

Reference

InternetConnectionInformation Class
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation.IsConnected Property

InternetConnectionInformationIsConnected Property
Gets whether or not an Internet connection is present. Note that this will always be true when ProxyAuthenticationRequired is true (meaning connectivity to a specific server is not verified when proxy authentication is required).

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool IsConnected { get; }
Public ReadOnly Property IsConnected As Boolean
    Get
public:
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

InternetConnectionInformation Class
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation.Proxy Property

InternetConnectionInformationProxy Property
Gets the WebProxy object.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public IWebProxy Proxy { get; }
Public ReadOnly Property Proxy As IWebProxy
    Get
public:
property IWebProxy^ Proxy {
    IWebProxy^ get ();
}

Property Value

Type: IWebProxy
See Also

Reference

InternetConnectionInformation Class
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation.ProxyAddress Property

InternetConnectionInformationProxyAddress Property
Gets the proxy server address (or an empty string if none is used).

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProxyAddress { get; }
Public ReadOnly Property ProxyAddress As String
    Get
public:
property String^ ProxyAddress {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InternetConnectionInformation Class
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation.ProxyAuthenticationRequired Property

InternetConnectionInformationProxyAuthenticationRequired Property
Gets whether or not authentication is required by the proxy server configured for the system.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool ProxyAuthenticationRequired { get; }
Public ReadOnly Property ProxyAuthenticationRequired As Boolean
    Get
public:
property bool ProxyAuthenticationRequired {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

InternetConnectionInformation Class
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation.ProxyRequired Property

InternetConnectionInformationProxyRequired Property
Gets whether or not this system is configured to use a proxy server.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool ProxyRequired { get; }
Public ReadOnly Property ProxyRequired As Boolean
    Get
public:
property bool ProxyRequired {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

InternetConnectionInformation Class
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation Methods

InternetConnectionInformation Methods

The InternetConnectionInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RunTestRequest | Runs a test HTTP request.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

InternetConnectionInformation Class
com.softwarekey.Client.Utils Namespace


InternetConnectionInformation.RunTestRequest Method

InternetConnectionInformationRunTestRequest Method
Runs a test HTTP request.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool RunTestRequest()
Public Function RunTestRequest As Boolean
public:
bool RunTestRequest()

Return Value

Type: Boolean
Returns true and sets IsConnected to true if the test request was successful, or returns false and sets IsConnected if it failed. If the request fails because proxy authentication is required, ProxyAuthenticationRequired is set to true.
See Also

Reference

InternetConnectionInformation Class
com.softwarekey.Client.Utils Namespace


IOHelper Class

IOHelper Class
Utility class for working with files, directories, and permissions.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.UtilsIOHelper

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class IOHelper
Public Class IOHelper
public ref class IOHelper

The IOHelper type exposes the following members.

Constructors
 | Name | Description
Public method | IOHelper | Initializes a new instance of the IOHelper class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
 | FilePathIsRemote | Evaluates a path to determine whether it is at a network/remote location.
Protected method | Finalize | (Inherited from Object.)
 | GetAssemblyFileVersion | Gets an Assembly object's file version in the format required by SOLO Server.
 | GetEveryoneAccountNameString | Uses WellKnownSidType.WorldSid to get the "Everyone" account name
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | GrantControlToWorld | Attempts to grant all users full control of the specified file.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
 | ToUncPath | Converts a path containing a mapped drive to a UNC-formatted path.
Top
See Also

Reference

com.softwarekey.Client.Utils Namespace


IOHelper Constructor

IOHelper Constructor
Initializes a new instance of the IOHelper class

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public IOHelper()
Public Sub New
public:
IOHelper()
See Also

Reference

IOHelper Class
com.softwarekey.Client.Utils Namespace


IOHelper Methods

IOHelper Methods

The IOHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
 | FilePathIsRemote | Evaluates a path to determine whether it is at a network/remote location.
Protected method | Finalize | (Inherited from Object.)
 | GetAssemblyFileVersion | Gets an Assembly object's file version in the format required by SOLO Server.
 | GetEveryoneAccountNameString | Uses WellKnownSidType.WorldSid to get the "Everyone" account name
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | GrantControlToWorld | Attempts to grant all users full control of the specified file.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
 | ToUncPath | Converts a path containing a mapped drive to a UNC-formatted path.
Top
See Also

Reference

IOHelper Class
com.softwarekey.Client.Utils Namespace


IOHelper.FilePathIsRemote Method

IOHelperFilePathIsRemote Method
Evaluates a path to determine whether it is at a network/remote location.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static bool FilePathIsRemote(
    string path
)
Public Shared Function FilePathIsRemote (
    path As String
) As Boolean
public:
static bool FilePathIsRemote(
    String^ path
)

Parameters

path
Type: SystemString
The path to evaluate.

Return Value

Type: Boolean
Returns true if the path given resides on a network resource, or false if it is on the local system/device.
Exceptions
Exception | Condition
ArgumentException |
ArgumentNullException |
DriveNotFoundException |
PlatformNotSupportedException |
Remarks
Caution note Caution

This function is presently only supported in Windows desktop operating systems. Attempting to call it from any other will throw a PlatformNotSupportedException.

Note Note

When a valid path which includes a drive letter is given, this function will return true if it is a mapped network drive. When a UNC path is specified, this function always assumes it is a network/remote path (even if said path is hosted by the local device/system).

See Also

Reference

IOHelper Class
com.softwarekey.Client.Utils Namespace


IOHelper.GetAssemblyFileVersion Method

IOHelperGetAssemblyFileVersion Method
Gets an Assembly object's file version in the format required by SOLO Server.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static string GetAssemblyFileVersion(
    Assembly assembly
)
Public Shared Function GetAssemblyFileVersion (
    assembly As Assembly
) As String
public:
static String^ GetAssemblyFileVersion(
    Assembly^ assembly
)

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly from which the file version number will be retrieved.

Return Value

Type: String
Returns a string containing the assembly's file version number, or an empty string if the version could not be found, parsed, or is in a format not compatible with SOLO Server's required format (X.X.X.X, where X is an integer value between 0 and 99999).
See Also

Reference

IOHelper Class
com.softwarekey.Client.Utils Namespace


IOHelper.GetEveryoneAccountNameString Method

IOHelperGetEveryoneAccountNameString Method
Uses WellKnownSidType.WorldSid to get the "Everyone" account name

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static string GetEveryoneAccountNameString()
Public Shared Function GetEveryoneAccountNameString As String
public:
static String^ GetEveryoneAccountNameString()

Return Value

Type: String
The "everyone" account name is returned. This may vary depending on the system's regional settings.
See Also

Reference

IOHelper Class
com.softwarekey.Client.Utils Namespace


IOHelper.GrantControlToWorld Method

IOHelperGrantControlToWorld Method
Attempts to grant all users full control of the specified file.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static void GrantControlToWorld(
    string path
)
Public Shared Sub GrantControlToWorld (
    path As String
)
public:
static void GrantControlToWorld(
    String^ path
)

Parameters

path
Type: SystemString
The absolute path to the file on which this method will attempt to alter permissions.
See Also

Reference

IOHelper Class
com.softwarekey.Client.Utils Namespace


IOHelper.ToUncPath Method

IOHelperToUncPath Method
Converts a path containing a mapped drive to a UNC-formatted path.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static string ToUncPath(
    string path
)
Public Shared Function ToUncPath (
    path As String
) As String
public:
static String^ ToUncPath(
    String^ path
)

Parameters

path
Type: SystemString
The absolute path to a network location (i.e. a location on a mapped drive).

Return Value

Type: String
Returns the UNC-formatted path to the network location.
See Also

Reference

IOHelper Class
com.softwarekey.Client.Utils Namespace


ManualRequestFile Class

ManualRequestFile Class
Utility class for creating HTML files to simplify client manual request processing.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.UtilsManualRequestFile

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ManualRequestFile
Public Class ManualRequestFile
public ref class ManualRequestFile

The ManualRequestFile type exposes the following members.

Constructors
 | Name | Description
Public method | ManualRequestFile | Creates a new ManualRequestFile object.
Top
Properties
 | Name | Description
Protected property | FormMarkup | The markup for the form which is to be posted. Make sure all other relevant properties are set before referencing this property. Override this method if it is necessary to apply non-aesthetic customizations of the form (not common or recommended).
Public property | MarkupBottom | Gets or sets the markup after the form. You may set or override this to implement a custom design.
Public property | MarkupTop | Gets or sets the markup prior to the form. You may set or override this to implement a custom design.
Public property | RequestData | Gets or sets the Request Data. (This should already be encrypted and signed.)
Public property | RequestFilePath | Gets or sets the absolute path where the request file should be saved.
Public property | RequestFormUrl | Gets or sets the URL used in the request form, where data will be posted to in order to obtain the response document. Set or override this if you are using the Instant SOLO Server Dedicated URL option or purchased SOLO Server.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save | Saves the request file to the specified path.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils Namespace


ManualRequestFile Constructor

ManualRequestFile Constructor
Creates a new ManualRequestFile object.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ManualRequestFile(
    string requestData,
    string requestFilePath
)
Public Sub New (
    requestData As String,
    requestFilePath As String
)
public:
ManualRequestFile(
    String^ requestData,
    String^ requestFilePath
)

Parameters

requestData
Type: SystemString
The manual request XML data.
requestFilePath
Type: SystemString
The path to save the manual request file.
See Also

Reference

ManualRequestFile Class
com.softwarekey.Client.Utils Namespace


ManualRequestFile Properties

ManualRequestFile Properties

The ManualRequestFile type exposes the following members.

Properties
 | Name | Description
Protected property | FormMarkup | The markup for the form which is to be posted. Make sure all other relevant properties are set before referencing this property. Override this method if it is necessary to apply non-aesthetic customizations of the form (not common or recommended).
Public property | MarkupBottom | Gets or sets the markup after the form. You may set or override this to implement a custom design.
Public property | MarkupTop | Gets or sets the markup prior to the form. You may set or override this to implement a custom design.
Public property | RequestData | Gets or sets the Request Data. (This should already be encrypted and signed.)
Public property | RequestFilePath | Gets or sets the absolute path where the request file should be saved.
Public property | RequestFormUrl | Gets or sets the URL used in the request form, where data will be posted to in order to obtain the response document. Set or override this if you are using the Instant SOLO Server Dedicated URL option or purchased SOLO Server.
Top
See Also

Reference

ManualRequestFile Class
com.softwarekey.Client.Utils Namespace


ManualRequestFile.FormMarkup Property

ManualRequestFileFormMarkup Property
The markup for the form which is to be posted. Make sure all other relevant properties are set before referencing this property. Override this method if it is necessary to apply non-aesthetic customizations of the form (not common or recommended).

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected virtual string FormMarkup { get; }
Protected Overridable ReadOnly Property FormMarkup As String
    Get
protected:
virtual property String^ FormMarkup {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ManualRequestFile Class
com.softwarekey.Client.Utils Namespace


ManualRequestFile.MarkupBottom Property

ManualRequestFileMarkupBottom Property
Gets or sets the markup after the form. You may set or override this to implement a custom design.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string MarkupBottom { get; set; }
Public Overridable Property MarkupBottom As String
    Get
    Set
public:
virtual property String^ MarkupBottom {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ManualRequestFile Class
com.softwarekey.Client.Utils Namespace


ManualRequestFile.MarkupTop Property

ManualRequestFileMarkupTop Property
Gets or sets the markup prior to the form. You may set or override this to implement a custom design.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string MarkupTop { get; set; }
Public Overridable Property MarkupTop As String
    Get
    Set
public:
virtual property String^ MarkupTop {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ManualRequestFile Class
com.softwarekey.Client.Utils Namespace


ManualRequestFile.RequestData Property

ManualRequestFileRequestData Property
Gets or sets the Request Data. (This should already be encrypted and signed.)

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string RequestData { get; set; }
Public Property RequestData As String
    Get
    Set
public:
property String^ RequestData {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ManualRequestFile Class
com.softwarekey.Client.Utils Namespace


ManualRequestFile.RequestFilePath Property

ManualRequestFileRequestFilePath Property
Gets or sets the absolute path where the request file should be saved.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string RequestFilePath { get; set; }
Public Property RequestFilePath As String
    Get
    Set
public:
property String^ RequestFilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ManualRequestFile Class
com.softwarekey.Client.Utils Namespace


ManualRequestFile.RequestFormUrl Property

ManualRequestFileRequestFormUrl Property
Gets or sets the URL used in the request form, where data will be posted to in order to obtain the response document. Set or override this if you are using the Instant SOLO Server Dedicated URL option or purchased SOLO Server.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string RequestFormUrl { get; set; }
Public Overridable Property RequestFormUrl As String
    Get
    Set
public:
virtual property String^ RequestFormUrl {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ManualRequestFile Class
com.softwarekey.Client.Utils Namespace


ManualRequestFile Methods

ManualRequestFile Methods

The ManualRequestFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save | Saves the request file to the specified path.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ManualRequestFile Class
com.softwarekey.Client.Utils Namespace


ManualRequestFile.Save Method

ManualRequestFileSave Method
Saves the request file to the specified path.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void Save()
Public Sub Save
public:
void Save()
Remarks
See the File.WriteAllText documentation for a list of exceptions which may be thrown.
See Also

Reference

ManualRequestFile Class
com.softwarekey.Client.Utils Namespace


RegistryViews Enumeration

RegistryViews Enumeration
Windows registry views (requires .NET 4.0 and later)

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum RegistryViews
Public Enumeration RegistryViews
public enum class RegistryViews
Members
Member name | Value | Description
DefaultView | 0 | The default registry view. If your code is running as a 32 bit program, then it will use 32 bit registry locations. If your code is running as a 64 bit program, then it will use 64 bit registry locations.
Use32BitView | 1 | Force the use of the 32 bit registry view (requires the application to target .NET 4.0 Framework or later). This can be used to force a 64 bit application to use 32 bit registry locations.
Use64BitView | 2 | Force the use of the 64 bit registry view (requires the application to target .NET 4.0 Framework or later, and a 64 bit Windows). This can be used to force a 32 bit application to use 64 bit registry locations.
See Also

Reference

com.softwarekey.Client.Utils Namespace


SimpleNetworkTime Class

SimpleNetworkTime Class
Class for performing SNTP queries.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.UtilsSimpleNetworkTime

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class SimpleNetworkTime
Public Class SimpleNetworkTime
public ref class SimpleNetworkTime

The SimpleNetworkTime type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleNetworkTime | Initializes a new instance of the SimpleNetworkTime class
Top
Properties
 | Name | Description
Public property | Host | Gets or sets the NTP host address.
Public property | Port | Gets or sets the NTP host port.
Public property | ReceiveTimeout | Gets or sets the time (in milliseconds) until a synchronous attempt to receive data times out.
Public property | SendTimeout | Gets or sets the time (in milliseconds) until a synchronous attempt to send data times out.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNetworkTime | Gets the current time from an NTP server.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Caution note Caution

This allows you to verify a system's time has not be altered by comparing it to the time on a specified Internet time server. Sometimes, the availability of time servers may be somewhat unreliable (which is why this class allows you to specify multiple servers as fallbacks), and it is common for SNTP requests to be blocked by firewalls and proxy servers.

Additionally, although it is technically possible to perform SNTP requests against public NTP servers in your application, we strongly recommend you get approval from the time server's administrators/owners first (as this could cause unexpected load on their time servers, which could cause problems for you and everyone else who might rely on them).

See Also

Reference

com.softwarekey.Client.Utils Namespace


SimpleNetworkTime Constructor

SimpleNetworkTime Constructor
Initializes a new instance of the SimpleNetworkTime class

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SimpleNetworkTime()
Public Sub New
public:
SimpleNetworkTime()
See Also

Reference

SimpleNetworkTime Class
com.softwarekey.Client.Utils Namespace


SimpleNetworkTime Properties

SimpleNetworkTime Properties

The SimpleNetworkTime type exposes the following members.

Properties
 | Name | Description
Public property | Host | Gets or sets the NTP host address.
Public property | Port | Gets or sets the NTP host port.
Public property | ReceiveTimeout | Gets or sets the time (in milliseconds) until a synchronous attempt to receive data times out.
Public property | SendTimeout | Gets or sets the time (in milliseconds) until a synchronous attempt to send data times out.
Top
See Also

Reference

SimpleNetworkTime Class
com.softwarekey.Client.Utils Namespace


SimpleNetworkTime.Host Property

SimpleNetworkTimeHost Property
Gets or sets the NTP host address.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Host { get; set; }
Public Property Host As String
    Get
    Set
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SimpleNetworkTime Class
com.softwarekey.Client.Utils Namespace


SimpleNetworkTime.Port Property

SimpleNetworkTimePort Property
Gets or sets the NTP host port.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SimpleNetworkTime Class
com.softwarekey.Client.Utils Namespace


SimpleNetworkTime.ReceiveTimeout Property

SimpleNetworkTimeReceiveTimeout Property
Gets or sets the time (in milliseconds) until a synchronous attempt to receive data times out.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ReceiveTimeout { get; set; }
Public Property ReceiveTimeout As Integer
    Get
    Set
public:
property int ReceiveTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SimpleNetworkTime Class
com.softwarekey.Client.Utils Namespace


SimpleNetworkTime.SendTimeout Property

SimpleNetworkTimeSendTimeout Property
Gets or sets the time (in milliseconds) until a synchronous attempt to send data times out.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int SendTimeout { get; set; }
Public Property SendTimeout As Integer
    Get
    Set
public:
property int SendTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SimpleNetworkTime Class
com.softwarekey.Client.Utils Namespace


SimpleNetworkTime Methods

SimpleNetworkTime Methods

The SimpleNetworkTime type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNetworkTime | Gets the current time from an NTP server.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SimpleNetworkTime Class
com.softwarekey.Client.Utils Namespace


SimpleNetworkTime.GetNetworkTime Method

SimpleNetworkTimeGetNetworkTime Method
Gets the current time from an NTP server.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime GetNetworkTime()
Public Function GetNetworkTime As DateTime
public:
DateTime GetNetworkTime()

Return Value

Type: DateTime
Returns the current time from an NTP server.
See Also

Reference

SimpleNetworkTime Class
com.softwarekey.Client.Utils Namespace


XmlHelper Class

XmlHelper Class
Contains common XML manipulation routines.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.UtilsXmlHelper

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static class XmlHelper
Public NotInheritable Class XmlHelper
public ref class XmlHelper abstract sealed

The XmlHelper type exposes the following members.

Methods
Name | Description
AddNewElement(XmlDocument, String, DateTime) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, Decimal) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, Double) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, Int32) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, String) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, XmlElement, String, DateTime) | Adds a new XML element to an XML document's referenced node
AddNewElement(XmlDocument, XmlElement, String, Decimal) | Adds a new XML element to an XML document's referenced node.
AddNewElement(XmlDocument, XmlElement, String, Double) | Adds a new XML element to an XML document's referenced node.
AddNewElement(XmlDocument, XmlElement, String, Int32) | Adds a new XML element to an XML document's referenced node.
AddNewElement(XmlDocument, XmlElement, String, String) | Adds a new XML element to an XML document's referenced node.
CreateDocument | Creates a new, empty XML document.
GetIso8601DateTimeNodeValue | Gets an XML node's ISO-8601 value and stores it to a DateTime variable (converted to local time automatically).
GetNodeValue(XmlNode, String, Boolean) | Gets an XML node's value and stores it to a Boolean variable.
GetNodeValue(XmlNode, String, DateTime) | Gets an XML node's value and stores it to an DateTime variable.
GetNodeValue(XmlNode, String, Decimal) | Gets an XML node's value and stores it to a decimal variable.
GetNodeValue(XmlNode, String, Int32) | Gets an XML node's value and stores it to an Int32 variable.
GetNodeValue(XmlNode, String, String) | Gets an XML node's value and stores it to a string variable.
GetNodeValue(XmlNode, String, String, Boolean) | Gets an XML node's value and stores it to a string variable.
ImportDocument(XmlDocument, XmlDocument) | Imports an xml document as a child element of the document element
ImportDocument(XmlDocument, XmlElement, XmlDocument) | Imports an xml document as a child element of the specified element
Top
See Also

Reference

com.softwarekey.Client.Utils Namespace


XmlHelper Methods

XmlHelper Methods

The XmlHelper type exposes the following members.

Methods
Name | Description
AddNewElement(XmlDocument, String, DateTime) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, Decimal) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, Double) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, Int32) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, String) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, XmlElement, String, DateTime) | Adds a new XML element to an XML document's referenced node
AddNewElement(XmlDocument, XmlElement, String, Decimal) | Adds a new XML element to an XML document's referenced node.
AddNewElement(XmlDocument, XmlElement, String, Double) | Adds a new XML element to an XML document's referenced node.
AddNewElement(XmlDocument, XmlElement, String, Int32) | Adds a new XML element to an XML document's referenced node.
AddNewElement(XmlDocument, XmlElement, String, String) | Adds a new XML element to an XML document's referenced node.
CreateDocument | Creates a new, empty XML document.
GetIso8601DateTimeNodeValue | Gets an XML node's ISO-8601 value and stores it to a DateTime variable (converted to local time automatically).
GetNodeValue(XmlNode, String, Boolean) | Gets an XML node's value and stores it to a Boolean variable.
GetNodeValue(XmlNode, String, DateTime) | Gets an XML node's value and stores it to an DateTime variable.
GetNodeValue(XmlNode, String, Decimal) | Gets an XML node's value and stores it to a decimal variable.
GetNodeValue(XmlNode, String, Int32) | Gets an XML node's value and stores it to an Int32 variable.
GetNodeValue(XmlNode, String, String) | Gets an XML node's value and stores it to a string variable.
GetNodeValue(XmlNode, String, String, Boolean) | Gets an XML node's value and stores it to a string variable.
ImportDocument(XmlDocument, XmlDocument) | Imports an xml document as a child element of the document element
ImportDocument(XmlDocument, XmlElement, XmlDocument) | Imports an xml document as a child element of the specified element
Top
See Also

Reference

XmlHelper Class
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method

XmlHelperAddNewElement Method
Overload List
Name | Description
AddNewElement(XmlDocument, String, DateTime) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, Decimal) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, Double) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, Int32) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, String, String) | Adds a new XML element to an XML document.
AddNewElement(XmlDocument, XmlElement, String, DateTime) | Adds a new XML element to an XML document's referenced node
AddNewElement(XmlDocument, XmlElement, String, Decimal) | Adds a new XML element to an XML document's referenced node.
AddNewElement(XmlDocument, XmlElement, String, Double) | Adds a new XML element to an XML document's referenced node.
AddNewElement(XmlDocument, XmlElement, String, Int32) | Adds a new XML element to an XML document's referenced node.
AddNewElement(XmlDocument, XmlElement, String, String) | Adds a new XML element to an XML document's referenced node.
Top
See Also

Reference

XmlHelper Class
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method (XmlDocument, String, DateTime)

XmlHelperAddNewElement Method (XmlDocument, String, DateTime)
Adds a new XML element to an XML document.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlElement AddNewElement(
    ref XmlDocument xml,
    string tagName,
    DateTime value
)
Public Shared Function AddNewElement (
    ByRef xml As XmlDocument,
    tagName As String,
    value As DateTime
) As XmlElement
public:
static XmlElement^ AddNewElement(
    XmlDocument^% xml,
    String^ tagName,
    DateTime value
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument to which the element will be added.
tagName
Type: SystemString
The tag name of the element which will be added.
value
Type: SystemDateTime
The DateTime value in the element which will be added.

Return Value

Type: XmlElement
Returns a reference to the newly created XmlElement.
Remarks
ISO-8601 formatting is used when storing the DateTime value in the XML element.
See Also

Reference

XmlHelper Class
AddNewElement Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method (XmlDocument, String, Decimal)

XmlHelperAddNewElement Method (XmlDocument, String, Decimal)
Adds a new XML element to an XML document.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlElement AddNewElement(
    ref XmlDocument xml,
    string tagName,
    decimal value
)
Public Shared Function AddNewElement (
    ByRef xml As XmlDocument,
    tagName As String,
    value As Decimal
) As XmlElement
public:
static XmlElement^ AddNewElement(
    XmlDocument^% xml,
    String^ tagName,
    Decimal value
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument to which the element will be added.
tagName
Type: SystemString
The tag name of the element which will be added.
value
Type: SystemDecimal
The decimal value in the element which will be added.

Return Value

Type: XmlElement
Returns a reference to the newly created XmlElement.
See Also

Reference

XmlHelper Class
AddNewElement Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method (XmlDocument, String, Double)

XmlHelperAddNewElement Method (XmlDocument, String, Double)
Adds a new XML element to an XML document.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlElement AddNewElement(
    ref XmlDocument xml,
    string tagName,
    double value
)
Public Shared Function AddNewElement (
    ByRef xml As XmlDocument,
    tagName As String,
    value As Double
) As XmlElement
public:
static XmlElement^ AddNewElement(
    XmlDocument^% xml,
    String^ tagName,
    double value
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument to which the element will be added.
tagName
Type: SystemString
The tag name of the element which will be added.
value
Type: SystemDouble
The double value in the element which will be added.

Return Value

Type: XmlElement
Returns a reference to the newly created XmlElement.
See Also

Reference

XmlHelper Class
AddNewElement Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method (XmlDocument, String, Int32)

XmlHelperAddNewElement Method (XmlDocument, String, Int32)
Adds a new XML element to an XML document.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlElement AddNewElement(
    ref XmlDocument xml,
    string tagName,
    int value
)
Public Shared Function AddNewElement (
    ByRef xml As XmlDocument,
    tagName As String,
    value As Integer
) As XmlElement
public:
static XmlElement^ AddNewElement(
    XmlDocument^% xml,
    String^ tagName,
    int value
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument to which the element will be added.
tagName
Type: SystemString
The tag name of the element which will be added.
value
Type: SystemInt32
The integer value in the element which will be added.

Return Value

Type: XmlElement
Returns a reference to the newly created XmlElement.
See Also

Reference

XmlHelper Class
AddNewElement Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method (XmlDocument, String, String)

XmlHelperAddNewElement Method (XmlDocument, String, String)
Adds a new XML element to an XML document.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlElement AddNewElement(
    ref XmlDocument xml,
    string tagName,
    string value
)
Public Shared Function AddNewElement (
    ByRef xml As XmlDocument,
    tagName As String,
    value As String
) As XmlElement
public:
static XmlElement^ AddNewElement(
    XmlDocument^% xml,
    String^ tagName,
    String^ value
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument to which the element will be added.
tagName
Type: SystemString
The tag name of the element which will be added.
value
Type: SystemString
The value/text in the element which will be added.

Return Value

Type: XmlElement
Returns a reference to the newly created XmlElement.
See Also

Reference

XmlHelper Class
AddNewElement Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method (XmlDocument, XmlElement, String, DateTime)

XmlHelperAddNewElement Method (XmlDocument, XmlElement, String, DateTime)
Adds a new XML element to an XML document's referenced node

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlElement AddNewElement(
    ref XmlDocument xml,
    ref XmlElement element,
    string tagName,
    DateTime value
)
Public Shared Function AddNewElement (
    ByRef xml As XmlDocument,
    ByRef element As XmlElement,
    tagName As String,
    value As DateTime
) As XmlElement
public:
static XmlElement^ AddNewElement(
    XmlDocument^% xml,
    XmlElement^% element,
    String^ tagName,
    DateTime value
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument to which the element will be added.
element
Type: System.XmlXmlElement
The root XmlElement, under which the new element will be added.
tagName
Type: SystemString
The tag name of the element which will be added.
value
Type: SystemDateTime
The new node's DateTime value.

Return Value

Type: XmlElement
Returns a reference to the newly created XmlElement.
See Also

Reference

XmlHelper Class
AddNewElement Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method (XmlDocument, XmlElement, String, Decimal)

XmlHelperAddNewElement Method (XmlDocument, XmlElement, String, Decimal)
Adds a new XML element to an XML document's referenced node.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlElement AddNewElement(
    ref XmlDocument xml,
    ref XmlElement element,
    string tagName,
    decimal value
)
Public Shared Function AddNewElement (
    ByRef xml As XmlDocument,
    ByRef element As XmlElement,
    tagName As String,
    value As Decimal
) As XmlElement
public:
static XmlElement^ AddNewElement(
    XmlDocument^% xml,
    XmlElement^% element,
    String^ tagName,
    Decimal value
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument to which the element will be added.
element
Type: System.XmlXmlElement
The root XmlElement, under which the new element will be added.
tagName
Type: SystemString
The tag name of the element which will be added.
value
Type: SystemDecimal
The new node's decimal value.

Return Value

Type: XmlElement
Returns a reference to the newly created XmlElement.
See Also

Reference

XmlHelper Class
AddNewElement Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method (XmlDocument, XmlElement, String, Double)

XmlHelperAddNewElement Method (XmlDocument, XmlElement, String, Double)
Adds a new XML element to an XML document's referenced node.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlElement AddNewElement(
    ref XmlDocument xml,
    ref XmlElement element,
    string tagName,
    double value
)
Public Shared Function AddNewElement (
    ByRef xml As XmlDocument,
    ByRef element As XmlElement,
    tagName As String,
    value As Double
) As XmlElement
public:
static XmlElement^ AddNewElement(
    XmlDocument^% xml,
    XmlElement^% element,
    String^ tagName,
    double value
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument to which the element will be added.
element
Type: System.XmlXmlElement
The root XmlElement, under which the new element will be added.
tagName
Type: SystemString
The tag name of the element which will be added.
value
Type: SystemDouble
The new node's double value.

Return Value

Type: XmlElement
Returns a reference to the newly created XmlElement.
See Also

Reference

XmlHelper Class
AddNewElement Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method (XmlDocument, XmlElement, String, Int32)

XmlHelperAddNewElement Method (XmlDocument, XmlElement, String, Int32)
Adds a new XML element to an XML document's referenced node.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlElement AddNewElement(
    ref XmlDocument xml,
    ref XmlElement element,
    string tagName,
    int value
)
Public Shared Function AddNewElement (
    ByRef xml As XmlDocument,
    ByRef element As XmlElement,
    tagName As String,
    value As Integer
) As XmlElement
public:
static XmlElement^ AddNewElement(
    XmlDocument^% xml,
    XmlElement^% element,
    String^ tagName,
    int value
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument to which the element will be added.
element
Type: System.XmlXmlElement
The root XmlElement, under which the new element will be added.
tagName
Type: SystemString
The tag name of the element which will be added.
value
Type: SystemInt32
The new element's integer value.

Return Value

Type: XmlElement
Returns a reference to the newly created XmlElement.
See Also

Reference

XmlHelper Class
AddNewElement Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.AddNewElement Method (XmlDocument, XmlElement, String, String)

XmlHelperAddNewElement Method (XmlDocument, XmlElement, String, String)
Adds a new XML element to an XML document's referenced node.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlElement AddNewElement(
    ref XmlDocument xml,
    ref XmlElement element,
    string tagName,
    string value
)
Public Shared Function AddNewElement (
    ByRef xml As XmlDocument,
    ByRef element As XmlElement,
    tagName As String,
    value As String
) As XmlElement
public:
static XmlElement^ AddNewElement(
    XmlDocument^% xml,
    XmlElement^% element,
    String^ tagName,
    String^ value
)

Parameters

xml
Type: System.XmlXmlDocument
The XmlDocument to which the element will be added.
element
Type: System.XmlXmlElement
The root XmlElement, under which the new element will be added.
tagName
Type: SystemString
The tag name of the element which will be added.
value
Type: SystemString
The new node's string value.

Return Value

Type: XmlElement
Returns a reference to the newly created XmlElement.
See Also

Reference

XmlHelper Class
AddNewElement Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.CreateDocument Method

XmlHelperCreateDocument Method
Creates a new, empty XML document.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static XmlDocument CreateDocument(
    string documentElementName
)
Public Shared Function CreateDocument (
    documentElementName As String
) As XmlDocument
public:
static XmlDocument^ CreateDocument(
    String^ documentElementName
)

Parameters

documentElementName
Type: SystemString
The tag name of the document/root element.

Return Value

Type: XmlDocument
Returns a new XmlDocument object containing only the specified document/root element.
See Also

Reference

XmlHelper Class
com.softwarekey.Client.Utils Namespace


XmlHelper.GetIso8601DateTimeNodeValue Method

XmlHelperGetIso8601DateTimeNodeValue Method
Gets an XML node's ISO-8601 value and stores it to a DateTime variable (converted to local time automatically).

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static void GetIso8601DateTimeNodeValue(
    XmlNode xml,
    string xpath,
    ref DateTime value
)
Public Shared Sub GetIso8601DateTimeNodeValue (
    xml As XmlNode,
    xpath As String,
    ByRef value As DateTime
)
public:
static void GetIso8601DateTimeNodeValue(
    XmlNode^ xml,
    String^ xpath,
    DateTime% value
)

Parameters

xml
Type: System.XmlXmlNode
The root XML node.
xpath
Type: SystemString
The XPath of the node to parse.
value
Type: SystemDateTime
The DateTime parsed from the XML node. This will be set to DateTime.MinValue if parsing fails.
See Also

Reference

XmlHelper Class
com.softwarekey.Client.Utils Namespace


XmlHelper.GetNodeValue Method

XmlHelperGetNodeValue Method
Overload List
Name | Description
GetNodeValue(XmlNode, String, Boolean) | Gets an XML node's value and stores it to a Boolean variable.
GetNodeValue(XmlNode, String, DateTime) | Gets an XML node's value and stores it to an DateTime variable.
GetNodeValue(XmlNode, String, Decimal) | Gets an XML node's value and stores it to a decimal variable.
GetNodeValue(XmlNode, String, Int32) | Gets an XML node's value and stores it to an Int32 variable.
GetNodeValue(XmlNode, String, String) | Gets an XML node's value and stores it to a string variable.
GetNodeValue(XmlNode, String, String, Boolean) | Gets an XML node's value and stores it to a string variable.
Top
See Also

Reference

XmlHelper Class
com.softwarekey.Client.Utils Namespace


XmlHelper.GetNodeValue Method (XmlNode, String, Boolean)

XmlHelperGetNodeValue Method (XmlNode, String, Boolean)
Gets an XML node's value and stores it to a Boolean variable.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static void GetNodeValue(
    XmlNode xml,
    string xpath,
    ref bool value
)
Public Shared Sub GetNodeValue (
    xml As XmlNode,
    xpath As String,
    ByRef value As Boolean
)
public:
static void GetNodeValue(
    XmlNode^ xml,
    String^ xpath,
    bool% value
)

Parameters

xml
Type: System.XmlXmlNode
The root XML node.
xpath
Type: SystemString
The XPath of the node to parse.
value
Type: SystemBoolean
The Boolean value parsed from the XML node. This will be set to false if parsing fails.
See Also

Reference

XmlHelper Class
GetNodeValue Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.GetNodeValue Method (XmlNode, String, DateTime)

XmlHelperGetNodeValue Method (XmlNode, String, DateTime)
Gets an XML node's value and stores it to an DateTime variable.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static void GetNodeValue(
    XmlNode xml,
    string xpath,
    ref DateTime value
)
Public Shared Sub GetNodeValue (
    xml As XmlNode,
    xpath As String,
    ByRef value As DateTime
)
public:
static void GetNodeValue(
    XmlNode^ xml,
    String^ xpath,
    DateTime% value
)

Parameters

xml
Type: System.XmlXmlNode
The root XML node.
xpath
Type: SystemString
The XPath of the node to parse.
value
Type: SystemDateTime
The DateTime value parsed from the XML node. This will be set to DateTime.MinValue if parsing fails.
See Also

Reference

XmlHelper Class
GetNodeValue Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.GetNodeValue Method (XmlNode, String, Decimal)

XmlHelperGetNodeValue Method (XmlNode, String, Decimal)
Gets an XML node's value and stores it to a decimal variable.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static void GetNodeValue(
    XmlNode xml,
    string xpath,
    ref decimal value
)
Public Shared Sub GetNodeValue (
    xml As XmlNode,
    xpath As String,
    ByRef value As Decimal
)
public:
static void GetNodeValue(
    XmlNode^ xml,
    String^ xpath,
    Decimal% value
)

Parameters

xml
Type: System.XmlXmlNode
The root XML node.
xpath
Type: SystemString
The XPath of the node to parse.
value
Type: SystemDecimal
The decimal value parsed from the XML node. This will be set to 0 if parsing fails.
See Also

Reference

XmlHelper Class
GetNodeValue Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.GetNodeValue Method (XmlNode, String, Int32)

XmlHelperGetNodeValue Method (XmlNode, String, Int32)
Gets an XML node's value and stores it to an Int32 variable.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static void GetNodeValue(
    XmlNode xml,
    string xpath,
    ref int value
)
Public Shared Sub GetNodeValue (
    xml As XmlNode,
    xpath As String,
    ByRef value As Integer
)
public:
static void GetNodeValue(
    XmlNode^ xml,
    String^ xpath,
    int% value
)

Parameters

xml
Type: System.XmlXmlNode
The root XML node.
xpath
Type: SystemString
The XPath of the node to parse.
value
Type: SystemInt32
The Int32 value parsed from the XML node. This will be set to 0 if parsing fails.
See Also

Reference

XmlHelper Class
GetNodeValue Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.GetNodeValue Method (XmlNode, String, String)

XmlHelperGetNodeValue Method (XmlNode, String, String)
Gets an XML node's value and stores it to a string variable.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static void GetNodeValue(
    XmlNode xml,
    string xpath,
    ref string value
)
Public Shared Sub GetNodeValue (
    xml As XmlNode,
    xpath As String,
    ByRef value As String
)
public:
static void GetNodeValue(
    XmlNode^ xml,
    String^ xpath,
    String^% value
)

Parameters

xml
Type: System.XmlXmlNode
The root XML node.
xpath
Type: SystemString
The XPath of the node to parse.
value
Type: SystemString
The string value parsed from the XML node. This will be set to an empty string ("") if parsing fails.
See Also

Reference

XmlHelper Class
GetNodeValue Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.GetNodeValue Method (XmlNode, String, String, Boolean)

XmlHelperGetNodeValue Method (XmlNode, String, String, Boolean)
Gets an XML node's value and stores it to a string variable.

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static void GetNodeValue(
    XmlNode xml,
    string xpath,
    ref string value,
    bool textOnly
)
Public Shared Sub GetNodeValue (
    xml As XmlNode,
    xpath As String,
    ByRef value As String,
    textOnly As Boolean
)
public:
static void GetNodeValue(
    XmlNode^ xml,
    String^ xpath,
    String^% value,
    bool textOnly
)

Parameters

xml
Type: System.XmlXmlNode
The root XML node.
xpath
Type: SystemString
The XPath of the node to parse.
value
Type: SystemString
The string value parsed from the XML node. This will be set to an empty string ("") if parsing fails.
textOnly
Type: SystemBoolean
When true, only retrieves the InnerText instead of the InnerXml
See Also

Reference

XmlHelper Class
GetNodeValue Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.ImportDocument Method

XmlHelperImportDocument Method
Overload List
Name | Description
ImportDocument(XmlDocument, XmlDocument) | Imports an xml document as a child element of the document element
ImportDocument(XmlDocument, XmlElement, XmlDocument) | Imports an xml document as a child element of the specified element
Top
See Also

Reference

XmlHelper Class
com.softwarekey.Client.Utils Namespace


XmlHelper.ImportDocument Method (XmlDocument, XmlDocument)

XmlHelperImportDocument Method (XmlDocument, XmlDocument)
Imports an xml document as a child element of the document element

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static void ImportDocument(
    ref XmlDocument doc,
    XmlDocument docToImport
)
Public Shared Sub ImportDocument (
    ByRef doc As XmlDocument,
    docToImport As XmlDocument
)
public:
static void ImportDocument(
    XmlDocument^% doc,
    XmlDocument^ docToImport
)

Parameters

doc
Type: System.XmlXmlDocument
The destination XmlDocument object.
docToImport
Type: System.XmlXmlDocument
The source XmlDocument document to import.
See Also

Reference

XmlHelper Class
ImportDocument Overload
com.softwarekey.Client.Utils Namespace


XmlHelper.ImportDocument Method (XmlDocument, XmlElement, XmlDocument)

XmlHelperImportDocument Method (XmlDocument, XmlElement, XmlDocument)
Imports an xml document as a child element of the specified element

Namespace: com.softwarekey.Client.Utils
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static void ImportDocument(
    ref XmlDocument doc,
    ref XmlElement element,
    XmlDocument docToImport
)
Public Shared Sub ImportDocument (
    ByRef doc As XmlDocument,
    ByRef element As XmlElement,
    docToImport As XmlDocument
)
public:
static void ImportDocument(
    XmlDocument^% doc,
    XmlElement^% element,
    XmlDocument^ docToImport
)

Parameters

doc
Type: System.XmlXmlDocument
The destination XmlDocument object.
element
Type: System.XmlXmlElement
The root XmlElement in the destination XmlDocument, under which the source document will be imported.
docToImport
Type: System.XmlXmlDocument
The source XmlDocument document to import.
See Also

Reference

XmlHelper Class
ImportDocument Overload
com.softwarekey.Client.Utils Namespace


com.softwarekey.Client.Utils.SystemComponent Namespace

com.softwarekey.Client.Utils.SystemComponent Namespace
Contains classes used to identify various system/hardware components.
Classes
 | Class | Description
Public class | BIOSInformation | SystemComponent implementation for retrieving information on the system's BIOS.
Public class | CDROMInformation | SystemComponent implementation for retrieving information on the system's CDROM/DVD drives.
Public class | ComputerSystemInformation | SystemComponent implementation for retrieving basic computer system information.
Public class | HardDriveInformation | SystemComponent implementation for retrieving information on the system's hard drives.
Public class | MotherboardInformation | SystemComponent implementation for retrieving information on the system's motherboard.
Public class | NetworkInterfaceInformation | SystemComponent implementation for retrieving information on the system's network adapters.
Public class | OperatingSystemInformation | SystemComponent implementation for retrieving information on the system's operating system
Public class | ProcessorInformation | SystemComponent implementation for retrieving information on the system's processor (CPU)
Public class | SoundCardInformation | SystemComponent implementation for retrieving information on the system's sound cards.
Public class | SystemComponent | Base class from which system component information implementations are derived. This is designed to facilitate retrieving data about a system using Windows Management Instrumentation (WMI) queries.
Public class | SystemComponentInformation | Collection of various SystemComponent objects, each of which contains information about the system.
Public class | SystemComponentProperty | Represents a property as a name/value pair of strings.
Public class | UserAccountInformation | SystemComponent implementation for retrieving information on the system's current user.
Public class | VideoCardInformation | Information on the system's video cards.


BIOSInformation Class

BIOSInformation Class
SystemComponent implementation for retrieving information on the system's BIOS.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentBIOSInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class BIOSInformation : SystemComponent
Public Class BIOSInformation
    Inherits SystemComponent
public ref class BIOSInformation : public SystemComponent

The BIOSInformation type exposes the following members.

Constructors
 | Name | Description
Public method | BIOSInformation | Creates a new BIOSInformation object.
Top
Properties
 | Name | Description
Public property | BIOSVersion | Gets the BIOSVersion property.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | SMBIOSBIOSVersion | Gets the SMBIOSBIOSVersion property.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


BIOSInformation Constructor

BIOSInformation Constructor
Creates a new BIOSInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public BIOSInformation()
Public Sub New
public:
BIOSInformation()
See Also

Reference

BIOSInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


BIOSInformation Properties

BIOSInformation Properties

The BIOSInformation type exposes the following members.

Properties
 | Name | Description
Public property | BIOSVersion | Gets the BIOSVersion property.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | SMBIOSBIOSVersion | Gets the SMBIOSBIOSVersion property.
Top
See Also

Reference

BIOSInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


BIOSInformation.BIOSVersion Property

BIOSInformationBIOSVersion Property
Gets the BIOSVersion property.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string BIOSVersion { get; }
Public ReadOnly Property BIOSVersion As String
    Get
public:
property String^ BIOSVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

BIOSInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


BIOSInformation.SMBIOSBIOSVersion Property

BIOSInformationSMBIOSBIOSVersion Property
Gets the SMBIOSBIOSVersion property.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SMBIOSBIOSVersion { get; }
Public ReadOnly Property SMBIOSBIOSVersion As String
    Get
public:
property String^ SMBIOSBIOSVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

BIOSInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


BIOSInformation Methods

BIOSInformation Methods

The BIOSInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BIOSInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


CDROMInformation Class

CDROMInformation Class
SystemComponent implementation for retrieving information on the system's CDROM/DVD drives.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentCDROMInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class CDROMInformation : SystemComponent
Public Class CDROMInformation
    Inherits SystemComponent
public ref class CDROMInformation : public SystemComponent

The CDROMInformation type exposes the following members.

Constructors
 | Name | Description
Public method | CDROMInformation | Creates a new CDROMInformation object.
Top
Properties
 | Name | Description
Public property | Names | Gets a list of String objects, each containing the name of a CD/DVD drive.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


CDROMInformation Constructor

CDROMInformation Constructor
Creates a new CDROMInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CDROMInformation()
Public Sub New
public:
CDROMInformation()
See Also

Reference

CDROMInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


CDROMInformation Properties

CDROMInformation Properties

The CDROMInformation type exposes the following members.

Properties
 | Name | Description
Public property | Names | Gets a list of String objects, each containing the name of a CD/DVD drive.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Top
See Also

Reference

CDROMInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


CDROMInformation.Names Property

CDROMInformationNames Property
Gets a list of String objects, each containing the name of a CD/DVD drive.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<string> Names { get; }
Public ReadOnly Property Names As List(Of String)
    Get
public:
property List<String^>^ Names {
    List<String^>^ get ();
}

Property Value

Type: List String
See Also

Reference

CDROMInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


CDROMInformation Methods

CDROMInformation Methods

The CDROMInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CDROMInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ComputerSystemInformation Class

ComputerSystemInformation Class
SystemComponent implementation for retrieving basic computer system information.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentComputerSystemInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ComputerSystemInformation : SystemComponent
Public Class ComputerSystemInformation
    Inherits SystemComponent
public ref class ComputerSystemInformation : public SystemComponent

The ComputerSystemInformation type exposes the following members.

Constructors
 | Name | Description
Public method | ComputerSystemInformation | Creates a new ComputerSystemInformation object.
Top
Properties
 | Name | Description
Public property | ComputerName | Gets the computer's name.
Public property | Domain | Gets the computer's domain.
Public property | Manufacturer | Gets the computer's manufacturer.
Public property | Model | Gets the computer's model.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | TotalPhysicalMemory | Gets the computer's total memory.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


ComputerSystemInformation Constructor

ComputerSystemInformation Constructor
Creates a new ComputerSystemInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ComputerSystemInformation()
Public Sub New
public:
ComputerSystemInformation()
See Also

Reference

ComputerSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ComputerSystemInformation Properties

ComputerSystemInformation Properties

The ComputerSystemInformation type exposes the following members.

Properties
 | Name | Description
Public property | ComputerName | Gets the computer's name.
Public property | Domain | Gets the computer's domain.
Public property | Manufacturer | Gets the computer's manufacturer.
Public property | Model | Gets the computer's model.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | TotalPhysicalMemory | Gets the computer's total memory.
Top
See Also

Reference

ComputerSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ComputerSystemInformation.ComputerName Property

ComputerSystemInformationComputerName Property
Gets the computer's name.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ComputerName { get; }
Public ReadOnly Property ComputerName As String
    Get
public:
property String^ ComputerName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ComputerSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ComputerSystemInformation.Domain Property

ComputerSystemInformationDomain Property
Gets the computer's domain.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Domain { get; }
Public ReadOnly Property Domain As String
    Get
public:
property String^ Domain {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ComputerSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ComputerSystemInformation.Manufacturer Property

ComputerSystemInformationManufacturer Property
Gets the computer's manufacturer.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Manufacturer { get; }
Public ReadOnly Property Manufacturer As String
    Get
public:
property String^ Manufacturer {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ComputerSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ComputerSystemInformation.Model Property

ComputerSystemInformationModel Property
Gets the computer's model.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Model { get; }
Public ReadOnly Property Model As String
    Get
public:
property String^ Model {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ComputerSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ComputerSystemInformation.TotalPhysicalMemory Property

ComputerSystemInformationTotalPhysicalMemory Property
Gets the computer's total memory.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int TotalPhysicalMemory { get; }
Public ReadOnly Property TotalPhysicalMemory As Integer
    Get
public:
property int TotalPhysicalMemory {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ComputerSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ComputerSystemInformation Methods

ComputerSystemInformation Methods

The ComputerSystemInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ComputerSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


HardDriveInformation Class

HardDriveInformation Class
SystemComponent implementation for retrieving information on the system's hard drives.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentHardDriveInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class HardDriveInformation : SystemComponent
Public Class HardDriveInformation
    Inherits SystemComponent
public ref class HardDriveInformation : public SystemComponent

The HardDriveInformation type exposes the following members.

Constructors
 | Name | Description
Public method | HardDriveInformation | Creates a new HardDriveInformation object.
Top
Properties
 | Name | Description
Public property | Models | Gets a list of hard drive models.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | SerialNumbers | Gets a list of hard drive serial numbers.
Public property | VolumeSerialNumbers | Gets a list of hard drive volume serial numbers.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


HardDriveInformation Constructor

HardDriveInformation Constructor
Creates a new HardDriveInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public HardDriveInformation()
Public Sub New
public:
HardDriveInformation()
See Also

Reference

HardDriveInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


HardDriveInformation Properties

HardDriveInformation Properties

The HardDriveInformation type exposes the following members.

Properties
 | Name | Description
Public property | Models | Gets a list of hard drive models.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | SerialNumbers | Gets a list of hard drive serial numbers.
Public property | VolumeSerialNumbers | Gets a list of hard drive volume serial numbers.
Top
See Also

Reference

HardDriveInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


HardDriveInformation.Models Property

HardDriveInformationModels Property
Gets a list of hard drive models.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<string> Models { get; }
Public ReadOnly Property Models As List(Of String)
    Get
public:
property List<String^>^ Models {
    List<String^>^ get ();
}

Property Value

Type: List String
See Also

Reference

HardDriveInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


HardDriveInformation.SerialNumbers Property

HardDriveInformationSerialNumbers Property
Gets a list of hard drive serial numbers.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<string> SerialNumbers { get; }
Public ReadOnly Property SerialNumbers As List(Of String)
    Get
public:
property List<String^>^ SerialNumbers {
    List<String^>^ get ();
}

Property Value

Type: List String
See Also

Reference

HardDriveInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


HardDriveInformation.VolumeSerialNumbers Property

HardDriveInformationVolumeSerialNumbers Property
Gets a list of hard drive volume serial numbers.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<string> VolumeSerialNumbers { get; }
Public ReadOnly Property VolumeSerialNumbers As List(Of String)
    Get
public:
property List<String^>^ VolumeSerialNumbers {
    List<String^>^ get ();
}

Property Value

Type: List String
See Also

Reference

HardDriveInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


HardDriveInformation Methods

HardDriveInformation Methods

The HardDriveInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

HardDriveInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


MotherboardInformation Class

MotherboardInformation Class
SystemComponent implementation for retrieving information on the system's motherboard.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentMotherboardInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class MotherboardInformation : SystemComponent
Public Class MotherboardInformation
    Inherits SystemComponent
public ref class MotherboardInformation : public SystemComponent

The MotherboardInformation type exposes the following members.

Constructors
 | Name | Description
Public method | MotherboardInformation | Creates a new MotherboardInformation object.
Top
Properties
 | Name | Description
Public property | Manufacturer | Gets the motherboard manufacturer.
Public property | Product | Gets the motherboard product name.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | SerialNumber | Gets the motherboard serial number.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


MotherboardInformation Constructor

MotherboardInformation Constructor
Creates a new MotherboardInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public MotherboardInformation()
Public Sub New
public:
MotherboardInformation()
See Also

Reference

MotherboardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


MotherboardInformation Properties

MotherboardInformation Properties

The MotherboardInformation type exposes the following members.

Properties
 | Name | Description
Public property | Manufacturer | Gets the motherboard manufacturer.
Public property | Product | Gets the motherboard product name.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | SerialNumber | Gets the motherboard serial number.
Top
See Also

Reference

MotherboardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


MotherboardInformation.Manufacturer Property

MotherboardInformationManufacturer Property
Gets the motherboard manufacturer.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Manufacturer { get; }
Public ReadOnly Property Manufacturer As String
    Get
public:
property String^ Manufacturer {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

MotherboardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


MotherboardInformation.Product Property

MotherboardInformationProduct Property
Gets the motherboard product name.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Product { get; }
Public ReadOnly Property Product As String
    Get
public:
property String^ Product {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

MotherboardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


MotherboardInformation.SerialNumber Property

MotherboardInformationSerialNumber Property
Gets the motherboard serial number.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

MotherboardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


MotherboardInformation Methods

MotherboardInformation Methods

The MotherboardInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MotherboardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


NetworkInterfaceInformation Class

NetworkInterfaceInformation Class
SystemComponent implementation for retrieving information on the system's network adapters.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentNetworkInterfaceInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class NetworkInterfaceInformation : SystemComponent
Public Class NetworkInterfaceInformation
    Inherits SystemComponent
public ref class NetworkInterfaceInformation : public SystemComponent

The NetworkInterfaceInformation type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkInterfaceInformation | Creates a new NetworkInterfaceInformation object.
Top
Properties
 | Name | Description
Public property | MACAddresses | Gets the list of MAC addresses.
Public property | Names | Gets the list of network adapter names.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Overrides SystemComponentShouldIgnore(String).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


NetworkInterfaceInformation Constructor

NetworkInterfaceInformation Constructor
Creates a new NetworkInterfaceInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkInterfaceInformation()
Public Sub New
public:
NetworkInterfaceInformation()
See Also

Reference

NetworkInterfaceInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


NetworkInterfaceInformation Properties

NetworkInterfaceInformation Properties

The NetworkInterfaceInformation type exposes the following members.

Properties
 | Name | Description
Public property | MACAddresses | Gets the list of MAC addresses.
Public property | Names | Gets the list of network adapter names.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Top
See Also

Reference

NetworkInterfaceInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


NetworkInterfaceInformation.MACAddresses Property

NetworkInterfaceInformationMACAddresses Property
Gets the list of MAC addresses.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<string> MACAddresses { get; }
Public ReadOnly Property MACAddresses As List(Of String)
    Get
public:
property List<String^>^ MACAddresses {
    List<String^>^ get ();
}

Property Value

Type: List String
See Also

Reference

NetworkInterfaceInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


NetworkInterfaceInformation.Names Property

NetworkInterfaceInformationNames Property
Gets the list of network adapter names.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<string> Names { get; }
Public ReadOnly Property Names As List(Of String)
    Get
public:
property List<String^>^ Names {
    List<String^>^ get ();
}

Property Value

Type: List String
See Also

Reference

NetworkInterfaceInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


NetworkInterfaceInformation Methods

NetworkInterfaceInformation Methods

The NetworkInterfaceInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Overrides SystemComponentShouldIgnore(String).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NetworkInterfaceInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


NetworkInterfaceInformation.ShouldIgnore Method

NetworkInterfaceInformationShouldIgnore Method
Determines whether or not to ignore the given component property.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected override bool ShouldIgnore(
    string value
)
Protected Overrides Function ShouldIgnore (
    value As String
) As Boolean
protected:
virtual bool ShouldIgnore(
    String^ value
) override

Parameters

value
Type: SystemString
The property value to examine.

Return Value

Type: Boolean
Returns true if the component property should be ignored.
See Also

Reference

NetworkInterfaceInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


OperatingSystemInformation Class

OperatingSystemInformation Class
SystemComponent implementation for retrieving information on the system's operating system
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentOperatingSystemInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class OperatingSystemInformation : SystemComponent
Public Class OperatingSystemInformation
    Inherits SystemComponent
public ref class OperatingSystemInformation : public SystemComponent

The OperatingSystemInformation type exposes the following members.

Constructors
 | Name | Description
Public method | OperatingSystemInformation | Creates a new OperatingSystemInformation object.
Top
Properties
 | Name | Description
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | SerialNumber | Gets the operating system's serial number.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


OperatingSystemInformation Constructor

OperatingSystemInformation Constructor
Creates a new OperatingSystemInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public OperatingSystemInformation()
Public Sub New
public:
OperatingSystemInformation()
See Also

Reference

OperatingSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


OperatingSystemInformation Properties

OperatingSystemInformation Properties

The OperatingSystemInformation type exposes the following members.

Properties
 | Name | Description
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | SerialNumber | Gets the operating system's serial number.
Top
See Also

Reference

OperatingSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


OperatingSystemInformation.SerialNumber Property

OperatingSystemInformationSerialNumber Property
Gets the operating system's serial number.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

OperatingSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


OperatingSystemInformation Methods

OperatingSystemInformation Methods

The OperatingSystemInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

OperatingSystemInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ProcessorInformation Class

ProcessorInformation Class
SystemComponent implementation for retrieving information on the system's processor (CPU)
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentProcessorInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ProcessorInformation : SystemComponent
Public Class ProcessorInformation
    Inherits SystemComponent
public ref class ProcessorInformation : public SystemComponent

The ProcessorInformation type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessorInformation | Creates a new ProcessorInformation object.
Top
Properties
 | Name | Description
Public property | Architecture | Gets the processor's architecture.
Public property | CurrentClockSpeed | Gets the processor's clock speed.
Public property | ProcessorId | Gets the processor's ID.
Public property | ProcessorType | Gets the processor's type.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | Revision | Gets the processor's revision.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


ProcessorInformation Constructor

ProcessorInformation Constructor
Creates a new ProcessorInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorInformation()
Public Sub New
public:
ProcessorInformation()
See Also

Reference

ProcessorInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ProcessorInformation Properties

ProcessorInformation Properties

The ProcessorInformation type exposes the following members.

Properties
 | Name | Description
Public property | Architecture | Gets the processor's architecture.
Public property | CurrentClockSpeed | Gets the processor's clock speed.
Public property | ProcessorId | Gets the processor's ID.
Public property | ProcessorType | Gets the processor's type.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | Revision | Gets the processor's revision.
Top
See Also

Reference

ProcessorInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ProcessorInformation.Architecture Property

ProcessorInformationArchitecture Property
Gets the processor's architecture.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Architecture { get; }
Public ReadOnly Property Architecture As String
    Get
public:
property String^ Architecture {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ProcessorInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ProcessorInformation.CurrentClockSpeed Property

ProcessorInformationCurrentClockSpeed Property
Gets the processor's clock speed.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CurrentClockSpeed { get; }
Public ReadOnly Property CurrentClockSpeed As String
    Get
public:
property String^ CurrentClockSpeed {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ProcessorInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ProcessorInformation.ProcessorId Property

ProcessorInformationProcessorId Property
Gets the processor's ID.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProcessorId { get; }
Public ReadOnly Property ProcessorId As String
    Get
public:
property String^ ProcessorId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ProcessorInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ProcessorInformation.ProcessorType Property

ProcessorInformationProcessorType Property
Gets the processor's type.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProcessorType { get; }
Public ReadOnly Property ProcessorType As String
    Get
public:
property String^ ProcessorType {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ProcessorInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ProcessorInformation.Revision Property

ProcessorInformationRevision Property
Gets the processor's revision.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Revision { get; }
Public ReadOnly Property Revision As String
    Get
public:
property String^ Revision {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ProcessorInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


ProcessorInformation Methods

ProcessorInformation Methods

The ProcessorInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ProcessorInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SoundCardInformation Class

SoundCardInformation Class
SystemComponent implementation for retrieving information on the system's sound cards.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentSoundCardInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class SoundCardInformation : SystemComponent
Public Class SoundCardInformation
    Inherits SystemComponent
public ref class SoundCardInformation : public SystemComponent

The SoundCardInformation type exposes the following members.

Constructors
 | Name | Description
Public method | SoundCardInformation | Creates a new SoundCardInformation object.
Top
Properties
 | Name | Description
Public property | ProductNames | Gets a list of sound card names.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


SoundCardInformation Constructor

SoundCardInformation Constructor
Creates a new SoundCardInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SoundCardInformation()
Public Sub New
public:
SoundCardInformation()
See Also

Reference

SoundCardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SoundCardInformation Properties

SoundCardInformation Properties

The SoundCardInformation type exposes the following members.

Properties
 | Name | Description
Public property | ProductNames | Gets a list of sound card names.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Top
See Also

Reference

SoundCardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SoundCardInformation.ProductNames Property

SoundCardInformationProductNames Property
Gets a list of sound card names.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<string> ProductNames { get; }
Public ReadOnly Property ProductNames As List(Of String)
    Get
public:
property List<String^>^ ProductNames {
    List<String^>^ get ();
}

Property Value

Type: List String
See Also

Reference

SoundCardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SoundCardInformation Methods

SoundCardInformation Methods

The SoundCardInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SoundCardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponent Class

SystemComponent Class
Base class from which system component information implementations are derived. This is designed to facilitate retrieving data about a system using Windows Management Instrumentation (WMI) queries.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
More...

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class SystemComponent
Public MustInherit Class SystemComponent
public ref class SystemComponent abstract

The SystemComponent type exposes the following members.

Constructors
 | Name | Description
Protected method | SystemComponent | Creates a new SystemComponent object, initialized with a set of specified Windows Management Instrumentation (WMI) queries.
Top
Properties
 | Name | Description
Protected property | Properties | Gets a list of SystemComponentProperty objects.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentBIOSInformation
com.softwarekey.Client.Utils.SystemComponentCDROMInformation
com.softwarekey.Client.Utils.SystemComponentComputerSystemInformation
com.softwarekey.Client.Utils.SystemComponentHardDriveInformation
com.softwarekey.Client.Utils.SystemComponentMotherboardInformation
com.softwarekey.Client.Utils.SystemComponentNetworkInterfaceInformation
com.softwarekey.Client.Utils.SystemComponentOperatingSystemInformation
com.softwarekey.Client.Utils.SystemComponentProcessorInformation
com.softwarekey.Client.Utils.SystemComponentSoundCardInformation
com.softwarekey.Client.Utils.SystemComponentUserAccountInformation
com.softwarekey.Client.Utils.SystemComponentVideoCardInformation


SystemComponent Constructor

SystemComponent Constructor
Creates a new SystemComponent object, initialized with a set of specified Windows Management Instrumentation (WMI) queries.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected SystemComponent(
    string[] wmiQueries
)
Protected Sub New (
    wmiQueries As String()
)
protected:
SystemComponent(
    array<String^>^ wmiQueries
)

Parameters

wmiQueries
Type: SystemString
An array of WMI queries
See Also

Reference

SystemComponent Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponent Properties

SystemComponent Properties

The SystemComponent type exposes the following members.

Properties
 | Name | Description
Protected property | Properties | Gets a list of SystemComponentProperty objects.
Top
See Also

Reference

SystemComponent Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponent.Properties Property

SystemComponentProperties Property
Gets a list of SystemComponentProperty objects.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected List<SystemComponentProperty> Properties { get; }
Protected ReadOnly Property Properties As List(Of SystemComponentProperty)
    Get
protected:
property List<SystemComponentProperty^>^ Properties {
    List<SystemComponentProperty^>^ get ();
}

Property Value

Type: List SystemComponentProperty
See Also

Reference

SystemComponent Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponent Methods

SystemComponent Methods

The SystemComponent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SystemComponent Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponent.Initialize Method

SystemComponentInitialize Method
Initializes this SystemComponent.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected void Initialize()
Protected Sub Initialize
protected:
void Initialize()
See Also

Reference

SystemComponent Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponent.ShouldIgnore Method

SystemComponentShouldIgnore Method
Determines whether or not to ignore the given component property.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected virtual bool ShouldIgnore(
    string value
)
Protected Overridable Function ShouldIgnore (
    value As String
) As Boolean
protected:
virtual bool ShouldIgnore(
    String^ value
)

Parameters

value
Type: SystemString
The property value to examine.

Return Value

Type: Boolean
Returns true if the property value should be ignored, or false if it should not be ignored.
See Also

Reference

SystemComponent Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation Class

SystemComponentInformation Class
Collection of various SystemComponent objects, each of which contains information about the system.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponentInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class SystemComponentInformation
Public Class SystemComponentInformation
public ref class SystemComponentInformation

The SystemComponentInformation type exposes the following members.

Constructors
 | Name | Description
Public method | SystemComponentInformation | Creates a new SystemComponentInformation object, which contains information on various system components.
Top
Properties
 | Name | Description
Public property | BIOSInformation | Gets the BIOS information.
Public property | CDROMInformation | Gets the CD/DVD drive information.
Public property | ComputerSystemInformation | Gets general computer system information.
Public property | HardDriveInformation | Gets the hard drive information.
Public property | MotherboardInformation | Gets the motherboard information.
Public property | NetworkInterfaceInformation | Gets the network adapter information.
Public property | OperatingSystemInformation | Gets the operating system information.
Public property | ProcessorInformation | Gets the processor (CPU) information.
Public property | SoundCardInformation | Gets the sound card information.
Public property | UserAccountInformation | Gets the current user's information.
Public property | VideoCardInformation | Gets the video card information.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation Constructor

SystemComponentInformation Constructor
Creates a new SystemComponentInformation object, which contains information on various system components.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemComponentInformation()
Public Sub New
public:
SystemComponentInformation()
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation Properties

SystemComponentInformation Properties

The SystemComponentInformation type exposes the following members.

Properties
 | Name | Description
Public property | BIOSInformation | Gets the BIOS information.
Public property | CDROMInformation | Gets the CD/DVD drive information.
Public property | ComputerSystemInformation | Gets general computer system information.
Public property | HardDriveInformation | Gets the hard drive information.
Public property | MotherboardInformation | Gets the motherboard information.
Public property | NetworkInterfaceInformation | Gets the network adapter information.
Public property | OperatingSystemInformation | Gets the operating system information.
Public property | ProcessorInformation | Gets the processor (CPU) information.
Public property | SoundCardInformation | Gets the sound card information.
Public property | UserAccountInformation | Gets the current user's information.
Public property | VideoCardInformation | Gets the video card information.
Top
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.BIOSInformation Property

SystemComponentInformationBIOSInformation Property
Gets the BIOS information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public BIOSInformation BIOSInformation { get; }
Public ReadOnly Property BIOSInformation As BIOSInformation
    Get
public:
property BIOSInformation^ BIOSInformation {
    BIOSInformation^ get ();
}

Property Value

Type: BIOSInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.CDROMInformation Property

SystemComponentInformationCDROMInformation Property
Gets the CD/DVD drive information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CDROMInformation CDROMInformation { get; }
Public ReadOnly Property CDROMInformation As CDROMInformation
    Get
public:
property CDROMInformation^ CDROMInformation {
    CDROMInformation^ get ();
}

Property Value

Type: CDROMInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.ComputerSystemInformation Property

SystemComponentInformationComputerSystemInformation Property
Gets general computer system information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ComputerSystemInformation ComputerSystemInformation { get; }
Public ReadOnly Property ComputerSystemInformation As ComputerSystemInformation
    Get
public:
property ComputerSystemInformation^ ComputerSystemInformation {
    ComputerSystemInformation^ get ();
}

Property Value

Type: ComputerSystemInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.HardDriveInformation Property

SystemComponentInformationHardDriveInformation Property
Gets the hard drive information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public HardDriveInformation HardDriveInformation { get; }
Public ReadOnly Property HardDriveInformation As HardDriveInformation
    Get
public:
property HardDriveInformation^ HardDriveInformation {
    HardDriveInformation^ get ();
}

Property Value

Type: HardDriveInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.MotherboardInformation Property

SystemComponentInformationMotherboardInformation Property
Gets the motherboard information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public MotherboardInformation MotherboardInformation { get; }
Public ReadOnly Property MotherboardInformation As MotherboardInformation
    Get
public:
property MotherboardInformation^ MotherboardInformation {
    MotherboardInformation^ get ();
}

Property Value

Type: MotherboardInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.NetworkInterfaceInformation Property

SystemComponentInformationNetworkInterfaceInformation Property
Gets the network adapter information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkInterfaceInformation NetworkInterfaceInformation { get; }
Public ReadOnly Property NetworkInterfaceInformation As NetworkInterfaceInformation
    Get
public:
property NetworkInterfaceInformation^ NetworkInterfaceInformation {
    NetworkInterfaceInformation^ get ();
}

Property Value

Type: NetworkInterfaceInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.OperatingSystemInformation Property

SystemComponentInformationOperatingSystemInformation Property
Gets the operating system information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public OperatingSystemInformation OperatingSystemInformation { get; }
Public ReadOnly Property OperatingSystemInformation As OperatingSystemInformation
    Get
public:
property OperatingSystemInformation^ OperatingSystemInformation {
    OperatingSystemInformation^ get ();
}

Property Value

Type: OperatingSystemInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.ProcessorInformation Property

SystemComponentInformationProcessorInformation Property
Gets the processor (CPU) information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ProcessorInformation ProcessorInformation { get; }
Public ReadOnly Property ProcessorInformation As ProcessorInformation
    Get
public:
property ProcessorInformation^ ProcessorInformation {
    ProcessorInformation^ get ();
}

Property Value

Type: ProcessorInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.SoundCardInformation Property

SystemComponentInformationSoundCardInformation Property
Gets the sound card information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SoundCardInformation SoundCardInformation { get; }
Public ReadOnly Property SoundCardInformation As SoundCardInformation
    Get
public:
property SoundCardInformation^ SoundCardInformation {
    SoundCardInformation^ get ();
}

Property Value

Type: SoundCardInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.UserAccountInformation Property

SystemComponentInformationUserAccountInformation Property
Gets the current user's information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UserAccountInformation UserAccountInformation { get; }
Public ReadOnly Property UserAccountInformation As UserAccountInformation
    Get
public:
property UserAccountInformation^ UserAccountInformation {
    UserAccountInformation^ get ();
}

Property Value

Type: UserAccountInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation.VideoCardInformation Property

SystemComponentInformationVideoCardInformation Property
Gets the video card information.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public VideoCardInformation VideoCardInformation { get; }
Public ReadOnly Property VideoCardInformation As VideoCardInformation
    Get
public:
property VideoCardInformation^ VideoCardInformation {
    VideoCardInformation^ get ();
}

Property Value

Type: VideoCardInformation
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentInformation Methods

SystemComponentInformation Methods

The SystemComponentInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SystemComponentInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentProperty Class

SystemComponentProperty Class
Represents a property as a name/value pair of strings.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponentProperty

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class SystemComponentProperty
Public Class SystemComponentProperty
public ref class SystemComponentProperty

The SystemComponentProperty type exposes the following members.

Constructors
 | Name | Description
Public method | SystemComponentProperty(String) | Creates a new SystemComponentProperty object, initialized with the name.
Public method | SystemComponentProperty(String, String) | Creates a new SystemComponentProperty object, initialized with the name and value.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the property name.
Public property | Value | Gets or sets the property value.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentProperty Constructor

SystemComponentProperty Constructor
Overload List
 | Name | Description
Public method | SystemComponentProperty(String) | Creates a new SystemComponentProperty object, initialized with the name.
Public method | SystemComponentProperty(String, String) | Creates a new SystemComponentProperty object, initialized with the name and value.
Top
See Also

Reference

SystemComponentProperty Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentProperty Constructor (String)

SystemComponentProperty Constructor (String)
Creates a new SystemComponentProperty object, initialized with the name.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemComponentProperty(
    string name
)
Public Sub New (
    name As String
)
public:
SystemComponentProperty(
    String^ name
)

Parameters

name
Type: SystemString
The name of the property.
See Also

Reference

SystemComponentProperty Class
SystemComponentProperty Overload
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentProperty Constructor (String, String)

SystemComponentProperty Constructor (String, String)
Creates a new SystemComponentProperty object, initialized with the name and value.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SystemComponentProperty(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
SystemComponentProperty(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
The name of the property.
value
Type: SystemString
The property's value.
See Also

Reference

SystemComponentProperty Class
SystemComponentProperty Overload
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentProperty Properties

SystemComponentProperty Properties

The SystemComponentProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the property name.
Public property | Value | Gets or sets the property value.
Top
See Also

Reference

SystemComponentProperty Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentProperty.Name Property

SystemComponentPropertyName Property
Gets or sets the property name.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SystemComponentProperty Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentProperty.Value Property

SystemComponentPropertyValue Property
Gets or sets the property value.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SystemComponentProperty Class
com.softwarekey.Client.Utils.SystemComponent Namespace


SystemComponentProperty Methods

SystemComponentProperty Methods

The SystemComponentProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SystemComponentProperty Class
com.softwarekey.Client.Utils.SystemComponent Namespace


UserAccountInformation Class

UserAccountInformation Class
SystemComponent implementation for retrieving information on the system's current user.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentUserAccountInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class UserAccountInformation : SystemComponent
Public Class UserAccountInformation
    Inherits SystemComponent
public ref class UserAccountInformation : public SystemComponent

The UserAccountInformation type exposes the following members.

Constructors
 | Name | Description
Public method | UserAccountInformation | Creates a new UserAccountInformation object.
Top
Properties
 | Name | Description
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | SID | Gets the user's security identifier (SID).
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


UserAccountInformation Constructor

UserAccountInformation Constructor
Creates a new UserAccountInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UserAccountInformation()
Public Sub New
public:
UserAccountInformation()
See Also

Reference

UserAccountInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


UserAccountInformation Properties

UserAccountInformation Properties

The UserAccountInformation type exposes the following members.

Properties
 | Name | Description
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Public property | SID | Gets the user's security identifier (SID).
Top
See Also

Reference

UserAccountInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


UserAccountInformation.SID Property

UserAccountInformationSID Property
Gets the user's security identifier (SID).

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SID { get; }
Public ReadOnly Property SID As String
    Get
public:
property String^ SID {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UserAccountInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


UserAccountInformation Methods

UserAccountInformation Methods

The UserAccountInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

UserAccountInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


VideoCardInformation Class

VideoCardInformation Class
Information on the system's video cards.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.Utils.SystemComponentSystemComponent
com.softwarekey.Client.Utils.SystemComponentVideoCardInformation

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class VideoCardInformation : SystemComponent
Public Class VideoCardInformation
    Inherits SystemComponent
public ref class VideoCardInformation : public SystemComponent

The VideoCardInformation type exposes the following members.

Constructors
 | Name | Description
Public method | VideoCardInformation | Creates a new VideoCardInformation object.
Top
Properties
 | Name | Description
Public property | Names | Gets the list of video card names.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.Utils.SystemComponent Namespace


VideoCardInformation Constructor

VideoCardInformation Constructor
Creates a new VideoCardInformation object.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public VideoCardInformation()
Public Sub New
public:
VideoCardInformation()
See Also

Reference

VideoCardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


VideoCardInformation Properties

VideoCardInformation Properties

The VideoCardInformation type exposes the following members.

Properties
 | Name | Description
Public property | Names | Gets the list of video card names.
Protected property | Properties | Gets a list of SystemComponentProperty objects. (Inherited from SystemComponent.)
Top
See Also

Reference

VideoCardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


VideoCardInformation.Names Property

VideoCardInformationNames Property
Gets the list of video card names.

Namespace: com.softwarekey.Client.Utils.SystemComponent
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public List<string> Names { get; }
Public ReadOnly Property Names As List(Of String)
    Get
public:
property List<String^>^ Names {
    List<String^>^ get ();
}

Property Value

Type: List String
See Also

Reference

VideoCardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


VideoCardInformation Methods

VideoCardInformation Methods

The VideoCardInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | Initialize | Initializes this SystemComponent. (Inherited from SystemComponent.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | ShouldIgnore | Determines whether or not to ignore the given component property. (Inherited from SystemComponent.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VideoCardInformation Class
com.softwarekey.Client.Utils.SystemComponent Namespace


com.softwarekey.Client.WebService Namespace

com.softwarekey.Client.WebService Namespace
Contains classes and data for making calls to SOLO Server web services.
Classes
Class Description
Public class WebFormCall
Base implementation for web form calls, including things like posting data to the trial tracking service, making previous-generation (Automation Client) calls, etc...
Public class WebServiceCall

The base/abstract class from which all WebServiceCall implementations are derived. Key functions of this class include:

  • Signing and encrypting web service requests.
  • Decrypting and verifying web service responses.
  • Validation of session codes (to prevent replay attacks).
  • Providing a common means in which web service requests may be generated and responses may be processed, regardless of whether or not direct Internet connectivity is being used.

Web services presently implemented include:

Name | Description
XmlActivationService | Includes methods for Electronic License Activation, status checking, and deactivation.
XmlLicenseFileService | Used for retrieving and refreshing License Files electronically.
XmlLicenseService | Used for retrieving and sending license data (such as checks for product updates, customer registration, etc...).
XmlNetworkFloatingService | Used for SOLO Server-based Network Floating licensing implementations. This allows limiting the number of concurrent users/open sessions, status checking, closing sessions, and provides a means to "check-out" sessions for off-line use (when allowed) and to "check-in" any checked-out sessions when off-line use is no longer required. This feature is presently in a pre-release state. If you are interested in using this feature, please open a support ticket for details and documentation.

Interfaces
 | Interface | Description
Public interface | IWebServiceCall | Interface implemented for all WebServiceCall implementations.
Enumerations
 | Enumeration | Description
Public enumeration | WebFormCallHttpMethod | HTTP method verbs supported by WebFormCall implementations.
Public enumeration | WebServiceCallSessionValidation | Session Validation Levels
Public enumeration | WebServiceCallSOLOServerLicenseStatus | Possible SOLO Server license status values.


IWebServiceCall Interface

IWebServiceCall Interface
Interface implemented for all WebServiceCall implementations.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public interface IWebServiceCall
Public Interface IWebServiceCall
public interface class IWebServiceCall

The IWebServiceCall type exposes the following members.

Methods
 | Name | Description
Public method | GeneratePlainTextRequest | Generates a plain-text web service request XML string.
Public method | ProcessResponse | Processes a web service response.
Top
See Also

Reference

com.softwarekey.Client.WebService Namespace


IWebServiceCall Methods

IWebServiceCall Methods

The IWebServiceCall type exposes the following members.

Methods
 | Name | Description
Public method | GeneratePlainTextRequest | Generates a plain-text web service request XML string.
Public method | ProcessResponse | Processes a web service response.
Top
See Also

Reference

IWebServiceCall Interface
com.softwarekey.Client.WebService Namespace


IWebServiceCall.GeneratePlainTextRequest Method

IWebServiceCallGeneratePlainTextRequest Method
Generates a plain-text web service request XML string.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
string GeneratePlainTextRequest()
Function GeneratePlainTextRequest As String
String^ GeneratePlainTextRequest()

Return Value

Type: String
Returns the plain-text web service request XML string.
See Also

Reference

IWebServiceCall Interface
com.softwarekey.Client.WebService Namespace


IWebServiceCall.ProcessResponse Method

IWebServiceCallProcessResponse Method
Processes a web service response.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
bool ProcessResponse(
    ref XmlNode response
)
Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
bool ProcessResponse(
    XmlNode^% response
)

Parameters

response
Type: System.XmlXmlNode
The XmlDocument or root XmlNode object of the web service response.

Return Value

Type: Boolean
Returns true if processing is successful.
See Also

Reference

IWebServiceCall Interface
com.softwarekey.Client.WebService Namespace


WebFormCall Class

WebFormCall Class
Base implementation for web form calls, including things like posting data to the trial tracking service, making previous-generation (Automation Client) calls, etc...
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebFormCall
com.softwarekey.Client.Compatibility.ProtectionPLUS4AutomationClientWebFormCall

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class WebFormCall
Public MustInherit Class WebFormCall
public ref class WebFormCall abstract

The WebFormCall type exposes the following members.

Constructors
 | Name | Description
Public method | WebFormCall | Creates a new WebFormCall object.
Top
Properties
 | Name | Description
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default).
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default).
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings.
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication.
Public property | RequireSsl | Gets or sets whether or not SSL is required.
Public property | Response | Gets or sets the response returned from the server.
Public property | StatusCode | Gets or sets the status code of the response returned from the server.
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds).
Top
Methods
 | Name | Description
Public method | CallWebForm | Calls the web form.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.WebService Namespace


WebFormCall Constructor

WebFormCall Constructor
Creates a new WebFormCall object.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public WebFormCall(
    string url,
    WebFormCallHttpMethod method
)
Public Sub New (
    url As String,
    method As WebFormCallHttpMethod
)
public:
WebFormCall(
    String^ url,
    WebFormCallHttpMethod method
)

Parameters

url
Type: SystemString
The URL to the web form.
method
Type: com.softwarekey.Client.WebServiceWebFormCallHttpMethod
The WebFormCallHttpMethod that will be used for this object.
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall Properties

WebFormCall Properties

The WebFormCall type exposes the following members.

Properties
 | Name | Description
Public property | ContentEncoding | Gets or sets the encoding used for the request and response (UTF-8 is the default).
Public property | ContentType | Gets or sets the content type ("application/x-www-form-urlencoded" is the default).
Public property | LastException | Gets or sets the last Exception that occurred when calling the web form.
Public property | Proxy | Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings.
Public property | ProxyAuthenticationRequired | Gets or sets whether the proxy server requires authentication.
Public property | RequireSsl | Gets or sets whether or not SSL is required.
Public property | Response | Gets or sets the response returned from the server.
Public property | StatusCode | Gets or sets the status code of the response returned from the server.
Public property | Timeout | Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds).
Top
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall.ContentEncoding Property

WebFormCallContentEncoding Property
Gets or sets the encoding used for the request and response (UTF-8 is the default).

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual Encoding ContentEncoding { get; set; }
Public Overridable Property ContentEncoding As Encoding
    Get
    Set
public:
virtual property Encoding^ ContentEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

Property Value

Type: Encoding
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall.ContentType Property

WebFormCallContentType Property
Gets or sets the content type ("application/x-www-form-urlencoded" is the default).

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string ContentType { get; set; }
Public Overridable Property ContentType As String
    Get
    Set
public:
virtual property String^ ContentType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall.LastException Property

WebFormCallLastException Property
Gets or sets the last Exception that occurred when calling the web form.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual Exception LastException { get; set; }
Public Overridable Property LastException As Exception
    Get
    Set
public:
virtual property Exception^ LastException {
    Exception^ get ();
    void set (Exception^ value);
}

Property Value

Type: Exception
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall.Proxy Property

WebFormCallProxy Property
Gets or sets the proxy server settings. Leave as null/Nothing to use the system's default proxy settings.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual IWebProxy Proxy { get; set; }
Public Overridable Property Proxy As IWebProxy
    Get
    Set
public:
virtual property IWebProxy^ Proxy {
    IWebProxy^ get ();
    void set (IWebProxy^ value);
}

Property Value

Type: IWebProxy
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall.ProxyAuthenticationRequired Property

WebFormCallProxyAuthenticationRequired Property
Gets or sets whether the proxy server requires authentication.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProxyAuthenticationRequired { get; set; }
Public Overridable Property ProxyAuthenticationRequired As Boolean
    Get
    Set
public:
virtual property bool ProxyAuthenticationRequired {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall.RequireSsl Property

WebFormCallRequireSsl Property
Gets or sets whether or not SSL is required.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool RequireSsl { get; set; }
Public Overridable Property RequireSsl As Boolean
    Get
    Set
public:
virtual property bool RequireSsl {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall.Response Property

WebFormCallResponse Property
Gets or sets the response returned from the server.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string Response { get; set; }
Public Overridable Property Response As String
    Get
    Set
public:
virtual property String^ Response {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall.StatusCode Property

WebFormCallStatusCode Property
Gets or sets the status code of the response returned from the server.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int StatusCode { get; set; }
Public Overridable Property StatusCode As Integer
    Get
    Set
public:
virtual property int StatusCode {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall.Timeout Property

WebFormCallTimeout Property
Gets or sets the timeout (in milliseconds). The default is 30000 milliseconds (or 30 seconds).

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual int Timeout { get; set; }
Public Overridable Property Timeout As Integer
    Get
    Set
public:
virtual property int Timeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall Methods

WebFormCall Methods

The WebFormCall type exposes the following members.

Methods
 | Name | Description
Public method | CallWebForm | Calls the web form.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCall.CallWebForm Method

WebFormCallCallWebForm Method
Calls the web form.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool CallWebForm()
Public Overridable Function CallWebForm As Boolean
public:
virtual bool CallWebForm()

Return Value

Type: Boolean
Returns true if successful. If false is returned, check the LastException and ProxyAuthenticationRequired properties for possible reasons why the call failed.
See Also

Reference

WebFormCall Class
com.softwarekey.Client.WebService Namespace


WebFormCallHttpMethod Enumeration

WebFormCallHttpMethod Enumeration
HTTP method verbs supported by WebFormCall implementations.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum WebFormCallHttpMethod
Public Enumeration WebFormCallHttpMethod
public enum class WebFormCallHttpMethod
Members
Member name | Value | Description
Get | 0 | Standard HTTP GET.
Post | 1 | Standard HTTP POST.
See Also

Reference

com.softwarekey.Client.WebService Namespace


WebServiceCall Class

WebServiceCall Class

The base/abstract class from which all WebServiceCall implementations are derived. Key functions of this class include:

  • Signing and encrypting web service requests.
  • Decrypting and verifying web service responses.
  • Validation of session codes (to prevent replay attacks).
  • Providing a common means in which web service requests may be generated and responses may be processed, regardless of whether or not direct Internet connectivity is being used.

Web services presently implemented include:

Name | Description
XmlActivationService | Includes methods for Electronic License Activation, status checking, and deactivation.
XmlLicenseFileService | Used for retrieving and refreshing License Files electronically.
XmlLicenseService | Used for retrieving and sending license data (such as checks for product updates, customer registration, etc...).
XmlNetworkFloatingService | Used for SOLO Server-based Network Floating licensing implementations. This allows limiting the number of concurrent users/open sessions, status checking, closing sessions, and provides a means to "check-out" sessions for off-line use (when allowed) and to "check-in" any checked-out sessions when off-line use is no longer required. This feature is presently in a pre-release state. If you are interested in using this feature, please open a support ticket for details and documentation.

Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
More...

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class WebServiceCall : IWebServiceCall
Public MustInherit Class WebServiceCall
    Implements IWebServiceCall
public ref class WebServiceCall abstract : IWebServiceCall

The WebServiceCall type exposes the following members.

Constructors
 | Name | Description
Public method | WebServiceCall | Creates a new WebServiceCall object.
Top
Properties
 | Name | Description
Public property | ClassName | Gets or sets the class name of the WebServiceClient object.
Public property | EncryptionKey | Gets or sets the author encryption key data.
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.)
Public property | LastError | Gets or sets the last error which occurred.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check.
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks).
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically.
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call.
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call.
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response.
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string
Public method | CallWebService | Calls the web service method.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string.
Public method | GeneratePlainTextRequest | Generates a plain-text web service call XML request string.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | ParseSOLOServerStatus | Parses a status string returned by SOLO Server web services.
Public method | ProcessResponse(String) | Processes a web service response XML string.
Public method | ProcessResponse(XmlNode) | Processes a web service response XML.
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.WebService Namespace
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlActivationServiceActivateInstallation
com.softwarekey.Client.WebService.XmlActivationServiceActivateInstallationLicenseFile
com.softwarekey.Client.WebService.XmlActivationServiceCheckInstallationStatus
com.softwarekey.Client.WebService.XmlActivationServiceDeactivateInstallation
com.softwarekey.Client.WebService.XmlLicenseFileServiceGetLicenseFile
com.softwarekey.Client.WebService.XmlLicenseServiceInfoCheck
com.softwarekey.Client.WebService.XmlLicenseServiceRegister
com.softwarekey.Client.WebService.XmlLicenseServiceUpdateCheck
com.softwarekey.Client.WebService.XmlLicenseServiceValidateRegistration
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceNetworkFloatingServiceCall


WebServiceCall Constructor

WebServiceCall Constructor
Creates a new WebServiceCall object.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public WebServiceCall(
    string className,
    string methodName,
    SoapHttpClientProtocol client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    className As String,
    methodName As String,
    client As SoapHttpClientProtocol,
    encryptionKey As AuthorEncryptionKey
)
public:
WebServiceCall(
    String^ className,
    String^ methodName,
    SoapHttpClientProtocol^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

className
Type: SystemString
The name of the web service client class.
methodName
Type: SystemString
The name of the web service method to be called.
client
Type: System.Web.Services.ProtocolsSoapHttpClientProtocol
The SoapHttpClientProtocol object used to make the web service method calls.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object, which is required for cryptographic routines.
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall Properties

WebServiceCall Properties

The WebServiceCall type exposes the following members.

Properties
 | Name | Description
Public property | ClassName | Gets or sets the class name of the WebServiceClient object.
Public property | EncryptionKey | Gets or sets the author encryption key data.
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.)
Public property | LastError | Gets or sets the last error which occurred.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check.
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks).
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically.
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call.
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call.
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response.
Top
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.ClassName Property

WebServiceCallClassName Property
Gets or sets the class name of the WebServiceClient object.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.EncryptionKey Property

WebServiceCallEncryptionKey Property
Gets or sets the author encryption key data.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public AuthorEncryptionKey EncryptionKey { get; }
Public ReadOnly Property EncryptionKey As AuthorEncryptionKey
    Get
public:
property AuthorEncryptionKey^ EncryptionKey {
    AuthorEncryptionKey^ get ();
}

Property Value

Type: AuthorEncryptionKey
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.ErrorMessage Property

WebServiceCallErrorMessage Property
Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.)

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string ErrorMessage { get; set; }
Public Overridable Property ErrorMessage As String
    Get
    Set
public:
virtual property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.LastError Property

WebServiceCallLastError Property
Gets or sets the last error which occurred.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual LicenseError LastError { get; set; }
Public Overridable Property LastError As LicenseError
    Get
    Set
public:
virtual property LicenseError^ LastError {
    LicenseError^ get ();
    void set (LicenseError^ value);
}

Property Value

Type: LicenseError
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.MethodName Property

WebServiceCallMethodName Property
Gets or sets the name of the method which will be called from the WebServiceClient object.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string MethodName { get; set; }
Public Property MethodName As String
    Get
    Set
public:
property String^ MethodName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.RequireSsl Property

WebServiceCallRequireSsl Property
Gets or sets whether or not SSL certificate validation to check.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool RequireSsl { get; set; }
Public Overridable Property RequireSsl As Boolean
    Get
    Set
public:
virtual property bool RequireSsl {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.ResultCode Property

WebServiceCallResultCode Property
Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.)

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ResultCode { get; set; }
Public Property ResultCode As Integer
    Get
    Set
public:
property int ResultCode {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.SessionCode Property

WebServiceCallSessionCode Property
Gets or sets the randomized session code (used to deter replay attacks).

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string SessionCode { get; set; }
Public Overridable Property SessionCode As String
    Get
    Set
public:
virtual property String^ SessionCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.SessionCodeValidation Property

WebServiceCallSessionCodeValidation Property
Gets or sets whether or not session code validation should be done automatically.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual WebServiceCallSessionValidation SessionCodeValidation { get; set; }
Public Overridable Property SessionCodeValidation As WebServiceCallSessionValidation
    Get
    Set
public:
virtual property WebServiceCallSessionValidation SessionCodeValidation {
    WebServiceCallSessionValidation get ();
    void set (WebServiceCallSessionValidation value);
}

Property Value

Type: WebServiceCallSessionValidation
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.UseDigitalSignature Property

WebServiceCallUseDigitalSignature Property
Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.)

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool UseDigitalSignature { get; set; }
Public Overridable Property UseDigitalSignature As Boolean
    Get
    Set
public:
virtual property bool UseDigitalSignature {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.UseEncryption Property

WebServiceCallUseEncryption Property
Gets or sets whether or not encryption is to be used or is required for the web service call.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool UseEncryption { get; set; }
Public Overridable Property UseEncryption As Boolean
    Get
    Set
public:
virtual property bool UseEncryption {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.WebServiceClient Property

WebServiceCallWebServiceClient Property
Gets or sets the SoapHttpClientProtocol object used to perform the web service method call.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public SoapHttpClientProtocol WebServiceClient { get; set; }
Public Property WebServiceClient As SoapHttpClientProtocol
    Get
    Set
public:
property SoapHttpClientProtocol^ WebServiceClient {
    SoapHttpClientProtocol^ get ();
    void set (SoapHttpClientProtocol^ value);
}

Property Value

Type: SoapHttpClientProtocol
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.WebServiceResponse Property

WebServiceCallWebServiceResponse Property
Gets or set the XmlNode object reference for the root XML node of the web service response.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual XmlNode WebServiceResponse { get; set; }
Public Overridable Property WebServiceResponse As XmlNode
    Get
    Set
public:
virtual property XmlNode^ WebServiceResponse {
    XmlNode^ get ();
    void set (XmlNode^ value);
}

Property Value

Type: XmlNode
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall Methods

WebServiceCall Methods

The WebServiceCall type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string
Public method | CallWebService | Calls the web service method.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string.
Public method | GeneratePlainTextRequest | Generates a plain-text web service call XML request string.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | ParseSOLOServerStatus | Parses a status string returned by SOLO Server web services.
Public method | ProcessResponse(String) | Processes a web service response XML string.
Public method | ProcessResponse(XmlNode) | Processes a web service response XML.
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.AppendSessionCode Method

WebServiceCallAppendSessionCode Method
Overload List
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string
Top
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.AppendSessionCode Method (String)

WebServiceCallAppendSessionCode Method (String)
Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected virtual string AppendSessionCode(
    string xml
)
Protected Overridable Function AppendSessionCode (
    xml As String
) As String
protected:
virtual String^ AppendSessionCode(
    String^ xml
)

Parameters

xml
Type: SystemString
The plain-text XML request string.

Return Value

Type: String
Returns true if successful. If not successful, check the LastError property for details.
See Also

Reference

WebServiceCall Class
AppendSessionCode Overload
com.softwarekey.Client.WebService Namespace


WebServiceCall.AppendSessionCode Method (XmlDocument)

WebServiceCallAppendSessionCode Method (XmlDocument)
Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
protected virtual string AppendSessionCode(
    XmlDocument xml
)
Protected Overridable Function AppendSessionCode (
    xml As XmlDocument
) As String
protected:
virtual String^ AppendSessionCode(
    XmlDocument^ xml
)

Parameters

xml
Type: System.XmlXmlDocument
The plain-text request XmlDocument.

Return Value

Type: String
Returns true if successful. If not successful, check the LastError property for details.
See Also

Reference

WebServiceCall Class
AppendSessionCode Overload
com.softwarekey.Client.WebService Namespace


WebServiceCall.CallWebService Method

WebServiceCallCallWebService Method
Calls the web service method.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool CallWebService()
Public Overridable Function CallWebService As Boolean
public:
virtual bool CallWebService()

Return Value

Type: Boolean
Returns true if successful. If not successful, check the LastError property for details.
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.GenerateEncryptedRequest Method

WebServiceCallGenerateEncryptedRequest Method
Generates an encrypted web service call XML request string.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual string GenerateEncryptedRequest()
Public Overridable Function GenerateEncryptedRequest As String
public:
virtual String^ GenerateEncryptedRequest()

Return Value

Type: String
Returns the encrypted web service call XML request string.
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.GeneratePlainTextRequest Method

WebServiceCallGeneratePlainTextRequest Method
Generates a plain-text web service call XML request string.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract string GeneratePlainTextRequest()
Public MustOverride Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() abstract

Return Value

Type: String
Returns the plain-text web service call XML request string.

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.ParseSOLOServerStatus Method

WebServiceCallParseSOLOServerStatus Method
Parses a status string returned by SOLO Server web services.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public static WebServiceCallSOLOServerLicenseStatus ParseSOLOServerStatus(
    string value
)
Public Shared Function ParseSOLOServerStatus (
    value As String
) As WebServiceCallSOLOServerLicenseStatus
public:
static WebServiceCallSOLOServerLicenseStatus ParseSOLOServerStatus(
    String^ value
)

Parameters

value
Type: SystemString
The SOLO Server status string.

Return Value

Type: WebServiceCallSOLOServerLicenseStatus
Returns a WebServiceCallSOLOServerLicenseStatus enumeration value representing the status of the License ID in SOLO Server.
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.ProcessResponse Method

WebServiceCallProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string.
Public method | ProcessResponse(XmlNode) | Processes a web service response XML.
Top
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.ProcessResponse Method (String)

WebServiceCallProcessResponse Method (String)
Processes a web service response XML string.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessResponse(
    ref string response
)
Public Overridable Function ProcessResponse (
    ByRef response As String
) As Boolean
public:
virtual bool ProcessResponse(
    String^% response
)

Parameters

response
Type: SystemString
The response XML string.

Return Value

Type: Boolean
Returns true if successful. If not successful, check the LastError property for details.
See Also

Reference

WebServiceCall Class
ProcessResponse Overload
com.softwarekey.Client.WebService Namespace


WebServiceCall.ProcessResponse Method (XmlNode)

WebServiceCallProcessResponse Method (XmlNode)
Processes a web service response XML.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual bool ProcessResponse(
    ref XmlNode response
)
Public Overridable Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
)

Parameters

response
Type: System.XmlXmlNode
XmlNode object reference, which references the root/document node of the web service response.

Return Value

Type: Boolean
Returns true if successful. If not successful, check the LastError property for details.

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

WebServiceCall Class
ProcessResponse Overload
com.softwarekey.Client.WebService Namespace


WebServiceCall.ResetSessionCode Method

WebServiceCallResetSessionCode Method
Sets the SessionCode value to a new, randomized value.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public virtual void ResetSessionCode()
Public Overridable Sub ResetSessionCode
public:
virtual void ResetSessionCode()
See Also

Reference

WebServiceCall Class
com.softwarekey.Client.WebService Namespace


WebServiceCall.SessionValidation Enumeration

WebServiceCallSessionValidation Enumeration
Session Validation Levels

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum SessionValidation
Public Enumeration SessionValidation
public enum class SessionValidation
Members
Member name | Value | Description
None | 0 | Do not use session validation.
WhenAvailable | 1 | Only use session validation when available.
Required | 2 | Always require the use of session validation and require it (recommended).
See Also

Reference

com.softwarekey.Client.WebService Namespace


WebServiceCall.SOLOServerLicenseStatus Enumeration

WebServiceCallSOLOServerLicenseStatus Enumeration
Possible SOLO Server license status values.

Namespace: com.softwarekey.Client.WebService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum SOLOServerLicenseStatus
Public Enumeration SOLOServerLicenseStatus
public enum class SOLOServerLicenseStatus
Members
Member name | Value | Description
OK | 0 | The License ID valid or "OK."
Duplicate | 1 | The License ID is a duplicate.
Fraud | 2 | The License ID has been determined to be part of a fraudulent order.
Expired | 3 | The License ID has expired.
Check | 4 | The License ID is not valid, and requires review.
Upgrade | 5 | The License ID has been upgraded to another License ID.
Void | 6 | The License ID has been cancelled or voided, or is part of an order which has been cancelled or voided.
Returned | 7 | The License ID has been returned, or is part of an order which has been returned.
Delete | 8 | The License ID has been marked for deletion by a system administrator, and will soon be unavailable.
Unknown | 9 | An unknown or unrecognized status is present.
See Also

Reference

com.softwarekey.Client.WebService Namespace


com.softwarekey.Client.WebService.XmlActivationService Namespace

com.softwarekey.Client.WebService.XmlActivationService Namespace
Contains classes and data for making calls to the XmlActivationService web service.
Classes
 | Class | Description
Public class | ActivateInstallation | Implements the XmlActivationService web service's ActivateInstallation method, which activates and retrieves an Installation ID.
Public class | ActivateInstallationLicenseFile | Implements the XmlActivationService web service's ActivateInstallationLicenseFile method, which activates, retrieves an Installation ID, and retrieves a signed License File.
Public class | CheckInstallationStatus | Implements the XmlActivationService web service's CheckInstallationStatus method to validate the status of an Installation ID.
Public class | DeactivateInstallation | Implements the XmlActivationService web service's DeactivateInstallation method to validate the status of an Installation ID.
Public class | XmlActivationService | SoapHttpClientProtocol implementation for calling methods in SOLO Server's XmlActivationService web service.


ActivateInstallation Class

ActivateInstallation Class
Implements the XmlActivationService web service's ActivateInstallation method, which activates and retrieves an Installation ID.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlActivationServiceActivateInstallation

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ActivateInstallation : WebServiceCall
Public Class ActivateInstallation
    Inherits WebServiceCall
public ref class ActivateInstallation : public WebServiceCall

The ActivateInstallation type exposes the following members.

Constructors
 | Name | Description
Public method | ActivateInstallation(AuthorEncryptionKey) | Creates a new ActivateInstallation object.
Public method | ActivateInstallation(XmlActivationService, AuthorEncryptionKey) | Creates a new ActivateInstallation object.
Top
Properties
 | Name | Description
Public property | ActivationData | Gets or sets the Activation Data document, which contains the SystemIdentifier information. This field is optional, but recommended. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | InstallationID | Gets or sets the Installation ID, which is a unique identifier for the given activation which was issued. If you specify the Installation ID of a prior activation, SOLO Server will show that the specified Installation ID is related to the new Installation ID (if issued).
Public property | InstallationName | Gets or sets the Installation Name, which may be a name of your choice or the user's choice. You may opt to use things like a username or computer name here, or you may also allow the user to specify a friendly name.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID, which is required for License ID and Password validation.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets password, which is required for License ID and Password validation.
Public property | ProdOptionID | Gets or sets the Product Option ID. When the value is non-zero, the Product Option ID in SOLO Server will be validated against the product for which the License ID was issued.
Public property | ProductID | Gets or sets the Product ID. When the value is non-zero, the Product ID in SOLO Server will be validated against the product for which the License ID was issued. This is only required when using serial number and Product ID validation.
Public property | ProductVersion | Gets or sets the product version number, which is optional. When set, this must be formatted like NNNNN.NNNNN.NNNNN.NNNNN format, where N represents a digit.
Public property | ProductVersionNumber | Gets or sets the product version number, which is optional. This corresponds with the ProductVersion property, but uses the System.Version class to create the ProductVersion string.
Public property | RegistrationKey1 | Gets or sets Activation Code 1. This is also known as "RegKey1" in Protection PLUS 4, and will be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.
Public property | RegistrationKey2 | Gets or sets Activation Code 2. This is also known as "RegKey2" in Protection PLUS 4, and may be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.
Public property | RequireRegistration | Gets or sets whether or not customer registration is required for activation. Customer registration is where the customer enters information (such as name, email, address, etc...) about himself or herself with SOLO Server.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SerialNumber | Gets or sets the serial number. This is only required when using serial number and Product ID validation.
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | UserCode1 | Gets or sets User Code 1. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Session Code") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)
Public property | UserCode2 | Gets or sets User Code 2. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Computer ID") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for ActivateInstallation calls. (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

The XmlActivationService documentation should be referenced for the most current information.

Caution note Caution

If you wish to call these web services for PLUSManaged License implementations, we recommend you use the License.ActivateOnline method, which implements this call for you.

Caution note Caution

Any Product Options in SOLO Server which you intend to use when issuing License IDs which will be activated with this method must have the "Issue Installation ID" option enabled. Please refer to the SOLO Server manual for details.

Note Note

Before calling the CallWebService method, some properties must be set:

  • LicenseID and Password, or SerialNumber and ProductID.
  • UserCode1 and UserCode2 (the default values will suffice unless you are using Protection PLUS 4 compatibility features).
Note Note

Properties strongly recommended to have set before calling the CallWebService method include:

  • ActivationData, which includes the system identification data. This can be generated via the SystemIdentifier.GenerateActivationDataXml method.
  • ProductID, which having set as valid (non-zero) Product ID will result in SOLO Server validating that the License ID being activated is for the specified Product ID. This is an important mechanism for preventing someone from activating the wrong product (or activated "Product A" with a license for "Product B", for example).
  • InstallationName, which may be used to specify a friendly name for the Installation ID issued during activation. This could include a user-specified name, or a name of your choosing (such as the computer name or username).
  • ProductVersion, which you may use to identify which version of your product is being activated. This can be very helpful for support and troubleshooting purposes.
Examples
This example shows how to make a typical activation call for a PLUSManaged license:
C#
VB
C++
Copy
public bool Activate(AuthorEncryptionKey encryptionKey,
    Int32 licenseId, string password, Int32 productID,
    string installationName, List<SystemIdentifier> currentIdentifiers,
    ref LicenseError lastError)
{
    ActivateInstallation ws = new ActivateInstallation(encryptionKey);
    ws.LicenseID = licenseId;
    ws.Password = password;
    ws.ProductID = productID;
    ws.ProductVersionNumber = System.Reflection.Assembly.GetCallingAssembly().GetName().Version;
    ws.InstallationName = installationName;
    if (currentIdentifiers.Count > 0)
        ws.ActivationData = SystemIdentifier.GenerateActivationDataXml(currentIdentifiers);

    XmlActivationService client = new XmlActivationService();
    // If you are using Instant SOLO Server Dedicated URL or a self-hosted instance of SOLO Server,
    // set the client.Url property here.  You may also configure proxy settings on this object here, if necessary.
    ws.WebServiceClient = client;

    if (!ws.CallWebService())
    {
        lastError = ws.LastError;
        return false;
    }

    //TODO: Store the new Installation ID from the value in the ws.InstallationID property

    return true;
}
Public Function Activate(ByVal encryptionKey As AuthorEncryptionKey, ByVal licenseId As Int32, _
    ByVal password As String, ByVal productID As Int32, _
    ByVal installationName As String, ByVal currentIdentifiers As List(Of SystemIdentifier), _
    ByRef lastError As LicenseError) As Boolean

    Dim ws As New ActivateInstallation(encryptionKey)
    ws.LicenseID = licenseId
    ws.Password = password
    ws.ProductID = productID
    ws.ProductVersionNumber = System.Reflection.Assembly.GetCallingAssembly().GetName().Version
    ws.InstallationName = installationName
    If currentIdentifiers.Count > 0 Then
        ws.ActivationData = SystemIdentifier.GenerateActivationDataXml(currentIdentifiers)
    End If

    Dim client As New XmlActivationService()
    ' If you are using Instant SOLO Server Dedicated URL or a self-hosted instance of SOLO Server,
    ' set the client.Url property here.  You may also configure proxy settings on this object here, if necessary.
    ws.WebServiceClient = client

    If Not ws.CallWebService() Then
        lastError = ws.LastError
        Return False
    End If

    ' TODO: Store the new Installation ID from the value in the ws.InstallationID property

    Return True
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation Constructor

ActivateInstallation Constructor
Overload List
 | Name | Description
Public method | ActivateInstallation(AuthorEncryptionKey) | Creates a new ActivateInstallation object.
Public method | ActivateInstallation(XmlActivationService, AuthorEncryptionKey) | Creates a new ActivateInstallation object.
Top
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation Constructor (AuthorEncryptionKey)

ActivateInstallation Constructor (AuthorEncryptionKey)
Creates a new ActivateInstallation object.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ActivateInstallation(
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey
)
public:
ActivateInstallation(
    AuthorEncryptionKey^ encryptionKey
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object.
See Also

Reference

ActivateInstallation Class
ActivateInstallation Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation Constructor (XmlActivationService, AuthorEncryptionKey)

ActivateInstallation Constructor (XmlActivationService, AuthorEncryptionKey)
Creates a new ActivateInstallation object.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ActivateInstallation(
    XmlActivationService client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    client As XmlActivationService,
    encryptionKey As AuthorEncryptionKey
)
public:
ActivateInstallation(
    XmlActivationService^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService
The XmlActivationService object used to perform the web service method call.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized ActivateInstallation object.
See Also

Reference

ActivateInstallation Class
ActivateInstallation Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation Properties

ActivateInstallation Properties

The ActivateInstallation type exposes the following members.

Properties
 | Name | Description
Public property | ActivationData | Gets or sets the Activation Data document, which contains the SystemIdentifier information. This field is optional, but recommended. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | InstallationID | Gets or sets the Installation ID, which is a unique identifier for the given activation which was issued. If you specify the Installation ID of a prior activation, SOLO Server will show that the specified Installation ID is related to the new Installation ID (if issued).
Public property | InstallationName | Gets or sets the Installation Name, which may be a name of your choice or the user's choice. You may opt to use things like a username or computer name here, or you may also allow the user to specify a friendly name.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID, which is required for License ID and Password validation.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets password, which is required for License ID and Password validation.
Public property | ProdOptionID | Gets or sets the Product Option ID. When the value is non-zero, the Product Option ID in SOLO Server will be validated against the product for which the License ID was issued.
Public property | ProductID | Gets or sets the Product ID. When the value is non-zero, the Product ID in SOLO Server will be validated against the product for which the License ID was issued. This is only required when using serial number and Product ID validation.
Public property | ProductVersion | Gets or sets the product version number, which is optional. When set, this must be formatted like NNNNN.NNNNN.NNNNN.NNNNN format, where N represents a digit.
Public property | ProductVersionNumber | Gets or sets the product version number, which is optional. This corresponds with the ProductVersion property, but uses the System.Version class to create the ProductVersion string.
Public property | RegistrationKey1 | Gets or sets Activation Code 1. This is also known as "RegKey1" in Protection PLUS 4, and will be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.
Public property | RegistrationKey2 | Gets or sets Activation Code 2. This is also known as "RegKey2" in Protection PLUS 4, and may be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.
Public property | RequireRegistration | Gets or sets whether or not customer registration is required for activation. Customer registration is where the customer enters information (such as name, email, address, etc...) about himself or herself with SOLO Server.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SerialNumber | Gets or sets the serial number. This is only required when using serial number and Product ID validation.
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | UserCode1 | Gets or sets User Code 1. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Session Code") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)
Public property | UserCode2 | Gets or sets User Code 2. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Computer ID") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.ActivationData Property

ActivateInstallationActivationData Property
Gets or sets the Activation Data document, which contains the SystemIdentifier information. This field is optional, but recommended. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlDocument ActivationData { get; set; }
Public Property ActivationData As XmlDocument
    Get
    Set
public:
property XmlDocument^ ActivationData {
    XmlDocument^ get ();
    void set (XmlDocument^ value);
}

Property Value

Type: XmlDocument
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.InstallationID Property

ActivateInstallationInstallationID Property
Gets or sets the Installation ID, which is a unique identifier for the given activation which was issued. If you specify the Installation ID of a prior activation, SOLO Server will show that the specified Installation ID is related to the new Installation ID (if issued).

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InstallationID { get; set; }
Public Property InstallationID As String
    Get
    Set
public:
property String^ InstallationID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.InstallationName Property

ActivateInstallationInstallationName Property
Gets or sets the Installation Name, which may be a name of your choice or the user's choice. You may opt to use things like a username or computer name here, or you may also allow the user to specify a friendly name.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InstallationName { get; set; }
Public Property InstallationName As String
    Get
    Set
public:
property String^ InstallationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.LicenseID Property

ActivateInstallationLicenseID Property
Gets or sets the License ID, which is required for License ID and Password validation.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.Password Property

ActivateInstallationPassword Property
Gets or sets password, which is required for License ID and Password validation.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.ProdOptionID Property

ActivateInstallationProdOptionID Property
Gets or sets the Product Option ID. When the value is non-zero, the Product Option ID in SOLO Server will be validated against the product for which the License ID was issued.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProdOptionID { get; set; }
Public Property ProdOptionID As Integer
    Get
    Set
public:
property int ProdOptionID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.ProductID Property

ActivateInstallationProductID Property
Gets or sets the Product ID. When the value is non-zero, the Product ID in SOLO Server will be validated against the product for which the License ID was issued. This is only required when using serial number and Product ID validation.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; set; }
Public Property ProductID As Integer
    Get
    Set
public:
property int ProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.ProductVersion Property

ActivateInstallationProductVersion Property
Gets or sets the product version number, which is optional. When set, this must be formatted like NNNNN.NNNNN.NNNNN.NNNNN format, where N represents a digit.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProductVersion { get; set; }
Public Property ProductVersion As String
    Get
    Set
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.ProductVersionNumber Property

ActivateInstallationProductVersionNumber Property
Gets or sets the product version number, which is optional. This corresponds with the ProductVersion property, but uses the System.Version class to create the ProductVersion string.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Version ProductVersionNumber { get; set; }
Public Property ProductVersionNumber As Version
    Get
    Set
public:
property Version^ ProductVersionNumber {
    Version^ get ();
    void set (Version^ value);
}

Property Value

Type: Version
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.RegistrationKey1 Property

ActivateInstallationRegistrationKey1 Property
Gets or sets Activation Code 1. This is also known as "RegKey1" in Protection PLUS 4, and will be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int RegistrationKey1 { get; set; }
Public Property RegistrationKey1 As Integer
    Get
    Set
public:
property int RegistrationKey1 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.RegistrationKey2 Property

ActivateInstallationRegistrationKey2 Property
Gets or sets Activation Code 2. This is also known as "RegKey2" in Protection PLUS 4, and may be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int RegistrationKey2 { get; set; }
Public Property RegistrationKey2 As Integer
    Get
    Set
public:
property int RegistrationKey2 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.RequireRegistration Property

ActivateInstallationRequireRegistration Property
Gets or sets whether or not customer registration is required for activation. Customer registration is where the customer enters information (such as name, email, address, etc...) about himself or herself with SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool RequireRegistration { get; set; }
Public Property RequireRegistration As Boolean
    Get
    Set
public:
property bool RequireRegistration {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.SerialNumber Property

ActivateInstallationSerialNumber Property
Gets or sets the serial number. This is only required when using serial number and Product ID validation.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SerialNumber { get; set; }
Public Property SerialNumber As String
    Get
    Set
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.UserCode1 Property

ActivateInstallationUserCode1 Property
Gets or sets User Code 1. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Session Code") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UserCode1 { get; set; }
Public Property UserCode1 As Integer
    Get
    Set
public:
property int UserCode1 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.UserCode2 Property

ActivateInstallationUserCode2 Property
Gets or sets User Code 2. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Computer ID") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UserCode2 { get; set; }
Public Property UserCode2 As Integer
    Get
    Set
public:
property int UserCode2 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation Methods

ActivateInstallation Methods

The ActivateInstallation type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for ActivateInstallation calls. (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.GeneratePlainTextRequest Method

ActivateInstallationGeneratePlainTextRequest Method
Generates a plain-text XML request string for ActivateInstallation calls.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string GeneratePlainTextRequest()
Public Overrides Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() override

Return Value

Type: String
Returns the plain-text XML request string for ActivateInstallation calls.

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.ProcessResponse Method

ActivateInstallationProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Top
See Also

Reference

ActivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallation.ProcessResponse Method (XmlNode)

ActivateInstallationProcessResponse Method (XmlNode)
Processes a web service response.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessResponse(
    ref XmlNode response
)
Public Overrides Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
) override

Parameters

response
Type: System.XmlXmlNode
The XmlNode reference to the root/document node of the web service response.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

ActivateInstallation Class
ProcessResponse Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile Class

ActivateInstallationLicenseFile Class
Implements the XmlActivationService web service's ActivateInstallationLicenseFile method, which activates, retrieves an Installation ID, and retrieves a signed License File.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlActivationServiceActivateInstallationLicenseFile

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ActivateInstallationLicenseFile : WebServiceCall
Public Class ActivateInstallationLicenseFile
    Inherits WebServiceCall
public ref class ActivateInstallationLicenseFile : public WebServiceCall

The ActivateInstallationLicenseFile type exposes the following members.

Constructors
 | Name | Description
Public method | ActivateInstallationLicenseFile(AuthorEncryptionKey) | Creates a new ActivateInstallationLicenseFile object.
Public method | ActivateInstallationLicenseFile(XmlActivationService, AuthorEncryptionKey) | Creates a new ActivateInstallationLicenseFile object.
Top
Properties
 | Name | Description
Public property | ActivationData | Gets or sets the Activation Data document, which contains the SystemIdentifier information. This field is optional, but recommended. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | InstallationID | Gets or sets the Installation ID, which is a unique identifier for the given activation which was issued. If you specify the Installation ID of a prior activation, SOLO Server will show that the specified Installation ID is related to the new Installation ID (if issued).
Public property | InstallationName | Gets or sets the Installation Name, which may be a name of your choice or the user's choice. You may opt to use things like a username or computer name here, or you may also allow the user to specify a friendly name.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseFileContents | Gets or sets the License File contents returned from SOLO Server.
Public property | LicenseID | Gets or sets the License ID, which is required for License ID and Password validation.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets password, which is required for License ID and Password validation.
Public property | ProdOptionID | Gets or sets the Product Option ID. When the value is non-zero, the Product Option ID in SOLO Server will be validated against the product for which the License ID was issued.
Public property | ProductID | Gets or sets the Product ID. When the value is non-zero, the Product ID in SOLO Server will be validated against the product for which the License ID was issued. This is only required when using serial number and Product ID validation.
Public property | ProductVersion | Gets or sets the product version number, which is optional. When set, this must be formatted like NNNNN.NNNNN.NNNNN.NNNNN format, where N represents a digit.
Public property | ProductVersionNumber | Gets or sets the product version number, which is optional. This corresponds with the ProductVersion property, but uses the System.Version class to create the ProductVersion string.
Public property | RegistrationKey1 | Gets or sets Activation Code 1. This is also known as "RegKey1" in Protection PLUS 4, and will be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.
Public property | RegistrationKey2 | Gets or sets Activation Code 2. This is also known as "RegKey2" in Protection PLUS 4, and may be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.
Public property | RequireRegistration | Gets or sets whether or not customer registration is required for activation. Customer registration is where the customer enters information (such as name, email, address, etc...) about himself or herself with SOLO Server.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SerialNumber | Gets or sets the serial number. This is only required when using serial number and Product ID validation.
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | UserCode1 | Gets or sets User Code 1. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Session Code") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)
Public property | UserCode2 | Gets or sets User Code 2. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Computer ID") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for ActivateInstallationLicenseFile calls. (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

The XmlActivationService documentation should be referenced for the most current information.

Caution note Caution

If you wish to call these web services for PLUSManaged License implementations, we recommend you use the License.ActivateInstallationLicenseFile method, which implements this call for you.

Caution note Caution

Any Product Options in SOLO Server which you intend to use when issuing License IDs which will be activated with this method must have the "Issue Installation ID" option enabled. Please refer to the SOLO Server manual for details.

Caution note Caution

After activating successfully, the raw contents of the License File from SOLO Server are available in the LicenseFileContents property. Once this data is available to you, it is recommended that you save the License File contents so that the data is available to your application. Additionally, if you are using a PLUSManaged License implementation, you may use the License.Load method (when using Read-Only License Files) or the WritableLicense.Load method (for writable License Files) to update the license properties with the data from new data in LicenseFileContents.

Note Note

Before calling the CallWebService method, some properties must be set:

  • LicenseID and Password, or SerialNumber and ProductID.
  • UserCode1 and UserCode2 (the default values will suffice unless you are using Protection PLUS 4 compatibility features).
Note Note

Properties strongly recommended to have set before calling the CallWebService method include:

  • ActivationData, which includes the system identification data. This can be generated via the SystemIdentifier.GenerateActivationDataXml method.
  • ProductID, which having set as valid (non-zero) Product ID will result in SOLO Server validating that the License ID being activated is for the specified Product ID. This is an important mechanism for preventing someone from activating the wrong product (or activated "Product A" with a license for "Product B", for example).
  • InstallationName, which may be used to specify a friendly name for the Installation ID issued during activation. This could include a user-specified name, or a name of your choosing (such as the computer name or username).
  • ProductVersion, which you may use to identify which version of your product is being activated. This can be very helpful for support and troubleshooting purposes.
Examples
This example shows how to make a typical activation call for a PLUSManaged license:
C#
VB
C++
Copy
public bool ActivateLicenseFile(AuthorEncryptionKey encryptionKey,
    Int32 licenseId, string password, Int32 productID,
    string installationName, List<SystemIdentifier> currentIdentifiers,
    ref LicenseError lastError)
{
    ActivateInstallationLicenseFile ws = new ActivateInstallationLicenseFile(encryptionKey);
    ws.LicenseID = licenseId;
    ws.Password = password;
    ws.ProductID = productID;
    ws.ProductVersionNumber = System.Reflection.Assembly.GetCallingAssembly().GetName().Version;
    ws.InstallationName = installationName;
    if (currentIdentifiers.Count > 0)
        ws.ActivationData = SystemIdentifier.GenerateActivationDataXml(currentIdentifiers);

    XmlActivationService client = new XmlActivationService();
    //If you are using Instant SOLO Server Dedicated URL or a self-hosted instance of SOLO Server, set the
    // client.Url property here.  You may also configure proxy settings on this object here, if necessary.
    ws.WebServiceClient = client;

    if (!ws.CallWebService())
    {
        lastError = ws.LastError;
        return false;
    }

    //TODO: Store the new Installation ID from the value in the ws.InstallationID property

    //TODO: Save the contents of the License File (in ws.LicenseFileContents) to disk.  This can be done with
    //      a call to <see cref="M:System.IO.File.WriteAllText(System.String,System.String)">File.WriteAllText</see>.

    return true;
}
Public Function ActivateLicenseFile(ByVal encryptionKey As AuthorEncryptionKey, ByVal licenseId As Int32, _
    ByVal password As String, ByVal productID As Int32, _
    ByVal installationName As String, ByVal currentIdentifiers As List(Of SystemIdentifier), _
    ByRef lastError As LicenseError) As Boolean

    Dim licenseContents As String = ""
    Dim ws As New ActivateInstallationLicenseFile(encryptionKey)
    ws.LicenseID = licenseId
    ws.Password = password
    ws.ProductID = productID
    ws.ProductVersionNumber = System.Reflection.Assembly.GetCallingAssembly().GetName().Version
    ws.InstallationName = installationName
    If currentIdentifiers.Count > 0 Then
        ws.ActivationData = SystemIdentifier.GenerateActivationDataXml(currentIdentifiers)
    End If

    Dim client As New XmlActivationService()
    'If you are using Instant SOLO Server Dedicated URL or a self-hosted instance of SOLO Server, set the
    ' client.Url property here.  You may also configure proxy settings on this object here, if necessary.
    ws.WebServiceClient = client

    If Not ws.CallWebService() Then
        lastError = ws.LastError
        Return False
    End If

    'TODO: Store the new Installation ID from the value in the ws.InstallationID property
    'TODO: Save the contents of the License File (in ws.LicenseFileContents) to disk.  This can be done with
    '      a call to <see cref="M:System.IO.File.WriteAllText(System.String,System.String)">File.WriteAllText</see>.

    Return True
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile Constructor

ActivateInstallationLicenseFile Constructor
Overload List
 | Name | Description
Public method | ActivateInstallationLicenseFile(AuthorEncryptionKey) | Creates a new ActivateInstallationLicenseFile object.
Public method | ActivateInstallationLicenseFile(XmlActivationService, AuthorEncryptionKey) | Creates a new ActivateInstallationLicenseFile object.
Top
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile Constructor (AuthorEncryptionKey)

ActivateInstallationLicenseFile Constructor (AuthorEncryptionKey)
Creates a new ActivateInstallationLicenseFile object.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ActivateInstallationLicenseFile(
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey
)
public:
ActivateInstallationLicenseFile(
    AuthorEncryptionKey^ encryptionKey
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object.
See Also

Reference

ActivateInstallationLicenseFile Class
ActivateInstallationLicenseFile Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile Constructor (XmlActivationService, AuthorEncryptionKey)

ActivateInstallationLicenseFile Constructor (XmlActivationService, AuthorEncryptionKey)
Creates a new ActivateInstallationLicenseFile object.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ActivateInstallationLicenseFile(
    XmlActivationService client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    client As XmlActivationService,
    encryptionKey As AuthorEncryptionKey
)
public:
ActivateInstallationLicenseFile(
    XmlActivationService^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService
The XmlActivationService object used to perform the web service method call.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object.
See Also

Reference

ActivateInstallationLicenseFile Class
ActivateInstallationLicenseFile Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile Properties

ActivateInstallationLicenseFile Properties

The ActivateInstallationLicenseFile type exposes the following members.

Properties
 | Name | Description
Public property | ActivationData | Gets or sets the Activation Data document, which contains the SystemIdentifier information. This field is optional, but recommended. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | InstallationID | Gets or sets the Installation ID, which is a unique identifier for the given activation which was issued. If you specify the Installation ID of a prior activation, SOLO Server will show that the specified Installation ID is related to the new Installation ID (if issued).
Public property | InstallationName | Gets or sets the Installation Name, which may be a name of your choice or the user's choice. You may opt to use things like a username or computer name here, or you may also allow the user to specify a friendly name.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseFileContents | Gets or sets the License File contents returned from SOLO Server.
Public property | LicenseID | Gets or sets the License ID, which is required for License ID and Password validation.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets password, which is required for License ID and Password validation.
Public property | ProdOptionID | Gets or sets the Product Option ID. When the value is non-zero, the Product Option ID in SOLO Server will be validated against the product for which the License ID was issued.
Public property | ProductID | Gets or sets the Product ID. When the value is non-zero, the Product ID in SOLO Server will be validated against the product for which the License ID was issued. This is only required when using serial number and Product ID validation.
Public property | ProductVersion | Gets or sets the product version number, which is optional. When set, this must be formatted like NNNNN.NNNNN.NNNNN.NNNNN format, where N represents a digit.
Public property | ProductVersionNumber | Gets or sets the product version number, which is optional. This corresponds with the ProductVersion property, but uses the System.Version class to create the ProductVersion string.
Public property | RegistrationKey1 | Gets or sets Activation Code 1. This is also known as "RegKey1" in Protection PLUS 4, and will be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.
Public property | RegistrationKey2 | Gets or sets Activation Code 2. This is also known as "RegKey2" in Protection PLUS 4, and may be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.
Public property | RequireRegistration | Gets or sets whether or not customer registration is required for activation. Customer registration is where the customer enters information (such as name, email, address, etc...) about himself or herself with SOLO Server.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SerialNumber | Gets or sets the serial number. This is only required when using serial number and Product ID validation.
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | UserCode1 | Gets or sets User Code 1. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Session Code") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)
Public property | UserCode2 | Gets or sets User Code 2. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Computer ID") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.ActivationData Property

ActivateInstallationLicenseFileActivationData Property
Gets or sets the Activation Data document, which contains the SystemIdentifier information. This field is optional, but recommended. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlDocument ActivationData { get; set; }
Public Property ActivationData As XmlDocument
    Get
    Set
public:
property XmlDocument^ ActivationData {
    XmlDocument^ get ();
    void set (XmlDocument^ value);
}

Property Value

Type: XmlDocument
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.InstallationID Property

ActivateInstallationLicenseFileInstallationID Property
Gets or sets the Installation ID, which is a unique identifier for the given activation which was issued. If you specify the Installation ID of a prior activation, SOLO Server will show that the specified Installation ID is related to the new Installation ID (if issued).

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InstallationID { get; set; }
Public Property InstallationID As String
    Get
    Set
public:
property String^ InstallationID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.InstallationName Property

ActivateInstallationLicenseFileInstallationName Property
Gets or sets the Installation Name, which may be a name of your choice or the user's choice. You may opt to use things like a username or computer name here, or you may also allow the user to specify a friendly name.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InstallationName { get; set; }
Public Property InstallationName As String
    Get
    Set
public:
property String^ InstallationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.LicenseFileContents Property

ActivateInstallationLicenseFileLicenseFileContents Property
Gets or sets the License File contents returned from SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseFileContents { get; set; }
Public Property LicenseFileContents As String
    Get
    Set
public:
property String^ LicenseFileContents {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.LicenseID Property

ActivateInstallationLicenseFileLicenseID Property
Gets or sets the License ID, which is required for License ID and Password validation.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.Password Property

ActivateInstallationLicenseFilePassword Property
Gets or sets password, which is required for License ID and Password validation.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.ProdOptionID Property

ActivateInstallationLicenseFileProdOptionID Property
Gets or sets the Product Option ID. When the value is non-zero, the Product Option ID in SOLO Server will be validated against the product for which the License ID was issued.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProdOptionID { get; set; }
Public Property ProdOptionID As Integer
    Get
    Set
public:
property int ProdOptionID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.ProductID Property

ActivateInstallationLicenseFileProductID Property
Gets or sets the Product ID. When the value is non-zero, the Product ID in SOLO Server will be validated against the product for which the License ID was issued. This is only required when using serial number and Product ID validation.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; set; }
Public Property ProductID As Integer
    Get
    Set
public:
property int ProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.ProductVersion Property

ActivateInstallationLicenseFileProductVersion Property
Gets or sets the product version number, which is optional. When set, this must be formatted like NNNNN.NNNNN.NNNNN.NNNNN format, where N represents a digit.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProductVersion { get; set; }
Public Property ProductVersion As String
    Get
    Set
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.ProductVersionNumber Property

ActivateInstallationLicenseFileProductVersionNumber Property
Gets or sets the product version number, which is optional. This corresponds with the ProductVersion property, but uses the System.Version class to create the ProductVersion string.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Version ProductVersionNumber { get; set; }
Public Property ProductVersionNumber As Version
    Get
    Set
public:
property Version^ ProductVersionNumber {
    Version^ get ();
    void set (Version^ value);
}

Property Value

Type: Version
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.RegistrationKey1 Property

ActivateInstallationLicenseFileRegistrationKey1 Property
Gets or sets Activation Code 1. This is also known as "RegKey1" in Protection PLUS 4, and will be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int RegistrationKey1 { get; set; }
Public Property RegistrationKey1 As Integer
    Get
    Set
public:
property int RegistrationKey1 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.RegistrationKey2 Property

ActivateInstallationLicenseFileRegistrationKey2 Property
Gets or sets Activation Code 2. This is also known as "RegKey2" in Protection PLUS 4, and may be populated with a Protection PLUS 4 compatible activation code (or "Trigger Code") after processing the response successfully.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int RegistrationKey2 { get; set; }
Public Property RegistrationKey2 As Integer
    Get
    Set
public:
property int RegistrationKey2 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.RequireRegistration Property

ActivateInstallationLicenseFileRequireRegistration Property
Gets or sets whether or not customer registration is required for activation. Customer registration is where the customer enters information (such as name, email, address, etc...) about himself or herself with SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool RequireRegistration { get; set; }
Public Property RequireRegistration As Boolean
    Get
    Set
public:
property bool RequireRegistration {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.SerialNumber Property

ActivateInstallationLicenseFileSerialNumber Property
Gets or sets the serial number. This is only required when using serial number and Product ID validation.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SerialNumber { get; set; }
Public Property SerialNumber As String
    Get
    Set
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.UserCode1 Property

ActivateInstallationLicenseFileUserCode1 Property
Gets or sets User Code 1. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Session Code") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UserCode1 { get; set; }
Public Property UserCode1 As Integer
    Get
    Set
public:
property int UserCode1 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.UserCode2 Property

ActivateInstallationLicenseFileUserCode2 Property
Gets or sets User Code 2. Although the web service requires a non-zero value in this field, this property is only relevant if you are using Protection PLUS 4 (where it is also referred to as the "Computer ID") "Trigger Code" compatibility features. (The default value will suffice if you are not using these features.)

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UserCode2 { get; set; }
Public Property UserCode2 As Integer
    Get
    Set
public:
property int UserCode2 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile Methods

ActivateInstallationLicenseFile Methods

The ActivateInstallationLicenseFile type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for ActivateInstallationLicenseFile calls. (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.GeneratePlainTextRequest Method

ActivateInstallationLicenseFileGeneratePlainTextRequest Method
Generates a plain-text XML request string for ActivateInstallationLicenseFile calls.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string GeneratePlainTextRequest()
Public Overrides Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() override

Return Value

Type: String
Returns the plain-text XML request string for ActivateInstallationLicenseFile calls.

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.ProcessResponse Method

ActivateInstallationLicenseFileProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Top
See Also

Reference

ActivateInstallationLicenseFile Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


ActivateInstallationLicenseFile.ProcessResponse Method (XmlNode)

ActivateInstallationLicenseFileProcessResponse Method (XmlNode)
Processes a web service response.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessResponse(
    ref XmlNode response
)
Public Overrides Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
) override

Parameters

response
Type: System.XmlXmlNode
The XmlNode reference to the root/document node of the web service response.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

ActivateInstallationLicenseFile Class
ProcessResponse Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus Class

CheckInstallationStatus Class
Implements the XmlActivationService web service's CheckInstallationStatus method to validate the status of an Installation ID.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlActivationServiceCheckInstallationStatus

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class CheckInstallationStatus : WebServiceCall
Public Class CheckInstallationStatus
    Inherits WebServiceCall
public ref class CheckInstallationStatus : public WebServiceCall

The CheckInstallationStatus type exposes the following members.

Constructors
 | Name | Description
Public method | CheckInstallationStatus(AuthorEncryptionKey) | Creates a new CheckInstallationStatus object.
Public method | CheckInstallationStatus(XmlActivationService, AuthorEncryptionKey) | Creates a new CheckInstallationStatus object.
Top
Properties
 | Name | Description
Public property | ActivationData | The Activation Data document, which contains the SystemIdentifier information. This field is optional, but recommended. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | ExpirationDate | Gets the Installation/License's expiration date from SOLO Server.
Public property | InstallationID | Gets or sets the Installation ID (required), which is a unique identifier for the given activation which was issued.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | Log | Gets or sets the optional XmlDocument containing metering usage log data. (This is for Instant Metering users.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | ProductVersion | Gets or sets the product version number, which is optional. When set, this must be formatted like NNNNN.NNNNN.NNNNN.NNNNN format, where N represents a digit.
Public property | ProductVersionNumber | Gets or sets the product version number, which is optional. This corresponds with the ProductVersion property, but uses the System.Version class to create the ProductVersion string.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for CheckInstallationStatus calls. (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

The XmlActivationService documentation should be referenced for the most current information.

Caution note Caution

If you wish to call these web services for PLUSManaged License implementations, we recommend you use the License.CheckInstallationStatus method, which implements this call for you.

Caution note Caution

Any Product Options in SOLO Server which you intend to use when issuing License IDs which will be validated with this method must have the "Issue Installation ID" option enabled, and must be activated with ActivateInstallation or ActivateInstallationLicenseFile. Please refer to the SOLO Server manual for details.

Note Note

Before calling the CallWebService method, the InstallationID property must be set.

Examples
This example shows how to make a typical activation call for a PLUSManaged license:
C#
VB
C++
Copy
public bool CheckInstallation(AuthorEncryptionKey encryptionKey,
    string installationId, ref LicenseError lastError)
{
    //make sure we have an Installation ID to use first
    if (string.IsNullOrEmpty(installationId))
    {
        lastError = new LicenseError(LicenseError.ERROR_INSTALLATIONID_REQUIRED);
        return false;
    }

    CheckInstallationStatus ws = new CheckInstallationStatus(encryptionKey);
    ws.InstallationID = installationId;
    ws.ProductVersionNumber = System.Reflection.Assembly.GetCallingAssembly().GetName().Version;

    XmlActivationService client = new XmlActivationService();
    // If you are using Instant SOLO Server Dedicated URL or a self-hosted instance of SOLO Server,
    // set the client.Url property here.  You may also configure proxy settings on this object here, if necessary.
    ws.WebServiceClient = client;

    if (!ws.CallWebService())
    {
        //If you wish to revoke the local license when web-based validation fails, you can add code to do so here.
        lastError = ws.LastError;
        return false;
    }

    return true;
}
Public Function CheckInstallation(ByVal encryptionKey As AuthorEncryptionKey, _
    ByVal installationId As String, ByRef lastError As LicenseError) As Boolean

    //make sure we have an Installation ID to use first
    If String.IsNullOrEmpty(installationId) Then
        lastError = new LicenseError(LicenseError.ERROR_INSTALLATIONID_REQUIRED)
        Return False
    End If

    Dim ws As New CheckInstallationStatus(encryptionKey)
    ws.InstallationID = installationId
    ws.ProductVersionNumber = System.Reflection.Assembly.GetCallingAssembly().GetName().Version

    Dim client As New XmlActivationService()
    'If you are using Instant SOLO Server Dedicated URL or a self-hosted instance of SOLO Server,
    ' set the client.Url property here.  You may also configure proxy settings on this object here, if necessary.
    ws.WebServiceClient = client

    If Not ws.CallWebService() Then
        'If you wish to revoke the local license when web-based validation fails, you can add code to do so here.
        lastError = ws.LastError
        Return False
    End If

    Return True
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus Constructor

CheckInstallationStatus Constructor
Overload List
 | Name | Description
Public method | CheckInstallationStatus(AuthorEncryptionKey) | Creates a new CheckInstallationStatus object.
Public method | CheckInstallationStatus(XmlActivationService, AuthorEncryptionKey) | Creates a new CheckInstallationStatus object.
Top
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus Constructor (AuthorEncryptionKey)

CheckInstallationStatus Constructor (AuthorEncryptionKey)
Creates a new CheckInstallationStatus object.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CheckInstallationStatus(
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey
)
public:
CheckInstallationStatus(
    AuthorEncryptionKey^ encryptionKey
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object.
See Also

Reference

CheckInstallationStatus Class
CheckInstallationStatus Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus Constructor (XmlActivationService, AuthorEncryptionKey)

CheckInstallationStatus Constructor (XmlActivationService, AuthorEncryptionKey)
Creates a new CheckInstallationStatus object.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CheckInstallationStatus(
    XmlActivationService client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    client As XmlActivationService,
    encryptionKey As AuthorEncryptionKey
)
public:
CheckInstallationStatus(
    XmlActivationService^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService
The XmlActivationService object used to perform the web service method call.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object.
See Also

Reference

CheckInstallationStatus Class
CheckInstallationStatus Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus Properties

CheckInstallationStatus Properties

The CheckInstallationStatus type exposes the following members.

Properties
 | Name | Description
Public property | ActivationData | The Activation Data document, which contains the SystemIdentifier information. This field is optional, but recommended. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | ExpirationDate | Gets the Installation/License's expiration date from SOLO Server.
Public property | InstallationID | Gets or sets the Installation ID (required), which is a unique identifier for the given activation which was issued.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | Log | Gets or sets the optional XmlDocument containing metering usage log data. (This is for Instant Metering users.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | ProductVersion | Gets or sets the product version number, which is optional. When set, this must be formatted like NNNNN.NNNNN.NNNNN.NNNNN format, where N represents a digit.
Public property | ProductVersionNumber | Gets or sets the product version number, which is optional. This corresponds with the ProductVersion property, but uses the System.Version class to create the ProductVersion string.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus.ActivationData Property

CheckInstallationStatusActivationData Property
The Activation Data document, which contains the SystemIdentifier information. This field is optional, but recommended. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlDocument ActivationData { get; set; }
Public Property ActivationData As XmlDocument
    Get
    Set
public:
property XmlDocument^ ActivationData {
    XmlDocument^ get ();
    void set (XmlDocument^ value);
}

Property Value

Type: XmlDocument
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus.ExpirationDate Property

CheckInstallationStatusExpirationDate Property
Gets the Installation/License's expiration date from SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime ExpirationDate { get; }
Public ReadOnly Property ExpirationDate As DateTime
    Get
public:
property DateTime ExpirationDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus.InstallationID Property

CheckInstallationStatusInstallationID Property
Gets or sets the Installation ID (required), which is a unique identifier for the given activation which was issued.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InstallationID { get; set; }
Public Property InstallationID As String
    Get
    Set
public:
property String^ InstallationID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus.Log Property

CheckInstallationStatusLog Property
Gets or sets the optional XmlDocument containing metering usage log data. (This is for Instant Metering users.)

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlDocument Log { get; set; }
Public Property Log As XmlDocument
    Get
    Set
public:
property XmlDocument^ Log {
    XmlDocument^ get ();
    void set (XmlDocument^ value);
}

Property Value

Type: XmlDocument
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus.ProductVersion Property

CheckInstallationStatusProductVersion Property
Gets or sets the product version number, which is optional. When set, this must be formatted like NNNNN.NNNNN.NNNNN.NNNNN format, where N represents a digit.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProductVersion { get; set; }
Public Property ProductVersion As String
    Get
    Set
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus.ProductVersionNumber Property

CheckInstallationStatusProductVersionNumber Property
Gets or sets the product version number, which is optional. This corresponds with the ProductVersion property, but uses the System.Version class to create the ProductVersion string.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Version ProductVersionNumber { get; set; }
Public Property ProductVersionNumber As Version
    Get
    Set
public:
property Version^ ProductVersionNumber {
    Version^ get ();
    void set (Version^ value);
}

Property Value

Type: Version
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus Methods

CheckInstallationStatus Methods

The CheckInstallationStatus type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for CheckInstallationStatus calls. (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus.GeneratePlainTextRequest Method

CheckInstallationStatusGeneratePlainTextRequest Method
Generates a plain-text XML request string for CheckInstallationStatus calls.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string GeneratePlainTextRequest()
Public Overrides Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() override

Return Value

Type: String
Returns the plain-text XML request string for CheckInstallationStatus calls.

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus.ProcessResponse Method

CheckInstallationStatusProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Top
See Also

Reference

CheckInstallationStatus Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


CheckInstallationStatus.ProcessResponse Method (XmlNode)

CheckInstallationStatusProcessResponse Method (XmlNode)
Processes a web service response.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessResponse(
    ref XmlNode response
)
Public Overrides Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
) override

Parameters

response
Type: System.XmlXmlNode
The XmlNode reference to the root/document node of the web service response.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

CheckInstallationStatus Class
ProcessResponse Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


DeactivateInstallation Class

DeactivateInstallation Class
Implements the XmlActivationService web service's DeactivateInstallation method to validate the status of an Installation ID.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlActivationServiceDeactivateInstallation

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class DeactivateInstallation : WebServiceCall
Public Class DeactivateInstallation
    Inherits WebServiceCall
public ref class DeactivateInstallation : public WebServiceCall

The DeactivateInstallation type exposes the following members.

Constructors
 | Name | Description
Public method | DeactivateInstallation(AuthorEncryptionKey) | Creates a new DeactivateInstallation object.
Public method | DeactivateInstallation(XmlActivationService, AuthorEncryptionKey) | Creates a new DeactivateInstallation object.
Top
Properties
 | Name | Description
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | InstallationID | Gets or sets the Installation ID (required), which is a unique identifier for the given activation which was issued.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for DeactivateInstallation calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

The XmlActivationService documentation should be referenced for the most current information.

Caution note Caution

If you wish to call these web services for PLUSManaged License implementations, we recommend you use the License.DeactivateInstallation method, which implements this call for you.

Caution note Caution

Any Product Options in SOLO Server which you intend to use when issuing License IDs which will be validated with this method must have the "Issue Installation ID" option enabled, and must be activated with ActivateInstallation or ActivateInstallationLicenseFile. Please refer to the SOLO Server manual for details.

Note Note

Before calling the CallWebService method, the InstallationID property must be set.

Examples
This example shows how to make a typical deactivation call for a Protection PLUS 5 license:
C#
VB
C++
Copy
public bool Deactivate(AuthorEncryptionKey encryptionKey,
    string installationId, ref LicenseError lastError)
{
    //make sure we have an Installation ID to use first
    if (string.IsNullOrEmpty(installationId))
    {
        lastError = new LicenseError(LicenseError.ERROR_INSTALLATIONID_REQUIRED);
        return false;
    }

    DeactivateInstallation ws = new DeactivateInstallation(encryptionKey);
    ws.InstallationID = installationId;

    XmlActivationService client = new XmlActivationService();
    // If you are using Instant SOLO Server Dedicated URL or a self-hosted instance of SOLO Server,
    // set the client.Url property here.  You may also configure proxy settings on this object here, if necessary.
    ws.WebServiceClient = client;

    if (!ws.CallWebService())
    {
        //If you wish to revoke the local license, you can add code to do so here.
        lastError = ws.LastError;
        return false;
    }

    return true;
}
Public Function Deactivate(ByVal encryptionKey As AuthorEncryptionKey, _
    ByVal installationId As String, ByRef lastError As LicenseError) As Boolean

    //make sure we have an Installation ID to use first
    If String.IsNullOrEmpty(installationId) Then
        lastError = new LicenseError(LicenseError.ERROR_INSTALLATIONID_REQUIRED)
        Return False
    End If

    Dim ws As New DeactivateInstallation(encryptionKey)
    ws.InstallationID = installationId

    Dim client As New XmlActivationService()
    'If you are using Instant SOLO Server Dedicated URL or a self-hosted instance of SOLO Server,
    ' set the client.Url property here.  You may also configure proxy settings on this object here, if necessary.
    ws.WebServiceClient = client

    If Not ws.CallWebService() Then
        'If you wish to revoke the local license, you can add code to do so here.
        lastError = ws.LastError
        Return False
    End If

    Return True
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.WebService.XmlActivationService Namespace


DeactivateInstallation Constructor

DeactivateInstallation Constructor
Overload List
 | Name | Description
Public method | DeactivateInstallation(AuthorEncryptionKey) | Creates a new DeactivateInstallation object.
Public method | DeactivateInstallation(XmlActivationService, AuthorEncryptionKey) | Creates a new DeactivateInstallation object.
Top
See Also

Reference

DeactivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


DeactivateInstallation Constructor (AuthorEncryptionKey)

DeactivateInstallation Constructor (AuthorEncryptionKey)
Creates a new DeactivateInstallation object.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DeactivateInstallation(
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey
)
public:
DeactivateInstallation(
    AuthorEncryptionKey^ encryptionKey
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object.
See Also

Reference

DeactivateInstallation Class
DeactivateInstallation Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


DeactivateInstallation Constructor (XmlActivationService, AuthorEncryptionKey)

DeactivateInstallation Constructor (XmlActivationService, AuthorEncryptionKey)
Creates a new DeactivateInstallation object.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DeactivateInstallation(
    XmlActivationService client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    client As XmlActivationService,
    encryptionKey As AuthorEncryptionKey
)
public:
DeactivateInstallation(
    XmlActivationService^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService
The XmlActivationService object used to perform the web service method call.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The pre-initialized AuthorEncryptionKey object.
See Also

Reference

DeactivateInstallation Class
DeactivateInstallation Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


DeactivateInstallation Properties

DeactivateInstallation Properties

The DeactivateInstallation type exposes the following members.

Properties
 | Name | Description
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | InstallationID | Gets or sets the Installation ID (required), which is a unique identifier for the given activation which was issued.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

DeactivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


DeactivateInstallation.InstallationID Property

DeactivateInstallationInstallationID Property
Gets or sets the Installation ID (required), which is a unique identifier for the given activation which was issued.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InstallationID { get; set; }
Public Property InstallationID As String
    Get
    Set
public:
property String^ InstallationID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DeactivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


DeactivateInstallation Methods

DeactivateInstallation Methods

The DeactivateInstallation type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for DeactivateInstallation calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DeactivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


DeactivateInstallation.GeneratePlainTextRequest Method

DeactivateInstallationGeneratePlainTextRequest Method
Generates a plain-text XML request string for DeactivateInstallation calls

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string GeneratePlainTextRequest()
Public Overrides Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() override

Return Value

Type: String
Returns the plain-text XML request string for DeactivateInstallation calls.

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

DeactivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


DeactivateInstallation.ProcessResponse Method

DeactivateInstallationProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a web service response. (Overrides WebServiceCallProcessResponse(XmlNode).)
Top
See Also

Reference

DeactivateInstallation Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


DeactivateInstallation.ProcessResponse Method (XmlNode)

DeactivateInstallationProcessResponse Method (XmlNode)
Processes a web service response.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessResponse(
    ref XmlNode response
)
Public Overrides Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
) override

Parameters

response
Type: System.XmlXmlNode
The XmlNode reference to the root/document node of the web service response.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, check the LastError property for details.

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

DeactivateInstallation Class
ProcessResponse Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService Class

XmlActivationService Class
SoapHttpClientProtocol implementation for calling methods in SOLO Server's XmlActivationService web service.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Web.Services.ProtocolsWebClientProtocol
System.Web.Services.ProtocolsHttpWebClientProtocol
System.Web.Services.ProtocolsSoapHttpClientProtocol
com.softwarekey.Client.WebService.XmlActivationServiceXmlActivationService

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class XmlActivationService : SoapHttpClientProtocol
Public Class XmlActivationService
    Inherits SoapHttpClientProtocol
public ref class XmlActivationService : public SoapHttpClientProtocol

The XmlActivationService type exposes the following members.

Constructors
 | Name | Description
Public method | XmlActivationService | Creates a new XmlActivationService object.
Top
Properties
 | Name | Description
Public property | AllowAutoRedirect | (Inherited from HttpWebClientProtocol.)
Protected property | CanRaiseEvents | (Inherited from Component.)
Public property | ClientCertificates | (Inherited from HttpWebClientProtocol.)
Public property | ConnectionGroupName | (Inherited from WebClientProtocol.)
Public property | Container | (Inherited from Component.)
Public property | CookieContainer | (Inherited from HttpWebClientProtocol.)
Public property | Credentials | (Inherited from WebClientProtocol.)
Protected property | DesignMode | (Inherited from Component.)
Public property | EnableDecompression | (Inherited from HttpWebClientProtocol.)
Protected property | Events | (Inherited from Component.)
Public property | PreAuthenticate | (Inherited from WebClientProtocol.)
Public property | Proxy | (Inherited from HttpWebClientProtocol.)
Public property | RequestEncoding | (Inherited from WebClientProtocol.)
Public property | Site | (Inherited from Component.)
Public property | SoapVersion | (Inherited from SoapHttpClientProtocol.)
Public property | Timeout | (Inherited from WebClientProtocol.)
Public property | UnsafeAuthenticatedConnectionSharing | (Inherited from HttpWebClientProtocol.)
Public property | Url | Gets or sets the base URL of the XML Web service the client is requesting.
Public property | UseDefaultCredentials | Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.
Public property | UserAgent | (Inherited from HttpWebClientProtocol.)
Top
Methods
 | Name | Description
Public method | Abort | (Inherited from WebClientProtocol.)
Public method | ActivateInstallation | Calls the ActivateInstallation web method.
Public method | ActivateInstallationAsync(String) | Begins an asynchronous call to the ActivateInstallation web method.
Public method | ActivateInstallationAsync(String, Object) | Calls the ActivateInstallation web method asynchronously.
Public method | ActivateInstallationLicenseFile | Calls the ActivateInstallationLicenseFile web method.
Public method | ActivateInstallationLicenseFileAsync(String) | Calls the ActivateInstallationLicenseFile web method asynchronously.
Public method | ActivateInstallationLicenseFileAsync(String, Object) | Calls the ActivateInstallationLicenseFile web method asynchronously.
Protected method | BeginInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | CancelAsync | Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).
Public method | CheckInstallationStatus | Calls the CheckInstallationStatus web method.
Public method | CheckInstallationStatusAsync(String) | Calls the CheckInstallationStatus web method asynchronously.
Public method | CheckInstallationStatusAsync(String, Object) | Calls the CheckInstallationStatus web method.
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Public method | DeactivateInstallation | Calls the DeactivateInstallation web method.
Public method | DeactivateInstallationAsync(String) | Calls the DeactivateInstallation web method asynchronously.
Public method | DeactivateInstallationAsync(String, Object) | Calls the DeactivateInstallation web method asynchronously.
Public method | Discover | (Inherited from SoapHttpClientProtocol.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from Component.)
Protected method | EndInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | GetReaderForMessage | (Inherited from SoapHttpClientProtocol.)
Protected method | GetService | (Inherited from Component.)
Public method | GetType | (Inherited from Object.)
Protected method | GetWebRequest | (Inherited from SoapHttpClientProtocol.)
Protected method | GetWebResponse(WebRequest) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWebResponse(WebRequest, IAsyncResult) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWriterForMessage | (Inherited from SoapHttpClientProtocol.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | Invoke | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback) | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback, Object) | (Inherited from SoapHttpClientProtocol.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Public method | ToString | (Inherited from Component.)
Top
Events
 | Name | Description
Public event | ActivateInstallationCompleted | Occurs when a call to ActivateInstallation(String) has completed.
Public event | ActivateInstallationLicenseFileCompleted | Occurs when a call to ActivateInstallationLicenseFile(String) has completed.
Public event | CheckInstallationStatusCompleted | Occurs when a call to CheckInstallationStatus(String) has completed.
Public event | DeactivateInstallationCompleted | Occurs when a call to DeactivateInstallation(String) has completed.
Public event | Disposed | (Inherited from Component.)
Top
Remarks
Note Note

This class should only be used directly as needed for specifying customized information, such as different end-point URLs, proxy server access credentials, etc... The com.softwarekey.Client.WebService.XmlActivationService namespace contains WebServiceCall implementations for each supported web service method.

See Also

Reference

com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService Constructor

XmlActivationService Constructor
Creates a new XmlActivationService object.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlActivationService()
Public Sub New
public:
XmlActivationService()
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService Properties

XmlActivationService Properties

The XmlActivationService type exposes the following members.

Properties
 | Name | Description
Public property | AllowAutoRedirect | (Inherited from HttpWebClientProtocol.)
Protected property | CanRaiseEvents | (Inherited from Component.)
Public property | ClientCertificates | (Inherited from HttpWebClientProtocol.)
Public property | ConnectionGroupName | (Inherited from WebClientProtocol.)
Public property | Container | (Inherited from Component.)
Public property | CookieContainer | (Inherited from HttpWebClientProtocol.)
Public property | Credentials | (Inherited from WebClientProtocol.)
Protected property | DesignMode | (Inherited from Component.)
Public property | EnableDecompression | (Inherited from HttpWebClientProtocol.)
Protected property | Events | (Inherited from Component.)
Public property | PreAuthenticate | (Inherited from WebClientProtocol.)
Public property | Proxy | (Inherited from HttpWebClientProtocol.)
Public property | RequestEncoding | (Inherited from WebClientProtocol.)
Public property | Site | (Inherited from Component.)
Public property | SoapVersion | (Inherited from SoapHttpClientProtocol.)
Public property | Timeout | (Inherited from WebClientProtocol.)
Public property | UnsafeAuthenticatedConnectionSharing | (Inherited from HttpWebClientProtocol.)
Public property | Url | Gets or sets the base URL of the XML Web service the client is requesting.
Public property | UseDefaultCredentials | Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.
Public property | UserAgent | (Inherited from HttpWebClientProtocol.)
Top
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.Url Property

XmlActivationServiceUrl Property
Gets or sets the base URL of the XML Web service the client is requesting.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.UseDefaultCredentials Property

XmlActivationServiceUseDefaultCredentials Property
Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool UseDefaultCredentials { get; set; }
Public Property UseDefaultCredentials As Boolean
    Get
    Set
public:
property bool UseDefaultCredentials {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService Methods

XmlActivationService Methods

The XmlActivationService type exposes the following members.

Methods
 | Name | Description
Public method | Abort | (Inherited from WebClientProtocol.)
Public method | ActivateInstallation | Calls the ActivateInstallation web method.
Public method | ActivateInstallationAsync(String) | Begins an asynchronous call to the ActivateInstallation web method.
Public method | ActivateInstallationAsync(String, Object) | Calls the ActivateInstallation web method asynchronously.
Public method | ActivateInstallationLicenseFile | Calls the ActivateInstallationLicenseFile web method.
Public method | ActivateInstallationLicenseFileAsync(String) | Calls the ActivateInstallationLicenseFile web method asynchronously.
Public method | ActivateInstallationLicenseFileAsync(String, Object) | Calls the ActivateInstallationLicenseFile web method asynchronously.
Protected method | BeginInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | CancelAsync | Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).
Public method | CheckInstallationStatus | Calls the CheckInstallationStatus web method.
Public method | CheckInstallationStatusAsync(String) | Calls the CheckInstallationStatus web method asynchronously.
Public method | CheckInstallationStatusAsync(String, Object) | Calls the CheckInstallationStatus web method.
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Public method | DeactivateInstallation | Calls the DeactivateInstallation web method.
Public method | DeactivateInstallationAsync(String) | Calls the DeactivateInstallation web method asynchronously.
Public method | DeactivateInstallationAsync(String, Object) | Calls the DeactivateInstallation web method asynchronously.
Public method | Discover | (Inherited from SoapHttpClientProtocol.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from Component.)
Protected method | EndInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | GetReaderForMessage | (Inherited from SoapHttpClientProtocol.)
Protected method | GetService | (Inherited from Component.)
Public method | GetType | (Inherited from Object.)
Protected method | GetWebRequest | (Inherited from SoapHttpClientProtocol.)
Protected method | GetWebResponse(WebRequest) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWebResponse(WebRequest, IAsyncResult) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWriterForMessage | (Inherited from SoapHttpClientProtocol.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | Invoke | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback) | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback, Object) | (Inherited from SoapHttpClientProtocol.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Public method | ToString | (Inherited from Component.)
Top
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.ActivateInstallation Method

XmlActivationServiceActivateInstallation Method
Calls the ActivateInstallation web method.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode ActivateInstallation(
    string xml
)
Public Function ActivateInstallation (
    xml As String
) As XmlNode
public:
XmlNode^ ActivateInstallation(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the ActivateInstallation class instead.

See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.ActivateInstallationAsync Method

XmlActivationServiceActivateInstallationAsync Method
Overload List
 | Name | Description
Public method | ActivateInstallationAsync(String) | Begins an asynchronous call to the ActivateInstallation web method.
Public method | ActivateInstallationAsync(String, Object) | Calls the ActivateInstallation web method asynchronously.
Top
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.ActivateInstallationAsync Method (String)

XmlActivationServiceActivateInstallationAsync Method (String)
Begins an asynchronous call to the ActivateInstallation web method.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ActivateInstallationAsync(
    string xml
)
Public Sub ActivateInstallationAsync (
    xml As String
)
public:
void ActivateInstallationAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the ActivateInstallation class instead.

See Also

Reference

XmlActivationService Class
ActivateInstallationAsync Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.ActivateInstallationAsync Method (String, Object)

XmlActivationServiceActivateInstallationAsync Method (String, Object)
Calls the ActivateInstallation web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ActivateInstallationAsync(
    string xml,
    Object userState
)
Public Sub ActivateInstallationAsync (
    xml As String,
    userState As Object
)
public:
void ActivateInstallationAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the ActivateInstallation class instead.

See Also

Reference

XmlActivationService Class
ActivateInstallationAsync Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.ActivateInstallationLicenseFile Method

XmlActivationServiceActivateInstallationLicenseFile Method
Calls the ActivateInstallationLicenseFile web method.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode ActivateInstallationLicenseFile(
    string xml
)
Public Function ActivateInstallationLicenseFile (
    xml As String
) As XmlNode
public:
XmlNode^ ActivateInstallationLicenseFile(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the ActivateInstallationLicenseFile class instead.

See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.ActivateInstallationLicenseFileAsync Method

XmlActivationServiceActivateInstallationLicenseFileAsync Method
Overload List
 | Name | Description
Public method | ActivateInstallationLicenseFileAsync(String) | Calls the ActivateInstallationLicenseFile web method asynchronously.
Public method | ActivateInstallationLicenseFileAsync(String, Object) | Calls the ActivateInstallationLicenseFile web method asynchronously.
Top
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.ActivateInstallationLicenseFileAsync Method (String)

XmlActivationServiceActivateInstallationLicenseFileAsync Method (String)
Calls the ActivateInstallationLicenseFile web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ActivateInstallationLicenseFileAsync(
    string xml
)
Public Sub ActivateInstallationLicenseFileAsync (
    xml As String
)
public:
void ActivateInstallationLicenseFileAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the ActivateInstallationLicenseFile class instead.

See Also

Reference

XmlActivationService Class
ActivateInstallationLicenseFileAsync Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.ActivateInstallationLicenseFileAsync Method (String, Object)

XmlActivationServiceActivateInstallationLicenseFileAsync Method (String, Object)
Calls the ActivateInstallationLicenseFile web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ActivateInstallationLicenseFileAsync(
    string xml,
    Object userState
)
Public Sub ActivateInstallationLicenseFileAsync (
    xml As String,
    userState As Object
)
public:
void ActivateInstallationLicenseFileAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the ActivateInstallationLicenseFile class instead.

See Also

Reference

XmlActivationService Class
ActivateInstallationLicenseFileAsync Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.CancelAsync Method

XmlActivationServiceCancelAsync Method
Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CancelAsync(
    Object userState
)
Public Sub CancelAsync (
    userState As Object
)
public:
void CancelAsync(
    Object^ userState
)

Parameters

userState
Type: SystemObject
The user state Object.
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.CheckInstallationStatus Method

XmlActivationServiceCheckInstallationStatus Method
Calls the CheckInstallationStatus web method.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode CheckInstallationStatus(
    string xml
)
Public Function CheckInstallationStatus (
    xml As String
) As XmlNode
public:
XmlNode^ CheckInstallationStatus(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CheckInstallationStatus class instead.

See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.CheckInstallationStatusAsync Method

XmlActivationServiceCheckInstallationStatusAsync Method
Overload List
 | Name | Description
Public method | CheckInstallationStatusAsync(String) | Calls the CheckInstallationStatus web method asynchronously.
Public method | CheckInstallationStatusAsync(String, Object) | Calls the CheckInstallationStatus web method.
Top
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.CheckInstallationStatusAsync Method (String)

XmlActivationServiceCheckInstallationStatusAsync Method (String)
Calls the CheckInstallationStatus web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CheckInstallationStatusAsync(
    string xml
)
Public Sub CheckInstallationStatusAsync (
    xml As String
)
public:
void CheckInstallationStatusAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CheckInstallationStatus class instead.

See Also

Reference

XmlActivationService Class
CheckInstallationStatusAsync Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.CheckInstallationStatusAsync Method (String, Object)

XmlActivationServiceCheckInstallationStatusAsync Method (String, Object)
Calls the CheckInstallationStatus web method.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CheckInstallationStatusAsync(
    string xml,
    Object userState
)
Public Sub CheckInstallationStatusAsync (
    xml As String,
    userState As Object
)
public:
void CheckInstallationStatusAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CheckInstallationStatus class instead.

See Also

Reference

XmlActivationService Class
CheckInstallationStatusAsync Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.DeactivateInstallation Method

XmlActivationServiceDeactivateInstallation Method
Calls the DeactivateInstallation web method.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode DeactivateInstallation(
    string xml
)
Public Function DeactivateInstallation (
    xml As String
) As XmlNode
public:
XmlNode^ DeactivateInstallation(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the DeactivateInstallation class instead.

See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.DeactivateInstallationAsync Method

XmlActivationServiceDeactivateInstallationAsync Method
Overload List
 | Name | Description
Public method | DeactivateInstallationAsync(String) | Calls the DeactivateInstallation web method asynchronously.
Public method | DeactivateInstallationAsync(String, Object) | Calls the DeactivateInstallation web method asynchronously.
Top
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.DeactivateInstallationAsync Method (String)

XmlActivationServiceDeactivateInstallationAsync Method (String)
Calls the DeactivateInstallation web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void DeactivateInstallationAsync(
    string xml
)
Public Sub DeactivateInstallationAsync (
    xml As String
)
public:
void DeactivateInstallationAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the DeactivateInstallation class instead.

See Also

Reference

XmlActivationService Class
DeactivateInstallationAsync Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.DeactivateInstallationAsync Method (String, Object)

XmlActivationServiceDeactivateInstallationAsync Method (String, Object)
Calls the DeactivateInstallation web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void DeactivateInstallationAsync(
    string xml,
    Object userState
)
Public Sub DeactivateInstallationAsync (
    xml As String,
    userState As Object
)
public:
void DeactivateInstallationAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the DeactivateInstallation class instead.

See Also

Reference

XmlActivationService Class
DeactivateInstallationAsync Overload
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService Events

XmlActivationService Events

The XmlActivationService type exposes the following members.

Events
 | Name | Description
Public event | ActivateInstallationCompleted | Occurs when a call to ActivateInstallation(String) has completed.
Public event | ActivateInstallationLicenseFileCompleted | Occurs when a call to ActivateInstallationLicenseFile(String) has completed.
Public event | CheckInstallationStatusCompleted | Occurs when a call to CheckInstallationStatus(String) has completed.
Public event | DeactivateInstallationCompleted | Occurs when a call to DeactivateInstallation(String) has completed.
Public event | Disposed | (Inherited from Component.)
Top
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.ActivateInstallationCompleted Event

XmlActivationServiceActivateInstallationCompleted Event
Occurs when a call to ActivateInstallation(String) has completed.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event ActivateInstallationCompletedEventHandler ActivateInstallationCompleted
Public Event ActivateInstallationCompleted As ActivateInstallationCompletedEventHandler
public:
 event ActivateInstallationCompletedEventHandler^ ActivateInstallationCompleted {
    void add (ActivateInstallationCompletedEventHandler^ value);
    void remove (ActivateInstallationCompletedEventHandler^ value);
}

Value

Type: ActivateInstallationCompletedEventHandler
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.ActivateInstallationLicenseFileCompleted Event

XmlActivationServiceActivateInstallationLicenseFileCompleted Event
Occurs when a call to ActivateInstallationLicenseFile(String) has completed.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event ActivateInstallationLicenseFileCompletedEventHandler ActivateInstallationLicenseFileCompleted
Public Event ActivateInstallationLicenseFileCompleted As ActivateInstallationLicenseFileCompletedEventHandler
public:
 event ActivateInstallationLicenseFileCompletedEventHandler^ ActivateInstallationLicenseFileCompleted {
    void add (ActivateInstallationLicenseFileCompletedEventHandler^ value);
    void remove (ActivateInstallationLicenseFileCompletedEventHandler^ value);
}

Value

Type: ActivateInstallationLicenseFileCompletedEventHandler
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.CheckInstallationStatusCompleted Event

XmlActivationServiceCheckInstallationStatusCompleted Event
Occurs when a call to CheckInstallationStatus(String) has completed.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event CheckInstallationStatusCompletedEventHandler CheckInstallationStatusCompleted
Public Event CheckInstallationStatusCompleted As CheckInstallationStatusCompletedEventHandler
public:
 event CheckInstallationStatusCompletedEventHandler^ CheckInstallationStatusCompleted {
    void add (CheckInstallationStatusCompletedEventHandler^ value);
    void remove (CheckInstallationStatusCompletedEventHandler^ value);
}

Value

Type: CheckInstallationStatusCompletedEventHandler
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


XmlActivationService.DeactivateInstallationCompleted Event

XmlActivationServiceDeactivateInstallationCompleted Event
Occurs when a call to DeactivateInstallation(String) has completed.

Namespace: com.softwarekey.Client.WebService.XmlActivationService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event DeactivateInstallationCompletedEventHandler DeactivateInstallationCompleted
Public Event DeactivateInstallationCompleted As DeactivateInstallationCompletedEventHandler
public:
 event DeactivateInstallationCompletedEventHandler^ DeactivateInstallationCompleted {
    void add (DeactivateInstallationCompletedEventHandler^ value);
    void remove (DeactivateInstallationCompletedEventHandler^ value);
}

Value

Type: DeactivateInstallationCompletedEventHandler
See Also

Reference

XmlActivationService Class
com.softwarekey.Client.WebService.XmlActivationService Namespace


com.softwarekey.Client.WebService.XmlLicenseFileService Namespace

com.softwarekey.Client.WebService.XmlLicenseFileService Namespace
Contains classes and data for making calls to the XmlLicenseFileService web service.
Classes
 | Class | Description
Public class | GetLicenseFile | Implements the XmlLicenseFileService web service's GetLicenseFile method to validate the status of an Installation ID.
Public class | XmlLicenseFileService | SoapHttpClientProtocol implementation for calling methods in SOLO Server's XmlLicenseFileService web service.


GetLicenseFile Class

GetLicenseFile Class
Implements the XmlLicenseFileService web service's GetLicenseFile method to validate the status of an Installation ID.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlLicenseFileServiceGetLicenseFile

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class GetLicenseFile : WebServiceCall
Public Class GetLicenseFile
    Inherits WebServiceCall
public ref class GetLicenseFile : public WebServiceCall

The GetLicenseFile type exposes the following members.

Constructors
 | Name | Description
Public method | GetLicenseFile(AuthorEncryptionKey) | GetLicenseFile Constructor - Accepts a pre-initialized AuthorEncryptionKey
Public method | GetLicenseFile(XmlLicenseFileService, AuthorEncryptionKey) | GetLicenseFile Constructor - Accepts a pre-initialized AuthorEncryptionKey
Top
Properties
 | Name | Description
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | InstallationID | Installation ID
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseFileContents | License file contents
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | ProductVersion | Product Version (Optional - must be formatted like x.x.x.x)
Public property | ProductVersionNumber | Product Version (Optional - this is the same as the ProductVersion property, but uses the System.Version class to create the ProductVersion string)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for GetLicenseFile calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response XmlNode (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

The XmlLicenseFileService documentation should be referenced for the most current information.

Caution note Caution

If you wish to call these web services for PLUSManaged License implementations, we recommend you use the License.RefreshLicense method, which implements this call for you.

Caution note Caution

Any Product Options in SOLO Server which you intend to use when issuing License IDs which will be validated with this method must have the "Issue Installation ID" option enabled, and must be activated with ActivateInstallation or ActivateInstallationLicenseFile. Please refer to the SOLO Server manual for details.

Note Note

Before calling the CallWebService method, the InstallationID property must be set.

Examples
This example shows how to make a typical license refresh call for a Protection PLUS 5 license:
C#
VB
C++
Copy
public bool DownloadLicenseFile(AuthorEncryptionKey encryptionKey,
    string installationId, ref LicenseError lastError)
{
    //make sure we have an Installation ID to use first
    if (string.IsNullOrEmpty(installationId))
    {
        lastError = new LicenseError(LicenseError.ERROR_INSTALLATIONID_REQUIRED);
        return false;
    }

    GetLicenseFile ws = new GetLicenseFile(encryptionKey);
    ws.InstallationID = installationId;

    XmlLicenseFileService client = new XmlLicenseFileService();
    // If you are using Instant SOLO Server Dedicated URL or a self-hosted instance of SOLO Server,
    // set the client.Url property here.  You may also configure proxy settings on this object here, if necessary.
    ws.WebServiceClient = client;

    if (!ws.CallWebService())
    {
        //If you wish to revoke the local license when web-based validation fails, you can add code to do so here.
        lastError = ws.LastError;
        return false;
    }

    return true;
}
Public Function DownloadLicenseFile(ByVal encryptionKey As AuthorEncryptionKey, _
    ByVal installationId As String, ByRef lastError As LicenseError) As Boolean

    //make sure we have an Installation ID to use first
    If String.IsNullOrEmpty(installationId) Then
        lastError = new LicenseError(LicenseError.ERROR_INSTALLATIONID_REQUIRED)
        Return False
    End If

    Dim ws As New GetLicenseFile(encryptionKey)
    ws.InstallationID = installationId

    Dim client As New XmlLicenseFileService()
    'If you are using Instant SOLO Server Dedicated URL or a self-hosted instance of SOLO Server,
    ' set the client.Url property here.  You may also configure proxy settings on this object here, if necessary.
    ws.WebServiceClient = client

    If Not ws.CallWebService() Then
        'If you wish to revoke the local license when web-based validation fails, you can add code to do so here.
        lastError = ws.LastError
        Return False
    End If

    Return True
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile Constructor

GetLicenseFile Constructor
Overload List
 | Name | Description
Public method | GetLicenseFile(AuthorEncryptionKey) | GetLicenseFile Constructor - Accepts a pre-initialized AuthorEncryptionKey
Public method | GetLicenseFile(XmlLicenseFileService, AuthorEncryptionKey) | GetLicenseFile Constructor - Accepts a pre-initialized AuthorEncryptionKey
Top
See Also

Reference

GetLicenseFile Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile Constructor (AuthorEncryptionKey)

GetLicenseFile Constructor (AuthorEncryptionKey)
GetLicenseFile Constructor - Accepts a pre-initialized AuthorEncryptionKey

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public GetLicenseFile(
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey
)
public:
GetLicenseFile(
    AuthorEncryptionKey^ encryptionKey
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
AuthorEncryptionKey
See Also

Reference

GetLicenseFile Class
GetLicenseFile Overload
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile Constructor (XmlLicenseFileService, AuthorEncryptionKey)

GetLicenseFile Constructor (XmlLicenseFileService, AuthorEncryptionKey)
GetLicenseFile Constructor - Accepts a pre-initialized AuthorEncryptionKey

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public GetLicenseFile(
    XmlLicenseFileService client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    client As XmlLicenseFileService,
    encryptionKey As AuthorEncryptionKey
)
public:
GetLicenseFile(
    XmlLicenseFileService^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlLicenseFileServiceXmlLicenseFileService
XmlActivationService
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
AuthorEncryptionKey
See Also

Reference

GetLicenseFile Class
GetLicenseFile Overload
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile Properties

GetLicenseFile Properties

The GetLicenseFile type exposes the following members.

Properties
 | Name | Description
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | InstallationID | Installation ID
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseFileContents | License file contents
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | ProductVersion | Product Version (Optional - must be formatted like x.x.x.x)
Public property | ProductVersionNumber | Product Version (Optional - this is the same as the ProductVersion property, but uses the System.Version class to create the ProductVersion string)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

GetLicenseFile Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile.InstallationID Property

GetLicenseFileInstallationID Property
Installation ID

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InstallationID { get; set; }
Public Property InstallationID As String
    Get
    Set
public:
property String^ InstallationID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GetLicenseFile Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile.LicenseFileContents Property

GetLicenseFileLicenseFileContents Property
License file contents

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseFileContents { get; set; }
Public Property LicenseFileContents As String
    Get
    Set
public:
property String^ LicenseFileContents {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GetLicenseFile Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile.ProductVersion Property

GetLicenseFileProductVersion Property
Product Version (Optional - must be formatted like x.x.x.x)

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProductVersion { get; set; }
Public Property ProductVersion As String
    Get
    Set
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GetLicenseFile Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile.ProductVersionNumber Property

GetLicenseFileProductVersionNumber Property
Product Version (Optional - this is the same as the ProductVersion property, but uses the System.Version class to create the ProductVersion string)

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Version ProductVersionNumber { get; set; }
Public Property ProductVersionNumber As Version
    Get
    Set
public:
property Version^ ProductVersionNumber {
    Version^ get ();
    void set (Version^ value);
}

Property Value

Type: Version
See Also

Reference

GetLicenseFile Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile Methods

GetLicenseFile Methods

The GetLicenseFile type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for GetLicenseFile calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response XmlNode (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

GetLicenseFile Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile.GeneratePlainTextRequest Method

GetLicenseFileGeneratePlainTextRequest Method
Generates a plain-text XML request string for GetLicenseFile calls

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string GeneratePlainTextRequest()
Public Overrides Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() override

Return Value

Type: String
string

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

GetLicenseFile Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile.ProcessResponse Method

GetLicenseFileProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response XmlNode (Overrides WebServiceCallProcessResponse(XmlNode).)
Top
See Also

Reference

GetLicenseFile Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


GetLicenseFile.ProcessResponse Method (XmlNode)

GetLicenseFileProcessResponse Method (XmlNode)
Processes a response XmlNode

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessResponse(
    ref XmlNode response
)
Public Overrides Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
) override

Parameters

response
Type: System.XmlXmlNode
XmlNode

Return Value

Type: Boolean
bool

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

GetLicenseFile Class
ProcessResponse Overload
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService Class

XmlLicenseFileService Class
SoapHttpClientProtocol implementation for calling methods in SOLO Server's XmlLicenseFileService web service.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Web.Services.ProtocolsWebClientProtocol
System.Web.Services.ProtocolsHttpWebClientProtocol
System.Web.Services.ProtocolsSoapHttpClientProtocol
com.softwarekey.Client.WebService.XmlLicenseFileServiceXmlLicenseFileService

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class XmlLicenseFileService : SoapHttpClientProtocol
Public Class XmlLicenseFileService
    Inherits SoapHttpClientProtocol
public ref class XmlLicenseFileService : public SoapHttpClientProtocol

The XmlLicenseFileService type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLicenseFileService | Creates a new XmlLicenseFileService object.
Top
Properties
 | Name | Description
Public property | AllowAutoRedirect | (Inherited from HttpWebClientProtocol.)
Protected property | CanRaiseEvents | (Inherited from Component.)
Public property | ClientCertificates | (Inherited from HttpWebClientProtocol.)
Public property | ConnectionGroupName | (Inherited from WebClientProtocol.)
Public property | Container | (Inherited from Component.)
Public property | CookieContainer | (Inherited from HttpWebClientProtocol.)
Public property | Credentials | (Inherited from WebClientProtocol.)
Protected property | DesignMode | (Inherited from Component.)
Public property | EnableDecompression | (Inherited from HttpWebClientProtocol.)
Protected property | Events | (Inherited from Component.)
Public property | PreAuthenticate | (Inherited from WebClientProtocol.)
Public property | Proxy | (Inherited from HttpWebClientProtocol.)
Public property | RequestEncoding | (Inherited from WebClientProtocol.)
Public property | Site | (Inherited from Component.)
Public property | SoapVersion | (Inherited from SoapHttpClientProtocol.)
Public property | Timeout | (Inherited from WebClientProtocol.)
Public property | UnsafeAuthenticatedConnectionSharing | (Inherited from HttpWebClientProtocol.)
Public property | Url | Gets or sets the base URL of the XML Web service the client is requesting.
Public property | UseDefaultCredentials | Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.
Public property | UserAgent | (Inherited from HttpWebClientProtocol.)
Top
Methods
 | Name | Description
Public method | Abort | (Inherited from WebClientProtocol.)
Protected method | BeginInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | CancelAsync | Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Public method | Discover | (Inherited from SoapHttpClientProtocol.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from Component.)
Protected method | EndInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLicenseFile | Calls the GetLicenseFile web method.
Public method | GetLicenseFileAsync(String) | Calls the GetLicenseFile web method asynchronously.
Public method | GetLicenseFileAsync(String, Object) | Calls the GetLicenseFile web method.
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | GetReaderForMessage | (Inherited from SoapHttpClientProtocol.)
Protected method | GetService | (Inherited from Component.)
Public method | GetType | (Inherited from Object.)
Protected method | GetWebRequest | (Inherited from SoapHttpClientProtocol.)
Protected method | GetWebResponse(WebRequest) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWebResponse(WebRequest, IAsyncResult) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWriterForMessage | (Inherited from SoapHttpClientProtocol.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | Invoke | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback) | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback, Object) | (Inherited from SoapHttpClientProtocol.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Public method | ToString | (Inherited from Component.)
Top
Events
 | Name | Description
Public event | Disposed | (Inherited from Component.)
Public event | GetLicenseFileCompleted | Occurs when an asynchronous call to GetLicenseFile has completed.
Top
Remarks
Note Note

This class should only be used directly as needed for specifying customized information, such as different end-point URLs, proxy server access credentials, etc... The com.softwarekey.Client.WebService.XmlLicenseFileService namespace contains WebServiceCall implementations for each supported web service method.

See Also

Reference

com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService Constructor

XmlLicenseFileService Constructor
Creates a new XmlLicenseFileService object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlLicenseFileService()
Public Sub New
public:
XmlLicenseFileService()
See Also

Reference

XmlLicenseFileService Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService Properties

XmlLicenseFileService Properties

The XmlLicenseFileService type exposes the following members.

Properties
 | Name | Description
Public property | AllowAutoRedirect | (Inherited from HttpWebClientProtocol.)
Protected property | CanRaiseEvents | (Inherited from Component.)
Public property | ClientCertificates | (Inherited from HttpWebClientProtocol.)
Public property | ConnectionGroupName | (Inherited from WebClientProtocol.)
Public property | Container | (Inherited from Component.)
Public property | CookieContainer | (Inherited from HttpWebClientProtocol.)
Public property | Credentials | (Inherited from WebClientProtocol.)
Protected property | DesignMode | (Inherited from Component.)
Public property | EnableDecompression | (Inherited from HttpWebClientProtocol.)
Protected property | Events | (Inherited from Component.)
Public property | PreAuthenticate | (Inherited from WebClientProtocol.)
Public property | Proxy | (Inherited from HttpWebClientProtocol.)
Public property | RequestEncoding | (Inherited from WebClientProtocol.)
Public property | Site | (Inherited from Component.)
Public property | SoapVersion | (Inherited from SoapHttpClientProtocol.)
Public property | Timeout | (Inherited from WebClientProtocol.)
Public property | UnsafeAuthenticatedConnectionSharing | (Inherited from HttpWebClientProtocol.)
Public property | Url | Gets or sets the base URL of the XML Web service the client is requesting.
Public property | UseDefaultCredentials | Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.
Public property | UserAgent | (Inherited from HttpWebClientProtocol.)
Top
See Also

Reference

XmlLicenseFileService Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService.Url Property

XmlLicenseFileServiceUrl Property
Gets or sets the base URL of the XML Web service the client is requesting.

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

XmlLicenseFileService Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService.UseDefaultCredentials Property

XmlLicenseFileServiceUseDefaultCredentials Property
Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool UseDefaultCredentials { get; set; }
Public Property UseDefaultCredentials As Boolean
    Get
    Set
public:
property bool UseDefaultCredentials {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

XmlLicenseFileService Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService Methods

XmlLicenseFileService Methods

The XmlLicenseFileService type exposes the following members.

Methods
 | Name | Description
Public method | Abort | (Inherited from WebClientProtocol.)
Protected method | BeginInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | CancelAsync | Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Public method | Discover | (Inherited from SoapHttpClientProtocol.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from Component.)
Protected method | EndInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLicenseFile | Calls the GetLicenseFile web method.
Public method | GetLicenseFileAsync(String) | Calls the GetLicenseFile web method asynchronously.
Public method | GetLicenseFileAsync(String, Object) | Calls the GetLicenseFile web method.
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | GetReaderForMessage | (Inherited from SoapHttpClientProtocol.)
Protected method | GetService | (Inherited from Component.)
Public method | GetType | (Inherited from Object.)
Protected method | GetWebRequest | (Inherited from SoapHttpClientProtocol.)
Protected method | GetWebResponse(WebRequest) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWebResponse(WebRequest, IAsyncResult) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWriterForMessage | (Inherited from SoapHttpClientProtocol.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | Invoke | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback) | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback, Object) | (Inherited from SoapHttpClientProtocol.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Public method | ToString | (Inherited from Component.)
Top
See Also

Reference

XmlLicenseFileService Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService.CancelAsync Method

XmlLicenseFileServiceCancelAsync Method
Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CancelAsync(
    Object userState
)
Public Sub CancelAsync (
    userState As Object
)
public:
void CancelAsync(
    Object^ userState
)

Parameters

userState
Type: SystemObject
The user state Object.
See Also

Reference

XmlLicenseFileService Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService.GetLicenseFile Method

XmlLicenseFileServiceGetLicenseFile Method
Calls the GetLicenseFile web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode GetLicenseFile(
    string xml
)
Public Function GetLicenseFile (
    xml As String
) As XmlNode
public:
XmlNode^ GetLicenseFile(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the GetLicenseFile class instead.

See Also

Reference

XmlLicenseFileService Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService.GetLicenseFileAsync Method

XmlLicenseFileServiceGetLicenseFileAsync Method
Overload List
 | Name | Description
Public method | GetLicenseFileAsync(String) | Calls the GetLicenseFile web method asynchronously.
Public method | GetLicenseFileAsync(String, Object) | Calls the GetLicenseFile web method.
Top
See Also

Reference

XmlLicenseFileService Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService.GetLicenseFileAsync Method (String)

XmlLicenseFileServiceGetLicenseFileAsync Method (String)
Calls the GetLicenseFile web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void GetLicenseFileAsync(
    string xml
)
Public Sub GetLicenseFileAsync (
    xml As String
)
public:
void GetLicenseFileAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the GetLicenseFile class instead.

See Also

Reference

XmlLicenseFileService Class
GetLicenseFileAsync Overload
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService.GetLicenseFileAsync Method (String, Object)

XmlLicenseFileServiceGetLicenseFileAsync Method (String, Object)
Calls the GetLicenseFile web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void GetLicenseFileAsync(
    string xml,
    Object userState
)
Public Sub GetLicenseFileAsync (
    xml As String,
    userState As Object
)
public:
void GetLicenseFileAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the GetLicenseFile class instead.

See Also

Reference

XmlLicenseFileService Class
GetLicenseFileAsync Overload
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService Events

XmlLicenseFileService Events

The XmlLicenseFileService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | (Inherited from Component.)
Public event | GetLicenseFileCompleted | Occurs when an asynchronous call to GetLicenseFile has completed.
Top
See Also

Reference

XmlLicenseFileService Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


XmlLicenseFileService.GetLicenseFileCompleted Event

XmlLicenseFileServiceGetLicenseFileCompleted Event
Occurs when an asynchronous call to GetLicenseFile has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseFileService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event GetLicenseFileCompletedEventHandler GetLicenseFileCompleted
Public Event GetLicenseFileCompleted As GetLicenseFileCompletedEventHandler
public:
 event GetLicenseFileCompletedEventHandler^ GetLicenseFileCompleted {
    void add (GetLicenseFileCompletedEventHandler^ value);
    void remove (GetLicenseFileCompletedEventHandler^ value);
}

Value

Type: GetLicenseFileCompletedEventHandler
See Also

Reference

XmlLicenseFileService Class
com.softwarekey.Client.WebService.XmlLicenseFileService Namespace


com.softwarekey.Client.WebService.XmlLicenseService Namespace

com.softwarekey.Client.WebService.XmlLicenseService Namespace
Contains classes and data for making calls to the XmlLicenseService web service.
Classes
 | Class | Description
Public class | InfoCheck | Implements the XmlLicenseService web service's InfoCheck method to retrieve and check license information.
Public class | Register | Implements the XmlLicenseService web service's Register method to update customer registration information.
Public class | UpdateCheck | Implements the XmlLicenseService web service's UpdateCheck method to check for product or application updates.
Public class | UpdateRegistration | Implements the XmlLicenseService web service's UpdateRegistration method to update customer registration information.
Public class | ValidateRegistration | Implements the XmlLicenseService web service's ValidateRegistration method to retrieve and check customer registration information.
Public class | XmlLicenseService | SoapHttpClientProtocol implementation for calling methods in SOLO Server's XmlActivationService web service.
Enumerations
 | Enumeration | Description
Public enumeration | UpdateCheckUpdateAction | Possible actions to take, as indicated by UpdateCheck responses.


InfoCheck Class

InfoCheck Class
Implements the XmlLicenseService web service's InfoCheck method to retrieve and check license information.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlLicenseServiceInfoCheck

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class InfoCheck : WebServiceCall
Public Class InfoCheck
    Inherits WebServiceCall
public ref class InfoCheck : public WebServiceCall

The InfoCheck type exposes the following members.

Constructors
 | Name | Description
Public method | InfoCheck | Creates a new InfoCheck object.
Public method | InfoCheck(XmlLicenseService) | Creates a new InfoCheck object with a specified web service client (XmlLicenseService) object.
Top
Properties
 | Name | Description
Public property | Address1 | Gets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets the customer's second address line (i.e. apartment or suite number).
Public property | City | Gets the city of the customer's address.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Company | Gets the customer's company name.
Public property | Country | Gets the country of the customer's address.
Public property | CurrentVersion | Gets the Current Version of the License ID.
Public property | CustomerID | Gets the Customer ID, which uniquely identifies the customer to which this License ID belongs.
Public property | DownloadExpiration | Gets the date in which the license and/or download will expire.
Public property | Email | Gets the customer's email address.
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | EnteredDate | Gets the date in which the license was created in SOLO Server.
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | Fax | Gets the customer's fax number.
Public property | FirstName | Gets the customer's first name.
Public property | InvoiceNo | Gets the Invoice Number for the License ID.
Public property | IsTestLicense | Gets whether the license is a test license.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LastName | Gets the customer's last name.
Public property | LatestVersion | Gets the latest, free version available.
Public property | LicenseCounter | Gets the License Counter field.
Public property | LicenseeEmail | Gets the licensee's email address.
Public property | LicenseeName | Gets the name of the licensee.
Public property | LicenseID | Gets or sets the License ID.
Public property | LicenseStatus | Gets the status of the SOLO Server License ID.
Public property | LicenseUpdate | Gets the License Update data for the License ID.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | OptionName | Gets the name of the Product Option.
Public property | Password | Gets or sets the password (optional). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.
Public property | Phone | Gets the customer's phone number.
Public property | PostalCode | Gets the customer's zip/postal code.
Public property | ProdOptionID | Gets the Product Option ID with which the License ID was created.
Public property | ProductID | Gets or sets the Product ID to which the License ID belongs (optional, recommended).
Public property | ProductName | Gets the product name in SOLO Server.
Public property | Quantity | Gets the quantity ordered.
Public property | RemainingActivations | Gets the number of activations remaining for this License ID.
Public property | RemainingDeactivations | Gets the number of deactivations remaining for this License ID.
Public property | ReplacedBy | Gets the License ID of the license which has replaced this LicenseID (typically used to indicate the License ID of an upgrade license).
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | StateProvince | Gets the state/province of the customer's address.
Public property | TCFixedValue | Gets the Trigger Code Fixed Value (or "TC Fixed Value") parameter from the product option.
Public property | UDefChar1 | Gets the user-defined string field 1 (UDefChar1) data.
Public property | UDefChar10 | Gets the user-defined string field 10 (UDefChar10) data.
Public property | UDefChar2 | Gets the user-defined string field 2 (UDefChar2) data.
Public property | UDefChar3 | Gets the user-defined string field 3 (UDefChar3) data.
Public property | UDefChar4 | Gets the user-defined string field 4 (UDefChar4) data.
Public property | UDefChar5 | Gets the user-defined string field 5 (UDefChar5) data.
Public property | UDefChar6 | Gets the user-defined string field 6 (UDefChar6) data.
Public property | UDefChar7 | Gets the user-defined string field 7 (UDefChar7) data.
Public property | UDefChar8 | Gets the user-defined string field 8 (UDefChar8) data.
Public property | UDefChar9 | Gets the user-defined string field 9 (UDefChar9) data.
Public property | UDefDate1 | Gets the user-defined date-time field 1 (UDefDate1) data.
Public property | UDefDate2 | Gets the user-defined date-time field 2 (UDefDate2) data.
Public property | UDefDate3 | Gets the user-defined date-time field 3 (UDefDate3) data.
Public property | UDefDate4 | Gets the user-defined date-time field 4 (UDefDate4) data.
Public property | UDefDate5 | Gets the user-defined date-time field 5 (UDefDate5) data.
Public property | UDefFloat1 | Gets the user-defined float field 1 (UDefFloat1) data.
Public property | UDefFloat2 | Gets the user-defined float field 2 (UDefFloat2) data.
Public property | UDefFloat3 | Gets the user-defined float field 3 (UDefFloat3) data.
Public property | UDefFloat4 | Gets the user-defined float field 4 (UDefFloat4) data.
Public property | UDefFloat5 | Gets the user-defined float field 5 (UDefFloat5) data.
Public property | UDefNum1 | Gets the user-defined number field 1 (UDefNum1) data.
Public property | UDefNum2 | Gets the user-defined number field 2 (UDefNum2) data.
Public property | UDefNum3 | Gets the user-defined number field 3 (UDefNum3) data.
Public property | UDefNum4 | Gets the user-defined number field 4 (UDefNum4) data.
Public property | UDefNum5 | Gets the user-defined number field 5 (UDefNum5) data.
Public property | UseDigitalSignature | Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures. (Overrides WebServiceCallUseDigitalSignature.)
Public property | UseEncryption | Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption. (Overrides WebServiceCallUseEncryption.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for InfoCheck calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

The XmlLicenseService documentation should be referenced for the most current information.

Note Note

Before calling the CallWebService method, the LicenseID property must be set. The Password and ProductID properties may optionally be set before calling the CallWebService method for extra validation. Setting the Password field will also afford you access to additional data in the results, including customer registration data and user-defined data.

Examples
This example shows how to make a typical InfoCheck call:
C#
VB
C++
Copy
public bool CheckLicenseInformation(int licenseID, string password, int productID)
{
    InfoCheck infoChecker = new InfoCheck();
    infoChecker.LicenseID = licenseID;
    infoChecker.Password = password;
    infoChecker.ProductID = productID;

    if (!infoChecker.CallWebService())
    {
        //TODO: check the LastError property and add error reporting here!
        return false;
    }

    //TODO: Add your custom logic here!

    return true;
}
Public Function CheckLicenseInformation(ByVal licenseID As Integer, ByVal password As String, ByVal productID As Integer) As Boolean
    Dim infoChecker As New InfoCheck()
    infoChecker.LicenseID = licenseID
    infoChecker.Password = password
    infoChecker.ProductID = productID

    If Not infoChecker.CallWebService() Then
        'TODO: check the LastError property and add error reporting here!
        Return False
    End If

    'TODO: Add your custom logic here!

    Return True
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck Constructor

InfoCheck Constructor
Overload List
 | Name | Description
Public method | InfoCheck | Creates a new InfoCheck object.
Public method | InfoCheck(XmlLicenseService) | Creates a new InfoCheck object with a specified web service client (XmlLicenseService) object.
Top
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck Constructor

InfoCheck Constructor
Creates a new InfoCheck object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public InfoCheck()
Public Sub New
public:
InfoCheck()
See Also

Reference

InfoCheck Class
InfoCheck Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck Constructor (XmlLicenseService)

InfoCheck Constructor (XmlLicenseService)
Creates a new InfoCheck object with a specified web service client (XmlLicenseService) object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public InfoCheck(
    XmlLicenseService client
)
Public Sub New (
    client As XmlLicenseService
)
public:
InfoCheck(
    XmlLicenseService^ client
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlLicenseServiceXmlLicenseService
The XmlLicenseService, web service client object, which may be initialized with a different URL and/or proxy server information.
See Also

Reference

InfoCheck Class
InfoCheck Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck Properties

InfoCheck Properties

The InfoCheck type exposes the following members.

Properties
 | Name | Description
Public property | Address1 | Gets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets the customer's second address line (i.e. apartment or suite number).
Public property | City | Gets the city of the customer's address.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Company | Gets the customer's company name.
Public property | Country | Gets the country of the customer's address.
Public property | CurrentVersion | Gets the Current Version of the License ID.
Public property | CustomerID | Gets the Customer ID, which uniquely identifies the customer to which this License ID belongs.
Public property | DownloadExpiration | Gets the date in which the license and/or download will expire.
Public property | Email | Gets the customer's email address.
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | EnteredDate | Gets the date in which the license was created in SOLO Server.
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | Fax | Gets the customer's fax number.
Public property | FirstName | Gets the customer's first name.
Public property | InvoiceNo | Gets the Invoice Number for the License ID.
Public property | IsTestLicense | Gets whether the license is a test license.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LastName | Gets the customer's last name.
Public property | LatestVersion | Gets the latest, free version available.
Public property | LicenseCounter | Gets the License Counter field.
Public property | LicenseeEmail | Gets the licensee's email address.
Public property | LicenseeName | Gets the name of the licensee.
Public property | LicenseID | Gets or sets the License ID.
Public property | LicenseStatus | Gets the status of the SOLO Server License ID.
Public property | LicenseUpdate | Gets the License Update data for the License ID.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | OptionName | Gets the name of the Product Option.
Public property | Password | Gets or sets the password (optional). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.
Public property | Phone | Gets the customer's phone number.
Public property | PostalCode | Gets the customer's zip/postal code.
Public property | ProdOptionID | Gets the Product Option ID with which the License ID was created.
Public property | ProductID | Gets or sets the Product ID to which the License ID belongs (optional, recommended).
Public property | ProductName | Gets the product name in SOLO Server.
Public property | Quantity | Gets the quantity ordered.
Public property | RemainingActivations | Gets the number of activations remaining for this License ID.
Public property | RemainingDeactivations | Gets the number of deactivations remaining for this License ID.
Public property | ReplacedBy | Gets the License ID of the license which has replaced this LicenseID (typically used to indicate the License ID of an upgrade license).
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | StateProvince | Gets the state/province of the customer's address.
Public property | TCFixedValue | Gets the Trigger Code Fixed Value (or "TC Fixed Value") parameter from the product option.
Public property | UDefChar1 | Gets the user-defined string field 1 (UDefChar1) data.
Public property | UDefChar10 | Gets the user-defined string field 10 (UDefChar10) data.
Public property | UDefChar2 | Gets the user-defined string field 2 (UDefChar2) data.
Public property | UDefChar3 | Gets the user-defined string field 3 (UDefChar3) data.
Public property | UDefChar4 | Gets the user-defined string field 4 (UDefChar4) data.
Public property | UDefChar5 | Gets the user-defined string field 5 (UDefChar5) data.
Public property | UDefChar6 | Gets the user-defined string field 6 (UDefChar6) data.
Public property | UDefChar7 | Gets the user-defined string field 7 (UDefChar7) data.
Public property | UDefChar8 | Gets the user-defined string field 8 (UDefChar8) data.
Public property | UDefChar9 | Gets the user-defined string field 9 (UDefChar9) data.
Public property | UDefDate1 | Gets the user-defined date-time field 1 (UDefDate1) data.
Public property | UDefDate2 | Gets the user-defined date-time field 2 (UDefDate2) data.
Public property | UDefDate3 | Gets the user-defined date-time field 3 (UDefDate3) data.
Public property | UDefDate4 | Gets the user-defined date-time field 4 (UDefDate4) data.
Public property | UDefDate5 | Gets the user-defined date-time field 5 (UDefDate5) data.
Public property | UDefFloat1 | Gets the user-defined float field 1 (UDefFloat1) data.
Public property | UDefFloat2 | Gets the user-defined float field 2 (UDefFloat2) data.
Public property | UDefFloat3 | Gets the user-defined float field 3 (UDefFloat3) data.
Public property | UDefFloat4 | Gets the user-defined float field 4 (UDefFloat4) data.
Public property | UDefFloat5 | Gets the user-defined float field 5 (UDefFloat5) data.
Public property | UDefNum1 | Gets the user-defined number field 1 (UDefNum1) data.
Public property | UDefNum2 | Gets the user-defined number field 2 (UDefNum2) data.
Public property | UDefNum3 | Gets the user-defined number field 3 (UDefNum3) data.
Public property | UDefNum4 | Gets the user-defined number field 4 (UDefNum4) data.
Public property | UDefNum5 | Gets the user-defined number field 5 (UDefNum5) data.
Public property | UseDigitalSignature | Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures. (Overrides WebServiceCallUseDigitalSignature.)
Public property | UseEncryption | Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption. (Overrides WebServiceCallUseEncryption.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.Address1 Property

InfoCheckAddress1 Property
Gets the customer's street address (or line 1 of the customer's address).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address1 { get; }
Public ReadOnly Property Address1 As String
    Get
public:
property String^ Address1 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.Address2 Property

InfoCheckAddress2 Property
Gets the customer's second address line (i.e. apartment or suite number).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address2 { get; }
Public ReadOnly Property Address2 As String
    Get
public:
property String^ Address2 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.City Property

InfoCheckCity Property
Gets the city of the customer's address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string City { get; }
Public ReadOnly Property City As String
    Get
public:
property String^ City {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.Company Property

InfoCheckCompany Property
Gets the customer's company name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Company { get; }
Public ReadOnly Property Company As String
    Get
public:
property String^ Company {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.Country Property

InfoCheckCountry Property
Gets the country of the customer's address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Country { get; }
Public ReadOnly Property Country As String
    Get
public:
property String^ Country {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.CurrentVersion Property

InfoCheckCurrentVersion Property
Gets the Current Version of the License ID.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CurrentVersion { get; }
Public ReadOnly Property CurrentVersion As String
    Get
public:
property String^ CurrentVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.CustomerID Property

InfoCheckCustomerID Property
Gets the Customer ID, which uniquely identifies the customer to which this License ID belongs.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int CustomerID { get; }
Public ReadOnly Property CustomerID As Integer
    Get
public:
property int CustomerID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.DownloadExpiration Property

InfoCheckDownloadExpiration Property
Gets the date in which the license and/or download will expire.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime DownloadExpiration { get; }
Public ReadOnly Property DownloadExpiration As DateTime
    Get
public:
property DateTime DownloadExpiration {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.Email Property

InfoCheckEmail Property
Gets the customer's email address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Email { get; }
Public ReadOnly Property Email As String
    Get
public:
property String^ Email {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.EnteredDate Property

InfoCheckEnteredDate Property
Gets the date in which the license was created in SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime EnteredDate { get; }
Public ReadOnly Property EnteredDate As DateTime
    Get
public:
property DateTime EnteredDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.Fax Property

InfoCheckFax Property
Gets the customer's fax number.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Fax { get; }
Public ReadOnly Property Fax As String
    Get
public:
property String^ Fax {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.FirstName Property

InfoCheckFirstName Property
Gets the customer's first name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string FirstName { get; }
Public ReadOnly Property FirstName As String
    Get
public:
property String^ FirstName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.InvoiceNo Property

InfoCheckInvoiceNo Property
Gets the Invoice Number for the License ID.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int InvoiceNo { get; }
Public ReadOnly Property InvoiceNo As Integer
    Get
public:
property int InvoiceNo {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.IsTestLicense Property

InfoCheckIsTestLicense Property
Gets whether the license is a test license.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool IsTestLicense { get; }
Public ReadOnly Property IsTestLicense As Boolean
    Get
public:
property bool IsTestLicense {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.LastName Property

InfoCheckLastName Property
Gets the customer's last name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LastName { get; }
Public ReadOnly Property LastName As String
    Get
public:
property String^ LastName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.LatestVersion Property

InfoCheckLatestVersion Property
Gets the latest, free version available.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LatestVersion { get; }
Public ReadOnly Property LatestVersion As String
    Get
public:
property String^ LatestVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.LicenseCounter Property

InfoCheckLicenseCounter Property
Gets the License Counter field.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseCounter { get; }
Public ReadOnly Property LicenseCounter As Integer
    Get
public:
property int LicenseCounter {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.LicenseeEmail Property

InfoCheckLicenseeEmail Property
Gets the licensee's email address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseeEmail { get; }
Public ReadOnly Property LicenseeEmail As String
    Get
public:
property String^ LicenseeEmail {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.LicenseeName Property

InfoCheckLicenseeName Property
Gets the name of the licensee.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseeName { get; }
Public ReadOnly Property LicenseeName As String
    Get
public:
property String^ LicenseeName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.LicenseID Property

InfoCheckLicenseID Property
Gets or sets the License ID.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks

If the License ID specified is not valid, or a bad Password is specified, then the result code returned by SOLO Server is 100.

See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.LicenseStatus Property

InfoCheckLicenseStatus Property
Gets the status of the SOLO Server License ID.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public WebServiceCallSOLOServerLicenseStatus LicenseStatus { get; }
Public ReadOnly Property LicenseStatus As WebServiceCallSOLOServerLicenseStatus
    Get
public:
property WebServiceCallSOLOServerLicenseStatus LicenseStatus {
    WebServiceCallSOLOServerLicenseStatus get ();
}

Property Value

Type: WebServiceCallSOLOServerLicenseStatus
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.LicenseUpdate Property

InfoCheckLicenseUpdate Property
Gets the License Update data for the License ID.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseUpdate { get; }
Public ReadOnly Property LicenseUpdate As String
    Get
public:
property String^ LicenseUpdate {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.OptionName Property

InfoCheckOptionName Property
Gets the name of the Product Option.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string OptionName { get; }
Public ReadOnly Property OptionName As String
    Get
public:
property String^ OptionName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.Password Property

InfoCheckPassword Property
Gets or sets the password (optional). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

When a value is specified, it will be validated by SOLO Server. When validation fails, the result code returned by SOLO Server is 100.

See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.Phone Property

InfoCheckPhone Property
Gets the customer's phone number.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Phone { get; }
Public ReadOnly Property Phone As String
    Get
public:
property String^ Phone {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.PostalCode Property

InfoCheckPostalCode Property
Gets the customer's zip/postal code.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string PostalCode { get; }
Public ReadOnly Property PostalCode As String
    Get
public:
property String^ PostalCode {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.ProdOptionID Property

InfoCheckProdOptionID Property
Gets the Product Option ID with which the License ID was created.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProdOptionID { get; }
Public ReadOnly Property ProdOptionID As Integer
    Get
public:
property int ProdOptionID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.ProductID Property

InfoCheckProductID Property
Gets or sets the Product ID to which the License ID belongs (optional, recommended).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; set; }
Public Property ProductID As Integer
    Get
    Set
public:
property int ProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks

When a value is specified, the Product ID will be validated against the License ID in SOLO Server. Otherwise, this extra validation is omitted when this property's value is 0 (zero). When validation fails, the result code returned by SOLO Server is 200.

See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.ProductName Property

InfoCheckProductName Property
Gets the product name in SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProductName { get; }
Public ReadOnly Property ProductName As String
    Get
public:
property String^ ProductName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.Quantity Property

InfoCheckQuantity Property
Gets the quantity ordered.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int Quantity { get; }
Public ReadOnly Property Quantity As Integer
    Get
public:
property int Quantity {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.RemainingActivations Property

InfoCheckRemainingActivations Property
Gets the number of activations remaining for this License ID.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int RemainingActivations { get; }
Public ReadOnly Property RemainingActivations As Integer
    Get
public:
property int RemainingActivations {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.RemainingDeactivations Property

InfoCheckRemainingDeactivations Property
Gets the number of deactivations remaining for this License ID.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int RemainingDeactivations { get; }
Public ReadOnly Property RemainingDeactivations As Integer
    Get
public:
property int RemainingDeactivations {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.ReplacedBy Property

InfoCheckReplacedBy Property
Gets the License ID of the license which has replaced this LicenseID (typically used to indicate the License ID of an upgrade license).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ReplacedBy { get; }
Public ReadOnly Property ReplacedBy As Integer
    Get
public:
property int ReplacedBy {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.StateProvince Property

InfoCheckStateProvince Property
Gets the state/province of the customer's address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string StateProvince { get; }
Public ReadOnly Property StateProvince As String
    Get
public:
property String^ StateProvince {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.TCFixedValue Property

InfoCheckTCFixedValue Property
Gets the Trigger Code Fixed Value (or "TC Fixed Value") parameter from the product option.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int TCFixedValue { get; }
Public ReadOnly Property TCFixedValue As Integer
    Get
public:
property int TCFixedValue {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefChar1 Property

InfoCheckUDefChar1 Property
Gets the user-defined string field 1 (UDefChar1) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UDefChar1 { get; }
Public ReadOnly Property UDefChar1 As String
    Get
public:
property String^ UDefChar1 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefChar10 Property

InfoCheckUDefChar10 Property
Gets the user-defined string field 10 (UDefChar10) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UDefChar10 { get; }
Public ReadOnly Property UDefChar10 As String
    Get
public:
property String^ UDefChar10 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefChar2 Property

InfoCheckUDefChar2 Property
Gets the user-defined string field 2 (UDefChar2) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UDefChar2 { get; }
Public ReadOnly Property UDefChar2 As String
    Get
public:
property String^ UDefChar2 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefChar3 Property

InfoCheckUDefChar3 Property
Gets the user-defined string field 3 (UDefChar3) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UDefChar3 { get; }
Public ReadOnly Property UDefChar3 As String
    Get
public:
property String^ UDefChar3 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefChar4 Property

InfoCheckUDefChar4 Property
Gets the user-defined string field 4 (UDefChar4) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UDefChar4 { get; }
Public ReadOnly Property UDefChar4 As String
    Get
public:
property String^ UDefChar4 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefChar5 Property

InfoCheckUDefChar5 Property
Gets the user-defined string field 5 (UDefChar5) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UDefChar5 { get; }
Public ReadOnly Property UDefChar5 As String
    Get
public:
property String^ UDefChar5 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefChar6 Property

InfoCheckUDefChar6 Property
Gets the user-defined string field 6 (UDefChar6) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UDefChar6 { get; }
Public ReadOnly Property UDefChar6 As String
    Get
public:
property String^ UDefChar6 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefChar7 Property

InfoCheckUDefChar7 Property
Gets the user-defined string field 7 (UDefChar7) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UDefChar7 { get; }
Public ReadOnly Property UDefChar7 As String
    Get
public:
property String^ UDefChar7 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefChar8 Property

InfoCheckUDefChar8 Property
Gets the user-defined string field 8 (UDefChar8) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UDefChar8 { get; }
Public ReadOnly Property UDefChar8 As String
    Get
public:
property String^ UDefChar8 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefChar9 Property

InfoCheckUDefChar9 Property
Gets the user-defined string field 9 (UDefChar9) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string UDefChar9 { get; }
Public ReadOnly Property UDefChar9 As String
    Get
public:
property String^ UDefChar9 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefDate1 Property

InfoCheckUDefDate1 Property
Gets the user-defined date-time field 1 (UDefDate1) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime UDefDate1 { get; }
Public ReadOnly Property UDefDate1 As DateTime
    Get
public:
property DateTime UDefDate1 {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefDate2 Property

InfoCheckUDefDate2 Property
Gets the user-defined date-time field 2 (UDefDate2) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime UDefDate2 { get; }
Public ReadOnly Property UDefDate2 As DateTime
    Get
public:
property DateTime UDefDate2 {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefDate3 Property

InfoCheckUDefDate3 Property
Gets the user-defined date-time field 3 (UDefDate3) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime UDefDate3 { get; }
Public ReadOnly Property UDefDate3 As DateTime
    Get
public:
property DateTime UDefDate3 {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefDate4 Property

InfoCheckUDefDate4 Property
Gets the user-defined date-time field 4 (UDefDate4) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime UDefDate4 { get; }
Public ReadOnly Property UDefDate4 As DateTime
    Get
public:
property DateTime UDefDate4 {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefDate5 Property

InfoCheckUDefDate5 Property
Gets the user-defined date-time field 5 (UDefDate5) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime UDefDate5 { get; }
Public ReadOnly Property UDefDate5 As DateTime
    Get
public:
property DateTime UDefDate5 {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefFloat1 Property

InfoCheckUDefFloat1 Property
Gets the user-defined float field 1 (UDefFloat1) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public decimal UDefFloat1 { get; }
Public ReadOnly Property UDefFloat1 As Decimal
    Get
public:
property Decimal UDefFloat1 {
    Decimal get ();
}

Property Value

Type: Decimal
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefFloat2 Property

InfoCheckUDefFloat2 Property
Gets the user-defined float field 2 (UDefFloat2) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public decimal UDefFloat2 { get; }
Public ReadOnly Property UDefFloat2 As Decimal
    Get
public:
property Decimal UDefFloat2 {
    Decimal get ();
}

Property Value

Type: Decimal
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefFloat3 Property

InfoCheckUDefFloat3 Property
Gets the user-defined float field 3 (UDefFloat3) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public decimal UDefFloat3 { get; }
Public ReadOnly Property UDefFloat3 As Decimal
    Get
public:
property Decimal UDefFloat3 {
    Decimal get ();
}

Property Value

Type: Decimal
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefFloat4 Property

InfoCheckUDefFloat4 Property
Gets the user-defined float field 4 (UDefFloat4) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public decimal UDefFloat4 { get; }
Public ReadOnly Property UDefFloat4 As Decimal
    Get
public:
property Decimal UDefFloat4 {
    Decimal get ();
}

Property Value

Type: Decimal
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefFloat5 Property

InfoCheckUDefFloat5 Property
Gets the user-defined float field 5 (UDefFloat5) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public decimal UDefFloat5 { get; }
Public ReadOnly Property UDefFloat5 As Decimal
    Get
public:
property Decimal UDefFloat5 {
    Decimal get ();
}

Property Value

Type: Decimal
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefNum1 Property

InfoCheckUDefNum1 Property
Gets the user-defined number field 1 (UDefNum1) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UDefNum1 { get; }
Public ReadOnly Property UDefNum1 As Integer
    Get
public:
property int UDefNum1 {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefNum2 Property

InfoCheckUDefNum2 Property
Gets the user-defined number field 2 (UDefNum2) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UDefNum2 { get; }
Public ReadOnly Property UDefNum2 As Integer
    Get
public:
property int UDefNum2 {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefNum3 Property

InfoCheckUDefNum3 Property
Gets the user-defined number field 3 (UDefNum3) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UDefNum3 { get; }
Public ReadOnly Property UDefNum3 As Integer
    Get
public:
property int UDefNum3 {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefNum4 Property

InfoCheckUDefNum4 Property
Gets the user-defined number field 4 (UDefNum4) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UDefNum4 { get; }
Public ReadOnly Property UDefNum4 As Integer
    Get
public:
property int UDefNum4 {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UDefNum5 Property

InfoCheckUDefNum5 Property
Gets the user-defined number field 5 (UDefNum5) data.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int UDefNum5 { get; }
Public ReadOnly Property UDefNum5 As Integer
    Get
public:
property int UDefNum5 {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UseDigitalSignature Property

InfoCheckUseDigitalSignature Property
Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool UseDigitalSignature { get; set; }
Public Overrides Property UseDigitalSignature As Boolean
    Get
    Set
public:
virtual property bool UseDigitalSignature {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.UseEncryption Property

InfoCheckUseEncryption Property
Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool UseEncryption { get; set; }
Public Overrides Property UseEncryption As Boolean
    Get
    Set
public:
virtual property bool UseEncryption {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck Methods

InfoCheck Methods

The InfoCheck type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for InfoCheck calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.GeneratePlainTextRequest Method

InfoCheckGeneratePlainTextRequest Method
Generates a plain-text XML request string for InfoCheck calls

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string GeneratePlainTextRequest()
Public Overrides Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() override

Return Value

Type: String
Returns a plain-text XML request string for InfoCheck calls.

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.ProcessResponse Method

InfoCheckProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Overrides WebServiceCallProcessResponse(XmlNode).)
Top
See Also

Reference

InfoCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


InfoCheck.ProcessResponse Method (XmlNode)

InfoCheckProcessResponse Method (XmlNode)

[Missing <summary> documentation for "M:com.softwarekey.Client.WebService.XmlLicenseService.InfoCheck.ProcessResponse(System.Xml.XmlNode@)"]

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessResponse(
    ref XmlNode response
)
Public Overrides Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
) override

Parameters

response
Type: System.XmlXmlNode
The XML formatted response.

Return Value

Type: Boolean
Returns true if the web service response was processed successfully. If false is returned, see the LastError property for additional information.

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

InfoCheck Class
ProcessResponse Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register Class

Register Class
Implements the XmlLicenseService web service's Register method to update customer registration information.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlLicenseServiceRegister
com.softwarekey.Client.WebService.XmlLicenseServiceUpdateRegistration

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class Register : WebServiceCall
Public Class Register
    Inherits WebServiceCall
public ref class Register : public WebServiceCall

The Register type exposes the following members.

Constructors
 | Name | Description
Public method | Register | Creates a new Register object.
Public method | Register(XmlLicenseService) | Creates a new Register object with a specified web service client (XmlLicenseService) object.
Top
Properties
 | Name | Description
Public property | Address1 | Gets or sets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets or sets the customer's second address line (i.e. apartment or suite number).
Public property | City | Gets or sets the city of the customer's address.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Company | Gets or sets the customer's company name.
Public property | Country | Gets or sets the country of the customer's address.
Public property | CustomerID | Gets the Customer ID to which the License ID belongs.
Public property | Email | Gets or sets the customer's email address.
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | EuropeanUnionVATNumber | Gets or sets the customer's European Union VAT number.
Public property | Fax | Gets or sets the customer's fax number.
Public property | FirstName | Gets or sets the customer's first name.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LastName | Gets or sets the customer's last name.
Public property | LicenseeEmail | Gets or sets the licensee's email address.
Public property | LicenseeName | Gets or sets the licensee's name.
Public property | LicenseID | Gets or sets the License ID (requires a value for the Password property when non-zero).
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | NewPassword | Gets or sets the customer's new password (leave empty unless you need to reset the customer's password).
Public property | Notes | Gets or sets notes about the customer.
Public property | Password | Gets or sets the password (required when LicenseID is set to a non-zero value). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.
Public property | Phone | Gets or sets the customer's phone number.
Public property | PostalCode | Gets or sets the customer's zip/postal code.
Public property | ProductID | Gets or sets the Product ID (required when SerialNumber is not empty).
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SerialNumber | Gets or sets the Serial number (requires a value for the ProductID property when not empty).
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | StateProvince | Gets or sets the state/province of the customer's address.
Public property | UseDigitalSignature | Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures. (Overrides WebServiceCallUseDigitalSignature.)
Public property | UseEncryption | Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption. (Overrides WebServiceCallUseEncryption.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for Register calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

The XmlLicenseService documentation should be referenced for the most current information.

Note Note

This function will only update a customer's registration if the customer is not already registered. If you wish to update registration details even when the customer is already registered, use UpdateRegistration instead.

Note Note

Before calling the CallWebService method, the LicenseID and Password properties must be set, or the SerialNumber and ProductID properties must be set.

Examples
This example shows how to make a basic Register call
C#
VB
C++
Copy
public bool RegisterCustomer(int licenseID, string password, string company, string firstName, string lastName, string email)
{
    Register registration = new Register();
    registration.LicenseID = licenseID;
    registration.Password = password;
    registration.Company = company;
    registration.FirstName = firstName;
    registration.LastName = lastName;
    registration.Email = email;

    if (!registration.CallWebService())
    {
        //TODO: check the LastError property and add error reporting here!
        return false;
    }

    //TODO: Add your custom, post-registration logic here!

    return true;
}
Public Function RegisterCustomer(ByVal licenseID As Integer, ByVal password As String, ByVal company As String, ByVal firstName As String, ByVal lastName As String, ByVal email As String) As Boolean
    Dim registration As New Register()
    registration.LicenseID = licenseID
    registration.Password = password
    registration.Company = company
    registration.FirstName = firstName
    registration.LastName = lastName
    registration.Email = email

    If Not registrationChecker.CallWebService() Then
        'TODO: check the LastError property and add error reporting here!
        Return False
    End If

    'TODO: Add your custom logic here!

    Return True
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register Constructor

Register Constructor
Overload List
 | Name | Description
Public method | Register | Creates a new Register object.
Public method | Register(XmlLicenseService) | Creates a new Register object with a specified web service client (XmlLicenseService) object.
Top
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register Constructor

Register Constructor
Creates a new Register object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Register()
Public Sub New
public:
Register()
See Also

Reference

Register Class
Register Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register Constructor (XmlLicenseService)

Register Constructor (XmlLicenseService)
Creates a new Register object with a specified web service client (XmlLicenseService) object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public Register(
    XmlLicenseService client
)
Public Sub New (
    client As XmlLicenseService
)
public:
Register(
    XmlLicenseService^ client
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlLicenseServiceXmlLicenseService
The XmlLicenseService, web service client object, which may be initialized with a different URL and/or proxy server information.
See Also

Reference

Register Class
Register Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register Properties

Register Properties

The Register type exposes the following members.

Properties
 | Name | Description
Public property | Address1 | Gets or sets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets or sets the customer's second address line (i.e. apartment or suite number).
Public property | City | Gets or sets the city of the customer's address.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Company | Gets or sets the customer's company name.
Public property | Country | Gets or sets the country of the customer's address.
Public property | CustomerID | Gets the Customer ID to which the License ID belongs.
Public property | Email | Gets or sets the customer's email address.
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | EuropeanUnionVATNumber | Gets or sets the customer's European Union VAT number.
Public property | Fax | Gets or sets the customer's fax number.
Public property | FirstName | Gets or sets the customer's first name.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LastName | Gets or sets the customer's last name.
Public property | LicenseeEmail | Gets or sets the licensee's email address.
Public property | LicenseeName | Gets or sets the licensee's name.
Public property | LicenseID | Gets or sets the License ID (requires a value for the Password property when non-zero).
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | NewPassword | Gets or sets the customer's new password (leave empty unless you need to reset the customer's password).
Public property | Notes | Gets or sets notes about the customer.
Public property | Password | Gets or sets the password (required when LicenseID is set to a non-zero value). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.
Public property | Phone | Gets or sets the customer's phone number.
Public property | PostalCode | Gets or sets the customer's zip/postal code.
Public property | ProductID | Gets or sets the Product ID (required when SerialNumber is not empty).
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SerialNumber | Gets or sets the Serial number (requires a value for the ProductID property when not empty).
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | StateProvince | Gets or sets the state/province of the customer's address.
Public property | UseDigitalSignature | Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures. (Overrides WebServiceCallUseDigitalSignature.)
Public property | UseEncryption | Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption. (Overrides WebServiceCallUseEncryption.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.Address1 Property

RegisterAddress1 Property
Gets or sets the customer's street address (or line 1 of the customer's address).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.Address2 Property

RegisterAddress2 Property
Gets or sets the customer's second address line (i.e. apartment or suite number).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address2 { get; set; }
Public Property Address2 As String
    Get
    Set
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.City Property

RegisterCity Property
Gets or sets the city of the customer's address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string City { get; set; }
Public Property City As String
    Get
    Set
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.Company Property

RegisterCompany Property
Gets or sets the customer's company name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Company { get; set; }
Public Property Company As String
    Get
    Set
public:
property String^ Company {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.Country Property

RegisterCountry Property
Gets or sets the country of the customer's address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.CustomerID Property

RegisterCustomerID Property
Gets the Customer ID to which the License ID belongs.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int CustomerID { get; }
Public ReadOnly Property CustomerID As Integer
    Get
public:
property int CustomerID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.Email Property

RegisterEmail Property
Gets or sets the customer's email address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.EuropeanUnionVATNumber Property

RegisterEuropeanUnionVATNumber Property
Gets or sets the customer's European Union VAT number.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string EuropeanUnionVATNumber { get; set; }
Public Property EuropeanUnionVATNumber As String
    Get
    Set
public:
property String^ EuropeanUnionVATNumber {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.Fax Property

RegisterFax Property
Gets or sets the customer's fax number.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Fax { get; set; }
Public Property Fax As String
    Get
    Set
public:
property String^ Fax {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.FirstName Property

RegisterFirstName Property
Gets or sets the customer's first name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string FirstName { get; set; }
Public Property FirstName As String
    Get
    Set
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.LastName Property

RegisterLastName Property
Gets or sets the customer's last name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LastName { get; set; }
Public Property LastName As String
    Get
    Set
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.LicenseeEmail Property

RegisterLicenseeEmail Property
Gets or sets the licensee's email address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseeEmail { get; set; }
Public Property LicenseeEmail As String
    Get
    Set
public:
property String^ LicenseeEmail {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.LicenseeName Property

RegisterLicenseeName Property
Gets or sets the licensee's name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseeName { get; set; }
Public Property LicenseeName As String
    Get
    Set
public:
property String^ LicenseeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.LicenseID Property

RegisterLicenseID Property
Gets or sets the License ID (requires a value for the Password property when non-zero).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.NewPassword Property

RegisterNewPassword Property
Gets or sets the customer's new password (leave empty unless you need to reset the customer's password).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string NewPassword { get; set; }
Public Property NewPassword As String
    Get
    Set
public:
property String^ NewPassword {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

Caution note Caution
Resetting the customer's password will impact any License IDs under that customer record, which will all then be required to use the new password.

See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.Notes Property

RegisterNotes Property
Gets or sets notes about the customer.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Notes { get; set; }
Public Property Notes As String
    Get
    Set
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.Password Property

RegisterPassword Property
Gets or sets the password (required when LicenseID is set to a non-zero value). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.Phone Property

RegisterPhone Property
Gets or sets the customer's phone number.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Phone { get; set; }
Public Property Phone As String
    Get
    Set
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.PostalCode Property

RegisterPostalCode Property
Gets or sets the customer's zip/postal code.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.ProductID Property

RegisterProductID Property
Gets or sets the Product ID (required when SerialNumber is not empty).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; set; }
Public Property ProductID As Integer
    Get
    Set
public:
property int ProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.SerialNumber Property

RegisterSerialNumber Property
Gets or sets the Serial number (requires a value for the ProductID property when not empty).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SerialNumber { get; set; }
Public Property SerialNumber As String
    Get
    Set
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.StateProvince Property

RegisterStateProvince Property
Gets or sets the state/province of the customer's address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string StateProvince { get; set; }
Public Property StateProvince As String
    Get
    Set
public:
property String^ StateProvince {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.UseDigitalSignature Property

RegisterUseDigitalSignature Property
Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool UseDigitalSignature { get; set; }
Public Overrides Property UseDigitalSignature As Boolean
    Get
    Set
public:
virtual property bool UseDigitalSignature {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.UseEncryption Property

RegisterUseEncryption Property
Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool UseEncryption { get; set; }
Public Overrides Property UseEncryption As Boolean
    Get
    Set
public:
virtual property bool UseEncryption {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register Methods

Register Methods

The Register type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for Register calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.GeneratePlainTextRequest Method

RegisterGeneratePlainTextRequest Method
Generates a plain-text XML request string for Register calls

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string GeneratePlainTextRequest()
Public Overrides Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() override

Return Value

Type: String
Returns a plain-text XML request string for Register calls.

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.ProcessResponse Method

RegisterProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Overrides WebServiceCallProcessResponse(XmlNode).)
Top
See Also

Reference

Register Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


Register.ProcessResponse Method (XmlNode)

RegisterProcessResponse Method (XmlNode)

[Missing <summary> documentation for "M:com.softwarekey.Client.WebService.XmlLicenseService.Register.ProcessResponse(System.Xml.XmlNode@)"]

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessResponse(
    ref XmlNode response
)
Public Overrides Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
) override

Parameters

response
Type: System.XmlXmlNode
The XML formatted response.

Return Value

Type: Boolean
Returns true if the web service response was processed successfully. If false is returned, see the LastError property for additional information.

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

Register Class
ProcessResponse Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck Class

UpdateCheck Class
Implements the XmlLicenseService web service's UpdateCheck method to check for product or application updates.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlLicenseServiceUpdateCheck

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class UpdateCheck : WebServiceCall
Public Class UpdateCheck
    Inherits WebServiceCall
public ref class UpdateCheck : public WebServiceCall

The UpdateCheck type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCheck | Creates a new UpdateCheck object.
Public method | UpdateCheck(XmlLicenseService) | Creates a new UpdateCheck object with a specified web service client (XmlLicenseService) object.
Top
Properties
 | Name | Description
Public property | ActionToTake | Gets which action should be taken, as indicated by SOLO Server's response.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | CurrentVersion | Gets or sets the Current Version of the application. This must be in the format X.X.X.X, where X may be any number from 0 to 99999.
Public property | DownloadUrl | Gets the URL where the new file/update, or information on how to download the new file(s)/update(s), may be found.
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | InformationUrl | Gets the URL where more information about the available update may be found.
Public property | LanguageCode | Gets or sets the language code of the message to retrieve. (The default is "en", for U.S. English.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LatestVersion | Gets the latest, free version available.
Public property | LicenseID | Gets or sets the License ID of the activated license.
Public property | LicenseStatus | Gets the status of the SOLO Server License ID.
Public property | LicenseUpdate | Gets a small, arbitrary string which may be used for customized status updates.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password (optional). When a value is specified, it will be validated by SOLO Server. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.
Public property | ProductID | Gets or sets the Product ID. If a Product ID is specified before calling CallWebService (this optional, but recommended), the Product ID will be validated against the License ID in SOLO Server. When this property's value is 0 (zero), this extra validation is omitted.
Public property | ProductUpdateName | Gets or sets the product update name to search for in SOLO Server.
Public property | ReleaseDate | Gets the date in which the LatestVersion was released.
Public property | ReplacedBy | Gets the License ID which has replaced this LicenseID. A zero value means the license has not been replaced by (or upgraded to) another License ID.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | ShortMessage | Gets a short, HTML-formatted message, which may be displayed to the user.
Public property | UseDigitalSignature | Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures. (Overrides WebServiceCallUseDigitalSignature.)
Public property | UseEncryption | Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption. (Overrides WebServiceCallUseEncryption.)
Public property | VerifyLicenseExpirationDate | Gets or sets whether or not the License ID's expiration date will be validated. (The default value is false.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for UpdateCheck calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response XmlNode (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

The XmlLicenseService documentation should be referenced for the most current information.

Caution note Caution

Please refer to the SOLO Server manual for details on configuring product updates.

Note Note

Before calling the CallWebService method, the LicenseID, CurrentVersion, and ProductUpdateName properties must be set. The Password, ProductID, LanguageCode, and VerifyLicenseExpirationDate properties may optionally be set before calling the CallWebService method.

Examples
This example shows how to make a typical UpdateCheck call:
C#
VB
C++
Copy
public bool CheckForUpdates(int licenseID)
{
    UpdateCheck updateChecker = new UpdateCheck();
    updateChecker.LicenseID = licenseID; //Optional if the ProductID property is set.
    updateChecker.ProductID = 12345; //Optional if the LicenseID property is set. TODO: Remove or update this line to your ProductID assigned in SOLO Server!
    updateChecker.CurrentVersion = "1.2.3.4"; //TODO: Update this line to use your application's version number!
    updateChecker.ProductUpdateName = "XYZ Product"; //TODO: Update this line of code to use the Product Update Name configured in SOLO Server!

    if (!updateChecker.CallWebService())
    {
        //TODO: check the LastError property and add error reporting here!
        return false;
    }

    if (updateChecker.ActionToTake != UpdateCheck.UpdateAction.None)
    {
        //TODO: Add your update logic here!
    }

    return true;
}
Public Function CheckForUpdates(ByVal licenseID As Integer) As Boolean
    Dim updateChecker As New UpdateCheck()
    updateChecker.LicenseID = licenseID 'Optional if the ProductID property is set.
    updateChecker.ProductID = 12345 'Optional if the LicenseID property is set. TODO: Remove or update this line to your ProductID assigned in SOLO Server!
    updateChecker.CurrentVersion = "1.2.3.4" 'TODO: Update this line to use your application's version number!
    updateChecker.ProductUpdateName = "XYZ Product" 'TODO: Update this line of code to use the Product Update Name configured in SOLO Server!

    If Not updateChecker.CallWebService() Then
        'TODO: check the LastError property and add error reporting here!
        Return False
    End If

    If updateChecker.ActionToTake <> UpdateCheck.UpdateAction.None Then
        'TODO: Add your update logic here!
    End If

    Return True
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck Constructor

UpdateCheck Constructor
Overload List
 | Name | Description
Public method | UpdateCheck | Creates a new UpdateCheck object.
Public method | UpdateCheck(XmlLicenseService) | Creates a new UpdateCheck object with a specified web service client (XmlLicenseService) object.
Top
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck Constructor

UpdateCheck Constructor
Creates a new UpdateCheck object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UpdateCheck()
Public Sub New
public:
UpdateCheck()
See Also

Reference

UpdateCheck Class
UpdateCheck Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck Constructor (XmlLicenseService)

UpdateCheck Constructor (XmlLicenseService)
Creates a new UpdateCheck object with a specified web service client (XmlLicenseService) object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UpdateCheck(
    XmlLicenseService client
)
Public Sub New (
    client As XmlLicenseService
)
public:
UpdateCheck(
    XmlLicenseService^ client
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlLicenseServiceXmlLicenseService
The XmlLicenseService, web service client object, which may be initialized with a different URL and/or proxy server information.
See Also

Reference

UpdateCheck Class
UpdateCheck Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck Properties

UpdateCheck Properties

The UpdateCheck type exposes the following members.

Properties
 | Name | Description
Public property | ActionToTake | Gets which action should be taken, as indicated by SOLO Server's response.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | CurrentVersion | Gets or sets the Current Version of the application. This must be in the format X.X.X.X, where X may be any number from 0 to 99999.
Public property | DownloadUrl | Gets the URL where the new file/update, or information on how to download the new file(s)/update(s), may be found.
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | InformationUrl | Gets the URL where more information about the available update may be found.
Public property | LanguageCode | Gets or sets the language code of the message to retrieve. (The default is "en", for U.S. English.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LatestVersion | Gets the latest, free version available.
Public property | LicenseID | Gets or sets the License ID of the activated license.
Public property | LicenseStatus | Gets the status of the SOLO Server License ID.
Public property | LicenseUpdate | Gets a small, arbitrary string which may be used for customized status updates.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password (optional). When a value is specified, it will be validated by SOLO Server. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.
Public property | ProductID | Gets or sets the Product ID. If a Product ID is specified before calling CallWebService (this optional, but recommended), the Product ID will be validated against the License ID in SOLO Server. When this property's value is 0 (zero), this extra validation is omitted.
Public property | ProductUpdateName | Gets or sets the product update name to search for in SOLO Server.
Public property | ReleaseDate | Gets the date in which the LatestVersion was released.
Public property | ReplacedBy | Gets the License ID which has replaced this LicenseID. A zero value means the license has not been replaced by (or upgraded to) another License ID.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | ShortMessage | Gets a short, HTML-formatted message, which may be displayed to the user.
Public property | UseDigitalSignature | Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures. (Overrides WebServiceCallUseDigitalSignature.)
Public property | UseEncryption | Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption. (Overrides WebServiceCallUseEncryption.)
Public property | VerifyLicenseExpirationDate | Gets or sets whether or not the License ID's expiration date will be validated. (The default value is false.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.ActionToTake Property

UpdateCheckActionToTake Property
Gets which action should be taken, as indicated by SOLO Server's response.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UpdateCheckUpdateAction ActionToTake { get; }
Public ReadOnly Property ActionToTake As UpdateCheckUpdateAction
    Get
public:
property UpdateCheckUpdateAction ActionToTake {
    UpdateCheckUpdateAction get ();
}

Property Value

Type: UpdateCheckUpdateAction
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.CurrentVersion Property

UpdateCheckCurrentVersion Property
Gets or sets the Current Version of the application. This must be in the format X.X.X.X, where X may be any number from 0 to 99999.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CurrentVersion { get; set; }
Public Property CurrentVersion As String
    Get
    Set
public:
property String^ CurrentVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.DownloadUrl Property

UpdateCheckDownloadUrl Property
Gets the URL where the new file/update, or information on how to download the new file(s)/update(s), may be found.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UpdateCheckDownloadUrl DownloadUrl { get; }
Public ReadOnly Property DownloadUrl As UpdateCheckDownloadUrl
    Get
public:
property UpdateCheckDownloadUrl^ DownloadUrl {
    UpdateCheckDownloadUrl^ get ();
}

Property Value

Type: UpdateCheckDownloadUrl
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.InformationUrl Property

UpdateCheckInformationUrl Property
Gets the URL where more information about the available update may be found.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string InformationUrl { get; }
Public ReadOnly Property InformationUrl As String
    Get
public:
property String^ InformationUrl {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.LanguageCode Property

UpdateCheckLanguageCode Property
Gets or sets the language code of the message to retrieve. (The default is "en", for U.S. English.)

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LanguageCode { get; set; }
Public Property LanguageCode As String
    Get
    Set
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.LatestVersion Property

UpdateCheckLatestVersion Property
Gets the latest, free version available.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LatestVersion { get; }
Public ReadOnly Property LatestVersion As String
    Get
public:
property String^ LatestVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.LicenseID Property

UpdateCheckLicenseID Property
Gets or sets the License ID of the activated license.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.LicenseStatus Property

UpdateCheckLicenseStatus Property
Gets the status of the SOLO Server License ID.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public WebServiceCallSOLOServerLicenseStatus LicenseStatus { get; }
Public ReadOnly Property LicenseStatus As WebServiceCallSOLOServerLicenseStatus
    Get
public:
property WebServiceCallSOLOServerLicenseStatus LicenseStatus {
    WebServiceCallSOLOServerLicenseStatus get ();
}

Property Value

Type: WebServiceCallSOLOServerLicenseStatus
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.LicenseUpdate Property

UpdateCheckLicenseUpdate Property
Gets a small, arbitrary string which may be used for customized status updates.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseUpdate { get; }
Public ReadOnly Property LicenseUpdate As String
    Get
public:
property String^ LicenseUpdate {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.Password Property

UpdateCheckPassword Property
Gets or sets the password (optional). When a value is specified, it will be validated by SOLO Server. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.ProductID Property

UpdateCheckProductID Property
Gets or sets the Product ID. If a Product ID is specified before calling CallWebService (this optional, but recommended), the Product ID will be validated against the License ID in SOLO Server. When this property's value is 0 (zero), this extra validation is omitted.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; set; }
Public Property ProductID As Integer
    Get
    Set
public:
property int ProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.ProductUpdateName Property

UpdateCheckProductUpdateName Property
Gets or sets the product update name to search for in SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ProductUpdateName { get; set; }
Public Property ProductUpdateName As String
    Get
    Set
public:
property String^ ProductUpdateName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.ReleaseDate Property

UpdateCheckReleaseDate Property
Gets the date in which the LatestVersion was released.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public DateTime ReleaseDate { get; }
Public ReadOnly Property ReleaseDate As DateTime
    Get
public:
property DateTime ReleaseDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.ReplacedBy Property

UpdateCheckReplacedBy Property
Gets the License ID which has replaced this LicenseID. A zero value means the license has not been replaced by (or upgraded to) another License ID.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ReplacedBy { get; }
Public ReadOnly Property ReplacedBy As Integer
    Get
public:
property int ReplacedBy {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.ShortMessage Property

UpdateCheckShortMessage Property
Gets a short, HTML-formatted message, which may be displayed to the user.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string ShortMessage { get; }
Public ReadOnly Property ShortMessage As String
    Get
public:
property String^ ShortMessage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.UseDigitalSignature Property

UpdateCheckUseDigitalSignature Property
Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool UseDigitalSignature { get; set; }
Public Overrides Property UseDigitalSignature As Boolean
    Get
    Set
public:
virtual property bool UseDigitalSignature {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.UseEncryption Property

UpdateCheckUseEncryption Property
Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool UseEncryption { get; set; }
Public Overrides Property UseEncryption As Boolean
    Get
    Set
public:
virtual property bool UseEncryption {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.VerifyLicenseExpirationDate Property

UpdateCheckVerifyLicenseExpirationDate Property
Gets or sets whether or not the License ID's expiration date will be validated. (The default value is false.)

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool VerifyLicenseExpirationDate { get; set; }
Public Property VerifyLicenseExpirationDate As Boolean
    Get
    Set
public:
property bool VerifyLicenseExpirationDate {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck Methods

UpdateCheck Methods

The UpdateCheck type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for UpdateCheck calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response XmlNode (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.GeneratePlainTextRequest Method

UpdateCheckGeneratePlainTextRequest Method
Generates a plain-text XML request string for UpdateCheck calls

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string GeneratePlainTextRequest()
Public Overrides Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() override

Return Value

Type: String
Returns a plain-text XML request string for UpdateCheck calls.

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.ProcessResponse Method

UpdateCheckProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response XmlNode (Overrides WebServiceCallProcessResponse(XmlNode).)
Top
See Also

Reference

UpdateCheck Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.ProcessResponse Method (XmlNode)

UpdateCheckProcessResponse Method (XmlNode)
Processes a response XmlNode

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessResponse(
    ref XmlNode response
)
Public Overrides Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
) override

Parameters

response
Type: System.XmlXmlNode
The XML formatted response.

Return Value

Type: Boolean
Returns true if the web service response was processed successfully. If false is returned, see the LastError property for additional information.

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

UpdateCheck Class
ProcessResponse Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateCheck.UpdateAction Enumeration

UpdateCheckUpdateAction Enumeration
Possible actions to take, as indicated by UpdateCheck responses.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum UpdateAction
Public Enumeration UpdateAction
public enum class UpdateAction
Members
Member name | Value | Description
None | 0 | No action required, or no update available.
DownloadFtp | 1 | Download a file using File Transfer Protocol (FTP).
DownloadHttp | 2 | Download a file using HyperText Transfer Protocol (HTTP).
Secure | 3 | The Password for the LicenseID is required and must pass validation. Prompt the user for his or her password and try again.
GoToUrl | 4 | Navigate to a URL using the user's default browser.
DisplayMessage | 5 | Display a message to the user.
See Also

Reference

com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateRegistration Class

UpdateRegistration Class
Implements the XmlLicenseService web service's UpdateRegistration method to update customer registration information.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlLicenseServiceRegister
com.softwarekey.Client.WebService.XmlLicenseServiceUpdateRegistration

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class UpdateRegistration : Register
Public Class UpdateRegistration
    Inherits Register
public ref class UpdateRegistration : public Register

The UpdateRegistration type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateRegistration | Creates a new UpdateRegistration object.
Public method | UpdateRegistration(XmlLicenseService) | Creates a new UpdateRegistration object with a specified web service client (XmlLicenseService) object.
Top
Properties
 | Name | Description
Public property | Address1 | Gets or sets the customer's street address (or line 1 of the customer's address). (Inherited from Register.)
Public property | Address2 | Gets or sets the customer's second address line (i.e. apartment or suite number). (Inherited from Register.)
Public property | City | Gets or sets the city of the customer's address. (Inherited from Register.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Company | Gets or sets the customer's company name. (Inherited from Register.)
Public property | Country | Gets or sets the country of the customer's address. (Inherited from Register.)
Public property | CustomerID | Gets the Customer ID to which the License ID belongs. (Inherited from Register.)
Public property | Email | Gets or sets the customer's email address. (Inherited from Register.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | EuropeanUnionVATNumber | Gets or sets the customer's European Union VAT number. (Inherited from Register.)
Public property | Fax | Gets or sets the customer's fax number. (Inherited from Register.)
Public property | FirstName | Gets or sets the customer's first name. (Inherited from Register.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LastName | Gets or sets the customer's last name. (Inherited from Register.)
Public property | LicenseeEmail | Gets or sets the licensee's email address. (Inherited from Register.)
Public property | LicenseeName | Gets or sets the licensee's name. (Inherited from Register.)
Public property | LicenseID | Gets or sets the License ID (requires a value for the Password property when non-zero). (Inherited from Register.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | NewPassword | Gets or sets the customer's new password (leave empty unless you need to reset the customer's password). (Inherited from Register.)
Public property | Notes | Gets or sets notes about the customer. (Inherited from Register.)
Public property | Password | Gets or sets the password (required when LicenseID is set to a non-zero value). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from Register.)
Public property | Phone | Gets or sets the customer's phone number. (Inherited from Register.)
Public property | PostalCode | Gets or sets the customer's zip/postal code. (Inherited from Register.)
Public property | ProductID | Gets or sets the Product ID (required when SerialNumber is not empty). (Inherited from Register.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SerialNumber | Gets or sets the Serial number (requires a value for the ProductID property when not empty). (Inherited from Register.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | StateProvince | Gets or sets the state/province of the customer's address. (Inherited from Register.)
Public property | UseDigitalSignature | Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures. (Inherited from Register.)
Public property | UseEncryption | Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption. (Inherited from Register.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for Register calls (Inherited from Register.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Inherited from Register.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

The XmlLicenseService documentation should be referenced for the most current information.

Note Note

This function will always update a customer's registration, even if the customer is already registered. If you wish to only update registration details when the customer is unregistered, use Register instead.

Note Note

Before calling the CallWebService method, the LicenseID and Password properties must be set, or the SerialNumber and ProductID properties must be set.

Examples
This example shows how to make a basic UpdateRegistration call
C#
VB
C++
Copy
public bool RegisterCustomer(int licenseID, string password, string company, string firstName, string lastName, string email)
{
    UpdateRegistration registration = new UpdateRegistration();
    registration.LicenseID = licenseID;
    registration.Password = password;
    registration.Company = company;
    registration.FirstName = firstName;
    registration.LastName = lastName;
    registration.Email = email;

    if (!registration.CallWebService())
    {
        //TODO: check the LastError property and add error reporting here!
        return false;
    }

    //TODO: Add your custom, post-registration logic here!

    return true;
}
Public Function RegisterCustomer(ByVal licenseID As Integer, ByVal password As String, ByVal company As String, ByVal firstName As String, ByVal lastName As String, ByVal email As String) As Boolean
    Dim registration As New UpdateRegistration()
    registration.LicenseID = licenseID
    registration.Password = password
    registration.Company = company
    registration.FirstName = firstName
    registration.LastName = lastName
    registration.Email = email

    If Not registrationChecker.CallWebService() Then
        'TODO: check the LastError property and add error reporting here!
        Return False
    End If

    'TODO: Add your custom logic here!

    Return True
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateRegistration Constructor

UpdateRegistration Constructor
Overload List
 | Name | Description
Public method | UpdateRegistration | Creates a new UpdateRegistration object.
Public method | UpdateRegistration(XmlLicenseService) | Creates a new UpdateRegistration object with a specified web service client (XmlLicenseService) object.
Top
See Also

Reference

UpdateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateRegistration Constructor

UpdateRegistration Constructor
Creates a new UpdateRegistration object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UpdateRegistration()
Public Sub New
public:
UpdateRegistration()
See Also

Reference

UpdateRegistration Class
UpdateRegistration Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateRegistration Constructor (XmlLicenseService)

UpdateRegistration Constructor (XmlLicenseService)
Creates a new UpdateRegistration object with a specified web service client (XmlLicenseService) object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public UpdateRegistration(
    XmlLicenseService client
)
Public Sub New (
    client As XmlLicenseService
)
public:
UpdateRegistration(
    XmlLicenseService^ client
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlLicenseServiceXmlLicenseService
The XmlLicenseService, web service client object, which may be initialized with a different URL and/or proxy server information.
See Also

Reference

UpdateRegistration Class
UpdateRegistration Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateRegistration Properties

UpdateRegistration Properties

The UpdateRegistration type exposes the following members.

Properties
 | Name | Description
Public property | Address1 | Gets or sets the customer's street address (or line 1 of the customer's address). (Inherited from Register.)
Public property | Address2 | Gets or sets the customer's second address line (i.e. apartment or suite number). (Inherited from Register.)
Public property | City | Gets or sets the city of the customer's address. (Inherited from Register.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Company | Gets or sets the customer's company name. (Inherited from Register.)
Public property | Country | Gets or sets the country of the customer's address. (Inherited from Register.)
Public property | CustomerID | Gets the Customer ID to which the License ID belongs. (Inherited from Register.)
Public property | Email | Gets or sets the customer's email address. (Inherited from Register.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | EuropeanUnionVATNumber | Gets or sets the customer's European Union VAT number. (Inherited from Register.)
Public property | Fax | Gets or sets the customer's fax number. (Inherited from Register.)
Public property | FirstName | Gets or sets the customer's first name. (Inherited from Register.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LastName | Gets or sets the customer's last name. (Inherited from Register.)
Public property | LicenseeEmail | Gets or sets the licensee's email address. (Inherited from Register.)
Public property | LicenseeName | Gets or sets the licensee's name. (Inherited from Register.)
Public property | LicenseID | Gets or sets the License ID (requires a value for the Password property when non-zero). (Inherited from Register.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | NewPassword | Gets or sets the customer's new password (leave empty unless you need to reset the customer's password). (Inherited from Register.)
Public property | Notes | Gets or sets notes about the customer. (Inherited from Register.)
Public property | Password | Gets or sets the password (required when LicenseID is set to a non-zero value). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from Register.)
Public property | Phone | Gets or sets the customer's phone number. (Inherited from Register.)
Public property | PostalCode | Gets or sets the customer's zip/postal code. (Inherited from Register.)
Public property | ProductID | Gets or sets the Product ID (required when SerialNumber is not empty). (Inherited from Register.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SerialNumber | Gets or sets the Serial number (requires a value for the ProductID property when not empty). (Inherited from Register.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | StateProvince | Gets or sets the state/province of the customer's address. (Inherited from Register.)
Public property | UseDigitalSignature | Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures. (Inherited from Register.)
Public property | UseEncryption | Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption. (Inherited from Register.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

UpdateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


UpdateRegistration Methods

UpdateRegistration Methods

The UpdateRegistration type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for Register calls (Inherited from Register.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Inherited from Register.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

UpdateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration Class

ValidateRegistration Class
Implements the XmlLicenseService web service's ValidateRegistration method to retrieve and check customer registration information.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlLicenseServiceValidateRegistration

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class ValidateRegistration : WebServiceCall
Public Class ValidateRegistration
    Inherits WebServiceCall
public ref class ValidateRegistration : public WebServiceCall

The ValidateRegistration type exposes the following members.

Constructors
 | Name | Description
Public method | ValidateRegistration | Creates a new ValidateRegistration object.
Public method | ValidateRegistration(XmlLicenseService) | Creates a new ValidateRegistration object with a specified web service client (XmlLicenseService) object.
Top
Properties
 | Name | Description
Public property | Address1 | Gets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets the customer's second address line (i.e. apartment or suite number).
Public property | City | Gets the city of the customer's address.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Company | Gets the customer's company name.
Public property | Country | Gets the country of the customer's address.
Public property | CustomerID | Gets the Customer ID, which uniquely identifies the customer to which this License ID belongs.
Public property | Email | Gets the customer's email address.
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | EuropeanUnionVATNumber | Gets the customer's European Union VAT number.
Public property | Fax | Gets the customer's fax number.
Public property | FirstName | Gets the customer's first name.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LastName | Gets the customer's last name.
Public property | LicenseeEmail | Gets the licensee's email address.
Public property | LicenseeName | Gets the licensee's name.
Public property | LicenseID | Gets or sets the License ID (requires a value for the Password property when non-zero).
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Notes | Gets notes about the customer.
Public property | Password | Gets or sets the password (required when LicenseID is set to a non-zero value). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.
Public property | Phone | Gets the customer's phone number.
Public property | PostalCode | Gets the customer's zip/postal code.
Public property | ProdOptionID | Gets the Product Option ID with which the License ID was created.
Public property | ProductID | Gets or sets the Product ID (required when SerialNumber is not empty).
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SerialNumber | Gets or sets the Serial number (requires a value for the ProductID property when not empty).
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | StateProvince | Gets the state/province of the customer's address.
Public property | UseDigitalSignature | Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures. (Overrides WebServiceCallUseDigitalSignature.)
Public property | UseEncryption | Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption. (Overrides WebServiceCallUseEncryption.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for ValidateRegistration calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks

The XmlLicenseService documentation should be referenced for the most current information.

Note Note

Before calling the CallWebService method, the LicenseID and Password properties must be set, or the SerialNumber and ProductID properties must be set.

Examples
This example shows how to make a typical ValidateRegistration call
C#
VB
C++
Copy
public bool CheckRegistration(int licenseID, string password)
{
    ValidateRegistration registrationChecker = new ValidateRegistration();
    registrationChecker.LicenseID = licenseID;
    registrationChecker.Password = password;

    if (!registrationChecker.CallWebService())
    {
        //TODO: check the LastError property and add error reporting here!
        return false;
    }

    //TODO: Add your custom logic here!

    return true;
}
Public Function CheckRegistration(ByVal licenseID As Integer, ByVal password As String) As Boolean
    Dim registrationChecker As New ValidateRegistration()
    registrationChecker.LicenseID = licenseID
    registrationChecker.Password = password

    If Not registrationChecker.CallWebService() Then
        'TODO: check the LastError property and add error reporting here!
        Return False
    End If

    'TODO: Add your custom logic here!

    Return True
End Function

No code example is currently available or this language may not be supported.

See Also

Reference

com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration Constructor

ValidateRegistration Constructor
Overload List
 | Name | Description
Public method | ValidateRegistration | Creates a new ValidateRegistration object.
Public method | ValidateRegistration(XmlLicenseService) | Creates a new ValidateRegistration object with a specified web service client (XmlLicenseService) object.
Top
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration Constructor

ValidateRegistration Constructor
Creates a new ValidateRegistration object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ValidateRegistration()
Public Sub New
public:
ValidateRegistration()
See Also

Reference

ValidateRegistration Class
ValidateRegistration Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration Constructor (XmlLicenseService)

ValidateRegistration Constructor (XmlLicenseService)
Creates a new ValidateRegistration object with a specified web service client (XmlLicenseService) object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public ValidateRegistration(
    XmlLicenseService client
)
Public Sub New (
    client As XmlLicenseService
)
public:
ValidateRegistration(
    XmlLicenseService^ client
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlLicenseServiceXmlLicenseService
The XmlLicenseService, web service client object, which may be initialized with a different URL and/or proxy server information.
See Also

Reference

ValidateRegistration Class
ValidateRegistration Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration Properties

ValidateRegistration Properties

The ValidateRegistration type exposes the following members.

Properties
 | Name | Description
Public property | Address1 | Gets the customer's street address (or line 1 of the customer's address).
Public property | Address2 | Gets the customer's second address line (i.e. apartment or suite number).
Public property | City | Gets the city of the customer's address.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Company | Gets the customer's company name.
Public property | Country | Gets the country of the customer's address.
Public property | CustomerID | Gets the Customer ID, which uniquely identifies the customer to which this License ID belongs.
Public property | Email | Gets the customer's email address.
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | EuropeanUnionVATNumber | Gets the customer's European Union VAT number.
Public property | Fax | Gets the customer's fax number.
Public property | FirstName | Gets the customer's first name.
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LastName | Gets the customer's last name.
Public property | LicenseeEmail | Gets the licensee's email address.
Public property | LicenseeName | Gets the licensee's name.
Public property | LicenseID | Gets or sets the License ID (requires a value for the Password property when non-zero).
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Notes | Gets notes about the customer.
Public property | Password | Gets or sets the password (required when LicenseID is set to a non-zero value). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.
Public property | Phone | Gets the customer's phone number.
Public property | PostalCode | Gets the customer's zip/postal code.
Public property | ProdOptionID | Gets the Product Option ID with which the License ID was created.
Public property | ProductID | Gets or sets the Product ID (required when SerialNumber is not empty).
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SerialNumber | Gets or sets the Serial number (requires a value for the ProductID property when not empty).
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | StateProvince | Gets the state/province of the customer's address.
Public property | UseDigitalSignature | Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures. (Overrides WebServiceCallUseDigitalSignature.)
Public property | UseEncryption | Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption. (Overrides WebServiceCallUseEncryption.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.Address1 Property

ValidateRegistrationAddress1 Property
Gets the customer's street address (or line 1 of the customer's address).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address1 { get; }
Public ReadOnly Property Address1 As String
    Get
public:
property String^ Address1 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.Address2 Property

ValidateRegistrationAddress2 Property
Gets the customer's second address line (i.e. apartment or suite number).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Address2 { get; }
Public ReadOnly Property Address2 As String
    Get
public:
property String^ Address2 {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.City Property

ValidateRegistrationCity Property
Gets the city of the customer's address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string City { get; }
Public ReadOnly Property City As String
    Get
public:
property String^ City {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.Company Property

ValidateRegistrationCompany Property
Gets the customer's company name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Company { get; }
Public ReadOnly Property Company As String
    Get
public:
property String^ Company {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.Country Property

ValidateRegistrationCountry Property
Gets the country of the customer's address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Country { get; }
Public ReadOnly Property Country As String
    Get
public:
property String^ Country {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.CustomerID Property

ValidateRegistrationCustomerID Property
Gets the Customer ID, which uniquely identifies the customer to which this License ID belongs.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int CustomerID { get; }
Public ReadOnly Property CustomerID As Integer
    Get
public:
property int CustomerID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.Email Property

ValidateRegistrationEmail Property
Gets the customer's email address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Email { get; }
Public ReadOnly Property Email As String
    Get
public:
property String^ Email {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.EuropeanUnionVATNumber Property

ValidateRegistrationEuropeanUnionVATNumber Property
Gets the customer's European Union VAT number.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string EuropeanUnionVATNumber { get; }
Public ReadOnly Property EuropeanUnionVATNumber As String
    Get
public:
property String^ EuropeanUnionVATNumber {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.Fax Property

ValidateRegistrationFax Property
Gets the customer's fax number.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Fax { get; }
Public ReadOnly Property Fax As String
    Get
public:
property String^ Fax {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.FirstName Property

ValidateRegistrationFirstName Property
Gets the customer's first name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string FirstName { get; }
Public ReadOnly Property FirstName As String
    Get
public:
property String^ FirstName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.LastName Property

ValidateRegistrationLastName Property
Gets the customer's last name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LastName { get; }
Public ReadOnly Property LastName As String
    Get
public:
property String^ LastName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.LicenseeEmail Property

ValidateRegistrationLicenseeEmail Property
Gets the licensee's email address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseeEmail { get; }
Public ReadOnly Property LicenseeEmail As String
    Get
public:
property String^ LicenseeEmail {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.LicenseeName Property

ValidateRegistrationLicenseeName Property
Gets the licensee's name.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string LicenseeName { get; }
Public ReadOnly Property LicenseeName As String
    Get
public:
property String^ LicenseeName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.LicenseID Property

ValidateRegistrationLicenseID Property
Gets or sets the License ID (requires a value for the Password property when non-zero).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.Notes Property

ValidateRegistrationNotes Property
Gets notes about the customer.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Notes { get; }
Public ReadOnly Property Notes As String
    Get
public:
property String^ Notes {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.Password Property

ValidateRegistrationPassword Property
Gets or sets the password (required when LicenseID is set to a non-zero value). This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.Phone Property

ValidateRegistrationPhone Property
Gets the customer's phone number.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Phone { get; }
Public ReadOnly Property Phone As String
    Get
public:
property String^ Phone {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.PostalCode Property

ValidateRegistrationPostalCode Property
Gets the customer's zip/postal code.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string PostalCode { get; }
Public ReadOnly Property PostalCode As String
    Get
public:
property String^ PostalCode {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.ProdOptionID Property

ValidateRegistrationProdOptionID Property
Gets the Product Option ID with which the License ID was created.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProdOptionID { get; }
Public ReadOnly Property ProdOptionID As Integer
    Get
public:
property int ProdOptionID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.ProductID Property

ValidateRegistrationProductID Property
Gets or sets the Product ID (required when SerialNumber is not empty).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int ProductID { get; set; }
Public Property ProductID As Integer
    Get
    Set
public:
property int ProductID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.SerialNumber Property

ValidateRegistrationSerialNumber Property
Gets or sets the Serial number (requires a value for the ProductID property when not empty).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SerialNumber { get; set; }
Public Property SerialNumber As String
    Get
    Set
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.StateProvince Property

ValidateRegistrationStateProvince Property
Gets the state/province of the customer's address.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string StateProvince { get; }
Public ReadOnly Property StateProvince As String
    Get
public:
property String^ StateProvince {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.UseDigitalSignature Property

ValidateRegistrationUseDigitalSignature Property
Overrides the UseDigitalSignature property to reflect the fact that this web service method does not support digital signatures.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool UseDigitalSignature { get; set; }
Public Overrides Property UseDigitalSignature As Boolean
    Get
    Set
public:
virtual property bool UseDigitalSignature {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.UseEncryption Property

ValidateRegistrationUseEncryption Property
Overrides the UseEncryption property to reflect the fact that this web service method does not support encryption.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool UseEncryption { get; set; }
Public Overrides Property UseEncryption As Boolean
    Get
    Set
public:
virtual property bool UseEncryption {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration Methods

ValidateRegistration Methods

The ValidateRegistration type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text XML request string for ValidateRegistration calls (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.GeneratePlainTextRequest Method

ValidateRegistrationGeneratePlainTextRequest Method
Generates a plain-text XML request string for ValidateRegistration calls

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string GeneratePlainTextRequest()
Public Overrides Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() override

Return Value

Type: String
Returns a plain-text XML request string for ValidateRegistration calls.

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.ProcessResponse Method

ValidateRegistrationProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | (Overrides WebServiceCallProcessResponse(XmlNode).)
Top
See Also

Reference

ValidateRegistration Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


ValidateRegistration.ProcessResponse Method (XmlNode)

ValidateRegistrationProcessResponse Method (XmlNode)

[Missing <summary> documentation for "M:com.softwarekey.Client.WebService.XmlLicenseService.ValidateRegistration.ProcessResponse(System.Xml.XmlNode@)"]

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessResponse(
    ref XmlNode response
)
Public Overrides Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
) override

Parameters

response
Type: System.XmlXmlNode
The XML formatted response.

Return Value

Type: Boolean
Returns true if the web service response was processed successfully. If false is returned, see the LastError property for additional information.

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

ValidateRegistration Class
ProcessResponse Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService Class

XmlLicenseService Class
SoapHttpClientProtocol implementation for calling methods in SOLO Server's XmlActivationService web service.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Web.Services.ProtocolsWebClientProtocol
System.Web.Services.ProtocolsHttpWebClientProtocol
System.Web.Services.ProtocolsSoapHttpClientProtocol
com.softwarekey.Client.WebService.XmlLicenseServiceXmlLicenseService

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class XmlLicenseService : SoapHttpClientProtocol
Public Class XmlLicenseService
    Inherits SoapHttpClientProtocol
public ref class XmlLicenseService : public SoapHttpClientProtocol

The XmlLicenseService type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLicenseService | Creates a new XmlLicenseFileService object.
Top
Properties
 | Name | Description
Public property | AllowAutoRedirect | (Inherited from HttpWebClientProtocol.)
Protected property | CanRaiseEvents | (Inherited from Component.)
Public property | ClientCertificates | (Inherited from HttpWebClientProtocol.)
Public property | ConnectionGroupName | (Inherited from WebClientProtocol.)
Public property | Container | (Inherited from Component.)
Public property | CookieContainer | (Inherited from HttpWebClientProtocol.)
Public property | Credentials | (Inherited from WebClientProtocol.)
Protected property | DesignMode | (Inherited from Component.)
Public property | EnableDecompression | (Inherited from HttpWebClientProtocol.)
Protected property | Events | (Inherited from Component.)
Public property | PreAuthenticate | (Inherited from WebClientProtocol.)
Public property | Proxy | (Inherited from HttpWebClientProtocol.)
Public property | RequestEncoding | (Inherited from WebClientProtocol.)
Public property | Site | (Inherited from Component.)
Public property | SoapVersion | (Inherited from SoapHttpClientProtocol.)
Public property | Timeout | (Inherited from WebClientProtocol.)
Public property | UnsafeAuthenticatedConnectionSharing | (Inherited from HttpWebClientProtocol.)
Public property | Url | Gets or sets the base URL of the XML Web service the client is requesting.
Public property | UseDefaultCredentials | Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.
Public property | UserAgent | (Inherited from HttpWebClientProtocol.)
Top
Methods
 | Name | Description
Public method | Abort | (Inherited from WebClientProtocol.)
Public method | Add | Calls the Add web method.
Public method | AddAsync(XmlNode) | Calls the Add web method asynchronously.
Public method | AddAsync(XmlNode, Object) | Calls the Add web method.
Public method | AddS | Calls the AddS web method.
Public method | AddSAsync(String) | Calls the AddS web method.
Public method | AddSAsync(String, Object) | Calls the AddS web method.
Protected method | BeginInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | CancelAsync | Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Public method | Discover | (Inherited from SoapHttpClientProtocol.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from Component.)
Protected method | EndInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLicenseCustomData | Calls the GetLicenseCustomData web method.
Public method | GetLicenseCustomDataAsync(XmlNode) | Calls the GetLicenseCustomData web method.
Public method | GetLicenseCustomDataAsync(XmlNode, Object) | Calls the GetLicenseCustomData web method.
Public method | GetLicenseCustomDataS | Calls the GetLicenseCustomDataS web method.
Public method | GetLicenseCustomDataSAsync(String) | Calls the GetLicenseCustomDataS web method.
Public method | GetLicenseCustomDataSAsync(String, Object) | Calls the GetLicenseCustomDataS web method.
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | GetReaderForMessage | (Inherited from SoapHttpClientProtocol.)
Protected method | GetService | (Inherited from Component.)
Public method | GetType | (Inherited from Object.)
Protected method | GetWebRequest | (Inherited from SoapHttpClientProtocol.)
Protected method | GetWebResponse(WebRequest) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWebResponse(WebRequest, IAsyncResult) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWriterForMessage | (Inherited from SoapHttpClientProtocol.)
Public method | InfoCheck | Calls the InfoCheck web method.
Public method | InfoCheckAsync(XmlNode) | Calls the InfoCheck web method asynchronously.
Public method | InfoCheckAsync(XmlNode, Object) | Calls the InfoCheck web method.
Public method | InfoCheckS | Calls the InfoCheckS web method.
Public method | InfoCheckSAsync(String) | Calls the InfoCheckS web method asynchronously.
Public method | InfoCheckSAsync(String, Object) | Calls the InfoCheckS web method.
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | Invoke | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback) | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback, Object) | (Inherited from SoapHttpClientProtocol.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Public method | Register | Calls the Register web method.
Public method | RegisterAsync(XmlNode) | Calls the Register web method asynchronously.
Public method | RegisterAsync(XmlNode, Object) | Calls the Register web method.
Public method | RegisterS | Calls the RegisterS web method.
Public method | RegisterSAsync(String) | Calls the RegisterS web method asynchronously.
Public method | RegisterSAsync(String, Object) | Calls the RegisterS web method.
Public method | ToString | (Inherited from Component.)
Public method | UpdateActivationFields | Calls the UpdateActivationFields web method.
Public method | UpdateActivationFieldsAsync(String) | Calls the UpdateActivationFields web method.
Public method | UpdateActivationFieldsAsync(String, Object) | Calls the UpdateActivationFields web method.
Public method | UpdateCheck | Calls the UpdateCheck web method.
Public method | UpdateCheckAsync(XmlNode) | Calls the UpdateCheck web method asynchronously.
Public method | UpdateCheckAsync(XmlNode, Object) | Calls the UpdateCheck web method.
Public method | UpdateCheckS | Calls the UpdateCheckS web method.
Public method | UpdateCheckSAsync(String) | Calls the UpdateCheckS web method asynchronously.
Public method | UpdateCheckSAsync(String, Object) | Calls the UpdateCheck web method.
Public method | UpdateLicenseCustomData | Calls the UpdateLicenseCustomData web method.
Public method | UpdateLicenseCustomDataAsync(XmlNode) | Calls the UpdateLicenseCustomData web method.
Public method | UpdateLicenseCustomDataAsync(XmlNode, Object) | Calls the UpdateLicenseCustomData web method.
Public method | UpdateLicenseCustomDataS | Calls the UpdateLicenseCustomDataS web method.
Public method | UpdateLicenseCustomDataSAsync(String) | Calls the UpdateLicenseCustomDataS web method.
Public method | UpdateLicenseCustomDataSAsync(String, Object) | Calls the UpdateLicenseCustomDataS web method.
Public method | UpdateRegistration | Calls the UpdateRegistration web method.
Public method | UpdateRegistrationAsync(XmlNode) | Calls the UpdateRegistration web method asynchronously.
Public method | UpdateRegistrationAsync(XmlNode, Object) | Calls the UpdateRegistration web method.
Public method | UpdateRegistrationS | Calls the UpdateRegistrationS web method.
Public method | UpdateRegistrationSAsync(String) | Calls the UpdateRegistrationS web method asynchronously.
Public method | UpdateRegistrationSAsync(String, Object) | Calls the UpdateRegistrationS web method.
Public method | UpdateUserDefinedFields | Calls the UpdateUserDefinedFields web method.
Public method | UpdateUserDefinedFieldsAsync(XmlNode) | Calls the UpdateUserDefinedFields web method.
Public method | UpdateUserDefinedFieldsAsync(XmlNode, Object) | Calls the UpdateUserDefinedFields web method.
Public method | UpdateUserDefinedFieldsS | Calls the UpdateUserDefinedFieldsS web method.
Public method | UpdateUserDefinedFieldsSAsync(String) | Calls the UpdateUserDefinedFieldsS web method asynchronously.
Public method | UpdateUserDefinedFieldsSAsync(String, Object) | Calls the UpdateUserDefinedFieldsS web method.
Public method | ValidateRegistration | Calls the ValidateRegistration web method.
Public method | ValidateRegistrationAsync(XmlNode) | Calls the ValidateRegistration web method asynchronously.
Public method | ValidateRegistrationAsync(XmlNode, Object) | Calls the ValidateRegistration web method.
Public method | ValidateRegistrationS | Calls the ValidateRegistrationS web method.
Public method | ValidateRegistrationSAsync(String) | Calls the ValidateRegistrationS web method.
Public method | ValidateRegistrationSAsync(String, Object) | Calls the ValidateRegistration web method.
Top
Events
 | Name | Description
Public event | AddCompleted | Occurs when an asynchronous call to Add has completed.
Public event | AddSCompleted | Occurs when an asynchronous call to AddS has completed.
Public event | Disposed | (Inherited from Component.)
Public event | GetLicenseCustomDataCompleted | Occurs when an asynchronous call to GetLicenseCustomData has completed.
Public event | GetLicenseCustomDataSCompleted | Occurs when an asynchronous call to GetLicenseCustomDataS has completed.
Public event | InfoCheckCompleted | Occurs when an asynchronous call to InfoCheck has completed.
Public event | InfoCheckSCompleted | Occurs when an asynchronous call to InfoCheckS has completed.
Public event | RegisterCompleted | Occurs when an asynchronous call to Register has completed.
Public event | RegisterSCompleted | Occurs when an asynchronous call to RegisterS has completed.
Public event | UpdateActivationFieldsCompleted | Occurs when an asynchronous call to UpdateActivationFields has completed.
Public event | UpdateCheckCompleted | Occurs when an asynchronous call to UpdateCheck has completed.
Public event | UpdateCheckSCompleted | Occurs when an asynchronous call to UpdateCheckS has completed.
Public event | UpdateLicenseCustomDataCompleted | Occurs when an asynchronous call to UpdateLicenseCustomData has completed.
Public event | UpdateLicenseCustomDataSCompleted | Occurs when an asynchronous call to UpdateLicenseCustomDataS has completed.
Public event | UpdateRegistrationCompleted | Occurs when an asynchronous call to UpdateRegistration has completed.
Public event | UpdateRegistrationSCompleted | Occurs when an asynchronous call to UpdateRegistrationS has completed.
Public event | UpdateUserDefinedFieldsCompleted | Occurs when an asynchronous call to UpdateUserDefinedFields has completed.
Public event | UpdateUserDefinedFieldsSCompleted | Occurs when an asynchronous call to UpdateUserDefinedFieldsS has completed.
Public event | ValidateRegistrationCompleted | Occurs when an asynchronous call to ValidateRegistration has completed.
Public event | ValidateRegistrationSCompleted | Occurs when an asynchronous call to ValidateRegistrationS has completed.
Top
Remarks
Note Note

This class should only be used directly as needed for specifying customized information, such as different end-point URLs, proxy server access credentials, etc... The com.softwarekey.Client.WebService.XmlLicenseService namespace contains WebServiceCall implementations for each supported web service method.

See Also

Reference

com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService Constructor

XmlLicenseService Constructor
Creates a new XmlLicenseFileService object.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlLicenseService()
Public Sub New
public:
XmlLicenseService()
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService Properties

XmlLicenseService Properties

The XmlLicenseService type exposes the following members.

Properties
 | Name | Description
Public property | AllowAutoRedirect | (Inherited from HttpWebClientProtocol.)
Protected property | CanRaiseEvents | (Inherited from Component.)
Public property | ClientCertificates | (Inherited from HttpWebClientProtocol.)
Public property | ConnectionGroupName | (Inherited from WebClientProtocol.)
Public property | Container | (Inherited from Component.)
Public property | CookieContainer | (Inherited from HttpWebClientProtocol.)
Public property | Credentials | (Inherited from WebClientProtocol.)
Protected property | DesignMode | (Inherited from Component.)
Public property | EnableDecompression | (Inherited from HttpWebClientProtocol.)
Protected property | Events | (Inherited from Component.)
Public property | PreAuthenticate | (Inherited from WebClientProtocol.)
Public property | Proxy | (Inherited from HttpWebClientProtocol.)
Public property | RequestEncoding | (Inherited from WebClientProtocol.)
Public property | Site | (Inherited from Component.)
Public property | SoapVersion | (Inherited from SoapHttpClientProtocol.)
Public property | Timeout | (Inherited from WebClientProtocol.)
Public property | UnsafeAuthenticatedConnectionSharing | (Inherited from HttpWebClientProtocol.)
Public property | Url | Gets or sets the base URL of the XML Web service the client is requesting.
Public property | UseDefaultCredentials | Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.
Public property | UserAgent | (Inherited from HttpWebClientProtocol.)
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.Url Property

XmlLicenseServiceUrl Property
Gets or sets the base URL of the XML Web service the client is requesting.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UseDefaultCredentials Property

XmlLicenseServiceUseDefaultCredentials Property
Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool UseDefaultCredentials { get; set; }
Public Property UseDefaultCredentials As Boolean
    Get
    Set
public:
property bool UseDefaultCredentials {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService Methods

XmlLicenseService Methods

The XmlLicenseService type exposes the following members.

Methods
 | Name | Description
Public method | Abort | (Inherited from WebClientProtocol.)
Public method | Add | Calls the Add web method.
Public method | AddAsync(XmlNode) | Calls the Add web method asynchronously.
Public method | AddAsync(XmlNode, Object) | Calls the Add web method.
Public method | AddS | Calls the AddS web method.
Public method | AddSAsync(String) | Calls the AddS web method.
Public method | AddSAsync(String, Object) | Calls the AddS web method.
Protected method | BeginInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | CancelAsync | Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Public method | Discover | (Inherited from SoapHttpClientProtocol.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from Component.)
Protected method | EndInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLicenseCustomData | Calls the GetLicenseCustomData web method.
Public method | GetLicenseCustomDataAsync(XmlNode) | Calls the GetLicenseCustomData web method.
Public method | GetLicenseCustomDataAsync(XmlNode, Object) | Calls the GetLicenseCustomData web method.
Public method | GetLicenseCustomDataS | Calls the GetLicenseCustomDataS web method.
Public method | GetLicenseCustomDataSAsync(String) | Calls the GetLicenseCustomDataS web method.
Public method | GetLicenseCustomDataSAsync(String, Object) | Calls the GetLicenseCustomDataS web method.
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | GetReaderForMessage | (Inherited from SoapHttpClientProtocol.)
Protected method | GetService | (Inherited from Component.)
Public method | GetType | (Inherited from Object.)
Protected method | GetWebRequest | (Inherited from SoapHttpClientProtocol.)
Protected method | GetWebResponse(WebRequest) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWebResponse(WebRequest, IAsyncResult) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWriterForMessage | (Inherited from SoapHttpClientProtocol.)
Public method | InfoCheck | Calls the InfoCheck web method.
Public method | InfoCheckAsync(XmlNode) | Calls the InfoCheck web method asynchronously.
Public method | InfoCheckAsync(XmlNode, Object) | Calls the InfoCheck web method.
Public method | InfoCheckS | Calls the InfoCheckS web method.
Public method | InfoCheckSAsync(String) | Calls the InfoCheckS web method asynchronously.
Public method | InfoCheckSAsync(String, Object) | Calls the InfoCheckS web method.
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | Invoke | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback) | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback, Object) | (Inherited from SoapHttpClientProtocol.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Public method | Register | Calls the Register web method.
Public method | RegisterAsync(XmlNode) | Calls the Register web method asynchronously.
Public method | RegisterAsync(XmlNode, Object) | Calls the Register web method.
Public method | RegisterS | Calls the RegisterS web method.
Public method | RegisterSAsync(String) | Calls the RegisterS web method asynchronously.
Public method | RegisterSAsync(String, Object) | Calls the RegisterS web method.
Public method | ToString | (Inherited from Component.)
Public method | UpdateActivationFields | Calls the UpdateActivationFields web method.
Public method | UpdateActivationFieldsAsync(String) | Calls the UpdateActivationFields web method.
Public method | UpdateActivationFieldsAsync(String, Object) | Calls the UpdateActivationFields web method.
Public method | UpdateCheck | Calls the UpdateCheck web method.
Public method | UpdateCheckAsync(XmlNode) | Calls the UpdateCheck web method asynchronously.
Public method | UpdateCheckAsync(XmlNode, Object) | Calls the UpdateCheck web method.
Public method | UpdateCheckS | Calls the UpdateCheckS web method.
Public method | UpdateCheckSAsync(String) | Calls the UpdateCheckS web method asynchronously.
Public method | UpdateCheckSAsync(String, Object) | Calls the UpdateCheck web method.
Public method | UpdateLicenseCustomData | Calls the UpdateLicenseCustomData web method.
Public method | UpdateLicenseCustomDataAsync(XmlNode) | Calls the UpdateLicenseCustomData web method.
Public method | UpdateLicenseCustomDataAsync(XmlNode, Object) | Calls the UpdateLicenseCustomData web method.
Public method | UpdateLicenseCustomDataS | Calls the UpdateLicenseCustomDataS web method.
Public method | UpdateLicenseCustomDataSAsync(String) | Calls the UpdateLicenseCustomDataS web method.
Public method | UpdateLicenseCustomDataSAsync(String, Object) | Calls the UpdateLicenseCustomDataS web method.
Public method | UpdateRegistration | Calls the UpdateRegistration web method.
Public method | UpdateRegistrationAsync(XmlNode) | Calls the UpdateRegistration web method asynchronously.
Public method | UpdateRegistrationAsync(XmlNode, Object) | Calls the UpdateRegistration web method.
Public method | UpdateRegistrationS | Calls the UpdateRegistrationS web method.
Public method | UpdateRegistrationSAsync(String) | Calls the UpdateRegistrationS web method asynchronously.
Public method | UpdateRegistrationSAsync(String, Object) | Calls the UpdateRegistrationS web method.
Public method | UpdateUserDefinedFields | Calls the UpdateUserDefinedFields web method.
Public method | UpdateUserDefinedFieldsAsync(XmlNode) | Calls the UpdateUserDefinedFields web method.
Public method | UpdateUserDefinedFieldsAsync(XmlNode, Object) | Calls the UpdateUserDefinedFields web method.
Public method | UpdateUserDefinedFieldsS | Calls the UpdateUserDefinedFieldsS web method.
Public method | UpdateUserDefinedFieldsSAsync(String) | Calls the UpdateUserDefinedFieldsS web method asynchronously.
Public method | UpdateUserDefinedFieldsSAsync(String, Object) | Calls the UpdateUserDefinedFieldsS web method.
Public method | ValidateRegistration | Calls the ValidateRegistration web method.
Public method | ValidateRegistrationAsync(XmlNode) | Calls the ValidateRegistration web method asynchronously.
Public method | ValidateRegistrationAsync(XmlNode, Object) | Calls the ValidateRegistration web method.
Public method | ValidateRegistrationS | Calls the ValidateRegistrationS web method.
Public method | ValidateRegistrationSAsync(String) | Calls the ValidateRegistrationS web method.
Public method | ValidateRegistrationSAsync(String, Object) | Calls the ValidateRegistration web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.Add Method

XmlLicenseServiceAdd Method
Calls the Add web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode Add(
    XmlNode xml
)
Public Function Add (
    xml As XmlNode
) As XmlNode
public:
XmlNode^ Add(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.AddAsync Method

XmlLicenseServiceAddAsync Method
Overload List
 | Name | Description
Public method | AddAsync(XmlNode) | Calls the Add web method asynchronously.
Public method | AddAsync(XmlNode, Object) | Calls the Add web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.AddAsync Method (XmlNode)

XmlLicenseServiceAddAsync Method (XmlNode)
Calls the Add web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddAsync(
    XmlNode xml
)
Public Sub AddAsync (
    xml As XmlNode
)
public:
void AddAsync(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
AddAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.AddAsync Method (XmlNode, Object)

XmlLicenseServiceAddAsync Method (XmlNode, Object)
Calls the Add web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddAsync(
    XmlNode xml,
    Object userState
)
Public Sub AddAsync (
    xml As XmlNode,
    userState As Object
)
public:
void AddAsync(
    XmlNode^ xml,
    Object^ userState
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
userState
Type: SystemObject
The user state object.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
AddAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.AddS Method

XmlLicenseServiceAddS Method
Calls the AddS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode AddS(
    string xml
)
Public Function AddS (
    xml As String
) As XmlNode
public:
XmlNode^ AddS(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.AddSAsync Method

XmlLicenseServiceAddSAsync Method
Overload List
 | Name | Description
Public method | AddSAsync(String) | Calls the AddS web method.
Public method | AddSAsync(String, Object) | Calls the AddS web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.AddSAsync Method (String)

XmlLicenseServiceAddSAsync Method (String)
Calls the AddS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddSAsync(
    string xml
)
Public Sub AddSAsync (
    xml As String
)
public:
void AddSAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
AddSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.AddSAsync Method (String, Object)

XmlLicenseServiceAddSAsync Method (String, Object)
Calls the AddS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void AddSAsync(
    string xml,
    Object userState
)
Public Sub AddSAsync (
    xml As String,
    userState As Object
)
public:
void AddSAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state object.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
AddSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.CancelAsync Method

XmlLicenseServiceCancelAsync Method
Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CancelAsync(
    Object userState
)
Public Sub CancelAsync (
    userState As Object
)
public:
void CancelAsync(
    Object^ userState
)

Parameters

userState
Type: SystemObject
The user state Object.
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.GetLicenseCustomData Method

XmlLicenseServiceGetLicenseCustomData Method
Calls the GetLicenseCustomData web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode GetLicenseCustomData(
    XmlNode xml
)
Public Function GetLicenseCustomData (
    xml As XmlNode
) As XmlNode
public:
XmlNode^ GetLicenseCustomData(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.GetLicenseCustomDataAsync Method

XmlLicenseServiceGetLicenseCustomDataAsync Method
Overload List
 | Name | Description
Public method | GetLicenseCustomDataAsync(XmlNode) | Calls the GetLicenseCustomData web method.
Public method | GetLicenseCustomDataAsync(XmlNode, Object) | Calls the GetLicenseCustomData web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.GetLicenseCustomDataAsync Method (XmlNode)

XmlLicenseServiceGetLicenseCustomDataAsync Method (XmlNode)
Calls the GetLicenseCustomData web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void GetLicenseCustomDataAsync(
    XmlNode xml
)
Public Sub GetLicenseCustomDataAsync (
    xml As XmlNode
)
public:
void GetLicenseCustomDataAsync(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
GetLicenseCustomDataAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.GetLicenseCustomDataAsync Method (XmlNode, Object)

XmlLicenseServiceGetLicenseCustomDataAsync Method (XmlNode, Object)
Calls the GetLicenseCustomData web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void GetLicenseCustomDataAsync(
    XmlNode xml,
    Object userState
)
Public Sub GetLicenseCustomDataAsync (
    xml As XmlNode,
    userState As Object
)
public:
void GetLicenseCustomDataAsync(
    XmlNode^ xml,
    Object^ userState
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
userState
Type: SystemObject
The user state object.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
GetLicenseCustomDataAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.GetLicenseCustomDataS Method

XmlLicenseServiceGetLicenseCustomDataS Method
Calls the GetLicenseCustomDataS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode GetLicenseCustomDataS(
    string xml
)
Public Function GetLicenseCustomDataS (
    xml As String
) As XmlNode
public:
XmlNode^ GetLicenseCustomDataS(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.GetLicenseCustomDataSAsync Method

XmlLicenseServiceGetLicenseCustomDataSAsync Method
Overload List
 | Name | Description
Public method | GetLicenseCustomDataSAsync(String) | Calls the GetLicenseCustomDataS web method.
Public method | GetLicenseCustomDataSAsync(String, Object) | Calls the GetLicenseCustomDataS web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.GetLicenseCustomDataSAsync Method (String)

XmlLicenseServiceGetLicenseCustomDataSAsync Method (String)
Calls the GetLicenseCustomDataS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void GetLicenseCustomDataSAsync(
    string xml
)
Public Sub GetLicenseCustomDataSAsync (
    xml As String
)
public:
void GetLicenseCustomDataSAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
GetLicenseCustomDataSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.GetLicenseCustomDataSAsync Method (String, Object)

XmlLicenseServiceGetLicenseCustomDataSAsync Method (String, Object)
Calls the GetLicenseCustomDataS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void GetLicenseCustomDataSAsync(
    string xml,
    Object userState
)
Public Sub GetLicenseCustomDataSAsync (
    xml As String,
    userState As Object
)
public:
void GetLicenseCustomDataSAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state object.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
GetLicenseCustomDataSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.InfoCheck Method

XmlLicenseServiceInfoCheck Method
Calls the InfoCheck web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode InfoCheck(
    XmlNode xml
)
Public Function InfoCheck (
    xml As XmlNode
) As XmlNode
public:
XmlNode^ InfoCheck(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.InfoCheckAsync Method

XmlLicenseServiceInfoCheckAsync Method
Overload List
 | Name | Description
Public method | InfoCheckAsync(XmlNode) | Calls the InfoCheck web method asynchronously.
Public method | InfoCheckAsync(XmlNode, Object) | Calls the InfoCheck web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.InfoCheckAsync Method (XmlNode)

XmlLicenseServiceInfoCheckAsync Method (XmlNode)
Calls the InfoCheck web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void InfoCheckAsync(
    XmlNode xml
)
Public Sub InfoCheckAsync (
    xml As XmlNode
)
public:
void InfoCheckAsync(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
InfoCheckAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.InfoCheckAsync Method (XmlNode, Object)

XmlLicenseServiceInfoCheckAsync Method (XmlNode, Object)
Calls the InfoCheck web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void InfoCheckAsync(
    XmlNode xml,
    Object userState
)
Public Sub InfoCheckAsync (
    xml As XmlNode,
    userState As Object
)
public:
void InfoCheckAsync(
    XmlNode^ xml,
    Object^ userState
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
InfoCheckAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.InfoCheckS Method

XmlLicenseServiceInfoCheckS Method
Calls the InfoCheckS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode InfoCheckS(
    string xml
)
Public Function InfoCheckS (
    xml As String
) As XmlNode
public:
XmlNode^ InfoCheckS(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.InfoCheckSAsync Method

XmlLicenseServiceInfoCheckSAsync Method
Overload List
 | Name | Description
Public method | InfoCheckSAsync(String) | Calls the InfoCheckS web method asynchronously.
Public method | InfoCheckSAsync(String, Object) | Calls the InfoCheckS web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.InfoCheckSAsync Method (String)

XmlLicenseServiceInfoCheckSAsync Method (String)
Calls the InfoCheckS web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void InfoCheckSAsync(
    string xml
)
Public Sub InfoCheckSAsync (
    xml As String
)
public:
void InfoCheckSAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
InfoCheckSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.InfoCheckSAsync Method (String, Object)

XmlLicenseServiceInfoCheckSAsync Method (String, Object)
Calls the InfoCheckS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void InfoCheckSAsync(
    string xml,
    Object userState
)
Public Sub InfoCheckSAsync (
    xml As String,
    userState As Object
)
public:
void InfoCheckSAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
InfoCheckSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.Register Method

XmlLicenseServiceRegister Method
Calls the Register web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode Register(
    XmlNode xml
)
Public Function Register (
    xml As XmlNode
) As XmlNode
public:
XmlNode^ Register(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.RegisterAsync Method

XmlLicenseServiceRegisterAsync Method
Overload List
 | Name | Description
Public method | RegisterAsync(XmlNode) | Calls the Register web method asynchronously.
Public method | RegisterAsync(XmlNode, Object) | Calls the Register web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.RegisterAsync Method (XmlNode)

XmlLicenseServiceRegisterAsync Method (XmlNode)
Calls the Register web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void RegisterAsync(
    XmlNode xml
)
Public Sub RegisterAsync (
    xml As XmlNode
)
public:
void RegisterAsync(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
RegisterAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.RegisterAsync Method (XmlNode, Object)

XmlLicenseServiceRegisterAsync Method (XmlNode, Object)
Calls the Register web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void RegisterAsync(
    XmlNode xml,
    Object userState
)
Public Sub RegisterAsync (
    xml As XmlNode,
    userState As Object
)
public:
void RegisterAsync(
    XmlNode^ xml,
    Object^ userState
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
userState
Type: SystemObject
The user state object.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
RegisterAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.RegisterS Method

XmlLicenseServiceRegisterS Method
Calls the RegisterS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode RegisterS(
    string xml
)
Public Function RegisterS (
    xml As String
) As XmlNode
public:
XmlNode^ RegisterS(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.RegisterSAsync Method

XmlLicenseServiceRegisterSAsync Method
Overload List
 | Name | Description
Public method | RegisterSAsync(String) | Calls the RegisterS web method asynchronously.
Public method | RegisterSAsync(String, Object) | Calls the RegisterS web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.RegisterSAsync Method (String)

XmlLicenseServiceRegisterSAsync Method (String)
Calls the RegisterS web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void RegisterSAsync(
    string xml
)
Public Sub RegisterSAsync (
    xml As String
)
public:
void RegisterSAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
RegisterSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.RegisterSAsync Method (String, Object)

XmlLicenseServiceRegisterSAsync Method (String, Object)
Calls the RegisterS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void RegisterSAsync(
    string xml,
    Object userState
)
Public Sub RegisterSAsync (
    xml As String,
    userState As Object
)
public:
void RegisterSAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state object

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
RegisterSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateActivationFields Method

XmlLicenseServiceUpdateActivationFields Method
Calls the UpdateActivationFields web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode UpdateActivationFields(
    string xml
)
Public Function UpdateActivationFields (
    xml As String
) As XmlNode
public:
XmlNode^ UpdateActivationFields(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateActivationFieldsAsync Method

XmlLicenseServiceUpdateActivationFieldsAsync Method
Overload List
 | Name | Description
Public method | UpdateActivationFieldsAsync(String) | Calls the UpdateActivationFields web method.
Public method | UpdateActivationFieldsAsync(String, Object) | Calls the UpdateActivationFields web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateActivationFieldsAsync Method (String)

XmlLicenseServiceUpdateActivationFieldsAsync Method (String)
Calls the UpdateActivationFields web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateActivationFieldsAsync(
    string xml
)
Public Sub UpdateActivationFieldsAsync (
    xml As String
)
public:
void UpdateActivationFieldsAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateActivationFieldsAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateActivationFieldsAsync Method (String, Object)

XmlLicenseServiceUpdateActivationFieldsAsync Method (String, Object)
Calls the UpdateActivationFields web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateActivationFieldsAsync(
    string xml,
    Object userState
)
Public Sub UpdateActivationFieldsAsync (
    xml As String,
    userState As Object
)
public:
void UpdateActivationFieldsAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state object.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateActivationFieldsAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateCheck Method

XmlLicenseServiceUpdateCheck Method
Calls the UpdateCheck web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode UpdateCheck(
    XmlNode xml
)
Public Function UpdateCheck (
    xml As XmlNode
) As XmlNode
public:
XmlNode^ UpdateCheck(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the UpdateCheck class instead.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateCheckAsync Method

XmlLicenseServiceUpdateCheckAsync Method
Overload List
 | Name | Description
Public method | UpdateCheckAsync(XmlNode) | Calls the UpdateCheck web method asynchronously.
Public method | UpdateCheckAsync(XmlNode, Object) | Calls the UpdateCheck web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateCheckAsync Method (XmlNode)

XmlLicenseServiceUpdateCheckAsync Method (XmlNode)
Calls the UpdateCheck web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateCheckAsync(
    XmlNode xml
)
Public Sub UpdateCheckAsync (
    xml As XmlNode
)
public:
void UpdateCheckAsync(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the UpdateCheck class instead.

See Also

Reference

XmlLicenseService Class
UpdateCheckAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateCheckAsync Method (XmlNode, Object)

XmlLicenseServiceUpdateCheckAsync Method (XmlNode, Object)
Calls the UpdateCheck web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateCheckAsync(
    XmlNode xml,
    Object userState
)
Public Sub UpdateCheckAsync (
    xml As XmlNode,
    userState As Object
)
public:
void UpdateCheckAsync(
    XmlNode^ xml,
    Object^ userState
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the UpdateCheck class instead.

See Also

Reference

XmlLicenseService Class
UpdateCheckAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateCheckS Method

XmlLicenseServiceUpdateCheckS Method
Calls the UpdateCheckS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode UpdateCheckS(
    string xml
)
Public Function UpdateCheckS (
    xml As String
) As XmlNode
public:
XmlNode^ UpdateCheckS(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the UpdateCheck class instead.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateCheckSAsync Method

XmlLicenseServiceUpdateCheckSAsync Method
Overload List
 | Name | Description
Public method | UpdateCheckSAsync(String) | Calls the UpdateCheckS web method asynchronously.
Public method | UpdateCheckSAsync(String, Object) | Calls the UpdateCheck web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateCheckSAsync Method (String)

XmlLicenseServiceUpdateCheckSAsync Method (String)
Calls the UpdateCheckS web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateCheckSAsync(
    string xml
)
Public Sub UpdateCheckSAsync (
    xml As String
)
public:
void UpdateCheckSAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the UpdateCheck class instead.

See Also

Reference

XmlLicenseService Class
UpdateCheckSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateCheckSAsync Method (String, Object)

XmlLicenseServiceUpdateCheckSAsync Method (String, Object)
Calls the UpdateCheck web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateCheckSAsync(
    string xml,
    Object userState
)
Public Sub UpdateCheckSAsync (
    xml As String,
    userState As Object
)
public:
void UpdateCheckSAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the UpdateCheck class instead.

See Also

Reference

XmlLicenseService Class
UpdateCheckSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateLicenseCustomData Method

XmlLicenseServiceUpdateLicenseCustomData Method
Calls the UpdateLicenseCustomData web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode UpdateLicenseCustomData(
    XmlNode xml
)
Public Function UpdateLicenseCustomData (
    xml As XmlNode
) As XmlNode
public:
XmlNode^ UpdateLicenseCustomData(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateLicenseCustomDataAsync Method

XmlLicenseServiceUpdateLicenseCustomDataAsync Method
Overload List
 | Name | Description
Public method | UpdateLicenseCustomDataAsync(XmlNode) | Calls the UpdateLicenseCustomData web method.
Public method | UpdateLicenseCustomDataAsync(XmlNode, Object) | Calls the UpdateLicenseCustomData web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateLicenseCustomDataAsync Method (XmlNode)

XmlLicenseServiceUpdateLicenseCustomDataAsync Method (XmlNode)
Calls the UpdateLicenseCustomData web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateLicenseCustomDataAsync(
    XmlNode xml
)
Public Sub UpdateLicenseCustomDataAsync (
    xml As XmlNode
)
public:
void UpdateLicenseCustomDataAsync(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateLicenseCustomDataAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateLicenseCustomDataAsync Method (XmlNode, Object)

XmlLicenseServiceUpdateLicenseCustomDataAsync Method (XmlNode, Object)
Calls the UpdateLicenseCustomData web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateLicenseCustomDataAsync(
    XmlNode xml,
    Object userState
)
Public Sub UpdateLicenseCustomDataAsync (
    xml As XmlNode,
    userState As Object
)
public:
void UpdateLicenseCustomDataAsync(
    XmlNode^ xml,
    Object^ userState
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
userState
Type: SystemObject
The user state object.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateLicenseCustomDataAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateLicenseCustomDataS Method

XmlLicenseServiceUpdateLicenseCustomDataS Method
Calls the UpdateLicenseCustomDataS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode UpdateLicenseCustomDataS(
    string xml
)
Public Function UpdateLicenseCustomDataS (
    xml As String
) As XmlNode
public:
XmlNode^ UpdateLicenseCustomDataS(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateLicenseCustomDataSAsync Method

XmlLicenseServiceUpdateLicenseCustomDataSAsync Method
Overload List
 | Name | Description
Public method | UpdateLicenseCustomDataSAsync(String) | Calls the UpdateLicenseCustomDataS web method.
Public method | UpdateLicenseCustomDataSAsync(String, Object) | Calls the UpdateLicenseCustomDataS web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateLicenseCustomDataSAsync Method (String)

XmlLicenseServiceUpdateLicenseCustomDataSAsync Method (String)
Calls the UpdateLicenseCustomDataS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateLicenseCustomDataSAsync(
    string xml
)
Public Sub UpdateLicenseCustomDataSAsync (
    xml As String
)
public:
void UpdateLicenseCustomDataSAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateLicenseCustomDataSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateLicenseCustomDataSAsync Method (String, Object)

XmlLicenseServiceUpdateLicenseCustomDataSAsync Method (String, Object)
Calls the UpdateLicenseCustomDataS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateLicenseCustomDataSAsync(
    string xml,
    Object userState
)
Public Sub UpdateLicenseCustomDataSAsync (
    xml As String,
    userState As Object
)
public:
void UpdateLicenseCustomDataSAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state object.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateLicenseCustomDataSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateRegistration Method

XmlLicenseServiceUpdateRegistration Method
Calls the UpdateRegistration web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode UpdateRegistration(
    XmlNode xml
)
Public Function UpdateRegistration (
    xml As XmlNode
) As XmlNode
public:
XmlNode^ UpdateRegistration(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateRegistrationAsync Method

XmlLicenseServiceUpdateRegistrationAsync Method
Overload List
 | Name | Description
Public method | UpdateRegistrationAsync(XmlNode) | Calls the UpdateRegistration web method asynchronously.
Public method | UpdateRegistrationAsync(XmlNode, Object) | Calls the UpdateRegistration web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateRegistrationAsync Method (XmlNode)

XmlLicenseServiceUpdateRegistrationAsync Method (XmlNode)
Calls the UpdateRegistration web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateRegistrationAsync(
    XmlNode xml
)
Public Sub UpdateRegistrationAsync (
    xml As XmlNode
)
public:
void UpdateRegistrationAsync(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateRegistrationAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateRegistrationAsync Method (XmlNode, Object)

XmlLicenseServiceUpdateRegistrationAsync Method (XmlNode, Object)
Calls the UpdateRegistration web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateRegistrationAsync(
    XmlNode xml,
    Object userState
)
Public Sub UpdateRegistrationAsync (
    xml As XmlNode,
    userState As Object
)
public:
void UpdateRegistrationAsync(
    XmlNode^ xml,
    Object^ userState
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
userState
Type: SystemObject
The user state object.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateRegistrationAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateRegistrationS Method

XmlLicenseServiceUpdateRegistrationS Method
Calls the UpdateRegistrationS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode UpdateRegistrationS(
    string xml
)
Public Function UpdateRegistrationS (
    xml As String
) As XmlNode
public:
XmlNode^ UpdateRegistrationS(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateRegistrationSAsync Method

XmlLicenseServiceUpdateRegistrationSAsync Method
Overload List
 | Name | Description
Public method | UpdateRegistrationSAsync(String) | Calls the UpdateRegistrationS web method asynchronously.
Public method | UpdateRegistrationSAsync(String, Object) | Calls the UpdateRegistrationS web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateRegistrationSAsync Method (String)

XmlLicenseServiceUpdateRegistrationSAsync Method (String)
Calls the UpdateRegistrationS web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateRegistrationSAsync(
    string xml
)
Public Sub UpdateRegistrationSAsync (
    xml As String
)
public:
void UpdateRegistrationSAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateRegistrationSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateRegistrationSAsync Method (String, Object)

XmlLicenseServiceUpdateRegistrationSAsync Method (String, Object)
Calls the UpdateRegistrationS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateRegistrationSAsync(
    string xml,
    Object userState
)
Public Sub UpdateRegistrationSAsync (
    xml As String,
    userState As Object
)
public:
void UpdateRegistrationSAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state object.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateRegistrationSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateUserDefinedFields Method

XmlLicenseServiceUpdateUserDefinedFields Method
Calls the UpdateUserDefinedFields web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode UpdateUserDefinedFields(
    XmlNode xml
)
Public Function UpdateUserDefinedFields (
    xml As XmlNode
) As XmlNode
public:
XmlNode^ UpdateUserDefinedFields(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateUserDefinedFieldsAsync Method

XmlLicenseServiceUpdateUserDefinedFieldsAsync Method
Overload List
 | Name | Description
Public method | UpdateUserDefinedFieldsAsync(XmlNode) | Calls the UpdateUserDefinedFields web method.
Public method | UpdateUserDefinedFieldsAsync(XmlNode, Object) | Calls the UpdateUserDefinedFields web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateUserDefinedFieldsAsync Method (XmlNode)

XmlLicenseServiceUpdateUserDefinedFieldsAsync Method (XmlNode)
Calls the UpdateUserDefinedFields web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateUserDefinedFieldsAsync(
    XmlNode xml
)
Public Sub UpdateUserDefinedFieldsAsync (
    xml As XmlNode
)
public:
void UpdateUserDefinedFieldsAsync(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateUserDefinedFieldsAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateUserDefinedFieldsAsync Method (XmlNode, Object)

XmlLicenseServiceUpdateUserDefinedFieldsAsync Method (XmlNode, Object)
Calls the UpdateUserDefinedFields web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateUserDefinedFieldsAsync(
    XmlNode xml,
    Object userState
)
Public Sub UpdateUserDefinedFieldsAsync (
    xml As XmlNode,
    userState As Object
)
public:
void UpdateUserDefinedFieldsAsync(
    XmlNode^ xml,
    Object^ userState
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
userState
Type: SystemObject
The user state object.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateUserDefinedFieldsAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateUserDefinedFieldsS Method

XmlLicenseServiceUpdateUserDefinedFieldsS Method
Calls the UpdateUserDefinedFieldsS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode UpdateUserDefinedFieldsS(
    string xml
)
Public Function UpdateUserDefinedFieldsS (
    xml As String
) As XmlNode
public:
XmlNode^ UpdateUserDefinedFieldsS(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateUserDefinedFieldsSAsync Method

XmlLicenseServiceUpdateUserDefinedFieldsSAsync Method
Overload List
 | Name | Description
Public method | UpdateUserDefinedFieldsSAsync(String) | Calls the UpdateUserDefinedFieldsS web method asynchronously.
Public method | UpdateUserDefinedFieldsSAsync(String, Object) | Calls the UpdateUserDefinedFieldsS web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateUserDefinedFieldsSAsync Method (String)

XmlLicenseServiceUpdateUserDefinedFieldsSAsync Method (String)
Calls the UpdateUserDefinedFieldsS web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateUserDefinedFieldsSAsync(
    string xml
)
Public Sub UpdateUserDefinedFieldsSAsync (
    xml As String
)
public:
void UpdateUserDefinedFieldsSAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateUserDefinedFieldsSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateUserDefinedFieldsSAsync Method (String, Object)

XmlLicenseServiceUpdateUserDefinedFieldsSAsync Method (String, Object)
Calls the UpdateUserDefinedFieldsS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void UpdateUserDefinedFieldsSAsync(
    string xml,
    Object userState
)
Public Sub UpdateUserDefinedFieldsSAsync (
    xml As String,
    userState As Object
)
public:
void UpdateUserDefinedFieldsSAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state object.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
UpdateUserDefinedFieldsSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.ValidateRegistration Method

XmlLicenseServiceValidateRegistration Method
Calls the ValidateRegistration web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode ValidateRegistration(
    XmlNode xml
)
Public Function ValidateRegistration (
    xml As XmlNode
) As XmlNode
public:
XmlNode^ ValidateRegistration(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.ValidateRegistrationAsync Method

XmlLicenseServiceValidateRegistrationAsync Method
Overload List
 | Name | Description
Public method | ValidateRegistrationAsync(XmlNode) | Calls the ValidateRegistration web method asynchronously.
Public method | ValidateRegistrationAsync(XmlNode, Object) | Calls the ValidateRegistration web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.ValidateRegistrationAsync Method (XmlNode)

XmlLicenseServiceValidateRegistrationAsync Method (XmlNode)
Calls the ValidateRegistration web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ValidateRegistrationAsync(
    XmlNode xml
)
Public Sub ValidateRegistrationAsync (
    xml As XmlNode
)
public:
void ValidateRegistrationAsync(
    XmlNode^ xml
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
ValidateRegistrationAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.ValidateRegistrationAsync Method (XmlNode, Object)

XmlLicenseServiceValidateRegistrationAsync Method (XmlNode, Object)
Calls the ValidateRegistration web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ValidateRegistrationAsync(
    XmlNode xml,
    Object userState
)
Public Sub ValidateRegistrationAsync (
    xml As XmlNode,
    userState As Object
)
public:
void ValidateRegistrationAsync(
    XmlNode^ xml,
    Object^ userState
)

Parameters

xml
Type: System.XmlXmlNode
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
ValidateRegistrationAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.ValidateRegistrationS Method

XmlLicenseServiceValidateRegistrationS Method
Calls the ValidateRegistrationS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode ValidateRegistrationS(
    string xml
)
Public Function ValidateRegistrationS (
    xml As String
) As XmlNode
public:
XmlNode^ ValidateRegistrationS(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.ValidateRegistrationSAsync Method

XmlLicenseServiceValidateRegistrationSAsync Method
Overload List
 | Name | Description
Public method | ValidateRegistrationSAsync(String) | Calls the ValidateRegistrationS web method.
Public method | ValidateRegistrationSAsync(String, Object) | Calls the ValidateRegistration web method.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.ValidateRegistrationSAsync Method (String)

XmlLicenseServiceValidateRegistrationSAsync Method (String)
Calls the ValidateRegistrationS web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ValidateRegistrationSAsync(
    string xml
)
Public Sub ValidateRegistrationSAsync (
    xml As String
)
public:
void ValidateRegistrationSAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
ValidateRegistrationSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.ValidateRegistrationSAsync Method (String, Object)

XmlLicenseServiceValidateRegistrationSAsync Method (String, Object)
Calls the ValidateRegistration web method.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void ValidateRegistrationSAsync(
    string xml,
    Object userState
)
Public Sub ValidateRegistrationSAsync (
    xml As String,
    userState As Object
)
public:
void ValidateRegistrationSAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state object.

Return Value

Type:
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly.

See Also

Reference

XmlLicenseService Class
ValidateRegistrationSAsync Overload
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService Events

XmlLicenseService Events

The XmlLicenseService type exposes the following members.

Events
 | Name | Description
Public event | AddCompleted | Occurs when an asynchronous call to Add has completed.
Public event | AddSCompleted | Occurs when an asynchronous call to AddS has completed.
Public event | Disposed | (Inherited from Component.)
Public event | GetLicenseCustomDataCompleted | Occurs when an asynchronous call to GetLicenseCustomData has completed.
Public event | GetLicenseCustomDataSCompleted | Occurs when an asynchronous call to GetLicenseCustomDataS has completed.
Public event | InfoCheckCompleted | Occurs when an asynchronous call to InfoCheck has completed.
Public event | InfoCheckSCompleted | Occurs when an asynchronous call to InfoCheckS has completed.
Public event | RegisterCompleted | Occurs when an asynchronous call to Register has completed.
Public event | RegisterSCompleted | Occurs when an asynchronous call to RegisterS has completed.
Public event | UpdateActivationFieldsCompleted | Occurs when an asynchronous call to UpdateActivationFields has completed.
Public event | UpdateCheckCompleted | Occurs when an asynchronous call to UpdateCheck has completed.
Public event | UpdateCheckSCompleted | Occurs when an asynchronous call to UpdateCheckS has completed.
Public event | UpdateLicenseCustomDataCompleted | Occurs when an asynchronous call to UpdateLicenseCustomData has completed.
Public event | UpdateLicenseCustomDataSCompleted | Occurs when an asynchronous call to UpdateLicenseCustomDataS has completed.
Public event | UpdateRegistrationCompleted | Occurs when an asynchronous call to UpdateRegistration has completed.
Public event | UpdateRegistrationSCompleted | Occurs when an asynchronous call to UpdateRegistrationS has completed.
Public event | UpdateUserDefinedFieldsCompleted | Occurs when an asynchronous call to UpdateUserDefinedFields has completed.
Public event | UpdateUserDefinedFieldsSCompleted | Occurs when an asynchronous call to UpdateUserDefinedFieldsS has completed.
Public event | ValidateRegistrationCompleted | Occurs when an asynchronous call to ValidateRegistration has completed.
Public event | ValidateRegistrationSCompleted | Occurs when an asynchronous call to ValidateRegistrationS has completed.
Top
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.AddCompleted Event

XmlLicenseServiceAddCompleted Event
Occurs when an asynchronous call to Add has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event AddCompletedEventHandler AddCompleted
Public Event AddCompleted As AddCompletedEventHandler
public:
 event AddCompletedEventHandler^ AddCompleted {
    void add (AddCompletedEventHandler^ value);
    void remove (AddCompletedEventHandler^ value);
}

Value

Type: AddCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.AddSCompleted Event

XmlLicenseServiceAddSCompleted Event
Occurs when an asynchronous call to AddS has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event AddSCompletedEventHandler AddSCompleted
Public Event AddSCompleted As AddSCompletedEventHandler
public:
 event AddSCompletedEventHandler^ AddSCompleted {
    void add (AddSCompletedEventHandler^ value);
    void remove (AddSCompletedEventHandler^ value);
}

Value

Type: AddSCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.GetLicenseCustomDataCompleted Event

XmlLicenseServiceGetLicenseCustomDataCompleted Event
Occurs when an asynchronous call to GetLicenseCustomData has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event GetLicenseCustomDataCompletedEventHandler GetLicenseCustomDataCompleted
Public Event GetLicenseCustomDataCompleted As GetLicenseCustomDataCompletedEventHandler
public:
 event GetLicenseCustomDataCompletedEventHandler^ GetLicenseCustomDataCompleted {
    void add (GetLicenseCustomDataCompletedEventHandler^ value);
    void remove (GetLicenseCustomDataCompletedEventHandler^ value);
}

Value

Type: GetLicenseCustomDataCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.GetLicenseCustomDataSCompleted Event

XmlLicenseServiceGetLicenseCustomDataSCompleted Event
Occurs when an asynchronous call to GetLicenseCustomDataS has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event GetLicenseCustomDataSCompletedEventHandler GetLicenseCustomDataSCompleted
Public Event GetLicenseCustomDataSCompleted As GetLicenseCustomDataSCompletedEventHandler
public:
 event GetLicenseCustomDataSCompletedEventHandler^ GetLicenseCustomDataSCompleted {
    void add (GetLicenseCustomDataSCompletedEventHandler^ value);
    void remove (GetLicenseCustomDataSCompletedEventHandler^ value);
}

Value

Type: GetLicenseCustomDataSCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.InfoCheckCompleted Event

XmlLicenseServiceInfoCheckCompleted Event
Occurs when an asynchronous call to InfoCheck has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event InfoCheckCompletedEventHandler InfoCheckCompleted
Public Event InfoCheckCompleted As InfoCheckCompletedEventHandler
public:
 event InfoCheckCompletedEventHandler^ InfoCheckCompleted {
    void add (InfoCheckCompletedEventHandler^ value);
    void remove (InfoCheckCompletedEventHandler^ value);
}

Value

Type: InfoCheckCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.InfoCheckSCompleted Event

XmlLicenseServiceInfoCheckSCompleted Event
Occurs when an asynchronous call to InfoCheckS has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event InfoCheckSCompletedEventHandler InfoCheckSCompleted
Public Event InfoCheckSCompleted As InfoCheckSCompletedEventHandler
public:
 event InfoCheckSCompletedEventHandler^ InfoCheckSCompleted {
    void add (InfoCheckSCompletedEventHandler^ value);
    void remove (InfoCheckSCompletedEventHandler^ value);
}

Value

Type: InfoCheckSCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.RegisterCompleted Event

XmlLicenseServiceRegisterCompleted Event
Occurs when an asynchronous call to Register has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event RegisterCompletedEventHandler RegisterCompleted
Public Event RegisterCompleted As RegisterCompletedEventHandler
public:
 event RegisterCompletedEventHandler^ RegisterCompleted {
    void add (RegisterCompletedEventHandler^ value);
    void remove (RegisterCompletedEventHandler^ value);
}

Value

Type: RegisterCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.RegisterSCompleted Event

XmlLicenseServiceRegisterSCompleted Event
Occurs when an asynchronous call to RegisterS has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event RegisterSCompletedEventHandler RegisterSCompleted
Public Event RegisterSCompleted As RegisterSCompletedEventHandler
public:
 event RegisterSCompletedEventHandler^ RegisterSCompleted {
    void add (RegisterSCompletedEventHandler^ value);
    void remove (RegisterSCompletedEventHandler^ value);
}

Value

Type: RegisterSCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateActivationFieldsCompleted Event

XmlLicenseServiceUpdateActivationFieldsCompleted Event
Occurs when an asynchronous call to UpdateActivationFields has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event UpdateActivationFieldsCompletedEventHandler UpdateActivationFieldsCompleted
Public Event UpdateActivationFieldsCompleted As UpdateActivationFieldsCompletedEventHandler
public:
 event UpdateActivationFieldsCompletedEventHandler^ UpdateActivationFieldsCompleted {
    void add (UpdateActivationFieldsCompletedEventHandler^ value);
    void remove (UpdateActivationFieldsCompletedEventHandler^ value);
}

Value

Type: UpdateActivationFieldsCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateCheckCompleted Event

XmlLicenseServiceUpdateCheckCompleted Event
Occurs when an asynchronous call to UpdateCheck has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event UpdateCheckCompletedEventHandler UpdateCheckCompleted
Public Event UpdateCheckCompleted As UpdateCheckCompletedEventHandler
public:
 event UpdateCheckCompletedEventHandler^ UpdateCheckCompleted {
    void add (UpdateCheckCompletedEventHandler^ value);
    void remove (UpdateCheckCompletedEventHandler^ value);
}

Value

Type: UpdateCheckCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateCheckSCompleted Event

XmlLicenseServiceUpdateCheckSCompleted Event
Occurs when an asynchronous call to UpdateCheckS has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event UpdateCheckSCompletedEventHandler UpdateCheckSCompleted
Public Event UpdateCheckSCompleted As UpdateCheckSCompletedEventHandler
public:
 event UpdateCheckSCompletedEventHandler^ UpdateCheckSCompleted {
    void add (UpdateCheckSCompletedEventHandler^ value);
    void remove (UpdateCheckSCompletedEventHandler^ value);
}

Value

Type: UpdateCheckSCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateLicenseCustomDataCompleted Event

XmlLicenseServiceUpdateLicenseCustomDataCompleted Event
Occurs when an asynchronous call to UpdateLicenseCustomData has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event UpdateLicenseCustomDataCompletedEventHandler UpdateLicenseCustomDataCompleted
Public Event UpdateLicenseCustomDataCompleted As UpdateLicenseCustomDataCompletedEventHandler
public:
 event UpdateLicenseCustomDataCompletedEventHandler^ UpdateLicenseCustomDataCompleted {
    void add (UpdateLicenseCustomDataCompletedEventHandler^ value);
    void remove (UpdateLicenseCustomDataCompletedEventHandler^ value);
}

Value

Type: UpdateLicenseCustomDataCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateLicenseCustomDataSCompleted Event

XmlLicenseServiceUpdateLicenseCustomDataSCompleted Event
Occurs when an asynchronous call to UpdateLicenseCustomDataS has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event UpdateLicenseCustomDataSCompletedEventHandler UpdateLicenseCustomDataSCompleted
Public Event UpdateLicenseCustomDataSCompleted As UpdateLicenseCustomDataSCompletedEventHandler
public:
 event UpdateLicenseCustomDataSCompletedEventHandler^ UpdateLicenseCustomDataSCompleted {
    void add (UpdateLicenseCustomDataSCompletedEventHandler^ value);
    void remove (UpdateLicenseCustomDataSCompletedEventHandler^ value);
}

Value

Type: UpdateLicenseCustomDataSCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateRegistrationCompleted Event

XmlLicenseServiceUpdateRegistrationCompleted Event
Occurs when an asynchronous call to UpdateRegistration has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event UpdateRegistrationCompletedEventHandler UpdateRegistrationCompleted
Public Event UpdateRegistrationCompleted As UpdateRegistrationCompletedEventHandler
public:
 event UpdateRegistrationCompletedEventHandler^ UpdateRegistrationCompleted {
    void add (UpdateRegistrationCompletedEventHandler^ value);
    void remove (UpdateRegistrationCompletedEventHandler^ value);
}

Value

Type: UpdateRegistrationCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateRegistrationSCompleted Event

XmlLicenseServiceUpdateRegistrationSCompleted Event
Occurs when an asynchronous call to UpdateRegistrationS has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event UpdateRegistrationSCompletedEventHandler UpdateRegistrationSCompleted
Public Event UpdateRegistrationSCompleted As UpdateRegistrationSCompletedEventHandler
public:
 event UpdateRegistrationSCompletedEventHandler^ UpdateRegistrationSCompleted {
    void add (UpdateRegistrationSCompletedEventHandler^ value);
    void remove (UpdateRegistrationSCompletedEventHandler^ value);
}

Value

Type: UpdateRegistrationSCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateUserDefinedFieldsCompleted Event

XmlLicenseServiceUpdateUserDefinedFieldsCompleted Event
Occurs when an asynchronous call to UpdateUserDefinedFields has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event UpdateUserDefinedFieldsCompletedEventHandler UpdateUserDefinedFieldsCompleted
Public Event UpdateUserDefinedFieldsCompleted As UpdateUserDefinedFieldsCompletedEventHandler
public:
 event UpdateUserDefinedFieldsCompletedEventHandler^ UpdateUserDefinedFieldsCompleted {
    void add (UpdateUserDefinedFieldsCompletedEventHandler^ value);
    void remove (UpdateUserDefinedFieldsCompletedEventHandler^ value);
}

Value

Type: UpdateUserDefinedFieldsCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.UpdateUserDefinedFieldsSCompleted Event

XmlLicenseServiceUpdateUserDefinedFieldsSCompleted Event
Occurs when an asynchronous call to UpdateUserDefinedFieldsS has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event UpdateUserDefinedFieldsSCompletedEventHandler UpdateUserDefinedFieldsSCompleted
Public Event UpdateUserDefinedFieldsSCompleted As UpdateUserDefinedFieldsSCompletedEventHandler
public:
 event UpdateUserDefinedFieldsSCompletedEventHandler^ UpdateUserDefinedFieldsSCompleted {
    void add (UpdateUserDefinedFieldsSCompletedEventHandler^ value);
    void remove (UpdateUserDefinedFieldsSCompletedEventHandler^ value);
}

Value

Type: UpdateUserDefinedFieldsSCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.ValidateRegistrationCompleted Event

XmlLicenseServiceValidateRegistrationCompleted Event
Occurs when an asynchronous call to ValidateRegistration has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event ValidateRegistrationCompletedEventHandler ValidateRegistrationCompleted
Public Event ValidateRegistrationCompleted As ValidateRegistrationCompletedEventHandler
public:
 event ValidateRegistrationCompletedEventHandler^ ValidateRegistrationCompleted {
    void add (ValidateRegistrationCompletedEventHandler^ value);
    void remove (ValidateRegistrationCompletedEventHandler^ value);
}

Value

Type: ValidateRegistrationCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


XmlLicenseService.ValidateRegistrationSCompleted Event

XmlLicenseServiceValidateRegistrationSCompleted Event
Occurs when an asynchronous call to ValidateRegistrationS has completed.

Namespace: com.softwarekey.Client.WebService.XmlLicenseService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event ValidateRegistrationSCompletedEventHandler ValidateRegistrationSCompleted
Public Event ValidateRegistrationSCompleted As ValidateRegistrationSCompletedEventHandler
public:
 event ValidateRegistrationSCompletedEventHandler^ ValidateRegistrationSCompleted {
    void add (ValidateRegistrationSCompletedEventHandler^ value);
    void remove (ValidateRegistrationSCompletedEventHandler^ value);
}

Value

Type: ValidateRegistrationSCompletedEventHandler
See Also

Reference

XmlLicenseService Class
com.softwarekey.Client.WebService.XmlLicenseService Namespace


com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace

com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace
Contains classes and data for making calls to the XmlNetworkFloatingService web service. Direct use of these objects is atypical, as it would normally be used through a [com.softwarekey.Client.Licensing.Network.NetworkSession] object.
Classes
 | Class | Description
Public class | CheckinSession | NetworkFloatingServiceCall implementation for checking-in a session which has been checked out by a CheckoutSession call.
Public class | CheckoutSession | NetworkFloatingServiceCall implementation for checking a session out for offline use, which may later be checked back in by a CheckinSession call.
Public class | CloseSession | NetworkFloatingServiceCall implementation for closing a session which has been opened by an OpenSession call.
Public class | NetworkFloatingServiceCall | Base class from which all calls to SOLO Server's XmlNetworkFloatingService are implemented.
Public class | OpenSession | NetworkFloatingServiceCall implementation for opening a new session. The opened session can be polled/checked by a PollSession call, or closed by a CloseSession call.
Public class | PollSession | NetworkFloatingServiceCall implementation for polling a session which was opened by an OpenSession call.
Public class | XmlNetworkFloatingService | SoapHttpClientProtocol implementation for calling methods in SOLO Server's XmlNetworkFloatingService web service.
Enumerations
 | Enumeration | Description
Public enumeration | NetworkFloatingServiceCallNetworkFloatingServiceCallType | Types of web service calls that can be made.


CheckinSession Class

CheckinSession Class
NetworkFloatingServiceCall implementation for checking-in a session which has been checked out by a CheckoutSession call.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceNetworkFloatingServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceCheckinSession

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class CheckinSession : NetworkFloatingServiceCall
Public Class CheckinSession
    Inherits NetworkFloatingServiceCall
public ref class CheckinSession : public NetworkFloatingServiceCall

The CheckinSession type exposes the following members.

Constructors
 | Name | Description
Public method | CheckinSession(AuthorEncryptionKey) | Creates a new CheckinSession object.
Public method | CheckinSession(XmlNetworkFloatingService, AuthorEncryptionKey) | Creates a new CheckinSession object.
Top
Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method. (Inherited from NetworkFloatingServiceCall.)
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file. (Inherited from NetworkFloatingServiceCall.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests. (Inherited from NetworkFloatingServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession). (Inherited from NetworkFloatingServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Inherited from NetworkFloatingServiceCall.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Inherited from NetworkFloatingServiceCall.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Caution note Caution

Unless a custom implementation is required, the NetworkSession.CheckinSession method should be used instead.

Caution note Caution

The following properties must be set before calling the CallWebService method.

  • SessionID
  • ActivationData (Necessary if you wish to bind the certificate to the system for check-outs.)
See Also

Reference

com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckinSession Constructor

CheckinSession Constructor
Overload List
 | Name | Description
Public method | CheckinSession(AuthorEncryptionKey) | Creates a new CheckinSession object.
Public method | CheckinSession(XmlNetworkFloatingService, AuthorEncryptionKey) | Creates a new CheckinSession object.
Top
See Also

Reference

CheckinSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckinSession Constructor (AuthorEncryptionKey)

CheckinSession Constructor (AuthorEncryptionKey)
Creates a new CheckinSession object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CheckinSession(
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey
)
public:
CheckinSession(
    AuthorEncryptionKey^ encryptionKey
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
See Also

Reference

CheckinSession Class
CheckinSession Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckinSession Constructor (XmlNetworkFloatingService, AuthorEncryptionKey)

CheckinSession Constructor (XmlNetworkFloatingService, AuthorEncryptionKey)
Creates a new CheckinSession object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CheckinSession(
    XmlNetworkFloatingService client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    client As XmlNetworkFloatingService,
    encryptionKey As AuthorEncryptionKey
)
public:
CheckinSession(
    XmlNetworkFloatingService^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService
The SoapHttpClientProtocol used to call the web service method.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
See Also

Reference

CheckinSession Class
CheckinSession Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckinSession Properties

CheckinSession Properties

The CheckinSession type exposes the following members.

Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method. (Inherited from NetworkFloatingServiceCall.)
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file. (Inherited from NetworkFloatingServiceCall.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests. (Inherited from NetworkFloatingServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession). (Inherited from NetworkFloatingServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

CheckinSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckinSession Methods

CheckinSession Methods

The CheckinSession type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Inherited from NetworkFloatingServiceCall.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Inherited from NetworkFloatingServiceCall.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CheckinSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckoutSession Class

CheckoutSession Class
NetworkFloatingServiceCall implementation for checking a session out for offline use, which may later be checked back in by a CheckinSession call.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceNetworkFloatingServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceCheckoutSession

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class CheckoutSession : NetworkFloatingServiceCall
Public Class CheckoutSession
    Inherits NetworkFloatingServiceCall
public ref class CheckoutSession : public NetworkFloatingServiceCall

The CheckoutSession type exposes the following members.

Constructors
 | Name | Description
Public method | CheckoutSession(AuthorEncryptionKey) | Creates a new CheckoutSession object.
Public method | CheckoutSession(XmlNetworkFloatingService, AuthorEncryptionKey) | Creates a new CheckoutSession object.
Top
Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method. (Inherited from NetworkFloatingServiceCall.)
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file. (Inherited from NetworkFloatingServiceCall.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests. (Inherited from NetworkFloatingServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession). (Inherited from NetworkFloatingServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Inherited from NetworkFloatingServiceCall.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Inherited from NetworkFloatingServiceCall.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Caution note Caution

Unless a custom implementation is required, the NetworkSession.CheckoutSession method should be used instead.

Caution note Caution

The following properties must be set before calling the CallWebService method.

  • SessionID
  • RequestedCheckoutDuration
  • CertificatePath
  • ActivationData (Necessary if you wish to bind the certificate to the system for check-outs.)
See Also

Reference

com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckoutSession Constructor

CheckoutSession Constructor
Overload List
 | Name | Description
Public method | CheckoutSession(AuthorEncryptionKey) | Creates a new CheckoutSession object.
Public method | CheckoutSession(XmlNetworkFloatingService, AuthorEncryptionKey) | Creates a new CheckoutSession object.
Top
See Also

Reference

CheckoutSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckoutSession Constructor (AuthorEncryptionKey)

CheckoutSession Constructor (AuthorEncryptionKey)
Creates a new CheckoutSession object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CheckoutSession(
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey
)
public:
CheckoutSession(
    AuthorEncryptionKey^ encryptionKey
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
See Also

Reference

CheckoutSession Class
CheckoutSession Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckoutSession Constructor (XmlNetworkFloatingService, AuthorEncryptionKey)

CheckoutSession Constructor (XmlNetworkFloatingService, AuthorEncryptionKey)
Creates a new CheckoutSession object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CheckoutSession(
    XmlNetworkFloatingService client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    client As XmlNetworkFloatingService,
    encryptionKey As AuthorEncryptionKey
)
public:
CheckoutSession(
    XmlNetworkFloatingService^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService
The SoapHttpClientProtocol used to call the web service method.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
See Also

Reference

CheckoutSession Class
CheckoutSession Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckoutSession Properties

CheckoutSession Properties

The CheckoutSession type exposes the following members.

Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method. (Inherited from NetworkFloatingServiceCall.)
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file. (Inherited from NetworkFloatingServiceCall.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests. (Inherited from NetworkFloatingServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession). (Inherited from NetworkFloatingServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

CheckoutSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CheckoutSession Methods

CheckoutSession Methods

The CheckoutSession type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Inherited from NetworkFloatingServiceCall.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Inherited from NetworkFloatingServiceCall.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CheckoutSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CloseSession Class

CloseSession Class
NetworkFloatingServiceCall implementation for closing a session which has been opened by an OpenSession call.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceNetworkFloatingServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceCloseSession

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class CloseSession : NetworkFloatingServiceCall
Public Class CloseSession
    Inherits NetworkFloatingServiceCall
public ref class CloseSession : public NetworkFloatingServiceCall

The CloseSession type exposes the following members.

Constructors
 | Name | Description
Public method | CloseSession(AuthorEncryptionKey) | Creates a new CloseSession object.
Public method | CloseSession(XmlNetworkFloatingService, AuthorEncryptionKey) | Creates a new CloseSession object.
Top
Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method. (Inherited from NetworkFloatingServiceCall.)
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file. (Inherited from NetworkFloatingServiceCall.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests. (Inherited from NetworkFloatingServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession). (Inherited from NetworkFloatingServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Inherited from NetworkFloatingServiceCall.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Inherited from NetworkFloatingServiceCall.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Caution note Caution

Unless a custom implementation is required, the NetworkSession.CloseSession method should be used instead.

Caution note Caution

The following SessionID property must be set before calling the CallWebService method.

See Also

Reference

com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CloseSession Constructor

CloseSession Constructor
Overload List
 | Name | Description
Public method | CloseSession(AuthorEncryptionKey) | Creates a new CloseSession object.
Public method | CloseSession(XmlNetworkFloatingService, AuthorEncryptionKey) | Creates a new CloseSession object.
Top
See Also

Reference

CloseSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CloseSession Constructor (AuthorEncryptionKey)

CloseSession Constructor (AuthorEncryptionKey)
Creates a new CloseSession object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CloseSession(
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey
)
public:
CloseSession(
    AuthorEncryptionKey^ encryptionKey
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
See Also

Reference

CloseSession Class
CloseSession Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CloseSession Constructor (XmlNetworkFloatingService, AuthorEncryptionKey)

CloseSession Constructor (XmlNetworkFloatingService, AuthorEncryptionKey)
Creates a new CloseSession object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public CloseSession(
    XmlNetworkFloatingService client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    client As XmlNetworkFloatingService,
    encryptionKey As AuthorEncryptionKey
)
public:
CloseSession(
    XmlNetworkFloatingService^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService
The SoapHttpClientProtocol used to call the web service method.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
See Also

Reference

CloseSession Class
CloseSession Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CloseSession Properties

CloseSession Properties

The CloseSession type exposes the following members.

Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method. (Inherited from NetworkFloatingServiceCall.)
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file. (Inherited from NetworkFloatingServiceCall.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests. (Inherited from NetworkFloatingServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession). (Inherited from NetworkFloatingServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

CloseSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


CloseSession Methods

CloseSession Methods

The CloseSession type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Inherited from NetworkFloatingServiceCall.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Inherited from NetworkFloatingServiceCall.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CloseSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall Class

NetworkFloatingServiceCall Class
Base class from which all calls to SOLO Server's XmlNetworkFloatingService are implemented.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceNetworkFloatingServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceCheckinSession
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceCheckoutSession
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceCloseSession
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceOpenSession
com.softwarekey.Client.WebService.XmlNetworkFloatingServicePollSession

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public abstract class NetworkFloatingServiceCall : WebServiceCall
Public MustInherit Class NetworkFloatingServiceCall
    Inherits WebServiceCall
public ref class NetworkFloatingServiceCall abstract : public WebServiceCall

The NetworkFloatingServiceCall type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkFloatingServiceCall | Creates a new NetworkFloatingServiceCall object
Top
Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service.
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response.
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession).
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall Constructor

NetworkFloatingServiceCall Constructor
Creates a new NetworkFloatingServiceCall object

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkFloatingServiceCall(
    NetworkFloatingServiceCallNetworkFloatingServiceCallType callType,
    SoapHttpClientProtocol client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    callType As NetworkFloatingServiceCallNetworkFloatingServiceCallType,
    client As SoapHttpClientProtocol,
    encryptionKey As AuthorEncryptionKey
)
public:
NetworkFloatingServiceCall(
    NetworkFloatingServiceCallNetworkFloatingServiceCallType callType,
    SoapHttpClientProtocol^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

callType
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceNetworkFloatingServiceCallNetworkFloatingServiceCallType
The type of web service call being made.
client
Type: System.Web.Services.ProtocolsSoapHttpClientProtocol
The SoapHttpClientProtocol object used to call the web service method.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey required for cryptographic routines.
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall Properties

NetworkFloatingServiceCall Properties

The NetworkFloatingServiceCall type exposes the following members.

Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service.
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response.
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file.
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server.
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests.
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession).
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.ActivationData Property

NetworkFloatingServiceCallActivationData Property
Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlDocument ActivationData { get; set; }
Public Property ActivationData As XmlDocument
    Get
    Set
public:
property XmlDocument^ ActivationData {
    XmlDocument^ get ();
    void set (XmlDocument^ value);
}

Property Value

Type: XmlDocument
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.Certificate Property

NetworkFloatingServiceCallCertificate Property
Gets the NetworkSessionCertificate object returned from the web service.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public NetworkSessionCertificate Certificate { get; }
Public ReadOnly Property Certificate As NetworkSessionCertificate
    Get
public:
property NetworkSessionCertificate^ Certificate {
    NetworkSessionCertificate^ get ();
}

Property Value

Type: NetworkSessionCertificate
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.CertificateDocument Property

NetworkFloatingServiceCallCertificateDocument Property
Gets the certificate XmlDocument obtained from processing a web service response.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlDocument CertificateDocument { get; }
Public ReadOnly Property CertificateDocument As XmlDocument
    Get
public:
property XmlDocument^ CertificateDocument {
    XmlDocument^ get ();
}

Property Value

Type: XmlDocument
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.CertificatePath Property

NetworkFloatingServiceCallCertificatePath Property
Gets or sets the absolute path to the NetworkSessionCertificate file.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string CertificatePath { get; set; }
Public Property CertificatePath As String
    Get
    Set
public:
property String^ CertificatePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.LicenseID Property

NetworkFloatingServiceCallLicenseID Property
Gets or sets the License ID issued in SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public int LicenseID { get; set; }
Public Property LicenseID As Integer
    Get
    Set
public:
property int LicenseID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.Password Property

NetworkFloatingServiceCallPassword Property
Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.RequestedCheckoutDuration Property

NetworkFloatingServiceCallRequestedCheckoutDuration Property
Gets or sets the requested checkout duration (in hours) for check-out requests.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public decimal RequestedCheckoutDuration { get; set; }
Public Property RequestedCheckoutDuration As Decimal
    Get
    Set
public:
property Decimal RequestedCheckoutDuration {
    Decimal get ();
    void set (Decimal value);
}

Property Value

Type: Decimal
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.SessionID Property

NetworkFloatingServiceCallSessionID Property
Gets or sets the Session ID issued by SOLO Server (used in NetworkSession).

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string SessionID { get; set; }
Public Property SessionID As String
    Get
    Set
public:
property String^ SessionID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall Methods

NetworkFloatingServiceCall Methods

The NetworkFloatingServiceCall type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Overrides WebServiceCallGeneratePlainTextRequest.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Overrides WebServiceCallProcessResponse(XmlNode).)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.GeneratePlainTextRequest Method

NetworkFloatingServiceCallGeneratePlainTextRequest Method
Generates a plain-text request for a call to the XmlNetworkFloatingService web service

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override string GeneratePlainTextRequest()
Public Overrides Function GeneratePlainTextRequest As String
public:
virtual String^ GeneratePlainTextRequest() override

Return Value

Type: String
Returns a plain-text request for a call to the XmlNetworkFloatingService web service

Implements

IWebServiceCallGeneratePlainTextRequest
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.ProcessResponse Method

NetworkFloatingServiceCallProcessResponse Method
Overload List
 | Name | Description
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Overrides WebServiceCallProcessResponse(XmlNode).)
Top
See Also

Reference

NetworkFloatingServiceCall Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.ProcessResponse Method (XmlNode)

NetworkFloatingServiceCallProcessResponse Method (XmlNode)
Processes a response from the XmlNetworkFloatingService web service and returns true if successful

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public override bool ProcessResponse(
    ref XmlNode response
)
Public Overrides Function ProcessResponse (
    ByRef response As XmlNode
) As Boolean
public:
virtual bool ProcessResponse(
    XmlNode^% response
) override

Parameters

response
Type: System.XmlXmlNode
The XmlNode or XmlDocument object to process.

Return Value

Type: Boolean
Returns true if successful. If it is not successful, see the LastError property for details.

Implements

IWebServiceCallProcessResponse(XmlNode)
See Also

Reference

NetworkFloatingServiceCall Class
ProcessResponse Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


NetworkFloatingServiceCall.NetworkFloatingServiceCallType Enumeration

NetworkFloatingServiceCallNetworkFloatingServiceCallType Enumeration
Types of web service calls that can be made.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public enum NetworkFloatingServiceCallType
Public Enumeration NetworkFloatingServiceCallType
public enum class NetworkFloatingServiceCallType
Members
Member name | Value | Description
OpenSession | 0 | Open Session
PollSession | 1 | Poll Session
CloseSession | 2 | Close Session
CheckinSession | 3 | Check-in Session
CheckoutSession | 4 | Check-out Session
See Also

Reference

com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


OpenSession Class

OpenSession Class
NetworkFloatingServiceCall implementation for opening a new session. The opened session can be polled/checked by a PollSession call, or closed by a CloseSession call.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceNetworkFloatingServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceOpenSession

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class OpenSession : NetworkFloatingServiceCall
Public Class OpenSession
    Inherits NetworkFloatingServiceCall
public ref class OpenSession : public NetworkFloatingServiceCall

The OpenSession type exposes the following members.

Constructors
 | Name | Description
Public method | OpenSession(AuthorEncryptionKey) | Creates a new OpenSession object.
Public method | OpenSession(XmlNetworkFloatingService, AuthorEncryptionKey) | Creates a new OpenSession object.
Top
Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method. (Inherited from NetworkFloatingServiceCall.)
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file. (Inherited from NetworkFloatingServiceCall.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests. (Inherited from NetworkFloatingServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession). (Inherited from NetworkFloatingServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Inherited from NetworkFloatingServiceCall.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Inherited from NetworkFloatingServiceCall.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Caution note Caution

Unless a custom implementation is required, the NetworkSession.OpenSession method should be used instead.

Caution note Caution

The following properties must be set before calling the CallWebService method.

  • LicenseID
  • Password
  • ActivationData (Necessary if you wish to bind the certificate to the system for check-outs.)
See Also

Reference

com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


OpenSession Constructor

OpenSession Constructor
Overload List
 | Name | Description
Public method | OpenSession(AuthorEncryptionKey) | Creates a new OpenSession object.
Public method | OpenSession(XmlNetworkFloatingService, AuthorEncryptionKey) | Creates a new OpenSession object.
Top
See Also

Reference

OpenSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


OpenSession Constructor (AuthorEncryptionKey)

OpenSession Constructor (AuthorEncryptionKey)
Creates a new OpenSession object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public OpenSession(
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey
)
public:
OpenSession(
    AuthorEncryptionKey^ encryptionKey
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
See Also

Reference

OpenSession Class
OpenSession Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


OpenSession Constructor (XmlNetworkFloatingService, AuthorEncryptionKey)

OpenSession Constructor (XmlNetworkFloatingService, AuthorEncryptionKey)
Creates a new OpenSession object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public OpenSession(
    XmlNetworkFloatingService client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    client As XmlNetworkFloatingService,
    encryptionKey As AuthorEncryptionKey
)
public:
OpenSession(
    XmlNetworkFloatingService^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService
The SoapHttpClientProtocol used to call the web service method.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
See Also

Reference

OpenSession Class
OpenSession Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


OpenSession Properties

OpenSession Properties

The OpenSession type exposes the following members.

Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method. (Inherited from NetworkFloatingServiceCall.)
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file. (Inherited from NetworkFloatingServiceCall.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests. (Inherited from NetworkFloatingServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession). (Inherited from NetworkFloatingServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

OpenSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


OpenSession Methods

OpenSession Methods

The OpenSession type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Inherited from NetworkFloatingServiceCall.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Inherited from NetworkFloatingServiceCall.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

OpenSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


PollSession Class

PollSession Class
NetworkFloatingServiceCall implementation for polling a session which was opened by an OpenSession call.
Inheritance Hierarchy
SystemObject
com.softwarekey.Client.WebServiceWebServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceNetworkFloatingServiceCall
com.softwarekey.Client.WebService.XmlNetworkFloatingServicePollSession

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class PollSession : NetworkFloatingServiceCall
Public Class PollSession
    Inherits NetworkFloatingServiceCall
public ref class PollSession : public NetworkFloatingServiceCall

The PollSession type exposes the following members.

Constructors
 | Name | Description
Public method | PollSession(AuthorEncryptionKey) | Creates a new PollSession object.
Public method | PollSession(XmlNetworkFloatingService, AuthorEncryptionKey) | Creates a new PollSession object.
Top
Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method. (Inherited from NetworkFloatingServiceCall.)
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file. (Inherited from NetworkFloatingServiceCall.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests. (Inherited from NetworkFloatingServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession). (Inherited from NetworkFloatingServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Inherited from NetworkFloatingServiceCall.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Inherited from NetworkFloatingServiceCall.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Caution note Caution

Unless a custom implementation is required, the NetworkSession.PollSession method should be used instead.

Caution note Caution

The following properties must be set before calling the CallWebService method.

  • SessionID
  • CertificatePath
  • ActivationData (Necessary if you wish to bind the certificate to the system for check-outs.)
See Also

Reference

com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


PollSession Constructor

PollSession Constructor
Overload List
 | Name | Description
Public method | PollSession(AuthorEncryptionKey) | Creates a new PollSession object.
Public method | PollSession(XmlNetworkFloatingService, AuthorEncryptionKey) | Creates a new PollSession object.
Top
See Also

Reference

PollSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


PollSession Constructor (AuthorEncryptionKey)

PollSession Constructor (AuthorEncryptionKey)
Creates a new PollSession object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public PollSession(
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    encryptionKey As AuthorEncryptionKey
)
public:
PollSession(
    AuthorEncryptionKey^ encryptionKey
)

Parameters

encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
See Also

Reference

PollSession Class
PollSession Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


PollSession Constructor (XmlNetworkFloatingService, AuthorEncryptionKey)

PollSession Constructor (XmlNetworkFloatingService, AuthorEncryptionKey)
Creates a new PollSession object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public PollSession(
    XmlNetworkFloatingService client,
    AuthorEncryptionKey encryptionKey
)
Public Sub New (
    client As XmlNetworkFloatingService,
    encryptionKey As AuthorEncryptionKey
)
public:
PollSession(
    XmlNetworkFloatingService^ client,
    AuthorEncryptionKey^ encryptionKey
)

Parameters

client
Type: com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService
The SoapHttpClientProtocol used to call the web service method.
encryptionKey
Type: com.softwarekey.Client.UtilsAuthorEncryptionKey
The AuthorEncryptionKey object required for cryptographic routines.
See Also

Reference

PollSession Class
PollSession Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


PollSession Properties

PollSession Properties

The PollSession type exposes the following members.

Properties
 | Name | Description
Public property | ActivationData | Gets or sets the XmlDocument of SystemIdentifier information to bind the NetworkSession to a specific computer. This document may be generated using the SystemIdentifier.GenerateActivationDataXml method. (Inherited from NetworkFloatingServiceCall.)
Public property | Certificate | Gets the NetworkSessionCertificate object returned from the web service. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificateDocument | Gets the certificate XmlDocument obtained from processing a web service response. (Inherited from NetworkFloatingServiceCall.)
Public property | CertificatePath | Gets or sets the absolute path to the NetworkSessionCertificate file. (Inherited from NetworkFloatingServiceCall.)
Public property | ClassName | Gets or sets the class name of the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | EncryptionKey | Gets or sets the author encryption key data. (Inherited from WebServiceCall.)
Public property | ErrorMessage | Gets or sets the error message returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | LastError | Gets or sets the last error which occurred. (Inherited from WebServiceCall.)
Public property | LicenseID | Gets or sets the License ID issued in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | MethodName | Gets or sets the name of the method which will be called from the WebServiceClient object. (Inherited from WebServiceCall.)
Public property | Password | Gets or sets the password. This may be set to the activation password assigned to the license, or the customer password, in SOLO Server. (Inherited from NetworkFloatingServiceCall.)
Public property | RequestedCheckoutDuration | Gets or sets the requested checkout duration (in hours) for check-out requests. (Inherited from NetworkFloatingServiceCall.)
Public property | RequireSsl | Gets or sets whether or not SSL certificate validation to check. (Inherited from WebServiceCall.)
Public property | ResultCode | Gets or sets the result code returned by the web service method call. (See http://www.softwarekey.com/go/?ID=20 for a list of possible values.) (Inherited from WebServiceCall.)
Public property | SessionCode | Gets or sets the randomized session code (used to deter replay attacks). (Inherited from WebServiceCall.)
Public property | SessionCodeValidation | Gets or sets whether or not session code validation should be done automatically. (Inherited from WebServiceCall.)
Public property | SessionID | Gets or sets the Session ID issued by SOLO Server (used in NetworkSession). (Inherited from NetworkFloatingServiceCall.)
Public property | UseDigitalSignature | Gets or sets whether or not a digital signature is to be used or is required for the web service call. (This can only be set to false if UseEncryption is already set to false.) (Inherited from WebServiceCall.)
Public property | UseEncryption | Gets or sets whether or not encryption is to be used or is required for the web service call. (Inherited from WebServiceCall.)
Public property | WebServiceClient | Gets or sets the SoapHttpClientProtocol object used to perform the web service method call. (Inherited from WebServiceCall.)
Public property | WebServiceResponse | Gets or set the XmlNode object reference for the root XML node of the web service response. (Inherited from WebServiceCall.)
Top
See Also

Reference

PollSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


PollSession Methods

PollSession Methods

The PollSession type exposes the following members.

Methods
 | Name | Description
Protected method | AppendSessionCode(String) | Appends the SessionCode value to an XML request string depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Protected method | AppendSessionCode(XmlDocument) | Appends the SessionCode value to an XmlDocument depending on the SessionCodeValidation setting, and returns the updated XML string (Inherited from WebServiceCall.)
Public method | CallWebService | Calls the web service method. (Inherited from WebServiceCall.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateEncryptedRequest | Generates an encrypted web service call XML request string. (Inherited from WebServiceCall.)
Public method | GeneratePlainTextRequest | Generates a plain-text request for a call to the XmlNetworkFloatingService web service (Inherited from NetworkFloatingServiceCall.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessResponse(String) | Processes a web service response XML string. (Inherited from WebServiceCall.)
Public method | ProcessResponse(XmlNode) | Processes a response from the XmlNetworkFloatingService web service and returns true if successful (Inherited from NetworkFloatingServiceCall.)
Public method | ResetSessionCode | Sets the SessionCode value to a new, randomized value. (Inherited from WebServiceCall.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PollSession Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService Class

XmlNetworkFloatingService Class
This API is preliminary and subject to change.
SoapHttpClientProtocol implementation for calling methods in SOLO Server's XmlNetworkFloatingService web service.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Web.Services.ProtocolsWebClientProtocol
System.Web.Services.ProtocolsHttpWebClientProtocol
System.Web.Services.ProtocolsSoapHttpClientProtocol
com.softwarekey.Client.WebService.XmlNetworkFloatingServiceXmlNetworkFloatingService

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public class XmlNetworkFloatingService : SoapHttpClientProtocol
Public Class XmlNetworkFloatingService
    Inherits SoapHttpClientProtocol
public ref class XmlNetworkFloatingService : public SoapHttpClientProtocol

The XmlNetworkFloatingService type exposes the following members.

Constructors
 | Name | Description
Public method | XmlNetworkFloatingService | Creates a new XmlLicenseFileService object.
Top
Properties
 | Name | Description
Public property | AllowAutoRedirect | (Inherited from HttpWebClientProtocol.)
Protected property | CanRaiseEvents | (Inherited from Component.)
Public property | ClientCertificates | (Inherited from HttpWebClientProtocol.)
Public property | ConnectionGroupName | (Inherited from WebClientProtocol.)
Public property | Container | (Inherited from Component.)
Public property | CookieContainer | (Inherited from HttpWebClientProtocol.)
Public property | Credentials | (Inherited from WebClientProtocol.)
Protected property | DesignMode | (Inherited from Component.)
Public property | EnableDecompression | (Inherited from HttpWebClientProtocol.)
Protected property | Events | (Inherited from Component.)
Public property | PreAuthenticate | (Inherited from WebClientProtocol.)
Public property | Proxy | (Inherited from HttpWebClientProtocol.)
Public property | RequestEncoding | (Inherited from WebClientProtocol.)
Public property | Site | (Inherited from Component.)
Public property | SoapVersion | (Inherited from SoapHttpClientProtocol.)
Public property | Timeout | (Inherited from WebClientProtocol.)
Public property | UnsafeAuthenticatedConnectionSharing | (Inherited from HttpWebClientProtocol.)
Public property | Url | Gets or sets the base URL of the XML Web service the client is requesting.
Public property | UseDefaultCredentials | Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.
Public property | UserAgent | (Inherited from HttpWebClientProtocol.)
Top
Methods
 | Name | Description
Public method | Abort | (Inherited from WebClientProtocol.)
Protected method | BeginInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | CancelAsync | Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).
Public method | CheckinSession | Calls the CheckinSession web method.
Public method | CheckinSessionAsync(String) | Calls the CheckinSession web method asynchronously.
Public method | CheckinSessionAsync(String, Object) | Calls the CheckinSession web method asynchronously.
Public method | CheckoutSession | Calls the CheckoutSession web method.
Public method | CheckoutSessionAsync(String) | Calls the CheckoutSession web method asynchronously.
Public method | CheckoutSessionAsync(String, Object) | Calls the CheckoutSession web method asynchronously.
Public method | CloseSession | Calls the CloseSession web method.
Public method | CloseSessionAsync(String) | Calls the CloseSession web method asynchronously.
Public method | CloseSessionAsync(String, Object) | Calls the CloseSession web method asynchronously.
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Public method | Discover | (Inherited from SoapHttpClientProtocol.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from Component.)
Protected method | EndInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | GetReaderForMessage | (Inherited from SoapHttpClientProtocol.)
Protected method | GetService | (Inherited from Component.)
Public method | GetType | (Inherited from Object.)
Protected method | GetWebRequest | (Inherited from SoapHttpClientProtocol.)
Protected method | GetWebResponse(WebRequest) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWebResponse(WebRequest, IAsyncResult) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWriterForMessage | (Inherited from SoapHttpClientProtocol.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | Invoke | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback) | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback, Object) | (Inherited from SoapHttpClientProtocol.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Public method | OpenSession | Calls the OpenSession web method.
Public method | OpenSessionAsync(String) | Calls the OpenSession web method asynchronously.
Public method | OpenSessionAsync(String, Object) | Calls the OpenSession web method asynchronously.
Public method | PollSession | Calls the PollSession web method.
Public method | PollSessionAsync(String) | Calls the PollSession web method asynchronously.
Public method | PollSessionAsync(String, Object) | Calls the PollSession web method asynchronously.
Public method | ToString | (Inherited from Component.)
Top
Events
 | Name | Description
Public event | CheckinSessionCompleted | Occurs when an asynchronous call to CheckinSession has completed.
Public event | CheckoutSessionCompleted | Occurs when an asynchronous call to CheckoutSession has completed.
Public event | CloseSessionCompleted | Occurs when an asynchronous call to CloseSession has completed.
Public event | Disposed | (Inherited from Component.)
Public event | OpenSessionCompleted | Occurs when an asynchronous call to OpenSession has completed.
Public event | PollSessionCompleted | Occurs when an asynchronous call to PollSession has completed.
Top
Remarks
Note Note

This class should only be used directly as needed for specifying customized information, such as different end-point URLs, proxy server access credentials, etc... The com.softwarekey.Client.WebService.XmlNetworkFloatingService namespace contains WebServiceCall implementations for each supported web service method.

See Also

Reference

com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService Constructor

XmlNetworkFloatingService Constructor
This API is preliminary and subject to change.
Creates a new XmlLicenseFileService object.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNetworkFloatingService()
Public Sub New
public:
XmlNetworkFloatingService()
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService Properties

XmlNetworkFloatingService Properties
This API is preliminary and subject to change.

The XmlNetworkFloatingService type exposes the following members.

Properties
 | Name | Description
Public property | AllowAutoRedirect | (Inherited from HttpWebClientProtocol.)
Protected property | CanRaiseEvents | (Inherited from Component.)
Public property | ClientCertificates | (Inherited from HttpWebClientProtocol.)
Public property | ConnectionGroupName | (Inherited from WebClientProtocol.)
Public property | Container | (Inherited from Component.)
Public property | CookieContainer | (Inherited from HttpWebClientProtocol.)
Public property | Credentials | (Inherited from WebClientProtocol.)
Protected property | DesignMode | (Inherited from Component.)
Public property | EnableDecompression | (Inherited from HttpWebClientProtocol.)
Protected property | Events | (Inherited from Component.)
Public property | PreAuthenticate | (Inherited from WebClientProtocol.)
Public property | Proxy | (Inherited from HttpWebClientProtocol.)
Public property | RequestEncoding | (Inherited from WebClientProtocol.)
Public property | Site | (Inherited from Component.)
Public property | SoapVersion | (Inherited from SoapHttpClientProtocol.)
Public property | Timeout | (Inherited from WebClientProtocol.)
Public property | UnsafeAuthenticatedConnectionSharing | (Inherited from HttpWebClientProtocol.)
Public property | Url | Gets or sets the base URL of the XML Web service the client is requesting.
Public property | UseDefaultCredentials | Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.
Public property | UserAgent | (Inherited from HttpWebClientProtocol.)
Top
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.Url Property

XmlNetworkFloatingServiceUrl Property
This API is preliminary and subject to change.
Gets or sets the base URL of the XML Web service the client is requesting.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.UseDefaultCredentials Property

XmlNetworkFloatingServiceUseDefaultCredentials Property
This API is preliminary and subject to change.
Gets or sets a value that indicates whether to set the System.Web.Services.Protocols.WebClientProtocol.Credentials property to the value of the System.Net.CredentialCache.DefaultCredentials property.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public bool UseDefaultCredentials { get; set; }
Public Property UseDefaultCredentials As Boolean
    Get
    Set
public:
property bool UseDefaultCredentials {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService Methods

XmlNetworkFloatingService Methods
This API is preliminary and subject to change.

The XmlNetworkFloatingService type exposes the following members.

Methods
 | Name | Description
Public method | Abort | (Inherited from WebClientProtocol.)
Protected method | BeginInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | CancelAsync | Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).
Public method | CheckinSession | Calls the CheckinSession web method.
Public method | CheckinSessionAsync(String) | Calls the CheckinSession web method asynchronously.
Public method | CheckinSessionAsync(String, Object) | Calls the CheckinSession web method asynchronously.
Public method | CheckoutSession | Calls the CheckoutSession web method.
Public method | CheckoutSessionAsync(String) | Calls the CheckoutSession web method asynchronously.
Public method | CheckoutSessionAsync(String, Object) | Calls the CheckoutSession web method asynchronously.
Public method | CloseSession | Calls the CloseSession web method.
Public method | CloseSessionAsync(String) | Calls the CloseSession web method asynchronously.
Public method | CloseSessionAsync(String, Object) | Calls the CloseSession web method asynchronously.
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Public method | Discover | (Inherited from SoapHttpClientProtocol.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from Component.)
Protected method | EndInvoke | (Inherited from SoapHttpClientProtocol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | GetReaderForMessage | (Inherited from SoapHttpClientProtocol.)
Protected method | GetService | (Inherited from Component.)
Public method | GetType | (Inherited from Object.)
Protected method | GetWebRequest | (Inherited from SoapHttpClientProtocol.)
Protected method | GetWebResponse(WebRequest) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWebResponse(WebRequest, IAsyncResult) | (Inherited from HttpWebClientProtocol.)
Protected method | GetWriterForMessage | (Inherited from SoapHttpClientProtocol.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | Invoke | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback) | (Inherited from SoapHttpClientProtocol.)
Protected method | InvokeAsync(String, Object, SendOrPostCallback, Object) | (Inherited from SoapHttpClientProtocol.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Public method | OpenSession | Calls the OpenSession web method.
Public method | OpenSessionAsync(String) | Calls the OpenSession web method asynchronously.
Public method | OpenSessionAsync(String, Object) | Calls the OpenSession web method asynchronously.
Public method | PollSession | Calls the PollSession web method.
Public method | PollSessionAsync(String) | Calls the PollSession web method asynchronously.
Public method | PollSessionAsync(String, Object) | Calls the PollSession web method asynchronously.
Public method | ToString | (Inherited from Component.)
Top
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CancelAsync Method

XmlNetworkFloatingServiceCancelAsync Method
This API is preliminary and subject to change.
Cancels an asynchronous call to an XML Web service method (unless the call has already been completed).

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CancelAsync(
    Object userState
)
Public Sub CancelAsync (
    userState As Object
)
public:
void CancelAsync(
    Object^ userState
)

Parameters

userState
Type: SystemObject
The user state Object.
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CheckinSession Method

XmlNetworkFloatingServiceCheckinSession Method
This API is preliminary and subject to change.
Calls the CheckinSession web method.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode CheckinSession(
    string xml
)
Public Function CheckinSession (
    xml As String
) As XmlNode
public:
XmlNode^ CheckinSession(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CheckinSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CheckinSessionAsync Method

XmlNetworkFloatingServiceCheckinSessionAsync Method
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | CheckinSessionAsync(String) | Calls the CheckinSession web method asynchronously.
Public method | CheckinSessionAsync(String, Object) | Calls the CheckinSession web method asynchronously.
Top
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CheckinSessionAsync Method (String)

XmlNetworkFloatingServiceCheckinSessionAsync Method (String)
This API is preliminary and subject to change.
Calls the CheckinSession web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CheckinSessionAsync(
    string xml
)
Public Sub CheckinSessionAsync (
    xml As String
)
public:
void CheckinSessionAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CheckinSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
CheckinSessionAsync Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CheckinSessionAsync Method (String, Object)

XmlNetworkFloatingServiceCheckinSessionAsync Method (String, Object)
This API is preliminary and subject to change.
Calls the CheckinSession web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CheckinSessionAsync(
    string xml,
    Object userState
)
Public Sub CheckinSessionAsync (
    xml As String,
    userState As Object
)
public:
void CheckinSessionAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CheckinSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
CheckinSessionAsync Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CheckoutSession Method

XmlNetworkFloatingServiceCheckoutSession Method
This API is preliminary and subject to change.
Calls the CheckoutSession web method.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode CheckoutSession(
    string xml
)
Public Function CheckoutSession (
    xml As String
) As XmlNode
public:
XmlNode^ CheckoutSession(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CheckoutSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CheckoutSessionAsync Method

XmlNetworkFloatingServiceCheckoutSessionAsync Method
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | CheckoutSessionAsync(String) | Calls the CheckoutSession web method asynchronously.
Public method | CheckoutSessionAsync(String, Object) | Calls the CheckoutSession web method asynchronously.
Top
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CheckoutSessionAsync Method (String)

XmlNetworkFloatingServiceCheckoutSessionAsync Method (String)
This API is preliminary and subject to change.
Calls the CheckoutSession web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CheckoutSessionAsync(
    string xml
)
Public Sub CheckoutSessionAsync (
    xml As String
)
public:
void CheckoutSessionAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CheckoutSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
CheckoutSessionAsync Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CheckoutSessionAsync Method (String, Object)

XmlNetworkFloatingServiceCheckoutSessionAsync Method (String, Object)
This API is preliminary and subject to change.
Calls the CheckoutSession web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CheckoutSessionAsync(
    string xml,
    Object userState
)
Public Sub CheckoutSessionAsync (
    xml As String,
    userState As Object
)
public:
void CheckoutSessionAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CheckoutSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
CheckoutSessionAsync Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CloseSession Method

XmlNetworkFloatingServiceCloseSession Method
This API is preliminary and subject to change.
Calls the CloseSession web method.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode CloseSession(
    string xml
)
Public Function CloseSession (
    xml As String
) As XmlNode
public:
XmlNode^ CloseSession(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CloseSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CloseSessionAsync Method

XmlNetworkFloatingServiceCloseSessionAsync Method
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | CloseSessionAsync(String) | Calls the CloseSession web method asynchronously.
Public method | CloseSessionAsync(String, Object) | Calls the CloseSession web method asynchronously.
Top
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CloseSessionAsync Method (String)

XmlNetworkFloatingServiceCloseSessionAsync Method (String)
This API is preliminary and subject to change.
Calls the CloseSession web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CloseSessionAsync(
    string xml
)
Public Sub CloseSessionAsync (
    xml As String
)
public:
void CloseSessionAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CloseSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
CloseSessionAsync Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CloseSessionAsync Method (String, Object)

XmlNetworkFloatingServiceCloseSessionAsync Method (String, Object)
This API is preliminary and subject to change.
Calls the CloseSession web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void CloseSessionAsync(
    string xml,
    Object userState
)
Public Sub CloseSessionAsync (
    xml As String,
    userState As Object
)
public:
void CloseSessionAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the CloseSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
CloseSessionAsync Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.OpenSession Method

XmlNetworkFloatingServiceOpenSession Method
This API is preliminary and subject to change.
Calls the OpenSession web method.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode OpenSession(
    string xml
)
Public Function OpenSession (
    xml As String
) As XmlNode
public:
XmlNode^ OpenSession(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the OpenSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.OpenSessionAsync Method

XmlNetworkFloatingServiceOpenSessionAsync Method
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | OpenSessionAsync(String) | Calls the OpenSession web method asynchronously.
Public method | OpenSessionAsync(String, Object) | Calls the OpenSession web method asynchronously.
Top
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.OpenSessionAsync Method (String)

XmlNetworkFloatingServiceOpenSessionAsync Method (String)
This API is preliminary and subject to change.
Calls the OpenSession web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void OpenSessionAsync(
    string xml
)
Public Sub OpenSessionAsync (
    xml As String
)
public:
void OpenSessionAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the OpenSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
OpenSessionAsync Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.OpenSessionAsync Method (String, Object)

XmlNetworkFloatingServiceOpenSessionAsync Method (String, Object)
This API is preliminary and subject to change.
Calls the OpenSession web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void OpenSessionAsync(
    string xml,
    Object userState
)
Public Sub OpenSessionAsync (
    xml As String,
    userState As Object
)
public:
void OpenSessionAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the OpenSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
OpenSessionAsync Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.PollSession Method

XmlNetworkFloatingServicePollSession Method
This API is preliminary and subject to change.
Calls the PollSession web method.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public XmlNode PollSession(
    string xml
)
Public Function PollSession (
    xml As String
) As XmlNode
public:
XmlNode^ PollSession(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.

Return Value

Type: XmlNode
Returns the XML formatted result.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the PollSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.PollSessionAsync Method

XmlNetworkFloatingServicePollSessionAsync Method
This API is preliminary and subject to change.
Overload List
 | Name | Description
Public method | PollSessionAsync(String) | Calls the PollSession web method asynchronously.
Public method | PollSessionAsync(String, Object) | Calls the PollSession web method asynchronously.
Top
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.PollSessionAsync Method (String)

XmlNetworkFloatingServicePollSessionAsync Method (String)
This API is preliminary and subject to change.
Calls the PollSession web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void PollSessionAsync(
    string xml
)
Public Sub PollSessionAsync (
    xml As String
)
public:
void PollSessionAsync(
    String^ xml
)

Parameters

xml
Type: SystemString
An XML formatted request string.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the PollSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
PollSessionAsync Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.PollSessionAsync Method (String, Object)

XmlNetworkFloatingServicePollSessionAsync Method (String, Object)
This API is preliminary and subject to change.
Calls the PollSession web method asynchronously.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public void PollSessionAsync(
    string xml,
    Object userState
)
Public Sub PollSessionAsync (
    xml As String,
    userState As Object
)
public:
void PollSessionAsync(
    String^ xml,
    Object^ userState
)

Parameters

xml
Type: SystemString
An XML formatted request string.
userState
Type: SystemObject
The user state Object.
Remarks
Caution note Caution

This method should not typically be called directly. Please use the PollSession class instead.

See Also

Reference

XmlNetworkFloatingService Class
PollSessionAsync Overload
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService Events

XmlNetworkFloatingService Events
This API is preliminary and subject to change.

The XmlNetworkFloatingService type exposes the following members.

Events
 | Name | Description
Public event | CheckinSessionCompleted | Occurs when an asynchronous call to CheckinSession has completed.
Public event | CheckoutSessionCompleted | Occurs when an asynchronous call to CheckoutSession has completed.
Public event | CloseSessionCompleted | Occurs when an asynchronous call to CloseSession has completed.
Public event | Disposed | (Inherited from Component.)
Public event | OpenSessionCompleted | Occurs when an asynchronous call to OpenSession has completed.
Public event | PollSessionCompleted | Occurs when an asynchronous call to PollSession has completed.
Top
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CheckinSessionCompleted Event

XmlNetworkFloatingServiceCheckinSessionCompleted Event
This API is preliminary and subject to change.
Occurs when an asynchronous call to CheckinSession has completed.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event CheckinSessionCompletedEventHandler CheckinSessionCompleted
Public Event CheckinSessionCompleted As CheckinSessionCompletedEventHandler
public:
 event CheckinSessionCompletedEventHandler^ CheckinSessionCompleted {
    void add (CheckinSessionCompletedEventHandler^ value);
    void remove (CheckinSessionCompletedEventHandler^ value);
}

Value

Type: CheckinSessionCompletedEventHandler
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CheckoutSessionCompleted Event

XmlNetworkFloatingServiceCheckoutSessionCompleted Event
This API is preliminary and subject to change.
Occurs when an asynchronous call to CheckoutSession has completed.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event CheckoutSessionCompletedEventHandler CheckoutSessionCompleted
Public Event CheckoutSessionCompleted As CheckoutSessionCompletedEventHandler
public:
 event CheckoutSessionCompletedEventHandler^ CheckoutSessionCompleted {
    void add (CheckoutSessionCompletedEventHandler^ value);
    void remove (CheckoutSessionCompletedEventHandler^ value);
}

Value

Type: CheckoutSessionCompletedEventHandler
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.CloseSessionCompleted Event

XmlNetworkFloatingServiceCloseSessionCompleted Event
This API is preliminary and subject to change.
Occurs when an asynchronous call to CloseSession has completed.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event CloseSessionCompletedEventHandler CloseSessionCompleted
Public Event CloseSessionCompleted As CloseSessionCompletedEventHandler
public:
 event CloseSessionCompletedEventHandler^ CloseSessionCompleted {
    void add (CloseSessionCompletedEventHandler^ value);
    void remove (CloseSessionCompletedEventHandler^ value);
}

Value

Type: CloseSessionCompletedEventHandler
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.OpenSessionCompleted Event

XmlNetworkFloatingServiceOpenSessionCompleted Event
This API is preliminary and subject to change.
Occurs when an asynchronous call to OpenSession has completed.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event OpenSessionCompletedEventHandler OpenSessionCompleted
Public Event OpenSessionCompleted As OpenSessionCompletedEventHandler
public:
 event OpenSessionCompletedEventHandler^ OpenSessionCompleted {
    void add (OpenSessionCompletedEventHandler^ value);
    void remove (OpenSessionCompletedEventHandler^ value);
}

Value

Type: OpenSessionCompletedEventHandler
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace


XmlNetworkFloatingService.PollSessionCompleted Event

XmlNetworkFloatingServicePollSessionCompleted Event
This API is preliminary and subject to change.
Occurs when an asynchronous call to PollSession has completed.

Namespace: com.softwarekey.Client.WebService.XmlNetworkFloatingService
Assembly: PLUSManaged (in PLUSManaged.dll) Version: 5.17.1.0
Syntax
C#
VB
C++
Copy
public event PollSessionCompletedEventHandler PollSessionCompleted
Public Event PollSessionCompleted As PollSessionCompletedEventHandler
public:
 event PollSessionCompletedEventHandler^ PollSessionCompleted {
    void add (PollSessionCompletedEventHandler^ value);
    void remove (PollSessionCompletedEventHandler^ value);
}

Value

Type: PollSessionCompletedEventHandler
See Also

Reference

XmlNetworkFloatingService Class
com.softwarekey.Client.WebService.XmlNetworkFloatingService Namespace