 About ContourCube

About ContourCube

ContourCube ActiveX is a high-performance OLAP component for interactive reporting and data analysis. It offers embeddable OLAP technology for all Windows and web applications based on relational data. Application powered with ContourCube allows users to create a numbers of nice-formed screen and printable reports in minute. User can interact with data: slice and dice, drill down and roll up, pivot with sub-second response times and without additional server.

ContourCube ActiveX enables you to embed reach Business Intelligence functionality just in native windows of your application and you can distribute this application royalty-free. Embedded OLAP is easy to install, zero administration and low cost. ContourCube can get data from any data source of your application through ADO, BDE, ODBC or unbound data source so you can just drop ContourCube onto your project form and link it with your data and get all new opportunities of embedded OLAP.

ContourCube gets data from existing relational data sources and calculates a multidimensional hypercube, which is then presented as a grid and/or graph. ContourCube control allows interactive rotating of the resulting hypercube, and can save it to or load from a very compact files called Microcubes on the local disk, or network, or the Internet.

From the developer's point of view, ContourCube is very flexible and easy to build into any application. It has embedded Formula Language for advanced data analysis, which allows to manipulate with single data elements, define custom fields and functions, build sophisticated expressions for conditional cell styles, etc. ContourCube styling facilities allow to easily highlight custom data in the grid, change the appearance of single columns, cascade styles, and more. The present Developer's Guide describes how to fast and easily deploy ContourCube, and create powerful analytical applications.


ContourCube: Overview

Features Applications Architectures User Interface Approaches

The internal composition of ContourCube control consists of three main parts:

  • The cube itself contains just data: facts as numeric values and dimension members as variant types of data. The cube doesn't contain any information on how this data is displayed: which dimensions are included in the view, and whether they are filtered, etc.
    In ContourCube class architecture, the cube features are reflected in IContourCube interface.

  • The slice has the sense like a physical slice of a geometric cube: it can be made in different ways, in order to view different data at once. In ContourCube control, the slice defines which dimensions are visible, what are their filter states, and at which axes they are located.

  • Finally, the grid forms the "visible part of iceberg" - it displays the data in the form specified by the slice, and applies various visual settings like styles, colors of some elements, mapping of dimension members, and so on. ContourCube grid provides a comprehensive visual user interface and handles its events.
    In ContourCube class architecture, the grid features are reflected in IContourGrid interface.

Visually, ContourCube grid looks as below:

Figure 1. ContourCube Control Layout.

ContourCube control shows hierarchical OLAP data in a flat grid view: active dimensions are placed onto two geometric axes in some order, so that many members of an underlaying dimension are shown under one member of an upstanding dimension, e.g. 12 products correspond to the Seafood category, as shown at Fig. 1. Dimensions are represented as boxes combined with their filters: user can drag and drop them between horizontal or vertical axis, or outside dimensions area. The outside dimensions area is not really a cube axis: this is a place where available, but actually not used for the analysis dimensions are stored. User can easily include these dimensions into the analysis just by moving them from outside area onto visible axes with mouse.
"+" and "-" signs on dimension members allow user to expand and collapse them, this way performing drill down and roll up. See more on these operations in article Using ContourCube: Dimensions.
Filtering of dimension members is done by pressing corresponding Dimension Filter button, and (un)selecting needed items in the drop-down list of dimension values. If at least one item is turned off for a dimension, the latter's title is displayed differently (by default, in emphasis - like Category at Fig. 1). Evidently, applying a filter to an upstanding dimension affects the underlying one - some its items will be hidden. Such hidden members are not displayed in the grid, but are shown with different style in the filter list (in gray by default) or not shown there at all.

Although the Facts Filter looks like a dimension, it's not a one. The Facts Filter cannot be moved from its place, and is used there for turning on or off fact columns in the grid. User can press the filter button with mouse, and check / uncheck needed items in the drop-down list.
Filter lists of both dimensions and facts have scroll bars and other controls facilitating filtering operations. They are located at the bottom of each list:

Figure 2. ContourCube Dimension Filter Layout.
  • + button checks all list items;
  • - button unchecks all list items;
  • * inverts the selection;
  • Last two buttons respectively commit and discard changes in filter settings;

See also

Working with Styles
ContourCube ActiveX Events


 ContourCube Features

ContourCube Features

Overview Applications Architectures User Interface Approaches
General features
  • ContourCubeX is an interactive OLAP tool, implemented as an ActiveX component
  • Provides extended set of analytical and statistical functions
  • No multidimensional database (OLAP) server needed
  • Supports bound and unbound modes through ADO or BDE connections
  • Supports data loading from arbitrary ADO Recordset
  • Automatic adaptation to existing data sources
  • Interactive data filtering, pivoting, drill-down and roll-up operations
  • Fast OLAP aggregation and pivoting. Interactive pivoting of hundreds of thousands data points in a fraction of second
  • Minimum hardware requirements
  • Support of upto 127 dimensions and 64 facts
  • Linking to almost any 3rd-party charting component
  • Produces presentation-quality analytical HTML reports. The component provides pure HTML 4.0 output and compatible with virtually every contemporary browser or browser control
Interface features
  • Very comprehensive user interface allowing instant manipulations on data with mouse
  • Cascading Stylesheets that define builtin or custom grid cell appearance as functions of data values, positions, cell types, and much more. ContourCube supports stylesheets for single columns and / or the entire grid.
  • Automatic sizing of columns and rows to fit values in cells
  • Programmatic control of all interface properties, property pages available at runtime
Microcube mode features
  • ContourCube generates extremely compact microcube files for persistent storage of data and metadata
  • A saved cube can be loaded very fast without referencing a data source
  • Contour microcubes store hypercube data in very compact form. For example, a microcube containing 150 000 records in 7 dimensions and 2 facts has the size of less than 1MB. This makes possible implementing mobile OLAP technology allowing user to deploy data for analysis and to publish reports to the Web
  • Microcubes can be loaded by URL, which enables effective support of Web applications.
Advanced analysis
  • Interactive drill-down into data and filtering of dimension data values
  • Instant switching between ascending and descending sort orders in the grid
  • Advanced ranking
  • Wide choice of aggregation functions: Sum, Min, Max, Count, etc., which can be easily switched at runtime.
  • The unique "LAST" aggregation algorithm that allows to analyze stocks, balance sheets, loan balance, and other data that has balance carried forward.
  • Date/Time fields can be automatically broken into parts: Year, Quarter, Month, Week, Ten-Day Period, Day of Month, etc.
  • Powerful and flexible embedded Formula Language for advanced data analysis allows to manipulate with single data points, define custom fields and functions, build sophisticated expressions for conditional cell styles, and more.
  • Rich set of dynamically embedded statistical functions: Average, Variance, Standard Deviation, Root Mean Square, Variance Ratio, etc.
  • Fast grid transposition


ContourCube Applications

Overview Features Architectures User Interface Approaches

This section describes several applications of ContourCube ActiveX control. It does not cover all possible uses of this Product; by contrast, you can elaborate your own original and effective applications powered by ContourCube.

Data Warehouse

Use ContourCube ActiveX to create Analyst and Manager Interfaces for your Data Warehouse. Also, you can develop a front-end application for a third-party Data Warehouse.

Analytical interface for an OLTP system

Use ContourCube control to create Analyst and Manager interfaces for your OLTP system. Develop analytical applications for other third-party OLTP systems.

Data Mart

Use ContourCube ActiveX to build Data Marts with Analyst and Manager interfaces for your OLTP system. You can also build front-end Data Mart applications for other third-party systems.

Publishing and Reporting Features

ContourCube includes features that facilitate publishing of financial, statistical, and other vital business information for trading companies on the network. Microcubes carry both report data and user interface configuration, providing unique "multidimensional report" features.

See also

ContourCube Features


ContourCubeX Architectures

ContourCube Architectures

Overview Features Applications User Interface Approaches

The flexibility of ContourCube component allows developers to meet the needs of various organizations. This section gives a brief description of some mostly used application architectures that you can implement with ContourCube.

OLAP Client: using relational database server

Use ContourCube to create an OLAP client for any relational database server.

Working with local database with tables placed on a file server

Use ContourCube to create an OLAP client for local databases such as DBF, Paradox, Access, TXT and other databases with tables stored on a network file server for multi-user access.

Using microcubes from a file server

Use ContourCube to create a MOLAP application for multi-user access. Microcubes may be created by Contour CubeMaker batch utility, and then stored on a network file server with shared access.

Connecting to a local database

Use ContourCube to create a Desktop OLAP application for local databases such as DBase, Paradox, MS Access, text, and other personal databases stored on a local workstation.

Using a local microcube

Use ContourCube to create a personal MOLAP application. Microcube files may be built and updated periodically by Contour CubeMaker tool.

Web OLAP Client for Internet server ContourCube file

Use ContourCube to create a Web-based OLAP application for multi-user access. Microcubes may be created periodically by a special server-side application and published to Web pages.

See also

Programming with ContourCube: Tutorial


User interface

User Interface approaches

Overview Features Applications Architectures
  • The simplest interface: one Data source, one Cube
  • Basic interface: one Data source, one Cube, one Grid, one Chart
  • Sophisticated interface: one Data source, two Cubes, two Charts
  • Highly sophisticated interface: one Data source, two Cubes, four Charts

Rich visualization and analytical capabilities enable people to rapidly identify opportunities and trends, find business paradigms, and examine multiple sets of data in user-friendly interface for better decision-making. This section covers a number of user interfaces that you can build with ContourCube ActiveX. Due to the complex architecture of the ContourCube component developers gain a dramatic flexibility in creating BI-interfaces.

The simplest interface: one Data source, one Cube

You can easily build this simplest interface. It enables users to analyze data using an interactive report with a grid.

Basic interface: one Data source, one Cube, one Grid, one Chart

You can develop an interface that equips an interactive report with a third party graph synchronized to a grid. This nice interface will satisfy any user!

Sophisticated interface: one Data source, two Cubes, two Charts

You can build a sophisticated interactive interface that will enable advanced analysts to see data at different angles at the same time.

Highly sophisticated interface: one Data source, two Cubes, four Charts

Finally, you can develop a highly sophisticated interface that will make the most advanced analysts enjoy seeing data at as many different angles as possible.


Using ContourCube: fields

Dimensions Facts Formulas

Since ContourCube control deals with relational databases, it deals with its fields. Briefly, fields are columns of a relational table. ContourCube transforms "plain" table data into multidimensional form, and fields become dimensions and facts.

Generally, dimensions are dataset fields included in aggregation function, i.e. they are fields by which source data is aggregated. By contrast, facts are fields being aggregated, either inside the cube, or when executing query to a database. In ContourCube control layout, dimension values are displayed around the grid (in its pivoting area), and fact values - in grid cells. ContourCube fields can be plain or calculated. Calculated fields are not present in the source dataset; ContourCube creates and calculates them from other existing fields of the same kind. Formula fields is the special case of calculated fields.

Note

All fields pertaining to one ContourCubeX object share the same namespace, i.e. the name of any field must be unique throughout facts and dimensions.

See also

Overview


Using ContourCube: Dimensions

Fields Facts Formulas

Fields by which data records are grouped in ContourCube, are called Dimensions. Dimensions can contain values of various types: strings, dates, numbers, and so on. ContoureCube can split dimensions of date type into a number of date parts, like Year, Quarter, Month, Day of Week, etc., so you don't need to have them in the source record set. Such date parts in ContourCube are called Dimension Modifiers; they can only be obtained from dimensions of date type.

Visual dimension grouping

ContourCube dimensions can be located either at the vertical or at the horizontal axis. For each axis, a dimensions list is built, in which dimensions are located in the following order: the first are upstanding dimensions and the last are the underlaying ones. This order determines tree-like data grouping: high tops are values of the first dimension in the list, and leaves are the values of the lowest dimension. Nodes of a such tree are called Data Points, and Totals are calculated for each branch of the tree. Grand Totals datapoint is located at the root.

Dimension representation

Each moment at any of cube axes not all dimensions from the dimensions list for this axis can be displayed, but only a part of them. Some underlaying dimensions may take part of grouping without being shown in the grid, if they are collapsed or hidden by a dimension of a higher level.
To collapse a dimension means to hide members of all underlaying dimensions; to expand it means to reveal them.
The number of the last (lowest) visible dimension at the axis is called Drill Down Level. The total number of dimensions at the axis is called Axis Width. The following expression defines the axis Roll Up Level:

RollUpLevel = DrillDownLevel - AxisWidth
To visually control expanding / collapsing dimensions at use the "+" and "-" symbols for each dimension. Expanding/collapsing is performed locally only for individual dimension. To collapse the whole dimension (all its values), hold Ctrl key in addition.

Coordinates in the dimension area

ContourCube control supports indexing in both the dimension and fact areas. For indexation in the dimension area it is necessary to localize one of the two dimension areas by specifying vertical or horizontal axis. Indexing in the fact area is performed by cells, in which dimension values are contained as if they were not grouped. So, the size of a cell in the dimension area is defined by the size of the cell for displaying the lowest (last in list) dimension. The cell [0; 0] is located in the upper left corner of the dimension area for both vertical and horizontal axes.

See also

ContourCube Overview


Using ContourCube: Facts

Fields Dimensions Formulas
Base facts and calculated facts

Fields being aggregated in ContourCube are called Facts. They may contain only numeric data that is displayed in cells of ContourCube grid.
There are several types of facts in ContourCube:

Figure 1. Facts in ContourCube
  • Base Facts perform preliminary data aggregation from data source fields with specified algorithms. There are several data source aggregation algorithms: sum, minimum value, maximum value, and record count.
    Base Facts are not displayable, but they supply data for all other visible facts in ContourCube, therefore, they must be declared first.

  • Primary Calculated Facts derive immediately from Base Facts. They aggregate base facts data with specified Fact Aggregation Algorithms: sum, minimum value, and maximum value. For example, if you want to see the sum of a certain value in your report, you should declare a base fact X with SUM algorithm, and a primary calculated fact Y, based on X, with SUM algorithm too.

  • Secondary Calculated (Modified) Facts are based on Primary ones, or other Secondary Calculated Facts, and enhance the set of analytical functions with numerous functions called Fact Modification Algorithms like average, variance, deviation, and others.

  • Formula Facts are entirely defined by certain text expressions, written in embedded ContourCube Formula Language, and returning numeric results. These expressions can refer to any existing fields in ContourCube, including dimensions and their attributes, e.g. position in OLAP hierarchy, count of child nodes, etc. Formulas cannot refer to Base Facts.

Each Primary or Secondary Calculated Fact can be based on one, and only one Base, Primary, or Secondary fact, and use one calculation algorithm at each moment. Formula facts are based on formulas, which can use any number of existing facts and other formulas. Circular references are not allowed in fact definitions; however, facts can switch their calculation algorithms at runtime.
In order to facilitate programming with ContourCube, there is no difference between Primary, Secondary, and Formula facts: they all are of the same type. Developers can know the fact kind through its specific properties determining whether a fact is secondary calculated (modified) or formula-based.

Facts are represented as columns in ContourCube grid. Like dimensions, they can be switched off from the analysis, for example, if you needn't some fact per se but only as a base for some secondary fact. User can turn a particular fact off in the Fact Filter combo box, located in the top-left corner of the control. For developers, there are two additional facilities that allow to disable and hide a fact from the Fact Filter list, or deactivate a single column at all, so that it would not take part of any OLAP calculations.

See also

DataSet Aggregation Algorithms
Fact Aggregation and Modification Algorithms


Using ContourCube: formulas

Fields Dimensions Facts

ContourCube provides its own Formula Language for various analytical purposes, including calculating fact values.
Facts based on formulas are completely independend from aggregation and modification algorithms, and calculate their values from almost any data contained in the cube: base, primary and secondary calculated facts, and dimension values.
Formula facts appear in the grid and are declared similarly to regular ones, except for the Source parameter, which defines the text of formula the fact is based upon. The formula defined with that text must return value castable to a number, and may not be recursive (refer to itself).

In general, formulas are not visual ContourCube fields - they only define calculation rules for facts based on formulas. In other cases, formulas are used in calculations within ContourCube, for example, to define conditional display styles.

See also

Tutorial: Performing custom calculations


ContourCube_Tutorial

Programming with ContourCube: Tutorial

About ContourCube

This section briefly describes how to quickly familiarize with ContourCube control and build applications powered with it.
There are 10 basic steps to deploy main functionality of ContourCube:

  1. Your first ContourCube appliction
    How to make ContourCube work for the first time.

  2. Customizing report appearance
    This chapter describes setting up the control's header and footer, applying cell styles, customizing fonts and colors of various grid elements at design time.

  3. Working in MOLAP mode
    Working with multidimensional OLAP report in a single compressed file.

  4. Printing and exporting views
    Here you'll find information on how to obtain readable printed version of your reports, and how to export it in different formats acceptable by non-ContourCube applications.

  5. Charting with ContourCube
    Accessing cube data for 3rd-party graphic tools.

  6. Optimizing ContourCube performance
    How to make ContourCube work faster with very large amounts of data. "Fine tuning" of connection and data retrieval parameters.

  7. Performing custom calculations
    This chapter describes the use of calculated and formula-based columns in ContourCube.

  8. Controlling the grid programmatically
    How to control ContourCube user interface from your program code: moving dimensions between axis, filtering their items, hiding columns and so on.

  9. Working with Styles
    Here you can read about cascading ContourCube stylesheets, and how their rules are applied to cells in the grid.

  10. Distributing ContourCube applications
    Which files you must distribute with your ContourCube-powered applications, and which operations must be done during its installation process.


ContourCube_Step1

Programming with ContourCube: Tutorial

About ContourCube

Step 1. Your first ContourCube application

After having installed ContourCube ActiveX, you are ready to build your first application powered with ContourCube.

Open your development environment and start a standard Windows GUI application. If needed, add ContourCube ActiveX control to your project dependency list. When ContourCube is available in your component palette, just place it onto your form. Now you can set up its database connection and the query to database. These parameters are available at both runtime and designtime: to populate ContourCube with data right in design mode, right-click on the control and open its Properties page. The first tab contains connection information: Data Source Type, Connection String and SQL query. Data Source may be of one of four types:

  • ADO (ActiveX Data Objects), which is most used for almost all data sources;
  • BDE (Borland Database Engine) alias, ususally used to connect to BDE-managed tables and databases;
  • Microcube connection. ContourCube can work with Contour microcube files - compressed multidimensional databases that store full-featured OLAP reports. No SQL statement is accepted in this mode. See more on this connection type in chapter Working in MOLAP mode
  • Unbound mode. In this case ContourCube opens arbitrary populated ADO recordset with IContourCube.Open method. Connection string and SQL statement are not needed here.

According to the type of Data Source, the connection string may contain either regular ADO connection string, or BDE alias with optional parameters, or just path / URL of a microcube file. Assemble the connection string with builtin composer (...), and place your SQL statement into the box below it.

The second tab of Properties page allows you to declare cube fields (dimensions and facts) and allocate dimensions on three cube axis: Horizontal, Vertical and Outside (the fourth axis, Invisible, is available programmatically). Facts represent ContourCube grid columns and are placed onto Facts area.
By pressing the Get Field List button, ContourCube retrieves all possible fields available from the recordset returned by SQL command: it automatically splits all date fields into years, quarters, months, and so on, so that you can place date parts directly onto appropriate axis. For facts, specify aggregation algorithms: SUM (default), MIN or MAX.

On other properties page tabs you can customize general ContourCube appearance like colors, fonts, data formats, headers and footers. All these properties are also available from code at runtime; see more on setting up report layout in chapter Customizing Report Appearance

Now when you have accomplished these manipulations, close Properties page, and set Active property to True. ContourCube will execute the query and show it in the multidimensional grid.

If you set up ContourCube at runtime, store your connection string in the ConnectionString property, and the query statement - in the SQL property. Before turning Active to True, call IContourCube.CreateFieldsFromDS procedure which retrieves list of fields and automatically puts them at their places. Or use Add method of IContourCube.Dims and IContourCube.Facts collections to declare fields implicitly.


ContourCube_Step2

Programming with ContourCube: Tutorial

About ContourCube

Step 2. Customizing report appearance

ContourCube has a lot of properties allowing to customize the appearance of your reports. You can set up various elements of the report: dimension titles, fonts, colors, and other.
All tabs in ContourCube Property Page, except for Data Source and Cube Dimensions & Facts, allow to customize grid appearance:

  • Field View Settings page allows to set titles for all cube fields. Also, you can enable, disable or set visibility of particular facts.
    This page also provides dimension values format settings. Some modified dimensions like date parts, have predefined format settings, for example "Quarter %s", "Week %s". Fact values are formatted using stylesheets.
  • Appearance Settings page allows you to customize various elements of the OLAP report: dimension filters, their titles while performing different operations, cube header & footer and others.
  • In Header Settings and Footer Settings pages you can compose header and footer of your report in Reach Text format.
  • Style Holder Editor page. Here you can edit the set of styles stored in ContourCube Style Holder. These styles apply to the cells of grid in your report. There are two kinds of predefined styles in ContourCube: Standard styles and builtin styles.
    builtin styles are manipulated by reference. i.e. all modifications made to these styles at run time are kept after that your application returns control to the design environment.
    Standard styles are copies of builtin styles, and every time you put a standard style into the style holder, all modifications you have made to this style before are overwritten with copies from a corresponding builtin style.
    Both builtin and standard style sets have styles applying to Leaf cells (default), Totals, Subtotals, Grandtotals, and cells of facts with Rank algorithm. There is also {StyleError} builtin style, which is used to highlight cells that use incorrect style settings.
  • Stylesheet Editor page. At this page you can define and edit rules according to which styles from ContourCube styleholder are applied to the grid cells. There are several builtin rules linking cell styles with specific conditions, so appropriate styles apply to cells on which these conditions are true.
    Like styles, builtin rules are operated by reference, so Populate With Builtin Rules button fills the collection with replicas of these builtin rules.

All settings available in ContourCube property page are also available programmatically through properties and methods of IContourGrid interface. You can also invoke this property page with any tabs from your program using methods of IContourGrid.ContourPropertyPages property.

See also

IContourStylesheet interface
IContourStyleholder interface
IContourStyle interface
IStyleRule interface


ContourCube_Step3

Programming with ContourCube: Tutorial

About ContourCube

Step 3. Working in MOLAP mode

The main intention of ContourCube component is to produce multidimensional OLAP reports from relational databases. Because any report contains not only data, but also layout settings which are generally not stored in database, ContourCube saves OLAP reports in the proprietary format. Files that contain Contour multidimensional reports are called microcubes and are very compact, so ContourCube control can fast open and save full-featured reports in microcubes, working in MOLAP (Multidimensional OLAP) mode.

Swithcing ContourCube to the MOLAP mode is done by setting DataSourceType property of IContourCube interface to xcdt_Microcube. At design time, open ContourCube Property Page, and select Microcube source type on the Data Source tab. After that, specify microcube file name as the connection string. Then, turning ContourCube active will open your report from the microcube. At run time, you an also use Load and Save methods, as shown below:

myContourCubeX.Cube.Load("C:\MyCubes\MyReport.cube")
. . .
myContourCubeX.Cube.Save("C:\MyCubes\MyNewReport.cube")

Note

Microcube files have .cube extension, and you must specify it when working in MOLAP mode.

See also

TxCCubeDSType enum


ContourCube_Step4

Programming with ContourCube: First Steps

About ContourCube

Step 4. Printing and exporting views

Multidimensional Contour OLAP reports would be much more valuable if you could view them not only with ContourCube control. Therefore, ContourCube provides a way to print the current view of the grid, and export it to HTML files.

To send your report to printer, use PrintCube method in IContourGrid interface. It has two parameters determining respectively whether to show preview window before printing, and if you want to obtain a colored paper copy. For example,
ContourCubeX.PrintCube(True, False)
 will show a Print Preview window and then send the report to printer in grayscale.

In Print Preview window you can set up various printing parameters, such as paper size and orientation, margins and so on, but all these settings are available through code as properties of IReportPrintSettings interface. Obtain this singletone interface from ReportPrintSettings property:

myContourCubeX.ReportPrintSettings.PaperSize = xpsA4
myContourCubeX.ReportPrintSettings.Orientation = xpoLandscape
myContourCubeX.ReportPrintSettings.PrinterBin = xpbAuto

The above example sets paper size to Standard A4 (297x210 millimeters) with landscape orientation, and tells printer to automatically select paper source. However, often you may need to allow end-user to set up the page. In this case, just invoke ReportPageSetup procedure.

If you want to print very wide grids that cannot fit the page width, set ShrinkToFit property to True. Then, FontScale setting will be ignored, and the grid will be printed one page width.

Well, now you may want to see your report not only on paper, but included in other printable documents like Excel spreadsheets, Word texts, etc. ContourCube gives you this opportunity with ExportToFile procedure. This method allows to save the current cube view to a file in specified format. If you have a chart drawn from the cube, use the same procedure to export the chart in its current state to a graphic file (usually JPEG). For example,

myContourCubeX.ExportToFile("MyCube.html", "MyChart.jpg", xet_html)

exports the cube view in HTML format to the file named MyCube.html, and the chart view - to the graphic file MyChart.jpg .

See also

ContourCube tutorial: Charting with ContourCube
TxPaperSize Enum
TxPrinterOrientation Enum
TxPrinterBin Enum
TxReportFontScale Enum
TxOLAPExportType Enum


ContourCube_Step5

Programming with ContourCube: Tutorial

About ContourCube

Step 5. Charting with ContourCube

One of the most useful feature of any deliverable report is the possibility to represent data in graphical form. ContourCube control provides you such feature in the way of accessing data in grid cells through IContourView interface obtained from ContourCube control.

IContourView interface provides information such as number of rows and columns in the grid, and a way to extract data from its cells, for example:

myView = myContourCubeX.CloneView(1, 1)
for i = 1 to myView.HAxis.Length
  for j = 1 to myView.VAxis.Length
    myCell = myView.GetViewCell(i, j)

Because ContourCube grid is based on an IContourView interface and inherits its members, you may use its current view instead of creating a new one:

for i = 1 to myContourCubeX.HAxis.Length
for j = 1 to myContourCubeX.VAxis.Length
myCell = myContourCubeX.GetViewCell(i, j)

Note: Drawing graph from a large cube may take long time, so it's better to create reduced views as shown
in previous example. To learn more on getting reduced views, see CloneView method.

The myCell variable above is an object accessed through IViewCell interface. This interface provides full information about any cell in a view, including datapoint in the OLAP hierarchy. For charting purpose, you'll need its Value function which returns an ICalcResult object corresponding to the cell:

NumericCellValue = myCell.Value(myContourCubeX.Facts.Item(0)).Value

To draw the entire graph, add the finally obtained numeric value of each view cell to the data grid or series of your charting control. You can then retrieve dimension values to an array using ICubeDim.GetValues method, and use them to set series labels of your chart:

myDimValues = myContourCubeX.Cube.Dims.Item("Dimension1").GetValues(xfs_Visible)

See also

IContourView.CloneView
IContourView.GetViewCell
IViewAxis interface
IViewCell.Value
ICalcResult interface
TxFilterState enum
IContourGrid.GetGridCell
IGridCell interface
IDimValues interface


ContourCube_Step6

Programming with ContourCube: Tutorial

About ContourCube

Step 6. Optimizing ContourCube performance

One of the main advantages of ContourCube before other desktop OLAP controls is its performance: ContourCube can aggregate and load upto some 2,000,000 records from any relational database. However, achieving such results requires some additional parameters to be set before you use the control with large data volumes.

The "Fine Tuning" of ContourCube is not difficult, and fits in following simple rules:

  • Always use a server-side, forward-only, read-only data cursor for cube data, if the dataset provider supports it. If you load data into the cube from an ADO data source, use ADOCursorLocation property to specify where to store the data cursor (by default, at server side). If you work in Unbound mode, set these properties for the ADO recordset that you load into your cube with Open method.

  • If your data source efficiently supports GROUP BY (e.g. MS SQL Server or IBM DB2), it is better to preliminary aggregate data on a server using GROUP BY in your SQL query, turning internal component's preliminary grouping off by setting PreGrouping property to False. On the other hand, providers of most local databases, e.g. Dbase, MS Access, Paradox, are extremely inefficient in GROUP BY emulation, so if you are working with such database, turn preliminary grouping on - it can give you performance gain up to an order of magnitude. By default, PreGrouping property is set to True.

  • In your SQL expression, don't query columns that won't be used as cube fields.

  • Don't create unneeded dimensions and facts. If you need some fact only as a base for other calculated fact(s), set FactEnabled property for that fact to False.

  • If dimension values in your database are numeric identifiers, and you want to show their descriptive names, don't map values using SQL query; instead, use ContourCube dimension values mapping feature.

  • If you have a Date or DateTime dimension which you use to analyze data by periods, and you need not to drill down deeply (e.g. the minimal individual period is Month), you may increase performance using preliminary aggregation of Date or DateTime columns in your SQL query, for example:

    SELECT CategoryName, ProductName, ShipCountry, SUM(Quantity) as Quantity,
      ShippedDate - ( DATEPART(d,ShippedDate) - 1 ) as ShippedYM,
      SUM((d.UnitPrice*Quantity*(1-Discount)/100)*100) AS ProductSales
    FROM (Categories c INNER JOIN Products p ON c.CategoryID = p.CategoryID)
      INNER JOIN (Orders o INNER JOIN [Order Details] d ON o.OrderID = d.OrderID)
        ON p.ProductID = d.ProductID
      CROSS JOIN Employees e1 CROSS JOIN Employees e2 CROSS JOIN Employees e3
    WHERE o.ShippedDate IS NOT NULL
    GROUP BY CategoryName, ProductName, ShipCountry,
      ShippedDate - ( DATEPART(d,ShippedDate) - 1 )

Depending on your local conditions, you can take or not some of these advices in account, and play with them in order to get the best performance for your application.

See also

IContourCube.DataSourceType
IContourCube.ConnectionString
IContourCube.SQL
ICubeDim.MapType
ICubeDim.Mapping


ContourCube_Step7

Programming with ContourCube: Tutorial

About ContourCube

Step 7. Performing custom calculations

The main feature that makes the difference between ordinary and analytical report is performing custom calculations within the report. ContourCube gives you a mechanism of calculating values in cube columns with a variety of algorithms.

ContourCube allows you to add calculated facts in three ways:

  • Creating Primary Calculated Facts. These ones are calculated from preliminarily aggregated Base Facts of the cube. Primary Calculated Facts can only be declared with aggregator IDs, for example:

    myContourCubeX.Cube.BaseFacts.Add ("SourceDBField", "BaseField")
    myContourCubeX.Cube.Facts.Add ("BaseField", "PrimaryFact", "Primary Fact", xfaa_SUM)
    The xfaa_SUM identifier is the aggregator ID which tells ContourCube to look for a base fact named BaseField, and to sum its values in PrimaryFact column.
    For Base Facts, you can also specify aggregation algorithm, i.e. the way of aggregation of data source records, by setting SourceAggregator property. The IsModified property of a Primary Calculated Fact returns False.

  • Adding Secondary Calculated Facts. These facts are built from similar, or Primary Calculated ones, i.e. they don't require Base Facts as source. Such columns can only be declared with modifier IDs, which force ContourCube to operate on specified Primary or Secondary column when calculating values of a such fact. The following example shows how to add such column, based on the one declared above:

    myContourCubeX.Cube.Facts.Add ("PrimaryFact", "NewColumn", "New Column", xfam_AVG)
    As you see, it adds fact named NewColumn which takes the average value of PrimaryFact column in each data point. The IsModified property of this fact will return True.

  • Finally, you can use powerful and flexible ContourCube Formula Language to specify your own algorithms of data calculation.
    To declare a Formula Fact, use the same routine as for Secondary Calculated Facts, but pass the formula text written in Formula Language instead of a Base Fact name:

    myContourCubeX.Cube.Facts.Add ("$end - $begin", "NewFormula", "New Formula")
    The above example adds a fact whose value in each data point is the number of its child datapoints. You can also change calculation algorithm of an existing fact at runtime, e.g. turn it into formula:

    myContourCubeX.Cube.Facts.Item("NewColumn").Formula = "$pos"
    Here, fact NewColumn has been made a formula which shows the position of each data point in current dimension.

Formula expressions can contain complex statements which perform sophisticated calculations on both cube facts and dimensions. Learn more on how to compose and use formula expressions in chapter "ContourCube Formula Language".

See also

Using ContourCube: Facts
ICubeBaseFact interface
TxDatasetAggrID enum
ICubeFact interface
TxFactAlgorithm enum
ICubeFact.Algorithm
ICubeFact.Formula
ContourCube Formula Language: Global Variables


ContourCube_Step8

Programming with ContourCube: Tutorial

About ContourCube

Step 8. Controlling the grid programmatically

ContourCube control has a powerful and flexible graphic user interface which provides a lot of functions for end-users. Now it's time to control this interface from your program code.

Dimension moving and filtering are the most frequent user operations in ContourCube grid. Programmatically, these features are available with ICubeDim.MoveTo procedure and IDimsFilter interface. For example, the following code moves dimension "Country" to the first position at the horizontal axis, and inverts its filter settings:

myContourCubeX.Cube.Dims.Item("Country").MoveTo(xda_Horizontal, 1)
myContourCubeX.Cube.DimensionsFilter.FilterAll("Country", xfo_InvertFilter)
myContourCubeX.Cube.DimensionsFilter.Apply()

Dimension value filtering in ContourCube is transactional: the call of Apply procedure commits at the last line above commits all changes made after the last call of this method. You can also roll back with Cancel method, or reset filter to its previous state with Reset procedure.
Unlike moving dimensions with mouse, MoveTo method allows you to put them even outside the control, i.e. place dimensions onto Invisible axis.
As you see, the IDimsFilter object is returned by DimensionsFilter property of the cube. This is a singletone object, i.e. each time you request it, you will get the same instance if this interface with all changes you made to it previously. Use properties and methods of IDimsFilter interface to programatically filter values of any dimension in ContourCube.

Controlling columns visibility in ContourCube grid is available for users with mouse, by clicking the Fact Filter drop-down list; from code, this functionality is available through IViewFact.Visible property. Setting it to False is equivalent to unselecting a fact with mouse in the Fact Filter list; but programmatically, it's also possible to remove a fact from that list at all, or even deactivate it, as if it was never declared in ContourCube.
To remove a fact from the list of available facts in the grid, set IViewFact.Enabled property to False. The IViewFact interface is available as an item of the collection returned by Facts property, as shown below:

myContourCubeX.Facts.Item("Amount").Visible = False
myContourCubeX.Facts.Item("Amount").Enabled = False

To deactivate a single fact in the cube, refer to the ICubeFact interface: it contains boolean Active property which can be set to False in order to turn corrresponding fact inactive:

myContourCubeX.Cube.Facts.Item("Amount").Active = False

This operation doesn't remove the fact's declaration but makes its data unavailable for the view, so that in fact you get almost the same result as if you deleted the fact at all, but with much less of work. Moreover, in this case you don't need to deactivate the whole control.

Note: Deactivating a fact makes it unavailable for all depending calculated columns in the grid, so their values will be no longer valid until you reactivate that fact.

Drill Down operations are also available from code: you can expand and collapse dimensions at horizontal and vertical axis, and even single dimension members.
Visible ContourCube axis are split into sections by dimension members; you can access any axis section from IViewAxis.GetSection method which returns corresponding IAxisSection interface. In its tour, this interface provides several methods and properties to control its expand / collapse state:

  • DrillDownLevel property returns integer value indicating the last visible level of the section or axis hierarchy. This property is read-only in IAxisSection.

  • Collapsed property returns True, if this axis section is completely collapsed, i.e. its Drill Down level is zero.

  • Finally, Collapse function allows you to set the section drill down depth. It accepts two parameters: an integer representing target drill-down level, and a boolean value determining the drill direction (up or down). The function returns a boolean value that tells whether the target level was collapsed before executing this method.

For example, the following code collapses all levels below 1 in the first section of horizontal axis:

BeenCollapsed = myContourCubeX.HAxis.GetSection(0).Collapse (1, True)

And this command expands level 2 and all underlying in the fifth section of vertical axis:

BeenCollapsed = myContourCubeX.VAxis.GetSection(4).Collapse (2, False)

If you want to set Drill Down level for all sections of an axis, use the appropriate features of IViewAxis interface:

  • DrillDownLevel property sets the last visible level of the dimension hierarchy at corresponding axis. For example,

    myContourCubeX.HAxis.DrillDownLevel = 1
    collapses all dimensions except top at the horizontal axis.

  • RollUpLevel is always negative and is related to the DrillDownLevel by this expression:

    axis.DrillDownLevel = axis.Width + axis.RollUpLevel
    , where axis is an IViewAxis object, and Width is the number of dimensions at the axis. Although DrillDownLevel and RollUpLevel look similar, in a number of cases it is preferrable to use one and not another. For example, you may want to collapse N last levels on an axis:

    axis.RollUpLevel = -N
    If you tried to do it through DrillDownLevel, it would be seamlessly much more difficult.
Note

Drill Down levels of cube axis and their sections are positive, and the first level has number 0. By contrast, RollUpLevel can take only negative values: -1, -2, -3, and so on.
The sense of the value returned by Collapse method does not depend on the value of its second parameter: it returns True only if the target level was collapsed before, no matter what operation (expand or collapse) you are performing.

See also

ICubeDim interface
IContourCube interface
TxDimAxis enum
TxFilterOperation enum
IViewAxis.Width
IViewAxis.MaxWidth
IViewAxis.Length


ContourCube_Step9

Programming with ContourCube: Tutorial

About ContourCube

Step 9. Working with Styles

Now when you can obtain a full-featured OLAP report from relational data, you may want to make visual data analysis easier, "animate" the report. ContourCube gives you such possibility through applying Grid Styles.

Because ContourCube is a grid-like reporting control, styles are applied to the cells of grid. ContourCube styling technology stands on three basic statements:

  • Style is a set of visual properties and their values determining the appearance of an element in the grid: background and font color, font size, format strings, and so on.

  • Condition is some boolean expression that evaluates for each grid cell. For example, 0 < Cell Value < 100 is a Range Condition which evaluates to True if value stored in a grid cell is positive and less than 100.

  • Rule is a statement that sets a relation between Condition and a Style, so if Condition is true for given cell, the corresponding Style is applied to that cell.

For convenient use, ContourCube styles are held in Style Holder, which is a container and at the same time a "factory" of styles. Style rules themselves are stored in Stylesheets, which can be cascaded. Cascading stylesheets allow you to group style rules between them, add / remove groups of rules related to various analytical functions, etc.

If more than one condition evaluates to True for a cell, styles are applied in order of checking style conditions: from the last condition in the fisrt stylesheet in cascade to the first one in the last cascading stylesheet, as indicated with arrows at Fig. 1:

Figure 1. ContourCube Styling Architecture.

In ContourCube ActiveX, there is a lot of interfaces for styling purpose. According to the architecture figured above, four of them can be picked out:

  • IContourStyle interface represents a style with all its elements: font, font color, cell color, format string, and some other special properties. Among its methods, there is a couple of methods DisableProperty / EnableProperty, which allow to exclude a style element from or include it in the style applying sequence mentioned above.

  • IContourStylesheet contains collections of style rules and status texts, which are displayed when grid cells or formulas contain errors. The cascading mechanism is implemented by BaseStylesheet property, which points to the stylesheet that the current one is based on.
    You can also allow user to customize stylesheet by showing its property page - Stylesheet Editor. This functionality is available in IContourStylesheet through Edit method.
    The collection of style ContourCube stylesheets is referred by IContourGrid.Stylesheets property.

  • IContourStyleHolder interface implements a collection and a factory of ContourCube styles. Properties and methods of this interface allow you to walk through the collection, add new custom, builtin, or standard styles.
    You can also allow user to customize style holder by invoking Style Holder Editor with Edit method.
    The default style holder of ContourCube control is referred by IContourGrid.StyleHolder property.

  • IStyleRule is the parent interface for its numerous descendants, which represent style rules with various kinds of conditions: cell type, comparating, formula-specified, range, and rank style rule. Use their properties and methods to specify appropriate style conditions.
    The Style property is common for all of them, and refers to the style that applies when the rule condition is true. You can also determine the kind of a particular StyleRule instance with Type property.

Different facts in ContourCube grid can have different effective stylesheets set through IViewFact.Stylesheet property. Its value can be NULL; in this case the column uses builtin stylesheet referenced by IViewFact.EffectiveStylesheet. If you want to use a stylesheet for all view facts, use similar properties of IContourView interface.

ContourCube also allows to stylize not only grid cells, but other grid elements, such as dimension titles and values:

  • IContourGrid.DimTitleStyle sets the style of a dimension header

  • IContourGrid.DimTitleDraggingStyle sets the style of a dimension header while it is being dragged

  • IContourGrid.DimTitleInactiveStyle sets the style of a dimension header when it is in the Inactive Dimensions Area

  • IContourGrid.DimValueStyle sets the style of dimension values

Styles of these elements include background color and font, specified through properties of IGridElementStyle interface.

See also

IContourView.Stylesheet
IContourView.EffectiveStylesheet
IContourStatusTexts interface
IStyleRulesCollection interface
IStylesheetCollection interface


ContourCube_Step10

Programming with ContourCube: Tutorial

About ContourCube

Step 10. Distributing ContourCube applications

ContourCube runtime is royalty-free. This means that with a few exceptions mentioned in the License Agreement, you need not to pay for distributing ContourCube-powered applications that you created. If you distribute a non-web ContourCube application, you only have to include the file CCubeX.ocx in your installation package. When installing on a target computer, this file is copied to some location (usually, %SYSTEM% folder, which is C:\WINDOWS\SYSTEM for Windows 95/98, or C:\WINNT\SYSTEM32 for Windows NT/2000/XP systems). Then, it must be registered as an ActiveX control by executing the following shell command:

RegSvr32.exe CCubeX.ocx /s

The /s key tells the tool to run in silent mode which is useful if you execute it in batch mode (e.g. from an installation script). After that, ContourCube ActiveX control is ready for use on the client computer.

If you develop a web-based application (a web site or page), you must create a License Package File (.LPK) from a licensed ContourCube ActiveX control. This file can be made with License Package Tool (LPK_Tool), available in Microsoft® Internet Client SDK. To create a LPK file, follow these instructions:

  • Launch Microsoft License Package Tool LPK_Tool.exe which is supplied with the MS Internet Client SDK. The application is actually simple to use. When you start the application, it displays a combo box that lists all of the ActiveX Controls currently running on your computer.
  • The next step requires that you choose the controls that you want to display on a given HTML page. You choose a control by highlighting it in the combo box and then clicking the Add button.
  • Once you've selected all the controls that you want to display on a given page, you can create and save the actual .lpk file by clicking the Save & Exit button. (This causes the application to display the File Save dialog box, which allows you to specify the path and file name.)

Another file needed to make your web application work on a web server is ccubex.cab, shipped within ContourCube package. Put both these files to a location on your web server so that client can access them from the browser, for example, to a virtual directory of your web site.

When you have placed required files to a web server, you must let your ContourCube-powered web pages know about their location. This is done by adding CODEBASE option to the HTML <OBJECT> tag corresponding to the ContourCube control, for example:

<OBJECT ID="myContourCubeX" CLASSID="clsid:07EE1598-351E-49A8-8B75-84BECBB9F4D0" CODEBASE="/CCube/ccubex.cab#VERSION=2,0,0,0">
</OBJECT>

The option VERSION tells client browser to download and update ContourCubeX control if its version at the client computer is older than 2.0.0.0.

Regarding the License Package file, the procedure of providing information about it in your web pages is different: add the following code into every HTML page containing ContourCube ActiveX control:

<OBJECT CLASSID="clsid:5220CB21-C88D-11CF-B347-00AA00A28331"> <PARAM NAME="LPKPath" VALUE="/CCube/license.lpk"> </OBJECT>

This code inserts a License Manager object which provides license information for all ActiveX control on the page, included in your LPK file. For ContourCube ActiveX, it prevents pop-up of the nag screen which is shown when you use the control in Trial mode.

Note

Some development environments such as Microsoft® Visual FoxPro and Microsoft® Visual Studio .NETTM require additional files and libraries to be distributed with new applications. Please refer to the documentation of your development tool in this regard.
Setting VERSION=-1,-1,-1,-1 in the <OBJECT> tag forces update of the ActiveX control any time its version at the web server is newer than user's one.
If you develop and distribute a server-side web application powered by ContourCube, put both ccubex.cab and License Package files to the installation disk of your product. To avoid licensing problems, please refer to the ContourCube License Agreement or contact ContourComponents Support.


CCFL_About

About ContourCube Formula Language

Using Formula Language

ContourCube provides Formula Language for calculated fields and conditional operations. The formula language is simple and easy to use, but at the same time is powerful and flexible enough for many applications. It supports calculations with facts and dimensions, definitions of parameterized functions, named constants and much more.

You can use Formula Language expressions in sophisticated algorithms of field calculations that return results depending on fact values and their levels in hierarchy. Formula Language may be applied not only to cube data, but to metadata as well. In other words, you can use Formula Language expressions to change appearance of data in ContourCube view.


CCFL_Using

Using ContourCube Formula Language

About Formula Language Constants Identifiers Operators Functions Macroformulas Magics

ContourCube Formula Language is closely related to the hierarchical OLAP data structure in the cube: all operations in Formula Language process data stored in ContourCube fields. Formula Language has simple syntax described in this chapter.

Comments in Formula Language can be added everywhere a blank space is allowed. They can contain any characters including line feeds, and are enclosed in /* and */ containers, like shown below:

/* This is a
    multiline
      comment */

Using Formula Language for fact definition

One of the main purposes of the Formula Language is defining calculated facts. Formulas may contain fact names like they were regular variables. Dimension names are also allowed in @-expressions .

@-expressions define not just value of a fact or pseudofact, but value of the given fact for the given dimension. Fact name is specified to the left of @-sign, and dimension - to the right of it.

For example, the formula Foo/Bar returns the value of calculated fact is the value of fact Foo in given data point of the OLAP hierarchy, divided by value of fact Bar at the same point.

Fact values as well as dimension values, are indexed with integer values. Indices of fact and dimension values facilitate work with cube fields in formulas, interpreting them as arrays of members (values):

Foo[0]        /* First value of fact Foo at current hierarchy level */
Foo[1]        /* Second value of fact Foo at current hierarchy level */
Foo@Bar[-1]   /* Value of fact Foo corresponding to the parent of dimension Bar */

Another powerful feature of the Formula Language, is the set of global "magic" variables that allow accessing data and useful parameters of the ContourCube OLAP hierarchy tree.

$magic variables ($-variables) are special global variables and shortcuts to some particular facts or dimensions.
Most of $-variables may be used in formulas as names or values of facts, or as names of dimensions, for example:

Foo@$parent

$parent is the reference to the parent dimension in the tree, so the whole expression returns value of fact Foo corresponding to the previous hierarchy level, i.e. current level subtotal.

See full list of $magic variables in Magics.


CCFL_Constants

ContourCube Formula Language: Constants

Using Formula Language Identifiers Operators Functions Macroformulas Magics

In ContourCube Formula Language, there are two types of constants: literal and named.

Literal constants are just numbers that may contain sign (+/-) and / or decimal point. If absolute value of a constant is less than 1, its zero integer part may be omitted. There are several examples of literal constants in ContourCube Formula Language:

0;  1;  99;  0.123;  .123;  -20.5;  -.777

Named constants are refrerenced by their identifiers. These constants are defined by user and stored in collections of ContourCube control. In formula code, named constants begin with # (sharp) followed by regular or quoted identifier, as shown below:

#X; #Const1; #{My named constant}


CCFL_Identifiers

ContourCube Formula Language: Identifiers

Using Formula Language Constants Operators Functions Macroformulas Magics

Names of variables, functions, parameters and named constants in Formula Language are referred by their identifiers. They are of two types: regular identifiers and quoted identifiers.

Regular identifiers start with a latin letter or underline char (_), follwed by latin letters and / or digits and / or underlines, for example:

foo;  _bar;  my_var;  My_var;  Variable5

All identifiers are case-sensitive; so for example my_var is not the same name as My_var .

Quoted identifiers are enclosed between acolades {} and may contain any character except acolades {} and dots . Leading or trailing spaces are not allowed in quoted identifiers as well.

Here are some examples of quoted identifiers in Formula Language:

{Name};  {Var1};  {This is a quoted identifier}

Along with regular identifiers, quoted identifiers are also case-sensitive.


CCFL_Magics

ContourCube Formula Language: $magic variables

Using Formula Language Constants Identifiers Operators Functions Macroformulas

In ContourCube Formula Language, a number of global variables is available. Their names start with $ (dollar sign), therefore these variables are called $- or $magic variables. Identifiers listed below are widely used in Formula Language and allow users easily perform sophisticated calculations with cube data.

$magic variables are of three possible types:

  • Dimensions are references to present ContourCube dimensions. $-variables of dimension type can be used in formula expressions in place of dimension names.
  • Facts are regular numeric values. Such $magic variables can substitute numbers in formulas.
  • Fact References are links to present ContourCube facts. They can be specified in formulas in place of fact names.

$magic variables are:
Variable | Type | Description | Example
$begin | Fact | Position of first subnode of the given node in the hierarchy. $begin == $pos@$child | $end - $begin == number of children of the given node
$end | Fact | Next position after last subnode of the given node
$dim | Dimension | Reference to the current dimension. $dim == $dim[0] | $begin@$dim - $end@$dim == same thing, with explicit dimension specification
$dimlen | Fact | Number of nodes at the given hierarchy level | $dimlen@$dim[-1] == number of nodes at parent level
$child | Dimension | Reference to the immediate descendant of the current dimension. $child == $dim[1] | $level@$child == $level@$dim + 1
$level | Fact | Hierarchy level of the given dimension. If $level is used outside of an @-expression, it returns level of the current dimension
$leaf | Dimension | Dimension at the bottom level of current hierarchy | $level@$leaf - $level@$root == number of levels in hierarchy
$root | Dimension | Hierarchy root - pseudo-dimension located one level upper the top dimension in current hierarchy (also called zero-datapoint). This dimension contains only one node, i.e. $dimlen@$root == 1
$grandtotal | Dimension | Alias for $root
$parent | Dimension | Reference to the immediate ancestor of the current dimension. $parent == $dim[-1] | $level@$parent == $level@$dim - 1
$subtotal | Dimension | Alias for $parent
$top | Dimension | Reference to the dimension that the current node Totals belong to | Foo@$top == current level Total for the fact Foo
$total | Dimension | Alias for $top
$pos | Fact | Position of the current cell in given dimension | $dimlen - $pos == Position of the current cell from the end of dimension
$self | Fact Ref. | Reference to the current fact* $self == $self[$pos] == $self@$dim == $self[$pos]@$dim | if($pos, $self[$pos-1] + Foo, 0) == growing total for the fact Foo

*) Self-referencing in formula facts (which defines a circular reference) is not allowed; if circular reference is encountered in formula fact, it returns NAN. In regular formulas (ones that don't define facts) $self may be used without restrictions.


CCFL_Operators

ContourCube Formula Language: Operators

Using Formula Language Constants Identifiers Functions Macroformulas Magics

In ContourCube Formula Language, there are three types of operators: Arithmetic, Comparison and Logical operators. All operators have their priority levels, with respect to which calculations are carried out.

Operator syntax is like in C++ language, so programmers can easily compose sophisticated expressions with operators of ContourCube Formula Language.

All Formula Language operators are listed below.

Priority | Operators
Highest Lowest | Unary + and unary -
 | ^ (raise to power)
 | /, *, div, mod, *%, /%
 | +, -, +%, -%
 | <, >, < =, > =, ==, !=
 | not
 | and
 | or, xor
 | eqv
Arithmetic operators
Operator | Description | Example
Unary + and unary - | arithmetic addition and subtraction | a + b
^ | Raise to power | 3^4 (3 raised to power 4)
/, * | Divide, multiply. Division by zero is handled and returns INF (infinity)*. | 10/4
/% | X /% Y - Calculates X in percents of Y. | 9/%45 returns 20 (9 is 20% of 45)
*% | X *% Y - Returns X percents of Y. | 20*%45 returns 9
div | Integer division. Division by zero is handled and returns INF. | 5 div 2 returns 2
mod | Returns division remainder. Division by zero is handled and returns 0. | 5 mod 2 returns 1
+% | X +% Y - increase X by Y percents. | 30 +% 50 returns 45
-% | X -% Y - decrease X by Y percents. | 30 -% 50 returns 15

*) INF pseudovalue may be positive or negative (+INF or -INF), depending on sign of the last evaluated operand.
For example, -1/0 returns -INF, and 1/0 == +INF .

Comparison operators

They are the same as in most used contemporary programming languages: <, >, <=, >=, ==, !=, <> (respectively less, greater, less or equal, greater or equal, equal, not equal). The last operator has two possible syntaxes (!= and <>); one is just the alias of other, and both of them can be used in any expression with operators.

Comparison operators return 1 if the result is true, and 0 if the expression evaluates to false.
Logical operators

ContourCube Formula Language provides five basic logical operators: AND, OR, XOR, EQV, NOT . Some of them have aliases: && for AND, || for OR, ! for NOT.

XOR and EQV operators are mutually reverse - when one returns True, another returns False and vice versa.

All logical operators evaluate only subexpressions required to calculate the end result. For example:
in the expression A and B, if A is zero, B is not evaluated, because the result is fully determined by the value of A.
Same way, in A or B, if A is not zero, B is not evaluated, because the result is fully determined by the value of A.

Logical operators return not 0 or 1, but "the result of last evaluated subexpression". For example,
22 or 789 == 22;
0 or 987 == 987;
0 or 0 == 0;
         22 and 789 == 789;
0 and 987 == 0;
22 and 0 == 0;

In usual boolean expressions, such behavior is equivalent to regular because in Formula Language boolean logic any non-zero value is interpreted as True.

Conditional operator - If

This operator allows controlling calculation flow with value that specific condition evaluates to. It has inline syntax:

if(condition, true part, false part)

Condition can be any acceptable expression. If Condition is zero, the value of false part is returned, otherwise if() returns true part. Here are several examples of using if operator:
if(a == a, 789, 22) == 789
if(3.14, 789, 22) == 789
if(round(0.6), 789, 22) == 789
if(round(0.4), 789, 22) == 22

Like in logical operations, once Condition is evaluated, only required result part is calculated. Thus, if Condition is zero, true part is not evaluated at all, and vice versa, if Condition is different from zero, only true part is calculated.


CCFL_Functions

ContourCube Formula Language: Functions

Using Formula Language Constants Identifiers Operators Macroformulas Magics

ContourCube Formula Language allows use of functions in subexpressions. Users can either compose their own functions, or use a set of global ones that are always present in ContourCube.

User-defined functions are stored in collections of ContourCube control; users can access these collections to add new or edit existing functions. The syntax of a function declaration in Formula Language is quite simple:

FunctionName (Parameter1 [, Parameter2 ... [, ParameterN]]) = FunctionText

For example, MySum(A, B) = A + B

Note: Recursive function declarations are not allowed in Formula Language.

Global functions in Formula Language are available and visible from everywhere. They perform some default calculations in ContourCube, such as summing totals. Users may use these functions in their formulas and Formula Language expressions (in <> brackets, parameter types are shown here):

Syntax | Return value / algorithm | Example
IsLeaf([<dimension>Bar]) 1 if the specified node is a leaf node if(IsLeaf(), Foo, 0) ==
Zero if current node is not leaf
Subtotal(<fact>Foo) | Foo@$parent | X = Subtotal(MyFact)
IsSubtotal([<dimension>Bar]) 1 if the specified node is a subtotal node if(IsSubtotal(), 0, Foo) ==
Zero if current node is not subtotal
Total(<fact>Foo) | Subtotal(Foo) /* alias for Subtotal */ | Y = Total(Fact1)
IsTotal([<dimension>Bar]) 1 if the specified node is a total node if(IsTotal(), 0, Foo) ==
Zero if current node is not total
Grandtotal(<fact>Foo) | Foo@$root | Z = GrandTotal(Some_Fact)
IsGrandtotal([<dimension>Bar]) 1 if the specified node is a grand total node if(IsGrandtotal(), 0, Foo) ==
Zero if current node is not grand total
IsRoot(<dimension>Bar) | Alias for IsGrandtotal()
IsIncluded(<dimension>Bar) | 1 if Bar is included in the slice (but may be inactive), 0 otherwise | A = IsIncluded(MyDim)
IsActive(<dimension>Bar) | 1 if Bar is included in the slice and is active; 0 if Bar is inactive, or not included in the slice | B = IsActive(Dimension1)
IsCurrent(<dimension>Bar) | 1 if Bar is the current dimension. As defined, IsCurrent($dim) returns 1. | C = IsCurrent(Some_Dimension)
IsSameDim(<dimension>Foo,
<dimension>Bar) 		1 if Foo is the same dimension as Bar IsSameDim(Some_Dim, $root) == 1
if Some_Dim is the root dimension.
PercentsToTotal(<fact>Foo) fact /% Total(fact) Assume Foo=2; its total is 5;
Grand total is 10,
and subtotal is 4:
PercentsToTotal(Foo)==40
PercentsGrandtotal(Foo)==20
PercentsToSubtotal(Foo)==50
PercentsToSubtotal(<fact>Foo) | fact /% SubTotal(fact)
PercentsToGrandtotal(<fact>Foo) | fact /% GrandTotal(fact)
WeightedAverage(<fact>Foo, <fact>Bar) | SUM(Foo * Bar) / SUM(Bar) - Weighted average of the fact Foo by Bar.

Builtin functions listed below work on fact values within one current data point:

Syntax | Action | Example
abs(x) | Get absolute value of the operand | abs(2) | 2
 |  | abs(-2) | 2
ceil(x) | Find the smallest integer not less than the operand. | ceil(1.9) | 2
 |  | ceil(-1.9) | -1
floor(x) | Find the greatest integer not greater than the operand. | floor(1.9) | 1
 |  | floor(-1.9) | -2
max(x, y, ...) | Get largest of operands | max(-3, -6.8) | -3
 |  | max(3, 2, 4, 1) | 4
min(x, y, ...) | Get smallest of operands | min(-3, -6.8) | -6.8
 |  | min(3, 2, 4, 1) | 1
round(x [, n]) | Get the value x rounded to n digits after the decimal point. By default, n is 0. Values are rounded to the closest multiple of 10 to the power minus n; if two multiples are equally close, rounding is done away from 0 (so. for example, round(0.5) is 1.0 and round(-0.5) is -1.0). | round(1.1) | 1
 |  | round(1.9) | 2
 |  | round(1.5) | 2
 |  | round(1.535, 2) | 1.54
sign(x) | Get the sign of the operand. If the operand >0, then 1; If the operand <0, then -1; If the operand ==0, then 0 | sign(120) | 1
 |  | sign(0) | 0
 |  | sign(-120) | -1
sqrt(x) | Get the square root of the operand | sqrt(9) | 3


CCFL_macroFormulas

ContourCube Formula Language: Macroformulas

Using Formula Language Constants Identifiers Operators Functions Magics

Any fact in ContourCube can be defined with a formula. Some special expressions are determined by the engine as macroformulas.
Macroformulas are not compiled as regular formulas, but they define regular aggregated or modified facts instead, exposing its parameters with respect to call syntax. Macroformulas can define both aggregators and modifiers.
Macroformula that defines an aggregator , has two parameters: the first is always $self, and the second is the name of the base fact in the cube. For example,

/* This example defines sum aggregator for the fact FooAmount */
SUM($self, FooAmount)

Macroformula that defines a modifier can have one or two parameters. The first parameter is the name of fact that the modifier is applied to; $self and any $magic variables are not allowed here.

MAX(Foo) /* Foo must be name of a fact */

The second parameter is optional and defines hierarchy level relatively to which the modifier is calculated. It may be name of a dimension, or a $magic variable.

MAX(Foo, $child) /* Max value of Foo among direct children of the current node */
MAX(Foo, $leaf)  /* Max value of Foo among leaf nodes */
MAX(Foo, Bar)    /* Max value of Foo among nodes on the level Bar. If the level of the current node (cell in which the formula is calculated) is greater than $level@Bar, it returns NAN */

ContourCube Formula Language provides a number of aggregators and modifiers that you may use to define new facts in the cube (optional parameters are enclosed in hooks [ ]):

Aggregators
Syntax | Description
SUM($self, Foo) | Sum of the previous level subtotals
LAST($self, Foo) | Last value of the previous level subtotals
MIN($self, Foo) | Minimum of the previous level subtotals
MAX($self, Foo) | Maximum of the previous level subtotals
Modifiers
SUM(Foo[, Bar | $bar]) | Sum of the previous level subtotals
AVG(Foo[, Bar | $bar]) | Average value
COUNT(Foo[, Bar | $bar]) | Number of records
MIN(Foo[, Bar | $bar]) | Minimum of the previous level subtotals
MAX(Foo[, Bar | $bar]) | Maximum of the previous level subtotals
AVEDEV(Foo[, Bar | $bar]) | Average deviation
VAR(Foo[, Bar | $bar]) | Variance
STDDEV(Foo[, Bar | $bar]) | Standard deviation
VARP(Foo[, Bar | $bar]) | Biased deviation
STDDEVP(Foo[, Bar | $bar]) | Biased standard deviation
RMS(Foo[, Bar | $bar]) | Root-mean square
RANKUP(Foo) | Ascending rank
RANKDOWN(Foo) | Descending rank


CCFL_Examples

Using Formula Language In Analytical Reports

About Formula Language Using Formula Language

A custom formula can evaluate not in any datapoint. For example, this simple expression

100*(A-B)/B

can not evaluate if B is zero or does not exist. In such cases formulas don't return values - the result is Not A Number (NAN), and a nonzero formula exit code. ContourCube has a set of predefined exit codes and corresponding status texts that appear in cells, in which a formula expression cannot be evaluated:

Figure 1. Formula exit codes.

However, you can control formula calculation flow by invoking your custom exit codes. The special function-like statement

abort(StatusCode)

interrupts the entire stack of current calculation and forces a formula to return specified exit code. For example, the above expression could look as

if(B, 100*(A-B)/B, abort(1))

, which exits with code 1, if B is zero or null.

Note

Negative status codes are reserved for predefined formula exceptions; you cannot pass these into abort() statement. The allowed range of its parameter values is from 1 upto 1,999,999,999 .

See also

IContourStatusTexts interface
ICalcResult.Status


CCFL_Examples

Using Formula Language In Analytical Reports

About Formula Language Using Formula Language

This page is currently under construction. You can find some useful examples of using Advanced Formula Language in following sample projects, included in this distribution:

VB\Average | Calculating average and weighed average values
VB\Trends | Sample Trends Analysis with conditional cell colors


 ContourCubeX object

ContourCubeX object

ActiveX controls are not just objects, but type libraries, stored mostly in .OCX files, containing lots of various OLE1) types, generally Interfaces and Enumerations.
The main object of ContourCube ActiveX library is named ContourCubeX. Visually, relations between its interfaces can be shown in form of the map below:

Figure 1. ContourCubeX object map.

The Default Interface of ContourCubeX object - IContourGrid - provides properties and methods that apply directly to the object; in many development environments, these members are exposed in Property Page or Object Manager for the control.

Its Default Event Interface (not shown at Fig. 1) handles all events of the control; its name is IContourGridEvents, and its methods are default handlers of corresponding events.

All other ContourCube interfaces apply to particular object properties and methods of ContourCubeX control: for example, ICubeHeader is the interface for IContourGrid.Header property.

Enumeration (Enum) types are basically sets of named integer constants that increase code readability and facilitate coding. For example, specifying axis with xda_Horizontal in a method call looks much more readable than its numeric equivalent - 1.

See also

About ContourCube
Overview

Notes

1) Object Linking and Embedding technology


ContourCubeX Events

AfterClose | Occurs immediately after the cube is deactivated
AfterMoveDimension | Occurs immediately after that a dimension has been moved
AfterOpen | Occurs immediately after that the cube is activated
BeforeClose | Occurs immediately before the cube is deactivated
BeforeMoveDimension | Occurs when attempting to move a dimension from one axis to another
BeforeOpen | Occurs immediately before that the cube is activated
KeyDown | Occurs when user presses a keyboard key
KeyPress | Occurs when user hits a keyboard key
KeyUp | Occurs when user releases a keyboard key
MouseDown | Occurs when user presses a mouse button
MouseMove | Occurs upon moving the mouse cursor over the control
MouseUp | Occurs when user releases a mouse button
OnActionWaitFinish | Occurs at the moment the control has finished waiting for some specific action
OnActionWaitStart | Occurs at the moment the control starts waiting for some specific action
OnBeforeOpenFacts | Occurs when user clicks the arrow to open the drop-down list of facts
OnBeforeOpenFilter | Occurs when user clicks the arrow to open the drop-down list of a filter
OnClick | Occurs upon click on the control
OnContextPopup | Occurs upon right button click on the grid or context menu popup
OnCubeLoaded | Occurs when a microcube has been loaded
OnDblClick | Occurs upon double-click on the control
OnDimMapping | Occurs upon displaying of each dimension value with user-defined mapping
OnDimTitleClick | Occurs upon click on a dimension title
OnDimTitleDblClick | Occurs upon double-click on a dimension title
OnDimValueClick | Occurs when user clicks on a dimension value
OnDimValueDblClick | Occurs when user double-clicks on a dimension value
OnErrorLoadingCube | Fires if an error occurs while loading data to the cube
OnErrorLoadingMicrocube | Occurs when an error occured during loading a given microcube
OnException | Occurs if an exception occurs outside of any COM method
OnFactCellClick | Occurs when user clicks on a grid cell
OnFactCellDblClick | Occurs when user double-clicks on a grid cell
OnFactCellEnter | Occurs when a grid cell gets the focus
OnFactHeadingClick | Occurs upon click on a fact heading
OnFactHeadingDblClick | Occurs upon double-click on a fact heading
OnFactStateChanged | Occurs upon any change made in fact filters
OnFiltered | Occurs upon any change made in dimension filters
OnLayoutChanged | Occurs upon any change in the visual layout
OnLoadCube | Occurs when a microcube starts loading
OnMicrocubeLoaded | Occurs when a given microcube has been loaded


ContourCubeX Class

ContourCubeX Control 2.0

ContourCubeX Class Interfaces

IContourGrid

Dispatch interface for ContourCubeX Control
Description

This is the main class of ContourCube type library: the ContourCube ActiveX object is an instance of this class. Properties and methods of its dispatch interface usually appear in the Object Browser or inspector of tour development environment, as members of ContourCubeX object. The control's events are implemented by its default event interface.

See also
IContourGridEvents interface


ContourRect Class

ContourRect coclass

ContourRect Class Interfaces

IContourRect

IContourRect interface
Description

Objects of this class represent visible rectangular areas in ContourCube control. Properties and methods of its default interface allow to link graphical grid geometry with logical structure of ContourCube.

Note

You can instantiate independent objects of class ContourRect, set up their properties, and use them to define custom grid areas. A set of predefined grid areas, such as data cells, is returned by IContourGrid.GetFrameRect method.

See also

IcontourGrid.GetFrameRect


IAxisSection Interface

Properties Methods

IAxisSection Interface

Hierarchy

IDispatch -> IAxisSection

Description

Visible ContourGrid axes are broken into atomic sections by values of their bottom dimensions. In other words, a section is an axis segment, which consists of one member of the bottom dimension at that axis. IAxisSection interface represents the sections.

Visually, the sense of the sections is best shown at the figure below:

Figure 1. ContourCube grid axis sections.

Sections are counted from left to right and from up to down. Each of them is featured by a number of properties. Thus, all sections belonging to an axis shown at the above figure, are coincident, and their coincidence status is 2 for horizontal, and 1 for vertical ones. See Coincidence property for more details.

Each section has its Drill Down level, which determines its expand / collapse depth, and allows you to control it from your program. Also, you can access cube data through axis section interface, using its DataPoint property and GetValue method.

Note

This interface is available through IViewAxis.GetSection method.

See also

IViewAxis.GetSection


IAxisSection properties

IAxisSection Methods

In IAxisSection:
Axis | Returns Axis this section belongs to
Collapsed | Returns whether the section is collapsed
CurrentWidth | Returns current section width
Datapoint | Returns data point for this section
DrillDownLevel | Returns DrillDownLevel at this axis section
Pos | Returns Position of the section on the axis


IAxisSection methods

IAxisSection Properties

In IAxisSection:
Coincidence | Returns number of the last level, at which two sections have common items (0 if no one)
Collapse | Collapses the section
Extent | Returns section extent
Flip | Obsolete feature. Do not use.
GetDisplayText | Returns string displayed at given section level
GetValue | Returns dim value at given section level


IBoolean Interface

Properties

Boxed interface for boolean values

Hierarchy

IDispatch -> IBoolean

Description

The IBoolean interface is not returned by any property or method in ContourCube library - it is just used for output parameters of boolean type in some event handlers.

Note

This interface applies to OnBeforeOpenFilter, OnBeforeOpenFacts, BeforeMoveDimension, OnErrorLoadingCube, OnException, and OnContextPopup events.

See also

OnBeforeOpenFilter event
OnBeforeOpenFacts event
BeforeMoveDimension event
OnErrorLoadingCube event
OnException event
OnContextPopup event


IBoolean properties

IBoolean

In IBoolean:

Value

Returns/sets Value of this Boolean


ICalcConst Interface

Properties

ICalcConst interface

Hierarchy

IDispatch -> ICalcConst

Description

ICalcConst interface contains properties related to the constants that are used in Formula Language calculations.
With this interface, you can get and specify constant names, by which they are referenced from formula expressions, and their values.

Note

Items of this type are contained in ICalcConstants collection obtained from ICalcContext.Constants property.

See also

About Formula Language
ICalcConstants interface
ICalcContext.Constants


ICalcConst properties

ICalcConst

In ICalcConst:
Name | Returns/sets Name of the Constant
Value | Returns/sets Value of the Constant


ICalcConstants Interface

Properties Methods

ICalcConstants Interface

Hierarchy

IDispatch -> ICalcConstants

Description

This interface implements collection of user-defined constants used in ContourCube Formula Language expressions. It allows to add, access, edit, and remove these constants, which are themselves represented by ICalcConst interface.

Note

Access this interface through ICalcContext.Constants property.

See also

ICalcConst interface
ICalcContext.Constants
About Formula Language


ICalcConstants properties

ICalcConstants Methods

In ICalcConstants:
Count | Gets number of defined constants.
Item | Gets a constant object by its name or index.


ICalcConstants methods

ICalcConstants Properties

In ICalcConstants:
Add | Defines a new constant.
Clear | Clears all constant definitions
Exists | Checks whether the constant with given name exists


ICalcContext Interface

Properties Methods

ICalcContext Interface

Hierarchy

IDispatch -> ICalcContext

Description

ICalcContext interface is accessed through IContourCube.CalcContext property, and incapsulates both user-defined constants and functions and provides methods of managing these collections. You can also use its CreateFormula method to define independend formula expressions, which don't belong to the context collections.

See also

IContourCube.CalcContext
ICalcConstants interface
ICalcFunctions interface
ICalcFormula interface


ICalcContext properties

ICalcContext Methods

In ICalcContext:
Constants | Gets the collection of constants defined in the context.
Functions | Gets the collection of user-defined functions belonging to the context.
IsEmpty | Check wheter CalcContext is empty.


ICalcContext methods

ICalcContext Properties

In ICalcContext:
Clear | Clears all definitions of both constants and user-defined functions.
CreateFormula | Creates a new standalone formula object
Load | Loads constant and function definitions from a text file.
Save | Saves constant and function definitions into a text file.


ICalcFormula Interface

Properties Methods

ICalcFormula interface

Hierarchy

IDispatch -> ICalcFormula

Description

ICalcFormula interface implements formula expressions in ContourCube. With its properties and methods you can edit, validate, and evaluate formulas for various data points.
Create instances of ICalcFormula interface with ICalcContext.CreateFormula function.

See also

ICalcContext.CreateFormula


ICalcFormula properties

ICalcFormula Methods

In ICalcFormula:

Text

Returns/sets the text of a formula


ICalcFormula methods

ICalcFormula Properties

In ICalcFormula:
Check | Compile the formula up to the level specified by , returns 'true' on successful compilation.
Eval | Evaluates the formula for given data point and fact, and returns ICalcResult
GridCellEval | Evaluates the formula for a grid cell, and retirns ICalcResult


ICalcFunction Interface

Properties

ICalcFunction interface

Hierarchy

IDispatch -> ICalcFunction

Description

ICalcFunction interface implements user-defined functions in ContourCube calculation context. Use properties of this interface to define and edit custom functions in Formula Language.

Note

Items of this type are contained in ICalcFunctions collection obtained from ICalcContext.Functions property.

See also

ICalcFunctions interface
ICalcContext.Functions
About Formula Language


ICalcFunction properties

ICalcFunction

In ICalcFunction:

Text

Returns/sets Text of the function


ICalcFunctions Interface

Properties Methods

ICalcFunctions Interface

Hierarchy

IDispatch -> ICalcFunctions

Description

This interface implements collection of user-defined functions used in ContourCube Formula Language expressions. It allows to add, access, edit, and remove these functions, which are themselves represented by ICalcFunction interface.

Note

Access this interface through ICalcContext.Functions property.

See also

About Formula Language
ICalcFunction interface
ICalcContext.Functions


ICalcFunctions properties

ICalcFunctions Methods

In ICalcFunctions:
Count | Gets number of user-defined functions.
Item | Returns a function object by its name or index.


ICalcFunctions methods

ICalcFunctions Properties

In ICalcFunctions:
Add | Defines a new function
Clear | Clears all function definitions
Exists | Checks whether the function with given text exists


ICalcResult Interface

Properties Methods

ICalcResult interface

Hierarchy

IDispatch -> ICalcResult

Description

ICalcResult interface implements result returned by formula expressions. Because formulas may return not only numeric values, but also error status, ICalcResult provides properties and methods that help you determine if a formula result is valid, and what is its numeric value.

Note

This interface is returned by a couple of ICalcFormula methods, and by IViewCell.Value property.

See also

About Formula Language
ICalcFormula.Eval
ICalcFormula.GridCellEval
IViewCell.Value


ICalcResult properties

ICalcResult Methods

In ICalcResult:
Status | Returns Status of the CalcResult
Value | Returns Value of the CalcResult


ICalcResult methods

ICalcResult Properties

In ICalcResult:

IsValid

Returns Validity of the CalcResult


ICellTypeStyleRule Interface

Properties Methods

Represents cell type style rule

Hierarchy

IDispatch -> IStyleRule -> ICellTypeStyleRule

Description

This interface represents style rule that applies appropriate styles to grid cells according to their types: Leaf cells, Totals, SubTotals, or GrandTotals.

You can instantiate ICellTypeStyleRule interface with IStyleRulesCollection.AddCellTypeStyleRule function.

See also

TxCellType enum
 IStyleRulesCollection.AddCellTypeStyleRule


ICellTypeStyleRule properties

ICellTypeStyleRule Methods

In ICellTypeStyleRule:
UseGrandTotalCells | Apply style to Grand total cells
UseLeafCells | Apply style to leaf cells
UseSubTotalCells | Apply style to subtotal cells
UseTotalCells | Apply style to total cells
Derived from IStyleRule:
Style | Returns Style
Type | Returns type of condition in the rule


ICellTypeStyleRule methods

ICellTypeStyleRule Properties

In ICellTypeStyleRule:
Add | Adds CellType to use in this rule
IsInUse | Returns whether given CellType is in use in this rule
Remove | Removes CellType from this rule
Derived from IStyleRule:
Delete | Deletes this rule


IComparatorStyleRule Interface

Properties Methods

Represents comparator style rule

Hierarchy

IDispatch -> IStyleRule -> ICellTypeStyleRule -> IComparatorStyleRule

Description

This interface represents style rule that applies appropriate styles to grid cells if the result of comparison of their values with certain constant is true. For example, if value contained in a cell is less than 100.

You can instantiate IComparatorStyleRule interface with IStyleRulesCollection.AddComparatorStyleRule function.

Note

ContourCube also allows to define style rules based on double inequality (range) expressions.

See also

IStyleRulesCollection.AddComparatorStyleRule
IRangeStyleRule interface


IComparatorStyleRule properties

IComparatorStyleRule Methods

In IComparatorStyleRule:
Operator | Returns/sets comparison operator to use
Value | Returns/sets value for comparing to
Derived from ICellTypeStyleRule:
UseGrandTotalCells | Apply style to Grand total cells
UseLeafCells | Apply style to leaf cells
UseSubTotalCells | Apply style to subtotal cells
UseTotalCells | Apply style to total cells
Derived from IStyleRule:
Style | Returns Style
Type | Returns type of condition in the rule


IComparatorStyleRule methods

IComparatorStyleRule Properties

Derived from ICellTypeStyleRule:
Add | Adds CellType to use in this rule
IsInUse | Returns whether given CellType is in use in this rule
Remove | Removes CellType from this rule
Derived from IStyleRule:
Delete | Deletes this rule


IContourCube Interface

Properties Methods

Interface for the core cube of the control

Hierarchy

IDispatch -> IContourCube

Description

IContourCube represents the interface for the core hypercube and its slice. HyperCube is in fact the internal multidimensional database inside ContourCube; it stores source data obtained from a relational database, microcube file, or import source file.
The Slice, in terms of ContourCube, is a subset of cube dimensions in specified order, as well as filter conditions of their members.

A singletone instance of IContourCube interface can be obtained from Cube property of IContourGrid interface. Singletone object means that it's created only once per application session, and no matter when you access it, you will obtain the same instance of IContourCube interface for the same instance of the grid.

See also

IContourView.Cube


IContourCube properties

IContourCube Methods

In IContourCube:
ADOCursorLocation | Returns/sets a cursor location for a dataset specified by ConnectionString and SQL properties
Active | Setting Active to true causes the cube to read data from the data source specified in the ConnectionString property.
BaseFacts | Returns an array of base facts
BoundMicrocube | Returns IMicrocube bound to the cube
BoundSlice | Returns name of the slice bound from Microcube to the cube
CalcContext | Returns ICalcContext
ConnectionString | Describes the real data source for the cube. The actual appearance of this string depends on a data source type (DataSourceType property). E.g., it can be ADO connection string for ADO datasource, or file path (or even URL) for a microcube.
DataSourceType | The type of a data source from which the cube is to be loaded.
DimensionsFilter | Returns the dimensions filter object.
Dims | Returns an array of dimensions
Facts | Returns an array of facts
Fields | Returns an array of fields including facts and dimensions
PinRootAxis | Gets/sets whether the root axis can be changed
PreGrouping | Allows/disables preliminary data grouping
RootAxis | Returns/sets the axis, along which the facts are calculated
RootDim | Returns/sets the dimension name, along which axis the facts are calculated.
SQL | This property specifies an SQL query string for ADO/BDE data sources.


IContourCube methods

IContourCube Properties

In IContourCube:
CreateFieldsFromDS | Create dimensions and facts from the dataset.
ExportData | Export cube data into external format (currently CSV only)
GetAxisDims | Returns a collection of dimensions placed at given axis
ImportData | Import cube data from external format (currently CSV only)
Load | Loads data from the microcube file.
Loading | Return TRUE if data loading in process
Open | Loads data from the recordset given in parameter and builds the cube.
OpenMicrocube | Starts microcube downloading and returns IMicrocube
Save | Saves the cube into the microcube file.
StopLoading | Stops loading data
Wait4LoadingCube | Waits while cube is loading


IContourDatapoint Interface

Properties Methods

Represents cube datapoint

Hierarchy

IDispatch -> IContourDatapoint

Description

This interface implements data point - one of the basic entities of ContourCube component.
In brief, data point is a node of tree-like OLAP data hierarchy at each moment of time, for example:

Figure 1. Data Points

Each Data point consists of values of all active facts corresponding to certain combination of dimension members. At the picture above, (12.16; 708.80) is the data point corresponding to Beverages - Austria - 1994 - August, and (11.20; 224.00) corresponds to Beverages - Brazil - 1994 - September. Blank cells mean that there is no data point for these intersections.

Data points can be not only leafs of the tree: thus, the Total of (14.28; 1223.00) above is also a data point (corresponding to all Condiments for August 1994). The data point that corresponds to the entire cube appears as Grand Totals cells in the grid (not shown at Fig. 1).

Use properties and methods of IContourDataPoint interface to get access to and perform sophisticated calculations on cube data.

Note

The order, in which dimensions define data points is also affected by IContourCube.RootAxis property. Thus, in the examples above it is assumed to be Vertical (setting it to Horizontal would place two first dimensions - Category and Country - at the end of sequences)

See also

IContourCube.RootAxis


IContourDatapoint properties

IContourDatapoint Methods

In IContourDatapoint:
Cardinality | Returns datapoint cardinality - the number of dimensions defining the datapoint. Parameter Level in all Datapoint methods can lie between 0 and Cardinality-1
Category | Returns Category
NextSibling | NextSibling - returns the next sibling datapoint
PrevSibling | PrevSibling - returns the previous sibling datapoint
RootPoint | Returns Root data point


IContourDatapoint methods

IContourDatapoint Properties

In IContourDatapoint:
ChildCount | Returns number of childs for this data point
ChildPoint | Returns a child point for this data point
DataByDim | Returns data at the specified dimension
DataByDimName | Returns data at the dimension specified by name
DataByLevel | Returns data at the specified hierarchy level
Dim | Dim(level) - the dimension at the of the hierarchy specified by the datapoint
IsActual | Returns whether this data point is actual
IsNone | Returns whether this data point is none
LeafPoint | Returns leaf data point with given index, derived from this point
ParentPoint | Returns a parent point for this data point
Value | Returns fact data corresponding to the data point


IContourExtent Interface

Properties

IContourExtent Interface

Hierarchy

IDispatch -> IContourExtent

Description

IContourExtent interface represents extent that applies to an axis section. In brief, Extent is the set of coincident sections occupied by the dimension member located at the particular level of the given section.
The section extent is figured by its beginning and ending sections. Length of the extent is defined as their difference.

You can obtain IContourExtent interface with IAxisSection.Extent method.

See also

IAxisSection interface
 IAxisSection.Extent
 IAxisSection.Coincidence


IContourExtent properties

IContourExtent

In IContourExtent:
Begin | Returns Begin of the Extent
End | Returns End of the Extent
Length | Returns Length of the Extent


IContourGrid Interface

Properties Methods

Dispatch interface for ContourCubeX Control

Hierarchy

IDispatch -> IContourView -> IContourGrid

Description

IContourGrid is the default interface of ContourCube control. It implements all visual properties of ContourCubeX object and triggers its events. In most development environments, its properties and methods appear in Property Browser (Object Inspector, etc.) as members of ContourCubeX control.

This interface is based on IContourView. There is always one initialized instance of IContourView interface, which forms underlaying data layer of what you see in the grid of the control. On the other hand, you can create multiple views with different data subsets, and use them for various purposes like charting, custom exporting, and so on.

Note

Like most types of ContourCube ActiveX library, IContourGrid interface is noncreatable. This means you cannot instantiate this interface programmatically - it is created and initialized automatically upon creation of a new ContourCubeX object.

Events triggered by ContourCube control are handled by IContourGridEvents interface.

See also

ContourCubeX object
IContourGridEvents interface


IContourGrid properties

IContourGrid Methods

In IContourGrid:
Alive | Setting Alive to true/false activates/deactivates both grid and cube at once.
AllowExpand | Allow/disallow expanding/collapsing of whole dimensions or individual nodes.
AllowInactiveDimArea | Show/hide inactive dimensions bar.
AllowPivot | Allow/disallow dimensions moving.
BackColor | Returns/sets the colour used for the control background.
BorderStyle | Returns/set the border style for the cube.
BuiltinStylesCount | Returns a number of builtin styles
ColCount | Returns the number of columns in the grid
ContourPropertyPages | Returns PropertyPages
CurrentCell | Returns CurrentCell
CursorX | Returns X coordinate of the mouse cursor
CursorY | Returns Y coordinate of the mouse cursor
DimFilter | Returns/sets the style used to draw dimension filter comboboxes.
DimTitleDraggingStyle | Returns/sets the style used to draw dragging dimension title.
DimTitleInactiveStyle | Returns/sets the style used to draw inactive dimension title.
DimTitleStyle | Returns/sets the style used to draw dimension title.
DimValueStyle | Returns/sets the style used to draw dimension values.
Enabled | Returns or sets a value that determines whether an object can respond to user-generated events.
FactsHeading | Returns/sets the style used to draw facts headings.
FactsList | Returns/sets the style used to draw facts list.
Footer | Returns footer object.
Header | Returns header object.
InactiveDimAreaBkColor | Returns/sets the background colour of the inactive dimensions area.
InfoURL | Returns/sets info URL
MousePointer | Sets/retrieves the mouse pointer shape then over the object.
PointedArea | Returns current PointedArea
ReportPrintSettings | Returns report print settings
RowCount | Returns the number of rows in the grid
ShiftState | Returns current ShiftState
StyleHolder | Returns StyleHolder.
Stylesheets | Returns collection of available Stylesheets
TitleSettings | Returns/sets the style used to draw cube title.
TotalsString | Returns/sets the text that appears as a label for totals and grand totals. (Default is "Totals")
UnusedDataAreaColor | Returns/sets the colour of the part of the data area not occupied by grid.
Visible | Returns or sets a value indicating whether an object is visible or hidden.
hWnd | Returns window handle to the object
Derived from IContourView:
Active | Setting Active to true sets Cube.Active to true and activates view.
Caption | Returns/sets Caption of this View
Cube | Returns ContourCube
Descending | Returns/sets whether dimensions use descending sort order
Dims | Returns a collection of dimensions
EffectiveStylesheet | Returns EffectiveStylesheet used in this View
Facts | Returns a collection of facts
Fields | Returns an array of fields including facts and dimensions
HAxis | Returns horizontal ViewAxis
NULLValueString | Returns/sets the NULLValueString.
NoGrandTotals | Returns/sets whether view don't present grand totals
NoTotals | Returns/sets whether view don't present totals
Stylesheet | Returns/sets Stylesheet used in this View
Transposed | Returns/sets the transposition status of the view wrt its slice. Setting Transposed to true causes rows and columns to swap their places (columns becomes rows and vice versa).
VAxis | Returns vertical ViewAxis
VisibleFacts | Returns a collection of visible facts


IContourGrid methods

IContourGrid Properties

In IContourGrid:
AboutBox | Shows ContourCube About dialog
BindMicrocube | Binds cube, slice and view from the given microcube
GetArea | Returns IGridArea for the given point
GetBuiltinStyle | Returns a builtin style by name or index
GetBuiltinStylesheet | Returns builtin stylesheet
GetFactInCol | Get a fact, whose values are in the given column.
GetFrameRect | Returns a rectangle containing the given frame
GetGridCell | Returns Cell for given coordinates.
GetPointedFrame | Returns type of frame located at the given coordinates
IsUpdating | Returns TRUE if cube currently updating
PrintCube | Print cube.
ReportPageSetup | Shows report page setup dialog
ReportToFile | Generate a report into an HTML or .xls file.
SortGridByFact | Sort a grid by fact values.
UnBindMicrocube | Unbinds microcube if one is bounded
Derived from IContourView:
CancelFactSorting | Cancel sorting by fact values.
CloneView | Create new IContourView object.
GetViewCell | Returns Cell for given coordinates.
SortViewByFact | Sort a view by fact values.


IContourGridEvents Interface

Methods

Events interface for ContourGridX Control

Description

This is the default event interface of ContourCubeX object. Its methods are default event handlers of the control; in most development environments they appear as the events of ContourCubeX object. Modify these handlers to execute specific code upon triggering of ContourCube events.

Note

Like most types of ContourCube ActiveX library, IContourGridEvents interface is noncreatable. This means you cannot instantiate this interface programmatically - it is created and initialized automatically upon creation of a new ContourCubeX object.

See also

ContourCubeX object
IContourGrid interface


IContourGridEvents methods

IContourGridEvents

In IContourGridEvents:
AfterClose | Occurs immediately after the cube is deactivated
AfterMoveDimension | Occurs immediately after that a dimension has been moved
AfterOpen | Occurs immediately after that the cube is activated
BeforeClose | Occurs immediately before the cube is deactivated
BeforeMoveDimension | Occurs when attempting to move a dimension from one axis to another
BeforeOpen | Occurs immediately before that the cube is activated
KeyDown | Occurs when user presses a keyboard key
KeyPress | Occurs when user hits a keyboard key
KeyUp | Occurs when user releases a keyboard key
MouseDown | Occurs when user presses a mouse button
MouseMove | Occurs upon moving the mouse cursor over the control
MouseUp | Occurs when user releases a mouse button
OnActionWaitFinish | Occurs at the moment the control has finished waiting for some specific action
OnActionWaitStart | Occurs at the moment the control starts waiting for some specific action
OnBeforeOpenFacts | Occurs when user clicks the arrow to open the drop-down list of facts
OnBeforeOpenFilter | Occurs when user clicks the arrow to open the drop-down list of a filter
OnClick | Occurs upon click on the control
OnContextPopup | Occurs upon right button click on the grid or context menu popup
OnCubeLoaded | Occurs when a microcube has been loaded
OnDblClick | Occurs upon double-click on the control
OnDimMapping | Occurs upon displaying of each dimension value with user-defined mapping
OnDimTitleClick | Occurs upon click on a dimension title
OnDimTitleDblClick | Occurs upon double-click on a dimension title
OnDimValueClick | Occurs when user clicks on a dimension value
OnDimValueDblClick | Occurs when user double-clicks on a dimension value
OnErrorLoadingCube | Fires if an error occurs while loading data to the cube
OnErrorLoadingMicrocube | Occurs when an error occured during loading a given microcube
OnException | Occurs if an exception occurs outside of any COM method
OnFactCellClick | Occurs when user clicks on a grid cell
OnFactCellDblClick | Occurs when user double-clicks on a grid cell
OnFactCellEnter | Occurs when a grid cell gets the focus
OnFactHeadingClick | Occurs upon click on a fact heading
OnFactHeadingDblClick | Occurs upon double-click on a fact heading
OnFactStateChanged | Occurs upon any change made in fact filters
OnFiltered | Occurs upon any change made in dimension filters
OnLayoutChanged | Occurs upon any change in the visual layout
OnLoadCube | Occurs when a microcube starts loading
OnMicrocubeLoaded | Occurs when a given microcube has been loaded


IContourPropertyPages Interface

Methods

ContourCube property pages interface

Hierarchy

IDispatch -> IContourPropertyPages

Description

IContourPropertyPages interface controls appearance of ContourCube Property Pages invoked from program code. It allows to add, remove and show separate property pages of the control at runtime, which allows end user to customize the component with zero programming.

ContourCube Property Pages include:

  • Appearance settings page;
  • Grid behaviour settings page;
  • Cube dimensions and facts settings page;
  • Data source settings page;
  • Field View settings page;
  • Header & Footer settings pages;
  • StyleHolder settings page;
  • Stylesheet settings page.

With IContourPropertyPages interface, you can invoke any combination of these pages. StyleHolder and Stylesheet settings pages can also be invoked by IContourStyleHolder.Edit and IContourStylesheet.Edit procedures.

See also

ContourCube Tutorial
IContourStyleHolder.Edit
IContourStylesheet.Edit


IContourPropertyPages methods

IContourPropertyPages

In IContourPropertyPages:
Add | Adds property page to be shown
Clear | Clears the list of property pages to be shown
IsPageEnabled | Returns whether the specified property page enabled or not
Remove | Removes property page from the list of pages to be shown
Show | Shows property pages


IContourRect Interface

Properties Methods

IContourRect interface

Hierarchy

IDispatch -> IContourRect

Description

This interface represents any visible rectangular area in ContourCube grid, and is referred to by IGridArea.FrameRect and IGridArea.ItemRect properties. Use properties and method of IContourRect interface to link graphical grid geometry with logical structure of ContourCube. For example, you can track mouse coordiantes and take specific actions when the mouse goes over certain fields, cells, etc.

See also

IGridArea.FrameRect
IGridArea.ItemRect


IContourRect properties

IContourRect Methods

In IContourRect:
Bottom | Returns/sets bottom coordinate of the rectangle
Height | Returns/sets height of the rectangle
IsEmpty | Returns whether this rectangle has zero size
Left | Returns/sets left coordinate of the rectangle
ReadOnly | Returns whether the rectangle has readonly coordinates
Right | Returns/sets right coordinate of the rectangle
Top | Returns/sets top coordinate of the rectangle
Width | Returns/sets width of the rectangle


IContourRect methods

IContourRect Properties

In IContourRect:
Contains | Returns whether this rectangle contains point located at the given coordinates
Intersect | Returns intersection rectangle of this rectangle and the given one
IntersectsWith | Returns whether this rectangle intersects with the given one


IContourStatusTexts Interface

Properties

The set of texts representing nonzero calculation statuses of ICalcResult

Hierarchy

IDispatch -> IContourStatusTexts

Description

IContourStatusTexts interface implements a simple set of strings, which are displayed in grid cells with nonzero CalcResult status, i.e. those who contain invalid values for some reason (e.g. division by zero).

Use properties of this interface to define custom status texts for various status codes returned by formula expressions.

See also

ICalcResult.Status


IContourStatusTexts properties

IContourStatusTexts

In IContourStatusTexts:
DimNdxRange | Returns/sets the status text for dimension index violation
FPDomain | Returns/sets the status text for floating point domain violation
FPError | Returns/sets the status text for floating point operation errors
FPValRange | Returns/sets the status text for floating point range violation
GeneralErr | Returns/sets the status text for general errors
InfNegative | Returns/sets the status text for negative infinity
InfPositive | Returns/sets the status text for positive infinity
InvalidDim | Returns/sets the status text for invalid dimensions
InvalidFact | Returns/sets the status text for invalid facts
NoDataPoint | Returns/sets the status text for datapoint miss
NodeNdxRange | Returns/sets the status text for node index violation
NullValue | Returns/sets the status text for NULL cells
UseParentStatusText | Returns/sets whether to use inherited status texts


IContourStyle Interface

Properties Methods

Represents ContourCube styles

Hierarchy

IDispatch -> IContourStyle

Description

This interface implements appearance style applicable to ContourCube grid cells according to the specific rules. IContourStyle properties represent various visual elements, and editing them changes the appearance of the cells that the style is applied to.Methods of this interface allow you to "turn on and off" certain style elements, so that these settings would be applied or ignored.

ContourCube styles are stored in the collection called StyleHolder, accessed through IContourGrid.StyleHolder property.

Note

There are several builtin styles, which determine default appearance of the grid. Although you can edit them, these styles are reset upon reinitializing.

See also

Tutorial: Working with styles
IStyleRule interface
ICellTypeStyleRule interface
IComparatorStyleRule interface
IFormulaStyleRule interface
IRangeStyleRule interface
IRankStyleRule interface
IContourGrid.StyleHolder


IContourStyle properties

IContourStyle Methods

In IContourStyle:
BkColor | Returns/sets background color
FontColor | Returns/sets color of the font used in this style.
Format | Returns/sets Format string
IsBuiltin | Returns whether this style is builtin
IsReplica | Returns whether this style is replica
Pure | Returns/sets Pure property
StyleFont | Returns/sets the font used in this style.
Title | Returns/sets Title of the style


IContourStyle methods

IContourStyle Properties

In IContourStyle:
Delete | Deletes this style
DisableProperty | Disables style property
EnableProperty | Enables style property
IsPropertyEnabled | Returns whether style property enabled


IContourStyleHolder Interface

Properties Methods

IContourStyleHolder Interface

Hierarchy

IDispatch -> IContourStyleHolder

Description

IContourStyleHolder interface implements Style Holder - a collection of ContourCube styles. Use properties and methods of this interface to define new, and manage existing styles, which are applied to grid cells according to the specific rules stored in stylesheets.

Note

Style Holder can be populated with builtin and standard styles, which determine default appearance of the grid. Although you can edit builtin styles, they are reset upon reinitializing. By contrast, standard styles are copies of builtin ones, and you can manipulate them as if they were user-defined.

You can also invoke Style Holder Editor at runtime, this way allowing end user to customize grid styles manually.

Unlike stylesheets, each ContourCube control owns only one style holder, which is accessed through IContourGrid.StyleHolder property.

See also

Tutorial: Working with styles
IContourStyle interface
IContourStylesheet interface
IContourGrid.StyleHolder


IContourStyleHolder properties

IContourStyleHolder Methods

In IContourStyleHolder:
Count | Returns number of existing Styles.
Item | Returns IContourStyle by name or index.


IContourStyleHolder methods

IContourStyleHolder Properties

In IContourStyleHolder:
Add | Adds new style with given name.
Edit | Shows styleholder editor
Exists | Returns whether a style with given name exists.
PopulateWithBuiltinStyles | Populates the holder with replicas of global (builtin) styles
PopulateWithStandardStyles | Populates the holder with copies of global (builtin) styles


IContourStylesheet Interface

Properties Methods

IContourStylesheet Interface

Hierarchy

IDispatch -> IContourStylesheet

Description

This interface implements stylesheet, which determines the appearance of various grid elements. It provides access to the set of rules, according to which styles are applied to grid cells.
Stylesheets of ContourCube control are cascading, i.e. they can be linked in order to add new and override existing elements of each other, forming very complex grid styling.
Stylesheet also incapsulates collection of custom status texts, implemeted by IContourStatusTexts interface.

Stylesheets can affect not only the entire view, but also separate facts. So, if you don't need to define global grid appearance, but just "highlight" a single column, use fact stylesheets through IViewFact.Stylesheet and IViewFact.EffectiveStylesheet properties.

See also

Tutorial: Working with styles
IStyleRulesCollection interface
IViewFact.Stylesheet
IViewFact.EffectiveStylesheet
IContourStatusTexts interface


IContourStylesheet properties

IContourStylesheet Methods

In IContourStylesheet:
BaseStylesheet | Returns/sets the parent stylesheet
Name | Returns name of the stylesheet
StatusTexts | Returns/sets status texts collection for this stylesheet
StyleRules | Returns collection of style rules for this stylesheet


IContourStylesheet methods

IContourStylesheet Properties

In IContourStylesheet:
Edit | Shows the stylesheet editor
PopulateWithStandardRules | Populates stylesheet with standard rules


IContourView Interface

Properties Methods

Base interface for IContourGrid

Hierarchy

IDispatch -> IContourView

Description

IContourView interface represents an abstract model of the grid, whose each cell, represented by IViewCell interface, is a single-fact data point. In general, each data point contains as many facts as there are calculated cube facts, i.e. in order to get a single cell value as it is shown in the grid, you must specify both data point and fact.

IContourView interface provides control & navigation facilities that don't depend on the number of visible facts and their layout. It controls such parameters as dimensions drill down / roll up levels, visibility of Totals / Subtotals, sort order of dimension members, etc. By contrast, slice parameters, such as dimensions layout and their filter states, are controlled through other programming interfaces, and apply to all view instances for this ContourCube object.

View axes

Dimension members are located at the horizontal and vertical view axes; the order, in which dimensions lay at an axis, is the slice parameter, and is common for all views of thie cube. You can access axes through corresponding properties of IContourView interface: HAxis and VAxis.

Multiple cube views

You can create multiple views of the one cube: one instance of IContourView is always present in the active ContourCube control, and contains data and parameters of the visual grid that you see at each moment. Besides, you can obtain a new IContourView instance with CloneView method, for example, to provide its data to a charting tool. All views created from the same cube share the parameters belonging to the slice, but all other data is separate in each view. In other word, if you pivot the cube or filter dimension members, these changes apply to all cube views; on the other hand, drill down levels, sort orders, visibility of Totals, transposition statuses, etc are not affected.

See also

IViewCell interface
IContourDataPoint interface
IContourView.HAxis
IContourView.VAxis
IContourView.CloneView


IContourView properties

IContourView Methods

In IContourView:
Active | Setting Active to true sets Cube.Active to true and activates view.
Caption | Returns/sets Caption of this View
Cube | Returns ContourCube
Descending | Returns/sets whether dimensions use descending sort order
Dims | Returns a collection of dimensions
EffectiveStylesheet | Returns EffectiveStylesheet used in this View
Facts | Returns a collection of facts
Fields | Returns an array of fields including facts and dimensions
HAxis | Returns horizontal ViewAxis
NULLValueString | Returns/sets the NULLValueString.
NoGrandTotals | Returns/sets whether view don't present grand totals
NoTotals | Returns/sets whether view don't present totals
Stylesheet | Returns/sets Stylesheet used in this View
Transposed | Returns/sets the transposition status of the view wrt its slice. Setting Transposed to true causes rows and columns to swap their places (columns becomes rows and vice versa).
VAxis | Returns vertical ViewAxis
VisibleFacts | Returns a collection of visible facts


IContourView methods

IContourView Properties

In IContourView:
CancelFactSorting | Cancel sorting by fact values.
CloneView | Create new IContourView object.
GetViewCell | Returns Cell for given coordinates.
SortViewByFact | Sort a view by fact values.


ICubeBaseFact Interface

Properties Methods

Cube base fact interface

Hierarchy

IDispatch -> IField -> ICubeField -> ICubeBaseFact

Description

ICubeBaseFact interface implements ContourCube Base Facts, which perform preliminary data aggregation from data source fields, and that all other cube facts are based upon.

Base facts are not displayable, but they form the bottom data layer for all visible facts. The main feature of base facts is the Source Aggregation Algorithms, which are in fact algorithms of preliminary data aggregation. You can considerably enlarge functionality of your application by setting different source aggregation algorithms for different base facts.

Note

ContourCube base facts are stored in ICubeBaseFacts collection accessed through IContourCube.BaseFacts property.

The component allows to declare only one base fact per each dataset field of the appropriate numeric type.

See also

Using ContourCube: Facts
TxDatasetAggrID enum
IContourCube.BaseFacts
ICubeBaseFacts interface
ICubeFact interface


ICubeBaseFact properties

ICubeBaseFact Methods

In ICubeBaseFact:
SourceAggregator | Returns/sets fact pregrouping algorithm
Derived from ICubeField:
FieldType | Returns Type of the Field in datasource
SrcName | Returns Name of the Field in datasource
Derived from IField:
Caption | Returns/sets Field caption
IsFact | Returns value that determines whether this Field is Fact or not
Name | Returns Name of the Field


ICubeBaseFact methods

ICubeBaseFact Properties

Derived from ICubeField:

Delete

Deletes field


ICubeBaseFacts Interface

Properties Methods

Collection of cube base facts

Hierarchy

IDispatch -> ICubeBaseFacts

Description

This interface implements a collection of ContourCube Base Facts, and is accessed through IContourCube.BaseFacts property.

Use properties and methods of this interface to add new and manage existing base facts of your ContourCube object. You can also let the end user define cube fields manually at runtime, by invoking cube dimensions and facts editor from IContourPropertyPages interface.

See also

Using ContourCube: Facts
IContourCube.BaseFacts
IContourPropertyPages interface


ICubeBaseFacts properties

ICubeBaseFacts Methods

In ICubeBaseFacts:
Count | Returns number of objects in collection.
Item | Returns a base fact by its name or index.


ICubeBaseFacts methods

ICubeBaseFacts Properties

In ICubeBaseFacts:
Add | Adds a new base fact.
Clear | Removes all base facts
Exists | Checks whether the base fact with given name exists


ICubeDim Interface

Properties Methods

Interface for cube dimension

Hierarchy

IDispatch -> IField -> ICubeField -> ICubeDim

Description

ICubeDim implements interface to cube dimension. There are two types of dimensions in ContourCube:

  • Plain dimensions that are created immediately from data source fields and can contain almost any data;
  • Modified dimensions derive from plain ones, and represent mostly parts of date/time fields (Months, minutes, etc.).

Both these types are represented by ICubeDim interface and are declared with same procedure. Use properties and methods of ICubeDim interface to access dimension members, manipulate their filters, move dimensions between axes, map dimension values, and so on.

Note

ContourCube dimensions are stored in a collection accessed through IContourCube.Dims property.

You can also use IDimsFilter interface to filter dimension values.

See also

Using ContourCube: Dimensions
IDimsFilter interface
ICubeDims interface
IContourCube.Dims


ICubeDim properties

ICubeDim Methods

In ICubeDim:
Axis | Returns axis of the dimension.
DisallowMultipleValues | Returns/sets whether Multiple Values are disallowed
Format | Returns/sets Format string
HasFilter | Returns whether dimension has filter.
MapType | Specifies a mode of mapping dimension values into displayable strings
Mapping | Returns dimension mapping object
Modifier | Returns Modifier
Options | Returns IDimOptions
Pos | Returns dimension\ index in the list at the axis.
Derived from ICubeField:
FieldType | Returns Type of the Field in datasource
SrcName | Returns Name of the Field in datasource
Derived from IField:
Caption | Returns/sets Field caption
IsFact | Returns value that determines whether this Field is Fact or not
Name | Returns Name of the Field


ICubeDim methods

ICubeDim Properties

In ICubeDim:
Filter | Filters dimension using given Operation
FilterValue | Sets filter state for the given Value
GetValueState | Returns filter state of the given Value.
GetValues | Return dimension values.
MoveTo | Moves dimension to the specified position on the specific axis.
Derived from ICubeField:
Delete | Deletes field


ICubeDims Interface

Properties Methods

Collection of cube dimensions

Hierarchy

IDispatch -> ICubeDims

Description

This interface implements a collection of ContourCube Dimensions, and is accessed through IContourCube.Dims property.

Use properties and methods of this interface to add new and manage existing dimensions of your ContourCube object. You can also let the end user define cube fields manually at runtime, by invoking cube dimensions and facts editor from IContourPropertyPages interface.

See also

Using ContourCube: Dimensions
IContourCube.Dims
IContourPropertyPages interface


ICubeDims properties

ICubeDims Methods

In ICubeDims:
Count | Returns number of objects in collection.
Item | Returns a dimension by its name or index.


ICubeDims methods

ICubeDims Properties

In ICubeDims:
Add | Adds a new dimension
AddCalculated | Adds a calculated dimension
Clear | Removes all dimensions
Exists | Checks whether dimension with given name exists


ICubeFact Interface

Properties Methods

Represents cube facts

Hierarchy

IDispatch -> IField -> ICubeField -> ICubeFact

Description

ICubeDim implements interface to cube fact. Besides Base Facts, there are three types of facts in ContourCube:

  • Primary Calculated facts that are created from Base Facts and aggregate their data;
  • Primary Calculated facts, which can be based on either primary, or other secondary calculated ones;
  • Formula facts are built upon custom expressions written in Formula Language.

All these types are represented by ICubeFact interface and are declared with same procedure. Properties and methods of ICubeFact interface allow you to set fact calculation modes and algorithms, activate and deactivate single facts at runtime, etc.

Note

Unlike base facts, you can declare multiple facts from one source (base or calculated fact).

ContourCube facts are stored in a collection accessed through IContourCube.Facts property.

See also

Using ContourCube: Facts
About Formula Language
ICubeFacts interface
IContourCube.Facts
ICubeBaseFacts interface
IContourCube.BaseFacts


ICubeFact properties

ICubeFact Methods

In ICubeFact:
Active | Returns/sets Active
Algorithm | Returns/sets an algorithm, used to calculate values of the fact.
CountLevel | Returns/sets CountLevel of the fact
Formula | Returns/sets a formula, used to calculate values of the fact.
IsFormula | returns true if the fact is a formula, or false if it is the modified or plain fact
IsModified | returns true if this is a calculated fact and neither formula nor plain fact
Derived from ICubeField:
FieldType | Returns Type of the Field in datasource
SrcName | Returns Name of the Field in datasource
Derived from IField:
Caption | Returns/sets Field caption
IsFact | Returns value that determines whether this Field is Fact or not
Name | Returns Name of the Field


ICubeFact methods

ICubeFact Properties

In ICubeFact:
GetDimAlgorithm | Returns the fact aggregation method by dimension.
SetDimAlgorithm | Sets the fact aggregation method by dimension.
Derived from ICubeField:
Delete | Deletes field


ICubeFacts Interface

Properties Methods

ICubeFacts collection

Hierarchy

IDispatch -> ICubeFacts

Description

This interface implements a collection of ContourCube Facts, and is accessed through IContourCube.Facts property.

Use properties and methods of this interface to add new and manage existing facts of your ContourCube object. You can also let the end user define cube fields manually at runtime, by invoking cube dimensions and facts editor from IContourPropertyPages interface.

See also

Using ContourCube: Facts
IContourCube.Facts
IContourPropertyPages interface


ICubeFacts properties

ICubeFacts Methods

In ICubeFacts:
Active | Returns/sets Active
Count | Returns number of objects in collection.
Item | Returns ICubeFact by name or index.


ICubeFacts methods

ICubeFacts Properties

In ICubeFacts:
Add | Adds a new fact of arbitrary type.
AddFormula | Adds a new formula-specified fact.
Clear | Removes all facts
Exists | Checks whether fact with given name exists


ICubeField Interface

Properties Methods

Base interface for cube dimensions and facts

Hierarchy

IDispatch -> IField -> ICubeField

Description

ICubeField is the base interface for cube dimensions (ICubeDim), facts (ICubeFact), and base facts (ICubeBaseFact), which inherit all its properties and methods.

Use ICubeField interface in cases when the kind of cube field is unknown, and you need to determine it. This interface also allows to determine field data type, and name of the field source.

Note

Objects of this type are stored in ICubeFields collection accessed through IContourCube.Fields property.

See also

ICubeDim interface
ICubeFact interface
ICubeBaseFact interface
ICubeFields interface
IContourCube.Fields


ICubeField properties

ICubeField Methods

In ICubeField:
FieldType | Returns Type of the Field in datasource
SrcName | Returns Name of the Field in datasource
Derived from IField:
Caption | Returns/sets Field caption
IsFact | Returns value that determines whether this Field is Fact or not
Name | Returns Name of the Field


ICubeField methods

ICubeField Properties

In ICubeField:

Delete

Deletes field


ICubeFields Interface

Properties Methods

ICubeFields collection

Hierarchy

IDispatch -> ICubeFields

Description

This interface implements a collection of both ContourCube Dimensions and Facts, and is accessed through IContourCube.Fields property.

Use properties and methods of this interface to manage existing cube dimensions and facts in your ContourCube object. You can also let the end user define cube fields manually at runtime, by invoking cube dimensions and facts editor from IContourPropertyPages interface.

Note

You cannot add items to this collection. Use appropriated method of ICubeFacts and ICubeDims collections instead.

See also

IContourCube.Fields
ICubeFacts interface
ICubeDims interface
IContourPropertyPages interface


ICubeFields properties

ICubeFields Methods

In ICubeFields:
Count | Returns number of objects in collection.
Item | Returns ICubeField (ICubeDim or ICubeFact) by name or index.


ICubeFields methods

ICubeFields Properties

In ICubeFields:

Exists

Checks whether field with given name exists


ICubeFooter Interface

Properties Methods

Represents report footer

Hierarchy

IDispatch -> ICubeFooter

Description

ICubeFooter allows to create and edit the cube footer in Reach Text format (RTF):

Figure 1. ContourCube Header and Footer.

Properties of this interface cover all its formatting elements, and enable to customize footer from your program code.
Cube footer is available for editing at design time as well, through ContourCube Header & Footer Property Page. You can let the end user customize it manually by invoking its Edit method.

See also

ICubeHeader interface
ICubeFooter.Edit


ICubeFooter properties

ICubeFooter Methods

In ICubeFooter:
BkColor | Specifies background color of the header (footer)
Height | Specifies height of the header (footer)
Text | Specifies the text displayed in header (footer)
UseOnExport | Specifies whether the header (footer) is exported with the report
Visible | Shows/hides the header (footer)


ICubeFooter methods

ICubeFooter Properties

In ICubeFooter:

Edit

Shows header / footer editor


ICubeHeader Interface

Properties Methods

Represents report header

Hierarchy

IDispatch -> ICubeFooter -> ICubeHeader

Description

ICubeHeader allows to create and edit the cube header in Reach Text format (RTF):

Figure 1. ContourCube Header and Footer.

Most members of this interface are inherited from ICubeFooter, and cover all header formatting elements, enabling to customize it from your program code.
Cube header is available for editing at design time as well, through ContourCube Header & Footer Property Page. You can let the end user customize it manually by invoking the Edit method.

See also

ICubeFooter interface
ICubeFooter.Edit


ICubeHeader properties

ICubeHeader Methods

In ICubeHeader:
AboveTitle | Returns/sets whether the header is displayed above the cube title
Derived from ICubeFooter:
BkColor | Specifies background color of the header (footer)
Height | Specifies height of the header (footer)
Text | Specifies the text displayed in header (footer)
UseOnExport | Specifies whether the header (footer) is exported with the report
Visible | Shows/hides the header (footer)


ICubeHeader methods

ICubeHeader Properties

Derived from ICubeFooter:

Edit

Shows header / footer editor


IDimFilterSettings Interface

Properties

Interface for dimension filter settings

Hierarchy

IDispatch -> IGridElementStyle -> IDimFilterSettings

Description

IDimFilterSettings interface incapsulates properties that control some useful features of ContourCube dimension filter. Use this interface to enable or disable filtering at all, customize appearance of dimension filters in the grid, and other.

You can access IDimFilterSettings interface through IContourGrid.DimFilter property.

Note

To perform filtering operations on cube dimensions, use IDimsFilter object through IContourCube.DimensionsFilter property.

Facts filtering options are available in IFactsListSettings interface.

See also
IContourGrid.DimFilter
IDimsFilter interface
IContourCube.DimensionsFilter
IFactsListSettings interface


IDimFilterSettings properties

IDimFilterSettings

In IDimFilterSettings:
AllowFilter | Returns/sets whether DimFilter Allowed or not.
ShowHiddenValues | Returns/sets whether Hidden Values should be shown or not
Derived from IGridElementStyle:
BkColor | Returns/sets background color
FontColor | Returns/sets the font color
StyleFont | Returns/sets the font used in this style.


IDimOptions Interface

Properties

The set of additional dimension options

Hierarchy

IDispatch -> IDimOptions

Description

IDimOptions interface implements a set of additional dimension options. Properties of this interface allow you to disable drag-and-dropping particular dimensions onto specified view axes.

Note

Each cube dimension has its own set of options available through ICubeDim.Options property.

See also
ICubeDim.Options


IDimOptions properties

IDimOptions

In IDimOptions:
ban_horizontal_pos | Returns/sets ban_horizontal_pos
ban_outside_pos | Returns/sets ban_outside_pos
ban_vertical_pos | Returns/sets ban_vertical_pos


IDimValues Interface

Properties

IDimValues collection

Hierarchy

IDispatch -> IDimValues

Description

IDimValues interface implements collection of dimension values, and is returned by ICubeDim.GetValues function.
Use properties of IDimValues interface to access dimension members and their filtering statuses at runtime.

Note

This collection is read-only, i.e. you cannot add items to it. Use ICubeDim.GetValues with different parameters to obtain different sets of dimension members.

IDimValues interface provides access to real dimension members; they are not affected by mapping.

See also

ICubeDim.GetValues
ICubeDim.MapType
ICubeDim.Mapping
IMapping interface


IDimValues properties

IDimValues

In IDimValues:
Count | Returns number of objects in the collection.
FilterState | Returns filter state of the dimension values.
Item | Returns dimension value by index.


IDimsFilter Interface

Properties Methods

Dimensions filter interface

Hierarchy

IDispatch -> IDimsFilter

Description

IDimsFilter interface implements the object that controls state of dimension filters. Use IContourCube.DimensionsFilter property to obtain the singletone IDimsFilter object. Each instance of ContourCubeX control has only one IDimsFilter object, so each time you invoke DimensionsFilter property, it returns the same object.

IDimsFilter interface provides methods for programmatic filtering of dimension values the same way the component itself does it when a user clicks on drop-down filter in the control. Also, it allows switching single dimensions between "check" and "radio" selection modes, allowing to show either multiple, or just one dim value at once.

Note

IDimsFilter object works in transactional mode. Performing one or many filtering operations does not take visual effect until you apply the changes. This prevents ContourCube from immediate update during setting filters, which is necessary to achieve high performance and prevent flickering. The filter can be rolled back by cancelling all unapplied changes.

Dimension value filtering is also available through properties and methods of ICubeDim interface.

See also

IContourCube.DimensionsFilter
ICubeDim interface


IDimsFilter properties

IDimsFilter Methods

In IDimsFilter:

Updating

Returns whether the dimension filter is being updated


IDimsFilter methods

IDimsFilter Properties

In IDimsFilter:
Apply | Commits filtering transaction
Cancel | Cancels filtering transaction
DisallowMultipleValues | Sets whether Multiple Values for the given dimension will be disallowed
FilterAll | Sets filter state for all values of the given dimension
FilterValue | Sets filter state for the given Value of given Dimension
GetValueState | Returns filter state for the given DimValue of given Dimension
Reset | Resets filter


IFactsHeadingSettings Interface

Properties

Interface for fact heading settings

Hierarchy

IDispatch -> IGridElementStyle -> IFactsHeadingSettings

Description

IFactsHeadingSettings interface incapsulates properties that control appearance of fact columns header in the grid. It allows to show / hide that header when there is only one fact in the grid, and set its font and color.

IFactsHeadingSettings interface is available through IContourGrid.FactsHeading property.

See also

IContourGrid.FactsHeading


IFactsHeadingSettings properties

IFactsHeadingSettings

In IFactsHeadingSettings:
AlwaysVisible | Returns/sets whether Facts Headings are always visible or not.
Derived from IGridElementStyle:
BkColor | Returns/sets background color
FontColor | Returns/sets the font color
StyleFont | Returns/sets the font used in this style.


IFactsListSettings Interface

Properties

Interface for fact list settings

Hierarchy

IDispatch -> IGridElementStyle -> IFactsListSettings

Description

IFactsListSettings interface incapsulates properties that control some useful features of ContourCube facts filter. Use this interface to enable or disable filtering at all, customize appearance of fact filter in the grid, and other.

You can access IFactsListSettings interface through IContourGrid.FactsFilter property.

Note

To perform filtering operations on cube factset, use properties of ICubeFact and IViewFact interfaces.

Dimension filtering options are available in IDimFilterSettings interface.

See also

IContourGrid.FactsFilter
ICubeFact interface
IViewFact interface
IDimFilterSettings interface


IFactsListSettings properties

IFactsListSettings

In IFactsListSettings:
AllowFilter | Returns/sets whether Filter is allowed or not.
Caption | Returns/sets FactsList Caption
ListInactiveFacts | Returns/sets whether to show inactive facts in the Facts Filter
ShowBitmap | Returns/sets whether to Show Bitmap on the FactsList or not
Derived from IGridElementStyle:
BkColor | Returns/sets background color
FontColor | Returns/sets the font color
StyleFont | Returns/sets the font used in this style.


IField Interface

Properties

Base interface for dimensions and facts

Hierarchy

IDispatch -> IField

Description

IField is the base interface for all ContourCube fields, which inherit all its properties and methods. They are cube dimensions (ICubeDim), cube facts (ICubeFact), base facts (ICubeBaseFact), view dimensions (IViewDim), and view facts (IViewFact).

Use IField interface in cases when the field kind is unknown, and you need to determine it. This interface also incapsulates some common properties, such as field caption and name.

Note

Objects of this type are stored in IFields collection accessed through IContourView.Fields property.

See also

ICubeDim interface
ICubeFact interface
ICubeBaseFact interface
IViewDim interface
IViewFact interface
IFields interface
IContourCube.Fields


IField properties

IField

In IField:
Caption | Returns/sets Field caption
IsFact | Returns value that determines whether this Field is Fact or not
Name | Returns Name of the Field


IFields Interface

Properties Methods

Collection of fields

Hierarchy

IDispatch -> IFields

Description

This interface implements a collection of all fields in ContourCube control, and is accessed through IContourView.Fields property.

Use properties and methods of this interface to perform common operations on all existing fields in your ContourCube object, without knowing whether they are dimensions or facts.

Note

You cannot add items to this collection. Use appropriated method of ICubeFacts, ICubeBaseFacts, and ICubeDims collections instead.

See also

IContourView.Fields
ICubeFacts interface
ICubeBaseFacts interface
ICubeDims interface
IViewFacts interface
IViewDims interface


IFields properties

IFields Methods

In IFields:
Count | Returns number of objects in collection.
Item | Returns IField (IViewDim or IViewFact) by name or index.


IFields methods

IFields Properties

In IFields:

Exists

Checks whether field with given name exists


IFormulaStyleRule Interface

Properties Methods

Represents Formula-based style rule

Hierarchy

IDispatch -> IStyleRule -> IFormulaStyleRule

Description

This interface implements style rule based on a custom formula expression. This kind of style rule applies given style to the cells, for which that formula either returns a non-zero value, or its result status lays within given range.

You can instantiate IFormulaStyleRule interface with IStyleRulesCollection.AddFormulaStyleRule function.

Note

Checking returned formula status code range has higher priority, so the specified style will be applied to the cells, for which formula returns status codes from given subrange, even if a zero value has been calculated for these cells.

See also

About Formula Language
IStyleRulesCollection.AddFormulaStyleRule


IFormulaStyleRule properties

IFormulaStyleRule Methods

In IFormulaStyleRule:
Formula | Returns/sets Formula used in condition
StatusMax | Returns/sets StatusMax
StatusMin | Returns/sets StatusMin
Derived from IStyleRule:
Style | Returns Style
Type | Returns type of condition in the rule


IFormulaStyleRule methods

IFormulaStyleRule Properties

Derived from IStyleRule:

Delete

Deletes this rule


IGridArea Interface

Properties

Grid area interface

Hierarchy

IDispatch -> IGridArea

Description

IGridArea interface represents an area of ContourCube grid, and provides access to its specific features as well as its geometrical parameters. It is obtained through IContourGrid.PointedArea property.

Use properties of this IGridArea to create interactive procedures for the ContourCube user interface.

Note

Properties of this interface are dependend on the area being represented. For example, the Dim property have no sense if this instance represents Header frame (Frame property set to xcfHeader).

See also

IContourGrid.PointedArea
IGridAxis interface
IContourRect interface


IGridArea properties

IGridArea

In IGridArea:
Axis | Returns GridAxis if this area is located on the axis area
Col | Returns grid column if this area is a data cell
Dim | Returns Dimension if this area is located on the dimension area
Fact | Returns Fact if this area is located on the fact area
Frame | Returns frame type of this area
FrameRect | Returns a rectangle covered by this area frame
Index | Returns section index if this area is an axis section
Item | Returns item type of this area
ItemRect | Returns a rectangle covered by this area item
ItemVisibleRect | Returns visible part of a rectangle covered by this area item
Level | Returns section level if this area is an axis section
Row | Returns grid row if this area is a data cell


IGridAxis Interface

Properties Methods

Grid axis interface

Hierarchy

IDispatch -> IGridAxis

Description

IGridAxis interface implements geometric axis of ContourCube grid and controls its visual properties. It reflects the axis state that you see in the grid at each moment.

Figure 1. ContourCube axes.

It allows to get and set the visible axis segment, access axis length and width, obtain its sections and corresponding IViewAxis object, etc.

Note

Access IGridAxis interface through IGridArea.Axis property.

See also

IGridArea.Axis
IAxisSection interface
IViewAxis interface


IGridAxis properties

IGridAxis Methods

In IGridAxis:
Axis | Returns type of the Axis
AxisStart | Returns/sets number of the first visible section at the axis
CellsPerSection | Returns the number of cells per section
FirstCell | Returns/sets number of the first visible cell at the axis
Length | Returns number of cells at the axis
ViewAxis | Returns ViewAxis corresponding to this grid axis
Width | Returns number of dimensions at the axis


IGridAxis methods

IGridAxis Properties

In IGridAxis:
GetSectionStart | Returns coordinate (in pixels) of the visible axis starting point
GetViewSection | Returns underlaying view section by its axis index


IGridCell Interface

Properties Methods

IGridCell Interface

Hierarchy

IDispatch -> IGridCell

Description

IGridCell interface represents a cell of Contourcube grid. Its properties and methods allow you to determine its coordinates, size, data point that it represents, view cell it is based upon, and more.

In ContourCube control, IGridCell interface is available through IContourGrid.GetGridCell function.

See also

IContourGrid.GetGridCell
IViewCell interface
IContourDataPoint interface


IGridCell properties

IGridCell Methods

In IGridCell:
CellType | Gets the cell type (i.e. whether the cell is total, grandtotal, etc.)
Col | Gets the cell column in grid coordinates
Datapoint | Gets the datapoint corresponding to the cell
DisplayText | Gets the display text of the cell
Fact | Gets the fact object of a cell
Rect | Gets the cell rectangle with respect to the grid client area
Row | Gets the cell row in grid coordinates
Value | Gets the cell value
ViewCell | Gets the view cell corresponding to this grid cell
ViewCol | Gets the cell column in coordinates of the underlying view
ViewRow | Gets the cell row in coordinates of the underlying view


IGridCell methods

IGridCell Properties

In IGridCell:
IsValid | Returns True if the cell contains valid data
IsValidCoordinates | Returns True if the cell has valid coordinates


IGridElementStyle Interface

Properties

Interface for style of grid elements

Hierarchy

IDispatch -> IGridElementStyle

Description

This interface incapsulates properties that determine appearance of various grid elements (mostly in dimensions area), which are not affected by ContourCube Styles.

IGridElementStyle is available through IContourGrid.DimTitleStyle, and some other properties of IContourGrid interface.

Note

IGridElementStyle is the base type for IDimFilterSettings, IFactsListSettings, and ITitleSettings interfaces.

See also

Tutorial: Working with Styles
IContourGrid interface
IContourGrid.DimTitleStyle
IContourGrid.DimTitleDraggingStyle
IContourGrid.DimTitleInactiveStyle
IContourGrid.DimValueStyle
IDimFilterSettings interface
IFactsListSettings interface


IGridElementStyle properties

IGridElementStyle

In IGridElementStyle:
BkColor | Returns/sets background color
FontColor | Returns/sets the font color
StyleFont | Returns/sets the font used in this style.


IGridFact Interface

Properties Methods

Represents facts of grid

Hierarchy

IDispatch -> IField -> IViewFact -> IGridFact

Description

IGridFact interface implements ContourCube fact in the grid, and incapsulates its visual settings. You can obtain this interface through IGridCell.Fact property, and use its properties to set grid column width for each fact.

Note

This interface inherits all properties and methods of its ancestor, IViewFact, so you can also use members of the latter to define separate style or stylesheet for the fact, toggle its visibility, set up its scale factor and position in the fact list, and access corresponding cube fact.

See also

IGridCell.Fact
IViewFact interface
ICubeFact interface


IGridFact properties

IGridFact Methods

In IGridFact:
AutoWidth | Returns/sets whether fact width should be calculated by grid
MinWidth | Returns/sets minimal width of fact column
Width | Returns/sets Width of fact column
Derived from IViewFact:
Appearance | Returns/sets Appearance Style
CubeFact | Returns base CubeFact of this fact.
EffectiveStylesheet | Returns EffectiveStylesheet used to display this fact
Enabled | Show/hide the fact
OwnsStylesheet | Returns/sets whether the fact owns stylesheet
Position | Returns/sets fact Position
ScaleFactor | Returns/sets ScaleFactor
Stylesheet | Returns/sets Stylesheet used to display this fact
Visible | Returns/sets a value indicating whether an object is visible or hidden.
Derived from IField:
Caption | Returns/sets Field caption
IsFact | Returns value that determines whether this Field is Fact or not
Name | Returns Name of the Field


IGridFact methods

IGridFact Properties

Derived from IViewFact:

EditAppearance

Opens the editor of fact appearance styles


IMapping Interface

Properties Methods

Collection of mappings

Hierarchy

IDispatch -> IMapping

Description

IMapping interface implements collection of mappings that substitute real dimension values at the moment they're displayed. Access this interface through ICubeDim.Mapping and use its properties and methods to specify and edit dimension mappings.

Note

In order to specify custom mapping, ICubeDim.MapType property must be set to xdmt_user. Then, displaying dimension members will trigger OnDimMapping event.

For dimensions with builtin mapping, representing some date parts, IMapping contains sets of predefined mappings, e.g. month numbers mapped by month names. Such builtin mappings are read-only.

See also

ICubeDim.Mapping
ICubeDim.MapType
OnDimMapping event
TxDimValMapType enum


IMapping properties

IMapping Methods

In IMapping:
Count | Returns number of ValueMappings
Item | Returns IValueMapping by real_value.
Keys | Returns Keys


IMapping methods

IMapping Properties

In IMapping:
Add | Adds new ValueMapping to Mapping list
Clear | Clears ValueMapping
Exists | Returns whether ValueMapping for Value exists


IMicrocube Interface

Properties Methods

IMicrocube interface

Hierarchy

IDispatch -> IMicrocube

Description

IMicrocube interface implements internal representation of a microcube, loaded into the ContourCube control. It allows to obtain names of slices and views contined in the microcube file, check whether it is valid and is being loaded, interrupt loading process, and more.

Get instance of IMicrocube interface from IContourCube.LoadMicrocube method; OnMicrocubeLoaded and OnErrorLoadingMicrocube events also operate on this interface.

Note

This interface is useful when working with multi-slice microcube files; if you don't need to switch between slices, or if you work on single-slice cubes, using IContourCube.Load and appropriate events which don't deal with IMicrocube, is more convenient.

See also

IContourCube.LoadMicrocube
OnMicrocubeLoaded event
OnErrorLoadingMicrocube event
IContourCube.Load
OnCubeLoaded event
OnErrorLoadingCube event


IMicrocube properties

IMicrocube Methods

In IMicrocube:
Bound | Returns whether data from microcube is bound to ContourCubeX
Error | Returns message describing an occured error
Loading | Returns TRUE if data loading in process
Valid | Returns whether microcube is valid


IMicrocube methods

IMicrocube Properties

In IMicrocube:
GetSliceNames | Returns names of slices in the loaded microcube
GetViewNames | Returns names of views attached to the given slice in the loaded microcube
StopLoading | Stops loading data
Wait4Loading | Waits while cube is loading


IRangeStyleRule Interface

Properties Methods

Represents Range style rule

Hierarchy

IDispatch -> IStyleRule -> ICellTypeStyleRule -> IRangeStyleRule

Description

This interface implements style rule that applies given style to the cells, whose fact values lay within specified range. For example, if value contained in a cell is greater or equal to 100 and less than 1000.

You can instantiate IRangeStyleRule interface with IStyleRulesCollection.AddRangeStyleRule function.

Note

For style rules based on simple (in)equality expressions, use properties and methods of IComparatorStyleRule interface.

See also

IStyleRulesCollection.AddRangeStyleRule
IComparatorStyleRule interface


IRangeStyleRule properties

IRangeStyleRule Methods

In IRangeStyleRule:
LowerBound | Returns/sets LowerBound of the range
LowerBoundIncluded | Returns/sets whether range includes LowerBound
UpperBound | Returns/sets UpperBound of the range
UpperBoundIncluded | Returns/sets whether range includes UpperBound
Derived from ICellTypeStyleRule:
UseGrandTotalCells | Apply style to Grand total cells
UseLeafCells | Apply style to leaf cells
UseSubTotalCells | Apply style to subtotal cells
UseTotalCells | Apply style to total cells
Derived from IStyleRule:
Style | Returns Style
Type | Returns type of condition in the rule


IRangeStyleRule methods

IRangeStyleRule Properties

Derived from ICellTypeStyleRule:
Add | Adds CellType to use in this rule
IsInUse | Returns whether given CellType is in use in this rule
Remove | Removes CellType from this rule
Derived from IStyleRule:
Delete | Deletes this rule


IRankStyleRule Interface

Properties Methods

Represents Rank style rule

Hierarchy

IDispatch -> IStyleRule -> IRankStyleRule

Description

This interface implements style rule that applies given style to the cells containing ascending or descending rank values. Its properties allow to specify the rank order that the rule applies to.

You can instantiate IRankStyleRule interface with IStyleRulesCollection.AddRankStyleRule function.

See also

IStyleRulesCollection.AddRankStyleRule


IRankStyleRule properties

IRankStyleRule Methods

In IRankStyleRule:
RankDown | Returns/sets RankDown
RankUp | Returns/sets RankUp
Derived from IStyleRule:
Style | Returns Style
Type | Returns type of condition in the rule


IRankStyleRule methods

IRankStyleRule Properties

Derived from IStyleRule:

Delete

Deletes this rule


IReportPrintSettings Interface

Properties

Contains report printing settings

Hierarchy

IDispatch -> IReportPrintSettings

Description

IReportPrintSettings interface incapsulates members that control page properties used to print ContourCube report. It allows to set up paper size and orientation, printing margins, paper source, etc., and determines whether to shrink report to fit it at one page width.

You can also allow user to manually set up page properties by invoking IContourGrid.ReportPageSetup procedure.

To print report, use IContourGrid.PrintCube method.

See also

IContourGrid.ReportPageSetup
IContourGrid.PrintCube


IReportPrintSettings properties

IReportPrintSettings

In IReportPrintSettings:
FontScale | Report fonts will be scaled using this value (Not applicable when ShrinkToFit is set)
MarginBottom | Gets/Sets bottom margin for report printing (mm)
MarginLeft | Gets/Sets left margin for report printing (mm)
MarginRight | Gets/Sets right margin for report printing (mm)
MarginTop | Gets/Sets top margin for report printing (mm)
Orientation | Gets/Sets paper orientation for report printing
PaperHeight | Gets/Sets paper height (mm) for report printing
PaperSize | Gets/Sets paper size for report printing
PaperWidth | Gets/Sets paper width (mm) for report printing
PrinterBin | Gets/Sets printer bin that has the paper for report printing
ShrinkToFit | Specifies whether report should be shrinked to fit one page width or not


ISequentialStream Interface

Methods

[To be supplied]

Hierarchy

ISequentialStream

Description


ISequentialStream methods

ISequentialStream

In ISequentialStream:
RemoteRead | [To be supplied]
RemoteWrite | [To be supplied]


IShiftState Interface

Properties

ShiftState interface

Hierarchy

IDispatch -> IShiftState

Description

Use properties of IShiftState interface to get state of the Alt, Ctrl, and Shift keys, as well as mouse buttons at each moment of time.

Note

This interface is accessed through IContourGrid.ShiftState property.

Note

IContourGrid.ShiftState


IShiftState properties

IShiftState

In IShiftState:
Alt | Returns whether the Alt key is held down.
Ctrl | Returns whether the Ctrl key is held down.
Double | Returns whether the mouse was double-clicked.
Left | Returns whether the left mouse button is held down.
Middle | Returns whether the middle mouse button is held down.
Right | Returns whether the right mouse button is held down.
Shift | Returns whether the Shift key is held down.


ISliceAxisDims Interface

Properties Methods

ISliceAxisDims Interface

Hierarchy

IDispatch -> ISliceAxisDims

Description

ISliceAxisDims implements collection of cube dimensions that belong to the specified cube axis, including Outside and Invisible dimensions areas. This interface is returned by IContourCube.GetAxisDims function.

Note

Items of ISliceAxisDims collection are of type ICubeDim. To obtain collections of IViewDim objects belonging to a view axis (horizontal or vertical), use IViewAxis.Dims property.

See also

IContourCube.GetAxisDims
ICubeDim interface
IViewDim interface
IViewAxis.Dims


ISliceAxisDims properties

ISliceAxisDims Methods

In ISliceAxisDims:
Axis | Returns axis of this collection.
Count | Returns number of dimensions on axis.
Item | Returns ICubeDim by name or index.


ISliceAxisDims methods

ISliceAxisDims Properties

In ISliceAxisDims:

Exists

Checks whether dimension with given name exists


IString Interface

Properties

Boxed interface for string values

Hierarchy

IDispatch -> IString

Description

The IString interface is not returned by any property or method in ContourCube library - it is just used for output parameters of string type in some event handlers.

Note

This interface applies to OnDimMapping event only.

See also

OnDimMapping event


IString properties

IString

In IString:

Value

Returns/sets Value of this String


IStyleRule Interface

Properties Methods

Base type for I*StyleRule interfaces

Hierarchy

IDispatch -> IStyleRule

Description

IStyleRule is the base type for all interfaces implementing custom style rules. At the same time, this interface per se represents a true-conditioned style rule, which applies given style to all cells in ContourCube grid. Also, IStyleRule can be used to perform common operations when the type of a style rule is not known.

IStyleRule interface can be instantiated with IStyleRulesCollection.AddTrueConditionStyleRule method.

See also

IStyleRulesCollection.AddTrueConditionStyleRule


IStyleRule properties

IStyleRule Methods

In IStyleRule:
Style | Returns Style
Type | Returns type of condition in the rule


IStyleRule methods

IStyleRule Properties

In IStyleRule:

Delete

Deletes this rule


IStyleRulesCollection Interface

Properties Methods

Contains style rules of the stylesheet

Hierarchy

IDispatch -> IStyleRulesCollection

Description

This interface implements collection of style rules stored in stylesheet, and is accessed through IContourStylesheet.StyleRules property. Style rules deteremine conditions, on which specific styles are applied to grid cells.
Use IStyleRulesCollection to add new and manage existing style rules in the stylesheet.

Note

Items of this collection are of different types, based on IStyleRule interface. Use appropriate methods to add style rules of corresponding types.

See also

IContourStylesheet.StyleRules
ICellTypeStyleRule interface
IComparatorStyleRule interface
IFormulaStyleRule interface
IRangeStyleRule interface
IRankStyleRule interface


IStyleRulesCollection properties

IStyleRulesCollection Methods

In IStyleRulesCollection:
Count | Returns number of existing Conditions.
Item | Returns IStyleRule by index.
Stylesheet | Returns IContourStylesheet this Collection belongs to


IStyleRulesCollection methods

IStyleRulesCollection Properties

In IStyleRulesCollection:
AddCellTypeStyleRule | Creates CellTypeConditionRule and inserts it into the given position.
AddComparatorStyleRule | Creates ComparatorStyleRule and inserts it into the given position.
AddCopyOfStyleRule | Creates a copy of the given style rule and inserts it into given position.
AddFormulaStyleRule | Creates FormulaStyleRule and inserts it into the given position.
AddRangeStyleRule | Creates RangeStyleRule and inserts it into the given position.
AddRankStyleRule | Creates RankStyleRule and inserts it into the given position.
AddTrueConditionStyleRule | Creates TrueConditionStyleRule and inserts it into the given position.
Clear | Removes all rules from this Collection


IStylesheetCollection Interface

Properties Methods

Collection of stylesheets

Hierarchy

IDispatch -> IStylesheetCollection

Description

IStylesheetCollection interface represents the cascade of Contour stylesheets, used by this ContourCube control. Use properties and methods of this interface to add, access and remove stylesheets from the cascade, this way changing current ContourCube appearance style.

Note

Access this interface through IContourGrid.Stylesheets property. Items of this collection are of type IContourStylesheet.

See also

IContourGrid.Stylesheets
IContourStylesheet interface


IStylesheetCollection properties

IStylesheetCollection Methods

In IStylesheetCollection:
Count | Returns number of existing Stylesheets.
Item | Returns IContourStylesheet by name or index.


IStylesheetCollection methods

IStylesheetCollection Properties

In IStylesheetCollection:
Add | Adds a new Stylesheet with given base (uses builtin stylesheet as parentstylesheet when no base is given)
Clear | Deletes all stylesheets.
Delete | Deletes IContourStylesheet by name or index.
Exists | Returns whether IContourStylesheet with given name exist.


ITitleSettings Interface

Properties

Title settings interface

Hierarchy

IDispatch -> IGridElementStyle -> ITitleSettings

Description

ITitleSettings interface implements cube title and its settings. It allows show / hide the title, specify its text, font, background color, and alignment.

Figure 1. ContourCube Title.

Access ITitleSettings through IContourGrid.TitleSettings property.

Note
By default, the title is displayed above cube header but you can swap them with ICubeHeader.AboveTitle property.
See also

IContourGrid.TtileSettings
ICubeHeader interface
ICubeHeader.AboveTitle


ITitleSettings properties

ITitleSettings

In ITitleSettings:
Alignment | Returns/sets Alignment of the Title text
Text | Returns/sets Title Text
Visible | Returns/sets whether Title visible or not.
Derived from IGridElementStyle:
BkColor | Returns/sets background color
FontColor | Returns/sets the font color
StyleFont | Returns/sets the font used in this style.


IValueMapping Interface

Properties

Dimension values mapping interface

Hierarchy

IDispatch -> IValueMapping

Description

This interface represents a couple of values that map a single dimension member: one is the real value being mapped, and other is the value being displayed in place of the first.

Items of IValueMapping interface are stored in IMapping collection, available through ICubeDim.Mapping property.

See also

IMapping interface
ICubeDim.Mapping


IValueMapping properties

IValueMapping

In IValueMapping:
DisplayValue | Returns DisplayValue of ValueMapping.
RealValue | Returns RealValue of ValueMapping.


IViewAxis Interface

Properties Methods

IViewAxis Interface

Hierarchy

IDispatch -> IViewAxis

Description

IViewAxis interface implements geometric (horizontal or vertical) axis of ContourCube grid and controls its logical properties.

Figure 1. ContourCube axes.

It allows to control drill down state of dimensions located at this axis, obtain axis sections and collections of IViewDim objects corresponding to the axis, etc.

The view axis is also featured with a couple of important properties:

  • Axis length, which is the number of sections at this axis;
  • Axis width, is the number of dimensions belonging to the axis.

Most operations on view axes in ContourCube are performed with respect to these properties.

Note

Access IViewAxis interface through IContourView.HAxis and IContourView.VAxis properties.

See also

IViewDim interface
IAxisSection interface
IViewAxis.Length
IViewAxis.Width
IContourView.HAxis
IContourView.VAxis


IViewAxis properties

IViewAxis Methods

In IViewAxis:
Axis | Returns type of the Axis
Dims | Returns dimensions at this axis.
DrillDownLevel | Returns/sets the number of this axis dimensions the slice initially drilled down to.
Length | Returns Length - the number of sections at the axis
MaxWidth | Returns/sets MaxWidth - the maximum number of expanded dimensions
RollUpLevel | Returns/sets rollup level for all dimensions at the axis
Width | Returns Width - the number of dimensions at the axis


IViewAxis methods

IViewAxis Properties

In IViewAxis:

GetSection

Returns ViewAxisSection


IViewAxisDims Interface

Properties Methods

IViewAxisDims Interface

Hierarchy

IDispatch -> IViewAxisDims

Description

IViewAxisDims implements collection of view dimensions that belong to the specified view axis (horizontal or vertical). This interface is returned by IViewAxis.Dims property.

Note

Items of IViewAxisDims collection are of type IViewDim. To obtain collections of ICubeDim objects belonging to a cube axis (including Outside and Invisible dimensions areas), use IContourCube.GetAxisDims function.

See also

IViewAxis.Dims
IViewDim interface
ICubeDim interface
IContourCube.GetAxisDims


IViewAxisDims properties

IViewAxisDims Methods

In IViewAxisDims:
Axis | Returns axis of this collection.
Count | Returns number of dimensions on axis.
Item | Returns IViewDim by name or index.


IViewAxisDims methods

IViewAxisDims Properties

In IViewAxisDims:

Exists

Checks whether dimension with given name exists


IViewCell Interface

Properties Methods

IViewCell Interface

Hierarchy

IDispatch -> IViewCell

Description

IViewCell interface implements nonvisual cell of IContourView virtual grid and forms underlaying data level for visual grid cells.. Its properties and methods allow to get information about cell type (Leaf or Total), access the data point that this cell displays, obtain its fact and displayed values for charting, etc.

Access IViewCell interface through IContourView.GetViewCell function and IGridCell.ViewCell property.

See also

IContourView interface
IGridCell interface
IContourDataPoint interface
IContourView.GetViewCell
IGridCell.ViewCell


IViewCell properties

IViewCell Methods

In IViewCell:
CellType | Returns CellType of the cell
Col | Returns the cell column
Datapoint | Returns Datapoint of the cell
Row | Returns the cell row


IViewCell methods

IViewCell Properties

In IViewCell:
DisplayText | Returns DisplayText of the cell
IsValid | Returns whether the view cell contains valid data
IsValidCoordinates | Returns whether the view cell has valid coordinates
Value | Returns Value of the cell


IViewDim Interface

Properties

Interface for view dimension

Hierarchy

IDispatch -> IField -> IViewDim

Description

IViewDim interface implements ContourCube dimension in the view, and incapsulates its visual settings. Items of this type are contained in IViewDims collection, available through IContourView.Dims property. Use properties and methods of IViewDim interface to define dimension value formatting, toggle its sorting order and totalling, and access corresponding cube dimension, containing dimension data.

Note

You can also let the end-user set up visual properties of ContourCube fields manually, by invoking Cube Dimensions and Facts property page with IContourPropertyPages.Show method.

See also

IViewDims interface
IContourView.Dims
ICubeDim interface
IContourPropertyPages interface


IViewDim properties

IViewDim

In IViewDim:
CubeDim | Returns base CubeDim of this Dimension.
Descending | Returns/sets whether dimension uses descending sort order
Format | Returns/sets format string for this dimension values
NoTotals | Returns/sets whether view don't present totals for this dimension
Derived from IField:
Caption | Returns/sets Field caption
IsFact | Returns value that determines whether this Field is Fact or not
Name | Returns Name of the Field


IViewDims Interface

Properties Methods

Collection of view dimensions

Hierarchy

IDispatch -> IViewDims

Description

IViewDims interface implements collection of dimensions in the view, and is accessed through IContourView.Dims property. Use members of this interface to access IViewDim objects, which incapsulate visual properties of ContourCube dimensions.

Note

You cannot add items to or remove them from this collection; they are added and deleted automatically upon execution of ICubeDims.Add and ICubeField.Delete procedures. To remove all dimensions, use ICubeDims.Clear.

See also

IContourView.Dims
IViewDim interface
ICubeDims.Add
ICubeDims.Clear
CubeField.Delete


IViewDims properties

IViewDims Methods

In IViewDims:
Count | Returns number of objects in collection.
Item | Returns IViewDim by name or index.


IViewDims methods

IViewDims Properties

In IViewDims:

Exists

Checks whether dimension with given name exists


IViewFact Interface

Properties Methods

Represents displayable facts

Hierarchy

IDispatch -> IField -> IViewFact

Description

IViewFact interface implements ContourCube fact in the view, and incapsulates its settings that apply to IContourView virtual grid. Items of this type are contained in IViewFacts collection, available through IContourView.Facts property. Use properties and methods of IViewFact interface to define separate style or stylesheet for the fact, toggle its visibility, set up its scale factor and position in the fact list, and access corresponding cube fact.

Note

You can also let the end-user set up visual properties of ContourCube fields manually, by invoking Cube Dimensions and Facts property page with IContourPropertyPages.Show method.

See also

IContourView interface
IViewFacts interface
IContourView.Facts
ICubeFact interface
IContourPropertyPages interface


IViewFact properties

IViewFact Methods

In IViewFact:
Appearance | Returns/sets Appearance Style
CubeFact | Returns base CubeFact of this fact.
EffectiveStylesheet | Returns EffectiveStylesheet used to display this fact
Enabled | Show/hide the fact
OwnsStylesheet | Returns/sets whether the fact owns stylesheet
Position | Returns/sets fact Position
ScaleFactor | Returns/sets ScaleFactor
Stylesheet | Returns/sets Stylesheet used to display this fact
Visible | Returns/sets a value indicating whether an object is visible or hidden.
Derived from IField:
Caption | Returns/sets Field caption
IsFact | Returns value that determines whether this Field is Fact or not
Name | Returns Name of the Field


IViewFact methods

IViewFact Properties

In IViewFact:

EditAppearance

Opens the editor of fact appearance styles


IViewFacts Interface

Properties Methods

Collection of view facts

Hierarchy

IDispatch -> IViewFacts

Description

IViewFacts interface implements collection of facts in the view, and is accessed through IContourView.Facts property. Use members of this interface to access IViewFact objects, which incapsulate visual properties of ContourCube facts.

Note

You cannot add items to or remove them from this collection; they are added and deleted automatically upon execution of ICubeFacts.Add and ICubeField.Delete procedures. To remove all facts, use ICubeFacts.Clear.

See also

IContourView.Facts
IViewFact interface
ICubeFacts.Add
ICubeFacts.Clear
CubeField.Delete


IViewFacts properties

IViewFacts Methods

In IViewFacts:
Count | Returns number of objects in collection.
Item | Returns IViewFact by name or index.


IViewFacts methods

IViewFacts Properties

In IViewFacts:

Exists

Checks whether fact with given name exists


TxAlignment Enum

Members

Text alignment constants

Description

Members of this enum are used in ITitleSettings.Alignment property to specify the alignment of ContourCube title text.

See also

ITitleSettings.Alignment


TxAlignment members

TxAlignment

xtaCenter | 2 | taCenter
xtaLeftJustify | 0 | taLeftJustify
xtaRightJustify | 1 | taRightJustify


TxCBorderStyle Enum

Members

ContourCube border style constants

Description

Members of this enum are used in IContourGrid.BorderStyle property, which determine the border style of ContourCube control.

See also

IContourGrid.BorderStyle


TxCBorderStyle members

TxCBorderStyle

xcbsNone | 0 | cbsNone
xcbsSingle | 1 | cbsSingle


TxCCubeDSType Enum

Members

Data source type constants

Description

Members of this enum are used in IContourCube.DataSourceType property, to specify from which kind of data source data is loaded to the cube.

See also

IContourCube.DataSourceType


TxCCubeDSType members

TxCCubeDSType

xcdt_ADO | 0 | cdt_ADO
xcdt_BDE | 1 | cdt_BDE
xcdt_MicroCube | 2 | cdt_MicroCube
xcdt_Recordset | 3 | cdt_Recordset


TxCFDS Enum

Members

IContourCube.CreateFieldsFromDS parameter flags

Description

Members of this enum are used in IContourCube.CreateFieldsFromDS method, to determine ContourCube fields creation mode. You can combine several modes by combining these constants with bitwise arithmetics.

See also

IContourCube.CreateFieldsFromDS


TxCFDS members

TxCFDS

xcfds_Ask | 1 | Ask whether to recreate fields collection
xcfds_NoDims | 4 | Don'd create dimensions (ignored for CreateFacts/CreateDims)
xcfds_NoFacts | 8 | Don'd create facts (ignored for CreateFacts/CreateDims)
xcfds_SplitDates | 16 | Create all possible period decompositions for Date dims
xcfds_Update | 2 | Update fields collection instead of recreating


TxCalcStatusCode Enum

Members

Calculation result status constants

Description

Members of this enum are used in ICalcResult.Status property, to determine the error code returned by a formula expression.

See also

ICalcResult.Status


TxCalcStatusCode members

TxCalcStatusCode

xcscDimNdxRange | -10 | Dimension index is out of range (e.g. $root[-1])
xcscFPDomain | -6 | Floating-point domain error (e.g. sqrt(-1))
xcscFPError | -5 | General floating-point error
xcscFPValRange | -7 | Floating-point overflow or underflow
xcscInfNegative | -3 | -INF: zerodivision or floating-point overflow
xcscInfPositive | -4 | +INF: zerodivision or floating-point overflow
xcscInvalidDim | -11 | Attempt to use an inactive or hidden dimension in an @-expression
xcscInvalidFact | -9 | Attempt to use invalid fact
xcscNoDataPoint | -1 | The cell doesn't represent a datapoint
xcscNodeNdxRange | -8 | Node index is out of range (e.g. Foo[$dimlen])
xcscNullValue | -2 | The fact used in calculation has NULL value for the datapoint
xcscOK | 0 | No errors on last calculation


TxCellType Enum

Members

Grid cell type constants

Description

Members of this enum are mostly used by ICellTypeStyleRule interface, to determine the grid cell type, to which certain members should be applied.

See also

ICellTypeStyleRule interface


TxCellType members

TxCellType

xctGrandTotal | 3 | grand total
xctLeaf | 0 | usual cell, contains a simple fact value
xctSubTotal | 1 | total
xctTotal | 2 | total


TxComparisonOperator Enum

Members

Numeric comparison operation identifiers

Description

Members of this enum are used to specify comparison operation between fact value and certain constant when adding or modifying a comparator style rule.

See also

IComparatorStyleRule interface
IStyleRulesCollection.AddComparatorStyleRule


TxComparisonOperator members

TxComparisonOperator

xco_EQ | 4 | Equal
xco_GE | 3 | Greater than or equal
xco_GT | 2 | Greater than
xco_LE | 1 | Less than or equal
xco_LT | 0 | Less than
xco_NE | 5 | Not equal


TxContourFrame Enum

Members

Grid frames of ContourCube

Description

Members of this enum are used to identify the area in ContourGrid, pointed with mouse. It enumerates all grid areas: axes, header, footer, data cells, etc. Use constants of this enum when creating interactive procedures for ContourCube.

Note

You can also use TxContourGridItem enum in IGridArea.Item property to determine what kind of grid element you deal with.

TxContourFrame enum constants are taken by IGridArea.Frame property.

See also

IGridArea.Frame
IGridArea.Item
TxContourGridItem enum


TxContourFrame members

TxContourFrame

xcfData | 6 | Data rectangle; includes xcfDataCells and, if there is some empty space to the right or left of data cells due to scrolling, includes that space as well
xcfDataCells | 7 | Data area; does not include anything out of actual grid cells
xcfFactHeading | 8 | Fact names (colums or rows heading, depending on facts placement)
xcfFooter | 10 | Footer frame
xcfHAxis | 4 | Horizontal axis, including xcfHDimVals and xcfFactHeading
xcfHDimVals | 5 | Dimension values on the V-axis. xcfHDimVals is enveloped by xcfHAxis
xcfHeader | 9 | Header frame
xcfNone | -1 | Not a grid area
xcfOutside | 1 | Outside-axis area
xcfTitle | 0 | Title area
xcfVAxis | 2 | Vertical axis, including xcfVDimVals
xcfVDimVals | 3 | Dimension values on the V-axis. xcfVDimVals is enveloped by xcfVAxis


TxContourGridItem Enum

Members

Grid item types of ContourCube

Description

Members of this enum are used to identify items, contained in ContourGrid areas. It enumerates such grid elements as dimension and data cells, titles and fact list. Use constants of this enum when creating interactive procedures for ContourCube.

Note

To enumerate grid areas (frames), use TxContourFrame enum in IGridArea.Frame property.

TxContourFrame enum constants are taken by IGridArea.Frame property.

See also

IGridArea.Item
IGridArea.Frame
TxContourFrame enum


TxContourGridItem members

TxContourGridItem

xgiDataCell | 1 | DataCell
xgiDimCell | 2 | Dimension Cell
xgiDimTitle | 4 | Dimension Title
xgiFactTitle | 8 | Fact Title
xgiFactsList | 16 | Facts List
xgiNone | 0 | None


TxDatasetAggrID Enum

Members

Preliminary aggregation algorithm constants

Description

Members of this enum are used to specify preliminary data aggregation algorithms in ICubeBaseFact.SourceAggregator property.

Note

The xdsa_COUNT aggregator can be used with only one base fact in ContourCube factset. Setting this algorithm for another base fact doesn't throw an error, but cancels it for the base fact that xdsa_COUNT was previously set for.

If you specify xdsa_COUNT aggregator for a base fact, whose name matches a field name in your source dataset, the latter is considered to be a counter, and its values are just summed up in the cube. Otherwise, this aggregation algorithm works as implied - it counts dataset records.

See also

ICubeBaseFact.SourceAggregator


TxDatasetAggrID members

TxDatasetAggrID

xdsa_COUNT | 3 | dsa_COUNT - the number of records
xdsa_MAX | 2 | dsa_MAX - the maximum value of all records
xdsa_MIN | 1 | dsa_MIN - the minimum value of all records
xdsa_SUM | 0 | dsa_SUM - the sum of all records values


TxDimAxis Enum

Members

ContourCube axes constants

Description

Members of this enum are widely used to identify ContourCube axes when performing various operations like moving dimensions, sorting by fact values, getting axis dimensions lists, etc.

Note
TxDimAxis enum incapsulates identifiers of both geometric (horizontal and vertical) and invisible ContourCube axes and dimension areas. Some properties and methods, such as IContourCube.RootAxis and IContourView.SortByFact, accept only geometric axes identifiers.
See also

IContourCube.RootAxis
ICubeDim.Axis
ISliceAxisDims.Axis
IViewAxis.Axis
IViewAxisDims.Axis
ICubeDim.MoveTo
IContourView.SortByFact
IContourView.CancelFactSorting
IContourCube.GetAxisDims
BeforeMoveDimension event
ICubeDims.Add


TxDimAxis members

TxDimAxis

xda_horizontal | 1 | da_horizontal
xda_invisible | 3 | xda_invisible
xda_outside | 2 | da_outside
xda_vertical | 0 | da_vertical


TxDimModifier Enum

Members

Dimension splitting algorithm identifiers

Description

Members of this enum are used to specify date/time field splitting modes: when adding ContourCube dimensions with ICubeDims.Add method, they determine date/time periods that the dimension is broken into. TxDimModifier constants are also returned by ICubeDim.Modifier property.

See also

ICubeDims.Add
ICubeDim.Modifier


TxDimModifier members

TxDimModifier

xmt_d_split | 7 | day splitter
xmt_date_split | 8 | date splitter
xmt_dw_split | 6 | day of week splitter
xmt_hour_split | 9 | hour splitter
xmt_m_split | 3 | month splitter
xmt_min_split | 10 | minute splitter
xmt_none | 0 | none
xmt_q_split | 2 | quarter splitter
xmt_sec_split | 11 | second splitter
xmt_t_split | 4 | ten day splitter
xmt_time_split | 12 | time splitter
xmt_w_split | 5 | week splitter
xmt_y_split | 1 | year splitter


TxDimValMapType Enum

Members

Dimension values mapping type constants

Description

Members of this type specify dimension value mapping types in ICubeDim.MapType property. You can choose between builtin, user-defined, and several types of date part mapping.

See also

ICubeDim.MapType


TxDimValMapType members

TxDimValMapType

xdmt_builtin | 1 | builtin mapping
xdmt_dw_long | 5 | long day of week name mapping
xdmt_dw_short | 6 | short day of week name mapping
xdmt_month_long | 4 | long month name mapping
xdmt_month_short | 3 | short month name mapping
xdmt_none | 0 | no mapping
xdmt_user | 2 | user mapping


TxExportData Enum

Members

Cube data exporting mode constants

Description

Use members of this enum to specify mode of exporting cube data to, and importing from a text file with IContourCube.ExportData and IContourCube.ImportData methods.

See also

IContourCube.ExportData
IContourCube.ImportData


TxExportData members

TxExportData

xed_CSV | 0 | CSV format
xed_CSV_FN | 1 | CSV format with field name in first line


TxFactAlgorithm Enum

Members

Fact calculation algorithm constants

Description

Members of this enum are used to get and specify aggregation / modification algorithms for primary and secondary caculated facts. These constants apply to ICubeFact.Algorithm property, ICubeFact.GetDimAlgorithm, ICubeFact.GetDimAlgorithm, and ICubeFacts.Add methods.

Note

Fact aggregation algorithm IDs start with xfaa_, and apply to primary calculated facts only. By contrast, fact modifiers apply only to secondary calculated facts; their names start with xfam_.

See also

Using ContourCube: Facts
ICubeFact.Algorithm
ICubeFact.GetDimAlgorithm
ICubeFact.SetDimAlgorithm
ICubeFacts.Add


TxFactAlgorithm members

TxFactAlgorithm

xfaa_LAST | 4 | faa_LAST - last value of the previous level subtotals
xfaa_MAX | 3 | faa_MAX - maximum of the previous level subtotals
xfaa_MIN | 2 | faa_MIN - minimum of the previous level subtotals
xfaa_SUM | 1 | faa_SUM - sum of the previous level subtotals
xfam_AVEDEV | 4102 | fam_AVEDEV - average deviation
xfam_AVG | 4101 | fam_AVG - average value
xfam_COUNT | 4097 | fam_Count - number of records
xfam_FORMULA | 4096 | fam_FORMULA - formula-specified algorithm
xfam_MAX | 4100 | fam_MAX - maximum of the previous level subtotals
xfam_MIN | 4099 | fam_MIN - minimum of the previous level subtotals
xfam_RANKDOWN | 4109 | fam_RANKDOWN - descending rank
xfam_RANKUP | 4108 | fam_RANKUP - ascending rank
xfam_RMS | 4107 | fam_RMS - root-mean-squre
xfam_STDDEV | 4104 | fam_STDDEV - standard deviation
xfam_STDDEVP | 4106 | fam_STDDEVP - standard deviation
xfam_SUM | 4098 | fam_SUM - sum of the previous level subtotals
xfam_VAR | 4103 | fam_VAR - variance
xfam_VARP | 4105 | fam_VARP - variance


TxFactCountLevel Enum

Members

Fact calculation mode constants

Description

Use members of this enum in ICubeFact.CountLevel property to specify mode of calculating fact values: by leaves, by child nodes, by entire cube, or by datasource records.

See also

ICubeFact.CountLevel


TxFactCountLevel members

TxFactCountLevel

xfcnt_CHILDCOUNT | 0 | Child Count
xfcnt_CUBECOUNT | 2 | Cube Count
xfcnt_LEAFCOUNT | 1 | Leaf Count
xfcnt_RECCOUNT | 3 | Record Count


TxFactStyleEditPageFlags Enum

Members

Fact Style editor pages flags

Description


TxFactStyleEditPageFlags members

TxFactStyleEditPageFlags

xfpAppearance | 1 | Fact Appearance settings editor page
xfpEditNotOwnedStylesheet | 8 | Edit a stylesheet even if it doesn't owned by the fact
xfpStyleHolder | 2 | StyleHolder settings editor page
xfpStylesheet | 4 | Stylesheet settings editor page


TxFilterOperation Enum

Members

Filtering operation constants

Description

Use members of this enum to specify what filtering operation should be carried out on values of a dimension. TxFilterOperation constants are used in IDimsFilter.FilterAll and ICubeDim.Filter methods.

See also

IDimsFilter.FilterAll
ICubeDim.Filter


TxFilterOperation members

TxFilterOperation

xfo_FilterAll | 2 | Filter out all values of the particular dimension.
xfo_InvertFilter | 0 | Invert filter settings. I.e., filter out all unfiltered values and vice versa.
xfo_Reset | 1 | Turn off filtering.


TxFilterState Enum

Members

Filtering status constants

Description

Use members of this enum to determine filtering status (filtered out, hidden or visible) of one or many dimension members with ICubeDim.GetValueState, and IDimsFilter.GetValueState functions.

Note

For ICubeDim.GetValues method, these constants may be combined to obtain values with different filtering statuses.

See also

ICubeDim.GetValues
ICubeDim.GetValueState
IDimsFilter.GetValueState


TxFilterState members

TxFilterState

xfs_ALL | -1 | Get all dimension values.
xfs_FilteredOut | 2 | Get filtered out values. This does not include values that hidden due to filters set on other dimensions.
xfs_Hidden | 4 | Get values that are not filtered out but nonetheless invisible due to filters set on other dimensions.
xfs_Visible | 1 | Get all values that are not filtered out and not hidden due to filters set on other dimensions.


TxFormulaCheckLevel Enum

Members

Formula validation constants

Description

Use members of this enum to specify how deeply the text of a formula should be checked for validity with ICalcFormula.Check method. You can choose between simple syntax, symbols and thorough complete check.

See also

ICalcFormula.Check


TxFormulaCheckLevel members

TxFormulaCheckLevel

xfcComplete | 2 | Check everything, resolve all names (including names of $magic variables and global functions)
xfcFields | 1 | Check both syntax and whether the all formula local variables refer to corresponding facts or dimensions in the cube
xfcSyntax | 0 | Check only syntax validity. Don't check local variable names.


TxMouseButton Enum

Members

Mouse button IDs

Description

Use constants of this enum to determine which mouse button is pressed or released respectively in MouseDown and MouseUp events.

Note

Members of this type can be combined to identify various combinations of mouse buttons.

See also

MouseDown event
MouseUp event


TxMouseButton members

TxMouseButton

xmbLeft | 0 | mbLeft
xmbMiddle | 2 | mbMiddle
xmbRight | 1 | mbRight


TxOLAPFieldType Enum

Members

ContourCube field type IDs

Description

Use constants of this enum to set data types of ContourCube dimensions and facts when defining them with ICubeDims.Add, and retrieve with ICubeField.FieldType property.

Note

Facts in ContourCube are generally of numeric types.

See also

ICubeDims.Add
ICubeField.FieldType


TxOLAPFieldType members

TxOLAPFieldType

xoft_Boolean | 2 | oft_Boolean
xoft_Currency | 7 | oft_Currency
xoft_Date | 9 | oft_Date
xoft_DateTime | 8 | oft_DateTime
xoft_Float | 6 | oft_Float
xoft_Integer | 5 | oft_Integer
xoft_None | 0 | oft_None
xoft_Smallint | 4 | oft_Smallint
xoft_String | 1 | oft_String
xoft_Time | 10 | oft_Time
xoft_Word | 3 | oft_Word


TxOlapReportType Enum

Members

Report exporting mode constants

Description

Use constants of this enum to specify format of the file that ContourCube report should be exported to with IContourGrid.ExportToFile procedure.

Note

Currently reports can only be exported in HTML format. However, You can specify appropriate file extension, and open exported documents with Microsoft® Office applications, such as Word and Excel.

See also

IContourGrid.ExportToFile


TxOlapReportType members

TxOlapReportType

xolaprpt_CSV | 3 | Create a comma-separated file from a grid
xolaprpt_HTML | 0 | Create an HTML report from a grid
xolaprpt_TXT | 2 | Create a plain text file from a grid
xolaprpt_XLS | 1 | Create an Excel workbook from a grid


TxPaperSize Enum

Members

Paper size identifiers

Description

Use constants of this enum to set paper size for printing ContourCube report. These constants apply to IReportPrintSettings.PaperSize property.

Note

xpsUserType constant allows you to specify custom paper size in IReportPrintSettings.PaperHeight and IReportPrintSettings.PaperWidth properties.

See also

IReportPrintSettings.PaperSize
IReportPrintSettings.PaperHeight
IReportPrintSettings.PaperWidth


TxPaperSize members

TxPaperSize

xps10x11 | 45 | 10 x 11 in
xps10x14 | 16 | 10 x 14 in
xps11x17 | 17 | 11 x 17 in
xps12x11 | 90 | 12 x 11 in
xps15x11 | 46 | 15 x 11 in
xps6_3_4Envelope | 38 | 6 3/4 Envelope, 3 5/8 x 6 1/2 in
xps9x11 | 44 | 9 x 11 in
xpsA2 | 66 | A2 420 x 594 mm
xpsA3 | 8 | A3, 297 x 420 mm
xpsA3Extra | 63 | A3 Extra 322 x 445 mm
xpsA3ExtraTransverse | 68 | A3 Extra Transverse 322 x 445 mm
xpsA3Rotated | 76 | A3 Rotated 420 x 297 mm
xpsA3Transverse | 67 | A3 Transverse 297 x 420 mm
xpsA4 | 9 | A4, 210 x 297 mm
xpsA4Extra | 53 | A4 Extra 9.27 x 12.69 in
xpsA4Plus | 60 | A4 Plus 210 x 330 mm
xpsA4Rotated | 77 | A4 Rotated 297 x 210 mm
xpsA4Small | 10 | A4, Small 210 x 297 mm
xpsA4Transverse | 55 | A4 Transverse 210 x 297 mm
xpsA5 | 11 | A5, 148 x 210 mm
xpsA5Extra | 64 | A5 Extra 174 x 235 mm
xpsA5Rotated | 78 | A5 Rotated 210 x 148 mm
xpsA5Transverse | 61 | A5 Transverse 148 x 210 mm
xpsA6 | 70 | A6 105 x 148 mm
xpsA6Rotated | 83 | A6 Rotated 148 x 105 mm
xpsB4 | 12 | B4, 250 x 354 mm
xpsB4JisRotated | 79 | B4 (JIS) Rotated 364 x 257 mm
xpsB5 | 13 | B5, 182 x 257 mm
xpsB5Extra | 65 | B5 (ISO) Extra 201 x 276 mm
xpsB5JisRotated | 80 | B5 (JIS) Rotated 257 x 182 mm
xpsB5Transverse | 62 | B5 (JIS) Transverse 182 x 257 mm
xpsB6Jis | 88 | B6 (JIS) 128 x 182 mm
xpsB6JisRotated | 89 | B6 (JIS) Rotated 182 x 128 mm
xpsC | 24 | C size sheet
xpsD | 25 | D size sheet
xpsE | 26 | E size sheet
xpsEnvelope | 36 | Envelope, 110 x 230 mm
xpsEnvelope10 | 20 | Envelope #10, 4 1/8 x 9 1/2 in
xpsEnvelope11 | 21 | Envelope #11, 4 1/2 x 10 3/8 in
xpsEnvelope12 | 22 | Envelope #12, 4 1/2 x 11 in
xpsEnvelope14 | 23 | Envelope #14, 5 x 11 1/2 in
xpsEnvelope9 | 19 | Envelope #9, 3 7/8 x 8 7/8 in
xpsEnvelopeB4 | 33 | Envelope B4, 250 x 353 mm
xpsEnvelopeB5 | 34 | Envelope B5, 176 x 250 mm
xpsEnvelopeB6 | 35 | Envelope B6, 176 x 125 mm
xpsEnvelopeC3 | 29 | Envelope C3, 324 x 458 mm
xpsEnvelopeC4 | 30 | Envelope C4, 229 x 324 mm
xpsEnvelopeC5 | 28 | Envelope C5, 162 x 229 mm
xpsEnvelopeC6 | 31 | Envelope C6, 114 x 162 mm
xpsEnvelopeC65 | 32 | Envelope C65, 114 x 229 mm
xpsEnvelopeDL | 27 | Envelope DL, 110 x 220 mm
xpsEnvelopeInvite | 47 | Envelope Invite 220 x 220 mm
xpsEnvelopeMonarch | 37 | Envelope Monarch, 3 7/8 x 7.5 in
xpsExecutive | 7 | Executive, 7 1/4 x 10 1/2 in
xpsFolio | 14 | Folio, 8 1/2 x 13 in
xpsGermanLegalFanfold | 41 | German Legal Fanfold, 8 1/2 x 13 in
xpsGermanStdFanfold | 40 | German Std Fanfold, 8 1/2 x 12 in
xpsISO_B4 | 42 | B4 (ISO) 250 x 353 mm
xpsJapDoublePostcard | 69 | Japanese Double Postcard 200 x 148 mm
xpsJapDoublePostcardRotated | 82 | Double Japanese Postcard Rotated 148 x 200 mm
xpsJapEnvelopeChou3 | 73 | Japanese Envelope Chou #3
xpsJapEnvelopeChou3Rotated | 86 | Japanese Envelope Chou #3 Rotated
xpsJapEnvelopeChou4 | 74 | Japanese Envelope Chou #4
xpsJapEnvelopeChou4Rotated | 87 | Japanese Envelope Chou #4 Rotated
xpsJapEnvelopeKaku2 | 71 | Japanese Envelope Kaku #2
xpsJapEnvelopeKaku2Rotated | 84 | Japanese Envelope Kaku #2 Rotated
xpsJapEnvelopeKaku3 | 72 | Japanese Envelope Kaku #3
xpsJapEnvelopeKaku3Rotated | 85 | Japanese Envelope Kaku #3 Rotated
xpsJapEnvelopeYou4 | 91 | Japanese Envelope You #4
xpsJapEnvelopeYou4Rotated | 92 | Japanese Envelope You #4 Rotated
xpsJapPostcardRotated | 81 | Japanese Postcard Rotated 148 x 100 mm
xpsJapanesePostcard | 43 | Japanese Postcard 100 x 148 mm
xpsLedger | 4 | Ledger, 17 x 11 in
xpsLegal | 5 | Legal, 8 1/2 x 14 in
xpsLegalExtra | 51 | Legal Extra 9 1/2 x 15 in
xpsLetter | 1 | Letter, 8 1/2 x 11 in
xpsLetterExtra | 50 | Letter Extra 9 1/2 x 12 in
xpsLetterExtraTransverse | 56 | Letter Extra Transverse 9 1/2 x 12 in
xpsLetterPlus | 59 | Letter Plus 8.5 x 12.69 in
xpsLetterRotated | 75 | Letter Rotated 11 x 8 1/2 in
xpsLetterSmall | 2 | Letter Small, 8 1/2 x 11 in
xpsLetterTransverse | 54 | Letter Transverse 8 1/2 x 11 in
xpsNote | 18 | Note, 8 1/2 x 11 in
xpsPrc16K | 93 | PRC 16K 146 x 215 mm
xpsPrc16KRotated | 106 | PRC 16K Rotated
xpsPrc32K | 94 | PRC 32K 97 x 151 mm
xpsPrc32KBIG | 95 | PRC 32K(Big) 97 x 151 mm
xpsPrc32KBigRotated | 108 | PRC 32K(Big) Rotated
xpsPrc32KRotated | 107 | PRC 32K Rotated
xpsPrcEnvelope1 | 96 | PRC Envelope #1 102 x 165 mm
xpsPrcEnvelope10 | 105 | PRC Envelope #10 324 x 458 mm
xpsPrcEnvelope10Rotated | 118 | PRC Envelope #10 Rotated 458 x 324 mm
xpsPrcEnvelope1Rotated | 109 | PRC Envelope #1 Rotated 165 x 102 mm
xpsPrcEnvelope2 | 97 | PRC Envelope #2 102 x 176 mm
xpsPrcEnvelope2Rotated | 110 | PRC Envelope #2 Rotated 176 x 102 mm
xpsPrcEnvelope3 | 98 | PRC Envelope #3 125 x 176 mm
xpsPrcEnvelope3Rotated | 111 | PRC Envelope #3 Rotated 176 x 125 mm
xpsPrcEnvelope4 | 99 | PRC Envelope #4 110 x 208 mm
xpsPrcEnvelope4Rotated | 112 | PRC Envelope #4 Rotated 208 x 110 mm
xpsPrcEnvelope5 | 100 | PRC Envelope #5 110 x 220 mm
xpsPrcEnvelope5Rotated | 113 | PRC Envelope #5 Rotated 220 x 110 mm
xpsPrcEnvelope6 | 101 | PRC Envelope #6 120 x 230 mm
xpsPrcEnvelope6Rotated | 114 | PRC Envelope #6 Rotated 230 x 120 mm
xpsPrcEnvelope7 | 102 | PRC Envelope #7 160 x 230 mm
xpsPrcEnvelope7Rotated | 115 | PRC Envelope #7 Rotated 230 x 160 mm
xpsPrcEnvelope8 | 103 | PRC Envelope #8 120 x 309 mm
xpsPrcEnvelope8Rotated | 116 | PRC Envelope #8 Rotated 309 x 120 mm
xpsPrcEnvelope9 | 104 | PRC Envelope #9 229 x 324 mm
xpsPrcEnvelope9Rotated | 117 | PRC Envelope #9 Rotated 324 x 229 mm
xpsQuarto | 15 | Quarto, 215 x 275 mm
xpsReservedDO_NOT_USE_48 | 48 | RESERVED--DO NOT USE
xpsReservedDO_NOT_USE_49 | 49 | RESERVED--DO NOT USE
xpsStatement | 6 | Statement, 5 1/2 x 8 1/2 in
xpsSuperA_A4 | 57 | SuperA/SuperA/A4 227 x 356 mm
xpsSuperB_A3 | 58 | SuperB/SuperB/A3 305 x 487 mm
xpsTabloid | 3 | Tabloid, 11 x 17 in
xpsTabloidExtra | 52 | Tabloid Extra 11.69 x 18 in
xpsUSStdFanfold | 39 | US Std Fanfold, 14 7/8 x 11 in
xpsUserType | 0 | User type paper size


TxPrinterBin Enum

Members

Printer paper source constants

Description

Use constants of this enum to set paper source for printing ContourCube report. These constants apply to IReportPrintSettings.PrinterBin property.

See also

IReportPrintSettings.PrinterBin


TxPrinterBin members

TxPrinterBin

xpbAuto | 7 | Auto select bin
xpbCassette | 14 | Cassette
xpbEnvelope | 5 | Envelope bin
xpbLargeCapacity | 11 | Large capacity
xpbLargeFormat | 10 | Large format
xpbLower | 2 | Lower bin
xpbManualFeed | 4 | Manual feed
xpbManualFeedEnvelope | 6 | Manual feed envelope
xpbMiddle | 3 | Middle bin
xpbSmallFormat | 9 | Small format
xpbTractorFeed | 8 | Tractor feed
xpbUpper | 1 | Upper bin


TxPrinterOrientation Enum

Members

Print paper orientation constants

Description

Use constants of this enum to set paper orientation for printing ContourCube report. These constants apply to IReportPrintSettings.Orientation property.

See also

IReportPrintSettings.Orientation


TxPrinterOrientation members

TxPrinterOrientation

xpoLandScape | 1 | Landscape paper orientation
xpoPortrait | 0 | Portrait paper orientation


TxPropertyPageIds Enum

Members

Property Page IDs

Description

Members of this enum are used to control what ContourCube property pages can be shown at runtime. Use these constants with Add, Remove, and IsPageEnabled functions of IContourPropertyPages interface.

Note

You can combine TxPropertyPageIDs constants in order to add / remove several pages at once.

See also

IContourPropertyPages.Add
IContourPropertyPages.IsPageEnabled
IContourPropertyPages.Remove


TxPropertyPageIds members

TxPropertyPageIds

xppAppearance | 32 | Appearance settings property page
xppBehaviour | 64 | Behaviour settings property page
xppCubeDimsAndFacts | 8 | Cube dimensions and facts settings property page
xppDataSource | 4 | Data source settings property page
xppFieldViewSettings | 16 | Field View settings property page
xppFooter | 2 | Footer settings property page
xppHeader | 1 | Header settings property page
xppStyleHolder | 128 | StyleHolder settings property page
xppStylesheet | 256 | Stylesheet settings property page


TxReportFontScale Enum

Members

Printable font scale constants

Description

Use constants of this enum to set font scale factor for printing ContourCube report. These constants apply to IReportPrintSettings.FontScale property.

See also

IReportPrintSettings.FontScale


TxReportFontScale members

TxReportFontScale

xrfsLarger | 3 | Report fonts will be scaled to larger size
xrfsLargest | 4 | Report fonts will be scaled to largest size
xrfsNormal | 2 | Report fonts will not be scaled
xrfsSmaller | 1 | Report fonts will be scaled to smaller size
xrfsSmallest | 0 | Report fonts will be scaled to smallest size


TxStyleRuleConditionType Enum

Members

Style rule condition identifiers

Description

Use members of this enum, returned by IStyleRule.Type property, to determine what kind of condition the style rule is based upon. For undefined condition types, xsctUnknownCondition constant is reserved.

See also

IStyleRule.Type


TxStyleRuleConditionType members

TxStyleRuleConditionType

xsctCellTypeCondition | 2 | ICellTypeStyleRule
xsctComparatorCondition | 3 | IComparatorStyleRule
xsctFalseCondition | 1 | Condition is always false
xsctFormulaCondition | 4 | IFormulaStyleRule
xsctRangeCondition | 6 | IRangeStyleRule
xsctRankCondition | 5 | IRankStyleRule
xsctTrueCondition | 0 | Condition is always true
xsctUnknownCondition | 7 | Unknown type of Rule Condition


TxStyledProperty Enum

Members

Style property IDs

Description

Use constants of this enum to identify what property of a grid style should be enabled or disabled with respectively EnableProperty and DisableProperty methods of IContourStyle interface. A TxStyledProperty constant is also returned by IContourStyle.IsPropertyEnabled interface.

See also

IContourStyle.DisableProperty
IContourStyle.EnableProperty
IContourStyle.IsPropertyEnabled


TxStyledProperty members

TxStyledProperty

xspBkColor | 7 | Apply BkColor to the object background
xspFontCharset | 5 | Apply Font Charset to the font
xspFontColor | 0 | Apply Color to the font
xspFontFamily | 1 | Apply Font Family to the font
xspFontPitch | 4 | Apply Font Pitch to the font
xspFontSize | 3 | Apply Font Size to the font
xspFontStyle | 2 | Apply Font Style to the font
xspFormat | 6 | Apply Format to the object display string


TxWaitActionType Enum

Members

Wait reason constants

Description

Members of this enum identify the action that triggers OnActionWait event, and that ContourCube must wait for completion. It can be data saving and loading, cube rotating, filtering, etc.

See also

OnActionWait event


TxWaitActionType members

TxWaitActionType

xCHART_BUILDING | 6 | A chart is being built
xCOLLAPSING | 4 | A view node or a whole view dimension is being collapsed or expanded
xFILTERING | 3 | Dimension values are being filtered out/in
xLOADING_DATA | 0 | A cube is being loaded from a dataset/microcube, or a slice is being built
xOTHER_ACTION | 7 | Miscellaneous action
xPERMUTING | 2 | A slice is being rebuilt after dimension move
xSAVING_DATA | 1 | A cube is being saved to a microcube
xSORTING_DATA | 5 | A view is being sorted by fact


ContourCube Layout

There are some terms, regarding part of ContourCube's visual layout, that are extensively used throughout the help. Here is a simple description of these terms.

Generally, it is possible to divide the whole ContourCubeX component area into 3 parts: dimensions area at the vertical axis, dimensions area at the horizontal axis, fact area (data display area). The data can be presented in ContourCubeX in a transposed form, thus the dimension placement at the axis is not changed, only its displaying is changed. For this purpose use the Transposed property. It is also possible to set additional flags for ContourCubeX using the ViewFlags property.

You can also filter values of each dimension interactively using dropdown filtering menus. When filter is applied, only selected dimension values are visible in the grid, and totals are automatically recalculated. Filtering menu has a toolbar at its bottom; buttons of this toolbar are accessible by mouse, as well by through keyboard, respectively Gray +, Gray -, Gray *, Enter and Esc keys.

To get access to filtering options from the code, use DimensionsFilter property. To allow or deny filtering of dimensions or facts, use AllowFilter and AllowFactFilter properties.


Using ContourCube

ContourCubeX
How to load and save data

ContourCubeX can load data from different sources: from an ADO datasource, from a microcube file or from arbitrary recordset. The type of a data source is specified in the DataSourceType property.

The description of a datasource (i.e. a connection string for the ADO dataset or an URL/path for the microcube) is specified in the ConnectionString property. For ADO datasources there should also be specified a request string in the SQL property.

There are several ways of loading data.

  • First, you can fill in DataSourceType with the desired datasource type, set appropriate values into ConnectionString and/or SQL and then set Active to True. The cube will automatically load data. This way you can load data from an ADO dataset or from a microcube file.

  • Second, to load data from a microcube, you can use the LoadCube method. This immediately loads a microcube and automatically sets Active to True.

  • Third, you can load data from arbitrary RecordSet using the Open method.

To control the process of loading from a microcube file use the LoadingCube and StopLoading methods. To save currently loaded cube into a microcube file use the SaveCube function. To save ContourCubeX visual image use the ExportToFile function.

How to print a cube

To print a cube, use PrintCube method. To specify report header and footer, use the Header and Footer properties.

How to filter dimension values from code

To filter values, use the DimsFilter property and the GetDimValues method.

How to place a cube onto HTML page

The object ID for ContourCubeX on an HTML page returns a ContourCubeX object. The programmatic identifier for the ContourCubeX object is CLSID:07EE1598-351E-49A8-8B75-84BECBB9F4D0. The following example creates a ContourCubeX list named "ContourCube1" on an HTML page.

<object id=ContourCube1 classid=CLSID:07EE1598-351E-49A8-8B75-84BECBB9F4D0></object>


IAxisSection.Axis

IAxisSection.Axis Property

IAxisSection Properties Methods

Returns Axis this section belongs to

Read-Only

Syntax

object.Axis As IViewAxis

Parameters
object An object of type IAxisSection


IAxisSection.Coincidence

IAxisSection.Coincidence Method

IAxisSection Properties Methods

Returns number of the last level, at which two sections have common items (0 if no one)

Syntax

object.Coincidence (ByRef Section As IAxisSection) As Integer

Parameters
object | An object of type IAxisSection
[in] Section | (Required) A IAxisSection value. Specifies another axis section, whose coincidence with this one is to be returned.

This method returns integer value that indicates the last level, at which this section has common members with specified one.


IAxisSection.Collapse

IAxisSection.Collapse Method

IAxisSection Properties Methods

Collapses the section

Syntax

object.Collapse (ByVal Level As Integer , ByVal Collapse As Boolean) As Boolean

Parameters
object | An object of type IAxisSection
[in] Level | (Required) A Integer value. Specifies number of the section level, upto which the operation is performed.
[in] Collapse | (Required) A Boolean value. Determines the sense of the operation: True to collapse section, False to expand it.

This method collapses or expands the axis section upto the given expand level. Use Collapse procedure to control drill down status of single axis members from the code.

Collapse returns True if the target level was collapsed before executing this method. Otherwise, it returns False.

To expand or collapse entire axis, use DrillDownLevel and RollUpLevel properties of IViewAxis interface.

See also

IViewAxis.DrillDownLevel
IViewAxis.RollUpLevel


IAxisSection.Collapsed

IAxisSection.Collapsed Property

IAxisSection Properties Methods

Returns whether the section is collapsed

Read-Only

Syntax

object.Collapsed As Boolean

Parameters
object An object of type IAxisSection


IAxisSection.CurrentWidth

IAxisSection.CurrentWidth Property

IAxisSection Properties Methods

Returns current section width

Read-Only

Syntax

object.CurrentWidth As Integer

Parameters
object An object of type IAxisSection


IAxisSection.Datapoint

IAxisSection.Datapoint Property

IAxisSection Properties Methods

Returns data point for this section

Read-Only

Syntax

object.Datapoint As IContourDatapoint

Parameters
object An object of type IAxisSection


IAxisSection.DrillDownLevel

IAxisSection.DrillDownLevel Property

IAxisSection Properties Methods

Returns DrillDownLevel at this axis section

Read-Only

Syntax

object.DrillDownLevel As Integer

Parameters
object An object of type IAxisSection


IAxisSection.Extent

IAxisSection.Extent Method

IAxisSection Properties Methods

Returns section extent

Syntax

object.Extent ([ByVal Level As Integer = -2]) As IContourExtent

Parameters
object | An object of type IAxisSection
[in] Level | (Optional) A Integer value. Specifies the axis section level, for which the extent should be returned. If this parameter is omitted, the returned extent will match entire axis.

The Extent method returns IContourExtent object for the given level of this axis section. That object contains numbers of the starting and ending sections of the extent, and its length defined as their difference. Length of an extent is the number of coincident axis sections occupied by the dimension member located at the given level of this section.
If level is equal to the drill down level of the section, the extent length will return 1.

See also

IContourExtent.Length
IAxisSection.Coincidence


IAxisSection.Flip

IAxisSection.Flip Method

IAxisSection Properties Methods

Obsolete feature. Do not use.

Syntax

object.Flip (ByVal Level As Integer) As Boolean

Parameters
object | An object of type IAxisSection
[in] Level | (Required) A Integer value.


IAxisSection.GetDisplayText

IAxisSection.GetDisplayText Method

IAxisSection Properties Methods

Returns string displayed at given section level

Syntax

object.GetDisplayText (ByVal Level As Integer) As String

Parameters
object | An object of type IAxisSection
[in] Level | (Required) A Integer value. Number of the axis section level, at which the sought dimension member is located.

Returns string displayed for the dimension member located at the given level of this axis section. Use this function to obtain displayed value for a single dimension member.

To get real values of all members of a dimension, use ICubeField.GetValues method.

See also

ICubeDim.GetValues


IAxisSection.GetValue

IAxisSection.GetValue Method

IAxisSection Properties Methods

Returns dim value at given section level

Syntax

object.GetValue (ByVal Level As Integer) As Variant

Parameters
object | An object of type IAxisSection
[in] Level | (Required) A Integer value. Number of the axis section level, at which the sought dimension member is located.

Returns Variant value of the dimension member located at the given level of this axis section. Use this function to obtain real value for a single dimension member.

To get all real values of all members of a dimension, use ICubeField.GetValues method.

See also

ICubeDim.GetValues


IAxisSection.Pos

IAxisSection.Pos Property

IAxisSection Properties Methods

Returns Position of the section on the axis

Read-Only

Syntax

object.Pos As Integer

Parameters
object An object of type IAxisSection


IBoolean.Value

IBoolean.Value Property

IBoolean Properties

Returns/sets Value of this Boolean

Read-Write

Syntax

object.Value As Boolean

Parameters
object An object of type IBoolean


ICalcConst.Name

ICalcConst.Name Property

ICalcConst Properties

Returns/sets Name of the Constant

Read-Write

Syntax

object.Name As String

Parameters
object An object of type ICalcConst


ICalcConst.Value

ICalcConst.Value Property

ICalcConst Properties

Returns/sets Value of the Constant

Read-Write

Syntax

object.Value As Float

Parameters
object An object of type ICalcConst


ICalcConstants.Add

ICalcConstants.Add Method

ICalcConstants Properties Methods

Defines a new constant.

Syntax

object.Add ByVal Name As String , ByVal Value As Float

Parameters
object | An object of type ICalcConstants
[in] Name | (Required) A String value. Specifies the constant name, by which it should be then referenced from functions and Formula Language expressions.
[in] Value | (Required) A Float value. Specifies the constant value that should be used in calculations.

The Add method appends new user-defined constant with given name and value to the collection of ContourCube Constants.


ICalcConstants.Clear

ICalcConstants.Clear Method

ICalcConstants Properties Methods

Clears all constant definitions

Syntax

object.Clear

Parameters
object An object of type ICalcConstants


ICalcConstants.Count

ICalcConstants.Count Property

ICalcConstants Properties Methods

Gets number of defined constants.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type ICalcConstants


ICalcConstants.Exists

ICalcConstants.Exists Method

ICalcConstants Properties Methods

Checks whether the constant with given name exists

Syntax

object.Exists (ByVal Name As String) As Boolean

Parameters
object | An object of type ICalcConstants
[in] Name | (Required) A String value. Name of the constant to look for.

This method returns True, if the constant with specified name exists in the collection. Otherwise, it returns False.

To add a new constant, use ICalcConstants.Add method.

See also

ICalcConstants.Add


ICalcConstants.Item

ICalcConstants.Item Property

ICalcConstants Properties Methods

Gets a constant object by its name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As ICalcConst

Parameters
object | An object of type ICalcConstants
[in] Index | (Required) A Variant value. Specifies either the string name of the constant, or its integer zero-based number in the collection.

Use this property to get a constant from the Constants collection. It returns instance of ICalcConst interface that contains name and value of the sought constant.

Note

If the constant is not found in the collection, the property throws an exception. To avoid this, use ICalcConstants.Exists function that checks if a constant with given name exists. To stay within collection bounds, use Count property.

See also

ICalcConstants.Exists
ICalcConstants.Count


ICalcContext.Clear

ICalcContext.Clear Method

ICalcContext Properties Methods

Clears all definitions of both constants and user-defined functions.

Syntax

object.Clear

Parameters
object An object of type ICalcContext


ICalcContext.Constants

ICalcContext.Constants Property

ICalcContext Properties Methods

Gets the collection of constants defined in the context.

Read-Only

Syntax

object.Constants As ICalcConstants

Parameters
object An object of type ICalcContext


ICalcContext.CreateFormula

ICalcContext.CreateFormula Method

ICalcContext Properties Methods

Creates a new standalone formula object

Syntax

object.CreateFormula (ByVal FormulaText As String) As ICalcFormula

Parameters
object | An object of type ICalcContext
[in] FormulaText | (Required) A String value. Specifies the text of the formula to be added, written in ContourCube Formula Language

CreateFormula instantiates and returns an ICalcFormula object that represents a formula, and can be applied to fact values in the cube.

See also

About Formula Language


ICalcContext.Functions

ICalcContext.Functions Property

ICalcContext Properties Methods

Gets the collection of user-defined functions belonging to the context.

Read-Only

Syntax

object.Functions As ICalcFunctions

Parameters
object An object of type ICalcContext


ICalcContext.IsEmpty

ICalcContext.IsEmpty Property

ICalcContext Properties Methods

Check wheter CalcContext is empty.

Read-Only

Syntax

object.IsEmpty As Boolean

Parameters
object An object of type ICalcContext


ICalcContext.Load

ICalcContext.Load Method

ICalcContext Properties Methods

Loads constant and function definitions from a text file.

Syntax

object.Load ByVal FileName As String

Parameters
object | An object of type ICalcContext
[in] FileName | (Required) A String value.


ICalcContext.Save

ICalcContext.Save Method

ICalcContext Properties Methods

Saves constant and function definitions into a text file.

Syntax

object.Save ByVal FileName As String

Parameters
object | An object of type ICalcContext
[in] FileName | (Required) A String value.


ICalcFormula.Check

ICalcFormula.Check Method

ICalcFormula Properties Methods

Compile the formula up to the level specified by , returns 'true' on successful compilation.

Syntax

object.Check ([ByVal CheckLevel As TxFormulaCheckLevel = 2]) As Boolean

Parameters
object | An object of type ICalcFormula
[in] CheckLevel | (Optional) A TxFormulaCheckLevel value. Determines how deeply the formula must be checked: the "lightest" check includes only syntax validation of the formula text. Complete check (default) also resolves all names used in formula, including $magic variables.

The Check procedure validates the formula and returns True if there were no errors. Although it doesn't return an error code, you can call it with different formula check levels, in order to determine kind of the error, if there is one.

See also

Formula Language: Global Variables


ICalcFormula.Eval

ICalcFormula.Eval Method

ICalcFormula Properties Methods

Evaluates the formula for given data point and fact, and returns ICalcResult

Syntax

object.Eval (ByRef Datapoint As IContourDatapoint [, ByRef ViewFact As IViewFact = 0]) As ICalcResult

Parameters
object | An object of type ICalcFormula
[in] Datapoint | (Required) A IContourDatapoint value. Refers to the cube data point, for which the calculation should be made.
[in] ViewFact | (Optional) A IViewFact value. Reference to the view fact, to whose value within given data point the formula should be applied. If this parameter is omitted, the first fact from the view's collection is taken.

Use Eval to evaluate the formula for a fact value specified with data point and fact name. This method returns instance of ICalcResult interface that contains information on whether the operation was succesful, the resulting value, and the eventual error code.

To evaluate the formula for a fact value referred by a grid cell, use GridCellEval method.

See also

IContourDataPoint interface
IViewFact interface
ICalcFormula.GridCellEval


ICalcFormula.GridCellEval

ICalcFormula.GridCellEval Method

ICalcFormula Properties Methods

Evaluates the formula for a grid cell, and retirns ICalcResult

Syntax

object.GridCellEval (ByRef GridCell As IGridCell) As ICalcResult

Parameters
object | An object of type ICalcFormula
[in] GridCell | (Required) A IGridCell value. Refers to the grid cell object, for which the calculation should be made.

Use Eval to evaluate the formula for a fact value specified with a grid cell containing it. This method returns instance of ICalcResult interface that contains information on whether the operation was succesful, the resulting value, and the eventual error code.

To evaluate the formula for a fact value referred by a data point and fact, use Eval method.

See also

IGridCell interface
ICalcFormula.Eval


ICalcFormula.Text

ICalcFormula.Text Property

ICalcFormula Properties Methods

Returns/sets the text of a formula

Read-Write

Syntax

object.Text As String

Parameters
object An object of type ICalcFormula


ICalcFunction.Text

ICalcFunction.Text Property

ICalcFunction Properties

Returns/sets Text of the function

Read-Write

Syntax

object.Text As String

Parameters
object An object of type ICalcFunction


ICalcFunctions.Add

ICalcFunctions.Add Method

ICalcFunctions Properties Methods

Defines a new function

Syntax

object.Add ByVal FunctionText As String

Parameters
object | An object of type ICalcFunctions
[in] FunctionText | (Required) A String value. Specifies function text, written in ContourCube Formula Language.

This method adds new function, defined by its text to the collection of user-defined functions. This function can then be referenced from various calculations, or take part of other functions and formulas.

A function from ICalcFunctions collection is referenced by its name, which is specified wihtin the function text:

[Visual Basic]
ContourCubeX.CalcContext.Functions.Add "MySum(A, B) = A + B"

Here MySum is the name of your function. Use this name to refer to it, and to get its text from the collection.

See also

About Formula Language


ICalcFunctions.Clear

ICalcFunctions.Clear Method

ICalcFunctions Properties Methods

Clears all function definitions

Syntax

object.Clear

Parameters
object An object of type ICalcFunctions


ICalcFunctions.Count

ICalcFunctions.Count Property

ICalcFunctions Properties Methods

Gets number of user-defined functions.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type ICalcFunctions


ICalcFunctions.Exists

ICalcFunctions.Exists Method

ICalcFunctions Properties Methods

Checks whether the function with given text exists

Syntax

object.Exists (ByVal FunctionText As String) As Boolean

Parameters
object | An object of type ICalcFunctions
[in] FunctionText | (Required) A String value. Text of the function to look for.

This property returns True, if user-defined function with specified text exists in the collection. Otherwise, it returns False.

To add a new function, use ICalcFunctions.Add method.

See also
ICalcFunctions.Add


ICalcFunctions.Item

ICalcFunctions.Item Property

ICalcFunctions Properties Methods

Returns a function object by its name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As ICalcFunction

Parameters
object | An object of type ICalcFunctions
[in] Index | (Required) A Variant value. Specifies either the string name of the function, or its integer zero-based number in the collection.

Use this property to get a function from the Functions collection. It returns instance of ICalcFunction interface that contains text of the sought function.

Note

If the function is not found in the collection, the property throws an exception. To avoid this, use ICalcFunctions.Exists method that checks if a function with given text exists. To stay within collection bounds, use Count property.

See also

ICalcFunctions.Exists
ICalcFunctions.Count


ICalcResult.IsValid

ICalcResult.IsValid Method

ICalcResult Properties Methods

Returns Validity of the CalcResult

Syntax

object.IsValid () As Boolean

Parameters
object An object of type ICalcResult


ICalcResult.Status

ICalcResult.Status Property

ICalcResult Properties Methods

Returns Status of the CalcResult

Read-Only

Syntax

object.Status As TxCalcStatusCode

Parameters
object An object of type ICalcResult


ICalcResult.Value

ICalcResult.Value Property

ICalcResult Properties Methods

Returns Value of the CalcResult

Read-Only

Syntax

object.Value As Float

Parameters
object An object of type ICalcResult


ICellTypeStyleRule.Add

ICellTypeStyleRule.Add Method

ICellTypeStyleRule Properties Methods

Adds CellType to use in this rule

Syntax

object.Add ByVal CellType As TxCellType

Parameters
object | An object of type ICellTypeStyleRule
[in] CellType | (Required) A TxCellType value. Specifies the cell type to be added.

This procedure adds a grid cell type to the list of types used in the style rule. There are several types of grid cells, identified with members of TxCellType enum: Leaf cells, Totals, SubTotals, and Grand Totals cells.

Note

To check whether a cell type is already used in this rule, call IsInUse method.

See also

ICellTypeStyleRule.IsInUse


ICellTypeStyleRule.IsInUse

ICellTypeStyleRule.IsInUse Method

ICellTypeStyleRule Properties Methods

Returns whether given CellType is in use in this rule

Syntax

object.IsInUse (ByVal CellType As TxCellType) As Boolean

Parameters
object | An object of type ICellTypeStyleRule
[in] CellType | (Required) A TxCellType value. Identifies the type of cell to be checked: Leaf cell, Totals, SubTotals, or GrandTotals cell.

This function returns True, if given cell type is used in this style rule. Othewise, it returns False.


ICellTypeStyleRule.Remove

ICellTypeStyleRule.Remove Method

ICellTypeStyleRule Properties Methods

Removes CellType from this rule

Syntax

object.Remove ByVal CellType As TxCellType

Parameters
object | An object of type ICellTypeStyleRule
[in] CellType | (Required) A TxCellType value. Identifies the cell type to be removed from the rule.

Remove procedure deletes a cell type from the list of types used in this style rule.

Note

If the cell type is not found in the collection, the method throws an exception. Use IsInUse function to check if a cell type is present in the collection.

See also

ICellTypeStyleRule.IsInUse


ICellTypeStyleRule.UseGrandTotalCells

ICellTypeStyleRule.UseGrandTotalCells Property

ICellTypeStyleRule Properties Methods

Apply style to Grand total cells

Read-Write

Syntax

object.UseGrandTotalCells As Boolean

Parameters
object An object of type ICellTypeStyleRule


ICellTypeStyleRule.UseLeafCells

ICellTypeStyleRule.UseLeafCells Property

ICellTypeStyleRule Properties Methods

Apply style to leaf cells

Read-Write

Syntax

object.UseLeafCells As Boolean

Parameters
object An object of type ICellTypeStyleRule


ICellTypeStyleRule.UseSubTotalCells

ICellTypeStyleRule.UseSubTotalCells Property

ICellTypeStyleRule Properties Methods

Apply style to subtotal cells

Read-Write

Syntax

object.UseSubTotalCells As Boolean

Parameters
object An object of type ICellTypeStyleRule


ICellTypeStyleRule.UseTotalCells

ICellTypeStyleRule.UseTotalCells Property

ICellTypeStyleRule Properties Methods

Apply style to total cells

Read-Write

Syntax

object.UseTotalCells As Boolean

Parameters
object An object of type ICellTypeStyleRule


IComparatorStyleRule.Operator

IComparatorStyleRule.Operator Property

IComparatorStyleRule Properties Methods

Returns/sets comparison operator to use

Read-Write

Syntax

object.Operator As TxComparisonOperator

Parameters
object An object of type IComparatorStyleRule


IComparatorStyleRule.Value

IComparatorStyleRule.Value Property

IComparatorStyleRule Properties Methods

Returns/sets value for comparing to

Read-Write

Syntax

object.Value As Float

Parameters
object An object of type IComparatorStyleRule


IContourCube.Active

IContourCube.Active Property

IContourCube Properties Methods

Setting Active to true causes the cube to read data from the data source specified in the ConnectionString property.

Read-Write

Syntax

object.Active As Boolean

Parameters
object An object of type IContourCube

Use Active property to establish a connection of ContourCube coreto a data source. When Active is set to False,the cube is closed, and it cannot read data from the data source. When Activeis True, the data is loaded from data source. Setting this property to True triggers BeforeOpen event, if its handler is defined for the ContourCube control. If an error occurs while opening the cube, Active resets to False, OnErrorLoadingCube event is fired, and data loading stops. If the cube is activated succesfully, AfterOpen event is triggered.

Because ContourCube loads data asynchronously, in some cases you may need to wait while data is being loaded, before continuing code execution. For this purpose, use Wait4LoadingCube method.

See also

BeforeOpen event
AfterOpen event
OnErrorLoadingCube event
IContourCube.Wait4LoadingCube


IContourCube.ADOCursorLocation

IContourCube.ADOCursorLocation Property

IContourCube Properties Methods

Returns/sets a cursor location for a dataset specified by ConnectionString and SQL properties

Read-Write

Syntax

object.ADOCursorLocation As CursorLocationEnum

Parameters
object An object of type IContourCube

When the DataSourceTypeis set to xcdt_ADO, ADOCursorLocationproperty allows you to choose between various cursor librariesaccessible to the provider. Usually, you can choose between using a client-sidecursor library or one that is located on the server.
The default value of this property is adUseServer. Consideringthe component always opens ADO datasets as forward-only & read-only, this providesmaximum performance and minimum memory overhead. adUseServer also works withlocal databases as well, though in that case it is the same as adUseClient.

CAVEAT: OLE DB through ODBC provider has a bug: if CursorLocation is set to adUseServer and the name of a table in SELECT is specified with an extension, and the nameof the table exceeds 8.3 naming scheme, OLEDB throws an exception. To avoid this, use table names without extensions, or set ADOCursorLocation explicitly to adUseClient. (The former workaround is better then the latter.)

Notes

See ADO API reference for more information

See also

IContourCube.DataSourceType


IContourCube.BaseFacts

IContourCube.BaseFacts Property

IContourCube Properties Methods

Returns an array of base facts

Read-Only

Syntax

object.BaseFacts As ICubeBaseFacts

Parameters
object An object of type IContourCube

IContourCube.BaseFacts collection stores the set of fields, which are then used as the base for other calculated facts. These fields belong to the hypercube and are permanent: you can't edit them while the cube is active. Base facts are not displayable, but they can only be used as base fields for primary and secondary calculated facts stored in IContourCube.Facts collection. Base facts are also available in the collection IContourCube.Fields. In its tour, calculated facts are shown in the grid, and can be used in formula-based fields. Elements of IContourCube.Facts collection can be edited "at the fly", even while the cube is active.

See also

Using ContourCube: Facts
IContourCube.Facts
IContourCube.Fields
Using Formula Language


IContourCube.BoundMicrocube

IContourCube.BoundMicrocube Property

IContourCube Properties Methods

Returns IMicrocube bound to the cube

Read-Only

Syntax

object.BoundMicrocube As IMicrocube

Parameters
object An object of type IContourCube


IContourCube.BoundSlice

IContourCube.BoundSlice Property

IContourCube Properties Methods

Returns name of the slice bound from Microcube to the cube

Read-Only

Syntax

object.BoundSlice As String

Parameters
object An object of type IContourCube


IContourCube.CalcContext

IContourCube.CalcContext Property

IContourCube Properties Methods

Returns ICalcContext

Read-Only

Syntax

object.CalcContext As ICalcContext

Parameters
object An object of type IContourCube


IContourCube.ConnectionString

IContourCube.ConnectionString Property

IContourCube Properties Methods

Describes the real data source for the cube. The actual appearance of this string depends on a data source type (DataSourceType property). E.g., it can be ADO connection string for ADO datasource, or file path (or even URL) for a microcube.

Read-Write

Syntax

object.ConnectionString As String

Parameters
object An object of type IContourCube

Use the ConnectionString property to specify detailed datasource description. The actual appearance of this string depends on the datasource type. It can contain an ADO connection string for ADO data source, or filenameand path (or even URL) for a microcube file.

Generally, an ADO connection string looks as

Provider=<Provider name>;Extended Properties="DSN=<DataSource Name>;DBQ=<DB filename>;UID=<UserID>;"

Note to Delphi developers

For an existing BDE connection in Delphi, the ConnectionStringproperty must contain the BDE alias of the data source, as well as some optionalparameters, separated by semicolon:
_AliasName_ | existing BDE alias (similar to TDatabase.AliasName in Delphi)
_SessionName_ | existing session name (similar to TDatabase.SessionName / TQuery.SessionName)
_DriverName_ | database driver (similar to TDatabase.DriverName)
_LoginPrompt_ | determines whether to show login dialog or not (see TDatabase.LoginPrompt). If not specified, the parameter is set automatically using USER NAME and PASSWORD parameters (FALSE if they do exist; TRUE otherwise)
USER NAME | user name used BDE authentication
PASSWORD | password used in BDE authentication

Commonly, a BDE connection string looks as

_AliasName_=BDEAlias;_LoginPrompt_=True or False;USER NAME=User;PASSWORD=Password''

You can pass over additional parameters using TDatabase.Params. To knowmore about BDE connection parameters, see Delphi Help reference on BDE components.

Note

To specify the type of the data source (ADO, BDE or microcube file), use DataSourceType property.

See also

IContourCube.DataSourceType


IContourCube.CreateFieldsFromDS

IContourCube.CreateFieldsFromDS Method

IContourCube Properties Methods

Create dimensions and facts from the dataset.

Syntax

object.CreateFieldsFromDS [ByVal Flags As Integer = 0]

Parameters
object | An object of type IContourCube
[in] Flags | (Optional) A Integer value. This parameter may contain any combination of TxCFDS enum constants, which turn on different creation options. By default, it is set to 0, which forces creation of all possible dimensions and facts from data source fields.

CreateFieldsFromDS automatically creates ContourCube fields with default settings (names, aggregation algorithms for facts, etc.) from fields of the source dataset. and places them onto view axes. You can specify filed creation options (Flags) to force the procedure to create specific field sets.

Examples

[Visual Basic]

'This creates all possible dimensions and facts:
ContourCubeX1.Cube.CreateFieldsFromDS

'The following code just updates the field set, and doesn't recreate existing fields:ContourCubeX1.Cube.CreateFieldsFromDS xcfds_Update

'This creates only dimensions and breaks eventual date fields into all possible date/time parts:
ContourCubeX1.Cube.CreateFieldsFromDS xcfds_SplitDates + xcfds_NoFacts

This code displays a dialog box asking user to confirm the operation:
ContourCubeX1.Cube.CreateFieldsFromDS xcfds_Ask

Note

This method is only applicable on condition that:

  • Cube DataSourceType is set to xcdt_ADO or xcdt_BDE,
  • and ADO or BDE connection parameters are correctly specified in the ConnectionString property,
  • and SQL property contains a valid SELECT statement.
Otherwise, CreateFieldsFromDS will throw an exception.
See also

TxCFDS enum
IContourCube.DataSourceType
IContourCube.ConnectionString
IContourCube.SQL


IContourCube.DataSourceType

IContourCube.DataSourceType Property

IContourCube Properties Methods

The type of a data source from which the cube is to be loaded.

Read-Write

Syntax

object.DataSourceType As TxCCubeDSType

Parameters
object An object of type IContourCube

This property tells ContourCube what kind of data source is used to populate the cube. It can take one of following TxCCubeDSType enum values:
xcdt_ADO | ADO data source
xcdt_BDE | BDE data source
xcdt_MicroCube | Contour microcube file
xcdt_Recordset | Recordset object

Remarks

Use DataSourceType property to specify data source typefor ContourCube ActiveX control.

Note

To specify the data source itself as well as its parameters, use ConnectionStringproperty.

To load data from an ADO recordset, use Open method; to load data from a microcube file, use Load procedure. Both these methods load data and specify the value of DataSourceType property, and then activate the ContourCube control.

See also

IContourCube.ConnectionString
IContourCube.Open
IContourCube.Load


IContourCube.DimensionsFilter

IContourCube.DimensionsFilter Property

IContourCube Properties Methods

Returns the dimensions filter object.

Read-Only

Syntax

object.DimensionsFilter As IDimsFilter

Parameters
object An object of type IContourCube

Use DimensionsFilter property to acquire the object that controls filters applied to the Cube dimensions. This is a singletone object with respect to ContourCube control, i.e. all requests to DimensionsFilter for the same cube will return the same IDimsFilter object.

See also

IDimsFilter interface


IContourCube.Dims

IContourCube.Dims Property

IContourCube Properties Methods

Returns an array of dimensions

Read-Only

Syntax

object.Dims As ICubeDims

Parameters
object An object of type IContourCube


IContourCube.ExportData

IContourCube.ExportData Method

IContourCube Properties Methods

Export cube data into external format (currently CSV only)

Syntax

object.ExportData ByVal FileName As String , ByVal ExportType As TxExportData

Parameters
object | An object of type IContourCube
[in] FileName | (Required) A String value. Name of the file, to which cube data should be exported.
[in] ExportType | (Required) A TxExportData value. Specifies format of the text file.

This method exports all cube data to a text file in specified format. This file can then be imported back into the cube with ImportData procedure.

Note

ExportData doesn't export metadata, such as filter settings, mappings, etc.
To export entire report, including layout settings, use IContourGrid.ExportToFile method.

See also

IContourCube.ImportData
IContourGrid.ExportToFile


IContourCube.Facts

IContourCube.Facts Property

IContourCube Properties Methods

Returns an array of facts

Read-Only

Syntax

object.Facts As ICubeFacts

Parameters
object An object of type IContourCube


IContourCube.Fields

IContourCube.Fields Property

IContourCube Properties Methods

Returns an array of fields including facts and dimensions

Read-Only

Syntax

object.Fields As ICubeFields

Parameters
object An object of type IContourCube


IContourCube.GetAxisDims

IContourCube.GetAxisDims Method

IContourCube Properties Methods

Returns a collection of dimensions placed at given axis

Syntax

object.GetAxisDims (ByVal Axis As TxDimAxis) As ISliceAxisDims

Parameters
object | An object of type IContourCube
[in] Axis | (Required) A TxDimAxis value. Specifies the axis, whose dimensions are to be returned.

Use GetAxisDims to obtain a collection of cube dimensions that belong to the specified cube axis.

Note

To access view dimensions belonging to the horizontal or vertical axis, use Dims collections of IViewAxis interface returned respectively by IContourView.HAxis and IContourView.HAxis properties.

See also

IViewAxis.Dims
IContourView.HAxis
IContourView.VAxis


IContourCube.ImportData

IContourCube.ImportData Method

IContourCube Properties Methods

Import cube data from external format (currently CSV only)

Syntax

object.ImportData ByVal FileName As String , ByVal ExportType As TxExportData

Parameters
object | An object of type IContourCube
[in] FileName | (Required) A String value. Name of the file, from which cube data should be imported.
[in] ExportType | (Required) A TxExportData value. Specifies format of the text file.

This method imports cube data from a text file in specified format. This file could be previously produced with ExportData procedure.

Note

ImportData doesn't import metadata, such as filter settings, mappings, etc. You must define cube fields with respect to the data structure, prior to call ImportData.

See also

IContourCube.ExportData


IContourCube.Load

IContourCube.Load Method

IContourCube Properties Methods

Loads data from the microcube file.

Syntax

object.Load ByVal FileName As String

Parameters
object | An object of type IContourCube
[in] FileName | (Required) A String value. Specifies path and name / URL of the microcube file. Must contain the filename extension.

The procedure asynchronously loads entire report from a microcube (.cube) file. If report was succesfully loaded, it fires OnCubeLoaded event and sets DataSourceType property to xcdt_Microcube.
After that the microcube was loaded into the memory, ContourCube closes the file, so that it can be then opened by another control.

Note

Because Load accepts URLs as parameters, you can use it to load reports directly from web locations.
To synchronize cube loading process, you can also use Wait4LoadingCube procedure.

See also

Tutorial: Working in MOLAP mode
OnCubeLoaded event
OnErrorLoadingCube event
IContourCube.Wait4LoadingCube
IContourCube.DataSourceType
CCubeDSType enum


IContourCube.Loading

IContourCube.Loading Method

IContourCube Properties Methods

Return TRUE if data loading in process

Syntax

object.Loading () As Boolean

Parameters
object An object of type IContourCube


IContourCube.LoadMetadata

IContourCube.LoadMetadata Method

IContourCube Properties Methods

Loads cube metadata from a file and creates a microcube without data (inactive)

Syntax

object.LoadMetadata (ByVal FileName As String) As IMicrocube

Parameters
object | An object of type IContourCube
[in] FileName | (Required) A String value.


IContourCube.LoadMetadataFromBuffer

IContourCube.LoadMetadataFromBuffer Method

IContourCube Properties Methods

Loads cube metadata from a stream and creates a microcube without data (inactive)

Syntax

object.LoadMetadataFromBuffer (ByVal ()Buffer As Integer) As IMicrocube

Parameters
object | An object of type IContourCube
[in] Buffer | (Required) A Integer value.


IContourCube.LoadMetadataFromStream

IContourCube.LoadMetadataFromStream Method

IContourCube Properties Methods

Loads cube metadata from a stream and creates a microcube without data (inactive)

Syntax

object.LoadMetadataFromStream (ByRef Stream As ISequentialStream) As IMicrocube

Parameters
object | An object of type IContourCube
[in] Stream | (Required) A ISequentialStream value.


IContourCube.Open

IContourCube.Open Method

IContourCube Properties Methods

Loads data from the recordset given in parameter and builds the cube.

Syntax

object.Open ByRef RecordSet As Recordset [, ByVal ForceActivateGrid As Boolean = True]

Parameters
object | An object of type IContourCube
[in] RecordSet | (Required) A Recordset value. Reference to the ADO recordset object to get data from.
[in] ForceActivateGrid | (Optional) A Boolean value.

Use this procedure to load data from arbitrary ADO recordset. In this case, connection parameters and SQL query are eventually specified in properties of the recordset object. See ADO API referense for more information on using recordsets.
After execution of this method the DataSourceType property gets the value xcdt_Recordset, and ContourCube ActiveX control is activated.

Note

Before the recordset is opened, BeforeOpen event is triggered. AfterOpen event is fired immediately after that the cube is activated.

See also

IContourCube.DataSourceType
TxCCubeDSType enum
BeforeOpen event
AfterOpen event


IContourCube.OpenMicrocube

IContourCube.OpenMicrocube Method

IContourCube Properties Methods

Starts microcube downloading and returns IMicrocube

Syntax

object.OpenMicrocube (ByVal FileName As String [, ByVal Async As Boolean = False]) As IMicrocube

Parameters
object | An object of type IContourCube
[in] FileName | (Required) A String value. Specifies path and name / URL of the microcube file. Must contain the filename extension.
[in] Async | (Optional) A Boolean value. Determines whether the report should be loaded asynchronously (True), or in the same thread. Asynchronous loading allows you to continue program execution immediately, without waiting until the report is completely loaded.

The procedure loads entire report from a microcube (.cube) file and returns interface to its image in ContourCube object. If report was succesfully loaded, it fires OnMicrocubeLoaded event and sets DataSourceType property to xcdt_Microcube.
After that the microcube was loaded into the memory, ContourCube closes the file, so that it can be then opened by another control.

Note

If for some reason a microcube could not be loaded, OnErrorLoadingMicrocube event is fired.

Because Load accepts URLs as parameters, you can use it to load reports directly from web locations.
To synchronize cube loading process, you can also use Wait4LoadingCube procedure.

See also

Tutorial: Working in MOLAP mode
OnMicrocubeLoaded event
OnErrorLoadingMicrocube event
IContourCube.Wait4LoadingCube
IContourCube.DataSourceType
CCubeDSType enum


IContourCube.PinRootAxis

IContourCube.PinRootAxis Property

IContourCube Properties Methods

Gets/sets whether the root axis can be changed

Read-Write

Syntax

object.PinRootAxis As Boolean

Parameters
object An object of type IContourCube


IContourCube.PreGrouping

IContourCube.PreGrouping Property

IContourCube Properties Methods

Allows/disables preliminary data grouping

Read-Write

Syntax

object.PreGrouping As Boolean

Parameters
object An object of type IContourCube

When a cube is activated, it reads data from a data source that has been specified by DataSourceType property, and converts it into internal multidimensional form. The data source can contain equal records (in this context, "equal" means records that have equal sets of dimension members while, of course, their fact field values can differ). Having loaded into a cube, records in each such set are aggregated and presented as one set of dimension values with corresponding aggregated fact values. Whether records have been aggregated before they have been converted into multidimensional form or inside the cube, doesn't matter - results are the same. But if records are aggregated after they converted, memory (and sometimes speed) overhead is much higher than would have been if aggregation were made before conversion.

Programmers can provide preliminary aggregation in two ways. Firstly, using GROUP BY clause of SQL query. If a data source is a DBMS server like MS SQL or IBM DB2, this is the most efficient way, because DBMS servers make aggregation quite effectively and besides, all aggregation is made on a powerful server rather than on a client workstation.
On the other hand, when data source is a local "client" database such as DBase or MS Access, GROUP BY implementation is usually very ineffective. Using GROUP BY with such databases may increase data loading time by up to several orders of magnitude. PreGrouping property resolves this issue, providing quite efficient mechanism of internal preliminary grouping. "Preliminary" in this context means that aggregation is made before data is converted into multidimensional form, thus avoiding memory and speed overhead of inadequate GROUP BY implementations.

Use PreGrouping property when a data source is a local database like DBase, Paradox, MS Access or such.

Note

Note that internal pregrouping comes not at no cost, so if your database does support GROUP BY efficiently, it is a good idea to use it and set PreGrouping to False.

The default value of PreGrouping property is True.

Example

Suppose you have a source recordset like below:

StrField1 | StrField2 | NumField1 | NumField2 | NumField3
A | X | 1 | 1 | 1
A | X | 2 | 2 | 2
A | Y | 3 | 3 | 3
A | Z | 4 | 4 | 4
A | Z | 5 | 5 | 5
B | X | 6 | 6 | 6
B | X | 7 | 7 | 7
B | Y | 8 | 8 | 8
B | Z | 9 | 9 | 9
B | Z | 0 | 0 | 0
C | X | 1 | 1 | 1
C | Y | 2 | 2 | 2
C | Y | 3 | 3 | 3
C | Y | 4 | 4 | 4
C | Z | 5 | 5 | 5
C | Z | 6 | 6 | 6

Executing the following SQL query requires that ContourCube Preliminary Grouping be turned off (PreGrouping = False), because records are grouped by SQL:

SELECT StrField1, StrField2, SUM(NumField1) AS SumField, MIN(NumField2) AS MinField, MAX(NumField3) AS MaxField, COUNT(*) AS CounterGROUP BY StrField1, StrField2

StrField1 | StrField2 | SumField | MinField | MaxField | Counter
A | X | 3 | 1 | 2 | 2
A | Y | 3 | 3 | 3 | 1
A | Z | 9 | 4 | 5 | 2
B | X | 13 | 6 | 7 | 1
B | Y | 8 | 8 | 8 | 1
B | Z | 9 | 0 | 9 | 2
C | X | 1 | 1 | 1 | 1
C | Y | 9 | 2 | 4 | 3
C | Z | 11 | 5 | 6 | 2

Then, ContourCube fields definitions should look like

[Visual Basic].Cube.Dims.Add "StrField1", "Dim1"
.Cube.Dims.Add "StrField2", "Dim2"

.Cube.BaseFacts.Add "SumField", "SumFact"
.Cube.BaseFacts.Add "MinField", "MinFact"
.Cube.BaseFacts.Add "MaxField", "MaxFact"
.Cube.BaseFacts.Add "Counter", "CntFact"

By contrast, if you excluded GROUP BY from the query, and turned PreGrouping on, you should specify aggregation algorithm for each base fact:

.Cube.Dims.Add "StrField1","Dim1"
.Cube.Dims.Add "StrField2","Dim2", ,xda_horizontal

Dim bf as CubeBaseFact
Set bf = .Cube.BaseFacts.Add("SumField" , "SumFact")
bf.SourceAggregator = xdsa_SUM
Set bf = .Cube.BaseFacts.Add( "MinField" , "MinFact")
bf.SourceAggregator = xdsa _MIN
Set bf = .Cube.BaseFacts.Add ("MaxField" ,"MaxFact")
bf.SourceAggregator = xdsa _MAX
Set bf = .Cube.BaseFacts.Add ("Counter" , "CntFact")
bf.SourceAggregator = xdsa _COUNT

In both cases, you get the same resulting cube, below but setting PreGrouping=True looks seamlessly faster compared to GROUP BY with slow SQL engines

Vertical | Horizontal | BaseFacts
Dim1 | Dim2 | SumFact | MinFact | MaxFact | CntFact
A | X | 3 | 1 | 2 | 2
A | Y | 3 | 3 | 3 | 1
A | Z | 9 | 4 | 5 | 2
B | X | 13 | 6 | 7 | 1
B | Y | 8 | 8 | 8 | 1
B | Z | 9 | 0 | 9 | 2
C | X | 1 | 1 | 1 | 1
C | Y | 9 | 2 | 4 | 3
C | Z | 11 | 5 | 6 | 2

See also

IContourCube.SQL
IContourCube.ADOCursorLocation


IContourCube.RootAxis

IContourCube.RootAxis Property

IContourCube Properties Methods

Returns/sets the axis, along which the facts are calculated

Read-Write

Syntax

object.RootAxis As TxDimAxis

Parameters
object An object of type IContourCube


IContourCube.RootDim

IContourCube.RootDim Property

IContourCube Properties Methods

Returns/sets the dimension name, along which axis the facts are calculated.

Read-Write

Syntax

object.RootDim As String

Parameters
object An object of type IContourCube


IContourCube.Save

IContourCube.Save Method

IContourCube Properties Methods

Saves the cube into the microcube file.

Syntax

object.Save ByVal FileName As String

Parameters
object | An object of type IContourCube
[in] FileName | (Required) A String value. Specifies path and name / URL of the microcube file. Must contain filename extension.

This procedure saves entire report to a microcube (.cube) file. Then, the report can be loaded into ContourCube control with Load method.

See also

Tutorial: Working in MOLAP mode
IContourCube.Load


IContourCube.SaveMetadata

IContourCube.SaveMetadata Method

IContourCube Properties Methods

Saves cube metadata into a file

Syntax

object.SaveMetadata ByVal FileName As String

Parameters
object | An object of type IContourCube
[in] FileName | (Required) A String value.


IContourCube.SaveMetadataToBuffer

IContourCube.SaveMetadataToBuffer Method

IContourCube Properties Methods

Saves cube metadata into a new buffer and returns the buffer

Syntax

object.SaveMetadataToBuffer ByRef ()Result As Integer

Parameters
object | An object of type IContourCube
[out] Result | (Required) A Integer value.


IContourCube.SaveMetadataToStream

IContourCube.SaveMetadataToStream Method

IContourCube Properties Methods

Saves cube metadata into a stream

Syntax

object.SaveMetadataToStream ByRef Stream As ISequentialStream

Parameters
object | An object of type IContourCube
[in] Stream | (Required) A ISequentialStream value.


IContourCube.SQL

IContourCube.SQL Property

IContourCube Properties Methods

This property specifies an SQL query string for ADO/BDE data sources.

Read-Write

Syntax

object.SQL As String

Parameters
object An object of type IContourCube

Use SQL property to set a specific SQL query string for ADO/BDE data sources.

To specify the data source type use the DataSourceType property. To specify the data source itself use the ConnectionString property.

See also

IContourCube.DataSourceType
IContourCube.ConnectionString


IContourCube.StopLoading

IContourCube.StopLoading Method

IContourCube Properties Methods

Stops loading data

Syntax

object.StopLoading

Parameters
object An object of type IContourCube


IContourCube.Wait4LoadingCube

IContourCube.Wait4LoadingCube Method

IContourCube Properties Methods

Waits while cube is loading

Syntax

object.Wait4LoadingCube

Parameters
object An object of type IContourCube


IContourDatapoint.Cardinality

IContourDatapoint.Cardinality Property

IContourDatapoint Properties Methods

Returns datapoint cardinality - the number of dimensions defining the datapoint. Parameter Level in all Datapoint methods can lie between 0 and Cardinality-1

Read-Only

Syntax

object.Cardinality As Integer

Parameters
object An object of type IContourDatapoint


IContourDatapoint.Category

IContourDatapoint.Category Property

IContourDatapoint Properties Methods

Returns Category

Read-Only

Syntax

object.Category As TxCellType

Parameters
object An object of type IContourDatapoint


IContourDatapoint.ChildCount

IContourDatapoint.ChildCount Method

IContourDatapoint Properties Methods

Returns number of childs for this data point

Syntax

object.ChildCount (ByVal Sublevel As Integer) As Integer

Parameters
object | An object of type IContourDatapoint
[in] Sublevel | (Required) A Integer value. Indicates sublevel number, for which the child count should be returned. SubLevel=0 means the current data point.

ChildCount returns number of child (i.e. immediately derived from it) data points at the given sublevel, counted from the current data point.

Note

If Sublevel is zero, and / or the data point is leaf, ChildCount returns 0.
To get a child data point from the given sublevel, use ChildPoint function.

See also

IContourDataPoint.ChildPoint


IContourDatapoint.ChildPoint

IContourDatapoint.ChildPoint Method

IContourDatapoint Properties Methods

Returns a child point for this data point

Syntax

object.ChildPoint (ByVal Sublevel As Integer , ByVal Index As Integer) As IContourDatapoint

Parameters
object | An object of type IContourDatapoint
[in] Sublevel | (Required) A Integer value. Specifies the sublevel number, counted from the current point, from which a child point should be returned.
[in] Index | (Required) A Integer value. Indicates index of the sought child point at the given sublevel.

This method returns instance of IContourDataPoint interface that represents a child data point, by its sublevel and index.

Note

If no data point is found by given coordinates, an exception is raised. To get the number of childs by sublevel, use ChildCount function.

See also

IContourDataPoint.ChildCount


IContourDatapoint.DataByDim

IContourDatapoint.DataByDim Method

IContourDatapoint Properties Methods

Returns data at the specified dimension

Syntax

object.DataByDim (ByRef CubeDim As ICubeDim) As Variant

Parameters
object | An object of type IContourDatapoint
[in] CubeDim | (Required) A ICubeDim value. Refers to the cube dimension object, whose member is to be returned.

Use DataByDim function to obtain member of the specified dimension, corresponding to this data point.

Note

To get the same result by dimension name instead of object reference, use DataByDimName method. To obtain it by hierarchy level, at which the dimension is located, use DataByLevel function.

See also

IContourDataPoint.DataByDimName
IContourDataPoint.DataByLevel


IContourDatapoint.DataByDimName

IContourDatapoint.DataByDimName Method

IContourDatapoint Properties Methods

Returns data at the dimension specified by name

Syntax

object.DataByDimName (ByVal DimName As String) As Variant

Parameters
object | An object of type IContourDatapoint
[in] DimName | (Required) A String value. Name of the cube dimension, whose member is to be returned.

Use DataByDimName function to obtain member of the specified dimension, corresponding to this data point.

Note

To get the same result by dimension object reference instead of its name, use DataByDim method. To obtain it by hierarchy level, at which the dimension is located, use DataByLevel function.

See also

IContourDataPoint.DataByDim
IContourDataPoint.DataByLevel


IContourDatapoint.DataByLevel

IContourDatapoint.DataByLevel Method

IContourDatapoint Properties Methods

Returns data at the specified hierarchy level

Syntax

object.DataByLevel (ByVal Level As Integer) As Variant

Parameters
object | An object of type IContourDatapoint
[in] Level | (Required) A Integer value. Specifies hierarchy level, at which the sought dimension is located.

Use DataByLevel function to obtain member of the dimension located at the specified hierarchy level, corresponding to this data point.

Note

Dimensions hierarchy (axis), at which the sought dimension is located, is determined by the value assigned to IContourCube.RootAxis property.

To get the same result by dimension name instead of hierarchy level, use DataByDimName method. To obtain it by dimension object reference, use DataByDim function.

See also

IContourCube.RootAxis
IContourDataPoint.DataByDimName
IContourDataPoint.DataByDim


IContourDatapoint.Dim

IContourDatapoint.Dim Method

IContourDatapoint Properties Methods

Dim(level) - the dimension at the of the hierarchy specified by the datapoint

Syntax

object.Dim (ByVal Level As Integer) As ICubeDim

Parameters
object | An object of type IContourDatapoint
[in] Level | (Required) A Integer value. Number of the hierarchy level, at which the sought dimension is located.

This method returns ICubeDim interface corresponding to the dimension located at the specified level of hierarchy.

Note

Dimensions hierarchy (axis) to be searched is determined by the value assigned to IContourCube.RootAxis property.

See also

IContourCube.RootAxis


IContourDatapoint.IsActual

IContourDatapoint.IsActual Method

IContourDatapoint Properties Methods

Returns whether this data point is actual

Syntax

object.IsActual () As Boolean

Parameters
object An object of type IContourDatapoint


IContourDatapoint.IsNone

IContourDatapoint.IsNone Method

IContourDatapoint Properties Methods

Returns whether this data point is none

Syntax

object.IsNone () As Boolean

Parameters
object An object of type IContourDatapoint


IContourDatapoint.LeafPoint

IContourDatapoint.LeafPoint Method

IContourDatapoint Properties Methods

Returns leaf data point with given index, derived from this point

Syntax

object.LeafPoint (ByVal Index As Integer) As IContourDatapoint

Parameters
object | An object of type IContourDatapoint
[in] Index | (Required) A Integer value. Index of the leaf to be returned.

LeafPoint returns leaf point of the hierarchy derived from the current data point, by its index.

Note

If the current data point is a leaf, LeafPoint returns itself. The hierarchy to walk through is determined by the value assigned to IContourCube.RootAxis property.

See also

IContourCube.RootAxis


IContourDatapoint.NextSibling

IContourDatapoint.NextSibling Property

IContourDatapoint Properties Methods

NextSibling - returns the next sibling datapoint

Read-Only

Syntax

object.NextSibling As IContourDatapoint

Parameters
object An object of type IContourDatapoint


IContourDatapoint.ParentPoint

IContourDatapoint.ParentPoint Method

IContourDatapoint Properties Methods

Returns a parent point for this data point

Syntax

object.ParentPoint (ByVal Superlevel As Integer) As IContourDatapoint

Parameters
object | An object of type IContourDatapoint
[in] Superlevel | (Required) A Integer value. Specifies the superlevel number, counted from the current point, from which a parent point should be returned.

This method returns instance of IContourDataPoint interface that represents a parent data point, by its superlevel number.

Note

If the current data point is root, ParentPoint throws an exception.


IContourDatapoint.PrevSibling

IContourDatapoint.PrevSibling Property

IContourDatapoint Properties Methods

PrevSibling - returns the previous sibling datapoint

Read-Only

Syntax

object.PrevSibling As IContourDatapoint

Parameters
object An object of type IContourDatapoint


IContourDatapoint.RootPoint

IContourDatapoint.RootPoint Property

IContourDatapoint Properties Methods

Returns Root data point

Read-Only

Syntax

object.RootPoint As IContourDatapoint

Parameters
object An object of type IContourDatapoint


IContourDatapoint.Value

IContourDatapoint.Value Method

IContourDatapoint Properties Methods

Returns fact data corresponding to the data point

Syntax

object.Value (ByRef ViewFact As IViewFact) As ICalcResult

Parameters
object | An object of type IContourDatapoint
[in] ViewFact | (Required) A IViewFact value. Refers to the view fact, whose data is to be returned.

This method returns instance of ICalcResult interface, which stores value of the specified fact, contained in the current data point.

Note

If the requested value is invalid, the returned ICalcResult contains information on the error kind. You can determine the result status with ICalcResult.Status propery.

See also

ICalcResult.Status


IContourExtent.Begin

IContourExtent.Begin Property

IContourExtent Properties

Returns Begin of the Extent

Read-Only

Syntax

object.Begin As Integer

Parameters
object An object of type IContourExtent


IContourExtent.End

IContourExtent.End Property

IContourExtent Properties

Returns End of the Extent

Read-Only

Syntax

object.End As Integer

Parameters
object An object of type IContourExtent


IContourExtent.Length

IContourExtent.Length Property

IContourExtent Properties

Returns Length of the Extent

Read-Only

Syntax

object.Length As Integer

Parameters
object An object of type IContourExtent


IContourGrid.AboutBox

IContourGrid.AboutBox Method

IContourGrid Properties Methods

Shows ContourCube About dialog

Syntax

object.AboutBox

Parameters
object An object of type IContourGrid


IContourGrid.Alive

IContourGrid.Alive Property

IContourGrid Properties Methods

Setting Alive to true/false activates/deactivates both grid and cube at once.

Read-Write

Syntax

object.Alive As Boolean

Parameters
object An object of type IContourGrid


IContourGrid.AllowExpand

IContourGrid.AllowExpand Property

IContourGrid Properties Methods

Allow/disallow expanding/collapsing of whole dimensions or individual nodes.

Read-Write

Syntax

object.AllowExpand As Boolean

Parameters
object An object of type IContourGrid


IContourGrid.AllowInactiveDimArea

IContourGrid.AllowInactiveDimArea Property

IContourGrid Properties Methods

Show/hide inactive dimensions bar.

Read-Write

Syntax

object.AllowInactiveDimArea As Boolean

Parameters
object An object of type IContourGrid


IContourGrid.AllowPivot

IContourGrid.AllowPivot Property

IContourGrid Properties Methods

Allow/disallow dimensions moving.

Read-Write

Syntax

object.AllowPivot As Boolean

Parameters
object An object of type IContourGrid


IContourGrid.BackColor

IContourGrid.BackColor Property

IContourGrid Properties Methods

Returns/sets the colour used for the control background.

Read-Write

Syntax

object.BackColor As Integer

Parameters
object An object of type IContourGrid


IContourGrid.BindMicrocube

IContourGrid.BindMicrocube Method

IContourGrid Properties Methods

Binds cube, slice and view from the given microcube

Syntax

object.BindMicrocube ByRef Microcube As IMicrocube , ByVal SliceName As String , ByVal ViewName As String

Parameters
object | An object of type IContourGrid
[in] Microcube | (Required) A IMicrocube value. References interface to the microcube, whose slice and view should be bound to the grid. Can be obtained from IContourCube.LoadMicrocube method.
[in] SliceName | (Required) A String value. Name of the slice to bind. You can obtain array of all slice names from IMicrocube.GetSliceNames function.
[in] ViewName | (Required) A String value. Name of the view to bind. You can obtain array of all view names from IMicrocube.GetViewNames function.

Use IContourGrid.BindMicrocube to bind specified slice and view from given microcube to the grid, so that you can see a custom report.

Contour microcubes can contain multiple slices and views, but although they all are loaded by IContourCube.LoadMicrocube, only one of them can be displayed in the grid at once. This method allows you to switch your ContourCube control between views, this way displaying various reports from the same data.

Note

After that a microcube has been bound to the grid, setting IContourCube.Active property to False clears all ContourCube fields and puts currently bound microcube into invalid state.

See also

ContourCube Overview
IContourCube.LoadMicrocube
IContourCube.Active
IMicrocube.GetSliceNames
IMicrocube.GetViewNames
IMicrocube.Valid


IContourGrid.BorderStyle

IContourGrid.BorderStyle Property

IContourGrid Properties Methods

Returns/set the border style for the cube.

Read-Write

Syntax

object.BorderStyle As TxCBorderStyle

Parameters
object An object of type IContourGrid


IContourGrid.BuiltinStylesCount

IContourGrid.BuiltinStylesCount Property

IContourGrid Properties Methods

Returns a number of builtin styles

Read-Only

Syntax

object.BuiltinStylesCount As Integer

Parameters
object An object of type IContourGrid


IContourGrid.ColCount

IContourGrid.ColCount Property

IContourGrid Properties Methods

Returns the number of columns in the grid

Read-Only

Syntax

object.ColCount As Integer

Parameters
object An object of type IContourGrid


IContourGrid.ContourPropertyPages

IContourGrid.ContourPropertyPages Property

IContourGrid Properties Methods

Returns PropertyPages

Read-Only

Syntax

object.ContourPropertyPages As IContourPropertyPages

Parameters
object An object of type IContourGrid


IContourGrid.CurrentCell

IContourGrid.CurrentCell Property

IContourGrid Properties Methods

Returns CurrentCell

Read-Only

Syntax

object.CurrentCell As IGridCell

Parameters
object An object of type IContourGrid


IContourGrid.CursorX

IContourGrid.CursorX Property

IContourGrid Properties Methods

Returns X coordinate of the mouse cursor

Read-Only

Syntax

object.CursorX As Integer

Parameters
object An object of type IContourGrid


IContourGrid.CursorY

IContourGrid.CursorY Property

IContourGrid Properties Methods

Returns Y coordinate of the mouse cursor

Read-Only

Syntax

object.CursorY As Integer

Parameters
object An object of type IContourGrid


IContourGrid.DimFilter

IContourGrid.DimFilter Property

IContourGrid Properties Methods

Returns/sets the style used to draw dimension filter comboboxes.

Read-Write

Syntax

object.DimFilter As IDimFilterSettings

Parameters
object An object of type IContourGrid


IContourGrid.DimTitleDraggingStyle

IContourGrid.DimTitleDraggingStyle Property

IContourGrid Properties Methods

Returns/sets the style used to draw dragging dimension title.

Read-Write

Syntax

object.DimTitleDraggingStyle As IGridElementStyle

Parameters
object An object of type IContourGrid


IContourGrid.DimTitleInactiveStyle

IContourGrid.DimTitleInactiveStyle Property

IContourGrid Properties Methods

Returns/sets the style used to draw inactive dimension title.

Read-Write

Syntax

object.DimTitleInactiveStyle As IGridElementStyle

Parameters
object An object of type IContourGrid


IContourGrid.DimTitleStyle

IContourGrid.DimTitleStyle Property

IContourGrid Properties Methods

Returns/sets the style used to draw dimension title.

Read-Write

Syntax

object.DimTitleStyle As IGridElementStyle

Parameters
object An object of type IContourGrid


IContourGrid.DimValueStyle

IContourGrid.DimValueStyle Property

IContourGrid Properties Methods

Returns/sets the style used to draw dimension values.

Read-Write

Syntax

object.DimValueStyle As IGridElementStyle

Parameters
object An object of type IContourGrid


IContourGrid.Enabled

IContourGrid.Enabled Property

IContourGrid Properties Methods

Returns or sets a value that determines whether an object can respond to user-generated events.

Read-Write

Syntax

object.Enabled As Boolean

Parameters
object An object of type IContourGrid


IContourGrid.FactsHeading

IContourGrid.FactsHeading Property

IContourGrid Properties Methods

Returns/sets the style used to draw facts headings.

Read-Write

Syntax

object.FactsHeading As IFactsHeadingSettings

Parameters
object An object of type IContourGrid


IContourGrid.FactsList

IContourGrid.FactsList Property

IContourGrid Properties Methods

Returns/sets the style used to draw facts list.

Read-Write

Syntax

object.FactsList As IFactsListSettings

Parameters
object An object of type IContourGrid


IContourGrid.Footer

IContourGrid.Footer Property

IContourGrid Properties Methods

Returns footer object.

Read-Only

Syntax

object.Footer As ICubeFooter

Parameters
object An object of type IContourGrid


IContourGrid.GetArea

IContourGrid.GetArea Method

IContourGrid Properties Methods

Returns IGridArea for the given point

Syntax

object.GetArea (ByVal X As Integer , ByVal Y As Integer) As IGridArea

Parameters
object | An object of type IContourGrid
[in] X | (Required) A Integer value.
[in] Y | (Required) A Integer value.


IContourGrid.GetBuiltinStyle

IContourGrid.GetBuiltinStyle Method

IContourGrid Properties Methods

Returns a builtin style by name or index

Syntax

object.GetBuiltinStyle (ByVal Index As Variant) As IContourStyle

Parameters
object | An object of type IContourGrid
[in] Index | (Required) A Variant value.


IContourGrid.GetBuiltinStylesheet

IContourGrid.GetBuiltinStylesheet Method

IContourGrid Properties Methods

Returns builtin stylesheet

Syntax

object.GetBuiltinStylesheet () As IContourStylesheet

Parameters
object An object of type IContourGrid


IContourGrid.GetFactInCol

IContourGrid.GetFactInCol Method

IContourGrid Properties Methods

Get a fact, whose values are in the given column.

Syntax

object.GetFactInCol ([ByVal Col As Integer = -1]) As IGridFact

Parameters
object | An object of type IContourGrid
[in] Col | (Optional) A Integer value. Number of the grid column, whose fact is to be returned.

Use this function to get reference to the fact, whose values are displayed in the grid column with given number.

Note

Except for the default parameter value, the function raises an exception, if its parameter is out of range. Passing -1 (default) to GetFactInCol tells the method to use the currently focused column.


IContourGrid.GetFrameRect

IContourGrid.GetFrameRect Method

IContourGrid Properties Methods

Returns a rectangle containing the given frame

Syntax

object.GetFrameRect (ByVal Frame As TxContourFrame) As IContourRect

Parameters
object | An object of type IContourGrid
[in] Frame | (Required) A TxContourFrame value. Specifies the frame, whose interface should be returned. You can know what frame is currently pointed by mouse, with IContourGrid.GetPointedFrame method.

Use this function to obtain interface to the specific ContourGrid area (frame). This interface can then be used to link graphical grid geometry with logical structure of ContourCube.

See also

IContourGrid.GetPointedFrame


IContourGrid.GetGridCell

IContourGrid.GetGridCell Method

IContourGrid Properties Methods

Returns Cell for given coordinates.

Syntax

object.GetGridCell (ByVal Col As Integer , ByVal Row As Integer) As IGridCell

Parameters
object | An object of type IContourGrid
[in] Col | (Required) A Integer value. Specifies grid column, at which the sought cell is located.
[in] Row | (Required) A Integer value. Specifies grid row, at which the sought cell is located.

This method returns interface to the cell with specified coordinates in ContourCube grid. Use GetGridCell to get access to the data stored in this cell.


IContourGrid.GetPointedFrame

IContourGrid.GetPointedFrame Method

IContourGrid Properties Methods

Returns type of frame located at the given coordinates

Syntax

object.GetPointedFrame (ByVal X As Integer , ByVal Y As Integer) As TxContourFrame

Parameters
object | An object of type IContourGrid
[in] X | (Required) A Integer value. Horizontal coordinate (in pixels) of a point contained within the frame.
[in] Y | (Required) A Integer value. Vertical coordinate (in pixels) of a point contained within the frame.

This method returns identifier of a ContourGrid geometric area (frame), containing the point with given coordinates. You can then use it to obtain the IContourRect interface to the rectangular grid area that that frame occupies.

See also

IContourRect interface
IContourGrid.GetFrameRect


IContourGrid.GridHAxis

IContourGrid.GridHAxis Property

IContourGrid Properties Methods

Returns horizontal grid axis

Read-Only

Syntax

object.GridHAxis As IGridAxis

Parameters
object An object of type IContourGrid


IContourGrid.GridVAxis

IContourGrid.GridVAxis Property

IContourGrid Properties Methods

Returns vertical grid axis

Read-Only

Syntax

object.GridVAxis As IGridAxis

Parameters
object An object of type IContourGrid


IContourGrid.Header

IContourGrid.Header Property

IContourGrid Properties Methods

Returns header object.

Read-Only

Syntax

object.Header As ICubeHeader

Parameters
object An object of type IContourGrid


IContourGrid.hWnd

IContourGrid.hWnd Property

IContourGrid Properties Methods

Returns window handle to the object

Read-Only

Syntax

object.hWnd As Integer

Parameters
object An object of type IContourGrid


IContourGrid.InactiveDimAreaBkColor

IContourGrid.InactiveDimAreaBkColor Property

IContourGrid Properties Methods

Returns/sets the background colour of the inactive dimensions area.

Read-Write

Syntax

object.InactiveDimAreaBkColor As Integer

Parameters
object An object of type IContourGrid


IContourGrid.InfoURL

IContourGrid.InfoURL Property

IContourGrid Properties Methods

Returns/sets info URL

Read-Write

Syntax

object.InfoURL As String

Parameters
object An object of type IContourGrid


IContourGrid.IsUpdating

IContourGrid.IsUpdating Method

IContourGrid Properties Methods

Returns TRUE if cube currently updating

Syntax

object.IsUpdating () As Boolean

Parameters
object An object of type IContourGrid


IContourGrid.MousePointer

IContourGrid.MousePointer Property

IContourGrid Properties Methods

Sets/retrieves the mouse pointer shape then over the object.

Read-Write

Syntax

object.MousePointer As Integer

Parameters
object An object of type IContourGrid


IContourGrid.PointedArea

IContourGrid.PointedArea Property

IContourGrid Properties Methods

Returns current PointedArea

Read-Only

Syntax

object.PointedArea As IGridArea

Parameters
object An object of type IContourGrid


IContourGrid.PrintCube

IContourGrid.PrintCube Method

IContourGrid Properties Methods

Print cube.

Syntax

object.PrintCube [ByVal ShowPreview As Boolean = True] [, ByVal Colored As Boolean = False]

Parameters
object | An object of type IContourGrid
[in] ShowPreview | (Optional) A Boolean value. Specifies whether to show the print preview or print immediately. True by default.
[in] Colored | (Optional) A Boolean value. Specifies whether to show / print the report in color or grayscale mode. False by default.

Use this procedure to show Print Preview window and print the current grid view.

Note

You can edit printer settings through IReportPrintSettings interface obtained from ReportPrintSettings property, before calling PrintCube.

See also

IReportPrintSettings interface
IContourGrid.ReportPrintSettings


IContourGrid.ReportPageSetup

IContourGrid.ReportPageSetup Method

IContourGrid Properties Methods

Shows report page setup dialog

Syntax

object.ReportPageSetup

Parameters
object An object of type IContourGrid


IContourGrid.ReportPrintSettings

IContourGrid.ReportPrintSettings Property

IContourGrid Properties Methods

Returns report print settings

Read-Only

Syntax

object.ReportPrintSettings As IReportPrintSettings

Parameters
object An object of type IContourGrid


IContourGrid.ReportToFile

IContourGrid.ReportToFile Method

IContourGrid Properties Methods

Generate a report into an HTML or .xls file.

Syntax

object.ReportToFile ByVal GridFileName As String , ByVal ChartFileName As String , ByVal ReportType As TxOlapReportType

Parameters
object | An object of type IContourGrid
[in] GridFileName | (Required) A String value. Name of the file the report should be exported to.
[in] ChartFileName | (Required) A String value. Name of the graphic file the chart should be saved to.
[in] ReportType | (Required) A TxOlapReportType value. Determines format of the file specified in the first parameter.

Use ExportToFile function to export data and metadata of ContourCube report to a file with the specified name. ContourCube is saved in the current configuration with all facts and dimensions settings. To save the chart associated with report as a graphic image, pass the graphic file name in the second parameter; if this parameter is empty, the chart is not saved.


IContourGrid.RowCount

IContourGrid.RowCount Property

IContourGrid Properties Methods

Returns the number of rows in the grid

Read-Only

Syntax

object.RowCount As Integer

Parameters
object An object of type IContourGrid


IContourGrid.SearchDimValue

IContourGrid.SearchDimValue Method

IContourGrid Properties Methods

Show search dialog for given dimension. If no dimension passed dialog permit choose dimension.

Syntax

object.SearchDimValue [ByRef ViewDim As IViewDim = 0]

Parameters
object | An object of type IContourGrid
[in] ViewDim | (Optional) A IViewDim value.


IContourGrid.SetCurrentCell

IContourGrid.SetCurrentCell Method

IContourGrid Properties Methods

Focus Cell with given coordinates.

Syntax

object.SetCurrentCell ByVal Col As Integer , ByVal Row As Integer

Parameters
object | An object of type IContourGrid
[in] Col | (Required) A Integer value.
[in] Row | (Required) A Integer value.


IContourGrid.ShiftState

IContourGrid.ShiftState Property

IContourGrid Properties Methods

Returns current ShiftState

Read-Only

Syntax

object.ShiftState As IShiftState

Parameters
object An object of type IContourGrid


IContourGrid.SortGridByFact

IContourGrid.SortGridByFact Method

IContourGrid Properties Methods

Sort a grid by fact values.

Syntax

object.SortGridByFact ByVal Direction As TxDimAxis , ByVal Col As Integer , ByVal Row As Integer

Parameters
object | An object of type IContourGrid
[in] Direction | (Required) A TxDimAxis value.
[in] Col | (Required) A Integer value.
[in] Row | (Required) A Integer value.


IContourGrid.StyleHolder

IContourGrid.StyleHolder Property

IContourGrid Properties Methods

Returns StyleHolder.

Read-Only

Syntax

object.StyleHolder As IContourStyleHolder

Parameters
object An object of type IContourGrid


IContourGrid.Stylesheets

IContourGrid.Stylesheets Property

IContourGrid Properties Methods

Returns collection of available Stylesheets

Read-Only

Syntax

object.Stylesheets As IStylesheetCollection

Parameters
object An object of type IContourGrid


IContourGrid.TitleSettings

IContourGrid.TitleSettings Property

IContourGrid Properties Methods

Returns/sets the style used to draw cube title.

Read-Write

Syntax

object.TitleSettings As ITitleSettings

Parameters
object An object of type IContourGrid


IContourGrid.TotalsString

IContourGrid.TotalsString Property

IContourGrid Properties Methods

Returns/sets the text that appears as a label for totals and grand totals. (Default is "Totals")

Read-Write

Syntax

object.TotalsString As String

Parameters
object An object of type IContourGrid


IContourGrid.UnBindMicrocube

IContourGrid.UnBindMicrocube Method

IContourGrid Properties Methods

Unbinds microcube if one is bounded

Syntax

object.UnBindMicrocube

Parameters
object An object of type IContourGrid


IContourGrid.UnusedDataAreaColor

IContourGrid.UnusedDataAreaColor Property

IContourGrid Properties Methods

Returns/sets the colour of the part of the data area not occupied by grid.

Read-Write

Syntax

object.UnusedDataAreaColor As Integer

Parameters
object An object of type IContourGrid


IContourGrid.Visible

IContourGrid.Visible Property

IContourGrid Properties Methods

Returns or sets a value indicating whether an object is visible or hidden.

Read-Write

Syntax

object.Visible As Boolean

Parameters
object An object of type IContourGrid


IContourGridEvents.AfterClose

IContourGridEvents.AfterClose Method

IContourGridEvents Methods

Occurs immediately after the cube is deactivated

Syntax

object.AfterClose

Parameters
object An object of type IContourGridEvents


IContourGridEvents.AfterMoveDimension

IContourGridEvents.AfterMoveDimension Method

IContourGridEvents Methods

Occurs immediately after that a dimension has been moved

Syntax

object.AfterMoveDimension

Parameters
object An object of type IContourGridEvents


IContourGridEvents.AfterOpen

IContourGridEvents.AfterOpen Method

IContourGridEvents Methods

Occurs immediately after that the cube is activated

Syntax

object.AfterOpen

Parameters
object An object of type IContourGridEvents


IContourGridEvents.BeforeClose

IContourGridEvents.BeforeClose Method

IContourGridEvents Methods

Occurs immediately before the cube is deactivated

Syntax

object.BeforeClose

Parameters
object An object of type IContourGridEvents


IContourGridEvents.BeforeMoveDimension

IContourGridEvents.BeforeMoveDimension Method

IContourGridEvents Methods

Occurs when attempting to move a dimension from one axis to another

Syntax

object.BeforeMoveDimension ByRef ViewDim As IViewDim , ByVal NewAxis As TxDimAxis , ByVal NewPos As Integer , ByRef Cancel As IBoolean

Parameters
object | An object of type IContourGridEvents
[in] ViewDim | (Required) A IViewDim value. Reference to the dimension being moved.
[in] NewAxis | (Required) A TxDimAxis value. Identifies grid axis the dimension is being moved to.
[in] NewPos | (Required) A Integer value. Specifies position at the axis, to which the dimension is being moved.
[in] Cancel | (Required) A IBoolean value. Determines whether to allow (False) or disable (True) the operation. This parameter allows you to disable moving of particular dimensions, leaving others unaffected.

Use this event to take actions upon pivoting, and to enable / disable moving certain dimensions between axes.

To enable or disable cube pivoting at all, use IContourGrid.AllowPivot property.

See also

IContourGrid.AllowPivot


IContourGridEvents.BeforeOpen

IContourGridEvents.BeforeOpen Method

IContourGridEvents Methods

Occurs immediately before that the cube is activated

Syntax

object.BeforeOpen

Parameters
object An object of type IContourGridEvents


IContourGridEvents.KeyDown

IContourGridEvents.KeyDown Method

IContourGridEvents Methods

Occurs when user presses a keyboard key

Syntax

object.KeyDown ByVal KeyCode As Integer , ByVal Register As Integer

Parameters
object | An object of type IContourGridEvents
[in] KeyCode | (Required) A Integer value. Stores the KeyCode of the pressed key.
[in] Register | (Required) A Integer value. Determines the state of the SHIFT, CTRL, and ALT keys at the time the event has occured. This is a bitwise mask with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values of 1, 2, and 4 respectively. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed.

This event is triggered immediately when user presses a key while ContourCube control has the focus.

Note

To take an action upon releasing a key, use KeyUp event. The KeyPress event is fired when user briefly presses and releases a key.

See also

KeyUp event
KeyPress event


IContourGridEvents.KeyPress

IContourGridEvents.KeyPress Method

IContourGridEvents Methods

Occurs when user hits a keyboard key

Syntax

object.KeyPress ByVal KeyASCII As Integer

Parameters
object | An object of type IContourGridEvents
[in] KeyASCII | (Required) A Integer value. Gets a standard numeric ASCII keycode of the key being pressed.

KeyPress event can involve any printable keyboard character, the CTRL key combined with a character from the standard alphabet or one of a few special characters, and the ENTER or BACKSPACE key.

Note

To take an action upon releasing a key, use KeyUp event. The KeyDown event is fired immediately when user just presses a key.

See also

KeyUp event
KeyDown event


IContourGridEvents.KeyUp

IContourGridEvents.KeyUp Method

IContourGridEvents Methods

Occurs when user releases a keyboard key

Syntax

object.KeyUp ByVal KeyCode As Integer , ByVal Register As Integer

Parameters
object | An object of type IContourGridEvents
[in] KeyCode | (Required) A Integer value. Stores the KeyCode of the released key.
[in] Register | (Required) A Integer value. Determines the state of the SHIFT, CTRL, and ALT keys at the time the event has occured. This is a bitwise mask with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values of 1, 2, and 4 respectively. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed.

This event is triggered when user releases a key while ContourCube control has the focus.

Note

To take an immediate action upon pressing a key, use KeyDown event. The KeyPress event is fired when user briefly presses and releases a key.

See also

KeyDown event
KeyPress event


IContourGridEvents.MouseDown

IContourGridEvents.MouseDown Method

IContourGridEvents Methods

Occurs when user presses a mouse button

Syntax

object.MouseDown ByVal Button As Integer , ByVal Register As Integer , ByVal X As Integer , ByVal Y As Integer

Parameters
object | An object of type IContourGridEvents
[in] Button | (Required) A Integer value. Identifies the mouse button(s) that was pressed to cause the event. Can contain any combination of TxMouseButton constants, depending on the combination of the mouse buttons being pressed.
[in] Register | (Required) A Integer value. Corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the first argument is pressed. This argument is a bitwise mask with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4 respectively. This argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed at the moment the event is fired.
[in] X | (Required) A Integer value. Stores horizontal coordinate of the mouse cursor.
[in] Y | (Required) A Integer value. Stores vertical coordinate of the mouse cursor.

Use MouseDown event procedure to specify actions that should be taken when given mouse button is pressed while the control has focus.

Note

To take an action upon releasing a mouse button, use MouseUp event. OnClick and OnDblClick events are triggered when user briefly clicks and double-clicks on the control, respectively.

See also

MouseUp event
 OnClick event
 OnDblClick event


IContourGridEvents.MouseMove

IContourGridEvents.MouseMove Method

IContourGridEvents Methods

Occurs upon moving the mouse cursor over the control

Syntax

object.MouseMove ByVal Register As Integer , ByVal X As Integer , ByVal Y As Integer

Parameters
object | An object of type IContourGridEvents
[in] Register | (Required) A Integer value. Corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the first argument is pressed. This argument is a bitwise mask with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4 respectively. This argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed at the moment the event is fired.
[in] X | (Required) A Integer value. Specifies horizontal coordinate the mouse pointer is moved to.
[in] Y | (Required) A Integer value. Specifies vertical coordinate the mouse pointer is moved to.

The MouseMove event is generated continuously as the mouse pointer moves across the control.

Note

Because this event occurs very often, to avoid "hanging", do not code any actions that may take a long time to execute.


IContourGridEvents.MouseUp

IContourGridEvents.MouseUp Method

IContourGridEvents Methods

Occurs when user releases a mouse button

Syntax

object.MouseUp ByVal Button As Integer , ByVal Register As Integer , ByVal X As Integer , ByVal Y As Integer

Parameters
object | An object of type IContourGridEvents
[in] Button | (Required) A Integer value. Identifies the mouse button(s) that was released to cause the event. Can contain any combination of TxMouseButton constants, depending on the combination of the mouse buttons being released.
[in] Register | (Required) A Integer value. Corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the first argument is released. This argument is a bitwise mask with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4 respectively. This argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed at the moment the event is fired.
[in] X | (Required) A Integer value. Stores horizontal coordinate of the mouse cursor.
[in] Y | (Required) A Integer value. Stores vertical coordinate of the mouse cursor.

Use MouseDown event procedure to specify actions that should be taken when given mouse button is released while the control has focus.

Note

To take an action upon pressing a mouse button, use MouseDown event. OnClick and OnDblClick events are triggered when user briefly clicks and double-clicks on the control, respectively.

See also

MouseDown event
 OnClick event
 OnDblClick event


IContourGridEvents.OnActionWaitFinish

IContourGridEvents.OnActionWaitFinish Method

IContourGridEvents Methods

Occurs at the moment the control has finished waiting for some specific action

Syntax

object.OnActionWaitFinish ByVal ActionType As TxWaitActionType

Parameters
object | An object of type IContourGridEvents
[in] ActionType | (Required) A TxWaitActionType value. Identifies type of the action that has been finished.

Use this event procedure to execute specific code when ContourCube has done certain actions, e.g. loading data, drilling, and so on.

Note

This event is always preceded by OnActionWaitStart event, which marks beginning of an action. To call OnActionWaitFinish default handler after your custom one, set the second parameter of OnActionWaitStart procedure to True. Thus, you cannot specify whether to call default handlers for these two events separately.

To execute specific code upon the cube has been loaded, use AfterOpen, OnCubeLoaded, and OnMicrocubeLoaded events.

See also

OnActionWaitStart event
AfterOpen event
OnCubeLoaded event
OnMicrocubeLoaded event


IContourGridEvents.OnActionWaitStart

IContourGridEvents.OnActionWaitStart Method

IContourGridEvents Methods

Occurs at the moment the control starts waiting for some specific action

Syntax

object.OnActionWaitStart ByVal ActionType As TxWaitActionType , ByRef CallDefault As IBoolean

Parameters
object | An object of type IContourGridEvents
[in] ActionType | (Required) A TxWaitActionType value. Identifies the action type ContourCube is waiting for.
[in] CallDefault | (Required) A IBoolean value. Determines whether to call the default event handler after the user-defined code has been executed.

Use this event procedure to execute specific code while ContourCube is waiting for certain actions, e.g. loading data, drilling, and so on.

Note

The second procedure parameter applies to OnActionWaitFinish event as well, which doesn't take such argument. Thus, you cannot specify whether to call default handlers for these two events separately.

To execute specific code while cube is being loaded, use OnLoadCube event.

See also

OnActionWaitFinish event
OnLoadCube event


IContourGridEvents.OnBeforeOpenFacts

IContourGridEvents.OnBeforeOpenFacts Method

IContourGridEvents Methods

Occurs when user clicks the arrow to open the drop-down list of facts

Syntax

object.OnBeforeOpenFacts ByRef AllowOpen As IBoolean

Parameters
object | An object of type IContourGridEvents
[in] AllowOpen | (Required) A IBoolean value. Determines whether the Facts Filter list can be opened. Set this parameter to False if you wand to disable that list to drop down.

Use this event to take custom actions just before that the Facts dropdown list opens upon mouse click, and eventually disable this operation.

You can also do the same on Dimension Filter boxes, handling OnBeforeOpenFilter event.

See also
OnBeforeOpenFilter event


IContourGridEvents.OnBeforeOpenFilter

IContourGridEvents.OnBeforeOpenFilter Method

IContourGridEvents Methods

Occurs when user clicks the arrow to open the drop-down list of a filter

Syntax

object.OnBeforeOpenFilter ByRef ViewDim As IViewDim , ByRef AllowOpen As IBoolean

Parameters
object | An object of type IContourGridEvents
[in] ViewDim | (Required) A IViewDim value. Reference to the view dimension, whose filter box is going to open.
[in] AllowOpen | (Required) A IBoolean value. Determines whether the Facts Filter list can be opened. Set this parameter to False if you wand to disable that list to drop down.

Use this event to take custom actions just before that the Dimension Filter dropdown list opens upon mouse click, and eventually disable this operation.

You can also do the same on Facts List box, handling OnBeforeOpenFacts event.

See also
OnBeforeOpenFacts event


IContourGridEvents.OnBeforeOpenSearchForm

IContourGridEvents.OnBeforeOpenSearchForm Method

IContourGridEvents Methods

Occurs when user clicks the "Search" menu of dimendion or SreachDimValue method called

Syntax

object.OnBeforeOpenSearchForm ByRef ViewDim As IViewDim , ByRef AllowOpen As IBoolean

Parameters
object | An object of type IContourGridEvents
[in] ViewDim | (Required) A IViewDim value.
[in] AllowOpen | (Required) A IBoolean value.


IContourGridEvents.OnClick

IContourGridEvents.OnClick Method

IContourGridEvents Methods

Occurs upon click on the control

Syntax

object.OnClick

Parameters
object An object of type IContourGridEvents


IContourGridEvents.OnContextPopup

IContourGridEvents.OnContextPopup Method

IContourGridEvents Methods

Occurs upon right button click on the grid or context menu popup

Syntax

object.OnContextPopup ByVal X As Integer , ByVal Y As Integer , ByRef Handled As IBoolean

Parameters
object | An object of type IContourGridEvents
[in] X | (Required) A Integer value. Stores horizontal coordinate of the mouse cursor.
[in] Y | (Required) A Integer value. Stores vertical coordinate of the mouse cursor.
[in] Handled | (Required) A IBoolean value. Determines whether the builtin context menu is shown (false) or not (true). In first case you may define and display your custom popup.

ContourCube fires this event when you right-click on a dimension, immediately before that the Dimension Context menu is displayed. It allows to eventually disable this builtin menu, and display a custom one instead.


IContourGridEvents.OnCubeLoaded

IContourGridEvents.OnCubeLoaded Method

IContourGridEvents Methods

Occurs when a microcube has been loaded

Syntax

object.OnCubeLoaded

Parameters
object An object of type IContourGridEvents


IContourGridEvents.OnDblClick

IContourGridEvents.OnDblClick Method

IContourGridEvents Methods

Occurs upon double-click on the control

Syntax

object.OnDblClick

Parameters
object An object of type IContourGridEvents


IContourGridEvents.OnDimMapping

IContourGridEvents.OnDimMapping Method

IContourGridEvents Methods

Occurs upon displaying of each dimension value with user-defined mapping

Syntax

object.OnDimMapping ByRef ViewDim As IViewDim , ByVal Key As String , ByRef Value As IString

Parameters
object | An object of type IContourGridEvents
[in] ViewDim | (Required) A IViewDim value. Reference to the dimension, whose members are being mapped.
[in] Key | (Required) A String value. Specifies the value to map, i.e. dimension value as it is.
[in] Value | (Required) A IString value. Returns mapped value that should be displayed in the grid.

ContourCube fires OnDimMapping for every unique value of the dimension whose mapping type is set to xdmt_user. Results are cached, so the event is occurred only one time per unique dimension value for the given dimension. The resulting value is used instead of original one when dimension values are displayed in the dimensions area and in the filters.

Note

Use ICubeDim.Mapping object property to define and edit mappings for a dimension. To set dimension mapping type, use ICubeDim.MapType property.

See also

ICubeDim.Mapping
ICubeDim.MapType
TxDimValMapType enum


IContourGridEvents.OnDimTitleClick

IContourGridEvents.OnDimTitleClick Method

IContourGridEvents Methods

Occurs upon click on a dimension title

Syntax

object.OnDimTitleClick ByRef ViewDim As IViewDim

Parameters
object | An object of type IContourGridEvents
[in] ViewDim | (Required) A IViewDim value.


IContourGridEvents.OnDimTitleDblClick

IContourGridEvents.OnDimTitleDblClick Method

IContourGridEvents Methods

Occurs upon double-click on a dimension title

Syntax

object.OnDimTitleDblClick ByRef ViewDim As IViewDim

Parameters
object | An object of type IContourGridEvents
[in] ViewDim | (Required) A IViewDim value.


IContourGridEvents.OnDimValueClick

IContourGridEvents.OnDimValueClick Method

IContourGridEvents Methods

Occurs when user clicks on a dimension value

Syntax

object.OnDimValueClick ByRef AxisSection As IAxisSection , ByVal Level As Integer

Parameters
object | An object of type IContourGridEvents
[in] AxisSection | (Required) A IAxisSection value. Refernces the axis section that has been clicked.
[in] Level | (Required) A Integer value. Determines drill down level, at which the section passed in first parameter has been clicked, i.e. the number of dimension at the axis, whose member has been clicked.

Use this event procedure to take specific actions when user clicks on a dimension member.

See also

IAxisSection.Axis


IContourGridEvents.OnDimValueDblClick

IContourGridEvents.OnDimValueDblClick Method

IContourGridEvents Methods

Occurs when user double-clicks on a dimension value

Syntax

object.OnDimValueDblClick ByRef AxisSection As IAxisSection , ByVal Level As Integer

Parameters
object | An object of type IContourGridEvents
[in] AxisSection | (Required) A IAxisSection value. Refernces the axis section that has been clicked.
[in] Level | (Required) A Integer value. Determines drill down level, at which the section passed in first parameter has been clicked, i.e. the number of dimension at the axis, whose member has been double-clicked.

Use this event procedure to take specific actions when user double-clicks on a dimension member.

See also

IAxisSection.Axis


IContourGridEvents.OnErrorLoadingCube

IContourGridEvents.OnErrorLoadingCube Method

IContourGridEvents Methods

Fires if an error occurs while loading data to the cube

Syntax

object.OnErrorLoadingCube ByVal ErrorMessage As String , ByRef RaiseException As IBoolean

Parameters
object | An object of type IContourGridEvents
[in] ErrorMessage | (Required) A String value. Contains the message text passed from exception.
[in] RaiseException | (Required) A IBoolean value. Defines whether the exception in the handler will be suppressed. The possible values: Set this argument to True to pass the error for handling; setting it to False forces handling the error in this function.

Use OnErrorLoadingCube event to intercept and handle errors that may occur while loading data into the ContourCube object.

Note

To take actions upon succesful loading, use AfterOpen and OnCubeLoaded events.

See also

AfterOpen event
 OnCubeLoaded event


IContourGridEvents.OnErrorLoadingMicrocube

IContourGridEvents.OnErrorLoadingMicrocube Method

IContourGridEvents Methods

Occurs when an error occured during loading a given microcube

Syntax

object.OnErrorLoadingMicrocube ByRef Microcube As IMicrocube

Parameters
object | An object of type IContourGridEvents
[in] Microcube | (Required) A IMicrocube value. References interface to the internal representation of the microcube that failed to load.

Use this event to take specific actions upon any error during microcube file loading.

If you don't handle multi-slice microcubes through IMicrocube interface, use simpler OnErrorLoadingCube event for this purpose.

See also

OnErrorLoadingCube event


IContourGridEvents.OnException

IContourGridEvents.OnException Method

IContourGridEvents Methods

Occurs if an exception occurs outside of any COM method

Syntax

object.OnException ByVal ErrorMessage As String , ByRef RaiseException As IBoolean

Parameters
object | An object of type IContourGridEvents
[in] ErrorMessage | (Required) A String value. Contains the message text passed from exception.
[in] RaiseException | (Required) A IBoolean value. Defines whether the exception in the handler will be suppressed. The possible values: Set this argument to True to pass the error for handling; setting it to False forces handling the error in this function.

ContourCube triggers this event when an exception is thrown in user interface, i.e. some user's actions, such as operations with mouse, etc., raise an error.

Note

This event isn't fired when an error occurs in code, e.g. when cube loading fails. To handle errors thrown in program code (for example, illegal method calls), use exception handling facilities of your development environment.
To execute code upon cube loading error, use OnErrorLoadingCube event.

See also

OnErrorLoadingCube event


IContourGridEvents.OnFactCellClick

IContourGridEvents.OnFactCellClick Method

IContourGridEvents Methods

Occurs when user clicks on a grid cell

Syntax

object.OnFactCellClick ByRef GridCell As IGridCell

Parameters
object | An object of type IContourGridEvents
[in] GridCell | (Required) A IGridCell value. Reference to the grid cell that has been clicked.

Use OnFactCellClick event to write code that should be executed when a user clicks on a value of a fact, contained in a cell of ContourCube grid.

Note

To take actions upon double-clicking of a cell, use OnFactCellDblClick procedure. To execute specific code when user selects a grid cell with keyboard, use OnFactCellEnter event.

See also

OnFactCellDblClick event
OnFactCellEnter event


IContourGridEvents.OnFactCellDblClick

IContourGridEvents.OnFactCellDblClick Method

IContourGridEvents Methods

Occurs when user double-clicks on a grid cell

Syntax

object.OnFactCellDblClick ByRef GridCell As IGridCell

Parameters
object | An object of type IContourGridEvents
[in] GridCell | (Required) A IGridCell value. Reference to the grid cell that has been double-clicked.

Use OnFactCellDblClick event to write code that should be executed when a user double-clicks on a fact value, contained in a cell of ContourCube grid.

Note

To take actions upon single clicking of a cell, use OnFactCellClick procedure. To execute specific code when user selects a grid cell with keyboard, use OnFactCellEnter event.

See also

OnFactCellClick event
OnFactCellEnter event


IContourGridEvents.OnFactCellEnter

IContourGridEvents.OnFactCellEnter Method

IContourGridEvents Methods

Occurs when a grid cell gets the focus

Syntax

object.OnFactCellEnter ByRef GridCell As IGridCell

Parameters
object | An object of type IContourGridEvents
[in] GridCell | (Required) A IGridCell value. References the grid cell that gets the focus.

Use this event to execute specific code when user enters a cell of ContourCube grid, i.e when this cell gets the focus.
If user selects a cell with mouse, the OnFactCellClick event is also generated.

See also

OnFactCellClick event


IContourGridEvents.OnFactHeadingClick

IContourGridEvents.OnFactHeadingClick Method

IContourGridEvents Methods

Occurs upon click on a fact heading

Syntax

object.OnFactHeadingClick ByRef GridFact As IGridFact , ByVal Col As Integer

Parameters
object | An object of type IContourGridEvents
[in] GridFact | (Required) A IGridFact value. References the fact, whose column heading has been clicked.
[in] Col | (Required) A Integer value. Specifies the column number, whose heading has been clicked.

Use OnFactHeadingClick event to execute code when a user clicks on the value of the specified ContourCube fact, whose values are displayed in the given column.

Note

To take actions upon double-clicking of fact headings, use OnFactHeadingDblClick event.

See also

OnFactHeadingDblClick event


IContourGridEvents.OnFactHeadingDblClick

IContourGridEvents.OnFactHeadingDblClick Method

IContourGridEvents Methods

Occurs upon double-click on a fact heading

Syntax

object.OnFactHeadingDblClick ByRef GridFact As IGridFact , ByVal Col As Integer

Parameters
object | An object of type IContourGridEvents
[in] GridFact | (Required) A IGridFact value. References the fact, whose column heading has been clicked.
[in] Col | (Required) A Integer value. Specifies the column number, whose heading has been clicked.

Use OnFactHeadingClick event to execute code when a user double-clicks on the value of the specified ContourCube fact, whose values are displayed in the given column.

Note

To take actions upon single clicking of fact headings, use OnFactHeadingClick event.

See also

OnFactHeadingClick event


IContourGridEvents.OnFactStateChanged

IContourGridEvents.OnFactStateChanged Method

IContourGridEvents Methods

Occurs upon any change made in fact filters

Syntax

object.OnFactStateChanged ByRef View As IContourView

Parameters
object | An object of type IContourGridEvents
[in] View | (Required) A IContourView value. References the view, which has fired the event.

This event occures every time when the fact state in any ContourCube view changes, for example, if it has been hidden, or disabled, or deactivated.
It applies to all views created from this cube, including the effective view, i.e. one visualized by ContourGrid.

Note

Use IContourView.CloneView method to obtain new instances of IContourView interface, containing the same data.

See also

IContourView.CloneView
IContourView interface


IContourGridEvents.OnFiltered

IContourGridEvents.OnFiltered Method

IContourGridEvents Methods

Occurs upon any change made in dimension filters

Syntax

object.OnFiltered

Parameters
object An object of type IContourGridEvents


IContourGridEvents.OnLayoutChanged

IContourGridEvents.OnLayoutChanged Method

IContourGridEvents Methods

Occurs upon any change in the visual layout

Syntax

object.OnLayoutChanged

Parameters
object An object of type IContourGridEvents


IContourGridEvents.OnLoadCube

IContourGridEvents.OnLoadCube Method

IContourGridEvents Methods

Occurs when a microcube starts loading

Syntax

object.OnLoadCube

Parameters
object An object of type IContourGridEvents


IContourGridEvents.OnMicrocubeLoaded

IContourGridEvents.OnMicrocubeLoaded Method

IContourGridEvents Methods

Occurs when a given microcube has been loaded

Syntax

object.OnMicrocubeLoaded ByRef Microcube As IMicrocube

Parameters
object | An object of type IContourGridEvents
[in] Microcube | (Required) A IMicrocube value. References interface to the internal representation of the microcube that has beed loaded.

Use this event to take specific actions when a microcube file has been loaded into ContourCube, for example, to enable appropriate controls on the form.

If you don't handle multi-slice microcubes through IMicrocube interface, use simpler OnCubeLoaded event for this purpose.

See also

OnCubeLoaded event


IContourPropertyPages.Add

IContourPropertyPages.Add Method

IContourPropertyPages Methods

Adds property page to be shown

Syntax

object.Add ByVal PageID As TxPropertyPageIds

Parameters
object | An object of type IContourPropertyPages
[in] PageID | (Required) A TxPropertyPageIds value. Identifies the property page to add.

Use this method to add a property page with specified ID to the list of displayable pages. These pages can then be shown by Show method.

See also

IContourPropertyPages.Show


IContourPropertyPages.Clear

IContourPropertyPages.Clear Method

IContourPropertyPages Methods

Clears the list of property pages to be shown

Syntax

object.Clear

Parameters
object An object of type IContourPropertyPages


IContourPropertyPages.IsPageEnabled

IContourPropertyPages.IsPageEnabled Method

IContourPropertyPages Methods

Returns whether the specified property page enabled or not

Syntax

object.IsPageEnabled (ByVal PageID As TxPropertyPageIds) As Boolean

Parameters
object | An object of type IContourPropertyPages
[in] PageID | (Required) A TxPropertyPageIds value. Identifies the property page to check for.

Use IsPageEnabled to check whether a property page with given ID is present in the list of displayable pages.
Property pages from that list are shown when you call Show procedure.

See also

IContourPropertyPages.Show


IContourPropertyPages.Remove

IContourPropertyPages.Remove Method

IContourPropertyPages Methods

Removes property page from the list of pages to be shown

Syntax

object.Remove ByVal PageID As TxPropertyPageIds

Parameters
object | An object of type IContourPropertyPages
[in] PageID | (Required) A TxPropertyPageIds value. Identifies the property page to remove.

This procedure removes property page with given ID from the list of displayable pages. The removed property page will not appear among ones displayed by Show method.

See also

IContourPropertyPages.Show


IContourPropertyPages.Show

IContourPropertyPages.Show Method

IContourPropertyPages Methods

Shows property pages

Syntax

object.Show

Parameters
object An object of type IContourPropertyPages


IContourRect.Bottom

IContourRect.Bottom Property

IContourRect Properties Methods

Returns/sets bottom coordinate of the rectangle

Read-Write

Syntax

object.Bottom As Integer

Parameters
object An object of type IContourRect


IContourRect.Contains

IContourRect.Contains Method

IContourRect Properties Methods

Returns whether this rectangle contains point located at the given coordinates

Syntax

object.Contains (ByVal X As Integer , ByVal Y As Integer) As Boolean

Parameters
object | An object of type IContourRect
[in] X | (Required) A Integer value. Specifies horizontal coordinate (in pixels) of the point being checked.
[in] Y | (Required) A Integer value. Specifies vertical coordinate (in pixels) of the point being checked.

Use this function to determine whether the rectangular grid area represented by this IContourRect interface contains point with specified graphical coordinates. If yes, Contains returns True, and False otherwise.

For example, you can check if the mouse pointer is being moved over the given area of ContourCube control, with IContourGrid.CursorX and IContourGrid.CursorY properties and the MouseMove event.

See also

IContourGrid.CursorX
IContourGrid.CursorY
MouseMove event


IContourRect.Height

IContourRect.Height Property

IContourRect Properties Methods

Returns/sets height of the rectangle

Read-Write

Syntax

object.Height As Integer

Parameters
object An object of type IContourRect


IContourRect.Intersect

IContourRect.Intersect Method

IContourRect Properties Methods

Returns intersection rectangle of this rectangle and the given one

Syntax

object.Intersect (ByRef Rect As IContourRect) As IContourRect

Parameters
object | An object of type IContourRect
[in] Rect | (Required) A IContourRect value. Interface to the rectangle to intersect with.

This method performs intersection of the rectangular area represented by this IContourRect interface with another one, and returns interface to the resulting rectangle.

Note

If two rectangles have no intersections, the IsEmpty property of the resulting interface will be True. If you want just to check for this, and not to obtain the instance, use IntersectsWith function.

See also

IContourRect.IsEmpty
IContourRect.IntersectsWith


IContourRect.IntersectsWith

IContourRect.IntersectsWith Method

IContourRect Properties Methods

Returns whether this rectangle intersects with the given one

Syntax

object.IntersectsWith (ByRef Rect As IContourRect) As Boolean

Parameters
object | An object of type IContourRect
[in] Rect | (Required) A IContourRect value. Interface to the rectangle to intersect with.

This method tries to intersect the rectangular area represented by this IContourRect interface with another one, and returns True if the result is not empty. Otherwise, it returns False.

Note

Calling this function is useful to perform a check before invoking Intersect method. Otherwise, you can use IsEmpty property of the interface returned by Intersect.

See also

IContourRect.IsEmpty
IContourRect.Intersect


IContourRect.IsEmpty

IContourRect.IsEmpty Property

IContourRect Properties Methods

Returns whether this rectangle has zero size

Read-Only

Syntax

object.IsEmpty As Boolean

Parameters
object An object of type IContourRect


IContourRect.Left

IContourRect.Left Property

IContourRect Properties Methods

Returns/sets left coordinate of the rectangle

Read-Write

Syntax

object.Left As Integer

Parameters
object An object of type IContourRect


IContourRect.ReadOnly

IContourRect.ReadOnly Property

IContourRect Properties Methods

Returns whether the rectangle has readonly coordinates

Read-Only

Syntax

object.ReadOnly As Boolean

Parameters
object An object of type IContourRect


IContourRect.Right

IContourRect.Right Property

IContourRect Properties Methods

Returns/sets right coordinate of the rectangle

Read-Write

Syntax

object.Right As Integer

Parameters
object An object of type IContourRect


IContourRect.Top

IContourRect.Top Property

IContourRect Properties Methods

Returns/sets top coordinate of the rectangle

Read-Write

Syntax

object.Top As Integer

Parameters
object An object of type IContourRect


IContourRect.Width

IContourRect.Width Property

IContourRect Properties Methods

Returns/sets width of the rectangle

Read-Write

Syntax

object.Width As Integer

Parameters
object An object of type IContourRect


IContourStatusTexts.DimNdxRange

IContourStatusTexts.DimNdxRange Property

IContourStatusTexts Properties

Returns/sets the status text for dimension index violation

Read-Write

Syntax

object.DimNdxRange As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.FPDomain

IContourStatusTexts.FPDomain Property

IContourStatusTexts Properties

Returns/sets the status text for floating point domain violation

Read-Write

Syntax

object.FPDomain As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.FPError

IContourStatusTexts.FPError Property

IContourStatusTexts Properties

Returns/sets the status text for floating point operation errors

Read-Write

Syntax

object.FPError As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.FPValRange

IContourStatusTexts.FPValRange Property

IContourStatusTexts Properties

Returns/sets the status text for floating point range violation

Read-Write

Syntax

object.FPValRange As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.GeneralErr

IContourStatusTexts.GeneralErr Property

IContourStatusTexts Properties

Returns/sets the status text for general errors

Read-Write

Syntax

object.GeneralErr As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.InfNegative

IContourStatusTexts.InfNegative Property

IContourStatusTexts Properties

Returns/sets the status text for negative infinity

Read-Write

Syntax

object.InfNegative As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.InfPositive

IContourStatusTexts.InfPositive Property

IContourStatusTexts Properties

Returns/sets the status text for positive infinity

Read-Write

Syntax

object.InfPositive As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.InvalidDim

IContourStatusTexts.InvalidDim Property

IContourStatusTexts Properties

Returns/sets the status text for invalid dimensions

Read-Write

Syntax

object.InvalidDim As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.InvalidFact

IContourStatusTexts.InvalidFact Property

IContourStatusTexts Properties

Returns/sets the status text for invalid facts

Read-Write

Syntax

object.InvalidFact As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.NoDataPoint

IContourStatusTexts.NoDataPoint Property

IContourStatusTexts Properties

Returns/sets the status text for datapoint miss

Read-Write

Syntax

object.NoDataPoint As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.NodeNdxRange

IContourStatusTexts.NodeNdxRange Property

IContourStatusTexts Properties

Returns/sets the status text for node index violation

Read-Write

Syntax

object.NodeNdxRange As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.NullValue

IContourStatusTexts.NullValue Property

IContourStatusTexts Properties

Returns/sets the status text for NULL cells

Read-Write

Syntax

object.NullValue As String

Parameters
object An object of type IContourStatusTexts


IContourStatusTexts.UseParentStatusText

IContourStatusTexts.UseParentStatusText Property

IContourStatusTexts Properties

Returns/sets whether to use inherited status texts

Read-Write

Syntax

object.UseParentStatusText As Boolean

Parameters
object An object of type IContourStatusTexts


IContourStyle.Alignment

IContourStyle.Alignment Property

IContourStyle Properties Methods

Returns/sets the text alignment specified by the style

Read-Write

Syntax

object.Alignment As TxAlignment

Parameters
object An object of type IContourStyle


IContourStyle.BkColor

IContourStyle.BkColor Property

IContourStyle Properties Methods

Returns/sets background color

Read-Write

Syntax

object.BkColor As Integer

Parameters
object An object of type IContourStyle


IContourStyle.Delete

IContourStyle.Delete Method

IContourStyle Properties Methods

Deletes this style

Syntax

object.Delete

Parameters
object An object of type IContourStyle


IContourStyle.DisableProperty

IContourStyle.DisableProperty Method

IContourStyle Properties Methods

Disables style property

Syntax

object.DisableProperty ByVal Property As TxStyledProperty

Parameters
object | An object of type IContourStyle
[in] Property | (Required) A TxStyledProperty value. Identifies the appearance property that should be disabled.

Use this procedure to remove a style element from the set of properties affected by this style. This way you could define styles that apply to selected appearance settings.

Example

[Visual Basic]
MyStyle.DisableProperty xspBkColor
'Now MyStyle will affect all appearance elements of the cells it applies to,
'except for their Background Color.

Note

By default, all appearance properties of a style are enabled.
To check if a property is enabled, use IsPropertyEnabled method.

See also

IContourStyle.IsPropertyEnabled
IContourStyle.EnableProperty


IContourStyle.EnableProperty

IContourStyle.EnableProperty Method

IContourStyle Properties Methods

Enables style property

Syntax

object.EnableProperty ByVal Property As TxStyledProperty

Parameters
object | An object of type IContourStyle
[in] Property | (Required) A TxStyledProperty value. Identifies the appearance property that should be enabled.

Use this procedure to add a style element to the set of properties affected by this style. This way you could define styles that apply to selected appearance settings.

Example

[Visual Basic]
MyStyle.EnableProperty xspBkColor
'Now MyStyle will affect Background Color of the cells it applies to.

Note

By default, all appearance properties of a style are enabled.
To check if a property is enabled, use IsPropertyEnabled method.

See also

IContourStyle.IsPropertyEnabled
IContourStyle.DisableProperty


IContourStyle.FontColor

IContourStyle.FontColor Property

IContourStyle Properties Methods

Returns/sets color of the font used in this style.

Read-Write

Syntax

object.FontColor As Integer

Parameters
object An object of type IContourStyle


IContourStyle.Format

IContourStyle.Format Property

IContourStyle Properties Methods

Returns/sets Format string

Read-Write

Syntax

object.Format As String

Parameters
object An object of type IContourStyle


IContourStyle.IsBuiltin

IContourStyle.IsBuiltin Property

IContourStyle Properties Methods

Returns whether this style is builtin

Read-Only

Syntax

object.IsBuiltin As Boolean

Parameters
object An object of type IContourStyle


IContourStyle.IsPropertyEnabled

IContourStyle.IsPropertyEnabled Method

IContourStyle Properties Methods

Returns whether style property enabled

Syntax

object.IsPropertyEnabled (ByVal Property As TxStyledProperty) As Boolean

Parameters
object | An object of type IContourStyle
[in] Property | (Required) A TxStyledProperty value. Identifies the appearance property to check.

Use IsPropertyEnabled to check whether an appearance element is affected by this style.

Note

To enable the style to apply to an appearance property, use EnableProperty method. DisableProperty disables it.

See also

IContourStyle.EnableProperty
IContourStyle.DisableProperty


IContourStyle.IsReplica

IContourStyle.IsReplica Property

IContourStyle Properties Methods

Returns whether this style is replica

Read-Only

Syntax

object.IsReplica As Boolean

Parameters
object An object of type IContourStyle


IContourStyle.Pure

IContourStyle.Pure Property

IContourStyle Properties Methods

Returns/sets Pure property

Read-Write

Syntax

object.Pure As Boolean

Parameters
object An object of type IContourStyle


IContourStyle.StyleFont

IContourStyle.StyleFont Property

IContourStyle Properties Methods

Returns/sets the font used in this style.

Read-Write

Syntax

object.StyleFont As Font

Parameters
object An object of type IContourStyle


IContourStyle.Title

IContourStyle.Title Property

IContourStyle Properties Methods

Returns/sets Title of the style

Read-Write

Syntax

object.Title As String

Parameters
object An object of type IContourStyle


IContourStyleHolder.Add

IContourStyleHolder.Add Method

IContourStyleHolder Properties Methods

Adds new style with given name.

Syntax

object.Add (ByVal StyleName As String) As IContourStyle

Parameters
object | An object of type IContourStyleHolder
[in] StyleName | (Required) A String value. Specifies the name of the newly added style.

The Add method creates a new style and adds it to the Style Holder of ContourCube control. This method returns reference to the newly created style, which can then be used in any stylesheet for the grid.

Note

To check whether a style with given name already exists in the style holder, use Exists function.

See also

IContourStyleHolder.Exists


IContourStyleHolder.Count

IContourStyleHolder.Count Property

IContourStyleHolder Properties Methods

Returns number of existing Styles.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type IContourStyleHolder


IContourStyleHolder.Edit

IContourStyleHolder.Edit Method

IContourStyleHolder Properties Methods

Shows styleholder editor

Syntax

object.Edit

Parameters
object An object of type IContourStyleHolder


IContourStyleHolder.Exists

IContourStyleHolder.Exists Method

IContourStyleHolder Properties Methods

Returns whether a style with given name exists.

Syntax

object.Exists (ByVal StyleName As String) As Boolean

Parameters
object | An object of type IContourStyleHolder
[in] StyleName | (Required) A String value. Name of the style to check for.

This function returns True, if a style with given name exists in the Style Holder collection. Otherwise, it returns False.

Note

To add a new style to the Style Holder of ContourCube control, use Add method.

See also

IContourStyleHolder.Add


IContourStyleHolder.Item

IContourStyleHolder.Item Property

IContourStyleHolder Properties Methods

Returns IContourStyle by name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As IContourStyle

Parameters
object | An object of type IContourStyleHolder
[in] Index | (Required) A Variant value. Specifies style name or zero-based index in the collection.

This property returns reference to the style from ContourCube style holder by its name or index.

Note

If no styles with given name were found, the function throws an exception. Use Exists method to check if a style is present in the style holder. To stay within collection bounds, see Count property.

See also
IContourStyleHolder.Exists
IContourStyleHolder.Count


IContourStyleHolder.PopulateWithBuiltinStyles

IContourStyleHolder.PopulateWithBuiltinStyles Method

IContourStyleHolder Properties Methods

Populates the holder with replicas of global (builtin) styles

Syntax

object.PopulateWithBuiltinStyles

Parameters
object An object of type IContourStyleHolder


IContourStyleHolder.PopulateWithStandardStyles

IContourStyleHolder.PopulateWithStandardStyles Method

IContourStyleHolder Properties Methods

Populates the holder with copies of global (builtin) styles

Syntax

object.PopulateWithStandardStyles ByVal Overwrite As Boolean

Parameters
object | An object of type IContourStyleHolder
[in] Overwrite | (Required) A Boolean value. Setting this parameter to True forces overwriting of similarly named styles with standard ones. If it is set to False, only styles not present in the style holder will be added.

This method fills the style holder with a set of standard styles. In brief, standard styles are just copies of builtin ones, so changes made to them at runtime won't affect builtin styles when you return to design time.

See also

IContourStyleHolder.PopulateWithBuiltinStyles


IContourStylesheet.BaseStylesheet

IContourStylesheet.BaseStylesheet Property

IContourStylesheet Properties Methods

Returns/sets the parent stylesheet

Read-Write

Syntax

object.BaseStylesheet As IContourStylesheet

Parameters
object An object of type IContourStylesheet


IContourStylesheet.Edit

IContourStylesheet.Edit Method

IContourStylesheet Properties Methods

Shows the stylesheet editor

Syntax

object.Edit

Parameters
object An object of type IContourStylesheet


IContourStylesheet.Name

IContourStylesheet.Name Property

IContourStylesheet Properties Methods

Returns name of the stylesheet

Read-Only

Syntax

object.Name As String

Parameters
object An object of type IContourStylesheet


IContourStylesheet.PopulateWithStandardRules

IContourStylesheet.PopulateWithStandardRules Method

IContourStylesheet Properties Methods

Populates stylesheet with standard rules

Syntax

object.PopulateWithStandardRules

Parameters
object An object of type IContourStylesheet


IContourStylesheet.StatusTexts

IContourStylesheet.StatusTexts Property

IContourStylesheet Properties Methods

Returns/sets status texts collection for this stylesheet

Read-Write

Syntax

object.StatusTexts As IContourStatusTexts

Parameters
object An object of type IContourStylesheet


IContourStylesheet.StyleRules

IContourStylesheet.StyleRules Property

IContourStylesheet Properties Methods

Returns collection of style rules for this stylesheet

Read-Only

Syntax

object.StyleRules As IStyleRulesCollection

Parameters
object An object of type IContourStylesheet


IContourView.Active

IContourView.Active Property

IContourView Properties Methods

Setting Active to true sets Cube.Active to true and activates view.

Read-Write

Syntax

object.Active As Boolean

Parameters
object An object of type IContourView


IContourView.CancelFactSorting

IContourView.CancelFactSorting Method

IContourView Properties Methods

Cancel sorting by fact values.

Syntax

object.CancelFactSorting [ByVal Axis As TxDimAxis = -1]

Parameters
object | An object of type IContourView
[in] Axis | (Optional) A TxDimAxis value. Indicates cube axis, along which sorting by fact values should be cancelled.

This method cancels sorting of a grid row or column by fact values, which was previously set by SortByFact procedure.

Note

CancelFactSorting accepts only xda_Horizontal and xda_Vertical axis identifiers. Specifying any other TxDimAxis constant will generate an exception.

See also

IContourView.SortByFact


IContourView.Caption

IContourView.Caption Property

IContourView Properties Methods

Returns/sets Caption of this View

Read-Write

Syntax

object.Caption As String

Parameters
object An object of type IContourView


IContourView.CloneView

IContourView.CloneView Method

IContourView Properties Methods

Create new IContourView object.

Syntax

object.CloneView (ByVal HDepth As Integer , ByVal VDepth As Integer [, ByVal Persistent As Boolean = False]) As IContourView

Parameters
object | An object of type IContourView
[in] HDepth | (Required) A Integer value. Determines horizontal depth of the view. Setting it to -1 forces the maximum depth along this axis.
[in] VDepth | (Required) A Integer value. Determines vertical depth of the view. Setting it to -1 forces the maximum depth along this axis.
[in] Persistent | (Optional) A Boolean value. Defines whether the newly created view is persistent, i.e. whether it can be saved to a microcube file with IContourCube.Save method.

CloneView creates and returns a new instance of IContourView interface, which contains the same data and settings as the current one. This method allows you to create multiple views of one cube, which can then be used for charting and other purposes.

CloneView takes three parameters. In brief, you'll get the view that corresponds to the grid, whose drill down levels along horizontal and vertical axes are respectively equal to the first two CloneView parameter values. In other words, these parameters indicate the number of dimensions from ContourCube axes that should be taken in the view.

You can save to microcube file not only cube data and metadata, but also one ore more whole grid views. Then, you'll can load that microcube and easily switch between its views instead of executing various routines to set them up. The third parameter of CloneView function just determines whether the view can be saved to a microcube.

See also

IViewAxis.DrillDownLevel
IContourCube.Save


IContourView.Cube

IContourView.Cube Property

IContourView Properties Methods

Returns ContourCube

Read-Only

Syntax

object.Cube As IContourCube

Parameters
object An object of type IContourView


IContourView.Descending

IContourView.Descending Property

IContourView Properties Methods

Returns/sets whether dimensions use descending sort order

Read-Write

Syntax

object.Descending As Boolean

Parameters
object An object of type IContourView


IContourView.Dims

IContourView.Dims Property

IContourView Properties Methods

Returns a collection of dimensions

Read-Only

Syntax

object.Dims As IViewDims

Parameters
object An object of type IContourView


IContourView.EffectiveStylesheet

IContourView.EffectiveStylesheet Property

IContourView Properties Methods

Returns EffectiveStylesheet used in this View

Read-Only

Syntax

object.EffectiveStylesheet As IContourStylesheet

Parameters
object An object of type IContourView


IContourView.Facts

IContourView.Facts Property

IContourView Properties Methods

Returns a collection of facts

Read-Only

Syntax

object.Facts As IViewFacts

Parameters
object An object of type IContourView


IContourView.Fields

IContourView.Fields Property

IContourView Properties Methods

Returns an array of fields including facts and dimensions

Read-Only

Syntax

object.Fields As IFields

Parameters
object An object of type IContourView


IContourView.GetViewCell

IContourView.GetViewCell Method

IContourView Properties Methods

Returns Cell for given coordinates.

Syntax

object.GetViewCell (ByVal Col As Integer , ByVal Row As Integer) As IViewCell

Parameters
object | An object of type IContourView
[in] Col | (Required) A Integer value. Specifies horizontal cell coordinate.
[in] Row | (Required) A Integer value. Specifies vertical cell coordinate.

This method returns reference to the cell of the view by its coordinates. View cells are not grid cells; they are parts of invisible virtual grid represented by IContourView interface.
Use properties and methods of the returned IViewCell interface to get access to the cube data through code.

See also

IGridCell interface


IContourView.HAxis

IContourView.HAxis Property

IContourView Properties Methods

Returns horizontal ViewAxis

Read-Only

Syntax

object.HAxis As IViewAxis

Parameters
object An object of type IContourView


IContourView.NoGrandTotals

IContourView.NoGrandTotals Property

IContourView Properties Methods

Returns/sets whether view don't present grand totals

Read-Write

Syntax

object.NoGrandTotals As Boolean

Parameters
object An object of type IContourView


IContourView.NoTotals

IContourView.NoTotals Property

IContourView Properties Methods

Returns/sets whether view don't present totals

Read-Write

Syntax

object.NoTotals As Boolean

Parameters
object An object of type IContourView


IContourView.NULLValueString

IContourView.NULLValueString Property

IContourView Properties Methods

Returns/sets the NULLValueString.

Read-Write

Syntax

object.NULLValueString As String

Parameters
object An object of type IContourView


IContourView.SortViewByFact

IContourView.SortViewByFact Method

IContourView Properties Methods

Sort a view by fact values.

Syntax

object.SortViewByFact ByRef ViewFact As IViewFact , ByVal Direction As TxDimAxis , ByVal LineNum As Integer

Parameters
object | An object of type IContourView
[in] ViewFact | (Required) A IViewFact value.
[in] Direction | (Required) A TxDimAxis value.
[in] LineNum | (Required) A Integer value.


IContourView.Stylesheet

IContourView.Stylesheet Property

IContourView Properties Methods

Returns/sets Stylesheet used in this View

Read-Write

Syntax

object.Stylesheet As IContourStylesheet

Parameters
object An object of type IContourView


IContourView.Transposed

IContourView.Transposed Property

IContourView Properties Methods

Returns/sets the transposition status of the view wrt its slice. Setting Transposed to true causes rows and columns to swap their places (columns becomes rows and vice versa).

Read-Write

Syntax

object.Transposed As Boolean

Parameters
object An object of type IContourView


IContourView.VAxis

IContourView.VAxis Property

IContourView Properties Methods

Returns vertical ViewAxis

Read-Only

Syntax

object.VAxis As IViewAxis

Parameters
object An object of type IContourView


IContourView.VisibleFacts

IContourView.VisibleFacts Property

IContourView Properties Methods

Returns a collection of visible facts

Read-Only

Syntax

object.VisibleFacts As IViewFacts

Parameters
object An object of type IContourView


ICubeBaseFact.SourceAggregator

ICubeBaseFact.SourceAggregator Property

ICubeBaseFact Properties Methods

Returns/sets fact pregrouping algorithm

Read-Write

Syntax

object.SourceAggregator As TxDatasetAggrID

Parameters
object An object of type ICubeBaseFact


ICubeBaseFacts.Add

ICubeBaseFacts.Add Method

ICubeBaseFacts Properties Methods

Adds a new base fact.

Syntax

object.Add (ByVal FactName As String [, ByVal SourceName As String]) As ICubeBaseFact

Parameters
object | An object of type ICubeBaseFacts
[in] FactName | (Required) A String value. Specifies the name of this base fact.
[in] SourceName | (Optional) A String value. Specifies the data source field name this field should be created from.

Use Add method to add new items to the collection of ContourCube base facts. Base facts perform preliminary data aggregation from data source fields with specified algorithms. All other facts in ContourCube derive from them.

Note

Adding multiple base facts from one source field is not allowed.

See also

Using ContourCube: Facts


ICubeBaseFacts.Clear

ICubeBaseFacts.Clear Method

ICubeBaseFacts Properties Methods

Removes all base facts

Syntax

object.Clear

Parameters
object An object of type ICubeBaseFacts


ICubeBaseFacts.Count

ICubeBaseFacts.Count Property

ICubeBaseFacts Properties Methods

Returns number of objects in collection.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type ICubeBaseFacts


ICubeBaseFacts.Exists

ICubeBaseFacts.Exists Method

ICubeBaseFacts Properties Methods

Checks whether the base fact with given name exists

Syntax

object.Exists (ByVal FactName As String) As Boolean

Parameters
object | An object of type ICubeBaseFacts
[in] FactName | (Required) A String value. Name of the base fact to be checked.

This function returns True, if a base fact with given name exists in ContourCube base facts collection. Otherwise, it returns False.

Note

To add a new item to the collection of ContourCube base facts, use Add method.

See also

ICubeBaseFacts.Add


ICubeBaseFacts.Item

ICubeBaseFacts.Item Property

ICubeBaseFacts Properties Methods

Returns a base fact by its name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As ICubeBaseFact

Parameters
object | An object of type ICubeBaseFacts
[in] Index | (Required) A Variant value. Specifies fact name or zero-based index in the collection.

This property returns reference to the base fact from ContourCube collection by its name or index.

Note

If no facts with given name were found, the function throws an exception. Use Exists method to check if a base fact is present in the collection. To stay within collection bounds, see Count property.

See also
ICubeBaseFacts.Exists
ICubeBaseFacts.Count


ICubeDim.Axis

ICubeDim.Axis Property

ICubeDim Properties Methods

Returns axis of the dimension.

Read-Only

Syntax

object.Axis As TxDimAxis

Parameters
object An object of type ICubeDim


ICubeDim.DisallowMultipleValues

ICubeDim.DisallowMultipleValues Property

ICubeDim Properties Methods

Returns/sets whether Multiple Values are disallowed

Read-Write

Syntax

object.DisallowMultipleValues As Boolean

Parameters
object An object of type ICubeDim


ICubeDim.Filter

ICubeDim.Filter Method

ICubeDim Properties Methods

Filters dimension using given Operation

Syntax

object.Filter ByVal Operation As TxFilterOperation

Parameters
object | An object of type ICubeDim
[in] Operation | (Required) A TxFilterOperation value. Determines the operation to carry out.

Use this procedure to execute a common filter operation on a whole cube dimension (i.e. on all its members). For example, you can invert filter settings, so that all unfiltered members become filtered out and vice versa, or reset the filter.

Note

Execution of this method does not take effect until you commit it with Apply procedure of IDimsFilter interface obtained from IContourCube.DimensionsFilter property.

See also

IDimsFilter interface
IDimsFilter.Apply
IContourCube.DimensionsFilter


ICubeDim.FilterValue

ICubeDim.FilterValue Method

ICubeDim Properties Methods

Sets filter state for the given Value

Syntax

object.FilterValue ByVal Value As Variant , ByVal FilterOut As Boolean

Parameters
object | An object of type ICubeDim
[in] Value | (Required) A Variant value. Specifies the dimension value to be filtered.
[in] FilterOut | (Required) A Boolean value. Determines whether to hide (True) or show (False) the member.

This procedure shows or hides a single dimension member in ContourCube grid. A hidden member appears unchecked in the dimension filter drop-down list.

Note

Execution of this method does not take effect until you commit it with Apply procedure of IDimsFilter interface obtained from IContourCube.DimensionsFilter property.

See also

IDimsFilter interface
IDimsFilter.Apply
IContourCube.DimensionsFilter


ICubeDim.Format

ICubeDim.Format Property

ICubeDim Properties Methods

Returns/sets Format string

Read-Write

Syntax

object.Format As String

Parameters
object An object of type ICubeDim


ICubeDim.GetValues

ICubeDim.GetValues Method

ICubeDim Properties Methods

Return dimension values.

Syntax

object.GetValues ([ByVal FilterState As Integer = -1]) As IDimValues

Parameters
object | An object of type ICubeDim
[in] FilterState | (Optional) A Integer value. Determines the filter status of dimension values to be returned. Can be any combination (sum) of TxFilterState enum constants. The default value of this parameter is xfs_ALL.

GetValues returns collection of dimension members with given filter status.

Note

For mapped dimensions, this method returns their real values.

See also

ICubeDim.MapType
ICubeDim.Mapping
TxFilterState enum


ICubeDim.GetValueState

ICubeDim.GetValueState Method

ICubeDim Properties Methods

Returns filter state of the given Value.

Syntax

object.GetValueState (ByVal Value As Variant) As TxFilterState

Parameters
object | An object of type ICubeDim
[in] Value | (Required) A Variant value. Contains the dimension value. For mapped members, it must specify their real values.

Use GetValueState function to determine whether a single dimension member is visible, hidden, or filtered out.

Note

If the requested dimension value is hidden due to filter settings applied to upstanding dimensions, and at the same time is filtered out implicitly, this method returns xfs_FilteredOut.

To set up filter on a dimension, use Filter and FilterValue procedures as well as methods of IDimsFilter interface.

See also

ICubeDim.MapType
ICubeDim.Mapping
ICubeDim.Filter
ICubeDim.FilterValue
IDimsFilter interface


ICubeDim.HasFilter

ICubeDim.HasFilter Property

ICubeDim Properties Methods

Returns whether dimension has filter.

Read-Only

Syntax

object.HasFilter As Boolean

Parameters
object An object of type ICubeDim


ICubeDim.Mapping

ICubeDim.Mapping Property

ICubeDim Properties Methods

Returns dimension mapping object

Read-Only

Syntax

object.Mapping As IMapping

Parameters
object An object of type ICubeDim


ICubeDim.MapType

ICubeDim.MapType Property

ICubeDim Properties Methods

Specifies a mode of mapping dimension values into displayable strings

Read-Write

Syntax

object.MapType As TxDimValMapType

Parameters
object An object of type ICubeDim


ICubeDim.Modifier

ICubeDim.Modifier Property

ICubeDim Properties Methods

Returns Modifier

Read-Only

Syntax

object.Modifier As TxDimModifier

Parameters
object An object of type ICubeDim


ICubeDim.MoveTo

ICubeDim.MoveTo Method

ICubeDim Properties Methods

Moves dimension to the specified position on the specific axis.

Syntax

object.MoveTo ByVal Axis As TxDimAxis [, ByVal Pos As Integer = -1]

Parameters
object | An object of type ICubeDim
[in] Axis | (Required) A TxDimAxis value. Specifies the axis where the dimension should be moved to.
[in] Pos | (Optional) A Integer value. Specifies the position at the axis where the dimension should be moved to. By default, the dimension is placed at the last position on the axis.

Use this procedure to move a dimension to the specified position at the given view axis, outside or invisible dimensions area.
This operation is equivalent to the dimension dragging and dropping with mouse, and hits corresponding events:

  • BeforeMoveDimension - just before that the dimension is dropped onto target. Handling this event you can cancel the operation.
  • AfterMoveDimension - immediately after that the dimension is moved.
See also

BeforeMoveDimension event
AfterMoveDimension event


ICubeDim.Options

ICubeDim.Options Property

ICubeDim Properties Methods

Returns IDimOptions

Read-Only

Syntax

object.Options As IDimOptions

Parameters
object An object of type ICubeDim


ICubeDim.Pos

ICubeDim.Pos Property

ICubeDim Properties Methods

Returns dimension\ index in the list at the axis.

Read-Only

Syntax

object.Pos As Integer

Parameters
object An object of type ICubeDim


ICubeDims.Add

ICubeDims.Add Method

ICubeDims Properties Methods

Adds a new dimension

Syntax

object.Add (ByVal DimName As String [, ByVal SourceName As String] [, ByVal DataType As TxOLAPFieldType = 1] [, ByVal Axis As TxDimAxis = 0]) As ICubeDim

Parameters
object | An object of type ICubeDims
[in] DimName | (Required) A String value. Determines the name of this dimension. It must be unique through all cube fields, including base and calculated facts. This name is then used to reference the dimension from formulas and some procedures. By default, dimension gets the same name as its data source field.
[in] SourceName | (Optional) A String value. Specifies the data source field name this dimension should be based upon.
[in] DataType | (Optional) A TxOLAPFieldType value. Specifies data type that this dimension contains. Its default value is xoft_None (unknown type).
[in] Axis | (Optional) A TxDimAxis value. Specifies the axis or dimensions area where the new dimension should be placed. If the target already contains items, the dimension is placed at the end of the list.

Use Add method to declare cube dimensions and add them to the collection of ContourCube fields. It instantiates and returns reference to the newly created dimension, so you can use the returned interface to set up its additional parameters.

Note

The list of cube dimensions must be completed before the cube is activated. Therefore, this procedure should only be called when the IContourCube.Active property is False, otherwise, an error occurs. When the cube is activated, all fields loaded from the data source or microcube are bound to corresponding dimensions.

See also

IContourCube.Active
IContourView.Active


ICubeDims.AddCalculated

ICubeDims.AddCalculated Method

ICubeDims Properties Methods

Adds a calculated dimension

Syntax

object.AddCalculated (ByVal DimName As String [, ByVal Source As String] , ByVal Algorithm As TxDimModifier [, ByVal Axis As TxDimAxis = 0]) As ICubeDim

Parameters
object | An object of type ICubeDims
[in] DimName | (Required) A String value.
[in] Source | (Optional) A String value.
[in] Algorithm | (Required) A TxDimModifier value.
[in] Axis | (Optional) A TxDimAxis value.


ICubeDims.Clear

ICubeDims.Clear Method

ICubeDims Properties Methods

Removes all dimensions

Syntax

object.Clear

Parameters
object An object of type ICubeDims


ICubeDims.Count

ICubeDims.Count Property

ICubeDims Properties Methods

Returns number of objects in collection.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type ICubeDims


ICubeDims.Exists

ICubeDims.Exists Method

ICubeDims Properties Methods

Checks whether dimension with given name exists

Syntax

object.Exists (ByVal DimName As String) As Boolean

Parameters
object | An object of type ICubeDims
[in] DimName | (Required) A String value. Name of the dimension to be checked.

This function returns True, if a dimension with given name exists in ContourCube collection of dimensions. Otherwise, it returns False.

Note

To declare and add a new item to the ContourCube dimensions collection, use Add method.

See also

ICubeDims.Add


ICubeDims.Item

ICubeDims.Item Property

ICubeDims Properties Methods

Returns a dimension by its name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As ICubeDim

Parameters
object | An object of type ICubeDims
[in] Index | (Required) A Variant value. Specifies dimension name or its zero-based index in the collection.

This property returns reference to the dimension from ContourCube collection by its name or index.

Note

If no dimensions with given name were found, the function throws an exception. Use Exists method to check if a dimension is present in the collection. To stay within collection bounds, see Count property.

See also
ICubeDims.Exists
ICubeDims.Count


ICubeFact.Active

ICubeFact.Active Property

ICubeFact Properties Methods

Returns/sets Active

Read-Write

Syntax

object.Active As Boolean

Parameters
object An object of type ICubeFact


ICubeFact.Algorithm

ICubeFact.Algorithm Property

ICubeFact Properties Methods

Returns/sets an algorithm, used to calculate values of the fact.

Read-Write

Syntax

object.Algorithm As TxFactAlgorithm

Parameters
object An object of type ICubeFact


ICubeFact.CountLevel

ICubeFact.CountLevel Property

ICubeFact Properties Methods

Returns/sets CountLevel of the fact

Read-Write

Syntax

object.CountLevel As TxFactCountLevel

Parameters
object An object of type ICubeFact


ICubeFact.Formula

ICubeFact.Formula Property

ICubeFact Properties Methods

Returns/sets a formula, used to calculate values of the fact.

Read-Write

Syntax

object.Formula As String

Parameters
object An object of type ICubeFact


ICubeFact.GetDimAlgorithm

ICubeFact.GetDimAlgorithm Method

ICubeFact Properties Methods

Returns the fact aggregation method by dimension.

Syntax

object.GetDimAlgorithm (ByVal DimName As String) As TxFactAlgorithm

Parameters
object | An object of type ICubeFact
[in] DimName | (Required) A String value. Specifies name of the dimension, by which the fact calculation algorithm should be returned.

Use this method to obtain the fact calculation algorithm used to aggregate its values at the hierarchy level identified by dimension name.

Note

To set the fact calculation algorithm by dimension, use SetDimAlgorithm procedure.

See also

ICubeFact.SetDimAlgorithm


ICubeFact.IsFormula

ICubeFact.IsFormula Property

ICubeFact Properties Methods

returns true if the fact is a formula, or false if it is the modified or plain fact

Read-Only

Syntax

object.IsFormula As Boolean

Parameters
object An object of type ICubeFact


ICubeFact.IsModified

ICubeFact.IsModified Property

ICubeFact Properties Methods

returns true if this is a calculated fact and neither formula nor plain fact

Read-Only

Syntax

object.IsModified As Boolean

Parameters
object An object of type ICubeFact


ICubeFact.SetDimAlgorithm

ICubeFact.SetDimAlgorithm Method

ICubeFact Properties Methods

Sets the fact aggregation method by dimension.

Syntax

object.SetDimAlgorithm ByVal DimName As String , ByVal Algorithm As TxFactAlgorithm

Parameters
object | An object of type ICubeFact
[in] DimName | (Required) A String value. Specifies name of the dimension, by which the fact calculation algorithm should be set.
[in] Algorithm | (Required) A TxFactAlgorithm value. Specifies the algorithm ID to be set for this fact.

Use this method to obtain the fact calculation algorithm used to aggregate its values at the hierarchy level identified by dimension name. It allows you to override default algorithms set up on fact declaration, this way using multiple calculation algorithms for one fact simultaneously.

Example
In a cube with dimensioins "Year" (1) and "City" (2) at one axis, and fact "Sales" with SUM aggregator, the following code forces the fact to use MAX algorithm by dimension "Year":

[Visual Basic]
MyContourCubeX.Cube.Facts.Item("Sales").SetDimAlgorithm "Year", xfaa_MAX

After having executed this code, you'll see sums of fact values in the Totals of dimension "City", and their maximum in the Totals of dimension "Year".

Note

You must use fact calculation algorithms of the same kind as the fact was declared with: aggregators for Primary facts, and modifiers for Secondary facts. Otherwise, the method will throw an exception.

To get the fact calculation algorithm by dimension, use GetDimAlgorithm method.

See also

Using ContourCube: Facts
ICubeFact.GetDimAlgorithm


ICubeFacts.Active

ICubeFacts.Active Property

ICubeFacts Properties Methods

Returns/sets Active

Read-Write

Syntax

object.Active As Boolean

Parameters
object An object of type ICubeFacts


ICubeFacts.Add

ICubeFacts.Add Method

ICubeFacts Properties Methods

Adds a new fact of arbitrary type.

Syntax

object.Add (ByVal FactName As String [, ByVal Source As String] [, ByVal Algorithm As TxFactAlgorithm = 1]) As ICubeFact

Parameters
object | An object of type ICubeFacts
[in] FactName | (Required) A String value. Specifies name of this fact. It must be unique through all cube fields, including dimensions, base and calculated facts. This name is then used to reference the fact from formulas and some procedures. By default, fact gets the same name as its data source field.
[in] Source | (Optional) A String value. Identifies data source for this fact. For Primary calculated facts, it must be name of a cube base fact; for Secondary calculated ones - name of another similar fact. If this fact is formula-based, this parameter must contain the formula text.
[in] Algorithm | (Optional) A TxFactAlgorithm value. Determines default fact calculation algorithm. For Primary calculated facts, it must be an aggregator ID; for Secondary calculated ones - a modifier ID. If this fact is formula-based, this parameter must be set to xfam_FORMULA.

Use Add method to declare cube facts and add them to the collection of ContourCube fields. It instantiates and returns reference to the newly created cube fact, so you can use the returned interface to set up its additional parameters, and adds corresponding item to the collection of view facts.

Note

You can add facts to the cube even when it is active. By default, newly created facts are invisible in the grid; set Visible property of the corresponding view facts to True if you want to show them.

See also

IViewFacts interface
ICubeBaseFact interface
IViewFact.Visible
Using ContourCube: Facts


ICubeFacts.AddFormula

ICubeFacts.AddFormula Method

ICubeFacts Properties Methods

Adds a new formula-specified fact.

Syntax

object.AddFormula (ByVal FactName As String , ByVal Formula As String) As ICubeFact

Parameters
object | An object of type ICubeFacts
[in] FactName | (Required) A String value.
[] Formula | (Required) A String value.


ICubeFacts.Clear

ICubeFacts.Clear Method

ICubeFacts Properties Methods

Removes all facts

Syntax

object.Clear

Parameters
object An object of type ICubeFacts


ICubeFacts.Count

ICubeFacts.Count Property

ICubeFacts Properties Methods

Returns number of objects in collection.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type ICubeFacts


ICubeFacts.Exists

ICubeFacts.Exists Method

ICubeFacts Properties Methods

Checks whether fact with given name exists

Syntax

object.Exists (ByVal f_name As String) As Boolean

Parameters
object | An object of type ICubeFacts
[in] f_name | (Required) A String value. Name of the fact to be checked.

This function returns True, if a fact with given name exists in ContourCube collection of facts. Otherwise, it returns False.

Note

To declare and add a new item to the ContourCube facts collection, use Add method.

See also

ICubeFacts.Add


ICubeFacts.Item

ICubeFacts.Item Property

ICubeFacts Properties Methods

Returns ICubeFact by name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As ICubeFact

Parameters
object | An object of type ICubeFacts
[in] Index | (Required) A Variant value. Specifies fact name or its zero-based index in the collection.

This property returns reference to the fact from ContourCube collection by its name or index.

Note

If no facts with given name were found, the function throws an exception. Use Exists method to check if a fact is present in the collection. To stay within collection bounds, see Count property.

See also
ICubeFacts.Exists
ICubeFacts.Count


ICubeField.Delete

ICubeField.Delete Method

ICubeField Properties Methods

Deletes field

Syntax

object.Delete

Parameters
object An object of type ICubeField


ICubeField.FieldType

ICubeField.FieldType Property

ICubeField Properties Methods

Returns Type of the Field in datasource

Read-Only

Syntax

object.FieldType As TxOLAPFieldType

Parameters
object An object of type ICubeField


ICubeField.SrcName

ICubeField.SrcName Property

ICubeField Properties Methods

Returns Name of the Field in datasource

Read-Only

Syntax

object.SrcName As String

Parameters
object An object of type ICubeField


ICubeFields.Count

ICubeFields.Count Property

ICubeFields Properties Methods

Returns number of objects in collection.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type ICubeFields


ICubeFields.Exists

ICubeFields.Exists Method

ICubeFields Properties Methods

Checks whether field with given name exists

Syntax

object.Exists (ByVal FieldName As String) As Boolean

Parameters
object | An object of type ICubeFields
[in] FieldName | (Required) A String value. Name of the field to be checked.

This function returns True, if a field with given name exists in ContourCube collection of fields. Otherwise, it returns False.

Note

To declare and add a new item to the ContourCube fields collection, use Add methods of ICubeDims or ICubeFacts collections.
To check whether this field is fact or not, use to IsFact property.

See also

ICubeDims.Add
ICubeFacts.Add
IField.IsFact


ICubeFields.Item

ICubeFields.Item Property

ICubeFields Properties Methods

Returns ICubeField (ICubeDim or ICubeFact) by name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As ICubeField

Parameters
object | An object of type ICubeFields
[in] Index | (Required) A Variant value. Specifies field name or its zero-based index in the collection.

This property returns reference to the field from ContourCube collection by its name or index.

Note

If no fields with given name were found, the function throws an exception. Use Exists method to check if a field is present in the collection. To stay within collection bounds, see Count property.

See also
ICubeFields.Exists
ICubeFields.Count


ICubeFooter.BkColor

ICubeFooter.BkColor Property

ICubeFooter Properties Methods

Specifies background color of the header (footer)

Read-Write

Syntax

object.BkColor As Integer

Parameters
object An object of type ICubeFooter


ICubeFooter.Edit

ICubeFooter.Edit Method

ICubeFooter Properties Methods

Shows header / footer editor

Syntax

object.Edit

Parameters
object An object of type ICubeFooter


ICubeFooter.Height

ICubeFooter.Height Property

ICubeFooter Properties Methods

Specifies height of the header (footer)

Read-Write

Syntax

object.Height As Integer

Parameters
object An object of type ICubeFooter


ICubeFooter.Text

ICubeFooter.Text Property

ICubeFooter Properties Methods

Specifies the text displayed in header (footer)

Read-Write

Syntax

object.Text As String

Parameters
object An object of type ICubeFooter


ICubeFooter.UseOnExport

ICubeFooter.UseOnExport Property

ICubeFooter Properties Methods

Specifies whether the header (footer) is exported with the report

Read-Write

Syntax

object.UseOnExport As Boolean

Parameters
object An object of type ICubeFooter


ICubeFooter.Visible

ICubeFooter.Visible Property

ICubeFooter Properties Methods

Shows/hides the header (footer)

Read-Write

Syntax

object.Visible As Boolean

Parameters
object An object of type ICubeFooter


ICubeHeader.AboveTitle

ICubeHeader.AboveTitle Property

ICubeHeader Properties Methods

Returns/sets whether the header is displayed above the cube title

Read-Write

Syntax

object.AboveTitle As Boolean

Parameters
object An object of type ICubeHeader


IDimFilterSettings.AllowFilter

IDimFilterSettings.AllowFilter Property

IDimFilterSettings Properties

Returns/sets whether DimFilter Allowed or not.

Read-Write

Syntax

object.AllowFilter As Boolean

Parameters
object An object of type IDimFilterSettings


IDimFilterSettings.ShowHiddenValues

IDimFilterSettings.ShowHiddenValues Property

IDimFilterSettings Properties

Returns/sets whether Hidden Values should be shown or not

Read-Write

Syntax

object.ShowHiddenValues As Boolean

Parameters
object An object of type IDimFilterSettings


IDimOptions.ban_horizontal_pos

IDimOptions.ban_horizontal_pos Property

IDimOptions Properties

Returns/sets ban_horizontal_pos

Read-Write

Syntax

object.ban_horizontal_pos As Boolean

Parameters
object An object of type IDimOptions


IDimOptions.ban_outside_pos

IDimOptions.ban_outside_pos Property

IDimOptions Properties

Returns/sets ban_outside_pos

Read-Write

Syntax

object.ban_outside_pos As Boolean

Parameters
object An object of type IDimOptions


IDimOptions.ban_vertical_pos

IDimOptions.ban_vertical_pos Property

IDimOptions Properties

Returns/sets ban_vertical_pos

Read-Write

Syntax

object.ban_vertical_pos As Boolean

Parameters
object An object of type IDimOptions


IDimsFilter.Apply

IDimsFilter.Apply Method

IDimsFilter Properties Methods

Commits filtering transaction

Syntax

object.Apply

Parameters
object An object of type IDimsFilter


IDimsFilter.Cancel

IDimsFilter.Cancel Method

IDimsFilter Properties Methods

Cancels filtering transaction

Syntax

object.Cancel

Parameters
object An object of type IDimsFilter


IDimsFilter.DisallowMultipleValues

IDimsFilter.DisallowMultipleValues Method

IDimsFilter Properties Methods

Sets whether Multiple Values for the given dimension will be disallowed

Syntax

object.DisallowMultipleValues ByVal DimName As String , ByVal Disallow As Boolean

Parameters
object | An object of type IDimsFilter
[in] DimName | (Required) A String value. Specifies name of the dimension this operation should be applied to.
[in] Disallow | (Required) A Boolean value. Determines whether to allow (False) or deny (True) selection of multiple values for this dimension.

This method allows you to set up whether user can select multiple values in the dimension filter list. Using it is useful when ContourCube control is active; on the inactive cube, you can also set ICubeDim.DisallowMultipleValues property.

Note

Execution of this method does not take effect until you commit it with Apply procedure.

Example

[Visual Basic]
With MyContourCube.Cube.DimensionsFilter
  .DisallowMultipleValues "MyDim", True
  .Apply
End With
'Now only one member of MyDim can be visible at once.
'Items of its filter drop-down list became radio buttons.

See also

IContourView.Active
ICubeDim.DisallowMultipleValues
IDimsFilter.Apply


IDimsFilter.FilterAll

IDimsFilter.FilterAll Method

IDimsFilter Properties Methods

Sets filter state for all values of the given dimension

Syntax

object.FilterAll ByVal DimName As String , ByVal FilterOperation As TxFilterOperation

Parameters
object | An object of type IDimsFilter
[in] DimName | (Required) A String value. Specifies name of the dimension the operation should be applied to.
[in] FilterOperation | (Required) A TxFilterOperation value. Determines whether to hide (True) or show (False) all members of the dimension.

Use this procedure to filter out or show all members of the given dimension. The same action can also be carried out with ICubeDim.Filter method.

Note

Execution of this method does not take effect until you commit it with Apply procedure.
To filter out / in a single dimension value, use FilterValue method.

See also

ICubeDim.Filter
IDimsFilter.Apply
IDimsFilter.FilterValue


IDimsFilter.FilterValue

IDimsFilter.FilterValue Method

IDimsFilter Properties Methods

Sets filter state for the given Value of given Dimension

Syntax

object.FilterValue ByVal DimName As String , ByVal Value As Variant , ByVal FilterOut As Boolean

Parameters
object | An object of type IDimsFilter
[in] DimName | (Required) A String value. Name of the dimension this operation should be applied to.
[in] Value | (Required) A Variant value. Specifies the dimension value to be filtered.
[in] FilterOut | (Required) A Boolean value. Determines whether to hide (True) or show (False) the member.

This procedure shows or hides a single dimension member in ContourCube grid. A hidden member appears unchecked in the dimension filter drop-down list. You can also use similar method of ICubeDim interface for that.

Note

Execution of this method does not take effect until you commit it with Apply procedure.

See also

ICubeDim.FilterValue
IDimsFilter.Apply


IDimsFilter.GetValueState

IDimsFilter.GetValueState Method

IDimsFilter Properties Methods

Returns filter state for the given DimValue of given Dimension

Syntax

object.GetValueState (ByVal DimName As String , ByVal Value As Variant) As TxFilterState

Parameters
object | An object of type IDimsFilter
[in] DimName | (Required) A String value. Name of the dimension, whose member's state should be returned.
[in] Value | (Required) A Variant value. Contains the dimension value. For mapped members, it must specify their real values.

Use GetValueState function to determine whether a single dimension member is visible, hidden, or filtered out. You can also use similar method of ICubeDim interface for that.

Note

If the requested dimension value is hidden due to filter settings applied to upstanding dimensions, and at the same time is filtered out implicitly, this method returns xfs_FilteredOut.

To set up filter on a dimension, use FilterAll and FilterValue procedures as well as similar methods of ICubeDimr interface.

See also

IDimsFilter.FilterAll
IDimsFilter.FilterValue
ICubeDim.GetValueState
ICubeDim.MapType
ICubeDim.Mapping


IDimsFilter.Reset

IDimsFilter.Reset Method

IDimsFilter Properties Methods

Resets filter

Syntax

object.Reset

Parameters
object An object of type IDimsFilter


IDimsFilter.Updating

IDimsFilter.Updating Property

IDimsFilter Properties Methods

Returns whether the dimension filter is being updated

Read-Only

Syntax

object.Updating As Boolean

Parameters
object An object of type IDimsFilter


IDimValues.Count

IDimValues.Count Property

IDimValues Properties

Returns number of objects in the collection.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type IDimValues


IDimValues.FilterState

IDimValues.FilterState Property

IDimValues Properties

Returns filter state of the dimension values.

Read-Only

Syntax

object.FilterState As Integer

Parameters
object An object of type IDimValues


IDimValues.Item

IDimValues.Item Property

IDimValues Properties

Returns dimension value by index.

Read-Only

Syntax

object.Item (ByVal Index As Integer) As Variant

Parameters
object | An object of type IDimValues
[in] Index | (Required) A Integer value. Specifies zero-based integer index of the member in the collection.

Use this property to get a dimension value from IDimValues collection. It returns a Variant value of the dimension member by its index in the collection.

Note

IDimValues collection is returned by ICubeDim.GetValues method. To stay within collection bounds, use Count property.

See also

ICubeDim.GetValues
IDimValues.Count


IFactsHeadingSettings.AlwaysVisible

IFactsHeadingSettings.AlwaysVisible Property

IFactsHeadingSettings Properties

Returns/sets whether Facts Headings are always visible or not.

Read-Write

Syntax

object.AlwaysVisible As Boolean

Parameters
object An object of type IFactsHeadingSettings


IFactsListSettings.AllowFilter

IFactsListSettings.AllowFilter Property

IFactsListSettings Properties

Returns/sets whether Filter is allowed or not.

Read-Write

Syntax

object.AllowFilter As Boolean

Parameters
object An object of type IFactsListSettings


IFactsListSettings.Caption

IFactsListSettings.Caption Property

IFactsListSettings Properties

Returns/sets FactsList Caption

Read-Write

Syntax

object.Caption As String

Parameters
object An object of type IFactsListSettings


IFactsListSettings.ListInactiveFacts

IFactsListSettings.ListInactiveFacts Property

IFactsListSettings Properties

Returns/sets whether to show inactive facts in the Facts Filter

Read-Write

Syntax

object.ListInactiveFacts As Boolean

Parameters
object An object of type IFactsListSettings


IFactsListSettings.ShowBitmap

IFactsListSettings.ShowBitmap Property

IFactsListSettings Properties

Returns/sets whether to Show Bitmap on the FactsList or not

Read-Write

Syntax

object.ShowBitmap As Boolean

Parameters
object An object of type IFactsListSettings


IField.Caption

IField.Caption Property

IField Properties

Returns/sets Field caption

Read-Write

Syntax

object.Caption As String

Parameters
object An object of type IField


IField.IsFact

IField.IsFact Property

IField Properties

Returns value that determines whether this Field is Fact or not

Read-Only

Syntax

object.IsFact As Boolean

Parameters
object An object of type IField


IField.Name

IField.Name Property

IField Properties

Returns Name of the Field

Read-Only

Syntax

object.Name As String

Parameters
object An object of type IField


IFields.Count

IFields.Count Property

IFields Properties Methods

Returns number of objects in collection.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type IFields


IFields.Exists

IFields.Exists Method

IFields Properties Methods

Checks whether field with given name exists

Syntax

object.Exists (ByVal FieldName As String) As Boolean

Parameters
object | An object of type IFields
[in] FieldName | (Required) A String value. Name of the field to be checked.

This function returns True, if a field with given name exists in the collection of view fields. Otherwise, it returns False.

Note

You can't add items to this collection - they are appended automatically when you call Add methods of ICubeDims or ICubeFacts interfaces.
To check whether this field is fact or not, use to IsFact property.

See also

ICubeDims.Add
ICubeFacts.Add
IField.IsFact


IFields.Item

IFields.Item Property

IFields Properties Methods

Returns IField (IViewDim or IViewFact) by name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As IField

Parameters
object | An object of type IFields
[in] Index | (Required) A Variant value. Specifies field name or its zero-based index in the collection.

This property returns reference to the field from view collection by its name or index.

Note

If no fields with given name were found, the function throws an exception. Use Exists method to check if a field is present in the collection. To stay within collection bounds, see Count property.

See also
IFields.Exists
IFields.Count


IFormulaStyleRule.Formula

IFormulaStyleRule.Formula Property

IFormulaStyleRule Properties Methods

Returns/sets Formula used in condition

Read-Write

Syntax

object.Formula As String

Parameters
object An object of type IFormulaStyleRule


IFormulaStyleRule.StatusMax

IFormulaStyleRule.StatusMax Property

IFormulaStyleRule Properties Methods

Returns/sets StatusMax

Read-Write

Syntax

object.StatusMax As Integer

Parameters
object An object of type IFormulaStyleRule


IFormulaStyleRule.StatusMin

IFormulaStyleRule.StatusMin Property

IFormulaStyleRule Properties Methods

Returns/sets StatusMin

Read-Write

Syntax

object.StatusMin As Integer

Parameters
object An object of type IFormulaStyleRule


IGridArea.Axis

IGridArea.Axis Property

IGridArea Properties

Returns GridAxis if this area is located on the axis area

Read-Only

Syntax

object.Axis As IGridAxis

Parameters
object An object of type IGridArea


IGridArea.Col

IGridArea.Col Property

IGridArea Properties

Returns grid column if this area is a data cell

Read-Only

Syntax

object.Col As Integer

Parameters
object An object of type IGridArea


IGridArea.Dim

IGridArea.Dim Property

IGridArea Properties

Returns Dimension if this area is located on the dimension area

Read-Only

Syntax

object.Dim As IViewDim

Parameters
object An object of type IGridArea


IGridArea.Fact

IGridArea.Fact Property

IGridArea Properties

Returns Fact if this area is located on the fact area

Read-Only

Syntax

object.Fact As IGridFact

Parameters
object An object of type IGridArea


IGridArea.Frame

IGridArea.Frame Property

IGridArea Properties

Returns frame type of this area

Read-Only

Syntax

object.Frame As TxContourFrame

Parameters
object An object of type IGridArea


IGridArea.FrameRect

IGridArea.FrameRect Property

IGridArea Properties

Returns a rectangle covered by this area frame

Read-Only

Syntax

object.FrameRect As IContourRect

Parameters
object An object of type IGridArea


IGridArea.Index

IGridArea.Index Property

IGridArea Properties

Returns section index if this area is an axis section

Read-Only

Syntax

object.Index As Integer

Parameters
object An object of type IGridArea


IGridArea.Item

IGridArea.Item Property

IGridArea Properties

Returns item type of this area

Read-Only

Syntax

object.Item As TxContourGridItem

Parameters
object An object of type IGridArea


IGridArea.ItemRect

IGridArea.ItemRect Property

IGridArea Properties

Returns a rectangle covered by this area item

Read-Only

Syntax

object.ItemRect As IContourRect

Parameters
object An object of type IGridArea


IGridArea.ItemVisibleRect

IGridArea.ItemVisibleRect Property

IGridArea Properties

Returns visible part of a rectangle covered by this area item

Read-Only

Syntax

object.ItemVisibleRect As IContourRect

Parameters
object An object of type IGridArea


IGridArea.Level

IGridArea.Level Property

IGridArea Properties

Returns section level if this area is an axis section

Read-Only

Syntax

object.Level As Integer

Parameters
object An object of type IGridArea


IGridArea.Row

IGridArea.Row Property

IGridArea Properties

Returns grid row if this area is a data cell

Read-Only

Syntax

object.Row As Integer

Parameters
object An object of type IGridArea


IGridAxis.Axis

IGridAxis.Axis Property

IGridAxis Properties Methods

Returns type of the Axis

Read-Only

Syntax

object.Axis As TxDimAxis

Parameters
object An object of type IGridAxis


IGridAxis.AxisStart

IGridAxis.AxisStart Property

IGridAxis Properties Methods

Returns/sets number of the first visible section at the axis

Read-Write

Syntax

object.AxisStart As Integer

Parameters
object An object of type IGridAxis


IGridAxis.CellsPerSection

IGridAxis.CellsPerSection Property

IGridAxis Properties Methods

Returns the number of cells per section

Read-Only

Syntax

object.CellsPerSection As Integer

Parameters
object An object of type IGridAxis


IGridAxis.FirstCell

IGridAxis.FirstCell Property

IGridAxis Properties Methods

Returns/sets number of the first visible cell at the axis

Read-Write

Syntax

object.FirstCell As Integer

Parameters
object An object of type IGridAxis


IGridAxis.GetSectionStart

IGridAxis.GetSectionStart Method

IGridAxis Properties Methods

Returns coordinate (in pixels) of the visible axis starting point

Syntax

object.GetSectionStart (ByVal Index As Integer) As Integer

Parameters
object | An object of type IGridAxis
[in] Index | (Required) A Integer value. Grid axis section index, whose beginning should be returned.

This function returns the meaning coordinate (in pixels) of the beginning of a grid axis section, given by its index. Grid axis sections are in fact grid columns for horizontal and rows for vertical axis, so you can identify these terms with each other.

Note

The meaning coordinate is the Y coordinate for the vertical axis, or X for the horizontal one.

See also

IAxisSection interface


IGridAxis.GetViewSection

IGridAxis.GetViewSection Method

IGridAxis Properties Methods

Returns underlaying view section by its axis index

Syntax

object.GetViewSection (ByVal GridAxisIndex As Integer) As IAxisSection

Parameters
object | An object of type IGridAxis
[in] GridAxisIndex | (Required) A Integer value. Zero-based index of a row or column, for which the axis section should be returned.

This method returns interface to the view axis section with specified number. It acts almost similarly to IViewAxis.GetSection function, but takes the grid axis index (row / column number) instead of section number as parameter, which allows you to retrieve sections directly "from what you see".

Note

Visually, sections are counted from left to right for horizontal, and from up to down for vertical axis.

See also

IGridAxis.Length
IViewAxis.GetSection
IAxisSection interface


IGridAxis.Length

IGridAxis.Length Property

IGridAxis Properties Methods

Returns number of cells at the axis

Read-Only

Syntax

object.Length As Integer

Parameters
object An object of type IGridAxis


IGridAxis.ViewAxis

IGridAxis.ViewAxis Property

IGridAxis Properties Methods

Returns ViewAxis corresponding to this grid axis

Read-Only

Syntax

object.ViewAxis As IViewAxis

Parameters
object An object of type IGridAxis


IGridAxis.Width

IGridAxis.Width Property

IGridAxis Properties Methods

Returns number of dimensions at the axis

Read-Only

Syntax

object.Width As Integer

Parameters
object An object of type IGridAxis


IGridCell.CellType

IGridCell.CellType Property

IGridCell Properties Methods

Gets the cell type (i.e. whether the cell is total, grandtotal, etc.)

Read-Only

Syntax

object.CellType As TxCellType

Parameters
object An object of type IGridCell


IGridCell.Col

IGridCell.Col Property

IGridCell Properties Methods

Gets the cell column in grid coordinates

Read-Only

Syntax

object.Col As Integer

Parameters
object An object of type IGridCell


IGridCell.Datapoint

IGridCell.Datapoint Property

IGridCell Properties Methods

Gets the datapoint corresponding to the cell

Read-Only

Syntax

object.Datapoint As IContourDatapoint

Parameters
object An object of type IGridCell


IGridCell.DisplayText

IGridCell.DisplayText Property

IGridCell Properties Methods

Gets the display text of the cell

Read-Only

Syntax

object.DisplayText As String

Parameters
object An object of type IGridCell


IGridCell.Fact

IGridCell.Fact Property

IGridCell Properties Methods

Gets the fact object of a cell

Read-Only

Syntax

object.Fact As IGridFact

Parameters
object An object of type IGridCell


IGridCell.IsValid

IGridCell.IsValid Method

IGridCell Properties Methods

Returns True if the cell contains valid data

Syntax

object.IsValid () As Boolean

Parameters
object An object of type IGridCell


IGridCell.IsValidCoordinates

IGridCell.IsValidCoordinates Method

IGridCell Properties Methods

Returns True if the cell has valid coordinates

Syntax

object.IsValidCoordinates () As Boolean

Parameters
object An object of type IGridCell


IGridCell.Rect

IGridCell.Rect Property

IGridCell Properties Methods

Gets the cell rectangle with respect to the grid client area

Read-Only

Syntax

object.Rect As IContourRect

Parameters
object An object of type IGridCell


IGridCell.Row

IGridCell.Row Property

IGridCell Properties Methods

Gets the cell row in grid coordinates

Read-Only

Syntax

object.Row As Integer

Parameters
object An object of type IGridCell


IGridCell.Style

IGridCell.Style Property

IGridCell Properties Methods

Returns the effective style for the cell

Read-Only

Syntax

object.Style As IContourStyle

Parameters
object An object of type IGridCell


IGridCell.Value

IGridCell.Value Property

IGridCell Properties Methods

Gets the cell value

Read-Only

Syntax

object.Value As Float

Parameters
object An object of type IGridCell


IGridCell.ViewCell

IGridCell.ViewCell Property

IGridCell Properties Methods

Gets the view cell corresponding to this grid cell

Read-Only

Syntax

object.ViewCell As IViewCell

Parameters
object An object of type IGridCell


IGridCell.ViewCol

IGridCell.ViewCol Property

IGridCell Properties Methods

Gets the cell column in coordinates of the underlying view

Read-Only

Syntax

object.ViewCol As Integer

Parameters
object An object of type IGridCell


IGridCell.ViewRow

IGridCell.ViewRow Property

IGridCell Properties Methods

Gets the cell row in coordinates of the underlying view

Read-Only

Syntax

object.ViewRow As Integer

Parameters
object An object of type IGridCell


IGridElementStyle.BkColor

IGridElementStyle.BkColor Property

IGridElementStyle Properties

Returns/sets background color

Read-Write

Syntax

object.BkColor As Integer

Parameters
object An object of type IGridElementStyle


IGridElementStyle.FontColor

IGridElementStyle.FontColor Property

IGridElementStyle Properties

Returns/sets the font color

Read-Write

Syntax

object.FontColor As Integer

Parameters
object An object of type IGridElementStyle


IGridElementStyle.StyleFont

IGridElementStyle.StyleFont Property

IGridElementStyle Properties

Returns/sets the font used in this style.

Read-Write

Syntax

object.StyleFont As Font

Parameters
object An object of type IGridElementStyle


IGridFact.AutoWidth

IGridFact.AutoWidth Property

IGridFact Properties Methods

Returns/sets whether fact width should be calculated by grid

Read-Write

Syntax

object.AutoWidth As Boolean

Parameters
object An object of type IGridFact


IGridFact.MinWidth

IGridFact.MinWidth Property

IGridFact Properties Methods

Returns/sets minimal width of fact column

Read-Write

Syntax

object.MinWidth As Integer

Parameters
object An object of type IGridFact


IGridFact.Width

IGridFact.Width Property

IGridFact Properties Methods

Returns/sets Width of fact column

Read-Write

Syntax

object.Width As Integer

Parameters
object An object of type IGridFact


IMapping.Add

IMapping.Add Method

IMapping Properties Methods

Adds new ValueMapping to Mapping list

Syntax

object.Add ByVal Key As String , ByVal Value As String

Parameters
object | An object of type IMapping
[in] Key | (Required) A String value. The real value of the dimension member to be mapped.
[in] Value | (Required) A String value. It will be displayed in place of the real value specified in first parameter.

Use Add method to declare dimension value mappings and add them to the IMapping collection.

Note

You must set MapType property of this dimension to xdmt_user before using this procedure. Otherwise, ContourCube will generate an exception. After setting up the dimension mapping type to user-defined, all unmapped values will appear as blanks. To avoid this "side effect", handle OnDimMapping event.

Dimension value mapping does not affect the result of procedures and functions taking or returning dimension members: they mostly work with real values.

See also

ICubeDim.MapType
OnDimMapping event


IMapping.Clear

IMapping.Clear Method

IMapping Properties Methods

Clears ValueMapping

Syntax

object.Clear

Parameters
object An object of type IMapping


IMapping.Count

IMapping.Count Property

IMapping Properties Methods

Returns number of ValueMappings

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type IMapping


IMapping.Exists

IMapping.Exists Method

IMapping Properties Methods

Returns whether ValueMapping for Value exists

Syntax

object.Exists (ByVal Key As String) As Boolean

Parameters
object | An object of type IMapping
[in] Key | (Required) A String value. The real dimension value, whose mapping is being looked for.

This function returns True, if a mapping for given dimension value exists in the dimension's Mapping collection. Otherwise, it returns False.

Note

To declare and add a new item to the mappings collection, use Add method.

See also

IMapping.Add


IMapping.Item

IMapping.Item Property

IMapping Properties Methods

Returns IValueMapping by real_value.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As IValueMapping

Parameters
object | An object of type IMapping
[in] Index | (Required) A Variant value. The real dimension value, whose mapping should be returned.

This property returns reference to the dimension value mapping interface from the collection by real dimension value.

Note

If no items were found, the function throws an exception. Use Exists method to check if a mapping is present in the collection. To stay within collection bounds, see Count property.

See also
IMapping.Exists
IMapping.Count


IMapping.Keys

IMapping.Keys Property

IMapping Properties Methods

Returns Keys

Read-Only

Syntax

object.Keys As Variant

Parameters
object An object of type IMapping


IMicrocube.Bound

IMicrocube.Bound Property

IMicrocube Properties Methods

Returns whether data from microcube is bound to ContourCubeX

Read-Only

Syntax

object.Bound As Boolean

Parameters
object An object of type IMicrocube


IMicrocube.Error

IMicrocube.Error Property

IMicrocube Properties Methods

Returns message describing an occured error

Read-Only

Syntax

object.Error As String

Parameters
object An object of type IMicrocube


IMicrocube.GetSliceNames

IMicrocube.GetSliceNames Method

IMicrocube Properties Methods

Returns names of slices in the loaded microcube

Syntax

object.GetSliceNames () As Variant

Parameters
object An object of type IMicrocube


IMicrocube.GetViewNames

IMicrocube.GetViewNames Method

IMicrocube Properties Methods

Returns names of views attached to the given slice in the loaded microcube

Syntax

object.GetViewNames (ByVal SliceName As String) As Variant

Parameters
object | An object of type IMicrocube
[in] SliceName | (Required) A String value.


IMicrocube.Loading

IMicrocube.Loading Property

IMicrocube Properties Methods

Returns TRUE if data loading in process

Read-Only

Syntax

object.Loading As Boolean

Parameters
object An object of type IMicrocube


IMicrocube.StopLoading

IMicrocube.StopLoading Method

IMicrocube Properties Methods

Stops loading data

Syntax

object.StopLoading

Parameters
object An object of type IMicrocube


IMicrocube.Valid

IMicrocube.Valid Property

IMicrocube Properties Methods

Returns whether microcube is valid

Read-Only

Syntax

object.Valid As Boolean

Parameters
object An object of type IMicrocube


IMicrocube.Wait4Loading

IMicrocube.Wait4Loading Method

IMicrocube Properties Methods

Waits while cube is loading

Syntax

object.Wait4Loading

Parameters
object An object of type IMicrocube


IRangeStyleRule.LowerBound

IRangeStyleRule.LowerBound Property

IRangeStyleRule Properties Methods

Returns/sets LowerBound of the range

Read-Write

Syntax

object.LowerBound As Float

Parameters
object An object of type IRangeStyleRule


IRangeStyleRule.LowerBoundIncluded

IRangeStyleRule.LowerBoundIncluded Property

IRangeStyleRule Properties Methods

Returns/sets whether range includes LowerBound

Read-Write

Syntax

object.LowerBoundIncluded As Boolean

Parameters
object An object of type IRangeStyleRule


IRangeStyleRule.UpperBound

IRangeStyleRule.UpperBound Property

IRangeStyleRule Properties Methods

Returns/sets UpperBound of the range

Read-Write

Syntax

object.UpperBound As Float

Parameters
object An object of type IRangeStyleRule


IRangeStyleRule.UpperBoundIncluded

IRangeStyleRule.UpperBoundIncluded Property

IRangeStyleRule Properties Methods

Returns/sets whether range includes UpperBound

Read-Write

Syntax

object.UpperBoundIncluded As Boolean

Parameters
object An object of type IRangeStyleRule


IRankStyleRule.RankDown

IRankStyleRule.RankDown Property

IRankStyleRule Properties Methods

Returns/sets RankDown

Read-Write

Syntax

object.RankDown As Boolean

Parameters
object An object of type IRankStyleRule


IRankStyleRule.RankUp

IRankStyleRule.RankUp Property

IRankStyleRule Properties Methods

Returns/sets RankUp

Read-Write

Syntax

object.RankUp As Boolean

Parameters
object An object of type IRankStyleRule


IReportPrintSettings.FontScale

IReportPrintSettings.FontScale Property

IReportPrintSettings Properties

Report fonts will be scaled using this value (Not applicable when ShrinkToFit is set)

Read-Write

Syntax

object.FontScale As TxReportFontScale

Parameters
object An object of type IReportPrintSettings


IReportPrintSettings.MarginBottom

IReportPrintSettings.MarginBottom Property

IReportPrintSettings Properties

Gets/Sets bottom margin for report printing (mm)

Read-Write

Syntax

object.MarginBottom As Integer

Parameters
object An object of type IReportPrintSettings


IReportPrintSettings.MarginLeft

IReportPrintSettings.MarginLeft Property

IReportPrintSettings Properties

Gets/Sets left margin for report printing (mm)

Read-Write

Syntax

object.MarginLeft As Integer

Parameters
object An object of type IReportPrintSettings


IReportPrintSettings.MarginRight

IReportPrintSettings.MarginRight Property

IReportPrintSettings Properties

Gets/Sets right margin for report printing (mm)

Read-Write

Syntax

object.MarginRight As Integer

Parameters
object An object of type IReportPrintSettings


IReportPrintSettings.MarginTop

IReportPrintSettings.MarginTop Property

IReportPrintSettings Properties

Gets/Sets top margin for report printing (mm)

Read-Write

Syntax

object.MarginTop As Integer

Parameters
object An object of type IReportPrintSettings


IReportPrintSettings.Orientation

IReportPrintSettings.Orientation Property

IReportPrintSettings Properties

Gets/Sets paper orientation for report printing

Read-Write

Syntax

object.Orientation As TxPrinterOrientation

Parameters
object An object of type IReportPrintSettings


IReportPrintSettings.PaperHeight

IReportPrintSettings.PaperHeight Property

IReportPrintSettings Properties

Gets/Sets paper height (mm) for report printing

Read-Write

Syntax

object.PaperHeight As Integer

Parameters
object An object of type IReportPrintSettings


IReportPrintSettings.PaperSize

IReportPrintSettings.PaperSize Property

IReportPrintSettings Properties

Gets/Sets paper size for report printing

Read-Write

Syntax

object.PaperSize As TxPaperSize

Parameters
object An object of type IReportPrintSettings


IReportPrintSettings.PaperWidth

IReportPrintSettings.PaperWidth Property

IReportPrintSettings Properties

Gets/Sets paper width (mm) for report printing

Read-Write

Syntax

object.PaperWidth As Integer

Parameters
object An object of type IReportPrintSettings


IReportPrintSettings.PrinterBin

IReportPrintSettings.PrinterBin Property

IReportPrintSettings Properties

Gets/Sets printer bin that has the paper for report printing

Read-Write

Syntax

object.PrinterBin As TxPrinterBin

Parameters
object An object of type IReportPrintSettings


IReportPrintSettings.ShrinkToFit

IReportPrintSettings.ShrinkToFit Property

IReportPrintSettings Properties

Specifies whether report should be shrinked to fit one page width or not

Read-Write

Syntax

object.ShrinkToFit As Boolean

Parameters
object An object of type IReportPrintSettings


ISequentialStream.RemoteRead

ISequentialStream.RemoteRead Method

ISequentialStream Methods

[To be supplied]

Syntax

object.RemoteRead ByRef pv As Integer , ByVal cb As Integer , ByRef pcbRead As Integer

Parameters
object | An object of type ISequentialStream
[out] pv | (Required) A Integer value.
[in] cb | (Required) A Integer value.
[out] pcbRead | (Required) A Integer value.


ISequentialStream.RemoteWrite

ISequentialStream.RemoteWrite Method

ISequentialStream Methods

[To be supplied]

Syntax

object.RemoteWrite ByRef pv As Integer , ByVal cb As Integer , ByRef pcbWritten As Integer

Parameters
object | An object of type ISequentialStream
[in] pv | (Required) A Integer value.
[in] cb | (Required) A Integer value.
[out] pcbWritten | (Required) A Integer value.


IShiftState.Alt

IShiftState.Alt Property

IShiftState Properties

Returns whether the Alt key is held down.

Read-Only

Syntax

object.Alt As Boolean

Parameters
object An object of type IShiftState


IShiftState.Ctrl

IShiftState.Ctrl Property

IShiftState Properties

Returns whether the Ctrl key is held down.

Read-Only

Syntax

object.Ctrl As Boolean

Parameters
object An object of type IShiftState


IShiftState.Double

IShiftState.Double Property

IShiftState Properties

Returns whether the mouse was double-clicked.

Read-Only

Syntax

object.Double As Boolean

Parameters
object An object of type IShiftState


IShiftState.Left

IShiftState.Left Property

IShiftState Properties

Returns whether the left mouse button is held down.

Read-Only

Syntax

object.Left As Boolean

Parameters
object An object of type IShiftState


IShiftState.Middle

IShiftState.Middle Property

IShiftState Properties

Returns whether the middle mouse button is held down.

Read-Only

Syntax

object.Middle As Boolean

Parameters
object An object of type IShiftState


IShiftState.Right

IShiftState.Right Property

IShiftState Properties

Returns whether the right mouse button is held down.

Read-Only

Syntax

object.Right As Boolean

Parameters
object An object of type IShiftState


IShiftState.Shift

IShiftState.Shift Property

IShiftState Properties

Returns whether the Shift key is held down.

Read-Only

Syntax

object.Shift As Boolean

Parameters
object An object of type IShiftState


ISliceAxisDims.Axis

ISliceAxisDims.Axis Property

ISliceAxisDims Properties Methods

Returns axis of this collection.

Read-Only

Syntax

object.Axis As TxDimAxis

Parameters
object An object of type ISliceAxisDims


ISliceAxisDims.Count

ISliceAxisDims.Count Property

ISliceAxisDims Properties Methods

Returns number of dimensions on axis.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type ISliceAxisDims


ISliceAxisDims.Exists

ISliceAxisDims.Exists Method

ISliceAxisDims Properties Methods

Checks whether dimension with given name exists

Syntax

object.Exists (ByVal DimName As String) As Boolean

Parameters
object | An object of type ISliceAxisDims
[in] DimName | (Required) A String value. Name of the dimension to be checked.

This function returns True, if a dimension with given name exists in ContourCube collection of dimensions belonging to an axis. Otherwise, it returns False.

Note

You can't add items to this collection - they are appended automatically when you call Add methods of ICubeDims interface.

See also

ICubeDims.Add


ISliceAxisDims.Item

ISliceAxisDims.Item Property

ISliceAxisDims Properties Methods

Returns ICubeDim by name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As ICubeDim

Parameters
object | An object of type ISliceAxisDims
[in] Index | (Required) A Variant value. Specifies dimension name or its zero-based index in the collection.

This property returns reference to the dimension from ContourCube collection of dimensions belonging to an axis, by its name or index.

Note

If no dimensions with given name were found, the function throws an exception. Use Exists method to check if a dimension is present in the collection. To stay within collection bounds, see Count property.

See also
ISliceAxisDims.Exists
ISliceAxisDims.Count


IString.Value

IString.Value Property

IString Properties

Returns/sets Value of this String

Read-Write

Syntax

object.Value As String

Parameters
object An object of type IString


IStyleRule.Delete

IStyleRule.Delete Method

IStyleRule Properties Methods

Deletes this rule

Syntax

object.Delete

Parameters
object An object of type IStyleRule


IStyleRule.Style

IStyleRule.Style Property

IStyleRule Properties Methods

Returns Style

Read-Only

Syntax

object.Style As IContourStyle

Parameters
object An object of type IStyleRule


IStyleRule.Type

IStyleRule.Type Property

IStyleRule Properties Methods

Returns type of condition in the rule

Read-Only

Syntax

object.Type As TxStyleRuleConditionType

Parameters
object An object of type IStyleRule


IStyleRulesCollection.AddCellTypeStyleRule

IStyleRulesCollection.AddCellTypeStyleRule Method

IStyleRulesCollection Properties Methods

Creates CellTypeConditionRule and inserts it into the given position.

Syntax

object.AddCellTypeStyleRule (ByRef Style As IContourStyle [, ByVal Index As Integer = -1]) As ICellTypeStyleRule

Parameters
object | An object of type IStyleRulesCollection
[in] Style | (Required) A IContourStyle value. Referneces the style to be applied to the cells specified in this rule.
[in] Index | (Optional) A Integer value. Determines the position of this rule in the collection. By default, style rules are appended to the end of list.

Use this method to add new style rule based on grid cell type to the specified position in the collection of ContourCube style rules.
This kind of style rule applies given style to the cells of the given type in ContourCube grid.
You can use returned interface to the newly created style rule to eventually set up its additional parameters.

Note

Styles are applied to the cells of ContourCube grid according to the inverted order of style rules in the collection; so the last added style rule is applied first to a cell.

To define style rules applying to all cells in the grid, use AddTrueConditionStyleRule procedure.

See also

Tutorial: Working with Styles
IStyleRulesCollection.AddTrueConditionStyleRule


IStyleRulesCollection.AddComparatorStyleRule

IStyleRulesCollection.AddComparatorStyleRule Method

IStyleRulesCollection Properties Methods

Creates ComparatorStyleRule and inserts it into the given position.

Syntax

object.AddComparatorStyleRule (ByRef Style As IContourStyle , ByVal Value As Float , ByVal Operator As TxComparisonOperator [, ByVal Index As Integer = -1]) As IComparatorStyleRule

Parameters
object | An object of type IStyleRulesCollection
[in] Style | (Required) A IContourStyle value. Referneces the style to be applied to the cells specified in this rule.
[in] Value | (Required) A Float value. Specifies the constant, with which fact values should be compared.
[in] Operator | (Required) A TxComparisonOperator value. Specifies the comparison operator between fact values at the left side and given constant at the right.
[in] Index | (Optional) A Integer value. Determines the position of this rule in the collection. By default, style rules are appended to the end of list.

Use this method to add new style rule based on (in)equality between cell value and a constant, to the specified position on the collection of ContourCube style rules.
This kind of style rule applies given style to the cells, for which that (in)equality is true.

Example

[Visual Basic]
'The following code defines style rule that applies MyStyle
'to the cells with positive values
MyContourCubeX.EffectiveStylesheet.StyleRules.AddComparatorStyleRule MyStyle, 0, xco_GT

You can use returned interface to the newly created style rule to eventually set up its additional parameters.

Note

Styles are applied to the cells of ContourCube grid according to the inverted order of style rules in the collection; so the last added style rule is applied first to a cell.

To define style rules based on double inequality expressions, it is more convenient to use AddRangeStyleRule procedure.

See also

Tutorial: Working with Styles
IStyleRulesCollection.AddRangeStyleRule


IStyleRulesCollection.AddCopyOfStyleRule

IStyleRulesCollection.AddCopyOfStyleRule Method

IStyleRulesCollection Properties Methods

Creates a copy of the given style rule and inserts it into given position.

Syntax

object.AddCopyOfStyleRule (ByRef Rule As IStyleRule [, ByVal Index As Integer = -1]) As IStyleRule

Parameters
object | An object of type IStyleRulesCollection
[in] Rule | (Required) A IStyleRule value. References the style rule to be copied. The source must exist in the collection.
[in] Index | (Optional) A Integer value. Determines the position of this rule in the collection. By default, style rules are appended to the end of list.

This method just makes a copy of given style rule and places it to the specified position in the collection of style rules.
You can use returned interface to the newly created style rule to eventually set up its additional parameters.

Note

Styles are applied to the cells of ContourCube grid according to the inverted order of style rules in the collection; so the last added style rule is applied first to a cell.

See also

Tutorial: Working with Styles


IStyleRulesCollection.AddFormulaStyleRule

IStyleRulesCollection.AddFormulaStyleRule Method

IStyleRulesCollection Properties Methods

Creates FormulaStyleRule and inserts it into the given position.

Syntax

object.AddFormulaStyleRule (ByRef Style As IContourStyle , ByVal FormulaText As String [, ByVal MinStatus As Integer = 0] [, ByVal MaxStatus As Integer = 0] [, ByVal Index As Integer = -1]) As IFormulaStyleRule

Parameters
object | An object of type IStyleRulesCollection
[in] Style | (Required) A IContourStyle value. Referneces the style to be applied to the cells specified in this rule.
[in] FormulaText | (Required) A String value. Text of the formula expression that should be evaluated for each grid cell.
[in] MinStatus | (Optional) A Integer value. The lower bound of the formula status code range, for which the style shuld be applied. Zero by default.
[in] MaxStatus | (Optional) A Integer value. The higher bound of the formula status code range, for which the style shuld be applied. Zero by default.
[in] Index | (Optional) A Integer value. Determines the position of this rule in the collection. By default, style rules are appended to the end of list.

Use this method to add new style rule based on a formula expression, to the specified position on the collection of ContourCube style rules.
This kind of style rule applies given style to the cells, for which that formula either returns a non-zero value, or its result status lays within given range.

Example

[Visual Basic]
'This line adds rule that applies style MyStyle to the
'cells, whose rounded values are odd
MyContourCubeX.EffectiveStylesheet.StyleRules.AddFormulaStyleRule MyStyle, _
 "round(MyFact) mod 2", 0, 0, -1
'And this one adds rule that applies style MyStyle to the
'cells, for which given formula returns error codes from -4 to -3 (divide by zero)
MyContourCubeX.EffectiveStylesheet.StyleRules.AddFormulaStyleRule MyStyle, _
 "1/MyFact", -4, -3, -1

You can use returned interface to the newly created style rule to eventually set up its additional parameters.

Note

Styles are applied to the cells of ContourCube grid according to the inverted order of style rules in the collection; so the last added style rule is applied first to a cell.

Checking returned formula status code range has higher priority, so the specified style will be applied to the cells, for which formula returns status codes from given subrange, even if a zero value has been calculated for these cells.

See also

Tutorial: Working with Styles
About Formula Language


IStyleRulesCollection.AddRangeStyleRule

IStyleRulesCollection.AddRangeStyleRule Method

IStyleRulesCollection Properties Methods

Creates RangeStyleRule and inserts it into the given position.

Syntax

object.AddRangeStyleRule (ByRef Style As IContourStyle , ByVal LowerBound As Float , ByVal LowerBoundIncluded As Boolean , ByVal UpperBound As Float , ByVal UpperBoundIncluded As Boolean [, ByVal Index As Integer = -1]) As IRangeStyleRule

Parameters
object | An object of type IStyleRulesCollection
[in] Style | (Required) A IContourStyle value. Referneces the style to be applied to the cells specified in this rule.
[in] LowerBound | (Required) A Float value. Specifies lower bound of the range, for which given style should be applied.
[in] LowerBoundIncluded | (Required) A Boolean value. Determines whether the range includes its lower bound.
[in] UpperBound | (Required) A Float value. Specifies higher bound of the range, for which given style should be applied.
[in] UpperBoundIncluded | (Required) A Boolean value. Determines whether the range includes its higher bound.
[in] Index | (Optional) A Integer value. Determines the position of this rule in the collection. By default, style rules are appended to the end of list.

Use this method to add new style rule that applies given style to the cells, whose fact values lay within specified range. AddRangeStyleRule appends newly created item to the specified position in ContourCube style rules collection.
You can use returned interface to the newly created style rule to eventually set up its additional parameters.

Note

Styles are applied to the cells of ContourCube grid according to the inverted order of style rules in the collection; so the last added style rule is applied first to a cell.

To define style rules based on simple (in)equality expressions, use AddComparatorStyleRule procedure.

See also

Tutorial: Working with Styles
IStyleRulesCollection.AddComparatorStyleRule


IStyleRulesCollection.AddRankStyleRule

IStyleRulesCollection.AddRankStyleRule Method

IStyleRulesCollection Properties Methods

Creates RankStyleRule and inserts it into the given position.

Syntax

object.AddRankStyleRule (ByRef Style As IContourStyle , ByVal RankUp As Boolean , ByVal RankDown As Boolean [, ByVal Index As Integer = -1]) As IRankStyleRule

Parameters
object | An object of type IStyleRulesCollection
[in] Style | (Required) A IContourStyle value. Referneces the style to be applied to the cells specified in this rule.
[in] RankUp | (Required) A Boolean value. Determines whether to apply given style to the ascending rank cells.
[in] RankDown | (Required) A Boolean value. Determines whether to apply given style to the descending rank cells.
[in] Index | (Optional) A Integer value. Specifies the position of this rule in the collection. By default, style rules are appended to the end of list.

Use this method to add new style rule that applies given style to the cells containing rank values. AddRankStyleRule appends newly created item to the specified position in ContourCube style rules collection.
You can use returned interface to the newly created style rule to eventually set up its additional parameters.

Note

Styles are applied to the cells of ContourCube grid according to the inverted order of style rules in the collection; so the last added style rule is applied first to a cell.

See also

Tutorial: Working with Styles


IStyleRulesCollection.AddTrueConditionStyleRule

IStyleRulesCollection.AddTrueConditionStyleRule Method

IStyleRulesCollection Properties Methods

Creates TrueConditionStyleRule and inserts it into the given position.

Syntax

object.AddTrueConditionStyleRule (ByRef Style As IContourStyle [, ByVal Index As Integer = -1]) As IStyleRule

Parameters
object | An object of type IStyleRulesCollection
[in] Style | (Required) A IContourStyle value. Referneces the style to be applied by this rule.
[in] Index | (Optional) A Integer value. Determines the position of this rule in the collection. By default, style rules are appended to the end of list.

Use this method to add new style rule applying to all grid cells, to the specified position on the collection of ContourCube style rules.
This kind of style rule applies given style to all cells in ContourCube grid. You can use returned interface to the newly created style rule to eventually set up its additional parameters.

Note

Styles are applied to the cells of ContourCube grid according to the inverted order of style rules in the collection; so the last added style rule is applied first to a cell.

To define style rules applying only to cells of the specified type, use AddCellTypeStyleRule procedure.

See also

Tutorial: Working with Styles
IStyleRulesCollection.AddCellTypeStyleRule


IStyleRulesCollection.Clear

IStyleRulesCollection.Clear Method

IStyleRulesCollection Properties Methods

Removes all rules from this Collection

Syntax

object.Clear

Parameters
object An object of type IStyleRulesCollection


IStyleRulesCollection.Count

IStyleRulesCollection.Count Property

IStyleRulesCollection Properties Methods

Returns number of existing Conditions.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type IStyleRulesCollection


IStyleRulesCollection.Item

IStyleRulesCollection.Item Property

IStyleRulesCollection Properties Methods

Returns IStyleRule by index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As IStyleRule

Parameters
object | An object of type IStyleRulesCollection
[in] Index | (Required) A Variant value. Specifies zero-based index of the style rule in the collection.

This property returns interface to the item from ContourCube style rules collection by its numeric index.

Note

To stay within collection bounds, use Count property.

See also
IStyleRulesCollection.Count


IStyleRulesCollection.Stylesheet

IStyleRulesCollection.Stylesheet Property

IStyleRulesCollection Properties Methods

Returns IContourStylesheet this Collection belongs to

Read-Only

Syntax

object.Stylesheet As IContourStylesheet

Parameters
object An object of type IStyleRulesCollection


IStylesheetCollection.Add

IStylesheetCollection.Add Method

IStylesheetCollection Properties Methods

Adds a new Stylesheet with given base (uses builtin stylesheet as parentstylesheet when no base is given)

Syntax

object.Add (ByVal Name As String [, ByRef BaseStylesheet As IContourStylesheet = 0]) As IContourStylesheet

Parameters
object | An object of type IStylesheetCollection
[in] Name | (Required) A String value. Name of the new stylesheet.
[in] BaseStylesheet | (Optional) A IContourStylesheet value. Reference to the stylesheet that this one is based upon. Rules of the base stylesheet will be applied after style rules of this "child" one.

Use Add method to add new stylesheets to the IStylesheets collection, this way cascading them. Cascading stylesheets allow you to group style rules between them, add / remove groups of rules related to various analytical functions, etc.

See also

Tutorial: Working with Styles


IStylesheetCollection.Clear

IStylesheetCollection.Clear Method

IStylesheetCollection Properties Methods

Deletes all stylesheets.

Syntax

object.Clear

Parameters
object An object of type IStylesheetCollection


IStylesheetCollection.Count

IStylesheetCollection.Count Property

IStylesheetCollection Properties Methods

Returns number of existing Stylesheets.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type IStylesheetCollection


IStylesheetCollection.Delete

IStylesheetCollection.Delete Method

IStylesheetCollection Properties Methods

Deletes IContourStylesheet by name or index.

Syntax

object.Delete ByVal Index As Variant

Parameters
object | An object of type IStylesheetCollection
[in] Index | (Required) A Variant value. Name or zero-based integer index of the stylesheet to be removed.

This method removes stylesheet with given name or index from ContourCube stylesheets collection.

Note

If no items with given name were found, the procedure throws an exception. Use Exists method to check if a stylesheet is present in the collection. To stay within collection bounds, see Count property.

See also
IStylesheetCollection.Exists
IStylesheetCollection.Count


IStylesheetCollection.Exists

IStylesheetCollection.Exists Method

IStylesheetCollection Properties Methods

Returns whether IContourStylesheet with given name exist.

Syntax

object.Exists (ByVal Name As String) As Boolean

Parameters
object | An object of type IStylesheetCollection
[in] Name | (Required) A String value. Name of the stylesheet to be checked.

This function returns True, if a stylesheet with given name exists in ContourCube collection of stylesheets. Otherwise, it returns False.

Note

To declare and add a new item to the stylesheets collection, use Add method.

See also

IStylesheetCollection.Add


IStylesheetCollection.Item

IStylesheetCollection.Item Property

IStylesheetCollection Properties Methods

Returns IContourStylesheet by name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As IContourStylesheet

Parameters
object | An object of type IStylesheetCollection
[in] Index | (Required) A Variant value. Name or zero-based integer index of the stylesheet that should be returned.

This property returns interface to the stylesheet with given name or index from ContourCube stylesheets collection.

Note

If no items with given name were found, the function throws an exception. Use Exists method to check if a stylesheet is present in the collection. To stay within collection bounds, see Count property.

See also
IStylesheetCollection.Exists
IStylesheetCollection.Count


ITitleSettings.Alignment

ITitleSettings.Alignment Property

ITitleSettings Properties

Returns/sets Alignment of the Title text

Read-Write

Syntax

object.Alignment As TxAlignment

Parameters
object An object of type ITitleSettings


ITitleSettings.Text

ITitleSettings.Text Property

ITitleSettings Properties

Returns/sets Title Text

Read-Write

Syntax

object.Text As String

Parameters
object An object of type ITitleSettings


ITitleSettings.Visible

ITitleSettings.Visible Property

ITitleSettings Properties

Returns/sets whether Title visible or not.

Read-Write

Syntax

object.Visible As Boolean

Parameters
object An object of type ITitleSettings


IValueMapping.DisplayValue

IValueMapping.DisplayValue Property

IValueMapping Properties

Returns DisplayValue of ValueMapping.

Read-Only

Syntax

object.DisplayValue As String

Parameters
object An object of type IValueMapping


IValueMapping.RealValue

IValueMapping.RealValue Property

IValueMapping Properties

Returns RealValue of ValueMapping.

Read-Only

Syntax

object.RealValue As String

Parameters
object An object of type IValueMapping


IViewAxis.Axis

IViewAxis.Axis Property

IViewAxis Properties Methods

Returns type of the Axis

Read-Only

Syntax

object.Axis As TxDimAxis

Parameters
object An object of type IViewAxis


IViewAxis.Dims

IViewAxis.Dims Property

IViewAxis Properties Methods

Returns dimensions at this axis.

Read-Only

Syntax

object.Dims As IViewAxisDims

Parameters
object An object of type IViewAxis


IViewAxis.DrillDownLevel

IViewAxis.DrillDownLevel Property

IViewAxis Properties Methods

Returns/sets the number of this axis dimensions the slice initially drilled down to.

Read-Write

Syntax

object.DrillDownLevel As Integer

Parameters
object An object of type IViewAxis


IViewAxis.GetSection

IViewAxis.GetSection Method

IViewAxis Properties Methods

Returns ViewAxisSection

Syntax

object.GetSection (ByVal Index As Integer) As IAxisSection

Parameters
object | An object of type IViewAxis
[in] Index | (Required) A Integer value. Number of the section to be returned. Can take values from 0 to Length - 1.

This method returns interface to the axis section with specified number.

Note

Visually, sections are counted from left to right for horizontal, and from up to down for vertical axis.

See also

IViewAxis.Length


IViewAxis.IsSortedByFact

IViewAxis.IsSortedByFact Property

IViewAxis Properties Methods

Returns value that indicates whether the axis is sorted by fact

Read-Only

Syntax

object.IsSortedByFact As Boolean

Parameters
object An object of type IViewAxis


IViewAxis.Length

IViewAxis.Length Property

IViewAxis Properties Methods

Returns Length - the number of sections at the axis

Read-Only

Syntax

object.Length As Integer

Parameters
object An object of type IViewAxis


IViewAxis.MaxWidth

IViewAxis.MaxWidth Property

IViewAxis Properties Methods

Returns/sets MaxWidth - the maximum number of expanded dimensions

Read-Write

Syntax

object.MaxWidth As Integer

Parameters
object An object of type IViewAxis


IViewAxis.RollUpLevel

IViewAxis.RollUpLevel Property

IViewAxis Properties Methods

Returns/sets rollup level for all dimensions at the axis

Read-Write

Syntax

object.RollUpLevel As Integer

Parameters
object An object of type IViewAxis


IViewAxis.Width

IViewAxis.Width Property

IViewAxis Properties Methods

Returns Width - the number of dimensions at the axis

Read-Only

Syntax

object.Width As Integer

Parameters
object An object of type IViewAxis


IViewAxisDims.Axis

IViewAxisDims.Axis Property

IViewAxisDims Properties Methods

Returns axis of this collection.

Read-Only

Syntax

object.Axis As TxDimAxis

Parameters
object An object of type IViewAxisDims


IViewAxisDims.Count

IViewAxisDims.Count Property

IViewAxisDims Properties Methods

Returns number of dimensions on axis.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type IViewAxisDims


IViewAxisDims.Exists

IViewAxisDims.Exists Method

IViewAxisDims Properties Methods

Checks whether dimension with given name exists

Syntax

object.Exists (ByVal DimName As String) As Boolean

Parameters
object | An object of type IViewAxisDims
[in] DimName | (Required) A String value. Name of the dimension to be checked.

This function returns True, if a dimension with given name exists and is located at this view axis. Otherwise, it returns False.

Note

You can't add items to this collection - they are appended automatically when you call Add methods of ICubeDims interface.

See also

ICubeDims.Add


IViewAxisDims.Item

IViewAxisDims.Item Property

IViewAxisDims Properties Methods

Returns IViewDim by name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As IViewDim

Parameters
object | An object of type IViewAxisDims
[in] Index | (Required) A Variant value. Specifies dimension name or its zero-based index in the collection.

This property returns reference to the dimension from the view's collection of dimensions belonging to an axis, by its name or index.

Note

If no dimensions with given name were found, the function throws an exception. Use Exists method to check if a dimension is present in the collection. To stay within collection bounds, see Count property.

See also
IViewAxisDims.Exists
IViewAxisDims.Count


IViewCell.CellType

IViewCell.CellType Property

IViewCell Properties Methods

Returns CellType of the cell

Read-Only

Syntax

object.CellType As TxCellType

Parameters
object An object of type IViewCell


IViewCell.Col

IViewCell.Col Property

IViewCell Properties Methods

Returns the cell column

Read-Only

Syntax

object.Col As Integer

Parameters
object An object of type IViewCell


IViewCell.Datapoint

IViewCell.Datapoint Property

IViewCell Properties Methods

Returns Datapoint of the cell

Read-Only

Syntax

object.Datapoint As IContourDatapoint

Parameters
object An object of type IViewCell


IViewCell.DisplayText

IViewCell.DisplayText Method

IViewCell Properties Methods

Returns DisplayText of the cell

Syntax

object.DisplayText (ByRef ViewFact As IViewFact) As String

Parameters
object | An object of type IViewCell
[in] ViewFact | (Required) A IViewFact value. References the view fact, whose value is to be returned.

Use DisplayText method to get the specified fact value as a displayable string. The returned string is formatted using style rules applicable to the given fact.

Note

To get unformatted numeric fact value contained in the cell, use Value function.

See also

IContourStyle.Format
IViewCell.Value


IViewCell.IsValid

IViewCell.IsValid Method

IViewCell Properties Methods

Returns whether the view cell contains valid data

Syntax

object.IsValid () As Boolean

Parameters
object An object of type IViewCell


IViewCell.IsValidCoordinates

IViewCell.IsValidCoordinates Method

IViewCell Properties Methods

Returns whether the view cell has valid coordinates

Syntax

object.IsValidCoordinates () As Boolean

Parameters
object An object of type IViewCell


IViewCell.Row

IViewCell.Row Property

IViewCell Properties Methods

Returns the cell row

Read-Only

Syntax

object.Row As Integer

Parameters
object An object of type IViewCell


IViewCell.Style

IViewCell.Style Method

IViewCell Properties Methods

Gets the effective style calculated for the fact

Syntax

object.Style (ByRef ViewFact As IViewFact) As IContourStyle

Parameters
object | An object of type IViewCell
[in] ViewFact | (Required) A IViewFact value.


IViewCell.Value

IViewCell.Value Method

IViewCell Properties Methods

Returns Value of the cell

Syntax

object.Value (ByRef ViewFact As IViewFact) As ICalcResult

Parameters
object | An object of type IViewCell
[in] ViewFact | (Required) A IViewFact value. References the view fact, whose value is to be returned.

Use Value method to get value of the specified fact. This method returns ICalcResult interface that contains information on the cell type, its floating-point numeric value, status, etc.

Note

To get the fact value as a displayable formatted string, use DisplayText function.

See also

IViewCell.DisplayText


IViewDim.CubeDim

IViewDim.CubeDim Property

IViewDim Properties

Returns base CubeDim of this Dimension.

Read-Only

Syntax

object.CubeDim As ICubeDim

Parameters
object An object of type IViewDim


IViewDim.Descending

IViewDim.Descending Property

IViewDim Properties

Returns/sets whether dimension uses descending sort order

Read-Write

Syntax

object.Descending As Boolean

Parameters
object An object of type IViewDim


IViewDim.Format

IViewDim.Format Property

IViewDim Properties

Returns/sets format string for this dimension values

Read-Write

Syntax

object.Format As String

Parameters
object An object of type IViewDim


IViewDim.NoTotals

IViewDim.NoTotals Property

IViewDim Properties

Returns/sets whether view don't present totals for this dimension

Read-Write

Syntax

object.NoTotals As Boolean

Parameters
object An object of type IViewDim


IViewDims.Count

IViewDims.Count Property

IViewDims Properties Methods

Returns number of objects in collection.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type IViewDims


IViewDims.Exists

IViewDims.Exists Method

IViewDims Properties Methods

Checks whether dimension with given name exists

Syntax

object.Exists (ByVal DimName As String) As Boolean

Parameters
object | An object of type IViewDims
[in] DimName | (Required) A String value. Name of the dimension to be checked.

This function returns True, if a dimension with given name exists in the collection of view dimensions. Otherwise, it returns False.

Note

You cannot add items to this collection - they're appended automatically upon calling ICubeDims.Add method.

See also

ICubeDims.Add


IViewDims.Item

IViewDims.Item Property

IViewDims Properties Methods

Returns IViewDim by name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As IViewDim

Parameters
object | An object of type IViewDims
[in] Index | (Required) A Variant value. Specifies dimension name or its zero-based index in the collection.

This property returns reference to the dimension from view's collection by its name or index.

Note

If no dimensions with given name were found, the function throws an exception. Use Exists method to check if a dimension is present in the collection. To stay within collection bounds, see Count property.

See also
IViewDims.Exists
IViewDims.Count


IViewFact.Appearance

IViewFact.Appearance Property

IViewFact Properties Methods

Returns/sets Appearance Style

Read-Write

Syntax

object.Appearance As IContourStyle

Parameters
object An object of type IViewFact


IViewFact.CubeFact

IViewFact.CubeFact Property

IViewFact Properties Methods

Returns base CubeFact of this fact.

Read-Only

Syntax

object.CubeFact As ICubeFact

Parameters
object An object of type IViewFact


IViewFact.EditAppearance

IViewFact.EditAppearance Method

IViewFact Properties Methods

Opens the editor of fact appearance styles

Syntax

object.EditAppearance [ByVal Flags As TxFactStyleEditPageFlags = 1]

Parameters
object | An object of type IViewFact
[in] Flags | (Optional) A TxFactStyleEditPageFlags value.


IViewFact.EffectiveStylesheet

IViewFact.EffectiveStylesheet Property

IViewFact Properties Methods

Returns EffectiveStylesheet used to display this fact

Read-Only

Syntax

object.EffectiveStylesheet As IContourStylesheet

Parameters
object An object of type IViewFact


IViewFact.Enabled

IViewFact.Enabled Property

IViewFact Properties Methods

Show/hide the fact

Read-Write

Syntax

object.Enabled As Boolean

Parameters
object An object of type IViewFact


IViewFact.OwnsStylesheet

IViewFact.OwnsStylesheet Property

IViewFact Properties Methods

Returns/sets whether the fact owns stylesheet

Read-Write

Syntax

object.OwnsStylesheet As Boolean

Parameters
object An object of type IViewFact


IViewFact.Position

IViewFact.Position Property

IViewFact Properties Methods

Returns/sets fact Position

Read-Write

Syntax

object.Position As Integer

Parameters
object An object of type IViewFact


IViewFact.ScaleFactor

IViewFact.ScaleFactor Property

IViewFact Properties Methods

Returns/sets ScaleFactor

Read-Write

Syntax

object.ScaleFactor As Float

Parameters
object An object of type IViewFact


IViewFact.Stylesheet

IViewFact.Stylesheet Property

IViewFact Properties Methods

Returns/sets Stylesheet used to display this fact

Read-Write

Syntax

object.Stylesheet As IContourStylesheet

Parameters
object An object of type IViewFact


IViewFact.Visible

IViewFact.Visible Property

IViewFact Properties Methods

Returns/sets a value indicating whether an object is visible or hidden.

Read-Write

Syntax

object.Visible As Boolean

Parameters
object An object of type IViewFact


IViewFacts.Count

IViewFacts.Count Property

IViewFacts Properties Methods

Returns number of objects in collection.

Read-Only

Syntax

object.Count As Integer

Parameters
object An object of type IViewFacts


IViewFacts.Exists

IViewFacts.Exists Method

IViewFacts Properties Methods

Checks whether fact with given name exists

Syntax

object.Exists (ByVal FactName As String) As Boolean

Parameters
object | An object of type IViewFacts
[in] FactName | (Required) A String value. Name of the fact to be checked.

This function returns True, if a fact with given name exists in the collection of view facts. Otherwise, it returns False.

Note

You cannot add items to this collection - they're appended automatically upon calling ICubeFacts.Add method.

See also

ICubeFacts.Add


IViewFacts.Item

IViewFacts.Item Property

IViewFacts Properties Methods

Returns IViewFact by name or index.

Read-Only

Syntax

object.Item (ByVal Index As Variant) As IViewFact

Parameters
object | An object of type IViewFacts
[in] Index | (Required) A Variant value. Specifies fact name or its zero-based index in the collection.

This property returns reference to the fact from view's collection by its name or index.

Note

If no facts with given name were found, the function throws an exception. Use Exists method to check if a fact is present in the collection. To stay within collection bounds, see Count property.

See also
IViewFacts.Exists
IViewFacts.Count